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The information provided in this documentation contains general descriptions and/or 
technical characteristics of the performance of the products contained herein. This 
documentation is not intended as a substitute for and is not to be used for 
determining suitability or reliability of these products for specific user applications. It 
is the duty of any such user or integrator to perform the appropriate and complete 
risk analysis, evaluation and testing of the products with respect to the relevant 
specific application or use thereof. Neither Schneider Electric nor any of its affiliates 
or subsidiaries shall be responsible or liable for misuse of the information contained 
herein. If you have any suggestions for improvements or amendments or have found 
errors in this publication, please notify us. 

No part of this document may be reproduced in any form or by any means, electronic 
or mechanical, including photocopying, without express written permission of 
Schneider Electric.

All pertinent state, regional, and local safety regulations must be observed when 
installing and using this product. For reasons of safety and to help ensure 
compliance with documented system data, only the manufacturer should perform 
repairs to components.

When devices are used for applications with technical safety requirements, the 
relevant instructions must be followed. 

Failure to use Schneider Electric software or approved software with our hardware 
products may result in injury, harm, or improper operating results.

Failure to observe this information can result in injury or equipment damage.

© 2010 Schneider Electric. All rights reserved.
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Safety Information
Important Information

NOTICE

Read these instructions carefully, and look at the equipment to become familiar with 
the device before trying to install, operate, or maintain it. The following special 
messages may appear throughout this documentation or on the equipment to warn 
of potential hazards or to call attention to information that clarifies or simplifies a 
procedure.
35016149 02/2010 7
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PLEASE NOTE

Electrical equipment should be installed, operated, serviced, and maintained only by 
qualified personnel. No responsibility is assumed by Schneider Electric for any 
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction 
and operation of electrical equipment and the installation, and has received safety 
training to recognize and avoid the hazards involved.
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About the Book
At a Glance

Document Scope

This manual presents the Web Designer for Modicon M340, Premium and Quantum 
software and describes the installation and operation.

NOTE: In this manual, the term "Web Designer" will be used for "Web Designer for 
Modicon M340, Premium or Quantum".

Validity Note

This documentation is valid for  Web Designer software.

Related Documents

You can download these technical publications and other technical information from 
our website at www.schneider-electric.com.

Product Related Information

All pertinent state, regional, and local regulations must be observed when installing 
and using this product. Only the manufacturer should perform repairs to this product 
to maintain system data.

When controllers are used for applications with technical requirements, please 
follow the relevant instructions. 

Title of Documentation Reference Number

FactoryCast for Modicon M340 User Manual 35015192

FactoryCast for Premium and Quantum User Manual 31001229

Communications Setup Manual TLX DS COMPL7 V4

Ethernet Network - Reference Manual TSX DR ETH

Modbus - User Guide TSX DG MDB
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Anyone who has access to a configuration tool and to your embedded server can 
override your security settings and download new settings to the server.

Unauthorized or incorrect changes to data may change the behavior of your 
application in ways that may be undesirable or even hazardous.

User Comments

We welcome your comments about this document. You can reach us by e-mail at 
techcomm@schneider-electric.com.

WARNING
UNINTENDED EQUIPMENT OPERATION

Use only Schneider Electric software or approved software with our hardware 
products.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

WARNING
UNINTENDED EQUIPMENT OPERATION

 Keep strict access to the embedded server by configuring passwords.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
10 35016149 02/2010
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Introduction
Scope of this Chapter

This chapter introduces Web Designer. It shows you how to install it. It also provides 
you a description of the graphical interface. 

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Presentation 12

Preparing for Web Designer installation 14

Interface Presentation 15
11
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Introduction
Presentation

Introduction 

Web Designer is a state-of-the-art software application with which you can create 
Web based operator panels and configure operating parameters for Web human 
machine interface (Web HMI) devices. It provides all the tools needed to design an 
HMI project, from the data acquisition to the creation and display of animated Web 
drawings.

Web Designer handles the following for the device website:
editing,
configuration,
modification.

Web Designer offers two levels of personalization:
the creation of a variable base of devices that can be viewed and modified in Web 
pages, 
the addition of your own Web pages on the device site.

Devices

In the Schneider product range, Web Designer unites website configuration with 
services carried out in the coupling unit or device. A project can simultaneously 
manage several devices.

Web Designer manages the following devices:

Simulation

Web Designer enables you to simulate devices in order to debug the application. 
This means you can verify the behavior of Web pages and services without being 
physically connected to the device or to the module.

PLC Range Device

Modicon M340 BMX NOE 0110

Premium TSX ETY 5103

Quantum 140 NOE 771 11
12 35016149 02/2010
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Introduction
Required configuration

To use this software at an optimal level, we recommend that your PC has the 
following configuration:

CPU 1GHz,

512 Mb RAM,

80 Mb Hard disk,

 800x600 screen,

Windows 2000 SP2, Windows XP Professional or Windows Vista Business 32-
bit,

Java Virtual Machine 1.4.2 minimum.

NOTE: For Windows XP or Windows Vista, you need administration privileges to 
install the Web Designer Software. You also need administration privileges to run 
the software under Windows Vista.
35016149 02/2010 13

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Introduction
Preparing for Web Designer installation

Foreword

If a previous version of Web Designer is already installed, it must be uninstalled first 
(Web Designer offers to perform the uninstall for you if this is the case).

NOTE: Once installed, you can access Web Designer by clicking Start → All 
programs → Schneider Electric → Vijeo Designer Suite → Web Designer.

Installation

The installation procedure is as follows: insert the CD-ROM into the CD drive. The 
CD is Auto-run, therefore if your PC is set up for this feature you should see the 
Web Designer main window. If Auto-run is disabled or does not work:

Importing Previous Projects

Previous projects are visible in the navigator once Web Designer is reinstalled.

Step Action

1 Click Start → Settings → Control panel.

2 Click Add/Remove Programs in the Control Panel.

3 Click Add New Programs in the menu on the left, then CD-ROM and follow 
the instructions.

4 The Install Tool will automatically find the WebDesigner.exe program on the 
CD and will also display the path and file name then prompt you to perform the 
installation.
14 35016149 02/2010

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Introduction
Interface Presentation

Main Window Contents

The following illustration describes the elements of the Web Designer main window:
35016149 02/2010 15
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Introduction
6 main zones compose this screen which are: 

Navigator

This zone displays all the files and folders associated with existing projects. It 
provides an overall view of the application displayed as a file tree.

The following figure describes the navigator:

Zone Description

1 Menu (see page 184): list of options available.

2 Toolbar: shortcuts to frequently used functions.

3 Navigator (see page 16): display all the files related to the projects.

4 Editing zone: Web Designer uses this zone to edit, create or configure services 
associated with the project.

5 Console zone: list of the last detected errors. 

6 Information zone: it displays the connection status and the available memory of the 
selected module.

7 Site Explorer View: it displays all the target files.
16 35016149 02/2010
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Introduction
3 main zones compose the navigator which are: 

Toolbar

The toolbar enables you to access the main functions of the program directly by 
clicking its icons.

The figure below shows you the toolbar:

The following table describes the elements of the toolbar:

Zone Description

1 This zone displays the name of the project as root directory. By clicking +, all the 
targets associated with the project appear.

2 This folder displays the name of the target associated with the project and its IP 
address. By clicking +, all the folders and files associated with the target appear.

3 5 main directories are visible for each target associated with the project:
Device: it displays the devices (CPUs connected to the module) associated with 
the target.
GraphicScreens: it contains pages created using the Graphic editor 
(see page 89).
DataTables: it contains tables created using the Data editor (see page 78).
Service: it displays the services created by the user (availability depending on 
the target).
Website: it contains all the website files for the project. You can therefore 
customize the website (see page 135) by changing these files or by adding your 
own pages.

Icon Function

New: by clicking the down arrow, you can:
create a new project,
add a target to the project,
add a device to the target,
create a new service,
create a folder,
create a file.

Open an existing project.

Save: save the currently edited window.

Save All: save all items modified in the project.
35016149 02/2010 17
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Introduction
Cut: destruction of the selected object and putting it on the clipboard.

Copy: copy the object to the clipboard.

Paste: paste the clipboard.

Undo: cancel last action.

Find: open the Search window in which you can search for a text located in a 
file of the project.

Lookup: open the Lookup window in which you can search a variable.

Global Transfer: download all the project's modules (and all the files).

Target -> PC: transfer a project from the target to the PC.

PC -> Target: transfer a project from the PC to the target.

Connection to the module: connect Web Designer to the target.

Connection to the local simulator: connect Web Designer to the simulator.

Disconnect: disconnect from the target or the simulator.

Statistics: view statistics for the selected service (incoming messages, 
outgoing messages, etc.).

o

Stop: shut down current service.

Run: start current service.

Icon Function
18 35016149 02/2010
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Getting Started
Scope of this Chapter

The purpose of this document is to show you the procedure for creating a 
Web Designer for Modicon M340 application.

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Presentation 20

Creating a New Project 21

Device Selection 23

Target Properties 25

Variable Selection 27

Data Editor 29

Graphic Editor 32

Transfer 34

Accessing the Website 36
19
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Getting Started
Presentation

Introduction

This getting started covers from project creation to visualizing it on a PC with a 
browser. The project is made with a BMX NOE 0110 module and a Modicon M340 
PLC connected on the same rack. The Web server will be hosted by the 
BMX NOE 0110 module, which will periodically scan the values of variables located 
in the PLC. The IP address for the module will be a.b.c.d. 

Architecture

The following diagram shows the architecture of the getting started example:

The following table describes the elements of the example:

Reference Type Description

BMX NOE 0110 Target Ethernet module

Modicon M340 Device PLC
20 35016149 02/2010
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Getting Started
Creating a New Project

Introduction

This section provides an example showing how to create a new project using a 
BMX NOE 0110 module.

Creating a New Project

Step Action

1 Click Project → New → Project
Result: the Web Designer Project Creation Wizard window appears. 

2 Enter the project name (Modicon_M340_example) in the Project field.

3 In the target box, scroll over the drop down menu of the FactoryCast and select 
the module you require (for example, BMX NOE 0110 v1.0) and click the > 
button.
Result: the chosen module appears in the Selected Target(s) box on the right.

4 Enter the Name of the target (NOE) in the Selected Target(s) box.
35016149 02/2010 21
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Getting Started
5 Enter the IP Address (a.b.c.d) in the Selected Target(s) box. For more 
information about IP addressing, refer to the Modicon M340 for Ethernet 
Communications Modules and Processors User Manual.

6 Repeat steps 3 to 5 if you want to select more than one target.

7 Click Next.
Result: The second window of the Web Designer Project Creation Wizard 
appears.

Step Action
22 35016149 02/2010
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Getting Started
Device Selection

Introduction

For each target you can configure the devices that are connected to it.

Device creation

The following table shows how to attach devices to a target:

Step Action

1 Select a device in the Device List box and click the > button. 
Result: The device appears in Selected Target(s) Device(s).

2 In the selected Target(s)/Device(s) zone, enter the device name in the Name 
column and its address in the Address column. For more information about 
addressing refer to the Modicon M340 for Ethernet Communications Modules 
and Processors User Manual.

3 If the device supports several protocols, enter the desired protocol in the 
Protocol column.
35016149 02/2010 23
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Getting Started
4 If you want to attach more than one target, repeat steps 1 to 4 until you have 
selected all devices required.

5 Click End.
Result: the project example appears in the browser.

6

Save your project by clicking:

Step Action
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Getting Started
Target Properties

Introduction

Target properties allow you to change the name of the target and its address.

This example shows you how to manually configure the IP parameters for a 
BMX NOE 0110. 

Accessing the Target Properties Page

You can access the Target Properties page in one of the following ways:
On the Web Designer browser, right-click the device name and click Properties.
On the Target menu, click Properties.

Result: the Target Properties window appears.

Setting Up the IP Parameters

Use the IP parameters area to define the IP configuration of the module.

Having two devices with the same IP address can cause unpredictable operation of 
your network.
35016149 02/2010 25
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Getting Started
NOTE: In this example, we manually assign the a.b.c.d address to the module. For 
details about managing IP address, refer to the Modicon M340 for Ethernet 
Communications Modules and Processors User Manual.

The following table shows how to manually configure the BMX NOE 0110 module:

WARNING
UNINTENDED OPERATION — DUPLICATE IP ADDRESS

Make sure that this device will receive a unique IP address.
Always obtain your IP address from your system administrator to avoid the 
possibility of duplicate addresses.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Access the Target Properties page.

2 Enter the IP address for the BMX NOE 0110 in the IP Address field.

3 Click OK to validate.

4

Save the new configuration by clicking:
26 35016149 02/2010

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Getting Started
Variable Selection

Introduction

The Select Symbol window lets you configure the variables for various devices that 
can be used in website pages.

All device variables used in a project are grouped in a file called Namespace. The 
Data Editors and Graphic Editors in a project use variables in this Namespace.

Types of Symbols

For Modicon M340, Premium and Quantum PLCs, symbols that can be used come 
from the PLC application (.stu, .xvm, .prj or .fef file type). 

Selecting PLC Symbols

The following table shows how to select PLC symbols:

Step Action

1 In the browser, extend the menu tree in the example.

2 In the Devices directory, double-click a PLC type device (Modicon M340 in our 
example).
Result: 

3 Click Import PLC symbols.
Result: the Open window appears.

4 Select the (.stu or .xvm) file in which the application symbols are.
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Namespace

By clicking the Namespace file of the project in the browser, a table that groups all 
symbols previously selected for targets or devices appears.

5 Click Open.
Result: the Select Variables to Import window appears.

6 Select the required symbols by double cliking the 1st column.

7 Click Import selected variables.

8 Save the project by using the menu Project → Save all. 

Step Action
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Data Editor

Introduction

The Data Editor enables you to create Web pages in which the values of variables 
are displayed in table format. In certain cases these values can be modified by the 
user.

Allowing write access can change system behavior.

Selecting Editor Symbols

WARNING
UNINTENDED OPERATION

 Make sure variables that can be written are accessible by trained personnel 
only (password protect).
Do not give write access to critical control variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 In the browser, extend the menu tree in the example.

2 Right-click the DataTables directory to open the contextual menu and choose 
New Table.

3 In the Table Name field, enter a name for the data table.

4 Click OK.
Result: An empty data table appears.
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5 To access the configuration zone:
Double-click a line of the Table window,
Or right-click the Table window to open the contextual menu and choose 
New.

Result: The configuration zone appears.

6
Click , to obtain a list of available symbols. 

Result: The search panel for symbols appears.

Note: The list corresponds to the variables coming from the devices connected 
to the target.

Step Action
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7 Select the symbols that you wish to monitor.

8 Click OK.

9

Save your table by clicking:

Step Action
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Graphic Editor

Introduction

The Graphic Editor enables you to create Web pages in which the values of 
variables are displayed as graphic objects, such as VU meters, indicators, etc.

Some graphic objects allow values to be entered. In this case, the variable must be 
write authorized and, in order to be able to use it, the user must have entered the 
write authorization password. 

In the configuration phase, the Graphic Editor allows you to edit and view screens 
at the same time. In the operation phase, you can only visualize one screen at a time 
in order to optimize memory resources.

Selecting Graphic Objects

The following table shows how to open the Graphic Editor:

Step Action

1 In the menu tree, select the target.

2 Right-click the GraphicScreens directory to open the contextual menu and 
choose New Graphic Page.
Result: the Graphic Editor panel appears.

3 Click Edit.

4 Select graphic objects from the band on top of the screen.

5 Click the sub-window under the main window to place them.

6 Open the Properties window by double-clicking on the graphic object.

7 You can specify a name, a label, the data type and many other parameters. Click  

 on the right of the Address field to associate a variable with the object.
Result: the Lookup Variables window appears.

8 Select the variable that you want to associate with the object.
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9 Repeat steps 4 to 8 to add other objects.

10 Once you have finished, click Done.

11 Click Save and enter a name for the graphic (graph).

Step Action
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Transfer

Introduction

Once you have completed the site construction on the configuration PC, you should 
transfer it to a target.

Transfer the Website to a Target

Step Action

1 Select BMX NOE 0110 in the menu tree.

2 Click Target → Transfer → PC ->Target. 
Result: The Target Validation window appears.

If there are errors in your project, the transfer cannot be performed. Refer to 
the Project Validation part (see page 55) for more information.
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3 Click OK.
Result: the Transfer Status window appears.

Note: if there are differences between the firmware version of the project and 
the target, the transfer cannot be performed.

4 Click Transfer.
Result: the Configuration Password window appears if a configuration 
password has already been set. Otherwise the project is transferred.

5 Enter the configuration password and click OK.
Result: the Progress Information window appears. The files are displayed one 
at a time in the Status Bar.

Step Action
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Accessing the Website

Introduction

At this time, you have:
created a project,
selected the devices and the variables of your choice,
created data and graphic table to monitor the installation,
transferred your application from the PC to the target.

The last step consists of connecting to the website. The Data Editor and the Graphic 
Viewer are used to view graphic animation pages related to the device variables or 
internal module variables.

Accessing the Website

Step Action

1 Open a Web browser.

2 Type the IP address of the module in the address bar. In this example, we set 
the IP address of the module to a.b.c.d (see page 50). Therefore type a.b.c.d 
in the address bar.

3 Click Go.
Result: The module website appears.

4 Click Monitoring on the horizontal menu bar of the website.
Result: The monitoring home page appears.
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5 Click Data Editor on the vertical menu bar of the website to see the animation 
tables created with the Data Editor.
Select the table created previously on the left side of the Data Editor applet and 

click  to launch the animation.

The following figure shows the Data Table:

6 Click Graphic Viewer on the vertical menu bar of the website to see the 
animation pages created with the Graphic Editor.
The following figure shows the graphics page:

Step Action
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Project Management
Scope of this Chapter

This chapter explains how to manage a project. It concerns: 

Modifying a project,

Opening and closing a project,

Importing a project from a file.

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Adding/Removing Targets 40

Adding/Removing a Device 42

Adding/Removing Items 44

Opening/Closing a Project 46

Import 47
39
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Adding/Removing Targets

Adding a New Target

The following table shows how to add a target:

Step Action

1 Select a project.

2 Click Project → New → Target.
Result: The Web Designer Project Creation Wizard opens, initialized with 
targets that already exist in the project.

3 In the Target List, select the targets to add.

4 Click [>].
Result: The new target appears in the Selected Target(s) list.

5 Type a name and an address for that target.

6 Click Next.
Result: The device selection wizard appears.
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Window Fields

The following table gives a description of the elements of the Web Designer Project 
Creation Wizard window:

The button > enables you to add one of the targets in the list. The button < enables 
you to remove a target in the list.

Removing a Target

To remove a target from the project, right-click the target in the navigator to open the 
contextual menu and select Delete.

NOTE: If you delete a target of the project, all the files associated with that target 
(including devices) are also deleted.

Number of Targets

A project can contain up to 16 targets. It’s possible to select the same type of target 
several times, on condition that you attribute a different name and IP Address for 
each target.

Field Function

Project Project name.

Target List List of available targets.

Target Target types selected in the Module List.

Name Target Name, to distinguish targets of the same type.

Address IP address of the target.
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Adding/Removing a Device

Adding a Device

The following table shows how to add a device:

NOTE: If you have more than one target in your project, select the target in the 
Target List to which you want to attach the device before achieving step 3.

Step Action

1 select the Devices directory of your project.

2 Click Project → New → Device, or
Right-click the Devices directory and then click New Device.
Result: Web Designer Project Creation Wizard window appears, initialized 
with devices that already exist in the project.

3 Select the devices to add in the Device List field and validate with the button >.

4 Type a name and an address for that device.

5 Click End to validate the project targets and devices.
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Window Fields

The following table shows the fields in the Web Designer Project Creation Wizard 
for the Device window.

Removing a Device

To remove a device from the project, right-click the device in the navigator to open 
the contextual menu and select Delete.

NOTE: When you delete a device, all variables relating to the Namespace of the 
device are also deleted.

Device Selection

You can only select 1 device.

Module Device

For a target in a rack, the default address is localhost.

Protocol

You can associate one or several protocols with each device. When a device 
supports several protocols, the protocol column is active and the user can choose 
one from the list. The address in the previous column depends on the protocol 
selected.

Field Function

Target List List of targets created in the previous panel.

Device List List of available devices.

Selected 
Target(s)/Device(s)

Device selected (from the Device List).

Name Name given to the device to distinguish it from other devices of the 
same type.

Address Address of the target.

Protocol Protocol supported by the device (the Protocol List is determined by 
the type of device).
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Adding/Removing Items

Presentation

The following pages show how to add elements of the following type to the project:

Data Tables,

Graphic Pages,

Services,

Folders,

Files.

Adding a Graphics Page

The following table shows how to add a graphics page:

Adding a Data Table

The following table shows how to add a Data table:

Step Action

1 Select the project.

2 Select the sub-directory GraphicScreens in the target directory.

3 Click Project → New → Graphic, or 
Right-click the GraphicScreens directory and click New Graphic Page.
Result: The Graphic Editor opens with a blank page to edit.

Step Action

1 Select the project.

2 Select the sub-directory DataTables in the target directory.

3 Click Project → New → Data, or
Right-click the DataTables directory and click New Table.
Result: The Data Editor opens with a blank table.
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Adding a Service

The following table shows how to add a service:

Adding a Folder

The following table shows how to add a folder:

 NOTE: you cannot create new folders outside of the Website menu tree.

Adding a File

The following table shows how to add a file:

 NOTE: You cannot create new files outside the Website menu tree.

Removing Items

To remove an item from the project, right-click the item in the navigator to open the 
contextual menu and select Delete.

Step  

1 Select the target.

2 Click Project → New → Service, or
Right-click the Service directory and click New Service.
Result: A window opens with a list of services that can be created.

3 Select the desired service from the list.

4 Click OK.
Result: The Service window opens.

Step Action

1 Select one of the Website folders or Website itself.

2 Click Project → New → Folder, or
Right-click the Website directory and click New → Folder.
Result: The Create a Folder window opens.

Step Action

1 Select one of the Website folders or Website itself.

2 Click Project → New → File, or
Right-click the Website directory and click New → File.
Result: The Create a File window opens.
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Opening/Closing a Project

Presentation

This section shows how to:

open/close a project,
save a project,
close Web Designer.

Opening an Existing Project

The following table shows how to open an existing project:

Closing a Project

The following table shows how to close an existing project:

Saving all Modifications

To save all modifications made, select Save All in the project menu or click the save 
all icon in the tool bar. This operation saves all modifications made in open windows. 
These modifications cover all open projects.

Closing Web Designer

When you close Web Designer, it memorizes the open or close state of projects. 
Projects that are open when you close Web Designer will automatically reopen the 
next time you launch the software.

Step Action

1 Click Project → Open Project. 
Result: the Open Project window opens. This window displays the list of 
projects in the workspace.

2 Select a project.

3 Click End. 
Result: the project appears in the menu tree.

Step Action

1 Select the project.

2 Click Project → Close Project. 
Result: the project disappears from the menu tree.
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Import

List of sources 

Web Designer can import a project from the following sources to recuperate 
previous developments:

a .zip file exported by Web Designer,
a Web Designer project outside the Workspace.

Import

To import a project, click Project → Import.

Import window:

After import, the project appears in the menu tree.

Export

To export a project as a .zip file, click Project → Export. This function is useful for 
saving a complete project before modifying it. The project stays open after being 
exported.
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Subject of this Chapter

This chapter describes how to transfer a website. You can transfer it from the 
configuration PC to the module or vice-versa. The transfer concerns the Web pages 
generated by Web Designer  as well as those created by the user. The transfer can 
be more general and it can include files describing services.

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Transfer 50

Project Validation 55

Connecting/Disconnecting to/from the Module 58
49
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Transfer

Introduction

These functions enable you to transfer the Data Editor tables, the Graphic Editor 
pages, the services, the website and its associated files, either from the 
configuration PC to the target, or from the target to the configuration PC. You must 
previously advise the target address. Web Designer carries out a validation on the 
structure of the project before transferring files to the target. 

Setting Up the IP Address

Having two devices with the same IP address can cause unpredictable operation of 
your network.

You must set the IP address of the module to perform a transfer. The following table 
shows how to advise the physical address of the module:

NOTE: You can also advise the address during the creation of the project with the 
Creation Wizard.

WARNING
UNINTENDED OPERATION — DUPLICATE IP ADDRESS

Make sure that this device will receive a unique IP address.
Always obtain your IP addresses from your system administrator to avoid the 
possibility of duplicate addresses.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Select the target in the browser.

2 Click Target → Set Target Address.
The following window appears:

3 Enter an IP Address.

4 Click Validate.
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Transferring from the PC to the Target

The following table shows how to transfer data to the module:

Step Action

1 In the browser, select the target.

2 Click Target → Transfer → PC ->Target. 
Result: the Target Validation window appears.

If there are detected errors in your project, the transfer cannot be performed. 
Refer to the Project Validation part (see page 55) for more information.

3 Click OK.
Note: if there are differences between the version of firmware for the project 
and the target, the transfer cannot be performed.
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4 The Transfer Status window appears:

5 Select the files you want to transfer.

6 Click Transfer.
Result: the Configuration Password window appears if a configuration 
password has already been set. Otherwise the project is transferred.

7 Enter the configuration password and click OK.
Result: the Progress Information window appears. The files are displayed one 
at a time in the Status Bar.

Step Action
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Transferring from the Target to the PC

The following table shows how to transfer data from the module to a PC:

Step Action

1 In the browser, select the target.

2 Click Target → Transfer → Target ->PC. 
The Transfer Status window appears:

3 Select the files you want to transfer.

4 Click Transfer.
Result: the Configuration Password window appears if a configuration 
password has already been set. Otherwise the project is transferred.

5 Enter the configuration password and click OK.
Result: the Progress Information window appears. The files are displayed one 
at a time in the Status Bar.
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Total Transfer of the Project

This function lets you transfer the entire project to all the targets associated with it. 
The transfer is done target by target. The global transfer only works in 1 way, you 
can transfer from the PC to the targets but not from the targets to the PC. In the last 
case, you have to manually transfer the files target by target.

To activate the transfer, click Project → Global transfer. The procedure is exactly 
the same than a transfer from the PC to the target (see page 51). 

Partial Transfer

To save time, it’s possible to do only a partial transfer. In the Website, gdt (graphic 
pages), rdt (data tables) and Service directories, the contextual menu authorizes a 
partial transfer limited to files located in these directories. In this way, you don’t have 
to transfer the entire project if you just modified a small part.

Documentation

To manage online documentation, the user can add Word (.doc) or Acrobat (.pdf) 
files to the website in the site directory. The Transfer function lets you copy these 
files to the target.

Site Explorer

The button Site Explorer displays all the target files in the lower window. This is 
especially useful before or after a data transfer, in order to analyze the contents of 
the target.
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Project Validation

Introduction

Web Designer carries out a validation on the structure of the project before 
transferring files to the target. If the verification detects anomalies, the transfer is 
cancelled. Web Designer also performs a comparison between the PC configuration 
and the target configuration.

Validating a Project

When you start a transfer, Web Designer performs a project validation. You can also 
validate a project at any time by selecting Project Validation in the Project menu.

The Project Validation window looks like this:

The validation process monitors the following points:
the available space on the target is bigger than the size of the website,

the use of a user page or a service, with variables that will not be in the 
Namespace (file Namespace.dat),
the number of variables is less that the maximum number authorized for the 
target (1000 variables),
the detected errors related to services.

Click a line with a message to display the details of detected errors encountered.
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Transfer Status

The following figure shows the Transfer Status window:

The information has not been found on the remote target. 

Inconsistent, non-blocking information between the target and the PC. 

Inconsistent, blocking information between the target and the PC. 

Consistent information between the target and the PC. 
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Use the Select area to specify the files you want to transfer: 

Parameter Action

Transfer Website Select this box to transfer files located in the Website directory.

Transfer only 
Modified Files

Select this box to transfer only files of the website that have been 
modified since the last transfer.

Transfer rdt and gdt 
Files

Select this box to transfer data tables (rdt directory) and graphic pages 
(gdt directory).
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Connecting/Disconnecting to/from the Module

Introduction

The information below explains the procedure for executing an application once the 
services have been created.

Transferring a project to the module permanently erases the existing project. When 
a project is transferred, the old project is overwritten.

Anyone who has access to Web Designer can modify the value of PLC variables 
that have been write enabled and also modify your security settings. Unauthorized 
or incorrect changes to data change the behavior of your application or your process 
in ways that can be undesirable or even hazardous.

NOTE: if an application is in RUN mode, the new project will be taken into account 
after a module reboot.

WARNING
UNAUTHORIZED SECURITY ACCESS

 Change or disable default passwords on all devices, since default settings are 
often easy to find in user manuals.
Change your passwords monthly.
Do not choose simple user names and passwords.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

CAUTION
LOSS OF DATA

Backup important information before transferring a new application.

Failure to follow these instructions can result in injury or equipment damage.
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Connecting to the Module and Recovering a Project from the Module

The following table shows the procedure for connecting to the module with a view to 
recovering its application:

Disconnecting from the Module

The following table shows the procedure for disconnecting from the module:

Step Procedure

1 Select the target in the browser.

2 Click Target → Connect → Target.
Web Designer analyses the changes between your project and the module 
content.
If you have modified the project, the software will ask you to transfer the project. 
Otherwise the application moves automatically to online mode.
Result: the Configuration Password window appears if a configuration 
password has already been set. Otherwise Web Designer connects to the 
module.

3 Enter the configuration password and click OK.
Result: Web Designer connects to the module.

Step Function Procedure

1 Disconnecting 
from the 
module

Click Target → Disconnect. 
Result: Web Designer has just switched back to offline mode.
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Simulation Mode
Scope of this Chapter

This chapter describes the simulation mode. This mode can be used for debugging 
data tables, graphic pages and services without being connected to the target. 

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Connecting/Disconnecting to/from the Simulator 62

Simulation 63
61
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Connecting/Disconnecting to/from the Simulator

Introduction

The following information describes the operating mode for launching an application 
through the simulator.

The simulator enables you to execute an application without having to connect to a 
module. It is therefore possible to test the application from a PC before transferring 
it to the module.

NOTE: The graphic and data editors (see page 77) are both active in simulation 
mode. You can therefore modify these pages in simulation mode.

Once the changes are made, carry out a part transfer in order to reduce transfer 
time.

Connecting to the Simulator

The following table shows the procedure for connecting to the simulator and 
transferring the application:

NOTE: Simulation does not work if a FTP server is running on the system.

Disconnecting from the Simulator

The following table shows the procedure for disconnecting from a module:

Animations

In simulation mode, the variables are animated as follows (value update frequency 
depends on the update frequency setting):

bit: value change, 0 or 1,
word: increment step 1.

Step Procedure

1 Select a target in a project.

2 Click Target → Connect → Simulation.
You are now connected to the simulator, the application is in 
simulation mode.

Step Procedure

1 Click Target → Disconnect → Simulation. You have just switched 
back to configuration mode.
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Simulation

Introduction

You can simulate your website or your application without using actual devices. This 
allows you to verify your configuration and test the behavior of your application even 
if devices are not yet available.

Simulation Mode

Simulation Mode is available with protocols:

UMAS,
UNITE,
Modbus.

Simulation Mode enables you to test the behavior of your application without running 
it in the module. In this case, the application runs in the configuration PC. 

The user can enter pertinent values for variables (symbols). The default values are 
set to zero. The values are entered manually in the window associated with the 
device (double-click the device in the menu tree) or they can be automatically 
incremented.

Using the Simulator Icon

Using the Simulator for Data Tables and Graphic Pages

Step Action

1

In the task bar, right-click on the simulation icon .

2 If you check AutoIncrement the variables will be automatically incremented.
If you uncheck AutoIncrement, the variables will no longer be incremented and 
you can modify the value of R/W variables.
If you check StopServer, the simulation stops.

Step Action

1 Select a target in a project.

2 Extend the target directory.

3 Select a table in the DataTables directory or a graphic in the GraphicScreens 
directory.

4 Right-click and select Open.
Result: an Internet Explorer window appears in which the selected table 
appears or the drop-down menu to select the graphic.
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5 For graphics, select a graphic in the drop-down menu.
Result: the following figure shows an example of a graphic being simulated.

6 Apply the values to simulate to the variables or the graphic objects.

Step Action
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Using the Simulator for Device windows

Step Action

1 Double-click the desired device in the Devices directory. 
Result: the following window appears.

2 Click Animate persistent.
If the AutoIncrement function is checked, the variables are automatically 
incremented. In the Value column, the simulated values are displayed.
Else, the variables are no longer incremented. For R/W variables, double-click 
the Value column to modify the values.
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Managing Variables
Subject of this Chapter

This chapter explains how Web Designer handles variables. This concerns 
importing variables, either from a file describing a piece of equipment, or from a file 
exported by software from the automated program, listing variables from the 
automated program. 

This chapter also presents the file called Namespace which groups all these 
variables. The data and graphics publishers as well as services use these variables.

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Namespace 68

Importing from a Programmable PLC 69

Manual Edit 73

Author Rights in Namespace 74
67
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Namespace

Introduction

Namespace groups all variables (symbols) previously selected for targets or 
devices. Data Editors, Graphic Editors, and services get symbols from Namespace.

Variables come from either connected devices or from PLC applications. If you 
connect a device type to the same target several times, compose the name as 
follows in order to have a unique name: device.name, variable name. If the device 
is a PLC, compose the names of variables declared in the PLC like this: PLC 
device.name, PLC variable name.

Accessing the Namespace

Step Action

1 Select the project.

2 Extend the target directory.

3 Double-click the Namespace icon. 
Result: the Namespace window appears.
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Importing from a Programmable PLC

Introduction

It’s possible to access a Unity Pro database with the function Import Symbols.

NOTE: Depending on the devices that you connect to the target, the type of 
variables you can access through the target might be different. Refer to the 
FactoryCast for Modicon M340 User Manual or FactoryCast for Premium and 
Quantum User Manual for more information on supported variables.
35016149 02/2010 69

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Managing Variables
Accessing the Software Database

The following table shows how to access the software database:

Step Action

1 Double-click the desired device in the Devices directory. 
Result: the following window appears.

Topic Name of the variable.
Variable Address of the variable.
Type Type of variable.
Access Access right to the variable.
Persistent Access mode to the variable. It cannot be changed.
Rate Frequency at which the variable value will be refreshed.

2 Click Import PLC symbols. 
Result: a file explorer window opens.

3 Select the file (.stu, .xvm, .fef or .prj) to import.
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Description of the Window

The following table shows the buttons in the preceding window:

4 Click Open.
Result: a window displaying symbols opens.

5 Select desired symbols.

6 Select the variables you want to import by double clicking the variables in the 
list.

7 Click Import selected variables.
Result: the variables appear in the Device window.

Step Action

Button Function

Remove Delete the variable.

Duplicate Duplicate the variable.

Import PLC Symbols Open a selection window of variables.

Import from CSV Import all the variables from a CSV file.

Export to CSV Export the variables to a CSV file.
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Accessing the Unity Pro Base

In order to access a Unity Pro database, you must install the Unity Pro software on 
your computer. Unity Pro database files have .stu extension. It’s also possible to use 
an Unity Pro export file (extension .xvm). In the latter case, the installation of 
UnityPro is not mandatory.

Synchronization with the PLC Program

Over the course of time, it's possible that you will modify the Unity Pro database from 
which you created your Namespace. The Web Designer Configuration Program will 
automatically alert you about the differences between the database and your 
Namespace when you open a configuration associated with the PLC database file.

Synchronization

The following table shows how to synchronize with a PLC database:

Step Action

1 Click Target → Synchronize with PLC database.
Result: Inconsistencies will be shown in a window. 

2 Click OK to start default resynchronization operations. 

3 Transfer the project to the module.
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Manual Edit

Presentation

You can manually add variables by directly entering a symbol, an address, its type 
and define the access right in the Variables window of each device.

NOTE: Depending on the devices that you connect to the target, the type of 
variables you can access through the target might be different. 

Automatic Input

Automatic Input is an option that makes easier the manual creation of variables by 
incrementing the value of the last record.

If you select this option, the value of the fields is automatically filled when you add a 
new variable. The values correspond to those of the previous line incremented by 1.

Activating / Desactivating Automatic Input:

Options → Automatic Input
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Author Rights in Namespace

Presentation

This table enables you to specify which variables can be accessed in read/write 
mode.

NOTE: Write access is controlled by a password (Security) whose default value is 
USER.

Unauthorized or incorrect changes to data may change the behavior of your 
application in ways that may be undesirable or even hazardous.

WARNING
UNAUTHORIZED CHANGES TO VARIABLES OR DIRECT ADDRESSES.

Carefully select the variables (symbols) and the direct addresses you authorize to 
be modified online, and the people authorized to do so.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Managing Author Rights 

Use the following procedure to manage author rights:

Step Action

1 In the navigator: 
double-click the NameSpace Write Access file or,
rigth-click the NameSpace Write Access file and select Open.

Result: the Window manager for author rights in Namespace appears.

2 Define the intervals at which variables can be written. Outside these intervals, 
variables with direct access are only accessible to read.
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Subject of this Chapter

This chapter presents the different ways provided by Web Designer  to monitor your 
system.

What's in this Chapter?

This chapter contains the following sections:

Section Topic Page

7.1 Data Editor 78

7.2 Graphic Editor 88

7.3 Creating Custom Web Pages 135

7.4 PLC Program Viewer 158
77
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7.1 Data Editor

Overview

The Data Editor allows you to edit/create data monitoring tables or to display Data 
tables. Data tables provide read/write access to application data and devices 
registers. Write access is password protected.

Allowing write access can change system behavior.

This section shows how to use the Data Editor to display and modify the values of 
the symbol variables and direct addresses.

What's in this Section?

This section contains the following topics:

WARNING
UNINTENDED OPERATION

 Variables that can be written must be accessed by trained personnel only 
(password protect).
Do not give write access to critical control variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Topic Page

Data Editor 79

Creating a Data Template 80

Data Editor Spreadsheet 81

Inserting a Symbol (Variable) in a Data Template 84

Inserting a Direct Address in a Data Template 86

Using an Existing Data Template 87
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Data Editor

Overview

Data Editor is a Java applet that enables you to create dynamic data tables that can 
be updated with run-time data from the PLC.

Elements of Data Editor

The following illustration shows you the Data Editor:

Number Description

1 List of the variables included in this table.

2 The configuration area makes it possible to:
select and/or modify a symbol,
select and/or modify an address,
select the variable type,
select the variable’s display format,
check the read-only option.
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Creating a Data Template

Overview

To display some symbols (variables), you must create a new data template.

Creating a Data Template

Follow the steps in the table below to create a data template: 

NOTE: Save the current spreadsheet before selecting a new spreadsheet. Selecting 
a new spreadsheet deletes the current spreadsheet.

Step Description

1 Right click the DataTables directory in the navigator and select New Table.
Result: the New Table window appears.

2 Enter a name of the new Data template.

3 Click OK.
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Data Editor Spreadsheet

Overview

Depending on the target, the Data Editor displays data in a spreadsheet with the 
following fields:

name,
address,
type,
read only,
format,
status.

This section describes the spreadsheet screen and gives an explanation of each 
field.

Spreadsheet

The following figure shows the Data Editor spreadsheet:
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Field Name

The fields in the Data Editor screen are:

Type Field

The Data Type field contains the data type of the symbol variable or direct address. 
The types of data of the symbolic variable appear automatically when the symbol 
variable is located. Direct address data types must be set by the user from a drop-
down list.

The following data types are valid:

Fields Function

Name The Name column contains the names of symbolic variables from the 
Namespace.
The symbolic variables which may be used in the Data Editor are those 
that have been predefined by the configuration tool.  The symbolic 
variables are grouped in a file called Namespace.

Address The Address column contains the addresses of the symbols. You can 
display any direct address by entering its reference in this field. This direct 
address does not need to be referenced in Namespace. However, a 
symbol must be associated with this direct address.

Type Data type (see page 82): input or output register, input or output bit.

Format Format (see page 83) of the data value.

Read Only If this box is selected the variable cannot be output directly.

Abbreviation Data type

INT 16-bit signed integer

UINT 16-bit unsigned integer

DINT 32-bit signed integer

UDINT 32-bit unsigned integer

REAL 32-bit IEEE floating point

TIME 32-bit unsigned integer (in ms)

DATE Date (32-bit BCD)

TOD Date/time (32-bit BCD)

BOOL 1 internal bit (boolean)
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Format Field

The Format field contains the format type for displaying the value of the symbol 
variable or direct address. The following formats are accepted:

Status Field

The Status column contains messages about the status of communications with the 
symbol variable or direct address. If communications are normal, the status 
message is "OK". 

If communication with a simple variable or a direct address is not operational, the 
Status column displays a message describing the event.

Abbreviation Format Type

bool Boolean

dec Decimal

hex Hexadecimal

binary Binary

ASCII Bytes displayed as ASCII characters

time Day_hr_min_sec_ms

date YYYY-MM-DD or HH:MM:SS
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Inserting a Symbol (Variable) in a Data Template

Overview

If you want to view or modify the value of a symbol (variable) in the Namespace, you 
must insert that symbol (variable) in a data template.

WARNING
UNINTENDED EQUIPMENT OPERATION

 Password-protect access to the embedded server.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Inserting a Symbol (Variable)

Follow the steps in the table below to insert a Symbol (variable):

Step Action

1 Double-click on an empty row in the spreadsheet.
Result: The data editor’s configuration area appears. 

2

In the configuration area, click on the button.
Result: The Lookup window appears.

3 Select the symbols (variables) you want to insert in the data template by clicking 
them in the list.

4 Click OK.
Result: New rows corresponding to the symbols (variables) you selected appear 
in the spreadsheet.

5

Save your data table by clicking .
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Inserting a Direct Address in a Data Template

Presentation

If you want to view or modify the value of a direct address, you must insert that direct 
address in a data template.

Allowing write access can change system behavior.

Inserting a Direct Address

WARNING
UNINTENDED EQUIPMENT OPERATION

 Limit embedded server access to qualified personnel.
Password-protect access to the embedded server.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Double-click on an empty row in the spreadsheet.
Result: The data editor’s configuration area appears. 

2 In the Address field of the configuration area, enter the variable’s Direct 
address.

3 In the configuration area, click on Apply.
Result: A new row that corresponds to the variable address is displayed in the 
spreadsheet.
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Using an Existing Data Template

Overview

Once you have created data templates, you may want to access or modify them. 

Accessing a Data Template

The following procedure shows you how to access a existing data template.

Step Action

1 Extend the DataTables directory in the navigator.
Result: The existing tables appear in the navigator.

2 Double click the table you want to modify in the list or,
Right click the table you to modify and select Edit.

Result: The selected table appears in the editing zone.
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7.2 Graphic Editor

Subject of this Section

This section describes the functions and characteristics of the Graphic Editor. The 
Graphic Editor is a Web page that enables the user to create dynamic graphic 
displays using a predefined set of graphic objects. The Graphic Editor is both a 
graphic editor that can be used to create and modify displays and a Runtime 
environment that allows the user to view animated displays using data from the PLC. 
To limit the size of the applet, only Viewer is accessible from the module’s website.

What's in this Section?

This section contains the following topics:

Topic Page

Overview of the Graphic Editor 89

Graphic Editor Toolbar 91

User Functions in the Display Window 96

Properties Sheet 99

Security 101

Graphic Editor Applet Parameters 102

Graphic Objects 104

Extended Graphic Objects 124
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Overview of the Graphic Editor

Interface

The Graphic Editor is made up of three windows:
Top window: features an area for presenting the user commands and dialog 
boxes for creating, saving, reading and editing a graphic display.
Display window: presents the current graphic display. When you create a new 
graphic display, this window turns into a blank space into which you can add the 
graphic objects that will make up the required graphic display.
Message window: contains messages generated by the Graphic Editor.

View of the Graphic Editor

The figure below shows the Graphic Editor with its initial top window and empty 
display and message windows.

Graphic Objects

All the graphic objects supplied with the Graphic Editor are able to communicate with 
the modbus devices from which the Graphic Editor was downloaded. There is no 
additional "wiring" between the graphic objects and the "communication objects". All 
the graphic objects are designed as standalone objects, which means that no 
connection is needed between the objects, and that each object is capable of 
operating on its own.

Allowing write access can change system behavior.
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NOTE: Write access is controlled by a password (Security) whose default value is 
USER.

Creating and Modifying Graphic Displays

To create and modify graphic displays, click Edit.... The standard functions of the 
Graphic Editor are displayed. With these tools, you can select objects from a palette, 
position them in an area, move and resize them with the mouse and define their 
properties. You can immediately test the graphic display modified with the execution 
data from modbus devices by clicking Done to leave Edit mode. If you are satisfied 
with the graphic display you have created, you can save it in the module for later use 
by clicking Save..., provided that you have entered the correct password.

NOTE: Be careful when you modify and save a graphic page, the last modifications 
will be saved and will overwrite the existing page even if someone else has created 
it.

User Functions

Most of the user functions in the Graphic Editor can be found in the top window 
(see page 91). You can modify the size and position of a graphic object directly in 
the display window. All the properties of a graphic object (such as its scale, labels, 
colors and Uni-Telway execution data device addresses) are defined in the 
properties sheet (see page 99).

WARNING
UNINTENDED EQUIPMENT OPERATION

Keep strict access to the embedded server by configuring passwords.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Graphic Editor Toolbar

Overview

The Graphic Editor toolbar is composed of several dialog panels, only one of which 
is shown at a time. Switching from one dialog to another is done by clicking the 
buttons on the current dialog. This section describes the dialog panels that comprise 
the top window.

Top Dialog

The Edit Dialog allows you to select a graphic object for placement in the display 
window, and provides access to all graphic editing functions. The available graphic 
objects are presented in a set of palettes, with one palette visible at a time. There 
are two palettes.

The standard palette:

The extended palette:

The controls in the top dialog box provide the following functions.
Drop-down List. The drop-down list box shows all the graphic pages that have 
been saved, and are available for retrieving. When you select a graphic page 
from this list, the graphic display currently visible in the window is replaced with 
the one selected. If the current graphic page has been modified since it was last 
saved, you will be asked for confirmation that the changes are to be discarded. If 
the special entry <new> is chosen from the list, then the display window is 
cleared, and a new graphic page can be created.
Save. The Save button causes the Save dialog box to become visible. This 
button is disabled until you have entered a correct write-enable password.
Delete. The Delete... button causes the Delete dialog box to become visible. 
This button is disabled until you have entered a correct password, or if the current 
graphic display has not yet been saved.
Edit. The Edit... button causes the Edit dialog box to become visible.
Information display area. The information display area shows the name and 
version of the Concept, PL7 or Unity Pro program that is running in the connected 
PLC.
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Save Dialog

The Save dialog box allows you to save the current graphic display.

When the Save dialog box is presented, the name of the current graphic page is 
shown in the dialog’s text field. If the current graphic page has never been saved 
(i.e., a "new" graphic display), then the text field is blank. Once you have either 
accepted the current name (a "save" operation) or provided a new name (a "save 
as" operation), then you can click OK to save the contents of the current graphic 
display to the Web server module. The Cancel button will cause the Top dialog box 
to be shown again, with no action being taken.

Delete Dialog

The Delete dialog box allows you to delete the current graphic page.

If you click Yes, the existing graphic display window is cleared and the graphics file 
on the Web server module is deleted. Clicking No will cause the Top dialog box to 
be shown again, with no action being taken.

Password Dialog

The Password dialog box allows you to enter the password that enables those 
user functions that modify graphic display files or PLC run-time data values.

If you enter the correct password and click OK, then you will be allowed to save and 
delete the current graphic display. Correct password entry also permits you to write 
new values to the PLC (via those graphic objects that support writing values to a 
PLC, if any). If you click OK when the text field is empty, then the current password 
permissions, if any, are cleared. The Cancel button will cause the Top dialog box 
to be shown again, with no changes made to current password permissions.
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Edit Dialog

The Edit dialog box allows you to create or modify a graphic page, by selecting a 
graphic object for placement in the display window, and accessing all the graphic 
editing functions. The graphic objects available are presented in a single object 
palette.

The controls of the Edit dialog box provide the following functions:
The Drop-down List Box shows the set of palettes that are available. When you 
select the name of a palette from the list, the palette area of the dialog displays 
the selected one’s graphic objects.
The Palette shows the graphic objects that are in the current palette with an icon 
that depicts each graphic object's type (meter, button, etc.). When you click any 
of the icons in the palette, a graphic object of the corresponding type becomes 
selected for insertion. While the Graphic Editor is in "insert mode," if you click in 
an open area of the display window, an instance of the selected graphic object is 
inserted into the graphic display.
The Information Area shows the name and size of the graphic object that is 
currently selected.
The Cut button causes the currently selected graphic object(s) to be removed 
from the graphic display and saved to a buffer (i.e., an internal clipboard), 
replacing any existing contents of the buffer.
The Copy button causes the currently selected graphic object(s) to be copied to 
the buffer, replacing any existing contents.
The Paste button causes the content of the clipboard to be inserted into the upper 
left corner of the graphic display. The pasted graphic objects can then be moved 
to the desired location in the display.
The Properties button causes the properties sheet (see page 99) for the 
currently selected graphic object to be shown.
The Customize button causes the Customizer for the currently selected object to 
be shown, if the graphic object has been provided with one.
The Layout button shows the Layout dialog box.
The Options button shows the Options dialog box.
The Done button causes the Top dialog box to be shown again.
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Layout Dialog

The Layout dialog box allows you to change the position and size of a group of 
graphic objects.

The controls of the Layout dialog box provide the following functions.
The Right, Bottom, Left, and Top buttons can be used to align the edges of the 
selected graphic objects so that their specified sides are at the same position. At 
least two graphic objects must be selected for these buttons to be enabled.
The Horizontal, and Vertical buttons are used to align the centers of the graphic 
objects. At least two graphic objects must be selected for these buttons to be 
enabled.
The Horizontal and Vertical buttons are used to space the selected graphic 
objects regularly, in order that the horizontal or vertical spacing between the 
objects is the same. At least three graphic objects must be selected for these 
buttons to be enabled.
The Width and Height buttons are used to achieve parity in dimensions of the 
graphic objects, so the selected width or height corresponds. At least two graphic 
objects must be selected for these buttons to be enabled.
The Done button causes the Edit dialog box to be shown again.

NOTE: For all layout operations (except Space evenly) one of the selected objects 
is considered the "reference object" to which all other selected objects refer in order 
to know their new position or dimension. For example, when the "Width" button is 
pressed, all of the selected objects will have their width changed to match the width 
of the reference object. The reference object is differentiated from the other selected 
objects by making its selection box a different color than the others.
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Options Dialog

The Options dialog box is used to change the settings related to a grid drawn in 
the display window. The grid is solely for assistance in editing or creating a graphic 
display and is shown only when the Graphic Editor is in "edit mode."

The controls of the Options dialog box provide the following function.
The cell size of the grid can be changed by the entering the grid's column width 
and row height into the dialog's text fields.
If the Show grid check-box is checked, the grid will be drawn; otherwise, no grid 
will be shown.
If the Snap to grid check-box is checked, then, when you change the size or 
position of a graphic object, the changed coordinate(s) or dimension(s) is 
automatically adjusted so that it coincides with a grid point.
The OK button causes the current option settings to become active, and the Edit 
dialog box to be shown again.
The Cancel button causes the Edit dialog box to be shown again, with no option 
settings being changed.
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User Functions in the Display Window

Overview

The user functions available in the Graphic Editor display window enable objects 
to be selected, moved and resized. To move or resize an object or objects, start by 
selecting the graphic object(s) to be modified. An object is selected when it is 
surrounded by a selection box. Conversely, objects that are not selected do not have 
selection boxes.

The figure below shows the Graphic Editor display window.
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Selecting Graphic Objects

You can set the selection status (selected/deselected) for a graphic object using the 
following user actions:

To select a graphic object, just click it with the mouse. If other objects have 
already been selected, they will immediately be deselected.
You can select several graphic objects at a time using the selection box in the 
display window. If you press the mouse button in a free area of the display 
window (not on a graphic object) and move the mouse without releasing the 
button, a box bordered with dotted lines will appear. One corner of the box 
remains fixed where you first pressed the button, while the opposite corner 
follows the mouse cursor position. When you release the mouse button, all the 
objects within the selection box are selected. Objects outside the selection box 
are deselected.
You can select/deselect a graphic object without altering the selection status of 
other objects. To do this, hold down the CTRL key when you click  an object. This 
allows you to add or remove individual graphic objects in a group of selected 
objects.
You can also select a graphic object without altering the selection status of other 
objects by holding down the SHIFT key when you click the object. When you 
select an object in this way, it becomes the reference object (see page 94) in the 
group of selected objects. The main purpose of this action is to modify the 
reference object in a group of selected objects before using one of the Page 
layout operations.
You can deselect all the graphic objects by clicking the mouse button in a free 
area of the display window, not a graphic object.

Sizing Graphic Objects

To change the size of a graphic object, select it and then use the mouse to change 
the size of the selection box around the object. When you move the mouse cursor 
over the object's selection box, the cursor's appearance changes according to the 
type of resizing you may perform. If you press the mouse button while the cursor is 
over the object's selection box and move the mouse without releasing the button, a 
box bordered with dotted lines will appear. When you release the mouse button, the 
object is resized to fit the dimensions of the area you have defined. You can carry 
out different resizing operations depending on which part of the object's selection 
box you move. Each corner of the box enables the adjacent sides to be moved, and 
each side enables that side only to be moved.
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Moving Graphic Objects

You can move a graphic object in the display window using the mouse. If you press 
the mouse button while the cursor is over an object and move the mouse without 
releasing the button, a selection box will appear. When you release the mouse 
button, the object is moved into the selection box.

To move several graphic objects, select them and then move the group of objects in 
the same way as you would a single object. When you move a group of objects, a 
selection box appears for each object in the group.

Defining Graphic Object Properties

You can define the properties of a graphic object using the property sheet 
(see page 99). If this window is displayed, you can modify the properties of the 
selected graphic object. You can display the property sheet by clicking Properties... 
or by double-clicking on the selected object in the display window.

Customizing Complex Graphic Objects

Certain complex graphic objects have a very wide range of properties. Configuring 
these objects using the properties sheet can be a long-winded process. You can use 
a customization module to make it easier to configure complex graphic objects. The 
customization module is a dialog box designed specially for configuring the graphic 
object with which it is associated. When the Graphic Editor detects a customization 
module associated with the selected graphic object, the Customize... button is 
enabled so that the module can be accessed. When you double-click a graphic 
object that has an associated customization module, the module is displayed 
instead of the properties sheet. If a graphic object has an associated customization 
module, only its name is displayed in the properties sheet.

Display Background Image

The Background image property of the Graphic Editor allows you to choose an 
image that will be used as the background for the display. The image may be a .gif 
file or a .jpeg file. Refer to the Adding Images part (see page 127) for information on 
adding images.
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Properties Sheet

Overview

The properties sheet is a floating (non-modal) dialog box which presents all the 
configurable properties of the selected graphic object:

The properties of a graphic object are specific to its type. They are contained in a 
drop-down list, and are identified by a name and value. The Graphic Editor provides 
a description of the graphic objects (see page 104).
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Find variables dialog box

For each of the graphic objects provided with the Graphic Editor, a property editor is 
provided for its Address property. This property editor not only allows you to directly 
enter the address of a variable, but also provides access to the Find variables 
dialog box. The Lookup Dialog allows you to pick a symbol (variable) name from a 
list of symbol (variables) that have been "Web enabled" by Web Designer.

The Lookup Variable dialog box looks like this:
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Security

Security

Your data is protected by three security devices:
The HTML page which contains the Graphic Editor applet has been placed in the 
secure directory on the Web module. The Web browser user is therefore invited 
to enter a password which will allow him/her to download the HTML page.
You must enter the correct password in the Password dialog box to be able to 
save/delete files or send data values. For the transfer of data values, the Graphic 
Editor reinforces the read only mode by deactivating all the graphic objects user 
commands.
The Graphic Editor allows you to indicate if an element is read only. The Graphic 
Editor reinforces the read only attribute of a symbol (variable) or address by 
rejecting any request which would define a new data value and by informing the 
user via the Graphic Editor message window.

For example, say you have programmed a pushbutton object to jog a motor when 
the button is depressed and to stop jogging when the button is released. If 
communications are lost while the button is depressed, the motor will continue to jog 
even when the button is released. Graphic objects should not be used to control 
situations such as this unless other interlock methods are installed in the system.

WARNING
UNINTENDED EQUIPMENT OPERATION

Do not use graphic objects in situation where loss of communication to the 
FactoryCast module can affect human or material integrity. Graphic objects are not 
intended for use in safety critical machine functions.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Graphic Editor Applet Parameters

Overview

Three applet parameters allow the Graphic Editor behavior to be customized. 
These are defined by the <PARAM> tags inside the <APPLET> tag on the Graphic 
Editor HTML page. The parameters recognized by the Graphic Editor applet are as 
follows:

LOAD: this parameter asks the Graphic Editor to automatically load a specific 
graphic file at start-up. If this file does not exist, a message is displayed. If this 
parameter does not appear in the <APPLET> tag, no file will be automatically 
loaded at start-up and you must choose an initial graphic file from the list 
proposed by the Graphic Editor.
MODE: this parameter asks the Graphic Editor to start either in Edit (normal 
mode) or View mode (specific mode). When starting in View mode, the Graphic 
Editor only displays the display window. When this parameter is used with the 
LOAD parameter, you can design a website with HTML pages dedicated to 
specific graphic display. The user does not need to select a graphic file so the 
behavior of the HMI screen is more standard. This parameter may take the 
following values:

EDIT (default value): The Graphic Editor starts up in Edit mode (normal 
mode).
VIEW_RO: The Graphic Editor starts up in View mode (read only). The Web 
browser user is not authorized to send data values to Modbus devices.
VIEW_RW: The Graphic Editor starts up in View mode (read/write). The Web 
browser user is authorized to send data values to Modbus devices after having 
entered the password to allow write access.

AUTO_LOGIN: this parameter asks the Graphic Editor to automatically indicate 
the password which authorizes write access to Modbus devices. If the MODE 
parameter is set to VIEW_RW or EDIT, and if you set AUTO_LOGIN to TRUE, 
the Graphic Editor authorizes write access to Modbus devices without asking 
the user to enter a password. This parameter may take the values FALSE 
(default value) and  TRUE.
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Example

Here is an example of an <APPLET> tag which asks the Graphic Editor to start in 
View mode and automatically load a graphic file called UNIT_1. In this case, the 
Web browser allows you to send values to Modbus devices via any graphic object 
handling the sending of values (providing that the password to allow write access 
has been entered).

<APPLET codebase="/classes"
archive="SAComm.jar,GDE.jar,Widgets.jar"
code="com.schneiderautomation.gde.GdeApplet"
width="700" height="514">
<PARAM name="LOAD" value="UNIT_1">
<PARAM name="MODE" value="VIEW_RW">
<PARAM name="AUTO_LOGIN" value="FALSE">
</APPLET>
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Graphic Objects

Introduction

All graphic objects offered by the Graphic Editor help you to create graphic displays 
imitating conventional instrument panels. All the data control and monitoring objects 
have integrated communication functions and are designed as standalone graphic 
objects.

Be aware, however, that if communication to the device linked to the graphic object 
is lost, the object becomes inoperative without the end device's knowledge.

For example, say you have programmed a pushbutton object to jog a motor when 
the button is depressed and to stop jogging when the button is released. If 
communications are lost while the button is depressed, the motor will continue to jog 
even when the button is released. Graphic objects should not be used to control 
situations such as this unless other interlock methods are installed in the system.

In addition, all the objects in the Graphic Editor exist in the form of applets to help 
clients who wish to insert several simple applets into a single HTML page. When 
combined with the LiveBeanApplet, the graphic objects in the Graphic Editor can 
be used in the same way as the LiveLabelApplet.

WARNING
UNINTENDED EQUIPMENT OPERATION

Do not use graphic objects in situations where loss of communication to the 
module can affect human or material integrity. Graphic objects are not intended for 
use in critical machine functions.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Horizontal Indicator

A horizontal indicator gives an analogue representation of the value of a variable in 
a device. This is a horizontal bar which represents a percentage of its range in 
physical units. It is possible to display the value’s digital indication in the centre of 
the bar.

The table below describes the horizontal indicator’s properties:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Major Scale 
Divisions

Number of major scale divisions (marked) 0 to 100

Minor Scale 
Divisions

Number of minor scale divisions (not marked) 0 to 100

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Scale Precision Number of decimal places to be shown for the 
scale labels (set to -1 to use a general exponential 
format)

-1 to 6

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

Value Visible Indicates if there should be digital display of the 
value on the scale

Value Font Font used for digital display of the value (where 
this exists)

Bar Background Background color of the indicator bar
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Vertical Indicator

A vertical indicator gives an analogue representation of the value of a variable in a 
device. This is a vertical bar which represents a percentage of its range in physical 
units.

The table below describes the vertical indicator’s properties:

Bar Color Color of the indicator bar (if the scale value is 
within the High/Low range)

High High Limit 
Value

Value expressed in physical units of the "High 
High" limit.

High High Limit 
Color

Color of the indicator bar if the scale value is 
greater than the "High High" limit

High Limit Value Value expressed in physical units of the "High" 
limit.

High Limit Color Color of the indicator bar if the scale value is 
greater than the "High" limit.

Low Limit Value Value expressed in physical units of the "Low" 
limit

Low Limit Color Color of the indicator bar if the scale value is less 
than the "Low" limit

Low Low Limit 
Value

Value expressed in physical units of the "Low 
Low" limit

Low Low Limit 
Color

Color of the indicator bar if the scale value is less 
than the "Low Low" limit

Limit Deadband Neutral range (as a percentage of the EU range) 
to apply to verification of the High/Low limit

0 to 10

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated gross starting value (without scale) for 
testing the graphic object

Note 3 
(see page 134)

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object
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Label Color Color of the label

Label Font Font used for the label

Major Scale 
Divisions

Number of major scale divisions (marked) 0 to 100

Minor Scale 
Divisions

Number of minor scale divisions (not marked) 0 to 100

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Scale Precision Number of decimal places to be shown for the 
scale labels (set to -1 to use a general exponential 
format)

-1 to 6

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Gross minimum value (without scale) of the 
variable in the device

Note 3 
(see page 134)

Bar Background Background color of the indicator bar

Bar Color Color of the indicator bar (if the scale value is 
within the High/Low range)

High High Limit 
Value

Value expressed in physical units of the "High 
High" limit.

High High Limit 
Color

Color of the indicator bar if the scale value is 
greater than the "High High" limit

High Limit Value Value of the "High" limit expressed in physical 
units

High Limit Color Color of the indicator bar if the scale value is 
greater than the "High" limit.

Low Limit Value Value of the "Low" limit expressed in physical 
units

Low Limit Color Color of the indicator bar if the scale value is less 
than the "Low" limit

Low Low Limit 
Value

Value of the "Low Low" limit expressed in physical 
units

Low Low Limit 
Color

Color of the indicator bar if the scale value is less 
than the "Low Low" limit

Property Description Limits
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Horizontal or Vertical Slider

A horizontal or vertical slider gives an analogue representation of the value of a 
variable in a device. This is a slider, whose position is indicated by the cursor, which 
represents a percentage of its range in physical units. Using the mouse, you can 
change the value of the slider by sending a new value to the device.

The table below describes the horizontal or vertical slider’s properties:

Limit Deadband Neutral range (as a percentage of the EU range) 
to apply to verification of the High/Low limit

0 to 10

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated gross starting value (without scale) for 
testing the graphic object

Note 3 
(see page 134)

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Major Scale 
Divisions

Number of major scale divisions (marked) 0 to 100

Minor Scale 
Divisions

Number of minor scale divisions (not marked) 0 to 100

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Scale Precision Number of decimal places to be shown for the 
scale labels (set to -1 to use a general exponential 
format)

-1 to 6

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)
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Horizontal or Vertical Selector

A horizontal or vertical selector allows you to choose from a number of options. 
Once the selection has been made, the value corresponding to the choice is sent to 
the device. The choices are represented by the marks on a "scale", the current 
selection being indicated by the position of the cursor on a slider.

The table below describes the horizontal or vertical selector’s properties:

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

Block Increment Amount by which the scale value is modified when 
the user clicks on the bar’s slide area.

Unit Increment Amount by which the scale value is modified when 
the user clicks on the slider arrows

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Choices Selector choices Each choice is indicated in the 
form of a "label=value" input (when you select a 
"label", the "value" is sent to the device).

At least two 
choices required

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Scale Visible Indicates if a "scale", labeled with the choices 
should be displayed

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border
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Digital Indicator

A digital indicator gives a digital representation of the value of a variable in a device. 
The value may be displayed in different formats and may be set to change color 
when a predefined high or low limit is exceeded.

The table below describes the digital indicator’s properties:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Value Format Format (decimal, hexadecimal, etc.) to be used to 
display the value on the scale

Value Precision Number of decimal places to be shown for the 
value on the scale (set to -1 to use a general 
exponential format)

-1 to 6

Value Background Background color of the value’s display zone

Value Color Color of the value’s digital display text

Value Font Font used for digital display of the value

Units Label of the value’s physical units (attached to the 
value’s digital display)

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

High High Limit 
Value

Value of the "High High" limit expressed in 
physical units

High High Limit 
Color

Color of the indicator bar if the scale value is 
greater than the "High High" limit

High Limit Value Value of the "High" limit expressed in physical 
units
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Message Display

A message display shows a text message based on the value of a variable in a 
device. For each specified message, a set value triggers its display.

The table below describes the message display’s properties:

High Limit Color Color of the indicator bar if the scale value is 
greater than the "High" limit.

Low Limit Value Value of the "Low" limit expressed in physical 
units

Low Limit Color Color of the indicator bar if the scale value is less 
than the "Low" limit

Low Low Limit 
Value

Value of the "Low Low" limit expressed in physical 
units

Low Low Limit 
Color

Color of the indicator bar if the scale value is less 
than the "Low Low" limit

Limit Deadband Neutral range (as a percentage of the EU range) 
to apply to verification of the High/Low limit

0 to 10

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated gross starting value (without scale) for 
testing the graphic object

Note 3 
(see page 134)

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Messages All messages to be displayed. A "value=text" input 
corresponds to each message (when the device 
value is equal to "value", the "text" message is 
diplayed).

At least one 
message required

Message 
Background

Background color of the message display zone

Message Color Message text color

Message Font Message text font

Label Label to be displayed as part of the graphic object

Label Color Color of the label
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Push Button

When activated with the mouse, a push button allows you to send one or more 
preset values to a device.

The table below describes the push button’s properties:

Label Font Font used for the label

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the border of the graphic object

Value Simulated input value for testing the graphic 
object

Note 3 
(see page 134)

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Background color of the graphic object

Values Values to send to the device Note 4 
(see page 134)

Reset Values Values to send to the device once the reset delay 
has expired. If no reset value is given, the reset 
will not take place.

Reset Delay Delay (in milliseconds) that the push button must 
comply with between sending the values to the 
device and sending the reset values

0-2000

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Button Label Text of the button label

Button 
Background

Button color 0 to 100

Button Label 
Color

Color used for the button label

Button Label Font Font used for the button label

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border
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Direct Output Station

The direct output station allows you to enter a digital value in a text zone directly from 
the keyboard. If the value entered is between the upper and lower preset limits, a 
Set button is activated. In this case, the value entered is sent to the device when you 
click Set or press ENTER (if keyboard input is authorized for the input zone).

The table below describes the direct output station’s properties:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

Maximum Input Maximum value, expressed in physical units, 
authorized for the value entered in input

Minimum Input Minimum value, expressed in physical units, 
authorized for the value entered in input

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border
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Indicator Light

The indicator light provides a double indication of the value of a variable in a device. 
If the Input Inverted property is not set to TRUE, a zero input value is declared as 
being OFF and a non-zero value is declared as being ON. If the Flash Interval 
property is set to a positive value, the indicator light will flash when the input value 
is equal to ON.

The table below describes the indicator light’s properties:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Off Word Text to be displayed when the input value is OFF

Off Word 
Background

Background color of the indicator light when Off 
Word is displayed

Off Word Color Color of the Off Word text

Off Word Font Font used for the Off Word text

On Word Text to be displayed when the input value is ON

On Word 
Background

Background color of the indicator light when On 
Word is displayed

On Word Color Color of the On Word font

On Word Font Font used for the On Word text

Flash Interval The flashing time for the indicator light (expressed 
in milliseconds) when the input value is ON. Set to 
zero for no flashing.

200 to 2000

Shape Shape (circular, rectangular, etc.) of the indicator 
light

Input Inverted On TRUE, inverts the input value. (The indicator 
displays  Off Word when the input value is ON.)

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the border of the graphic object

Value Simulated input value for testing the graphic 
object

Note 3 
(see page 134)
114 35016149 02/2010

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Monitoring
Motor Control Station

The motor control station is designed to imitate the on/off push button standard 
station which is frequently used to control the motors. This graphic object is 
essentially compose of two push buttons and an indicator light. To facilitate the 
configuration of this object’s many properties, a custom module is provided. It is by 
means of this module, and not the Graphic Editor properties sheet, that all the 
properties (apart from the name) are configured.

The table below describes the motor control station’s properties:

Analog Meter

An analog meter gives an analog representation of the value of a variable in a 
device. It is represented by a pointer on a circular dial whose position corresponds 
to a percentage of its range in physical units. You can set the size of the meter’s 
circular dial (circle degrees sweep), its colors and the style of the pointer.

The table below describes the analog meter’s properties:

Property Description Limits

Name Name of the graphic object

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Indicator Light Properties identical to those of the Indicator Light 
graphic object with the exception of the shared 
properties listed above

Top Push Button Properties identical to those of the Push Button 
graphic object with the exception of the shared 
properties listed above

Bottom Push 
Button

Properties identical to those of the Push Button 
graphic object with the exception of the shared 
properties listed above

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 
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Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Major Scale 
Divisions

Number of major scale divisions (marked) 0 to 100

Minor Scale 
Divisions

Number of minor scale divisions (not marked) 0 to 100

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Scale Precision Number of decimal places to be shown for the 
scale labels (set to -1 to use a general exponential 
format)

-1 to 6

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

Dial Degrees 
Sweep

Portion of circular arc to be used to draw the dial 60 to 300

Pointer Type Type of pointer used (needle, arrow, etc.)

Pointer Color Color used for the pointer

Dial Color Color used for the dial (for the part in the High/Low 
range)

High High Limit 
Value

Value of the "High High" limit expressed in 
physical units

High High Limit 
Color

Color of the indicator bar if the scale value is 
greater than the "High High" limit

High Limit Value Value of the "High" limit expressed in physical 
units

High Limit Color Color of the indicator bar if the scale value is 
greater than the "High" limit.

Low Limit Value Value of the "Low" limit expressed in physical 
units

Low Limit Color Color of the indicator bar if the scale value is less 
than the "Low" limit

Property Description Limits
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Rotary Slider

A rotary slider gives an analog representation of the value of a variable in a device. 
It is represented by a knob on a circular dial whose position corresponds to a 
percentage of its range in physical units. You can set the size of the dial and the 
color of the knob. Using the mouse, you can change the position of the knob by 
sending a new value to the device.

The table below describes the rotary slider’s properties:

Low Low Limit 
Value

Value of the "Low Low" limit expressed in physical 
units

Low Low Limit 
Color

Color of the indicator bar if the scale value is less 
than the "Low Low" limit

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated gross starting value (without scale) for 
testing the graphic object

Note 3 
(see page 134)

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Major Scale 
Divisions

Number of major scale divisions (marked) 0 to 100

Minor Scale 
Divisions

Number of minor scale divisions (not marked) 0 to 100

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Scale Precision Number of decimal places to be shown for the 
scale labels (set to -1 to use a general exponential 
format)

-1 to 6

Dial Degrees 
Sweep

Portion of circular arc to be used to draw the dial 60 to 300

Dial Color Color of the dial
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Rotary Selector

A rotary selector allows you to choose from a number of options. Once the selection 
has been made, the value corresponding to the choice is sent to the device. The 
choices are represented by the marks on a "scale", the current selection being 
indicated by the position of the knob. The size of the circular dial (circle degrees 
sweep) and the color of the knob can be configured.

The table below describes the rotary selector’s properties:

Knob Color Color used for the knob

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Choices Selector choices Each choice is indicated in the 
form of a "label=value" input (when you select a 
"label", the "value" is sent to the device).

At least two 
choices required

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Scale Visible Indicates if a "scale", labeled with the choices 
should be displayed

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Dial Degrees 
Sweep

Portion of circular arc to be used to draw the dial 60 to 300
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Trend Recorder

A trend recorder enables you to obtain a continuous, time-based graphic of the 
values of a maximum of six variables in a device. It emulates a strip-chart recorder, 
with the pens on the right and the "paper" moving from right to left. A vertical scale 
to the left of the graphic indicates the range of registered values and a horizontal 
scale beneath the graphic displays the range’s time frame. You can set the update 
frequency and the appearance of the graphic.

To facilitate the configuration of the many properties of this object, a custom module 
is provided. It is by means of this module, and not the Graphic Editor properties 
sheet, that all the properties (apart from the name) are set.

The table below describes the trend recorder’s properties: The properties available 
for each of the pens are described in the second table:

Knob Color Color used for the knob

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Property Description Limits

Property Description Limits

Name Name of the graphic object

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Major Scale 
Divisions

Number of major scale divisions (marked) 0 to 100

Minor Scale 
Divisions

Number of minor scale divisions (not marked) 0 to 100

Scale Color Color of the scale and its labels

Scale Font Font used for the scale labels

Scale Precision Number of decimal places to be shown for the 
scale labels (set to -1 to use a general exponential 
format)

-1 to 6

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Update Period Graphic update interval (in seconds) 0.5 to 120
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The following trend recorder properties are available for each pen:

Display Link

A display link is a special graphic object which allows you to move to another graphic 
display by clicking it. To indicate that the object represents a link towards another 
display, the link’s text label is underlined and the mouse cursor changes to a hand 
when it passes over it. This object is especially useful when the Graphic Editor is 
used in View mode which has no drop-down list of graphic displays.

A display link can also be used as an hypertext link to an HTML file. If you enter a 
URL such as Link Display Name, you can open it in a new browser window by 
pressing the SHIFT key while clicking the link. If you only click the link, the existing 
browser window is replaced by the URL.

If the Link Display Name is blank, the label is not displayed underlined and the 
object displayed becomes a simple text label.

Time Scale 
Divisions

Number of divisions on the horizontal scale 0 to 6

Chart Background Color of the graphic zone

Grid Color Color of the grid drawn in the graphic zone

Vertical Grid 
Divisions

Number of vertical divisions in the grid 0 to 100

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Property Description Limits

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the device 
variable

Note 3 
(see page 134)

Pen Color Color of the "pen" which allows the value placed 
on the scale to be recorded

Pen Label Label used to identify the pen

Property Description Limits
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The table below describes the display link’s properties:

Datalogging History

A Datalogging History provides a continuous, time-based charting of the value of up 
to six symbols (variables) coming from the log file of the Datalogging service. A 
Datalogging History emulates a strip-chart recorder, with the pens on the right, and 
the "paper" moving from right to left. A vertical scale can be shown on the left side 
of the chart for showing the range of the values being recorded, and a horizontal 
scale can be shown below the chart for showing the time span of the chart.

NOTE: In order to plot the Datalogging History, you must select the Timestamp 
option in the Datalogging Service (see Web Designer for TSX ETG 30••, User 
Manual) configuration window.

In order to make it easier to set this object’s many properties, a Customizer is 
provided. All properties (except Name) are set with its Customizer, not with the 
Graphic Editor’s Property Sheet.

3 buttons are available in edition and animation mode:
Reload: the Datalogging History object is a static widget. This button enables to 
refresh the value used to build the chart.
+: zoom on the trend. It decreases the time scale in order to have a better vision 
of a part of the trend.
-: zoom out on the trend. It increases the time scale in order to have a larger vision 
of the trend.

If you place the mouse cursor on a point of the trend, a tooltip appears displaying 
the exact value at that point. Stay pressed and rollover several points to display the 
tooltips of all of those points.

Releasing the mouse button and rolling over any point will cleanup existing tooltips 
and display a new one.

Right click on it to make it disappear.

Property Description Limits

Label Label of the link

Link Display Name Name of the graphic display to load when the user 
clicks on the link, or URL of a web page

Label Color Color of the label

Label Font Font used for the label
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The following table describes properties for the Datalogging History. Properties 
available for each pen are described in the next table:

Property Description Limits

Name The name for the graphic object

Background The background color for the graphic object

Label The label to be displayed as part of the graphic 
object

Label Color The color for the label

Label Font The font for the label

Major Scale 
Divisions

The number of major (labeled) scale divisions 0 to 100

Minor Scale 
Divisions

The number of minor (unlabeled) scale divisions 0 to 100

Scale Color The color for the scale and its labels

Scale Font The font for scale labels

Scale Precision The number of fractional digits to be shown for 
scale labels (Set to -1 to use a general 
exponential format.)

-1 to 6

Maximum EU 
Value

The maximum value, in engineering units, of the 
symbol (variable)

Minimum EU 
Value

The minimum value, in engineering units, of the 
symbol (variable)

Update Period The update interval (in seconds) for the chart 0.5 to 120

Time Scale 
Divisions

The number of horizontal scale divisions 0 to 6

Chart Background The color for the chart area

Grid Color The color of the grid drawn in the chart area

Vertical Grid 
Divisions

The number of vertical divisions for the grid 0 to 100

Border Width The width (in pixels) for the graphic object’s 
border

0 to 32

Border Color The color for the graphic object’s border
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These Datalogging History properties are available for each pen:

Property Description Limits

Name of the CSV 
file

The name of the CSV file used to build the trend.
Location:

Default (no path): the file is located on the 
FLASH memory.
/CFA00/USERDATA/TABLEx: the file is 
located on the CF card.
/USBHD/00/USERDATA/TABLEx: the file is 
located on the USB memory.
/RAMDISK/USERDATA/TABLEx: the file is 
located on the saved RAM.

Note: the log file must include timestamps 
(see Web Designer for TSX ETG 30••, User 
Manual).

Address The name of a symbol (variable) to monitor.

Data Type The data type of the symbol (variable).
Note: the data type must be numerical.

Maximum PLC 
Value

The maximum raw (unscaled) value of the symbol 
(variable) in the PLC.

Note 3 
(see page 134)

Minimum PLC 
Value

The minimum raw (unscaled) value of the symbol 
(variable) in the PLC.

Note 3 
(see page 134)

Pen Color The color of the "pen" used to record the scaled 
value.

Pen Label The label used to identify the pen.
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Extended Graphic Objects

Introduction

The extended graphic objects available in the Graphic Editor are designed to help 
you to create graphic displays imitating advanced graphic display panels. All the 
data control and monitoring objects have integrated communication functions and 
are designed as standalone graphic objects.

Be aware, however, that if communication to the device linked to the graphic object 
is lost, the object becomes inoperative without the end device's knowledge.

For example, say you have programmed a pushbutton object to jog a motor when 
the button is depressed and to stop jogging when the button is released. If 
communications are lost while the button is depressed, the motor will continue to jog 
even when the button is released. Graphic objects should not be used to control 
situations such as this unless other interlock methods are installed in the system.

In addition, to help clients who wish to insert several simple applets into a single 
HTML page, all objects in the Graphic Editor exist in the form of applets. When 
combined with the LiveBeanApplet, the graphic objects in the Graphic Editor can be 
used in the same way as the LiveLabelApplet.

ASCII Text Editor

The ASCII text editor is based on the message display graphic element. It enables 
new text to be entered.

The properties of the ASCII text editor are as follows:

WARNING
UNINTENDED EQUIPMENT OPERATION

Do not use graphic objects in situations where loss of communication to the 
module can affect human or material integrity. Graphic objects are not intended for 
use in critical machine functions.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Max. Text Length Maximum length of the text

Text Color Color of the text
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Bar Graph

A bar graph gives an analog representation of the value of a variable in a device. It 
draws a vertical bar whose length is proportional to the value and represents a 
percentage of its range in physical units.

The properties of the bar graph are as follows:

Text Font Font of the text

Swap Bytes False if the target byte order is the same as that of 
the PC

Value The text itself

Property Description Limits

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Maximum EU 
Value

Maximum value of the variable in physical units

Minimum EU 
Value

Minimum value of the variable in physical units

Maximum Value Maximum gross value (without scale) of the 
device variable

Note 3 
(see page 134)

Minimum Value Minimum gross value (without scale) of the 
variable in the device

Note 3 
(see page 134)

Bar Background Background color of the indicator bar

Bar Color Color of the indicator bar (if the scale value is 
within the High/Low range)

High High Limit 
Value

Value of the "High High" limit expressed in 
physical units

High High Limit 
Color

Color of the indicator bar if the scale value is 
greater than the "High High" limit

High Limit Value Value of the "High" limit expressed in physical 
units
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Bitmap

The bitmap interface graphic element displays a static bitmap on the screen.

The properties of the bitmap interface graphic element are as follows:

High Limit Color Color of the indicator bar if the scale value is 
greater than the "High" limit.

Low Limit Value Value of the "Low" limit expressed in physical 
units

Low Limit Color Color of the indicator bar if the scale value is less 
than the "Low" limit

Low Low Limit 
Value

Value of the "Low Low" limit expressed in physical 
units

Low Low Limit 
Color

Color of the indicator bar if the scale value is less 
than the "Low Low" limit

Limit Deadband Neutral range (as a percentage of the EU range) 
to apply to verification of the High/Low limit

0 to 10

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated gross input value (without scale) for 
testing the graphic object

Note 3 
(see page 134)

Property Description Limits

Property Description Limits

Name Name of the graphic object

Background Graphic object background color Note 1 
(see page 134)

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Border Width Width (in pixels) of the graphic object border

Border Color Color of the graphic object border

Bitmap Choices File names of custom bitmaps to display
Refer to the next paragrah for information on 
adding images into the module.
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Adding Images

You can add images into the module in one of the following way:
Add your images into the images.zip file (path: /NAND/FLASH1/wwwroot).
Create a directory into the module (i.e. /NAND/FLASH1/wwwroot/bitmaps). Copy 
your images into this directory. In this case, you need to specify the path of the 
images you want to use (i.e. /NAND/FLASH1/wwwroot/bitmaps/key.gif).

Generic Bitmap

The generic Bitmap interface graphic element can display a static bitmap for each 
separate value of a variable. It can be used to display dynamic animations, such as 
the variation in level of a reservoir.

The properties of the generic Bitmap interface graphic element are as follows:

Step Action

1 Create an images folder on your PC.

2 Copy the images you want to use in this folder.

3 Import the user.jar file from the TSX ETG 30•• to the PC (path: 
/NAND/FLASH1/wwwroot/classes) using a FTP client.

4 Open the user.jar file using a file archiver.

5 Drag and drop the images folder in the user.jar file. Make sure the relative path 
of the image files is ‘images/’.

6 Transfer the user.jar file back to the module using a FTP client.

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color Note 1 
(see page 134)

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Bitmap Choices File names of custom bitmaps to display
Refer to the previous paragrah for information on 
adding images into the module.
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Graphic Link

A graphic link is a special graphic object that moves to another graphic display when 
you click it with the mouse. Graphic links can also be recognized by their underlined 
labels, and by the fact that the mouse cursor changes to a hand when it passes over 
them. They are especially useful when the Graphic Editor is used in Display mode, 
in which there is no pull-down list of graphic displays.

A graphic link can also be used as a hypertext link to an HTML file. If you enter a 
URL such as Link Display Name, you can open the URL in a new browser window 
by pressing the SHIFT key while clicking on the link. If you only click the link, the URL 
will open in the existing browser window.

If the Link Display Name is not filled in, the label will not be underlined and the 
object displayed becomes a simple text label.

The properties of the graphic link are as follows:

Border Width Width (in pixels) of the graphic object border

Border Color Color of the graphic object border

Value Simulated starting value for testing the behavior of 
the graphic object

Property Description Limits

Property Description Limits

Label Label of the link

Link Display Name Name of the graphic display to load when the user 
clicks on the link, or URL of a Web page

Label Color Color of the label

Label Font Font used for the label

Bitmap Choices Name of the bitmap file to be clicked on
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Indicator Light

The indicator light displays the value of a variable in a device. The input value of 0 
is equal to OFF, and any value other than 0 is equal to ON. If the Flash Interval 
property is set to a positive value, the indicator light will flash when the input value 
is equal to ON. There is one bitmap for the ON state and another for the OFF state.

The properties of the indicator light are as follows:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 3 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

OFF Word Text to be displayed when the input value is OFF

OFF Bitmap 
Choice

Indicator bitmap when the OFF word is displayed

OFF Word Color Color of the OFF word text

OFF Word Font Font of the OFF word text

ON Word Text to be displayed when the input value is ON

ON Bitmap Choice Indicator bitmap when the ON word is displayed

ON Word Color Color of the ON word font

ON Word Font Font of the ON word text

Flash Interval The flashing time for the indicator light (expressed 
in milliseconds) when the input value is ON. Set to 
0 for no flashing.

200 to 2,000

Input Inverted On TRUE, inverts the input value. (The indicator 
displays the OFF word when the input value is 
ON.)

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated input value for testing the graphic 
object

Note 3 
(see page 134)
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Motor

The Motor graphic interface element displays the value of a variable in a device. The 
input value of 0 is equal to OFF, the value 1 is equal to ON and other values are 
equal to DEFAULT. These three states are represented by different bitmaps.

The properties of the Motor graphic interface element are as follows:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

OFF Word Text to be displayed when the input value is OFF

OFF Bitmap 
Choice

Motor bitmap when the OFF word is displayed

OFF Word Color Color of the OFF word text

OFF Word Font Font of the OFF word text

ON Word Text to be displayed when the input value is ON

ON Bitmap Choice Motor bitmap when the ON word is displayed

ON Word Color Color of the ON word font

ON Word Font Font of the ON word text

DEFAULT Word Text to be displayed when the input value is ON

DEFAULT Bitmap 
Choice

Motor bitmap when the DEFAULT word is 
displayed

DEFAULT Word 
Color

Color of the DEFAULT word font

DEFAULT Word 
Font

Font of the DEFAULT word text

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated input value for testing the graphic 
object

Note 3 
(see page 134)
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Pipe

A pipe displays the value of a variable in a device that has two possible states. The 
input value of 0 is equal to OFF, and any value other than 0 is equal to ON. There is 
one bitmap for the ON state and another for the OFF state.

The properties of the pipe are as follows:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

OFF Word Text to be displayed when the input value is OFF

OFF Bitmap 
Choice

Pipe bitmap when the OFF word is displayed

OFF Word Color Color of the OFF word text

OFF Word Font Font of the OFF word text

ON Word Text to be displayed when the input value is ON

ON Bitmap Choice Pipe bitmap when the ON word is displayed

ON Word Color Color of the ON word font

ON Word Font Font of the ON word text

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated input value for testing the graphic 
object

Note 3 
(see page 134)
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Push button

When activated with the mouse, a push button allows the user to send one or more 
preset values to a device.

The properties of the push button are as follows:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 3 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color

Values Values to send to the device Note 4 
(see page 134)

Reset Values Values to send to the device once the reset delay 
has expired. If no reset value is given, the reset 
will not take place.

Reset Delay Delay (in milliseconds) that the push button must 
comply with between sending the values to the 
device and sending the reset values.

0-2000

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

Button Label Button label text

Button Label 
Color

Color used for the button label

Button Label Font Font used for the button label

OFF Bitmap 
Choice

Button bitmap when the OFF state is displayed

ON Bitmap Choice Button bitmap when the ON state is displayed

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border
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Distributor

A distributor displays the value of a variable in a device that has two possible states. 
The input value of 0 is equal to OFF, and any value other than 0 is equal to ON. 
There is one bitmap for the ON state and another for the OFF state.

The properties of the distributor are as follows:

Property Description Limits

Name Name of the graphic object

Address Direct address of the variable to monitor Note 1 
(see page 134)

Data Type Variable data type Note 2 
(see page 134)

Background Graphic object background color 

Label Label to be displayed as part of the graphic object

Label Color Color of the label

Label Font Font used for the label

OFF Word Text to be displayed when the input value is OFF

OFF Bitmap 
Choice

Distributor bitmap when the OFF word is 
displayed

OFF Word Color Color of the OFF word text

OFF Word Font Font of the OFF word text

ON Word Text to be displayed when the input value is ON

ON Bitmap Choice Distributor bitmap when the ON word is displayed

ON Word Color Color of the ON word font

ON Word Font Font of the ON word text

Flash Interval The flashing time for the indicator light (expressed 
in milliseconds) when the input value is ON. Set to 
0 for no flashing.

200 to 2,000

Border Width Width (in pixels) of the graphic object border 0 to 32

Border Color Color of the graphic object border

Value Simulated input value for testing the graphic 
object

Note 3 
(see page 134)
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Notes

The notes relating to this section are as follows:

1. The Data Type property must correspond exactly to the actual data type of the 
variable.
If the Address property is the direct address of a binary PLC reference (reference 
0x/1x Quantum for example), the Data Type property must be set to Coil for outputs 
or Discrete Input for discrete inputs.

2. The various values of the Data Type property have the following meanings:

Type Signification

COIL output bit (Boolean)

DISCRETE INPUT input bit (Boolean)

REGISTER 16-bit signed integer

INT32 32-bit signed integer

INT32SWAP 32-bit signed integer with least significant and most significant 
words inverted

INPUT REGISTER 16-bit signed integer for analog input

3. The limits of the Maximum PLC Value and Minimum PLC Value properties are the 
natural limits of the configured Data Type property.

4. For a push button you must specify at least one value. If several values are entered, 
they will be assigned to an address table starting with the direct address indicated.

5. For the applet to display a numerical data value instead of a label, specify parameters 
in the HTML code as follows: name = "label" value = "$data$".
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7.3 Creating Custom Web Pages

Scope of this Section

This part shows you how to create custom Web pages for your website using 
FrontPage 2000 or Microsoft Expression web.

NOTE: For other ways to create custom pages, refer to the FactoryCast HMI 
Gateway TSX ETG 30•• Product Range user manual.

What's in this Section?

This section contains the following topics:

Topic Page

Installing FactoryCast Extension for Microsoft FrontPage 136

Installing FactoryCast Extension for Microsoft Expression Web 141

Inserting a LiveBeanApplet with FrontPage or Expression Web 143

Inserting a LiveLabelApplet with FrontPage or Expression Web 151

Internet Explorer 7 compatibility 157
35016149 02/2010 135

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Monitoring
Installing FactoryCast Extension for Microsoft FrontPage

Overview

This section describes how to install/remove the FactoryCast Extension for 
Microsoft FrontPage 2000.

Installing FactoryCast

During the installation of Web Designer, if FrontPage 2000 has been installed on the 
same PC, then the FactoryCast Extension for FrontPage 2000 is automatically 
installed as a FrontPage "Macro File". If this is the case, then proceed to the next 
section, which provides instructions for adding the Extension to FrontPage's menu.

However, if FrontPage 2000 is installed after Web Designer has been installed, then 
the Extension can be installed by either re-installing Web Designer or manually 
copying the macro file to FrontPage's macro folder. For manual installation, after 
installing FrontPage 2000, the following will install the Extension:

Copy the file Microsoft FrontPage.fpm from CD-ROM to the folder 
%USERPROFILE%\Application Data\Microsoft\FrontPage\Macros (create the final 
'Macros' folder, if it does not already exist).
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Adding FactoryCast Extension

To add the FactoryCast Extension to the FrontPage Insert menu, do the following. 

Step Action

1 Start FrontPage 2000.

2 Click Customize on the Tools menu.

3 Click the Commands tab, and then select Macros from the Categories list.
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4 Drag and drop the entry Custom Menu Item from the Commands list to the 
Insert menu, beneath the Advanced command. (The Insert menu will 
automatically drop down when you drag over it.)

5 Click Modify Selection, change the name to FactoryCast Applet, and then 
press ENTER key.

Step Action
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6 Click Modify Selection again, and then choose Assign Macro.

7 Choose FactoryCast_Applet from the list, and then click OK.

8 Click Close.
The FactoryCast Applet command is added to the Insert menu.

Step Action
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Removing FactoryCast Extension

To remove the FactoryCast Extension from the FrontPage menu, do the following.

Editing Applets

There are two ways to edit an applet that has been inserted into your Web page. 
First, you can double-click on the object and make changes via dialog boxes. Or you 
can switch to the HTML editor in FrontPage and do your editing in this environment. 
It is suggested you edit via the first approach unless you are comfortable 
programming in the HTML language used to build Web pages. 

Step Action

1 In FrontPage, click Customize on the Tools menu.

2 Click the Insert menu, and then select FactoryCast Applet.

3 Right click, and then select Delete from the popup menu.
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Installing FactoryCast Extension for Microsoft Expression Web

Overview

This section describes how to install/remove the FactoryCast Extension for 
Microsoft Expression Web.

Installing FactoryCast

During the installation of Web Designer, if Expression Web has been installed on the 
same PC, then the FactoryCast Extension for Expression Web is automatically 
installed as a Expression Web "Macro File". If this is the case, then proceed to the 
next section, which provides instructions for adding the Extension to the menu of 
Expression Web.

However, if Expression Web is installed after Web Designer has been installed, then 
the Extension can be installed by either re-installing Web Designer or manually 
copying the macro file to the macro folder of Expression Web. For manual 
installation, after installing Microsoft Expression Web, the following will install the 
Extension:

Copy the file Microsoft Expression Web.wdmacro from CD-ROM to the folder 
%USERPROFILE%\Application Data\Microsoft\Expression\Web Designer\Macros 
(create the final 'Macros' folder, if it does not already exist).

Adding FactoryCast Extension

To add the FactoryCast Extension to the Expression Web Insert menu, do the 
following. 

Step Action

1 Start Microsoft Expression Web.

2 Click Customize on the Tools menu.

3 Click the Commands tab, and then select Macros from the Categories list.

4 Drag and drop the entry Custom Menu Item from the Commands list to the 
Insert menu, beneath the Advanced command. (The Insert menu will 
automatically drop down when you drag over it.)

5 Click Modify Selection, change the name to FactoryCast Applet, and then 
press ENTER key.

6 Click Modify Selection again, and then choose Assign Macro.

7 Choose FactoryCast_Applet from the list, and then click OK.

8 Click Close.
The FactoryCast Applet command is added to the Insert menu.
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Removing FactoryCast Extension

To remove the FactoryCast Extension from the Expression Web menu, do the 
following.

Editing Applets

There are two ways to edit an applet that has been inserted into your Web page. 
First, you can double-click on the object and make changes via dialog boxes. Or you 
can switch to the HTML editor in Expression Web and do your editing in this 
environment. It is suggested you edit via the first approach unless you are 
comfortable programming in the HTML language used to build Web pages. 

Step Action

1 In Expression Web, click Customize on the Tools menu.

2 Click the Insert menu, and then select FactoryCast Applet.

3 Right click, and then select Delete from the popup menu.
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Inserting a LiveBeanApplet with FrontPage or Expression Web

Overview

The LiveBeanApplet applet is included one time for each symbol (variable) or direct 
address monitored/controlled on the Web page. For instance, if you are monitoring 
three symbols (variables), you would include the applet three times. LiveBeanApplet 
allows any graphic object/Java Bean that was created with the Graphic Editor to be 
included on a Web page as a separate applet.

.Any graphic object that has been saved as part of a Graphic Editor graphic display 
can be retrieved from the graphic file and presented by the applet.Before any beans 
are inserted into a Web page, the special applet called LiveBeanMgrApplet must be 
inserted into the server.

NOTE: Prior to inserting a LiveBeanApplet into a Web page, you must create a 
JavaBeans library using the Graphic Editor. Generally a user will create a 
JavaBeans library that has one instance of every object that they would like to use 
in a Web page. Think of this library as a set of templates that are copied to and 
customized for your Web pages. For example a library may have one analog meter, 
one rotary selector, and one push button. Multiple instances of each bean can then 
be added to a Web page, each with a set of unique parameters such as an address.

LiveBeanMgrApplet

The LiveBeanMgrApplet allows the Web page to display dynamic data from the 
controller. This applet must be included once on the page if any instances of 
LiveBeanApplet are included in the page.

The LiveBeanMgrApplet can be included on a Web page in two possible forms:
Invisible applet—if the Web page is used only to monitor PLC values, then no 
input is needed from the user
Icon of a key—if the Web page is used both to send new values and to monitor 
values to the PLC, then input is needed from the user in order to send new values.
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Inserting a LiveBeanApplet

To insert a LiveBeanApplet, follow the steps below:

Step Action

1 In FrontPage or Expression Web, select Tools → Macros → Macros.

2 Select the macro that corresponds to the target.

3 Click Run.

4 Select the LiveBeanMgrApplet, then click OK. 

Note: The LiveBeanMgrApplet is a special applet, which should only be inserted 
into your Web page once.
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5 Configure the Mode and Auto-Login parameters, then click OK.

6 A window opens, showing the Java code which will be inserted in your HTML 
document.

Click Insert to complete insertion of this applet.
Note: Although a gray box containing a blue letter "J" appears on your Web page 
while editing, the applet will only be displayed on your downloaded Web page if 
you have set the Mode parameter to ReadWrite. (Read/Write). It will appear in 
the form of a key when you visualize it with your browser. On the other hand, if 
the ReadOnly Mode is set (ReadOnly), the width and height of the applet will be 
set to 0 and will not be visible in your browser. To find out more about the 
operation of the Mode parameter, refer to the FactoryCast HMI Setup Manual.

Step Action
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7 Select the LiveBeanApplet in the Target applet selection window, then click OK.

8 Enter the name of a library and the name of the "bean" you wish to display in it. 
If you do not need to customize the bean properties (the address, for example), 
click OK.

Step Action
146 35016149 02/2010

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Monitoring
9 In general, you will at least need to customize the Address property of your 
beans. Once you have entered the names of the library and bean, select the 
object type in the Object Type dialog box.

Click Edit when you have finished.

10 In the Edit window, only change parameters that are specific to this bean, such 
as the address. All other parameters will be set to the same values as for the 
bean saved in your library. Click OK when you have finished.

Step Action
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11 Click OK. A window opens, showing the Java code which will be inserted in your 
HTML document. Click Insert to complete the insertion of the applet.

12 Continue inserting instances of LiveBeanApplet in your Web page. Once you 
have inserted the last applet, click Cancel in the Web Designer applet selection 
window to return to editing your Web page.

Step Action
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13 Save your custom Web page.

14 Transfer the custom Web page to the Web server.

15 Test the application.

Step Action
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LiveBeanApplet Parameters

The LiveBeanApplet uses parameters that allow you to specify the graphic object to 
be presented by the applet and to set the applet’s background color.

The applet’s parameters and their meanings are shown below.

In addition to the above parameters, the <APPLET> tag for a LiveBeanApplet must 
include width and height attributes. Normally, the size of a LiveBeanApplet is set to 
match the size of the graphic object that it is presenting. To get the size of a graphic 
object, select the object while the Graphic Editor is in editing mode. The selected 
object’s name and size are shown in the Information Area at the top of the Graphic 
Editor applet.

Parameter... Defines...

LIBRARY The name of the graphic display which contains the graphic object that is 
to be presented by the applet (This will be the same name that was used 
when the graphic display was saved with the Graphic Editor).
This parameter is required.

BEAN The name of the graphic object that is to be retrieved from the graphic 
display specified by the LIBRARY parameter (This will be the name that 
appears as the ‘Name’ property of the graphic object).
This parameter is required.

BACKGRND The background color for the applet.
Acceptable values are WHITE, LT_GRAY, GRAY, DK_GRAY, BLACK, 
RED, PINK, ORANGE, YELLOW, GREEN, MAGENTA, CYAN, and 
BLUE.
Also, a RGB color value can be entered using the format "0xRRGGBB" 
where RR, GG, and BB are the hexadecimal values for the red, green, 
and blue components, respectively.
This parameter is optional but is normally set to match the color of the 
HTML page.
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Inserting a LiveLabelApplet with FrontPage or Expression Web

Overview

Use one LiveLabelApplet applet for every symbol (variable) or direct-address 
monitored on the Web page used. For example, if you are monitoring three symbols 
(variables), you would include the applet three times.

Before any live labels are inserted into a Web page, the special applet called 
LiveLabelMgrApplet must be inserted into the page.The LiveLabelMgrApplet allows 
the Web page to display dynamic data from the controller. This applet must be 
included once on the page if any instances of LiveLabelApplet are included on the 
page.

NOTE: However, if a Web page contains both LiveLabelApplet and LiveBeanApplet, 
then that page must contain a single instance of LiveBeanMgrApplet, not 
LiveLabelMgrApplet. LiveBeanMgrApplet supports both LiveLabelApplet and 
LiveBeanApplet, while LiveLabelMgrApplet supports only LiveLabelApplet.)

Inserting a LiveLabelApplet

To insert a LiveLabelApplet, follow the steps below:

Step Action

1 In FrontPage or Expression Web, select Tools → Macros → Macros.

2 Select the macro that corresponds to the target.

3 Click Run.

4 Select the LiveLabelMgrApplet associated with your target, then click OK.

Note: LiveLabelMgrApplet is a special applet, which should only be inserted into 
your Web page once. Although a gray box containing a blue letter "J" appears 
on your Web page while editing, the applet will not be displayed on the Web page 
from the built-in server module.
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5 Select the LiveLabelApplet, then click OK. The Parameter editing window is 
displayed.

6 Enter the label parameters, then click OK.

Note:  For a description on each parameter, see the next paragraph.

Step Action
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7 A window opens containing the HTML code that will be inserted into your HTML 
document. Click Insert to complete the insertion of the applet.

8 Continue to add additional instances of LiveLabelApplet to your Web page. Once 
the last applet has been inserted, click Cancel in the applet selection window to 
return to editing your Web page.

Step Action
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LiveLabelApplet Parameters

The applet’s parameters, their meaning, and the default values are shown below:

Parameter... Defines... With Default Value 
of...

LABEL A text label to identify the data item. No label

UNITS A text label to identify the value’s engineering units. No units displayed

ADDRESS The name of  Concept/PL7/Unity Pro symbol 
(variable) or Quantum/Premium/Micro direct 
address.

None

DATATYPE The data type of the symbol (variable) or direct 
address.
Acceptable values for this parameter are:

UNDEFINED

UNDEFINED No data type specified

SHORT 8-bit signed integer

USHORT 8-bit unsigned integer

INT 16-bit signed integer

UINT 16-bit unsigned integer

DINT 32-bit signed integer

UDINT 32-bit unsigned integer

REAL 32-bit IEEE floating point

TIME 32-bit unsigned integer (in ms)

BOOL 1-bit discrete (boolean)

NOTES: If the ADDRESS parameter is a direct 
address, and the DATATYPE parameter is not 
specified, a default DATATYPE (BOOL ,INT,DINT or 
REAL based on the implied size of the data value) is 
used. 
If ADDRESS is a direct address for a discrete PLC 
reference (Quantum 0x/1x reference), DATATYPE 
must be set to BOOL. DATATYPE may be set to 
BOOL only for discrete PLC references. 
If the ADDRESS parameter is the name of a 
Concept, PL7 or Unity Pro symbol (variable), the 
DATATYPE parameter is optional. If the DATATYPE 
is specified for a symbol (variable), it must exactly 
match its actual data type,TIME is not a valid data 
type for PL7 Premium.
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FORMAT The display format for the value.
Acceptable values for this parameter are:

DEC for most data 
types
TIME for data type 
TIME
BOOL for data type 
BOOL

DEC decimal

HEX hexadecimal

BIN binary

ASCII bytes displayed as ASCII 
characters

TIME ‘day_hr_min_sec_ms’

BOOL ON_WORD or OFF_WORD (see 
below)

NOTE: If DATA TYPE is REAL, a FORMAT other 
than DEC will give unpredictable results if the value 
cannot be converted to an integer.

GAIN The gain (multiplier) used for scaling the retrieved 
value to engineering units.

1.0

NOTE: Scaling is to be performed only if GAIN or 
BIAS is set and FORMAT is DEC. 
Linear scaling is performed by the formula: 
SCALED_VALUE=GAINxRAW_VALUE+BIAS

BIAS The bias (offset) used for scaling the retrieved value 
to engineering units. See NOTE for GAIN.

0.0

ON_WORD A text value to be shown when value is non-zero
(Use only if the FORMAT is BOOL).

ON

OFF_WORD A text value to be shown when value is zero 
(Use only if the FORMAT is BOOL).

OFF

FOREGRND Foreground color of the applet.
Acceptable values are: WHITE, LT_GRAY, 
DK_GRAY, BLACK, RED, PINK, ORANGE, 
YELLOW, GREEN, MAGENTA, CYAN, and BLUE
Also, a RGB color value can be entered using the 
format "0xRRGGBB" where RR, GG, and BB are the 
hexadecimal values for the red, green, and blue 
components, respectively.

BLACK

BACKGRND Background color for the applet.
For acceptable values, see FOREGRND.

LT_GRAY

ERROR_ 
COLOR

Foreground color of the VALUE field when unable to 
retrieve the value from the PLC.
For acceptable values, see FOREGRND.

MAGENTA

Parameter... Defines... With Default Value 
of...
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LABEL_ 
ALIGN

Alignment of the text in the LABEL field, if the width 
of the field is greater than the length of the text.
Acceptable values are: LEFT, CENTER, and 
RIGHT.

LEFT

VALUE_ 
ALIGN

Alignment of the text in the VALUE field, if the width 
of the field is greater than the length of the text.
Acceptable values are: LEFT, CENTER, and 
RIGHT.

LEFT

UNITS_ 
ALIGN

Alignment of the text in the UNITS field, if the width 
of the field is greater than the length of the text.
Acceptable values are: LEFT, CENTER, and 
RIGHT.

LEFT

FONT_ 
NAME

Name of the font used by the applet.
Acceptable values are: SERIF, SANSSERIF, and 
MONOSPACE.

SANSSERIF

FONT_ 
BOLD

If set, displays all text in the applet as bold.
Acceptable values are: TRUE and FALSE.

FALSE

FONT_ 
ITALIC

If set, displays all text in the applet in italics.
Acceptable values are: TRUE and FALSE.

FALSE

FONT_SIZE Sets the point size of the font used by the applet. 12

LABEL_ 
WIDTH

The width of the LABEL field.

UNITS_ 
WIDTH

The width of the UNITS field.

Parameter... Defines... With Default Value 
of...
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Internet Explorer 7 compatibility

Presentation

Because of an Internet Explorer 7 limitation, it is recommended for this browser to 
manually insert the widgets in the pages using a Javascript provided on the CD-
ROM (Applets.js).
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7.4 PLC Program Viewer

PLC Program Viewer

Presentation

The PLC program viewer feature enables you to visualize and monitor UnityPro 
programs in run mode using a Web Designer. The PLC programs are displayed and 
animated as they are in UnityPro

PLC programs developed in any languages supported by UnityPro can be 
visualized:

Ladder (LD)
Instruction List (IL)
Function Block Diagram (FBD)
Structured Text (ST)
Sequential Function Chart (SFC)

Accessing the PLC Program Viewer

Step Action

1 Double click the PLC (Devices directory) you want to monitor in the 
Web Designer navigator.

2 Click the PLC Programs tab.
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Importing PLC Programs

The following procedure shows you how to import PLC programs from UnityPro to 
Web Designer.

Step Action

1 Click Import on the right side of the PLC Program window.
Result: the Open window appears.
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Accessing an Animated PLC Program

2 Select the UnityPro file (.XEF) containing PLC Programs data.
Click Open.
Result: the Import PLC Programs window appears.

3 Select the sections of the PLC program you want to monitor using the checkbox.
Click Browse to select the STU or .XVM file associated to the .XEF for variables 
animation.
Note: It is advised to import from .XVM for the import to be faster. As some 
elements are not available in the .XVM, a STU could be required to complete the 
import.

Click Import.
Result: the sections of the PLC program selected appear in the navigation tree of 
the PLC Program tab.

Step Action

Step Action

1 Select a target in a project.

2 Click Target → Connect → Simulation (Alt + S) to switch to simulation 
mode or,
click Target → Connect → Target (Alt + C) to switch to run mode.

3 Extend the target directory.
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Representation and Color Convention

The following figure shows you the PLC Program Viewer window:

1 Navigation tree: select the section of the PLC program you want to visualize
2 Display window: this zone display the animated PLC program

Variables animation:

Boolean are displayed in:
green if its value is true
red if its value is false

Other types display the name or the value of the variable in yellow. Use the tool 
tip to see more information as the name of the variable, its type, its address and 
its comment.

4 Select a device in the Devices directory.

5 Right-click and select Open.
Result: an Internet Explorer window in which the PLC program viewer window 
associated with the selected device appears.

5 Select the PLC program section you want to visualize in the navigation tree.
Result: the PLC program appears in the Display window.

Step Action
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Links animation:

Links connected to boolean variables are displayed in green or red depending on 
the value of the variable they are connected to (green if true red if false).
Other links are displayed in black.

SFC animation:

The colors used for the different elements are: 
for steps: 

green if the step is active,
white if the step is inactive,
yellow if the activity time of the step is less than the minimum programmed 
time,
pink if the activity time of the step is greater than the minimum programmed 
time.

for macro-steps:
when a macro-step becomes active the upper half is shown in green,
when the OUT step of the macro-step is active the whole of the macro-step is 
shown in green,
when the macro-step becomes inactive it is then shown in white.

for transitions associated with a Boolean element or a simple Boolean 
expression:

green if the element or the expression is TRUE,
red if the element or the expression is FALSE.

for transitions associated with a section:
black as long as the previous step remains inactive,
green if the conditions in the section are TRUE, 
red if the conditions in the section are FALSE.
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Tool Tip

The tool tip function is a help bubble which is displayed when you move the cursor 
over a variable. 

It displays information about the value of the variable only if its name is visible in the 
viewer.

Click on the variable to display the bubble permanently. Right click on it to make it 
disappear.

Limitations

Only PLC programs created using UnityPro 4.0 or later can be viewed.
You can only monitor PLC programs, edition is not allowed.
The following objects are not animated, they appear in black:

Objects for which the result depends on an expression
Function blocks without instance for which there is no information on 
input/output variables
Standard DFB (i.e. ALARM_DIA)
Multiple dimension tables
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Setting Up an External Tool
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Setting Up an External Tool
Setting Up an External Tool

Overview

This function enables you to setup an external tool that will be used by 
Web Designer. For example, you can setup FrontPage to edit the files of your 
website.

The following part shows you how setup FrontPage to open the files of the website, 
however the procedure is the same if you use another software. 
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Example

The following table shows how to set up a HTML editor. Here, hostname is used as 
an example:

Step Action

1 Click Options → Configuration of an external tool → External tools.
Result: the setup window for external tools appears.
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Setting Up an External Tool
2 Click New.
Result: the following window appears.

3 Enter a name for the external software (i.e. FrontPage).

4 In the Location area, click Browse File System.
Result: a file explorer opens.

5 Select the path of the .exe file of the external software (i.e. 
C:\windows\frontpage\frontpage.exe).

6 In the Working Directory area, click Browse File System.
Result: a file explorer opens.

7 Specify the directory that contains the files you want to open with your external 
tool (i.e. C:\workspace\WD_project\website.

Step Action
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Setting Up an External Tool
8 In the Arguments area, click Variables....
Result: the Select Variables window appears.

9 Select the ressource_loc variable that returns the absolute file system path of a 
resource.

10 Click Apply.

11 Click Close.

12 Select a file of the website in your Web Designer navigator.

13 Click Options → Configuration of an external tool → FrontPage. 
Result: FrontPage opens automatically the selected file.

Step Action
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Workspace
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Changing the Workspace 
Directory
Changing the workspace directory.

Presentation

The workspace is the space where projects are stored. Only those located in the 
current workspace are accessible when open. Projects are automatically created in 
the current workspace. It’s possible to have several workspaces and to pass from 
one to another.

This function enables you to change the path to the workspace.

To do this, select Change Workspace... in the Options menu.
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Formatting and Re-Starting a 
Module
Re-start/Format a Module

Introduction

Re-starting is necessary to take into account the modifications made to the 
application.

Formatting deletes the website on the module and restores the default website 
(Website, gdt and rdt directories). Formatting allows you to delete all the 
modifications made to the website of a module, in order to start a fresh one from a 
defined status. It does not modify the system configuration.

Re-start the Module

The following table shows how to re-start a module:

Step Action

1 In the menu tree, select a module.

2 In the Target menu, click Reboot target. 
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arr-thorp.com



Formatting and re-starting
Format the Module

The following table shows how to format a module:

Step Action

1 In the menu tree, select a module.

2 In the Target menu, click Format target. 
Result: the Configuration Password window appears if a configuration 
password has already been set. Otherwise the formatting starts.

3 Enter the configuration password and click OK.
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Security
Subject of this Chapter

This chapter explains how to manage the security for a website using firewall, 
access rights and password protection. 

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Internal Security 174

External Security 175

Variable Access Security, Symbol, Direct Address 177

Changing Passwords 178
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Internal Security

Overview

Web Designer provides 2 mechanisms to allow that only authorized users view and 
modify your data:

password entry,
write restrictions.

Anyone who has access to a configuration tool and to your embedded server can 
override your security settings and download new settings to the server. 
Unauthorized or incorrect changes to data may change the behavior of your 
application in ways that may be undesirable or even hazardous.

Password Entry

Although you may add unprotected Web pages to the site, the default Web pages 
and any other pages you choose to protect can only be viewed by users who supply 
the correct user name and password.

Restrictions 

Restrictions are applied overall.

When you create a website and you want to protect it, you must place it in the folder 
called secure.

WARNING
UNINTENDED OPERATION

Keep strict control of access to the embedded server:

Change passwords monthly,
Do not use simple user names and passwords,
Disable default passwords before commissioning the module.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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External Security

Overview

If your network has been configured to enable users to consult your Internet site, 
your security system is the same as that of an intranet site, only you have an 
additional security measure: a firewall.

Architecture of a Firewall

A firewall forms a gateway between Internet and your embedded server. You can 
use a firewall to restrict or forbid access to your website.

A firewall can be configured to authorize network connections to a limited range of 
ports, or to authorize traffic to or from certain IP addresses. 

Types of Firewalls

There are two types of firewalls:
Network firewalls
Application firewalls

Network Firewalls

Network firewalls are often installed between the Internet and a single entry point to 
an intranet or internal protected network.
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Application-Level Firewalls

An application firewall works for an application, for example FTP. It intercepts all 
traffic sent to this application, and decides whether or not to transmit this traffic to 
the application. Application firewalls are located on individual host computers.

Firewall Configuration

Web Designer uses HTTP, FTP and Schneider Electric Modbus application protocol 
(MBAP) to access embedded server pages and files. If you want viewers to be able 
to access your site from the Internet and your embedded server is protected by a 
firewall, you must configure the firewall to authorize HTTP, FTP and MBAP traffic.

NOTE:  

The default FTP name and password are USER/USER.
The FactoryCast client follows the "Firewall Friendly FTP" standard, RFC 1579. 
It issues an FTP PASV command to the FactoryCast server before any attempt 
to establish an FTP data connection.
The online mode of the configuration tool is not operational if the module is 
protected by a firewall. The ports in this mode are dynamically assigned.

Port Protocol Access to...

21 FTP Protected embedded server files

Higher than 1024

80 HTTP Web pages

502 MBAP Operational data
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Variable Access Security, Symbol, Direct Address

Presentation

Users who enter the write password can only modify variables (symbols) and direct 
addresses which are write-enabled. When you create a Web-enabled database of 
variables and direct addresses, you can designate each element as read-only or 
write-enabled.

Unauthorized or incorrect modifications made to symbols and direct addresses may 
have undesirable or even dangerous effects on the behavior of your application.

WARNING
UNINTENDED EQUIPMENT OPERATION

 Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Changing Passwords

Introduction

This page enables you to modify the different user names and passwords that are 
used for identification.

Modify Passwords

This table describes how to change passwords:

Step Action

1 In the browser, select the target.

2 In the Target menu, click Properties.
Result: the Target Properties window appears.

3 Select Security.
Result: the following window appears.
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Function

This table shows the fields in the various windows used to modify passwords:

4 Click Modify to change a password. Refer to next paragraph for a description of 
each passwords.
Result: the Password window appears.

5 Enter a new password and confirm it by typing it in the Confirm new password 
field.
If it's an HTTP password, the login is also requested.

6 Click OK in the Password window. 
Note: if you leave any fields empty during the modification, you will be asked to 
confirm the replacement of the current password by an empty password.

7 Repeat actions 4...6 for each password to modify.

8 Click OK in the Properties window of the target to close the window.

Step Action

Window Function

Secure HTTP 
Password

Required for connecting to the secure pages of the module website 
via a browser.

Write Password Required to write variables in animation mode.

Configurator 
Password

Required to access the configuration parameters of the module.

FTP Password Not available.
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Menu
Subject of this Chapter

This chapter describes the menus for Web Designer functions. 

What's in this Chapter?

This chapter contains the following topics:

Topic Page

Menu 184

Contextual Menu 186
183
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Menu

Overview

The following table shows the complete menu system when all functions are 
supported:

Menu Sub-menu Overview

Project New Create a new project:
Creating a new module/device/data table/graphic page.
Creating a service.
Creating files and folders.

Open project Open an existing project.

Close project Close current project.

Save Save item modified in the project.

Save all Save all items modified in the project.

Import Importing an existing (.zip) project or converting a 
FactoryCast or FactoryCast HMI project.

Export Exporting the current project to a .zip file.

Global transfer Downloading all the project's modules (and all the files).

Project Validation Verifying the project before transfer.

Refresh Updating the window and menu tree.

Properties View/modify the project’s properties (passwords, 
comments, etc.).

Quit Exit application

Edit Undo Cancel last action.

Cut Destruction of the selected object and putting it on the 
clipboard (the object can be a project, a module, a 
device, a graphic object, a file, a variable etc.).

Copy Copy the object to the clipboard.

Paste Paste the clipboard.

Delete Delete the selected object.

Find... Search for text in the project.
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Menu
Target Transfer Transfer all files, either from your PC to the destination, 
or from the destination to your PC.

Partial Transfer Transfer only graphic pages, data tables and service 
directories, either from your PC to the destination, or 
from the destination to your PC.

Connect Connecting to the module (if the module authorizes the 
connection) or to the simulator.

Disconnect Disconnecting from the module or from the simulator

Stop all services Shutting down all the services (for targets using 
services).

Start all services Starting all the services (for targets using services).

Site Explorer Display a view of the website in the window on the 
bottom.

Reboot target Rebooting the connected module (for modules that 
authorize).

Format target Formatting the connected module (for modules that 
authorize).

Set target address Display/modify the IP Address, user name and 
password of the target.

Synchronize with 
PLC database

Synchronize the namespace of your project with a PLC 
database. Not available for FactoryCast targets.

Properties View/modify the target’s properties.

Service Stop Shut down current service.

Run Start current service.

Operator screens View operator screens.

Print Print current service.

Statistics View statistics for the selected service (incoming 
messages, outgoing messages, etc.).

Options Configuration of an 
external tool

Set up an external tool (for example FrontPage).

Change 
workspace...

Changing a workspace directory.

Default display Restoring the three-dimensional view of the work 
window by default.

Automatic input Fill in automatically the values of a new variable by 
incrementing the values of the last record.

Help Help Access to Web Designer Help file.

About Information about the version, copyright etc. of Web 
Designer .

Menu Sub-menu Overview
35016149 02/2010 185

This document provided by Barr-Thorp Electric Co., Inc.   800-473-9123    www.barr-thorp.com



Menu
Contextual Menu

Table

The following table shows the contextual menu of the file tree.

File tree item Menu (right-click) Sub-menu Comment

Project name New Project
Target

Launch the wizard. 1st window.

Edit

Paste Paste project.

Delete Destroy project.

Rename Rename project.

Global transfer Transfer project.

Properties View the project properties.

Module name New Device
Service

Launch the wizard. 2nd window.

Edit

Cut Cut module.

Copy Copy module.

Paste Paste module.

Delete Delete module.

Rename Rename module.

Transfer PC->Target
Target->PC

Transfer web site.

Connect Target
Simulation

Connect module.

Disconnect Disconnect module.

Properties View the module's properties.

Devices folder New device View the selection window of symbols.

Paste Paste device.
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Device element Edit Launch the device display window.

Cut Cut device.

Copy Copy device.

Delete Delete device.

Rename Rename device.

Run Start the service.

Stop Stop the service.

Partial transfer Target>PC Transfer only the folder.

GraphicScreens 
folder

New Graphic Page Launch Graphic Editor.

Paste Paste the graphic.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

GraphicScreens item Edit Graphic Editor.

Open View graphic.

Cut Cut the graphic.

Copy Copy the graphic.

Delete Delete graphic.

Rename Rename gaphic.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

DataTables folder New data Launch the data editor.

Paste Paste the data table.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

DataTables item Edit Data Editor.

Open Data Viewer.

Cut Cut the data table.

Copy Copy the data table.

Delete Delete the data table.

Rename Rename the data table.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

 Services folder New service Create a new service.

Paste Paste a service.

Partial transfer Target>PC 
PC->Target

Transfer only the folder. See note.

File tree item Menu (right-click) Sub-menu Comment
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Menu
A Services folder
calculation, email, 
database, data 
logging, active pages

New Launch the service wizard with the selected 
service.

Cut Cut a service.

Copy Copy a service.

Paste Paste a service.

Delete Delete a service.

Partial transfer Target>PC 
PC->Target

Transfer only the folder. See note.

Services item Edit Launch the edit window of the service.

Cut Cut the service.

Copy Copy the service.

Delete Delete the service.

Rename Rename the service.

Run Start the service.

Stop Stop the service.

Partial transfer PC->Target Transfer only the folder. See note.

Website folder New Folder
File

Create a new file or folder.

Paste Paste a new file or folder.

Import File Importing an existing website.

Partial transfer Target>PC
PC->Target

Transfer only the website. See note.

Folder in Website New Folder
File

Create a new file or folder.

Cut Cut the folder.

Copy Copy the folder.

Paste Paste a new file or folder.

Delete Delete the folder.

Rename Rename the folder.

Import File Importing an existing file.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

File tree item Menu (right-click) Sub-menu Comment
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Menu
File in WebSite Open Open the file.

Open with System 
Editor

Launch another window with System Editor.

Edit with Notepad Launch the HTML page in Edit mode with notepad.

FrontPage Launch the HTML page in Edit mode with 
FrontPage.

Cut Cut the file.

Copy Copy the file.

Delete Delete the file.

Rename Rename the file.

Partial transfer Target>PC
PC->Target

Transfer only the file.

Namespace Open Launch the Namespace window.

Namespace Write 
Access

Edit Launch the author rights Namespace window.

File tree item Menu (right-click) Sub-menu Comment
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Glossary
A

applet
Software component that runs in the context of another program, for example a Web 
browser.

ASCII
American Standard Code for Information Interchange.

Pronounced "aski". This is an American code (but now an international standard) 
which allows all alphanumerical characters used in English, punctuation marks, 
some graphics characters and various commands to be defined with 7 bits.

AT commands
Also called Hayes Commands: Set of commands for various phone-line 
manipulations, dialing and hanging up for instance.

B

bit
Contraction of Binary Digit.

This is the binary unit of information content, which can represent two separate 
values (or states): 0 or 1.

A field of 8 bits constitutes 1 byte.
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BOOTP
Bootstrap Protocol: Protocol for booting diskless terminals or stations by 
centralized management of network parameters.

C

CF card
CompactFlash card: Type of data storage device, used in portable electronic 
devices.

communication interruption
Communication error detected by the module when the periodic exchanges with the 
PLC stop.

configuration
The configuration comprises all the data that defines the device (invariable) and that 
is necessary to the operation of the module.

CPU
Central Processing Unit: The microprocessor. This comprises the entire control 
unit and the arithmetic unit. The purpose of the control unit is to extract the execution 
instruction from the central memory along with the data needed to execute this 
instruction, to establish electrical connections in the arithmetic and logic unit and to 
start the processing of this data in the unit. ROM or RAM memories are sometimes 
included on the same chip, and sometimes even I/O interfaces or buffers.

CRC
Cyclic Redundancy Check: Type of hash function used to produce a checksum – 
a small, fixed number of bits – against a block of data, such as a packet of network 
traffic or a block of a computer file.

D

DHCP
Dynamic Host Configuration Protocol: Protocol allowing a station connected to 
the network to obtain its configuration dynamically.
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DNS
Domain Name System: It stores and associates many types of information with 
domain names, but most importantly, it translates domain names (computer 
hostnames) to IP addresses.

driver
Program which informs the operating system of the presence and characteristics of 
a peripheral.

F

FactoryCast HMI
Active Web server that executes HMI functions integrated in a PLC module. The 
active Web server eliminates the need for communication via polling to update the 
HMI/SCADA database.

FDR
Faulty Device Replacement: Automatic configuration recovery service provided by 
the module. 

firewall
Information technology (IT) security device which is configured to permit, deny or 
proxy data connections set and configured by the organization's security policy.

Flash memory
Form of non-volatile computer memory that can be electrically erased and 
reprogrammed. 

FTP/TFTP
File Transfer Protocol/Trivial File Transfer Protocol: Network file transfer 
protocol.

G

GPRS
General Packet Radio Service: A radio technology for GSM networks that adds 
packet-switching protocols and shorter set-up time for ISP connections.
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H

HMI
Human Machine Interface: The aggregate of means by which people (the users) 
interact with a particular machine, device, computer program or other complex tool 
(the system).

HTML
HyperText Markup Language: the predominant markup language for the creation 
of web pages. It provides a means to describe the structure of text-based 
information in a document and to supplement that text with interactive forms, 
embedded images, and other objects.

HTTP
HyperText Transfer Protocol: Network transfer protocol for documents written in 
hypertext (links).

I

IP
Internet Protocol: Data-oriented protocol used for communicating data across a 
packet-switched internetwork (i.e. the Internet).

IP Address
Unique address that devices use in order to identify and communicate with each 
other on a computer network utilizing the Internet Protocol standard (IP)—in simpler 
terms, a computer address.

ISO
International Standards Organization. The ISO code is the most widely used. 
Formats, symbols, transmission rules are all covered by ISO standards. AFNOR is 
a member of ISO.

ISP
Internet Service Provider: Business or organization that sells to consumers access 
to the Internet and related services.
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M

MIB
Management Information Base: Database used by the SNMP protocol for network 
management and containing information on data transmission, station or router 
components, etc.

MIB II: standard MIB
Schneider Automation MIB: private MIB

N

NAT
Network Address Translation: is the translation of an Internet Protocol address (IP 
address) used within one network to a different IP address known within another 
network.

NTP
Network Time Protocol: Protocol for synchronizing the clocks of computer systems 
over packet-switched, variable-latency data networks.

O

operating mode
The rules governing the behavior of the module when it is running.

P

PAP
Password Authentication Protocol: Password identification protocol used for 
remote modem connections.

PL7
Schneider Automation PLC programming software.
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PLC
Programmable Logic Controller: It is a small computer used for automation of 
industrial processes, such as control of machinery on factory assembly lines.

PPP
Point-to-Point Protocol: Point-to-point communication protocol used for modem 
connections.

Premium
Family of Schneider Automation PLCs.

PSTN/RTC
Public Switched Telephone Network: The network of the world's public circuit-
switched telephone networks.

Q

Quantum
Family of Schneider Automation PLCs.

R

RGB
Additive model in which red, green, and blue (often used in additive light models) are 
combined in various ways to reproduce other colors.

RS232
Serial communication standard that in particular defines the following operating 
voltage:

A signal of +3 to +25V indicates a logic 0

A signal of -3V to -25V indicates a logic 1

Between +3V and -3V the signal is regarded as invalid.

RS 232 connections are relatively sensitive to interference. The standard 
recommends not exceeding a distance of 15 meters and a speed of 20,000 baud 
(bps) maximum.
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RS485
Serial connection standard operates at +/-5V differential. The connection uses 
separate wires for transmission and receipt. Their "3-status" outputs allow them to 
switch to listening mode when transmission is completed.

RUN
Function used to start execution of the application program in the PLC.

S

SCADA
Supervisory Control And Data Acquisition: Software that, interfacing with a 
programmable logic controller, gathers and analyzes information used to monitor 
and control commercial equipment.

SMTP
Simple Mail Transfer Protocol: Application protocol used to transmit messages via 
the Internet and direct them to a mailbox.

SNMP
Simple Network Management Protocol: Network management protocol for 
controlling a network remotely by polling the stations for their status and modifying 
their configuration, performing security tests and viewing information relating to data 
transmission. It can also be used to manage software and databases remotely.

SQL
Structured Query Language: Used to query (request data from) a relational 
database.

T

TCP
Transmission Control Protocol: Virtual circuit protocol that is one of the core 
protocols of the Internet protocol suite, often simply referred to as TCP/IP.
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TCP/IP
The set of communications protocols that implement the protocol stack on which the 
Internet and most commercial networks run.

Time Out
Expiry of a waiting time. Stops the application or disconnects after a lengthy period 
of non-use.

U

UDP
User Datagram Protocol: One of the core protocols of the Internet protocol suite. 
Using UDP, programs on networked computers can send short messages 
sometimes known as datagrams to one another.

URL
Uniform Resource Locator: The global address of documents and other resources 
on the World Wide Web.

V

VPN
Virtual Private Network: A private network that is configured within a public 
network. It uses encryption and other security mechanisms so that only authorized 
users can access the network and that the data cannot be intercepted.

X

XML
Extensible Markup Language: it is aimed to facilitate the sharing of data across 
different information system. It is a simplified subset of the SGML and is designed 
to be relatively human-legible.
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Index
A
automatic input, 73

D
Data Editor

spreadsheet, 81
symbol, 84
templates, 80
variable, 81, 84

data templates, 80
direct addresses, 86

E
example

see (getting started), 19
export, 47
Expression Web

LiveBeanApplet, 143
LiveLabelAppet, 151

external tool
configuration, 165

F
format target, 172
FrontPage

LiveBeanApplet, 143
LiveLabelAppet, 151
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Graphic Editor
applet parameters, 102
presentation, 89
properties sheet, 99
security, 101
toolbar, 91
user functions, 96

Graphic objects
extended, 124
presentation, 104

I
import, 47

synchronization, 72
installation, 14
introduction, 12
IP address, 50
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M
module

connecting/disconnecting, 58
FTP, 54
IP address, 50

N
namespace, 68

write access, 74

O
online documentation, 54

P
password, 178

configuration, 179
HTTP, 179
write, 179

PC configuration, 13
PLC program viewer, 158
presentation, 12
project

add devices, 42
add targets, 40
close, 46
device list, 43
global transfer, 54
open, 46
partial transfer, 54
remove devices, 43
remove items, 45
remove targets, 41
save, 46
target list, 41
transfer, 51
validation, 55

R
reboot target, 171
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access, 177
Security

access, 174
firewall, 175
passwords, 174

service
creation, 45

simulation, 62, 63
site explorer, 54
symbol

 name, 68
import from PLC, 70
manual selection, 73

synchronization, 72

T
transfer status, 56

V
variable

import from PLC, 70
manual selection, 73
name, 68
Unity Pro, 72

W
Web Designer

close, 46
Workspace directory, 169
write

password, 179
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