D

PolyLogic

Podium Data Analysis Software

User Manual

RCA40 Version

Issue 1.00
March 2003



D

PolyLogic

Contents

1 Introduction
1 What is Podium?

2 About This Manual

3 Typographical Conventions
4  Getting Technical Support
Getting Started

1 System Requirements

2 Installing Podium
.3 Uninstalling Podium

4 Using Online Help

5 Starting Podium

6 Selecting Data Logger

7  Licences

8  Exiting Podium

Getting to Know Podium

NN NN NN N

3

1

2 Main Menu

3 Main Toolbar

4  Lap Explorer

5  Cursor Values

.6 Notes

7  Circuit Map

8 Graphs

9 Reports

.10 Status Bar

.11 Resizing Windows

.12 Command Reference

4  Managing Session Data
Downloading Session Data
Importing Old Data

Changing the Beacon Position
Changing Session Details
Graphs
C

WWwwwwuwwwwwww

N N N

5
Setting the Current Lap
Adding Graphs
Removing Graphs
Setting the Reference Lap
Clearing the Reference Lap
Moving the Graph Cursor

ircuit Mapping
Creating a New Circuit Map
Map Segments

6.2.1  Adding Segments
6.2.2  Deleting Segments
6.2.3  Deleting All Segments
7  Reports
7.1 Min/Max Values Report

U1 U1 U1 U1 U1 U1

A
2
3
4
N
2
3
4
)
.6

6

A

2

[o) 3 o)}

Issue 1.00

Tour of the Podium User Interface

Page 2 of 43

Podium Data Analysis Software

User Manual

OO0 NNNONONUT U1 O

March 2003



@ Podium Data Analysis Software

PolyLogic User Manual
7.2  Speed Report 30
7.3 Split Report 30
7.4  Removing Reports 31
8 Configuration 32
8.1  Data Logger 32
8.1.1 Reading Current Configuration 32
8.1.2  General 32
8.1.3  Lap Timing 34
8.1.4  Display 35
8.1.5 Data Logging 36
8.1.6  Writing New Configuration 36
8.2  Show Setup For Session 37
8.3  Channels 37
8.3.1 User Channels 38
8.3.2  Filtering 38
8.4  Serial Port 40
8.5 Colours 40
8.5.1 Current Lap Graph 41
8.5.2  Reference Lap Graph 41
8.5.3  Circuit Map Outline 41
8.5.4  Circuit Map Segments 41
9 Troubleshooting 42
10 Glossary 43

Issue 1.00 Page 3 of 43 March 2003



D

PolyLogic

Table of Figures

Figure 1 -
Figure 2 -
Figure 3 -
Figure 4 -
Figure 5 -
Figure 6 -
Figure 7 -
Figure 8 -
Figure 9 -

Figure 10 -
- Graphs Window
Figure 12 -
Figure 13 -
Figure 14 -
- Session Data Download Dialog (Downloading)
Figure 16 -
Figure 17 -
Figure 18 -
Figure 19 -
Figure 20 -
- Edit Map Segments Dialog (No Segments)

Figure 11

Figure 15

Figure 21

Figure 22 -
Figure 23 -
Figure 24 -
- Edit Map Segments Dialog (Segment Deleted)
Figure 26 -
Figure 27 -
Figure 28 -
Figure 29 -
Figure 30 -
- Setup Data Logger (Data Logging Page)
Figure 32 -
Figure 33 -
Figure 34 -
Figure 35 -

Figure 25

Figure 31

Select Data Logger Dialog
Licence Details Dialog
Add Licence Dialog
Podium Main Screen
Podium Main Menu
Podium Main Toolbar

Lap Explorer Window
Cursor Values Window
Notes Window

Circuit Map Window

Reports Window
Podium Status Bar
Session Data Download Dialog (ldle)

Save Session Data Dialog
Open RCA40 Dump File Dialog
Edit Beacon Position Dialog
Edit Session Details Dialog
New Circuit Map Dialog

Edit Map Segments Dialog (Defining a Segment)
Edit Map Segments Dialog (Segment Defined)
Edit Map Segments Dialog (Deleting a Segment)

Edit Map Segments Dialog (Delete All Segments)
Configuration Download Dialog

Setup Data Logger Dialog (General Page)

Setup Data Logger (Lap Timing Page)

Setup Data Logger (Display Page)

Configuration Upload Dialog

Setup Channels Dialog (User Channel Page)
Setup Channels Dialog (Filtering Page)
Setup Serial Port Dialog

Figure 36 - Standard Colour Dialog

Issue 1.00

Page 4 of 43

Podium Data Analysis Software

User Manual

10
11
11
12
13
13
14
15
16
16
19
19
20
20
21
22
25
26
27
27
28
29
29
32
33
34
35
36
37
38
38
40
40

March 2003



@ Podium Data Analysis Software

PolyLogic User Manual

1 Introduction

1.1 What is Podium?

PolyLogic’s Podium Data Analysis Software enables data logged by the Farringdon
Instruments RCA40 lap timer to be downloaded to a host PC and analysed in a variety of
ways. Podium also provides facilities for configuring the lap timer via the serial port of
the host PC.

With PolyLogic’s Podium Data Analysis Software you can:

e Download and store data logged by the Farringdon Instruments RCA40
e Group related data together under common headings
e Display graphs of:

= Wheel speed

= Engine speed

= Two user channels

e Overlay and compare lap data from different sessions
e Create a track map for each circuit visited - using optional lateral accelerometer
e Define segments for each circuit map
e Produce reports of:
=  Minimum and maximum values logged for a lap
= Minimum and maximum speeds for each segment for a lap
= Split times for all laps in a session
e Configure the RCA40 via the serial port of the host PC
1.2 About This Manual

This User Manual is intended to complement the help files built into the Podium
application. The chapters are presented in an order intended to help new users
understand the program as quickly as possible. Be aware, however, that this manual and
the program’s help file assume that you are comfortable using the Microsoft Windows
98/2000/Me/NT4/XP operating system. If you are new to Windows you may find the
Windows Online Help file useful. To access Microsoft Windows Help choose Help from
the start menu on your Windows desktop.
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1.3 Typographical Conventions
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User Manual

Please be aware of the following typographical conventions when reading this manual:

e Menu items that you are instructed to choose appear with an arrow (») symbol
separating each menu level. For example, if you if you are instructed to choose
the Download command in the File menu it will appear as File » Download. If you
are instructed to select the Track command from the Map Colours sub-menu in
the Setup menu it will appear as Setup » Map Colours » Track.

e Where a button or other control needs to be clicked the name of the button or

control will be shown in bold text.

1.4 Getting Technical Support

For technical support with Podium please contact:

support@polylogic.co.uk

In addition, there are pages dedicated to support issues with PolyLogic’s products on the

PolyLogic web site.

The table below lists the ways to contact PolyLogic:

Contact Method Address or Number
Website: www.polylogic.co.uk
Telephone: +44 (0) 1462 621066
Fax: +44 (0) 1462 621066
Mail: PolyLogic Limited
21 Cambridge Road
Langford
Biggleswade
Bedfordshire
SG18 9PR
UK
Issue 1.00 Page 6 of 43 March 2003
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2 Getting Started

Podium is supplied on a CD-ROM. The CD-ROM also includes some sample data so you can
start exploring the software straightaway.

2.1 System Requirements

Before attempting to install Podium, make sure that your computer meets the following
minimum system requirements shown in the table below:

Component Requirement

Processor Pentium class processor or equivalent
Operating System | Microsoft Windows 98/Me/NT4/2000/XP
Hard Disk Space 10Mb

System Memory 32Mb (64Mb recommended)

Other Drives CD-ROM

Monitor/Display Super VGA (800 x 600) or higher resolution with 256 colours
Serial Port One serial port or USB port with USB-serial adapter
Pointing Device Microsoft Mouse or compatible pointing device

2.2 Installing Podium
Before you can run Podium you must install it on the hard disk of your computer.

Follow these steps to install the software:

e Switch on your computer and log on in the normal way.

Insert the Podium CD into the CD drive. The Podium Setup Wizard dialog will
appear automatically.

Click Next.

Choose the installation folder for the software and click Next.

Click Next again to complete the installation.

Click Close once the installation is complete.

The installation process places shortcuts to Podium on the computer’s desktop
and Start menu.

NOTE: If the Podium installation process does not start automatically, you can start it
manually by using My Computer or Windows Explorer to navigate to the contents of the
CD and then double-clicking the file SETUP.EXE.
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2.3 Uninstalling Podium

Podium can be removed from your computer by selecting the Add and Remove
Programs option within Windows Control Panel. Find Podium in the list of installed
software, select it, and then click Remove.

This will remove the Podium software together with its shortcuts and configuration
entries but all logged data, including the sample data provided on the installation CD,
will remain on the hard disk of the computer.

2.4 Using Online Help

Once Podium is running you can view items in the Help menu at any time. To display the
online Help file press F1 or choose Help » Topics.

2.5 Starting Podium

Start Podium by either double clicking the shortcut on the computer’s desktop or by
selecting Programs » PolyLogic » Podium from the Start button on the desktop’s
toolbar.

2.6 Selecting Data Logger

The first time that Podium is run, the Select Data Logger Dialog (Figure 1) is displayed.

Data Logger
* |ap Timer [RCA40]
™ Steering Wheel [SWI1510-3)

0K | Cancel

Figure 1 - Select Data Logger Dialog

Select the Lap Timer (RCA40) option and then click OK.
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2.7 Licences

A licence is require to access certain features within Podium such as downloading data
from the data logger.

To enter the licence code supplied do the following:

1. Select Help » Licences from the main menu, the Licence Details Dialog (Figure 2)
appears.

Podium Licences

Licence Code | Fermiszion | E=piry D ate | Add

B

Cloze

Figure 2 - Licence Details Dialog

2. Click Add to display the Add Licence Dialog (Figure 3), enter the licence code and
then click OK.

Add New Licence

Q. | Cancel |

Figure 3 - Add Licence Dialog

2.8 Exiting Podium

You can exit Podium using either of the following methods:
e Choose File » Exit from the main menu, or
e Click the close button [XI in the upper right corner of the title bar, or
e Press the key combination Ctrl + Q, or

e Press the key combination Alt + F4.
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3 Getting to Know Podium

This chapter provides an overview of the Podium user interface. It describes the main
windows, menu, toolbars and other important features. To help you better understand
the program and become familiar with its features, please review this chapter
thoroughly prior to analysing any data.

3.1 Tour of the Podium User Interface

When you start Podium the main program window appears. This window is your work
area and is divided up into sections where specific types of information are displayed.

The following screen shot shows the main program window during a typical session. The
Lap Explorer and Notes window are displayed on the right hand side with four overlay
graphs plotted on the left.

@5 Podium Q@g]
File Edit WYiew Map Setup Help
an = = o T - —
BLaehmnBEO B -5 ® 2 7
Distance Plok ] ap Explarer b
oy 140 B Z| e
1204
il e = Lap Explorer {6 circuits) ~
1004 W + Anglesey
Speed + Brands Hatch (Indy)
a0 + Rockingham {Sportscar)
= Silverstone {Mational)
607 . + ] natswi
40 | = EI natswza
o 9000 ] Lap 00102 10:58.93
a0004 Lap 00103 1:03.91
Lap 001/04 1:02,39
7000 Lap 001/05 1:02.52
50004 - Lap 00106 1:03.73
revs Lap 001/07 1:03.59
000 Lap 001j08 1:02.79
4000+ Lap 001/09 1:06.06
3000 | Lap 001/10 1:02,23*
£ A lannni il 107 20
5 10 Lap Expl fl Cursor Yalues
ap Explorer | 52
a0 & Lap Expl
60—
Userl | Session natswZa, Lap 00104 ﬂ
40
Tem | Yalug |
20 Gap to Fastest lap 0.16
0 L Yalues at beacon:
= RPM Lell-tale 0 rpm
c 2 Battery voltage 13.8 Yolts
Fuel level 100 %
19 i B Cil kemperature 28 °C
& ‘Water temperature 28 °C
o i) Oil pressure 255 psi
Lat.c At Thraottle position -353.0 %
! ; User channel 2 100 bits
_2_
T T T T T T T T T T T T
Distance 0 250 500 750 1000 1250 1500 1750 2000 2250 2500 2750
m| 2 Notes | 4| Circuit Map
W natswza Lap 002/04 1:05.49 W natswza Lap 002/06 1:05.81

Figure 4 - Podium Main Screen

At the top of the main program window a menu and toolbar provide access to a majority
of the program’s features.
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A status bar at the bottom of the screen identifies the laps for which data is currently

being displayed.
@ Podium
File Edit Yew Map Setup Help

Figure 5 - Podium Main Menu

3.2 Main Menu

The Main Menu (Figure 5), which is directly below the title bar, displays the menu
headings. Click a menu heading to open the menu and choose a command.

Use either of the following methods to choose a menu command:
e Open the menu and click the command, or

e Open the menu, use the Up arrow or Down arrow key to highlight a command, and
then press <Enter>.

In addition, each menu may be opened by pressing the <Alt> key and then pressing the
key associated with the required menu. Section 3.12 lists all the available menu
commands.

3.3 Main Toolbar
ey ZECcOE-2- B 202
Figure 6 - Podium Main Toolbar

The Main Toolbar (Figure 6), which is located directly below the Main Menu, contains
buttons for accessing frequently used menu commands. To see the name of a button,
place the cursor over it without clicking.

To execute the command associated with a toolbar button click the button. If a button is
greyed out the command is not available. Section 3.12 lists the function of each of the
toolbar buttons.
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3.4 Lap Explorer

The Lap Explorer window (Figure 7) displays the

Elﬂ( © : available data in a ‘tree’ or hierarchical manner.
=15 Lap Explorer (6 circuits . . .
C ey This window is used to select the laps to be analysed.
+ ranads FAacc nady,
: §;\j§g§:;§;g§j;ﬂ Nodes are displayed for each circuit and session for
= [ natsw which data exists. To expand a node either click on the
Lap 00102 1:27.93 . y s
Lap 00Lj03 1123.77 +| next to the node or double click the node’s icon or
Lap 00104 1:23.54 *
+ EI natswza teXt-
+ Snetterton .
: gmumn Once a node has been expanded it can be collapsed by

either clicking on the [=I next to the node or double
clicking the node’s icon or text again.

Lap Explorer :l Cursor Yalues
Figure 7 - Lap Explorer Window

If the Lap Explorer window is not currently visible it can be activated in any of the
following methods:

e Click the Lap Explorer tab next to the Cursor Values tab, or
e Click the Lap Explorer button “Z# on the main toolbar, or
e Choose View » Lap Explorer from the main menu.

The content of the toolbar below the window’s title bar changes depending on the type
of node that is currently highlighted as shown below:

Toolbar Highlighted Node
8| 2] & Root or circuit.
2] & Session.

]| [2] & | Lap.

To see the name of a button, place the cursor over it without clicking. To execute the
command associated with a toolbar button click the button. If a button is greyed out the
command is not available.

i3 Downloads data from data logger.

Makes the highlighted lap the Reference Lap.
Removes the Reference Lap.

B Makes the highlighted lap the Current Lap.

7] Refreshes the contents of the Lap Explorer window.
@ Makes the Notes window visible.
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3.5 Cursor Values

The Cursor Values window (Figure 8) displays the value
= Reforencs | Current of each graph at the current cursor position.
Distance 596 m 596 m o . o .
Wheelpocd  117.6mph 1169 meh This window is used to compare parameters at any point
Lateral G 023G 021G
Longitudinal G 099G 045G on a lap
Thrqttle posit... 83.3% 50,0 %
Engnospoed | 7183rpm 7048 fom The values change as the graph or map cursor are
moved.
Time and distance are always displayed with other
parameters being added when a graph for that
parameter is selected.
Removing a graph removes that parameter from the list
@ oppoe [ cursarvaues | of parameters displayed in the Cursor Values window.

Figure 8 - Cursor Values Window

If the Cursor Values window is not currently visible it can be activated in any of the
following methods:

e Click the Cursor Values tab next to the Lap Explorer tab, or
e Click the Cursor Values button =3 on the main toolbar, or

e Choose View » Cursor Values from the main menu.

3.6 Notes
The Notes window (Figure 9) displays additional
session naksuzs =l information about the item currently highlighted in the
SIt:s:m t:!ate :\?:;esday, 30 October 2002 | Lap Explorer W.Indow'
FNT This window is used in conjunction with the Lap Explorer
b window to identify the laps to be analysed.
RPM tell-tale 8561 rpm
Db bnsinth The list of information displayed depends on the type of
Tk D node highlighted in the Lap Explorer node.

S+ Motes E‘ Circuit Map

Figure 9 - Notes Window

If the Notes window is not currently visible it can be activated in any of the following
methods:

e Click the Notes tab next to the Circuit Map tab, or
e Click the Notes button "~ on the main toolbar, or

e Choose View » Notes from the main menu.
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3.7 Circuit Map
The Circuit Map window (Figure 10) displays a map of
]| - the circuit for the Current Lap.
b "\i This window is used in conjunction with the Graphs
: window to relate the graph cursor position to a specific
Q point on the lap.

Clicking on the map moves the map cursor to the point
on the track closest to the mouse click. This also moves
j the graph cursor to the same point.

‘o Motes 3] Circuit Map
Figure 10 - Circuit Map Window

If the Circuit Map window is not currently visible it can be activated in any of the
following methods:

e Click the Circuit Map tab next to the Notes tab, or
e Click the Circuit Map button I on the main toolbar, or
e Choose View » Circuit Map from the main menu.

The buttons on the toolbar immediately below the title bar are enabled whenever a map
is displayed and they perform the following:

sl Shows/hides segments.
) Allows the segments for the current circuit map to be edited.

To see the name of a button, place the cursor over it without clicking. To execute the
command associated with a toolbar button click the button. If a button is greyed out the
command is not available.
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3.8 Graphs

Distanoe Mot |

ah 1407
120"y, ) _’_,,:_.---L;'- P . § -

1m0 b 5, Ay =
3 - =
Spead o ._\-L — ,-"’ '.‘ /

— l{l_ p 15‘1«. A _.-""
50 N e \v;‘f

40 |

mm > A A
8000 A | A A A A ru L
Tw. . S EYST R S :|l/f ?L.—-’w?‘. 1 Vi ff’r
. Jh

7000 =

T T T T T T T T T T T T
Distance O 250 500 7S50 1000 1250 1500 1750 2000 2250 2500 2750
m

Figure 11 - Graphs Window

The Graphs window (Figure 11) displays logged values for a lap against either distance or
time. This window is used to plot data for the laps of interest and to compare two laps
from the same or different sessions.

Clicking on a graph moves the graph cursor to that point on the graph. This also moves
the map cursor to the same point. The values of the displayed parameters at the current
cursor position are displayed in the Cursor Values window.

Once a lap has been highlighted in the Lap Explorer window a graph of any of the logged
parameters is displayed using either of the following methods:

e Activate the graphs drop down menu by clicking on the arrow w next to the
Graphs button 22 on the main toolbar and select the parameter to display, or

e Choose View » Graphs from the main menu and select the parameter required.
Clicking the Graphs button 2 on either the main toolbar or the Lap Explorer toolbar will

either display the current graphs for the highlighted lap or display a graph of wheel
speed against distance for the highlighted lap if no graphs are currently displayed.

Issue 1.00 Page 15 of 43 March 2003



@ Podium Data Analysis Software

PolyLogic User Manual

3.9 Reports

Item | Current Minimurn | Reference Minimum | Delka Minimumm | Current Maximum | Reference Maximum | Delta Maximum |
wheel speed 50.2 mph 50.8 mph -0.6 mph 127.9mph 127.7 mph 0.2 mph
Engine speed 5013 rpm 5074 rpm -61 rpm 8351 rpm 8370 rpm -19rpm
Throttle position 33% 6.7 % -33 % 89.9 % 93,2 % -33%
User channel 2 74 bits 75 hits 3 bits 105 bits 104 bits 1 bits
EBattery voltage 13.6 Yalts 13.5 Valts 0.1 Yolts 13.9 Valts 13.9 Yals 0.0 Yalts
Fuel level 100 % 100 % 0% 100 % 100 % 0%
Lateral G -1.0% G -1.20G 0.10G 130G 130G 0.00G
Longitudinal G -1.74 G -1.83 G 0.09G 0,095 0,393 -0.30 G
il pressure 255 psi 255 psi 0 psi 255 psi 255 psi 0 psi
Oil kemperature 25 *C 28 % o= 280 28 °C o=
‘\Water ternperature 28 °C 28°C 0=C 28°C 28°C 0=C

Min/Max Yalues | Speed Report | Split Report ]

Figure 12 - Reports Window

The Reports window (Figure 12) displays tabular data for the currently selected laps or
session. This window is used to compare laps in more detail.

Once at least one graph is displayed in the Graphs window any of the available reports
can be selected using either of the following methods:

e Activate the reports drop down menu by clicking on the arrow « next to the
Reports button =¥ on the main toolbar and selecting the report to display, or

e Choose View » Reports from the main menu and select the report required.

3.10Status Bar

B natswza Lap 00104 1:02.39 B natswza Lap 001/07 1:03.59

Figure 13 - Podium Status Bar

The Status Bar (Figure 13) identifies the laps for which data is currently being displayed
together with the colours used.

3.11Resizing Windows

The relative proportions of the various windows can be altered to suit the data being
displayed.

To adjust the position of the line dividing two windows do the following:

1. Move the mouse over the space between the two windows until the mouse pointer
changes shape.

2. Drag the dividing line to the required position. The windows either side of the

dividing line will be redrawn to fill their new boundaries when the mouse button
is released.
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3.12Command Reference

The following commands are available:

Menu Command

File Menu
Download
Import Old Data
Export
Page Setup
Print Preview
Print
Exit

Edit Menu
Beacon Position
Session Details

View Menu
Zoom In
Zoom Out
Lap Explorer
Cursor Values
Notes
Circuit Map
Graphs
Reports
Histograms
X-Y Plots
Map Menu
New
Edit Segments

Issue 1.00

Keyboard Shortcut

Alt + F

Ctrl + P
Ctrl + Q

Alt + E

Alt +V
Ctrl + 1
Ctrl+ O

Alt + M

Page 17 of 43
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Toolbar Button Section
) 4.1
4.2
]
[&
&
2.6
4.3
4.4
®,
&,
3.4
H 3.5
& 3.6
i) 3.7& 6
&) 3.8&5
& 39&7
Al
E
6.1
e 6.2
(On Circuit Map
toolbar)
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Menu Command Keyboard Shortcut Toolbar Button Section

Setup Menu Alt +S
Data Logger - - 8.1
Show Setup For Session - - 8.2
Channels - - 8.3
Serial Port - - 8.4
Graph Colours - - 8.5
Map Colours - - 8.5

Help Menu Alt + H
Help Topics F1 =)

About PolyLogic Podium
Licences - - 2.7
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4 Managing Session Data

This chapter describes how Podium allows you to download and manage data logged by
the Farringdon Instruments RCA40 lap timer .

4.1 Downloading Session Data

Before any analysis can be performed, the logged data must be transferred from the
data logger to the hard disk of the host computer. This process, referred to as
downloading, is straightforward and is achieved in the following way:

1. Click the Download button *& on either the main toolbar or the Lap Explorer tool
bar, or select File » Download from the main menu. The Session Data Download
dialog (Figure 14) appears.

RCA40 Session Data Download E]
Connect PC to data

logger and click Ok ﬁ

Status
Ready

Figure 14 - Session Data Download Dialog (Idle)

2. Connect the data logger to the serial port of the host computer using the cable
provided and click OK. The process of transferring the data from the data logger
to the host computer will start.

RCA40 Session Data Download g]

Connect PC to data 4
logger and click OK

Stabuz
Fieading session data...

Figure 15 - Session Data Download Dialog (Downloading)

3. When the data has been successfully transferred the Save Session Data dialog
(Figure 16) appears. Podium will populate the Session field with a unique
identifier for this session based on the current date. Other fields will be set to the
values used previously.
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Sawve Session Data g|

Circuit: |Erands Hatch (Indy] ﬂ
Session; | 030206

Drriver: Jahn Smith
‘weather: ’m

Track: Dy -
Comment. [Debris ontrack
oo |

Figure 16 - Save Session Data Dialog

4. Update the fields to reflect the prevailing conditions and add a comment if
necessary. Note that the Driver, Weather, Track, and Comment fields are all
optional but the Circuit and Session fields determine where the data is stored so
cannot be left blank. If the current circuit is not listed then the name can be
typed in. The optional fields can be changed at a later date using the Edit »
Session Details option from the main menu. See Section 4.4 for more
information.

5. When all the required information has been entered click Save and the data will
be stored on the hard disk of the host computer.

6. The Save Session Data Dialog closes and the new session appears highlighted and
expanded in the Lap Explorer window.

4.2 Importing Old Data

To import data downloaded using the FIDAP application do the following:

1. Select File » Import Old Data from the main menu. The Open RCA40 Dump File
Dialog (Figure 17) appears.

Open RCA40 Dump File @@
Lok in: | (=) Oulton Park. j EF ,
-1 B practice_75epz002.dmp
E¢5) BYrace_75ep2002.dp
My Recent
D ocuments
=
Desktop
My Documents
—
8
by Computer
y " .
Wy Metwark, File name: - Open |
Flaces
Files of type: |F|CA4D Dumnp Files [*.dmp] ﬂ Cancel

Figure 17 - Open RCA40 Dump File Dialog
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2. Locate the dump file you wish to import, highlight it and then click Open.

3. The data in the chosen dump file is converted into the correct format and the
Save Session Data dialog (Figure 16) is displayed when this process is complete.

4. Update the fields in the Save Session Data Dialog as required and click Save to
store the imported data.

4.3 Changing the Beacon Position

When using a portable beacon it is not always possible to place the beacon at the same
location for each session at a particular track.

Podium provides a mechanism to move the position of the beacon on a session-by-session
basis so that all sessions for a track can have a common start point.

The beacon position for a session is changed in the following way:
1. Highlight the session (or any lap within the session) in the Lap Explorer window.

2. Select Edit » Beacon Position from the main menu. The Edit Beacon Position
dialog (Figure 18) appears.

Edit Beacon Position E

Session
Brands Hatch [Indy)
Tuesday, 04 February 2003
0302044

Beacon Position

Direction Offzet

(¥ Faorwards 0 3: m
(™ Backwards Reset

Save | Cancel |

Figure 18 - Edit Beacon Position Dialog

3. Enter the required beacon offset in m and indicate whether the beacon position is
to be moved forwards or backwards from its current point. Clicking Reset sets the
offset to zero.

4. Click Save to update the session. All laps in the session will now use the revised
beacon position. Click Cancel to leave the beacon offset unchanged.
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4.4 Changing Session Details
The details associated with a session may be changed in the following way:
1. Highlight the session (or any lap within the session) in the Lap Explorer window.

2. Select Edit » Session Details from the main menu. The Edit Session Details dialog
(Figure 19) appears.

Edit Session Details g|

Session
Brands Hatch [Indy)
Tuesday, 04 February 2003
0302044

Details

Driver:  |John Smith

Weather  |Sumny -

Track: Dy -

Comment; |Debris oh track

Save | Cancel |

Figure 19 - Edit Session Details Dialog
3. Enter the new details for the session.

4. Click Save to update the session or Cancel to leave the session details unchanged.
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5 Graphs

This chapter describes how graphs are produced from stored lap data and how graphs for
different laps can be compared.

Podium allows data to be plotted for up to two laps at any one time. One lap is
designated the Current Lap whilst the other is the Reference Lap. The Reference Lap is
typically the fastest lap for a particular session, driver, or circuit and is used as a
benchmark against which other laps completed at the same circuit are compared.

5.1 Setting the Current Lap
The Current Lap is set as follows:
1. Highlight the lap in the Lap Explorer window.
2. Click the Graphs button =] on the Lap Explorer toolbar.

3. A graph of wheel speed vs distance is plotted in the Graphs window and the
session and lap details for the new Current Lap are displayed in the status bar. If
a circuit map has been defined for this circuit then this will appear in the Circuit
Map window.

The colour of the graph lines for the Current Lap can be changed via the Setup option of
the main menu. See Section 8.5.1 for more information.

5.2 Adding Graphs
Further graphs are added by either of the following methods:

e Activate the graphs drop down menu by clicking on the arrow w next to the
Graphs button 22 on the main toolbar and select the graph to display, or

e Choose View » Graphs from the main menu and select the graph required.

5.3 Removing Graphs
Existing graphs are removed by either of the following methods:

e Activate the graphs drop down menu by clicking on the arrow « next to the
Graphs button 22 on the main toolbar and select the graph to remove, or

e Choose View » Graphs from the main menu and select the graph no longer
required.
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5.4 Setting the Reference Lap

The Reference Lap is set as follows:
1. Select a Current Lap and plot data for it as described in Section 5.1.
2. Highlight the lap to use as a Reference Lap in the Lap Explorer.
3. Click the Set Reference button © on the Lap Explorer toolbar.

4. A new line is added to each graph showing the data for the new Reference Lap.
The session and lap details of the new Reference Lap are displayed in the status
bar.

The colour of the graph lines for the Reference Lap can be changed via the Setup option
of the main menu. See Section 8.5.2 for more information.

5.5 Clearing the Reference Lap
The Reference Lap is cleared as follows:
1. Highlight any lap in the Lap Explorer window.
2. Click the Clear Reference button “ on the Lap Explorer toolbar.

3. The lines for the Reference Lap are removed from each graph in the Graphs
window and the details of the Reference Lap are removed from the status bar.

5.6 Moving the Graph Cursor

The graph cursor can be moved by clicking or dragging the mouse or by using the
following keys:

Action Result
- Moves the cursor one sample to the right.
« Moves the cursor one sample to the left.
Ctrl + » Moves the cursor 25 samples to the right.
Ctrl + « Moves the cursor 25 samples to the left.
Home Moves the cursor to the start of the graph.
End Moves the cursor to the end of the graph.

Note that the cursor can only be moved using the keyboard when the Graphs window has
the input focus, i.e. immediately after it has been clicked.
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6 Circuit Mapping

Podium allows a track map to be produced for each circuit for which data has been
logged and stored. This chapter describes how circuit maps are produced and how they
may be divided up into segments that allow more detailed analysis to be performed.

Note that data must have been logged from a suitable lateral accelerometer connected
to one of the user channels for circuit maps to be produced.

6.1 Creating a New Circuit Map
A new circuit map is created in the following way:

1. Highlight the lap to use as the basis for the circuit map in the Lap Explorer
window.

2. Choose Map » New from the main menu. The New Circuit Map dialog (Figure 20)
appears.

Mew map for Qulton Park (Fosters) @

Settings

Zern 1283: bitz

Gair: |-0.0300-= G/hit

Source
" User channel 1

+ Lser channel 2

Save

Cancel

el

Figure 20 - New Circuit Map Dialog

3. The mapping process produces an approximate map based on the current zero and
gain values for the lateral accelerometer connected to the chosen user channel.
Some adjustment may be necessary to make the plotted map resemble the actual
circuit.

4. To make an adjustment alter the zero or gain value and then click Draw Map. The
circuit map is redrawn using the new settings. Experiment with the zero and gain
settings until the map most closely matches the actual layout of the circuit.

5. Click Save to make this the default map for this circuit or Cancel to abandon any
changes made.
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6.2 Map Segments

Once a map has been created and stored for a circuit it can then be divided up into
segments.

6.2.1 Adding Segments
Segments are added to an existing circuit map in the following way:

1. Highlight the circuit (or any session or lap for the circuit) in the Lap Explorer
window.

2. Choose Map » Edit Segments from the main menu. The Edit Map Segments dialog
(Figure 21) appears.

Edit Map Segments for Oulton (Fosters) E]

Save

Distance:
101 m
Segments
Start
[ e
[ Ao
e
oEEE
Cancel

Figure 21 - Edit Map Segments Dialog (No Segments)

3. Mark the start point of the segment by clicking on the map and then clicking
Start. The start point of the segment is marked with a square drawn in a dashed
line (see Figure 22). The Start button is disabled and the End and Abandon
buttons are enabled.
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Edit Map Segments for, Oulton {Fosters) E|
Distance:
189 m
Segments L) : D
e
End
Abandon
[ois ]
[om]
Cancel

Figure 22 - Edit Map Segments Dialog (Defining a Segment)

4. If you want a segment to start at the end of another segment place the cursor
anywhere in the other segment before clicking Start.

5. Mark the end point of the segment by clicking on the map and then clicking End.
The portion of the map between the start and end points changes colour with
small bars marking the extents of the segment (see Figure 23). Clicking Abandon
before marking the end point of a segment allows the definition of the current
segment to be cancelled.

Edit Map Segments for, Oulton {Fosters) E|

Distance:

273 m

Segments L,
Start

Delete Al

Cancel

]y A

Save

Figure 23 - Edit Map Segments Dialog (Segment Defined)

6. If you want a segment to end at the start of another segment place the cursor
anywhere in the other segment before clicking End.

7. Continue to define more segments if required.

8. Click Save to update the segments for the circuit map or Cancel to abandon any
changes made.
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The Edit Map Segments dialog can also be accessed using the Edit Segments button @ on
the Circuit Map toolbar.

The colours for both the track and the segments can be changed via the Setup option of
the main menu. See Section 8.5 for more information.

6.2.2 Deleting Segments
Unwanted circuit map segments are deleted in the following way:

1. Highlight the circuit (or any session or lap for the circuit) in the Lap Explorer
window.

2. Choose Map » Edit Segments from the main menu. The Edit Segments dialog
appears.

3. Place the cursor over the segment to be deleted by clicking the map anywhere in
the segment. The Delete button is enabled (see Figure 24).

Edit Map Segments for Oulton (Fosters) E]

811m -{N
Seaments L; N

Delete
Delete Al

Figure 24 - Edit Map Segments Dialog (Deleting a Segment)

4. Click Delete. The segment is removed from the map (see Figure 25).
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Edit Map Segments for Oulton (Fosters) §|

811 m {3\
Seaments L; N

L

Cancel D

Figure 25 - Edit Map Segments Dialog (Segment Deleted)

5. Click Save to update the segments for the circuit map or Cancel to abandon any
changes made.

6.2.3 Deleting All Segments
All the segments for a circuit map are deleted in the following way:

1. Highlight the circuit (or any session or lap for the circuit) in the Lap Explorer
window.

2. Choose Map » Edit Segments from the main menu. The Edit Segments dialog
appears.

3. Click Delete All. A message box is displayed which requests confirmation of the
delete operation (see Figure 26).

i x|
Distance:
314 m
Segments
Start
Podium
Delete all map segments?
| i Yes Ma
T
Cancel
w;

Figure 26 - Edit Map Segments Dialog (Delete All Segments)
4. Click Yes to delete all the map segments or No otherwise.

5. Click Save to update the segments for the circuit map or Cancel to abandon any
changes made.
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7 Reports

Reports are used to summarise important aspects of a specific lap or session. They are a
particularly useful way of comparing relative times and speeds when a circuit map has
been divided up into segments. This chapter describes how reports are produced from
stored data.

7.1 Min/Max Values Report

A min/max values report shows the minimum and maximum values attained for each
parameter for the currently selected lap or laps. If both a Current Lap and a Reference
Lap have been selected then the difference between each minimum and maximum value
is also displayed.

Use either of the following methods to produce a min/max values report:

e Activate the reports drop down menu by clicking on the arrow « next to the
Reports button = on the main toolbar and select Min/Max Values, or

e Choose View » Reports from the main menu and select Min/Max Values.

7.2 Speed Report

A speed report shows the minimum and maximum speeds for each segment for the
currently selected lap or laps. If both a Current Lap and a Reference Lap have been
selected then the difference between each minimum and maximum value is also
displayed.

Use either of the following methods to produce a speed report:

e Activate the reports drop down menu by clicking on the arrow « next to the
Reports button =¥ on the main toolbar and select Speed Report, or

e Choose View » Reports from the main menu and select Speed Report.

7.3 Split Report

A split report shows the time taken to complete each segment for each lap in the
current session. The theoretical fastest lap time is calculated together with the fastest
rolling lap achieved in the session.

The theoretical fastest lap is made up of the fastest time for each segment and these
are highlighted in the report. The values of the segments making up the fastest rolling
lap are shown in a different text colour.
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Use either of the following methods to produce a split report:

e Activate the reports drop down menu by clicking on the arrow « next to the
Reports button ¥ on the main toolbar and select Split Report, or

e Choose View » Reports from the main menu and select Split Report.

7.4 Removing Reports
Use either of the following methods to remove a report:

e Activate the reports drop down menu by clicking on the arrow « next to the
Reports button =! on the main toolbar and select the report to be removed, or

e Choose View » Reports from the main menu and select the report to remove.
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8 Configuration
Podium provides facilities for the RCA40 lap timer to be configured via the serial port.

The way in which Podium itself operates can also be configured to suit each particular
application or personal taste.

This chapter describes how this configuration is carried out.

8.1 Data Logger

The parameters available via the setup mode of the RCA40 lap timer can also be
accessed using Podium.

8.1.1 Reading Current Configuration

Before the configuration of the lap timer can be changed the current configuration must
be downloaded to the host computer. This is achieved in the following way:

1. Choose Setup » Data Logger from the main menu. The Configuration Download
Dialog (Figure 27) appears.

RCA40 Configuration Download

Ok
Connect PCto data _
logger and click OK

Cancel

Status
Fieady

Figure 27 - Configuration Download Dialog

2. Connect the data logger to the serial port of the host computer using the cable
provided and click OK. The current configuration of the lap timer is transferred to
the host computer and the Setup Data Logger Dialog (Figure 28) appears.

The Setup Data Logger Dialog contains four pages which are described in the following
sections.

Note that any configuration changes made in the Setup Data Logger Dialog will only
come into effect when they have been transferred back to the lap timer.

Refer to the RCA40 User Manual for a more complete description of the purpose of each
of the configuration settings.

8.1.2 General

Click the General tab to display the General page (Figure 28) of the Setup Data Logger
Dialog.
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G l Lap Timing ] Dizplay ] [ata Logging ]

Farringdon Instruments BCA40

Software revision: 31

Session number; 1 3:
Diiver code; 2 3:
Track code: 3 3:

Set Defaults | QK. | Cancel |

Figure 28 - Setup Data Logger Dialog (General Page)

The model and software revision of the lap timer are displayed at the top of the page.

Session Number Type a number or use the up/down arrows to set the Session Number

value.

Driver Code Type a number or use the up/down arrows to set the Driver Code
value.

Track Code Type a number or use the up/down arrows to set the Track Code
value.
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8.1.3 Lap Timing

Click the Lap Timing tab to display the Lap Timing page (Figure 29) of the Setup Data
Logger Dialog.

General |- ngl Dizplay ] [ ata Logging ]

b ain channel: ,1—::|
IM charinel ,le
Hald time in seconds: ’G
Blatk time in seconds: 'El

Set Defaults | QK. | Cancel |

Figure 29 - Setup Data Logger (Lap Timing Page)

Main Type a number or use the up/down arrows to set the Main Channel
Channel value.

IN Channel Type a number or use the up/down arrows to set the IN Channel value.
Hold Time Type a number or use the up/down arrows to set the Hold Time value.
Blank Time  Type a number or use the up/down arrows to set the Blank Time value.
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Click the Display tab to display the Display page (Figure 30) of the Setup Data Logger

Dialog.

Backlight On

Backlight On for
Hold Time Only

Display
Hours/Minutes

Bar Graph Range In
Seconds
Top Left

Top Right

Issue 1.00

Setup Data Loggern gl
| _'.Jl D ata Lagging ]

General] Lap Timing D

[ Backlight on [ Dizplay hours/minutes

[ Backlight on far hald time anly

Performance Dizplay
Bar graph range in seconds;. |20+
Top Left Top Right
" Laps completed * ‘wheel speed
" Elapsed time " Relative time
" User channel 1
" User channel 2

* Engine speed

Set Defaults | QK. | Cancel |

Figure 30 - Setup Data Logger (Display Page)
Check this box if you want the backlight to be on all the time
the lap timer is on.

Check this box if you want the backlight to come on as the
beacon is passed and stay on for the hold time.

Check this box if you want the elapsed time displayed as hours
and minutes rather than minutes and seconds.

Select the required full scale range of the bar graph displayed in
performance mode.

Choose the parameter you want to be displayed in the top left of
the the screen in performance mode.

Choose the parameter you want to be displayed in the top right
of the screen in performance mode.
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Click the Data Logging tab to display the Data Logging page (Figure 31) of the Setup

Setup Data Loggern @

Data Logger Dialog.

General ] Lap Timing ] Dizplay

Mumber of magnets:

‘wiheel circumnference in cm:

[ Clear data logging memary

Mumber of wheel turhz per sample:

g

B
B
=]

MHumber of pulzes for 2 engine rews: 4 3:

v Enable perfarmance display and data logging

Set Defaults |

oK

| Cancel |

Figure 31 - Setup Data Logger (Data Logging Page)

Number of Magnets Enter a number or use the up/down arrows to set the number
of magnets fitted to the sensing wheel.

Wheel Turns Per Enter a number or use the up/down arrows to set the number

Sample of turns per sample value.

Wheel Circumference Enter a number or use the up/down arrows to set the wheel
circumference value.

Engine Pulses Enter a number or use the up/down arrows to set the number
of sensor pulses for two revolutions of the engine.

Enable Data Logging Check the box to enable performance mode and data logging.

Clear Memory Check the box to clear the data logging memory.

8.1.6 Writing New Configuration

Once all the required changes to the configuration of the lap timer have been made,
click OK. The Configuration Upload Dialog (Figure 32) appears.
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RCA40 Configuration Upload @
ak.
Connect PCto data _

logger and click OK ﬁ

Status
Fieady

Figure 32 - Configuration Upload Dialog

Verify that the data logger is still connected to the host computer and click OK. The
updated configuration is transferred to the data logger.

8.2 Show Setup For Session

To examine the data logger configuration used for a session do the following:
1. Highlight the session of interest, or any lap within it, in the Lap Explorer window.
2. Choose Setup » Show Setup For Session from the main menu.

The configuration for the chosen session will be displayed using the Setup Data Logger
Dialog as described above.

8.3 Channels

Podium needs to know how the sensors connected to the RCA40 are configured so that
logged data can be displayed correctly.

The sensors are setup (or calibrated) in the following way:

1. Choose Setup » Channels from the main menu. The Setup Channels Dialog (Figure
33) appears.

2. Make the necessary changes and click Apply to update the current configuration.
Click Cancel to abandon any changes made.

The Setup Channels Dialog has five pages which are described in the following sections.
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8.3.1 User Channels

The two user channels of the RCA40 are configured in the same way so the pages used to
set them up are identical. Click the User Channel 1 tab to display the User Channel 1
page (Figure 33) and the User Channel 2 tab to display the User Channel 2 page.

Set

1] User Channel 2 | Fitering |

Marne: |L|ser channel 1

Zero DE|: bitz

Units: |Units

Gain: 1 .DDE|: itz Bit

=]

Cancel |

Figure 33 - Setup Channels Dialog (User Channel Page)

Name Type the name for the user channel.

Units Type in the units of measurement for the user channel or pick an option
from the list.

Zero Enter a number or use the up/down arrows to set the zero point of the
sensor attached to the user channel.

Gain Enter a number or use the up/down arrows to set the gain of the sensor

attached to the user channel.

8.3.2 Filtering

Click the Filtering tab to display the Filtering page (Figure 34) of the Setup Channels
Dialog.

Setup Channels E|
User Channel 1 ] User Channel 2

Issue 1.00

[ Engine Speed
[ wheel Speed

[v Uzer Channel 1
v Uzer Channel 2

Cancel |

Figure 34 - Setup Channels Dialog (Filtering Page)
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Podium uses a simple, but effective, averaging filter to remove noise from logged data.

To filter data for a particular channel, check the box adjacent to the channel name on
the Filtering page.

Note that filtering cannot compensate for poor quality data due to electrical noise or
poorly mounted sensors. If the data is excessively noisy then filtering may give
unpredictable results.
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8.4 Serial Port

To alter the serial port that Podium uses to communicate with the RCA40 do the
following:

1. Choose Setup » Serial Port from the main menu. The Setup Serial Port Dialog
(Figure 35) appears.

Cancel

Figure 35 - Setup Serial Port Dialog

2. Select the new serial port from the list.

3. Click OK to update the serial port or Cancel to leave it unchanged.

8.5 Colours

The colours used to display the graphs and circuit map can be changed if required.

In each case, the standard colour dialog (Figure 36) is used to set the new colour. Forty-

eight standard colours are available as well as an almost infinite number of user-defined
custom colours.

EEEENT N

Custom colorz

EEEEEEEN
HEEEEEEN

Define Custom Colors =

Ok, | Cancel |

Figure 36 - Standard Colour Dialog

Issue 1.00 Page 40 of 43 March 2003



@ Podium Data Analysis Software

PolyLogic User Manual

8.5.1 Current Lap Graph
The colour used to display graphs for the Current Lap is changed in the following way:

1. Choose Setup » Graph Colours » Current Lap from the main menu. The Standard
Colour Dialog (Figure 36) appears.

2. Select the new colour for Current Lap graphs and click OK or click Cancel to leave
the colour unchanged.

8.5.2 Reference Lap Graph
The colour used to display graphs for the Reference Lap is changed in the following way:

1. Choose Setup =» Graph Colours » Reference Lap from the main menu. The
Standard Colour Dialog (Figure 36) appears.

2. Select the new colour for Reference Lap graphs and click OK or click Cancel to
leave the colour unchanged.

8.5.3 Circuit Map Outline

The colour used to display the track outline for the circuit map is changed in the
following way:

1. Choose Setup » Map Colours » Track from the main menu. The Standard Colour
Dialog (Figure 36) appears.

2. Select the new colour for the track outline and click OK or click Cancel to leave
the colour unchanged.

8.5.4 Circuit Map Segments

The colour used to display the map segments for the circuit map is changed in the
following way:

1. Choose Setup » Map Colours » Segments from the main menu. The Standard
Colour Dialog (Figure 36) appears.

2. Select the new colour for the map segments and click OK or click Cancel to leave
the colour unchanged.
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9 Troubleshooting

Problem | can’t download data from the lap timer or read/write its
configuration.

Cause The lap timer is not powered up.

Action Turn on the Master switch, and the ignition switch (if necessary).

Cause The download lead is not connected.

Action Connect the data logger to the serial port of the host computer using

the cable provided and try again.

Cause The lead is not making a good connection.

Action Ensure both connectors are fully home and that the lead is not
damaged in any way.

Cause The serial port is not configured correctly.

Action Choose Setup » Serial Port from the main menu and select the correct
serial port.

Problem The circuit map doesn’t match the track layout.

Cause The lateral accelerometer has not been installed in the correct
orientation.

Action Re-position the accelerometer so that the arrow is perpendicular to

the direction of travel.

Cause The zero and gain values are incorrect.

Action Enter the correct zero and gain values and try again.
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10 Glossary

Accelerometer A sensor for measuring acceleration, or the rate of change of speed.

Calibration The process of scaling logged data into engineering units.

Downloading The process of transferring stored data from a data logger to a host
computer.

Filtering A mathematical method for removing noise from a graph.

Gain (of sensor)  The relationship between the logged value (in bits) and the physical
value (in engineering units).

Lateral G The sideways acceleration caused by cornering.

Longitudinal G The fore-aft acceleration caused by accelerating and braking.

Session Data stored for one or more track outing and downloaded to the host
computer.

Zero (of sensor)  The value logged by the data logger when the parameter being
measured by the sensor is zero.
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