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This manual describes the features that are used to program Series 90™-30 PLCs, VersaMax™ PLCs,
VersaMax Nano/Micro PLCs, and Series 90 Micro PLCs using the VersaPro™ programming software,
Version 2.0x.

Revisions to This Manual

This manual and the product online help have been updated to reflect the new features provided by
Version 2.0x. New features include:

• Support for Series 90-70 PLCs, including Genius redundancy and CPU redundancy over Genius.
(Refer to the Important Product Information document, GFK-1671K or later, for a complete list of
features supported.)

• Support for additional VersaMax I/O modules and Series 90-30 power supply modules. (Refer to
GFK-1671K or later for a list.)

• Usability enhancements:

- SNF/VCD Import able to swap variable names

- Multiple instances of VersaPro on the same computer simultaneously communicating to PLCs.

- Minimum supported Firmware Revisions / Unsupported CPU models

- Warn if Store to PLC with LM90 folder

- Block Locking/Unlocking (other than via an import or load)

- Online Use Tables

- Print Header / Footer

- Auto-backup

- Find local scope variables

- Size of block reported to the Information Window

- %R upper limit change

- Serial number provided in Help About box

- Site licensing
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Content of This Manual

Chapter 1. Introduction:   Provides an overview of the VersaPro Programming Software
components.

Chapter 2. Working With Folders:   Describes how to create new folders, perform file
operations on existing folders and provides an overview of the Folder Browser.

Chapter 3. Working With Blocks:   Describes how to create and manage blocks and
objects in the VersaPro browser.  This chapter also describes how to convert
blocks between IL and RLD.

Chapter 4. Working in the LD Editor:   Describes how to customize the LD Editor
Window, enter and edit logic, and how to work with variables in the LD editor.

Chapter 5. Working in the Instruction List Editor:   Describes how to customize the IL
Editor Window, enter and edit logic, and how to work with variables in the IL
editor. This chapter also provides information on Instruction List operands.

Chapter 6. Working with the Variable Declaration Table:   Provides an overview of
working in the Variable Declaration Table (VDT) and shows how to create and
edit variables.

Chapter 7 Configuring PLC Hardware:  Describes how to access hardware
configuration and how to configure Series 90-30 and VersaMax PLC systems.

Chapter 8 Using Reference and Variable View Tables:  Provides an overview of
Reference View Tables (RVT) and Variable View Tables (VVT). Describes
how to create and manage data in the view tables.

Chapter 9. Motion Programming.  Provides an overview of motion programming for the
Motion Mate DSM314 motion control module. Describes the Motion, Local
Logic, and Cam editors.

Chapter 10. Communicating with the PLC:   Describes how to connect your computer to
the PLC and gives the procedures for common online operations.

Chapter 11. Working with Fault Tables:   Gives the procedures for viewing the PLC and
I/O Fault Tables.

Appendix A: VersaPro Menus and Toolbars:  Provides summary information about the menus
and toolbars available in VersaPro.

Appendix B: Communications Cabling:  Provides cabling information and diagrams.

Appendix C: VersaPro License Transfer Procedure:  Describes how to transfer a VersaPro
license from one machine to another.

Appendix D: Using the VersaPro Keyboard: A quick reference guide to keyboard shortcuts.
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Introduction

Welcome to VersaPro

Welcome to VersaPro, GE Fanuc's Windows -based programming software for the
Series 90-30 and VersaMax PLCs. VersaPro is designed to install and run under
Windows 95, Windows 98, Windows NT  4.0 SP5 onwards, Windows 2000 and Windows XP.

With VersaPro, you can:

Create PLC logic and information associated with that logic in a folder

• Configure PLC Hardware

• Create and edit variables

• Create, edit, and monitor the execution of Ladder or Instruction List logic

• Create Motion, Local Logic and Cam programs for the 90-30 DSM314 Motion
module

Chapter Contents

• Overview of the VersaPro Programming Software components

• The Workbench Window

• Configuring Workbench Options (setting editor and target hardware)

Chapter

1
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Installing VersaPro Software

Note: VersaPro must be installed on a hard drive in your computer. Do not
attempt to install VersaPro on removable media such as Jaz® or Zip®
drives.

1. It is recommended that you close all applications including virus checking, Internet
Explorer,and CIMPLICITY HMI software that might be running in the background.
You may need to check the task manager to determine if other applications are
running.

2. Put the VersaPro CD in the CD-ROM Drive.

3. Select the CD drive from Windows Explorer.

4. Double click Setup.exe

5. Follow the user prompts to complete the installation.  If you have a previous version
of VersaPro installed, the installation tool will first uninstall the previous version.
During this uninstall process, you may be asked whether you would like remove
shared files.  It is recommended that you always answer “No to All” to ensure that no
files are deleted that might be needed by another application.

Note: When you upgrade from VersaPro Version 1.0x or VersaPro 1.1x to
1.50, your user screen settings and the directory location for program
files will be lost. You will need to re-establish these settings after
completing the upgrade.

Note: For procedures to transfer your VersaPro license to another computer,
refer to Appendix C.

Starting VersaPro Software

The VersaPro application is installed in the GE Fanuc Software Program group.  The
application can be started by selecting Start->Programs->GE Fanuc Software->VersaPro.
It is also possible to create a shortcut to the VersaPro application and place the shortcut on
the desktop, or to click on a file created by VersaPro (the file in the VersaPro folder with a
.fld extension), and start the application in the context of the selected folder.  VersaPro
may also be started using CTRL-ALT-V.
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Multiple Instances of VersaPro

• If you are using a serial connection, only one instance of VersaPro can be connected
to the PLC. You can have multiple offline (not connected to the PLC) instances.

• If you are connecting to the PLC via Ethernet, you can have only one instance of
VersaPro.

Using VersaPro – Overview

VersaPro provides a single programming interface to configure your PLC hardware, create
and edit PLC logic, and monitor the execution of the PLC program.

Component Description

Folder Browser Displays a tree-like structure that provides an overview of the current folder

Hardware
Configuration

VersaPro's default hardware platform is the VersaMax PLC.  You can
change the hardware platform to create programs and hardware
configuration for all Series 90-30, VersaMax, and Series 90 Micro PLCs.

Logic Editors There are two editors for creating PLC logic: the Instruction List Editor and
the Ladder Diagram Editor. You can convert programs and blocks from IL to
RLD.

Motion Editors A Motion editor and a Local Logic editor are provided for creating local
logic and Motion programs for the Motion Mate DSM314 motion control
module. A Cam editor has been added to VersaPro 1.5.  If the Cam editor is
installed, it can also be used with DSM314 release 2.0.

Syntax Checking VersaPro provides a tool to check that your program is syntactically valid
before storing to the PLC.

PLC
Communications

VersaPro supports serial and Ethernet connections to the Series 90-30 and
VersaMax PLCs.

Online
Monitoring

Online monitoring and control is supported in logic editors and Reference
View Tables and Variable View Tables.

Fault System The fault system provides quick connection to view PLC and I/O fault tables
in the PLC.

Information
Window

The Information window displays the results of actions performed in
VersaPro.

The following abbreviations are used in VersaPro:

Abbreviation Component

IL Instruction List

RLD Relay Ladder Diagram

RVT Reference View Table

VDT Variable Declaration Table

VVT Variable View Table

LL Local Logic

LLVT Local Logic Variable Table
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The Workbench Window

When you first start VersaPro, the workbench is displayed. You can perform the following
tasks from the workbench:

• Create and Open Folders

• Backup and Restore VersaPro folders

• Setup communications parameters, Connect to the PLC and view Fault Tables

• Customize Workbench Options

Setting Workbench Options

VersaPro allows you to customize editor and window options. It is important to confirm
the default language and hardware configuration before creating a new folder.  Other
options may be customized before opening a folder, or after the folder is opened.

General Options

VersaPro's default hardware configuration is the VersaMax PLC.  The default block
language is Ladder Diagram.  To change the default configuration so that you can create
programs and hardware configuration for the target devices, or to customize display and
editing options, select the Tools menu and choose Options.  The Options dialog box will
appear.
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• Setting Block Language: The default language is Ladder Diagram.  To change
the default block language to Instruction List, select the General tab.  Click the
Default Block Language and select Instruction List

• Changing Hardware Configuration default: VersaPro's default hardware
platform is the VersaMax PLC.  You can create programs and hardware
configuration for all Series 90-30, VersaMax, VersaMax Nano/Micro, and
Series 90 Micro PLCs. To change the default hardware configuration, select the
General tab and set the Default Hardware Configuration field.

• Setting Full or Brief comments:  In the LD and IL Editors, comments can be
configured to be viewed in full or brief mode. The default is to view comments
in brief mode.  To change the default, select the General Tab and check the Full
Comments button.

• Setting Syntax Check (Turn off Warnings): By default, when VersaPro
performs syntax checking on logic, multiple coil usage warnings are displayed
in the information window. To suppress the warnings, select the General tab and
check the Turn Off Warnings box.

• Enable SNF Auto-Export: This option causes variables to be automatically
exported in SNF format when you create or edit variables and then save the
VDT. Only variables in the VDT with the EXT checkbox selected will be auto-
exported. The .snf file will be exported to the current folder; any existing .snf
file with the same name will be overwritten.

• Setting the number of undoable actions: VersaPro allows you to configure the
number of undo/redo operations available during editing sessions.  The default
number is 10.  The valid range is 1 to 100.

• Filename: If Use Folder Name is not selected, a filename is required. This name
follows the same naming rules as VersaPro folder names.

• Use Folder Name (default): If this box is checked, the exported filename will
be foldername.snf.

• File Lock Timeout: A *.lck (lock) file is generated at the same time as the *.snf
file. The *.lck file is used to prevent reading or writing of the *.snf file while it
is in use. VersaPro will attempt to access the *.lck file for the number of seconds
specified in this field. Valid values are from 1 to 60 seconds.
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Setting Display Options

VersaPro allows you to set text font, size and color separately for the IL, LD, Local Logic,
and Motion Editors, for the VDT, and for Variable View, Reference View, and Local
Logic Variable tables.

Perform these steps to set display options:

1. Choose Options from the Tools menu, or from the LD or IL Editor context sensitive
menu (CSM).

2. The Options dialog box appears.

3. Select the Display tab.

4. From the Category list, select the editor or table whose display options you wish to
configure.

5. The Colors list displays the items you can configure for the selected editor or table.

6. Select the color to be used for each configurable area of the selected editor or table.
The list of configurable areas differs based on the window whose display you are
configuring.

Note: Certain combinations of colors and backgrounds can be difficult
to read.
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7. Select the font name and font size to be used to display text in the selected editor or
table.  Click OK

Note: You cannot change the font used for Column and Row headings.

The selected colors are applied to selected areas of the selected editor or table. The
selected font is applied to all text within the selected editor or table. If the selected editor
or table is visible, it appears with its changed colors, font and size.

Note: Selected fonts are used when you print your program.

Setting Communications Options

You can configure VersaPro to connect to a particular device immediately upon startup
and to open the folder associated with that PLC.

To configure Autoconnect

1. Choose Options from the Tools menu, or from the Editor CSM.

2. The Options dialog box appears.

3. Select the Communications tab.
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Note: The Wait Time parameter on the Communications tab has no effect on
the operation of Autoconnect.  The length of time that VersaPro tries to
connect on startup is determined by the Connect Timeout parameter in
the CCU. To set Connect Timeout, go to the Tools menu, and select
Communications Setup. In the CCU, choose the Global Parameters tab.

4. Click the Enable Autoconnect checkbox.

5. In the Device field, select the Device to which you wish to connect automatically
upon startup.

6. In the Location field, enter the starting search path for the folder associated with this

PLC, or click the Browse for Folder button  and select the location from the
Browse for Folder dialog box. This specifies the location where VersaPro will start to
search for the VersaPor folder that is stored in the PLC.

VersaPro uses the PLC Folder Nickname (PLC program name) to determine what
folder to open. By default, the Nickname is the last seven characters onf the folder
name. The Nickname may be viewed and set in the Folder Properties dialog box.
(Choose Properties from the Edit menu or the folder root node CSM.)

7. Click OK.

Note: To turn off Autoconnect, select the Communications tab in the Options
dialog and uncheck the Enable Autoconnect button.
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Setting Ladder Options

VersaPro allows you to specify the types of information displayed about LD Editor
symbols, and the width of LD Editor grid cells. You can also zoom in or out in order to
proportionally enlarge or decrease the display size information in cells.

To specify the types of information displayed about LD Editor symbols:

1. Choose Options from the Tools menu, or from the LD Editor CSM. The Options
dialog box appears.

2. Select the Ladder tab.

3. Choose whether to show or hide the variable name, reference address, and
description. Each of the checked items appears in the LD Editor.

4. Determine whether variable names and descriptions should be displayed in part or full
by selecting Brief or Full for each.

5. The variable description and/or reference address display in the bottom portion of
each cell according to the current cell width. Text that exceeds the available space is
replaced with "..."
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To set LD Editor grid cell width:

VersaPro allows you to change the width of LD Editor grid cells, to make more text
visible.  Only the width of the cells changes: cell height and font size remain unchanged.

1. Choose Options from the Tools menu, or from the LD Editor CSM. The Options
dialog box appears.

2. Select the Ladder tab.

3. Under Grid Cell Width, drag the slider to the right to increase the grid cell size, or to
the left to decrease the size.

4. Click OK.  The LD Editor grid changes to the new size.
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Setting Motion Program/Local Logic Editor Options

1. Choose Options from the Tools menu, or from the Editor CSM. The Options dialog
box appears.

2. Select the MP/LL Editors Tab.

Tab Size Sets the number of spaces that is equal to one tab. Valid
values are integers 1 to 64.

Insert Spaces Converts the tabs to the number of spaces specified in
Tab Size.

Keep Tabs Saves the tabs as tab characters.

None No automatic indenting of code.

Default Indent code using the Tab Size. The indent is based on
the scope words.

Use Previous Line Indents the current line the same as the line directly
above it.

3. Select the tab and auto-indent options you want.

4. Click OK.
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Working With Folders

A folder contains all of the components required to program, configure and monitor your
Series 90-30, VersaMax, VersaMax Nano/Micro, and Series 90 Micro PLCs.  The
components include Hardware Configuration, Variable Declaration Table, View Tables
and program blocks. You can also insert other windows-components into the folder, like
user documents and spreadsheets.

VersaPro allows you to have only one folder open at a time.  However, you can have
multiple instances of VersaPro running on your PC.

Chapter Contents

This chapter describes how to create and manage folders using the VersaPro software.

• Creating a New Folder

• Creating an empty folder

• Creating a folder, based on an existing VersaPro folder

• Creating a new folder – importing logic from a Logicmaster 90 folder

• Creating a new folder – importing logic from Control

• Working with existing folders (opening, saving, closing, deleting)

• Overview of the folder browser view

• Backing up and Restoring folders

• Protecting folders

• Changing folder properties

• Inserting blocks and objects

• Printing folder logic

Chapter

2
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Creating and Opening VersaPro Folders

Creating a New Folder

VersaPro provides several options when creating a new folder.  You can create an empty
folder, or create a new folder based on an existing VersaPro folder. VersaPro also
provides an option for you to create a folder by importing content from Logicmaster 90
(Series 90-30 or Series 90 Micro folders) or Control  (Series 90-30 or VersaMax folders).

To create a new, empty folder:

The default language for new folders is Ladder Diagram.  The default hardware
configuration is VersaMax.  If you want to change the default language or target hardware
for your new folder, select the Tools menu and choose Options. Change the settings in the
Options dialog box.

To create a new, empty folder from the VersaPro workbench:

1. Click the New Folder button , choose New Folder from the File menu, or press
Ctrl+N. The New Folder Wizard will appear.
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• In the Folder Name field, type a name for the new folder. A folder name is
required. (See "Rules for Folder Names and Nicknames" on page 2-10.)

• If you want to save the new folder to a location different from the default, click
on the Browse button opposite the Location field.

• Enter a folder description in the Folder Description field.  You may enter up to
64 characters.  This field is optional.

2. Click the Next button.  The next screen of the New Folder Wizard will appear.

3. The Empty Folder (Default) button is automatically selected.  Click Finish to create
the new, empty folder.

The Folder Browser appears, displaying the new folder.  The _MAIN block will appear in
the default language’s editor.
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To create a new folder based on an existing VersaPro folder:

To create a new folder based on an existing VersaPro folder, launch VersaPro and perform
the following steps:

1. Click the New Folder button , choose New Folder from the File menu, or press
Ctrl+N. The New Folder Wizard will appear.

• In the Folder Name field, type a name for the new folder. A folder name is
required.

• If you want to save the new folder to a location different from the default, click
on the Browse button opposite the Location field.

• Enter a folder description in the Folder Description field.  You may enter up to
64 characters.  This field is optional.

2. Click the Next button.  The next screen of the New Folder Wizard will appear.
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3. Click the Based on Existing VersaPro Folder button, then click the Browse button for
the From field and, in the Browse dialog box that appears, locate the VersaPro folder
upon which you wish to base this new folder.

4. Click Finish.  The existing folder's structure and contents (blocks, VDT, etc) are
duplicated in the new folder.

The Folder Browser appears, displaying the new folder.  The _MAIN block will appear.
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To create a new folder, importing a Logicmaster 90 Folder:

You can import Logicmaster folders configured for Series 90-30 or Series 90 Micro PLCs.

To create a new folder based on an existing Logicmaster 90 folder, start VersaPro and
perform the following steps:

1. Click the New Folder button , choose New Folder from the File menu, or press
Ctrl+N. The New Folder Wizard will appear.

• In the Folder Name field, type a name for the new folder. A folder name is
required.

• If you want to save the new folder to a location different from the default, click
on the Browse button opposite the Location field.

• Enter a folder description in the Folder Description field.  You may enter up to
64 characters.  This field is optional.
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2. Click the Next button.  The next screen of the New Folder Wizard will appear.

3. Click the Import Logicmaster 90 button, then click the Browse button for the From
field and, in the Browse dialog box that appears, locate the Logicmaster 90 folder
upon which you wish upon which you wish to base this new folder.

4. Click Finish.  The content of the Logicmaster 90 folder is imported into the new
folder.  The logic is checked for correct syntax.

5. If any syntax errors are found, they are reported in the Information Window, and the
process is aborted.  The new folder is not created.

• If no syntax errors are found, the folder is populated with the logic and hardware
configuration from the Logicmaster 90 folder.

When a folder contains a locked block

You may import a Logicmaster 90 folder or load a folder from a PLC containing a locked
(protected) block. The following will occur:

• When a folder containing a locked block is imported from Logicmaster 90 or
Control, the block name, type and language are retained, but the block contains
no contents.

• When a protected block is loaded from a PLC, an empty block is created.

The Folder Browser displays an icon for the block.
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To create a new folder, importing logic from a Control folder:

You can import VersaMax (.F2K) and Series 90-30 (.F3X) folders from Control.

To create a new folder based on an existing Control folder, launch VersaPro and perform
the following steps:

1. Click the New Folder button , choose New Folder from the File menu, or press
Ctrl+N. The New Folder Wizard will appear.

• In the Folder Name field, type a name for the new folder. A folder name is
required.

• If you want to save the new folder to a location different from the default, click
on the Browse button opposite the Location field.

• Enter a folder description in the Folder Description field.  You may enter up to
64 characters.  This field is optional.
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2. Click the Next button.  The next screen of the New Folder Wizard will appear.

3. Click the Import Control button, then click the Browse button of the From field and,
in the Browse dialog box that appears, locate the Control folder upon which you wish
to base this new folder.

Note: Only Control folders with .f3x and .f2k extensions may be imported.

Note: Your Control folder must be successfully built in Control before
importing, and the hardware configuration must also have been built in
Control.

4. If you are importing variables from Control, select the Include SNF checkbox, then
click the Browse button and, in the Browse dialog box that appears, locate the SNF
file that is associated with the Control file to be imported. (This field is optional.)

Note: When importing a Control folder, in order to add variable nicknames,
the SNF (shared name format) file associated with the folder to be
imported must first be exported from the Control folder using Control.
Refer to the Control online help for details on exporting an SNF file.
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5. Click Finish.  The content of the Control folder is imported into the new folder.  The
logic is checked for correct syntax.

• If syntax errors are found, they are reported in the Information Window, and the
process is aborted.  The new folder is not created.

• If no syntax errors are found, the folder is populated with the logic and hardware
configuration from the Control folder.

Rules for Folder Names and Nickname

This section describes naming conventions and rules for new folders and folder
nicknames.

Rules for Folder Names

The following rules apply to folder names for new VersaPro folders:

• A folder name may be no longer than 103 characters.

• The following characters may not be used in a folder name: . (period), \ (backslash), /
(forward slash), : (colon), * (asterisk), ? (question mark), < (less than), > (greater
than), | (vertical bar), " (quotation mark).

Rules for Folder Nicknames

The Folder Nickname (or Program Name) is the name used when storing the folder to the
PLC.  Both the Series 90-30 and VersaMax PLCs will recognize a nickname that is 7
characters or less.

• A nickname must be 7 characters or less.

• The first character of a nickname must be a letter.

• The remaining characters may be letters, digits, or the underscore character ("_").

• An underscore may not appear directly after an underscore.

• When a folder is created, the Folder Nickname defaults to the last 7 characters of the
folder name.
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Directory structure and files for a new folder

When a new empty folder is created, the following files are created at the folder's
specified location. For these examples, the folder's name is newfolder.

• _MAIN.blk  (the _MAIN block)

• newfolder.fld  (a description of the folder's contents)

• newfolder.vdt  (the Variable Declaration Table)

• newfolder.hwcfg (Hardware Configurations)

• newfolder.ssx (Smart Store Extensions)

For a new folder created based on an LM90 import named, for example, LM90impt, the
folder is created at the specified location including these files:

• _MAIN.blk  (the _MAIN block)

• a .blk file for each LM90 block

• LM90impt.fld  (a description of the folder's contents)

• LM90impt.vdt  (the Variable Declaration Table)

• newfolder.hwcfg (Hardware Configurations)

• newfolder.ssx (Smart Store Extensions)

Opening an Existing Folder

VersaPro allows you to open a folder from a local drive or diskette, or from a network
drive. Perform the following steps to open an existing VersaPro folder.

1. From the File menu, choose Open Folder, or on the toolbar, click the Open Folder

button. 

2. If another folder is already open, a dialog box appears, asking if you wish to close the
open folder.

3. Once you have closed the open folder, an Open dialog box appears. Folders have file
type .fld, so you will see "*.fld" in the "Files of type:" list.

4. Select the drive and folder to open.

5. Click the Open button.

6. The folder opens. Its components are displayed according to the properties retained
upon the last Save.
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Using the Folder Browser

After creating a new VersaPro folder or opening an existing folder, the Folder Browser
appears, along with the default windows (logic editor, information window, etc.).

Menu Bar and Toolbars
Provide quick access to
frequently used functions.

Logic Editor Window
Displays program or block logic.

Browser View
Displays all components contained
in the folder. To view details for a
component, double-click the item.

Information Window
• Displays warnings and error messages
• Displays results of Load, Store, Verify
• Displays results of Find operations
• Displays results of View Online Cross-Reference

Variable Declaration Table
Displays all variables defined in
the folder.

Status Bar
Shows the PLC run/stop state,
scan time, and equality status.
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The Folder Browser displays a tree-like structure, showing all of the components
associated with the folder. The display includes a list of all blocks included in the folder
(including _MAIN block), as well as icons providing access to Hardware Configuration,
the Variable Declaration Table and View Tables.

The Folder Browser allows you to navigate through the current folder easily and to create,
arrange, modify or delete blocks and block properties. It also allows you to check the
syntax of blocks within a folder.

To open an item in the browser window, double-click the item in the browser.

Information Window

The General tab displays error and warning messages (for example, the results of checking
logic for syntax errors). It also displays the details of searches, replacements, conversions
from one language to another, and the results of the Find Unused Variables command
(from the Folder menu, select Find Unused Variables).

The Find tab displays the results of the Find in Blocks operation. (Select Find in Blocks
from the Edit menu or the Folder Browser CSM.) Lists block, rung, and instruction where
each instance of the item being searched for was found.

The Cross Reference tab lists all variables used in the selected block and identifies the
rung and instruction each variable is used in. To display the Cross Reference, select View
Online Cross Reference from the Tools menu or the Folder Browser CSM.

Note: When the Information Window is resized to a larger window, the scroll
box becomes too large to be moved in the scroll bar. To scroll the
window, use the arrow buttons at the top and bottom of the scroll bar.
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Context-sensitive Menu

The context-sensitive menu (CSM) is not on the menu bar. It appears when you click the
secondary (right) mouse button in certain VersaPro windows or on certain elements.  The
menu contains a list of frequently-used options appropriate to the given context.

To use the CSM

1. Select a folder element (the folder or one of its sub-elements).

2. Click the secondary mouse button on the element.

3. A CSM similar to the one shown below appears. Unavailable options appear in gray
text.

4. Click the desired option.
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Working with Windows in the VersaPro Workspace

All windows in the VersaPro workspace can be moved by dragging and dropping and
resized. To move a window, click its title bar or top border, if it doesn't have a title bar,
and drag it. To resize a window, click its edge or corner and drag.

The Folder Browser, Information Window, Variable Declaration Table, and Local Logic
Variable Table (used in Motion programs) can be docked (fixed) or undocked (floating).
To select or deselect docking, click the secondary mouse button in the window and choose
Allow Docking from the context-sensitive menu.

Note: If you click in an undocked window, you will not be able to select
items from the main menus or other windows in VersaPro until the
window is docked again.  These windows can be docked and undocked
by selecting Allow Docking from the CSM.

You should undock these windows only temporarily in order to move
them to a new docked location.

Hiding a window makes it disappear temporarily. It does not cause the window's data to
be saved. To hide a window, click the window's button on the View toolbar, or choose the
window's name from the View menu. To hide a dockable window choose Hide from the
CSM.

To display a window once it has been hidden, click the window's toolbar button, or from
the View menu, choose the window's name.
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Folder Operations

This section describes additional operations and functions which may be performed on
VersaPro folders, including:

• Performing standard file operations (close, save, delete, backup, restore)

• Restricting access to VersaPro folders (enabling password protection)

• Editing folder properties

Closing a VersaPro Folder

Since only one folder can be open at a time in a single instance of VersaPro, an open
folder must be closed before creating a new folder or opening an existing folder. When
you try to open a folder when a folder is currently open in VersaPro, you will be prompted
to save the currently-open folder before opening the new folder.  You can also close a
folder by performing the following steps:

1. Select the File menu and choose Close Folder. If any of the folder's components have
changed, you will be prompted to save the changes for each component.

• Click Yes to save changes or No to ignore changes. Clicking Cancel aborts the close
operation.

2. The folder is closed.  As part of the folder closing process, the Folder Browser is
automatically saved, the size of the last active block is saved as the retentive block
state, and the individual size and position of all dockable windows and all columns
are saved as retentive states.

Saving a Folder

VersaPro allows you to save an open folder and folder contents to its current location.
This operation saves the entire folder, not individual parts.

To save a folder, select the File menu and choose Save All. You can also click the Save

folder button   on the toolbar.  The open folder is saved.

The File, Save menu item saves only the selected component.

Deleting a Folder

To delete a VersaPro folder, locate the folder on your hard drive and  use Windows
Explorer to delete.
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Backing Up and Restoring

VersaPro provides commands to back up a folder and to restore a folder from backup.
VersaPro creates backup files with a .flb extension.

Backing Up a Folder

Backing up ensures that data is not lost in any event.  It is recommended that you backup
your folder occasionally to protect your program.

1. Select the Folder menu and choose  Backup.  The Backup Folder dialog box will
appear.

2. In the Source Folder field, enter the path and name of the folder that you want to back
up, or locate it by clicking on the Open Folder button and selecting the folder in the
Browse dialog box that appears.

3. In the Destination field, enter the name of the backup and the location to which you
wish to save it, or locate the path by clicking on the Open Folder button and selecting
the folder in the Browse dialog box that appears.

4. Click OK. A backup of the folder you select is created and saved under the specified
name to the indicated location.

Restoring a Folder from Backup

VersaPro allows you to restore backed up files as necessary. Compressed backup files are
decompressed and fully restored when a restore is performed.  Perform the following steps
to restore a folder from backup.

1. Close any open folders.

2. Select the Folder menu and choose Restore.  The Restore Folder dialog box will
appear.

3. In the Source Folder field, enter the path and name of the folder that you want to
restore, or locate it by clicking on the Open Folder button and selecting the folder in
the Browse dialog box that appears.

4. In the Destination field, enter the location to which you wish to restore the folder, or
locate the path by clicking on the Open Folder button and selecting it in the Browse
dialog box that appears.

5. Click OK. The folder that you selected is restored to the location that you specified.
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Restricting Folder Access

VersaPro allows you to restrict access to a folder by locking it. A locked folder's contents
may be viewed but not changed. A folder may be locked with or without a password. If a
folder is locked with a password, you must enter the password to unlock the folder. A
locked folder is "read-only."

Locking a Folder

Perform the following steps to lock a folder:

1. Open the folder you want to lock.

2. From the Folder menu, select Lock. The Folder Security dialog box will appear.

• To lock the folder without a password, click OK.

• To lock the folder with password protection, check the Lock with Password
checkbox.  Enter the password in both the Enter Password and Verify Password
fields.  Note:  The password is case sensitive.

• A password must be eight characters or less.

• Valid password characters are digits (0-9), uppercase (A-Z) and lowercase (a-z)
letters, and the underscore (_).

3. Once the folder is successfully locked, the folder title bar will display READ_ONLY,
indicating that the folder is protected.  You cannot edit any portions of the folder,
except for temporarily adding variables to existing view tables.

Note: Once a folder is locked with a password, that password cannot be
changed.  To assign a new password, unlock the folder, then lock it
with a new password.

Operations permitted on locked folders

• Edit existing view tables. You may not create new view tables. Variables already
defined in the Variable Declaration Table may be added to VVTs for the purposes of
monitoring, but the changes cannot be saved. New variables may not be created in the
VVT. Addresses may be added to RVTs, but cannot be saved.

• Open and close windows or blocks

• Rearrange windows

• Monitor logic execution

• Toggle and Override I/O
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• Change variable values

• Copy blocks and portions of logic from the folder

• Create a new folder based on the locked folder. The new folder will also be
locked, with the old folder's password.

• Store and Verify folders

Unlocking a Folder

If a folder is READ_ONLY, you must unlock the folder to edit the folder.  If passwords
were used when locking the folder, they must be supplied to successfully unlock the
folder.  Perform the following steps to unlock a folder:

1. From the Folder menu, select Unlock.

2. If the folder has a password, the Enter password dialog box appears.

3. Type the password.

4. The  phrase "READ ONLY" in the folder's title bar disappears.

5. The old password is cleared. The folder can now be edited.

Changing Properties

Folder properties are set when a folder is created. However, you can change the folder
description and nickname. Perform the following steps to change folder properties:

1. Open the folder whose description or nickname you wish to change.

2. From the Edit menu, choose Properties, Folder. The Folder Properties dialog box will
appear.

3. Change the description as desired. A description may be up to 64 characters long.

4. Change the nickname as desired. The nickname may be up to 7 characters

5. Click OK. The folder properties are saved, and the Properties dialog box closes.
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Printing Your Program

Hardware Configuration is not included in any printed report. If you want to print out
Hardware Configuration, you must do so using the Stand Alone Hardware
Configuration utility.

Printing a Report

The Print Report dialog box allows you to define which components should be printed
when you generate a report. You can print Blocks, a Cross Reference, a Table of Contents,
a Header Page, and Variables. The Print dialog box allows you to choose printers, print
ranges, and the number of copies that you want to print. The Page Setup dialog box allows
you to select paper size, source, orientation, and margins.

Information about which Print Components, which Blocks and which details about blocks,
whether or not a Table of Contents or a Header page, and whether Cross References and
the associated Reference Addresses are to be included in printing, is retained after you
generate your first report. You can change this information as desired, but you need not
reset the specifications every time you print. All other settings require input each time a
report is generated.

Perform the following steps to customize and print your program:

1. From the open folder, select the File menu and choose Print Report.  The Print Report
dialog box will appear.  Use this dialog box to customize your listing as described
below.
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• To include Blocks in your report, click the Blocks checkbox.

Note: When multiple blocks are printed, they are printed in the order they
appear in the Folder Browser.

In the Blocks group, check each block element that you want to include in the
report. You can choose:

o Logic

o Properties

o Variable Information (all variables used in this block plus local variables,
even if they are not used in the block)

Note: To activate the Selected radio button, you must first go to the folder
browser and select the block or blocks that you want to print.

• To include a Cross Reference list in your report, click the Cross References checkbox,
then choose whether you want to include Cross References for the entire folder, or per
block by clicking the appropriate option button.

o If you choose to print Cross References per block, and you want to include
identifiers (Jump, Label Names, Calls, and MCR Names) check the Include
Identifiers checkbox.

Note: The Cross Reference includes implicit addresses for all variables that
use them. Implicit addresses are enclosed by brackets [ ].

• To include Variable Tables in your report, click the Variables checkbox, then select
which variables you want to include by checking the appropriate checkboxes.

• To include Local Logic variables, select the Include Local Logic Variables checkbox.

• To select paper size, source, orientation, and margins, choose Page Setup from the
File menu, or click the Page Setup button in the Print Report dialog. Click the OK
button to save your specifications.

• To print contents of the report, select Print Table of Contents.

• To print Folder Properties information, select Print Header Page.

• To change the starting page number for the report, type the number you want in the
Starting Page Number box. Maximum is 9999. Default is 1.

2. Click the OK button or press Enter to print.
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Printing Logic, Variable Declaration Table, or Information Window Contents

With the window you want to print selected, choose Print from the File menu, click the

Print button , or press Ctrl + P. The Print dialog box appears.

1. In the Printer group, use the drop-down list to choose the printer that you want to use
to print the report. You can also view or alter Printer Properties by clicking the
Properties button, or choose to print to file by clicking in the Print to file checkbox.

2. In the Print range group, determine whether the current selection, a certain range of
Rows, Rungs or Tabs, or All items should be printed in the report.

3. In the Copies group, determine the number of copies that you want to print by
entering it manually or by using the arrow buttons to the right of the field.

4. Click OK to print, or Cancel to close the dialog box without printing.
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Working With Blocks

The Series 90-30 and VersaMax PLCs support multiple blocks per folder (the total
number of blocks vary, depending on the PLC configured).  All PLCs require that
one of the blocks is _MAIN. This block is automatically created when you create a
new folder.

This chapter describes how to work with blocks using VersaPro Programming
Software.

Chapter Contents

• How to create and open blocks and objects

• How to manage blocks and related components in the folder browser

• How to work with variables associated with folder components.

• How to convert blocks between IL and LD

Chapter

3
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Creating, Inserting and Opening Blocks

VersaPro allows you to use multiple blocks per folder, one of which must always be
a _MAIN block. A name is always required in order for a block to be created. Note
that each PLC model has a different limit for the number of blocks, excluding
_MAIN, that can be created in a folder. (Series 90 Micro supports only a _MAIN
block.) More than one block can be open at once.

Once a block has been created, it can be called from within the _MAIN or any other
block. You can also call a block that does not yet exist, but that you intend to create.
When you compile, a syntax error appears, reminding you that the new block has not
been defined.

The following types of blocks can be created in VersaPro:

Block Type Supported by

Ladder Subroutine All, except Series 90 Micro
Instruction List Subroutine Series 90-30, VersaMax, VersaMax

Nano/Micro

External (C Block) Series 90-70
Series 90-30 models 350, 351, 352, 360,
363, and 364

Motion (Local Logic, Motion, and Cam
programs)

Series 90-30 DSM314 motion module

Creating a Subroutine

1. With a folder open, choose New from the File or Context-Sensitive menu. From
the Subroutine submenu, select Ladder or Instruction List. (You can also create
a Ladder subroutine by clicking the New Block button on the toolbar. 

The Create New Ladder Diagram or Create New Instruction List dialog box
appears.

2. On the Basic Properties tab, enter a unique name for the new block. Restrictions
on name entries.

If you are creating a timed interrupt block for a 90-30 PLC, the block name must
conform to the requirements for Timed Interrupt.

3. If you wish, enter a description for the block.

4. To assign Interrupt parameters to the block, select the Schedule tab. Double
click under the Type column to select I/O Interrupt or Timed Interrupt. For
details about the interrupt parameters, click the dialog box Help button.
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Note: For a 90-30 timed interrupt block, the block name determines the time base, delay, and
time interval parameters. If you change these values, an error message will appear when
you try to close the dialog.

5. To place restrictions on editing or viewing the block, select the Lock tab.

6. Click OK. A new block is created.

If the Folder Browser is open and a block is selected, the block is added to the
Folder Browser above the currently selected item. If the Folder Browser is
closed, or the Folder node, Hardware Configuration, or VDT in the browser is
selected, the block is added at the end of the browser.

Creating an External C Block

Note: The C executable file must be created using the C Programmer’s
Toolkit for Series 90 PLCs. Also, it must be created specifically for the
target PLC (90-70 or high-end 90-30). 90-30 C blocks do not use
input/output parameters.

1. With a folder open, choose New, External from the File or Context-Sensitive
menu. The Create New C Block dialog box appears.

2. On the Basic Properties tab, enter a unique name for the new block. Restrictions
on name entries.

3. If you wish, enter a description for the block. Restrictions on Descriptions..

4. To associate a C executable file (.exe) to the block, select the C Binary tab. To
locate the C program that you want to use, click the browser button next to the
Update Using field.

5. To assign Interrupt parameters to the block, select the Schedule tab. Double
click under the Type column to select I/O Interrupt or Timed Interrupt. For
details about the interrupt parameters, click the dialog box Help button. (A C
block can have either Interrupt parameters or Input/Output parameters, not
both.)

6. To assign Input/Output parameters to the block, select the Parameters tab. Up to
seven parameter pairs can be assigned to an external C block for 90-70.

7. Click OK. A new block is created.

If the Folder Browser is open and a block is selected, the block is added to the
Folder Browser above the currently selected item. If the Folder Browser is
closed, or the Folder node, Hardware Configuration, or VDT in the browser is
selected, the block is added at the end of the browser.
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90-30 Timed Interrupt Block Name Requirements

For the 90-30 PLC, Timed Interrupt blocks are defined and named in the form
"pTiiii" where p is the time base and iii is the time interval.

If p is 1, iiii can range from 0001 to 0010 (with block names 1T0001 to 1T0010).

If p is 2, iiii must be 0001 (with block name 2T0001).

Examples:

Block Name Time Base Initial Delay Time Interval

1T0005 .001 sec. 0 5 msec.

2T0001 .01 sec. 0 10 msec.

The Timed Interrupt block 1T0005 would be defined as follows: Time Base = .001 s; Initial Delay = 0;
Time Interval = 5 (5 msec).

The Timed Interrupt block 2T0001 would be defined as follows: Time Base = .01 s; Initial Delay = 0;
Time Interval = 1 (10 msec).

The Initial Delay for a 90-30 PLC Timed Interrupt block is always 0.

If a 90-30 PLC is declared in Hardware Configuration and the block is designated as a Timed Interrupt
block, but the name does not match the naming specification, an error is reported when you click OK
to close the Create new block dialog box.

Name Field Restrictions

• Only the characters A-Z, a-z, 0-9, and _ (no consecutive “_”s) are permitted.

• The block name must start with a letter or underscore.  Series 90-30 Timed
Interrupt Blocks follow different rules.

• A block cannot have the same name as another block that exists in the open
folder. An error appears if you enter a repeated name.

• The block name can be no longer than seven characters.

Description Field Restrictions

• The description may be up to 64 characters.
• There is no restriction on the type of characters that can be used in a description.

Inserting a Block from Another Folder
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You can copy blocks between folders using the Insert Block option.  The name of the
block you are inserting must be unique for the current folder.  If the block you want
to insert has the same name as an existing block, an error message will display.

When you add a block, the block's variables are added to the Variable Declaration
Table.

Perform the following steps to insert a block from another folder.

1. Open the folder into which you wish to insert a block, and go to the Folder
Browser.

2. Select the Insert menu and choose Block, or click the right mouse button and
select Insert Block. The Insert Block dialog box will appear.

3. In the Look In box, navigate to the folder containing the block you want to
insert.

4. Select the block type:
*.blk for LD, IL, Local Logic, or Motion blocks
*.exe for C blocks

5. To change the name of the block, edit name in the Insert As box.

6. To define variable offsets for the block, or add a prefix or suffix to the variable
names, select the Insert Block With Offsets checkbox, then click the Offsets
button.
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7. Make the needed changes in the Define Variable Offsets dialog box and click
Accept.

8. In the Insert Block dialog box, click Open.

The block is copied to the current folder's directory.

• If the Folder itself, Hardware Configuration, or the Variable Declaration table are
selected in the Folder Browser tree, the block is inserted at the bottom of the tree.

• If a block or view table is selected, the block appears above the selected item.

• If the inserted block has the same name as an existing block, an error message
appears.

• Adding a block includes adding the block's variables to the Variable Declaration
Table. If the block being inserted contains variables that conflict with existing
variables in the folder, the message, "Variable name/scope already exists in the
variable declaration table" appears. Clicking OK, opens the Variable Resolution
dialog box, which allows you to resolve variable conflicts. (See "Variable Resolution"
in chapter 6.)

• If you are inserting a “C” block, select the .exe file  you created using the C Toolkit.

Opening a Block

Once a block is part of the Folder Browser, you can open and edit the block at any
time.  Multiple blocks may be open at the same time.  To open a block in the Folder
Browser, select the block you want to open and double-click the block name.

Note: “C” blocks cannot be opened in VersaPro.
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Maximum Block Size

The following table lists maximum sizes for subroutine blocks.

VersaMax 16KB

VersaMax Nano/Micro 18KB

Series 90-30 16 KB for LD blocks
80 KB for C blocks

Series 90-70 32 KB for LD blocks
64 KB for C blocks

Inserting and Editing Objects

VersaPro allows you to associate objects with your folder.  For example, you can
insert an Excel spreadsheet, Word document or Access database file into your folder.
Once the object is associated with your folder, you can edit the object by double-
clicking in the Folder Browser.

To insert an object into a folder:

1. Open the folder into which you wish to insert an object. Go to the Folder
Browser.

2. Select the item below which you want to insert an object.

3. Select the Insert menu and choose Object, or click the right mouse button and
select Insert Object.  The Insert Object dialog box will appear.

4. Select the name and the location of the file you want to insert. VersaPro
component files (files with an extension of .blk, .fld, .hwc, .wvr, .wrt, or .vdt)
may not be inserted.

5. Click Open. The object is inserted.

To launch an inserted object:

1. Open the folder containing the object that you want to launch. Go to the Folder
Browser.

2. To open the object, double-click on the inserted object, or select the object using
the up or down arrow keys and then press Enter, or select the object , click the
right mouse button and choose Open.

If an application is associated with the folder type, the application will start up,
opening the selected object.  If no application is associated with the object, the
standard “Open With” Windows prompt will appear.
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Working with Blocks and Objects in the Folder Browser

VersaPro provides a flexible browser interface to manage the blocks, view tables,
variable declaration tables and objects associated with the folder.

This section describes how to manage the files and information associated with the
components in the Folder Browser.

Arranging Blocks

VersaPro allows you to change the order in which blocks are displayed and printed.
(Blocks are printed in the order they appear in the Folder Browser).  To rearrange the
order, simply select the component you want to move and then drag and drop it to
the new location.  You can also move blocks using standard Windows cut, copy and
paste commands.

Viewing and Modifying Block Properties

After a block is created, you can view and modify the block name, description and
type.

Perform the following steps to edit the properties of a block.

1. From the Folder Browser, select the block whose properties you wish to view.

2. Select the Edit menu and choose Properties, Block, or click the right mouse
button and choose Properties. The Properties dialog box will appear.
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3. Select the General Properties tab, which displays the block’s name, language,
type, description, and description. You can edit the Name and Description.

4. To define Timed Interrupts or I/O Interrupts, select the Schedule tab.

5. To lock or unlock the block, select the Lock tab.

Moving Folder Components

VersaPro allows you to determine the order in which folder components, including
logic blocks, are displayed and printed by dragging and dropping or cutting/copying
and pasting.

You can cut or copy IL, LD, Motion, and Local Logic blocks, and view tables, and
paste them in the same folder with a unique name or a repeated name with a suffix
number. You can also drag and drop, and rename blocks and view tables. Block
pasting and dropping works within and across folders. (_MAIN can be copied and
pasted, but not cut.) When you copy or move a block, its properties will be included.

You can copy and paste (or drag and drop) Cam blocks within a folder, but not
between folders.

You can copy and paste Hardware Configuration between folders, but not within the
same folder.
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Cutting Folder Components

Note: To cut a block, it must be closed.

1. Open the Folder Browser.

2. Select an item or number of items in the Folder Browser. The _MAIN block,
VDT, Hardware Configuration, and Folder node cannot be cut.

3. Choose Cut from the Edit or Context-Sensitive menu, click the Cut button
,or press Ctrl + X.

The selected item and its contents are moved to the clipboard. It may now be
pasted within other VersaPro folders or to another application.

Copying Folder Components

Note: To copy a block, it must be closed.

1. Open the Folder Browser.

2. Select an item or number of items in the Folder Browser. The Folder node and
the VDT cannot be copied.

3. Choose Copy from the Edit or Context-Sensitive menu, click the Copy button
,or press Ctrl + C.

The selected item and its contents are copied to the clipboard. They may now be
pasted within other VersaPro folders or to another application.

Pasting Folder Components

1. Cut or copy an item from the Folder Browser.

2. In the same or another folder, select an item above which you wish to paste the
cut or copied item.

3. Select Paste from the Edit or Context-Sensitive menu, click the Paste button
, or press Ctrl + V.

4. If the item you are pasting has been copied from the same folder, a dialog
appears asking you to provide a new name for the item.

5. Type a new name for the item, then click OK.

The item is pasted above the selected item in the Folder Browser.
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Dragging and Dropping in the Folder Browser

You can use drag and drop to move or copy a components within a folder or between
VersaPro folders. The following drag and drop operations are allowed:

• Moving blocks, Reference View Tables and Variable View Tables within a folder
browser (changing order)

• Copying the _MAIN block to a different folder (must rename the copy of _MAIN)

• Moving or copying blocks, Reference View Tables, and Variable View Tables
between folders

• Copying Hardware Configuration between folders

Note: To drag and drop a block, it must be closed. Drag and Drop works only within VersaPro.
Items are not placed on the clipboard and are not available to other Windows
applications.

You cannot drag and drop the folder’s root node.

Moving Folder Components

1. Select (highlight) an item in the Folder Browser.

2. Click and hold on the selected item. (The selected item is highlighted.)

3. Drag the image of the selected item to the desired location in the same or
another folder.

4. Drop the image by releasing the mouse button.

The selected item and its contents are moved to the new location.

If you are dragging from one instance of VersaPro to another, and the drop
action that you are attempting involves a conflict in variables (for instance, if
you are copying a Reference View Table that contains a variable already defined
in the target folder's VDT), the Variable Resolution dialog box appears so that
you can change the conflicting variable to eliminate the conflict. You can
change the variable name, type, length, or scope, then click OK. Or, click
Cancel to cancel the drag and drop operation.

Copying Folder Components

1. Select (highlight) an item in the Folder Browser.

2. Press and hold the Ctrl key.

3. Click and hold on the selected item. (The selected item is highlighted.)
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4. Drag the image of the selected item to the desired location in the same or
another folder.

5. Drop the image by releasing the mouse button and the Ctrl key.

Variable conflicts are handled the same as for components being moved.
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Deleting a Block

If you decide that a block is no longer desirable within a folder, you can delete it. If
the block is _MAIN, it cannot be deleted, but the same procedure allows you to clear
any contents from _MAIN. Deleting a block does not delete global variables from
the Variable Declaration Table, but it does delete local variables.

To delete a block or View Table:

1. Open the folder from which you wish to delete a block. The folder must contain
multiple blocks.

2. Make sure that the block to be deleted is closed.

3. Select any block except _MAIN in the Folder Browser tree.

4. Choose Delete from the Edit or the Context-Sensitive menu, click the Delete
button , or press the Delete key.

5. A warning message appears asking if you are sure you want to perform this
operation. If you click OK, the block is deleted from your folder and removed
from the browser tree.

In the future, any reference to the deleted block will produce a warning at syntax
check.

Global variables contained in a deleted block are not deleted from the Variable
Declaration Table, but local variables are.

To delete the contents of the _MAIN block:

1. Open the folder from which you wish to delete the contents of _MAIN. Select
_MAIN in the Folder Browser.

2. Press the Delete key, or click the delete toolbar button  . You will be
prompted that the contents of _MAIN will be cleared.

3. Click OK. _MAIN is cleared of all logic and the Block Description is cleared.
Other blocks in the folder are kept intact and are unaffected by this operation.
Variables local to _MAIN are deleted.  Global variables are not deleted from the
Variable Declaration Table.
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Saving a Block

VersaPro allows you to save the selected block to its current location. If the VDT or
the Folder Browser have changed, they are also saved.

To save a block

1. Select the block you wish to save.

2. From the File menu, choose Save. (This option is available only if the selected
block has changed since the last save.)  The active block and any changed items
(VDT, folder) are saved.

Closing Blocks

You may wish to close a selected block, or close all open blocks, but leave other
windows (for example, the VDT and Folder Browser) open.

• To close a block: Select the block you want to close.  From the File Menu, choose
Close.  The selected block will close.

• To close all blocks:  Select the Window menu and choose Close All.  If a block
contains unsaved changes, you will be prompted to save changes before closing the
block.

• Click Yes to save the changes and close the block.

• Click No to close the block without saving.

• Click Cancel to leave the block open.
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Using Editing Operations on Folder Components

VersaPro allows you to use any of the standard editing commands to cut, copy and
paste information. VersaPro also supports undo and redo to manage changes made to
folder components.

This section describes how to use windows-standard commands to manage data and
changes in the VersaPro Folder Browser.

Using Undo and Redo

VersaPro allows you to undo or redo certain actions (like placing an element or
deleting a row) in Hardware Configuration, in the Variable Declaration Table, in the
Variable View Table, and in the IL Editor or LD Editor.

You can undo or redo actions using the standard menu commands, keyboard shortcut
keys, or toolbar buttons.

The number of undo/redo operations supported can be set to a value between 1 and
100 (the default is 10). To adjust the number of undo/redos supported by VersaPro,
select the Tools menu and choose Options.  If you are about to perform an action
which, due to its complexity or the amount of data involved, cannot be undone, a
message box will appear, warning you of this fact.

• To undo an action: Click the Undo toolbar button. , select the Edit menu
and choose Undo, or press Ctrl+Z.  The Undo menu option will be grayed out if
there is no previous undo operation to perform.

• To redo an action:  click the Redo button  , select the Edit menu and
choose Redo, or press Ctrl+Y. The Redo menu option will be grayed out if there
is no previous operation to redo.



3-16  VersaPro™ Programming Software User's Guide – October 2001  GFK-1670D

3   

Working with Variables while Editing Blocks

VersaPro allows you to create variables while you are working with logic. One way
to do this is to add a block with new variables to your logic. New variables included
in an added block are checked for validity. If they are valid, they are added to the
Variable Declaration Table and are available for use.

Temporary variables must be declared if you are using Instruction List for blocks.

To create a variable when adding a block:

1. Open a folder.

2. Add a block with defined variables to the folder.

3. Row validation is performed on each variable to check for global scope conflicts
with existing variables.

4. If a variable fails row validation, an error message appears describing the
problem.

5. Click OK A dialog box appears allowing you to correct the problem. If the
problem is corrected, row validation continues for other variables. If you click
Cancel, the variable is not added to the VDT, and the entire process is cancelled.
When row validation is completed and no conflicts exist, the Variable
Declaration Table is populated with original data and with data from the added
block.

To assign temporary variables:

1. Open a folder. Choose Properties from the Edit menu or from the Context-
Sensitive menu in the Folder Browser.

2. The Properties dialog box appears.

3. Select the Temporary Variables tab.

4. Select the Temporary Variables (IL) radio button.

5. The starting address fields for Boolean and Integer variables become enabled.

Note: If at any point you wish to delete the current temporary variables, you can do so by
selecting the No Variables (IL) radio button. The memory areas used for Temporary
variables may not overlap with those used for Conversion variables.
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6. To assign temporary Boolean variables, enter a valid starting bit address.

• Boolean Temporary variables can only be assigned in the %M, %Q and %T
Memory areas.

• Boolean Temporary variables must start on a byte-aligned address (for
example: 1, 9, 17, etc.) and use 8 bits of memory.

7. To assign integer temporary variables, enter a valid starting word address.

• Integer Temporary variables can only be assigned in the %R, %AI and
%AQ Memory areas and use 2 words of memory.

• Starting and ending address values must be in the range 1 - 99,999

• Neither starting address field may be left empty. As you type each starting
address, its ending address is dynamically calculated and displayed in the
read-only field beneath it.

8. Click OK. If all starting and ending values are valid, the dialog box is closed and
the temporary variables are added to the VDT's Temporary tab. Syntax Check
checks for the appropriate creation and correct number of temporary variables.
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Searching and Replacing in VersaPro

VersaPro provides a number of tools to navigate, locate, and search for and replace
data in folder components. This section describes the methods of locating
information and using search and replace in the Folder Browser.

Navigating in VersaPro
There are several methods of finding and going to certain points in folder
components:

� Go To: This action allows you to go to a specific row or rung in language editors (IL
or LD), or to locate and go to the location of a specific variable.

� Find: This action allows you to locate variables, reference address or call references
in block logic.

� Edit Variable: Selecting this command from the IL or LD editor will take you to the
variable definition in the Variable Declaration Table.

Locating and going to a Rung, Row or Variable

You can use the Go To feature to change focus to a specific Rung (LD Editor), Row
(IL Editor) or Variable (Variable Declaration Table).

Follow the steps below to use the Go To feature:

1. Place the cursor in the LD Editor, IL Editor, or Variable Declaration Table.

2. Select the Edit menu and choose Go To (LD or IL Editor) or choose Go To
Variable (Variable Declaration Table).  The Go To dialog box will appear.

3. Complete the dialog box as described for the LD Editor, IL Editor or Variable
Declaration Table.  After entering the rung, row or name, click OK.

� LD Editor: Type the number of the rung you want to go to.

� IL Editor: Type the number of  the row you want to go to.

� Variable Declaration Table: Type the name of the variable you want to go to.



GFK-1670D  Chapter 3  Working With Blocks 3-19

  3

Locating Names, Instructions, Addresses or Call Statements in Blocks

You can use the Find In Blocks feature to find all occurrences of variable names,
reference addresses, instructions, or call subroutines in IL and LD blocks.

Follow the steps below to use the Find In Blocks:

1. From the Folder Browser or folder components, select the Edit menu and choose
Find In Blocks.  The Find In Blocks dialog box will appear.

2. Complete the dialog box as follows:  Click the Find button to start the search.

• Search By: Specifies what you are searching for

o Address: Select address to search for a reference address.

o Call Sub: Select Call Sub to search for a call to a subroutine block.

o IL Instruction: Searches for an Instruction List instruction.

o LD Instruction: Searches for a Ladder Diagram instruction.

o Name: Select Name to search for a variable name

• Search For Sets the address, block name, instruction, or variable name to be used in
the search.

• Blocks: Establishes the scope of the search.  Choose All blocks or Selected blocks
(searches all blocks currently selected in the Folder Browser)

• Outputs Only: Limits the scope of the search to references used as outputs only
(coils).  To limit the search to outputs only, check this box.

• Implicit Addresses: Allows you to locate logic where an address is used, but is not
referenced explicitly in the function block.  To search for implicit addresses, check this
box.
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The search is performed, and the results of the search appear in the Information
Window. Found items are listed by block, rung or row, and instruction. Double-
clicking an item in the Information window opens the appropriate block and selects
the matching element.

Using Search and Replace

VersaPro allows you to search for and replace elements in block logic. You can
search for variable names, reference addresses and other elements in block logic and
replace the search item with a new name or address.

Follow the steps below to use the Find/Replace feature.

1. Open the block you want to modify using search and replace. Select the Edit
menu and choose Find/Replace.  The Find/Replace dialog box will appear

2. Complete the dialog box as follows

• Search By:  Use this field to define what you are searching for.

o Address: Select address to search for a reference address.

o Call Sub: Select Call Sub to search for a call to a subroutine block.

o Name: Select Name to search for a variable name.

o Jump(n)/Label(n): Select this choice to search for a Jump or Label in your
program.

o MCR(N)/END_MCR(N): Select this choice to search for MCR/ENDMCR
functions in your program.

• Search For: Use this field to set the address, block name, variable name or label
to be used in the search/replace
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• Replace With: Enter the string, address, label or variable name which will be
used in the replace operation.

• Outputs Only: To limit the scope of the search to references used as outputs only
(coils), check this box.

• Implicit Addresses: To locate addresses which are included, but not named in a
function block (for example, in an array), check this box.

3. Select the action you want to perform:

• Find Next: Click this button to find the (next) instance of the search string in
your program.

• Replace: Click this button to replace the highlighted instance of the search
string in your program.

• Replace All Button: Click this button to replace all occurrences of the search
string in your program.

4. To close the Find/Replace dialog box, click the Cancel button.

Note: If a Find and Replace action has been specified during the current edit
session, you can use the Find Next to locate additional occurrences of
the search string using the Find Next command. To find the next
instance, select the Edit menu and choose Find Next, or press F3.
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Performing Syntax Checks

VersaPro provides syntax checking for logic blocks. Once you’ve created block
logic, you can check either portions of the folder or the entire folder (all blocks) for
syntax errors.

In a syntax check, instructions within your logic are compared against information
about the configured PLC.  Any unsupported instructions are flagged.

Syntax checking is automatically performed when you store or verify logic to the
PLC.

To manually initiate a syntax check perform the following steps:

• To Check All Blocks, go to the Folder Browser, click the right mouse button

and select Check All    or select the Check All Blocks toolbar button.

• To Check Selected Blocks, highlight the blocks you want to check in the Folder

Browser, click the right mouse button and select Check Selected Blocks  or
select the Check Selected Blocks toolbar button.

The block(s) are checked.  All warnings and errors are written to the Information
Window.

Note: You can navigate to the location of the syntax error by double-clicking
on the error in the Information Window.
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Converting Block Logic

VersaPro allows you to convert IL logic to LD logic (and from one editor) to
another. Most, but not every, formation in one language can be translated to the
other. Certain exceptional instructions may lead to errors upon attempted conversion.
Therefore, if you intend your logic to be translatable, avoiding a particular set of
instructions will minimize the errors you encounter. (See "Rules for Successful
Conversion" on page 3-25.)

Note: Blocks are converted on an instruction by instruction basis, so logic is
not optimized for the LD language.

Note: Series 90-70 and Series 90 Micro PLCs do not support IL
programming.

Assigning Conversion Variables

1. Open a folder.

2. From the Edit menu, choose Properties, Variable Table, or select the Variable
Declarations node and choose Properties from the CSM.

3. The Properties dialog box appears.

4. Select the Conversion Variables (LD) tab.

5. Select the Conversion Variables (LD) radio button.

6. The starting address fields for Boolean and Integer variables become enabled.

Note: If at any point you wish to delete the current temporary variables, you can do so by
selecting the No Variables (IL) radio button.

7. To assign Boolean variables, enter a valid starting bit address.

• Boolean conversion variables can only be assigned in the %M, %Q and %T
Memory areas and must start on a byte-aligned address (for example: 1, 9, 17,
etc.).

8. To assign integer variables, enter a valid starting word address.

• Integer conversion variables can only be assigned in the %R, %AI and %AQ
Memory areas.

• Starting and ending address values must be in the range 1 - 99,999

• Neither starting address field may be left empty.
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As you type each starting address, its ending address is dynamically calculated
and displayed in the read-only field beneath it.

9. Click OK.

If all starting and ending values are valid, the dialog box is closed and the
temporary variables are added to the VDT's Temporary tab.
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Converting Block Logic

Once conversion variables have been configured, you can select a block for
conversion.  Be sure to check the block's syntax before converting the block. (Select
Check Block or Check All from the Folder menu.)

1. Select a block in the Folder Browser, or make the block you want to convert the
active block.

2. Select the Tools menu and choose Convert Block.

The logic in the block you are attempting to convert is checked for syntactical
validity.  If the logic is found to be syntactically valid, the logic is converted from
one language to the other, and the details of the conversion appear in the Information
Window.

If any syntax errors are found, they are logged in the Information Window and the
conversion is aborted.

Rules for Successful Conversion

The following guidelines are suggested for successful block conversion:

• IL logic containing the following instructions cannot be converted to LD

o XOR, XORN, XOR(

o ANDN(, ORN(, XORN(

o NOT

• Use the Properties dialog box to define the use of temporary variables, which are
necessary for IL logic, and conversion variables, which are necessary whenever you
convert IL logic to the LD language.
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Converting Non-Nested Instructions

Series 90 Micro and low-end 90-30 PLCs support non-nested forms of the MCR,
ENDMCR, JUMP, and LABEL instructions. When you import a Logicmaster folder
containing non-nested instructions or convert a Series 90 Micro folder to a
VersaMax Nano/Micro folder, these instructions will not be automatically converted
to nested forms. To be able to compile your programs after conversion, you will need
to change these instructions to their nested forms (MCRN, ENDMCRN, JUMPN,
and LABELN).

To convert non-nested instructions, go to the Tools menu and select Non-Nested to
Nested Conversion. You will be prompted to indicate whether you wish to proceed
with the conversion. To proceed, click OK.

Note: All non-nested instructions will be converted to their nested forms. This
conversion may increase the size of the compiled logic. Also this
conversion cannot be undone.
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Working in the LD Editor

The LD Editor window allows you to create, edit, display and monitor programs and
blocks created in ladder logic.  This chapter introduces you to the LD Editor window
and how you can customize its look as well as how to create and edit logic.

Chapter Contents

• How to access the LD Editor

• An overview of the LD Editor Window

• How to customize the LD Editor Window display and set rung editing and coil
checking options

• How to enter and edit logic

Chapter

4
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Overview of the LD Editor

The Ladder Diagram Editor is used to create programs using the Ladder Diagram
programming language.  Ladder Diagram is used to graphically represent the actions
to be performed by a PLC.

The editor window is divided in to rows (rungs).  Each rung is divided into cells.
Each cell can accept a logic element (function block  or relay function.). The LD
Editor allows you to enter ladder logic elements via keyboard, mouse, or toolbar. All
elements are inserted by overwriting the contents of the selected cell.

The figure below shows some of the commonly-referenced components of the LD
Editor window and browser view.

Ladder Toolbar
Provides quick access to
frequently-used LD
functions

Function
Toolbars
Expanded View
Displays all
instruction
groups and
functions that
can be used in
the LD Editor.

Variable Declaration Table
Docked at the bottom of the folder
view, provides quick access to global
variables and local variables defined
for the active block.

Rung Number
Displays rung
number for each
discrete rung

Active Cell
Shows active
location for inserting
additional logic.

Comment Rung
Example of
comment rung,
configured for brief
display mode.
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Customizing the LD Editor Window

VersaPro allows you to select the format of information displayed in the LD Editor
window and control the grid and display size.

This section describes the elements of the LD Editor window which can be
customized.

Customizing Ladder display options

When working in the LD Editor, you may want to customize the fields which display
online.  Perform the following steps to customize Ladder display options:

1. Select the Tools menu and choose Options, or click the right mouse button from
the LD Editor and choose Options.  The Options dialog box will appear.  Select
the Ladder tab.
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2. Customize the display options to suit your needs:  Click the OK button to accept
changes.

• Show/Hide Field: Allows you to set the fields which will display in the LD
Editor window:

• Variable Name: You can set the display mode to brief or full by selecting
Variable Name and clicking the appropriate button in mode. checking the
appropriate button.  Brief mode displays one line, and full mode displays up to
two lines.

• Reference Address: To view the reference address associated with variables,
check this box.

• Description: To view the variable description, check this box.  If you want to see
the entire description, you may also need to increase the Grid Cell Width.  You
can also set the display mode to brief or full by checking the appropriate button.
Brief mode displays one line, and full mode displays up to four lines.

• Grid Cell Width: Allows you to make the grid for cells wider or narrower.  To
increase or decrease the width, slide the control between Min and Max.

• Coil Justification Column: If this box is checked, when you insert a coil, it is
placed in the column specified (right justified). Valid values are integers 10 to 20.
If this box is not checked, coils are inserted in the next empty column.

Adjusting the Zoom Ratio

You can increase or decrease the zoom ratio for the LD Editor by click the zoom
in/zoom out buttons.  To adjust the zoom ratio perform the following steps:

1. Make an LD block active

2. Select the View menu and choose Zoom In  or Zoom Out .  You can
also click the toolbar buttons.
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Entering Instructions and Instruction Parameters

This section describes how to enter and modify instructions and rungs in your ladder
program.  Program logic consists of elements such as relays, timers, math functions
and other functions placed together to form rungs of logic. Variables and constants
are assigned to function parameters as inputs and outputs to the function.

Variable Combo Box
Type a new variable
name, or click the arrow
and select from list

Typed Instruction

Constant

Function Block Parameters

 Function
Data  Length

Function
Address

The example above highlights some of the concepts and details you will encounter
entering logic in the LD Editor.

• Typed Instructions (Functions): In VersaPro, many function blocks are "typed".
This means that the type (INT, DINT, REAL) is associated with the function, not the
variable.

• Function Data Length: Many functions require a data length. The length is
associated with the function, not the variable.

• Function Address: Displays the reference address if required by the function block.

• Function Block Parameters: Input and Output parameters to function blocks must
be completed.  Many function block parameters require variables or constant values,
like the Add function.  Other function blocks require Boolean parameters (like
contacts) to enable or control how the function executes.
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• Variable Combo Box: When assigning variables to function block parameters, the
variable combo box allows you to quickly select existing variables or create new
variables.

Entering Instructions

There are several methods of entering instructions into the LD Editor to suit personal
preferences and editing styles.  With VersaPro, you can enter instructions using the
Function Toolbar, Ladder Toolbar or through direct keyboard entry (where no mouse
interaction is required).  This section describes the various ways you can enter
instructions into your program.

Entering Instructions using the Function Toolbar

The Function toolbar is used to select and add function blocks to your LD program.
The Function Toolbar can be displayed in either of two forms. The compact form,
which requires less room on the screen and the expanded form, which displays all the
groups and their functions.

Selecting Functions Using the Function Toolbar – Compact

The Function Toolbar, displayed in compact form, consists of a Group combo box,
an Instruction combo box, and a Function Drop button.  To select Compact form,
select the View Menu, choose Function Toolbars -> Compact.  The function toolbar
will appear above the LD Editor window.
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Function Groups
Click the arrow to select
a specific function
group, or to view all
function groups.

Function Drop Button
Click button to select function,
then click in the editor window
to drop the function into your
LD program.

Functions
Shows instructions
available for the active
Function Group.
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• To select a function group, click the arrow on the Function Groups box and choose a
function group.  To view all instructions, select All Function Groups.

• To select an instruction, click the arrow on the Functions box – use the mouse to scan
through the list or type the first few characters of the function name to locate in the
list.

• To drop the function in the LD Editor window, click the Function Drop Button,
position the cursor at the insert location in the LD Editor window, and click to drop
the function into your program.

Selecting Functions Using the Function Toolbar – Expanded

The Function Toolbar, displayed in expanded form, consists of a Group window and
Instruction window.  To select Expanded form, select the View Menu, choose
Function Toolbars -> Expanded.  The Group and Instruction windows will appear to
the right of the LD Editor window.

Instruction GroupFunction Group

• To select a function group, highlight the Function Group name in the Group window.
To view all instructions, select All Function Groups.

• To select an instruction, use the slide control to scan the list of instructions, locating
the instruction you want to add to your program.

• To drop the function in the LD Editor window, double click the instruction name
(notice that the cursor changes to a function block icon),  position the cursor at the
insert location in the LD Editor window, and click to drop the function into your
program.
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Entering Instructions using the Ladder Toolbar

You can use the Ladder Toolbar to select commonly-used Boolean functions,
comments and call instructions to your LD program.

To select one of the toolbar instructions, simply click the toolbar button, move the
cursor to the insertion point, and click to place the instruction.

The comment toolbar button places a comment at the current cursor location.

Note: When a function or instruction is selected, an instance of the function
will be inserted into your LD Program each time you click the mouse
button.  To de-select the active function, click the Normal Pointer
toolbar button.
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Entering Instructions using Keyboard Entry

It is possible to enter logic directly with the keyboard, rather than using the mouse.
Perform these steps to enter an instruction using keyboard entry:

1. Navigate to the cell where you want to insert an instruction.

2. Press Shift + Enter.  A combo box containing the list of all instructions will
appear. (If the cell is empty, simply press Enter.)

3. To locate the function, type the first few characters of the instruction name, or
use the arrow keys to scroll through the list.

4. Press Enter to select the name and insert the instruction into your program.

Completing Address and Length Information

Certain function blocks require you to supply a length (for example, a Move
Instruction) or  an address (for example, a Timer Instruction) for the function to
operate correctly.  Functions which require this information will display ?? inside the
function block.  Perform the following steps to complete address or length
information:

1. Enter a function which requires address or length information.  Notice the ??
fields on the function block.

2. Double-click the ?? area or select the function and press Enter. The Function
Properties dialog box will appear so that you can enter a length and/or address,
as appropriate.
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3. Type a length or address, depending on the active parameter in the Function
Properties dialog box. Click OK when the information is complete.

4. The function will display the length and/or address supplied in the Function
Properties dialog box.

Completing Function Block Parameters

After a function block, coil or contact is added to the program, you need to assign a
variable or constant to each parameter. This section describes how to complete
function block parameters in one of the following ways:

• Assign an existing variable to a parameter

• Creating a new variable for a parameter

• Assigning a constant value to a parameter

Assigning Variables to Function Block Parameters

Variables can be assigned to elements and parameters in ladder logic. Variables may
be Local Scope (local to the block) or Global Scope (Global to all blocks in the
folder).  The default scope for variables is Global Scope.

You may assign an existing variable or create a new variable for the function block
parameter.  This section describes how to assign variables to parameters using the
mouse and the keyboard.

Note: You can also drag and drop selected variables from the Variable
Declaration Table to the function block parameter.

Note: Declaration of variables with overlaps will result in conflicts when you
attempt to Store the stored values to the PLC.  In order to resolve these
conflicts, you must use the VDT to relocate variables so that they do
not overlap. (For example a variable at %R8 with length 3 and a
variable at %R10 of length 2 have an overlap at %R10.)
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To assign an existing variable using keyboard entry:

1. Use the arrow keys to position the cursor on the parameter where you want to
assign a variable.

2. Type or select the variable as follows:

• To select a variable from the list of defined variables, press Enter.  The variable
combo-box will appear.  Use the up and down arrow keys to display the variables.
When you find the variable you want to use, press Enter to accept.

• To enter a variable by name, simply type the variable name.  Press Enter to accept.

To assign an existing variable using the mouse:

1. Double-click on the parameter cell where you want to assign a variable.  The
variable combo-box will appear.

2. To expand the variable list, click the arrow on the combo-box.  Use the slide
control to scroll up and down through the list.

3. Select the variable from the list.  Press Enter, or click outside the parameter cell
area to accept.

To create a new variable for a function block parameter

1. Select the parameter cell using the keyboard or mouse

• Keyboard Select: Use the arrow keys to position the cursor on the parameter where
you want to assign a variable.  Press Enter.  The variable combo-box will appear.

• Mouse Select: Double-click the parameter cell.  The variable combo-box will appear.

2. Type a variable name, reference address and scope (optional) into the edit box
using the following guidelines.  (Fields must be separated by commas.)

• The following example shows creating a variable "LINE2_COUNT" for parameter
IN2 of the ADDINT Function.
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 Variable Combo Box:
 Creating Variable "LINE2_COUNT",
 Reference Address %R00300,
 Local Scope

3. To accept the variable, press the Enter key – or use the mouse to click off the
active cell.

Note: To edit information for an existing variable, select the variable in the
LD Editor, click the right mouse button and choose Edit Variable. The
variable will be highlighted in the Variable Declaration Table, allowing
you to edit information about the variable.

The exceptions in changing LD logic involve replacing existing variables.  When a
variable is  replaced, information about that variable is still retained in the Variable
Declaration Table. If you replace the existing variable with a new variable, the new
variable information is added to the Variable Declaration Table.  In some cases, a
constant can be replaced by a variable.

You can replace a variable (or constant) either with an existing variable, or with a
new variable.

To replace a variable with an existing variable in LD:

1. Select the parameter cell using the keyboard or mouse

• Keyboard Select: Use the arrow keys to position the cursor on the parameter where
you want to assign a variable.  Press Enter.  The variable combo-box will appear.  The
current variable or constant will display in the edit field.

• Mouse Select: Double-click the parameter cell.  The variable combo-box will appear.
The current variable or constant will display in the edit field.

2. Type the name of the replacement variable, or enter a constant. Press Enter to
accept.
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Assigning Constants to Function Block Parameters

Constants can be assigned to functions and parameters in ladder logic. Constant
values are displayed during monitoring, in the default type format of the element in
which each is used.

To assign a constant using keyboard entry:

1. Use the arrow keys to position the cursor on the parameter where you want to
assign a constant.

2. Type the constant value. Press the Enter key.  If the constant is not valid for the
function block an error message will appear.

To assign a constant using the mouse:

1. Click the arrow button   to de-select any active functions. Double-click on
the parameter cell where you want to assign a variable.  The variable combo-box
will appear.

2. Type the constant value.  Press the Enter key.  If the constant is not valid for the
function block an error message will appear.

Rules on constants

A constant’s value may not exceed the capacity of the operand’s type and must be
entered in a format consistent with the Function Block type:

Format Prefix Example

Decimal (default) None 43

Real None 43.72

Scientific None 6.93e4

Binary 2# 2#11110000

Octal 8# 8#730

Hexadecimal 16# 16#dc4b
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Editing Ladder Logic

Once logic is in your LD program, you may need to edit, copy, or delete sections of
logic.  This section describes how to select logic in the LD editor, and how to delete,
copy and paste selected logic.

Selecting Logic

Before you can perform editing operations on LD logic, you need to select the logic
you plan to work with.  This section describes how to select logic using the mouse
and keyboard.

To set a selection in the Ladder Editor using the mouse:

1. Make sure placement mode is off by clicking on the arrow button (normal
pointer) on the Ladder toolbar. 

2. Place the mouse pointer over a cell or over the power rail next to a rung.

3. Press and hold the primary mouse button.

4. Drag the mouse to move the selection over the desired cells, or along the power
rail over the desired rungs.

5. To select non-contiguous rungs, hold down the Ctrl key while selecting rungs.
The desired rungs are selected.

To set a selection in the Ladder Editor using the keyboard:

1. Make sure placement mode is off by pressing Esc.

2. Select cells:

• To select a single cell, navigate to the desired cell and press the spacebar.

• To select a group of cells, navigate to a cell, then hold down the Shift key while using
navigation keys to move the selection over the desired area.

• To select a single rung, navigate to the power rail and press Ctrl + the spacebar.

• To select a contiguous group of rungs, navigate to the power rail. The entire rung is
implicitly selected. To select more rungs, hold down the Shift key and use the up or
down arrow keys to move the selection over contiguous rungs.

• To select non-contiguous rungs, select a single rung, hold down the Ctrl key, navigate
to another rung, and press the spacebar.  The rungs are selected.
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Using Cut, Copy, Paste and Delete in the LD Editor

In the LD Editor, you can cut or copy rung(s) or cell(s) from one portion of a ladder
to another portion, or from one block to another, without removing the variables
included in those rungs or cells from the Variable Declaration Table.

You can also delete selected rungs or cells.

Logic cannot be pasted from LD blocks to IL blocks, nor can you paste LD logic to
applications other than VersaPro. You can, however, copy ladder logic as a bitmap
image.

You can paste a variable from the VDT to the LD Editor.

This section describes the different ways you can perform cut, copy, paste, and drag-
and-drop in the LD Editor window.

To cut or copy in the LD Editor:

1. Open the LD block you want to edit. Select rung(s) or cell(s) you want to copy
or cut.

2. Choose Cut or Copy from the Edit or right mouse menu, click the Cut  or
the Copy  button on the Standard toolbar, or press Ctrl+C to Copy or Ctrl+X
to Cut. The selected information is cut or copied to the Clipboard.

To cut or copy in the LD Editor using Drag and Drop:

1. Open the LD block you want to edit. Select rung(s) or cell(s) you want to copy
or cut.

2. To Cut (using drag and drop), position the mouse arrow over the selected logic,
press down and hold down the primary mouse button.

To Copy (using drag and drop), position the mouse arrow  over the selected
logic, press and hold the CTRL key, then press and hold the primary mouse
button.

3. Move the logic to the appropriate area.  To drop the selection, release the mouse
button and/or the Ctrl key.

To copy as a bitmap in the LD Editor:

1. Open the LD block you want to edit. Select rung(s) or cell(s) you want to copy.

2. Select the Edit menu and choose Copy As -> Bitmap.

3. The selected information is copied to the Clipboard as a bitmap image.  This
image may be pasted into any application which recognizes the bitmap image.
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To paste in the LD Editor:

1. Open the LD block you want to edit. Select rung(s) or cell(s) you want to copy.

2. Select the Edit menu and choose Paste , click the Paste toolbar button or
press Ctrl+V.

3. The elements are pasted into the ladder.  The paste operation overwrites any
elements previously existing in the destination cells. Existing comments, Labels,
or MCRs are shifted down in order to accommodate a pasted element(s).

To delete one or more elements:

1. In the LD Editor, select a row or a group of rows, a cell or rectangular group of
cells, or one or more rungs.

2. Select the Edit menu and choose Delete, click the Delete button  on the
toolbar, or press the Delete key.  The selection is deleted. Variables defined in
the deleted logic remain in the VDT.

Note: Cut/Copy/Paste/Delete actions may be undone by selecting the Edit
menu and choosing Undo, or by clicking the Undo toolbar button..

Inserting an empty row in the LD Editor

Perform these steps to insert an empty row into the LD Editor.

1. Open the block you want to edit.

2. Select any instruction in the row above which you wish to insert an empty row.

3. Select the Insert menu and choose Row, press the Insert key, or click the right
mouse button and select Insert Row.  An empty row is inserted above the
selected row. All subsequent rows move down one row. The cell in the new row
immediately above the insertion point is selected.  If a cell in the first row of the
rung is selected, the new row is appended to the previous rung. If a cell in the
first row of the first rung is selected, a new rung is created above the first rung.

To go to the next coil:

In the LD Editor, select a contact or coil.

Choose Go to the Next Coil from the Edit menu or the CSM (or press Alt + F3.)

The cursor will go to the next coil that has the same name as the contact or coil you
started from.
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Working in the Instruction List Editor

The Instruction List Editor window allows you to create, edit, display and monitor
programs and blocks created in Instruction List.  This chapter introduces you to the
IL Editor window and how you can customize its look as well as how to create and
edit logic.

Chapter Contents

• How to access the IL Editor

• An overview of the IL Editor Window

• How to customize the IL Editor Window display

• How to enter and edit logic

• Details about Instruction List Operation

Chapter

5
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Overview of the Instruction List Editor

The Instruction List Editor is used to create programs using the Instruction List
programming language.  Instruction List is a text-based language which consists of a
series of instructions, which combined, represent actions to be performed on a PLC.

Instruction List Editor Window:
Displays IL Logic.  Columns include Label, Instruction,
Operand, Reference Address, Value and Comment.

Active Cell:
To change the
contents of the
active cell, double
click the cell.
A combo-box will
appear, displaying
valid choices
based on the
insertion point.

Row Numbers:
Lists the number for
each row in the IL Editor

Variable
Declaration Table
Lists all variables
which can be used in
your IL logic.

The IL Editor contains the following columns/fields:

• Label: Displays a label that can be referenced by a JUMP instruction.

• Instruction: Displays the function name. Instructions are entered by clicking on
the Instruction field and then typing or selecting from the drop-down list.

• Operand: Displays the variables or constants used by the instruction. Operands
are entered by clicking on the field and then typing or selecting from the drop-
down list. This list only displays variables appropriate to this type of instruction.

• Reference Address: Displays the memory location of the operand.

• Value: The actual value of the operand in the PLC.

• Comment: Displays an optional comment about the instruction.
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Customizing the IL Editor Display

You can customize font selection and color for the IL Editor.  Perform the following
steps to customize the display:

1. From the Folder Browser, click the Tools menu and select Options.  The
Options dialog box will appear.  Select the Display tab.

2. You can change the font selection and change the colors used for the display of
online values (animate), background display color and color used to display
comments.

3. Make the desired changes.  Click OK to accept.
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Entering Instructions and Instruction Parameters

This section describes how to enter and modify IL logic.  Instructions consist of
program elements to perform Boolean logic and execute functions such as timers,
math functions and other functions.  Variables and constants are assigned as
operands for the instruction.

Selecting the Instruction

Instructions are selected directly in the IL Editor window.  To add a new instruction
or change an existing instruction, perform the following steps:

1. Select the location where you want to add a new instruction or modify an
existing instruction.

2. Double-click the cell.  The Instruction combo-box will appear, as shown below.

3. Select the instruction.  Functions are identified as FUNCTION_NAME{.  If a
function is selected, parameters will appear between the brackets framing the
function block.

4. The new instruction is inserted into the IL program.
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Completing Address and Length Information

Certain instructions require you to supply a length (for example, a Move Instruction)
or an address (for example, a Timer Instruction) for the instruction to operate.
Instructions which require this information will show a Length or Address field in
the Instruction column as shown below.  Simply enter a length or address, as
appropriate.

The MOVE_INT
instruction
requires a length
to operate
correctly.

The TMR_HUND
instruction
requires an
address to
operate correctly.

Completing Instruction Parameters

After an instruction is added to the program, you need to assign a variable or
constant to each instruction operand. This section describes how to complete
instruction operands in one of the following ways:

• Assign an existing variable to an operand

• Creating a new variable for an operand

• Assigning a constant value to an operand

Assigning Variables to Instruction Operands

Variables can be assigned to instruction operands. Variables may be Local Scope
(local to the block) or Global Scope (Global to all blocks in the folder).  The default
scope for variables is Global Scope.

You may assign an existing variable or create a new variable for the instruction
operand.  This section describes how to assign variables to parameters using the
mouse and the keyboard.
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To assign an existing variable using keyboard entry:

1. Use the arrow keys to position the cursor on the operand where you want to
assign a variable.

2. Type or select the variable as follows:

• To select a variable from the list of defined variables, press Enter.  The variable
combo-box will appear.  Use the up and down arrow keys to display the
variables.  When you find the variable you want to use, press Enter to accept.

• To enter a variable by name, simply type the variable name.  Press Enter to
accept

To assign an existing variable using the mouse:

1. Double-click on the operand where you want to assign a variable.  The variable
combo-box will appear.

2. To expand the variable list, click the arrow on the combo-box.  Use the slide
control to scroll up and down through the list.

3. Select the variable from the list.  Press Enter, or click outside the operand  area
to accept.

To create a new variable for an instruction operand

1. Select the instruction operand using the keyboard or mouse

• Keyboard Select: Use the arrow keys to position the cursor on the operand
where you want to assign a variable.  Press Enter.  The variable combo-box will
appear.

• Mouse Select: Double-click the operand.  The variable combo-box will appear.

2. Type a variable name, reference address and scope (optional) into the edit box
using the following guidelines.  (Fields must be separated by commas.)

• The following example shows creating a variable "p1_count" for parameter IN
of the MOVE_INT Function.
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3. To accept the variable, press the Enter key – or use the mouse to click off the
active cell.

Assigning Constants to Instruction Operands

Constants can be assigned to instruction operands.

To assign a constant using keyboard entry:

1. Use the arrow keys to position the cursor on the instruction operand where you
want to assign a constant.

2. Type the constant value. Press the Enter key.

Rules on constants

A constant’s value may not exceed the capacity of the operand and must be entered
in a format consistent with the instruction type.

Format Prefix Example

Decimal (default) None 43

Real None 43.72

Scientific None 6.93e4

Binary 2# 2#11110000

Octal 8# 8#730

Hexadecimal 16# 16#dc4b
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Using Cut, Copy, Paste and Delete in the IL Editor

In the IL Editor, you can cut or copy row(s) or cell(s) from one portion of Instruction
List logic to another portion, or from one block to another, without removing the
variables included in those rungs or cells from the Variable Declaration Table.

You can also delete selected rungs or cells.

This section describes the different ways you can perform cut, copy, paste, and drag-
and-drop in the IL Editor window.

To cut or copy in the IL Editor:

1. Open the IL block you want to edit. Select row(s) or cell(s) you want to copy or
cut.

2. Choose Cut or Copy from the Edit or right mouse menu, click the Cut  or

the Copy  button on the Standard toolbar, or press Ctrl+C to Copy or Ctrl+X
to Cut. The selected information is cut or copied to the Clipboard.

Note: You can only copy a part of a multi-row instruction as text.  If you
copy a single row of a multi-row instruction, the selection cannot be
pasted back into VersaPro.

To cut or copy in the IL Editor using Drag and Drop:

1. Open the IL block you want to edit. Select row(s) or cell(s) you want to copy or
cut.

2. To Cut (using drag and drop), position the mouse arrow over the selected logic,
press down and hold down the primary mouse button.

To Copy (using drag and drop), position the mouse arrow over the selected
logic, press and hold the CTRL key, then press and hold the primary mouse
button.

3. Move the logic to the appropriate area.  To drop the selection, release the mouse
button and/or the Ctrl key.

To copy as tab-delimited text for pasting into another application:

1. Open the IL block you want to edit. Select row(s) or cell(s) you want to copy.

2. Select the Edit menu and choose Copy as Text.

3. The selected information is copied as tab-delimited text, and becomes available
for pasting into any application that accepts tab-delimited text.
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Instruction List Operation

The IL programming language is an Accumulator based language. The instructions
executed by the IL program modify or use an Accumulator that is located in PLC
memory. The Accumulator also has a Type associated with it that has been set by an
operator or Function call.

The operators that can be used in an IL program are listed in the following table.
Since IL is an accumulator-based programming language, the operators work directly
on the Accumulator. Comparison operators have a Boolean (1 or 0) result depending
upon the result of the operation. Operands for IL instructions can be in the form of
Variables, References, or Constants. Operators and Functions are unconditionally
executed when encountered in the IL program. That is, an instruction  is executed
regardless of the result of a previous instruction.

The LD* (Load) operators are used to set the contents of the accumulator to the
value of the variable or constant specified by the operand. The LD operators also set
the Type of the accumulator. The ST* (Store) operators are used to set the value of
the variable specified by the operand to the contents of the accumulator. The
remainder of the operators manipulate the contents of the accumulator or perform an
action based on the accumulator’s value. For the Math and Relational operators, the
type of the accumulator must be Integer.

Operator Operand Description / Affect upon Accumulator

 LD_BOOL Discrete Variable or Ref
Address

Accumulator := Boolean Variable
Load the contents of the Boolean variable into the
Accumulator. Accumulator Type set to Boolean.

 LDN_BOOL Discrete Variable or Ref
Address

Accumulator := NOT Variable
Load the negative contents of the Boolean variable into
the Accumulator.
Accumulator Type set to Boolean.

LD_INT Variable, Ref Address, or
constant

Accumulator := Integer Variable
Load the contents of the Integer variable into the
Accumulator. Accumulator Type set to Integer.

LD_ENO None Accumulator := Boolean ENO
Load the contents of the ENO (Enable Output) from the
last Function or Function Block call into the
Accumulator.
Accumulator Type set to Boolean.

ST_BOOL Discrete Variable or Ref
Address

Variable := Boolean Accumulator
Store the contents of the Boolean Accumulator to the
Boolean variable.
Accumulator value and Type are unchanged (Boolean).

STN_BOOL Discrete Variable or Ref
Address

Variable := NOT Boolean Accumulator
Store the negative contents of the Boolean Accumulator
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to the Boolean variable.
Accumulator value and Type are unchanged (Boolean).

ST_INT
ST_DINT
ST_REAL
ST_WORD

Variable or Ref Address Variable := Integer Accumulator
Variable := Double Integer Accumulator
Variable := Real Accumulator
Variable := Word Accumulator
Store the contents of the Integer, Double Integer, Real,
or Word Accumulator to the variable.
Accumulator value and Type are unchanged.

S Discrete Variable or Ref
Address

Set Coil Variable := Boolean Accumulator
Store the contents of the Boolean Accumulator to the Set
Coil Boolean variable.
Accumulator value and Type are unchanged (Boolean).

R Discrete Variable or Ref
Address

Reset Coil Variable := Boolean Accumulator
Store the contents of the Boolean Accumulator to the
Reset Coil Boolean variable.
Accumulator value and Type are unchanged (Boolean).

NT Discrete Variable or Ref
Address

Negative Transition Variable := Boolean Accumulator
Store the contents of the Boolean Accumulator to the
Negative Transition Coil Boolean variable.
Accumulator value and Type are unchanged (Boolean).

PT Discrete Variable or Ref
Address

Positive Transition Variable := Boolean Accumulator
Store the contents of the Boolean Accumulator to the
Positive Transition Coil Boolean variable.
Accumulator value and Type are unchanged (Boolean).

NOT None Accumulator := NOT Accumulator
Invert the Boolean state of the Accumulator.
Accumulator Type unchanged (Boolean).

AND
ANDN
AND(

Discrete Variable or Ref
Address

Accumulator := Accumulator AND Boolean Variable
Accumulator := Accumulator AND NOT Boolean
Variable
Accumulator := Accumulator AND Boolean expression
Accumulator Type unchanged (Boolean).

OR
ORN
OR(

Discrete Variable or Ref
Address

Accumulator := Accumulator OR Boolean Variable
Accumulator := Accumulator OR NOT Boolean
Variable
Accumulator := Accumulator OR Boolean expression
Accumulator Type unchanged (Boolean).

XOR
XORN

Discrete Variable or Ref
Address

Accumulator := Accumulator XOR Boolean Variable
Accumulator := Accumulator XOR NOT Boolean
Variable
Accumulator Type unchanged (Boolean).

ADD Variable, Ref Address, or
Constant

Accumulator := Accumulator + operand
Accumulator Type unchanged (Integer).

SUB Variable, Ref Address, or
Constant

Accumulator := Accumulator - operand
Accumulator Type unchanged (Integer).

MUL Variable, Ref Address, or
Constant

Accumulator := Accumulator * operand
Accumulator Type unchanged (Integer).

DIV Variable, Ref Address, or
Constant

Accumulator := Accumulator / operand
Accumulator Type unchanged (Integer).
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MOD Variable, Ref Address, or
Constant

Accumulator := Accumulator  MOD operand
Accumulator Type unchanged (Integer).

GT Variable, Ref Address, or
Constant

Accumulator := (Accumulator > operand)
Accumulator Type set to Boolean.

GE Variable, Ref Address, or
Constant

Accumulator := (Accumulator >= operand)
Accumulator Type set to Boolean.

EQ Variable, Ref Address, or
Constant

Accumulator := (Accumulator = operand)
Accumulator Type set to Boolean.

NE Variable, Ref Address, or
Constant

Accumulator := (Accumulator != operand)
Accumulator Type set to Boolean.

LE Variable, Ref Address, or
Constant

Accumulator := (Accumulator <= operand)
Accumulator Type set to Boolean.

LT Variable, Ref Address, or
Constant

Accumulator := (Accumulator < operand)
Accumulator Type set to Boolean.

RET
RETC
RETCN

None Unconditional Return from Block
Return from Block if Boolean Accumulator has value of
1
Return from Block if Boolean Accumulator has value of
0

JMP
JMPC
JMPCN

Label Unconditional Jump to label
Jump to label if Boolean Accumulator has value of 1
Jump to label if Boolean Accumulator has value of 0

CAL
CALC
CALCN

Subroutine Name Unconditional Call Block
Call Block if Boolean Accumulator has value of 1
Call Block if Boolean Accumulator has value of 0

FUNC_NAME(
  IN1:=
  IN2:=
  Q2=>
)

Variable, Ref Address, or
Constant, dependent upon
type of the function
parameters.

Call built-in PLC Function.
Accumulator value and Type are set to value and type of
Output parameter Q1, if it exists.

) End of Boolean nested operation.
Accumulator value and Type are unchanged (Boolean).

Constants

The IL editor supports the following constants for use as operands : Integer, Real,
Real with exponents, Base 16 (16#xxxx), Base 8 (8#xxx), and Binary (2#xxxxxxxx).
To use a Constant of 1 or 0 for an operand used with a Boolean operator, the
ALW_ON (1 or TRUE) and ALW_OFF (0 or FALSE) System variables must be
used.
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Functions

Functions are invoked using formal input lists. Functions are also unconditionally
executed, regardless of the result of a previous instruction. Functions usually place
their result in the Accumulator. The type of the accumulator is also usually
determined by the function.

Function Blocks

Function Blocks are also invoked using formal input lists. Function Blocks are also
unconditionally executed, regardless of the result of a previous instruction. Function
Blocks usually place their result in the Accumulator. The type of the accumulator is
also usually determined by the function block. The Address of a Function Block is an
input parameter.
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PLC Built-in Functions and Function Blocks

The following PLC Built-in Functions and Function Blocks can be called by the IL
program. The resulting Accumulator’s value and Type are also specified for each
function and function block. A Yes in the ENO column indicates that the function or
function block sets the ENO (Enable Output) variable. The table also indicates
whether the function or function block requires the accumulator to be initialized by
placing an LD Bool instruction in front of the function block.

Function or Function Block ENO Requires
LD Boolean
Instruction

Resulting Accumulator
Value and Type

Timers and Counters (Function Blocks)

ONDTR_TENTHS

ONDTR_HUNDS

ONDTR_THOUS

TMR_TENTHS

TMR_HUNDS

TMR_THOUS

OFDT_TENTHS

OFDT_HUNDS

OFDT_THOUS

UPCTR

DNCTR

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

N/A

N/A

N/A

N/A

N/A

N/A

N/A

N/A

N/A

N/A

N/A

Standard Math (Functions)

ADD_INT

ADD_DINT

ADD_REAL

SUB_INT

SUB_DINT

SUB_REAL

MUL_INT

MUL_DINT

MUL_REAL

DIV_INT

DIV_DINT

DIV_REAL

ADD_INT

ADD_DINT

ADD_REAL

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Output Parameter Q, Real

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Output Parameter Q, Real

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Output Parameter Q, Real

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Output Parameter Q, Real

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Output Parameter Q, Real

MOD_INT

MOD_DINT

Yes

Yes

Output Parameter Q, Integer

Output Parameter Q, Double Integer
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Function or Function Block ENO Requires
LD Boolean
Instruction

Resulting Accumulator
Value and Type

SQRT_INT

SQRT_DINT

SQRT_REAL

Yes

Yes

Yes

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Output Parameter Q, Real

Trig Functions (Functions)

SIN

COS

TAN

ASIN

ACOS

ATAN

Yes

Yes

Yes

Yes

Yes

Yes

Output Parameter Q, Real

Output Parameter Q, Real

Output Parameter Q, Real

Output Parameter Q, Real

Output Parameter Q, Real

Output Parameter Q, Real

Logarithmic/Exponential Functions
(Functions)

LOG

LN

EXP

EXPT

Yes

Yes

Yes

Yes

Output Parameter Q, Real

Output Parameter Q, Real

Output Parameter Q, Real

Output Parameter Q, Real

Radian Conversion Functions (Functions)

RAD_2_DEG

DEG_2_RAD

Yes

Yes

Output Parameter Q, Real

Output Parameter Q, Real

Relational Functions (Functions)

EQ_INT

EQ_DINT
EQ_REAL

NE_INT
NE_DINT
NE_REAL

GT_INT
GT_DINT
GT_REAL

GE_INT
GE_DINT
GE_REAL

LT_INT
LT_DINT
LT_REAL

LE_INT
LE_DINT
LE_REAL

No

No

No

No

No

No

No

No

No

No

No

No

No

No

No

No

No

No

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Relational Functions (Functions)

RANGE_INT No Output Parameter Q, Boolean
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Function or Function Block ENO Requires
LD Boolean
Instruction

Resulting Accumulator
Value and Type

RANGE_DINT

RANGE_WORD

No

No

Output Parameter Q, Boolean

Output Parameter Q, Boolean

Bit Functions (Functions)

AND_WORD

OR_WORD

XOR_WORD

NOT_WORD

Yes

Yes

Yes

Yes

Output Parameter Q, Word

Output Parameter Q, Word

Output Parameter Q, Word

Output Parameter Q, Word

Bit Functions (Functions)

SHL_WORD

SHR_WORD

ROL_WORD

ROR_WORD

BTST_WORD

BSET_WORD

BCLR_WORD

BPOS_WORD

MSKCMP_WORD
MSKCMP_DWORD

No

No

Yes

Yes

No

Yes

Yes

Yes

No

No

Output Parameter B2, Boolean

Output Parameter B2, Boolean

N/A

N/A

Output Parameter Q, Boolean

N/A

N/A

Output Parameter POS, Integer

Output Parameter MC, Boolean

Output Parameter MC, Boolean

Data Move Functions (Functions)

MOVE_BOOL
MOVE_INT
MOVE_WORD
MOVE_REAL

Yes

Yes

Yes

Yes

N/A

N/A

N/A

N/A

Data Move Functions (Functions)

BLKMOV_INT
BLKMOV_WORD
BLKMOV_REAL

BLKCLR_WORD

SHFR_BIT

SHFR_WORD

COMM_REQ

Yes

Yes

Yes

Yes

Yes

Yes

No

Yes

Yes

N/A

N/A

N/A

N/A

N/A

N/A

Output Parameter FT, Boolean

Data Move Function Blocks (Functions)

BIT_SEQ Yes Yes N/A

Table Functions (Functions)

ARRAY_MOVE_INT
ARRAY_MOVE_DINT
ARRAY_MOVE_BIT
ARRAY_MOVE_BYTE
ARRAY_MOVE_WORD

SRCH_EQ_INT
SRCH_EQ_DINT

Yes

Yes

Yes

Yes

Yes

N/A

N/A

N/A

N/A

N/A
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Function or Function Block ENO Requires
LD Boolean
Instruction

Resulting Accumulator
Value and Type

SRCH_EQ_BYTE
SRCH_EQ_WORD

SRCH_NE_INT
SRCH_NE_DINT
SRCH_NE_BYTE
SRCH_NE_WORD

SRCH_GT_INT
SRCH_GT_DINT
SRCH_GT_BYTE
SRCH_GT_WORD

SRCH_GE_INT
SRCH_GE_DINT
SRCH_GE_BYTE
SRCH_GE_WORD

SRCH_LT_INT
SRCH_LT_DINT
SRCH_LT_BYTE
SRCH_LT_WORD

SRCH_LE_INT
SRCH_LE_DINT
SRCH_LE_BYTE
SRCH_LE_WORD

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Output Parameter FD, Boolean

Conversion Functions (Functions)

INT_TO_BCD4

BCD4_TO_INT

INT_TO_REAL

DINT_TO_REAL

BCD4_TO_REAL

WORD_TO_REAL

REAL_TO_WORD

REAL_TO_INT

REAL_TO_DINT

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Output Parameter Q, Word

Output Parameter Q, Integer

Output Parameter Q, Integer

Output Parameter Q, Integer

Output Parameter Q, Integer

Output Parameter Q, Integer

Output Parameter Q, Word

Output Parameter Q, Integer

Output Parameter Q, Double Integer

Control Functions (Functions)

DOIO

SVC_REQ

Yes

Yes

N/A

N/A

Control Function Blocks  (Function
Blocks)

PID_IND
Yes

Yes

Yes

Yes

Output Parameter CV, Integer

Output Parameter CV, Integer



GFK-1670D  Chapter 5  Working in the Instruction List Editor 5-17

  5

Function or Function Block ENO Requires
LD Boolean
Instruction

Resulting Accumulator
Value and Type

PID_ISA

New Series 90-30 (36x) Function Blocks
(Function Blocks)

SER Yes Yes N/A

VersaMax Release 1.1 and later Function
Blocks

DRUM

SCALE_INT

SCALE_WORD

Yes

Yes

Yes

Yes Output Parameter Q, Word

Output Parameter OUT, Integer

Output Parameter OUT, Word

Nesting of Boolean Expressions

The user can nest Boolean expressions using the AND( and OR( operators up to a
nesting level of 8. When a nested Boolean expression is started with an AND( or OR
(operator, the next instruction must be a LD_BOOL or LDN_BOOL operator. The
only operators that are allowed within a nested Boolean expression are : S, R,
ST_BOOL, STN_BOOL, NT, PT, NOT, AND*, OR*, and XOR*. Nested Boolean
expressions can be used to evaluate complex Boolean equations. A sample nested
Boolean expression is as follows :

No control instructions or function calls may be placed within nested Boolean
expression.
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Using ENO

When a function or function block is executed, it’s ENO output is used to indicate
the successful execution of the function block. If an error occurs when the function is
executed, it will set or reset the ENO output. The user can check the status of the
ENO output by using the LD_ENO operator to load the ENO output value into the
Accumulator. The user can then examine this value for error handling.
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Defining Temporary Variables

When programming in Instruction List, the user must define the memory locations to
be used by the IL Accumulator. The user must define 8 consecutive discrete points in
%T, %M, or %Q memory for use as the Boolean Accumulator. The user must also
define 2 words of reference memory in %AI, %AQ, or %R memory for use as the
Word, Integer, Double Integer, and Real Accumulator. The user defines the IL
Temporary Variables using the Folder Properties dialog. Once these temporary
variables have been defined, these references may not be referenced directly in the
program.

Error Checking

The following error checking is performed on the IL program when it is compiled.

1. The type of the Accumulator must be compatible with the type of the operator.

2. A LD instruction or Function call must occur before a ST instruction.
(Accumulator must have a Value and Type.)

3. Parenthesis of nested expressions must be matched.

4. Reference Types must be correct for operators. For example, can’t do a “S
%R00001” since data type must be bit.

5. JMPs and MCRs must have matching labels.

6. All variables must be defined.

7. CALs must have matching IL/LD Blocks.

8. Reference Addresses must be within the limits of the configured CPU.

9. Function and Function Block parameters must be the correct memory types and
values.
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Working with the Variable Declaration Table

The Variable Declaration Table (VDT) is the window used to create, edit and view
variables online. The VDT usually displays automatically when the Folder Browser is
open. If the VDT is not displaying from the Folder Browser, select the View menu and
select Variable Declaration Table, or click the Variable Declaration Table toolbar button

.

This chapter introduces you to variables and describes how to create variables for use in
your LD and IL programs.

Chapter Contents

• An overview of the Variable Declaration Table (VDT)

• An introduction to variables

• How to create and edit variables

• How to work with variables using standard cut, copy and paste commands

• How to delete variables and compact and save the VDT

• How to import and export variables to and from SNF Files

Chapter

6
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Overview of the Variable Declaration Table

The Variable Declaration Table is organized into tabs.  Each tab displays variables as
described below:

Global Tab: Displays all Global variables.

Local Tab: Displays variables local to the active block. If no block is open the Local tab
is blank.

All Tab: Displays all variables, Global and Local.

System Tab: Displays System variables. These variables are not editable, but they can be
used in logic.

Temporary Tab: Displays variables created in the Folder Properties dialog box for
temporary use in the IL Editor. Temporary variables are not editable.

A sample Variable Declaration Table is shown below.

VDT Tabs
Click a tab to view
variables at a
different scope

Variable Scope
Global variables may be used on
all blocks.
Local variables may be used
only in the block where the
variable is defined.
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Variable Table Field Descriptions

This section describes the fields which are included when defining a variable.

Name

In variable programming, names are assigned to memory addresses. You can assign a
logical name, or let the reference address match the variable name. If you do not assign a
name for the variable, the reference address is automatically used as a name.  A variable
name can be no longer than 31 characters, and may only consist of the characters A - Z, a -
z, 0 - 9, _, +, -, #, @, <, >, =. Variable names must start with a letter or underscore ("_").
For a list of reserved words, see page 6-4.

Type

Each variable must be assigned a data type describing how the variable is to be used in the
program. VersaPro allows you to assign a variable a Bit, Byte, or Word data type.

Length

The Length field specifies the amount of data that a variable is to use. For word data type,
length specifies the number of words. For Byte data type, the it specifies the number of
bytes. For bit data type, the length must be 1.  The Data Length defines the amount of
Stored Value Data that is specified for a variable.

Address

A reference address links a variable with a physical location in the PLC.

Description

The Description field allows you to enter descriptive information about a variable. The
field is optional and may be left blank. Descriptions can be no longer than 64 characters.

Stored Value

Any initial value specified for a variable in the Variable Declaration Table is transferred to
the PLC upon program transfer, even if the variable is not used in the program. Such
values are considered an attribute of the variable. You can specify as much information
per variable as the Reference Table will hold.

Scope

Scope defines the areas where a variable can be used in a folder. The possible values for
scope are “Global” and (for each block in the folder) “Local: <block name>”. System
variables are pre-defined for use by the PLC CPU.
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Retentive

The Retentive field specifies whether or not the selected variable retains its value after
loss of power.  The retentive state shown in the VDT initializes the variable when stored.
It does not show the current retentive state as logic is running. VersaPro requires that the
retentive state be checked for all memory areas except %M, %Q, and %T. Row validation
automatically corrects any incorrect settings for all but these areas.

Overrides

Overrides are tools for program checking and maintenance. You can test a program in a
PLC that is not connected to I/O hardware by using overrides to simulate inputs. You can
also check a program when I/O hardware is connected by using overrides to prevent coil
operation. Overrides can temporarily bypass a failed input device so that machine
operation can continue until the device can be repaired. However, using overrides in this
manner can cause the overriding of safety devices and is not recommended. The override
state shown in the VDT initializes the variable when stored values or overrides are stored.
It does not show the current override state as a program is running.  Override may only be
checked on a non-system bit variable assigned to %G, %I, %M, or %Q.

EXT

When the EXT (show externally) field is selected, the variable can be shared by other
applications.

Reserved Words

 In addition to function block names, the following words are reserved and may not
be used as variable, program, block, label, or task names:

AUX CONFIGURATION                      PROGRAM
CLOCK$ LPT1                                              RESOURCE
COM1 LPT2                                              SYSTEM
COM2 LPT3                                              GLOBAL
COM3 LPT4                                              TEMPORARY
COM4 LPT5
COM5 LPT6
COM6 LPT7
COM7 LPT8
COM8                                     LPT9
COM9 NUL
CON                                         PRN
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Creating and Modifying Variables

VersaPro allows you to create and modify variables for use in program logic. Variables
can have different data types, scopes, lengths, and addresses. Several variables can
reference the same address, and you can associate descriptions and initial stored values
with any variable. VersaPro allows you to create and modify variables on the fly or prior
to program construction.

System Variables (%S, %SA, %SB, %SC) cannot be edited. They are present in the
variable list whenever a new folder is created.

Modifications that you make to variables in the Variable Declaration Table are reflected at
all reference points including program logic.

Note: Declaration of variables with overlaps, for example a variable at %R8
with length 3 and a variable at %R10 of length 2 have an overlap at
%R10, will result in stored value conflicts when you attempt to Store
the stored values to the PLC.  In order to resolve these conflicts, you
must use the VDT to relocate variables so that they do not overlap.

To create a new variable or modify an existing variable in the VDT:

1. From the Folder Browser, double click on the Variable Declarations icon.  The cursor
will become active in the Variable Declaration Table

2. Perform the following steps to create or edit:

• To create a new variable, click the right mouse button and choose Insert Row.  A
new row will appear in the VDT.

• To edit an existing variable, locate the variable and double click on the fields you
want to edit.

3. For new variables, complete the Name, Type and Address fields.  Verify Scope and
Length.  You may also enter a Description and Stored Value, if desired. To modify
existing variables, change the parameters as required in your application:

• VersaPro will display message boxes if the variable definition is incomplete, or
(for modified variables) does not pass validation.
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Navigating in the VDT

VersaPro allows you to navigate using either the mouse or the keyboard. You can also
navigate to a particular variable using the Go to Variable dialog box or the Edit Variable
menu item.

Navigating Using the Mouse or Keyboard

To navigate using the mouse:

Move the mouse arrow to the cell that you want to edit, then click the primary mouse
button.  As with keyboard navigation, if you’re editing a cell, moving the selection implies
accepting the data in the cell from which you are moving.

To navigate using the keyboard:

Reference the following table to navigate through the VDT using the keyboard.

Key Action

Arrow Keys If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted):, the arrow keys move the selection one cell in the direction of the arrow
key.

If the current cell has been selected for editing:, the Left and Right arrow keys move
the cursor to the left or right in the cell until the beginning or end of the text is
reached

Moving from one row to another, by using up/down or right/left arrow keys, always
triggers row validation.

Enter If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted), the Enter key selects the cell for editing.

If the current cell has been selected for editing, the Enter key submits the contents of
the cell for row validation, and selects the cell below the current one.

F2 Selects or unselects the current cell for editing.

Shift + Arrow Keys If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted), the Shift + Arrow keys select the current cell and moves the selection
one cell in the direction of the arrow key.

If the current cell has been selected for editing, the keys select the current character
and moves the selection one character in the direction of the arrow key.

Shift + Space Bar Selects the current row.

Home If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted), the Home key selects the first cell in the current row.

If the current cell has been selected for editing, the Home key moves the cursor to the
left of the first character in the cell.
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End If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted), the End key selects the last cell in the current row.

If the current cell has been selected for editing:, the End key moves the cursor to the
right of the last character in the cell.

Ctrl + Home Selects the first cell in the first row.

Ctrl + End Selects the first cell in the last row.

Tab If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted), the Tab key selects the next cell to the right.

If the current cell has been selected for editing, the Tab key submits the contents of
the cell for row validation, and selects the next cell to the right.

Note: Moving from one row to another, by tabbing left from the leftmost cell or right
from the rightmost, always triggers row validation.

Shift + Tab If the current cell has not been selected for editing (if the cell, but not the text, is
highlighted), the Shift + Tab keys select the next cell to the left.

If the current cell has been selected for editing, the Shift + Tab keys submits the
contents of the cell for row validation, and selects the next cell to the left.

Note: Moving from one row to another, by tabbing left from the leftmost cell or right
from the rightmost, always triggers row validation.

Ctrl + Tab Displays the next VDT tab (Local, Global, All, System) to the right.

Page Down/Up Moves the display one vertical viewable page down/up, and selects the cell in the
same relative x,y position as before the movement.

Locating a Variable using the Go To Variable Dialog Box

You can quickly locate variables using the Go To Variable dialog box.  Perform the
following steps to locate a variable by name.

1. From the Variable Declaration Table, click the right mouse button and choose Go to
Variable.  The Go to Variable dialog box will appear.

2. Enter the name of the variable that you want to go to, or select it from the drop-down
list.

3. Click OK. The variable that you entered becomes selected in the Variable Declaration
Table.
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Using Cut, Copy, Paste and Drag and Drop in the VDT

VersaPro allows you to cut or copy and then paste variables or cells in single or multiple
variables within the Variable Declaration Table without removing ladder elements from
ladder logic or instructions from instruction list logic. It also allows you to paste items
placed on the clipboard by applications other than VersaPro into the Variable Declaration
Table, and to cut or copy items to the clipboard for pasting to any other application that
accepts tab-delimited text. Pasting overwrites any information in a cell or variable.

VersaPro also allows you to drag and drop -cut or -copy within the VDT, or from the
Variable Declaration Table to either editor. Dropping in the VDT overwrites any
information in a cell or variable.

To cut, copy and paste in the Variable Declaration Table:

1. Open the Variable Declaration Table Select a variable(s) or cell(s) within single or
multiple variables.

2. Choose Cut or Copy from the Edit menu, click the Cut button  or the Copy button

 on the toolbar, or press Ctrl + C for Copy or Ctrl + X for Cut. To select a
variable, every field in the variable must be selected.  The selected data is cut or
copied to the clipboard. It is now available for pasting to any other application that
accepts tab-delimited text.

3. Select the variable(s) or cell(s), to which you wish to paste the information that
you’ve cut or copied. Information on the clipboard that originated in another
application may also be pasted to VersaPro.

4. Choose Paste from the Edit menu, click the Paste button , or press Ctrl + V.
Row validation is performed on each variable to check for global scope conflicts with
existing variables before pasting to the VDT. If a variable fails row validation, an
error message appears, and then a dialog box appears allowing you to correct errors
appears. If the problem is corrected, row validation continues for other variables. If
the information on the clipboard is valid for pasting in VersaPro and the number of
variables or cells corresponds to the area that you’ve highlighted, the information is
pasted.
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Details on Cutting and Copying

• If every cell in a variable is selected and a cut is performed, the variable is deleted
from the folder.

• Vertical gaps between non-contiguous variables are deleted when the variables are
copied to the clipboard.

• Rows on the clipboard are separated by a CR/LF. Columns are separated by tabs.
These separations become obvious when pasting to an external application.

• If a cut or copied variable’s length is greater than 1, its stored values are separated by
commas when pasted to external applications (like Microsoft Excel).

• When cut or copied to the clipboard, Retentive and Override values are stored as 1 for
True and 0 for False.

• It is not possible to make non-contiguous row selections with the keyboard.

• The following fields cannot be cut from a variable: Type, Length, Scope, Retentive,
Override.

Details on Pasting

• If more variables reside on the clipboard than have been selected to be overwritten,
the selected variables are overwritten and the remaining clipboard variables are
inserted on to the table(s)

• If fewer variables reside on the clipboard than have been selected to be overwritten,
as many of the selected variables as possible are overwritten, and the rest are deleted.

• Nothing may be pasted into the System tab.

• Nothing may be pasted into the Temporary tab.

• If a variable is pasted onto the Global table, it becomes a global variable regardless of
its original scope.

• If a variable is pasted onto a Local table, it becomes local to that block regardless of
its original scope.

• If a global variable is pasted onto the All table, it remains global.

• If a local variable is pasted onto the All table, the program will attempt to assign it to
its defined block. If that block does not exist in the folder, it will be made a global
variable.

• Any values changed by a paste operation on the visible table will also be changed on
any other table where they appear.

• Values that have been altered by a paste in the VDT are also altered in the IL and LD
program logic displays.
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• For cells, if the selected area is smaller than the area on the clipboard, an error
message appears and the paste is aborted. If the selected area is larger than the area on
the clipboard, the cut or copied information is pasted in the upper left corner of the
selected area.

• Any text may be pasted into a free floating or line comment.

• For rows, if the selected number of rows is smaller than the number on the clipboard,
an error message appears and the paste is aborted. If the selected number of rows is
greater than the number on the clipboard, the extra rows are deleted. If only a cell is
selected, the rows are pasted above that cell.

To drag and drop-cut in the VDT:

1. Open the Variable Declaration Table.

2. Select a variable(s) or cell(s) within single or multiple variables.

3. Position the mouse arrow over the selected variable or cell.

4. Press and hold the primary mouse button.

5. Move the variable or cell to the appropriate area.

6. To drop the selection, release the mouse button. If it is valid in the new location, the
selected variable or cell is removed from the original position and placed in the new
position. If it is not valid, the drag and drop operation is cancelled.

To drag and drop-copy in the VDT:

1. Open the Variable Declaration Table.

2. Select a variable(s) or cell(s) within single or multiple variables.

3. Position the mouse over the selected variable or cell.

4. Press and hold the Ctrl key.

5. Press and hold down the primary mouse button.

6. Move the variable or cell to the appropriate area.

7. To drop the selection, release the mouse button.  If it is valid in the new location, the
selected variable or cell is copied from the original position and placed in the new
position. If it is not valid, the drag and drop operation is cancelled.
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Details on Dragging and Dropping in the VDT

• Changes to values that occur through Dragging and Dropping will also appear on any
other affected table(s) or editors.

• Drag and drop of variables is only available on the same VDT tab.

• When a selection spans more than one variable, row validation is performed. If any
cell in the selected area is invalid in its new location, the entire drag and drop
operation is cancelled.

• You cannot cut the following cells, unless the entire row is selected: Type, Length,
Scope, Retentive, Override

• If a selection is dropped that would go beyond the last row of the VDT, new rows are
created to accommodate the drop.

• When a selection is dropped, it overwrites the existing cells.

• VersaPro does not allow dragging and dropping a discontinuous set of cells.

To drag and drop from the VDT to the LD or IL Editor:

1. Open a block in the IL or LD Editor.

2. Open the Variable Declaration Table.

3. Select a variable in the VDT.

4. Position the mouse over the selected variable.

5. Press and hold down the primary mouse button.

6. Move the variable to the Operand field of an existing instruction in the IL Editor, or
to an element or operand in the LD Editor.

7. Release the mouse button to drop the variable.  The variable becomes the operand for
the selected instruction.

Details on Dropping a Variable into an Editor

• When a selection is dropped it overwrites the existing cell.

• Variables may only be dropped on existing elements or operands.

• If the variable is invalid in its new location, the entire drag and drop operation is
cancelled.

• Multiple rows cannot be dragged and dropped from the VDT to the IL Editor.
No more than one row from the VDT may be dropped into the LD Editor.
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Variable Declaration Table Utilities

VersaPro provides several utilities to sort variables, delete variables as well as clear and
save the VDT.

This section describes how to use the utilities supported by the VDT.

Sorting Variables

VersaPro allows you to sort variables in the VDT, in ascending or descending order,
according to any but the Stored Value column.

To sort variables in the VDT

1. Open the Variable Declaration Table.

2. Select a column in the VDT, other than the Stored Value column, by clicking on its
quick-select button. VersaPro does not allow sorting on the Stored Value column.

3. Choose Sort from the View menu, then choose Ascending or Descending from the
submenu that appears, or choose Sort Ascending or Sort Descending from the
Context-Sensitive Menu.

Deleting Variables and the Contents of a VDT

Variables can be deleted from the Variable Declaration Table without removing ladder
elements from ladder logic or instructions from instruction list logic. Elements from which
variables have been removed become unnamed.

VersaPro also allows you to delete the contents of a Variable Declaration Table (clearing
the VDT). Performing such a deletion removes all the VDT’s variables from the Global,
Local, and All tabs and from program logic. The logic itself is not affected. The VDT
remains in the folder and is always displayed in the Folder Browser; it can only be cleared,
not deleted.

To delete a variable in the VDT

1. Open the Variable Declaration Table.

2. Select  the variable or variables that you want to delete.

3. Choose Delete from the Edit menu or press the Delete key. The variable or variables
are deleted from the VDT.

4. The variables are deleted from program logic.
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• In Ladder Diagram blocks, the names of deleted variables are removed from
elements, but the elements to which these variables had been assigned are not
removed.

• In Instruction List blocks, the names of deleted variables are removed from the
Operand column, and their addressees are removed from the Reference Address
column, but the relays and instructions to which these variables had been
assigned are not removed.

Note: In order for a single variable to be deleted, every field in the variable
(the entire row) must be selected. If every field is not selected when the
deletion is performed, the selected fields are cleared, but the variable
remains in existence.

To clear the Variable Declaration Table

1. Highlight the Variable Declaration Table in the Folder Browser.

2. Choose Delete from the Edit or the Context-Sensitive menu, or press the Delete key.
A confirmation message appears asking if you are sure you want to erase all variables
from the program.

3. Click OK to delete all variables. Otherwise click Cancel.

• All global and local variables are deleted from the VDT. No variables remain on
the Global, Local, or All tables.

• All variables are removed from program logic.

• System variables remain on the System table. They can never be deleted.

Saving Edits in the VDT

To save the Declaration Table:

1. From the Variable Declaration Table, click the Save Folder button on the toolbar

, choose Save from the File or the Context-Sensitive menu, or press
 Ctrl + S.

2. VDT data is saved.

Note: In a number of circumstances, for instance, when you close a folder or
close the application, the VDT is saved automatically.
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Compacting the VDT

When you edit the VDT by cutting, copying, pasting, or deleting, the VDT retains
information about your edits. This edit history can cause the VDT to grow substantially in
size. If a large amount of editing has taken place in a particular VDT, it is sometimes
useful to remove the VDT's edit history and thereby lessen its size. The Compact option
on the Folder menu allows you to do so.

To compact the VDT:

1. Open a folder.

2. Open the Variable Declaration Table.

3. Make the Variable Declaration Table active.

4. Choose Compact from the Folder menu.

The VDT is compacted.

Viewing the Highest References Used

To display a list of the highest references used for all memory types, select Highest
References Used from the VDT context sensitive menu.

Finding Unused Variables

Unused variables are variables which have been created, but are not used in any program
logic. From the Folder menu, select Find Unused Variables. The unused variables will be
listed in the Information window by Name, Scope, and Address.

Creating a Cross-Reference Listing of Variables

From the Tools menu or the Folder browser CSM menu, select View Online Cross
References. The Information window will display a list of all variables used in the selected
block by reference type. The cross reference also lists each Rung and Instruction that uses
the variable.
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Importing and Exporting Variables

VersaPro allows you to import and export variables to external locations using a Shared
Name File Format.  This section describes how to import and export variables to and from
SNF Files.

To import a variable:

1. Open the folder into which you wish to import an SNF file.

2. Choose Import Variable from the VDT CSM or the Tools menu. A browse dialog box
appears asking you to locate the file that you wish to import.

3. Locate the file that you wish to import.

4. Click the Open button. The file is imported and the variables are displayed in the
VDT.

Details on Importing an SNF File

• VersaPro ignores the Header section of SNF files.

• The Imported SNF file must contain a PT_ID field, and that field must be the first
field in the first non-comment field row.

• The number of Data Entries must correspond to the number of Field Names.

VersaPro supports the following field names:

o PT_ID (name)

o ADDR

o DESC

o PT_TYPE

o LENGTH

o RETENTIVE

o OVERRIDE

o STORED_VAL

o SHOW_EXT



6-16  VersaPro™ Programming Software User's Guide – October 2001  GFK-1670D

6   

All other field names and corresponding data entries are ignored.

• Empty data entries default to the same default entry as the VDT.

• Any data entries that violate row validation , contain invalid entries for a particular
field (other than the PT_TYPE field), or repeated variables produce a conflict error.

• All imported SNF variables are added to the global table unless another block has
been specified in the address field.

• Imported SNF variables are added below any existing variables.

• Selecting Cancel from the Conflict dialog cancels the entire import process. All data
is purged.

• Any Description that contains quotation marks must start and end with quotation
marks, to determine where separations occur between Descriptions and the additional
text in the variable.

To export a variable:

1. From the VDT, select the variable or variables that you wish to export.

2. Choose Export Variable from the VDT CSM or the Tools menu. If no variables are
selected, an error message appears informing you that at least one variable must be
selected in order to export. A dialog appears asking you to determine the location to
which you wish to save the exported file.

3. Choose a location. The default export location is the last Import/Export directory
used.  Click OK.
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Details on Exporting an SNF File

• The following Field Names are exported as:

o PT_ID (name) - variable name

o ADDR (“address, block name” format for local variables) - variable reference
address and scope

o DESC - variable description

o PT_TYPE - variable type

o LENGTH – length of variable

o RETENTIVE - variable retentive state

o OVERRIDE - variable override state

o STORED_VAL - stored values in comma delimited format

o SHOW_EXT – variables to be viewed by HMI

• The $$&&FileType section of the SNF header will be I/O.

o VersaPro does not export the ##DelVarDEcl section of the SNF header.

o Any additional comments in the SNF files must be added using an outside editor.

o The default extension of the exported file is *.SNF.
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Variable Resolution

This dialog allows you to easily resolve variable conflicts. You can keep existing variable
definitions or overwrite them. This dialog appears as the result of a Paste, Import SNF, or
Insert Block operation that causes one or more variables to conflict with existing
variables.

If Prompt for Each Conflict is selected, the following dialog box will appear.
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To enter Description, Stored Value, Scope, Override, Retentive, and External for the
variable, select the Auxiliary tab. (These values can also be edited in the VDT.)
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Configuring PLC Hardware

Stand Alone Hardware Configuration (HWC) contains the configuration information for
your Series 90-70, Series 90-30, VersaMax, VersaMax Nano/Micro, and Series 90 Micro
PLCs, as well as Ethernet Global Data (EGD) configuration.  It also provides tools to
allow you to monitor power consumption and I/O mapping for modules added to your
system. The default rack and CPU configuration that appears when you enter HWC is set
by selecting Options from the Tools menu in VersaPro.

The configuration information must match the physical hardware of your system. Typical
steps in configuring your PLC hardware include:

• Configuring the rack type and power supply

• Selecting and configuring a CPU for a PLC rack system, or an NIU for a VersaMax
Remote I/O rack system.

• Configuring modules and customizing parameters for your application

• Configuring EGD exchanges and Name Resolution, if applicable

• Saving the HWC so that it can be stored to the PLC from VersaPro

Detailed information about configuring parameters for a specific module is available
through the online help.  To access this information, open the Parameter Editor window
for the module (double-click the module), then select Module Help from the Help menu.

Chapter Contents

• Accessing Hardware Configuration

• Configuring the Series 90-30 Rack

• Configuring the Series 90-70 Rack

• Configuring the VersaMax Modular Rack

• Configuring the VersaMax Remote I/O Rack

• Configuring VersaMax Nano and Micro PLCs

• Configuring Series 90 Micro PLCs

• Hardware Configuration Reference View

• Hardware Configuration Log View

• Converting Rack Systems

• Printing Hardware Configuration

Chapter

7
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Accessing Hardware Configuration 

To access HWC from VersaPro, double-click the Hardware Configuration icon  in the
folder browser. The rack system for the configured CPU hardware will appear, along with
a graph showing power consumption statistics for the module, a table showing references
used in hardware configuration, and a log that maintains a record of HWC events.

Rack View

Log View

Power
Consumption
View

Reference
View

Status Bar
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Hardware Configuration Toolbar

When you launch HWC, the main window displays   While you are working in Hardware
Configuration, you may want to display the Hardware Configuration toolbar, which
provides access to commonly used areas of Hardware Configuration:

To display the Hardware Configuration toolbar, go to the View menu and place a
checkmark next to Toolbar.

Using the Parameter Editor

To configure module parameters, you will use the Parameter Editor, which appears
automatically when you insert or replace a module. To change parameters for a module,
choose Configure Parameters from the context-sensitive menu, or choose Configure
Parameters from the Edit, Module Operations submenu, or double click on the module.

The Parameter Editor provides an extended set of Windows-compatible editing facilities
to make configuring your system less labor intensive.

• Parameters are displayed in an edit window that can be resized, maximized, and
minimized.

• You can open multiple parameter views at the same time.  This feature allows you to
view the parameter set of one module while editing another, and you can easily copy
and paste a single parameter value between module views.

• The Edit Window can be displayed in Tabbed mode (default) or Spreadsheet Mode
(allows all parameter groups to be displayed and edited in a single, scrollable view).
To change the display, select Parameter Edit from the View menu.

• The Title Bar of the window uniquely identifies the associated module with the rack
system name, the module rack/slot address, and the module catalog number.
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Note: Some of the more complex modules, such as the Motion modules,
contain key parameters known as Mode Setters.

All parameters, including Mode Setters, that affect other parameters are
listed in italics. To obtain an explanation of parameter relationships for
these parameters, press F1 in the Editor window and select the
parameter name from the Help index. Or, right click the parameter and
select What's This from the CSM.

Mode Setter
Changes the set of
parameters available for
editing. Resets the
parameters it affects.

Tool Tip
Displays valid choices
for selected parameter.

Status Bar
Displays information about
module being configured.

Editing Tips

Valid values for each parameter are displayed in a tool tip that appears when you hover
the mouse cursor over the parameter cell. To edit parameter values:

• Type directly into the selected cell in a manner similar to typing into a spreadsheet
cell, or use the Data Entry Tool. To open the Data Entry Tool, right click in the
parameter cell and choose Data Entry Tool from the context-sensitive menu, press the
F2 key, or double click.

• If the valid values consists of a list of choices with unique initial letters, select a value
by simply typing its first letter in the cell.

You can save time when entering the same value for multiple parameters (of the same
type) by Copying and Pasting or dragging and dropping one parameter value into other
parameter value cells. Copy/Paste and drag/drop can be used within the same module view
or between module views.
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Drag/drop works with the keyboard as follows:

• To copy the data from the source cell to the drop cell, do not press any key, or press
the Ctrl key while dragging.

• To move the data from the source cell to the drop cell, press the Shift key while
dragging.

• To copy the data from the source cell to all cells between the source and drop cell
(including the drop cell), press the Alt key while dragging. This assumes that drag
and drop is occurring on the same Edit window and the source and drop cells are in
the same column.  This features allows you to quickly fill an entire range of cells with
identical information.

Note: Parameter values that have been changed since the start of the editing
session are shown in bold.

Undoing Changes

• To reset a single parameter to the Start of Edit Session value or to Factory Original
(default) setting, right click on the parameter and choose Reset Parameter from the
context-sensitive menu.

• To reset all the parameters on a tab, right click anywhere in the tab, and choose Reset
Tab from the context-sensitive menu.

• To Undo changes, choose Undo from the Edit menu, or click the Undo button on the
Editor toolbar.

The Editor supports from 1 to 32 levels of Undo/Redo (default is 10). You can set the
levels of Undo/Redo by choosing Options from the Tools menu.

Note: You cannot Undo changes that result from changing a Mode Setter
parameter.

Error Notification

Erroneous values are displayed in the Error Color (red by default) and an explanatory
ToolTip is provided for the error.

To see the ToolTip for an erroneous setting in the Parameter Editor, hover the mouse
cursor over the parameter cell.

To change error notification colors

1. Select Options from the Tools menu.

2. In the Options dialog box, choose the General tab.
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3. In the Colors list, choose the condition for which you want to set the color.

4. Click the Choose button. The Windows color selection dialog box will open.

5. Select a color, click OK in the color selection dialog box, then click OK in the
Options dialog box.

Correcting Errors

To automatically correct an erroneous value, right click on the value and select Auto
Correct from the context-sensitive menu. If you attempt to close a configuration that
contains an error, the Parameter Error List dialog box will appear. To automatically
correct all errors listed in this dialog box, click the Auto Correct button.

Shortcut Keys for HWC

You can edit information in Hardware Configuration through menu bar selections, the
context-sensitive menu, or short-cut key sequences.

• To edit modules using the menu bar, click the module or slot you want to configure,
go to the Edit menu, and select the appropriate action.

• To edit modules using the right mouse button, click the module or slot you want to
configure, click the right mouse button, and select the appropriate action.

• To edit modules using standard cut, copy, and paste functions, highlight the module
and use the Edit menu options or CTRL key shortcuts.

• To copy a module, click the module you want to copy and press CTRL+C. To paste
the module, click the new slot and press CTRL + V.

• To cut a module (which allows you to paste it in another slot), click the module and
press CTRL+X. To delete a module, click the module, and select Delete from the Edit
Menu or press the Delete key.

• To Undo a previous operation, press CTRL + Z.

• You can use drag and drop to move modules between slots. To use drag and drop,
highlight the module you want to move, click and hold the left-mouse button, and
drag the module to the new slot.

• To close a window, press Ctrl + F4.

• To Close HWC, press Alt + F4.
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Setting Options in Hardware Configuration

To set HWC options, go to the Tools menu and select Options. To adjust the size and
content of the HWC System Log, enable Audit Trail Mode, set the number of Undo
Levels, and select Error and Warning colors, select the General Options tab.

To change the format of the Parameter Editor window and the mode for assigning the next
reference, select the Parameter Edit Options tab.
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Configuring a Series 90-30 or 90-70 Rack

When you enter Hardware Configuration for the Series 90-30, the default view is the Rack
(Main).  The default 90-30 CPU model is  the CPU351. The default 90-70 CPU model is
the CPX772.

Power Supply

CPU

Context Sensitive Menu
Choices:
Click the secondary mouse button to
view list of available commands for the

Rack Tabs

Changing Rack Type

To change rack type:

1. Position the cursor anywhere in the Rack window, then click the right mouse button.

2. Choose Change Rack Type.

3. Click the catalog number and description of the type matching your system, then click
the OK button.

Note: Change Rack Type is only active for Series 90-70 and non-imbedded
Series 90-30 CPUs (CPU331 and higher).
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Changing/Configuring Power Supply and CPU

Configuring a Power Supply

To change the default power supply:

1. Click the power supply slot in the Rack window.

2. Click the right mouse button and choose Replace Module.

3. Click the catalog number and description of the power supply in your system, then
click the OK button.

4. Respond to prompts if any appear.

5. When you replace the default power supply, the Parameter Editor appears allowing
you to view detailed power consumption information. If you are using the default
power supply, you can double-click on the power supply slot in the Rack window to
view the details.

6. When you have finished, click the OK button.

Configuring a CPU

To change the default CPU:

1. From the rack view, click the right mouse button and choose Replace CPU.

2. Click the catalog number and description of the CPU in your system, then click the
OK button.

Note: To configure EGD exchanges for a 90-30 CPU364 or a 90-70
CMM742, see “Ethernet Global Data Configuration” on page 7-33.

Configuring the CPU's Parameters

To configure the CPU’s parameters:

1. When you replace the CPU, the Parameter Editor window appears. If you are using
the default CPU, then double-click the CPU slot.

2. Within the Parameter Editor window, click the tab pertaining to the parameters you
want to view or modify (where applicable).

3. Click in the Values fields you want to edit. (See "Editing Tips" on page 7-4.)

4. When you have finished editing the CPU parameters, click the window close button.
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Adding/Configuring Rack Modules

To add modules to the rack:

1. Select the slot where the module is to be placed.

2. Double-click on the empty slot or click the right mouse button and choose Add
Module. (If you are replacing a previously configured module, click the right mouse
button and choose Replace Module.)

3. Click the tab describing the I/O module type you need (Discrete Input, Discrete
Output, Analog Input, Analog Output, Communications, etc.).

4. Click the catalog number and description of the module in your system, then click the
OK button.

Configuring the Module’s Parameters

To configure the module’s parameters:

1. When you add or replace a module, the Parameter Editor appears. You can also
access this dialog box by double-clicking the module slot from the Rack window.

2. Within the Parameter Editor, click the tab pertaining to the parameters you want to
view or modify (where applicable).

3. Click in the Values fields you want to edit.  (See "Editing Tips" on page 7-4.)

4. When you have finished editing the module parameters, click the window close

button. .

Configuring Expansion Racks

Expansion racks are configured in the same manner as the main rack.  To add modules to
an expansion rack, click the Rack tab and add the module configuration which
corresponds to the attached hardware.
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Deleting Rack Modules

Deleting a module removes it from the rack. If you save the Hardware Configuration after
deleting the module, the configuration information about the deleted module will be lost.
Perform these steps to delete a module:

1. Select the module you want to delete.

2. Press the Delete key or click the right mouse button and choose Delete Module.

Clearing the Rack

Clearing the rack removes all modules except the power supply and CPU. If you save the
Hardware Configuration after clearing the rack, the configuration information about the
deleted modules will be lost.

Perform these steps to clear the rack configuration:

1. Click anywhere in the Rack.

2. Click the right mouse button and choose Clear Rack.

3. A confirmation dialog box will appear. To confirm the clear rack operation, click the
Yes button.

Genius Bus Configuration (Series 90-70 PLCs)

The Genius Bus view is used to configure the bus attached to a 90-70 Genius Bus
Controller (GBC). This window contains serial bus addresses (SBAs) for 32 devices
(0 – 31). The controlling GBC occupies the SBA corresponding to its Serial Bus
Address (31 by default), which is configured in the module parameters for the GBC.
In a Redundant Controller system, the redundant GBC also occupies a SBA on the
bus.

SAHWC assigns a name to the bus in the format FileName: Bus_rack_slot. If you
move the GBC to a different rack/slot location, the bus name will be updated.

The Genius Bus view appears automatically when you add a GBC to the 90-70 rack
system configuration. You can also access this window by selecting a GBC and
choosing Expand Bus from the context sensitive menu (CSM).

Bus Operations

To set Redundancy to Yes for all devices on the bus

Go to the Edit menu, select the Bus Operations submenu, and choose Set All Devices
Redundant. On all blocks that have a Redundancy parameter, it will be set to Yes.
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To set Redundancy to No for all devices on the bus

Go to the Edit menu, select the Bus Operations submenu, and choose Set All Devices
Non-Redundant. On all blocks that have a Redundancy parameter, it will be set to
No.

To clear the bus

Choose Clear Bus from the Edit, Bus Operations submenu or from the CSM. All
blocks will be removed from the bus except for the controlling GBC.

Block Operations

Except for Edit Configuration, these operations cannot be performed on the
controlling GBC in a Genius bus. In a Redundant Controller system, Edit
Configuration, Copy, and Paste can be performed on the redundant GBC.

To add a block

Double click an empty SBA, or select the SBA, go to the Edit menu, and choose
Block Operations, Add Block. The Block Catalog will appear. Select a device and
click OK.

To edit block configuration

Select the block and choose Configure Parameters from the Edit, Block Operations
submenu or from the CSM. The Parameter Editor window for the selected block will
appear.

Keyboard shortcut: Ctrl +E

To delete a block

Select the block and choose Delete Block from the Edit, Block Operations submenu
or from the CSM. (To delete all blocks, except the controlling GBC, from the bus,
use the Clear Bus command.)

Keyboard shortcut: Del

To replace a block

Select the block and choose Replace Block from the Edit, Block Operations submenu
or from the CSM. The Block Catalog will appear. Select a device and click OK.

Drag and Drop

You can use drag and drop to move a block to a different SBA on the Genius bus.
(To move the controlling GBC, you must edit its Serial Bus Address in the Parameter
Editor window.)

Cut, Copy, and Paste
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To perform these commands, select a block and choose the command from the CSM.

Keyboard shortcuts:

Cut Ctrl + X
Copy Ctrl + C
Paste Ctrl + V

CPU Redundancy

There are three types of basic CPU redundancy. These redundant systems can be
used in combination with Genius redundancy schemes. For examples, see CPU
Redundancy over Genius.

For more information about redundant systems based on IC697CGR772 and
IC697CGR93, refer to the Series 90-70 Enhanced Hot Standby CPU Redundancy
User's Guide, GFK-1527. For redundant systems based on IC697CPU780, refer to
the Series 90-70 Hot Standby CPU Redundancy User's Guide, GFK-0827.

Single Bus with Preferred Master

Uses a single Genius bus with bus controllers in each PLC. The primary unit is
always chosen as the active unit when the units initially synchronize. (GHS control
strategy.)

Single Bus with Floating Master

Uses a single Genius bus with bus controllers in each PLC. No switchover occurs on
initial synchronization to make the primary unit the active unit. (GDB control
strategy.)

Dual Bus with Floating Master

Uses dual buses with the bus controllers in each PLC. No switchover occurs on
initial synchronization. Bus Switching Modules (BSMs) are required in accordance
with configuration of a dual bus network. This option provides redundancy of both
the PLC and the I/O bus. (GDB control strategy.)

Configuring CPU Redundancy Over Genius

CPU Redundancy Over Genius Types

There are five types of CPU Redundancy Over Genius systems, which are built upon
the various types of redundant Genius systems.

CPU Redundancy (GHS) Using Genius Dual GBC Redundancy (Paired GBC
External) – Single Bus with Preferred Master

CPU Redundancy (GDB) Using Genius Dual GBC Redundancy (Paired GBC
External) – Single Bus with Floating Master
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CPU Redundancy (GDB) Using Genius Dual Bus Redundancy (Paired GBC
External) – Single Bus with Floating Master

CPU Redundancy (GDB) Using Genius Dual Bus and Dual GBC Redundancy –
Dual Bus with Floating Master

CPU Redundancy (GDB) Using a Mixed Genius Redundancy Scheme

CPU Redundancy (GHS) Using Genius Dual GBC Redundancy (Paired GBC External

The following procedure configures two separate PLCs in one equipment folder.
The first one configured will be considered the Primary PLC in the system.  The
software will automatically create the configuration for the Secondary PLC.  The
configuration of the two PLCs will be identical except for a few necessary
differences such as CPU Redundancy Mode (Primary or Secondary) and the Serial
Bus Addresses (SBA) of the GBCs (31 for the Primary and 30 for the secondary).

1. From the Redundancy menu, select Wizard.

2. In the Wizards window, select a CPU. CPU model CPU780, CGR772, or CGR935
can be used in this redundancy system.

3. Select the Single Bus with Preferred Master redundancy setup and click Next.

4. Select the Rack and Slot locations for the BTM and RCM. Click Next.

5. Review the settings for Redundancy Scheme, BTM location, and RCM location. If
settings are correct, click Finish. If you need to make changes, click Back.

6. When you click Finish, the wizard will create a rack configuration with the selected
CPU, a BTM, and an RCM.

7. Use the redundancy wizard to configure Redundant Controllers, Two PLCs.

8. Configure critical data and all redundant %AQ and %Q references in the Shared I/O
section of the CPU Settings tab.

9. Use the redundancy wizard to generate the secondary rack system.

CPU Redundancy (GDB) using Genius Dual GBC Redundancy (Paired GBC External)

The following procedure configures two separate PLCs in one Equipment Folder.
The first one configured will be considered the Primary PLC in the system.  The
software will automatically create the configuration for the Secondary PLC.  The
configurations of the two PLCs will be identical except for a few necessary
differences such as CPU Redundancy Mode settings (Primary and Secondary), the
Serial Bus Addresses (SBA's) of the Genius Bus Controllers (31 for the Primary and
30 for the Secondary), and the possible differences in non-redundant Genius Bus
devices.

1. From the Redundancy menu, select Wizard.

2. In the Wizards window, select a CPU. CPU model CGR772 or CGR935 can be used
in this redundancy system.
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3. Select the Single Bus with Floating Master redundancy setup and click Next.

4. Select the Rack and Slot locations for the BTM and RCM. Click Next.

5. Review the settings for Redundancy Scheme, BTM location, and RCM location. If
settings are correct, click Finish. If you need to make changes, click Back.

6. When you click Finish, the wizard will create a rack configuration with the selected
CPU, a BTM, and an RCM.

7. Use the redundancy wizard to configure Redundant Controllers, Two PLCs.

8. Configure critical data and all redundant references in the Shared I/O section of the
CPU Settings tab.

9. Use the redundancy wizard to generate the secondary rack system.

CPU Redundancy (GDB) using Genius Dual Bus Redundancy (Paired GBC External)

The following procedure configures two separate PLCs in one Equipment Folder.
The first one configured will be considered the Primary PLC in the system.  The
software will automatically create the configuration for the Secondary PLC.  The
configurations of the two PLCs will be identical except for a few necessary
differences such as CPU Redundancy Mode settings (Primary and Secondary), and
the Serial Bus Addresses (SBA's) of the Genius Bus Controllers (31 for the Primary
and 30 for the Secondary).

1. From the Redundancy menu, select Wizard.

2. In the Wizards window, select a CPU. CPU model CGR772 or CGR935 can be used
in this redundancy system.

3. Select the Single Bus with Floating Master redundancy setup and click Next.

4. Select the Rack and Slot locations for the BTM and RCM. Click Next.

5. Review the settings for Redundancy Scheme, BTM location, and RCM location. If
settings are correct, click Finish. If you need to make changes, click Back.

6. When you click Finish, the wizard will create a rack configuration with the selected
CPU, a BTM, and an RCM.

7. Use the redundancy wizard to configure Dual Bus, Two PLCs.

8. Configure critical data and all redundant references in the Shared I/O section of the
CPU Settings tab.

9. Use the redundancy wizard to generate the secondary rack system.

CPU Redundancy (GDB) using Genius Dual Bus and Dual GBC Redundancy

The following procedure configures two separate PLCs in one Equipment Folder.
The first one configured will be considered the Primary PLC in the system.  The
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software will automatically create the configuration for the Secondary PLC.  Each
PLC will have two GBCs and they will control two Genius Buses.  The
configurations of the two PLCs will be identical except for a few necessary
differences such as CPU Redundancy Mode settings (Primary and Secondary), and
the Serial Bus Addresses (SBA's) of the Genius Bus Controllers (31 for the Primary
and 30 for the Secondary).

1. From the Redundancy menu, select Wizard.

2. In the Wizards window, select a CPU. CPU model CGR772 or CGR935 can be used
in this redundancy system.

3. Select the Single Bus with Floating Master redundancy setup and click Next.

4. Select the Rack and Slot locations for the BTM and RCM. Click Next.

5. Review the settings for Redundancy Scheme, BTM location, and RCM location. If
settings are correct, click Finish. If you need to make changes, click Back.

6. When you click Finish, the wizard will create a rack configuration with the selected
CPU, a BTM, and an RCM.

7. Use the redundancy wizard to configure Dual Bus and Redundant Controllers, Two
PLCs.

8. Configure critical data and all redundant references in the Shared I/O section of the
CPU Settings tab.

9. Use the redundancy wizard to generate the secondary rack system.

CPU Redundancy (GDB) using a Mixed Genius Redundancy Scheme

The following procedure configures two separate PLCs, each in its own Equipment
Folder.  The first one configured will be considered the Primary PLC in the system.
The Primary PLC shares CPU Redundancy Over Genius using a Dual Bus (Paired
GBC External) scheme with the Secondary PLC.  However, the Primary PLC also
has another redundant Genius system using a Dual GBC (Paired GBC Internal)
scheme that doesn't take part in the CPU redundancy scheme.

Use of Rack 7 in this CPU Redundancy Scheme

In this system, each PLC's CPU addresses the other PLC's Main Rack as though it
was its own Rack 7.  Therefore, Rack 7 in each PLC system (both Primary and
Secondary) will be reserved for this purpose and will not be available for use as a
physical expansion rack.

Storing the Configurations to the PLCs

The configurations for both the Primary and Secondary PLCs are stored in one
Equipment Folder.  The Store procedure lets you select what portions of the
equipment configuration to include in a Store operation.  Details about the store
procedure in general are found elsewhere in the online help.
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Basic Store Procedure

This example describes how to store the correct configuration to the Primary PLC.  If
your programmer is already connected to and communicating with the Primary PLC,
skip down to Step 4.

1. Connect your serial communications cable from your programmer (probably a
personal computer) to the PLC's programming port.

2. In the PLC menu, choose Connect.  The Connect dialog box will appear.

3. Select the Device name of your communications setup, then click the Connect button.
The connection will be made, and a Connection successful box will display.  Click the
OK button.

4. Select Tools on the Menu Bar to display the Tools menu.

5. Select Transfer Utilities on the Tools menu.

6. Select Store.  The Store to PLC dialog box will display.

7. Select only Hardware Configuration and Primary in the selection window.  A selected
item will have a check mark next to it.  Clicking the item will toggle its selection
check mark between on and off.

8. When finished with your selections, click the Store button to store your Primary
configuration to the Primary PLC.

Note: You can use this basic procedure to store your Secondary configuration
to the Secondary PLC, by connecting your programmer to the
Secondary PLC and selecting Secondary instead of Primary in the
selection window in step 7 above.

Configuring the Genius Redundant System

Genius Redundancy Types

There are five types of redundant Genius systems.  These are sometimes used in
conjunction with CPU redundancy schemes to provide additional protection against
component failure.  This type of system is called "CPU Redundancy Over Genius."

Dual Bus Redundancy (Paired GBC Internal)

1. From the Redundancy menu, select Wizard. Note that two open rack slots must be
available in this PLC for the GBCs, although the Paired GBC may be in another rack.

2. In the Wizards window, select Add GBCs for Genius Redundancy and click the Next
button.

3. Select Dual Bus, One PLC and click Next.
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4. Select rack and slot locations for the primary GBC and the Paired GBC. Click Next.

5. Review the settings for Redundancy Scheme and GBC locations. If settings are
correct, click Finish. If you need to make changes, click Back.

When you click Finish, the software will create the two Genius buses, and will add a
two GBCs to the PLC.  The parameter settings of this second GBC (except for the
rack and slot numbers, and SBA) will be a copy of those of the first GBC.  These
two GBCs will, by default, be assigned Serial Bus Addresses (SBAs) 30 and 31.
Each bus will contain an image of its GBC.

To configure devices on a Genius bus, see "Genius Bus Configuration."

To copy the device configurations from a redundant bus to its partner, select Wizard
from the Redundancy menu. Choose Copy a Redundant Bus and click Next. Follow
the Wizard instructions to complete the copy operation.

Dual Bus Redundancy Paired (GBC External) System

1. From the Redundancy menu, select Wizard.

2. In the Wizards window, select Add GBCs for Genius Redundancy and click the Next
button.

3. Select Dual Bus, Two PLCs and click Next.

4. Select rack and slot locations for the primary GBC. Click Next.

5. Review the settings for Redundancy Scheme and GBC locations. If settings are
correct, click Finish. If you need to make changes, click Back.

When you click Finish, the software will create the two Genius buses, and will add a
GBC to the PLC.  The GBC will, by default, be assigned Serial Bus Address (SBAs)
31. Each bus will contain an image of its GBC.

Genius Blocks used on this system may be redundant or non-redundant.  To configure
devices on a Genius bus, see "Genius Bus Configuration."

To copy the device configurations from a redundant bus to its partner, select Wizard from
the Redundancy menu. Choose Copy a Redundant Bus and click Next. Follow the Wizard
instructions to complete the copy operation.

Dual GBC Redundancy (Paired GBC Internal) System

1. From the Redundancy menu, select Wizard. Note that two open rack slots must be
available in this PLC for the GBCs. The Paired GBC may be in any rack.

2. In the Wizards window, select Add GBCs for Genius Redundancy and click the Next
button.

3. Select Redundant Controllers, One PLC and click Next.

4. Select rack and slot locations for the primary GBC and the Paired GBC. Click Next.
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5. Review the settings for Redundancy Scheme and GBC locations. If settings are
correct, click Finish. If you need to make changes, click Back.

When you click Finish, the software will add two GBCs to the PLC.  The parameter
settings of this second GBC (except for the rack and slot numbers, and SBA) will be
a copy of those of the first GBC.  These two GBCs will, by default, be assigned
Serial Bus Addresses (SBAs) 30 and 31. These SBAs should not be changed.

Genius Blocks used on this system may be redundant or non-redundant.  To configure
devices on a Genius bus, see "Genius Bus Configuration."

Although there is only one Genius bus in this system, each GBC has its own Genius
Bus window.  If all devices on the bus are configured as redundant, the Genius Bus
windows for these two GBCs will be identical.  However, if there are non-redundant
devices on the bus, they will only appear in the Genius Bus window of the GBC that
they were configured in.

To configure the second PLC rack in this system, see "Configuring the Second
PLC."

Dual GBC Redundancy (Paired GBC External) System

1. From the Redundancy menu, select Wizard. Note that two open rack slots must be
available in this PLC for the GBCs. The Paired GBC may be in any rack.

2. In the Wizards window, select Add GBCs for Genius Redundancy and click the Next
button.

3. Select Redundant Controllers, Two PLCs and click Next.

4. Select rack and slot location for the primary GBC. Click Next.

5. Review the settings for Redundancy Scheme and GBC locations. If settings are
correct, click Finish. If you need to make changes, click Back.

When you click Finish, the software will add a second GBC to the PLC.  The
parameter settings of this second GBC (except for the rack and slot numbers, and
SBA) will be a copy of those of the first GBC.  These SBA for the primary GBC
will, by default, be 31. The SBA of the other GBC will be 30. It is recommended that
you leave the SBAs at their default settings.

Genius Blocks used on this system may be redundant or non-redundant.  To configure
devices on a Genius bus, see "Genius Bus Configuration."

Although there is only one Genius bus in this system, each GBC has its own Genius
Bus window.  If all devices on the bus are configured as redundant, the Genius Bus
windows for these two GBCs will be identical.  However, if there are non-redundant
devices on the bus, they will only appear in the Genius Bus window of the GBC that
they were configured in.

To configure the second PLC rack in this system, see Configuring the Second PLC.

Dual Bus and Dual GBC Redundancy System
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1. From the Redundancy menu, select Wizard. Note that two open rack slots must be
available in this PLC for the GBCs. The Paired GBC may be in any rack.

2. In the Wizards window, select Add GBCs for Genius Redundancy and click the Next
button.

3. Select Dual Bus and Redundant Controllers, Two PLCs and click Next.

4. Select rack and slot location for the two GBCs. Click Next.

5. Review the settings for Redundancy Scheme and GBC locations. If settings are
correct, click Finish. If you need to make changes, click Back.

When you click Finish, the software will create the two Genius buses, and will add a
two GBCs to the PLC.  The parameter settings of this second GBC (except for the
rack and slot numbers, and SBA) will be a copy of those of the first GBC.  These
two GBCs will, by default, be assigned Serial Bus Addresses (SBAs) 30 and 31.
Each bus will contain an image of both GBCs.

Genius Blocks used on this system may be redundant or non-redundant.  To configure
devices on a Genius bus, see "Genius Bus Configuration."

To configure the second PLC rack in this system, see Configuring the Second PLC.

Configuring the Second PLC

1. To configure the second PLC rack in this system, first save the rack system.

2. Go to the Redundancy menu and select Wizard.

3. In the Wizards window, select Generate Secondary Rack System from the Current
Configuration and click Next.

4. If you wish to change the name or location of the secondary rack, edit the path field.
(You can also change the path by clicking the Browse button.)

5. Click Finish. A secondary rack system that is a copy of the primary rack system will
be generated.
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Configuring a VersaMax Modular Rack

When you enter Hardware Configuration for VersaMax equipment folders, the default
view is the Rack (Main). The power supply (PWR001) and CPU (CPU001) are in the
default configuration.

The VersaMax rack system is built by selecting carriers into which I/O, communications
and power supply modules are added.

The default VersaMax rack system has a main rack.  Multiple power supplies are
supported on the main rack, as required by the modules you need to add into your rack
system.

Two types of VersaMax expansion networks are available: Local Single Rack and
Multiple Remote Rack. The Multiple Remote Rack configuration allows up to seven
expansion racks. Multiple power supplies can be used in expansion racks.

In the physical hardware, field wiring is connected to the module carriers instead of the
modules.  HWC displays module wiring in the Module Parameters.  If you move a module
between carriers, be sure to update the wiring information accordingly.

Power Supply and CPU:
To edit CPU parameters, click the
right mouse button and select
Configure CPU Parameters.

Right Mouse Menu Choices:
Click the right mouse button to view
list of available commands for the
active carrier/module.

Empty Carrier
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Changing/Configuring the CPU

The default CPU is IC200CPU001.

• To replace the CPU:

1. Click the secondary mouse button and choose Replace CPU from the CSM.

2. Select a CPU from the Module Catalog. The Parameter Editor window for the
selected CPU will appear.

3. Review and modify CPU parameters in the Parameter Editor.

4. When you are finished editing the CPU parameters, click the window close button

 to close the Parameter Editor window.

• To view or change CPU parameters:

1. Click the secondary mouse button and choose Configure CPU Parameters from the
CSM. The Parameter Editor window for the CPU will appear.

2. Review and modify CPU parameters in the Parameter Editor.

3. When you are finished editing the CPU parameters, click the window close button

 to close the Parameter Editor window.

Note: To configure EGD exchanges for a CPUE05 see “Ethernet Global Data
Configuration” on page 7-33.

Rack/Module Operations

In addition to configuring the CPU (or NIU), the VersaMax rack configuration is
completed through the following operations, as required:

• Changing/Configuring the Power Supply

• Adding Module Carriers

• Adding Power Supply Booster Bases

• Configuring a Power Supply for a Booster Base

• Adding/Configuring Modules

• Deleting Carriers

• Clearing the Rack

• Configuring VersaMax Expansion Networks
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Changing/Configuring the Power Supply

The default power supply is the IC200PWR001. To change the default power supply:

1. Click the power supply slot, click the secondary mouse button and select Replace
Module. Select the new power supply from the Module Catalog.

2. The Parameter Editor window for the power supply will appear.

3. When you are finished reviewing the power supply parameters, click the window

close button  to close the Parameter Editor window.

Adding Module Carriers

Carriers must be configured to house module in the VersaMax PLC. Perform these steps
to configure module carriers.

1. To add a carrier to the right of configured modules, click the right mouse button and
choose Add Base/Carrier. The Module Catalog for Carriers will display.

To insert a carrier between two configured modules, highlight the module which will
be to the right of the new carrier, click the right mouse button and choose Insert
Base/Carrier.  The Module Catalog for Carriers will display.

Note: You must click the right mouse button over a module or carrier in the
rack configuration to view configuration choices from the right mouse
button.

2. Click the catalog number and description of the carrier you want to add, then click the
OK button.

Adding Power Supply Booster Bases

Power Supply boosters may be added into the system configuration to power modules
downstream from the booster.  Perform these steps to add a power supply booster base:

1. To add a Power Supply Booster Base to the right of configured modules, click the
right mouse button and choose Add Base/Carrier. The Module Catalog  will display.

To insert a Power Supply Booster base between two configured modules, highlight
the module which will be to the right of the new base, click the right mouse button
and choose Insert Base/Carrier.  The Module Catalog will display.

2. Click the Power Supply Booster Bases tab. Click the catalog number to select the
base, then click the OK button.

3. To configure the power supply, click the right mouse button and choose Add Module.
Select the Power Supply from the list and click OK.
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4. Configuring a Power Supply for a Booster Base

Power Supplies can be added throughout your VersaMax system. To add or replace a
configured power supply on a Booster Base:

1. Double-click the empty booster base. For booster bases with configured power
supplies, click the right mouse button and select Replace Module. The Power Supply
Module Catalog dialog box will appear.

2. Click the catalog number of the power supply you want to configure, then click the
OK button.  The Parameter Editor will display.

3. You can view information about the power supply.  Click OK to complete power
supply configuration.

Adding/Configuring Modules

Once a carrier is configured, the module may be added to the system:

1. Highlight the carrier which will house the module.

2. Double-click on the empty carrier or click the right mouse button and choose Add
Module. (If you are replacing a previously configured module, click the right mouse
button and choose Replace Module.)

3. Click the tab describing the I/O module type you need (Discrete Input, Discrete
Output, Analog Input, Analog Output, etc.).

4. Click the catalog number and description of the module in your system, then click the
OK button.

Configuring Module Parameters

To configure the module’s parameters:

1. When you add or replace a module, the Parameter Editor appears. You can also
access this window by double-clicking the module slot from the Rack window.

2. Within the Parameter Editor, click the tab pertaining to the parameters you want to
view or modify (where applicable).

3. Click in the Values fields you want to edit.  (See "Editing Tips" on page 7-4.)

4. When you have finished configuring module parameters, click the window close

button .
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Deleting Rack Modules

Deleting a module removes it from the rack. If you save the Hardware Configuration after
deleting the module, the configuration information about the deleted module will be lost.

Perform these steps to delete a module:

1. Select the module you want to delete.

2. Press the Delete key or click the right mouse button and choose Delete Module.

Deleting Carriers

You must use the menu bar or right mouse operations to delete a carrier. Perform these
steps to delete a carrier:

1. Highlight the empty carrier you want to delete.

2. Click the right mouse button and choose Delete Carrier.

Clearing the Rack

Clearing the rack removes all modules (except the power supply and CPU). If you save
the Hardware Configuration after clearing the rack, the configuration information about
the deleted modules will be lost.

Perform these steps to clear the rack configuration:

1. Click anywhere in the Rack.

2. Click the right mouse button and choose Clear Rack.

3. A confirmation dialog box will appear. To confirm the clear rack operation, click the
Yes button.

Configuring VersaMax Expansion Networks

There are three types of configurations in the VersaMax rack system. To change the rack
configuration, select the type you want from the context-sensitive menu or from the Edit,
Expansion Rack System submenu.

None

Includes only the Main VersaMax rack (no Expansion). Systems created using VersaPro
1.0 have this type of configuration. This is the default VersaMax System, which is created
when you select New from the File menu or when you convert from another rack system,
such as Series 90-30.
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Local Single Rack

Includes the Main VersaMax I/O station and one Expansion rack. The Main VersaMax
rack does not contain a Transmitter. The Expansion rack contains a non-isolated Power
Supply and Receiver Integrated Unit (IC200ERM002). The power supply is not
configured unless the Receiver unit is active. The default power supply in the expansion
rack will be the same as the main rack's power supply. Replacing the main rack's primary
power supply will not affect the expansion rack's primary power supply.

Multiple Remote Rack

Allows you to configure up to seven Expansion racks (seven Rack tabs are always shown).
The Main VersaMax rack contains a Transmitter (IC200ETM001). The Non Isolated
Receiver (IC200ERM002), which is configured by default, can be replaced by an Isolated
Receiver (IC200ERM001).

Notes: The Transmitter and Receiver modules cannot be added from the
module catalog. The only way to add these modules to a rack
configuration is to choose the appropriate configuration type. Also, you
cannot delete them from a rack configuration except by changing the
rack configuration type.

If a single-ended receiver is configured and an expansion transmitter is
present, a fatal “expansion transmitter mismatch” fault will be
generated. This fault will also be generated if a differential (transmitter
and receivers) is configured and no expansion transmitter is physically
present.  In these cases, no faults will be generated for individual
modules in the expansion racks. The CPU detects the presence or
absence of receiver modules connected through the expansion bus and
compares the physical configuration with the programmed
configuration.  It will generate a “Loss of rack” alarm for missing
receivers and an “Addition of or extra rack” alarm for extra receivers.

Switching Between VersaMax Rack Systems

You can switch from one VersaMax rack system type to another. This allows single rack
systems created in VersaPro versions earlier than 1.10 to be upgraded to Local Single
Rack and Multiple Remote Rack systems. Switching rack system types has the following
effects:

When you switch configurations, a message is displayed which gives you the option of
carrying out the parameter changes of the existing CPU/modules to the new rack
configuration.

To change rack system type, choose Expansion Rack System from the CSM or the Edit
menu. Select an expansion rack type from the submenu.
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Changing VersaMax Rack Systems

From To Results

None Local Single Rack A new expansion rack appears.

None Multiple Remote
Rack

Seven new expansion racks appear in the rack
system.

Multiple Remote Rack or
Local Single Rack

None A message is displayed to warn about the loss
of rack(s) and modules in it and the fact that
these operations cannot be undone. If you click
OK, the standard rack will be displayed.

Multiple Remote Rack Local Single Rack A message is displayed to warn about the loss
of rack(s) and modules in it and the fact that
these operations cannot be undone. If you click
OK, a rack system containing Main and Rack 1
tabs will be displayed. If there is an isolated
receiver in the first expansion rack, it is
replaced with the default non isolated receiver.

Related Parameters for Multiple Remote Rack Systems

On the Settings tab for CPU parameters, the Expansion Bus Speed parameter appears if
Multiple Remote Rack is selected and if there is an isolated receiver present in any one of
the expansion racks. Values are Extended Distance (default) and Normal. For Normal
distance, the maximum allowable cable length is 15m (250ft) and the baud rate may vary
between 250KHz, 1MHz, 3MHz, or 5MHz. For Extended Distance, the maximum
allowable distance is 250m (820ft) and baud rate is fixed at 250KHz.

Each expansion rack has one Power Supply and Non Isolated Receiver Unit. The isolated
receiver can be replaced with the non-isolated receiver and vice versa. (see “Expansion
Rack Operations”).

Note: When a module is auto-configured and the Expansion Bus Speed
setting changes as a result, an "Expansion bus speed change" fault will
be generated. You should correct the Expansion Bus Speed setting.
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Expansion Rack Operations

The catalog ID and description for the Power Supply And Receiver-Integrated unit is
shown on the status bar. When you select the integrated unit, the receiver information is
shown as a part of the status bar.

Selecting an Expansion Receiver

By default, the Expansion Receiver type is None. A power supply is not configured for the
Expansion Rack until an Expansion Receiver is configured. There are three ways you can
configure an Expansion Receiver:

• By adding any base unit in the expansion rack. A Non-Isolated Receiver Unit will be
configured by default.

• By right-clicking on the rack and selecting a Receiver Unit from the Expansion
Receiver submenu.

• By choosing a Receiver Unit from the Edit submenu, Expansion Receiver.

To deactivate the unit, select None from the Expansion Receiver submenu. (This
option is not available if the rack configuration contains one or more Carrier/Base
units.

Changing Receiver Type for Expansion Racks in Multiple Rack Systems

The Power Supply And Receiver-Integrated unit consists of IC200PWR001 and
IC200ERM002 (non-isolated receiver) by default. For expansion racks in Multiple
Remote Rack systems, an isolated receiver (IC200ERM001) can be selected. To change
the receiver, choose Expansion Receiver from the Edit menu or the CSM.

Viewing Power Consumption Values

To view the parameters for the power supply, double click on the Power Supply and
Receiver-Integrated unit. Power values for the receiver are shown in the parameter dialog
of the receiver and the value is non-editable. Receiver power is included as part of the
total power consumption of the main power supply.

To view the parameters for the receiver, choose Configure Receiver Parameters from the
context-sensitive menu or from the Edit, Rack Operations menu.

Clearing the Rack for Multiple Remote Rack Systems

When you select this option with focus on the Main rack, the transmitter will not be
cleared. If you select this option with focus on expansion rack, it clears all the modules
except the Power Supply And Receiver-Integrated unit.
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Configuring Receiver Parameters

This option displays the Receiver parameters for the selected Expansion rack. (The
Receiver units have no configurable parameters.)

Loading VersaMax Hardware Configurations

For general information on loading a hardware configuration, see “Loading a Folder to
Your Computer” in Chapter 10.

VersaMax Modules with Shared IDs

When the configuration is loaded from a rack system, HWC uses the hardware module ID
to determine the correct module catalog number and description. However, some
VersaMax modules share the same module IDs. When a VersaMax rack system containing
these modules is auto configured and the configuration is loaded an incorrect catalog
number and description may be displayed. You will need to select the correct module from
the modules catalog and store it to the rack system. After storing the configuration, you
will be able to load the configuration properly.

The following modules share hardware module IDs:

IC200MDL650 loads as IC200MDL636
IC200MDL750 loads as IC200MDL742
IC200MDL331 loads as IC200MDL329
IC200MDD844 loads as IC200MDD842
IC200MDL141 loads as IC200MDL140
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Configuring a VersaMax Remote I/O Rack

A VersaMax Remote I/O (RIO) rack consists of a network interface unit (NIU) and
supported I/O modules. Three types of NIUs are available: Genius (GNIU), Profibus
(PNIU), and Ethernet (ENIU). All VersaMax I/O modules are supported except
IC200BEM002 and IC200BEM103.

When you enter Hardware Configuration for VersaMax equipment folders, the default
view is the Rack (Main). The power supply (PWR001) and CPU (CPU001) are in the
default configuration. To configure a Remote I/O rack, you must replace the CPU with an
NIU and configure the NIU parameters.

As in a VersaMax rack system with a CPU, the RIO rack system is built by selecting
carriers into which I/O, communications and power supply modules are added.

The default VersaMax rack system has a main rack.  Multiple power supplies are
supported on the main rack, as required by the modules you need to add into your rack
system.

The RIO supports two types of expansion networks: Local Single Rack and Multiple
Remote Rack. The Multiple Remote Rack configuration allows up to seven expansion
racks. Multiple power supplies can be used in expansion racks.

In the physical hardware, field wiring is connected to the module carriers instead of the
modules.  HWC displays module wiring in the Module Parameters.  If you move a module
between carriers, be sure to update the wiring information accordingly.

Configuring an NIU

The default CPU is IC200CPU001.

• To replace the CPU with an NIU:

1. Click the secondary mouse button and choose Replace CPU from the CSM.

2. Select an NIU from the Module Catalog. The Parameter Editor window for the
selected NIU will appear.

3. Review and modify NIU parameters in the Parameter Editor.

4. When you are finished editing the NIU parameters, click the window close button

 to close the Parameter Editor window.
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• To view or change NIU parameters:

1. Click the secondary mouse button and choose Configure NIU Parameters from the
CSM. The Parameter Editor window for the NIU will appear.

2. Review and modify NIU parameters in the Parameter Editor.

3. When you are finished editing the NIU parameters, click the window close button

 to close the Parameter Editor window.

Configuring the RIO Rack

The general procedures for configuring carriers, power supplies, and modules in an RIO
rack are the same as for a modular CPU rack. For details, see “Rack/Module Operations”
on page 7-22.

Load/Store/Verify RIO Configuration

For Genius and Profibus NIUs, the Load, Store, and Verify operations require cable
IC200CBL002, which is used to connect a COM port on your PC to the serial port on the
left side of the VersaMax NIU.

For Ethernet NIUs, these operations use an Ethernet connection.

Communications Setup

To define communications parameters for the rack system, select Communications Setup
from the Tools menu. The CCU will open.  (If a password has been defined for the
Communication Configuration Utility, the Password dialog box will appear. Enter your
password and press OK to continue.)  The main screen of the Communication
Configuration Utility will appear.

When configuring a Device in the CCU for use with a GNIU or PNIU, you should assign
a Name and default Port. Port Type should be set to SNP_SERIAL. All other fields should
be left at their default values.

When configuring a Device for use with an ENIU, you should assign a Name, default
Port, and IP address. Port Type should be set to TCPIP_ETH.
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Storing RIO Configuration

To transfer the configuration data to the associated Rack System:

1. Choose Load/Store/Verify in the Tools menu.

If the configuration has not been saved, the message, “Please save this rack system
first,” will appear, followed by the “Save As” dialog box. You must save the rack
system once before the Load/Store/Verify dialog box can be opened.  After you have
saved the rack system once, auto-saves will be performed when this command is
invoked.

2. In the Load/Store/Verify Hardware Configuration dialog box select a Device and a
Port.

3. Click the Store button. The programming software will automatically connect to the
NIU.

Note: If you attempt to store a hardware configuration to an NIU that does not
match the type selected in the configuration, an error message will
appear and the operation will be stopped.
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Loading RIO Configuration

To load configuration data from the Rack System:

1. Choose Load/Store/Verify in the Tools menu.

2. In the Load/Store/Verify Hardware Configuration dialog box select a Device and a
Port.

3. Click the Load button. The programming software will automatically connect to the
NIU.

Note: If you attempt to load a hardware configuration from an NIU that does
not match the type selected in the configuration, an error message will
appear and the operation will be stopped.

VersaMax Modules with Shared IDs

When the configuration is loaded from a rack system, HWC uses the hardware module ID
to determine the correct module catalog number and description. However, some
VersaMax modules share the same module IDs. When a VersaMax rack system containing
these modules is auto configured and the configuration is loaded an incorrect catalog
number and description may be displayed. You will need to select the correct module from
the modules catalog and store it to the rack system. After storing the configuration, you
will be able to load the configuration properly.

The following modules share hardware module IDs:

IC200MDL650 loads as IC200MDL636
IC200MDL750 loads as IC200MDL742
IC200MDL331 loads as IC200MDL329
IC200MDD844 loads as IC200MDD842
IC200MDL141 loads as IC200MDL140

Verifying RIO Configuration

To verify the rack configuration:

1. In the Load/Store/Verify Hardware Configuration dialog box select a Device and a
Port.

2. Click the Verify button. The programming software will automatically connect to the
NIU, perform the verification, and disconnect from the NIU. The Log window will
display the results of the operation.
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Clearing RIO Configuration

This procedure clears the configuration and forces an autoconfiguration. If you clear the
NIU and then do a load from the NIU, you will be loading a default configuration that will
overwrite your existing configuration.

1. In the Load/Store/Verify Hardware Configuration dialog box select a Device and a
Port.

2. Click the Clear button. The programming software will automatically connect to the
NIU, clear the configuration, disconnect and display the results in the Log Window..
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Ethernet Global Data Configuration

EGD allows one device (the producer) to transfer (exchange) data to one or more other
devices (the consumers) at a regularly scheduled transfer rate. EGD exchanges can be
configured for a Series 90-30 CPU364 or a VersaMax CPUE05.

Caution

EGD exchanges are designed for simple, efficient
communication of sampled data between devices. They are not
intended for event notification where the possible loss of a
sample of data would be significant. For event notification, it is
recommended that a Service Request Transfer Protocol
(SRTP) connected service be used.

The exchange of data is uniquely defined through a combination of the Producer ID
(identification number) and the Exchange ID:

• Each device exchanging Ethernet Global data on the network must be assigned its
own unique Producer ID.  This Producer ID uniquely identifies the source device of
Ethernet Global data on the network.  The Producer ID number is in dotted-decimal
format (like an IP Address).  For example, 3.0.0.1 is a valid Producer ID.

• An Exchange ID is a unique number that identifies a particular variable or group of
variables to be transferred.

Producing devices and consuming devices operate completely asynchronously to each
other.  Therefore, for each device, both the data that the device produces and the data that
the device consumes must be separately defined.

Note: For the CPUE05, the local Ethernet device used for each exchange is
specified as a Rack/Slot value instead of as a configured Adapter Name.
The CPUE05 does not support named aliasing and name resolution and
routing. To define EGD exchanges for a CPUE05, refer to page 7-38.
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Configuring the Ethernet Interface Adapter Name (CPU364)

If the CPU364 will be used in EGD exchanges, you must specify an Adapter Name.
When you define an EGD exchange, you will use the Adapter Name to specify which
network adapter will produce the exchange.

To specify the adapter name for a CPU364 Ethernet Interface:

• From Hardware Configuration, confirm that the CPU364 has been configured. Also,
confirm that the IP address for the Ethernet module is correct. If so, double-click the
CPU slot.

• The Parameter Editor will appear. Choose the Ethernet tab.

• Click the Values field beside Adapter Name and type a name for the adapter. When
finished, click the OK button.

Setting Aliases for Remote Ethernet Interfaces (CPU364)

If a remote Ethernet controller will be used in EGD exchanges, you must associate an alias
with the card's IP address. When you define an EGD exchange, you will use this alias to
specify which network adapter will produce the exchange.

To specify an alias for a remote Ethernet Interface:

• In Hardware Configuration go to the Edit menu, choose Rack Operations, and select
Name Resolution and Routing (or click the right mouse button and choose Name
Resolution Routing from the pop-up menu).

• In the Name Resolution and Routing Table dialog box, click the Aliases tab.

• Click the Add Entry button.

• In the Alias field, type the name you want to use to refer to the remote Ethernet
controller.

• Click the IP Address field and type the IP address of the Ethernet controller then click
the OK button.

Name Resolution and Routing Table Configuration (CPU364)

The CPU364 supports the Routing Table feature, an advanced tool for configuring
communications between PLCs.  The Routing Table should not be configured without
assistance from a network administrator.  A Routing Table should only be configured
when more than one gateway is to be configured.
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Definitions of routing table terms:

Destination Subnet ID - The destination subnet of the data to be routed is evaluated
against this subnet ID.  A match (same subnets) causes the data to be routed to the next
hop IP address.

Destination Subnet Mask - The mask associated with the destination subnet under
evaluation.

Next Hop IP Address -  The IP address where the data should be sent next to progress
toward its final destination.

Cost - This field is reserved.  Default value is 1.

Accessing the Routing Table Configuration

From Hardware Configuration go to the Edit menu, choose Rack Operations, and
select Name Resolution and Routing. (or click the right mouse button and choose
Name Resolution and Routing from the shortcut menu).  The Name Resolution and
Routing Tables dialog box will display.

In the Name Resolution and Routing Tables dialog box, click the Routing tab.

Click the Add Entry button.

In the Destination Subnet ID field, enter the subnet ID (in dotted decimal
format) of the remote subnet to which you wish to route data (for example,
4.12.20.0).

In the Destination Subnet Mask field, enter the subnet mask associated with that
remote subnet (for example, 255.255.255.0).

In the Next Hop IP Address field, enter the IP address of the local gateway to
which you wish to send the data (for example, 3.16.32.1), then click the OK
button.

Subnet, Subnet ID, Subnet Mask

The subnet mask is a mechanism to logically divide a large network into smaller subnets
according to your local assignment of IP addresses to nodes on the network.  Nodes on the
network which have their IP addresses alike for the bits specified in the subnet mask can
talk to each other directly; nodes whose IP addresses are not alike in these same bits must
talk indirectly, via an intermediate gateway or router.

As described in an appendix to your Ethernet module user manual, the 32 bits of an IP
address are divided between a net id part and a host id part.  (The class of the IP address
determines how many bits are in the net id and how many are in the host id.)  In general,
the net id portion of the IP address (on the left) is assigned by the Internet authorities.  The
host id (on the right) is assigned by your local network administrator.  Subnetting is
locally optional and consists of designating some (any number) of the host id bits as a an
extended net id, or subnet id.  The added subnet id bits are normally taken from the host id
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bits adjacent to the net id and the subnet mask identifies these bits.  In your Ethernet
module configuration, you specify these bits as one (1) and the remaining host id bits as
zero (0).  For example:

IP Address: 11.22.33.44

Net Id bits: 255.0.0.0 Net Id: 11.0.0.0

Added Subnet Id bits: 0.255.0.0 Subnet Id: 0.22.0.0

Subnet Mask: 255.255.0.0 "Extended" Net Id: 11.22.0.0

Subnet ids and subnet masks are entered into the Routing Table when configuring
Multiple Gateways.  The extended net id (for example, 11.22.0.0 in the above example)
should be entered for the subnet id.

All nodes on a "subnetted" network must use the same value for subnet mask; subnets are
distinguished by different subnet id's, created by your local assignment of IP addresses.

Defining EGD Exchanges

You need to specify the operating characteristics and data to be exchanged for each
exchange your PLC will produce or consume. Note the following exchange limitations:

• The maximum number of exchanges that can be defined for a PLC system is as
follows:

Series 90 CPU364 128
VersaMax CPUE05 64

This number can be divided up into any combination of produced and consumed
exchanges.

• Up to 100 variables can be configured per exchange. The CPUE05 is restricted to a
total of 1200 variables across all EGD exchanges.

• The total size of a single exchange cannot exceed 1400 bytes.  The total size is
defined to be the sum of the data type lengths of all of the variables within the list.
The exchange size is displayed in the Ethernet Global Data dialog box.

To define an EGD exchange:

1. From Hardware Configuration, go to the Edit menu, choose Rack Operations, and
select Ethernet Global Data (or click the right mouse button and choose Ethernet
Global Data from the pop-up menu).

2. In the Ethernet Global Data dialog box, click the Produced Exchanges tab to define
exchanges produced by your PLC or click the Consumed Exchanges tab to define
exchanges consumed by your PLC.
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PLC Timing Considerations

Since the PLC scan time and the exchange time settings (Exchange Period for produced
exchanges and Scan Period for consumed exchanges) are asynchronous, the following
should be noted:

• The production of a data sample onto the network occurs at the specified Exchange
Period and is independent of the time the data sample is actually updated from the
CPU.  The CPU will attempt to update the data sample at the Exchange Period
interval but cannot guarantee delivery at that specific time due to being delayed by the
PLC sweep time. For example, if the CPU is executing logic when the exchange
period expires, the update will be delayed until the logic execution is complete.
Therefore, the data sample produced on the network may be a duplicate of a
previously sent sample. Use the timestamp feature to verify whether the data is new.
(The CPU364 uses SNTP timestamping and the CPUE05 uses NTP timestamping.)

• The first update of the data sample from the CPU to the network adapter will occur at
the end of the first scan.  The first production of data onto the network will occur one
Production Period after the CPU transitions to the I/O Enabled state.

• The CPU in the consumer will scan the data at the Scan Period independent of when
the data is updated from the network. (The network adapter updates the data upon
arrival of the data sample from the network.)  Data will not be updated in CPU
memory unless it has been received from the network.

• A range of reference memory within an exchange list can be viewed as coherent to
scan if the length is less than 256 bytes.  If interrupts are enabled, a string of multiple
ranges may not all be deposited on the consumer side during the same scan.
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Ethernet Global Data: Example 1

Here is an example to illustrate how EGD works. The figure that follows shows three
devices (two PLCs and a PC running CIMPLICITY HMI) participating in an EGD
exchange.

Device A
Assigned Producer ID: 10.0.0.1

Device B
Assigned Producer ID: 10.0.0.2

Device C
Assigned Producer ID: 10.0.0.3

Exch. Definition: Prod ID 10.0.0.1 Exch ID: 1

Exch. Definition: Prod ID 10.0.0.1 Exch ID: 2

Exch. Definition: Prod ID 10.0.0.2 Exch ID: 1

In this example, Device A produces two exchanges and consumes none, Device B
produces one exchange and consumes one, and Device C produces no exchanges but
consumes three. The exchange produced by Device A and consumed by both Device B
and Device C is an example of Group Usage, whereby multiple devices consume data
produced by one producing device.
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Ethernet Global Data: Example 2

This example shows the details of a simple exchange of data from producing device A to
consuming device B.

Device A
Assigned Producer ID: 10.0.0.1

Device B
Assigned Producer ID: 10.0.0.2

PLC A sends the information
contained in the memory locations
defined for the following variables:

P_Var1 (6 bytes)
P_Var2 (4 bytes)

PLC B receives the sent information
and stores it in the memory location

defined for the following variable:
C_Var1 (10 bytes)

PLC A sends the information contained in the following reference memory locations.
Each byte in the exchange contains eight discretes aligned at byte boundaries.

%I00001 to %I00016

%Q00001 to %Q00008

PLC B receives the information and stores it in three consecutive bytes in %G memory, as
follows:

%G00001 to %G00024
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Details of Producing PLC A

The details of the exchange that PLC A produces are defined in the Produced Exchanges
tab of the Ethernet Global Data dialog box:

• Local Producer:  By default, uses the IP address of the network interface card closest
to the CPU of PLC A.  The Local Producer can be changed by the user.

• Exchange ID: Identifies the packet of data that will be sent.

• Net Address Name: The name assigned to the network adapter within this PLC
system that will be producing the exchange.

• Consumer Type: Specifies how the consuming device will be identified (by name, IP
address, or group ID). For this example, the consuming PLC is identified by its Local
Producer IP Address.

• Consumer Address: The Local Producer IP Address assigned to PLC B.

• Send Type: Defines when the exchange will be transmitted.  This field is fixed at
Always.

• Producer Period: PLC A will produce the data every 50 milliseconds.

• Reply Rate: Not used.

• Status Word: A reference address for status memory location where the status word
is stored. The status word can signify when an error has occurred.

Details of Consuming PLC B

The details of the exchange that PLC B consumes are defined in the Consumed Exchanges
tab of the Ethernet Global Data dialog box:

• Local Producer:  Uses the IP address of the network interface card closest to the
CPU of PLC B

• Exchange ID: Identifies the packet of data that will be received.

• Net Address Name: The name assigned to the network adapter within this PLC
system that will be consuming the exchange.

• Producer ID: The Local Producer IP Address assigned to PLC A.

• Group ID: Used when more than one device is consuming the same exchanges from
one producer. Value 0 means only one device is consuming the information.

• Consumed Period: The CPU of PLC B will scan the local network adapter for new
data and/or status updates every 25 milliseconds.

• Update Timeout: The network adapter will set a status error to signal a refresh error
if data is not received within 1000 milliseconds.
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• Status Word: A reference address for the memory location where the status word is
stored. The status word can signify when an error has occurred.

• Time Stamp: A reference address for the memory location where the time stamp is
stored. The time stamp can be checked to verify if the data received is a new sample
rather than a duplicate of a previously received sample.

Restoring EGD and Name Resolution

You cannot load EGD or Name Resolution from the CPU364. When you initiate the Load
configuration process, the confirmation dialog box presents the option of backing up the
EGD and Name Resolution configuration.

To restore these configuration components to your folder, go to the HWC File menu and
select Restore EGD and Name Resolution. A browser window will open to enable you to
navigate to the backup file.

Advanced User Parameters for EGD (CPUE05)

The Ethernet firmware maintains default values for all advanced user parameters. These
default values satisfy the needs of most applications. Under special circumstances, some
users may need to modify some of these parameters. Advanced user parameters can be
modified using an Advanced User Parameters file, which can be created using an ASCII
text editor. This file contains the name and value of all non-default advanced user
parameters. (The Ethernet firmware assigns the proper default value to every advanced
user parameter not specified in the Advanced User Parameters File.

All advanced user parameter data for a single Ethernet interface must be provided in a
single file.

The Advanced User Parameter file is named AUP_0_0.apf, where 0_0 specifies the rack
and slot location of the embedded Ethernet interface within the CPUE05. This file is
placed in the folder containing the PLC configuration. During a Configuration Store
operation, the VersaPro programmer stores the Advanced User Parameter file into the
PLC along with the PLC Configuration.
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Advanced User Parameter File Format

AUP_r_s

<parameter name> = <parameter value>

<parameter name> = <parameter value>

<parameter name> = <parameter value>

• One parameter may be specified per line.

• Each parameter is listed by name and value, separated by an equals sign (=).

• All parameter names must be entered in lower case.

• Parameter values are converted to lowercase unless enclosed in a pair of double
quotes (" "). The enclosing quotes are removed and the parameter value is not
converted to lowercase.

• The parameter value data format depends upon the parameter. Numeric parameters
are entered in decimal or hexadecimal format. Hexadecimal values must be
terminated with an "h" or "H" character.

• IP address parameters must be entered in standard dotted decimal format. (Example:
10.0.0.1)

• The semicolon character delimits comments. All characters in the line following a
semicolon are ignored.

• Blank lines are ignored.

Sample Advanced User Parameter File

AUP_0_0

stpasswd = "system"

g01_udp = 4741H

g01_addr = 224.0.7.121

g02_udp = 4742H

g01_addr = 224.0.7.122

; This is a comment

The CPUE05 advanced user parameters are similar to CPU364 advanced user parameters.
Additional information for the CPU364 is provided in the TCP/IP Ethernet
Communications for the Series 90 PLC, GFK-1541. For the CPUE05, refer to the
VersaMax Station Manager Manual, GFK-1873.
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Configuring VersaMax Nano and Micro PLCs

A VersaMax Micro PLC system consists of a main module and up to four optional
Expansion Units. (The VersaMax Nano PLC does not support Expansion Units.)

The main module contains CPU, I/O, and HSC/PWM/PTO functions. Expansion Units
provide I/O functions only. The compact, lightweight units are designed for 35mm DIN
rail or panel mounting.

The sample system shown below has a main module (required) and one Expansion Unit.

Rack/Module Operations

To replace a main module (IC200UDR005/010 is the default), select Replace Module or
Replace CPU from the context-sensitive menu or select Replace CPU from the Edit, Rack
Operations submenu.

To add an Expansion Unit to the system, select Add Module from the context-sensitive
menu or from the Edit, Module Operations submenu. The Expansion Unit is added to the
end of the chain.

To replace an Expansion Unit, select the Expansion Unit and choose Replace Module
from the context-sensitive menu or from the Edit, Module Operations submenu.

To remove an Expansion Unit from the system, select Delete Module from the context-
sensitive menu or from the Edit, Module Operations submenu. Only the last expansion
unit in the chain can be deleted.

Note: The main module cannot be deleted from the system.

To remove all Expansion Units from the system, select Clear Rack from the context-
sensitive menu or from the Edit, Rack Operations submenu.

When you add or replace a module, the Parameter Editor window will appear.
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Counter, Pulse Width Modulation, and Pulse Train Output

To configure the High Speed Counter, Pulse Width Modulation, and/or Pulse Train Output
functions, go to the Edit menu and select Module Operations, Configure Parameters,
HSC/PWM/PTO. You can also choose Configure Parameters, HSC/PWM/PTO from the
context-sensitive menu. A Parameter Editor window similar to the one shown below will
appear (Nano PLCs have only three counter tabs.) For details on configuring these
functions, choose Module Help from the Help menu.

PWM Frequency and Duty Cycle

The frequency and duty cycle of the PWM output are specified from the application
program. Pulse Train Output frequency is also controlled from the application program
(duty cycle is nominally 50%).

For details on configuring and using these features, refer to Chapter 10 of the VersaMax
Micro PLCs and Nano PLCs User’s Manual, GFK-1645.

Configuring Averaging Filter for Analog Input Potentiometers

VersaMax Micro PLCs have two potentiometers, located below the Run/Stop switch, that
can be used to manually set input values that are stored in %AI16 and %AI17.

The number of samples to be averaged can be controlled by the application program. By
default, 16 samples will be averaged.

For details on configuring and using this feature, refer to Chapter 9 of the VersaMax
Micro PLCs and Nano PLCs User’s Manual, GFK-1645.
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Configuring Series 90 Micro PLCs

A Series 90 Micro PLC is a self-contained module that provides CPU, I/O, and
HSC/PWM/PTO functions. The 23 and 28-point Micro PLCs support up to four optional
Expansion Units that provide I/O functions only. The compact, lightweight units are
designed for 35mm DIN rail or panel mounting.

The sample system shown below has a main module (required) and one Expansion Unit.

Rack/Module Operations

To replace a main module (IC693UDR005/010 is the default), select Replace Module or
Replace CPU from the context-sensitive menu or select Replace CPU from the Edit, Rack
Operations submenu.

To add an Expansion Unit to the system, select Add Module from the context-sensitive
menu or from the Edit, Module Operations submenu. The Expansion Unit is added to the
end of the chain.

To replace an Expansion Unit, select the Expansion Unit and choose Replace Module
from the context-sensitive menu or from the Edit, Module Operations submenu.

To remove an Expansion Unit from the system, select Delete Module from the context-
sensitive menu or from the Edit, Module Operations submenu. Only the last Expansion
Unit in the chain can be deleted.

Note: The main module cannot be deleted from the system.

To remove all Expansion Units from the system, select Clear Rack from the context-
sensitive menu or from the Edit, Rack Operations submenu.

When you add or replace a module, the Parameter Editor window will appear.
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Counter, Pulse Width Modulation, and Pulse Train Output

To configure the High Speed Counter, Pulse Width Modulation, and/or Pulse Train Output
functions, go to the Edit menu and select Module Operations, Configure Parameters,
HSC/PWM/PTO. You can also choose Configure Parameters, HSC/PWM/PTO from the
context-sensitive menu. A Parameter Editor window similar to the one shown below will
appear (Nano PLCs have only three counter tabs.) For details on configuring these
functions, choose Module Help from the Help menu.

PWM Frequency and Duty Cycle

The frequency and duty cycle of the PWM output are specified from the application
program. Pulse Train Output frequency is also controlled from the application program
(duty cycle is nominally 50%).

For details on configuring and using these features, refer to Chapter 5 of the Series 90
Micro PLC User’s Manual, GFK-1065.

Configuring Averaging Filter for Analog Input Potentiometers

VersaMax Micro PLCs have two potentiometers, located below the Run/Stop switch, that
can be used to manually set input values that are stored in %AI16 and %AI17.

The number of samples to be averaged can be controlled by the application program. By
default, 16 samples will be averaged.

For details on configuring and using this feature, refer to Chapter 8 of the Series 90 Micro
PLC User’s Manual, GFK-1065.
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Hardware Configuration Reference View

HWC Reference View provides information about references allocated when modules are
added to the rack system. This view is updated each time an I/O or specialty module is
added to or deleted from the system.

The Reference View is a dockable view, which means that you can select it with your
mouse and move it anywhere in the HWC main window.  You can control display of the
reference view. To display or hide the reference view, select the View menu and click
Reference View.

The reference view maintains a separate tab for each reference type used in HWC (%I,
%Q, %AI, %AQ, %G, %M, %R, …).  To view reference information for a specific
reference type, click the tab that corresponds to that reference type.

Each row provides reference point assignments for a specific module.  The columns are
configured as follows:

• Overlap: By default, non-fatal overlaps are identified in blue text and fatal overlaps
are identified in red text.

• Start: Displays the starting reference point assignment for the module.

• End: Displays the ending reference point assignment for the module.

• Addr: Displays the module’s Rack/Slot address in the form R.S where:

o R is the relative rack number (0 indicates first, or main, rack)

o S is the relative slot number within the assigned rack (0 indicates the leftmost
slot)

• Mem Type: Identifies whether the module produces or consumes data in the
allocated memory area.

• Catalog #: Display’s the module’s catalog number.



7-50  VersaPro™ Programming Software User's Guide – October 2001  GFK-1670D

7   

Hardware Configuration Log View

HWC offers a logging facility which records and maintains a history of HWC events and
status information. The data is saved in a separate log file on the PC hard disk, and may be
accessed through multiple edit sessions. The default size of the log file default is 1MB.  If
the log data exceeds this size, the oldest log information is overwritten with new log data.

HWC provides two modes for recording log data:

• Exception Only Mode: Only warnings and exception conditions are recorded in the
log.

• Audit Trail Mode (default mode): Informational messages (such as module deletes,
adds, etc.) are recorded in the log, in addition to warnings and exception conditions.

To change the setting for the log file, select the Tools menu and choose Options.  The
Options dialog box will display, allowing you to set Audit Trail Mode and adjust the
default log file size.

The Log View is a dockable view, which means that you can select it with your mouse
and move it anywhere in the HWC main window.  You can control display of the log
view. To display or hide the log view, select the View menu and click Log View.
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Hardware Configuration Power Consumption View

The Power view displays current power consumption statistics for the power supply that is
providing power to the currently selected module.  These statistics are provided to assist
you in monitoring the power requirements of the I/O modules you are configuring in the
individual racks.

To enable or disable docking, choose Dock from the popup menu. To change the color
scheme, see Error Notification.

Following is a summary description of the power consumption statistics displayed:

• The bar graph shows the percentage of power used for each voltage and the total The
bar graphs show the percentage of power used for each voltage and, for Series 90-30
racks, the percentage of total system power used.

• For VersaMax racks, Used and Supplied power statistics are shown in Amps.

• For Series 90-30 racks, Used, Supplied power statistics are shown in Watts.

• AVL Ext (available externally) displays the external power available at each voltage
and the total available external power in Watts. (Series 90-30 systems only)

Power Consumption Limit Calculations

The Power view displays graphs showing amount of consumption for the various voltages
produced by the power supply.  In addition, for Series 90-30 racks, the graph shows a
system Total graph bar, which represents the percentage of overall total power supply
capacity that is currently used.  Please note that the system total is typically not a
summation of all the voltages produced by the power supply, but rather, a lesser value.

The 90-30 power supplies are power limited, and therefore display units are Watts.
Conversely, the VersaMax power supplies are current limited, and therefore display units
are Amps.
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VersaMax Power View

Series 90-30 Power View
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Components of the Power Consumption View

Power Supply Whose Statistics are Displayed

This is always the most immediate leftmost power supply to the selected module.  For a
90-30 System, the Power Supply will always be in slot 0, since there is only a single
Power Supply per rack.  For a VersaMax System, which supports multiple Power
Supplies, the power supply can be in any slot and is the first one encountered traveling left
from the selected module.

Normal Range

Power Consumption percentage bars representing less than 75% consumption are
displayed in the Power Normal color (default is green).

Warning Range

Power Consumption percentage bars representing more than 75% to 100% consumption
are displayed in the Power Warning color (default is yellow).

Exceeded Range

Power Consumption percentage bars representing greater than 100% consumption are
displayed in the Power Error color (default is red).  Note that if consumption is exceeded,
the label at the bottom of the graph displays the actual amount used, but the percentage bar
does not show greater than 100%.

Note: To change the normal, warning, and error colors in the Power View
display, choose Options from the Tools menu.



7-54  VersaPro™ Programming Software User's Guide – October 2001  GFK-1670D

7   

Converting Rack Systems

The default hardware configuration is VersaMax. If this is not the type you plan to work
with, the type can be changed using the following steps:

1. From HWC, select the File Menu and choose Convert To.

2. Select the PLC type that is available in the list.

3. A message box will appear, warning that I/O modules will not be carried over to the
new rack system.  Please note that this operation cannot be undone.

4. To continue with the conversion, click Yes.  To abort the conversion and keep the
existing hardware configuration, click No.

Note: To change the default hardware configuration, go to the Tools menu in
the VersaPro window and select Options. On the General tab, change
the Default Hardware Configuration to the type that you will be using.

Printing Hardware Configuration

You can print your Rack configuration by going to the File menu and choosing Print. To
set print options, click the Range button in the Print dialog box. The following print
options are available:

• You can choose to print hardware configuration information for the entire rack, or for
a range of modules (selected by rack:slot).

• You can select  to print overview or detail for the configuration:

o Overview:  Prints the Rack as shown on the screen.

o Detail:  Prints the parameter information for each module in the Rack.

o Ethernet Global Data: If your CPU is configured to participate in EGD
exchanges, select this box to print EGD configuration for the CPU.

o Reference Details:  Prints a table showing start and end memory locations, rack
slot addresses, and other reference data.

o Name Resolution: For Series 90-30 CPU364 configurations using Name
Resolution, check this box to print the Name Resolution configuration
information.

If you want to change your target printer or paper size or orientation, click the Setup
button in the Print dialog box.
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Using Reference and Variable View Tables

VersaPro provides two View Tables for monitoring the real-time values and states of
elements in the PLC:

• The Variable View Table allows you to group important variables into a window for
online viewing.

• The Reference View Tables allows you to group important references into a window
for online viewing.

Multiple View Tables may be open at once.

Chapter Contents

• Overview of Reference View Tables (RVT) and Variable View Tables (VVT)

• Information on creating and managing data in the view tables.

Chapter

8
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Variable View Tables – Overview

Variable View Tables (VVTs) allow you to monitor the states of variables. A folder may
have zero or more mixed-type VVTs. VVTs and VVT entries can be cut and copied, and
dragged and dropped between folders.

An example of a VVT is shown below.

Only the Name column may be edited. All other columns are read-only.

The Value column is blank until the Folder is on-line and equal. The value cell displays
“****” for variables that have no assigned reference address.

If the cell is too narrow to display the online value, the cell will display ####.

Name:
Displays variable name,
which may be user-
defined or match the
Reference Address.

Address:
Displays PLC
reference address
for each variable.

Scope:
Shows variable
scope: Global or
Local:block.

Value:
Displays PLC online
value if you are
connected to the PLC,
with logic equal, and
monitoring active.
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Reference View Tables – Overview

Reference View Tables (RVTs) contain a list of references that can be monitored and
updated in real-time. A folder can have zero or more reference tables. RVTs can be cut
and copied and dragged and dropped between Folders. More than one Reference Area can
be entered into a single RVT.

The number of entries contained in an RVT does not affect the performance of the RVT.
Performance is affected only by the number of entries that are displayed and have to be
updated in the view.

Example RVTs are shown below.

All Reference Addresses are displayed that begin with the closest byte offset smaller than
or equal to the starting address you enter and finish eight columns later (Ten columns of
data are displayed for %R, %AI, and %AQ reference addresses.) The amount of data
displayed in the columns depends on the format.

Note: Upon opening a folder created with VersaPro 1.00, the Reference View
Tables will be converted to the new format. However, table format
selections will be reset to the defaults.

Format of selected
address Selected address

Starting address

Display format can
be selected for
individual cells
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Customizing View Table Display

You can customize font selection and color for VVTs and RVTs.  Perform the following
steps to customize the display:

1. From the Folder Browser, click the Tools menu and select Options.  The Options
dialog box will appear.  Select the Display tab.

2. You can change the font selection and change the color used for the display of online
values.

• To modify the settings for the RVT, set the Category to RVT and make the
desired changes. Click OK to accept.

• To modify the settings for the VVT, set the Category to VVT and make the
desired changes.  Click OK to accept.
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Changing Reference View Table Display Format

Your selections of Byte, Word, or Dword governs how much data is displayed in each
cell. Formatting for an RVT occurs on a table, not a row, basis.  Perform these steps to
change the display format for a RVT:

1. Open the RVT.

2. Select the View menu and choose Format View Table.  The Format Display dialog
box will appear.

3. Select the Grouping and Display Format which suits your application needs:

• Grouping Field

o Byte (each cell contains 8 bits)

o Word (each cell contains 16 bits)

o Dword (each cell contains 32 bits)

• Display Format

o Binary

o Hex

o Octal

o Unsigned Decimal

o Signed Decimal

o Real (Only available when Dword is selected)

o Scientific Notation (Only available when Dword is selected).

You can change the display format of an individual cell by selecting the cell and choosing
Display Format from the context-sensitive menu.
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Customizing Variable View Table Display Format

You can customize the value display format for Variable View Tables.  To change the
display format for online values, perform the following steps:

1. Open the VVT.  Select row containing the variable where you want to change the
display format.

2. Click the right mouse button and select Display Format from the CSM..

3. Change the display to suit your application requirements.  The format is changed for
the variable selected.

Note: If the value displays ####, increase the width of the value column to
see the online value.
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Creating New Reference and Variable View Tables

New Variable View Tables and Reference View Tables are created quickly from the
folder browser.  You can have multiple view tables in your folder.  This section describes
how to create new VVTs and RVTs.

To create a Variable View Table:

1. From the Folder Browser, click the right mouse button and choose New Variable
View Table (or select the File menu and choose New Variable View Table).  The
New Variable View Table dialog box will appear:

2. Enter a name for the VVT. Click OK to accept.

3. The new VVT is created and displays in the folder window. The new VVT icon is
added to the Folder Browser with the VVT name.

To create a new Reference View Table:

1. From the Folder Browser, click the right mouse button and choose New Reference
View Table (or select the File menu and choose New Reference View Table).  The
New Reference View Table dialog box will appear:

2. Enter a name for the RVT. Click OK to accept.

3. The new RVT is created and displays in the folder window. The new RVT icon is
added to the Folder Browser with the RVT name.

Note: Offsets columns are not populated until you are connected to the PLC
and have enabled Monitoring.
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Adding Elements to a View Table

You can add logic elements (references or variables) to a View Table for online
monitoring.

You may be either off-line or on-line when you add a new entry to a Variable View Table.
If you are on-line and equal to the PLC, the new variable’s data updates automatically.

Adding an Element by Direct Entry to a VVT

1. From the Folder Browser, open a VVT.

2. Select the Name field on a blank line in the VVT.

3. Select a variable using the Name field’s drop-down list, or type in a valid variable
name.

4. Press Enter, or select another field. The entered variable and corresponding columns
(address and scope) are displayed in the VVT.

Valid VVT Variable Entries

Valid variable entries may consist of any of the following:

• name

• address (If only an address is typed into the Name field, that address will appear in
both the Name and Address fields.)

• name, address (The Scope will default to global.)

• name, g (The scope will be assigned as Global.)

• address, g

• name, address, g

• name, local: scope (Scope is the block to which the variable should be locally
assigned. For example, to assign a variable with the name "A" locally to a block
named "B", type "A,local:B" in the Name field.)

• address, local: scope

• name, address, local: scope

The length of a variable in a View Table reflects the length that was entered into the
Variable Declaration Table. Changes to length may only be made through the VDT.
Information may not be entered directly into the Address or Scope fields.
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Adding an Address to a Reference View Table

1. From the Folder Browser, open an RVT.

2. On a blank line, select the Reference Address column. Type a reference address in
one of the following formats (%I00001 , 1I)

3. Press Enter, or select another field. The reference and corresponding columns are
displayed in the RVT.

Valid RVT Entries

• Word Memory areas (R, AI, AQ) begin with the address you enter.

• The same reference address may be entered and displayed more than once.

• If a value is too large to display in the current cell width, “#####”s appear until you
increase the column width so that the entire value can be displayed.

• Valid offsets range from 0-99999. If an entered offset exceeds the maximum, an error
message appears informing you of the maximum value and the fact that it has been
exceeded. Monitoring within an RVT can not take place until all offsets are
determined to be within the limits of the PLC.

• If an offset is valid, but data is not available, a 0 displays. If the offset is not valid, the
cell remains blank.

Adding a Range to a Reference View Table

1. Open an RVT by double-clicking on it in the Folder Browser.

2. On a blank line, select the Reference Address column .

3. Enter the first address in the range, a comma, and then the last address in the range.
Multiple reference addresses must be separated by commas. Entering an invalid
multiple range Reference Address results in an error.

• The same reference address range may be entered and displayed more than once.

• Valid offsets range from 0-99999. If an entered offset exceeds the maximum, an error
message appears informing you of the maximum value and the fact that it has been
exceeded. Monitoring within an RVT can not take place until all offsets are
determined to be within the limits of the PLC.

• If an offset is valid, but data is not available, a 0 displays. If the offset is not valid, the
cell remains blank.
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Modifying Information in a View Table

VersaPro allows you to edit the variables contained in a View Table by changing the
Name of a variable. Changing the Name in a View Table selects a different variable from
the VDT, and replaces the existing variable in the View Table. True changes to a Name
must be made in the VDT.

To write a value to a reference, select the cell corresponding to the reference in the VVT
or RVT, and type the new value. (You can also place the view table in edit mode by
double clicking in the cell, pressing F10 or choosing Write from the PLC menu.)
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Editing Operations in View Tables

Using cut, copy, paste in a VVT

1. Open the VVT from which you wish to cut a variable entry or entries.

2. Select at least one cell within each row that you wish to cut.

3. Choose Cut or Copy from the Edit menu, click the Cut  or Copy  button, or
press Ctrl + X to cut or Ctrl + C to copy.

4. All rows entirely selected are removed from the VVT and placed on the clipboard in
VersaPro list format (not as text), and other rows shift to fill the cut space.

5. If you want to insert the variables between existing variables on the destination VVT,
rather than overwrite existing variables, select any cell in the row beneath the desired
insertion point.

6. If you want to overwrite existing variables, select the rows that you wish to overwrite.

7. Choose Paste from the Context-Sensitive or Edit menu, click the Paste button , or
press Ctrl + V.  If the variables are inserted, they appear in a new row above the row
in which a cell is selected, and are appended to any other affected table(s). If the
variables overwrite previously-existing variables, they appear in the position of those
variables.

Details on Cutting and Copying

• Variables cut or copied from a VVT can be pasted only in the same or another view
table. They can also be pasted between view tables in different folders.

• Cutting or copying a variable in a VVT does not affect the VDT.

• Variables can be cut or copied during monitoring.

• Text can be pasted into the name field only when it is in edit mode.

Note: Only entire rows may be cut. Selecting any cell in a row, and then
cutting, results in cutting the entire row.
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Details on Pasting

• If more variables reside on the clipboard than have been selected to be overwritten,
the selected variables are overwritten and the remaining clipboard variables are
inserted into the table.

• If fewer variables reside on the clipboard than have been selected to be overwritten,
as many of the selected variables as possible are overwritten, and the rest are deleted.

• When you paste to a second instance of a VVT, a new variable is created in the VDT.

• If collisions occur when creating variables in the VDT, an error message appears
describing the problem.

• Click OK. A dialog appears allowing you to correct the problem.

• Correct the problem. Row validation continues for other variables. If you cancel, the
entire paste is cancelled.

To drag and drop-cut in a VVT:

1. Open the VVT from which you wish to cut a variable entry or entries.

2. Select at least one cell within each row that you wish to cut.

3. Position the mouse arrow over the selected row.

4. Press and hold the primary mouse button.

5. Move the variable or cell to the appropriate area.

6. A graphical representation of the selected area is displayed to indicate a selection is
being dragged. This representation changes dynamically when you drag between two
instances of the VVT which have different cell dimensions.

7. To drop the selection, release the mouse button. If it is valid in the new location, the
selected variable or cell is removed from the original position and placed in the new
position. If it is not valid, the drag and drop operation is cancelled.

To drag and drop-copy in a VVT:

1. Open the VVT from which you wish to cut a variable entry or entries.

2. Select at least one cell within each row that you wish to cut.

3. Position the mouse over the selected variable or cell.

4. Press and hold the Ctrl key.

5. Press and hold down the primary mouse button.

6. Move the variable or cell to the appropriate area.
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7. A graphical representation of the selected area is displayed to indicate a selection is
being dragged. This representation changes dynamically when you drag between two
instances of the VVT which have different cell dimensions.

8. To drop the selection, release the mouse button. If it is valid in the new location, the
selected variable or cell is copied from the original position and placed in the new
position. If it is not valid, the drag and drop operation is cancelled.

Details on Dragging and Dropping in a VVT

• Selections may be dropped on any part of a row.

• If a section is dropped on the last row of the VVT that would go beyond the last row
of the table, new rows are created to accommodate the drop.

• Variables can be entered more than once within a VVT.

• If a selection is dropped that would go beyond the last row of the VVT, new rows are
created to accommodate the drop.

• When a selection is dropped, it overwrites the existing cells.

• VersaPro does not allow dragging and dropping a discontinuous set of cells.

• When you drop to a second instance of a VVT, a new variable is created in the VDT.

• If collisions occur when creating variables in the VDT, an error message appears
describing the problem.

• Click OK. A dialog appears allowing you to correct the problem.

• Correct the problem. Row validation continues for other variables. If you cancel, the
entire paste is cancelled.

Saving View Tables

It is important to save changes to both RVT and VVTs when editing. This section
describes how to save View Tables.

Online values are not saved with view tables.  Online values are maintained in the PLC
and are displayed in the view tables.

To save changes when editing a view table, Select the File menu and choose Save, or click

the Save toolbar button. 
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Online Viewing

To view online values for view tables, the folder must be open and you must be connected
with the PLC.  In addition, the View Table window must be monitoring PLC data.  To set
the View Table to monitoring, click the Monitor All or Monitor Active toolbar buttons.

This section provides details about window behavior when working online and describes
how to change values online.

Details about Online Viewing

• If the value is too large to display in the current Value column cell width, "####"
displays until the column width is altered.

• Override status is displayed as an underlined value (as in both editors).

• Overriding and toggling variables is done through the right mouse menu.

• Array Variables (variables with a length greater than 1) display the address, scope,
and value on subsequent lines under the first entry.

To Toggle or Override a Reference in an RVT

To work online in the RVT, connect to the PLC and perform the following steps to toggle
and override references.

1. Open the RVT.  Select the View menu and choose Monitoring -> All or Monitoring -
> Active Window.

2. Place the cursor on an offset of the reference that you want to toggle or override.

3. Select the PLC menu and choose Toggle, press the F12 key or click the Toggle

button. . The RVT Override/Toggle Bit dialog box will appear.

4. To override, press the F11 key or click the Override button. The appropriate reference
is toggled or overridden.
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To Write a Value to a Reference in an RVT

1. Open the RVT.  Select the View menu and choose Monitoring -> All or Monitoring -
> Active Window.

2. Place the cursor on an offset of the reference that you want to change.

3. Select the PLC menu and choose Write Reference Value, or click the Write Reference

Value button. .

4. Enter the value.  Click the OK button to accept. The value is written to the reference
address in the PLC.
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Motion Programming

The Motion Mate DSM314 is a high performance, easy-to-use, multi-axis motion control
module that is highly integrated with the Series 90-30 PLC logic solving and
communications functions.  VersaPro provides the following capabilities:

• DSM314 Configuration.  Allows you to select module settings and default
operational parameters using SAHWC.

• Motion Editor.  Used to create and modify Motion programs. A Motion program
consists of a series of motion command statements that are stored to and executed in
the DSM314. Up to 10 Motion programs and 40 subroutines are allowed.

• Local Logic Editor.  Used to create and modify Local Logic programs, which run
synchronously with the Motion program, independently of the PLC’s CPU scan.  This
allows the DSM314 to interact much more quickly with motion I/O signals than if the
logic for these signals was handled in the main ladder program running in the PLC.

• Cam Editor.  Used to create, edit, and manage Cam profiles. A Cam profile specifies
the response of a slave servo (follower) to a master position index and is referenced
by name in the associated Motion program. Cam profiles are grouped into Cam
blocks which are downloaded to the DSM314 module via the PLC.

The Motion, Local Logic, and Cam editors are accessed from the Folder Browser.
Motion, Local Logic, and Cam blocks can be dragged, cut, copied, etc. within the Folder
Browser the same as other program blocks, as described in chapter 3. Once created and
saved, Motion, Local Logic, and Cam programs become part of the hardware
configuration and are Stored to the PLC with the other configuration information. For
additional information about configuring and programming the DSM314, refer to the
Motion Mate DSM314 for Series 90-30 PLCs User’s Manual, GFK-1742.

Chapter

9
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Setting Motion Program/Local Logic Editor Options

1. Choose Options from the Tools menu, or from the Editor CSM.

2. The Options dialog box appears.

3. Select the MP/LL Editors Tab.

4. Select the tab and auto-indent options you want and click OK.
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Using the Motion Program Editor

To Open the Motion Program Editor

• Click File on the menu bar, select New Motion, then Motion Program.

• The Create New Motion Program dialog box will appear.

• Type the motion program Name and Description.  If more than one motion module
type is available in the drop-down listbox, select the motion module type that
indicates the module type on which this program will be run.  Then click the OK
button.  The Name is required.  The Description is optional.  A Motion Editor window
for the new motion program block will open. The motion program name appears as
the title of the Motion Editor window and an icon for the new motion program
appears in the Folder Browser window.

• The text-based motion programs and subroutines are created in the Motion Editor
window, as shown in the following figure.  Ten motion programs and forty
subroutines, maximum, separated by their identifying headers (such as “PROGRAM
1 MULTI-AXIS”), can be programmed in the same editor window and are stored in
the same motion program block.
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Creating Motion Program Logic

The DSM314 supports 10 motion programs, 40 subroutines, and a maximum total of 1000
motion program statements.  Comments and white space are not considered as motion
program statements.

Basic Requirements

Format

• Motion programs and subroutines are written using ASCII text.

• Only one motion language statement is permitted per line, and a motion language
statement may not span more than one line. Normal comments may span multiple
lines.

• White space and blank lines may be used to improve readability and to separate
certain items.

• The Motion Editor is not case sensitive.

• All motion programs and subroutines must be contained in a single, motion program
block.

Single axis and multi-axis programs and subroutines

A given single axis program must be able to run on any one axis specified in the Program
definition statement.  Therefore, motion language commands in single axis programs and
subroutines will not specify an axis.  Rather, the axis specified in the PROGRAM
statement is used for all motion commands and subroutines called in the program.  Multi-
axis programs and subroutines can only call multi-axis subroutines.  Likewise, single axis
programs and subroutines can only call single axis subroutines. A multi-axis motion
program is valid only for axis 1 and axis 2. Axis 3 and 4 if enabled in configuration must
be programmed as single axis programs only.

Note: CAM instructions are not valid in Multi-Axis programs.

Program and subroutine definition statements

The Motion Editor requires “Program” and “Subroutine” statements that specify
program/subroutine number and axis configuration (PROGRAM 1 MULTIAXIS or
SUBROUTINE 2 MULTIAXIS).   These statements are placed on the first line of the
program or subroutine.  Programs are terminated with an ENDPROG statement,
subroutines are terminated with an ENDSUB statement.   These statements serve as
separators between programs and subroutines, identify the program and subroutine
numbers, and indicate the type of program (single axis or multi-axis).
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Block numbers and sync blocks

Block numbers will be suffixed with a colon (10: for example). Block numbers may
appear alone on a line or preceding a motion command on the same line.

Sync blocks (blocks containing a SYNC instruction) are identified by a line with a block
number followed by the SYNC command (20: SYNC  for example).

The SYNC (synchronize block) command is used in multi-axis programming to
synchronize two axes at designated points. For additional information, refer to the Motion
Mate DSM314 for Series 90-30 PLCs User’s Manual, GFK-1742.
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Using the Local Logic Editor

To Open the Local Logic Editor

• Click File on the menu bar, select New Motion, then select Local Logic Program.

• The Create New Local Logic Program dialog box will appear.

• Type the Local Logic program Name and Description, select the module type, then
click the OK button.  The Name is required, the description is optional.  A Local
Logic Editor window for the new program block will open. The program name
appears as the title of the Local Logic Editor window and an icon for the new
program appears in the Folder Browser window.

Local Logic Commands

The local logic language uses free-format text based constructs derived from the IEC 1131
structured text standard.

The local logic syntax is easy to learn and provides a rich feature set that allows you to
accomplish the programming task. For details about Local Logic programming, refer to
Motion Mate DSM314 for Series 90-30 PLCs User’s Manual, GFK-1742.
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Using the Local Logic Variable Table

Local Logic accesses the DSM314 motion controller variables and parameter registers
using pre-defined variable names. The Local Logic Variable Table (LLVT) displays these
variables, which are organized into six tabs: Axis 1 – 4, Global, CTL Bits, and Parameter
Registers.

Each set of Axis variables contains Control variables, Status variables and
Faceplate I/0.

Tips for working in the LLVT

• To change the width of a column, select and drag the divider on the right side of the
column head.

• To copy the contents of a selected area in the LLVT to the Clipboard, press Ctrl + C
or choose Copy from the CSM. To select a single cell, simply click in it. To select a
block of adjacent cells, click and drag, or click, hold the Shift key, and click again.
You can select rows or columns by clicking or clicking and dragging the border at the
top or left side of the table. Select the entire table by clicking the upper left corner.

• To sort the LLVT, click in the column you want to sort by, then choose Sort from the
CSM or from the View menu. Choose Ascending or Descending from the submenu
that appears.

• To print the LLVT, select the LLVT and choose Print from the File menu or press
Ctrl + P.

To open the Local Logic Variable Table

To open the LLVT, select Local Logic Variable Table from the View menu, press Alt + 6,

or click the Toggle Local Logic Variable Table button on the toolbar.  
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Information Provided by the Local Logic Variable Table

The LLVT contains the following tabs: Axis 1, Axis 2, Axis 3, Axis 4, Global, CTL Bits,
Parameter Registers

Each tab provides the following information:

Name

This column contains the variable name, which can be used within a local logic program.

Type

The data type for this variable.

Attempting to write a value larger than a given variable size will result in the value being
truncated. For example, if the result of a math operation is 32 bits long and is assigned to a
16 bit variable only the low 16 bits will be stored. The Parser reports a warning if a Bit
Operand is used as the destination variable in a non-Boolean Math operation (only the
least significant bit of the result would be stored).

Local Logic variables that are less than 32 bits long are either Signed or Unsigned (except
Bit Operands which are always Unsigned). All Math/Logic operations in the Logic Engine
are signed 32 bit operations (except the 64 bit signed Divide and Modulus operations).
Signed variables that are less than 32 bits long are automatically sign extended to 32 bits
when they are loaded by the Logic Engine. Unsigned variables are not sign extended.
Thus the Logic Engine handles all data conversion and limit checking automatically.

Note: The immediate command (%AQ) variables (Torque Limit, Velocity
Loop Gain, Follower Ratio, Position Increment, and Position Loop
Time Constant) may have an allowed range that is smaller than the
Local Logic variable size. The module reports a warning error code and
rejects any invalid values if the program attempts to write a value
outside the valid range of an immediate command. Refer to the Motion
Mate DSM314 for Series 90-30 PLCs User’s Manual, GFK-1742 for a
description of the allowed range for each immediate command.

Group

Each set of axis-specific variables contains Control variables, Status variables and
Faceplate I/0. (The Global tab contains only Global variables.)
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Description

This column contains a description of the variable. To view the complete description,
hover the cursor over the cell, refer to the Motion Mate DSM314 for Series 90-30 PLCs
User’s Manual, GFK-1742.

R

If this column is checked, the variable can be read by a local logic program.

W

If this column is checked, the variable can be written to by a local logic program.

Note: Variables can be Read-Only, Write-Only or Read-Write. The Parser
reports an error if you attempt to write to a Read-Only variable or read
from a Write-Only variable.
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Saving Motion/Local Logic Programs

When ready to save your motion program/subroutine file to your computer’s hard disk,
either click the Save icon on the tool bar (looks like a floppy diskette), or click File from
the Menu bar and click Save.

Printing Motion/Local Logic Programs

There are two ways to print a motion program.  You can use either the Print function or
the Print Report function.  Both of these items may be found on the File menu.

To use the Print function, with the Motion Editor active, click File on the menu bar and
select Print.  The Printer dialog box will appear.  Make any desired printer setup changes,
then click the OK button.

To print all motion programs as part of a report with other information in the folder, click
File on the menu bar and select Print Report.  The Print report dialog box will appear.
Click the Blocks checkbox on the Print Report dialog box.  Both motion program and
local logic blocks will be printed as part of this report.

If you want to print only selected motion program blocks, highlight those blocks in the
browser, then click File and select Print Report. Check the Blocks checkbox and then
choose the Selected radio button.  This limits the report to only those blocks that you have
selected.

Storing Motion Programs and Subroutines to the PLC

Motion, Local Logic, and Cam programs are stored as part of hardware configuration. To
store motion programming, first put the PLC in STOP mode. Then choose Store from the
PLC menu. In the dialog box, select Store Hardware Configuration and Motion to PLC.
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Restoring Motion and Local Logic Blocks

Backup copies of motion and local logic blocks in the open VersaPro folder are
automatically made when you load the PLC configuration, including all motion and local
logic programs from a PLC containing blocks of the same name.  VersaPro will only
create these backups if there is a difference between the motion/local logic block stored in
the folder and the block stored on the PLC.  A user prompt will ask if you wish to create
the backups. The backup is one deep.  Multiple backups of a single block are not
automatically made.  This restore mechanism provides a method of recovering modified
motion program blocks from the PLC without the loss of comments stored in the VersaPro
folder.  Comments are not stored to the PLC and are available only if the VersaPro folder
containing the comments is available.

To restore a Motion (*.mbk) or Local Logic (*.lbk) block:

1. Choose Restore Motion Blocks from the Folder menu.

2. The Restore Blocks dialog box will be displayed.  The Available Blocks list contains
a list of all backups of the motion and local logic blocks found in that folder.  You can
select one or more blocks to restore.  If the PLC and VersaPro folder motion blocks
are the same during the load from PLC process, motion backups will not be made and
the list will be empty.  However, if this is not a first time load and there were motion
block differences between the PLC and the VersaPro folder, those backups will be
displayed in the list.  In other words, when you restore a backed up motion block, the
backup remains in the folder and will be displayed in the list unless you physically
remove it.

3. To restore a single motion block, highlight the block and click the Add button.

4. To restore multiple blocks, either select the Add All button, or press the Ctrl or Shift
key and use the mouse to select blocks or sections of the list. Then, click the Add
button.

5. If you want to remove a block from the Blocks to Restore List, select the block and
click the Remove Button.

6. To remove all blocks from the list, click the Remove All button.

7. To remove a set of selected blocks, press Ctrl or Shift key and click to select the
blocks and then click the Remove button.
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8. When you are satisfied with the list, click the OK button.  The blocks in the folder
(that have been loaded from the PLC) will be replaced with the backups (from the
VersaPro folder) you selected.

9. To cancel the replace operation, click the Cancel button.

Note: When the block is restored, the backup is not deleted.  If you are
running out of disk space and don't want to keep backups, you must use
the MS-Explorer or My Computer to navigate to the folder and
manually delete the backup.  Backups have an .mbk (motion) or .lbk
(local logic) extension.
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Using the Cam Editor

The Cam editor provides a means to create, edit and manage electronic Cam profiles for
DSM314 motion modules. Each Cam profile specifies the response of a slave servo
(follower) to a master position index. Cam profiles are referenced by name in the
associated motion program.

Cam profiles are grouped into Cam blocks; each block is intended for download to the
DSM314 module via a PLC controller. A block can contain up to 40 profiles.

Installing the Cam Editor

Note: You must have Internet Explorer 5.0 installed on your computer in
order to install the Cam editor..

The CAM editor is installed as a separate tool.

1. It is recommended that you close all applications including virus checking, Internet
Explorer,and CIMPLICITY HMI software that might be running in the background.
You may need to check the task manager to determine if other applications are
running.

2. Put the Cam Editor CD in the CD-ROM Drive.

3. Select the CD drive from Windows Explorer.

4. Run setup.exe to start the installation process

5. Follow the user prompts to complete the installation.

Starting the Cam Editor

You can open the Cam Editor by adding a new Cam block to the folder or double
clicking an existing Cam block. You can also open the Cam Editor by choosing Cam
Editor from the Tools menu.
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Sample Cam Profile
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Adding a Cam Block to the VersaPro Folder

To add a Cam block to your VersaPro folder, click File on the menu bar, select New
Motion, then Cam Program. The Create a New Cam Program dialog box will appear.

Type a name and a description for the Cam block and click OK. The Cam Editor will open

and an icon for the new Cam block will appear in the folder browser. 

Note: If the Cam Editor is already open, you can also create a new block in
the Cam Editor project browser. The new block will automatically
appear in the VersaPro folder browser.

Opening an Existing Cam Block

To open a Cam block, double click its icon in the Folder Browser. 

The Cam Editor window will appear. Refer to the FrameWorX InfoViewer for details on
developing profiles and creating links to profiles in Cam blocks.

Deleting a Cam Block

To delete a Cam block from the VersaPro folder, select the block in the folder browser and
press the Delete key, or choose Delete from the Edit menu or CSM.

Duplicating a Cam Block

To duplicate a Cam block, select it in the folder browser and choose Copy (Ctrl + C) from
the Edit menu or CSM. You can paste (Ctrl + P) the block into the same folder or a
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different folder. If you paste it into the same folder, you will be asked to provide a new
name. (Each component in the folder must have a unique name.)

Viewing and Editing Cam Block Properties

To view the name, description, and module type for a Cam block, select Properties from
the Edit menu or the CSM. The Name and Description can be edited at any time. DSM314
is the only module that supports Cam blocks.

Renaming a Cam Block

To rename a Cam block, select the block, then choose Properties from the Edit menu or
CSM, or press Alt + Enter. Type a new name in the Cam tab of the Properties dialog box.

Using Cam Profiles in a Motion Program

Cam profiles are referenced by name in the associated Motion program. Cam profiles are
grouped into Cam blocks which are downloaded to the DSM314 module with the
hardware configuration, via the PLC.

For a Cam profile to function in a Motion program, the following conditions must be met:

• The specified profile must be defined in the Cam Library and linked to a Cam block
(using the Cam Editor). To execute the profile on a DSM314, this must be the Cam
block specified in the hardware configuration.

• A Cam block that contains the profile must be defined in the VersaPro equipment
folder. This can be done in the Cam Editor or in VersaPro (go to the File menu and
choose New Motion, Cam Program).

• The Cam block containing the profile must be specified in the DSM314 hardware
configuration and stored to the PLC.

• The profile name referenced in the Motion program must match the name defined in
the Cam Library.

For details on using Cam profiles in a Motion program, refer to the user
documentation for the DSM314.

Three instructions are available for programming Cam motion: CAM, CAM-LOAD,
and CAM-PHASE.

Note: CAM instructions are not valid in Multi-Axis programs.
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Communicating with the PLC

Communicating with the PLC is necessary to perform such operations as storing and
loading programs or viewing reference or PLC status information.  This chapter describes
how to connect to the PLC and perform some basic online operations.

Chapter Contents

This chapter provides the following information:

• How to connect your computer to the PLC using the Communication Configuration
Utility (CCU)

• Guidelines for Communications Configuration

• How to transfer Folders to and from the PLC

• How to clear Folder data from the PLC and verify PC/PLC Folder information

• How to read/write/verify flash memory

• How to read/write/verify the EZ Program Store device (VersaMax CPUs)

• How to view PLC status information

• How to place the PLC in Run or Stop mode

• Monitoring logic execution

Chapter

10
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Connecting to a PLC

You can connect to a PLC from VersaPro over a serial or Ethernet connection, depending
on the capabilities of the PLC. Connections are made by identifying a device and selecting
a port.  The device specifies information necessary to successfully connect including the
default PC communication port, target PLC type, PLC SNP address and PLC IP address.
The port identifies the PC port used to initiate communications to the PLC.

This section describes the various ways to connect to the PLC: Direct Serial Port,
Multidrop and Modem Connections, and TCIP/IP.

Direct Serial Port Connection

The simplest method of communicating with the PLC is SNP Direct. To make it easy to
connect SNP direct, a preconfigured device name, DEFAULT, is provided. DEFAULT is
designed to be used for a direct connection from your PC to a PLC, connecting from
COM1 on the PC to the built-in SNP port on the PLC.  This device will work for any SNP
direct connection using default protocol settings (19200, odd parity, 1 stop bit).

To connect directly from COM1 on your PC, follow these steps:

1. Connect the serial cable from COM1 on your PC to the RS-232/RS-485 converter on
your PLC.

2. Select the PLC menu and choose Connect. The Connect dialog box will appear. This
dialog box is used to select a device and port to initiate communication with the PLC.

3. Select Device  "DEFAULT" and Port  "COM1". Click the Connect button to establish
communications.
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Multidrop and Modem Connections

If a Multidrop or Modem configuration has never been defined for a device, or your PLC
hardware configuration has not been set to support these connections, follow the
instructions below.

The physical connection from PC to PLC will depend on your application;  see Appendix
B, “Communications Cabling,” for details about cables and connectors.

Configuring Your Device and PLC CPU

If your application requires that you change the default serial port settings from the SNP
default (19200, ODD, 8 Data Bits, 1 Stop Bit) or set an SNP ID, do the following:

1. Start Hardware Configuration (HWC) and double-click the PLC CPU.

2. From the Parameters dialog box, click the Settings tab:

3. Make the appropriate changes to your serial port settings and/or SNP ID and click the
OK button.

4. Store the hardware configuration changes to the PLC.

Once you have made any necessary changes to the SNP default settings for the PLC
CPU, you need to change the settings for the PC port. Follow these steps to modify
port configuration for the PC.

5. From the Tools menu, choose Communications Setup.  (If a password has been
defined for the CCU, the Password dialog box will appear. Enter your password and
press OK to continue.)  The main screen of the CCU will appear.

6. To add a new device, click the New button.  The Add New Device dialog box will
appear:

7. Set the Default Port to match the PC port you will be using (COM1 through COM4)
and enter the SNP ID for the PLC, if one exists.  Click OK to add the device.

8. To change default serial port settings, click the Ports tab, highlight the PC port you
want to modify (COM1 through COM4) and click Edit. The Edit Port dialog box will
appear.  Customize the port configuration to suit your application. (SNP timers may
be accessed by clicking the Advanced button). Click OK to save changes for the port.
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9. Set your PC port (COM1 through COM4) and enter your SNP ID, if one exists for
your PLC SNP port. Enter NULL if there is no SNP ID. Click OK to add the device.

Connecting to the PLC

To connect to the PLC:

1. From the Folder browser, select the PLC menu and choose Connect (or click the

Connect button  on the PLC toolbar ).

2. Select the Device name and Port name configured in the Communications Utility
dialog box. Click the Connect button to establish communications.

3. When the connection is made, the status information at the bottom of the screen will
change to Connected.
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TCP/IP Ethernet Connection

The configuration of a TCP/IP Ethernet connection is not associated with a particular
folder and becomes part of your setup in VersaPro.

If a TCP/IP Ethernet configuration has never been defined for a device, or your PLC
Ethernet Interface has not been configured, follow the instructions in “Configuring Your
PLC and PLC Hardware.”

Configuring Your PC and PLC Hardware

Before connecting via TCP/IP Ethernet, you must set the IP address in your PLC Ethernet
Interface.  Perform these steps to configure the PLC IP address:

1. From Hardware Configuration, add an Ethernet module or CPU364 to the Series 90-
30 rack. .

2. Set the IP Address for the module. Store the hardware configuration to the PLC CPU.

Once you have configured the IP address for the PLC CPU, you need to change the
settings for the PC port. Follow these steps to modify port configuration for the PC.

1. Connect your PLC and PC to the Ethernet network.

2. From the Tools menu, choose Communication Setup.   (If a password has been
defined for the CCU, the Password dialog box will appear. Enter your password and
press OK to continue.)  The main screen of the CCU will appear.

3. To add a new device, click the New button.  The Add New Device dialog box will
appear.



10-6  VersaPro™ Programming Software User's Guide – October 2001  GFK-1670D

10   

4. Set the Default Port to ENET and enter an IP Address that matches the IP Address
configured for the Ethernet Interface. Click OK to add the device.

5. To customize global timeouts, click the Ports tab, select ENET, and Click Edit. Click
Advanced to access global timeouts.

Note: Changes made to Modem Properties through CCU are not saved in the
operating system modem settings. To retain these changes, you must
edit the Modem Properties in the Windows Control Panel (select
Control Panel, then Settings).
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Connecting to the PLC

To connect to the PLC:

1. Select the PLC menu and choose Connect (or click the Connect button  on the
PLC toolbar). The Connect dialog box will appear. Select the Device Name and Port
(ENET) for Ethernet communication.  Click the Connect button to establish
communications.

2. When the connection is made, the status information at the bottom of the screen will
change to Connected.
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Guidelines for Communications Configuration

Many communication issues can be resolved by properly setting the communications
timing parameters which may have been altered from previous programmer sessions on
the same PC.

The CCU allows you to view and change your settings for the PLCs that you connect to
(over Ethernet or serial line). This information provides guidelines on how to configure
your communications parameters properly.

Opening the CCU

From VersaPro you can select Tools -> Communications Setup to invoke the CCU
application.

From a command line (within an MS-DOS box or from Start -> Run) you may enter
GEFCCU32.EXE. This application is installed in the Windows root directory (usually
C:\Windows for Windows 95 or Windows 98, and usually C:\WinNT for Windows
NT). Since this location is always in your path, you do not need to specify the path when
invoking the CCU.

Password

If a password has been defined for the CCU, you will be presented with a dialog box
asking for a password. If you only want to look at your communications parameters (not
make changes), click the View Only button to view the parameters in Read-Only mode.
To change the password, click the Change Password button on the Password dialog box.

To define or change a password for the CCU, go to the File menu and choose Password.

Serial Parameter Settings

If you have used Control software version 1.00 and earlier, your communications
configuration may contain invalid settings for some of the SNP timers (SNP is the GE
Fanuc proprietary protocol used to communicate to PLCs over a serial line). VersaPro can
inherit these settings since it uses the same communications driver.  If you encounter
communications difficulties, it is recommended that you check your settings in the CCU
on the Port tab for each serial COM port and use the following values:

1. Select the Display Advanced Parameters checkbox

2. If you need to make changes, click the Edit button.

3. Set Request Timeout to 20000 or higher (units are in milliseconds, highest valid value
is 63000).
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4. Set SNP_T3 parameter to a value at least 250 greater than Request Timeout. For
example, if your Request Timeout parameter is 20000, set SNP_T3 to 20250 or more.

5. Set SNP_T3P parameter to a value at least 250 greater than the SNP_T3 parameter.
For example, if your SNP_T3 parameter is 20250, set your SNP_T3P parameter to
20500 or more.

6. Set SNP_T3PP parameter to a value at least 250 greater than the SNP_T3P parameter.
For example, if your SNP_T3P parameter is 20500, set your SNP_T3PP parameter to
20750 or more.

7. To save your changes, click OK on both the Edit dialog box and on the main CCU
screen.

Modem Issues

1. When editing modem parameters in the CCU, any settings made in the setup that the
Configure Line button brings up are not saved. For the modem settings to be retained,
they need to be entered through the Windows operating system.  From the Windows
Start menu, select Settings, Control Panel, Modems.

2. When setting up VersaPro to communicate with the PLC via modem, you should
ensure that the settings in the PLC match those of the modem.  For example, for
typical modem applications the PLC should be set up for 19200 baud, no parity, 1
stop bit, and a modem turn around time of 1 using the hardware configuration
package in VersaPro and then storing this configuration to the PLC. Next, the
programmer's PC port must be set up through the Windows operating system by
selecting Start, Settings, Control Panel and selecting the Modems icon.  The Modems
Properties dialog box will appear. The Modem Properties should be set to match the
PLCs configuration for number of bits, parity and stop bits.  The Advanced
Connection Settings should be set to enable Use Flow Control and Hardware
(RTS/CTS).

3. From VersaPro, select Tools, Communications Setup to invoke the CCU application.
Select Ports, Edit to set the modem turnaround time.



10-10  VersaPro™ Programming Software User's Guide – October 2001  GFK-1670D

10   

Transferring Folders

After you have established a connection to the PLC,  you can transfer Folders between
your computer and the PLC. This section covers the following:

• Storing a folder from your PC to the PLC

• Loading a folder from the PLC to the PC

• Verifying that a folder matches the one currently running in the PLC

• Clearing items in the PLC

• Performing read/write operations on PLC flash memory

Storing a Folder to the PLC  

You can store hardware configuration, logic or stored/overridden values to the PLC.

In most cases, before storing to the PLC you will need to place the PLC in Stop mode.
You can perform a Run mode store only when you are storing certain program changes
and the folder nickname matches the PLC nickname.

To place the PLC in Stop mode, click the Stop toolbar button , or go to the PLC menu
and choose Stop PLC.

To store the current Folder from your computer to the connected PLC, follow these steps:

1. Confirm that you are connected the PLC. (The VersaPro status bar should indicate
“Connected.” If the status bar is not visible, press Ctrl + 0.)

2. Click the Store Button  (or select the PLC menu and choose Store).  The Store
Folder to PLC dialog box will appear.
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3. Select the folder components you want to store to the PLC:  hardware configuration
and motion, logic and stored/overridden values. (Motion programs for the Motion
Mate DSM314 module are stored as part of hardware configuration.)

4. VersaPro will store the selected components to the PLC. If the store is successful, a
message box will appear.  The Information Window will provide additional details
about the store operation.

CPU Model Checking

When a configuration is Stored, all VersaMax (modular and micro) models reject
configuration for a different model.

Version 8.00 and later 350 and above 90-30 CPUs do not check the CPU model type
when a configuration is stored (they will accept configuration for a different model).
Versions earlier than 8.00 do have this check (they will reject configuration for a different
model).

Word for Word Changes in LD

Word for word changes may be performed on Series 90-30, Series 90 Micro and
VersaMax modular PLCs. (VersaMax Nano/Micro PLCs do not support word for word
changes.)

Changes to the program that do not modify the size of the program are considered word-
for-word changes.  Examples include changing the type of contact or coil, or changing a
reference address used for an existing function block.

VersaPro Goes Unequal After Check All or Verify

If the following conditions exist when making a Word for Word reference address change:

• The reference is the highest reference used in the program

• The address is changed to a lower value (for example from 500 to 499)

• The reference is only used in one location in the program

VersaPro will go unequal with the PLC after a Check All or a Verify because VersaPro
does not update the PLC to the new highest reference used in order to minimize the time
to make a Word for Word change.  To gain equality, you must store the program to the
PLC.
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Loading a folder to Your Computer 

You can load hardware configuration, logic or stored/overridden values from the PLC to
your PC.

To load a folder from the PLC to your computer, follow these steps:

1. Confirm that you are connected to the PLC.  (The VersaPro status bar should indicate
“Connected.” If the status bar is not visible, press Ctrl + 0.)

2. Click the Load button  (or select the PLC menu and choose Load). The Load
Folder from PLC dialog box will appear:

3. Select the components that you want to load.  Choose from hardware configuration
and motion, logic and stored/overridden values.

4. To begin the load procedure, click the Load button.

5. The selected information will be loaded from the PLC. The Information Window will
display the results of the load operation.  If the load is successful, a message box will
display "Load from PLC Completed."

Note: You cannot load Ethernet Global Data or Name Resolution from a
CPU364. When you initiate the Load configuration process, the
confirmation dialog box presents the option of backing up the EGD and
Name Resolution configuration. To restore these configuration
components to your folder, go to the HWC File menu and select
Restore EGD and Name Resolution. A browser window will open to
enable you to navigate to the backup file.
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Clearing the PLC

You can clear Hardware Configuration, Logic, stored/overridden values and PLC and I/O
Fault Tables in the PLC.

To clear selected program items from the PLC, follow these steps:

1. Confirm that you are connected to the PLC. (The VersaPro status bar should indicate
“Connected.” If the status bar is not visible, press Ctrl + 0.)

2. Select the PLC menu and choose Clear. The Clear PLC dialog box will appear.

3. Select the items you want to clear in the PLC.  Components that have a check mark
next to them will be cleared. You can select and deselect individual components by
clicking them.

4. To clear the items, click the OK button.

5. When the clear operation is complete, a message box will display "Clear Completed
Successfully".
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Verifying Folder Data

To verify that the Folder matches what is currently running in the PLC, follow the steps
below. You can verify hardware configuration, logic or overridden/stored values with the
PLC.

1. Confirm that you are connected to the PLC. (The VersaPro status bar should indicate
“Connected.” If the status bar is not visible, press Ctrl + 0.)

2. From the PLC menu, choose Verify, or click the Verify with PLC button. 

3. The Verify Folder with PLC dialog box will appear.

4. Components that have a check mark next to them will be verified. You can select and
deselect individual components by clicking them.

5. To begin the verify procedure, click  the OK button.

6. A message box will confirm that the verify operation is complete.  The Information
Window will contain details about the Verify operation.
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Reading/Writing/Verifying Flash Memory

Certain CPU models support a flash memory option that allows you to store Folder data to
the flash memory device located on the PLC.

To perform read, write, or verify operations on the PLC’s Flash memory, follow these
steps:

1. Connect to the PLC.

2. Select the PLC menu and choose Flash/EEPROM.  The Read/Write/Verify Flash
Memory dialog box will appear.

3.  Select the folder components you want for the flash operation.  You can select
individual components by clicking on them.

4. Under Memory Type, select Flash/EEPROM.

5. Select the flash operation by clicking the appropriate button :

• To read from Flash memory to the CPU, click the Read button.

• To write from the CPU to Flash memory, click the Write button.

• To verify that the program data in Flash memory matches that in the CPU, click
the Verify button.

6. When the operation is complete, a message box will indicated success or error.
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Reading/Writing/Verifying the EZ Program Store Device

The VersaMax EZ Program Store device stores configuration and logic and provides the
ability to update configuration and logic in a PLC without the need for a programmer. An
end user can update a PLC by connecting the EZ Program Store device to the RS-485 port
on the PLC and pressing the momentary-contact switch on the device (PLC must not be
scanning I/O). The user can specify whether the data is written only to the PLC's RAM or
also to flash memory.

To perform read, write, or verify operations on the EZ Program Store device, follow these
steps:

1. Connect to the PLC.

2. Select the PLC menu and choose Flash/EEPROM.  The Read/Write/Verify Flash
Memory dialog box will appear.

3.  Select the folder components you want for the flash operation.  You can select
individual components by clicking on them.

4. Under Memory Type, select EZ Program Store.

5. Select the flash operation by clicking the appropriate button :

• To read from the EZ Program Store device to the CPU, click the Read button.

• To write from the CPU to the EZ Program Store device, click the Write button.

• To verify that the program data in the EZ Program Store device matches that in
the CPU, click the Verify button.

6. When the operation is complete, a message box will indicated success or error.
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Viewing PLC Status Information

Once VersaPro is connected with the PLC, you can view PLC status information through
the status line at the bottom of the window and through the Status Window dialog box.

When you connect to a PLC, the status line at the bottom of the folder window  provides a
summary display of status information.

Confirms that
you are
connected to
the PLC

Tells whether the
PLC is in Stop or
Run mode and
whether outputs
are enabled or
disabled

Shows sweep time
and logic equality
status.

More detailed information is available through the status information dialog box. To view
this information select the PLC menu and choose Status Info, or press F4.

The tabs of the Target Communications Window contain the following information:

• Memory:  Supplies CPU device information, the currently stored program’s name,
and CPU memory usage

• Date:  Allows you to view, change, or synchronize date and time

• Reference:  Displays sizes for all reference tables in the PLC CPU as well as the
status of all point fault references

• Protection: Displays access level and OEM protection status. Allows you to set
access passwords and OEM key.

• Sweep: Displays sweep modes and times. When VersaPro is connected, you can set
the Sweep Mode and Constant Sweep Time while the PLC is in RUN mode. This
change will only affect the PLC until it is transitioned to STOP. When the PLC is
returned to RUN mode, the default sweep mode takes effect.

Note: Settings for this tab are stored in the PLC, not in the program folder.
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Viewing and Changing Date and Time

To view the current PLC time and date, select the Date tab.

If the CPU’s date and time do not match the host computer’s, you can synchronize to the
CPU clock, or set the CPU date and time.

• Synchronize CPU to Host:  Click the Synchronize CPU to Host button.

• Set CPU Date & Time:  Type the month, day, and year (optional)  in the New Date
field and type the time in hours, minutes, and seconds (optional) in the New Time
field. Click the Apply button to accept the changes.
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Placing the PLC in Run or Stop Mode

You can manually set the PLC for Run or Stop mode.  In Run mode, you can choose to
have Outputs enabled or disabled.  In Stop mode, you can choose to enable or disable the
I/O Scan.

To Place the PLC in Run Mode

1. Confirm that you are connected to the PLC.

2. Click the Run PLC button  (or choose Run from the PLC menu).

To Place the PLC in Stop Mode

1. Confirm that you are connected to the PLC.

2. Click the Stop button  (or choose Stop from the PLC menu).

3. In the Stop Execution dialog box, choose to enable or disable outputs then click the
OK button.
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Monitoring Logic Execution

VersaPro allows you to view the value or state of an element or operand from the
Reference View Table, the Variable View Table, the Ladder Editor, or the Instruction List
Editor during logic execution. This can provide you with an opportunity to test the
execution of logic, to trigger an event within an executing folder, or to remove an element
from logic execution. You can also monitor multiple blocks simultaneously. In order to
monitor values online, the logic must be running on the PLC, and VersaPro must be
logically connected to the PLC.

Turning Monitoring On and Off

1. Connect to the PLC whose executing logic you wish to monitor.

2. Make sure that the logic in the current folder is equal to that on the PLC.

3. Choose Monitor from the View menu.

4. From the submenu that appears, choose Active Window or All to determine whether
elements in only the active window, or all windows, should be updated in real-time.

If you choose Active Window, the active window is updated with data from logic
execution.

If you choose All, all active windows are updated with data from logic execution.

• IL, LD, VVT, and RVT are the only active windows that can be monitored.

• A single active window updates at roughly 10 times a second over a TCP/IP
connection.

• When “All” is selected and more than one window is open, the active window
always updates more often than the others. However, each additional open
window slows this active window’s updating speed by roughly 1 time per second.

• Once monitoring has been turned on, it remains on until specifically turned off.

5. To turn monitoring off, choose Monitoring from the View menu.

6. From the submenu that appears, choose Off.

Note: In order to view real time updates, logic needs to be executing. If you
stop executing logic, the latest values remain displaying until
monitoring is turned off.
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Changing the Display Format of Monitored Logic

1. Connect to the PLC whose executing logic you wish to monitor.

2. Make sure that the logic in the current folder is equal to that on the PLC.

3. Select one variable in the IL or LD Editor.

4. Choose Display Format from the Context-Sensitive or View menu.

5. From the submenu that appears, choose the format in which you wish data to display.
You can choose:

Octal

Binary

Hex

Real (Only available for the Real data type)

Scientific Notation (Only available for the Real data type)

Signed Decimal

Unsigned Decimal

The display format you select is applied to the selected variables.

Update in progress or unavailable - Press F1 for Help

The "* Update in progress or unavailable – Press F1 for Help *" message is placed on the
window title bar while VersaPro is waiting for real time data from the PLC. This message
may appear on the Reference View Table, Logic, and Variable View Table windows. This
message will appear momentarily under normal operation while real time updates (RTU)
are active.

If this message remains on the window title bar for an extended amount of time, it is an
indication that you have more windows open for RTU than can be supported by the PLC.
In this situation, you should place VersaPro in "Monitor Active" mode using the View
menu or tool bar; or reduce the number of windows open for RTU. The following table
lists maximum number of open windows that can be monitored for each PLC model.
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Maximum Number of Windows and Applications Supported

Target Windows Applications*

VersaMax Nano  2 2

VersaMax Micro  2 4

VersaMax modular 16 N/A

Series 90-30 (CPU350-364) 16 N/A

Series 90-30 (CPU311-341) 32 N/A

Series 90 Micro 16 N/A

* Example: VersaPro and the Fault Table count as two applications.

Searching for Overrides

When the VersaPro folder is connected to a PLC, you can search the PLC logic for
variables that have overrides. To use this feature, select Search for Overrides from the
PLC menu. Variables that are overridden will be listed in the Information Window.
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Working with Fault Tables

The PLC and I/O Fault Tables display fault information logged by the CPU or modules in
the PLC. This information is used to determine if there are problems with the PLC
hardware or software running in the PLC CPU.

You can view, sort, print and clear faults with the Fault system.

Note: The Fault Table system is a separate application from VersaPro with its
own menu bar and toolbar.  The Fault Table when minimized is
reduced to a button on the Windows taskbar and does not appear in the
Equipment Workbench window.

Chapter Contents

• How to view PLC and I/O Fault Tables

• How to obtain details about individual faults

• Sorting faults

• Saving fault information

• Clearing the Fault Table

Chapter

11
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Working with the PLC and I/O Fault Tables

To view the PLC and I/O Fault Tables, your PC must be connected to and online with the
PLC.  You can connect to the PLC before opening the Fault Tables. If VersaPro is not
connected to a PLC, and you open the Fault Table window, then click the PLC or IO
button, the Connect dialog box will appear. (For details, refer to “Connecting to a PLC” in
chapter 10.)

Viewing the PLC and I/O Fault Tables

To view the Fault Table from VersaPro, go to the Tools menu, and choose Fault Table. If
you are in the PLC Fault Table, click the IO toolbar button to access the I/O Fault Table:
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To view the I/O Fault Table from VersaPro, click the IO toolbar button:

Viewing Fault Details

The fault table provides a summary description of each fault. Additional information
describing the fault can be accessed in one of the following ways:

• To obtain additional information for a specific fault, double-click the fault. The Fault
Detail dialog box will appear.

• To list all faults and expanded fault data, select the File menu and choose Save (or
Save As).  Once you have saved this information, you can then use a text editor to
view or print the text file created by the Save operation.
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Sorting Faults

Faults are displayed in the order they are logged (based on date and time). However, you
can select for faults to be ordered by fault location or grouped by fault description.

To change the order of display, select the View menu, choose Sort and select the key field
for the sorted display.

For the PLC Fault Table, the sorting choices are as follows:

• Location

• Description

• Date/Time

• For the I/O Fault Table, the sorting choices are as follows:

• Location

• Circuit Number

• Reference Address

• Category

• Type

• Date/Time

Note: To restore the list to the original dated order, select the View menu and
choose Sort Ascending.

Saving Fault Information

You can save fault information to a text file to help you document or troubleshoot a
problem. When you save to a file, both the fault table entry and the fault details are saved
to file.

Perform these steps to save the fault data:

1. Select the PLC or I/O Fault Table.

2. Select the File menu and choose Save or click the Save button  within the Fault
Table window.

3. In the Save As dialog box type the file name for the fault data. (If you previously
saved fault information, the new data will be saved to the same file name.)
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Clearing the Fault Table

You can clear the entire fault table by pressing F9 or selecting Clear Table from the Edit
menu. Clearing faults also clears latched fault indications in all connected logged-in
Genius blocks.

If you select Clear Table to clear the fault table, the fault bit in the PLC is reset, and  you
can put the PLC back into run mode. If  you select Clear Entry, the fault bit is NOT reset,
and you cannot place the PLC in run mode.

Caution

Clearing the fault table removes the faults.  However, it does
not fix the underlying problem that generated the fault.
Clearing the fault table will allow the PLC to be put in Run
mode, even though the fault condition may still exist. If the
condition that caused the fault still exists, the fault may be
reported again after storing the configuration, cycling power to
the PLC, or during a Stop-to-Run transition.

Note: Clearing the fault table does clear fault conditions in the block at the
same time the I/O fault table is cleared. Unlike Genius circuit faults, an
I/O fault is not logged if it persists after the fault table is cleared. After
clearing a fault table, it is possible to place the PLC in RUN mode with
an active fault condition that is configured to be fatal. To avoid this
condition, always clear the fault tables before storing the program and
configuration to the PLC.

Opening Other Fault Tables

It is possible to view fault tables in other PLCs, if the port/device assignment has been
established using the Communications Setup option found in the Comm menu.

Perform these steps to open other fault tables:

1. From the File menu, select New I/O Table or New PLC Table. The Connect dialog
box will appear.

2. Select the Device Name that matches the PLC containing the fault table you want to
open.

3. Select the Port that matches the communication link to the PLC.

4. Click the OK button.
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Changing Fonts

You can change the font for the Fault Tables by selecting the Edit menu and choosing Set
Font. The Font dialog box will appear allowing you to change the font type, style, and
size.

Note: The font changes will affect only the fault tables, not the other areas
of VersaPro.

Printing Fault Tables

To print the active Fault Table, select the File menu and choose Print or click the Print
button on the toolbar.
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VersaPro Menus and Toolbars

This appendix shows the menu bars and toolbars used in VersaPro programming software
and the Stand Alone Hardware Configuration tool.

VersaPro Menus

File Menu

The file menu includes standard file and print operations for VersaPro components.

Option Button Action

New Block (Ctrl + B) Creates a new block.

New Motion Creates a new Local Logic, Motion, or Cam program.

New Reference View Table Creates a New Reference View Table

New Variable View Table Creates a new Variable View Table

Save (Ctrl + S) Saves the selected item.

Save All (Shift + Ctrl +A)  Saves the entire folder.

Close (Ctrl + F4) Closes the selected window.

New Folder (Ctrl + N) Creates a new folder, or imports an existing folder.

Open Folder (Ctrl + O) Opens an existing folder.

Close Folder Closes the open folder.

Print Prints the selected item.

Print Report Allows you to define which components and blocks should be
included in a report, then print the report.

Page Setup Allows you to specify page parameters.

<MRU list> Lets you open a recently used folder from a list of Most Recently
Used folders (the MRU list) that appears here on the menu.

Exit (Alt + F4) Closes VersaPro software.

Appendix

A
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Edit Menu

Option Button Action

Undo <action> (Ctrl + Z) Reverses the previous action. The previous action (for example,
Drop or Delete) appears instead of "<action>".

Redo <action> (Ctrl + Y) Reverses the previous undo action. The previous action (for
example, Drop or Delete) appears instead of "<action>".

Cut (Ctrl + X) Removes the selected item and places it on the Clipboard.

Copy (Ctrl + C) Copies the selected item to the Clipboard.

Copy As Copies the selected element(s) as either a bitmap image or as text
to the Clipboard.

Paste (Ctrl + V) Pastes the Clipboard contents to the selected area.

Delete (Del) Deletes selected item(s).

Select All (Ctrl + A) Selects all items

Find/Replace (Ctrl + F3) Allows you to Find and Replace a variable Name or Address, a
Call to a Subroutine, or a Jump/Label or MCR/END_MCR pair
in logic

Find Next (F3) Finds next item of defined search criteria.

Find In Blocks
(Ctrl + F10)

Finds a particular global or system variable by Name or Address,
or a Call to a Subroutine in blocks.

Go to (Ctrl + G) Allows you to go to a row in IL logic or a rung in LD logic.

Go to Variable
(Ctrl + F11)

Allows you to got to a variable in the VDT.

Go to Next Coil (Alt + F3) In the LD editor, moves the cursor to the next coil with the same
name as the selected reference

Properties (Alt + Enter) Allows you to add a description to the current block, to add a
description to  the current folder, or to set the properties of
temporary variables or conversion variables.
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View Menu

Option Button Action

Toolbars (Ctrl + T) Shows or hides toolbars.

Function Toolbars Allows you to expand or compact function toolbars

Status Bar (Alt + O) Shows or hides the Status bar.

Folder Browser (Alt + 1)
 

Opens or closes the Folder Browser window.

Information Window
(Alt + 2)

Opens or closes the Information window.

Variable Declaration
Table (Alt + 3)

Opens or closes the Variable Declaration Table Window

Hardware Configuration
(Alt + F4)

Opens the Hardware Configuration window.

MAIN block (Alt + F5) Opens the _MAIN block.

Local Logic Variable
Table (Alt + 6)

Opens or closes the Local Logic Variable Table, if the folder
contains a Local Logic program.

Sort Allows you to sort specific columns of the VDT in ascending or
descending order.

Monitor Allows you to disable or enable real-time logic execution on the
PLC in all windows or in the active window.

Display Format Allows you to change the display format of monitored logic.

Format View Table Allows you to determine how data is displayed in the selected
Variable View Table row, Reference View Table row, or entire
Reference View Table.

Zoom In (Ctrl + "=") Makes view larger.

Zoom Out (Ctrl + "-") Makes view smaller.

Insert Menu

Option Button Action

Object Allows you to insert an object into the Folder Browser.

Block Allows you to insert a block into the Folder Browser.

Row (Ins) Inserts a row above the selected row in the IL editor, LD editor,
VDT, or a View Table.

Comment Allows you to insert a comment.
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Folder Menu

Option Button Action

Check Selected Block(s)
(Ctrl + F7)

Checks the selected block(s) for syntactic correctness. If no block
is selected, this menu option reads "Check Block_Main" and
selecting it results in checking the _Main block for syntactic
correctness.

Check All (F7) Checks all blocks for syntactic correctness.

Lock/Unlock Locks or unlocks the open folder.

Backup (F8) Backs up a folder.

Restore (Ctrl + F8) Restores a folder.

Restore Motion Blocks Allows you to restore individual Motion blocks that have been
backed up during a Load operation.

Find Unused Variables Finds unused variables. The unused variables are listed in the
Information window by Name, Scope, and Address.

Compact Reduces the size of the folder by removing edit history
information from the VDT.
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PLC Menu

Option Button Action

Connect (F9) Connects to the PLC

Disconnect (Ctrl + F9) Disconnects from the PLC

Store (Alt + F2) Stores the contents of a folder to the PLC

Load (Ctrl + F2) Loads the contents of a folder from the PLC

Verify (F4)
 

Verifies the equality of the current folder and the connected PLC.

Clear Clears the memory of the PLC.

Flash/EEPROM Allows you to read, write, or verify Flash memory.

Search for Overrides When VersaPro is connected to a PLC, searches the PLC logic
for variable overrides.

Run (F5) Runs the logic resident in the PLC

Stop (Ctrl + F5) Stops the logic resident in the PLC

Toggle (F12) Allows you to toggle a reference.

Override (F11)
 

Allows you to override a reference.

Write (F10) Allows you to write a value to the selected reference in the LD
editor, IL editor, VVT or RVT..

Tuning Parameters Allows you to tune PID Instructions.

Status Info (Shift + F4) Allows you to view the status of the PLC.

Abort! (Ctrl + Break) Stops a communications action.
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Tools Menu

Option Action

Fault table Opens a fault table.

Communications Setup Allows you to define communications parameters

Cam Editor Opens the Cam Editor, which is used for creating Cam profiles and blocks for
Motion programming.

Import Variables Allows you to import a variable.

Export Variables Allows you to export a variable.

Convert Block Allows you to convert logic from one language to another.

View Online Cross
Reference

Displays, in the information window, a list of all variables used in the selected
block by reference type.

Convert Block Converts selected block from LD to IL or IL to LD.

Non-Nested to Nested
Conversion

Converts non-nested MCR, ENDMCR, JUMP, and LABEL instructions to the
nested version.

Options (Ctrl + E) Allows you to set General (language–related), Display (colors, fonts), Ladder
(show fields, cell width), and Autoconnect options.

Window Menu

Option Action

Cascade (Alt + 6) Arranges all open block windows so that all title bars are visible and the active
window is in front.

Tile Horizontally
(Alt + F7)

Resizes and horizontally arranges all open block windows so that all of them are
visible.

Tile Vertically (Alt + F8) Resizes and vertically arranges all open block windows so that all of them are
visible.

Arrange Icons (Alt + F9) Aligns all minimized block windows.

Close All (Alt + F10) Closes all open block windows.

Next Window (F6) Moves focus among the active editor window and the dockable windows that
are open. (In the editor window, goes to the selected row or cell, which may be
out of view.)

Previous Window
(Shift + F6)

Moves focus among the active editor window and the dockable windows that
are open. (In the editor window, goes to the selected row or cell, which may be
out of view.)

[Current Window] Displays the name of the active window.

Help Menu

Option Action

Contents and Index Displays VersaPro Help.

About VersaPro Displays information about this version of VersaPro.
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VersaPro Toolbars

VersaPro has six toolbars: the Standard toolbar, the Ladder toolbar, the View toolbar,
the Folder toolbar, the PLC toolbar, and the Function toolbar. You may hide any or
all toolbars to provide more space to work. Unavailable toolbar buttons appear in
dim gray.

Standard toolbar

The Standard toolbar is displayed by default, although you can hide it.  The Standard
toolbar buttons provide common functions, such as opening folders, saving folders
and blocks, cutting, copying and pasting, and undo and redo.

Button Function

Creates a new folder.

Creates a new block.

Opens an existing folder.

Saves the selected block.

Saves the entire folder.

Removes the selected item and places it on the Clipboard.

Copies the selected item to the Clipboard.

Pastes the Clipboard contents to the selected area.

Reverses the previous action.

Reverses the previous undo action.

Deletes selected item(s).

Sends the selected item to a printer.

Displays context-sensitive help.

Aborts a communications action.
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Ladder toolbar

Use the Ladder toolbar to create ladder logic using "click and drop."

Button Function

Selects the normal pointer; disables "click and drop"

Lets you drop a normally open contact

Lets you drop a normally closed contact

Lets you drop a normally open coil

Lets you drop a normally closed coil

Lets you drop a positive transition coil

Lets you drop a negative transition coil

Lets you drop a set coil

Lets you drop a reset coil

Lets you drop a vertical or horizontal wire

Lets you drop a CALL instruction

Lets you insert a comment row.

Note: Pressing the Escape key disables drop mode and makes the pointer
active again.
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View toolbar

Use the View toolbar to show or hide windows, to open the _MAIN block, or to
magnify or reduce a window's contents. Buttons not related to the current task are not
available.

Button Function

Shows or hides the Folder Browser

Shows or hides the Variable Declaration Table

Shows or hides the Information Window

Opens the Hardware Configuration window

Opens the _MAIN block

Opens the Local Logic Variable Table

Monitors all windows.

Monitors the active window.

Turns monitoring off.

Zooms In on (magnifies) the active window's contents

Zooms Out from (reduces) the active window's contents

Folder toolbar

Use the Folder toolbar to check syntax.

Button Function

Checks all blocks for syntactic correctness.

Checks selected block(s) for syntactic
correctness.
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PLC toolbar

Use the PLC toolbar to connect to a PLC, and to perform operations involving a
connected PLC, like storing and loading, or running and stopping logic.

Button Function

Connects to the PLC.

Disconnects from the PLC.

Stores this folder to the PLC.

Loads a folder from the PLC.

Verifies equality between the current folder and
elements present on the PLC.

Runs the PLC.

Stops the PLC.

Toggles a reference.

Overrides a reference.

Writes a value to a reference.

Shows the status of the PLC.

Function toolbar

Use the Function toolbars to select function block types while programming in the
LD editor. Function groups are listed in alphabetic order.

The Function toolbars can be configured to display in expanded or compact mode.
To change the mode, select the View menu, choose Function Toolbars, then select
Expanded or Compact.
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HWC Menus

File Menu

The File menu offers the following commands:

Option Action

New (Ctrl + N) Creates a new Hardware Configuration Folder.

Open (Ctrl + O) Opens an existing Hardware Configuration Folder.

Close Closes an opened Hardware Configuration Folder.

Import Stand-Alone
HWC File

Imports an existing HWC Hardware Configuration Folder (.hwcfg) into the current
Rack System Edit window.

Import Hardware
Configuration Folder

Imports an IOCFG.CFG file (and optional CPUCFG.CFG file), that was produced by
either LM90 or CC90, into a designated new HWC Hardware Folder.

Restore EGD and Name
Resolution

Restores EGD and Name Resolution configuration from a backup file created during
configuration Load.

Save (Ctrl + S) Saves an opened document using the same file name.

Save As Saves an opened document to a specified file name.

Convert To Converts the current Rack System configuration to a default Rack System configuration
of the type selected:

Series 9030

VersaMax

VersaMax Nano/Micro

Series 90 Micro

(You can only convert a Rack System configuration to a different type of Rack System.
If you want to create the same type of Rack configuration as the current one, use Save
As.)

Print (Ctrl + P) Prints all or portions of the current Rack System Hardware Configuration.

Print Preview Displays all, or portions, of the current Rack System Hardware Configuration on the
screen as it would appear when printed.

Print Setup Selects a printer and printer connection.

Exit Exits HWC.
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Edit Menu

Option Action

Undo (Ctrl + Z) Reverse previous Module operation.  Up to 16 levels of Undo are supported.

Redo (Ctrl + Y) Reverses previous Undo operation.  Up to 16 levels of Redo are supported

Cut (Ctrl + X) Deletes the selected Module from the Rack System and moves it to the clipboard.

Delete (Del) Deletes the currently selected Module from the Rack System and reverts it to a blank slot.

Copy (Ctrl + C) Copies selected Module from the Rack System to the clipboard.

Paste (Ctrl + V) Pastes the previously cut or copied Module from the clipboard into the selected slot of the
Rack System.

Expansion Rack System Sub-menu of edit operations that are specific to VersaMax Rack Systems.

Expansion Receiver Sub-menu of edit operations that are specific to VersaMax Expansion Rack Systems.

Rack Operations Sub-menu of edit operations that are specific to the Rack System.

Module Operations Sub-menu of edit operations that are specific to the selected Module.

Edit menu, Expansion Rack System Sub-menu

The Expansion Rack System sub-menu of the Edit menu allows you to select the
type of VersaMax system. You can switch from one VersaMax system type to
another, however resulting changes to the configuration cannot be undone.

Option Action

None This is the default VersaMax system, which is created when you select New from the
File menu. It includes only the Main VersaMax I/O station (no Expansion).

Local Single Rack Includes the Main VersaMax I/O station and one Expansion I/O Station (Rack). The
Main VersaMax system does not contain a Transmitter. The Expansion I/O Station
contains a Non Isolated Receiver and Power Supply Integrated Unit (IC200ERM002).

Multiple Remote Rack Allows you to configure up to seven Expansion I/O Stations (seven Rack tabs are
always shown). The Main VersaMax rack contains a Transmitter (IC200ETM001).
Each Expansion I/O Station contains a Power Supply and Receiver Integrated Unit. The
Non Isolated Receiver (IC200ERM002), which is configured by default, can be
replaced by an Isolated Receiver (IC200ERM001).

Note: The Transmitter module cannot be selected from the module catalog.
The only way to add this module to a rack configuration is to choose
the appropriate configuration type. Also, you cannot delete a
Transmitter module from a rack configuration except by changing the
rack configuration type.
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Edit menu, Expansion Receiver Sub-menu

The Expansion Receiver sub-menu of the Edit menu allows you to select the receiver
for a VersaMax Local Single Rack or Multiple Remote Rack system.

Option Action

None Deactivates the Receiver. This is the default selection if no carrier/base is configured.
This option is not available if there is at least one carrier/base configured in the
expansion rack.

Non-Isolated Receiver Unit Selects the Non Isolated Receiver and Power Supply Integrated Unit (IC200ERM002).
This is the only receiver type allowed for Local Single Rack systems.

Isolated Receiver Unit Selects the Non Isolated Receiver (IC200ERM002). This option is available only for
Multiple Remote Rack systems.

Edit menu, Rack Operations Sub-menu

Option Action

Change Rack Type Displays the 90-30 Change Rack Type Dialog.  This menu item is not available for
VersaMax systems.

Clear Rack Deletes all modules, excluding the Power Supply and CPU, for the selected Rack.

Configure CPU Parameters Displays the Module Parameter Dialog, which allows editing of the configuration
parameters for the Rack System CPU.

Replace CPU Displays the Module Selection Dialog, which allows for the selection of a replacement
Rack System CPU.

Name Resolution and Routing Displays the 90-30 Ethernet Adapter Name Resolution Dialog, which allows for the
specification of Ethernet Adapter Naming and Routing Tables.  This menu item is not
available for VersaMax systems.

Ethernet Global Data Displays the 90-30 Ethernet Global Data Dialog, which allows for the definition of
Ethernet Exchange Ids.  This menu item is not available for VersaMax systems.

Add Base/Carrier Displays the VersaMax Add Base/Carrier Dialog, and extends the selected rack with the
selected Base/Carrier.  This menu item is not available for 90-30 systems.

Delete Base/Carrier Deletes the currently selected Base/Carrier in a VersaMax rack.  This menu item is not
available for 90-30 systems.

Insert Base/Carrier Displays the VersaMax Insert Base/Carrier Dialog, and inserts the selected Base/Carrier
in front of the selected slot of the VersaMax rack.  This menu item is not available for
90-30 systems.

Replace Base/Carrier Displays the VersaMax Replace Base/Carrier Dialog, and replaces the selected
Base/Carrier  in the selected slot of the VersaMax rack.  This menu item is not available
for 90-30 systems.

Configure Receiver Parameters Displays the power consumption tab for the VersaMax expansion rack receiver, which
has no configurable parameters. This menu item is available only when the receiver
unit, located in the first slot of the expansion rack, is selected.
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Edit menu, Module Operations Sub-menu

Option Action

Configure Parameters
(Ctrl + E)

Displays the Module Parameter Dialog, which allows for the editing of the configuration
parameters for the selected Module.

Add Module Displays the Module Selection Dialog, which allows for the selection and configuration
of a new Module in the selected empty rack slot (or Carrier/Base in a VersaMax modular
system).

Replace Module Displays the Module Selection Dialog, which allows for the selection and configuration
of a replacement Module for the selected Module.

Delete Module Deletes the selected Module from the Rack system.

Parameter Menu

Option Action

Data Entry Tool (F2) Opens the Data Entry Tool for a selected, editable parameter.

Reset Parameter Resets a single parameter to the Start of Edit Session value or to the Factory Original
Value

Reset Tab Resets all the parameters on the tab to the Start of Edit Session value or to the Factory
Original value.

Cancel Edit Session Closes the active parameter edit window without saving changes.

Insert Inserts a row with default values above the selected row in certain tabs, such as the
Profibus Slave Information tab.

Delete Deletes the selected row in certain tabs such as the Profibus Slave Information tab and
adds a default row to the end of the matrix.

View Menu

Option Action

Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Log View Shows or hides the on-line HWC Log View.

Reference View Shows or hides the on-line Rack System Reference View

Power Consumption Shows or hides the Power View window.

Parameter Edit Displays a sub-menu that allows you to change the Parameter Editor display format.
These options are available only when a Parameter Editor window for a module is
open.
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View Menu, Parameter Edit Sub-menu

Note: These settings are not saved when you close the Parameter Editor. To
set the default display mode for the Parameter Editor, go to the Tools
menu, choose Options and select the Parameter Edit tab in the Options
dialog box.

Option Action

Singlerow Tab Displays the Parameter Editor window in a tabbed format. If you resize the window so
that it is too narrow to display all the tabs, a scroll bar is provided to access tabs that are
not visible.

Multirow Tab Displays the Parameter Editor window in a tabbed format. If you resize the window so
that it is too narrow to display the tabs in a single row, the tabs will be stacked.

Spreadsheet Displays the Parameter Editor window in a spreadsheet format. Tab headings are
displayed in bold, underlined text.

Error Status Displays the Parameter Editor Error List, which identifies parameter errors and allows
you to correct them before closing the window. This option is available only when the
current Parameter Editor window contains errors.

Tools Menu

Option Action

Hardware Configuration
Data View

Displays the PLC Configuration Data in a tabbed dialog, allowing for both text and
binary formatted presentation of the contained information.

Options Displays an Options dialog, which allows you to adjust certain application behavior
such as Log size and Parameter Editor view.

Communications Setup Opens the CCU. Allows you to define communications parameters.

Load/Store/Verify If an NIU is configured in the rack system, allows you to load, store, verify, or clear the
hardware configuration.
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Window Menu

Option Action

Cascade Arranges windows in an overlapped fashion.

Tile Arranges windows in non-overlapped tiles.

Arrange Icons Arranges icons of closed windows.

Window 1, 2, ... Goes to specified window.

Help Menu

Option Action

Contents Displays a structured Help Table of Contents from which you can get help.

Help Index Offers you an index to topics on which you can get help.

Module Help Provides parameter-specific help for the selected Parameter Editor window.

How to Use Help Enumerates the different types of Help available in HWC and describes how each can
be applied to assist you in learning and using the program.

About HWC Displays the version number of this application.
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HWC Toolbar

Button Function

Opens Parameter Editor window for CPU.

Opens Parameter Editor window for selected module.

Opens the Module Catalog, from which you can select a
module to be configured.

Opens the Module Catalog, from which you can select a
CPU to be configured.

Opens the Module Catalog, from which you can select a
module to be configured in place of the selected module.

Displays or hides the Reference View, which lists references
configured for the rack system.

Displays or hides the Log View, which displays a history of
significant events and status relative to your hardware
configuration editing activities.

Displays or hides the Power View, which shows the power
consumed by the modules in the system.
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Serial Connections

This appendix describes the serial port, converter, and cables used to connect to Series 90
and VersaMax PLCs for Series 90 Protocol (SNP) as well as the Miniconverter Kit. This
information is included for reference and for those users who have applications that
require cable lengths different than the factory­supplied cables.

Appendix

B
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Serial Port and Cables

RS­422 Interface

The Series 90-30, Series 90 Micro, and VersaMax PLC products are compatible with EIA
RS­422 specifications.  RS­422 drivers and receivers are utilized to accomplish
communications between several system components using multiple driver/receiver
combinations on a single cable with five twisted pairs.  The total cable length cannot
exceed 4000 feet.

A multi­drop system of eight drivers and receivers can be configured.  The maximum
common mode voltage between each additional drop is the RS­422 standard of +7 Volts to
–7 Volts.  The driver output must be capable of ± 2 V minimum into 100 ohms.  The
driver output impedance must be at least 120 K ohms in the high impedance state.  The
receiver input resistance is 12 K ohms or greater.  Receiver sensitivity is  ± 200 millivolt.

Caution

Care must be taken that common mode voltage specifications
are met.  Common mode conditions that exceed those specified
will result in errors in transmission and/or damage to
components.
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Cable and Connector Specifications

The cable assembly presents one of the most common causes of communication failure.
For best performance construct the cable assemblies according to the  recommended
connector parts and specifications.

Item Description

 PLC:  Serial (RS­422) port with metric hardware

Connector:  15­pin male, D­Subminiature Type, Cannon DA15S (solder pot) Hood:  AMP
207470­1 connector shell
Hardware Kit:  AMP 207871­1 Kit includes 2 metric screws  and 2 screw clips

IBM­AT/XT:  Serial (RS­232) port with standard RS­232  connector

Mating
Connectors:

Connector:  9­pin female, D­Subminiature Type, Cannon DE9S (solder pot) with
DE110963­31 hood or equivalent (standard RS­232 connector)

RS­232/RS­485 Converter:  one 15­pin male, and one 25­pin male
connector

15­pin male connector requires metric hardware (same connector, hood, and hardware as
for Series 90 PLC listed above)

25­pin male D­Subminiature Type, Cannon DA25S (solder pot) with DB110963­3 hood
or equivalent (standard RS­232 connector)

Computer grade, 24 AWG (.22 mm2), minimum with overall shield

Catalog Numbers:  Belden 9505, Belden 9306, Belden 9832

Cable: These cables provide acceptable operation for data rates up to 19.2 Kbps
as follows:

RS­232:  50 feet (15 meters) maximum cable length
RS­422/RS­422:  4000 feet (1200 meters) maximum length.  Must not exceed the
maximum RS­422 Common Mode specification of +7V to ­7V. Isolation at the remote
end may be used to reduce or eliminate Common Mode voltages.

At shorter distances under 50 feet (15 meters), almost any twisted pair or shielded twisted
pair cable will work, as long as the wire pairs are connected correctly

When using RS­422/RS­422, the twisted pairs should be matched so that both transmit
signals make up one twisted pair and both receive signals make up the other twisted pair.
If this is ignored, cross­talk resulting from the mismatching will affect the performance of
the communications system.

When routing communication cables outdoors, transient suppression devices can be used
to reduce the possibility of damage due to lightning or static discharge.

Care should be exercised that all connected devices are grounded to a common point.
Failure to do so could result in damage to the equipment.
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PLC Serial Port

The Series 90 and VersaMax PLC serial port is compatible with RS­422.  An RS­232 to
RS­422 converter is required to interface to systems that provide RS­232 compatible
interfaces.

The PLC RS­422 serial port provides the physical connection for SNP communication.

The figure below shows the serial port orientation and connector layout for the PLC port.

a43621

15 8

9 PIN
1

PLC

The table below shows the pin numbering and signal assignment:

Pin Number Signal Name Description

1
2
3
4

Shield

ATCH  *

No Connection
No Connection
Hand­Held Programmer attach signal

5
6
7
8

+5V  *
RTS (A)
Signal Ground
CTS (B’)

+5V Power for: HHP and RS­232/485 Converter
Request To Send
Signal Ground, OV
Clear To Send

9
10
11
12

RT  *
RD (A’)
RD (B’)
SD (A)

Terminating Resistor for RD  **
Receive Data
Receive Data
Send Data

13
14
15

SD (B)
RTS (B)
CTS (A’)

Send Data
Request To Send
Clear To Send

*  Signals available at the Connector but are not included in the RS­422 specification.
SD (Send Data) and RD (Receive Data) are the same as TXD and RXD (used in the Series Six PLC).
(A) and (B) are the same as ­ and + .  A and B denote outputs, and A’ and B’ denote inputs.

.
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IBM­AT/XT Serial Port

The IBM­AT, IBM­XT or compatible computer’s RS­232 serial port is a 9­pin D­type
male connector as shown in the figure below.

9

PIN
1

5

6

a44523

IBM-AT/XT

The following table shows the serial port pins-out:

IBM­A
T

Pin No.
Signal Description

IBM­X
T

Pin No.
Signal Description

1 DCD Data Carrier Detect 1 NC
2 RD Receive Data 2 TD Transmit Data
3 TD Transmit Data 3 RD Receive Data
4 DTR Data Terminal

Ready
4 RTS Request to Send

5 GND Signal Ground 5 CTS Clear to Send
6 NC 6 NC
7 RTS Request to Send 7 GND Signal Ground
8 CTS Clear to Send 8 DCD Data Carrier Detect
9 NC 9 DTR Data Terminal

Ready
NC = Not Connected

RS­232/RS­485 Converter

The RS­232/RS­485 Converter (IC690ACC900) can be used to convert from RS­232 to
RS­422/RS­485 communications.  The converter has one 15­pin female  D­type port, and
one 25­pin female D­type port.

This converter unit can be purchased from GE Fanuc Automation.  Please contact any GE
Fanuc Automation sales office or field service representative.
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Serial Cable Diagrams

This section shows two serial port connections for Series 90 and VersaMax PLCs.
Cabling may vary, depending on the devices and converter used in your application.

In the point­to­point configuration only two devices can be connected to the same
communication line.  The communication line can be directly connected using RS­232 (50
feet, 15 meters maximum) or RS­485 (4000 feet, 1200 meters maximum).  Modems can
be used for longer distances.

RS­232 Point­to­Point Connection

**

**

1

25-PIN

MALE

15-PIN

PORT

RS-422

FEMALE

25-PIN

MALE

PORT

RS-232

FEMALE

15- PIN

RS-232/RS-422

(IC690ACC900)

CONVERTER

SHLD

2

3

10

11

12

13

9

15

8

6

14

5

7

1

0V

SHLD

+5V

RTS ( B )

RTS ( A )

CTS ( B' )

CTS ( A' )

SD ( B )

SD ( A )

RD ( A' )

RD ( B' )

RT

DCD ( B )

DCD ( A )

PIN PIN

15- PIN

TD

GND

DTR

CTS

RD

DCD

2

3

20

8

7

7

2

3

8

1

5

4

GND

FEMALE

PIN

9-PIN

RS-232

PORT

IBM-AT

(COMPATIBLE)

MALE

9-PIN

TD

RD

DCD

CTS

RTS

DTR

IC690CBL702 OR EQUIVALENT

SHIELDED PAIRS

RS-232

FEMALE

15- PIN

MALE

15- PIN

SD ( A )

2

3

12

13

10

11

9

6

14

15

8

5

7

1

PIN

SHLD

CTS ( B' )

CTS ( A' )

RTS ( B )

RTS ( A )

RD

RD ( B' )

RD ( A' )

SD ( B )

+5V

0V

RS-422

PORT

Power source for point-to-point connection 10 feet (3 meters) only. Converter power source beyond 10 feet (3 meters) and for multidrop

connection must be external source.
*

a44507

SERIES

RS-422

*
*

Termination resistance for the receive data (RD) signal needs to be connected only on units at the end of the lines.

Series 90 PLC products by connecting a jumper between pin 9 and pin 10 inside the 15-pin D-shell with the following exception.  For Series 90-70 PLCs,
catalog numbers IC697CPU731 and IC697CPU771, the termination for RD at the PLC is implemented by a jumper between pin 9 and pin 11.

PAIRS

TWISTED SHIELDED

90 PLC

5
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Multidrop Connections

In the multidrop configuration, the host device is configured as the master and one or
more PLCs are configured as slaves.  This method can be used when the maximum
distance between the master and any slave does not exceed 4000 feet (1200 meters).  This
figure assumes good quality cables and a moderately noisy environment.  A maximum of
8 slaves can be connected using RS­422 in a daisy chain or multidrop configuration.  The
RS­422 line must include handshaking and use wire type as specified in the “Cable and
Connector Specifications” section.

+5V

PORT

STATION

SERIES

LAST

FEMALE
15- PIN

MALE
15- PIN

SD ( A )

2
3

12
13
10
11

9
6

14
15

8
5
7
1

PIN

SHLD

CTS ( B' )
CTS ( A' )
RTS ( B )
RTS ( A )
RD
RD ( B' )
RD ( A' )
SD ( B )

+5V
0V

90-30

RS-422
CPU

PORT

STATION

SERIES

SLAVE

FEMALE
15- PIN

MALE
15- PIN

SD ( A )

2
3

12
13
10
11

9
6

14
15

8
5
7
1

PIN

SHLD

CTS ( B' )
CTS ( A' )
RTS ( B )
RTS ( A )
RD
RD ( B' )
RD ( A' )
SD ( B )

+5V
0V

90-70

RS-422
CPU

1

25-PIN
MALE

15-PIN

PORT
RS-422

FEMALE
25-PIN

MALE

PORT
RS-232

FEMALE
15- PIN

RS-232/RS-422

(IC690ACC900)
CONVERTER

SHLD

2
3

10
11
12
13

9
15

8
6

14

5

7
1

0V
SHLD

+5V
RTS ( B )
RTS ( A )
CTS ( B' )
CTS ( A' )

SD ( B )
SD ( A )

RD ( A' )
RD ( B' )

RT

DCD ( B )
DCD ( A )

PIN PIN

15- PIN

TD

GND

DTR
CTS

RD

DCD

2
3

20
8

7

4

2
3

5
8

7
9

GND

FEMALE

PIN

9-PIN

RS-232
PORT

IBM-AT
(COMPATIBLE)

MALE
9-PIN

RD
TD

DCD
CTS
RTS

DTR

IC690CBL702 OR EQUIVALENT
RS-232 SHIELDED PAIRS

POWER

Ground Potential:  multiple units, not connected to the same power source, must have common ground potentials

proper operation of this system.

Termination resistance for the receive data (RD) signal needs to be connected only on units at the end of the lines. this termination is made on the
Series 90 PLC products by connecting a jumper between pin 9 and pin 10 inside the 15-pin D-shell with the following exception.  For Series 90-70 PLCs,

catalog numbers IC697CPU731 and IC697CPU771, The termination for RD at the PLC is implemented by a jumper between pin 9 and pin 11.

0V

a44513

*

RS-422

*
PLC 15-PIN CONNECTOR
SERIES 90-30 LOCATED
ON POWER SUPPLY
SERIES 90-70 LOCATED
ON THE CPU BOARD

TO OTHER PLC's

NOTE
WHEN WIRING RS-422 /485 MULTIDROP CABLES REFLECTIONS ON
TRANSMISSION LINE CAN BE REDUCED BY CONFIGURING THE

CONVERTERMASTER SLAVE LAST STATION

5

INSIDE D-CONNECTORS
MAKE CONNECTIONS

CONVERTER
FOR

SOURCE

*

ALSO IT IS RECOMMENDED TO MAKE ANY NECESSARY
NSIDE THE CABLE CONNECTOR TO BE MOUNTED ON THE PLC.  IT IS
RECOMMENDED TO USE TERMINAL STRIPS TO  OTHER TYPES
CONNECTORS ALONG THE LENGTH OF THE TRANSMISSION
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Miniconverter Kit

This section describes the Miniconverter Kit for use with Series 90 and VersaMax PLCs.

Description of Miniconverter

The Miniconverter Kit (IC690ACC901) consists of an RS­422 (SNP) to RS­232
Miniconverter, a 6 foot (2 meter) serial extension cable, and a 9­pin to 25­pin Converter
Plug assembly.  The 15­pin SNP port connector on the Miniconverter  plugs directly into
the serial port connector on the Series 90­30 and VersaMax PLCs.  The 9­pin RS­232 port
connector on the Miniconverter connects to an RS­232 compatible device.

a44985

RS-232
PORT

RS-422
PORT

When used with an IBM PC­AT, or compatible computer, one end of the extension cable
plugs into the Miniconverter’s 9­pin serial port connector, the other end plugs into the
9­pin serial port of the computer.  The Converter plug (supplied with kit) is required to
convert the 9­pin serial port connector on the Miniconverter to the 25­pin serial port
connector on the IBM PC­XT or PS/2 Personal Computer.
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Pin Assignments, RS­232 Port

The pinout of the Miniconverter is shown in the following two tables.  The first table
shows the pinout for the RS­232 port.  The direction of signal flow is with respect to the
Miniconverter.

Pin Signal Name Direction

2 SD ­ Send Data Output

3 RD ­ Receive Data Input

5 GND ­ Ground n/a

7 CTS ­ Clear To Send Input

8 RTS ­ Request To Send Output

The pinouts were chosen to allow direct connection (using a straight through, or 1 to 1
cable (as provided with kit) to the IBM PC­AT.  Most IBM compatible computers
equipped with an RS­232 port will provide a pinout compatible with the one shown above.

Pin Assignments, RS­422 Port

The following table shows the pinout for the Miniconverter’s RS­422 serial port.  The
direction of signal flow is also with respect to the Miniconverter.

Pin Signal Name Direction

1 SHLD ­ Shield n/a

5 +5 VDC ­ Power Input

6 CTS(A') ­ Clear To Send Input

7 GND ­ Ground n/a

8 RTS(B) ­ Request To Send Output

9 RT ­ Receive Termination Output

10 SD(A) ­ Send Data Output

11 SD(B) ­ Send Data Output

12 RD(A') ­ Receive Data Input

13 RD(B') ­ Receive Data Input

14 CTS(B') Clear To Send Input

15 RTS(A) ­ Request To Send Output
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System Configurations

The Miniconverter can be used in a point­to­point configuration as described above, or in
a multidrop configuration with the host device configured as the master and one or more
PLCs configured as slaves.

The multidrop configuration requires a straight through (1 to 1) cable from the
Miniconverter’s RS­422 port to the first slave PLC’s SNP port.  Other slaves will require a
daisy chain connection between slaves.  A maximum of eight devices can be connected in
an RS­422 multidrop configuration.  All of the devices must have a common ground.  If
ground isolation is required, you can use the GE Fanuc Isolated Repeater/Converter
(IC655CCM590) in place of the Miniconverter.

When using the Miniconverter with a modem connection, it may be necessary to jumper
RTS to CTS (consult the user’s manual for your modem).

Cable Diagrams (Point­To­Point)

When connecting the Miniconverter to IBM PC and compatible computers with hardware
handshaking, the following cable connections should be used:

5

8
7

3

2

4

6

1

5

8
7

3

2 RXDTXD

PIN

MINICONVERTER IBM PC-AT

PIN
a44982

GND

RTS
CTS

RXD

CONNECTOR
9-PIN

RS-232 PORT
CONNECTOR

9-PIN

DTR

DSR

DCD

GND

CTS
RTS

TXD
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The following table shows the Miniconverter’s specifications

Mechanical:

RS­422 15­pin D shell male for direct mounting to Series 90 or
VersaMax serial port.

RS­232 9­pin D shell male for connection to RS­232 serial port
of a Workmaster II computer or Personal Computer.

Electrical and General:
Voltage Supply +5 VDC (supplied by PLC power supply)
Typical Current Version A (IC690ACC901A) ­ 150 mA

Version B (IC690ACC901B) ­ 100 mA
Operating Temperature 0 to 70° C  (32 to 158° F)
Baud Rate 38.4K Baud maximum
Conformance EIA­422 (Balanced Line) or EIA­423 (Unbalanced Line)
Ground Isolation Not provided
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VersaPro License Transfer Procedure

Use this procedure to transfer your license from one computer to another. Usually, a
floppy disk is used to transfer a license but a network shared directory (write-able by both
machines) can also be used.  In this example, a floppy disk is assumed.  The floppy disk
does not need to be reformatted.

Step 1.  Register Machine (performed on the unlicensed machine)

To start the Register Now! Program, go to the Windows Start menu and choose Programs,
GE Fanuc Software, VersaPro, RegisterNow!  Click the Next button on the Welcome
dialog.

Appendix
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Click the Yes button on the Software License Agreement dialog.

Click the Transfer In License button on the License VersaPro dialog.
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Click the Register Floppy for Transfer In button on the Transfer In License dialog.

Enter a floppy disk into the floppy drive and click the OK button.  (The floppy disk
doesn’t have to be clean.)

The following message will appear when the floppy is successfully registered.

The Transfer In License dialog will remain.  Do not click any buttons.  Proceed to the
licensed machine to perform “Step 2 – Transfer Out.”
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Step 2.  Transfer Out  (performed on the licensed machine)

Startup the Register Now! program found under Start->Programs->GE Fanuc Software-
>VersaPro->RegisterNow!  Click the Next button on the Welcome dialog.

Click the Transfer License Out by Floppy button on the Transfer Out License dialog.
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Since we are transferring via a floppy disk, insert the registered floppy disk into the floppy
and click the OK button.

You should see one of the following two messages reflecting a successful license transfer
out.  Click the OK button.

(Message 1)  This message appears when the licensed machine carries only one
license.  This is the more common of the two.   Since the machine’s only license is
transferred out, a 4 day trial license is assigned to the machine.

or

(Message 2)  This message appears when the licensed machine contains multiple
licenses and shows how many licenses remain.

You are finished using this machine.  Return to the unlicensed machine with the licensed
floppy disk to proceed with “Step 3 – Transfer In.”
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Step 3.  Transfer In  (performed on the unlicensed machine)

The Transfer In License dialog should still be visible.  Click the Transfer Authorization In
by Floppy button.

Insert the licensed floppy disk into the floppy drive and click the OK button.

The following message indicates a successful license transfer.  Click the OK button to exit
the Register Now! program.  You are now ready to run your licensed VersaPro product.
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Using the VersaPro Keyboard

The quick reference card on the next page contains a listing of keyboard shortcuts for
VersaPro commands, as well as other programming tips.
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VersaPro™ Programming Software
Quick Reference

To launch/exit VersaPro
CTRL+ALT+V Launch VersaPro from Windows; Bring

VersaPro into focus.

ALT+F4 Exit VersaPro.

CTRL+ALT+R Launch Remote IO Manager (Stand Alone

Hardware Config) from Windows; Bring
Remote I/O Manager into focus.

To modify the VersaPro workspace
F6 Move focus to next block/dockable window.

SHIFT+F6 Move focus to previous block/dockable
window.

ALT+0 Show or hide the status bar.

ALT+1 Show or hide the Folder Browser.

ALT+2 Show or hide the Information Window.

ALT+3 Show or hide the Variable Declaration Table.

ALT+6 Show or hide the Local Logic Variable
Table.

ALT+F6 Arrange windows so they overlap.

ALT+F7 Arrange windows as horizontal non-
overlapping tiles.

ALT+F8 Arrange windows as vertical non-
overlapping tiles.

ALT+F9 Arrange icons at the bottom of the window.

CTRL+T Display the toolbar dialog.

CTRL+E Display the options dialog.

CTRL+TAB Display next tab/window to the right.

CTRL+SHIFT+TAB Display next tab/window to the left.

To perform folder operations
CTRL+N Create a new Folder.

CTRL+O Open an existing Folder.

CTRL+SHIFT+A Save an entire Folder.

F8 Backup a Folder to (*.flb).

CTRL+F8 Restore a Folder from backup (*.flb).

CTRL+B Create a new Ladder/Instruction List block.

ALT+5 Open _MAIN Block; Bring _MAIN into
focus.

ALT+F10 Close all open Blocks.

CTRL+F7 Check selected Block(s).

F7 Check all Blocks in the Folder.

ALT+4 Open Hardware Configuration.

To perform general operations
ESC Abort the current operation.

CTRL+BREAK Abort.

DELETE Delete the selection.

F1 Display help for the item with focus.

INSERT Inserts a row.

PGUP Move up a page in the selected editor or
table.

PGDN Move down a page in the selected editor or
table.

HOME Move to the top of the selected editor or table.

END Move to the bottom of the selected editor or
table.

ALT+BACKSPACE Undo the last action.

ALT+ENTER Display properties dialog for selected block
or folder.

CTRL+A Select the entire block or table.

CTRL+C Copy the selection to the Clipboard.

CTRL+INSERT Copy the selection to the Clipboard.

CTRL+V Insert Clipboard contents.

CTRL+F3 Find/replace the specified item.

CTRL+G Moves to a specified location.

CTRL+P Print the block that has focus.

CTRL+S Save the block or table that has focus.

CTRL+Y Redo the previously undone action.

CTRL+Z Undo the last action.

SHIFT+DELETE Cut the selection to the Clipboard.

SHIFT+F1 Display help for clicked on buttons, menus
and windows.

SHIFT+INSERT Insert Clipboard contents.

To perform operations in the LD editor
CTRL+- Decrease font size.

CTRL++ Increase font size.

CTRL+= Increase font size.

ALT+F3 Navigate to the next coil.

CTRL+←← Draw/erase horizontal shunt to the left.

CTRL+→→ Draw horizontal shunt to the right.

CTRL+↑↑ Draw vertical shunt up.

CTRL+↓↓ Draw vertical shunt down.

Click right mouse button and drag to target location
Connect two cells with a shunt.

C
ut

 h
er
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To perform operations in the LD and IL editors
F2 Toggle edit mode off/on.

F3 Find next item of defined search criteria.

CTRL+F10 Find specified item in blocks in folder.

CTRL+F11 Go to variable in Variable Declaration Table.

←← Move left by cell.

→→ Move right by cell.

↑↑ Move up by cell.

↓↓ Move down by cell.

SHIFT+←← Increase/decrease selection area to left.

SHIFT+↑↑ Increase/decrease selection area to right.

SHIFT+→→ Increase/decrease selection area up.

SHIFT+↓↓ Increase/decrease selection area down.

HOME If edit mode is off, focus moves to the current row's first
cell the first time Home is pressed. Pressing Home again
moves focus and to the entire rung.

If edit mode is on in the current cell, the cursor moves to
the left of the first character in the field.

END If edit mode is off, focus moves to the current row's last
occupied cell the first time End is pressed. Pressing End
again, moves focus to the row's last cell.

If edit mode is on in the current cell, the cursor moves to
the right of the last character in the field.

CTRL+HOME Move to the first row's first cell.

CTRL+END Moves to the last row's first cell.

TAB Move to right one cell.

SHIFT+TAB Move to left one cell.

ENTER on an empty cell The Instruction dropdown list is activated.
As you type the instruction mnemonic, VersaPro sorts the
possible instructions for the specified location.

ENTER on a cell that contains an instruction or operand
The Variable dropdown list is activated. As you type the
Variable name, VersaPro sorts the possible variables that
are valid for this context. If the instruction is a comment,
it is placed in Edit mode.

SHIFT+ENTER on a cell that contains an instruction or operand
The Instruction dropdown list is activated. As you type
the instruction mnemonic, VersaPro sorts the possible
instructions for the specified location.

SPACEBAR Toggle selection on/off.

CTRL+SPACEBAR Toggle selection on/off.

DELETE Delete the selection.

CTRL+ENTER Exits a comment that has been placed in Edit
mode.

<Instruction Mnemonic>, <Variable Name>
Enter an instruction and variable name at the same time.
i.e. “NOCON , DiscreteVarOne.”

<Instruction Mnemonic>, <Variable Name>, <Reference Address>
Enter an instruction and define a variable name at the
same time. i.e. “NOCON , DiscreteVarTwo, %I12”

<Instruction Mnemonic>, <Variable Name>, <Reference
Address>, <Scope>
Enter an instruction and define a variable name at the
same time, including variable scope (G = Global, L =
Local). i.e. “NOCON , DiscreteVarTwo, %I12, G”

%<Reference Type> Specify the next available PLC reference
address. i.e. “%M”

To change a selected variable’s on-line value
in LD Editor, IL Editor, RVT, and VVT
F10 Write a value to a variable.

F11 Override a discrete variable or reference
address.

F12 Toggle a discrete variable or reference
address.

To perform operations with the connected PLC
F9 Connect to a specific PLC.

CTRL+F9 Disconnect from PLC.

ALT+F2 Store this folder to PLC.

CTRL+F2 Load from PLC into this folder.

F4 Verify this folder with PLC.

F5 Place the PLC in Run Mode.

CTRL+F5 Place the PLC in Stop Mode.

SHIFT+F4 View PLC status.

ALT+V, ALT+N, ALT+L Set Monitor Active for All Blocks.

ALT+V, ALT+N, ALT+ASet Monitor Active for Active Block.

ALT+V, ALT+N, ALT+OSet Monitor Off.

To change a selected variable’s data display format
in LD Editor, IL Editor, RVT, or VVT
CTRL+SHIFT+B Display the value in binary format.

CTRL+SHIFT+D Display the value in signed decimal format.

CTRL+SHIFT+H Display the value in hex format.

CTRL+SHIFT+O Display the value in octal format.

CTRL+SHIFT+R Display the value in real format.

CTRL+SHIFT+S Display the value in scientific notation
format.

CTRL+SHIFT+U Display the value in decimal format.
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#
####

view tables, 8-2, 8-3

_
_MAIN, 3-1

9
90-30 Rack

configuring, 7-8
90-70 Rack

configuring, 7-8

A
Accessing Hardware

Configuration, 7-2
Adding elements to a View

Table, 8-8
Address

completing in IL Editor, 5-5
completing in LD Editor, 4-9

Advanced User Parameters,
EGD (CPUE05)

format, 7-43
Assigning conversion

variables, 3-22
Assigning temporary variables,

3-15
Audit trail mode

setting, 7-7
Audit Trail Mode

configuring log view, 7-50
Auto Correct, 7-6
Autoconnect options

setting, 1-7

B
Bases (VersaMax)

configuring, 7-23
power supply booster, 7-23

Bitmap
copy as, 4-15

Block logic
converting, 3-22, 3-24

Block properties
viewing, 3-8

Block size, maximum, 3-7
Blocks

_MAIN, 3-1
arranging in browser, 3-8
changing order, 3-9
closing, 3-13
copying between folders, 3-4
deleting, 3-12
inserting, 3-4
locating names, addresses, or

call statements, 3-18
opening, 3-6
saving, 3-13

Boolean expressions
nesting, 5-17

Browser, 2-12
Built-in functions

IL editor, 5-13

C
Cable and connections for

serial port, B-3
Cable diagrams, serial

connection, B-6
Cam blocks

creating, 9-16
deleting, 9-16
duplicating, 9-16
editing, 9-16
properties, 9-17
renaming, 9-17

Cam Editor, 9-14
installing, 9-14

Cam profiles
example, 9-15
using in a Motion program,

9-17
Carriers (VersaMax)

configuring, 7-23
deleting, 7-25
power supply booster, 7-23

Catalog numbers, converters
IC690ACC901, B-8

CCU. See Communications
Configuration Utility



Index

Index-2  VersaPro™ Programming Software User's Guide–October 2001 GFK-1670D

  

Changing rack type, 7-8
Checking Blocks, 3-21
Clearing the rack

Series 90-30/90-70, 7-11
VersaMax, 7-25

Clearing the Variable
Declaration Table, 6-13

Closing blocks, 3-13
Comment column

IL editor, 5-2
Communications

connecting to a PLC, 10-2
direct serial connect, 10-2
ethernet, 10-5
modem connection, 10-3
multidrop connection, 10-3
RIO rack, 7-31
serial direct, 10-2
TCP/IP, 10-5

Communications
Configuration Utility

guidelines, 10-8
Compacting the VDT, 6-14
Completing function block

parameters, 4-10
Completing instruction

parameters, 5-5
Configuration

NIU, 7-30
Series 90 Micro, 7-47
Series 90-30 or Series 90-70,

7-8
VersaMax expansion

networks, 7-25
VersaMax modular rack,

7-21
VersaMax Nano/Micro, 7-45
VersaMax Remote I/O rack,

7-30
Configuring VersaMax

Modules, 7-24
Connecting to a PLC, 10-2
Constants

assigning to function block
parameters, 4-13, 5-7

IL editor, 5-11
rules, 4-13, 5-7

Context-sensitive Menu, 2-14
Conversion variables

assigning, 3-22

Converters
IC690ACC901, B-8
RS-232/RS-485, B-5

Converting Blocks, 3-22, 3-24
guidelines, 3-24

Converting Rack Systems,
7-54

Copy as bitmap, 4-15
CPU model checking, 10-11
CPU Redundancy, 7-13
CPU, configuring

series 90-30/90-70, 7-9
VersaMax, 7-23

Creating a New Folder, 2-2
based on VersaPro folder, 2-4

Creating and modifying
variables, 6-5

Creating New
Reference/Variable View
Tables, 8-7

Cross-reference of variables
creating, 6-14

CSM, 2-14
Customizing display

IL editor, 5-3
LD editor, 4-3

Customizing display format,
8-6

Customizing View Tables, 8-4
Cut, Copy, Paste

IL editor, 5-8
LD editor, 4-15
using in the variable

declaration table, 6-8
view tables, 8-10

D
Date and time

viewing and changing, 10-18
Deleting

in LD editor, 4-16
Deleting blocks, 3-12
Deleting Carriers (VersaMax),

7-25
Deleting rack modules (Series

90-30/90-70), 7-11
Deleting rack modules

(VersaMax), 7-25
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Deleting variables, 6-12
Device, CCU

configuring, 10-3
DEFAULT, 10-2

Direct serial port connection,
10-2

Display format, changing
monitored logic, 10-21
Reference View Tables, 8-5

Display format,changing
Variable View Tables, 8-6

Display options
setting, 1-6

Docking, 2-15

E
Editing Ladder Logic, 4-14
EGD. See Ethernet Global

Data
Empty row

inserting, 4-16
ENO

using in IL editor, 5-18
Error checking

IL editor, 5-19
Error color

setting, 7-7
Ethernet communications, 10-5
Ethernet Global Data

advanced user parameters,
7-43

configuration, 7-35
configuring interface adapter

name, 7-36
name resolution and routing

table, 7-36
PLC timing considerations,

7-39
restoring, 7-43
setting aliases, 7-36

Ethernet interface adapter
name, 7-36

Expansion networks,
VersaMax

configuring, 7-25
Expansion Racks (Series 90-

30/90-70)
configuring, 7-10

Exporting Variables, 6-17

EZ Program Store, 10-16

F
Fault details, 11-3
Fault Tables, 11-1

clearing, 11-5
fault details, 11-3
printing, 11-6
selecting font, 11-6
viewing, 11-2

Find in blocks, 3-18
Find/Replace, 3-19
Finding program rung, row or

variable, 3-17
Flash memory, 10-15
Folder

creating, 2-2
creating based on existing

VersaPro folder, 2-4
names, 2-10
properties, 2-19

Folder components, 1-3
changing order, 3-9

Font
changing in IL Editor, 5-3

Format Reference Table, 8-5
Function Address, 4-5
Function block parameters

completing, 4-10
Function blocks

IL editor, 5-12
LD editor, 4-5

Function Data Length, 4-5
Function properties, 4-9, 5-5
Function toolbar

compact, 4-6
expanded, 4-7

Functions
built-in, 5-13
IL editor, 5-12
LD editor, 4-5

G
Genius bus configuration, 7-11
Go To, 3-17
Go To variable
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locating variables in the
VDT, 6-7

H
Hardware Configuration

accessing, 7-2
converting rack systems, 7-54
log window, 7-50
menus, A-11
overview, 7-2
printing, 7-54
reference view, 7-49
setting, 1-4
setting options, 7-7
shortcut keys, 7-6
toolbar, 7-3

High speed counter
Series 90 Micro, 7-48
VersaMax Nano/Micro, 7-46

Highest references used, 6-14

I
I/O Fault Table, 11-1
IBM-AT/XT serial port, B-5
IL editor

built-in functions, 5-13
IL Editor

customizing display, 5-3
entering instructions, 5-4
nesting Boolean expressions,

5-17
IL instructions

entering, 5-4
IL language

overview, 5-9
Importing Variables, 6-15
Information window, 2-12,

2-13
Inserting an empty row, 4-16
Inserting objects, 3-7
Installing

Cam Editor, 9-14
VersaPro, 1-2

Instruction column
IL editor, 5-2

Instruction List Editor
overview, 5-2

Instruction parameters

completing in IL editor, 5-5
Instructions

entering in IL Editor, 5-4
entering in LD Editor, 4-5
selecting in IL editor, 5-4

K
Keyboard entry

LD editor, 4-9
Keyboard shortcuts

HWC, 7-6

L
Label column

IL editor, 5-2
Ladder display options

customizing, 4-3
Ladder Logic

editing, 4-14
LD Editor

customizing options, 4-3
entering instructions, 4-5
overview, 4-2

LD functions
toolbar, 4-6

LD Functions
toolbar, 4-7

LD instructions
entering using keyboard, 4-9
entering using toolbar, 4-6,

4-8
LD Instructions

data length, 4-5
entering, 4-5
function address, 4-5

LD_BOOL, 5-9
LD_ENO, 5-9
LD_INT, 5-9
LDN_BOOL, 5-9
Length

completing in IL Editor, 5-5
completing in LD Editor, 4-9

License
transferring, C-1

Load/Store/Verify RIO
configuration, 7-31

Loading
folder from PLC, 10-12
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RIO configuration, 7-33
VersaMax hardware

configurations, 7-29
Local Logic editor, 9-7
Local Logic Variable Table,

9-8
Locked blocks

importing from Logicmaster,
2-7

Log file size, setting, 7-7
Log View

hardware configuration, 7-50
Logic editor window, 2-12

M
Maximum block size, 3-7
Memory

EZ Program Store, 10-16
flash memory, 10-15

Menu bar and toolbars, 2-12
Menus

HWC, A-11
VersaPro, A-1

Miniconverter kit
cable diagrams, B-10
RS-232 port pin assignments,

B-9
RS-422 (SNP) to RS-232,

B-8
RS-422 port pin assignments,

B-9
system configurations, B-10

Modem issues, 10-9
Modules

Series 90-30/90-70, 7-10
VersaMax, 7-24

Monitoring logic, 10-20
Motion Program editor, 9-4
Motion Program/Local Logic

blocks
restoring, 9-12

Motion Program/Local Logic
options

setting, 9-3
Multidrop connections, B-7
Multiple instances of

VersaPro, 1-3

N
Name Resolution

restoring, 7-43
Name Resolution and Routing

Table configuration, 7-36
Nesting Boolean expressions,

5-17
New Reference View Table,

8-7
New Variable View Table, 8-7
Next reference assignment, 7-7
NIU

configuring, 7-30

O
Objects

inserting, 3-7
Online viewing

view tables, 8-14
Opening blocks, 3-6
Operand column

IL editor, 5-2
Operators

valid in IL editor, 5-9
Options

display, 8-4
hardware configuration, 7-7
Motion Program/Local

Logic, 9-3
Override reference

reference view tables, 8-14
Overrides

searching for, 10-22

P
Parameter Editor

editing tips, 7-4
error color, 7-5
using, 7-3

Parameter view
(tabbed/spreadsheet), 7-7

Passwords
CCU, 10-8
folder, 2-18

Paste
LD editor, 4-16
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PLC
configuring, 7-8, 7-21, 7-45,

7-47
run/stop mode, 10-19

PLC communication
connecting, 10-2
direct serial port connection,

10-2
PLC Fault Table, 11-1
PLC Hardware

setting, 1-4
PLC status information, 10-17
Point-to-point RS-232

connections, B-6
Power supply

series 90-30/90-70, 7-9
Power Supply (Series 90-30)

configuring, 7-9
Power Supply (VersaMax)

configuring, 7-24
Power Supply Bases

(VersaMax)
adding, 7-23

Power Supply Booster Bases
configuring, 7-23

Printing Hardware
Configuration, 7-54

Properties
blocks, 3-8
folder, 2-19

Pulse train output
Series 90 Micro, 7-48
VersaMax Nano/Micro, 7-46

Pulse width modulation
Series 90 Micro, 7-48
VersaMax Nano/Micro, 7-46

Q
Quick reference, D-1

R
Rack modules (Series 90-

30/90-70)
adding, 7-10
configuring, 7-10
deleting, 7-11

Rack modules (VersaMax)

deleting, 7-25
Rack type (Series 90-30/ 90-

70)
changing, 7-8

Rack, clearing
Series 90-30/90-70, 7-11
VersaMax, 7-25

Real-time updates, 10-20
Redo, 3-14
Redundancy

CPU, basic, 7-13
Reference Address column

IL editor, 5-2
Reference View

hardware configuration, 7-49
Reference View Tables

adding an address, 8-9
changing display format, 8-5
conversion, 8-3
creating new, 8-7
overview, 8-3

Remote ethernet interfaces
setting aliases, 7-36

Remote I/O
communications, 7-31
configuring, 7-30
load/store/verify, 7-31

Reserved words, 6-4
Reset

parameters, 7-5
Restoring

Motion/Local Logic blocks,
9-12

Restoring EGD and Name
Resolution, 7-43

Restricting folder access, 2-18
RIO. See Remote I/O
RS-232 point-to-point

connections, B-6
RS-232/RS-485 converter, B-5
RS-422 interface, B-2
Rules for constants, 4-13, 5-7
Run Mode, 10-19

S
Saving blocks, 3-13
Saving View Tables, 8-13
Search and Replace, 3-19
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Selected blocks
printing, 2-21

Selecting instructions, 5-4
Selecting logic, 4-14

LD editor, 4-14
Serial parameter settings, 10-8
Serial port

IBM-AT/XT, B-5
Serial port and cables,

appendix C
cable and connector

specifications, B-3
IBM-AT/XT serial port, B-5
multidrop connections, B-7
RS-232 point-to-point

connections, B-6
RS-232/RS-485 converter,

B-5
RS-422 interface, B-2
serial cable diagrams, B-6
Serial port, B-4

Serial port update device. See
EZ Program Store

Series 90 Micro
configuring, 7-47

Shared module IDs
VersaMax, 7-29, 7-33

Shortcut Keys
hardware configuration, 7-6

SNF File
exporting variables, 6-17
importing variables, 6-15

Sorting variables, 6-12
Specifications

serial port cables, B-3
ST_BOOL, 5-9
ST_DINT, 5-10
ST_INT, 5-10
Starting VersaPro, 1-2
Status bar, 2-12
Status information

PLC, 10-17
STN_BOOL, 5-9
Stop Mode, 10-19
Storing

folder to PLC, 10-10
Motion/Local Logic, 9-11
RIO configuration, 7-32

Syntax checks
performing, 3-21

T
Tabs

variable declaration table, 6-2
Target communications

status information, 10-17
TCP/IP, 10-5
Temporary variables

assigning, 3-15
defining, 5-19

Timed interrupt
90-30 block name, 3-3

Timing Considerations
for EGD, 7-39

Toggle reference
reference view tables, 8-14

Toolbar
compact, 4-6
expanded, 4-7

Toolbars
hardware configuration, 7-3,

7-8
VersaPro, A-7

Transfer utilities
read/write/verify EZ Program

Store, 10-16
read/write/verify flash

memory, 10-15
Transfer Utilities

clearing PLC Memory, 10-13
loading from the PLC, 10-12
loading from the PLC, 10-10
storing to the PLC, 10-10
verifying folder data, 10-14

Transferring your VersaPro
license, C-1

Type
instructions, 4-5

U
Undo, 3-14
Undo levels

setting, 7-7
Unequal after check all or

verify, 10-11
Unused variables

finding, 6-14
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Update in progress or
unavailable, 10-21

V
Value column

IL editor, 5-2
Variable Declaration Table, 2-

12, 6-1
address field, 6-3
clearing, 6-13
compacting, 6-14
description field, 6-3
EXT field, 6-4
field descriptions, 6-3
length field, 6-3
name field, 6-3
navigating, 6-6
navigating with the keyboard,

6-6
navigating with the mouse,

6-6
overrides field, 6-4
retentive field, 6-4
saving edits, 6-13
scope field, 6-3
stored value field, 6-3
tabs, 6-2
type field, 6-3

Variable Name, 4-11
Variable View Table

customizing display, 8-6
Variable View Tables

creating new, 8-7
overview, 8-2

Variables
assigning to function block

parameters, 4-10
assigning to instruction

operands, 5-5
creating, 6-5
creating when adding blocks,

3-15
deleting, 6-12
exporting, 6-16, 6-17
Go To, 6-7
importing and exporting,

6-15
locating in the VDT, 6-7
modifying, 6-5
replacing in LD Editor, 4-12

sorting, 6-12
using Cut, Copy, Paste and

Drag and Drop, 6-8
with overlaps, 4-10

VersaMax expansion networks
configuring, 7-25

VersaMax modules
shared IDs, 7-29, 7-33

VersaMax Nano/Micro
configuring, 7-45

VersaMax Rack
configuring, 7-21

VersaMax Remote I/O
configuring, 7-30

VersaPro
overview, 1-3

View Tables
adding entries, 8-8
customizing, 8-4
options, 8-4
saving, 8-13
viewing online, 8-14

W
Warning color

setting, 7-7
Windows

docking, 2-15
hiding, 2-15
moving and resizing, 2-15

Word for word changes, 10-11
Workbench options

setting, 1-4
Workbench Window, 1-4
Writing

a value to a reference, 8-10

Z
Zoom ratio

setting, 4-4
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