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1 MADRIX 3 Fixture Editor

This topic includes:

Introduction

The MADRIX 3 Fixture Editor is a separate application and useful tool to create and configure lighting fixtures for
MADRIX.

LED fixtures are implemented into MADRIX using the MADRIX Fixture Editor. All the fixtures, their profiles and
configurations are stored in the MADRIX Fixture Library (madrix.mflx). This is a separate file. MADRIX will access this

file to load all available fixture configurations.

Usage

With the help of the MADRIX Fixture Editor, you can:

» see how fixtures are implemented in MADRIX.
= see how many and which fixtures are already included.
= adjust settings and profiles to your requirements.

= implement and add new fixture configurations to the library yourself.

Where To Find The MADRIX Fixture Editor

The Fixture Editor is automatically installed together with MADRIX. You can access the tool or its documentation by
calling up the shortcut in the Windows Start Menu or in the MADRIX installation directory.

= In Windows, go to Start > All Programs > MADRIX 3 > Fixture Editor
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The original, executable program can be found in the MADRIX installation directory:

» C:\Program Files (x86)\MADRIX3

1.1 Important Notes

= The MADRIX Fixture Library is loaded into MADRIX, when the MADRIX software is launched. In this
way, MADRIX will load the new settings and profiles during start-up.

= MADRIX needs to be restarted when changes have been made to the fixture library.

= MADRIX can only access 1 MADRIX Fixture Library during run-time. All fixture profiles that are
required need to be in 1 library file.

= By default, MADRIX loads the madrix.mfix, which is the original MADRIX Fixture Library.

= MADRIX allows you to load a fixture library that is not the default MADRIX Fixture Library [In
MADRIX, go to Preferences > Options... > Start Options > Load A Special Fixture Library].

= MADRIX 3 Fixture Editor can load MADRIX 2.X Fixture Libraries [*.mfl] as well as MADRIX 3.X
Fixture Libraries [*.mflx].

= MADRIX 3 Fixture Editor can save only MADRIX 3.X Fixture Libraries [*.mflx].

= MADRIX 3 Fixture Editor can load MADRIX 2.X Fixtures [*.mfx] as well as MADRIX 3.X Fixtures [*.
mfxx].

= MADRIX 3 Fixture Editor can save only MADRIX 3.X Fixtures [*.mfxx].

= Always make a backup of the madrix.mfix before and after applying any changes!

= When updating your MADRIX software, the Setup (Auto Installer) will completely overwrite the
current madrix.mfix in order to update the library.

= When updating your MADRIX software, the Setup (Auto Installer) will automatically create a
"madrix.mfix.bak”. This file is a backup of your previous MADRIX Fixture Library.

www.madrix.com /15



MADRIX Fixture Editor 3.2. [Part A] MADRIX 3 Fixture Editor

1.2 Getting Started

This topic includes:

Getting Started

If you open the MADRIX 3 Fixture Editor, you will see that no fixture library is loaded. At first, the tool is empty.

To load the original MADRIX Fixture Library file:
1] Select File > Open Library...
[Keyboard shortcut: Ctri+0]
2] A new window will open.

3] Navigate to the installation directory of MADRIX:
- C:\Program Files (x86)\MADRIX3

4] Choose madrix.mfilxand press Open

Choosing The Language

Before starting work with the MADRIX Fixture Editor, you can choose the language of the user interface.

= In the menu Language, choose from:
- English
[Keyboard shortcut: Ctri+Shift+Alt+E]
- Deutsch [German]
[Keyboard shortcut: Ctrl+Shift+Alt+D)]

[This user manual only includes English.]
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MADRIX Fxture Editor 3.2.

Overview

The MADRIX 3 Fixture Editor window is divided into 3 parts [from left to right]:

» A Fixture Library list

Fixture and Channeloverviews

» A Fixture preview

File Fixture Language

SMADRIX

3 Fixture Editor

+ e
- Futurelight

1"
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Fixture Library

= On the left-hand side, a tree structure represents the content of the currently loaded fixture library.
» The items are arranged in alphabetical order.
= Each top branch of the structure names a lighting fixtures manufacturer.

= Every item has one or more sub-items representing the fixture profile or a variation of the fixture profile for

different modes.

= Expands the complete list of fixtures with all of its entries.
= Collapses all entries of the list.
= Allows you to edit the selected fixture profile. First, select one fixture profile from the list.

Fixture And Channels

In the center of the Fixture Editor window, the configuration for the currently selected fixture and channels is displayed

and can be changed. Learn more »

Fixture Preview

The area on the right-hand side of the Fixture Editor serves as a preview while editing. The upper part shows a
graphical model of the fixture. The pixel or voxel belonging to the currently selected channel is highlighted with the
specified color. Additionally, the lower part summarizes all information [channels, colors, positions, values, types, and

names] of this pixel/voxel. The preview is updated every time you edit the fixture profile.
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1.3 Managing Fixture Libraries

This topic includes:

Overview

Creating A New Library
Loading A Library

Adding A Library

Saving A Library

Checking A Library For Errors

Overview

Exit

Mew Library
Open Library...
Add Library...
Save Library
Save Library As...
Check Library

Recent Files

Ctrl+M
Ctrl+0
Ctrl+A
Ctrl+5
Ctrl+Shift+5
Ctrl+ K

Alt+F4

= File - Use this menu to manage your original MADRIX Fixture Library [and additional libraries].

= File > Recent Files - Displays libraries that were previously loaded.

= File > Exit - Closes the Fixture Editor.

Creating A New Library

= File > New Library - Creates a new library. This library will not include any fixture profiles yet.

Loading A Library

www.madrix.com
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= File > Open Library... - Loads a fixture library into the MADRIX Fixture Editor. This will open a new window for

yout to choose the fixture library. [A fixture library file has the extension *.mflx.]

If you open the MADRIX 3 Fixture Editor, you will see that no fixture library is loaded. At first, the fixture library is
empty.

To open the original MADRIX Fixture Library file:

1] Select File > Open Library...
[Keyboard shortcut: Ctri+0]

2] Navigate to the installation directory of MADRX:
- C:\Program Files (x86)\MADRIX3

3] Choose madrix.mfixand press Open

Adding A Library

= File > Add Library... - Allows you to add other libraries to the currently loaded library in order to merge several

library files, for example [add and append].

Saving A Library

» File > Save Library - Saves a library file including all the changes you have made. This will change your

currently loaded fixture library.

= File > Save Library As... - Saves a library file including all the changes you have made into a new file. This will

open a new window. Choose the location, enter a name for the new file, and press Save

Modifications to your library cannot simply get lost. You will have to confirm it if you want to quit the MADRIX 3

Fixture Editor without having saved.

If the library was modified, the title bar shows an asterisk, too.
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Checking A Library For Errors

= File > Check Library... - Checks the fixture library for logical errors. The Fixture Editor will look for logical
errors, such as having a defined a Color Depth of 4, but only including 3 channels for the fixture. This option is
useful if you want to have an automatic check up after having implemented new fixtures. But the option should

not replace checking the fixture profile for errors yourself.
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1.4 Managing Fixtures

This topic includes:

Overview

Creating A New Fixture
Copying A Fixture

Editing A Fixture

Deleting A Fixture

Loading And Saving A Fixture

Overview

» Fixtures - Use this menu to manage your fixture profiles.

Creating A New Fixture

E Fisture

Add Mew Fixture
Copy Fixture
Edit Fixture
Delete Fixture

Open Fixture...

Save Fiture...

Ctrl+Alt+M
Ctrl+Alt+C
Ctrl+ Alt+E
Ctrl+Alt+D

Ctrl+Alt+ O
Ctrl+ Alt+5

» Fixtures > Add New Fixture - Allows you to create a new fixture profile. Make sure to edit all Fixture and

Channelsettings afterwards.

Learn more »Configuration Of Fixture Profiles

Copying A Fixture

www.madrix.com

1113



MADRIX Fixture Editor 3.2. [Part A] MADRIX 3 Fixture Editor

= Fixtures > Copy Fixture - Allows you to copy a current fixture profile and edit the settings in order to create a

new fixture profile based on another profile. Make sure to edit all Fixture and Channelsettings afterwards.

Learn more »

Editing A Fixture

» Fixtures > Edit Fixture - Allows you to edit all settings of a fixture profile.

Learn more »

Deleting A Fixture

» Fixtures > Delete Fixture - Instantly removes the currently selected fixture profile from the library.

Loading And Saving A Fixture

= Fixtures > Open Fixture... - Allows you to load a fixture from an external file [MADRIX Fixture of the file type *.
mfxx]. The fixture profile will be added to the fixture library.

» Fixtures > Save Fixture... - Allows you to save a fixture to an external file [MADRIX Fixture of the file type *.
mfxx]. First, select a fixture. Second, go to Fixtures > Save Fixture.... Third, a new window opens. Fourth, enter

a file name, open the correct location to save the file, and press Save.
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1.5 Configuration of Fixture Profiles

This topic includes:

= Introduction

= Step-By-Step Configuration
= Settings

Introduction

This topic describes how to create and how to set up a new fixture.

This is the most important part when creating a new fixture profile.

Step-By-Step Configuration

1] Load a MADRIX Fixture Library.
2] Create a new fixture or copy an existing profile.
3] Configure all fixture settings.

4] Save the fixture library.

1] Loading A Library

» First, make sure to load an existing MADRIX Fixture Library or create a new library.

Learn more »Managing Fixture Libraries

2] Creating Or Copying A Fixture

» Create a completely new fixture profile or copy a profile to edit its available settings.

Learn more »Managing Fixtures
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3] Setting Up A Profile

= Make sure to set up all settings, including Fixture Settings as well as Channel Settings.

= Press Apply and OKto confirm your changes!

Learn more

4] Saving The Library

= Make sure to save your library after making any chances.

Learn more »

Settings

Overview

Each fixture profile includes two types of settings:

» Fixture Settings

[Includes data about the fixture in general]

= Channel Settings

[Includes detailed data about each DMX channel/color channel]

Edit Fixture

= Go to Fixtures > Edit Fixture in order to be able to edit all settings as described below [Edit mode].
Or Double-click on a fixture in the Fixture Library list.

Fixture Settings
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Manutacturers ELEMEMTS

Homepage :
Fisture Mame & Titanium TR Matrix Bar
——

Short Hame : IME‘t”“E‘ar—I

ol Mame | S4ch
e EEEEEEE———————|

= Dt
|

Set up the following settings:

= Manufacturer - Enter the name of the manufacturer.

= Homepage - Enter the website of the manufacturer. Press Callto let Windows automatically open your default

web browser and launch the website.
» Fixture Name -Enter the complete name of the fixture.
= Short Name -Enter a short label for the fixture.

= Protocol Name - Fixtures might have several modes or come in different types. Specify the type or mode here

[e.g., 54ch - 54 DMX channel mode].

» Type - Specify if the fixture is controlled via DMX512 [or DMX-based in general] or via DVI [or DVI-based in
general]. DMX-based types include protocols that are based on DMX512 or function similar [e.g., KiNet or Art-
Net].

= VoxelAmount X /Y / Z - Specify how many pixels/voxels the fixture has in X [horizontal], Y [vertical], and Z
[depth].

= Color Depth - Specify the color mixing mode of your fixture or in other words how many channels one voxel/
pixel of your fixture requires [e.g., RGB fixtures use 3 channels per voxel/pixel, while RGBW fixtures require a
color depth of 4.] You can enter the values directly, or you can use the drop-down list to define the color mode:
W hite, RG, RGB, or RGBW

= DMX Channel Amount - Is only available for DMX-based fixtures. Enter the total number of DMX channels
which the fixture requires [e.g., a 16-pixel RGB fixture usually requires 48 DMX channels per fixture].
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« DMX Address Min / Max - Is only available for DMX-based fixtures. Enter the lowest DMX channel address
possible for this fixture and power supply/controller [usually 1]. Enter the highest DMX channel address possible
for this fixture and power supply/controller [usually 512; but if you have a 150-channels fixture and you can only
address one fixture per controller for example, then DMX Address Max should be 150. In this way, you can only

add one fixture per controller and DMX universe].

Channel Settings

Matne Channel :

Hame : | Fed
Default Walue :
Walue Min !
Irnwert :

006

ooy

008 Green
nog

010

011

012 Blue

013 Red

014 Green

= + - Creates a new channel and adds it to the fixture profile. Make sure to correctly set up all settings for this

channel as explained below.
» — = Deletes a channel from the list of channels.
= Up -Moves an entry one place up in the list of channels. Select the particular channel first.

= Down-Moves an entry one place down in the list of channels. Select the particular channel first.

OK - Confirms your settings for the fixture profile and leaves Edit mode.

= Apply - Confirms your settings, but you will stay in Edit mode and you can change further settings.
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= Cancel - Aborts the process and does not confirm any changes. All changes will be discarded. You will leave Edit

mode.

Set up the following settings:

» Channel # - Specifies the channel number. Especially, when using DMX-based fixtures, every channel has a
specific function. Make sure to set up the channels correctly.
Absolute - Sets the channel as a global identifier. This is optional. There are manufacturers that allow several

fixtures to use one master channel, for example.

= Name - Allows you to change the name of the channel. This name will be displayed in the list of channels to the

left and in the preview to the right.

» Type - Specifies if the channel is of a certain type.
HTP - Activates Highest Takes Precedence for this channel.
[Is a feature only used in special cases. For example, you have 2 fixtures with the same DMX address. But due
to their different locations in the MADRIX Patch, they receive different color values. If HTP is activated for these
fixtures, the highest color value will be put out onto the LEDs. Otherwise, the position in the patch decides which

color value is send out. The latter position wins.]

» Default Value - Specifies the default value for this channel [initial value].
Fixed - Sets the channel always to the Default Value and does not allow any changes to the values, when
working with the fixture in MADRIX. [E.g, a fixture might require the master channel to always be 255 in order to

work correctly].

» Value Min / Max - Limits the value range with an lower and upper limit. By default, the values of a DMX channel
range from 0 to 255. 0 represents Off, while 255 represents Full On. Some fixtures might work with a different
range of values or require a certain minimal value to avoid flickering.

Invert - Some fixture might work the other way around [0 = On and 255 = Off]. Activate Invert in this case.

= Color # - Defines which color the channel controls. Choose from Red, Green, Blue, or W hite [according to the
Color Depth].

» Voxel Pos X - Defines the horizontal position of the channel on the fixture. [Fixtures of MADRIX work on a voxel/

pixel basis. For example, 1/1/1 for example represents the upper left voxel/pixel.]

= VoxelPos Y - Defines the vertical position of the channel on the fixture. [Fixtures of MADRIX work on a voxel/

pixel basis. For example, 1/1/1 for example represents the upper left voxel/pixel.]

= Voxel Pos Z - Defines the depth position of the channel on the fixture. [Fixtures of MADRIX work on a voxel/pixel

basis. For example, 1/1/1 for example represents the upper left voxel/pixel.]
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Confirm Settings

» Press Apply and OKto confirm any changes.
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2 Imprint & Copyright

This topic includes:

Company And Address

@) INOAGE

inoage GmbH
Wiener StraB3e 56
D-01219 Dresden

Germany
Managing Directors: Christian Hertel, Sebastian Pinzer, Sebastian Wissmann

Phone: +49 351 482 056 30
Fax: +49 351 482 056 31

WWW:

E-mail:

Copyright

MADRIX is a registered trademark of inoage GmbH.

All other company names and/or product names are trademarks and/or entered trademarks of their respective
holders. The product might not always be conforming to the presentation, features, and performances. Technical data

can differ slightly, depending on the operating system and the chosen hardware.
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We withhold the option of changes without notification. inoage GmbH does not give any guaranty for function capability
for a certain purpose, the marked ability or other features of the product. No other guaranty claims, on legal or other

terms, can be enforced.

Under no circumstances does inoage GmbH take on the responsibility for liabilities for faults for loses in sales volume
or profits, that occur through the usage of the product, through the serviceability, through abuse, happenings,
circumstances or actions, that we have no influence on. No matter if the damages were caused by the holder of the

product or a third person.

Copyright (c) 2001 - 2014 inoage GmbH. All rights reserved.

Third Parties

Qt
Included Libraries

MADRIX [in this case the MADRIX Fixture Editor] uses the following libraries of the Qt development framework. The
libraries and their use are covered by GNU LGPL v.2.1.

= QtCore4.dll

= QtGui4.dll

= QtOpenGL4.dll

= QtXml4.dll

= QtSvg4.dll

qgif4.dll (Qt Plugin DLL)

gico4.dll (Qt Plugin DLL)

gipeg4.dil (Qt Plugin DLL)

gmng4.dil (Qt Plugin DLL)

gsvg4.dll (Qt Plugin DLL)

gtiff4.dll (Qt Plugin DLL)

www.madrix.com 1123



MADRIX Fixture Editor 3.2. [Part B] Imprint & Copyright

The complete, corresponding, and machine-readable source code of these files, incl. the license text, is available:

= On the MADRIX product CD, in the subfolder ThirdParty. For example, D:\MADRIX3\ThirdParty

= Online at http://www.madrix.com/en/home/download/madrix-software.html

Copy of License

GNU LESSER GENERAL PUBLI C LI CENSE

Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc.
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Everyone is permtted to copy and distribute verbati m copies

of this license docunment, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts
as the successor of the GNU Library Public License, version 2, hence
the version number 2.1.]

Preanbl e

The licenses for nost software are designed to take away your freedom to share and change it. By
contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and

change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to sonme specially designated software
packages--typically libraries--of the Free Software Foundation and other authors who decide to
use it. You can use it too, but we suggest you first think carefully about whether this license
or the ordinary General Public License is the better strategy to use in any particular case,

based on the expl anations bel ow.

When we speak of free software, we are referring to freedom of use, not price. OQur General
Public Licenses are designed to nmake sure that you have the freedom to distribute copies of free
software (and charge for this service if you wish); that you receive source code or can get it
if you want it; that you can change the software and use pieces of it in new free prograns; and

that you are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these
rights or to ask you to surrender these rights. These restrictions translate to certain

responsibilities for you if you distribute copies of the library or if you nodify it.
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For exanple, if you distribute copies of the library, whether gratis or for a fee, you nust give
the recipients all the rights that we gave you. You must make sure that they, too, receive or
can get the source code. If you link other code with the library, you nust provide conplete
object files to the recipients, so that they can relink them with the library after making
changes to the library and reconpiling it. And you nust show them these ternms so they know their

rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer
you this license, which gives you legal permssion to copy, distribute and/or nodify the

library.

To protect each distributor, we want to make it very clear that there is no warranty for the
free library. Also, if the library is nodified by soneone else and passed on, the recipients
should know that what they have is not the original version, so that the original author's

reputation will not be affected by problens that m ght be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program W wi sh
to make sure that a conpany cannot effectively restrict the users of a free program by obtaining
a restrictive license from a patent holder. Therefore, we insist that any patent |Iicense
obtained for a version of the library nust be consistent with the full freedom of use specified

in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public
License. This license, the GNU Lesser General Public License, applies to certain designated
libraries, and is quite different fromthe ordinary General Public License. We use this license

for certain libraries in order to permt |linking those libraries into non-free prograns.

When a program is linked with a library, whether statically or using a shared library, the
conmbination of the two is legally speaking a conbined work, a derivative of the original
library. The ordinary General Public License therefore permts such linking only if the entire
conmbination fits its criteria of freedom The Lesser General Public License pernmits nmore |ax

criteria for linking other code with the library.

We call this license the "Lesser" General Public License because it does Less to protect the
user's freedom than the ordinary General Public License. It also provides other free software
devel opers Less of an advantage over conpeting non-free programs. These disadvantages are the
reason we use the ordinary General Public License for nmany libraries. However, the Lesser

l'icense provides advantages in certain special circunstances.
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For exanple, on rare occasions, there may be a special need to encourage the w dest possible use
of a certain library, so that it beconmes a de-facto standard. To achieve this, non-free prograns
must be allowed to use the library. A nmore frequent case is that a free library does the sane
job as widely used non-free libraries. In this case, there is little to gain by limting the

free library to free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free prograns enables a greater
nunber of people to use a |large body of free software. For exanple, perm ssion to use the GNU C
Library in non-free programs enables many nore people to use the whole GNU operating system as

well as its variant, the GNU Linux operating system

Al t hough the Lesser General Public License is Less protective of the users' freedom it does
ensure that the user of a program that is linked with the Library has the freedom and the

wherewi thal to run that programusing a nodified version of the Library.

The precise terns and conditions for copying, distribution and nodification follow Pay close
attention to the difference between a "work based on the Ilibrary" and a "work that uses the
library". The former contains code derived fromthe library, whereas the latter nust be conbined

with the library in order to run.

TERMS AND CONDI TI ONS FOR COPYI NG, DI STRI BUTI ON AND MODI FI CATI ON

0. This License Agreenent applies to any software library or other program which contains a
notice placed by the copyright holder or other authorized party saying it may be distributed
under the ternms of this Lesser General Public License (also called "this License"). Each

licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be
conveniently linked with application prograns (which use some of those functions and data) to

form execut abl es.

The "Library", below, refers to any such software library or work which has been distributed
under these terns. A "work based on the Library" neans either the Library or any derivative work
under copyright law. that is to say, a work containing the Library or a portion of it, either
verbatim or with nodifications and/or translated straightforwardly into another |anguage.

(Hereinafter, translation is included without limtation in the term"nodification".)

"Source code" for a work neans the preferred form of the work for making nodifications to it.
For a library, conplete source code means all the source code for all nmodules it contains, plus
any associated interface definition files, plus the scripts used to control conpilation and

installation of the library.
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Activities other than copying, distribution and nodification are not covered by this License;
they are outside its scope. The act of running a program using the Library is not restricted,
and output from such a programis covered only if its contents constitute a work based on the
Li brary (independent of the use of the Library in a tool for witing it). Whether that is true

depends on what the Library does and what the programthat uses the Library does.

1. You may copy and distribute verbatim copies of the Library's conplete source code as you
receive it, in any medium provided that you conspicuously and appropriately publish on each
copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices
that refer to this License and to the absence of any warranty; and distribute a copy of this

Li cense along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option

of fer warranty protection in exchange for a fee.

2. You may nodify your copy or copies of the Library or any portion of it, thus formng a work
based on the Library, and copy and distribute such nmodifications or work under the terms of

Section 1 above, provided that you also neet all of these conditions:

a) The modified work nmust itself be a software library.

b) You nust cause the files nodified to carry promnent notices stating that you changed the
files and the date of any change.

c) You nust cause the whole of the work to be licensed at no charge to all third parties under
the terms of this License.

d) If a facility in the nodified Library refers to a function or a table of data to be supplied
by an application program that uses the facility, other than as an argument passed when the
facility is invoked, then you nust make a good faith effort to ensure that, in the event an
application does not supply such function or table, the facility still operates, and perforns
what ever part of its purpose remai ns neani ngful.

(For exanple, a function in a library to conmpute square roots has a purpose that is entirely
wel | -defined independent of the application. Therefore, Subsection 2d requires that any
application-supplied function or table used by this function must be optional: if the

application does not supply it, the square root function nust still conpute square roots.)

These requirenents apply to the nodified work as a whole. If identifiable sections of that work
are not derived from the Library, and can be reasonably considered independent and separate
works in themselves, then this License, and its terms, do not apply to those sections when you
di stribute them as separate works. But when you distribute the same sections as part of a whole
which is a work based on the Library, the distribution of the whole nust be on the terns of this
Li cense, whose permissions for other |icensees extend to the entire whole, and thus to each and

every part regardl ess of who wote it.
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Thus, it is not the intent of this section to claim rights or contest your rights to work
written entirely by you; rather, the intent is to exercise the right to control the distribution

of derivative or collective works based on the Library.

I'n addition, mere aggregation of another work not based on the Library with the Library (or with
a work based on the Library) on a volume of a storage or distribution medium does not bring the

ot her work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this
License to a given copy of the Library. To do this, you nust alter all the notices that refer to
this License, so that they refer to the ordinary GNU General Public License, version 2, instead
of to this License. (If a newer version than version 2 of the ordinary GNU General Public
Li cense has appeared, then you can specify that version instead if you wish.) Do not make any

ot her change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU

General Public License applies to all subsequent copies and derivative works made from that

copy.

This option is useful when you wish to copy part of the code of the Library into a programthat

is not a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2)
in object code or executable form under the terms of Sections 1 and 2 above provided that you
acconpany it wth the conplete corresponding machine-readable source code, which nust be
di stributed under the ternms of Sections 1 and 2 above on a nedium customarily used for software

i nterchange.

If distribution of object code is nmade by offering access to copy from a designated place, then
of fering equival ent access to copy the source code from the same place satisfies the requirenent
to distribute the source code, even though third parties are not conpelled to copy the source

al ong with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work
with the Library by being conpiled or linked with it, is called a "work that uses the Library".
Such a work, in isolation, is not a derivative work of the Library, and therefore falls outside

the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a
derivative of the Library (because it contains portions of the Library), rather than a "work
that uses the library". The executable is therefore covered by this License. Section 6 states

terns for distribution of such execut abl es.
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When a "work that uses the Library" uses material from a header file that is part of the
Li brary, the object code for the work nmay be a derivative work of the Library even though the
source code is not. Whether this is true is especially significant if the work can be I|inked
wi thout the Library, or if the work is itself a library. The threshold for this to be true is

not precisely defined by |aw

If such an object file uses only nunerical paranmeters, data structure |ayouts and accessors, and
smal |l macros and small inline functions (ten lines or less in length), then the use of the
object file is unrestricted, regardless of whether it is legally a derivative work. (Executables

containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for
the work under the terms of Section 6. Any executables containing that work also fall under

Section 6, whether or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also combine or link a "work that uses the
Li brary" with the Library to produce a work containing portions of the Library, and distribute
that work under terns of your choice, provided that the terns permt nodification of the work

for the custoner's own use and reverse engi neering for debugging such nodifications.

You nust give prom nent notice with each copy of the work that the Library is used in it and
that the Library and its use are covered by this License. You nust supply a copy of this
License. If the work during execution displays copyright notices, you mnust include the copyright
notice for the Library anong them as well as a reference directing the user to the copy of this

Li cense. Al so, you nust do one of these things:

a) Acconpany the work with the conplete corresponding machine-readable source code for the
Li brary including whatever changes were used in the work (which must be distributed under
Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the
conpl ete machi ne-readable "work that uses the Library", as object code and/or source code, so
that the user can nodify the Library and then relink to produce a nodified executable containing
the nodified Library. (It is understood that the user who changes the contents of definitions
files in the Library will not necessarily be able to reconpile the application to use the
modi fi ed definitions.)

b) Use a suitable shared library nechanismfor linking with the Library. A suitable mechanismis

one that (1) uses at run tinme a copy of the library already present on the user's conputer
system rather than copying library functions into the executable, and (2) will operate properly
with a nodified version of the library, if the user installs one, as long as the nodified

version is interface-conpatible with the version that the work was made with.
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c) Acconpany the work with a witten offer, valid for at |east three years, to give the sane
user the materials specified in Subsection 6a, above, for a charge no nore than the cost of
perform ng this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer
equi val ent access to copy the above specified materials fromthe same place.

e) Verify that the user has already received a copy of these materials or that you have already
sent this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data
and utility prograns needed for reproducing the executable from it. However, as a special
exception, the nmaterials to be distributed need not include anything that is normally
distributed (in either source or binary form wth the major conponents (conpiler, Kkernel, and
so on) of the operating system on which the executable runs, unless that conponent itself

acconmpani es the executabl e.

It may happen that this requirenent contradicts the license restrictions of other proprietary
libraries that do not normally acconpany the operating system Such a contradiction neans you

cannot use both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a
single library together wth other library facilities not covered by this License, and
di stribute such a combined library, provided that the separate distribution of the work based on
the Library and of the other library facilities is otherwise permtted, and provided that you do

these two things:

a) Accompany the conbined library with a copy of the sane work based on the Library, uncombined
with any other library facilities. This nust be distributed under the ternms of the Sections
above.

b) G ve promnent notice with the conbined library of the fact that part of it is a work based

on the Library, and explaining where to find the acconpanyi ng unconbi ned form of the same work.

8. You my not copy, nmodify, sublicense, link with, or distribute the Library except as
expressly provided under this License. Any attenpt otherwise to copy, nmodify, sublicense, |ink
with, or distribute the Library is void, and will automatically term nate your rights under this

Li cense. However, parties who have received copies, or rights, from you under this License will

not have their licenses term nated so long as such parties remain in full conpliance.

9. You are not required to accept this License, since you have not signed it. However, nothing
el se grants you permssion to nodify or distribute the Library or its derivative works. These
actions are prohibited by law if you do not accept this License. Therefore, by nodifying or
distributing the Library (or any work based on the Library), you indicate your acceptance of
this License to do so, and all its terns and conditions for copying, distributing or nodifying

the Library or works based on it.
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10. Each tine you redistribute the Library (or any work based on the Library), the recipient
automatically receives a license from the original licensor to copy, distribute, link with or
modi fy the Library subject to these terns and conditions. You may not inpose any further
restrictions on the recipients' exercise of the rights granted herein. You are not responsible

for enforcing conpliance by third parties with this License.

11. If, as a consequence of a court judgnment or allegation of patent infringement or for any
other reason (not limted to patent issues), conditions are inposed on you (whether by court
order, agreenent or otherwi se) that contradict the conditions of this License, they do not
excuse you from the conditions of this License. If you cannot distribute so as to satisfy
si mul taneously your obligations under this License and any other pertinent obligations, then as
a consequence you may not distribute the Library at all. For exanple, if a patent |icense would
not permt royalty-free redistribution of the Library by all those who receive copies directly
or indirectly through you, then the only way you could satisfy both it and this License would be

to refrain entirely fromdistribution of the Library.

If any portion of this section is held invalid or wunenforceable wunder any particular
circunmstance, the balance of the section is intended to apply, and the section as a whole is

intended to apply in other circunstances.

It is not the purpose of this section to induce you to infringe any patents or other property
right clains or to contest validity of any such clainms; this section has the sole purpose of
protecting the integrity of the free software distribution system which is inplenented by public
license practices. Many people have nade generous contributions to the w de range of software
distributed through that systemin reliance on consistent application of that system it is up
to the author/donor to decide if he or she is willing to distribute software through any other

system and a |icensee cannot inmpose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the

rest of this License.

12. If the distribution and/or use of the Library is restricted in certain countries either by
patents or by copyrighted interfaces, the original copyright holder who places the Library under
this License nay add an explicit geographical distribution limtation excluding those countries,
so that distribution is permtted only in or anpng countries not thus excluded. In such case,

this License incorporates the limtation as if witten in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser GCeneral
Public License fromtime to time. Such new versions will be simlar in spirit to the present

version, but may differ in detail to address new problens or concerns.
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Each version is given a distinguishing version nunber. If the Library specifies a version nunber
of this License which applies to it and "any later version", you have the option of follow ng
the terms and conditions either of that version or of any later version published by the Free
Software Foundation. If the Library does not specify a license version nunber, you may choose

any version ever published by the Free Software Foundati on.

14. If you wish to incorporate parts of the Library into other free prograns whose distribution
conditions are inconpatible with these, wite to the author to ask for perm ssion. For software
whi ch is copyrighted by the Free Software Foundation, wite to the Free Software Foundation; we
sonetines nake exceptions for this. Our decision will be guided by the two goals of preserving
the free status of all derivatives of our free software and of pronoting the sharing and reuse

of software generally.

NO WARRANTY

15. BECAUSE THE LI BRARY IS LI CENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LI BRARY, TO THE
EXTENT PERM TTED BY APPLICABLE LAW EXCEPT WHEN OTHERW SE STATED IN WRITING THE COPYRI GHT
HOLDERS AND/ OR OTHER PARTIES PROVI DE THE LIBRARY "AS |S" W THOUT WARRANTY OF ANY KIND, EITHER
EXPRESSED OR | MPLI ED, I NCLUDI NG, BUT NOT LIMTED TO, THE | MPLI ED WARRANTI ES OF MERCHANTABI LI TY
AND FI TNESS FOR A PARTI CULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
LIBRARY IS WTH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY
SERVI CI NG, REPAI R OR CORRECTI ON.

16. I N NO EVENT UNLESS REQUI RED BY APPLI CABLE LAW OR AGREED TO IN WRITING WLL ANY COPYRI GHT
HOLDER, OR ANY OTHER PARTY WHO MAY MODI FY AND/ OR REDI STRI BUTE THE LI BRARY AS PERM TTED ABOVE, BE
LI ABLE TO YOU FOR DAMAGES, | NCLUDI NG ANY GENERAL, SPECI AL, | NCIDENTAL OR CONSEQUENTI AL DAMAGES
ARI SING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT NOT LIMTED TO LOSS OF
DATA OR DATA BEI NG RENDERED | NACCURATE OR LOSSES SUSTAI NED BY YOU OR THI RD PARTIES OR A FAI LURE
OF THE LI BRARY TO OPERATE W TH ANY OTHER SOFTWARE), EVEN |IF SUCH HOLDER OR OTHER PARTY HAS BEEN
ADVI SED OF THE POSSI BI LI TY OF SUCH DAMAGES.

END OF TERMS AND CONDI Tl ONS

How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public,
we recommend meking it free software that everyone can redistribute and change. You can do so by
permtting redistribution under these ternms (or, alternatively, under the ternms of the ordinary

General Public License).
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To apply these terns, attach the following notices to the library. It is safest to attach them
to the start of each source file to nmost effectively convey the exclusion of warranty; and each

file should have at |east the "copyright" line and a pointer to where the full notice is found.

one line to give the library's name and an idea of what it does.

Copyright (C) year nanme of author

This library is free software; you can redistribute it and/or
modi fy it under the terms of the GNU Lesser General Public
Li cense as published by the Free Software Foundation; either

version 2.1 of the License, or (at your option) any |ater version.

This library is distributed in the hope that it will be useful,
but W THOUT ANY WARRANTY; without even the inplied warranty of
MERCHANTABI LI TY or FI TNESS FOR A PARTI CULAR PURPOSE. See the GNU

Lesser General Public License for nore details.

You shoul d have received a copy of the GNU Lesser General Public
License along with this library; if not, wite to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Al so add information on how to contact you by el ectronic and paper mail.

You shoul d al so get your enployer (if you work as a progranmer) or your school, if any, to sign

a "copyright disclaimer"” for the library, if necessary. Here is a sanple; alter the nanes:

Yoyodyne, Inc., hereby disclaims all copyright interest in
the library "Frob' (a library for tweaking knobs) written

by James Random Hacker.

signature of Ty Coon, 1 April 1990
Ty Coon, President of Vice

That's all there is to it!
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