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LICENCE AGREEMENT FOR WEBCAM WATCHER PROFESSIONAL 
 
INSTALLING THE SOFTWARE INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS.  IF 
YOU DO NOT AGREE TO THESE TERMS AND CONDITIONS, THEN YOU SHOULD NOT INSTALL THE 
SOFTWARE. THIS AGREEMENT APPLIES TO THE SOFTWARE CONTAINED ON THE CD-ROM AND ANY 
UPDATES TO SUCH SOFTWARE THAT YOU MAY DOWNLOAD FROM THE INTERNET. 
 
1. COPYRIGHT 
You acknowledge that you are receiving a LIMITED LICENSE TO USE Webcam Watcher Professional 
(“the Software”) and documentation, and that you shall obtain no ownership, title nor any other rights 
in or to the Software and related documentation, all and any portion of which title and rights shall 
remain with Beausoft Ltd. 
 
2. RESTRICTIONS 

• You may not copy the Software, except as reasonably necessary for back-up purposes  
• You may not modify the Software 
• You may not attempt to reverse engineer, decompile or disassemble any portion of the 

Software 
• You may not distribute the software in any way, or make it available for downloading on 

the Internet 
 
3. TERM: 
This license is effective until terminated. You may terminate this Agreement at any time by uninstalling 
and destroying the Software and related documentation and all copies thereof. This license will also 
terminate if you fail to comply with any term or condition of this Agreement. Upon such termination, 
you agree to destroy the Software and related documentation and all copies thereof. 
 
4. LIMITATION OF LIABILITY: 
WEBCAM WATCHER IS PROVIDED "AS IS" WITHOUT ANY WARRANTY. EXCEPT AS EXPRESSLY PROVIDED 
HEREIN, BEAUSOFT DOES NOT MAKE OR PASS ON TO YOU OR ANOTHER THIRD PARTY, ANY WARRANTY 
OR REPRESENTATION INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. WITHOUT LIMITING THE GENERALITY OF 
THE FOREGOING, BEAUSOFT DOES NOT WARRANT THAT THE SOFTWARE WILL BE ERROR FREE OR THAT IT 
WILL MEET YOUR REQUIREMENTS. BEAUSOFT SHALL NOT BE LIABLE FOR ANY DAMAGE SUFFERED BY 
YOU INCLUDING, BUT NOT LIMITED TO, CONSEQUENTIAL, INCIDENTAL, INDIRECT, SPECIAL, EXEMPLARY 
OR PUNITIVE DAMAGES. THE ABOVE LIMITATIONS SHALL APPLY REGARDLESS OF THE FORM OF ACTION, 
WHETHER IN CONTRACT, TORT (INCLUDING NEGLIGENCE), AND STRICT PRODUCT LIABILITY OR 
OTHERWISE, EVEN IF SUCH PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
 
 
 
 
 
 
Version 1.2.2 05/June/2003 
 
 
 
Webcam Watcher Professional is Copyright © 1998-2003 Beausoft Ltd Waiuku New Zealand 
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Getting Started 
 

Overview 
 
Webcam Watcher Professional is a full-featured Digital Video Recorder for 
Network Cameras that can record from multiple cameras simultaneously.  
 
It can also record from conventional snapshot webcams, and Webcam32 
streaming webcams. 
 

 
 
Here is a summary of the Main Features of Webcam Watcher Professional: 

• Easily reconfigurable display lets you see as many cameras as you like  
• Masked motion detection allows precise control over Frame Recording 

and Alarms. 
• Cameras can operate according to easily defined Schedules (e.g. “Office 

Hours”). 
• E-mail image when Alarm occurs. 
• Disk Space Management optionally overwrites old archived images to 

allow for continuous operation. 
• CamBar lets you keep a subset of cameras on screen at all times. 
• Print utility allows multiple images per page to be printed. 
• Built-in MJPEG player lets you view recorded images and display each 

frame’s timestamp. 
• Convert recorded MJPEG files to AVI format. 
• Image Enhancer for poor quality or lighting. 
• Search archived images and display motion graphically. 
• Instantly jump to a particular motion event. 
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Installing Webcam Watcher Professional 
 
Webcam Watcher Professional is normally supplied on CD. To install, insert the 
CD and the installation process should automatically start. 
 
If it does not automatically start, open My Computer and located the CD drive 
and double click. 
 
If you downloaded from the Internet, save the file that you downloaded and 
then open it when the download is complete. 
 
Installation is straightforward.  
 

 
 

This is the initial screen of the Installer. Click Next to start the installation and then 
follow the on-screen instructions. 
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Registering Webcam Watcher Professional 
 
Webcam Watcher Professional is licensed according to the maximum number 
of cameras that can be used. 
 
When first installed, Webcam Watcher Professional runs in demo mode. This 
has limited functionality and only allows a maximum of 4 cameras. 
 
To unlock Webcam Watcher Professional you need to enter the Code and 
Password that was supplied to you. 
 
To do this, run Webcam Watcher Professional and select Help then Enter 
Registration Code from the main menu at the top of the screen. 
 

 
 
If you reinstall Webcam Watcher Professional or Windows then you will need 
to repeat this procedure, so it is important to keep your registration code in a 
safe place. 
 
It is recommended that you make a note of your codes here: 
 
 

CODE:…………………………………………………………………………………………….. 
 
 
 

PASSWORD:………………………………………………………………………………….. 
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System Requirements 
 
Webcam Watcher Professional requires Windows 98, ME, XP or 2000 with a 
minimum of 128Mb of RAM and SVGA display (800x600) or better. 
 
For serious use you should consider using Windows 2000 or XP with 256Mb or 
more of RAM. 
 
The amount of disk space required depends entirely on how much you want to 
record, how many cameras you have, what frame rates you use, and many 
other factors. For assistance in determining your disk space requirements, contact 
your distributor. 

 
Cameras Supported 
 
This is a partial list of cameras that have been tested with Webcam Watcher 
Professional: 
 

• Axis Network Cameras (eg 2100) and Servers (eg 2400) 
• Intellinet Network IP Cameras 
• VivoTek Network Cameras 
• Panasonic WV-NP472, WJ-NT104, WV-NS324 and HCM Range 
• Webcam32 streaming format cameras. 
• Any Netscape-style Motion JPEG streaming camera. 
• Any network snapshot camera that uses JPEG images. This includes 

most Webcams on the Internet. 
 
All Trademarks identified above are the property of their respective owners. 
 
Webcam Watcher Professional has the ability to define new camera types, so 
some cameras can be supported simply by defining the correct URLs. 
 
Beausoft intends to add support for new cameras. Check with your distributor for 
the latest compatibility list. 
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Main Screen 
 

 
 

1. Main Menu.  
2. Main Toolbar. Common commands. Master Timer and Alarm switches. 
3. Image Zoom Controls. These allow you to magnify or reduce the 

current image 
4. Image for Current Camera. Shows the current image for the selected 

camera. If the camera is not currently running it shows the last saved 
picture. 

5. Camera Status and Control Toolbar. Controls to start and stop 
recording the current camera. 

6. Camera Thumbnails. Shows the last picture for every camera. Use this 
panel to select a camera. 

7. Motion Detection Bar Shows the amount of motion detected. 
8. Camera Access Buttons Allows one-click access to the current 

camera’s homepage and admin page. 
9. Image Enhancer Dynamically enhances images. Special enhancement 

for low light conditions. Right click to adjust. 
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Clicking the Recordings tab shows the recorded MJPEG files for the current 
camera. You can view a recording by double-clicking it. 
 

 
 
You can change the size of the Camera Thumbnails by clicking the button at 
the top of the panel. 
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Configuring Cameras 
 

Selecting a Camera Folder 
 
Webcam Watcher Professional uses a Camera Folder to store details of your 
cameras, and to store recordings. You can select the location of the camera 
folder by using File > Select Camera Folder from the main menu. 
 
Initially the camera folder is set to be the same as the program folder. Unless 
you want to store your camera database here, it is a good idea to change this 
before creating any cameras. 
 

New Camera / Edit Camera Dialog 
 
To create a new camera, select Edit > Create New Camera from the main 
menu. This opens the Edit Camera dialog. You can also edit an existing camera 
by selecting the camera and clicking the Edit Camera button. 
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Camera Details 
This section lets you define the Camera’s and characteristics: 

• Camera Name: A short name used for tagging the thumbnails. Also 
used for camera sub-folder name. 

• Description: Optional longer description. 
• Location: Optional location string. 
• Camera Address: IP address of camera. This can be a dotted IP 

address like: 
     192.168.0.253 or it can be a named address: 
     camera1.mydomain.com.  …or a non-standard port: 
     camera.mydomain.com:8080 

• Camera Type: Select from one of the predefined types or choose User 
Defined (in which case you can click the Define button to define the 
camera’s URLs) 

• Camera Channel: For camera servers, select the channel number here. 
 

Monitoring Type 
This section lets you specify how the image is fetched from the camera, and the 
image size and quality. 
 

• Full Motion means that the camera is sending a stream of images. 
• Snapshot means that Webcam Watcher Professional fetches a 

snapshot at regular intervals. 
 

Security 
If the camera needs a Username and Password to view the image, you need 
to enter them here, and check the Use Authentication box. 
 

Default Saving Mode 
When you Start All cameras, the camera is started in the mode specified here: 

• Monitor: The camera is running (in other words, Webcam Watcher 
Professional is fetching pictures) but no pictures are saved.  

• Motion Detect: The camera is running and saving frames where 
motion is detected. If Use Mask is checked then the motion detection 
mask for this camera is used. 

• Record Every Frame: The camera is running and every frame is 
recorded. 
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Disk and CPU Usage Limits 
Webcam Watcher Professional can limit the amount of Disk and CPU that a 
camera uses. 
 
If you enable automatic disk space management (by checking the Limit Disk 
Usage checkbox) then Webcam Watcher Professional will delete old MJPEG 
files if the limit specified here is exceeded. 
 
If you specify a non-zero value for CPU Throttle then Webcam Watcher 
Professional will sleep for this period of time after each frame is received from 
this camera. 
 
Note that you can also specify a Global CPU Throttle on the Preferences 
dialog. The camera’s throttle is applied in addition to the global throttle. 
 

Schedule 
You can specify a Schedule to use for this camera. See the section on 
Schedules to see how this works. 
 

Extra Functions 
User-defined Extra functions can be useful for providing additional functions like 
activating switches or browsing to a related web page. 
 
You can specify up to 16 extra User Defined Functions for a camera. These are 
URLs that can be accessed by clicking the User Defined Functions button on 
the Camera Status and Control Toolbar. 

For each extra function you can specify a Name, URL and Hint. The Name is 
displayed on the Extra Function button, and the hint is displayed when the 
mouse pointer hovers over the button. 
 
If the URL starts with “http” then a direct address is assumed. Otherwise the URL is 
constructed by appending the string to the camera’s Address. Note : No leading 
“/” is required. 
 
If Browse To is checked, a Browser window is opened to the specified URL.  
 
Otherwise Webcam Watcher Professional simply fetches the URL internally (i.e. it 
issues a http GET). Any errors are ignored. 
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Defining Camera Types 
 
You can add new camera types to Webcam Watcher Professional using the 
Edit Camera Definitions dialog. 
 

 
 

Load Definition loads an existing Camera Definition.  
 
Save Definition lets you save a definition. This then becomes available on the 
Edit Camera dialog. 
 
Camera Definitions are stored in files with the extension .CDF 
 
For detailed information about how to define camera types, contact Beausoft 
Technical Support. 
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Monitoring and Recording 
 
 
The Camera Control Toolbar lets you control the current camera. 
 

 
 

      1       2   3  4   5    6   7    8    9 
 

1. Motion Detection Bar shows the amount of motion currently detected. 
Clicking on this allows you to adjust the motion detection settings for the 
current camera. 
 
Then there are four VCR-style buttons to control the camera: 
 

2. Stop button 
3. Monitor button  
4. Motion-Detection button 
5. Recording button 

 
And some other buttons: 
 

6. Camera Home Page button 
7. Camera Admin Page button 
8. Image Enhancer On/Off. Right click to Adjust 
9. Show / Hide User Defined Functions 

 
When Webcam Watcher Professional records images, it records into MJPEG 
files (Motion JPEG). 
 
One file is created per hour. All frames recorded for that hour go into that file. 
You can see the MJPEG files saved using the Recordings tab. If you double click 
on a recording it plays it in the MJPEG Player. 
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MJPEG Player 
 

 
 
If the recordings that Webcam Watcher Professional makes are like videos, then 
this is the Video Player. 
 
The VCR-style buttons at the bottom let you start and stop playing. 
 
The blue arrows let you go to the start and end of the recording. Also forward 
and back single frames. 
 
The slider lets you set the position anywhere in the recording. 
 
The Main Menu on the MJPEG Player lets you perform additional functions: 

• Save the current MJPEG file 
• Copy or Save the current frame 
• Print the current frame 
• Extract the individual JPEGs from the MJPEG file 
• Convert the MJPEG file into an AVI file 

 
The last option, Convert to AVI, uses the codecs that are currently installed on 
your system. Not all codecs perform as expected. 
 
Hint: Press Escape to close the MJPEG player. 
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Motion Detection 
 
When a camera is running, Webcam Watcher Professional is constantly 
comparing frames, looking for motion. It displays the amount of motion on the 
Motion Detection Bar at the bottom of the screen. 
 
You can adjust the motion detection settings by clicking on the bar graph. 
 

 
 
There are three sliders that let you control three parameters: 

• Cell Size. The picture is divided into square cells, and each cell is 
compared. This slider controls how large the cells are. This can range 
from 4x4 pixels to one large cell that covers the whole picture. Smaller 
cell sizes mean more CPU required, but better motion discrimination. 

• Percentage of cells changed determines how many cells need to be 
changed before the picture is considered different. This slider adjusts the 
position of the red and green bars on the Motion Detection BarGraph. 

• Sensitivity controls how sensitive to motion the bargraph is.  
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Motion Detection Mask 
 
Motion Detection can be restricted to a certain area by using a Motion 
Detection Mask. You can edit a camera’s mask by selecting the camera and 
choosing Edit Motion Detection Mask for Current Camera from the Edit 
menu. 
 

 
 

The Mask Editor is easy to use. Select either Mask or Unmask and the brush 
size.  
 
The Red area defines the masked area, which is ignored when detecting 
motion. 
 
The Motion Detection Mask is enabled and disabled by the Use Mask 
checkbox on the Edit Camera dialog. 
 



  

 15 

Searching 
 
Webcam Watcher Professional lets you search for motion graphically. Click the 
Search button to open the Search dialog. 
 

 
 

The Green area (below the line) shows the presence or absence of MJPEG files 

that cover the time period. 
 
The Red area (above the line) shows where frames have been recorded. If 
Motion Detection recording was used, this gives a graph of the motion detected. 
 
Select the Endpoint for the search, Select the period, Hour, Day or Week, and 
click Do Search. The results are displayed. (Note: this may take some time). 
 
You can double click on the results to open the corresponding MJPEG file at the 
correct place. 
 
Right clicking opens a menu that lets you: 

• Open in MJPEG Viewer (same as double clicking) 
• Set Endpoint Here – sets the end of a subsequent search where you 

click. 
 
You can also click the < and > buttons to perform searches for the previous and 
next periods. 
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The CamBar 
 
Webcam Watcher Professional’s CamBar lets you keep some or all of your 
cameras on-screen (much like the Windows taskbar). This remains visible even 
when Webcam Watcher Professional is minimized. 
 
To Open the CamBar click the Cambar button.  
 
The CamBar will open at the top of your screen. Initially it will be empty. 
 
You can drag webcams from the Thumbnails panel (either individually, or you 
can select several and drag them all). 
 

 
 
The CamBar can be dragged to dock on any edge of the screen. It can also be 
made to float anywhere on the screen. Move the CamBar by dragging the 
handlebars, the thin vertical bars at the left of the CamBar. 
 
Clicking on a camera on the cambar restores the main screen and selects the 
camera. 
 
Right click on a camera and a menu opens that lets you: 

• Start or Stop the camera 
• Edit the camera 
• Remove the camera from the CamBar 
• Open the camera’s homepage 
• Copy the current image to the clipboard 

 
Clicking on the CamBar Icon opens a menu that lets you: 

• Start or Stop all cameras 
• Start or Stop all cameras on the CamBar 
• Empty the CamBar 
• Close the Cambar 
• Quit the program 
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Alarms 
 
Webcam Watcher Professional includes an Alarm facility. Alarms are generated 
when more than a certain amount of motion occurs. The Alarms for a camera 
are configured by clicking the Alarms button on the Edit Webcam dialog, or by 
selecting Edit Alarms for Current Camera from the Edit menu. 
 
 

 
 

The top panel, Global or Individual Alarm Settings selects whether you use 
the default settings for this camera, or use individual settings. 
 
You can Copy the current global settings by clicking the button in this panel. 
 
The Alarm Filter panel enables single event filtering. If enabled, more than one 
motion event is required to trigger an alarm.  The time box lets you specify how 
far motion events must be apart to be considered single events. 
 
The Local Alarm panel lets you configure alarms that produce actions on the 
PC that Webcam Watcher Professional is running on: 

• Log to Alarm Log 
• Play a sound 
• Select the camera 

 
You can view the Alarm Log using Show Alarm Log on the Alarms menu. 
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The Remote Alarm panel lets you configure alarms that can send messages, 
etc: 

• Email Alarm Notification to a specified e-mail address 
• Attach the last image to the e-mail message 
• Send GET request to a particular web address.  The URL specified can 

have expandable parameters: %CAMNAME% for the camera name. 
%CAMNUM% for the camera number. 

• Run an external program, passing the camera name and camera 
number as parameters. 

 
For Email Alarms to work you must set up an SMTP mail server on the main 
Preferences dialog. 
 
There is a Maximum Rate that can be set for remote alarms, to prevent too 
many being generated. 
 
Note that Alarms are only generated when the Alarms button on the main 
Toolbar is down. 
 
Alarms can be set according to an Alarm Schedule. This operates similarly to 
regular schedules. Edit this using Edit Alarm Schedule on the Alarms menu. 
 

 
 
This defines a schedule of when the Alarms (local and/or remote) should be 
Enabled or Disabled. 
 
Like regular schedules, the Alarm Schedule only operates when the 
Timer button on the main toolbar is down. 
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Schedules 
 
Webcam Watcher Professional includes a scheduling facility. 
 
This lets you set schedules for each camera, and for alarms. Think of this as 
similar to setting programs on a video recorder. 
 
To actually Run the schedules, the Timer button on the main toolbar must be 
Down. This is analogous to pressing the Timer button on a video recorder. 
 
Some things to note about the Timer button on the main toolbar: 

• If you quit Webcam Watcher Professional with the Timer button down, 
it will be down when the program next starts. 

• You can force the Timer and/or Alarm buttons to be down on program 
start-up by selecting this on the main Preferences dialog. 

• You can force the Timer and/or Alarm buttons to be down on program 
start-up by passing the parameters –TIMER and/or –ALARMS when 
running the program. 

• Pressing the Timer button Down will start scheduling; this may cause 
cameras to start or stop. 

• Pressing the Timer button Up will stop scheduling, but will not cause 
cameras to start or stop. They simply carry on as they were. 

 
You can Create and Edit schedules using the Schedule Editor. Select Edit 
Schedules from the Edit menu. 
 

 
 
You can assign each camera a schedule on the Edit Camera dialog. 
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Printing 
 
Webcam Watcher Professional includes a printing utility. 
 
You can print up to 6 rows and 6 columns of pictures per page, allowing a 
maximum of 36 pictures per page. You select the page layout using the Page 
Setup dialog on the Print menu. 
 
 

 
 

When printing, the page is filled left to right, top to bottom. When a page is full it 
is printed. You can see the current status of a page by using the Print Status 
dialog on the Print menu 
 

 
 

You can print pictures either from the current camera by using Print Current 
Image from the Print menu, or you can print frames from within the MJPEG 
player. 
 
The Print menu also has options to print or cancel an incomplete page.  
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Proxy Setup 
 
Webcam Watcher Professional can communicate using a proxy server. To set 
this up use Proxy Setup on the File menu. 
 

 
 
Note that currently Intellinet cameras do not work via a Proxy. 
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Preferences 
 
Set global preferences and options using the Preferences dialog on the File 
menu. 
 

 
 

• Show Icon in System Tray: the program minimizes to a small icon in 
the system tray. 

• Outgoing Email Server: You need to specify an email (SMTP) server to 
use if you want to send e-mail alarms. 

• Email From Address: used to identify outgoing email alarm messages. 
• Global CPU Throttle: Number of milliseconds paused between each 

frame received. 
• Force Alarms, Timer On: If checked forces these buttons to be down 

on program startup. 
• AVI frame rate: When converting MJPEG to AVI this specifies the frame 

rate. 
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Security 
 
Webcam Watcher Professional can be set up to require Admin and/or User 
passwords. 
 
If an Admin password is set, the following functions require the Admin password 
to be entered: 
 

• Editing Cameras or Motion Detection Masks 
• Editing Schedules 
• Editing Alarm Schedules 
• Changing Preferences 
• Changing Proxy Setup 

 
If a User password is set then either this or the Admin password must be 
entered to run the program. 
 
Set and configure the Security settings on the Program Security tab on the 
global Preferences dialog. 
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Importing and Exporting Cameras 
 
You can save your current camera definitions (i.e., the current cameras that you 
have configured) by using Tools > Export Camera Definitions. This creates a 
coded file with the default name webcams.def  
 
You can also load cameras from a def file, using Tools > Import Camera 
Definitions. In this case any cameras in the def file that you open are added to 
the current set of cameras. 
 
 

Help and Support 
 
Webcam Watcher Professional can send an email message directly to the 
support center. Use Send Us a Comment on the Help menu. 
 
You can send technical support or other questions and we will get back to you 
as soon as possible. 
 

 
 
You can also use this dialog to join our mailing list. This list is never shared with 
anyone. It is only used to give news about Webcam Watcher Professional. 
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