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Chapter 1

Introduction

This document introduces ViTE, a software for visualising traces with a graphic
interface. It can print the format of Pajé traces and can export a trace in a svg file.

ViTE was done for a project by students in a French engineering school, for
INRIA searchers because the current software Pajé was not maintained and had
some features not implemented yet.

The figures 1.1a and 1.1b are examples of a trace you can watch with ViTE.
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(a) Example of a trace on linux (ubuntu 8.04)

(b) Example of a trace on windows Vista

Figure 1.1: Example of traces
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Chapter 2

How to use

2.1 Compilation/Installation

ViTE uses the Qt library for its graphic window and OpenGL library for the trace
graphic render. You need to get the last version of these library files on your system
to run properly the software.

ViTE can be downloaded from its website : http://vite.gforge.inria.fr/.
Click on the download button and depending of your Operating System, the best
choice will be proposed. You can also go into the download section where you will
find the different packages (for Linux, Windows...) and its sources. If you want to
compile the source code, please read the following instructions to compilate source
code depending on your operating system.

2.1.1 Linux

In order to install ViTE, you need to have the following libraries on your computer :

• libqt4-dev.

• libqt4-opengl-dev.

• libglut3-dev.

For Debian system only, use :

sudo apt-get install libqt4-dev libqt4-opengl-dev libglut3-dev

Then, you go on the source directory and you hit ./configure and then make
on the console.

The configure script is useful because on some implementation, in order to com-
pilate Qt sources, you have qmake or qmake-qt4.

For example, if the directory of ViTE is in your home, hit :

cd vite/source && ./configure && make

The binary will be in the bin/ directory under the name of vite.

2.1.2 MacOS

It seems to be the same manipulation as for Linux computers. You will need the
frameworks for openGL, glut and Qt.
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2.1.3 Windows

There is a tar.gz archive in the source directory which contains:

• a file how to install.txt which lead you for the installation. We recommand
you to have a good internet connexion and at least 1.6 Gb because Qt is
greddy :) . The manipulations were done on windows Vista but it should run
on a windows XP.

• the Makefile for compiling.

• three folders include, dll and lib which are useful for installing glut (the
library used to write in the interface).

The tar.gz file can be extracted by 7-zip or winrar for example.

2.2 First use

2.2.1 Launching ViTE

After getting ViTE (by compiling or executables), you can type on your console the
path to vite, which is bin/vite if you have just compiled from the source directory.

When you launch ViTE without any options (these will be described in the
section 3), you will have a window like the one in the figure 2.1 :

Figure 2.1: Launching of Vite

2.2.2 Open a file

You go on the File menu and click on Open. A dialog box will appear and you will
have to choose the file you want to open.

After choosing it, you must click on Open to open the file or Cancel if you do
not want to open the selected file.

If you try to open a file which is not recognised by ViTE, an error message will
be displayed.
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2.2.3 Export a file

Figure 2.2: The export option box

After opening a file, you can export it by choosing Export on the File menu.
Extra informations can be added in the dialog box :

• if export a part of the trace is enable, you can add floating values in
both fields min and max time. By default, min time and max time are ini-
tialized respectively with the minimum and the maximum displayed entity
time.

• if More options is enable, you can add the following floating values

• wide : to widden elements in the output (an element wide is wide-value time
its time-duration).

• grow : to heighten elements in the output (the heighten is the height of a
container in pixel)

If you do not know or do no want to change the values, uncheck them so default
values will be used. The next dialog box will invit you to choose the name of the
destination file and save it.

2.2.4 Close a file

You can close a trace file on choosing Close on the File menu. The window will
be the same as if no file is shown.

2.2.5 Navigation under the trace

You can change the position and the scale by moving the horizontal and vertical
scroll bars.

Also, you can zoom in or out by clicking in the zoom button. You can select an
area with the mouse to zoom in. You can also directly set a zoom level by selecting
a zoom level in the bottom right. It is also possible to select an area to zoom by
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clicking, and keeping the clic while moving, the zoom will be in the rectangle defined
by the beginning and the end of the clic. The use of the right clic undo the previous
zoom.

You can go to the beginning or the end of the trace by clicking on the left and
rigth arrow button and view the whole trace by clicking on the Show all button.

You can see the trace in fullscreen going on the View menu and picking fullscreen.
Moreover, it is possible to hide the links and/or the events using the No arrow

and No Event buttons of the toolbar. An other option is to get informations about
an event, a state, a communication in the trace by clicking over this element on the
screen. If a lot a element are grouped, you may be force to zoom to be able to get
the right information about the elmeent.

2.2.6 Preferences

This menu contains the statistics module. Inside it, you can have important infor-
mations from the trace file. You can choose the containers you want (check the box
beside the node in order to have all the children of it). Then, you can watch the
percentage of each states for these containers by two ways like in figures 2.3 and
2.4.

Moreover, you can export them in a svg file to easily have them for putting in
reports for example.

2.2.7 Other options

You can show or hide the informations window by chosing Show infos window in
the View menu.

You can hide the warning messages shown in the informations window by chosing
No warning in the View menu.
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Figure 2.3: Vertical diagram

Figure 2.4: Horizontal diagram
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Chapter 3

Shortcuts

3.1 Launching by command line

There are useful shortcuts for launching ViTE or functionalities of ViTE. For exam-
ple, the export of a file in a svg format can be done without launching the graphical
interface, in one line.

Shortcut Action Example
-f [file path] Open a file.1 ./vite -f example.trace

-h Display the help ./vite -h
-a [file path] Open the file and display

all of it.
./vite -a example.trace

[file path] -t ([start]):([end]) Open the trace file and
display it in the interval
(in seconds). 2

/vite file -t [0]:[10]

-f [path-source] -e [path-dest] export the trace file in the
svg format.

./vite -f in.trace -e out.svg

-f [source] -e [dest] -t
([start]):([end])

export the trace file in the
svg format in the interval
given.

./vite -f in.trace -e out.svg
-t [1]:

1The -f is facultative : ./vite filename works too.
2There could be no time init or time end : ./vite file -t :[1]
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3.2 In the graphical interface

Here is a list of all the shortcuts implemented in ViTE that you can find in the
menu bar :

Shortcut Action
CTRL+O Open the open file dialog box.

CTRL+W Close the file.
CTRL+E Open the export file dialog box.
CTRL+S Save the current configuration for the file opened.3

CTRL+Q or ALT+F4 Quit ViTE.
CTRL+SHIFT+A Show all the trace.
Mouse wheel or + or - Horizontal zoom in or out.
CTRL + Mouse wheel or + or - Quick horizontal zoom in or out.
ALT + Mouse wheel Quick vertical zoom in or out.
HOME Show the start of the trace.
END Show the end of the trace.
PAGE UP (resp. PAGE DOWN) Move the visualisation to the left (resp. right).
UP, DOWN, RIGHT, LEFT Move the trace.
CTRL + UP, DOWN, RIGHT, LEFT Quickly move the trace.
SELECT AN AREA WITH LEFT
CLIC

Select a square area of the view and display it.

RIGHT CLIC Backup the previous square area selection view.

3Not yet implemented
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Chapter 4
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Chapter 5

Licence of ViTE

ViTE is under the licence CeCILL.

This software is governed by the CeCILL-A license under French law and abiding
by the rules of distribution of free software. You can use, modify and/or redistribute
the software under the terms of the CeCILL-A license as circulated by CEA, CNRS
and INRIA at the following URL: http://www.cecill.info.

As a counterpart to the access to the source code and rights to copy, modify and
redistribute granted by the license, users are provided only with a limited warranty
and the software’s author, the holder of the economic rights, and the successive
licensors have only limited liability.

In this respect, the user’s attention is drawn to the risks associated with loading,
using, modifying and/or developing or reproducing the software by the user in light
of its specific status of free software, that may mean that it is complicated to
manipulate, and that also therefore means that it is reserved for developers and
experienced professionals having in-depth computer knowledge. Users are therefore
encouraged to load and test the software’s suitability as regards their requirements
in conditions enabling the security of their systems and/or data to be ensured and,
more generally, to use and operate it in the same conditions as regards security.

The fact that you are presently reading this means that you have had knowledge
of the CeCILL-A license and that you accept its terms.
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Chapter 6

FAQ

Question : How can I help improving this beautiful software ?

Answer : ViTE is not perfect yet. Some features that could be implemented are
written in the technical manual but it is just a start and a lot of other things

can be done.

Question : I have some problems when I want to see a trace because
the window glitters ?

Answer : If you use Compiz, you have to disable it while using ViTE.

Question : Why do I only have a black screen when I try to open a
trace ?

Answer : Are you sure the trace is right ? Some errors of meaning may have
not been detected in the data structure.

Question : Why does a new window open when I open a trace?

Answer : Make sure you close the current trace before opening the following. Or
it will open it in another window in order to let the user visualize both traces.

Question : Why can’t I open my svg export?

Answer : The export of a trace in svg format can be more than three times bigger
than the trace file. So if the trace you want to export is big the svg reader can

be slow. You can try using another software to open it (inkscape, mozilla, ...) or
convert the svg in a png file (this feature is not include in ViTE) or export only a
part of the trace.

Question : Why does not ViTE run well?

Answer : The export of a trace in svg format can be more than three times bigger
than the trace file. So if the trace you want to export is big the svg reader can

be slow. You can try using another software to open it (inkscape, mozilla, ...) or
convert the svg in a png file (this feature is not include in ViTE) or export only a
part of the trace.
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Question : I am on Windows and I double click on the executable and
an error tell me that a dll is not found?

Answer : If you launch ViTE by the Qt prompt, the path to find dll libraries is
changed and these dll missing are found. A solution is to find (there are on

your computer) the dll missing and to copy them in the bin/ folder of ViTE.

Question : Why does not ViTE run well?

Answer : Check if ViTE is runnable on your computer (cf configuration).
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