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1. The AsTrend Program 
 

The AsTrend program task is to graphically visualize trends in data acquired by the 
ASPAD data archiving program. The program may run in two modes: it may statically 
chart data stored within some archive files, or dynamically display data while they are 
being collected from an object (simulation of a data logger).  
 

Some definitions of asix system variables are necessary if some new trends are to be 
defined or the existing ones – modified. Detailed procedures of defining databases of 
variable definitions may be found in the Architect program user manual. 
 

AsTrend program may chart data from external sources: *.csv files, *.xls files, and/or 
external databases accessible via the OLE DB mechanism (such as MSSQL and/or 
Access). The data structure of external source must allow data readout in ordered way. 

 

1.1. AsTrend Version 5.1 News 
 

 
The new version 5.1 of the AsTrend program has been equipped with new advanced 
functionality that is more intuitive for the user. The new version means new capabilities 
to display data of various types, to chart averaging values over very long time periods  as 
well as to chart values of variables retrieved from some external files. The version 
features also a new user-friendly graphical interface that offers more effective and 
creative ways of defining and analyzing trends. 
 
 
New Trend Wizard  
   
Improved Trend Wizard in the 5.1 version of the AsTrend program leads users through 
successive phases of the procedure to define a trend i.e. to define contents and layout of 
a window which displays set of charts for declared variables. System of context-sensitive 
tips introduced in the new wizard speeds the design process and makes it an easy and 
comfortable experience for the users. The system informs the user on various options 
available at the given stage of the process. The options include currently available chart 
types, axis types, legend fields, sampling periods and many more. 
 
 
Access Control of AsTrend Users 
 
Version 5.1 of the AsTrend program supports access control based on individual 
passwords that must be entered during log-in procedure. Each user may be granted an 
individual set of privileges that specify which charts will be visible and which parameters 
he/she will be able to modify.  
   
Access control functionality in version 5.1 of the AsTrend program may be accomplished 
in two ways:  

• using the AsAudit module that offers extensive set of functions used to manage 
users and their privileges (which requires MS SQL Express database engine 
installed on a single central server to run database of user privileges), or  

• using the simplified internal access control mechanisms available in previous 
versions of the AsTrend program. 
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Aggregator – Built-in Module for Calculating and Archiving Statistical Data  
   
Application of Aggregator – asix built-in module for calculating and archiving statistical 
data - optimizes the procedure of displaying charts that cover long time periods. 
Whenever possible, the aggregated data retrieved from the asix server are charted 
instead of a raw data. Such approach significantly improves speed of charting and 
flexibility of the display. The AsTrend program automatically selects the aggregate period 
according to the charted time period. 
 
 
New Aggregates – New Capabilities to Analyze Statistical Data  
   
To facilitate effective analyses of the trends, users of the AsTrend version 5.1 may access 
various sets of values aggregated for various time periods. Such aggregates may be 
calculated on demand. Each set includes minimum, maximum, value range, start value, 
end value, delta value, total, average value, average0 value and gradient (i.e. value 
range divided by the time period in seconds).  
   
The aggregates may be calculated and displayed for the chosen time period or calculated 
from the data of currently displayed period and shown in legend columns. 
 
 
Two Read Lines 
 
Precise values associated with a charted point (including the time, value and calculated 
value) may be read-out using a manually controlled read line. The read line position may 
be set with use of cursor or a separate dialog window.  
   
Using the second read line introduced in the version 5.1, user may freely define period of 
time taken into account to locally calculate the aggregates shown in the legend fields. If 
the read lines are off, the legend presents the aggregates calculated for the entire 
displayed period. Separate fields in the legend show values associated with the point 
highlighted with the second read line (the time, value, calculated value and length of the 
time period between both read lines).  
   
Such solution facilitates fast and convenient analyses of the trends in freely chosen time 
periods. 
 
 
New Options of ‘Export data’ Command  
   
The new Export data command allows to easily export the charted data to a *.txt file, 
*.csv file, or Clipboard.  
   
Modified export format consists of sequence of measured values and time marker values, 
each separated by a separator character. In case of exporting to the Clipboard, the Tab 
character is the separator. Data are exported in the following order: time value, variable 
value. Each variable column is associated with its own time data column except for 
uniform data when the time data column may be common. Time data are exported in the 
system format (‘2008-02-20 16:48:22’). In case of alarm series and/or some external 
data, the time data column additionally contains millisecond values. The exported data 
may be optionally supplemented with a two-line header, as well as with units of measure 
next to each variable name. 
 
 
 
External Data Sources  
   
Besides data delivered by the asix system, the AsTrend program may chart data from 
external sources: *.csv files, *.xls files, and/or external databases accessible via the OLE 
DB mechanism (such as MSSQL and/or Access). Correct import of such external data is 
facilitated by an easy to use and totally intuitive dialog window, that offers tips on the 
structure of data necessary for proper read from an external source. 
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New Data Types  
   
New version of the AsTrend program may chart more data types, this way broadening the 
range of information that may be analyzed.  
   
Besides process variables, the following elements may now be charted:  
   

• constants (horizontal lines)  

• variable calculated on the basis of other variables  

• information on moments when some alarm status has changed  

• data retrieved from some external sources (*.csv/*.xls files, MS SQL and/or 
Access databases).  

 
 
X-Y Two-Dimensional Charts  
   
Two-dimensional charts available in version 5.1 of the AsTrend facilitate analysis of 
possible inter-variable dependencies.  
   
Such chart is a function of two asix variables drawn at the assumption that both 
variables are evenly spaced in time and are not binary.  
   
Labels of X,Y-chart points may be optionally modified. 
 
 
Additional Time Axis  
   
Various fragments of a chart of one variable (charted for different time periods) or the 
charts of different variables may be now compared on a screen. In the AsTrend program 
this possibility is achieved by an additional time axis that may be turned on for one of the 
to-be-compared charts. 
 
 
Changes in Sampling Methods / Handling Various Data Types  
   
Methods of sampling data for charting purposes are related with specific data types. 
Methods available in the AsTrend version 5.1 include:  
   

• charted data intervals are forced by the archiving program – genuine data;  

• periods between consecutive samples are constant – uniform data;  

• periods between consecutive samples are set by the AsTrend program depending 
on the length of the period in which the data are averaged (averaged data) or 
minima and maxima are calculated (approximated data).  

   
Essential modifications introduced to the supported data types include:  
   

• type of the data is now defined for the entire trend rather than for individual series  

• uniform data, averaged data, and approximated data are now calculated by the 
asix server with use of the Aggregator, therefore the AsTrend program may read 
ready-to-chart aggregated data instead of calculating them from a raw data  

• approximate data are now charted as the HighLow charts (two curves representing 
maxima and minima, the area in-between flooded with the color of the given 
series).  

  
 
Change of Charted Period  
   
The new AsTrend user interface provides for smooth and precise control of the charted 
period. The available period selection methods include:  
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• buttons of the navigational toolbar;  

• period selection window opened from the toolbar;  

• standard (predefined) period selection window with an extended list of predefined 
periods (in this case selected period is relative to current time, i.e. last minute, …, 
last 30 minutes, … last 2 days, …);  

• mouse wheel support: rotating the wheel one can shift the period to the past/to the 
future, rotating the wheel while the Ctrl key is pressed one can change the charted 
period length, rotating the wheel while the Shift key is pressed one can quickly shift 
the period.  

 
 
Setting of Relative Time Period to Be Used at the Moment of Trend File Opening  
   
The OPC format options make possible to precisely define period of time which is to be 
charted when a trend file is opened. Period start and end times may be expressed using 
designations like “now”, “beginning of the current day”, “beginning of the current month”, 
„Today 6 am”. OPC format expressions are automatically built by the OPC format time 
editor. The editor is equipped with a user-friendly interface with a set of fields that 
greatly facilitate the task of defining time periods. 
 
 
New Options of Trend Legend Customization  
   
Extended functionality of trend legend in the new AsTrend program version increases 
effectiveness:  
   

• due to an option to remember current settings each defined legend may now be 
used as a default one for newly defined trends  

• sequence of series in a legend may now be modified using the drag&drop technique  

• set of attributes displayed in a legend has been extended to include aggregates 
calculated for the currently charted period  

• information on attribute type (stored within the trnx file) is now used to 
automatically align values displayed in the legend (texts are left-aligned, numbers 
are right-aligned)  

• set of standard legend columns has been extended to include the Series colour 
column, where a line in color of the given series is displayed (if the column is 
displayed, all legend data are displayed in black, otherwise the data are displayed 
in colors of respective series)  

• since attributes of all variables declared in the legend are now stored within the 
trend file, legend may be correctly displayed without accessing database of 
definitions of variables  

• display format of legend data is retrieved from variable definition database (should 
the displayed range of values change, the format will reflect the new range or else 
may be individually set up by the user).  

 
 
Additional Functions  

   

• Display edge points at the right edge of the chart.  

• Display warning and critical limits (when the limits are declared in VarBase as 
numbers).  

• A new option concerning Many Vertical Axes - Stack charts: Vertical axis position. 
Depending on the Vertical axis position option in the series parameters, vertical 
axis may be placed at the left or at the right side of the chart. If two adjacent 
charts of single variables have their vertical axes placed at the same side of the 
chart, both axes may be put together on one chart to better use screen area (print-
out area) and to improve chart legibility, as well as to facilitate comparing trends.  
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1.2. Hardware Requirements  
 

The AsTrend program may run on any computer running one of the following operating 
systems: Windows XP, Windows 2000, Windows NT 4.0. The sole hardware requirement 
necessary for correct operation of the program is screen resolution – it must not be 
lower than 800x600.  
 

1.3. Starting the Program  
 

The AsTrend program may operate in two modes: in conjunction with an asix system 
application, or alone.  
 
In both modes the to-be-displayed data may be served by the same computer, on which 
the AsTrend program runs, or else by any of the networked computers. 
 
 
Starting the Program with the Asix Application 
 
In the former mode the program is started by the asix system. Set of predefined trends 
and database of variable definitions are made available. The users may browse the pre-
defined trends, perform operations on them, and define his/her own trends in the 
directory defined by the program developer.  
 
The program may be started while the application is loaded.  Detailed information on 
configuration of starting parameters you find in Architect manual, chapter: 3.4.2. 
Declaration of programs started together with the application. 
 
 
Starting the Program without the Asix Application 
 
In the latter mode the program is started by the user. He/she decides which trends are to 
be displayed and usually also he/she defines them on his/her own.  
 

 It is possible to run more instances of AsTrend program. 
 
Use the following command to start the program alone:  
 
Astrend.exe [trend_definition] [-iset_definition] [-iMDBdatabase_filename] [-

iMSSQL_database_servername / MSSQL_databasename] [-dindexfile] [-b] 
where: 
trend_definition - optional pathname to a file (*.TRN or *.TRNX extension) that 
contains trend definition to be displayed once the program starts 
 
-iset_definition - optional pathname to a set of variables file (*.ZEZ extension) 

that is to be open once the program starts  
-iMDBdatabase_filename - optional pathname to a file with database of variable 

definitions (in the Jet format) 
-iMSSQL_database_servername / MSSQL_databasename 
 - optional pathname to a file with database of variable definitions 

in the MSSQL format 
-dindexfile - optional pathname to an index file, from which trend definition 

filenames are to be read in. The *.trn files are read into the Czytaj 
trend window. If no specific *.trn filename was specified within 
the program starting command, the window with contents of the 
index specified by this parameter will opens as soon as the 
program starts. 

-b  - optional parameter used to exclude the possibility to modify 
trend definitions 
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 The trend_definition filename may be appended by a list of names of variables that 
are to be displayed. Names on the list must be separated by the ‘ # ’  or ‘ < ’ character. 
 

 
There is no need to open any database of variable definitions in order to browse stored 
trends. 
 
 

1.3.1. Shortcut Creation 

 
 
Shortcut creator is run from File menu > Create Shortcut command. 
 
 

 

 

1.4. Operation of the Program in Conjunction with the asix 
System 

 
 
 
Two following AsTrend program operational modes may be distinguished: 

• the operator / administrator mode;  
• the user mode serviced by AsAudit module that offers extensive set of functions used 

to manage users and their privileges.  
 
User Mode 
 
In user mode all privileges of users are defined in AsAudit. The list of functions controlled 
by AsAudit is as follows - each logged-in user may (depending on his/her privileges):  

• change the AsTrend program settings;  
• create new files; 
• modify existing files;  
• modify existing read-only files;  
• operate the program in a custom-tailored layout of menus and toolbars;  
• modify the common set of menus and toolbars;  
• manage the display optimization mechanism. 
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Operator Mode  
 
Access control mechanism accomplished without the AsAudit module enables each user to 
log-in as an Administrator or as an Operator only. 
 
Each time the program is started from an application of the asix system, it is set into the 
operator mode.  
 
Operators can not: 

• create and modify .TRNX files with the „read-only" attribute  (see: 4.17.  Saving 
Trend Definition) 

• print out charts on printers other than the system printer (see: 4.15.2. Printing). 
 
 
 
Administrator Mode  
 

Use the  toolbar icon or File > Administrator mode menu command to switch into the 
administrator mode. The correct password must be supplied except the first time the 
AsTrend program is run on the computer – it is enough then to press the Enter key. 
When in the administrator mode, the password may be changed using the File > Change 
password… menu command (see: 4.18.1. Administrator Login).  
 
Administrators can: 

• open all index files on computer disks 
• write trend files with the „read-only" attribute set – such files may not be modified 

by operators 

• disable/enable window re-size function (  button and the Trend > Change Size 
Block menu command)  

• modify layout of menus/toolbars 
• export graphs/legends to . PDF or .BMP files. 

 
 

 After 15 minutes the administrator mode will be automatically terminated and the 
program will return to the operator mode. 
 

 If a trend definition is stored in the administrator mode with the window re-size 
function enabled, the function will remain enabled after the definition is opened as a 
template in the operator mode. Operator may read trend definition templates, modify 
them, store under other names, or create new trend definitions. 

 

1.5. Location of Configuration Options 
 

 
 
One of the AsTrend5 program features is capability to define separate menu/toolbar 
layouts for Operators and for Administrators. These definitions are stored in an internal 
program file residing in the application directory.  
 
The layouts (for Administrators and for Operators) are definable only by an Administrator. 
 
If the AsTrend program is run alone, a separate menu/toolbar layout may be defined for 
each user of the operating system. Configuration files are then stored in respective 
Documents and Settings subfolders of the Windows folder.  
 
All remaining configuration options regarding trend display are stored in a single file 
residing in the application folder or in the Documents and Settings folder. 
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2. Trend Wizard 
 

  
Improved Trend Wizard in the 5.1 version of the AsTrend program leads users through 
successive phases of the procedure to define a trend i.e. to define contents and layout 
of a window which displays set of charts for declared variables. System of context-
sensitive tips introduced in the new wizard speeds the design process and makes it an 
easy and comfortable experience for the users. The system informs the user on various 
options available at the given stage of the process. The options include currently 
available chart types, axis types, legend fields, sampling periods and many more. 
 

Trend wizard can be run by New-Wizard... command from File menu or by the  
button available on toolbar. Obligatory steps must be performed to go to next step. 
 
 
Step 1 – Introduction 
 
First window explains the definition of a ‘trend’.  
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Step 2 – Select Variable Definitions Database 
 

It is obligatory to select VarBase. You may push the  button placed on wizard 
window or select the Open Variable Definitions Base… command from File menu. 
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Step 3 – Add Variable to Trend 
 
Variable selection is necessary to perform other steps. 
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Step 4 – Select Time Period 
 
Variable selection is necessary to perform other steps. You may select visible time 
period on chart horizontal axis. If you don’t select any period, the last hour will be set 
by default. 
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Step 5 – Select Chart Type and Axes Type 
 
Chart type and Axes type are optional settings. By default, it is taken linear chart with 
physical axis.  
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Step 6 – Set Data Type 
 
Methods of sampling data for charting purposes are related with specific data types: 
genuine, uniform, averaged and approximated data. By default, it is taken first type 
(setting data type isn’t necessary at that step). 
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Step 7 – Set Read Line 
 
Precise values associated with a charted point (including the time, value and calculated 
value) may be read-out using a manually controlled read line (or 2 read lines).  
 

The read line /2 read lines are displayed with use of the buttons:  , . 
 
The read line position may be set with use of cursor or a separate dialog window 

activated by the  button.   
 
It is an optional step. 
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Step 8 – Execute Operations Determining the Way of Trend Displaying 
 
After displaying trend you can execute some operations, like: zoom, panning, starting 
registering.  
 
It is an optional step. 
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Step 9 – Customize Legend 
 
You can choose columns you want to display in legend. 
 
It is an optional step. 
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Step 10 – Define Trend Title and Time Period 
 
Before saving trend you can specify some additional parameters like: title, header and 
footer. You can also specify time period used when trend is opened. 
 
It is an optional step. 
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Step 11 – Save Trend in File 
 
It is an optional step. You can save created trend later. 
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Step 12 – The End of Trend Creation 
 
At this step you can erase the current and open the other trend. 
 
Choose End to back to main AsTrend window. 
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3. The Trend window  
 

 
Main program window that appears as soon as the program has started include the following 
elements: 
 
Main menu bar - collection of submenus with commands 
Toolbars - collections of buttons equivalent to majority of the main menu 

commands  
Chart area  - curves, coordinates 
Legend area - charted data descriptions 
Status bar  - status of the displayed trends. 

 

 
 
 

Chart area and legend area remain empty if the program has been called without any 
parameter. Just after starting the program most of its functions remains inactive. Use the 
trend wizard to easily complete the entire procedure of defining a trend. The wizard is 
recommended particularly for novice users. 
 

3.1. Main Menu Bar 
 

Collection of commands grouped in several submenus of the main menu bar at the top of 
the program window allow to perform variety operations on trends. 
 
 
 

Main menu bar 

Toolbars Chart area 

Legend area 

Status bar 
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3.1.1. The File Menu  

 
 

  
 
 
Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 New – open a new trend window 

 New – Wizard... – run trend wizard  

 Reopen Trend – cancel modifications, restore the original trend 

 Open… – open trend file (*.trn, *.trnx) 

 Open Variable Definitions Base…  – display variable database selection window  

 Save – store the displayed trend 

 Save as… – store the displayed trend in another file 

 Create Shortcut… - create shortcut that runs the AsTrend program 

 Data Table… - display data table 

 Export data… - export the charted data to a *.txt file, *.csv file, or Clipboard 

 Export to PDF…– export chart / legend area to a PDF file 

 Export to BMP – export chart / legend area to a BMP file 
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 Program Options… – display program options 

 Print Preview – display trend print-out preview 

 Print… – print the displayed trend  

 Clear Printer Queue – purge printing queue 

 Administrator Mode – log-in as Administrator (the command active only if the program 
has been run in conjunction with an asix application) 

 Change Password – change the administrator password  

 Program Options… - open ‘Program Options’ window 

 Hide Main Window – minimize the program window to a icon in the Taskbar notification 
area 

 Exit – shut down the program.  
 
 

 

3.1.2. The Trend Menu  

 
 

  
 
 
Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 Start of Registration – start the data logging mode 
 Stop of Registration – stop the data logging mode 

     Genuine Data - charted data intervals are forced by the archiving program 

 Uniform Data – periods between consecutive samples are constant 

     Approximated Data - periods between consecutive samples are set by the AsTrend 
program depending on the length of the period in which minima and maxima are calculated 

    Averaged Data - periods between consecutive samples are set by the AsTrend 
program depending on the length of the period in which the data are averaged 
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Update Attributes – update range values retrieved from database of variable definitions (in 
case they have been modified in the database) 
 
 Update Attributes and Save - update range values retrieved from database of variable 
definitions (in case they have been modified in the database) and store the changes 
 

 Change Size Block – disable the capability to change trend window size and layout 

 Trend Options... – display trend options 
 

 

3.1.3. The Period Menu 

 
 

  
 
 
Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 Set Period… – open period start/end date selection window  

  Increase / Decrease Period – increase / decrease period to the span determined 
by the consecutive default periods defined in AsTrend  

   Backward/Forward By Period – move horizontally (pan) by one current period 

  Backward/Forward – move horizontally (pan) by quarter of the current period 

 Move Forward To The End – set end of the trend period for the current time 

 Copy Period to Clipboard – copy the period to the period Clipboard 

 Periods Clipboard… – display Period Clipboard contents 

      Block Changing Period With Mouse – disable the capability to zoom-in horizontally 
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3.1.4. The Chart Menu  

 
 

  
 
 
Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 Set Period… – open period start/end date selection window  

  Increase / Decrease Period – increase / decrease period to the span determined 
by the consecutive default periods defined in AsTrend  

   Backward/Forward By Period – move horizontally (pan) by one current period 

  Backward/Forward – move horizontally (pan) by quarter of the current period 

 Move Forward To The End – set end of the trend period for the current time 

 Copy Period to Clipboard – copy the period to the period Clipboard 

 Periods Clipboard… – display Period Clipboard contents 

      Block Changing Period With Mouse – disable the capability to zoom-in horizontally 
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3.1.5. The Series Menu  

 
 

  
 

 
Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 Add … – open variable selection window 

 Add Calculated Variable... – open the window that allows adding variable calculated on 
the basis of other variables with use of given expression 

 Add Alarm... – open alarm selection window 

 Add Constant... –  open the window that allows adding a constant 

 Add variables from external data source... –  open the window the variables from 
external source are loaded by 

 Exchange Variable... -  change name of the selected variable 

 Remove – clear the currently selected variable 

 Move up – move the selection of variable series up 1 row 

 Move down – move the selection of variable series down 1 row 

 Hide – show/hide the selected curve 
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  Linear/Bars – select chart type (lines, bars) 

 Points – display points for the selected curves 

 Labels – display labels for the selected curves 

 Stairs Interpolation – interpolate the selected curves 

 Variable Attributes… – display the variable metrics window 

 Data Server... – open the window with the information on network server name, 
archive name and archive type, the data series of variable are retrieved from 

 Range – set vertical range for the selected variable 

 Options… – open series option selection window. 

 

3.1.6. The View Menu  

 

  
 

 
Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 Toolbars – show/hide toolbars 

 Scale and Grid – display axis scales and chart grid 

 Legend – show/hide the legend 

 Styles – select a style for the program window 
 Restore the Last Layout of the Toolbars – restore toolbars as they were before running the 
program  
 Reset the Layout of the Buttons – restore the default layout of buttons 
 Reset the Layout of the Buttons and the Toolbars – restore the default layout of buttons 
and toolbars 
 Load Buttons and Toolbars Layout of the Operator – change to the Operator mode window 
layout. 
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3.1.7. The Help Menu  

 

  
 

Menu includes the following commands (respective toolbar icon – if any – is also shown): 

 Topics – open the program help file 

 About – display “About the program” information screen.  
 

 

3.2. Toolbars 
 

Program toolbars (layout, position, contents) are fully configurable separately for Operators 
and separately for Administrators. Modifications may be introduced only by Administrators. 
 
The main menu has constant position but it is possible to modify its content. 
 
Default layout of the toolbars: 

 

 
 
 

3.2.1. Main Menu Layout and Content Modification 

 
To change the main menu layout, select the arrow on the menu right end, click Add or 
Remove Buttons > Customize – the following window should be displayed: 
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When the above window is opened, you can modify the main menu layout by dragging and 
dropping the menu item – just like on the scheme beneath: 
 

 
 
 
To hide/show the item on main menu, select the arrow on the menu right end: 
 

- click Add or Remove Buttons > Customize. In displayed ‘Customize’ window select 
Commands tab > Main Menu item; you can hide the item by dragging it beyond the 
menu area; if you want to add new item to menu, drag the item from Command list on 
Commands tab to the menu area. 
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- or click Add or Remove Buttons and clear/set (respectively) the toolbar check box on 
the displayed list of all menu items. 
 

 
 
 
To add/remove the command on the displayed list of menu item, select the arrow on the 
menu right end, than click Add or Remove Buttons > Customize. In displayed ‘Customize’ 
window select Commands tab. You can add a command by dragging and dropping it from 
the Commands tab. You can remove a command by dragging it beyond the menu item list.  
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3.2.2. Toolbar Layout Modifications 

 
To move a toolbar onscreen position, drag it by its left edge and drop in the target position.  
 
To hide/show a toolbar, right-click any visible toolbar, and clear/set (respectively) the 
toolbar check box on the displayed list of all toolbars: 
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3.2.3. Toolbar Content Modifications 
 
 
To add a button to/remove a button from a toolbar, click the arrow on the toolbar right end, 
click the Add or Remove Buttons option to drop down list of all buttons possible in the 
toolbar, then set/clear (respectively) the button check box on the list: 

 

 

 
 
Click the Customize… option to display the Customize window, in which toolbars may be 
fully configured.  
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3.2.4. Local Menu for Main Menu/Toolbar Commands - Edition of Command 
Description 

 
When the ‘Customize’ window is opened (select the arrow on the main menu right end, than 
click Add or Remove Buttons > Customize), it is possible to call local menu for any 
command executed from menus or toolbar by mouse right-click. It allows changing 
command description (displayed on menus or toolbar). 

 

 



asix5 AsTrend documentation
 

 

36 ©ASKOM, Gliwice 

 

3.2.5. Button/Toolbar Layout Management 

 

 
Current menu/toolbar layout is stored separately for Operators and separately for 
Administrators in internal AsTrend program files residing in the program directory. The 
layouts are stored when the program is being shut down. 
 
Set the View > Load Buttons and Toolbars Layout of the Operator option to switch to 
operator layout. From that moment on, every modification will be stored in the operator 
layout. Clear the option to immediately store the current operator layout and return to the 
administrator layout. 
 
Widok menu commands related to toolbar layout management include: 
Reset the Last Layout of the Toolbars – restore toolbars as they were before running the 
program  
Reset the Layout of the Buttons – restore the default button layout 
Reset the Layout of the Buttons and the Toolbars – restore the default layout of buttons and 
toolbars 

 

3.3. Chart Area  
 

Chart area is located directly below the toolbars. 
 

 
 
Operations that may be performed directly within the chart area include: 

• point with the mouse to a chart point to display the point data (time, value) in the 
status bar 

• drag-and-drop marker within the chart area (use the  toolbar button to display the 
marker) 

• drag a selected region boundary to grow the region  
• double click a point within the chart area to select all variables 
• click a variable chart to select the variable 
• click an axis to modify parameters of the axis 
• display 0-100% axis at the right area edge for the selected curve (click a curve to 

select it) 
• right click a point within chart area or a point of a curve to display context menu: 
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The context menu includes options to add/remove a variable curve, copy displayed charts to 
the chart clipboard, copy chart area to the chart clipboard as a bitmap, change chart/axis 
description background color. 
 
The Show all command causes curves to not be limited at the chart horizontal axis or at 
the chart area top edge. This function is useful when a curve coincides with the axis/edge. 

 

3.4. Legend   
 

Chart legend is located beneath the chart area. Use the  button to turn the legend off 
(provided that the chart re-sizing function is enabled). The Name, Description, Unit legend 
columns may be user-edited. 
 

 
 

Legend may include: 
 

• Name – variable name  
• Measurement range – set by operator or loaded from variable definition database 
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• Series color – when the field is displayed, all information on data series are displayed 
in black – only Series color field displays the given series color  

• Sampling – information on period and method of sampling 
• Precision - data acquisition accuracy 
• Time of Read Line 1 - time of a variable in the point highlighted by the marker (Read 

Line) 
• Indicated Value of Read Line 1 - value of a variable in the point highlighted by the 

marker (the last valid measurement preceding the point) 
• Computed Value of Read Line 1 - value of variable interpolated for a time indicated 

with the marker between two measured points 
• Indicated Value of Read Line 2 - value of a variable in the point highlighted by the 

marker (the last valid measurement preceding the point indicated by Read Line 2) 
• Computed Value of Read Line 2 - value of variable interpolated for a time indicated 

with the Read Line 2 between two measured points 
• Read Lines Distance – distance between two read lines (if Read Line 2 is set) 

 
Legend includes also fields displaying aggregates (see: 3.4.1. Displaying Aggregates). 
 
When loading variable definition database, it is possible to display in Legend other attributes 
of variables (i.e.: Description, Unit,...). 

 

 

3.4.1. Displaying Aggregates 

 
 
The aggregate values are locally calculated by the AsTrend program for data displayed on 
screen within declared time period (regardless of type of the charted data: raw data, 
uniform data, approximated data, averaged data). The results may be browsed in columns 
of the legend. Such aggregates may be calculated:  

o minimum,  
o maximum,  
o value range,  
o start value,  
o end value,  
o delta value,  
o total,  
o average value,  
o average0 value  
o and gradient (i.e. value range divided by the time period in seconds). 

 
Using the second read line introduced in the version 5.1, user may freely define period of 
time taken into account to locally calculate the aggregates shown in the legend fields. 

 

 

3.4.2. Operations Available Directly Within the Legend Area 

 

 
Operations available directly within the legend area include: 

• click the Name field to display the Variable name window and select a variable using 

the  button: 
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• mouse point a field to display the entire field contents (displayed until mouse pointer 
is moved away): 

 

 
 

• click the Value Range field to display the variable range selection window: 
 

 
 

• right click a point within the legend area to display context menu: 
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Context menu commands options include: 
 
Add… display the Select item window to select a to-be-charted variable 
Remove select a variable that is to be removed from the chart 
Hide     show/hide the selected curve 
Move up     move the selection of variable series up 1 row 
Move down    move the selection of variable series down 1 row 
Variable Attributes… display the variable metrics window 
Exchange Variable… change name of the selected variable 
Range display the Variable range window to select a range for the selected 

variable  
Points     display points for the selected curves 
Labels     display labels for the selected curves 
Options… display the Options window to define preferences (legend font, 

chart/legend color, value format) 
Background color display the ‘Trend Options’ window with the possibility of background 

color change 
 
 

3.5. Status Bar 
 
 
Status bar located beneath legend is always visible: 
 

  
 
Fields of the bar include: 
Name - name of the highlighted variable displayed in the variable-specific 

color (provided a variable has been highlighted) 
Value -variable value in the highlighted point (provided a point has been 

highlighted on a curve), or the “|” character (if the marker is active) 
Time - time of the highlighted point (provided a point has been highlighted 

on a curve), or time of the point selected with the marker (if the 
marker is active) 

Points - number of the currently displayed measurement points 
empty field to the right of the bar 
  context-related (regarding the element pointed with the mouse) 

contents; in particular the entire name/description of the pointed 
variable.  
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4. Using the Program  
 
 
As soon as the AsTrend program is installed and database of variable definitions is set-up, 
the program may be used very easily. Typical activities include: 

• display the defined trends  
• perform some operations on the trends 
• print the displayed charts 
• define new trends. 

 

4.1. Help System  
 
 
Use the menu Help > Topics menu command to enter the Help system. 
 

4.2. Selecting Variable Definition Database 
 

 
To select VarDef (Variable Definition Database), click the button on toolbar or the Open 
Variable Definitions Base command from File menu. It opens the following window for 
database selection:  
 

 
 
Database is identified by XML file, Server and Database name (for an SQL database), MDB 
file name or ZEZ file name (for a database in old Paradox format). 
 
VarDef may be loaded automatically during AsTrend running (see: 1.3. Starting the 
Program). 
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4.3. Data Series Types / Adding Variables 
 

4.3.1. Data Series Type 
 
New version of the AsTrend program may chart more data types, this way broadening the 
range of information that may be analyzed.  
   
Besides process variables, the following elements may now be charted:  
   

• constants (horizontal lines)  
• variable calculated on the basis of other variables  
• information on moments when some alarm status has changed  
• data retrieved from some external sources (*.csv/*.xls files, MS SQL and/or 

Access databases).  
 
 

4.3.2. Adding Variables from VarDef 
  
 
Name of the to-be-added variable may be selected in the variable selection window. To open 
the window you may: 

• press the  toolbar button;  
• select the Series >Add… menu command; 
• right click chart area to display context menu and select the Add… option. 

 
Neither of the above listed capabilities is available unless a database of variable definitions 
is open.  

 

For asix5 databases (MSSQL or Jet format), the  button displays the ‘Select item’  
window: 
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To select some variables in the ‘Select item’ window, first expand the group that contains 
that variables on tree in the left segment of the window. List of all variables belonging to 
that group appears in the right window segment. To select some of them, highlight them on 
the list (hold down Ctrl key and click each of the to-be-selected variable), then click the OK 
button. Alternatively you may subsequently double click each of the to-be-selected variables 
on the list. 
 
If there are plenty of variables in a group, search and/or filter functions may be particularly 
handy. 
 
Each of the variable description column may be separately shown/hidden. To this end click 

the  button located to the left of the column headers, set/clear respective checkboxes on 
the displayed list of columns, then click some point outside the list. 

 
 

4.3.2.1. How to Find a Variable 
 
 
To find a variable: 

• on the tree expand the group that contains the variable 
• click header of a column to sort records according to that column 
• click any field in the selected column 
• start to enter the variable name from the keyboard; after each entry the list of 

variables is scrolled to the first record matching the so-far entered characters. 
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4.3.2.2. Variable Filters 

 
Use the Filtering and grouping button to turn on the record filtering/grouping function. The 
function must be turned on to be able to perform the below described operations.  
 
To group variables according to values of an attribute, drag header column of that attribute 
to the grey bar located above the header bar (indicated with two green arrows in the figure 
below):  
  
 

 
 
 
To simply filter records by some value in a column, press the  button next to the column 
header and select the desired value from the dropped down list of all values.  
  
 

 
 
 
Use the button  located at the left bottom side of the value table to run filter wizard that 
facilitates defining more complicated filters. 
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4.3.2.3. Add Variables on the Basis of ZEZ File 

 
 
If the old database format is used (Paradox .ZEZ files), the Variables List window appears 
instead of the variable selection window: 
 

 
 
To select some variables in the ‘Variables List’ window, expand variable group that 
contains that variables on tree in the left segment of the window. List of all variables 
belonging to that group appears in the right window segment. To select some of them, 
highlight them on the list (hold down Ctrl key and click each of the to-be-selected 
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variable), then click the OK button. Alternatively you may subsequently double click each 
of the to-be-selected variable on the list. 
 
 

4.3.3. Adding a Calculated Variable 

 
 
Variables calculated on the basis of other variables can be added with use of ‘Add 

Calculated Variable’ window activated by the  Add Calculated Variable command from 
Series menu. 
 
The window includes tabs that allow to set variable attributes, calculate expression, set 
display and measurement range and set period of time from which data are displayed. 
 
 

• Attributes tab: 
 
- Name, 
- Description, 
- Unit, 
- Sampling interval, 
- Treat the result as a Boolean variable option. 
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• Calculated expression tab: 

 
- Expression – there is the field where you should enter expression for calculating 

the variable; you can use built-in library of allowed functions, operators and 
constants – the library window is displayed by Insert button; 

- Expression test – using this option you can check the expression syntax; 
- Variables – there is the list of symbols you should joined with variables; these 

symbols are used in the expression syntax. 
 
 

 
 

 
 
 

• Ranges tab: 
 

- Display range – display range is used for scaling physical axis of all series and 
axes of individual series on multiaxis chart; for scaling physical axis display range 
of ALL series are taken into account; 

- Measurement range – measurement range is used for checking correctness of 
series samples values; values of samples which exceed series range by number 
equal width of range are cut off; measurement range can be used also for scaling 
physical axis of all series and axes of individual series on multiaxis chart. 
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4.3.4. Adding an Alarm 

 
 
Alarms may be added to the chart with use of ‘Add alarm’ window called by the Add 
Alarm… command in Series menu. 
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To add new alarm to the chart, you have to enter: Alarm number, Network name of the 
alarms set. Alarm description is loaded from VarBase by Read description from server 
button. 
 
 

4.3.5. Adding a Constant 

 
It is possible to put into the chart constant value displayed as horizontal line. The constant 
is added by the ‘Add Constant’ window opened by Add Constant… command. The window 
includes tabs that allow to set variable attributes, value (expression) and ranges. 
 

• Attributes tab: 
 
- Name, 
- Description, 
- Unit. 

 

 
 
 

• Value tab: 
 

- Expression - there is the field where you may enter expression for calculating the 
variable; you can use built-in library of allowed functions, operators and constants 
– the library window is displayed by Insert button, 

- Expression test - using this option you can check the expression syntax. 
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• Ranges tab: 
 

- Display range – display range is used for scaling physical axis of all series and 
axes of individual series on multiaxis chart; for scaling physical axis display range 
of ALL series are taken into account; 

- Measurement range – measurement range is used for checking correctness of 
series samples values; values of samples which exceed series range by number 
equal width of range are cut off; measurement range can be used also for scaling 
physical axis of all series and axes of individual series on multiaxis chart. 
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4.3.6. Adding Variables form External Data Source 

 
 

In AsTrend, there is the possibility to display charts of variables the values of which 
are retrieved from external data source (CSV, XLS files, as well as resources 
accessible by OLE DB: MSSQL, Access databases), on condition the database 
structure allows readout of all data in systematic manner.  
 
You can add variables form external source with use of the Add variables from 
external data source… command from Series menu. 
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4.4. Setting a Period  
  
 

 
Setting a Period Using Trend Moving Buttons  
 
Trend moving buttons: 

  Backward/Forward By Period – move horizontally (pan) by one current period, 

  Backward/Forward – move horizontally (pan) by quarter of the current period, 
and 

 Start of Registration – start the data logging mode, 
 
automatically change trend period. 
 
 
Setting a Period Using Period Editor 
 
You can set a period with use of period editor activated by the Set Period… command from 
Period menu or from toolbar. 
 
 



AsTrend documentation asix5 

 

©ASKOM, Gliwice 53 

 

 
 
 
Setting a period demands determining: data period length and base date. 
 
The ‘Period’ window supply the user with pre-defined period lengths: 
 
1 minute, 
2 minutes, 
5 inutes, 
10 minutes, 
15 minutes, 
30 minutes, 
1 hour, 
2 hours, 
4 hours, 
8 hours, 
12 hours, 
1 day, 
2 days, 
4 days, 
7 days, 
14 days, 
1 month, 
2 months, 
3 months, 
6 months, 
1 year. 
 
 
Setup using the Period Clipboard 
 
 
Trend period may also be retrieved from any trend stored in the Period Clipboard. See the 
4.21.2. Periods Clipboard section for description of the Periods Clipboard. 
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Setup by Trend Definition 
 
Each time a trend definition is loaded, trend period is changed to the one stored within the 
definition in accordance with the following option: 
 
AsTrend > Trend menu > Trend Options > Opening tab > Period after opening trend file 
option 
 
 
Possible settings of automated period loading: 
 

- Like during write, 
- Period end equals now, 
- Current day, time without change, 
- Last used, 
- Set in OPC format, 
- Ask me. 
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Setting a Period Using Toolbar at the Period-Sampling Automatic Adjustment 
Turned On 
 
If the Period-Sampling automatic adjustment is turned on (File > Program Options > 
Program Parameters > Automat), every change of trend period is going to modify 
sampling frequency. 
 
 
Setting a Period with Use of Mouse Button 
 
Movement of mouse roller causes moving the period forward/backward. 
Movement of mouse roller with pressed Ctrl key causes changing the period span. 
Movement of mouse roller with pressed Shift key causes fast movement of the period. 
 

4.5. Trend Axis Types 
 

The AsTrend5 program may chart variables using the following axis types: 
• a single physical axis 
• a single percent axis 
• many axes 
• many axes - stack 
• XY axes. 

 
Each type is presented in following chapters. 
 
 

4.5.1. Vertical Axis - Physical 

 
 
The axis type is turned on with use of the Vertical Axis – physical command from Chart 
menu or from toolbar. 
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4.5.2. Vertical Axis - 0-100% 

 

The axis type is turned on with use of the  Vertical Axis – 0-100% command from Chart 
menu or form toolbar. 
 
 

 
 
 
 

4.5.3. Many Vertical Axes 

 
 

The axis type is turned on with use of the  Many Vertical Axes command from Chart 
menu or form toolbar. 
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4.5.4. Many Vertical Axes - Stack 

 

The axis type is turned on with use of the  Many Vertical Axes – Stack command from 
Chart menu or from toolbar. 
 
Additionally, it is possible to display 2 adjacent series on one common axis. It is useful when 
area of the chart should be organized for better legibility. The option of displaying two series 
on one axis is set on the ‘Series Options’ window run by the Options… command from Series 
menu (or from toolbar).  
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4.5.5. XY Axes 

 
AsTrend can create the chart being the function of two asix variables. For each chart point, 
one can display the label containing: 

- Number of series point; 
- Number of point, time stamp; 
- Number of point, time stamp, values of samples from two series; 
- Number of point, time stamp, values of samples from three series. 

 
Labe content is determined on ‘Trend Options’ window > Chart tab activated by Trend 
Options command from Trend menu (or from toolbar). 
 

 
 

 

4.6. Operations on Variables  
  
 
If neither any individual curve nor any group of curves displayed within the chart area is 
selected, the commanded operation will concern all variables of the trend. Operations may 
be commanded by toolbar buttons or menu commands. 
 

 

4.6.1. Selection of Variables 

 
To select a curve (variable): 

• click the curve, or 
• click the variable row in the legend. 

 
To select all variables, double click any point of the chart area outside any of the displayed 
curve. 
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4.6.2. Removal of Variables 

 
 
To remove a variable: 

• click the  toolbar button 
• use the Series > Remove menu command 
• use the Remove option of the chart area context menu, or 
• press the DEL key. 

 
Neither of the above listed option is available unless some variable is selected. 
As soon as a variable is removed, next variable in the legend becomes automatically 
selected. 

 

4.6.3. Displaying Variable Metrics 

 

 
To display variable metrics (definition): 

• click the  toolbar button 
• use the Series > Variable Attributes… menu command, or 
• use the Variable Attributes… option of the chart area context menu 

 
Neither of the above listed option is available unless some variable is selected. 
Variable metrics is displayed in the variable attributes window. 
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Attributes are loaded from VarDef. 
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4.6.4. Displaying Labels 

 
Labels are small boxes displayed above curve points, in which values of the points are 
shown. 

Use the  toolbar button or Series > Labels menu command to show/hide labels. If at the 
moment the button/menu command is used some variable is selected, only labels of that 
curve will be shown/hidden, otherwise labels of all curves will be affected. 
 
 

 
 
 
 

4.6.5. Displaying Measurement Points 

 
Squares representing measurement points may be displayed only within line charts. They 
are located on curves in places corresponding to the point values. 

Use the  toolbar button or Series > Points menu command to show/hide measurement 
points. If at the moment the button/menu command is used some variable is selected, only 
points of that curve will be shown/hidden, otherwise points of all curves will be affected. 
 



asix5 AsTrend documentation
 

 

62 ©ASKOM, Gliwice 

 

 
 
 
 

4.6.6. Changing Variable Range 

 
 
By default, chart vertical axis range is set according to database of variable definitions (e.g. 
0-10,000). However, you can modify the range of the selected curve(s). To change variable 
range: 

• click the  toolbar button 
• use the Series > Range menu command, or 
• click the Range field within the legend. 

 
The following window should be displayed: 
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4.6.7. Replacing Variable 

 
 
To replace variable (preserving curve attributes such as color etc.): 

• click the  toolbar button 
• use the Series > Exchange Variable…  menu command, or 
• click the variable Name field within the legend. 

 
Neither of the above listed option is available unless a database of variable definitions is 
open.  
 
The first two options are not available unless some variable is selected (clicking a Name field 
within the legend automatically selects the variable). 
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Enter new variable name. If the Get range from the legend checkbox is set (as in the 
Figure), new variable range will be taken from the legend, otherwise – from the database of 
variable definitions. Confirm with the OK button (or press the ENTER key). The entered 
variable name appears next to the text box in the color assigned to its curve. This way one 
can easily check whether the entered variable is correct. If duplicate of a variable is entered 
(e.g. to compare raw and averaged data points within a single trend) the shown color 
facilitates differentiating both instances of the same variable. 
 
The Replace function is particularly handy if names of variables are systematically assigned 
according to some convention. Suppose for example that names of all variables of some 
category start with “B1” and names of all variables of another category start with “B2”. 
Suppose that a trend presents some B1-category variables and you want to quickly re-
define it so that equivalent B2-category variables are charted instead. Of course you might 
manually remove a B1 variable, add a B2 variable, assign to it the removed B1 variable 
attributes, an so on for the whole group of variables. However, it is much simpler and 
quicker to just use the Replace function.  
 
If an opened Variable name window will be closed with its OK button without any editing 
actions performed, definition of that variable within the trend will be updated with definition 
retrieved from database of variable definitions. 
 
 

4.6.8. Interpolation 

 
 
By default linear interpolation is used. However, step-wise interpolation may also be used 
(in particular well suited for multi-state variables).  
 

Use the  toolbar button or Series > Stairs Interpolation menu command to switch 
interpolation type.  
 
Both interpolation methods are illustrated in the figure below. 
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The function affects only the selected variable(s). 
 
 
 

4.6.9. Showing/Hiding a Curve 

 

 
By default each variable curve is shown.  

Use the  toolbar button or Series > Hide menu command to show/hide the curve.  
 
The function affects only the selected variable(s).  
 
 

4.6.10. Color Change 

 
 
The program automatically assigns colors to different variables according to a pre-defined 
sequence (red, green, yellow…). However, color of each variable may be changed manually.  
 

Select the variable, use the  toolbar button or Series > Options menu command to open 
Series Options window, and select a color on the Appearance tab. 
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Both curve and legend colors will be changed. See also how to change background color. 

 

4.7. Chart Type of Series 
 

Use the   toolbar buttons (or the Series  menu options) to select chart type: 

• Line chart (  button or Linear Chart menu option) 

• Bar chart (  button or Bar Chart  z menu option). 
 
By default all new variables are presented on line charts. 
 
To change type of an existing chart, select the curve and click one of the above toolbar 
buttons. 
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4.7.1. Linear Chart 

 

Sample line chart in the 3D mode is show below (use the  button to turn on the 3D 
mode). 
 
 

 
 

 

4.7.2. Bar Chart 

 

Sample bar chart in the 3D mode is show below (use the  button to turn on the 3D 
mode). 
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4.7.3. Variable State Labels 

 
 
State of variables may be indicated on charts within labels. If a chart presents many 
variables (multi-curve chart), the labels may be used provided that all the variables have 
identical states.  
 
All possible states of a to-be-monitored variable must first be declared in a database of 
variable definitions. Detailed information on configuration of variable definitions servicing 
state definitions you find in Architect manual, 2.6. Storing description of variable states in 
VarDef. 
 
 

4.7.4. Binary Variable Charts 

 
 
Regardless of chart type/axis arrangement, bi-stable variables are always charted on 
separate 0-1 axes. 
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4.8. Data Type 
 

 
Methods of sampling data for charting purposes are related with specific data types. 
Methods available in the AsTrend include:  
   

• genuine data (switched on by the  Genuine Data command from Trend menu or 
from toolbar) - charted data intervals are forced by the archiving program;  

• uniform data (switched on by the  Uniform Data command from Trend menu or 
from toolbar) - periods between consecutive samples are constant; 

• averaged data (switched on by the  Averaged Data command from Trend menu or 
from toolbar) - periods between consecutive samples are set by the AsTrend program 
depending on the length of the period in which the data are averaged; 

• approximated data (switched on by the  Approximated Data command from 
Trend menu or from toolbar) - periods between consecutive samples are set by the 
AsTrend program depending on the length of the period in which minima and maxima 
are calculated. 

 
 
To set sampling period for uniform data, you have to use ‘Trend Options’ window > Data tab 
activated by Trend Options… command from Trend menu or from toolbar. 
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4.8.1. Declaration of Aggregate Used for Reading Uniform Data 

 
 
The user indicates an aggregate used for reading uniform data he/she is interested in and 
aggregator period, which is the basis for calculating the successive aggregated values (the 
uniform data is the data for which the period between consecutive samples is constant). 
When the Aggregator is used, the uniform data is calculated by asix server, from where the 
AsTrend retrieves them – that way the statistical data is ready to be quickly and efficiently 
displayed. 
 
 
Aggregate for reading uniform data is set with use of ‘Series Options’ window > Data tab > 
Aggregate for ‘Uniform Data’ option. The window is activated by Options… command from 
Series menu or from toolbar. 
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4.9. Series Options 
 

 
Series options are set with use of the window activated by Options… command from Series 
menu or from toolbar. 
 
There are six tabs: 

- Ranges; 
- Data; 
- Chart; 
- Vertical axis; 
- Appearance; 
- Legend. 

 
  

• Ranges tab: 
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- Display range – display range is used for scaling physical axis of all series and 
axes of individual series on multiaxis chart; for scaling physical axis display range 
of ALL series are taken into account; 

- Measurement range – measurement range is used for checking correctness of 
series samples values; values of samples which exceed series range by number 
equal width of range are cut off; measurement range can be used also for scaling 
physical axis of all series and axes of individual series on multiaxis chart. 

 

 
 
 
 
 

• Data tab: 
 
- Period of time, from which data is displayed – displays additional period of time; 

when used one can simultaneously display within trend data from two different 
periods of time; 

- Aggregate for ‘Uniform Data’; 
- Application archive, from which data is displayed. 
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• Chart tab: 
 
- Hide series on chart; 
- Chart type – set chart type of series: linear or bar; 
- Misc – displays point, labels or sets stair interpolation; 
- Series limit lines – set of options that allow to display particular series limits on 

chart. 
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• Vertical axis tab: 
 
- Labels format – sets labels format for percentage chart and many vertical axes 

chart; 
- Vertical axis position – sets location of vertical axis (left side or right side) on 

many vertical axes charts; 
- Vertical axis position – allows to display vertical axis on the left or right side 

together with adjacent series; it concerns many vertical axes - stack charts; 
- Axis scale type – sets linear or logarithmic scale; axis scale can be logarithmic only 

when minimum and maximum range is greater than zero. 
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• Appearance tab: 
 
- Color options – this option allow to set custom series color; in other case, series 

color will be first not used color form palette, defined in program options; 
- Line options – sets line width in pixels; by default, it is set 1 pixel; 
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• Legend tab: 
 
- Font options  - sets font options: type-face, bold, italic, underline; 
- Values format – sets number of decimal places; option is used during formatting 

values displayed in legend, displayed in table and exported to text file; 
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4.10. Trend Attributes  
 
 
Some attributes influence trend window appearance. The attributes may be turned on/off 
using toolbar buttons or respective menu commands. The attributes show/hide: 

• chart grid and axis scales 
• legend 
• marker (read-out line)  
• 3D appearance. 

 
By default all the above attributes except 3D appearance are on.  
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4.10.1. Displaying Chart Grid/Axis Scale 

 
 
Chart grid and axis scale are by default on, but may be turned off.  
 

Use the  toolbar button (or the View > Scale and Grid menu command) to show hidden 
grid / scale. The button will be replaced by a depressed version, the menu command will be 
accompanied by a checkmark.  
 

 The Chart grid/axis scale button as well as the corresponding menu option are active 
only if the window re-size function is enabled. 

 

 

4.10.2. Displaying Legend 

 
 
Legend below the chart area may be hidden.  
 

Use the  toolbar button (or the View > Legend menu command) to show hidden legend. 
The button will be replaced by a depressed version, the menu command will be 
accompanied by a checkmark. 
 

 The Legend button as well as the corresponding menu option are active only if the 
window re-size function is enabled. 

 

 

4.10.3. Displaying Read Line/Lines 

 
 
A marker (a read-out vertical line) may be displayed within the chart area. The marker may 
be dragged horizontally along the time axis (mouse cursor changes its shape while the 
mouse points to the marker). Time corresponding to the current marker position is 
displayed in the status bar. Values of time and variables corresponding to the current 
marker position are also displayed in the Time of Read Line and Indicate Value of Read Line 
columns of the Legend (provided that these columns are shown on screen). If the marker is 
situated between two adjacent points, interpolated values are displayed in the Cmpute 
Value of Read Line legend column.  
 

Use the  toolbar button (or the Chart > Read Line menu command) to show hidden 
marker.  

Use the  toolbar button (or the Chart > Two Read Lines menu command) to show two 
markers. 
 

Use the  toolbar button (or the Chart > Set Read Line Position… menu command) to 
display the following windows, in which you may precisely position the markers (when one 
read line is switched on, the Position of additional read line field is disabled): 
 
 
 



AsTrend documentation asix5 

 

©ASKOM, Gliwice 79 

 

 

 

Thickness of read lines may be defined by options found in the ‘Program Options’ window > 
Chart tab: 

 

 

 

4.10.4. Displaying 3D Charts 

 
Optionally each chart may be presented in three dimensions.  
 

Use the  toolbar button or the Chart > 3D menu command to display pseudo-3D graph.  
 
If the button is pressed (menu is marked) two-dimensional graph displaying is active. 
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4.11. Trend Options 
 

 
The basic trend options: data type, axis type, legend format, colors, trend description for 
printout, as well as period set while opening trend file, may be defined with use of the ‘Trend 
Options’ window activated by the Trend Options… command from Trend menu or from 
toolbar. 
 
  

• Data tab: 
 
- Genuine Data; 
- Uniform Data; 
- Approximated Data. 
- Averaged Data; 
- Uniform Data – Sampling Period. 

 
See more information on data type: 4.8. The AsTrend Program. 

 

 
 
 

• Chart tab: 
 
- Axis Type: 
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Vertical Axis – physical; 
Vertical Axis – 0-100%; 
Many Vertical Axes; 
Many Vertical Axes – Stack; 
XY Chart. 
 

See more information on axis type: 4.5. Trend Axis Types. 
 

- Labels on XY chart: 
 

Number of series point; 
Number of point, time stamp; 
Number of point, time stamp, values of samples from two series; 
Number of point, time stamp, values of samples from three series. 

 
- Margins – margins of chart area; margin value set distance between label of 

minimum/maximum value and chart edge. 
 
 

 
 
 
 

 
• Legend tab: 

 
- Legend font; 



asix5 AsTrend documentation
 

 

82 ©ASKOM, Gliwice 

 

- Legend column width. 
 

 

 
 
 
 
 

• Colors tab: 
 

- Color palette – when option is used, it is possible to define custom trend color 
palette for trend curves (in ‘Trend Options’ window appears new tab – Color 
palette); 

- Variable custom colors – when option is active, the custom trend color palette will 
be used for new added series.   

 
 



AsTrend documentation asix5 

 

©ASKOM, Gliwice 83 

 

 
 
 
 
 
 

• Color palette tab: 
 

- The tab is available when the Color palette option on Colors tab is active. 
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• Printout tab: 
 

- Title – the title on trend printout; 
- Header – the header on trend printout; 
- Footer  - the footer on trend printout. 
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• Opening tab: 
 

- Period after opening trend file – set the period loaded when trend is opened; the 
possibilities: 

 
Like during write; 
Period end equals now; 
Current day, time without change; 
Last used; 
Set in OPC format (Begin, End); 
Ask me. 
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4.12. Aggregator of asix System 
 

 
Application of Aggregator – asix built-in module for calculating and archiving 
statistical data - optimizes the procedure of displaying charts that cover long time periods. 
Whenever possible, the aggregated data retrieved from the asix server are charted 
instead of a raw data. Such approach significantly improves speed of charting and 
flexibility of the display. The AsTrend program automatically selects the aggregate period 
according to the charted time period.  
   
Application administrator or application designer must declare only a few parameters and 
options of the process of calculating and archiving the statistical data, including required 
aggregate types. The declarations are entered in the asix system configurator window 
(under supervision of the Architekt program). 
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4.13. Automatic Trend Display  
 
 

Automatic trend display functions take care to adjust number of the displayed data points 
depending on the time span selected to chart on screen. That way the charted curves may 
be drawn faster.  
 
 
When Aggregator is not used in asix system, the charted curves may be drawn faster by 
defining automatic trend display in AsTrend options (It demands additional variables to be 
defined for storing averaged values of row variables – see: Architect module manual, 
2.2.2.7. Variable Averages defined for AsTrend Usage). 
 
AsTrend > File menu > Program Options > ‘Program Options’ window > Automat tab 
 

 
 

Display may be optimised according to two different approaches: 
 

• If the Period - Sampling checkbox is set, sampling frequency will be adjusted to the 
selected period charted on screen. Every modification of the latter (e.g. by means of 
the relevant toolbar button) will automatically be followed by adjustment of the 
sampling frequency performed according to criteria defined in the Automatization 
parameters window (the window may be opened by the Parameters command button). 

• If the Sampling - Period checkbox is set, period charted on screen will be adjusted to 
the selected sampling frequency. Also in this case adjustment criteria may be defined in 
the Automatization parameters window. 
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Suppose the Period ->Sampling checkbox is set. In the example shown above, if the period 
charted on screen is selected as: 

• shorter than 1 hour, sampling frequency will be set to 1 sample every 2 seconds, all 
variable values will be taken as-measured  

• not shorter than 1 hour but shorter than 1 day, the frequency will be set to 1 sample 
every 5 minutes, all values will be taken as 5-minute averages 

• not shorter than 1 day, the frequency will be set to 1 sample every hour, all values will 
be taken as hourly averages.  

 
Any modification of sampling frequency affects all variables defined on the chart, regardless 
of whether they are selected or not. 

 

 
 

Now suppose the Sampling -> Period checkbox is set. In the example shown, above if 
the sampling method is selected as: 

• as-measured (current) values, the period charted on screen will be set to 10 
minutes 

• 5-minute averages, the period charted on screen will be set to 1 day 
• hourly averages, the period charted on screen will be set to 7 days. 
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The latter approach is applied very often in practice. Usually one starts with long 
periods and hourly averages in order to speed up browsing. If any irregularity is 
detected, its region is zoomed-in and the charts may be re-drawn using short-term 
averages or even the as-measured values. 

 

4.14. Reading Trend Definition  
 
 

Use the  toolbar button (or the File > Open menu command) to read-in a stored trend 
definition. The read-in definition replaces the so-far used one. 
 
Trend definition contains: 

• names of the charted variables 
• trend period 
• curve attributes (colors, chart types, labels etc.) 
• window attributes (window appearance) 
• print-out parameters (title, header, footer). 
 

 

 
 
Period displayed on screen may be modified in relation to period stored in trend definition. 
In fact the program may prompt user for the to-be-displayed period each time a new trend 
definition is open. 
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Trend definitions are stored in XML files. Trend definition may be read-in automatically 
during the program startup if name of such a file will appear as argument of the program 
calling command.  
 

 The Open window appears in the above shown form in the administrator program mode 
only. In the operator mode the window appears without the Search in list box and without 
the change directory button. 
 

 

4.15. Trend Printing  
  
 

Each trend may be printed out. Print preview may be checked before printing. Printouts 
contain the following elements: 

• chart area  
• legend 
• title 
• header  
• footer. 

 
All these elements are visible in the print preview window. The elements may be configured: 

•  on the Printout tab of the File menu > Program Options > ‘Program Options’ window; 
values defined on this page are the default ones for new trends; 

• on the Printout tab of the Trend  menu > Trend options… > ‘Trend Options’ window; 
values defined on this page are the individual ones for separate trends. 
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4.15.1. Print Preview 

 
 

Use the  toolbar button (or the File > Print Preview menu command) to pre-view print-
out on screen. 
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Depending on the selected printer, print-out will be black&white or color. In the former case 
all colors will get automatically translated into gray values. Buttons in the preview window 
make possible to scale the print-out several different ways (fit to window, 100% size as on 
the printer, fit to page width etc.), to configure some printer options, as well as to start 
printing. 

 

4.15.2. Printing 

 

Use the  toolbar button (or the File > Print menu command) to start printing. The button 
starts printing immediately on the default system printer. The menu command works the 
same way if the program runs in the operator mode. However, if the program runs in the 
administrator mode, the File > Print menu command opens dialog window, in which 
administrator may select another printer and set up its properties. 
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4.15.3. Printing Trends with More than 12 Curves 

 
 
In case the to-be-printed trend contains more than 12 curves, prior to printing use the 
Trend > Trend Options menu command to open the Trend parameters dialog window and 
change legend layout into double column one. That way the legend area capacity will 
increase to 16 variables. Of course chart area size will decrease. 
 
Printout with one-column legend layout 
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If the above is not done and the to-be-printed out trend contains more than 12 curves, the 
following warning will appear on screen:  

 

 

 
Page layout is up to the operator. However, remember that chart size will be different than 
in case when window re-size/auto-adjustment function is disabled. 

 

4.16. Closing Displayed Trend  
 
 

Use the  toolbar button (or the File > New menu command) to close the currently 
displayed trend. Chart area will become empty. 
 

 

4.17. Saving Trend Definition  
 
 
Trend definition may be stored using: 

• the File > Save menu command 
• the File > Save as... menu command, or 

• the  or  toolbar buttons. 
 
The store function works differently in the Operator mode than in Administrator/Full modes. 
 
Operator mode 
 
Trends qualified by an Administrator as read-only (Tylko_do_odczytu) may not be modified 
by Operators. An attempt to do so will generate warning message: 
 

 
 
 
However, Operator may store the trend under a new filename: 
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Trends are stored in binary files. 
 
 
Administrator mode 
 
The administrator can create new trends with Read_only status. 
 
 

 
 
Administrator may also modify each existing trend definition regardless of its status. Each 
attempt to overwrite any existing trend file will generate the following warning message: 
 

 
 
If the to-be-overwritten file is read-only, another warning message will follow: 
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The “read-only” status is meant to distinguish trend definition templates that should not be 
modified. 
 

 

4.18. Administrator Password and Login 
 

 
Access control functionality in version 5.1 of the AsTrend program may be accomplished in 
two ways:  
• using the AsAudit module that offers extensive set of functions used to manage users 

and their privileges (which requires MS SQL Express database engine installed on a 
single central server to run database of user privileges), or  

• using the simplified internal access control mechanisms available in previous versions 
of the AsTrend program.  

  
Access control mechanism accomplished without the AsAudit module enables each user to 
log-in as an Administrator or as an Operator only. See more: 1.4. Operation of the Program 
in Conjunction with the asix System. 

 

4.18.1. Administrator Login 

 
Use the  toolbar button (or the File > Administrator mode menu command) to log in as 
administrator. The Enter password dialog window opens, in which the correct administrator 
password must be entered. 
 

  

 
 

 If the AsTrend program is run the first time on the given computer, it is enough to press 
the OK key in the Enter password window. Having logged-in, use the File > Change password 
menu command to define a password that will be required at subsequent log-in attempts.  
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4.18.2. Changing Password 

 
 
To change the administrator password, log in as administrator, use the File > Change 
password menu command to open the Change password dialog window, enter a new 
password into the Enter new password text box, re-enter it into the lower Admin new 
password text box, and click the OK command button. 
 
 

  
 
Administrator password is stored within the computer Windows Registry. 

 
 

4.19. Context Menus  
 

 
You can right-click chart area, legend and/or table of values to display context menu. 
 
Chart area context menu options include: 
• add a new variable to the chart (Add…) 
• remove a variable from the chart (Remove) 
• display metrics of a variable (Variable Attributes) 
• copy the displayed range to the Clipboard (Copy Period to Clipboard) 
• adjust background color in the chart/legend/axes area (Background color). 
 
Legend context menu options include: 
• add a new variable to the chart (Add…) 
• remove a variable from the chart (Remove) 
• show/hide the selected curve (Hide) 
• move the selection of variable series up 1 row (Move up) 
• move the selection of variable series down 1 row (Move down) 
• display metrics of a variable (Variable Attributes) 
• exchange a variable (Exchange Variable) 
• set vertical range for the selected variable (Range) 
• display points for the selected curves (Points) 
• display labels for the selected curves (Labels) 
• open series option selection window (Options…) 
• adjust background color in the chart/legend/axes area (Background color) 
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4.20. Data Export 
 

 

The  Export data command from File menu allows to easily export the charted data to a 
*.txt file, *.csv file, or Clipboard.  
   
Modified export format consists of sequence of measured values and time marker values, 
each separated by a separator character. In case of exporting to the Clipboard, the Tab 
character is the separator. Data are exported in the following order: time value, variable 
value. Each variable column is associated with its own time data column except for uniform 
data when the time data column may be common. Time data are exported in the system 
format (‘2008-02-20 16:48:22’). In case of alarm series and/or some external data, the 
time data column additionally contains millisecond values. The exported data may be 
optionally supplemented with a two-line header, as well as with units of measure next to 
each variable name. 
 
It is also possible to export data to a PDF or BMP file by the following command run from 
File menu or from toolbar: 
 

 Export to PDF…– export chart / legend area to a PDF file 

 Export to BMP – export chart / legend area to a BMP file 
 

4.21. Clipboards 

4.21.1. Clipboard  
 
 
You can copy table and/or list of variables to the Clipboard in order to paste later the 
Clipboard contents into another program e.g. Notepad or Excel (using the Ctrl+V keys).  
 
You can not copy that way either chart or legend. However, the chart together with the 
legend may be exported to a bit map file that may be opened later in a graphical program 
like Paint.  
 
You have to use context menu to copy list of variables to the Clipboard: 
 

• use the Copy Rows to Clipboard or Copy Cell to Clipboard options in case of a list of 
variables; 

 
In case of table, use Export data… from main menu with the Destination – Clipboard option 
to copy all rows to Clipboard. 
 
 
There is also Period Clipboard in AsTrend. Using the Copy Period to Clipboard command 
from Period menu you can easily copy the period that is displayed on the chart and set it 
from the Clipboard when needed. 
 
 

4.21.2. Periods Clipboard  
  
 
Periods Clipboard is a very useful tool that helps to analyze trends. It is particularly handy if 
a user wants to compare the analyzed trend with another one (perhaps somehow related) 
without storing the first one. Clipboard is a kind of cache memory, in which various 
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interesting periods may be stored to be later used. Clipboard capacity is limited by the 
system memory only.  
 
Clipboard contents may be browsed in the Periods Clipboard (menu Period > Periods 
Clipboard) window shown below. Each stored period is described with the Description, Start, 
End and Length parameters. 
 

  
 

Use the toolbar button (or the Period > Periods Clipboard menu command) to show the 
Periods Clipboard window. The window is displayed always on top. Use scrollbar if the 
number of occupied rows in the window is large. You may close the window without deleting 
Clipboard contents.  
 
Click a period row to select the period (necessary for some operations on periods). Click an 
Description field to edit period description in the field (blue background of the selected row 
disappears). Description should clearly identify the period for the user. Press Enter key to 
end editing session. The remaining fields are filled up automatically by relevant functions 
(you may not edit the fields). 
 
NOTE Do not position the Periods Clipboard window in the middle of the screen 
since it is always on top and therefore might make impossible to display messages 
on encountered system errors that are always displayed centrally. 

 
 

4.21.3. Clipboard Functions 

 
 
Clipboard-related functions include: 

•  button (in the trend window toolbar or the clipboard toolbar) or the Period > Copy 
Period to Clipboard menu command: add a period to the Periods Clipboard. The period 
ID data will automatically occupy the last row in the Periods Clipboard window. If the 
period is to be used for a longer time, it is recommended to click the Opis field and 
enter some description of the stored period. 

•  button: re-draw trend within the preset period using the indicated data stored in 
the Period Clipboard. Instead of selecting a period on the Periods Clipboard window list 
and clicking the button, you may also double click the period (the latter method will 
additionally close the window). 
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•  button (or the DEL key): delete from the Clipboard the period indicated by ID data 
selected on the Periods Clipboard window list. 

•  button: clear the entire Clipboard contents. 
The above functions may also be called from the Periods Clipboard window context menu 

(options Add, Use, Delete and Delete All, respectively). 
 
 

4.22. Operations on Chart Axes  
 
 
Parameters of both chart axes (range, scaling, labels etc.) may automatically match legend, 
or else may be user-defined. User may modify default parameters of the horizontal or the 
vertical axis using (respectively):  

•  or  button  
• Chart > Horizontal or Vertical axis menu command 
• clicking the respective axis. 

 
 

4.22.1. Horizontal Axis 

 
 

Horizontal axis adjustments are available in the dialog window shown below. 
 

 
 
 
Automatic scaling mode may not be turned off for the horizontal axis – range of this axis 
must be selected by the program, user may only read the minimum/maximum displayed 
time. The standard (default) label format is “yy-mm-dd" in case the range is longer than 1 
day, or “hh:mm” otherwise. The adopted default is convenient if the axis range is frequently 
changed. However, user may modify label format; the available format options include: 
 

• default 
• user 
• yy-mm-dd hh:mm:ss 
• yy-mm-dd hh:mm 
• yy-mm-dd hh 
• yy-mm-dd 
• yy-mm 
• mm-dd hh:mm:ss 
 

• mm-dd hh:mm 
• mm-dd hh 
• mm-dd 
• dd hh:mm:ss 
• dd hh:mm 
• dd hh 
• hh:mm:ss 
• hh:mm 
• mm:ss 

 
To define some format, enter a string composed of the yy/mm/dd/hh/mm/ss 
year/month/day/hour/minute/second symbols and the desired separators to the text box. For 
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example, enter the “yy*mm*dd” string to use asterisks instead of default hyphens as 
separators in date labels. 
 

 

4.22.2. Vertical Axis 

 
Vertical axis adjustments are available in the dialog window shown below. 
 

 
 
Vertical axis range in each open trend is by default automatically scaled to match the 
lowest/highest values among all variables defined within the trend. However, alternatively 
the range may also be: 

• set automatically on the basis of values charted on screen 
• matched to the range defined in database of variable definitions 
• set manually (arbitrarily) by the user 
• calculated on the basis of user-supplied ranges. 

 
If the range may not be determined on the basis of database of variable definitions, the 
default range is used. A manually-set range will be used until the user re-defines it. Range 
calculation consists in finding the lowest/highest values among all trend curves. 
 
Use the Labels format to modify format of the vertical axis labels (the command is also 
accessible on the Vertical axis tab of the window opened by the Series > Options menu 
command). You may edit number of digits, number of decimal places, decimal separator etc. 
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4.23. Operations on the Displayed Curves  
 

 
 
Once a trend is charted, usually some adjustments of the displayed curves are necessary to 
optimize the view to the current needs.  
 
Some operations may exclude some other operations. For example, if the data logging mode 
is activated, panning function is disabled.  
 
 

4.23.1. Data Loging Mode 
 

Each trend may be switched to the data logging mode: trend period is constant, but the 
period start and end time advance synchronously so that the period end at all times 
coincides with the current time. This mode is basically used to continuously monitor freshly 
acquired data. Charts are re-drawn every second provided new data have appeared. 

Use the  toolbar button or Trend > Register  menu command (provided it is active) to 
turn on the data logging mode.  
 

Use the  toolbar button or Trend > Stop menu command to suspend logging. While 
logging is suspended, trend is immobilized, but all regular trend operations become 
available. 
 
 

4.23.2. Zooming 

 

 
Each trend fragment inside the chart area may be zoomed-in. Use one of the following 
methods. 

• Drag from top left towards right bottom to select the to-be-zoomed rectangular area 
(see Figure below). As soon as the mouse button is released, the selected rectangle is 
zoomed. The point selected as t p left must not belong to any curve since pressing the 
mouse button down in such situation will be interpreted as instruction to select the 
curve. By default trends may not be mouse-zoomed vertically (the function is disabled). 

To enable the function, click the  Block Vertical Zoom toolbar button (corresponding 
option is available also in the Chart menu). 
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• Click the /  toolbar button to zoom-in/out by 50% per click. Corresponding 
options are available also in the Chart menu: Zoom In Vertical, Zoom Out Vertical. 

• Use the  Without Zoom toolbar button to restore the initial zoom. This operation 
may also be commanded with the mouse: drag from right bottom towards top left i.e. 
in the opposite direction as compared to the zoom-in operation. 

Zooming operations may be animated. Click the button to enable animation. If 
animation is enabled, chart zoomed with the mouse will enlarge smoothly. 

Zooming may be disabled in respect to individual axes. Click the  toolbar button or 
select the Period > Block Vertical Zoom menu command to disable horizontal zooming. Click 

the  toolbar button or select the Chart > Block Vertical Zoom menu command to disable 
vertical zooming.  
       
       

4.23.3. Panning 

 
 
The charted fragment of the archived data may be moved forward or backward along the 
time axis. 

To pan the chart by the entire time period use the   buttons (backward/forward 
respectively). 
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To pan by 25% of the current chart period use the   buttons (backward/forward 
respectively). 
 

The   buttons increase / decrease the period according to predefined in AsTrend 
period spans.   
 

The  Move Forward To The End button sets end of the trend period for the current time. 
 
 
 

4.23.4. Readout of Numeric Values 

 
 

You can point with the mouse to any curve point in order to read out numeric coordinates of 
that point (time and the value the variable had at that time). Mouse cursor overlapping a 
displayed curve changes its shape from an arrow into a cross. If you click mouse button 
while the mouse cursor is a cross, a small box pops up next to the cross. Numeric 
coordinates of the indicated curve point are displayed within the box for about 1 second (see 
Figure below). 
 

 
 
Press down and hold mouse button to display numeric coordinates of the indicated curve 
point for a longer period of time. The coordinates will appear in the status bar. 
 
The operation of reading out numeric values has a side effect: the indicated variable 
becomes selected. 
 
You can read larger blocks of data from table of values. 
 
 

4.23.5. Variable Selection 

 

 
Many operations may be performed only if some variable is selected. You can select a 
variable two ways: 

• point with mouse the displayed curve of that variable (mouse cursor should change its 
shape from an arrow into a cross) and click, or 

• click the Name or Description field in that variable row of the legend. 
 
Name of that variable will appear in the status bar.  
The operation of selecting a variable has a side effect: some toolbar buttons and some 
menu options become enabled. 
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4.23.6. Window Size Locking/Unlocking 

 
 
Window re-size function may be disabled/enabled only while the program runs in the 
administrator mode.  

Use the  button to disable resizing.  
 
Operator may not terminate the program while it runs with the window re-size function 
disabled. 
 
If administrator has stored a trend with window re-size function enabled, the trend opened 
in the operator mode will be treated as a template, but the capability to modify size of 
individual window elements will not be excluded. 

 
 

4.23.7. Restoring Original Appearance of the Window 

 
 

Use the  button to cancel all modifications introduced to the trend window (to restore 
original appearance of the window). Screen will show the most recently read-in trend.  
 
 

4.24. Warning Declaration  
 
 
 
The AsTrend program may display the following warnings: 

• more than 80% points of the displayed curve outside the vertical axis range 
• a too large zoom-in attempted 
• too many points in table of values (display of the table may take too long; it is 

recommended to modify sampling frequency) 
• a zoom-in attempted while zooming operations are disabled 
• some points of the displayed trend exceed by 100% the vertical axis range 
• the Period-Sampling automatic adjustment enabled 
• the Sampling-Period automatic adjustment enabled. 

 
 
You can turn each of the warning on/off on the Warning tab of the File > Program Options… 
>Program options window.  
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Configuration of warnings is stored and loaded while the AsTrend program starts. 
 
 
 

4.25. 0-100% Percent Scale  
 
 
To facilitate comparing of variables of different value ranges, all variables may be charted at 
the chart vertical axis expressed in percents. 0% corresponds to the lowest value of the 
variable, 100% - to the highest value. The axis range will be 0-100% if automatic re-scaling 
function is turned on, or if the variable range is retrieved from database of variable 
definitions. Otherwise the axis percents will correspond to the selected range of values. 
 

Use the  toolbar button (or the Chart > Scale 0-100% menu command) to turn on/off 
the automatic scaling function.  
 
If the function is turned on, select a variable to draw its regular Y axis at the right side of 
chart area (the axis will be drawn in the color of the variable). Depending on the adopted 
axis scaling method, axis range will span values of all points, or user-defined range only. 
Percent axis will remain at the left side of the chart. In case more than a single curve is 
charted with percent axis turned on, regular axis for the selected curve is displayed in the 
color of that curve.  
 
Even if the automatic scaling function is turned on, marker or mouse reads out real vales of 
variables rather than percentages. 
 
Sample chart with two curves and two vertical axes for one of the curve is show below: 
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4.26. Table of Values  
  
 
 
Table of values is a collection of coordinates of points charted within the chart area. Use the 

 toolbar button or the File > Data Table…  menu command to display the table. The 
table may be displayed only in the administrator mode or the full mode of the program. 
 
Marker in the trend window is coupled with highlight in the table window: moving the 
marker will automatically move the highlight to respective row (if necessary, window 
scrollbar will be automatically moved to show the highlighted row), and clicking a row in the 
table window will automatically move the marker to the chart point representing the clicked 
row. 
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Table of values may be stored to a file using the Export data command from main menu. 

 

4.27. Changing Color Palette 
 
 
If you define default color palette of the AsTrend program, successive curves added to the 

trend will be assigned successive colors from the palette. Use the toolbar button or the 
Color Palette tab in the File > Program Options… > Program Options window to display 
palette definition window. 
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Click a color box to the right to select a new color. The defined palette will be used until it is 
re-defined.  
 
Use the Standard command button to restore default AsTrend colors. 
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5. Aslink Network Module Setup  
 
 
The Aslink network module is responsible for retrieving archive data. No module 
configuration is necessary to operate the AsTrend5 program – the system may 
correctly operate at default network module settings. However, the Network protocols 
and the Station name parameters must be set up. 
 

• In case the AsTrend program is to operate in conjunction with the asix system 
application, values of both parameters are retrieved from the application 
configuration (XML) file.  

 
The Network protocols parameter value is set up on: 
Architect > Fields and Computers > Network module > Standard tab 
 
The Station name parameter values is set up on: 
Architect > Fields and Computers > Network module > Standard tab 
 

• In case the AsTrend program is to operate alone, the following lines should be 
inserted into the ASLINK.INI file (the file should reside within the directory, from 
which the AsTrend program is run): 

 
[ASLINK] 
NAME=ASIXTREND 
ADAPTER=TCPIP 

 
Instructions how to prepare the configuration file for a stand alone workstation and for 
a networked workstation are given in subsequent chapters below. 
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