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Microblaze  MCS Tutorial for Xilinx Vivado 2015.1 

This tutorial shows how to add a Microblaze Microcontroller System (MCS) embedded processor to a 

project including adding a simple C program. The design was targeted to an Artix 7 FPGA (on a 

Nexys4DDR board) but the steps should be general enough to work on other platforms. 

Create a new project and create a top level module for the inputs and outputs we will use with the 

microblaze MCS. Create a constraints file to connect the ports to the appropriate FPGA pins to match 

your board. 

 

Select IP Catalog from the Project Manager and then select ‘Microblaze MCS’: 

 



Microblaze MCS Tutorial  Jim Duckworth, WPI 

2 

 

The Customize IP for the Microblaze MCS opens: 

 

We can use the default component name of microblaze_mcs_0. 

• Set the Input Clock Frequency to match your Nexys4DDR  board (100MHz) 

• Increase the memory size from 8KB to 32KB (allows for slightly larger C program) 
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Select the UART Tab and enable the receiver and transmitter and select your baud rate: 

 

Add an 8-bit GPO (we will connect to LEDs later): 
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Add an 8-bit GPI (we will connect to the slider switches later): 

 

Click on OK 

 

Click on Generate 
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Click OK 

You will now see the microblaze_mcs_0 core in the Design Sources window 

 

We now need to access the Instantiation Template so we can add the mcs to our top level module. 

Select the IP sources tab then select the template: 

 

Selecting the file you can now scroll down the veo file and copy the template portion: 
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Copy the template (with control C) and then paste (control V) into your top level file: 

 

 

 

 



Microblaze MCS Tutorial  Jim Duckworth, WPI 

7 

 

Change the instance_name to mcs_0 and modify the signal names in the instantiation to match your top 

level port names as shown below: 

Note: you may see a GPI1_Interrupt signal (you can ignore this port – just leave it open) 

 

In this simple project we just have the microblaze_mcs module but of course you could add extra 

components or modules or other logic as required. 

Select Run Synthesis to synthesize your project.  

You will notice there are 106 Synthesis Warnings but you can ignore these! 
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Software Development 

The next steps are related to the software development using SDK (Software Development Kit). You can 

download this from the Xilinx website if you do not already have this installed. 

Start SDK and select the Workspace to match where your design is stored (for example the project is 

located in this example at C:\ece574\microblaze_mcs\mcs_tutorial): 

 

Click OK 

SDK Starts: 

 

Close the Welcome screen and the Project Explorer Window will open: 
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We need to import the Microblaze Hardware Description. 

Select File -> New -> Project … in the menu 

Expand Xilinx, and select Hardware Platform Specification 

 

Click Next 

Click Browse and navigate to the hardware description file which will be located at: 

project-name.srcs/sources_1/ip/component_name/component-name_sdk.xml: 
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Note: At this point I modified the Project Name to just hw_platform_0 but you can leave with the 

default name provided when you provided the path to the hardware specification file. 

Click Finish to perform the import 
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Now we have imported the hardware description, a standalone board support package can be created. 

Select File -> New -> Board Support Package: 

 

Make sure ‘standalone’ for the Board Support Package OS  is selected and then Click Finish 

 

Click OK 
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You should eventually see in the SDK Console Window at the bottom of the window (select the Console 

Tab): 

 

"Compiling iomodule" 
"Running Make libs in microblaze_mcs_0/libsrc/standalone_v5_1/src" 
make -C microblaze_mcs_0/libsrc/standalone_v5_1/src -s libs  "SHELL=CMD" 
"COMPILER=mb-gcc" "ARCHIVER=mb-ar" "COMPILER_FLAGS= -O2 -c -mcpu=v9.5 -mlittle-endian 
-mno-xl-reorder -mxl-soft-mul" "EXTRA_COMPILER_FLAGS=-g" 
"Compiling standalone"; 
'Finished building libraries' 

Now we will create a new C program: 

Select File => New Project and select Application Project under Xilinx 

 

Click Next 

Type ‘hello_world’ for the project name 

Select the existing Board support Package: 
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Click Next 

 

Select Hello World and click Finish 

Hello_world_0.elf is produced (ELF is Executable and Linkable Format):  



Microblaze MCS Tutorial  Jim Duckworth, WPI 

14 

 

mb-size hello_world.elf  |tee "hello_world.elf.size" 
   text    data     bss     dec     hex filename 
   4412     372    2104    6888    1ae8 hello_world.elf 
'Finished building: hello_world.elf.size' 
' ' 

 

You can view the C program for Hello World by expanding the src folder under hello_world and selecting 

the helloworld.c file:  

 

 

We now need to associate the ELF file with our hardware. 

Go back to Vivado. 

Select Tools -> Associate ELF file … in the menu. 
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Initially the default infinite loop ELF file, mb_bootloop_le.elf is associated with the Microblaze MCS core. 

Click on browse under Design Sources,  

Select Add Files, and browse to the hello_world.elf file (in mcs_tutorial/hello_world/debug): 

 

Select OK 

 



Microblaze MCS Tutorial  Jim Duckworth, WPI 

16 

 

We now have the hello_wrold.elf file containing our software progeam associated with the hardware 

design. 

 

Click OK 
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In Project Manager add a constraint source file to match your board for all the FPGA connections. 

For example: 

 

A comment regarding the UART connection:  

In the Nexys4DDR board reference manual the UART TX and RX are shown as follows. This is showing 

the direction of transmission as seen by the UART. 

 

This means that the FPGA transmits on D4 (port ‘tx’ in the XDC file) and receives on C4 (port ‘rx’). 

For comparison, on the Basys3 board the FPGA transmits on A18 and receives on B18: 
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We can now Implement the Project and then create a bit file by running the Generate Bitstream step. 

You may receive 8 warning messages after implementation. 

7 warnings are related to the Microblaze core that you can ignore. 

1 warning is related to the clk_fpga (100MHz) being driven directly by an IO rather than a Clock Buffer. 

(In this simple example we did not use an MMCM for the clock but this would be recommended.) 

 

Note: On the Nexys4DDR and Basys3 boards the USB-UART bridge (Serial Port) allows a PC application to 

communicate with the board using standard Windows COM port commands. The same USB is also used 

for the Digilent USB-JTAG circuitry but the functions behave independent of each other (read the 

Digilent user manual for more information). 

 

Once a bitstream is created use the Hardware Manager to program the device. 

Connect to the USB-UART using a serial communications link connected to the correct serial com port. 

Press the reset button on the board and you should see “Hello World” appear on a serial 

communications link such as Putty or a Hyperterminal window: 
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Extra: Modifying the C Program. 

In the Xilinx XDK program, expand the src folder from the C project ,and double-click on the  

hello_world.c file. You can see the C statements: 

 

Modify the statements as required (for example change the “Hello World” to add your name) and then 

press save. A new ELF file is automatically generated. 

Back in Vivado we will now see a message that says ‘write_bitsream Out-of-date’. This is due to 

hello_world.elf changing.  

Rerun the Generate Bitstream process to create an updated bit file with the new C program added (you 

do not need to redo any of the previous synthesis or implementation steps unless you also change the 

hardware design). 

Download the new bit file to the board and verify the new changes. 

 

 

 

 



Microblaze MCS Tutorial  Jim Duckworth, WPI 

20 

 

Extra: Accessing the GPIO. 

To access GPI/GPO use XIOModule_DiscreteRead and XIOModule_DiscreteWrite with channel 

1-4 for GPI1-4 and GPO1-4. For example: 

#include <stdio.h> 

#include "platform.h" 

#include "xparameters.h" // add 

#include "xiomodule.h"  // add 

 

void print(char *str); 

 

int main() 

{ 

    init_platform(); 

 

    u32 data; 

    XIOModule gpi; 

    XIOModule gpo; 

 

    print("Reading switches and writing to LED port\n\r"); 

 

    data = XIOModule_Initialize(&gpi, XPAR_IOMODULE_0_DEVICE_ID); 

    data = XIOModule_Start(&gpi); 

 

    data = XIOModule_Initialize(&gpo, XPAR_IOMODULE_0_DEVICE_ID); 

    data = XIOModule_Start(&gpo); 

 

    while (1) 

    { 

        data = XIOModule_DiscreteRead(&gpi, 1); // read switches (channel 1) 

        XIOModule_DiscreteWrite(&gpo, 1, data); // turn on LEDs (channel 1) 

    } 

 

    cleanup_platform(); 

 

    return 0; 

} 

 

You can find the API documentation in the SDK Project Explorer, under <BSP Name>/BSP 

Documentation/iomodule_v1_00_a. Click on "Files", "xiomodule.h" for a list of functions. 
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Extra: Modifying the C Program to use xil_printf 

The usual printf function is too large to fit into the small memory of the Microblaze but you can use the 

Xilinx light-weight version of printf called xil_printf. 

Here is an example of its use in my C program: 

 

    counter = 1234; 

    xil_printf("The counter value is %d in decimal and %x in hex.", counter, counter); 

 

And this is what is displayed in hyperterminal: 

    The counter value is 1234 in decimal and 4D2 in hex. 

 

xil_printf is defined in 'stdio.h'. 

 

Note: However I found out that in Xilinx version 14.1 the declaration was missing in this header file and 

you will see an 'implicit function declaration' warning. It did seem to link without errors and run OK. 

(This seems to be corrected in Version 14.2 and later so you can probably ignore this step) 

 

But if you see the warning and want to fix it on your own system, right click on the stdio.h at the top of 

your C program ( #include <stdio.h> ) and select 'Open Declaration'  

Add this to line 230 

 

void    _EXFUN(xil_printf, (const char*, ...)); 

 

so the nearby lines look like: 

 

int        _EXFUN(remove, (const char *)); 

int        _EXFUN(rename, (const char *, const char *)); 

void    _EXFUN(xil_printf, (const char*, ...)); 

#endif 

 

 

Assembler instructions: 

 

If you want to see the assembler instructions that are created from your C program look in the 

hello_world => Debug => Src folder (top left pane in the Xilinx SDK application) and double-click on the 

hello_world_0.elf file. 

 

If you scroll down this file until you find 'int main()' you will see your C instructions and the  

corresponding assembler and machine code values. Interesting stuff! 
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Extra: Accessing the GPIO, using xil_printf, and using the UART. 

#include <stdio.h> 

#include "platform.h" 

#include "xparameters.h" // add 

#include "xiomodule.h" // add 

 

void print(char *str); 

 

int main() 

{ 

    init_platform(); 

 

    u32 data; 

    XIOModule iomodule; // iomodule variable for gpi, gpo, and uart 

 

    u8 msg[15] = "This is a test";// buffer for sending message using XIOModule_Send 

    u8 rx_buf[10];   // receive buffer using XIOModule_Recv 

 

    u32 counter; 

 

    // example using xil_printf 

    counter = 1234; 

    xil_printf("The counter value is %d in decimal and %x in hex\n\r", counter, 

counter); 

 

    print("Read switches, write to LED port, and UART send and receive chars\n\r"); 

 

    // Initialize module to obtain base address 

    data = XIOModule_Initialize(&iomodule, XPAR_IOMODULE_0_DEVICE_ID); 

    data = XIOModule_Start(&iomodule); 

 

    // Need to call CfgInitialize to use UART Send and Recv functions 

    // int XIOModule_CfgInitialize(XIOModule *InstancePtr, XIOModule_Config *Config, 

u32 EffectiveAddr); 

    // note config and effective address arguments are not used 

    data = XIOModule_CfgInitialize(&iomodule, NULL, 1); 

    xil_printf("CFInitialize returned (0 = success) %d\n\r", data); 

 

    // Send 12 characters using Send 

    // Send is non-blocking so must be called in a loop, may return without sending a 

character 

    // unsigned int XIOModule_Send(XIOModule *InstancePtr, u8 *DataBufferPtr, unsigned 

int NumBytes); 

    const int count = 14; 

    int index = 0; 

    while (index < count) { 

     data = XIOModule_Send(&iomodule, &msg[index],  count - index); 

        index += data; 

    } 

    xil_printf("\n\rThe number of bytes sent was %d\n\r", index); 

 

    // Another way to send individual characters 

    outbyte('X'); 

    outbyte(0x37); // number '7' 

    outbyte('Z'); 

    outbyte('\n'); // line feed 

 

    // Receive a character and store in rx_buf 

    // unsigned int XIOModule_Recv(XIOModule *InstancePtr, u8 *DataBufferPtr, unsigned 

int NumBytes); 

    while 

     ((data = XIOModule_Recv(&iomodule, rx_buf, 1)) == 0); 
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    xil_printf("The number of bytes received was %d\n\r", data); 

    xil_printf("Recv: The received char was %c\n\r", rx_buf[0]); 

 

    // Another way to receive a single character 

    rx_buf[0] = inbyte(); 

    xil_printf("inbyte: The received char was %c\n\r", rx_buf[0]); 

 

    while (1) 

    { 

        //data = XIOModule_DiscreteRead(&iomodule, 1); // read switches (channel 

1) 

        data = XIOModule_DiscreteRead(&iomodule, 2); // read push (channel 2) 

        XIOModule_DiscreteWrite(&iomodule, 1, data); // turn on LEDs (channel 1) 

    } 

 

    cleanup_platform(); 

 

    return 0; 

 

} 

 

 


