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INFINITY Software v6.4.1 

What’s New 

 INFINITY Software v6.4.0 and 6.4.1 Release 

This release introduces a number of enhancements relating to new product introductions, the 
INFINITY ANALYZE package, and the INFINITY CAPTURE and TWAIN interface.   

 Camera Device Drivers 

 Included device driver files for the new INFINITY3-3UR camera models 

INFINITY CAPTURE & TWAIN interface 

 Incorporated support for the INFINITY3-3UR camera models 

 Specific to the INFINITY3-3UR camera, a modification has been implemented to the 
Options -> Preview Quality.  For this camera model the Optimized for Speed will 
enable the camera to output at the fastest possible frame rate, while the Optimized for 
Quality will limit to a lower frame rate.  
 

INFINITY ANALYZE 

 Live video preview performance has been improved with a significant increase to the 
display frame rate capability on all camera models. 

 The ability to capture short, compressed video clips has been added to the software.  
This newly introduced capability has performance limitations, specifically with the 
larger resolution sensors running at fast frame rates, in this release.  Performance 
improvements are anticipated in subsequent releases.  The AVI file is stored 
according to the folder location specified in the Capture Options: Save to File location, 
using the file prefix provided there.  There is no video file playback capability available 
within INFINITY ANALYZE, so a folder open option is presented adjacent to the video 
record button, allowing a browser window to open.  The user selects an AVI file from 
the list, and chooses a 3rd-party tool to display the video clip.  Video clip capture 
performance depends on the processor, memory, and hard drive storage speeds. 

 The default behavior of the Live Preview window is to freeze when measurement 
operations are initiated in that view, to ensure that the field of view does not alter 
during a measurement operation.  An option has been added to the Help -> Settings 
panel to allow for user to request that the preview remain live, if desired. 

 Project Tags are now persistent between ANALYZE sessions 

 The Calibration dialog now includes a dropdown featuring presets for common 
measurement units (um, mm, mil, inch) 
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 Extended exposure time can now be selected to switch the camera into a new 
acquisition mode to extend the camera exposure time up to 2 seconds,  The camera 
will change from streaming video to sequential snapshots when the exposure time is 
increased above 500 ms. 

 The Capture Options pane now includes the ability to specify an Alternate Gain, along 
with the existing Alternate Exposure for captured images.  This feature also allows for 
specified pairs of exposure and gain settings to be stored during the session, for quick 
reference or retrieval.  This function reduces the steps required to acquire 
fluorescence images  

 Annotation tools now remain in edit mode once activated, until the operator selects a 
different action, or chooses the Edit -> Abort menu item. This allows for easier 
alignment and re-positioning of placed annotation objects. 

 Performing measurement functions such as Point-to-Point, Polyline, or Measure -> 
Calibrate, can now be constrained to either horizontal or vertical motion while holding 
down either the Ctrl or the Shift keys (respectively), while moving the mouse. 

 The File menu includes a new feature called ‘Stretch Histogram’, which can be 
enabled on the Live Preview window.  It invokes a Look-Up Table (LUT) configured to 
enhance the image under light challenged applications.  This function can be helpful 
when framing and focusing on a fluorescence sample.  The LUT will remains active 
until cancelled by toggling the option in the File menu, or using the Reset LUT icon 
above the histogram auxiliary window.  If the LUT is active it will apply to a captured 
image. 

 An option has been added to the Help -> Settings dialog, specific to the INFINITY3-
3UR camera.  If the fastest possible video frame rates are desired, the option to select 
a preview quality that is optimized for speed will result in a performance increase for 
the live preview on most computers.  The Live Preview window must be closed and re-
opened (File -> New for video preview), to switch between display processing modes 

 Corrected a problem with the Print operation that resulted in the incorrect scaling / 
position of annotation objects with respect to the underlying image.  

 Corrected the behavior of the multiple camera selection dialog that appears on 
application launch when more than one INFINITY camera is detected, such that when 
Cancel is selected, the application launch is aborted. 

 Corrected an implementation issue introduced in release 6.4.0, that caused the live 
preview window to flicker continually while the Save As dialog was displayed, when 
the Verify file name option was enabled. 

 Improved the performance of the Continuous auto exposure over what was introduced 
in release 6.4.0 

 Improved the Extended exposure time performance for CMOS cameras over what 
was introduced in release 6.4.0 

 For the INFINITY1-2CB camera model, an option is available in the Help -> Settings 
panel to Optimize live preview for frame rate, which allows the camera to operate up 
to 15fps.  A horizontal segmentation may be detected across the image in this mode.  
Enable the Capture full field under Capture Options to produce a captured image 
without the segmentation.  
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 INFINITY Software v6.3.0 Release 

This release introduces a number of enhancements to the INFINITY ANALYZE package.   

 Camera Device Drivers 

 Adjusted INFINITY1-1C device driver to correct incompatibility occurring with some 
Windows 7 computers 

 INFINITY2-3C camera device driver updated. 

INFINITY CAPTURE & TWAIN interface 

 Corrected issue where captured image color did not match the live preview 

 Established persistence of window position in dual monitor configurations, to prevent 
the live preview from returning to the main monitor location 

INFINITY ANALYZE 

 Refer to the INFINITY ANALYZE User’s Manual for Release 6.3.0, which has been 
updated with the changes to the user interface and inclusion of the new features and 
functions. 

 Measurement on live preview is now available.  Users can take measurements without 
the need to first capture an image.  The live preview is temporarily frozen while 
measurement operations are underway, but the live updates resume when the 
measurement tool is closed.  A calibration preset must be active for accurate 
measurement results at a given magnification.  

 The ability to define an ROI in a live preview window or on a captured image is now 
provided.  Frame rate increases are realized when using a cropped ROI invoked 
through the Adjust -> Crop menu option.  The area outside the active ROI can be 
masked.  A cropped selection from a captured image can be saved to provide an 
exactly dimensioned image extract to save to file, if desired.   

 Dynamic bitmap overlay is now available as Project Tags, from the Annotate menu.  
Define both fixed and dynamic text or image overlay to be added automatically to 
captured or live preview images.  Time / date or project IDs can now be easily added 
to any images. 

 Micrometer placement options have been altered to minimize the chance of specifying 
an incorrectly labeled micrometer bar on an image.  The length of the bar is 
determined by the numeric value entered for the label text.  If desired, the automatic 
label can be omitted and a custom label can be added manually as an annotation. 

 Direct export of measurement records into a new Excel spreadsheet has been added 
to the Measure menu 

 Measurement operations now include a temporary line from the current vertex to the 
start point for easier tracking 
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 Polyline measurements now support both vertex placement and freehand drawing 
interchangeably 

 The ability to select and delete an individual measurement has been implemented 

 All Annotation object text and graphic properties are controlled through a single dialog 
with multiple tabs. 

 Annotation objects and Project Tags can be duplicated from a captured image onto 
the live preview 

 Annotation objects overlaid on the live preview are preserved as annotation objects in 
the captured image, and can be manipulated after the capture. 

 The Live Preview window can be made to remain visible when images are captured, 
by choosing an option on the Help -> Settings menu 

 A new option allows for captured images to be acquired using a Snapshot mode that 
provides for a lower image noise in captured images, when specified 

 The Measure Options dialog now provides for the selection of a comma (,) or a period 
(.) as the decimal indicator used for measurement reports in the annotations and in the 
measurement auxiliary window. 

 The File -> Time Lapse Capture menu item has been removed.  Time Lapse is now 
controlled only from the Camera controls pane 

 Changes to the way annotation objects are managed meant that the Adjust -> Overlay 
[color / size] menu functions are now obsolete.  Use the Annotate -> Properties to 
change annotation appearances. 

 Convert into Bitmap has been removed from the Annotate menu since bitmap overlays 
can now be managed dynamically using the Project Tags tool. 

 A green progress bar replaces the live preview window during image capture 
operations.  This is of specific benefit when image averaging or pixel-shifting functions 
are enabled. 

 Image acquisition parameters have been adjusted to correct color shift observed with 
some camera models, between the appearance of the live preview when compared to 
the colors captured in the still image. 

 

 INFINITY Software v6.2.0 Release 

This release includes driver addition. 
 
The following list summarizes the highlights for this 6.2.0 release: 
 

 Camera Device Drivers 

 Added support for the new INFINITY3-1UR camera. 
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 INFINITY Software v6.1.0 Release 

This release includes several device driver updates, as well as improvements to performance 
and some bug fixes for INFINITY ANALYZE.  
 
The following list summarizes the highlights for this 6.1.0 release: 
 

 Camera Device Drivers 

 Device driver files for the INFINITY2-3C camera have been updated to correct a 
problem with captured images that were all black in INFINITY CAPTURE.  This timing 
problem was only evident on some computers. 

 An update to the INFINITY2-1 device driver fixes an issue present on some Windows 
7 computers. 

 Improved frame rate range adjustments included in the device drivers for the 
INFINITY2-1R and INFINITY2-5 camera models.  

 An improvement to the INFINITY2-5 drivers to better manage transitions between 
clocks.  

INFINITY CAPTURE & TWAIN interface 

 No changes. 

INFINITY ANALYZE 

 The area WB (white balance) function has been revised since release 6.0.0 where 
performance was compromised on several camera models. 

 Camera frame rates have been configured to operate at their fastest speeds. 

 Closing the histogram window removes additional processing that was  impacting the 
frame rate performance for the INFINITY1-5 and INFINITY2-5 models on some 
computers. 

 Certain computers experienced lock-up with ANALYZE when capturing images from 
the INFINITY1-3C camera model.  The application has been altered to correct this 
issue. 

 

 INFINITY Software v6.0.0 Release 

This release incorporates improvements to the installation package, device driver updates, 
and some nice additions to the INFINITY ANALYZE package.  The locations of some 
application-related files have been altered to better accommodate Windows 7 and VISTA 
permissions. 
 
The following list summarizes the highlights for this 6.0.0 release: 
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 Camera Device Drivers 

 Improvements to the INFINITY1-2CB exposure controls allow this frame rate-centric 
camera to respond more like an exposure-centric camera. 

 INFINITY CAPTURE & TWAIN interface 

 Changed location of Last Settings file to overcome write protection issues as follows:  
On VISTA & Windows 7 –  C:\Program Data\Twain_32\INFINITY 
On Windows XP – C:\ \Documents and Settings\All Users\Application 
Data\TWAIN_32\INFINITY\ 

 INFINITY ANALYZE 

 Now includes dynamic window zoom for both live preview and captured images. 

 New Cell Counting menu item available on the Measure menu allows for interactive 
thresholding and quantitative results based on pixel intensities. 

 The image title bar is updated with the image file name as soon as it has been saved. 

 Micrometer bar text and length are now associated to the active calibration. 

 User Manual has been fully updated to reflect all menus and dialogs. 

 User interface is now available in 7 different languages. 

 Help menu provides direct access to video tutorials available on the Lumenera 
website. 

 New Annotation menu item creates a bitmap overlay image from displayed graphics. 

 All auxiliary windows and toolbars can be interactively enabled / disabled from the 
Help -> Settings dialog, on a new tab. 

 Photometry auxiliary window displays pixel intensity distribution for measured areas. 

 The camera presets file (containing calibrations) is now located in this folder location: 
On VISTA & Windows 7 – C:\users\[User Name]\AppData\Roaming\INFINITY 
ANALYZE\ 
On Windows XP – C:\Documents and Settings\ [User Name]\Application 
Data\INFINITY ANALYZE\ 

 

KNOWN ISSUES 

 Frame rate of the INFINITY1-2CB is limited to 10 fps, but can be extended to 15 fps in 
INFINITY CAPTURE. Note that vertical bands may be visible, impacting image quality. 

 Frame rate of the INFINITY1-2CB is limited to 5 fps in INFINITY ANALYZE, but will be 
increased in a subsequent release. 

 INFINITY ANALYZE does not currently take advantage of the modified ‘exposure-
centric’ behavior that has been implemented for the INFINITY1-2CB camera, and 
included with INFINITY CAPTURE. This will be addressed in a subsequent release. 
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 INFINITY Software v5.0.6 Release 

The following list summarizes the highlights for this 5.0.6 release: 

 INFINITY ANALYZE 

 Added the default previewing video mode for the INFINITY2-5 camera. 

 Camera Drivers 

 Improvement of the exposure and gain properties control. 
  

 

 INFINITY Software v5.0.5 Release 

The following list summarizes the highlights for this 5.0.5 release: 

 Camera Drivers 

 Added support for the new INFINITYLiteB cameras. 

 Improved support for the new INFINITY1-2B cameras. 
 

 INFINITY Software v5.0.4 Release 

The following list summarizes the highlights for this 5.0.4 release: 
 

 Camera Drivers 

 Added support for the new INFINITY4-11 cameras. 

 Added support for the new INFINITY2-5 cameras. 

 Added support for the new INFINITY1-2B cameras using the SOI image sensor. 
 

 Upgrade to new API version 2.1.0.241 

 Improve Windows 7 support. 

INFINITY Software v5.0.3 Release 

This section describes all the additions and updates we have made to the latest 
release of the software: 
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 Camera Drivers 

 Added CIM3 support for INFINITY2-1 and INFINITY2-2 cameras. 

 

INFINITY Software v5.0.2 Release 

The following list summarizes the highlights for this 5.0.2 release:   

 Installation and Camera Drivers 

 The installation process has been revised to include a screen prompting for the 
INFINITY camera to be disconnected from the PC prior to continuing.   

 New driver file updates are included to correct an issue with the INFINITY4-11 
and Lw11057-SCI models that could result in corruption of the live video 
preview.  Currently does not support external signaling of start of frame in 
Video mode (GPO4: Video SoF). 

 Corrected an issue where pixels would not fully saturate at default gain for the 
INFINITY1-5 model.  In addition, the following Still Mode properties have been 
enabled: 
 STILL_EXPOSURE 
 STILL_GAIN 
 STILL_GAIN_RED 
 STILL_GAIN_GREEN1 
 STILL_GAIN_GREEN2 
 STILL_GAIN_BLUE 
 STILL_STROBE_DURATION 

 Corrected issue for the INFINITY4 and Lu330 camera models with driver 
signing for Windows Vista.  Also improved quality of Brightness, Contrast and 
Gamma in 16-bit mode. 

 

 INFINITY ANALYZE 

 ANALYZE Settings files have been relocated to the standard Windows folder 
location for Application Data, providing better compatibility with future releases 
of the O/S. This new location will be different on XP and VISTA platforms: 
 
For XP: 

 [Drive:]\Documents and Settings\All Users\Application Data\INFINITY ANALYZE\ 

 
For VISTA: 

[Drive:]\ProgramData\INFINITY ANALYZE\Settings 

 

 A problem has been rectified with saving new camera Presets. The original 
release of INFINITY 5.0 introduced a problem resulting in ANALYZE failing to 
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store the camera white balance settings. When a Preset was restored, the 
appropriate color gains were not being set on the camera.   

 An incorrectly imposed restriction on number of decimal places allowed in the 
Measure Options dialog has been removed. Entry of any value less than 2 was 
not permitted in the first releases of the 5.0 version. 

 An enhancement has been added to the micrometer bar placement allowing the 
previously selected location to be used again in the current image. The option 
is presented in the pop-up dialog after using the mouse to select a location in 
the image. This allows for the micrometer bar to be easily placed in a consistent 
location on all images, if desired.  

 Italian language files have been added to the installation, and the additional 
entry may now be selected from the View -> Language menu option. 

 The ANALYZE Advanced Features USB-Key is now being distributed as a 
driver-less device, making for a simpler installation supported across more O/S 
platforms. The Release 5.0.2 of INFINITY ANALYZE is required to take 
advantage of this new style of USB key. 

INFINITY Software v5.0.1 Release 

Includes a correction to the driver for the INFINITY1-3 model. This patch release is 
identical to the 5.0.0 release in all respects for INFINITY CAPTURE and ANALYZE 
applications. 

INFINITY Software v5.0.0 Release 

 Release Highlights 

The following list summarizes the highlights for this 5.0.0 release. Details can be found 
below, with even more information available in the Release Notes and product 
documentation. 

 

 64-bit drivers are now available for all INFINITY cameras on Windows platforms 

 ANALYZE now includes a FULL SCREEN mode 

 Preview grid pattern artefacts have been eliminated from ANALYZE 

 Bitmap Overlay added to Live Preview and Captured images in ANALYZE 

 CAPTURE can now export camera settings to a named ANALYZE preset 

 ANALYZE now offers a Simple layout for demos and first time operators 

 Camera Drivers 

 Added support for 64-bit Windows XP and Windows Vista operating systems. 

 All drivers are digitally signed for Windows Vista operating systems. 

 Added support for new revision of INFINITY2-2 cameras. 
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 INFINITY CAPTURE 

 New function to export current camera settings into an INFINITY ANALYZE 
preset. 

 Added additional 75% zoom mode to preview zoom control. 

 Improved AVI filenames when converting a RAW AVI file to a standard AVI file. 

 INFINITY ANALYZE 

 Changes to the Layout: 

 On initial start-up of the software, the first-time user will be presented with 
ANALYZE shown in a simple configuration.   

 New options to quickly modify the application layout are provided as Simple 
Mode and Enable All, available from the View Menu. 

 A new Full Screen display function has been added. This feature allocates the 
maximum amount of the display for either the live preview or for captured 
images. The application can switch in and out of Full Screen mode by using the 
View menu, or with a simple press on the <Esc> key. 

 The contrast of the status bar has been improved by making the background 
color black. 

 Some toolbar icons used for image positioning have been removed to reduce 
clutter. These seldom used navigation functions are now accessible only from 
the View menu, as items labelled as Center and Corner.  

 The Field Menu entry formerly labelled as Vector Arithmetic has been 
changed to Math. 

 The buttons labelled Video On/Off have been removed from the CAPTURE 
Control panel, providing more space.  

 The sequence of Control panels (from top to bottom) has been rearranged for 
greater ease of use.   

 The Measure Menu has undergone a transformation to make the most 
commonly used options readily accessible and to improve the ease of use for 
common measurement tasks. The Calibration and Micrometer functions have 
been moved onto this menu. 

 Revisions to the Micrometer function allow the bar and the text to be re-
positioned anywhere on the image by placing them in the annotation layer.  

 The distance or length measurements tool formerly labelled as Caliper, has 
been changed to Point to Point. 

 A new option has been added to the File menu called Close All Images. This 
feature pops-up a single confirmation dialog prior to closing down all displayed 
images in the working area. 



 

Lumenera Corporation • 7 Capella Court, Ottawa, ON, Canada K2E 8A7 • (t) 1.613.736.4077 • (f) 1.613.736.4071 • www.lumenera.com • support@lumenera.com 
©2013 Lumenera Corporation. All rights reserved. 

Design, features, and specifications are subject to change without notice 
08082013 

 

 Warnings and information messages now alert the operator when the Field 
Group memory is consumed, or if the number of fields has been used. 

 Camera performance and controls:  

 The Camera Control panel now includes a new option to provide a 
Continuous Auto Exposure function.   

 In previous revisions of the ANALYZE package the live preview from certain 
high resolution camera models (notably the INFINITY2-3, INFINITY1-5, and 
INFINITY4-11) would often produce a grid pattern appearance that varied 
based on the display window dimensions. While this artefact was observed only 
in the live preview and not on captured images, it was an undesirable 
characteristic. Modifications have been made to the display capabilities to help 
eliminate or minimize this problem.   

 Other functional changes 

 A Bitmap Overlay function has been added to both the Live Preview display 
and to Captured images.   This function is accessed using the File Menu  
Bitmap Overlay…   

 The newly designed Grid Options function allows for the origin and size of the 
grid spacing to be easily defined.  A new tool allows for the operator to specify 
the grid parameters using the cursor position on the captured image.  

 It is now possible to change the units of measurement without re-calibrating.   

 A new auxiliary window called Photometry has been added to ANALYZE.  It 
reports pixel intensity values for any defined measurement areas.   


