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1  Getting Started  
PQView® 3.48 is a multi-component software system, developed by Electrotek Concepts, Inc. and the 
Electric Power Research Institute, Inc. (EPRI), for building and analyzing databases of power quality and 
energy measurements. Measurements can be stored in either Microsoft® Access or Microsoft SQL Server. 
 
Through its components, PQView builds measurement databases, writes summary reports, computes power 
quality indices, views waveforms, rms samples, and trend steady-state quantities, via workstations and web 
browsers. Throughout the world, power providers, industrial power consumers, consulting companies, and 
university researchers widely recognize PQView for its capabilities and flexibility. 
 
PQView helps build databases with billions of measurements from thousands of monitoring plants taken by 
many different types of meters, including power quality monitors, voltage recorders, in-plant monitors, and 
digital fault recorders. It can store and analyze information with the measurements about cause and source 
of triggered events, as well as evaluate the financial impact of events to both a power provider and a power 
user. It can quickly extract meaningful information from a one megabyte or one terabyte database. 
 
In addition, PQView provides the following specialized functionality: 
 

• Radial and network fault location 
• Compliance with international and national power quality standards, including EuroNorm 501060, 

the Colombian Energy and Gas Regulatory Commission (CREG), and the Norwegian Water 
Resources and Energy Directorate (NVE) 

• Voltage sag and interruption contract management 
• Power quality event log correlation with SCADA operation logs 
• Load forecasting 
• Wind generation feasibility and assessment 

 
PQView offers all these powerful features through a user-friendly interface.  
 
The complete PQView system consists of these main applications:  
 

• Power Quality Data Manager (PQDM) 
• Power Quality Data Analyzer (PQDA)  
• PQWeb®  

 
   

1.1 Power Quality Data Manager (PQDM) 
One of PQDM’s primary functions is to characterize data files logged by measuring instruments. PQDM 
processes the data from these instruments into characteristics suitable for analysis.  It then stores the 
characterized data from these instruments in Power Quality Database files. The Power Quality Data 
Analyzer (PQDA) then uses the resulting Power Quality Database file (PQDB) to generate reports and 
perform other types of data analysis. 
 
The Power Quality Data Manager (PQDM) is responsible for performing the following specific tasks for 
creating, loading, and editing database files:   
 
• Automatically builds power quality databases from data sources. 
• Automatically sends e-mail notifications using SMTP servers or Microsoft Outlook clients, when data 

sources have finished importing, when rms voltage variations are imported from data sources, or when 
measurements are not collected from a monitoring instrument for a specified period. 

• Automatically correlates measurements by time stamp and location. 
• Deletes old measurements. 
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• Manually adds missed rms voltage. 
• Performs EN50160 compliance calculations, automatic derivations, and automatic fault location. 
• Updates measurement databases automatically once per day, manually, or as fast as once every minute.  
 
Figure 1Figure 1 below shows the data flow for the Power Quality Data Manager. 

 

PQDM
Power Quality 
Data Manager 

Site and Characterized 
Event Data 

Power Quality 
Database 

Raw Event 
Data 

Instrument Data 
(e.g., PASS Data) 

 
Figure 1: Power Quality Data Manager − Data Flow 

 
PQDM characterizes power quality data from different types of monitoring instruments, providing you the 
flexibility to decide how to organize data.  
 
PQView is compatible with the following data sources: 
 

• Dranetz-BMI Signature System®, Encore Series DataNode, Ethernet-connected InfoNode® 
systems and PCInfoNodes, NodeLink, or NodeCenter 

• IEEE std 1159.3-2003 PQDIF: Dranetz-BMI, SoftSwitching Technologies®, Power 
Measurement®, PMI®, Unipower® 

• PQNode® meters from PASS and PES, Power Xplorer®, PowerGuide®, or Power Guia 
• IEEE Std C37.111-1991/1999 COMTRADE: Schweitzer Engineering Laboratories®, SATEC 

ABB®, GE®, E-Max, LEM®, Square D® 
• EDMI: EziView recorded by MK3 and MK6 meters 
• Electro Industries/GaugeTech Communicator Log Files Fluke®/Reliable Power Metrics in 

Scenario and PAS Omega database format 
• HIOKI®: CSV files by PQA-HiView Pro 
• Landis+Gyr/Siemens: Quad4 and Quad4 Plus meters 
• Schneider Electric  (Power Measurement) ION® and ACM meters in ION Enterprise® and 

PEGASYS® databases 
• SoftSwitching Technologies: I-GRID® I-Sense® measurements from IEEE PQDIF files and 

magnitude-duration text files 
• Square D: measurements from PowerLogic® circuit monitor meters in System Manager databases 

and then exported to IEEE PQDIF and IEEE COMTRADE files 
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1.2 Power Quality Data Analyzer (PQDA) 
PQDA creates trends, histograms, and statistical summary tables of more than 125 steady-state 
characteristics, defined within the IEEE Std. 1159.3 PQDIF standard. It creates charts, event lists, tables, 
and indices to analyze voltage sags/dips, swells, and interruptions. PQDA interfaces with Microsoft Word 
to create summary documents automatically and allows the user to filter invalid measurements from final 
analysis. 
  
1.2.1 Steady-State Data Log Analysis 
PQDA creates trends, histograms, profiles, and statistics for any steady-state voltage, current, power, and 
energy quantity. The data for trend and histogram charts can be filtered to exclude invalid measurements. 
Each trend can become an event timeline by plotting any associated waveform or rms variation 
measurements as tick marks along the x-axis. 
 
Each trend and histogram can be copied automatically into Microsoft Word documents, exported to HTML 
documents with related graphics files, or sent to a printer. 
 
Users can view trends and histograms for the minimum, average, maximum, standard deviation, count, and 
any percentile for steady-state data in intervals of minutes, hours, days, weeks, months, and years. 
 
Figure 2 below shows the data flow for the Power Quality Data Analyzer. 
 

 

PQDA
Power Quality Data 

Analyzer 

Configuration, Site, and 
Event Data 

Reports GigaSoft
Trends 

Histograms 
Correlations

Power Quality 
Database 

 
Figure 2: Power Quality Data Analyzer − Data Flow 

 
PQDA provides dialogs that allow you to select part or all of the data in the Power Quality Database for 
analysis. Once you make a data selection, you can choose from a number of predefined reports. PQView 
provides reports to view disturbance and steady-state data in a number of ways.  For example, different 
reports are provided to view disturbance data in tabular listings, CBEMA plots, ITIC plots, and histograms.  
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1.3 PQWeb 
 
PQWeb is a web server application for viewing and reporting power quality data, stored in a PQView 
database. PQWeb opens databases in read-only mode but never alters any database. Its use is limited to 
retrieving data for viewing and analysis. 
 
PQWeb provides the following functionality: 
 
• Event listing of transients and RMS variations 

• Waveform plotting and zooming 

• Summary report of RMS variations with magnitude-duration plots 

• Trend plots and histograms of steady-state samples 

• Monitor availability report 

• Download files in Power Quality Data Interchange Format (PQDIF) 

Users require an Internet browser compliant with JavaScript 1.3, and with Portable Network Graphics 
(PNG) format.  Supported versions include Internet Explorer 4.72 or later, and Netscape Navigator 4.72, or 
later. 

Table 1: Platform Requirements 
 
Computer and Processor Personal computer with an Intel Pentium 233-

megahertz (MHz) or faster processor (Pentium III 
recommended.) 
 

Operating System¹ Microsoft Windows® 2000 with Service Pack 3 
(SP3), Windows XP, Windows 2003. 

Additional Software² Required: Microsoft Access 2000, Access 2002 
(Access XP), or Access 2003 (runtime versions 
acceptable).   
 
Optional: Microsoft Word 2000, 2002, or 2003; 
Microsoft Excel 2000, 2002, or 2003; TOP® The 
Output Processor, Microsoft SQL Server 2000 or 
2005. 

Memory 128 MB of RAM or greater.
Disk Space³ 45 MB.
Display Super VGA (800 × 600) or higher-resolution 

monitor.
  
1 PQView can also be run on the following operating systems: Microsoft Windows 95, Windows 98, 
Windows 98 Second Edition, Windows Millennium Edition (Windows Me), Windows NT 4.0 with Service 
Pack 6 (SP6).  Effective June 30, 2005, the only Microsoft operating systems supported by PQView 
software is Windows 2000, Windows XP and Windows Server 2003. Because Microsoft no longer supports 
Windows 95, 98, NT, and ME, the anti-virus software companies (for example, McAfee, Norton) no longer 
provide updates or support for the anti-virus definitions. Therefore PQView no longer officially supports 
these older Microsoft operating systems. 
 
2 PQView is compatible with both the commercial and free runtime version of Microsoft Access. 
 
3 The disk space requirement does not include space needed for user databases, temporary files, and 
supporting system files. 
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1.4 Using PQView: A Three-Step Process 
 
Using PQView is a three-step process:   
 
1. Use the PQDM program to create a new Power Quality Database from your existing data files. New 

database files are created from template files, which contain the table structure, but no data. 
 
• Microsoft Access  Users: For steps, see the section “Creating a Power Quality Database” on page 

2-9. 
• Microsoft SQL Server 2000 Users: For steps, see the section “Creating a New PQView Database 

with Microsoft SQL Server 2000” on page 4-1. 
• Microsoft SQL Server 2005 Users: For steps, see the section “Creating a New PQView Database 

with Microsoft SQL Server 2005” on page 5-1 
 

2. Use PQDM to import data into the Power Quality Database. For steps, see the section “Managing Data 
from Data Sources” on page 2-11. 
 

3. Once you have created a database, you can run the PQDA program to generate reports, trend plots, 
histogram plots, and correlation plots from the database. For steps, see the sections in  
“Using the Power Quality Data Analyzer,” starting on page 3-1. 
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2  Using the Power Quality  
Data Manager 

This section provides detailed steps for completing the following key tasks in the Power Quality Data 
Manager (PQDM): 
 

• Navigating PQDM 
• Creating a Power Quality Database 
• Opening and Closing Existing Power Quality Databases 
• Managing Data from Data Sources 

 
After creating or importing a data source, proceed to the next major section, “Using the Power Quality Data 
Analyzer” which explains how to generate reports, trend plots, histogram plots, and correlation plots from 
the database. 
 

2.1 Navigating PQDM 
This section describes the commands that are available through PQDM's menus.  The commands available 
change with the active window.  For example, the commands used to open a database are only available 
when the main window is active. In addition, many of the commands are simply passed by PQDM to the 
Microsoft Access engine for processing (for example, the Edit menu commands). 
 
2.1.1 File Menu Commands 
The table below describes the commands available from the PQDM File menu. 
 

Table 2: File Menu Commands for the PQDM 
New Power Quality Database  Creates a new, empty Power Quality Database.  

The program uses a template file that contains 
empty tables corresponding to all tables that 
PQDM and PQDA use in a Power Quality 
Database.  The normal template file is called 
PQDM.PQT and is located in the directory where 
you installed Access.  A Power Quality Database 
created with this template initially has no site data 
in the Sites Table; you must enter information 
about your sites into the Sites Table before you can 
load data into the database. 
 

Open Power Quality Database  Opens an existing Power Quality Database file 
which you have created using the New Power 
Quality Database command described above.  
 

Close Power Quality Database  Closes the Power Quality Database file that is 
currently open.  After using this command, you 
will have to use the New or Open commands to 
connect to another database file. 
 
 

Data Sources  
 

Opens the Data Source dialog.  From this dialog 
you can create, setup, activate, deactivate, delete, 
and take ownership of data sources.  
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Start Background Processing   Enables PQDM’s background processing tasks, 
including alarm processing, poll request processing 
(unscheduled import operations), and scheduled 
data import operations.   
 
This command is active by default. 
 

Stop Background Processing  
 

Disables PQDM’s background processing.  These 
menu items are enabled or disabled, as appropriate, 
to reflect the current background processing state.  
The background processing state is remembered 
for each database.  This last state for a specific 
database is restored whenever PQDM is started or 
a Power Quality Database is opened.  Exit closes 
all database files and exits from the Access system. 
 

Database Connections  Use this form to create, open, edit, and delete 
connections to databases containing PQView 
measurements. If you enable a database for 
background scanning, then the PQ Data Manager  
connects to the database automatically when a data 
source in that database needs to be imported 
according to its schedule. 
 

ODBC Data Sources  Opens the dialog box for the ODBC Data Source 
Administrator with tabs for the User DSN, System 
DSN, File DSN, Drivers, Tracing, and 
Connection Pooling. 
 
ODBC is a programming interface that enables 
applications to access data in database 
management systems that use Structured Query 
Language (SQL) as a data access standard. 
 

Transfer  Use this tool to copy measurements from one 
PQView database to another. Specify a source 
database from which to copy measurements, and a 
destination database into which the measurements 
will be copied. 
 
All records will be removed from the destination 
database before transfer begins. Supported 
PQView database versions include 2.x and 3.x. 
 

Import  To import measurements from a data source, select 
a data handler, select one or more sites, specify a 
date range, and click the Import command button. 
Leave either data range text boxes empty to leave 
that date range limit unbound. If you select no sites 
in the ‘Select Sites’ list box, all sites will be 
imported. 
 

Export  Use this command to export sites, site properties, 
and documents. You also can export to PQDIF and 
export events to COMTRADE.  
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Translate  Translates INST to PQDIF files. 
 

Print Setup  Provides print-setup options for margins, page, and 
columns.   
 

Print Preview  Allows you to preview documents before printing. 
 

Print  Opens the Print dialog box. 
 

Database Properties  Provides database properties, including database 
information (version, site count, source count, 
event count) and file information (name, location, 
size, and date). 
 

Version Information  Provides file version info for files, libraries, and 
controls used by PQView. 
 

Exit  Lets you quit PQDM. 
 
2.1.2 Edit Menu Commands 
From the Edit menu, standard editing commands are available to cut, copy, paste, find, and replace when 
you are entering text into any PQDM Selection windows. Commands are also available for selecting and 
deleting records. The Go To selection allows you to navigate through the various site, disturbance, or 
steady-state records. 
 
 
2.1.3 View Menu Commands 

The table below describes the commands available from the PQDM View menu. 
   

Table 3: View Menu Commands for the PQDM 
Site Selection  Opens the Sites window, where you can view, edit, 

or add site data to the Sites Table. Site data consists 
of site name, site description, data source for this 
site, sorting rank, self-reference to the parent record 
(for creating a hierarchical list), the UTC offset, the 
flag for  Daylight Saving Time, connection time, 
Nominal base voltage (for example, 12000 V),and 
Nominal fundamental frequency (that is, 50 or 60 
Hz).  

 

Events  Opens the Events window, which allows you to 
view tables of all of the data for individual event 
records, including general event data, properties, 
triggers, RMS variations, transients, and trends.   

 

Steady-State Measurements Opens the Steady-State Measurements window, 
which allows you to view tables of all of the data 
for individual steady-state measurement records, 
including site name, source name, channel name, 
start time, start time Offset, end time, end time 
Offset, number of samples, and samples. 
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Channels Opens the Channels window, which allows you to 
view all of the data for individual channel records, 
including channel name, description, rank, parent, 
and properties. 

  

Site Properties Opens the Site Properties window, which allows 
you to enter site properties, add site properties to all 
sites, add site properties to active sights, and 
import/export site properties from comma-
separated-vale (CSV) files.  

 

Event Properties Opens the Event Properties window, which allows 
you to enter event properties, including name, 
description, rank, and parent. 

 

Channel Properties Opens the Channel Properties window, which 
allows you to enter channel properties, including 
name, description, rank, and parent, as well as 
adding properties to active channels and adding to 
all channels. 

 

Source Properties Opens the Source Properties window, which allows 
you to enter source properties, including name, 
description, rank, and parent. 

 

Form or Datasheet View Allows you to toggle between the form and 
datasheet view when viewing properties.  

 

UTC Time Provides Coordinated Universal Time (UTC), based 
on the local computer’s time zone information and 
clock.   

Many data sources for PQView provide their time 
stamp in UTC. For those data sources, you must 
provide a UTC offset in PQView’s Site table to 
display a measurement in local time. 

  

Standard Time Opens the Standard Time Zone Information 
window. 

 

Daylight Saving Time Opens the Daylight Saving Time Zone Information 
window. 

 

Log Opens the PQDM log window. 
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Data Source Log Opens the PQDM log window for the data source. 

 

Background Processing Log Opens the Background Processing Log window, 
which shows background processing messages. This 
window does not have to be open for background 
processing to run. 

 
2.1.4 Format Menu Commands 
 
The Format menu contains standard formatting functions (for example, Font, Row Height, Column 
Width, etc.). 
 
2.1.5 Records Menu Commands 
 

The table below describes the commands available from the PQDM Records menu. 
 
Note: The following commands are used only when the Site, Event, or Steady-State windows are open:   
Filter, Sort, Apply Filter/Sort, Remove Filter/Sort, Save Record, Refresh, Requery, and Data Entry. 

 
Table 4: Record Menu Commands for the PQDM 

Filter Screens records by form, by selection, excluding selection, or 
according to specified criteria for filtering. 
 

Sort Arranges records either in ascending or descending order. 
 

Apply Filter/Sort Applies the filter after the criteria have been entered. 
 

Remove Filter Sort Disables the filter after the criteria have been entered. 
 

Save Record Saves changes to the current record. 
 

Refresh Refreshes screen. 
 

Requery Synchronizes the records on the window with the database. 
 

Data Entry Creates a new, empty record. 
 

Add RMS Variations Lets you select a site for which you can add an rms voltage 
variation record. Also lets you specify a time when the event 
occurred. You must specify an event duration for the RMS 
variation and a voltage magnitude for each phase. To complete 
the entry, click Add Record.  
 

Derive 
 
 

Opens the Add Derivations window with tabs for All Sites, 
Selected Sites, Virtual Line-Line, and Virtual Char, as 
described below: 
 
All Sites – These derivations are performed on all sites in the 
database. To manually derive the measurements now, specify a 
date range and click Derive Now. They can also be completed 
during data source import, if they are enabled in data source 
setup. 
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Selected Sites – These derivations are performed on the sites 
selected in the database. To manually derive the measurements 
now, specify a date range and click Derive Now. They can also 
be completed during data source import, if they are enabled in 
data source setup. 
 
Virtual Line-Line – Use this tab to create virtual sites with 
line-line voltages that are derived from the line-neutral voltages 
of other sites. Virtual line-line voltages configured on this tab 
will be derived automatically during data source import if that 
option is enabled in the data source setup. To manually derive 
the measurements now, select one or more sites, specify a date 
range, and click Derive Now. 
 
Virtual Char – Use this tab to create virtual sites with 
characteristic rms voltages that are derived from the line-
neutral voltages of other sites. Virtual rms voltages configured 
on this tab will be derived automatically during data source 
import, if that option is enabled in the data source setup. To 
manually derive the measurements now, select one or more 
sites, specify a date range, and click Derive Now.   
 

Derive XTF This is an optional add-in module for PQView RTF. 
 

Unpack Samples Opens a form which lets you unpack steady-state samples into 
the Steady-State Value and/or the Steady State Harmonic 
tables. This form can also delete unpacked samples. 
 

Correlate Events Opens a form which lets you correlate event records using 
system event records. 
 

Recharacterize Opens a form which lets you manually characterize or 
recharacterize already loaded events now. 
 
For CREG 024 Users: 
The user can now cancel the re-characterization process by 
using the <Esc> key. 
  

Set Load Flag Opens a form which you can use to set the b3 flag to true if 
either of the following conditions is met: 
 

• if the rms load current above a minimum value 
is found 

• if a manually entered rms variation or 
interruption is accompanied by a load 
interruption.  

 
It also removes the b3 flag from events that do not meet either 
of those two criteria.  
 

Delete Sites Opens the Delete Sites window, which lets you select one or 
more sites to delete from the database and then click Delete. 
The system deletes all measurements associated with the site.   
 

Copy/Merge/Delete Opens a tool that lets you copy, merge, or delete measurements. 
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Rescue Opens a tool that lets you modify data already loaded in the 
connected database. 

Execute Query Opens the Execute Query window, which lets you enter an 
action SQL statement in the text box. Also lets you run 
multiple queries. 
 

2.1.6 Tools Menu Commands 
 

The table below describes the commands available from the PQDM Tools menu. 
 

Table 5: Tool Menu Commands for the PQDM 
Compact and Repair Another Database Opens a window that lets you compact and repair 

another database. When a database becomes 
corrupt or your computer experiences a power 
outage or hardware problem, it may be necessary 
to repair a particular database. This command lets 
you perform this function. 
 

Compact and Repair This Database Opens a window which lets you compact and 
repair this database.  
 

Compact and Repair PQDA During routine use of PQView, the PQA.MDB 
database file may grow because Microsoft Access 
does not fully recover space used by temporary 
files. To recover this space and optimize 
performance, you can occasionally compress these 
database files. 
 

Rebuild SQL Server Indexes Rebuilds table indices when connected to a SQL 
Server database.  This command requires that you 
have database administrator (DBA) or database 
owner (DBO) permission to the database. 
 

Zoom Box This command can be used to open a popup “zoom 
box” in a modal window from the text boxes of 
most windows. 
 

IEEE COMTRADE File Viewer Opens the PQView COMTRADE File Viewer 
dialog box.  
 

Display Event Sample Count Provides a count of all waveform and/or rms 
samples stored in the open database. 
 

Display Steady-State Sample Count Provides a count of all steady-state samples stored 
in the open database. 
 

Fix 1159.3 Annex C Folder Opens a window that lets you browse for the 
1159.3 Annex C folder. Use this command to 
correct PQDIF folders that do not follow the IEEE 
Std 1159.3 Annex C recommendation. 
 

Add-Ins Opens a window that lets you select an add-in to 
open as well as view currently installed add-ins 
and reports. 
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Install Data Handler Opens a window that lets you specify optional data 
handlers. 
 

Microsoft Access Options Opens a window that displays tabs for the 
following Microsoft Access options: Pages, 
Advanced, International, Spelling, 
Tables/Queries, View, General, Edit/Find, 
Keyboard, Datasheets, and Forms/Reports.  
 

Options Opens the PQDM Options window with tabs for 
configuring General, SMTP, NodeLink, PASS, 
PES, PQDIF, and Exclude options. 

 
 
 
2.1.7 Setup Menu Commands 

The table below describes the commands available from the PQDM Setup menu. 
 

Table 6: Setup Menu Commands for the PQDM 
Standard End Macro Opens an obsolete tool, as all its major 

functionality is available in Data Source Setup or 
under the Records menu. This tool will not be 
available in future versions of PQView. 
 

PQNotify Messages Opens the PQNotify Messages window that lets 
you configure e-mail notification through these 
tabs: General, RMS Variation, Imbalance, No 
Data, Outbox, and Sent mail. 
 

COMTRADE MAP Opens a window that lets you map COMTRADE 
channels to PQView sites and channels. 
 

Fault Location To use this form, you must have the Radial fault 
Location Add-In Module or Reactance-to-Fault 
Add-In Module installed. 
 

Compliance Opens a window where you can set up compliance 
rules. 

 
2.1.8 Menu Shortcuts via the Keyboard 
Table 7Table 7 below shows the keyboard shortcuts available from the PQDM menus.  
 

Table 7: Menu Shortcuts via the Keyboard - PQDM 
Cut Ctrl + X 
Copy Ctrl + C 
Delete Del 
Find Ctrl + F 
Paste Ctrl + V 
Replace Ctrl + H 
Save Record Shift + Enter 
Select All Records Ctrl + A 
Undo Ctrl + Z 
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2.2 Creating a Power Quality Database 
PQDM allows you to create any number of Power Quality Database files. PQDM creates new database files 
from template files that contain the table structure, but no data. These template files are installed in your 
PQView directory and labeled with the “.PQT” extension. Additional templates are installed with Add-In 
packages. 
 
To create a new database, complete the following steps: 

1. From the File menu, select New Power Quality Database.   
The Select Template Database dialog box appears. (Figure 3Figure 3).   

 

 
Figure 3: Select Template Database Dialog 

 
2. Accept the most recent default template and click OK.   

The New Power Quality Database dialog box appears. 
3. Specify the name and directory for your new Power Quality Database (Figure 4Figure 4) and click 

Save.  Your new database automatically opens, as described in the following section, “Opening 
and Closing Existing Power Quality Databases.”  

 
Figure 4: Standard File Dialog 
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2.3 Opening and Closing Existing Power Quality Databases  
PQDM operates on one Power Quality Database at a time.   
 
To open and/or close a Power Quality Database, complete the following steps: 
 
1. From the File menu, select Open Power Quality Database to specify the database to process.  

The Open Power Quality Database dialog box appears, as shown in Figure 5Figure 5. 

 
Figure 5: Power Quality Database Dialog 

 
2. Specify the path to the database file to open.   
3. From the File menu, select the Close Power Quality Database command to close the currently open 

database. 
 
The PQDM window is always on the screen when you are using PQDM.  Its purpose is to display the status 
of the Power Quality Database that is currently in use.  
 

 
Figure 6: PQDM Main Window − Databases Closed 

 
Once you have opened a Power Quality Database, the PQDM window displays the directory path and file 
name of the database, the number of sites, events, and steady-state measurements, and the time range of the 
events and steady-state measurements (Figure 7Figure 7). 
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Figure 7: PQDM Main Window − Connected (Open) Database 

2.4 Managing Data from Data Sources 
 
Data is imported or loaded into a PQView database from data sources.  
 
A data source is a unique combination that consists of a type of data store format and location. For 
example, if you have data from a single Dranetz-BMI PCInfoNode® and data from a single ION 
Enterprise® (Schneider Electric ION Enterprise database), then you would have two databases. A data 
source can contain data for one or more sites.  PQDM allows you to create up to two billion data sources. 
 
To view the list of data sources, select the Data Sources command from the File menu.  This command 
opens the Data Sources dialog box (see Figure 8Figure 8).  From this dialog, you can create, setup, 
activate, deactivate, delete, and take ownership of data sources. To create a new data source, click New. 
 
Note: Background processing is disabled while this form is open.  
 

 
Figure 8: The Data Sources Dialog 

Data source information is stored in the current Power Quality Database, allowing you to configure each 
Power Quality Database independently. 
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In a network environment, it is possible to have a single Power Quality Database, receiving data from more 
than one computer, each running PQDM. 
 
From the Data Sources window, you can perform the following tasks, as described in the next sections: 
 
• Setting the Data Source Format and Path Specification 
• Setting Up  the Data Source 
• Importing Data from a Data Source 
• Activating or Deactivating a Data Source 
• Resetting a Data Source 
• Taking Ownership of a Data Source 
• Deleting a Data Source 
• Viewing and Editing Data 
• Viewing and Editing Site Data 
 
2.4.1 Setting the Data Source Format and Path Specification 
The Specification string is used to associate a data source with the actual data collected from an instrument.  
This string includes both data format information (that is, what type of instrument created the data) and 
data location information (that is, where is the data located). 
 
This Data Store Format dialog box appears after you click New in the Data Sources dialog box (see 
Figure 9Figure 9).  From the Data Store Format dialog box, you can view the format selections for 
instruments supported by PQDM and then select which type of event files to process.  Select one of the 
listed formats and click OK. 
 

 
 

Figure 9: Data Store Format Dialog 
 
After you have selected a data format using the Data Store Format dialog, a second dialog 
appears, where you select the disk and directory path, where the files you want to import are 
located.  The exact appearance of this dialog varies with the specific format selection.  
 
The following examples show the Import Source Path dialog box for two different data store 
formats.  
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Figure 10Figure 10 below shows the dialog that appears if you select Dranetz-BMI NodeCenter® 
Database as the data format.  
 

 
 

Figure 10:  Import Source Path Dialog for Dranetz-BMI NodeCenter Database 
 
In the Import Source dialog box, enter the file name and click Open.  The Data Source Setup dialog box 
opens. 
 
Figure 11Figure 11 below shows the dialog that appears if you select Dranetz-BMI 
InfoNode®/DualNode/PCInfoNode as the data format. 
 

 
Figure 11: Specify InfoNode Connection Dialog for Dranetz-BMI 

InfoNode/DualNode/PCInfoNode 
 
Note: If the PCInfoNode service is running on the same computer that is running PQView, then you can 
use 127.0.0.1 for the IP address. 127.0.0.1 is the standard IP address used for a loopback network 
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connection. The default password for the InfoNode user name guest is password. After you Enter the IP 
Address, user name, and password, click OK. The Data Source Setup dialog box opens. 
 
For CREG Report Users: 
An option is available when downloading directly from InfoNodes and PCInfoNodes.  Status observation events 
are now added to the PQView database as interruption events.  This option is not enabled for new data sources 
unless your computer has a locale country code setting set to Colombia. 
 
 
 
2.4.2 Setting Up the Data Source 
 
The Data Source Setup dialog (Figure 12Figure 12) opens whenever you create a new data source or select 
an existing data source and click Setup.  This dialog box also appears by double-clicking on a data source 
in the Data Sources list box.  
 
For CREG Summary Report Users: 
When creating a new data source for computers configured with a locale country code set to Colombia, the 
checkbox to create CREG summary reports is marked automatically and the output folder is set automatically to 
the PQView application folder (for example, C:\Program Files\PQView30\). 
 
Setting up a new data source includes the following tasks, as described in the next sections: 
• Setting the Data Source Name 
• Scheduling Imports 
• Enabling Automatic Data Source Processing 
• Specifying Start and End Macros 
• Setting the Import Data Selection 
 
 

 
Figure 12: Data Source Setup Dialog 
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2.4.2.1 Setting the Data Source Name 
In the Name field , enter the data source name. 
 
Each data source must have a unique name.  This name is used to identify the data source and is displayed 
whenever operations are being performed on the data source.  The name can be any unique string less than 
32 characters in length. 
 
 
2.4.2.2 Scheduling Imports 
You can schedule imports to run periodically at specific times of the day and/or day of the month.  To 
specify a time to start an import, enter date and time information into the Start poll at box.  If the date is 
omitted, the current date is assumed.  Assuming that this data source is enabled and that background 
processing is enabled, an import is started at the date and time specified.  
 
The Repeat every box allows you to schedule subsequent import operations to be performed at regular 
intervals.  Import operations are repeated at the interval specified in the text box and units list box.  For 
example, if an interval of 1 (one) and a unit of “Days” is selected from the list box, an import operation 
would be repeated every day, at the time specified in the Start poll at box. 
 
2.4.2.3 Enabling Automatic Data Source Processing 
The automatic import can not occur unless you select Start Processing from the File menu. Use the 
checkbox on the main menu or select Start Background Processing from the File menu to enable 
automatic data source processing. 
   

 
Figure 13: Selecting Start Background Processing from the File Menu to 

enable Automatic Data Source Processing 
 
When background processing is enabled, PQDM checks to see if it is time to import a data source once 
every 10 seconds. 
 
 
2.4.2.4 Specifying Start and End Macros 
Macros can be run before and after each import operation.  The Start Macro and End Macro list boxes 
allow you to specify the macro that is to be run before and after an import operation, respectively.   
Note: The End Macro is run only if the import operation is successful.  If these fields are blank, then no 
corresponding macro is run. 
 
An included macro that is useful when specified as an End Macro is named “Delete Future Records.”  
When run, it automatically deletes measurements that are more than three days (72 hours) in the future.  
This macro is useful for automatically filtering bad measurement dates from your database. 
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2.4.2.5 Setting the Import Data Selection 
After you have successfully configured a data source specification as described in the preceding sections, 
the list of sites available from the data source are displayed in the Sites list box.  You can specify to import 
all sites , or you can mark specific sites in the list by clicking on the check-box, located to the left of each 
site’s name, and then choose to import data from the marked sites.  Sites that do not already exist in the 
database are automatically added during an import operation.  The import operation fills in the siteID, 
description, and data source values in the Sites Table for the new site.  You must manually enter any 
additional Sites Table information you require. 
 
The Date and Time Range section lets you specify a time range for which events will be imported.  Any 
event files that are found to have occurred outside this time range will be ignored.  You can enter any valid 
dates and times into these edit boxes.  The following Date and Time Range options are available:  

• All to select all data − All dates found in the data source will be imported. This option is usually 
wasteful if performed more than once. 

• New Data − This option is more recent than the latest event (per site) currently in the database. It 
is useful when importing data on a daily basis. Use the but not older than text box to prevent 
loading of very old data. 

• From/To − Specify the UTC date range to import. 
• New Files in Each Site’s Data Folder. 

 
In the Data Reloading box there are two available options: Replace Previously Loaded Data and Leave 
Previously Loaded Data Unchanged.  If for any reason you want to change the properties of the data that 
have been loaded and include other properties, then select Replace Previously Loaded Data.  In this way, 
the old data that has been loaded will be deleted and replaced by the same data with the added 
characteristics.  The advantage to selecting Leave Previously Loaded Data Unchanged is this—at some 
time there may be data which duplicates the data already imported. If this feature is not selected, the import 
process will be slowed because time must be taken to delete the already imported data and replace it with 
the new data. 
 
Note: Usually you want to leave previously loaded data unchanged. 
 
2.4.2.5.1 For CREG 024 Report Users: Creating and Exporting CREG Summaries and 

Downloading Status Events  
There are many other options that can be completed after a data source import completes.  For example, 
under the Export tab, the user can specify export folder locations, where IEEE COMTRADE files can 
exported for new events, or where CREG 024 summaries should be written.  When exporting CREG 
summaries, the last fourteen days of data will be exported to CSV files automatically.  To create CREG 
summaries for historical data, use the CREG reporting tool in the PQView PQ Data Analyzer. Select 
View>Reports & Tools and then click the CREG 024 link, under Report Writer.  
 
2.4.2.5.2 For CREG 024 Report Users: Downloading Status Events from Dranetz-BMI Info-Nodes  
 
To download status events from Dranetz-BMI InfoNodes, which are required for the feeder sites of a 
CREG 024 summary report, mark the “Status Events” check box under the Characteristic tab.  This check 
box is marked automatically when creating a data source on a computer, with its locale set to Colombia. 
 
2.4.3 Importing Data from a Data Source 
You can manually import the data by selecting a data source in the Data Sources list box and clicking 
Import. The PQDM Status window appears during the data source import. 
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2.4.4 Activating or Deactivating a Data Source 
Scheduled imports and poll requests (externally initiated imports) are only performed on active data 
sources.  Select the data source in the Data Source list box and click Activate or Deactivate. Under the 
Active column, you can note whether the data source is active or inactive. 
 
2.4.5 Resetting a Data Source 
To reset a data source, select it in the Data Sources list box and click Reset. 
 
Resetting removes the “Last Import Time” information, which is just as if the data source had never been 
imported. 
 
2.4.6 Taking Ownership of a Data Source 
Normally, the Data Source list box only displays the data sources that are “owned” by your computer.  
Clicking on the Show All check-box causes the data sources for all computers to be displayed. 
 
As you scroll through the list of data sources, notice that the controls for manipulating a data source are 
enabled only for those data sources that belong to your computer.  To take ownership of a data source, 
select it in the list box and click Own.  Your computer is now responsible for the data source.  The 
computer that previously owned the data source no longer process it. 
 
2.4.7 Deleting a Data Source 
To delete a data source, select it in the Data Sources list box and click Delete. 
 

2.5 Viewing and Editing Data 
Once you open a database, you can view and edit the data within that database through windows.  Separate 
windows are provided for viewing and editing site information, event data, and steady-state measurements.   
 
To open one of these windows, choose the appropriate command from the View menu or double-click on 
the corresponding icon in the PQDM window. 
 
2.5.1 Viewing and Editing Site Data 
The Sites window allows you to view the site description records from the database.  In addition, use this 
window to enter new site descriptions into the database and to edit site descriptions. 

 
Figure 14: Sites Window 
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Site information is displayed one site at a time.  The records navigation commands are used to move from 
site to site.  Filters can be used to select a specific set of sites for processing. 
 
Fields in the Sites window are described in the table below. 
 

Table 8: Fields in the Sites Window 
Field Purpose 
Site name Enter the name of a data gathering site. 

 
Description Enter any relevant information. 

 
Source Name Select the data source for this site. 

 
Rank Enter a sorting rank that overrides the name for displayed values. 

 
Parent* A reference to the parent site record.  Used to create a hierarchy for the sites.  

For CREG 024 Report Users: 
This field is also used in the CREG 024 report to link a site that only records 
status measurements (for example, the “feeder site” or “virtual site”) to another 
site that has power quality measurements (for example, the “bus” or “master” 
site). 
 

UTCOffset* Number of hours to add to a measurement time stamp to convert it to local 
standard time.  Universal Coordinated Time is an ISO standard. 
 

Use DST Correction Daylight Savings Time. Checking the box activates Daylight Savings Time.  
PQView uses Windows localization information to determine the start and end of 
Daylight Savings Time. 
 

Connection Type** From the list box, select the type of connection (for example, three-phase three-
wire, three-phase, four-wire, and so on). 
 

Nominal BaseVoltage (V)** Enter the nominal base voltage in volts. 
 

Nominal Fundamental 
Frequency** 

Enter the nominal fundamental frequency in hertz (for example, 50 or 60). 
 

Properties View the list of properties associated with the site. 
 
2.5.2 Viewing and Editing Sites Sub-Window − Properties 
To edit or add properties to the sites, double-click on the Site icon or select Sites from the View menu.  The 
Sites window opens. 

                                                           
* Note that both the “parent” and “connection” fields contain a drop-down list to facilitate your selection. 
** It is important that both the nominal base voltage and nominal fundamental fields be specified, as some 
reports dealing with normalization may not function correctly without these values. 



Electrotek Concepts, Inc. 2-19

 

 
Figure 15: Sites Window 

 
At the bottom of the Sites window, properties are added by entering a name that identifies the property in 
the Name field. 
 

 
Figure 16: Entering a Property Name in the Name Field 

 
To edit or specify more information about the property, place the cursor on the name of the property to be 
edited and double-click.  The Site Properties window opens. 
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Figure 17: Site Properties Window 

 
In this window, the name of the property may be edited or changed.  A description giving more information 
about the property may be added.  A rank may be applied to the property to affect its order in the list of 
properties.  Assigning a rank to a property gives the property a value or weight.  For example, a property 
with a lower rank appears before a property with a higher rank. 
 
Another property may be designated as the “parent” for a property.  By associating properties to “parents”, 
a hierarchy may be developed within the list of properties. 
 

 
Figure 18: Associating a Property to a "Parent" 

 
In the example, you can see that all of the properties are associated with Event1.  The properties A, B and E 
are of equal rank and associated with Site1.  Given equal rank, the properties are then sorted in ascending 
order, alphabetically.  Property C and D are of equal ranking, but in this case are associated directly with 
Property B. Property B has been designated as the “parent” of Property C and D.   
 

 Hierarchy 
 

 Site1 
  Property A 

  Property B  
   Property C 
   Property D 

  Property E 
  

Figure 19: Property Hierarchy 
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3  Using the Power Quality 
Data Analyzer 

The Power Quality Data Analyzer (PQDA) provides reporting and analysis functions, using Power Quality 
Databases created by the Power Quality Data Manager.  
 
 
This section provides detailed steps for completing the following key tasks in the Power Quality Data 
Analyzer (PQDA): 
 

• Navigating the PQDA 
• Opening a Power Quality Database in PQDA 
• Selecting Data 

o Selecting a Group of Sites 
o Selecting the Date and Time Range 

• Analyzing Data 
• Creating Reports 

 

3.1 Navigating the PQDA 
 
This section lists the commands that are available in each menu when PQDA is running, and its main 
window is active.  When you perform certain functions, such as displaying a report in Preview mode, the 
standard Access menus described in the Access manual are active, rather than the custom PQDA menus. 
 
3.1.1 File Menu Commands 
The File menu is used to open or close a Power Quality Database for use with PQDA.  The Open Power 
Quality Database command opens a database file for use by PQDA.  You must first create the database 
files using PQDM and load data into them, before you can open and use them with PQDA.  The Close 
Power Quality Database command closes the currently selected database file.  Selecting Exit closes the  
database system.  
 
Additional file menu options consist of standard selections for page setup, print preview, and print as well 
as a Send to command for selecting the format of your file output.  
 
From the File menu, you can also select Database Properties and Version Info for database, file, and 
version information.  
 
3.1.2 Edit Menu Commands 
The Edit menu allows you to perform standard Windows editing functions, such as Copy, Cut, Paste, and 
Delete when you are entering text into any of the PQDA Selection Windows. The Go To selection allows 
you to navigate through the various site, disturbance, or steady-state records. 
 
3.1.3 View Menu Commands 
Use the commands in the View menu to open the data selection windows and the analysis windows.  If you 
are using the commercial version of Microsoft Access, you can also open the Access Database window 
from this menu. 
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The table below describes the commands available from the PQDA View menu. 
 

Table 9: View Menu Commands for the PQDA 
 

Site Selection Opens the Select Sites window where you can select 
sites to include in reports. 
  

Date & Time Selection Opens the Select Date and Time window where you 
select the date and time range. 
 
Only measurements greater than or equal to the 
From date, and less than the To date, will be 
included in analysis reports. Leaving the From or 
To fields blank will leave that date limit range 
unbound. 
 

Events Opens the PQ Event Viewer window, where tabs 
are available for viewing the event list, setting 
preferences, and selecting query shortcuts. 
 

Monitor Availability Opens the Monitor Availability Reports window, 
where you can select sites to analyze, select a date 
range, select a report, and then click the print-
preview to open a report. 
  

RMS Variations Opens the RMS Voltage Variations Analysis Panel, 
where tabs are available for Charts and Reports, 
Report, SARFI, Preferences, and Event Filters. 
 

Trends Opens the Steady State Trends window, where tabs 
are available for Select, Formats, Profile, 
Compliance, Aggregation, Interval, Operations, 
Filters, and Options. 
 

Map Opens the PQView Site Map window, where you 
can select sites, the date range, select actions for 
showing voltage sags and interruptions, and open 
ESRI Shapefiles. 
  

Report Writer Opens the Report Writer window, where you can 
create, edit, and run configurations. 
 
Each report can have different configurations using 
combinations of check boxes and text boxes.  
 
Available tabs include General, Events, Event 
Filters, Metering, Imbalance, Harmonics, 
Flicker, Aggregation, and Compliance. 
  

Report & Tools Opens the Reports & Tools window with links 
available under the following categories: Viewers, 
RMS Variations, Steady-State Analysis, Report 
Writer, Monitor Availability, System Events, and 
Report Browser. 
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Report Browser Opens the Report Browser window, where you can 
select or mark report(s). After the report(s) has been 
marked or selected, you can view or print an 
individual report or batch print a number of reports. 
  

Form View or Datasheet View Lets you toggle between form or datasheet view 
when you view reports. 

 
 
 
3.1.4 Format Menu Commands 
The Format menu contains standard and other formatting functions (for example, Font, Datasheet, Row 
Height, Column Width, Hide Columns, Unhide Columns, and Freeze Columns). 
 
3.1.5 Records Menu Commands 
The following selections are used only when forms displaying more than one record at a time are open.  
 

Table 10: Record Menu Commands for the PQDA 
Filter Provides the following options: Filter by Form, 

Filter by Selection, Filter Excluding Selection, and 
Advanced Filter Sort. 
 

Sort Arranges records either in ascending or descending 
order 
 

Apply Filter/Sort Applies the filter after the criteria have been 
entered. 
 

Remove Filter/Sort Disables the filter after the criteria have been 
entered. 
 

Save Record Saves changes to the current record. 
 

Refresh Allows you to refresh the screen. 
 

Data Entry Creates a new, empty record. 
 

   
 
3.1.6 Window Menu Commands 
The Window menu is used to select the active window if more than one window is open.  It can also be 
used to arrange and close windows.  It functions the same way as in other standard Windows applications. 
 
3.1.7 Tools Menu Commands 

The table below describes the commands available from the PQDA Tools menu. 
 



Electrotek Concepts, Inc. 3-4

Table 11: Tools Menu Commands for the PQDA 
Compact and Repair PQDM During routine use of PQView, the PQDM.MDB 

database file may grow because Microsoft Access 
does not fully recover space used by temporary 
files. To recover this space and optimize 
performance, you can occasionally compact and 
repair these database files. 
 

Demo Runs a demo showing events for the selected sites 
and/or date range. 
 

Zoom Box This command can be used to open a popup “zoom 
box” in a modal window from the text boxes of 
most windows. 
 

Microsoft Access Options Opens a window that displays tabs for the 
following Microsoft Access options: Pages, 
Advanced, International, Spelling, 
Tables/Queries, View, General, Edit/Find, 
Keyboard, Datasheet, and Forms/Reports.  
 

Options Opens the PQDA Options window with tabs for 
setting General, Charts, Color, event roll, 
quantity labels, characteristic labels, and other 
labels. 

 
 
 

3.1.8 Menu Shortcuts via the Keyboard 
 
The menus for the Power Quality Data Analyzer include the following keyboard shortcuts.  
 

Table 12: Menu Shortcuts via the Keyboard - PQDA 
Cut Ctrl + X 
Copy Ctrl + C 
Delete Del 
Find Ctrl + F 
Paste Ctrl + V 
Replace Ctrl + H 
Save Record Shift + Enter 
Select All Records Ctrl + A 
Undo Ctrl + Z 

 
 
 

3.2 Opening a Power Quality Database in PQDA 
The PQDA window appears when you start the Power Quality Data Analyzer, and it remains on the screen 
at all times while you are using PQDA, although it may be covered up by other windows.  
 
Power quality databases housed in Microsoft SQL Server are opened by specifying ODBC Databases in the 
Files of type box.  A standard Select Data Source dialog box appears.  (You must have an ODBC Data 
Source Name configured on your client machine in order to access SQL Server databases.) 
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The PQDA window always shows the current status of the Power Quality Database that is being used by 
PQDA.  If no Power Quality Database is open, the window displays a message, telling you how to open a 
database by selecting the Open command from the File menu (Figure 20Figure 20). 
 

 
Figure 20: PQDA Main Window with No Database Connection 

 
Once you open a Power Quality Database, PQDA displays the path and file name of the database, along 
with the number of sites, events, and steady-state measurements contained in the database.  The date and 
time ranges of event and steady-state data are displayed in the PQDA window (Figure 21Figure 21). 
 

 
Figure 21: PQDA Main Window showing a Connected Database 

 
In addition, the Sites icon in the main window acts as a shortcut to activate other PQDA features.  Double-
click on the Sites icons, and the respective selection windows are displayed. 

3.3 Selecting Data 
Three data selection windows are available to help you select sites, date ranges, and event types for 
generating analyses and reports.  Selections made using these windows are persistent, so the selections you 
make here remain in effect until you use the window again to change your selections.  Also, the selections 
made using these windows apply to many analysis and reporting functions in PQDA.  This means that you 
can select a group of sites and a date range, and then run several different reports, without having to 
reselect the same sites or date range. 
 
3.3.1 Selecting a Group of Sites 

 
The Select Sites window can be activated by double-clicking the cursor on the Sites icon in the window, or 
by selecting Site Selection from the View menu.  This window is used to select a group of sites to be 
included in a report or other analysis (Figure 22Figure 22).  
 
Use this window to select the sites to include in reports. Select the site selection mode. If you want to select 
only certain sites, then select one or more sites from the site list box. You can limit the sites displayed in 
the site list box, by using one or more site property filters.  

A site property is a number, string, or any binary object that you want associated with the site. To add a site 
property, select from the drop-down list box of available site property names.  There will be no useful 
properties for a new database, unless you manually add them from the PQView Power Quality Data 
Manager.  
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If you do not select any sites from the site selection box, then all sites will be selected.   
 
 

 
Figure 22: Select Sites Window 

 
Note: 
Wildcards may be used to match site property values.  For example, to match all site property values that 
begin with “North,” then specify “North*” for a Site Property Value.  This would, for example, match both 
“North” and “Northwest.”  The table below shows wildcards that you can use to match site property values.  
 

Table 13: Wildcard Character Patterns Available with Site Property Filter 
Wildcard Character Matches Examples 

? Any single character “a?a” matches “aaa,” “a3a,” and “aBa” 
* Zero or more characters “a*a” matches “aa,” “aBa,” “aBBBa” 

“ab*” matches “abcdefg,” and  “abc” 
# Any single digit (0–9) “a#a” matches “a0a,” “a1a,” and “a2a” 

 
 
3.3.2 Selecting the Date and Time Range 
To activate the Date and Time Selection window, select Date & Time from the View menu. The Select 
Date and Time window opens. (Figure 24Figure 24)  Here, you can specify the starting and ending dates of 
the time range for your reports or analysis (Figure 24Figure 24).  You can enter any starting and ending 
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dates in the edit boxes at the bottom of the window.  For convenience in setting up standard reports, the 
window also provides buttons, which let you easily select standard time ranges, such as last month, last 
week, this quarter, and so on. 
 

 
Figure 23: View Menu 

 

 
Figure 24: Select Date and Time Window 

 
If you use the text boxes at the bottom of the Select Date and Time window to enter start and end dates, 
you can enter a time along with the date to further narrow the range. The format of the date you enter in the 
date range filter window depends upon the regionalization information of the computer you are using. 
 
Note: When you select the date and time range, remember that the analysis reports include measurements 
only greater than or equal to the From date, and less than the To date. For example, to set the time range to 
the entire month of May, including May 31st, enter May 1, 2007 in the From text box, and June 1, 2007 in 
the To text box.   
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3.4 Analyzing Selected Data 
PQDA’s main function is to allow you to view Power Quality Data in meaningful visualizations.  To this 
end, it provides powerful tools for analyzing the data you select.  These include tools to construct and 
display correlation plots, histogram plots, trend plots, and reports that can combine graphics and tabular 
data.  
 

3.5 Creating Reports  
 
Reports allow you to combine graphics and tabular data that can be grouped, sorted, and summarized (for 
example., sum, minimum, maximum, and average).  Using the capabilities found in Microsoft Access, you 
can create your own reports.  Also available in Reports & Tools is the ability to create histogram, 
correlation, and trend plots. 
 
To display helpful shortcut links to all the reports and analysis tools available in PQDA, select Reports & 
Tools from the View menu.  The Reports & Tools window opens (Figure 25Figure 25). 
 

 
Figure 25: Reports and Tools Window 

 
Subsequent sections describe frequently used reports and tools, available from the Reports & Tools 
window shown above, as follows: 
 

• PQ Event Viewer 
• RMS Voltage Variations Analysis Panel 
• Harmonic Statistics 
• Monitor Availability Reports 
• Conformance with CREG 024 2005 Report Window 
• Report Writer 
• Report Browser 
• Single-Site Statistical Calculator (available from the Report Browser) 
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3.5.1.1 PQ Event Viewer 
 
To access the PQ Event Viewer, start the Power Quality Data Analyzer. Double-click on the Events icon in 
the main window or select Events from the View menu. The PQ Event Viewer window opens. (See Figure 
26Figure 26).  
 
An additional way to access the PQ Event Viewer is to select Report Browser from the View menu to 
display the Report Browser dialog box. Select Viewer as the Report Type, and then select Event Viewer as 
the Report.  
 

 
Figure 26:  PQ Event Viewer - Selection Dialog Box 

 
 
The PQ Event Selection dialog box contains a summary of the events. It displays the site name with the 
associated event, the trigger phase, and the date and time of the event (Figure 26Figure 26). 
 
The summary of events is filtered by the sites and the date/time range specified (Figure 27Figure 27). To 
filter the selected sites, click Sites from the command buttons in the upper-left corner of the PQ Event 
Viewer window, and then define the site selection. To set the date/time range, click Date/Time Range from 
the command buttons in the upper-left corner of the PQ Event Viewer window, and then define the range.  
 
Note: The command buttons located in the upper-left corner of the PQ Event Viewer window let you select 
sites, select the date range, build an event list, sort the event list ascending by time, sort the event list 
descending by time, export the selected event to TOP, view characteristics of the selected event, view 
properties of the selected event, enable the system event edit mode, export events, view marked events in 
roll, view specific events by ID, and close the PQ Event Viewer. 
 
 
 

 
Figure 27:  Apply Filtering by Selecting Sites or Date/Time Range from the 

Command Buttons in the PQ Event Viewer 
 
After changing either filter, click OK to apply the changes to the list of events. 
 
To view an event in the list, select the event and click Go (Figure 28Figure 28). 
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Figure 28: Selecting an Event 

 
By default, all phases are shown or displayed (Figure 29Figure 29). 
 

 
Figure 29: Event Display 
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3.5.1.2 RMS Voltage Variations Analysis Panel 
To access the RMS Voltage Variations Analysis Panel, select RMS Variations from the View menu. The 
RMS Voltage Variations Analysis Panel window opens.  
 
You can also access the panel by selecting Reports & Tools from the View menu and then selecting the 
shortcut link to the panel.   
 
The RMS Voltage Variations Analysis Panel lets you select which categories of events to include in 
reports (Figure 30Figure 30).  For many reports, the selection must include all event types, because the 
report queries include their own filters for selecting the proper events.  For other reports, you can use this 
window to produce a specialized report, covering only a particular type or category of events.    
 
 

 
 

Figure 30: RMS Voltage Variations Analysis Panel 
 
Note: RMS variations can be selected by both voltage magnitude and event duration.  These categories are 
based on the definitions in IEEE Std. 1159-1995.  
 
The RMS Voltage Analysis Panel analyzes rms variations by graphs, statistics, and indices.  These 
analyses present a summary of the event itself.  The RMS Voltage Variations Analysis Panel permits 
customization in the creation of events, graphs, and reports.  It provides a list of report types that you can 
customize.  Note that not all reports are available for all selections.  These are the available reports: 
 
• RMS Variation Event List 
• RMS Variation  Event List (Spatial Grouping) 
• RMS Variation SARFI Event Analysis 
• RMS Variation SARFI System Event Analysis 
• RMS Variation Sensitivity  Curves 
• RMS Variation Summary 
• RMS Variation Summary Sort by Site 
• RMS Variation Sort by Site (SDGE) 
• RMS Variation Frequency Index for Each Site 
• RMS Variation Magnitude Column Chart 
• RMS Variation Magnitude-Duration Column Chart 
• RMS Variation Magnitude-Duration Column Chart (DPQ) 
• RMS Variation Magnitude-Duration Contour Chart 
• RMS Variation Magnitude-Duration Statistical Summary 
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The RMS Variation Analysis Panel presents you with options for creating and customizing reports and 
plots, including the following command buttons, as described in the table below: 

• Site, Date, and Events 
• Graphic Displays  

 
Site, Date, and Events In the upper left-hand corner of the RMS Variations 

Analysis Panel are displayed the icons for site, date, 
and events.  To display these windows, click their 
respective icons.  By making selections in these 
windows, you can choose the sites, date, and define 
the event by duration or magnitude.  These windows 
are the same windows available from the View 
menu selections. 
 

Graphic Displays The icons at the lower left hand side of the RMS 
Variations Analysis Panel let you determine how to 
display the data (see Figure 31Figure 31 through 
Figure 38Figure 38). 
 

 
 
 

Command 
Button 

Display Type 

 

 
 

Figure 31: RMS Variation Magnitude Column Chart 
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Command 
Button 

Display Type 

 

 
Figure 32: RMS Variation Magnitude-Duration Column Chart 

 
 
 

 
Command 

Button 
Display Type 

 

 
Figure 33: RMS Variation Cumulative Magnitude - Duration Contour Chart 

This graph follows the procedure for making contour charts from IEEE Std. 1346-1998. 
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Command 

Button 
Display Type 

 

 
  

Figure 34: CBEMA Magnitude - Duration Scatter Plot 
The total number of events represented on the curve are counted as “Total Events.”  Events that fall below 
the lower CBEMA curve are counted as “Events Violating CBEMA Lower Curve.”  Events that are above 
the upper CBEMA curve are counted as “Events Violating CBEMA Upper Curve.” 
 
Note: In the upper-left corner, command buttons are available (see Figure 35Figure 35) to copy the scatter 
plot, export to Excel, save the scatter plot as a CVS file, print the scatter plot, edit properties, enable the 
Toggle Event Click Mode (which lets you click on a point to see the event and its temporally related 
events), enable the Toggle Event Zoom Mode (which lets you draw a box around groups of events to see 
them in an event roll), enable the Toggle Edit Mode (which lets you click on a point to delete it),  unzoom, 
toggle crosshairs, and close the scatter plot. 
 
From the drop-down list under the command buttons (see Figure 35Figure 35), you can also select and 
generate more than thirty additional report types. 
 

 
Figure 35: CBEMA Magnitude - Duration Scatter Plot – Command Buttons and 

Drop-Down List Box for Additional Reports 
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You can also right-click on the scatter plot to access commands for setting the viewing style, border style, 
font style, show the legend, numeric precision, plotting method, data shadows, grid options, include data 
labels, mark data points, undo the zoom, maximize the scatter plot, open the customization window, and 
export the scatter plot. 
 

 
Figure 36: Right-Click on Scatter Plot to Include Data Labels 
 

Command 
Button 

Display Type 

 

 
Figure 37: ITIC Magnitude - Duration Scatter Plot 
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The total number of events represented on the curve are counted as “Total Events.”  Events that fall below 
the lower ITIC curve are counted as “Events Violating ITIC Lower Curve.”  Events that are above the 
upper ITIC curve are counted as “Events Violating ITIC Upper Curve.” The deeper the voltage, the more 
likely a computer will trip off-line. 
 
 

Command 
Button 

Display Type 

 

 
Figure 38: Table Summary of RMS Voltage Variation Events 

 
To create a Microsoft Word report, select Report Writer from the View menu or select the General 
Report Writer shortcut from the Reports & Tools window. You must have Word 95, Word 97, Word 
2000, or Word 2003 installed on the computer to use the Report Writer.  The options and criteria selected 
from the RMS Variations Panel will be inserted into a report template and saved to a directory. For more 
information, see the “Report Writer” section on page 3-21. 
 

Command 
Button 

Display Type 

 

 
Figure 39: RMS Variation Frequency Index at Each Monitoring Site 
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Command 
Button 

Display Type 

 

Figure 40: RMS Variation Magnitude Scatter Plot 
 
 
3.5.1.3 Harmonic Statistics 
The Harmonic Statistical Summary form is a means to statistically summarize voltage and current 
harmonic distortion.  The characteristics that can be summarized include THDV, TDDI, and individual 
voltage and current harmonics.   
 
The main user dialog depicted in Figure 41Figure 41 can be found by using the PQDA menu bar command 
View>Reports & Tools and selecting from the shortcuts under the “Steady-State Analysis” report group. 
Click the shortcut link Harmonic Statistics. The Harmonic Statistical Summary dialog box opens. 
 
The Harmonic Statistical Summary tool is used to statistically analyze multiple measurements (see Figure 
41Figure 41).  From the form, clicking Voltage Chart opens a window that graphically summarizes 
voltage total harmonic distortion and selected individual voltage harmonics, as Figure 42Figure 42 shows. 
Clicking Current Chart opens a window that graphically summarizes the total demand distortion and 
selected individual voltage harmonics  (see Figure 41Figure 41). 
 



Electrotek Concepts, Inc.   3-18

 
Figure 41: Harmonic Statistical Summary 

 
The form offers a means to select a single site and a date range.  The form also allows the user to specify 
the specific harmonics that should be summarized.  For instance, harmonics under the 14th can be 
summarized by entering 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, and 13 in the table of selected harmonics.  Or, you 
can choose to summarize only odd harmonics by entering 3, 5, 7, 9, 11, 13, 15, 17, 19, 21, 23, 25, and 27 in 
the table of selected harmonics.  The limit on the harmonics that can be analyzed is based upon the 
sampling rate of the power quality monitor that recorded the data.  The specific harmonics entered in the 
table will be saved after the summary form is closed.  The summary charts can be computed for only a 
single phase at a time (that is, Phase A or AB, Phase B or BC, or Phase C or CA). 
 
The three statistics computed are the 5th percentile (CP05), arithmetic mean (average), and 95th percentile 
(CP95).  If the voltage summary is selected, statistics for voltage THD and the individual harmonics 
selected will be displayed.  These values are normalized to the fundamental voltage (V1).  If the current 
summary is selected, then statistics for current TDD and the individual harmonics selected will be 
displayed.  These values need to be normalized by IL, which in IEEE Std. 519-1992 is defined to be the 
average monthly maximum load current at a particular location.  The value can be supplied by the user by 
selecting “User-Defined” for Current Base or can be computed by PQView by selecting CP99.  If CP99 is 
selected, then the 99th percentile value of rms current is computed and then used to normalize the TDD and 
individual harmonics.  This computed or user-defined current base value appears on the summary form. 
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Figure 42: Voltage Total Harmonic Distortion and Selected Harmonics 

 

 
Figure 43: Current Total Demand Distortion and Selected Harmonics 

 
Current Total Demand Distortion can be normalized in one of two ways.  By default, the summary tool can 
compute the 99th percentile value of rms current for the selected site and selected date range.  This number 
can be used to normalize the value of total harmonic rms current to compute TDD.  Or, you can specify a 
value of current for normalization. 
 
3.5.1.4 Monitor Availability Reports 
 
Monitor Availability calculations indicate if a monitoring instrument is on-line or off-line on a given day. A 
meter is considered on-line if an event is found on a particular day or if rms voltage steady-state data is 
found. 
 
To open Monitor Availability Reports, select Monitor Availability from the View Menu or click the 
Reports link under “Monitor Availability” in the Reports & Tools window. The Monitor Availability 
dialog box opens. 
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Figure 44: Monitor Availability Reports  

Monitor Availability Reports are designed to list the number of days per month that each power quality 
monitor is online.  The following reports are available: 
 
• Summary Table 
• Summary Report 
• Summary Report by Month 
• Summary Report by Month with Totals 
• Unavailability Report 
 
These reports present a summary of the availability of each monitoring instrument on a monthly basis.  
Availability is based upon the existence of any measurement1 taken by the instrument for a given day.  Any 
day during a particular month that measurements were taken is one monitor day.  The report displays the 
number of monitor days and the number of triggered events.  It also reports the date range, as well as the 
availability of the monitor, expressed in percent (see Figure 45Figure 45). 
 

 
Figure 45: Example of the type of information in Monthly Report 

 

                                                           
1Any triggered measurement (that is, records in the the Event Table) or steady-state measurements on 
phase V RMS A or V RMS AB will qualify a monitor as being available for a given day. 
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The Monthly Availability Report with Totals is identical to the Monthly Report, with the exception that the totals for 
all categories are included (Figure 46). 
 

 
Figure 46: Example of Totals included in Monthly Report with Totals Report 
 
3.5.1.5 Conformance with CREG 024 2005 Report Window 

 
To view the CREG reporting tool, select View>Reports & Tools and then the CREG 024 Report link under the 
Report Writer section. 

 
You can select between an English user interface and a Spanish user interface.  By default, the user interface appears 
in Spanish on computers configured to be in a Spanish-speaking country. You can select the report start date and 
finish date using a calendar. You can also cancel the recharacterization process by using the <Esc>key. 
 

 
Figure 47: CREG 024 2005 Window 

 
3.5.1.6 Report Writer 
 
The Repot Writer creates Microsoft Word documents, based on templates that you can create, edit, and run through 
the tabs available in the Report Writer window. Available tabs for configuring Microsoft Word documents are as 
follows: General, Events, Event Filters, Metering, Imbalance, Harmonics, Flicker, Aggregation, and 
Compliance. Each report can have different configurations using combinations of check boxes and text boxes.  
 
To open the PQView Report Writer, select Report Writer from the View menu.  You can also click the General 
Report Writer shortcut link under the “Report Writer” heading in the Reports & Tools window. The Report Writer 
window opens (see Figure 48Figure 48). 
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Figure 48: Report Writer Window Lists Several Types of Reports Available 

 
To start creating customized Microsoft Word templates for your reports, use the check boxes on the General tab to 
create a summary report for all selected sites or to create a summary report for each selected site. You can also select 
the Table of Contents, Table of Figures, and Page Footer check boxes to specify whether your templates should 
include these standard document parts. In the Output Folder field, specify the location for your Microsoft Word 
documents. (The default output folder is the PQView application folder.) In the Template field, specify the location 
of the template to use for new documents. Use the buttons under the Report Configurations panel to the left of the 
window, to create a new report configuration and to save, rename, run, or delete a report configuration.  
 
3.5.1.7 Report Browser 
To display the reports available in PQDA, select Report Browser from the View menu.  The Report Browser 
window opens (see Figure 49Figure 49).  From this window, you can select a report to view or print.  Available 
report types are displayed in a drop-down list.  You can “mark” one or more reports and print them all with a single 
command. 
 

 
Figure 49: Report Browser 

Each time this window opens, it builds a list of all reports and determines their groups.  The report groups are 
displayed in the Report Group drop-down list box.  As you change the Report group selection, the reports of that 
group type are displayed in the Reports list box. 
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Select a report and then click View to preview the report on the screen, or click Print to print the report.  Double-
clicking a report in the list also opens the report in view mode. 
3.5.1.8 Single-Site Statistical Calculator 
To open the “Single-Site Statistical Calculator,” select View>Report Browser to obtain the Report Browser.  
Change the Report Type property to “Steady-State Analysis.”  The Steady-State Statistics tool appears in the list of 
available reports. Select Steady-State Analysis in the Reports list and then click View. The Steady-State Statistics 
Calculator window opens. 
 

 
Figure 50: Single-Site Statistical Calculator (Initial Window) 

The calculator is a single form that lets you quickly compute a variety of statistics on steady-state sampled data.  The 
quantities that can be evaluated include steady-state sampled voltage, current, and power qualities, including, but not 
limited to Vrms, Vthd, V3, V5, Vneg, Ineg, Vzero, P, Q, S, pf, and df.  The statistics that can be computed include 
minimum, average, maximum, standard deviation, sum, and count.  Up to three cumulative probability values can be 
computed simultaneously (for example, CP05, CP50, and CP95).  Additionally, you can specify up to three 
thresholds.  The calculator counts and reports the number of samples above each threshold.   
This computation is useful, for example, if you want to count the number of samples of Vthd that violated the IEEE 
Std. 519-1992 limit of 5%.  Figure 51Figure 51 shows an example where statistics are computed for VRMS.  The user 
chose to compute the 5th percentile and the 50th percentile for the selected site and date range. 
 

 
Figure 51: Single-Site Statistical Calculator 
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The Copy All command copies all of the statistics to the Windows Clipboard.  The Print Preview button lets you 
print a one-page report summarizing the statistics. 
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4  Creating a New PQView 
Database with Microsoft SQL 
Server 2000 

 
This section describes how to create a new PQView database with Microsoft SQL Server 2000. 
 
The table below describes where to complete each task. 
 

Table 14: Overview:  
Creating a New PQView Database with Microsoft SQL Server 2000  

 
Task… Where to Complete Task… 
“Creating the PQView DatabaseCreating the 
PQView Database,” as described on page 4-
1 

Create the database in  Microsoft SQL Server 2000 
Enterprise. 
 

“Running the Script FileRunning the Script 
File,” as described on page 4-5 
 

Run the script file to create system tables, triggers, indexes, 
roles, and properties in SQL Query Analyzer. 
 

(Optional) Selecting a Recovery 
Option(Optional) Selecting a Recovery 
Option, as described on page 4-9 
 

Select a Recovery Option in  Microsoft SQL Server 2000 
Enterprise. 
 

“Opening the Database,” as described on 
page 4-10 
 

Open the database in PQView’s PQ Data Manager 
(PQDM). 

  

4.1 Creating the PQView Database 
 
To create the PQView database, complete the following steps: 

 
1. Select Start > Programs > Microsoft SQL Server > Enterprise Manager.  

SQL Enterprise Manager displays a window, similar to Figure 52Figure 52.  
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Figure 52: SQL Server Enterprise Manager 

 
2. If necessary, expand the tree under Microsoft SQL Servers on the left side of the window. 
3. From the SQL Server Group in the tree, select the server upon which you will create the database. For this 

example, the server is (local)(Windows NT). The (local) server is the SQL server instance running on the 
current computer. 
Note: On a given server, you can run multiple SQL Server services, each with their own ports, logins, and 
databases. Each of these services is called an “instance” of SQL Server. 

4. Highlight the Databases folder. 
5. Select Action > New Database from the menu bar or right-click the Databases folder and select New 

Database. The Database Properties – General tab dialog box displays, as shown in Figure 53Figure 53. 
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Figure 53: Database Properties − General Tab 

 
6. In the Name field on the General tab, type the name of your PQView database. For this example, the name 

is PQView_DemoDB.  
7. If you want to change the data file folder from the default location, click on the Data Files tab and specify 

a  new folder in the Location field. You can type the name of the folder or browse to it.  
Tip: We recommend that you store the data file in a folder on a hard drive of your computer, not on a  
network drive. 
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Figure 54: Database Properties − Data Files Tab 
 

8. In the Initial Size (MB) field, specify the size of the database, by typing a size in this field.  
Tip: We recommend using a reasonable initial size for the database, such as 10240 MB or 10 gigabytes. To 
anticipate future growth of the database file and gauge an appropriate size, talk to the PQView database 
owner. 

9. In the File properties section of the Data Files tab, deselect the option Automatically grow file.  

 
 
Figure 55: File Properties Section in Database Properties - Data Files Tab 

 

Deselect this 
option.
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Note: If you are sure that the database will never exceed 2 gigabytes in size, then it is ok to select the 
Automatically grow file option, since problems seem to occur after the database grows larger than 2 
gigabytes. For more information on the database size, see “PQView Database Size”below. 

10. If you want to change the transaction log file folder from the default location, click the Transactions Log 
tab. In the Location section, specify a new folder. You can type the folder name or browse to it.  
Tip: A one MB initial size is adequate for most PQView databases. It is OK to grow transaction log 
databases automatically, using 10% increments with unrestricted file growth, because the transaction log 
associated with a PQView database rarely exceeds a few tens of megabytes.   

11. Click OK. You create your PQView database.  
Note: It takes a few minutes to create a 10 gigabyte database.  

12. Complete “Running the Script FileRunning the Script File,” as described below. By running the 
PQView3x.sql script file against the new database, you populate it with PQView tables, triggers, indexes, 
properties, roles, and database user ID and password.   

 
4.1.1 PQView Database Size 
The default setting for SQL Server is to grow databases automatically, when needed in 10% chunks. For example, if 
the database is 1 gigabyte in size, SQL Server can automatically grow the database to 1.1 gigabytes. During the 
database expansion, no queries can be run against the database. When the expansion is small or if the server is 
unloaded, this expansion can take just a few seconds. However, when the database is large (in excess of several 
gigabytes), the expansion can take many seconds. If PQView’s PQDM triggers the expansion during import from a 
data source, an ODBC (open database connectivity) error can appear in PQDM, with no other explanation. 
 
It is recommended that you choose to not grow a database using automatic database expansion. In contrast, if you 
choose to not automatically grow a database, but instead choose a fixed size and then meet that size, you will receive 
a much more helpful error message in PQDM: “Could not allocate space for object…because the ‘PRIMARY’ 
filegroup is full.” 
 
To receive the more helpful error message in PQDM, when you create a database, specify a fixed file size for the 
PQView database in the Initial Size (MB) field on the Data Files tab in the Database Properties dialog box.  
 

4.2 Running the Script File 
To create the PQView database system tables, triggers, and indexes, roles, and database user ID and password, you 
must run a Transact-SQL (TSQL) script file on the PQView database file that you just created in the previous 
section. The name of the script file is PQView3x.SQL. It is available to you in these ways: 
 

• By download from the PQView Users Group download page 
• On a computer with a current PQView 3.x installation, where it can be found (in this example) in 

c:\Program Files\pqview30\sql\pqview3x.sql.   
 
The script creates the following objects: 

• Tables 
• Indexes 
• Triggers 
• Default properties 
• A role for read/write access to the database (pqview_writer) 
• A role for read-only access to the database (pqview_reader) 
• A user account for read/write access to the database (pqview) 
• A user account for read-only access to the database (pqweb) 

 
You can edit the PQView3x.sql script file to create security permissions that are appropriate for your organization. 
For more information, see “Editing the Script File” on page 4-8.  
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Complete the following steps to run the script file: 
 

1. Know the location of the PQView3x.sql script file before you begin. For this example, we assume it is on 
the hard drive in folder c:\Program Files\PQView\SQL.  

2. In SQL Server Enterprise Manager, highlight the new database you just created.  
Caution: Verify that that the database you have just created is highlighted. It is easy to run the script file 
against the wrong database. 
 

 
Figure 56: Verify the Database Name before Running the Script File 

 
3. Select Tools > SQL Query Analyzer from the menu bar. A Query window appears. 

 
4. Highlight the database you just created and check that it matches the database listed in the drop-down menu 

in the SQL Query Analyzer menu bar. If the correct database name is not displayed in the drop-down box 
on the menu bar, click the down-arrow next to the drop-down box and select the new PQView database you 
just created, as shown in Figure 57Figure 57.  
 
Warning: The script file deletes any tables, triggers, and defaults that are already in the PQView 
database. Be sure to select the correct PQView database and not an existing PQView database when you 
run this script file. 
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Figure 57: Verify the Database Name in SQL Query Analyzer 
 

5. Select File > Open.  
6. Browse to where the script file is stored on your hard drive. 
7. Select the file PQView3x.sql. In this example, the script file is in the c:\Programs Files\PQView 30\SQL 

folder.  
8. Click Open.  
9. (Optional) Edit or delete the section of the PQView3x.sql script file to create security permissions that are 

appropriate for your organization. For more information, see the section, “Editing the Script File” on page 
4-8. 

10. From the menu bar, select Query > Execute.  
11. Check the results of running the script file after it has been executed. Scroll down in the lower half of the 

screen to see the results, as shown in Figure 58Figure 58. 
 

 
 
Figure 58: Check the Messages tab of the Query Window after Running the Script File
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Tip: If you do not see any error messages after the script file runs, click the Messages tab at the bottom of the Query 
window.  
 
4.2.1 Editing the Script File 
Roles are created at the database level, and the user accounts are defined across the entire SQL server instance. The 
permissions on the various PQView tables are listed in the PQView3x.sql script file. After the script creates the 
roles, it creates the user accounts.  
 
You may want to edit or delete the section of the PQView3x.sql script file to create security permissions that are 
appropriate for your organization. The section to edit starts near the end of the script file at line 7813 (in this 
example) after the comment line: / Create a role for reading and writing to the database/, as shown in Figure 
59Figure 59. 
 

 
 

Figure 59: Section of PQView3x.sql Script File to Edit  
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4.3 PQView and PQWeb Database User ID, Password, and Role 
 
When you create a new PQView database using the PQView3x.sql script, you automatically create a database-level 
user ID and password for the PQView and PQWeb products. These user IDs are created if they do not already exist 
on the server instance. The last step completed by the script is to add the PQView role to these database-level user 
IDs. The PQView user ID automatically is assigned to the pqview_writer role, while the PQWeb user ID is 
assigned to the pqview_reader role. Table 15Table 15 presents details about the user accounts.  
 

Table 15: User Account Information 
Product ID User ID Password 

(Case-Sensitive) 
Role Role Description 

PQView pqview pqview3 pqview_writer Grants select, insert, 
update, and delete 
permissions to the group 

PQWeb pqweb pqweb3 pqview_reader Grants read-only 
permissions to the group 

 
4.4 (Optional) Selecting a Recovery Option  
 
After a new database is created, we recommend that you modify a database recovery option for your PQView 
database. This task does not need to be completed, if it conflicts with your corporate environment’s standard 
procedure for database backup.  
Note: You can select a recovery option after you create the PQView database or run the script file.  
 
To select a recovery option for your new PQView database, complete the following steps:  
 

1. In SQL Enterprise Manager, expand the tree under Microsoft SQL Servers on the left side of the window, if 
necessary. You see a window, similar to Figure 60Figure 60 displayed.  
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Figure 60: Microsoft SQL Servers 

 
 

2. From the SQL Server Group tree, select the Server upon which you will create the database. For this example, 
the server is (local)(Windows NT). 

3. Highlight the new PQView database you just created in the Databases folder. In this example, the PQView 
database is PQView_DemoDB. 

4. Select Action > Properties from the menu bar. The database Properties dialog box displays. In this example, 
it is PQView_DemoDB Properties.  
Tip: You can also right-click the highlighted database and select Properties.  

5. On the Options tab of the database Properties dialog box, select Simple from the Model drop-down list box. 
You have now set the Recovery (or backup) option for the database. Leave all other defaults on this tab as they 
are.  
Note: If you select the Full option, you must be sure that you have enough hard disk space to accommodate 
the same amount of file space for the database backup file that will be the same size as the data file of files of 
the database itself. 

6. Click OK. 
7. Select File > Exit to close SQL Enterprise Manager. 

4.5 Opening the Database 
Last, you must open the new SQL Server database with PQView’s PQ Data Manager to prepare it to accept data. 
Before you can open the database, ensure that you have the following connectivity information from your database 
administrator: 

• Server Name or IP address 
• PQView Database Name 
• User ID 
• Password 
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If your database administrator only provides you with a database name and user ID, you can still try to connect to the 
PQView database, by leaving the User Name and Password fields blank. When these fields are blank, you  connect to 
the database, using Windows Authentication mode. 
 
1. Select Start > Programs > PQView 3.0 > Power Quality Data Manager. 
2. Select File > Open Power Quality Database. The Open Power Quality Database dialog box displays, as shown in 

Figure 61Figure 61.  
Tip: The File > New Power Quality Database command creates a Microsoft Access database from a template.  

3. In the Database Type section, select the radio button for Microsoft SQL Server.  
Note to Microsoft SQL Users: Power quality databases housed in Microsoft SQL Server are opened by specifying 
ODBC Databases in the Files of type box.  A standard Select Data Source dialog box appears.  (You must have an 
ODBC Data Source Name configured on your client machine in order to access SQL Server databases.). The 
preferred method of connecting to the SQL database, however, is to address the SQL server directly. 
Support for ODBC connections to PQView databases in PQView will be discontinued in 2008. 

4. In the Server field, type the name of the SQL server, upon which the PQView database resides. Or get a list of all 
available SQL Servers in your network by clicking the Browse (…) button, as shown in Figure 61Figure 61, and 
then select the server name upon which the PQView database resides.   
OR 
If your PQView database and SQL Server are on the same machine, you can leave the Server field blank, use the 
loopback IP address 127.0.0.1, or use the alias (local) as the server name.  
 

 
 

Figure 61: Open Power Quality Database Dialog Box 
5. In the Database field, type the name of the PQView database.  

Tip: Click the button to get a list of all available databases on your server. Select the PQView database you just 
created.  

6. In the User Name field, type the user ID. 
7. In the Password field, type the password for the user ID in Step 6.  

Caution: Be sure you are connecting to the database with a user ID having read/write permissions because you 
will be adding look-up records to the database. For more information about possible errors you may see if you 
try to connect to the database without the proper user ID, see “Using the Correct Database User ID”  
on page  4-12. 

8. Click Yes for the first informational message, Missing Lookup Records. 
9. When PQView has finished processing, your new PQView SQL Server database is ready to be populated with data. 

Figure 62Figure 62 displays the ODBC Database dialog box that appears when you connect.  
 

 

Database browse 
button. 

Server browse button. 
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Figure 62: ODBC Database Dialog Box 

 
10. Select File > Exit to close PQDM. 
 
Note: Using the Correct Database User ID: 
When you connect to the PQView database, you must connect to the database, using a user account with read/write 
permissions on the database. If you connect with a user account with read-only permissions, you may see the following 
error message: “ODBC—insert on a linked table ‘Channel’ failed.” 
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5  Creating a New PQView 
Database with Microsoft 
SQL Server 2005 

This section assumes that you have installed both SQL Server 2005 and SQL Server Management Studio. 
You can use the same instructions with SQL Server 2005 Express edition. 
 

5.1 Creating the PQView Database 
Notice that in SQL Server Management Studio Studio or SQL Server Management Studio Express, the 
fields for the database and log file are in the same view in the New Database dialog box. 
 
To create a new PQView database, complete the following steps: 
 

1. Select Start > Programs > Microsoft SQL Server 2005 > SQL Server Management Studio. 
The Connect to Server dialog box displays.   

2. Connect to the server.  
3. If your installation uses Windows Authentication, as shown in Figure 63Figure 63, click 

Connect.  
 

 
Figure 63: Windows Authentication 

4. If your installation uses SQL Server Authentication, type the system administration user ID in the 
Login field and the password for this user ID in the Password field. Then click Connect.  

5. Highlight and then right-click on the Databases folder. A drop-down menu displays. 
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6. Select New Database. The New Database dialog box displays, as shown in Figure 64Figure 64.  
 

Figure 64: New Database Dialog Box 
 

7. In the Database name field, type a database name for your PQView database. For this example, 
type PQView_DemoDB. 

8. In the Initial size (MB) field, specify the size of the database by typing a size in this field. For this 
example, type 100 MB.  
Tip: We recommend using a reasonable initial size for the database, such as 10240 MB or 10 
gigabytes. To anticipate future growth of the database file and gauge an appropriate size, talk to 
your PQView database owner. It is easier to set the size of the PQView database to be large now, 
rather than try to fix a database later that is too small.  

9. Take the defaults for the Log file. You do not need to change any defaults on this line. 
10. In the Object Explorer (left-hand navigation), click Options. The Options dialog box displays, as 

shown in Figure 65Figure 65.  
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Figure 65: New Database - Options Dialog Box 

 
11. (Optional) In the Recovery model field, select the Simple option from the drop-down list or verify 

that this is the default option.   
 
Tip: For more information about this optional step, see “(Optional) Selecting a Recovery 
Option(Optional) Selecting a Recovery Option” on page 4-9  in “Creating a New PQView 
Database with Microsoft SQL Server 2000.”  
 

12. Click OK. Your new PQView database is created.  
 
Tip: Leave the SQL Server Management Studio Express open. See the next section to run the 
script file. 
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5.2 Running the Script File 
To run the script file, complete the following steps: 
 

1. In the Object Explorer (left-hand navigation) of Server Management Studio Express, expand the 
Databases folder tree.  

2. Highlight the name of the PQView database you just created. In this example, it is 
PQView_DemoDB.   

3. Right-click the selected database. A menu selection list displays.  
4. Select New Query from the list, as shown in Figure 66Figure 66.  

 
Tip: You can also select the New Query button or select File > New > Query with Current 
Connect. Ensure the correct database name is selected.  
 

 
Figure 66: Select New Query  

 
5. Select Edit > Insert File As Text from the menu bar. The Insert File dialog box displays.   
6. Browse to the file PQView3x.sql file on your computer. In this example, it is in c:\Program 

Files\PQView30\SQL\PQView3x.sql. 
7. Select the PQView3x.sql file and click Open.  
8. (Optional) Edit or delete the section of the PQView3x.sql script file to create security 

permissions that are appropriate for your organization. For more information, see the section 
“Editing the Script File” on page 4-8  and the section, “PQView and PQWeb Database User ID, 
Password, and Role” on page 4-9.  

9. Verify that you have the correct database selected, as shown in Figure 67Figure 67. 
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Figure 67: Verify the Correct Database is Selected 

 
10. Select Query > Execute from the menu bar.  
11. Click the Execute button. 
12. Select File > Exit to close Studio Express. A Microsoft SQL Server Management Studio Express 

dialog box displays, as shown in Figure 68Figure 68. 
 

 
Figure 68: Microsoft SQL Server Management Studio Express Dialog Box 

 
13. Click No. You do not want to save the query you just ran.  
14. Complete the steps for “Opening the Database” on page 4-10 in the section, “Creating a New 

PQView Database with Microsoft SQL Server 2000”. You open the database to prepare it to 
accept data. 
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Note to Microsoft SQL Users: Power quality databases housed in Microsoft SQL Server are 
opened by specifying ODBC Databases in the Files of type box.  A standard Select Data Source 
dialog box appears.  (You must have an ODBC Data Source Name configured on your client 
machine in order to access SQL Server databases.) The preferred method of connecting to the SQL 
database, however, is to address the SQL server directly. 
 
Support for ODBC connections to PQView databases in PQView will be discontinued in 2008. 
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