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1. Introduction
Welcome to ArahPaint - a drawing tool that helps the designer to create a picture to be woven on
a jacquard type of looms. ArahPaint is the first step in preparing a design for weaving. The
program includes several functions, from basic drawing primitives to sophisticated and dedicated
functions. And all functions are simple to use and easy accessible. They have the undo capability;
thus enabling the designer to correct quickly undesired modifications to the picture. Furthermore,
there is context sensitive help to assist the designer without having to browse trough this manual
too many times.

The topics of this manual are arranged in a way that is similar to the sequence of the design
preparation procedure. The reader should be familiar with graphical user interfaces, since its
basics (selection with mouse, double click, buttons, file selection boxes, text entry and editing,
etc.) will not be explained here.

ArahPaint is aimed at designers, who have some knowledge of the weaving process. Namely, the
manual does not contain complete instructions to develop a design into a fabric. ArahPaint
contains many tools to assist a textile designer, but they can not replace the skills and knowledge
of a professional textile designer.

We hope you find ArahPaint a powerful designing tool, which will help you in the everyday work.
We are always open to comments and suggestions, so please send them to our address and we
will do our best to improve the program accordingly.

2. Program appearance
After starting the program by double clicking on the ArahPaint's icon or from selecting it from
desktop menu, the main window is displayed on the screen (Figure 1).

The description of the components follows the numbers on the picture:

1. Title bar displays the program name, version and current design filename name and size
in pixels.

2. Menu bar with menus File, Edit, Tools, View and Help. When the mouse pointer is
inside the drawing area, the coordinates of the mouse inside the picture replace the Help
label. Note that design's first row is at the bottom of the picture.

3. Main window it is the area where the picture is displayed in a way that every pixel (dot)
on the screen represents one dot (hook) of the design.

4. Toolbar with icon button for drawing, filling, text insertion, selecting, rotating, and
mirroring.

5. Zoom window - pressing this icon button will bring up zoom window, where the user can
edit the design.

6. Line width - this setting sets the width of lines, rectangles/squares, ellipses/circles, arcs
and polygons.

7. Color indicator  - shows which color is foreground and which is background. By
pressing color indicator with mouse, the window with the color palette will pop up.

3. Basic operations
While running the program, there are some most frequently used operations like loading and
saving file, selecting region, setting color and similar. In this chapter we will not go into detail
with all of them, because they are thoroughly explained in other chapters. The user should know
how to do the basic operations before continuing with the other chapters.
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3.1 Getting help
During most of the operations there is help available. When in doubt about how to perform an
action, just select the Help button if there is one visible or press F1 key. Help is context
sensible, this means the contents of the help window depend on from which operation it was
called for.

3.2 Undo
Everyone can make a mistake, so Undo command in the Edit menu helps you restoring the
previous state, but only for one command. Undo is available for most of the commands; it is
missing only where big amounts of memory would be necessary to backup the last action. Saving
the picture clears the undo buffer. We are planning a multiple undo feature for some of the future
releases. We can not give a date, but it will be done.

3.3 Loading a design into ArahPaint
The necessary command is located in the File menu with the name Load file. Choosing this
command will bring a file selection menu on the screen, from which the desired file needs to be
selected.

After confirmation of the chosen file, the menu disappears and loading starts. The process is
visible on the screen with a progression bar showing the percentage of file loaded. The user can
interrupt loading by pressing the Cancel button. After the procedure, the picture is visible in
the main window.
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Figure 1: Main window of ArahPaint (design courtesy of IBI Kranj)
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Program can load pictures in PNG, GIF, PCX, TIFF and JPEG graphic file formats. JPEG
pictures are automatically converted to 128 color images from 24 bits per pixel (16 million
colors), while PNG, GIF, TIFF and PCX are only supported in their 256 color variations. This is
due to specific nature of ArahPaint, which is only intended for jacquard images, which rarely
exceed 20 colors in the final result. True color (16 million colors) images are unsuitable for
jacquard. We have made the exception with JPEG format, because it compresses images so well,
and it is suitable for scanning the images in high resolution. On the positive side, most of the
jacquard specific machine formats (TIS, Grosse, Stäubli, Bonas, Schleicher) and some
competitors (Sophis, EAT) are supported as well.

3.4 Saving a design
After some editing was performed on the picture, it is wise to save it. The user can save it under
existing name by selecting the command Save from the File menu.

In case the user wants to change the name of the design, it invokes the command Save as from
the File menu. This action will bring up the file selection box, where he can choose the desired
directory and enter the new name. If the file with the same name exists, the user is warned before
continuing the saving procedure. The program gives him the option to overwrite the existing file
with the new design or to change the file name.

3.5 Selecting a rectangular area of the design
Many operations require from the user to show on which part of the picture this action
will be performed. By selecting a particular rectangular region, the user sets the
boundaries of the operation.

The select tool works in the following way:

1. Select the rectangular selection tool by pressing the icon button in the toolbar area.

2. Move the mouse pointer to one of the corners of the selected area.

3. Presses left mouse button and drag the mouse until the desired area will be inside the
dashed rectangle.

4. Release the mouse button.

If the user wants to change the size of the dashed rectangle, he/she may do so by:

1. Moving the mouse pointer to the border of the dashed rectangle (from inside out) until the
mouse pointer shape changes.

2. Pressing the left mouse button and dragging the mouse until the desired rectangle size is
achieved.

The whole picture can be selected by choosing command Select all from the Edit menu.

Selected area can be transformed into motif, which can to be copied, pasted, etc.

3.6 Clearing the motif
If the selected area - selection is no longer needed, the user can remove the selection/motif.
This action will:

• Remove the bounding rectangle when only an area was selected but none of the following
actions were taken: move, cut, copy, paste, rotate, mirror. It the motif is floating on top
of the image, it will be drawn into the image at its current location.

• If motif is not visible and does not float over the image, it will be deleted from program’s

memory. The icon will be grayed out into , so the user will know that there is no
selection in the image or in the program’s memory.
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The user is encouraged to perform this operation immediately after the selection/motif is not
needed any more. This will free the computer memory and accelerate editing operations in
memory-low situations.

3.7 Setting foreground and background color
This is probably the most frequently used operation. The foreground (drawing) color and
background colors are used with drawing operations.

Foreground color (among others) determines:

• color of basic elements: dots, lines, rectangles/squares, ellipses/circles, arcs, spray drawn
with left mouse button

• color for fill area operation

• text color

Background color (among others) determines:

• color of  basic elements: dots, fill with color areas, lines, rectangles/squares,
ellipses/circles, arcs, spray, drawn with middle mouse button

• color of the area of the new picture

• background text color

• the color that will remain in the picture after cutting out a selection

Foreground color can be selected from the color palette. Figure 2 shows the appearance of the
color palette window where numbers denote the following:

1. Edit menu with color specific operations

2. palette region - all colors available in the program; the size of colored rectangles depends
on the number of colors used, the smaller the number of colors the bigger the rectangles.

3. foreground color - depicted as upper square

4. background color - depicted as lower square

5. modify color – these sliders enables the user to change values of the selected color

ArahPaint uses two color spaces: RGB (Red Green Blue) and HSL (Hue Saturation Luminance).
When RGB color space is selected (toggle button with RGB label set), the attributes of the last
selected color (top right area of the window) are modified by changing red, green and blue
component.

Similarly, with HSL color space activated, hue, saturation and luminance components determine
the color.

By moving the slider of the components, the color in the top right area of the window changes.
The user must gain some experience in varying the values of the components in order to achieve
the desired color quickly.
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Figure 2: Color palette window
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Colors values inside ArahPaint are mostly of informational value. They give the designer the
overall look of the picture, dominance of particular colors etc. The final colors will be set in
ArahWeave program and will depend on the colors of the yarn and weaves selected.

Selecting the foreground color is very simple: move the mouse pointer inside the palette region so
that the sharp part of the mouse pointer is inside the desired color and press left mouse button to
select new foreground color.

You can set background color only in indirect way. First you put the desired color to foreground
color, and then you click the arrows besides the foreground/background indication blocks, so you
will swap foreground and background colors.

Immediately after a new color was selected, the color of the upper square changes accordingly.
The new active color has a black and white frame around its rectangle in the palette.

The user can also change or copy colors in the image. First select color in color palette: with
middle button exchanges colors, with right button copies color. Note that the actual pixel values
are not changed, you can still select the color and change it, if you want the old pixels back. But
once you do "Sort colors" or go into set number of colors to reduce them, all pixels with the same
color will be reduced to one color.

Double clicking with either button will show selected color in the main window by temporarily
changing the pixels of this color to black and then to white.

The foreground color can be selected by pointing with the mouse pointer inside the (focused)
main or zoom window on the pixel with the desired color and pressing space. This way, the
user can quickly change the drawing color without having to move the mouse pointer to the color
palette window.

3.8 Drawing in zoom window
Drawing operation can not be very accurate in the
main window, since the one-screen pixels equal to
one dot of the picture, so user can also draw in a
separate window - a zoom window. In this window
the picture is the same as in the main window, just
the user can set the enlargement factor for easier
operation. Otherwise drawing in zoom window is
equal to drawing in the main window.

Pressing the button will open the window.
Zoom window has its own menu bar with three
menus: Actions, Mesh and Zoom menu.

You can also bring up the zoom window by
pressing right mouse button anywhere in the
picture. The zoomed area will be centered on the
area where you have clicked! And you can also
keep the right mouse button pressed and move
across the picture, and zoom window will be
updated accordingly. This can be very useful to
scan borders of color effects, to see if contours are clean and nice, or there are still some stray
pixels remaining from scanning.

3.8.1 Actions menu
contains four commands: Undo, Show position of enlarged area, Select center of
enlargement and Close. The last command closes the window; the first one is the same as
Undo in main window. Show position of enlarged area temporarily closes down the zoom

Figure 3: Zoom window
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window and shows which part of the picture is visible in the zoom window by flashing a dark
rectangular in the main window. The dark filled rectangle corresponds to the enlarged area in the
zoom window. This function is useful when large magnifying factors are set and the user does not
know which part of the picture does the zoom window represent.

As the name denotes, Select center of enlargement gives the user the possibility to quickly
move the zoom window to a desired part of the picture in the main window. After selecting the
command you should move the mouse pointer to the main window and then press the left mouse
button. The point under the mouse cursor will become the center of the zoom window. The same
operation can be reached by pressing the right button in the main window, as described above.

3.8.2 Mesh menu
Enables the user to set the magnification factor to set the color of mesh and to switch the mesh
on/off. ArahPaint draws a mesh if one of the magnifying factors is bigger than four and the
Mesh command is activated. If none of factors is bigger than three only thick lines will be
drawn. There are 10 different factors from 1:1 to 10:1 ratio and they set the equal magnifying
factor for width and height. Pressing the corresponding key on the main part of the keyboard will
set the magnification factor. For example: pressing 5 will set the width and height magnification
factor to 5. If the user wants to have different factor for width and height, she can select the
command Mesh dimensions from the same menu and a window will popup.

In the top two fields is set the enlargement factor.
In the bottom the last two parameters determine on
how many thin mesh lines a thicker one will be
drawn. In our example in Figure 4 every eight line
will be thicker. If you change the zoom level using
1, 2, 3, 4 etc. zoom level, then program will
automatically set zoom aspect ratio according to
the fabric density, as entered in Repeat
dimensions window. The program will display
current zoom level in the zoom window title.
User can change grid color to black, gray or white.

4. Suggested sequence of steps
The process of converting a design, an idea into a fabric can be divided into three steps:

1. Preparation of the design with the ArahPaint program

2. Preparing the necessary weaves in the ArahWeave program

3. Combining the design and the weave into a jacquard control data with the color
simulation on screen and paper

The phase 1 - preparation of the design - can be subdivided into the following steps:

1. drawing a design on paper

2. scanning the design into the computer

3. transferring the scanned design to Linux

4. loading the design into ArahPaint program

5. cutting out the color border

6. putting it into repeat

7. scaling the image to the desired dimensions

8. setting the number of colors (weaves)

9. cleaning the scanned picture

Figure 4: Setting mesh dimension
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10. editing the picture

11. saving the final picture

After every step from point 4 to 10 it is a good practice to save picture often and under different
names (lets say adding an increasing number at the end of the file name). This way, whatever
happens in subsequent steps, the user can always go back (if necessary) to every step backwards.
However, after the design is finished, the user should erase the unnecessary files.

4.1 Drawing a design on paper
Drawing a design on paper is usually simpler and easier for a designer than drawing directly into
computer. Therefore, a design can be drawn by hand on paper using normal drawing techniques.
The drawing can be black and white or colored. It is preferable to color particular regions by use
of ArahPaint’s flood fill tool rather than do it by hand. This is due smaller accuracy of the latter
method. For shaded designs, however, hand coloring is a better choice.

The design does not need to be drawn in 1:1 scale, because the computer can resize an image to
any desirable size. Thus, a design on paper needs not to exceed a size of A4 format. This way the
scanner of a normal A4 format size will be enough to import the picture into the ArahPaint
program.

4.2 Scanning the drawing into the computer
Before starting the scanning procedure it is suggested to consult scanner’s manual thoroughly.
Regardless of the scanner type used (hand, flatbed, drum scanners) the user should take care that:

1. Image is aligned with the scanning area - which will reduce the need to rotate the drawing
later on

2. A proper scanning mode is used: for black and white drawing black and white mode for
colored drawing color mode. For design prepared for jacquard type of weaving, a 256-
color mode is sufficient, therefore do not use the true color mode (24 bits per pixel).

3. The unnecessary white space is cut out from scanned picture. By using preview mode
(available with most scanning software) the user can see the size of the drawing in
correspondence to the scanning area the scanner is capable of. By use of bounding
rectangles, the user can limit the scanning area to the area actually covered by the
drawing.

4. A proper scanning accuracy is chosen. This is measured in dpi (dots per inch) and for
modern scanners it ranges from 150 to 2400 dpi. The bigger the dpi the better the
accuracy. But a better way to calculate the accuracy is to set the proper dimensions of a
scanned drawing. The user usually knows in what quality the design will be woven. Let
say, a particular design will be woven on jacquard looms with 1344 hooks. This means,
the scanning width in pixels shall not exceed 150% of the hooks used. For our example
this means 1355*1.50 = 2016 pixels of scanning width. Dividing the drawings width on
paper in inches by scanning width in pixels will give us the dpi. Again, for our example
lets suppose the drawing is 15 cm wide. Thus 2016/(15/2.54) = 341,3 dpi.
By using this simple formula, the user can calculate the accuracy and/or scanning width,
whichever can be set in the scanning software.
Limiting the scanning width and height is very important because it reduces the need for
memory and accelerates editing operations.

5. Proper saving format is set. For ArahPaint you can use PNG, GIF, JPEG, TIFF, or
PCX graphic file format.

6. Drawing is saved to the desired director, and the filename should remind you of the
contents of the drawing.
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4.3 Transferring the scanned design to Linux
4.3.1 The difficult way
Since the scanning software, which you get for free with the scanner, usually runs only under
DOS/Windows XY operating system, the file with scanned drawing must be first transferred to
Linux file system. The procedure follows below:

1. The user must be logged into the Linux system.

2. Then you open a shell by click with right mouse button outside of any window on the
screen.

3. A popup menu will appear; select the Terminal command.

After a few seconds, a Linux shell window will appear on the screen. Then the user types in the
following command:

mcopy a:pictureName /home/capdam/data/img

if the file with the scanned image is on floppy disk A: Where path stands for the directory path
to the location of the file and pictureName stands for the name under which the scanned
image was saved.

Now the user can load the design into ArahPaint program.

If the DOS/FAT32/NTFS (Windows) partition is mounted into your Linux filesystem (usually it
is a good idea to take care of this during installation), you can load images directly from the
position on the Windows part of the hard disk, where you have saved your scanned images.

4.3.2 The easy way
Since many users had problems with manual transfer of the files, described above, we have
implemented a simple menu entry Load image from floppy, which reads the contents of the
floppy, copies all the files to directory /tmp/floppy and positions the file selection box to that
location. Just double click on the desired file to load it, but remember to save it to a different
location, where you normally keep the files, since /tmp location will be cleared.

If your floppy contains many files, it can take up to a minute to load all the files, and the program
will not be reacting to user’s actions in the mean time. If you want to load again a different file
from the same floppy, you can eject the floppy and select the same command; the old floppy files
will not be cleared and you will still be able to load them. Only the next loading of floppy will
clear the contents of the previous load.

4.3.3 Scanning from Linux
Luckily, Linux is growing in popularity very fast, so now it is also possible to scan from Linux.
At the moment, you need a SCSI controller and a supported scanner connected to it; serial
scanners are not supported. You should load packages SANE (Scanner Access Now Easy) and
GIMP (GNU Image Manipulation Program), so you can scan images directly into GIMP. Gimp
is a 24-bits per pixel paint program similar to Adobe PhotoShop, aimed at photo retouching and
web design. Some of the things that are very easy in ArahPaint are very difficult of impossible in
Gimp. You are free to complement Gimp with ArahPaint, if some functions are not available in
ArahPaint. Refer to your Linux manual to check which scanners are supported in current release,
and how to configure GIMP/SANE, so that they will work with your scanner. Remember to save
images in 256-color format, so ArahPaint will be able to read them.

4.4 Cutting off the border
First the user must check whether the image is aligned horizontally and vertically with window
borders. If not, he must rotate the whole image to achieve alignment. (See chapter 6.7).
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Typically the scanned image contains more than just a repeat. This can be surrounded by white
(or other color) space or there are more repeats in picture. To cut off the color border the user
must:

1. set the foreground color to the border color

2. select the area containing the design with the border; the whole picture or just a part of it

3. invoke the command Reduce selection by color border from the Tools menu

The program will decrease the size of the dashed rectangle from outside in every direction until
first dot in different color in every direction is detected. When there are small spots of different
color as (scanning debris), the user can manually decrease the selection so the selecting rectangle
does not include the spots. Then applies the same command Reduce selection by color
border again.

After the selected area does not contain the color border, the user can decrease the picture size by
invoking the command Reduce to selected area from Edit menu, Picture size submenu.

4.5 Putting the design into repeat
Putting the design into repeat means making the design in a way that placing several design one
after another in both directions will make an illusion of a bigger repeat. The dimensions of a
single design are not visible at the first glance. Of course, this only matters when the designer
wants to achieve this effect. If there is only one repeat in the full fabric width (towels, shawls),
this operation is not necessary. At this point it is a good idea to save the picture.

ArahPaint has a special function, which can assist the user in putting the design into repeat. The
name of the command is Find repeat in the Tools menu. As the function name denotes, the
programs searches if there are multiple repeats present inside the selected area. If there are, the
program will most probably find the dimensions of a single repeat. Program will not always
succeed, due to irregularities and differences between repeats in the picture (caused by scanning
or inaccuracies in original drawing).

Remember to first select the area where multiple repeats exist and use the command Find
repeat in the Tools menu only after.

The new repeat size will be visible as rectangular selected area. To check if the correctness of
repeat size, do the following:

1. Use the command Reduce to selected area from Edit menu, Picture size
submenu.

2. Use the command Repeats in the View menu. This view mode shows multiple repeats
(see chapter 9) so possible irregularities at the design limits are easily visible. It is most
likely that some manual corrections of the design will be necessary. Use drawing tools to
achieve perfect repeat. Switch to Normal view afterwards. An alternative method is to
use the command for moving the repeat's start - see chapter 6.10.

After the design is put into repeat, save it under a different name.

4.6 Setting the repeat size: number of pattern hooks (warps)
and wefts
The size of the repeat is determined by two settings: dimensions in pixels (pattern hooks and
wefts) and dimensions in millimeters - the actual size of the design when woven.

The first setting is done by issuing the command Manually change the size from Edit menu,
Picture size submenu. This will bring up the window as on Figure 5.
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Width means the number of hooks necessary
to do the design, while height means the
number of wefts. The user must know how
many hooks are available on the machine,
which will weave the fabric, and set the
width parameter accordingly.

Remember to set the toggle button Resize
contents! Otherwise only the picture size
will change, cutting off parts of the image or
adding extra space in background color. Changing picture size without resize is typically used,
when a new empty picture is created, and the user will draw the design directly into the computer
from scratch.

When the Keep width/height ratio toggle button is set, the user can modify width
(height) value and the program will calculate height (width) using the original width/height ratio.

Pressing OK will confirm the settings and start the operation, which will end in a few seconds. In
case of huge picture dimensions (regarding to the available memory) the operation may not
succeed.

4.7 Changing the number of colors (weaves)
A scanned image will have more colors then what you need in jacquard fabric. Number of colors
in the picture determines the number of different weaves. For most fabrics, twenty colors are
more than sufficient. Available colors are visible inside the color palette window. There are two
ways of decreasing the number of colors used by the picture/program:

1. automatic decreasing/increasing function

2. user defined color reduction

It is wise to save the image before this operation.

4.7.1 Automatic decreasing/increasing of number of colors
is available through command Change
number of colors from the Edit menu of
the Color palette window. After this
command the window on Figure 6 will
popup.

The scale Number of colors shows the
current value. Bellow the scale is written the
number of colors actually used in the picture.
Dragging the slider to left/right will
decrease/increase the number of colors.
When the new number of colors is smaller than the number of colors present in the picture, a
warning is issued. If the user confirms the action, the program will reduce the number of colors
according to the presence of a particular color. Colors, which cover smaller areas of the picture,
will be converted to the most similar from the remaining ones (more frequently used colors).

Figure 5: Repeat size; hooks by wefts

Figure 6: Change number of colors window
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4.7.2 User defined color number reduction
If the user wants to manually control
removal of individual colors from the
picture, he/she shall use the command
Color number reduction from the Edit
menu of the Color palette window. There
are two types of color number reduction:

• color; the user selects the colors
which will not be removed from the
picture.

• black and white; the picture will be
converted to black and white picture where the user can adjust the threshold value.

For both modes feature the Preview button.

4.7.2.1 Color

The user selects the colors, which will not be removed from the color palette. After a new color is
selected, a rectangle filled with this color is drawn in the window. ArahPaint will retain all the
colors in the window, while the remaining ones from the picture will be converted to the closest
color from the ones, selected by the user. If the user wants to remove some/all colors in the
window he/she presses the right mouse button inside the area with rectangles and selects the
desired command. Currently selected color has a black bounding rectangle around it.

After confirmation only the selected colors will remain in the color palette.

4.7.2.2 Black and white

Picture will be transformed to black and
white picture using the threshold value.
Every color in picture is first converted to
gray, and depending on its gray value it is
either converted to black or white. If its gray
value is lower than the threshold value it
will be converted to black, otherwise to
white. The user can play with the threshold
value until the desired effect is achieved.

4.8 Cleaning the picture
Like other input methods, scanning produces some noise, which is present in the digitized image.
Noise is usually visible as single dots or groups of dots in a color different from (or not present
in) the original. Averaging and despeckling were implemented as a remedy. All cleaning and
contour operations are located in the submenu Contours of the Tools menu. Let's describe each
of the function available.

Averaging algorithm works in the following way: it searches through the image for dots that
differ from the ones in its neighborhood. Then it looks which color is predominant in the
surrounding and applies it.

Despeckleing algorithm works in a similar way, but removes just the isolated dots of a
foreground color.

Figure 7: User defined color number reduction - color
mode

Figure 8: User defined color number reduction - black &
white mode
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Due to the nature of the two algorithms, they can be applied several times to achieve the desired
result. Some information will be inevitably lost in this process.

4.9 Working with the contours
Beside the noise, many irregularities can be seen in a digitized image, especially if the scanned
design was hand drawn. This is due the high precision of the scanner that emphasizes all errors,
which are barely perceptible by human eye. Curves and lines (contours in a black and white
images or boundary lines in color images) have varying width and/or are interrupted several
times. Since contours have an important role in design coloration and post-processing as well, it
is very important they are or equal width and have continuity on a particular region or on the
whole image. To cope with these problems thinning, thickening, pruning, removing and adding
functions are present in the Tools menu, Contours submenu.

For all these methods, the user must set the contour color - the foreground color first. These
algorithms are also called morphological operations, since they keep a very important
morphological feature: connectedness. This means that they will not break up a connected
contour.

Thinning is an algorithm for equalization of the contour width while preserving their continuity.
Usually the desired line width is one dot. The algorithm makes many passages through the image.
Every passage gradually thins the contour until the desired contour width is achieved. Eliminated
contour dots are replaced with the color of its neighbors.

Thickening is the opposite of the thinning algorithm. It increases the contour width by one dot.
This algorithm is used when contours will not be removed after the coloration of the bounded
regions but are emphasized and will be visible in the final design.

Figure 9: Before and after averaging
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Applying thinning algorithm may produce some undesired contour dead ends, visible as “twigs”.
This undesired side effect is more likely to occur on the corners in the original design. The
pruning algorithm looks for such dead ends in the image and prunes them. Using this algorithm
will also show if the contour is connected (i.e. not leaking). If it is not connected, it will create
problems when you will fill the areas with weave effect colors.

Contours can be used just to denote regions filled with a particular color (weave). After the user
has cleaned the image, worked out the contours and colored the areas, he may remove
contours from the picture. This operation will remove the contours (dots in foreground color)
and replace them with the neighboring color using the majority principle. Sometimes, depending
on a design type, contours must remain in the final image and are even thickened.

The opposite function is Add contour, which will add contour on borders of areas of
different colors. Every two adjacent pixels (horizontally or vertically) of different color
will be colored with contour (foreground) color. With arrows user adjusts the direction of
adding the contours.

4.10 Editing the picture
No matter how well and accurately the design was drawn on paper; it will still need some
corrections. The user must therefore correct the details until the desired picture quality is

achieved. Editing is done by use of drawing primitives, motif functions and color operations. All
these functions will be described in the following chapters.

Figure 10: Original, thinned, pruned and thickened picture
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5. Drawing operations
are drawing tools like dot, line, freehand, polygon, rectangle/square,
ellipses/circles, arc drawing, fill area and eraser. All these tools are accessible
through icon buttons in the toolbar. All tool use with the exception of eraser the
foreground (drawing) color to draw. Line, freehand, rectangle/square,
ellipses/circles, arc drawing can be also drawn in background color, if the middle
mouse button is used for drawing. And they use the line width value set in the
bottom part of the color palette (see Figure 2).

5.1 Freehand drawing
Pressing the icon button activates this frequently used tool. Simply move
the mouse pointer to a starting point in the picture, press the left mouse

button and drag the mouse as if a pencil would be in your hand. To stop, release
the mouse button.

5.2 Drawing straight lines
Use icon button to activate this tool. Then move the mouse pointer to a line
starting point in picture and press the left mouse button. Drag the mouse

until the line is of the desired length and angle. Then release the mouse button.

5.3 Polygon drawing
Polygon is a series of straight lines, whose ends are connected, so that the ending
point of one line is the starting point of the next line. It is useful for drawing
figures that will be colored later with the fill area tool. Since lines are connected,
coloring the figure will not extend itself over figure's boundaries.

Polygon drawing is a little bit different from line drawing:

1. Select the icon button.

2. Move the mouse pointer to the starting point and press left mouse button.

3. Move (not drag) the mouse to the next point and press left mouse button again.

4. Repeat step 3 until the desired polygon is drawn.

5. Press right mouse button to stop polygon drawing or middle mouse button to erase last
polygon point.

5.4 Drawing rectangles/squares and ellipses/circles
Drawing ellipses/circles is very similar to drawing rectangles/squares in way that ellipse/circle is
drawn by means of an invisible rectangle/square, whose borders determine the extents of the
ellipse/circle.

First press the desired icon button -  or  or  or .

1. Move the mouse pointer to the one corner and press left mouse button.

2. Drag the mouse to the opposite corner of the (bounding) rectangle.

3. Release the mouse button.

In case when physical width and height of the repeat are not equal and circles/squares are being
drawn, the program calculates the size of the circles/squares to match the ratio of width to height.
The consequence is that in normal view (main window) circles will be drawn as ellipses and
squares as rectangles. If the view mode is changed to Repeats in real size, objects will have
the right proportions.

Figure 11:
Toolbar
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When drawing in zoom, if the ratio of the resizing factor of width to height matches the ratio of
the picture's real size width to height (in mm), then the objects will be visible in right proportions
as well.

If the icon button of the selected operation is filled (not empty), the object will be filled as well.
We set the filling attribute with two clicks on same icon button (for instance square). The icon

will be changed into  and the next drawn object will be filled.

5.5 Drawing arcs
An arc is a part of ellipse or circle. It is used for drawing round shapes like flower leafs and
similar round objects. Three points determine the arc: first and second set the starting and ending
point of the arc, while the third one sets the curvature.

1. Select the icon button.

2. Move the mouse pointer to the point where arc will start and press the left mouse
button. The program will draw a cross on that point.

3. Move the mouse pointer to the point where arc will end and press the left mouse button.
The program will draw a cross on that point.

4. Now move the mouse pointer to the point of maximum extent of the arc's curve and press
left mouse button.

5. Drag the mouse button until the desired arc is drawn and release the mouse button.

5.6 Fill area
Fills a particular area of selected color with the foreground color or pattern (motif). Filling stops
when it can not pass trough groups of dots of different color to pointed one or when the borders
of the selection are reached.

Procedure:

Press the fill icon button. Second click on fill tool icon will switch to pattern fill , if
there is any active selection

1. Move the mouse pointer inside the selection and point to a color that will be replaced
with the foreground (fill) or pattern color. Pattern fill works only if a motif was loaded or
created before the fill operation.

2. Press left mouse button. After a few moments the modified selection is displayed.

3. Repeat the steps 3 and 4 as many times as desired and change the foreground color if
necessary.

5.7 Spray
tool draws many randomly distributed of dots in foreground color around the mouse pointer. As
with "analogue" spray, dot density diminishes from the center (of the mouse pointer) to outside.

1. Press the icon button; inside window the mouse pointer will change into a spray
can.

2. Move the mouse pointer to the desired spot and press left mouse button. Drag the mouse
to other areas or leave it on the same spot if a stronger effect is desired.

3. The program will spray dots until the user releases the button.
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If you want to change the
number of dots and the spray
diameter, press the icon button
twice and a dialog with spray
parameters will pop up (see
Figure 12). Change the desired
parameter and confirm the
changes.

5.8 Mix colors

 tool is same as spray, but exchanges existing colors. Used to soften the border between two
or more colors, without introducing new colors. The foreground and background colors are
disregarded in this operation.

5.9 Parametric drawing
Circles/ellipses,
squares/rectangles and straight
lines can be also drawn
parametrically. This means the
user can input the absolute
coordinates of the drawing
primitive in a dialog window. By
pressing the right mouse button
inside the picture, a popup menu
will appear with two commands:

Edit - change the parameters of the last drawing operation

New - draw a new primitive

In both cases the same window will appear on the screen. In case the user has selected the Edit
command, the parameters in the window will have the actual values of the last operation, zero
otherwise.

6. Working with motifs
Selection becomes a motif, when the user moves, cuts, copies, rotates or mirrors the selected area.
After any of these actions is performed, the program copies selected area into a special buffer.
Beside the mentioned actions, motif can be loaded in the picture, saved and pasted.

Note that after motif has been created, selecting any of the drawing tools (drawing
primitives) or picture saving will irreversibly draw down motif on the picture! But it won't
delete the motif from the program memory.

Loading a new picture will not destroy the motif. In both cases, the user can have access to the
motif with the Paste command.

6.1 Making a freehand selection
In chapter 3.5 we have learned how to make a rectangular selection. But many times there is the
need to make a freehand selection, therefore ArahPaint gives this possibility. This means, the user
can select the area of any shape in the picture. The procedure is very similar to freehand drawing:

1. Select button.

2. Move the mouse button to the place where freehand selection should begin.

Figure 12: Spray parameters

Figure 13: Drawing parameters
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3. Press the left mouse button and drag the mouse. As the mouse moves, the dashed line
follows the mouse pointer.

4. To stop release the mouse button. Connecting the last point in selection with the starting
one is not necessary. The program does it automatically by connecting the two points
with a line.

6.2 Cut/copy a selection
First make a selection; a rectangular or a freehand. Then use the command from the Edit menu:

• Cut to cut out the selected area into buffer. The selected region on the picture will be
filled with the background color. When a motif is already pasted on the picture, this
command will remove it from the picture without coloring the area below.

• Copy to make a copy of the selection without changing the contents of the picture.

6.3 Moving motif
Move the mouse pointer inside the selection/motif until the mouse pointer changes its shape to

form of a cross with four arrows - . Then press the left mouse button and drag the mouse.
Motif will follow the mouse pointer. To stop, release the mouse button.

6.4 Pasting motif
Pasting means putting another motif copy on the picture. There are two types of motif pasting
available: single and multiple pasting.

6.4.1 Single
Is more frequently used than multiple pasting. The user selects the command Single from the
Paste submenu in the Edit menu. ArahPaint puts a motif copy on the top left area of the
drawing window. The user can then move the motif to a desired location. The user can paste the
motif several times but it must know, every time the new motif copy was pasted, the old one (if
present) will be drawn on the picture on the place where it was laid down.

6.4.2 Multiple
The purpose of multiple pasting is to lay down many copies of a single motif. This way, the user
can fill the entire picture with motifs, laid in a particular order. This command is located in the
Paste submenu of the Edit menu under the name Multiple. Invoking this command will bring
up a window described below.
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Let's explain every element of this
rather complex window:

§ Repeat mode. There are
four different repeat modes
possible: block, brick, pillar
and custom. Picture beside
each of the option explains how
motifs are laid down.

§ Distance type. The top
right icons determine the value
of the distance field. In
case the left icon is selected
(default) the distance
parameters sets the distance
between two consecutive motif
placements. If the distance
value set is bigger than the
motif size, this can be aligned
inside the virtual frame
determined by the distance
parameter.
When the rightmost icon is
selected, the distance parameter
sets the distance between the
two nearest borders of two
consecutive motifs (as depicted on the icon). In this mode the Alignment parameter is has no
meaning and therefore it is not visible.

§ Horizontal/Vertical. Window is separated into two identical parts where:

§ Motif width/height are displayed at the top to help the user with calculations.

§ Offset sets for how much every row/column of pasted motifs is shifted regarding to its
predecessor. Offset can be relative or absolute. In the first case it can be only fraction of the
repeat width/height (1/2, 1/3, ... 1/n); in the second case, the user can change the offset value
with one pixel accuracy. Offset setting depends on the repeat mode: when block repeat is
selected, neither of offsets (width and height) can be set, while with brick or pillar mode only
one of the offset can be set.

§ Paste times. Enter the value how many times the motif will be repeated in each
direction. Program limits this value to the (picture size)/ (motif size) + 1 value.

§ Margin. Value determines the left and top margin of the first column/row of pasted motifs
from the picture's border.

§ Distance. According to the distance type value, determines the distance between
two consecutive motif placements or the distance between the two nearest borders of two
consecutive motifs (see above).

§ Alignment. Sets the alignment inside a virtual frame when distance parameter value is
greater than the motif size in the particular direction.

§ Preview button gives the user the possibility to see the result of settings made, without
leaving the window. If not satisfied, it can change the parameters and tries again.

§ OK button will confirm the values.

Figure 14: Multiple paste window
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6.5 Resizing motif
The user can resize the motif if necessary. Procedure is similar to changing selection limits in the
3.5 with the following exceptions:

• When the mouse pointer is near the border (from inside out), the user presses the middle
mouse button (not the left one) and by dragging the mouse sets the new motif size.

• When resizing in both directions (pressing the middle mouse button near the corners),
ArahPaint will preserve the motif width/height ratio.

6.6 Loading/saving a motif
Motif can be saved to enable the user to use it in different pictures. Saving motif is identical to
picture saving. Use the command Save motif in File menu and use the same procedure as in
chapter 3.4.

Loading motif is only slightly different from loading a picture. Use the command Load motif in
File menu and use the same procedure as in chapter 3.3. ArahPaint puts the motif on the screen
and increases the number of colors used by the number of colors present in the motif. If there are
not enough colors available (motifs with many colors), ArahPaint will map the least frequently
used colors of motif to most similar colors of the main picture.

6.7 Rotating motif
User can rotate a rectangular motif according to his needs. After the motif has been
created, the user can press the icon button and a rotation dialog will pop up (Figure 15).

Desired angle is reached by changing position of slider.
Below there are three frequently used rotation angles (45,
90 and 135 degrees) for quick setting.

Selecting one of the two toggle buttons (clockwise or
counter clockwise) sets rotation direction.

Immediately after the angle or direction is modified,
ArahPaint rotates motif accordingly, thus designer can see
the results without leaving the window. If the rotated motif
is bigger than the whole picture in any dimension,
ArahPaint will adjust the picture size accordingly. As always, OK will confirm the action.

6.8 Rotating whole picture to make straight lines
After scanning, picture is often rotated, no matter how much we try to make it straight. The usual
procedure would be to select the whole image, and then rotate it by small angles to make straight
lines at the edges of repeat, and visually guess what is “straight”. Easier way to achieve this is to
clear any selection, if you had it from previous operations, and select rotation tool as above.
Then, select two points in the image, as if you would be drawing a line: draw on top of the line,
that you would want to be straight. Program will automatically calculate by which angle does it
need to rotate the image to make this line straight, and will rotate the image accordingly.

6.9 Mirroring motif

is simple. Use  button for mirroring of motif along vertical axe, or  button for
mirroring along horizontal axe. Nonrectangular motif can be mirrored as well.

Figure 15: Rotating motif
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6.10 Changing the start of repeat
Sometimes, after the picture is put into repeat, it is desirable to move the starting point of the

repeat up/down or left/right. This function is accessible through icon buttons  and

from the toolbar. The first tool moves the starting point in horizontal direction, while the
second in vertical direction.

The procedure is:

1. Select one of the icon buttons.

2. Move the mouse pointer to the new starting point in the selected direction. The new point
is the middle of the mouse pointer, not its edge!

3. Press left mouse button.

7. Operations with colors
There is variety of different color functions beside Change number of colors and Color
number reduction in the Edit menu of the Color palette window.

7.1 Define transparent and protected colors
Transparent and protected colors are used in motif
placement. A transparent color means all areas of
this color in motif will become transparent to the
design below the motif. Let's say the motif has
inside a figure surrounded by some white space.
Pasting such motif will inevitably erase some
undesired areas of the main picture. By making the
white color transparent, only the main figure will be
placed on the picture.

Protected colors are colors that can never be
overridden by motif placement. An example of such
color is contour color, but there are also other uses.
Figure 16 shows the window that pops up after
issuing this command.

The window is divided into two equal parts, the top
part shows the transparent colors, while the bottom
part protected colors. Colors are depicted as filled
rectangles. Currently active color has a dark border
around its rectangle.

7.1.1 Setting transparent/protected colors
1. Select the upper or bottom window part by pressing the left mouse button inside that

area.

2. Select a color from the color palette window.

3. Selected color will be drawn as a filled rectangle in the active window part.

A color can not be transparent and protected at the same time. ArahPaint will not allow setting a
color to be transparent, if it is already set as protected and vice versa.

7.1.2 Removing transparent/protected colors
1. Select the upper or bottom window part by pressing the left mouse button inside that

area.

Figure 16: Setting transparent and protected
colors
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2. Select a color to be removed by pointing to it with the mouse cursor and pressing the left
mouse button. A dark rectangle will be drawn around it.

3. Press the right mouse button until a popup menu appears.

4. Select Delete selected color to delete just the selected color or use Delete all colors
in group command to delete all colors in the active window part.

If there is motif placed on the picture after the confirmation of the settings, the user will see the
result immediately.

Transparent and protected color settings are lost when a new picture is loaded or the number of
colors is modified.

7.2 Sort colors
Sorts colors according to their frequency inside the picture. After this command is used, the most
frequent color will be in the first row, first column position of the color palette area and the least
frequent one in the last row, right column.

7.3 Make a gradation
Will make a gradual color scale between the foreground and background color. All colors
between rectangle in foreground color and rectangle in background color of the color palette will
be modified. The number of colors changed depends on the position of foreground and
background rectangles in the color palette area.

7.4 Convert to gray scale
Converts the color palette into gray scale palette. Applicable for shaded designs for damask type
of fabrics.

7.5 Color remapping
User can define how the selection
colors are going to be mapped.
The window is split into two
areas. In the left one, all colors of
the selected area are drawn. The
right area is displays the color
mapping table. In its first column
are shown the destination colors.
On their left are colors, which are
going to be mapped to destination
colors (see Figure 17).
Procedure:
1. Select destination colors from
the color palette; after every
selection the color is shown in a
first column of a new row.

2. In the color mapping table point
to the desired destination color. A
black rectangle is drawn around
currently active destination color.

3. Go to selection color area and
Figure 17: Color remapping window
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click on every color you want to be mapped to currently active destination color. The color will
be removed from selection color area and added to currently active destination color row.

4. Select another destination color and repeat the above two steps.

5. Selection colors not in the mapping table remain unchanged in the selected area.

6. Button Preview gives the preview of the color mapping result, Undo restores to the initial
condition.

7. If you want to remove a (non destination) color from the mapping table, just click on it and it
will be added back to selection colors area. If you want to erase entire mapping row, press right
mouse button end in the popup menu select the respective command.

8. Inserting text
is useful when making design for labels or bed linen fabrics. Insertion of the text is done
through a dialog window (Figure 18), brought up by pressing the icon button.

The procedure consists of four steps:

1. Entering the text to be inserted

2. Choosing font from the Font scrolled list

3. Choosing style from the Style scrolled list

4. Choosing size from the Size scrolled list

In the text field named Input
Text enter the text. Then in
every scrolled list (Font, Style
and Size) choose one option.
Only when all three settings are
chosen, the program shows the
text in the desired font, style and
size. Besides, it will enable
inserting characters from the font
window. Namely, there are some
font characters, which are not
accessible through the keyboard,
thus the only way to insert them is
to choose them from the font
window. To insert a particular
character just point with the
mouse on the character in the font
window and press mouse button.

Bellow the size list is displayed
the size of the text in pixels and
millimeters.

Toggle button named Show
proportional width
fonts enables or disables the access to proportional fonts.

Figure 18: Text insertion window
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Keep width / height ratio
toggle button switches on/off the function of
keeping the same width to height ratio of the
font and the picture. The actual ratio is:

[ ]
[ ]

[ ]
[ ]mmheight

ptsheight

mmwidth

ptswidth
:

By enabling this feature, the rendered the
font will keep the vertical (weft) and
horizontal (warp) density for the inserted
text the same to the respective picture
densities. The text may look distorted in
some cases, but switching to density view
will show the real text look.

Pressing OK button will display desired text
on the screen as motif. The background
color of the text is the background color set.
The user can set this color as transparent if
desired.

The amount of different fonts, styles and
sizes depends on the installed base of

fonts.Drawing in repeat
Many times the picture consists of one or more building blocks (motifs), which are placed in
columns or rows and some of them can be mirrored (horizontally or vertically). Of course, the
user may draw one motif and then place it several times with paste functions described in Chapter
6.4. However, when motifs are regularly placed it is easier to set the repeat pattern first, then
draw/edit one motif, while the computer will repeat the operations for all the other motifs. The
advantage of this method of drawing is, the user can interactively modify the building block and
immediately see how every drawing operation will affect the whole image.

The proper sequence of steps is the following:

1. Setting the repeat parameters: building block size, repeat type and mirroring information
of each element.

2. Drawing/editing the picture.

3. Converting image of several repeats to a single image.

9.1 Setting the repeat parameters
First use the command Wrap around drawing in the Tools menu and the main window and
the following window will appear. Its content is similar to multiple paste window, with some
modifications. Let's describe the elements of the window.

On the top is symbolically displayed the configuration of the repeat pattern;
each repeat is displayed as an arrow. This can assume four different positions determining the
mirroring of the repeat:

: no mirroring of the repeat

: horizontally mirrored repeat

: vertically mirrored repeat

: horizontally and vertically mirrored repeat

Figure 19: Font character picker
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Pointing with the mouse to the desired repeat and pressing the left mouse button can change
mirroring type. The arrow will jump to next mirror type. Since there are only 4 mirror types, you
will get what you want in maximum 3 clicks. If you press the right mouse button, it will put the
arrow to the default orientation.

Repeat mode; determines three different types of repeat alignment: block (first icon), brick
(middle icon) and pillar (rightmost icon).

Offset: Active only when brick or pillar modes is selected. It can be either fixed (fraction of
width/height of repeat - like half drop) or absolute, where the user inputs the offset in pixels.

Paste (times): Number of repeats in a row/column.

Distance: Distance between two subsequent repeats in a row/column.

The number below Horizontal and Vertical displays the total size of the picture. Two
exclamation signs (!!) beside the number denote picture size mismatch due to the wrong offset.

Draw delimiter lines:
when selected, a dotted line will be
drawn between the repeats (only in
Repeat view).

New picture: Program will
create a new picture made of
repeats according to parameters
set in this window. This is usually
the last step in the process of
creation of a compound image.

9.2 Drawing/editing
the picture
First change view type with the
command Repeats from the
View menu. Perform drawing
operations. Every operation is
repeated on every repeat forming
the image. Some operations like
multiple paste, or contour
operations don't work in this
mode. There might be some small
position shifts of particular
drawing primitives when drawing
into a mirrored repeat.

9.3 Converting image of several repeats to a single image
After the individual repeat is drawn to a level it perfectly joins with the other, the user again uses
the command Repeat drawing in the Tools menu and checks the Create new picture toggle
button. After confirmation, the new picture will be formed of all repeats according to parameters
set in the window. From this point on, the whole picture is treated as one big repeat.

Figure 19: Repeat parameters
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10. Other tools

10.1 Creating a new picture
The user can create a new - empty - picture by selecting the command New picture from Files
menu. If the previous picture has been modified, the program will first ask the user to save the old
picture. Then the window in Figure 5 will be displayed. After insertion of new dimensions and
their confirmation, the program will create a new picture filled with the background color.

10.2 Setting repeat dimensions
Beside the size of the picture in pixels (hooks by
wefts), the user can enter the size of the repeat in
millimeters (mm), dots per inch (dpi) or threads
per centimeter. This parameter is used:

1. for displaying the design in real size on
the monitor using the View in real size
in the View menu

2. for insertion of text using Keep
width/height ratio toggle button

3. for drawing squares and circles

4. to determine the print size of the picture.

Physical picture's size is set with the command Set repeat size in the Edit menu.

(See Figure 21). Values may be entered with decimals, however internally this parameter is stored
in integer millimeters. Magnification in % enables the user to set the picture
magnification factor. Value of 100% means image on screen will have the dimensions set with
values above. The size of repeat is also saved in the picture file.

10.3 Printing a picture
Select the Print picture command from the File menu to open the printing window on Figure 21
and repeat dimensions window on Figure 22. The view of picture is changed to View in real size,
which works as Print Preview. It is easy to see if the print settings are correct. Repeat of the
image starts from the bottom of the printout area / drawing area in the window. Program prints
the area according to the current scrollbar position, so that the left bottom area of the screen
image corresponds to the left bottom area of the image on paper.

Let's explain the meaning of each window element:

On the top of the window are displayed: the currently selected printer, printer mode and density.
See chapter 10.3.1 how to change them.

Left, top margin, Print width, and Print height parameters need no special
explanation. Their values are in millimeters.

No. of repeats in width and No. of repeat in height show how many
repeats of the picture fit into the print width and height respectively. ArahPaint calculates these
values on base of picture sizes in pixels and repeat size in mm.

Figure 21: Setting physical size (density)
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Fit to page toggle button will modify the magnification
factor to a value, which will fit at least one repeat on the print
width and height.

10.3.1 Changing printer and its settings
To change the printer and its settings, press the Printer
button. A window on Figure 23 will pop up.

Settings are for:

• printer type

• printer mode

• printout quality

• printing to the file

Their values are shown in boxes below respective scrolled
lists.

First select printer by clicking its name in the list. Then select
printing mode, which depends on the selected printer. There
are at most three different printing modes:

• black & white

• color dithered

• true color

Please note color pictures can not be printed with black and white mode selected. In such case
ArahPaint will issue an error massage. Quality of the printout is defined by dot density (dpi - dots
per inch). The higher the density the better the quality of the printout. High values may slow
down printing.

The printing can be redirected to a file when printer is not available on the computer or on the
network. In this case, check toggle button labeled Print to file and enter printout filename
in the box below the scrolled lists (Print file).

Figure 22: Printing the picture

Figure 23: Changing printer settings


