
Getting Started with 
EnSight 10.0

Computational Engineering International, Inc.
2166 N. Salem Street, Suite 101, Apex, NC 27523
USA • 919-363-0883 • 919-363-0833 FAX
http://www.ceisoftware.com 



 Copyright © 1994 - 2012, Computational Engineering International, Inc. All rights reserved.
Printed in the United States of America.

EN-GS Revision History

This document has been reviewed and approved in accordance with Computational Engineering International, 
Inc. Documentation Review and Approval Procedures.

This document should be used only for Version 10.0 and greater of the EnSight program.

Information in this document is subject to change without notice. This document contains proprietary 
information of Computational Engineering International, Inc. The contents of this document may not be 
disclosed to third parties, copied, or duplicated in any form, in whole or in part, unless permitted by contract or 
by written permission of Computational Engineering International, Inc. Computational Engineering 
International, Inc. does not warranty the content or accuracy of any foreign translations of this document not 
made by itself. The Computational Engineering International, Inc. Software License Agreement and Contract 
for Support and Maintenance Service supersede and take precedence over any information in this document.

EnSight® is a registered trademark of Computational Engineering International, Inc. All registered trademarks 
used in this document remain the property of their respective owners.

CEI’s World Wide Web addresses:
 http://www.ceisoftware.com

Restricted Rights Legend

Use, duplication, or disclosure of the technical data contained in this document by the Government is subject to 
restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause 
at DFARS 252.227-7013. Unpublished rights reserved under the Copyright Laws of the United States. 
Contractor/Manufacturer is Computational Engineering International, Inc., 2166 N. Salem Street, Suite 101, 
Apex, NC  27523.

EN-GS:6.0-1 June 1997
EN-GS:6.0-2 August 1997
EN-GS:6.0-3 October 1997
EN-GS:6.0-4 October 1997
EN-GS:6.1-1 March 1998
EN-GS:6.2-1 September 1998
EN-GS:6.2-2 December 1998
EN-GS:7.0-1 December 1999
EN-GS:7.1-1 April 2000
EN-GS:7.3-1 March 2001
EN-GS:7.4-1 March 2002
EN-GS:7.4-2 October 2002
EN-GS:7.6-1 May 2003
EN-GS:8.0-1 December 2004
EN-GS:8.2-1 August 2006
EN-GS:9.0-0 September 2008
EN-GS:9.1-0 January 2010
EN-GS:9.2-0 November 2010
EN-GS:10.0-0 January 2012



Table of Contents

Table of Contents
 Introduction

1 EnSight Graphical User Interface

1.1 Tour of the GUI. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-2

1.2 User Interface Conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-8

1.3 Where’s the Rest? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-13

2 Starting EnSight

2.1 Necessary Prerequisites  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2

2.2 Starting EnSight for Stand-alone Use  . . . . . . . . . . . . . . . . . . . . . . . . . 2-3

2.3 Starting EnSight for Distributed Use - Manual Connection  . . . . . . . . . 2-4

2.4 Starting EnSight for Distributed Use - Automatic Connection  . . . . . . . 2-5

2.5 Welcome Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-6
Sessions Tab  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-6
Data Tab . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7
Tips and Tutorials . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7
News from CEI  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7
Cancel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7
Welcome Screen Visibility. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7

3 Simple Demonstration

3.1 Reading a Dataset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2
Welcome Screen. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2
Drag and Drop. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3
Getting Your Data Into EnSight. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-4

3.2 Performing Transformations. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5

3.3 Parts and Part Attributes  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-8

3.4 Saving Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-13
Saving Images  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-13

3.5 Using Online Help  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-14
Getting Started with EnSight 10 iii



Table of Contents
3.6 Exiting EnSight . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-16

3.7 Where’s the Rest?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-17

4 Flow Visualization Example: Unstructured Mesh

4.1 Reading a Dataset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-2

4.2 Feature Demonstration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-4

4.3 Where’s the Rest?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4-14

5 Flow Visualization Example: Structured Mesh

5.1 Reading a Dataset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-2

5.2 Feature Demonstration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-5
Saving an Archive  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-9

5.3 Where’s the Rest?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5-10

6 Structural Mechanics Example

6.1 Reading a Dataset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-2

6.2 Feature Demonstration. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-3

6.3 Annotation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-8

6.4 Flipbook Animation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-12

6.5 Where’s the Rest?  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-13

7 Where Do I Go From Here?
iv Getting Started with EnSight 10



Introduction

What’s in Getting Started?

This Getting Started manual contains the following information:

• An introduction to the EnSight user interface (Chapter 1).

• How to Start EnSight, stand-alone or distributed (Chapter 2).

• Some simple, step-by-step demonstrations of basic EnSight functionality (Chapters 
3–6).

Conventions Used in Getting Started

The following typographic conventions are used in the Getting Started manual:

A numbered step tells you exactly what to do:

1. Change the value to “0.0” and press Enter.

UNIX and DOS level commands are denoted in a fixed-width font. Never type the 
leading “%” – it indicates that the command is to be issued at a shell prompt.

% ensight100.client -cm

Menu selections use “>” to indicate the selection hierarchy. For example, “Tools > 
Plane > Line” means to select Plane from the Tools menu and then select Line from the 
Plane cascade menu.

Notes and warnings provide particularly important information:

Note: Text emphasized in this fashion is a note.

Warning: Text emphasized in this fashion is a warning. Warnings typically indicate 
that your actions may have unintended consequences.
Getting Started with EnSight 10 v



Where’s the Rest?

The remainder of the EnSight documentation (as well as a version of this manual) is 
available online (and is accessible via the Help menu). 

The other documentation is divided into three manuals:

How To The How To documentation consists of relatively short articles that describe how to 
perform a specific operation in EnSight, such as change the color of an object or create 
an isosurface. Step-by-step instructions and pictures of relevant dialogs are included. 
In addition, each How To article typically contains numerous hyperlinks (colored blue) 
to other related articles (and relevant sections of the User Manual).

To access a list of the online How To articles, select Help > How To Manual.... From 
this location you can easily navigate to any of the articles or to the table of contents.

User Manual The User Manual provides a detailed reference for EnSight.

To access the User Manual, select Help > User Manual.... From this location you can 
easily navigate to any of the chapters or the table of contents.

Note: When navigating in the online User Manual, you can easily return to the User 
Manual Table Title Page by clicking on the footer text: EnSight User Manual.

Interface Manual The Interface Manual provides details on interface API’s, as well as customization 
available through issuing commands to EnSight via a socket interface or through 
Python.

Note: The manuals contain useful navigation bookmarks which have been set up 
automatically for your PDF viewer. Also we encourage the use of the search function 
of your PDF viewer.
vi Getting Started with EnSight 10



1 EnSight Graphical User Interface

This chapter provides a quick introduction to the EnSight Graphical User Interface. In 
this chapter you will explore the layout of the user interface. Conventions used in the 
interface (such as how to select multiple items in a list) will also be discussed.

Note: If you are using EnSight Lite, this chapter will explain some icons/features 
which are NOT available to you.
Getting Started with EnSight 10 1-1



Tour of the GUI
1.1 Tour of the GUI

The major components of the EnSight user interface are shown below.

Main Menu The Main menu provides access to basic EnSight functionality.  The Help menu (at the 
far right end of the menu bar) contains items for accessing online help.

Message/Feedback 
Area

The Message area displays brief messages during various operations. 

Information Button Clicking the Information button  in the Tools Icon Bar will bring up the EnSight 
Message Window where additional information about EnSight operations is displayed. 

The color of the Information button will indicate when content is present .

Parts List The Parts List displays all parts associated with the current session. A part is a named 
collection of elements (or cells) and associated nodes. All components of a part share 
the same set of attributes (such as color or line width).

Parts are accessed via the Parts list. Items in the list are selected by placing the mouse 
pointer over the item and clicking the left mouse button. You can extend a selection by 

Quick Action Icon Bar - shows attributes and functions for the last object 
selected - in this case part attributes.

Tools Icon Bar - contains Tools and Transformation control access.

Main Menu

Feature Icon Bar

Transient Controls

Parts List

List Panels - by default 
Variables, Annotations, 
Query/Plot and Viewports.  A 
tabbed interface showing any 
one of these at a time.

Message/Feedback Area

Graphics Window

Note: This whole upper 
level of the GUI is referred 
to as the “Desktop”
1-2 Getting Started with EnSight 10



Tour of the GUI
pressing the shift key as you click an item. Additional techniques for selecting parts 
are discussed on page 1-10.

Understanding part concepts is crucial for productive use of EnSight. See section 
3.3 Parts and Part Attributes for more information on parts. 

Feature Icon Bar The Feature Icon Bar contains icons associated with the major “features” of EnSight 
(not all of which will be showing by default). Clicking the left mouse button on an 
icon selects the feature and opens the associated interface in the Feature Panel.

Attached to the Feature Icon bar are the secondary features. By default contours, 
isosurfaces, clips, vector arrows, and particle traces. These icons are simply fast access 
to the Features, i.e., if you click on the Clip icon it sets the Part feature into the clip 
setting. 

All of the features (and secondary features) on the Feature Icon Bar can be customized. 
Simply right click on the Feature Icon Bar and select  Customize Feature Toolbar...

Features include the following:

Part Icon Opens the Parts Feature Panel which allows editing and 
creation of parts.

Variable 
Calculator

Opens the variable calculator, for creating computed 
variables.

Query/Plot Opens the Query/plot Feature Panel allowing editing and 
creation of queries and plotters.

Interactive 
Query

Provides controls for specifying interactive queries, which 
display variable values as the mouse is moved over objects in 
the Graphics Window, as the cursor tool is moved within a 
volume, or at specific node, element, ijk, or xyz locations. 

Viewports Opens the Viewports Feature Panel and allows the editing and 
creation of viewports. 

Annotations Opens the Annotation Feature Panel and allows the editing 
and creation of various annotations such as text, lines, dials, 
etc.

Solution Time Provides controls for managing time for transient datasets.
This icon is only present for transient data.

Flipbook 
Animation

Provides controls for specifying Flipbook animations.  
Flipbook animations are on-screen animations that permit 
graphic transformations during playback.  Flipbooks can be 
used to animate clipping planes and isosurfaces and are also 
useful for visualizing transient data 

Keyframe 
Animation

Provides controls for specifying keyframe animations.  
Keyframe animation provides sophisticated motion control 
and output options for generating animations for either online 
presentation (e.g. MPEG) or video.
Getting Started with EnSight 10 1-3



Tour of the GUI
Other Secondary Features not shown in the typical start GUI (Use Right click to 
Customize the Feature Icon bar to add these)

User Defined 
Tools

Provides a user interface to plug-in extensions from CEI and 
site or user customization.

Contour Create or modify a new contour (isoline) part using the part(s) 
selected in the Parts list as parents and the specified variable.

Isosurface Create or modify a new isosurface part using the part(s) 
selected in the Parts list as parents and based on an isovalue 
of the variable specified.

Clip Create or modify a new clip part using the part(s) selected in 
the Parts list as parents.  EnSight can create several types of 
clips including 1D line clips, planar clips, and quadric clips.

Vector Arrows Create or modify a new vector arrow part using the part(s) 
selected in the Parts list as parents and the variable specified.  
Vector arrows display direction and magnitude of a vector 
variable.

Particle Trace Create or modify a new particle trace part using the part(s) 
selected in the Parts list as parents and the variable specified 
as the velocity variable.

Subset Parts Create or modify a new subset part from node and/or element 
label ranges of model parts.

Profile Plot Create or modify a new profile plot part using the part(s) 
selected in the Parts list as parents and the variable specified.  
A profile plot is the 1D counterpart of an elevated surface.

Elevated 
Surface

Create or modify a new elevated surface part using the part(s) 
selected in the Parts list as parents and the variable specified.  
An elevated surface is a surface projected away from another 
surface with scaling based on the value of a variable.

Vortex Cores Create or modify a vortex core part using the part(s) selected 
in the Parts list as parents and the variable specified.

Shock Surfaces/ 
Regions 

Create or modify a shock surface or region part using the 
part(s) selected in the Parts list as parents and the variable 
specified.

Separation/ 
Attachment 
Lines

Create or modify separation or attachment line parts using the 
part(s) selected in the Parts list as parents and the variable 
specified.
1-4 Getting Started with EnSight 10



Tour of the GUI
Feature Panel The Feature Panel provides the interface controls associated with the current feature 
selected from the Feature Icon bar.

The Feature Panels provide “Create” buttons. Clicking the Create button will build a 
new object (such as an isosurface, clipping plane, or text annotation) based on current 
settings. Once built, the new object will appear in one of the object list panels (part, 
annotation, viewports, etc.).

Quick Action
 Icon Bar

The Quick Action Icon Bar displays the icons associated with the most recently 
selected object (such as part, annotation, viewport, etc.). The icons displayed will 
depend on what object is selected. By default the Quick Action Icon Bar is displayed 
on the same level as the Feature Icon Bar but you are free to move it wherever you 
want by grabbing it by the tear off marker and dragging it to a new location. The Quick 
Icon Reference in the How To Manual online documentation provides a quick 
reference for all EnSight icons as well as hotlinks from the icons to relevant online 
articles.

Material Part Create or modify parts which are based on the intersection or 
domain of elements with mixed material values.

Tensor Glyph Create or modify a tensor glyph part using the part(s) selected 
in the Parts list (as parents) and the tensor specified. This icon 
is invisible by default.

Developed 
Surface

Create or modify a new developed surface part using the 
part(s) selected in the Parts list as parents.  A developed 
surface is constructed by unrolling a quadric clip about its 
axis of revolution.

Point Part Create or modify a point part from specified locations in a 
parent part selected in the Parts list. A point part consists only 
of points and their variable values from the parent part. Think 
of a point part as a point clip.

Extrusion Part Create or modify a new extrusion part using the part(s) 
selected in the Parts list as parents. An extrusion part is the 
3D part created from rotating or translating a 2D parent part 
and incrementally creating 3D elements from the 2D parent.
Getting Started with EnSight 10 1-5



Tour of the GUI
Transformation 
Control Area of 
Tools Icon Bar

The Transformation Control Area provides icons that control various aspects of object 
transformations. Transformations are accomplished by selecting the action (such as 
rotate), moving the mouse into the Graphics Window, clicking and holding the left 
mouse button, and dragging the mouse to achieve the desired transformation. Also 
keep in mind that rotate, translate and zoom are by default attached to the left, middle, 
and right mouse buttons.

Several transforms are found in the transformations pulldown (which effectively maps 
the transform to the mouse key (by default left) attached to the “current’ transform.

The possible actions are:

Rotate Rotate: click and drag
• left-right to rotate about the vertical axis
• up-down to rotate about the horizontal axis
• left-right or up-down with the control key pressed 

to rotate about the screen Z axis.

Translate Translate: click and drag
• left-right to translate in the horizontal direction
• up-down to translate in the vertical direction
• left-right or up-down with the control key pressed 

to translate in Z.

Zoom Zoom: click and drag
• up/right to zoom out or down/left to zoom in 
• with control key pressed to pan

Zoom is implemented by moving the look from point.

Band Zoom Rubber-band zoom: click and hold the left mouse button 
on one corner of the desired viewing region, drag to 
opposite corner.  An outline of the region will appear as 
you drag.  Release the mouse button to zoom to the 
outlined region.

Rubberband 
region

Selection tool: click and hold the left mouse button on 
one corner of the desired viewing region, drag to 
opposite corner. An outline of the region will appear as 
you drag. Release the mouse button to see the selection 
tool. Adjust the center or corner locations of the tool 
further if needed. Then click the magnifying glass 
symbol near upper left corner to zoom. Or click the 
eraser symbol to blank out elements under the tool.
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Tour of the GUI
Graphics Window All 3D objects, as well as annotation entities, are displayed in the Graphics Window. 
The Graphics Window can contain additional (up to fifteen) user-defined viewports as 
well as X-Y plots.

Transformation 
Editor...

Opens the Transformation Editor dialog. From within 
this editor, all global transforms (including scaling 
where appropriate) as well as frame and tool transforms 
can be controlled. There is also control of the center of 
transform, look-at/look-from locations, and z-clipping.

Reset... Open the Reset Tools and Viewports dialog that permits 
easy resetting of all or some transformation operations.

Reset 
Transforms

Resets the global transforms for the current viewport.

Fit

     

Fits the currently visible model in the currently selected 
viewport and resets the center of transform to center of 
visible parts.

Standard or 
Saved Views      

A pulldown to set +/- X/Y/Z views or to bring up the 
views manager to store/recall saved views.

Undo Allows the user to undo/redo the last transformation.

information Read informational feedback for EnSight status
Getting Started with EnSight 10 1-7



User Interface Conventions
1.2 User Interface Conventions

The EnSight user interface uses standard menus, dialogs, buttons, and other interface 
components. This section provides information on these components as well as 
instructions for interaction.

Dialog Windows A dialog is a window that groups interface components based on function. Dialogs are 
typically opened by making selections from a menu or clicking an icon. Menu 
selections and icons that open dialogs usually end with “...”. Most EnSight dialogs can 
be opened and closed independently. In order to optimize scarce workstation screen 
real estate, you should close dialogs that are not in use. The default position of each 
dialog was chosen to best use the space available. You can, however, move the dialogs 
using your window manager - the next time you restart EnSight the dialogs should be 
the same size and location.

Dialogs typically consist of buttons, menus, lists, and areas to type in.  Some EnSight 
dialogs also have expandable sections that let you hide parts of the interface that you 
use infrequently.  Each expandable section consists of an indicator button, a section 
title, and the contents of the section.  The indicator button and the section title are 
always visible.  If the section is open, the contents are visible as well.

The indicator button is a toggle switch for 
opening and closing the section.  Aright-
pointing arrow indicates a closed section.  
Clicking the arrow will open the section.  
A down pointing arrow indicates an open 
section.  Clicking the arrow will close the 
section.  These indicators are referred to as 
turndown buttons.
1-8 Getting Started with EnSight 10



User Interface Conventions
Menus The EnSight documentation uses the following terms to describe various types of 
menus:

Menu bar A horizontal strip across the top of a dialog listing menu 
titles.

Pull-down menu A pull-down menu is one accessed directly from a menu 
bar.

Cascade menu or
submenu

A submenu is accessed from another menu selection.  
Submenu selections are indicated by a right-pointing 
arrow.

Options menu  or pop-
up menu

An options menu is accessed by pressing the associated 
button.  The current selection always appears as the 
button title.

Menu bar

Pull-down menu

Cascade menu
Getting Started with EnSight 10 1-9



User Interface Conventions
Lists Lists (such as Variable lists and the Parts list) are presented in panels or dialogs as 
scrollable sections. Various mechanisms are used to select items from a list for further 
action:

You can also double-click list items which is the same action as right clicking and 
selecting Edit... To double-click, place the mouse pointer over the item and click the 
left mouse button twice in rapid succession.

To... Do This... Details...

Select an item  Single-click Place the mouse pointer over the item and 
click the left mouse button.  The item is 
highlighted to reflect the “selected” state.

Extend a (possibly 
long) contiguous 
selection

Shift-click Place the mouse pointer over the item.  Press 
the shift key and click the left mouse button.  
This action will extend a selection to include 
all those items sequentially listed between the 
previous selection and this one.

Extend a non-
contiguous 
selection

Control-click Place the mouse pointer over the item.  Press 
the control key and click the left mouse 
button.  This action will extend a selection by 
adding the new item, but not those in-between 
any previously selected items.

De-select an item Control-click Place the mouse pointer over the selected 
item.  Press the control key and click the left 
mouse button.  This action will de-select the 
item.

Shortcuts Right-click Place the mouse pointer over the selected 
item in a list or in the graphics window and 
click the right mouse button. This action will 
pop up a context-sensitive pulldown list if 
available.
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User Interface Conventions
Buttons EnSight uses the following kinds of buttons:

Rectangular Place the mouse cursor in the button area and click the left mouse 
button.  Rectangular buttons typically access the function described 
in the label.  If the label is followed by “...” then the button opens 
another dialog.

Arrow Place the mouse cursor in the button area and click the left mouse 
button.  Arrow buttons typically have an associated text field or 
scroll bar.  Clicking the button increments or decrements the text 
field or scroll bar value.

Diamond Place the mouse cursor in the button area and click the left mouse 
button. Diamond buttons (also called radio buttons) are toggles that 
select an item from a mutually exclusive list. Exactly one diamond 
button of a group can be on at any given time. 

Square Place the mouse cursor in the button area and click the left mouse 
button.  Square buttons are toggles that access the function 
indicated by the label.
Getting Started with EnSight 10 1-11



User Interface Conventions
Text Fields EnSight utilizes two types of text fields:

Where appropriate (i.e. in File Selection dialogs), EnSight recognizes the following 
shortcut specifications for directories:

Note that standard wildcard characters (e.g. * to represent a series of zero or more 
arbitrary characters) can also be used in File Selection dialogs.

Information
Text Fields

These text fields are used to report information and cannot be edited 
by the user. 

Editable Text
Fields

Place the mouse cursor in the text field and click to insert a blinking 
insertion cursor. Several techniques are available to accelerate text 
editing. Select a single word by double-clicking or the entire string 
by triple-clicking. Selected text is replaced by subsequent typing. 
The left and right arrow keys (on most systems) will move the 
insertion cursor.

~/ Expands to your home directory.

~username/ Expands to the home directory of username.

./ Expands to the current working directory.

../ Expands to the parent directory of the current working directory
1-12 Getting Started with EnSight 10



Where’s the Rest?
1.3 Where’s the Rest?

See Starting EnSight in Chapter 2 and familiarize yourself with the EnSight user 
interface, then proceed to Chapter 3, Simple Demonstration.

Several online articles provide overview and reference information. See the EnSight 
Overview (Help > EnSight Overview...) and the Quick Icon Reference (Help > Quick 
Icon Reference...).

For additional overview information, see Chapter 1 of the User Manual.

Finally, the table of contents as well as internal links, are easily navigated. For 
questions related to a specific task, see the How To Manual (Help > How To 
Manual...). For detailed information on a feature or concept, see the User Manual 
(Help > User Manual...).
Getting Started with EnSight 10 1-13
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2 Starting EnSight
EnSight can be started by double clicking icons or by typing commands in a shell 
window.  EnSight can run in a stand-alone manner (client and server process both on 
the same machine, started simultaneously) or as separate processes (client and server 
started separately on the same or separate machines and provided connection 
parameters to link the two processes). This chapter provides a quick introduction to 
various ways of starting and connecting EnSight.
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Necessary Prerequisites
2.1 Necessary Prerequisites

EnSight must have been installed and the CEI_HOME and PATH environment variables 
setup properly. If you successfully performed the installation verification as described 
in the Installation Guide, you have verified that these things are correct.  Note that the 
different versions of EnSight shown below can all be simultaneously installed to the 
same $CEI_HOME directory and work fine, using the same license manager.
(See $CEI_HOME/ensight100/doc/Manuals/Installation.pdf)

Note:
ensight100 - will start version 10.0
ensight92 - will start version 9.2
ensight91 - will start version 9.1
ensight90 - will start version 9.0
ensight82 - will start version 8.2
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Starting EnSight for Stand-alone Use
2.2 Starting EnSight for Stand-alone Use

If you want to run EnSight in a stand-alone manner (i.e. the Client and Server are both 
running on the same workstation), you can use these simplified steps to start EnSight 
and auto-connect the Client and Server processes.

This will automatically start both the Client and the Server and make the connection. 
To see if the connection is successful, you can click on the Information button on the 
EnSight Desktop. You should see “Connection accepted” in the EnSight Message 
Window which comes up. You should now close the EnSight Message Window and 
proceed to the next section.

If the connection failed, please consult Troubleshooting the Connection in the 
Installation Guide before contacting CEI support.

(See $CEI_HOME/ensight100/doc/Manuals/Installation.pdf)

1. Log into the machine on which the EnSight Client and Server have been installed.

For Linux Systems:

2. Open a shell window and start 
EnSight using the ensight100 
shell script:

For Windows Systems:

2. Start EnSight by double 
clicking on the EnSight 
10.0 icon on the desktop:

Or by choosing EnSight 10.0 
from the Start > Programs > 
CEI menu.

For Mac Systems:

2. Start the EnSight100 app in the 
Applications folder.

ensight100

EnSight 10.0

Reveal 3.0

EnLiten 10.0

EnVe 3.2

EnVideo 10.0EnVideo 

EnSight 10.0

EnSightCFD3

EnSight 10.0

EnSight100

Note:
ensight100 - will start version 10.0
ensight92 - will start version 9.2
ensight91 - will start version 9.1
ensight90 - will start version 9.0
ensight82 - will start version 8.2
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Starting EnSight for Distributed Use - Manual Connection
2.3 Starting EnSight for Distributed Use - Manual Con-
nection

You can perform a manual connection where the Client is started in manual connection 
mode waiting for a server, and the server is started separately and told to connect to the 
waiting Client. 

See How To Connect EnSight Client & Server (Help > How To Manual ...) in the 
online documentation for details. 

(For information on the online help facility, see Using Online Help on page 3-14.)
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2.4 Starting EnSight for Distributed Use - Automatic 
Connection

You can perform an automatic connection where the Server starts automatically and 
connects to the Client, even though the two processes are on different host systems.  
This type of connection requires some initial setup and is not discussed in the Getting 
Started manual.  However, once configured, the automatic connection lets you start a 
session in a single step.  

See How To Connect EnSight Client & Server (Help > How To Manual ...) in the 
online documentation for details. 

(For information on the online help facility, see Using Online Help on page 3-14.)
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Welcome Screen
2.5 Welcome Screen

The first thing you will see when you start EnSight 10 is the Welcome screen.

From the Welcome screen you can load a session file, most recently used data, view 
screencast tutorials, or jump to a file dialog to load new data.

Sessions Tab

A list of example session files are provided with the 10.0 release and show up in the 
Welcome Screen under the Sessions tab.  As you select each one in the list, a preview 
image will appear together with a brief description.  To load a session file simply select 
it and hit the Open button.

A session file is a binary file containing state information and may (optionally) contain 
the data.   As shown below, a session file can be saved by the user by selecting the 
Save Session.... option from the File pulldown. Notice also that the version of EnSight 
as well as the dataset name is shown in the title bar at the top.
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Welcome Screen
Data Tab

From the Welcome Screen Data tab you are presented with a list of the most recently 
used datasets that you have loaded.  This is functionally equivalent to accessing this 
list via the File->Open recent data file.

To use simply select the dataset you wish to load and hit the Open button.

Tips and Tutorials

This area of the Welcome Screen dialog will show you a link to a screencast containing 
the tip described.  The up/down arrow buttons allow you to browse the available 
screencasts.  The screencasts are streamed and require an internet connection.

News from CEI

This area of the Welcome Screen dialog will show you a link to the latest 
communications from CEI.  The up/down arrow buttons will allow you to browse the 
available news communications. This requires an internet connection.

Cancel

Select this button to dismiss this dialog.  Next step for you will likely be an option 
under the File pulldown.

Welcome Screen Visibility

Toggle off the “Show this window at startup” if you do not wish to see this dialog at 
startup.  You will still have the option to later see the Welcome Screen from EnSight’s 
Window menu as shown below.
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3 Simple Demonstration

This chapter provides a step-by-step demonstration of basic EnSight operation.  After 
successfully completing this chapter, you should be able to:

• read a dataset and load a model,

• transform objects in the Graphics Window: rotate, translate, and zoom,

• reset transformations,

• work with parts and change part attributes,

• save an image of the graphics window to a file,

• access the online documentation,

• exit EnSight.
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Reading a Dataset
3.1 Reading a Dataset

After starting EnSight, the next step in any session is to read a dataset and load the 
parts. To read a dataset, the relevant files and data format must be specified. EnSight 
supports several common computational analysis formats. In addition, EnSight also 
supports native formats suitable for storing both block structured and unstructured (i.e. 
finite-element) geometry. In this example, we will load an EnSight native format file.

Welcome Screen

After you start EnSight you will see the Welcome screen

From this window you can read sessions (data plus commands) or the most recently 
used data sets. In fact, for this particular example you can read the data by simply 
choosing Frame Dataset from the Sessions tab followed by a "Open". Your starting 
view will be slightly different than if you read the data with the instructions below but 
no harm done. Or select the Cancel button to load data from the File menu as described 
in the next few pages.
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Reading a Dataset
Drag and Drop

For many file formats, drag-n-drop will load your initial data. For recognized formats, 
you can start EnSight and drag the data file onto EnSight’s window, or you can drag 
the dataset onto the EnSight executable icon on your desktop. 

See Help > How To Manual ... (and select How To Read Data) for more information 
on data reading. In this case, you can also get there by clicking the Help button.

For more control over the data loading process, or to load additional data:.

1. Select File > Open... from the EnSight Main menu.

For EnSight to properly read data, it must know both the file name and format. When File > Open... is used, 
EnSight attempts to obtain this information from the suffix of the chosen file. If the file suffix is known to 
EnSight (as contained in an association file), it can proceed to read the data and load all of the files into 
EnSight. If an association is not known, EnSight will ask for more information. In this example, we will 
load a simple geometry in a known format.

2. Navigate to the $CEI_HOME/ensight100/data/frame directory.

Note: On Windows you can type “/*” in the Look in: field to display the mounted drives.

3. Click frame.case

4. Make sure you are using the 
Simple Interface

5. Click OK to accept the 
selections and close the 
dialog window.
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Reading a Dataset
When the File Selection dialog is closed, EnSight reads the data and loads all four 
model parts (they will be listed in the Parts list and displayed in the Graphics 
Window). They will not be oriented as below, but that is okay.

Note: To improve the legibility of the Getting Started manual, the images in the 
Graphics Window are shown with a white background rather than the default dark 
background that EnSight uses.

If you desire to only load some of the parts, or to use different representations as they 
are loaded, this is easily done. See How To Read Data (Help > How To Manual ...) for 
information on the two-step method of reading and loading data.

Getting Your Data Into EnSight
EnSight supports a number of common data formats as well as interfaces to various 
simulation packages. In order to keep the list of readers and translators as current as 
possible, tables are maintained on our website. Please go to the following location to 
see the latest (http://www.ceisoftware.com/data-interfaces/).
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Performing Transformations
3.2 Performing Transformations
It’s easy to rotate, translate, and zoom the geometry displayed in the Graphics Window.

Note: By default EnSight ships with the left mouse button defined to do Transformation Actions 
(by default set to Rotate), the middle button click and move defined to do Translations directly, 
the right mouse button (or rolling the mouse wheel) defined to do Zoom operations directly.

The assignment of operations to mouse buttons can be customized by the user.

Rotate using the mouse:

1. Move the mouse pointer into the Graphics 
Window.

2. Click and hold the left mouse button and 
drag the mouse left and right. The model 
rotates about the screen vertical axis.

3. Drag the mouse up and down. The model 
rotates about the screen horizontal axis.

4. Hold down the control key and move the 
mouse left and right. The model rotates 
about the screen perpendicular axis.

5. Or, to redefine the left mouse button (if it 
has been changed to something else), 
select the Graphics Window Transforms 
icon and choose Rotate from the pulldown.

Translate using the mouse: or:

1. Move the mouse pointer into the 
Graphics Window.

2. Click and hold the center mouse 
button and drag the mouse left and 
right. The model translates 
horizontally.

3. Drag the mouse up and down. The 
model translates vertically.

4. Hold down the control key and move 
the mouse left and right. The model 
translates in and out along the axis 
perpendicular to the screen.

5. To redefine the left mouse button, 
select the Graphic Window Transform 
icon and choose Translate from the 
pulldown.

6. Move the mouse pointer into the 
Graphics Window.

7. Click and hold the left mouse button 
and drag the mouse left and right. The 
model translates horizontally.

8. Drag the mouse up and down. The 
model translates vertically.

9. Hold down the control key and move 
the mouse left and right. The model 
translates in and out along the axis 
perpendicular to the screen.
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Performing Transformations
See How To Rotate, Zoom, Translate, Scale (Help > How To Manual ...) for more 
information on model transformations.

At this point, you have probably transformed the 
model into a strange orientation.  Before going on 
set the transformation mode back to Rotate

Then click on the Reinitialize View icon.

See How To Reset Tools and Viewports (Help > 
How To Manual ...) for more information on 
resetting transformations.
 

Zoom using the mouse: or:

1. Move the mouse pointer into the 
Graphics Window.

2. Click and hold the right mouse 
button and drag the mouse up or to 
the right. The “camera” zooms out.

3. Drag the mouse down or to the left. 
The “camera” zooms in.

4. Hold down the control key and move 
the mouse. The “camera” pans.

5. To redefine the left mouse button, 
select the Graphic Window Transform 
icon and choose from the pulldown 
Zoom.

6. Move the mouse pointer into the 
Graphics Window.

7. Click and hold the left mouse button 
and drag the mouse up or to the right. 
The “camera” zooms out.

8. Drag the mouse down or to the left. The 
“camera” zooms in.

9. Hold down the control key and move 
the mouse. The “camera” pans.

Note that the zoom operation actually moves the virtual camera rather than moving 
the geometry.
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You can also perform precise transformations (such as rotating 22.5 degrees about the X axis) using the 
Transformation Editor

1. Click Transformation editor... in the Transformation pulldown.

This opens the Transformation Editor dialog in Global Transform mode.



Performing Transformations
2. Select Rotate icon in the Transformation Editor dialog.

3. Select X Axis.

4. Place the mouse pointer in the Increment field and 
triple-click   the left mouse button to select the entire 
value “1.000000”.

5. Enter the value “22.5”, then slick the right arrow button.

The model will be rotated precisely 22.5 degrees about the 
X axis (in either the negative or positive direction) when 
you click the arrow buttons.

6. Grab the slider (click and hold the left mouse button) 
and drag left and right. Note that the actual number of 
degrees rotated is printed above the slider thumb switch 
as it is moved.

Experiment with the Transformation Editor – set Axis to 
other values or change the current action in the 
Transformation Control area to edit translation or scale. (If 
the model doesn’t seem to move in the translate mode, 
increase the increment and limit, press Enter, and move the 
slider again.) When you are done:

7. Click Close.

8. Reinitialize all transformations by clicking on the Reinitialize 
View icon as described above.
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Parts and Part Attributes
3.3 Parts and Part Attributes

Since virtually every task you perform in EnSight involves some form of part 
manipulation, it is vital to understand how parts work.

Parts are either built during the reading/loading process (such as File > Open...) or 
created during an EnSight session. Parts created during reading/loading are called 
model parts and are based on your computational mesh and associated surfaces as 
defined in your data files. Model parts can also be created during an EnSight session 
by performing geometric operations (such as a copy) on other model parts.

All other parts are created during an EnSight session and are called created or derived 
parts. Created parts are built using one or more other parts as the parent parts. The 
created parts are said to depend on the parent parts. If one or more of the parent parts 
change, all parts depending on those parent parts are automatically recalculated and 
redisplayed to reflect the change. Examples of created parts include clipping planes, 
isosurfaces, isocontours, and particle traces.

Only model parts will be used in this section.  The next two chapters will work with 
created parts.

The Parts list provides access to all parts. Each part is listed individually in a scrollable 
list. By default, each entry provides a part descriptor (name) and additional pieces of 
information:

EnSight provides a large number of attributes that can be edited on a per-part basis. 
Attributes control the appearance or behavior of parts. Examples include visibility, 
color, line width, and transparency. Part attributes for selected parts can be changed via 
the Quick Action Icon bar. Some global part attributes can be changed in the View 
Menu. For example, Main Menu > View > Shaded (or the shaded toggle on the 
desktop) enables/disables shaded surface display for all parts. For example, there is a 
shaded surface icon in the Quick Acton Icon Bar for parts that enables/disables shaded 
surface display on a per-part basis, and a global toggle on the Tools Icon Bar that turns 
it on and off on a global basis.

Many operations in EnSight (such as setting attributes) require that the parts to be 
acted upon are selected (highlighted) prior to the operation. Items in the Parts list are 
selected by placing the mouse pointer over the item and clicking the left mouse button. 
You can extend a selection by pressing the shift or control key as you click an item. 
Additional techniques for selecting items in lists are discussed on page 1-10.

Part number or Part ID 
(as designated in the data 
or assigned by EnSight)

Case number

Part Descriptor

Part Visibility

Part Color and what 
variable it’s colored by
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Parts and Part Attributes
In the remainder of this section, we will explore parts and changing part attributes.

The first task is to enable shaded (hidden surface) display. By default, the part-specific 
shaded attribute is on. By toggling on the corresponding Shaded toggle on the 
Desktop, we enable hidden surface display for all parts.

Parts are assigned a default color when loaded into EnSight.  These colors are 
constant, meaning that every portion of the part is colored the same.  Parts can also be 
colored by a variable value.  Since the value associated with a variable typically varies 
from node to node, the displayed color will vary across the surface of the part.

1. If the Shaded Toggle is not ON, click it to toggle shaded surface 
display for all parts (icon becomes brighter). Leave shaded ON.

All objects in the Graphics Window are now displayed with shaded 
surfaces. Turning this toggle off will result in a wireframe display. We can 
now selectively disable shaded display for individual parts.

2. Select the “green arrow” and “blue arrow” parts in the Parts list: place 
the mouse pointer over the green arrow part, click the left mouse 
button, followed by a Ctrl left click (push and hold the Ctrl button on 
the keyboard and press the left mouse button) on the blue arrow part.  
When completed both parts should be highlighted in the Part list. Note 
that the selected parts are highlighted in the graphics area. To toggle 
this off, click on the Highlight Selected parts icon.Toggle it back ON.

3. Click the Part Shaded Toggle to disable shaded surface display for the 
selected parts.

Note that the Part Shaded Toggle icon changes (the icon will be dimmed)  
to reflect the fact that the selected parts have shaded disabled.

Let’s change the line width of the selected parts:

4. Click the Part Line Width pulldown and select 3 Pixels from the menu.

Note that the line width of the selected parts (the arrows) has increased.

5. Select the “frame base” part in the Parts list.

6. Click the Part Visibility Toggle to disable display of the part.

After these operations, the geometry in your Graphics Display should look 
like the following.
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Parts and Part Attributes
To change part colors:

See How To Change Color (Help > How To Manual ...) for more information.

7. Select all the parts in the Parts list by using the Left 
mouse button to click on the Case1 line in the Part 
list.

8. Click the Color/transparency icon in the Quick 
Action icon bar.

The Part color, lighting, & transparency dialog opens.  
(Note that the variables list is set to Constant Color.)

9. Pick a shade of gray from the bottom row of the 
color palette.

Note that all parts in the Graphics Window are now 
colored by the same shade of gray.

Although this dataset has no associated variable data, we 
can still color the parts by a variable since EnSight 
provides some defaults: Coordinates and Time.  The 
Coordinates variable treats the XYZ coordinate of a 
node as a vector; color is assigned based on the 
magnitude of that vector.

10.  Select Coordinates from the Color by list.

Note the color change. The left rear post of the frame is 
closest to the origin of the coordinate system and is 
colored blue. The right front post of the frame farthest 
from the origin is colored red.

Another way to color a part is to utilize the 
extensive right click capability.  To test this 
reselect all of the parts using Step 7

11. Right click on any of the selected parts in 
the list which brings up a right click menu.

12.  Select “Color By” then either select “Select 
Variable” or “Select Color” 
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Parts and Part Attributes
Up to this point, all parts have been selected by clicking in the Parts list. You can also 
select parts by picking them in the Graphics Window. Although this dataset contains 
only four parts, most contain many more and selecting parts via the list can become 
tedious. To select parts by picking:

See How To Display Labels (Help > How To Manual ...) for more information.

13. Move the mouse into the Graphics Window and place the pointer 
over the arrow on the left side of the model.

14. Left click on this part.

Look at the Parts list: the “green arrow” part (number 2) should now 
be the only part selected.  (If this is not the case, be sure the mouse 
pointer is directly over one of the lines of the part left-click again.)

15. Move the mouse pointer over the arrow on the right side of the 
model.

16. Press and hold the control key.  With the control key still down, 
left-click the mouse button while it is over the right arrow part.

Holding down the control key during the pick extends the current 
selection: both the “green arrow” and the “blue arrow” parts should 
now be selected in the Parts list. See How To Select Parts (Help > 
How To Manual ...) for more information.

Note that the selected parts are highlighted in the graphics window to 
assist you in identifying selected parts.     

17. Toggle the highlight parts toggle OFF.

EnSight indicates in the graphics window which parts are selected as 
long as the global toggle is ON.

18.  Now toggle the highlight parts toggle ON.

19. Click the Part Shaded Toggle to enable shaded surface display for 
the selected parts.

20. Select the “frame base” part in the Parts list.

21. Click the Part Visibility Toggle to enable display of the part.

EnSight can display node and element labels on selected parts.  The 
label values are either provided explicitly from the dataset or are 
provided by EnSight.  To display node labels:

22. Click the Node/Element Labeling icon, and toggle on Node label 
visibility in the dialog that comes up, then close the dialog.
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Parts and Part Attributes
After these operations (and some rotate and zoom transformations) your Graphics 
Window should look something like the following. (Note that the node labels have 
been colored black here to contrast with the white background – your labels will be 
white on a darkened background.)
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Saving Files
3.4 Saving Files
Saving Images

EnSight supports several formats for image output. In this example, both PNG and 
JPEG files will be saved.

See How To Print/Save an Image (Help > How To Manual ...) for more information on 
image formats and options.

For Quick output:
1. Right click on the graphics window background and select Send Image To 

and choose File.  Name the file and pick a location.  The image is saved in 
PNG format, the size of the graphics window, with all the default image 
settings.

Detailed output options:
2. Select File > Export > Image... to open the Save Image dialog.  By 

default, EnVideo is selected.

3. Click on Set Format...
 and select JPEG image file.

4. Click OK to close the format dialog.

5. Enter a file prefix in the To File field, and              
hit Return.

Note: By default, EnSight will save images in the directory from which the Client is started. Since this directory is part 
of the EnSight distribution, it is probably write protected. To save the image in your home directory instead, on a Linux 
system prefix the filename with “~/”. On a Windows system, use “~\”. Note on Windows, ~ = C:\Documents and 
Settings\username

6. Click on Convert to Default Print Colors
 (changes background to white and white objects to 
black).

7. Click OK 
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3.5 Using Online Help
EnSight 10 provides several manuals online. The two you will use most often are:

How To The How To documentation consists of relatively short articles that describe how to 
perform a specific operation in EnSight, such as change the color of an object or create 
an isosurface.  Step-by-step instructions and pictures of relevant dialogs are included.  
In addition, each How To article typically contains numerous hyperlinks (colored blue) 
to other related articles (and relevant sections of the User Manual).

User Manual The User Manual provides a detailed reference for EnSight.

Several documents are directly accessible from the main Help menu. The remainder 
can be accessed through hyperlinks or a table of contents. Most of the complex dialogs 
within EnSight have help buttons that will open a corresponding How To article.

To open the How To Table of Contents:

1. Select Help > How To Manual...

The EnSight online documentation uses a PDF viewer. The PDF viewer provides much the same 
functionality as a World Wide Web browser while providing greater control over document content quality. 
The user interface is very simple and provides intuitive navigation controls.

Besides the use of bookmarks for navigation, The following can be used:

• Clicking on the 
house icon will 
return you to the 
How To table of 
contents.

• Blue text is a link: 
clicking on it will 
jump to a new 
location.

• You can go back to 
the previously 
viewed page by 
clicking the back 
button (very similar 
to a Web browser).

The How To articles are 
heavily cross-linked 
and also provide links 
to relevant sections of 
the User Manual.

For more information 
on using Acrobat 
Reader (including 
printing) and the How 
To documentation, click 
on the question mark 
beside the house icon.
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To access the User Manual table of contents:

Printing the 
documentation

Adobe Acrobat .pdf files for all documentation are included on the EnSight CD 
distribution (and were placed in the $CEI_HOME/ensight100/doc/Manuals directory 
during the installation process). These documents (GettingStarted.pdf, HowTo.pdf, 
UserManual.pdf, and others for advanced users) have been optimized for printing and 
formatted for letter-size paper.

You can open these files and print any or all pages from within a pdf reader, or you can 
order printed copies from our website.

1. Select Help > User Manual... from the EnSight Main menu, then click “Table of Contents” on the 
title page itself or in the Bookmark list.

2. The User Manual contains blue hypertext links just like the How To articles: you can click on items 
and jump to a new location:

• chapter and 
section entries in 
the table of 
contents

• cross references in 
the text that begin 
“See ...”

• the footer of every 
page will jump 
back to the title 
page of the User 
Manual (from 
which you can 
jump to any 
chapter).

3. Close the reader 
when done.
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3.6 Exiting EnSight

All EnSight actions have a counterpart in the EnSight command language. During a 
session, all actions are being recorded to a default command file. When you exit 
EnSight, you have the option of saving this command file.

To quit EnSight:

If you toggle on Save Command Backup File To and save the commands (for example, 
to a file called file.enc), you could then start a subsequent Linux version EnSight 
session (from the same starting directory) with the command:

% ensight100 -p ~/file.enc

(assuming you are running stand-alone) to duplicate the entire session. You could 
accomplish the same thing by starting EnSight normally and then playing the 
command file from the command dialog (this would be the normal way to do it in the 
Windows version: File>Command and load the command file). See How To Record 
and Play Command Files (Help > How To Manual ...) for more information. In 
Windows, you can start EnSight and just drag the .enc command file from the desktop 
to the EnSight window and EnSight will recognize it as a command file and run it.

Note that the Quit Confirmation dialog also provides an option to save a “Full Backup 
Archive File”. An archive (which is saved for both the Client and the Server), contains 
a binary memory dump of the complete state of each system. Unlike replaying a 
command file (which has to re-execute every action), the restoration of an archive 
occurs very fast since only the saved memory state for each system is restored. See  
How To Save or Restore an Archive (Help > How To Manual ...) for more information.

1. Select File > Quit... from EnSight’s Main menu. The Quit 
Confirmation dialog opens.

2. Click OK to exit EnSight.
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3.7 Where’s the Rest?

After successfully completing this tutorial, you should proceed to the next 
demonstration. Although the next tutorial contains some material applicable to all 
users, it is intended primarily for analysts doing computational fluid dynamics (CFD) 
work. If your application area is not CFD, you may wish to consider skipping the next 
chapter and proceeding directly to Chapter 6.

The How To Manual contains details on the operations covered in this chapter. The 
following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual... 
(Help > How To Manual...), then the topic indicated below: 

Consult... For More Information On...

How To Read Data specifying data to read into EnSight

How To Rotate, Zoom, 
Translate, Scale

performing transformations in the Graphics Window 
as well as performing precise transformations using 
the Transformation Editor

How To Reset Tools and 
Viewports

resetting transformations back to the default settings

How To Select Parts selecting parts

How To Set Attributes setting part attributes
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4 Flow Visualization Example: 
Unstructured Mesh

This chapter provides step-by-step instructions for performing many basic 
postprocessing operations – especially those relevant to computational fluid dynamics 
analysis.  After successfully completing this chapter, you should be able to:

• create a clipping plane and display contours on the plane,

• move the clipping plane with the mouse (interactive clipping),

• create an isosurface and change the isovalue interactively,

• create a single particle trace and a rake of traces,

• move the rake of traces with the mouse (interactive particle tracing),

• animate particle traces,
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4.1 Reading a Dataset

In this demonstration, we will load a simple CFD model of a hypersonic vehicle with 
an 8 degree angle of attack and a 6 degree side-slip. The dataset includes velocity and 
pressure values.

The two constituent parts are now listed in the Parts list and displayed in the Graphics 
Window (with the flow field in feature angle mode and the hypersonic body part in full 
mode)

Note: To improve the legibility of the Getting Started manual, all images of the 
Graphics Window are shown with a white background rather than the default darkened 
background that EnSight uses.

1. Start Ensight as described in Chapter 2 and 
cancel the Welcome Screen.

2. Select File > Open... from the EnSight 
Main menu.

This opens the File Selection dialog.

3. Make sure the Simple Interface is selected.

4. Navigate to the 
$CEI_HOME/ensight100/data/ami 
directory.

5. Click ami.case in the Files list.

6. Click OK to accept the selection and close 
the dialog window.
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Since we don’t really need to see the flow field, we will make it invisible and fit the 
geometry to the window.

The model should now look like the following (but may be zoomed in further):

7. Select the external flow field part in the Part List.

8. Click the Visibility Icon in the Quick Action Icon bar.

9. Click Fit.
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4.2 Feature Demonstration

Unlike the dataset used in the previous chapter, this data contains two variables: 
pressure and velocity. The first step is to color the model by the pressure variable and 
display a color legend showing the mapping from variable values to color.

1. Select the “ami-x hypersonic body” part in the Parts list.

2. Toggle off the Highlight Parts When Selected toggle to turn 
off part selection highlighting.

3. Click the Color/transparency icon in the Quick Action icon 
bar to open the Color editor.

4. Select pressure variable in the ‘Color by’ list.

The color legend appears to the right of the model in the Graphics 
Window (default behavior - this is a user-controllable preference). 
Note that the display of legends can be 
controlled by right clicking on the proper 
Legend in the Annotation object list.

We won’t actually modify the legend visibility 
at this time. Also note that color legends have 
many display attributes – see How To Create 
Color Legends (Help > How To Manual ...) 
for more information.

5. Click the X to close the dialog.

Your Graphics Window should now appear similar to the
 following:

There are several other ways to color a part by a variable.  If 
your hardware is properly set up you can use drag and drop. 

6. In the Variable list open the Vectors group to find Velocity

7. Click with the left mouse button on Velocity and keep the 
mouse button pressed while you drag the mouse into the 
background of the graphics window.

8. Release the left mouse button.  This will now color all parts in 
the viewport by Velocity, as well as change the legend.

9. Open the Scalars group and drag and drop Pressure into the 
graphics window.
4-4 Getting Started with EnSight 10



Feature Demonstration
In the next sequence of operations, we will create a new part: an X clip.

Once the clipping plane has been created, we will build a contour part using the 
clipping plane as the parent part.

Clipping Plane Part

The new “Clip_plane” part listed in the Parts list has attributes just like the original 
model parts. For example, we can color the part based on the value of a variable and 
change other attributes as well (like we just did with its visibility).

10.  Like many things in EnSight there are several ways to perform the 
X clip operation.  We will take advantage of the right click 
capability.  In the Parts list right click on the “external flow field” 
part.

11. Select Clips, then X to create an X clip through the part you right 
clicked on at the default position, i.e., the mid point in the X 
direction.

Note that a new part “Clip_plane” is now listed in the Parts list.  There is also a 
new part in the Graphics Window but you cannot see it since it is perfectly 
parallel to our line of sight: rotate the model to see the clipping plane. See How 
To Create Clips (Help > How To Manual...) for more info.

12. Move the mouse pointer into the Graphics Window, click and hold 
the left mouse button and drag to rotate the model. Similarly, you 
may want to zoom the model by dragging the right mouse button (or 
rotating the mouse wheel) in the Graphics Window.

It might be better if the clip plane was not shaded, so we could see the model through it.

13.  If the Quick Action Icon bar is not currently showing part icons (i.e., the toolbar is showing the 
first icon to be a puzzle piece), click on the Clip_plane part in the Parts list.  Then click the 
Shaded icon in the Quick Action Icon bar.

Depending on how you rotated and zoomed, you should now see something like the following in the 
Graphics window.
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The following should be kept in mind when creating new parts in EnSight:

• A new part is created from one or more parent parts. You must select these parts 
either in the Part list or by selecting them in the graphics window. If you use right 
click the selection is performed during the right click operation.

• A part creation type is selected - either from right click, selecting the feature from 
the Secondary Feature bar, or selecting it from the Create pulldown.

• The new part is created either directly or through the Feature Panel after possibly 
modifying the creation attributes.

• Any desired attributes - visual or creation - are modified for the new part.

14. Click the Color icon in the Part Quick Action Icon bar.

15. Select velocity in the variables list and then close the dialog.

Your Graphics Window display should look something like the following:

16. A quick way to color a part is to right click on it and select 
Color By> Select Variable in the resulting popup

17. In the popup window select Velocity and click OK.  The clip 
plane is colored by Velocity.

18. Or click and drag the variable out from the Variable list and 
drop it on the part in the graphics window.
4-
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Contour Part The clip plane was built using the external flow field as the parent part. Since the clip 
plane is itself a part, it can be used as a parent part to create other parts. To create 
contour loops of velocity on the clip plane, for example.

The Clip plane was created using right click capability. We could to the same for the 
contours, i.e., right click on the Clip_plane part and use the Contour function in the 
pulldown list. But here we build the part through the user interface so you can see how 
this is done.

19. Select the “Clip_plane” part in the Parts list.

20. Click the Contour icon in the Feature Icon bar to open the Feature Panel 
for Contours.

21. Select Velocity in the variable list.

22. Change the value of the Sublevels field to 3.

23. Click “Create with selected parts” to build the new contour part.

By default the Sync To Palette toggle is activated so that EnSight 
creates a contour loop at each level in the color palette assigned to the 
selected variable. Levels are evenly spaced values that span from the 
minimum to the maximum range of the variable. Default color 
palettes have five levels. The subcontour value sets the number of 
additional contour loops that will be calculated between each level. In 
this case, 17 total contours will be calculated: ((5–1)*3)+5.

If the preference called “Color by creation variable” toggle is set the 
contour loops are colored by velocity. If this toggle is not set, the 
contours will appeared as white lines initially (and can be colored 
later if desired). We can change the line width of the contours to make 
them a little more visible:

24. Click the Part Line Width pulldown from the Quick Action Icon bar and set the width to 3 pixels.

Your Graphics Window should look something like: 

Alternatively, you could have right-clicked on 
the clip plane part and chosen contour.

See How To Create Contours (Help > How To Manual ...) for more information on contours and how 
color palettes affect contours.
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Clip parts in EnSight can be interactive: the tool that created the part can be grabbed with the mouse and 
moved. Or in cases like our X plane, a slider is provided. Once you release the mouse button, any parts that 
depend on the clip (i.e. that have the clip part as a parent), are automatically recalculated to reflect the new 
condition of the parent. 

Any kind of part (model or created) can be deleted. Note that a deletion cannot be 
undone.

25. Double-click the “Clip_plane” part in the Parts list.
(Or right click and Edit.)

Double-clicking a created part opens the Feature Panel and places it 
into Edit mode.  Any changes in the Feature Panel will affect only 
the parts marked with a pencil in the Parts list.

26. Click the Interactive pulldown and select Manual.

27. Manipulate the slider.

As the slider moves, the X plane is translated.

When the slider is released, the contour part recalculates to reflect the 
ending location of the clip plane. You can also type precise locations 
into the X Value field (and press Enter) if desired. You can also click 
the slider arrow buttons, which stride by the increment value.

28. Alternatively, you can left click on the clip plane until you get a 
handle and then drag the clip plane using the left mouse button on 
the handle.

29. If the Feature Panel is no longer showing the “Clip_plane” 
part, follow step 22 to redisplay the part’s Feature Panel, then 
click the Interactive pulldown again and select Off to disable 
interactive operation.

30. Select all the created parts in the Parts list: place the mouse pointer 
over part 3, click the left mouse button then Shift click on part 4 so it 
is selected as well.

31. Right click and “Delete” (or move the mouse into the graphics 
window and press the delete key, or choose Main Menu > Edit > 
Part > Delete...) and confirm the deletion if prompted.

The parts are removed from the display and the Parts list.
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Isosurface Part Another type of created part is an isosurface. An isosurface is a surface of constant 
value (the isovalue) in a 3D field. The region on one side of the isosurface has values 
greater than the isovalue and the region on the other side has values less than the 
isovalue. To create an isosurface:

32. Select the “external flow field” part in the Parts list.

33. Click the Isosurface icon
 in the Feature Icon bar to open the Feature Panel.

34. Select pressure in the variables pulldown.

35. Triple-click the Value field to select the “MID-RANGE” 
value. Type “0.9” 

36. Click “Create with selected parts” to build the isosurface 
part.

37. Color the new isosurface part by pressure by right 
clicking on the part (in the graphics window or in the 
Parts list) to “Color By->Select Variables” and choosing 
pressure in the resulting pop-up dialog.

38. Isosurfaces can be interactive.  Manipulating a slider 
changes the isovalue and the isosurface is recalculated 
and redisplayed.

39. Change the Interactive setting from Off to Manual.

40. Grab the slider and move it left and right.

The isosurface changes as the slider is moved. Or better, left-
click on the isosurface to see a part handle. Left click and 
drag to change the isovalue.

41. Turn the Interactive mode Off, and delete the isosurface 
part.

See How To Create Isosurfaces (Help > How To Manual ...) 
for more information.
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Particle Trace Part EnSight provides particularly powerful tools for exploring flow with particle traces.  
Traces can be emitted from a point, a line, a plane, or even the nodes of an arbitrary 
part. A trace emitter can be made interactive: moving the emitter with the mouse will 
recalculate and re-display the traces. In this example, a simple point trace will be 
created. As before, the operation can be performed through the user interface or via 
right click. We will use right click.

42. Click the Reinitialize Transforms icon to reset the view back to the 
default.

43. Click the Cursor tool toggle.

The Cursor tool is used to specify the position of a 3D point and, in this 
case, will be used to set the location of the particle trace emitter.  
Unfortunately, the Cursor may not be visible and may be initialized inside 
the hypersonic body part.  The part needs to be made temporarily 
invisible so the Cursor can be moved.

44. Right click on the “hypersonic body” part in the Parts list to Hide.

You should now see the Cursor tool (the red, green, blue cross) in the 
center of the screen. 

45. Move the mouse pointer into the Graphics Window and directly on 
top of the center of Cursor tool.  Note: The mouse cursor will change 
to a “+” shape when over the tool.

46. Click and hold the left mouse button and drag the Cursor to a location 
up and to the left (see image below).

47. Turn the visibility of the “hypersonic body” back on by again right 
clicking on it (this time it can only be done in the Parts list) and select  
“Show”.

Your Graphics Window should look something like the following:
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48. Select the “external flow field” part in the Parts list.  This will be the 
part (“parent part”) we trace the particle through.

49. Click the Particle Traces icon in the Feature
 Icon bar to open the Feature Panel.

50. Select velocity in the variable pulldown in the Feature Panel.

The Emit From setting in the Feature Panel is set to Cursor by default.

51. Click Create with selected part, to trace the particle.
Note that this could have also been done by right clicking on the 
cursor tool. 

The trace should be visible extending from the Cursor tool to the right 
and down over the hypersonic body. See How To Use the Cursor (Point) 
Tool (Help > How To Manual ...) for more information on manipulating 
the Cursor tool.

EnSight can also trace from the Line tool 
to create a rake of particles.  This can 
also be done via the right click capability 
but we will do it here by following the 
user interface.

52. Right click on the particle trace part 
in the Parts list and delete it.

53. Click the Cursor toggle on the 
desktop to disable display of the 
Cursor tool and click on the Line 
toggle to turn the line tool visible.

This selection displays the Line tool 
which is also completely enclosed within 
the hypersonic body part.

54. Right-click the on the hypersonic body part and choose Hide to disable part display. 
The Line tool (oriented horizontally) should now be visible.

55. Move the mouse pointer into the Graphics Window and directly on top of the center of 
Line tool. (The mouse cursor will change to a “+” when over a tool hotpoint.)

56. Click and hold the left mouse button and drag the Line to a location up and to the left.

57. Click the Part Visibility Toggle to re-enable display of the hypersonic body part.

58. Select the “external flow field” part in the Parts list.

59. Click on the Particle Trace icon in the Feature bar to bring up the Particle 
trace Feature Panel.
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See How To Create Particle Traces (Help > How To Manual ...) for more information 
on particle tracing.

60. Move the mouse pointer back into the Graphics Window and directly over the right 
end of the Line tool.

61. Click and drag the end of the Line tool down and to the left such that the Line is 
vertically stretched across the front of the hypersonic body (see image below).

Your Graphics Window should look something like the following:

62. Select velocity from the variable pulldown.

63. Select Line to Emit From

64. Change the # Points field to 12.

65. Make sure that the external flow field is selected in the 
Parts list as the parent part.

66. Click “Create with selected parts”

This operation created 12 evenly spaced traces along the 
Line tool.

Interactive particle traces are particularly useful for exploring fluid flow.

67. In order to make the traces interactive you must click Interactive Emitters.

68. Move the mouse pointer into the Graphics Window and directly over the center of the 
Line tool.

69. Click and hold the left mouse button and drag the Line tool up and down.  Release the 
mouse button.

The constituent traces are recalculated and re-displayed as the Line tool moves. It may help 
to rotate the model to a new orientation and then move the Line tool again.

70. Click Interactive Emitters again to disable interactive operation.
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Particle traces can be animated to provide intuitive comprehension of flow 
characteristics. Traces are animated by displaying one or more tracers on all traces of 
the trace part. A tracer moves along the path of a trace with length proportional to the 
local velocity. EnSight provides complete control over all aspects of the tracers 
including length, speed, and release interval for multiple pulses.

See How To Animate Particle Traces (Help > How To Manual ...) for more information 
on trace animation.

71. Toggle Animate.

The tracers can be seen moving down the 
length of the traces.  Numerous controls are 
provided for altering the appearance and 
behavior of the tracers.

It may be beneficial to turn off Highlighting - 
see step 2.

72. Click Animate settings... to open the Trace 
Animation Settings dialog.

73. Click Get Defaults to load suitable default 
values to the various trace parameter fields.

74. Click Multiple Pulses.

Note that there are now several tracers are 
moving down each trace.  The Pulse Interval 
field controls the spacing between tracers.

75. Triple-click in the Pulse Interval field to 
select the value.  Type “10” and press 
Enter.

76. You can lengthen or shorten the tracer via 
the Tracer Time field.  Either enter a new 
value (like 1.0) or use the up/down arrows 
to modify the value.

77. The speed of the tracers is controlled by the  
Tracer Delta field.  Enter a val (try 0.1 for 
example) or use the up/down arrows. 

78. Click the X to Close the dialog.

Animating traces often look better with the 
trace part invisible.

79. Right click on the particle trace part and 
select Hide in the pulldown.

80. Click the Line Tool icon to disable the 
display of the Line tool.

81. Quit Ensight (File > Quit > OK)
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4.3 Where’s the Rest?

After successfully completing this tutorial, if you wish to work through an example 
utilizing a structured mesh, you should proceed to the next chapter. Otherwise, you 
might prefer to jump to Chapter 6 which presents a tutorial containing some material 
applicable to all users, but intended primarily for analysts doing structural mechanics 
(finite element) analysis.

The How To Manual contains details on the operations covered in this chapter. The 
following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual... 
(Help > How To Manual...), then the topic indicated below:

Consult... For More Information On...

How To Read Data specifying data to read into EnSight

How To Change the Visual 
Representation

element representations

How To Create Color 
Legends

color legends and the variable to color mapping

How To Create Contours creating contours

How To Create Particle 
Traces

creating particle traces

How To Animate Particle 
Traces

animating particle traces
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5 Flow Visualization Example: Structured 
Mesh

This chapter is intended for users of structured mesh CFD software and those using the 
PLOT3D format to import data into EnSight. In addition, this chapter describes the use 
of the predefined CFD functions to compute variables derived from the fluid flow 
analysis. It is assumed that you have already worked through the features described in 
Chapter 4, flow visualization example for an unstructured mesh. After successfully 
completing this chapter, you should be able to:

• load a PLOT3D dataset

• create a part from a logical plane of the volume mesh

• create an IJK clipping plane

• use the predefined CFD functions

• save an archive
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5.1 Reading a Dataset

In this demonstration, we will load a simple CFD model of the viscid, subsonic 
symmetric flow around a half-model of the shuttle orbiter. The dataset consists of the 
standard xyz (mesh) and q (results) PLOT3D format files.

When the File Selection dialog is closed, EnSight reads the indicated file but does not 
load any of the geometry.

A number of different PLOT3D formats are supported by EnSight. For a complete 
description, see How To Read Data (Help > How To Manual ...) or PLOT3D Reader in 
Chapter 2 of the User Manual ( Help > User Manual ...). EnSight scans the PLOT3D 
files to determine which format is being used.

1. Start EnSight as described in Chapter 2 
and cancel the Welcome Screen.

2. Select File > Open... from the Main 
EnSight menu.

This opens the File Selection dialog.

3. Navigate to the 
$CEI_HOME/ensight100/data/plot3d
directory

4. Click shuttle.xyz in the Files list.

5. Click “Select parts to load...” to accept 
the selections that appear in the File and 
results fields and to close the dialog 
window.
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After the file has been read the Parts list will show “Zone 
1” as a grayed out entry in the list indicating that the zone 
is available but not currently loaded.

6. Right click “Zone 1” in the Parts List and select 
“Load Part” from the pulldown to bring up the 
Structured Part Builder dialog. 

This dialog allows us to create parts from a structured 
block.  We can extract out any range of I, J, K from the 
block and we can extract out multiple parts from the same 
block.

The most basic part is the fluid flow region, in this case 8-noded hexahedral cells 
surrounding the surface of the shuttle geometry. For reference, this single block will be 
named by typing in a Part Description before creating the part. A second part, defined by 
the surface of the geometry, will be created by choosing an appropriate limited range of 
nodes (which are normally known by the author of the PLOT3D mesh). In this manner 
any number of surface parts may be created in addition to the 3D (fluid) parts. Note that 
the Data Part Loader may be used at any time to create new parts from the original 
PLOT3D data files.

7. Click Element Visual Rep. and change the setting to "Feature Angle".                                                                                    

8. Type “external flow field” in the Description field.

9. Uncheck the “Close dialog after create” button - this will allow us to create two parts 
from this block

10. Click “Load as new part” button.

At this point the external flow field part will show up in the Parts list.  The graphics 
window will not display the new part until the dialog is closed.
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11.  Change I indices to 1-54, the J indices to 1-53 and change the K indices to 1-1 (the geometry's 
surface).

 

12. Click Element Visual Rep. and change the setting to "3D border, 2D full".

13. Type “surface”.in the Description field

14. Click “Load as new part”.

15. Click “X” to Close.

The second part now appears in the Parts list and both parts will appear in the graphics window. The 
external flow field is displayed as a wire frame and the surface is displayed as a mesh. As the flow 
field and geometry are both symmetric, only a half-model was used. The image in your Graphics 
window should appear as follows:
5
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5.2 Feature Demonstration

Unlike the case of unstructured meshes as in the previous example, logical planes of a 
structured mesh may be viewed in addition to the arbitrary planes described using the 
plane tool. In this demonstration, constant I, J, and K planes will be created and used to 
display results.

Remember that model reads in with shaded surfaces toggled ON:

1. Use the Shaded toggle on the Tools Icon bar to toggle shaded surface 
OFF then back ON for all parts.

2. Toggle OFF Highlight Selected Parts

After some rotations, translations, and a zoom - you should be able to 
produce an image approximately as follows:

 (The model should be green)

16. Select the “external flow field” part in the Parts list.

17. Click the Clip icon in the Feature Icon bar to open the
Feature Panel for clip creation.
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3. Click the Tool button and change the setting to IJK.

4. Change the value for an I Mesh Slice to 48.

5. Click “Create with selected parts”.

Notice that a new part appears in the Parts list, "Sweep 
surface"

6. Right click on the “Sweep surface” part to bring up the 
right click pulldown.  From the pulldown select “Color 
By->Select Variable” and in the resulting pop-up dialog 
choose Momentum (under Vectors) followed by the OK 
button.

The image in your graphics window should
 appear as follows:

As in the previous example, it is possible to interactively manipulate the clip plane. In this case, 
however, the plane will move along a given logical coordinate as the slide bar is moved:
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7. Select “Manual” from the Interactive menu.

8. Move the slider to view different constant I Mesh planes

9. Change the Mesh Slice from "I" to "J" and "K" and use the 
slider to view different constant J and constant K mesh planes. Note 
that the Min, Max and Step settings can be used to limit the extent 
and resolution of these planes.

10.  Set the Mesh Slice back to “I”.

11. Set the Interactive setting back to OFF.

It is possible to use both IJK and arbitrary plane Clips within the 
same session of EnSight. The IJK Clip feature may also be used as 
an alternative to creating model parts via the Part Builder as 
described above.

Extended CFD Variables

Often, the primitive variables solved by a given CFD code are of less interest than certain derived variables, 
for instance the Mach number, defined as the ratio of the local fluid speed to the freestream speed of sound. 
In the aerospace community, a number of these derived quantities are referred to as the "PLOT3D 
functions", as they were available in the program PLOT3D. EnSight includes most of these functions, and 
enhances their original form in two important ways. First, these Extended CFD Variables may be computed 
based on the "q file" variables of the PLOT3D format, namely the scalars density and energy and the 
momentum vector. In this case, EnSight makes the appropriate mapping of the variables. If, however, 
PLOT3D files are not used, or if the PLOT3D variables are used in a non-standard fashion, the user may 
define the appropriate mapping between the variable names as they were defined in the results and those 
quantities needed by EnSight to create the desired extended variable. The second enhancement is the ability 
to define any value for the ratio of specific heats, Cp, or use a scalar variable to define a different Cp value 
at each node of the mesh.

The Extended CFD variables are turned on by default when 
you read a Plot3d file.  To edit the settings or to turn them off:

12. Right click on any variable in the Variable list.

13. And select  “Extended 
CFD Variables...” from 
the pulldown which 
opens the Extended 
CFD Variable Settings 
dialog

Normally this is where you 
would adjust any needed 
parameters or turn the 
extended CFD variables 
off. Things are good for 
this model.

14. Click OK.
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With the Extended CFD Variables turned on the Variable list contains the original variables as well as the 
Extended CFD Variables. As with all others, these variables will not be activated until they are needed, for 
instance to color a model part. The activation of the extended variables involve a computation requiring one 
or more of the primitive variables. This, in turn, will require their activation, which EnSight performs 
automatically. All activated variables will remain so until they are explicitly deactivated. Note also that some 
extended variables (for instance vorticity) involve complex computations which may require significant time 
to complete. Variables that are grayed out in the list have not yet been activated (or computed).  Solid black 
colored variables are active.

15. Right click on the “Sweep surface” part in the Parts list and color the part by Mach number.

The image in your Graphics Window should look something like the following:

See How To Create New Variables (Help > How To Manual ...) for more information.
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Saving an Archive

EnSight can save the complete state of a session as an archive. An archive consists of 
two binary files containing the state of the Client and Server as well as an “Archive 
Information file” that stores additional information (including pointers to the two 
binary files).

Although you can duplicate a session by replaying a saved command file, restoring an 
archive is much faster. When you replay a command file, EnSight has to re-execute 
every action performed by the user, even if that action had no effect on the final state. 
An archive restores quickly since only the final state is restored.

To save an archive:

You can restore an archive during a session (either immediately after the Client-Server 
connection or after replacing a case) by selecting File > Restore > Full Backup....  You 
can also have an archive automatically load at startup. From a command line:

% ensight100 -ar ~/ens_chapter5.ar

And even easier - drag and drop the .ar file from a file browser onto the ensight100 
desktop icon.  See How To Save or Restore an Archive (Help > How To Manual ...) for 
more information.

1. Select File > Save > Full Backup... to open the Save Full Backup Archive dialog.

By default, EnSight will save the archive information file 
and the Client archive in the directory from which the 
Client is started. The Server archive will be saved on the 
Server host (by default, in the directory from which the 
Server was started). Since these directories are part of the 
EnSight distribution, they are probably write protected. To 
save the archive files in your home directory instead, prefix 
the entries with “~/”.

2. Triple-click in the Archive Information File field and type “~/ens_chapter5.ar”.

3. Double-click in the Client Directory field and type “~/”.

4. Double-click in the Server Directory field and type “~/”.

5. Click OK.
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Where’s the Rest?
5.3 Where’s the Rest?

After successfully completing this tutorial, you should proceed to the next 
demonstration.  Although the next tutorial contains some material applicable to all 
users, it is intended primarily for analysts doing structural mechanics (finite element) 
analysis.

The How To Manual contains details on the operations covered in the chapter. The 
following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual... 
(Help > How To Manual...), then the topic indicated below:.

Consult... For More Information On...

How To Read Data specifying PLOT3D format results data to read into 
EnSight

How To Create IJK Clips creating clip surfaces in structured models

How To Create New 
Variables

creating extended CFD variables

How To Save or Restore an 
Archive

saving and restoring archives
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6 Structural Mechanics Example

This chapter provides step-by-step instructions for performing basic postprocessing 
operations – especially those relevant to non-linear dynamics (e.g. crash) analysis. 
Unlike the two previous datasets, the data used here is transient – the model variables 
vary over time. EnSight provides a wide range of features for postprocessing and 
animating transient data.

After successfully completing this chapter, you should be able to:

• group multiple parts into a single part,

• show geometry displacements,

• probe for data values,

• change time steps,

• perform a query and plot it,

• add annotation to an image,

• create a flipbook animation.
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Reading a Dataset
6.1 Reading a Dataset

In this demonstration, we will load a transient dataset of a car crash into a guard rail.  
The dataset includes displacement and plastic strain values.

This procedure (using File > Open...) is a quick read which loads all parts for file types 
that have been mapped (using a mapping file) to a specific reader and a specific part 
visualization representation. The site preferences mapping file (named 
ensight_reader_extension.map) is found in the site_preferences subdirectory in the 
EnSight 10.0 install directory, and the local mapping file (same name 
ensight_reader_extension.map) is found in the EnSight Defaults Directory (located 
at %HOMEDRIVE%%HOMEPATH%\(username)\.ensight100 commonly located at 
C:\Users\username\.ensight100 on Win7, C:\Documents and 
Settings\yourusername\.ensight100 on older Windows, and ~/.ensight100 on Linux, 
and in ~/Library/Application Support/EnSight100 on the Mac).   The local file takes 
precedence over the site preference file.

The constituent parts are now listed in the Parts list and displayed in the Graphics 
Window:

Note: To improve the legibility of the Getting Started manual, all images of the 
Graphics Window are shown with a white background rather than the default dark 
background that EnSight uses.

1. Start EnSight as described in Chapter 2,
and cancel the Welcome screen.

2. Select File > Open... from the EnSight Main 
menu.

This opens the File Selection dialog.

3. Navigate to the 
$CEI_HOME/ensight100/data/guard_rail 
directory

4. Click crash.case in file list.

5. Make sure you are using the Simple Interface, 
and click OK to accept the selections and load 
all of the parts in the dataset.
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Feature Demonstration
6.2 Feature Demonstration
In many types of analysis, multiple parts are used to distinguish between various 
components or material types. To the extent allowed by the particular data format, 
EnSight maintains this distinction by assigning these entities to separate model parts. 
In some cases, however, this distinction is no longer useful for postprocessing. When 
manipulating objects in EnSight, you often want to apply the same attributes or 
operators to a group of parts. If the group is large, this process can become unwieldy. 
Fortunately, EnSight provides a mechanism, called grouping, for grouping multiple 
parts into a single group part. The original parts comprising the group will no longer be 
visible in the list.

In this example, we will group all parts associated with the car into a single part.

1. Select all the parts associated with the car: place the mouse 
pointer over the first part in the Parts list, click the left 
mouse button, then hold down the Shift button and left click 
on part 12.  You should now have the first twelve parts 
selected in the list.

2. Right-click on the list of parts and select “New Group”.  

3. In the pop-up dialog enter “car” as the group name (replacing the 
default name of “New group”), and click OK.  
You will now see a hierarchy in the Parts list with a group called “car” and 
parts 1 - 12 included in that group.

4. Click on the minus sign for the car group to hide the parts in 
the group. 

The interesting parts are now the four parts in the Parts list: 
three parts for the guard rail and the new group part (named 
“car”).
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Feature Demonstration
EnSight can displace geometry based on the value of a vector variable. Each 
displacement vector represents a translation of a node from its original position (an 
offset)

5. Select all of the parts in the Parts list.  This can be done multiple 
ways (a) Click on the Case1 line in the Parts list which will select 
all the parts in the Case1 group, (b) Right click on any part and 
“Part Select -> All”, (c) From the main toolbar Edit->Part->Select 
All. 

6. Click on the Part element settings icon in the Quick Action Icon bar 
for parts and select 3D border, 2D full from the pulldown.

7. Click the Displacement icon in the Part Quick Action Icon bar to 
open a variable chooser dialog for displacement.

8. Select the displacement variable, then close the dialog.

Note the new positions of the car and the guard rail.  See How To 
Display Displacements (Help > How To Manual ...) for more 
information.

Now color the car by the plastic strain variable.  Below we do this 
operation by using the user interface dialogs.  Another way to do this 
would be to right click on the “car” group and then “Color By”

9. Select the “car” group in the Parts list.

10. Click the Color/transparency icon in the Quick Action Icon Bar to 
open the Part color, lighting, & transparency dialog.

11. Select the plastic variable from the ‘Color by’ list,
then close the dialog by selecting the X in the upper right corner.

The color legend appears to the right of the model in the Graphics 
Window. Color legends have many display attributes – see How To 
Create Color Legends (Help > How To Manual ...) for more 
information.
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Feature Demonstration
.

See How To Probe Interactively (Help > How To Manual ...) for more information.

12. Rotate and zoom the model until the view in the Graphics Window 
looks something like the image below:

13. Toggle OFF the Highlight Selected 
Parts icon

EnSight provides 
an interactive 
probe tool that 
uses the mouse pointer to select points 

of interest.

14. Click the Probe icon in the Feature Icon bar to open the Feature Panel.

15. Select the plastic variable.

16. Change the Query to Surface Pick.

17. Move the mouse pointer into the Graphics Window and 
place the pointer over the car (preferably in a non-blue 
region). Press the ‘p’ key.

The value of the plastic strain variable is calculated for the point under the 
mouse and displayed. A marker (the sphere) is also displayed. 

18. Change the Query back to None.
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Feature Demonstration
By default, EnSight initially displays the last time step. However, it’s easy to change 
timesteps. 

EnSight provides powerful query and plot features. Query/plot is fully integrated with 
the transient data handling facility so that plots will automatically update during time 
changes. Here we will query for the maximum plastic strain over all timesteps using 
right click functionality to perform the task. 

The Solution Time panel provides several methods for 
working with time.  Perhaps the easiest way to change time 
steps is to use the slider bar.

19. Place the mouse pointer over the slider bar.  Click the 
left mouse button and drag the bar until the value in the 
Current field is “12”.

20. Release the mouse button.

Note that the geometry in the Graphics Window has 
updated to reflect the data at the new time step.  See How 
To Change Time Steps (Help > How To Manual ...) for 
more information.

21. Select the “car” group in the Parts list.

22. Right click on the plastic variable in the Variables list.  
You may need to open the Scalars to see it. 

23. From the right click pulldown choose “Plot Maximum vs. Time -> 
Selected Parts”.

The plot appears in the upper left corner of the Graphics Window.
See How To Query/Plot (Help > How To Manual ...) for more information.
And see  How To Change Plot Attributes (Help > How To Manual ...) for more information regarding 
the plotter.
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Feature Demonstration
Your Graphics Window should now look something like the following:
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Annotation
6.3 Annotation
Many postprocessing tasks require the production of hardcopy (or video) output with 
various types of annotation. EnSight provides comprehensive features for annotation: 
text, lines/arrows, color legends, and bit mapped logos.

To add text annotation:

1. Right click in the graphics window background 
towards the upper right of the window (the text 
annotation will appear where you right click).

2. From the right click pulldown select “Quick 
Text”.  The pulldown will close and a “New 
Text” annotation will appear in the graphics 
window along with the Feature Panel.

3. Edit the “New Text” and type “Car Crash”

4. Close the dialog.

You now have a text annotation visible in the graphics window.  It may not be 
the correct size and location.  To adjust:

5. As you move the mouse pointer over the text annotation two handles will 
appear - a move and a resize. (Note, if they don’t appear when your mouse is 
over the text, click on the text to get them to appear.)

6. Click and drag the move and resize handles.
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Annotation
If you change time steps (as described on page 6-6) or load a new flipbook (as we will 
do on page 6-12) the text will automatically update to reflect the current time.

See How To Create Text Annotation (Help > How To Manual ...) for more information.

EnSight supports several “special strings” that let you automatically display constant variable 
values as well as various internal values.  For example, you can have a text string that displays 
the current solution time.  When the time step is changed, the text automatically updates.

7. Left click on the Time variable in the Variables list.  Keep holding the left mouse button and 
drag it out and drop it into the graphics window.

The text “Time = 0.141” appears in the Graphics Window.

This value corresponds to the solution time at time step 12.

8. Use the handles on the new annotation string to move it off of the plotter.  Hint - since the 
string is on top of the plotter you may not get the pop-up handles because you are also over 
the plotter.  So click on the annotation string and you will see the handles appear on the 
string.

Your Graphics Window should look something like the following:
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Annotation
As you have seen, EnSight can display color legends for any variable.  Legends are 
annotations and can be adjusted.

Color legends can be resized and repositioned.  The quick way 
is to use the touch-and-go and right click shortcuts

9. Move the mouse pointer to the legend.  The Touch-n-go 
handles will appear.  You can drag anywhere on the legend 
or you can resize by the upper right corner icon.  The two 
left (up down arrows) icons adjust the min/max values of 
the palette.

10. Many of the legend attributes can be adjusted via the 
Quick Action Icon bar.  Make sure you select the legend 
(click on it in the graphics window or select it in the 
Annotations list) 

11. Click on the Font size and select  “30” from the pulldown 
list.

12. To adjust the format for the legend values right click on the 
legend and pick Format-> and choose “1.20”, i.e., two 
decimal places.
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Annotation
Your Graphics Window should look something like the following:

See How To Create Color Legends (Help > How To Manual ...) for more information.
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Flipbook Animation
6.4 Flipbook Animation
In many cases, dynamic phenomena can only be understood through interactive 
exploration as a transient dataset is animated. EnSight provides this capability in a 
transient flipbook. The process of creating a flipbook begins with an initial load. 
During this process, EnSight builds 3D graphics objects from the existing parts 
modified by the results at each time step. Once loading is complete, the objects can be 
replayed as fast as the graphics hardware permits while still allowing transformations 
(such as rotation).

To load a flipbook:

13. Click the Flipbook icon in the Feature Icon bar to open the 
Flipbook Panel.

14. Be sure the Load Type is set to Transient.

15. Click Load to begin the loading process.

The Load Flipbook Status dialog displays the progress of the 
load.  Once the load is complete the flipbook will begin to 
play.

16. Click on the VCR buttons to control the animation.

17. Use the mouse to rotate the model while the animation is 
playing.

Note that both the plot and the time variable text update 
during playback.  By default, the animation plays as fast as 
the graphics hardware permits.  In some cases (for small 
models or very fast hardware), this can be too fast.  To adjust 
the display speed:

18. Adjust the Speed from the Flipbook Panel by clicking the 
up/down arrows or entering a value.

19. You can record the animation to an animation format by 
utilizing the record button.

20. When you are done viewing and saving the animation, click 
the stop button to stop the animation, then Delete to remove 
the flipbook from memory.

See How To Animate Transient Data (Help > How To Manual 
...) for more information. For greater animation control, 
EnSight also provides a keyframe animation system – see How 
To Create a Keyframe Animation (Help > How To Manual 
...)for details.
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Where’s the Rest?
6.5 Where’s the Rest?

The How To Manual contains details on the operations covered in the chapter. The 
following online articles are relevant to the topics covered here.

Note: you get to these by selecting Help from the main menu, then How To Manual... 
(Help > How To Manual...), then the topic indicated below:

Consult... For More Information On...

How To Group Parts grouping parts into a single part

How To Display 
Displacements

displaying displacement variables on parts

How To Probe Interactively probing interactively with the mouse

How To Create Text 
Annotation

creating annotating text

How To Create Lines creating annotating lines and arrows

How To Create Color 
Legends

displaying and modifying color legends.

How To Create a Flipbook 
Animation

creating flipbook animations.
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Where’s the Rest?
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7 Where Do I Go From Here?

Browse the Manuals After completing the Getting Started tutorials, we suggest the following approach to 
learning EnSight:

1. Load one of your own datasets and practice the techniques presented here with 
your results. See Chapter 2, User Manual, for information on EnSight data readers.

2. Learn new features by using the articles in the How To Manual (Help > How To 
Manual ...). The Table of Contents (which is where you will be sent first) is a good 
place to search for the topics you need. Clicking the Help buttons in the dialog 
windows is also a good way to find topics of interest.

Online Support  
Report Trouble

Still need help?  Rather than sending an email to support that may lack critical details, 
we recommend you use our Report Trouble tab. Click this tab to email a detailed 
description of your problem to your EnSight Distributor. In this Tab, Toggle on the 
System Information to send, fill out the form, Select a Destination that is your CEI 
distributor (CEI in the U.S.), and click Send Report.   

Contact Support If you are evaluating EnSight for purchase or have an active support and maintenance 
contract you can contact CEI Support at:

Email: support@ceisoftware.com
Hotline: 800-551-4448 (U.S)

919-363-0883 (Non-U.S.)
Fax: 919-363-0833

The support hotline in the U.S. is staffed Monday through Friday from 8:00 AM to 
5:00 PM Eastern time except during U.S. holidays. If you are outside the U.S., please 
contact your local distributor of EnSight for support.
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Software 
Maintenance

CEI is constantly working to improve both the quality and functionality of EnSight. 
New major releases are automatically made available to all customers with an active 
support and maintenance contract. EnSight updates are available from CEI’s website:

www.ceisoftware.com/download/

Also see our website support page for Frequently Asked Questions, white papers, 
performance metrics, list of available readers/translators, and updated product 
information. 

www.ceisoftware.com/support/

Training Training courses are held regularly by CEI and in conjunction with CEI’s international 
distributors. Courses may be arranged at customer facilities. Contact your EnSight 
representative for details.
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