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This manual describes the installation and operation of the generation 1 and generation 2 DPFlex 
sensorless brushless DC motor drives manufactured by Allied Motion Technologies.  

Every effort has been made to ensure the accuracy of the information in this manual. However, Allied 
Motion assumes no responsibility for any errors or omissions. The information contained in this 
document is subject to change without prior notice. We welcome your critical evaluation and suggestions 
for improvements to be made in future revisions. 

This manual is supplied to the user with the understanding that it will not be reproduced, duplicated, or 
disclosed in whole or in part without the express written permission of Allied Motion Technologies. 
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III. Safety 

 
Read all provided 
documentation 
before assembly 
and 
commissioning. 
Failure or 
incorrect or 
improper use of 
this equipment can 
cause death, 
personal injury 
and consequential 
damage. 

 
Allied Motion disclaims any responsibility for such occurrence whereby unskilled and/or 
untrained personnel have incorrectly installed the equipment. 

 
Do not apply power to the motor without checking for proper wiring. 

 

The final responsibility for the safe use of this motor is solely that of the user. 

Allied Motion has used its best effort in the preparation of this manual. We reserve the right to make 
modifications, and alterations to improve the content and amend errors may be made to it without notice. 
Check the appendices for errata and revisions. 
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IV. Inspection upon Receipt 

All Allied Motion products are thoroughly inspected and tested before leaving the factory. Although our 
products are packaged with extreme care, it is important that the user complete a thorough inspection of 
the product upon arrival. 

Examine the condition of the shipping container and materials. If damage is found, notify the commercial 
carrier involved. It is the user’s responsibility to file any necessary damage claims with the carrier. Our 
products are shipped EXW (ex works), unless other arrangements have been made. Allied Motion is not 
responsible for carrier mishandling. 
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1 Introducing DPFlex  

This chapter provides an overview of the DPFlex: its features, functions, and specifications. 

1.1 What is DPFlex?  

The DPFlex™ provides sensorless control of rotary brushless DC 
motors at performance levels that exceed those of conventional 
Hall commutated drives. DPFlex detects motor rotor position at 
motor stand still through an innovative algorithm based on motor 
phase-inductance measurement. You can integrate the DPFlex 
into a motor, e.g. into the bell end, or mount it separately from 
the motor. 

 

 

 

DPFlex features include:  

 Enables a brushless DC motor to provide controlled torque or speed without the need for motor 
commutation sensors  

 One non-isolated analog input to adjust torque or speed  

 One non-isolated digital input to select the direction of motor rotation  

 One non-isolated digital input to enable or disable the drive and motor  

 One non-isolated digital output  

 Over-temperature and over-current protection  

 Auto-start programming function  

 Models for motors requiring up to 30 A peak  

 Allied Motion’s DP.D software for Microsoft® Windows® 2000/XP/Vista/7/8 enables you to 
tune, configure, and program the drive. It provides the following features:  

 Motor set-up and configuration tools 

 Inputs set-up and configuration tools  

 Motor verification and performance analysis tools  

 Integrated online help  

DPFlex is suitable for a wide range of applications, including control of fans, pumps, compressors, 
centrifuges, drills and mills, conveyors, office and medical equipment, automotive subsystems, and 
many others.  

1.2 DPFlex Components  

The DPFlex product family includes the following components:  

 The DPFlex drive  
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 The DP.D software for Microsoft Windows 2000/XP./Vista/7/8 

 Cables and connectors for connecting a DPFlex drive to power, motor, and   

 A personal computer  

 This user manual  

1.3 DPFlex Evaluation Kits 

Allied Motion offers DPFlex evaluation kits that contain all the components you need to design and 
test the DPFlex in your application. Contact us for more information. 

 

Voltage/Current  Part Number  

16 V / 30 A  11-F0012-30  

16 V / 15 A  11-F0012-15  

16 V / 10 A  11-F0012-10  

30 V / 30 A  11-F0024-30  

30 V / 15 A  11-F0024-15  

30 V / 10 A  11-F0024-10  

Table 1: DPFlex Evaluation Kits-generation 1 

Component  Part Number  

DPFlex Drive 16 V Maximum  30A: 10-F0012-30 
15A: 10-F0012-15 
10A: 10-F0012-10  

DPFlex Drive 30 V Maximum  30A: 10-F0024-30 
15A: 10-F0024-15 
10A: 10-F0024-10  

USB to UART Communication Cable  10-0099  

USB A to B Communication Cable  40-0089  

Motor Cable  40-0106  

Power Cable  40-0105  

Kit Connection Instruction  07-0044  

DP.D CD  35-0028  

DPFlex User Manual  34-2109  

Table 2: DPFlex Evaluation Kit Contents-generation 1 
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Voltage/Current  Part Number  

16 V / 30 A   

16 V / 15 A   

16 V / 5 A   

30 V / 30 A   

30 V / 15 A   

30 V / 5 A   

60 V / 30 A   

60 V / 15 A   

60 V / 5 A   

Table 3: DPFlex Evaluation Kits-generation 2 

 

 

Component  Part Number  

DPFlex Drive 16 V Maximum  30A: 10-F0012-30 
15A: 10-F0012-15 
6A: 10-F0012-10  

DPFlex Drive 30 V Maximum  30A: 10-F0024-30 
15A: 10-F0024-15 
6A: 10-F0024-10  

DPFlex Drive 60 V Maximum 30A: 10-F0024-30 
15A: 10-F0024-15 
6A: 10-F0024-10 

USB to UART Communication Cable  10-0099  

USB A to B Communication Cable  40-0089  

Motor Cable  40-0106  

Power Cable  40-0105  

Kit Connection Instruction  07-0044  

DP.D CD  35-0028  

DPFlex User Manual  34-2109  

Table 4: DPFlex Evaluation Kit Contents-generation 2 

 



 DPFlex Sensorless Brushless Motor Drive 

Allied Motion Technologies, Inc.  www.alliedmotion.com 
November 12, 2014 Version R1 Page 13 of 70 

2 Sensorless Drive Technology 

2.1 Understanding Commutation and DPFlex  

Controlling current in a motor to produce torque is called commutation. Torque in an electric motor is 
the interaction between two magnetic fields, one from a rotor and the other one from a stator. These 
two magnetic fields must move relative to each other to maintain torque. 

There are two ways to produce a moving magnetic field. One way is to apply AC current to stationary 
windings. The other is to change the physical path of DC current in a stator. A DC motor uses the 
latter approach to commutation. 

DPFlex changes the path of current in motor coils in the following manner. Electrical commutation is 
done using an external controller to change the current path. Current is directed through various wires 
in the stator creating a moving magnetic field. To control the paths for current, DPFlex uses a six-step 
sensorless method that relies on back electromotive force sensing. 

2.2 Six-Step or Trapezoidal Commutation 

In this method, there are only two phases of the stator coils energized by the DC source. To complete 
one electrical cycle (360 degrees) for magnetic field rotation, every phase would be energized four 
times (two times in the positive polarity and the other two in the negative polarity). Because the 
transition from one step to the next is discrete, the waveform of the field is like a trapezoid. This 
method is simple and can be used for different types of BLDC motors. The simplicity and 
effectiveness of this method makes it an attractive choice for commutation even at high speed. BLDC 
motors are commutated in six 60°steps during each full 360° electrical cycle. Only two of the three 
motor coils are energized during each step. 

 
Figure 1: Six-Step Commutation Phase Current & Back-EMF Diagram 
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2.3 Sensorless Six-step Commutation  

Once the shaft of the motor is spinning sufficiently fast, the induced back-emf (speed) voltage caused 
by the time varying magnetic flux linking the stator windings can be measured by the drive. The 
magnetic flux is produced from the permanent magnets contained in the rotor. It is possible to use this 
information to commutate the motor without any other position feedback information. This is what is 
meant by the term sensorless: it is the absence of any physical position feedback devices in the motor. 

For trapezoidal commutation, only two coils of the three motor coils are energized at any one time. 
The coils that are energized are the two that yield the maximum developed electromagnetic torque. 
For a Y (WYE) connected motor, the third coil is off and the speed voltage can be sensed at its phase 
terminal. Each of the three coils is energized (ON) for 120 electrical degrees and is then de-energized 
(OFF) for 60 electrical degrees. This pattern is repeated again and again every 180 electrical degrees 
and the current is switched in direction each 180 degree segment. 

The speed voltage induced in the OFF phase undergoes a polarity reversal during the time the phase is 
OFF. The bias voltage is the voltage of the neutral point of the WYE connection. Ideally, the drive 
should shut OFF a coil as the induced speed voltage across that coil is undergoing a polarity reversal. 
The coil should then be re-energized once the voltage has changed polarity and that coil can 
contribute to torque production. In order to do this, the controller samples the voltage of the OFF 
phase once the current in that phase has dropped to zero. Once it detects that the rotor flux is 
generating a speed voltage of the proper polarity, it shuts OFF the coil that is just beginning to go 
through this voltage reversal process and energizes the one that just finished this process.  

The drive uses a physical constant of the motor in order to assess when the time is appropriate. The 
motor constant related to the volts per rpm (Ke) of the motor is used to calculate how much flux there 
is per pole. By integrating the induced speed voltage in the OFF phase and waiting for the proper 
amount of flux to accumulate, the drive can commutate at the appropriate time.  

Since this is a motor constant, it is speed independent and it is applicable at all speeds at which 
the back-emf of the motor can be detected by the drive. 

 
Figure 2: Six-Step Commutation Sequence 
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2.4 Special Considerations for Sensorless Commutation  

During the process of commutation, current in one phase must drop to zero and be transferred to the 
phase that is just coming ON. Because of the fact that the coils are not mutually coupled 100% and 
that each coil has its own leakage reactance, there will be a portion of time, albeit brief, where all 
three coils have current in them. During this period of time, an accurate back- EMF or speed voltage 
cannot be obtained from the voltage sense circuit on the controller.  

Immediately after commutation, the drive will shut OFF the phase voltage and wait until it determines 
that an accurate back EMF signal can be obtained from the analog input dedicated to BEMF sensing 
in the OFF phase.  

It is only after this has been successfully detected that the drive will begin to use the measured speed 
voltage for commutation purposes. Since DPFlex itself monitors the speed voltage feedback and 
activates the back EMF sensing itself, there is no parameter associated with the coil-coil current 
transfer.  

2.5 Sensorless Startup  

As the back-EMF is proportional to speed a sensorless controller needs a means of finding the initial 
rotor position, in order to start the motor and accelerate it to sufficient speed to be able to detect the 
back-EMF voltage. Startup is undoubtedly the biggest hurdle any sensorless-control algorithm must 
overcome. Conventional methods drive a current through the motor windings, in order to force the 
motor rotor into a known position to ensure proper motor start. This can cause up to 180° of (2-pole) 
motor rotation opposite to the desired direction, adding to acceleration and startup time. The current 
required to orient the rotor depends on the inertial and frictional load of the motor. If the initial 
current to orient the motor is too high, there may be overshoot and ringing in the system. If the 
current is too low, the motor may not start at all. Such a system is not robust with respect to system 
load conditions.  

More advanced methods determine motor rotor position based on the motor-phase saturation 
inductance change. The drive generates 6 short, opposing current pulses that drive the motor phases 
into saturation. The drive calculates the motor rotor position based on the saturation inductance 
change in each phase. We refer to this procedure as the ping method. The motor rotor remains 
stationary during the initial ping period, because the current pulses are short and in opposing 
sequence. In most cases, the motor reaches sufficient speed before the next commutation-sector 
change for the back-EMF commutation algorithm to take over. In a few cases, usually if the load on 
the motor is extremely heavy, the ping process repeats while the motor rotates at low speeds below 
the back-EMF commutation threshold. This is possible, because the ping period time is negligible 
with respect to the time between sector transitions at low motor speeds. The ping method guarantees 
unidirectional motor start, which is independent of motor loading conditions. The system is robust 
with respect to system load conditions. 
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3 DPFlex Specifications 

3.1 DPFlex Specifications Generation 1 

Specification Value 

DC Supply Voltage  15 V (min), 24 V (typ), 30 V(max) 

8 V (min), 12 V (typ), 16 V (max) 

Acceptable Motor Type  Brushless AC/DC, WYE/DELTA connected   

Output Phase Current  10 / 15 / 30 A peak 

Motor phase-to-phase inductance  100 μH (min) 

Motor time constant  150 μsec 

Trip temperature1 90 °C 

Digital Input2: motor direction, enable/disable  0 V (min), 30 V (max) 

Digital output3  0 V (min), 30 V (max) 

Analog input4 5 V, single-ended 

Analog Input Sampling Frequency   100 Hz 

Input Sampling Frequency   20 kHz 

Commutation Type Six-step back-emf 

Commutation Period 250 μsec (min) 

Diagnostics  400-point data logger  

Protection Over voltage, over current,  
over temperature 

USB-UART communications  Digital TX, 115 kbps 
(1) Refer to the power dissipation curve shown in Figure 13 to properly heat-sink the drive. 

(2) Digital inputs require isolation if connected to active circuitry. Refer to schematic shown in Figure 3 and  

 

Figure 4. 
(3) Refer to schematic shown in Figure 5. 
(4) Refer to schematic shown in Figure 6. 
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Figure 3: Digital input 1 (motor enable) circuitry (DI 1) generation 1 

 

 

Figure 4: Digital input 2 (motor direction) circuitry (DI 2) generation 1 
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Figure 5: Digital output circuitry generation 1 

 
Figure 6: Example of connecting passive circuitry to DPFlex's analog input generation 1 

 
 
 
 
 
  



 DPFlex Sensorless Brushless Motor Drive 

Allied Motion Technologies, Inc.  www.alliedmotion.com 
November 12, 2014 Version R1 Page 19 of 70 

3.2 DPFlex Specifications Generation 2 

 

(1) Refer to the power dissipation curve shown in Figure 13 to properly heat-sink the drive. 
(2) Digital inputs require isolation if connected to active circuitry. Refer to schematic shown in Figure 7 and Figure 8. 
(3) Refer to schematic shown in Figure 9. 
(4) Refer to schematic shown in Figure 10. 

  

Specification Value 

DC Supply Voltage  36 V (min), 48 V (typ), 55 V(max) 

18 V (min), 24 V (typ), 34 V (max) 

9 V (min), 12 V (typ), 18 V (max) 

Acceptable Motor Type  Brushless AC/DC, WYE/DELTA connected   

Output Phase Current  5 / 15 / 30 A peak 

Motor phase-to-phase inductance  10 μH (min) 

Motor time constant  150 μsec 

Trip temperature1 90 °C 

Digital Input2: motor direction, enable/disable  Active High: 8 V (min), 60 V (max) 

Active Low :0.5V active low 

Digital output3  0 V (min), 24 V (internally clamped) 

Analog input4 5 V, single-ended 

Analog Input Sampling Frequency   100 Hz 

Input Sampling Frequency   20 kHz 

Commutation Type Six-step back-emf 

Commutation Period 75 μsec (min) 

Diagnostics  400-point data logger  

Protection Over/under voltage, over current,  
over temperature 

USB-UART communications  Digital TX, 115 kbps 
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Figure 7: Digital input (active high) circuitry generation 2 

 

 

 

Figure 8: Digital input (active low) circuitry generation 2 
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Figure 10: Example of connecting passive circuitry to DPFlex's analog input generation 2 

 

Figure 9: Digital output circuitry generation 1 
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3.3 DPFlex Connectors  

Connector  Type  Pins 

Power  Keystone Horizontal Quick-Fit Terminals 
(P/N #: 4907, Tab Size : 187" [4,75])  

2 

Motor  Keystone Horizontal Quick-Fit Terminals 
(P/N #: 4907, Tab Size : 187" [4,75])  

3 

Enable  Horizontal Quick-Fit Terminals 
(P/N #: 4907, Tab Size : 187" [4,75])  

1 

Analog & Digital I/O  JST 
(P/N #: SM06B-GHS-TB)  

6 

USB-UART Communication  JST 
(P/N #: SM04B-GHS-TB)  

4 

Table 5: DPFlex connectors 

For connector pinouts for DPFlex, see Making Cables for DPFlex Drives.  

3.4 DPFlex Dimensions  

  
Figure 11: DPFlex dimensions (top view) 
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Figure 12: DPFlex dimensions (side view) 

3.5 DPFlex Safety  

To ensure safe operation of DPFlex, your application must meet the following requirements:  

 CAUTION Failure to comply with the requirements listed below may create 
an electrical hazard in your application.  

 Use two AWG 16 twisted (with one twist per cm) cables 3 ft  [1 m] long to connect the DC power 
supply to DPFlex.  

 Use three AWG 16 twisted (with one twist per cm) cables 1 ft [.3 m] long to connect the motor to 
DPFlex.  

 Connect a fuse between the positive voltage from the DC power supply and pin J3 (B+) on 
DPFlex's power terminal. Size the fuse to 150% of DPFlex's rated current.  

 Spot ground the DPFlex drive itself.  

 Use a USB cable to connect the PC to the USB-UART adapter.  

 Heat sink the DPFlex drive, using the power dissipation curve shown in Figure 3-8 to guide the 
heat sink’s design.  

3.6 DPFlex Power Dissipation  

DPFlex generates heat as its consumption of power increases. Use the graphs in Figure 13 and Figure 
14 below to determine safe operating conditions. 
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Figure 13: DPFlex power dissipation 30A variant 

Note: The power dissipation curve was generated with balanced, 3-phase sinusoidal 
current at a 100 Hz fundamental and a 20 KHz switching frequency.   

 
Figure 14: DPFlex safe operating area 30A variant 
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4 Setting Up DPFlex 

This chapter describes how to set up DPFlex and configure it for a motor. 

4.1 Installing the Software 

The software provided with the DPFlex drive includes DP.D, an application for Microsoft Windows 
that enables you to configure and monitor the drive, and a USB-to-serial driver that enables a PC to 
communicate with the drive over a USB port.  

For details about installing the DP.D software see the upcoming topics:  

4.2 Installation Requirements  

To install and run the DPFlex software, you need a personal computer that meets the following 
minimum requirements:  

 Windows 2000 with SP4 or Windows XP with SP2  

 A USB port or an RS-232 serial communication port capable of 115200 bps  

 133 MHz or higher Pentium-compatible microprocessor  

 At least 64 megabytes (MB) RAM  

 50 MB available storage  

 SVGA or higher resolution monitor.   

Note: A personal computer equipped with more RAM or a faster microprocessor will 
provide significantly better performance.  

4.3 Using the Installation CD  

The DPFlex software is packaged on a CD-ROM (part number 35-0028) containing the DP.D 
software. 

To run the installation utility: 

 Insert the CD in your CDROM drive.  

 Wait for the Install Application to run.  
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If the installation utility does not automatically run, run the Setup.exe program found in the 
root of the CD.  

To install DP.D: 

 In the installation utility, choose Install DP.D. The installation utility launches the DP.D 
installation wizard:  

 

 Follow the instructions in the wizard to install DP.D. 
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Note: DP.D requires an Open Database Connectivity driver to be installed on the 
PC. If you do not have one, you can install one by running the MDAC_TYP.EXE 
program in the MDAC2_8 directory found on the CD.  

To install the USB-to-serial driver: 

 In the installation utility, choose Install USB-to-serial Driver. The installation utility launches the 
driver installation wizard:  

 

 If you want to change where the driver is installed, choose Browse to select another location.  
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 Choose Next to install the driver or Cancel to abort the operation. 

 

4.4 Connecting the DPFlex Drive  

To use the DPFlex drive in an application, you must connect it to power and to a motor. To configure 
DPFlex and to monitor its performance, you must also connect it to a PC.  

 DPFlex safety  

To ensure safe operation of DPFlex, your application must meet the following requirements:  

CAUTION Failure to comply with the requirements listed below may 
create an electrical hazard in your application.  

 Use two AWG 16 twisted (with one twist per cm) cables 3 ft  [1 m] long to connect the DC 
power supply to DPFlex.  

 Use three AWG 16 twisted (with one twist per cm) cables 1 ft  [.3 m] long to connect the 
motor to DPFlex.  

 Connect a fuse between the positive voltage from the DC  power supply and pin J3 (B+) on 
DPFlex's power terminal.  Size the fuse to 150% of DPFlex's rated current.  

 Spot ground the DPFlex drive itself.  

 Use a USB cable to connect the PC to the USB-UART adapter.  

 Heat sink the DPFlex drive, using the power dissipation curve  shown in Figure 3-8 to guide 
the heat sink’s design.  
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 Connecting DPFlex with the Cable Kit  

The easiest way to connect a DPFlex drive is to use cables offered by Allied Motion:  

 The DPFlex Power Cable (part number 40-0105) connects the drive to power. One end (fitted 
with Amp 8-520182-1) of the red wire in the cable connects to J3/B+ (the positive pin). One 
end (also fitted with Amp 8-520182-1) of the white wire in the cable connects to J4/B- (the 
ground pin). The other ends connect to the power supply.  

 The DPFlex Motor Cable (40-0106) connects the drive to a motor. One end (fitted with Amp 
8-520182-1) of each of the red, white, and black wires in the cable connects to the motor pins 
(Motor Phase A: pin J5; Motor Phase B: pin J6; Motor Phase C: pin J7). The other ends 
connect to the corresponding motor phases.  

 The DPFlex USB to UART Communication Cable Kit (part number 10-0099) connects the 
drive to a USB port on a PC. It includes the following cables:  

 A 6-foot USB A to B Cable (part number 40-0098)  

 A USB-UART adapter cable (part number 40-0094)  

Note: You can make your own cables. For details, see Making Cables for DPFlex Drives. 

 Connecting DPFlex to a PC  

1. Plug one end of the USB A to B cable into the USB port of the USB-UART adapter 
cable.  

2. Plug the free end of the USB A to B cable into a USB port on the PC.  

Note: If you did not install the USB-to-serial driver when you installed DP.D, the PC will 
launch a device driver install wizard when it detects the adapter cable. Use the wizard to 
install the driver from the driver directory on the DP.D CD.  

3. Plug the free end of the adapter cable into the serial communications connector on the 
DPFlex drive.  
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Figure 15: DPFlex connector locations 

 Connecting DPFlex to power  

1. Plug the power cable into DPFlex's power connector.  

2. Wire the other end of the power cable to your power supply, referring to their labels for 
pin number and signal name.  

CAUTION Failure to connect a properly-rated fuse between DPFlex's 
high voltage input (pin J5 on the power connector) and the power supply may create 
an electrical hazard. Size the fuse to 150% of DPFlex's rated current.  

 Connecting DPFlex to a motor  

1. Plug the motor cable into DPFlex's motor connector.  

2. Wire the other end of the motor cable to the motor.  

4.5 Making Cables for DPFlex Drives  

You can make your own cables for DPFlex as long as the following points are adhered to:  

 The signal cables for J1 must be less than 1m in length.  

 Drive dc power supply cables connected to J3/J4 should be made as short as possible and should 
be twisted together using 1 twist or more per cm.  

 Motor cables connected to J5/J6/J7 should be as short as possible and should be twisted together 
using 1 twist or more per cm.  
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 An additional electrolytic capacitor placed as close as possible to the J3/J4 power connectors is 
recommended.  Rule of thumb sizing for this capacitor is 30uF per amp.  Cables running to and 
from the added capacitor should follow the above cabling practices.  

 If extra capacitance is used, it is highly recommended that a pre-charge circuit be used to limit the 
inrush current required to charge this capacitance.  The limiting resistor should then be shorted 
out using a relay or some other appropriate means.  

The following tables list the pinouts and connector type for each connector on the drive. Figure 16 
below shows how external devices are connected to DPFlex. 

Note: The serial communications connector on the drive uses TTL signals. If you want to 
communicate with the drive from a device using standard RS-232 signals, you must 
provide a means to convert the signal levels between the two devices. 

 
Figure 16: DPFlex connection points 

Pin (Name)  Purpose  

J1.1 (ASupply)  Analog Supply (5V Gen1) (3.3V Gen2) 

J1.2 (AIN)  Analog Input (0-5V DC)  

J1.3 (ACH)  Analog Common  

J1.4 (DI1) or J8 (DI1)  Digital Input 1 [motor enable/disable] (Referenced to J4/B-)  

J1.5 (DI2)  Digital Input 2 [motor direction] (Referenced to J4/B-)  

J1.6 (D0)  Digital Output (Referenced to J4/B-)  

Table 6: Analog & digital I/O connector pinout [J1] 

Pin (Pin Name)  Purpose  

J2.1 (GND)  Communication Ground  

J2.2 (TX)  Host Transmit  

J2.3 (LogicV)  Communication Logic supply (5V 
Gen1) (3.3V Gen2)  

J2.4 (RX)  Host Receive  

Table 7: Serial communication connector pinout [J2] 
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Pin (Pin Name)  Purpose  

J3 (B+)  (+) DC Voltage  

J4 (B-)  (-) DC Voltage   

Table 8: Power connector pins (Keystone Terminals P/N #: 4907) 

Pin (Pin Name)  Purpose 

J5 (APH)  A Motor Phase 

J6 (BPH)  B Motor Phase 

J7 (CPH)  C Motor Phase 

Table 9: Motor connector pins (Keystone Terminals P/N #: 4907) 
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5 Creating DPFlex Applications 

This chapter describes how to develop and deploy the DPFlex in your application: How to configure it for 
a motor; how to check the analog and digital inputs; how to set motor performance parameters; and how 
to check application performance. 

5.1 Developing DPFlex Applications  

Once you have installed the DP.D software and connected a motor and power to DPFlex, you can 
start developing your application. 

 Steps To Develop a DPFlex Application 

1. Create a configuration. A configuration stores controller and motor settings, and other 
application parameters. DP.D enables you to create and store multiple configurations. For 
details, see Creating and Managing Configurations. 

2. Configure DPFlex for the motor you want to use in the application. For details, see 
Configuring DPFlex. 

3. Tune the current loop for the application. For details, see Tuning the Current Loop. 

4. Tune the velocity loop for the application. For details, see Tuning the Velocity Loop. 

5. Check DPFlex's inputs. For details, see Viewing DPFlex Inputs. 

6. Configure thresholds and check for faults. For details, see Viewing and Configuring 
Faults. 

7. Save the application parameters and deploy them to other DPFlex controllers. For details, 
see Deploying DPFlex Applications. 

5.2 Using DP.D  

You use the DP.D application software for Microsoft Windows 2000/XP/Vista/7 to develop and 
deploy DPFlex applications.  

For details about installing DP.D, see Installing the Software. 

 To start DP.D: On your Windows Desktop, choose Start > Programs > Allied Motion > DP.D.  

 To exit  DP.D: In DP.D, choose File > Exit.  

5.3 About DP.D  

DP.D enables you to perform the following tasks:  

 Configure DPFlex for a motor.  

 Tune the current and velocity loops for your application.  

 Configure thresholds and view faults: over temperature, over current, and over voltage.  

 Monitor DPFlex inputs.  

 Save configuration parameters to a file on the PC and to DPFlex's non-volatile memory.  

 Create, save, and open sets of DPFlex configurations.  
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5.4 Using the DP.D Navigation Tree  

When you start DP.D, it opens a navigation tree that you use to create and manage multiple DPFlex 
configurations. 

 
Figure 17: DP.D navigation tree with two configurations 

DP.D displays each DPFlex configuration as a branch in the navigation tree. It displays the 
parameters for each configuration as leaves on the branch. 

Each DPFlex configuration shows which port the controller is connected to, and provides access to 
the following configuration parameters: 

 The Stimulus Tools forms enable you to vary motor current or velocity. 

 The Motor Parameters form enables you to set motor ratings and command DPFlex to configure 
itself for that motor. 

 The Current Compensator form enables you to define the gains for the application's current 
loop, and provides access to DPFlex current loop tuning tools. 
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 The Velocity Compensator form enables you to define the gains for the application's velocity 
loop, and provides access to DPFlex velocity loop tuning tools. 

 The Inputs form enables you to view the current values of DPFlex digital and analog inputs. 

 The Faults form enables you to configure and view fault settings, states, warnings, and error 
messages. 

 The Registers form enables you to store and retrieve DPFlex settings in files, and to save those 
settings to DPFlex's non-volatile memory. It also enables you to configure the drive autostart 
mode. 

To open a parameters form, take one of the following steps: 

 Right-click the desired parameters leaf in the navigation tree and choose Interact, or 

 Double-click the leaf. DP.D displays the form. 

To view system configuration properties, take one of the following steps:  

 Right-click the DPFlex ( Port ) leaf in the navigation tree and choose Interact.  

 Double-click the leaf. DP.D displays the system properties form.  

 
Figure 18: System properties form 

The system properties form displays the following controller information:  

 The current supply voltage  

 The firmware version, and its date and time of compilation  

 The drive's current and voltage ratings  

To display or hide a configuration's system properties: 

 Click Show Details or Hide Details. 

To rename a configuration: 

 Right-click the DPFlex ( Port ) branch in the navigation tree and choose Rename.  
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To add, delete, or change the properties of configurations, take one of the following steps:  

 Right-click the System branch in the navigation tree and choose Connection.  

 Double-click the System branch. DP.D displays the Interact form, which lists defined 
connections. 

 
Figure 19: DP.D Interact form 

For details about using the Interact form, see “Creating and Managing Configurations” 

5.5 Using DPFlex's Digital Oscilloscope  

DPFlex features a four-channel digital oscilloscope that enables you to view your application's set 
points and the motor's actual performance.  

To display the digital oscilloscope, take one of the following actions: 

 In the Tools menu, choose Oscilloscope.  

 In the Current Compensator form or Velocity Compensator form, choose Tuning Tools. 
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Figure 20: DP.D digital oscilloscope 

The digital oscilloscope features the following controls:  

 The tool bar enables you to manage oscilloscope settings, examine captured signals, and control 
the display 

 The signal display traces the signal on each channel after the trigger occurs and for the selected 
time base.  

 The channel controls enable you to assign a signal to a channel.  

 The trigger type controls enable you to select the type of triggering to use.  

 The time base control enable you to specify the time base used in the display  

 The datalog controls enable you to specify the rate at which inputs are logged and the number of 
data points to plot.  

 The trigger settings enable you to specify the timing and type of trigger.  

 The cursor position indicators show the coordinates of the current cursor position.  

To use the tool bar: 

 Clicking on buttons in the tool bar performs the actions listed in the table below. 
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Choose button...  ...to perform this action  

 
Zoom in on the selected segment of the graph.  

 
Zoom out of the selected segment of the graph.  

 
Rescale the display to the input signals' range.  

 
Show or hide the cursor.  

 Open an oscilloscope configuration.  

 Save the current oscilloscope configuration.  

 
Print the captured data points.  

 Copy all captured data points to the clipboard.  

 
Display inputs as graphs.  

 
Display inputs in a table.  

 
Display scaled data.  

 Position the cursor on the selected input.  

 
Zoom out on the graph to show all captured data points.  

Table 10: DP.D oscilloscope tool bar buttons 

To view or change a channel's settings: 

  Click the channel's settings button: 

 

 DP.D displays the channel settings form:  

 
Figure 21: Channel settings form 

 Choose Axis to log data or None to disable logging. 
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 Choose the data to log from the list in the Axis Register To Log panel. 

 Choose OK to save the settings or Cancel to abort the operation. 

To change the oscilloscope display, take the following actions: 

To take this action...  ...choose this button  

Display inputs as graphs.  
 

Display inputs in a table.  
 

Display scaled data.  
 

Position the cursor on the select the input channel.   
Zoom out to show all captured data points.  

 
Zoom in on the selected segment of the graph.  

 
Zoom out of the selected segment of the graph.  

 
Rescale the display to the input signals' range.  

 
Show or hide the cursor.  

 
Table 11: Change oscilloscope display 

To manage captured data, take the following actions: 

To take this action...  ...choose this button  

Open an oscilloscope configuration.  
Save the current oscilloscope configuration.  

 
Print the captured data points.   
Copy all captured data points to the clipboard.   

Table 12: Manager captured data 

To select the trigger type, choose one of the following commands:  

 Choose Manual to trigger input logging once immediately. 

 Choose Single to trigger input logging once at the point set with the trigger settings controls.  

 Choose Auto to enable the oscilloscope to trigger continuously and display captured data.  

To set the time base: 

 Using the mouse, rotate the time base control to the desired period.  

To set the data logging frequency: 

 In the Datalog Rate field, enter the sampling period in seconds.  

 In the Datalog Points field, enter the number of points to log during the time base period.  

To change the trigger settings: 
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 In the Trigger Settings area, choose one of the following triggers from the drop-down list: 

Choose this setting... ...to set this trigger  

No Auto Trigger... None.  

On Stimulus Edge... On the edge of the current or velocity stimulus  

On +ve Stimulus Edge... On the positive edge of the current or velocity stimulus  

On -ve Stimulus Edge... On the negative edge of the current or velocity stimulus  

On Enable... When the motor is enabled  

Figure 22: Setting the trigger type 

 In the Trigger Settings area, set the point in time to trigger by rotating the Position at % of 50 ms 
control or entering a value in milliseconds in the field below.  

5.6 Managing Views  

DP.D provides several options for managing its display:  

 You can set DP.D to always display DP.D forms on top of other application windows and forms.  

 If you have multiple parameter forms open, you can save their current display positions and 
restore them to those positions after closing the forms or re-starting DP.D.  

 You can set whether DP.D displays a status bar.  

To toggle displaying DP.D forms on top: 

 Choose View > Always on Top.  

To save the currently displayed forms' positions: 

 Choose View > Save Windows.  

To restore forms to their displayed positions:  

 Choose View > Restore Windows.  

To toggle display of the status bar  

 Choose View > Status Bar.  

5.7 Getting Help  

DP.D provides online help for all procedures and forms.  

To display online help, take one of the following actions:  

 Right-click a node in the navigation tree and choose Help.  

 Choose Help > DP.D Help Topics.  

 Press the F1 key.  

To view information about DP.D:  

 Choose Help > About DP.D. DP.D displays the About DP.D form:  
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Figure 23: DP.D About screen 

5.8 Creating and Managing Configurations  

A configuration stores controller and motor settings, and other application parameters. DP.D enables 
you to create and store multiple configurations.  

To create a configuration: Click Start > Programs > Allied Motion > DP.D DP.D opens the navigation 
tree:  

 

To create a new configuration: 

 In the navigation tree, double-click System. DP.D displays the Interact form, which lists defined 
connections:  

 

 Choose Add. DP.D displays the Connection Info form.  

 If the port to which the DPFlex controller is connected is not displayed in the Port drop-down list, 
choose Scan Ports. DP.D scans the PC for serial ports or the USB-to-serial adapter.  

 If the USB port does not appear in the list, check the following items and re-scan:  
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 That the USB-to-serial driver is installed  

 That the USB-to-serial cables are properly connected  

 In the Port drop-down list, choose the port to which the DPFlex controller is connected.  

 

 Choose Test to confirm the connection to the controller is working.  

 If the test fails, check the following items and re-test:  

 That the communication cables are properly connected  

 That the DPFlex controller is powered  

 Choose OK to accept the connection or Cancel to abort the operation. The Interact form now lists 
the connection to the controller:  

 

 Choose OK to accept the controller connection configuration or Cancel to abort the operation. 
DP.D updates the navigation tree for the new configuration:  
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To save the current configurations: 

 Choose File > Save. If you have not previously saved the configurations, DP.D displays a 
browser.  

 Select a path and file name for the configurations and choose Save.  

To save the current configurations to a different file: 

 Choose File > Save As. DP.D displays a browser. 

 Select a path and file name for the configurations and choose Save.  

To create a new set of configurations: 

 Choose File > New. If you have not previously saved the current configurations, DP.D prompts 
you to save or discard them. 

 If you want to save the current configurations:  

 Choose Yes. DP.D displays a browser.  

 Select a path and file name for the configurations and choose Save. 

 If you want to discard the current configurations, choose No.  

 If you want to cancel the creation of the new configurations, choose Cancel.  

To open a set of configurations: 

 Choose File > Open. DP.D displays a browser.  

 Select a path and file name for the configurations and choose Open.  

5.9 Configuring DPFlex 

You configure DPFlex by setting motor parameters and running the configuration tool. After the tool 
has finished, you can save the configuration parameters to the controller's non-volatile memory so 
that they are not lost if the controller loses power.  

To set motor parameters: 

 In the DP.D navigation tree, double-click System > DPFlex ( Port ) > Motor . DP.D displays the 
Motor parameters form:  
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Figure 24: Motor parameters form 

 From the motor's data sheet, set the following parameters:  

To set this parameter...  ...take this action  

Number of Pole Pairs  Enter the number of pairs.  

Motor Peak Current  Enter the number of Amperes.  

 Choose Apply to update the motor parameters.  

To run the configuration tool: 

 In the Motor parameters form, choose Start. The DP.D configuration tool displays the 
configuration instructions:  

 

 

CAUTION Failure to ensure that the motor is fixed in place, not connected to a 
load, and that the shaft can turn freely may result in improper configuration and damage 
to equipment or personnel.  
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 Choose Continue to start the configuration operation. Choose Stop at any time to immediately 
halt the configuration operation.  

 Follow the instructions in the configuration tool to complete the configuration. Note that the 
configuration operation can take several minutes to complete. 

 Click  to close the configuration tool. 

To save configuration parameters to DPFlex's non-volatile memory: 

 In the DP.D navigation tree, double-click System > DPFlex ( Port ) > Registers. DP.D displays 
the Registers form:  

 
Figure 25: DP.D Registers form 

 Choose Update Registers. DP.D saves the current configuration parameters into the drive's 
non-volatile memory. 

 Click  to close the Registers form.  

5.10 Tuning the Current Loop  

Once you have configured DPFlex for the target motor, you can tune the current loop for the 
application.  

A well-tuned current loop is the first step to acceptable velocity and torque control. Without proper 
current tuning, satisfactory velocity and torque control cannot be achieved. 

 Current Compensator Loop  

The current loop is a control loop inside the velocity loop, which ensures the desired current 
setpoint is achieved and maintained. Refer to the block diagram shown in Figure 26 below. 
Except for the plant (the motor and its load), all of the blocks are parts of the drive. For the 
sake of simplicity, the plant is just an R-L transfer function of a BLDC motor. 

In the control loops, two main tasks must be achieved:  
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 Keeping the output (in this case, current in the motor coil) as close as possible to the input (in 
this case, a current setpoint). This is called steady state response .  

 Proper response to the change in the setpoint. This is called dynamic response .  

To achieve these two goals, a second order infinite impulse response filter (biquad 
compensator) is used to approximate a classic PID control loop. 

 
Figure 26: Current loop block diagram 

 Biquad Compensator  

A classic PID control loop can be approximated in the discrete time domain by a 2nd order 
IIR filter with the following (z) domain transfer function.  

 (1) 

Which has the following block diagram: 

 
Figure 27: Biquad filter structure 

 Calculating Filter Coefficients  

DP.D automatically calculates the biquad filter coefficients (Bn and An ) from the on screen 
representation (gains Kp, Ki, and Kd). Biquad coefficients are values described in Q1.15 
format with exponent value. (Most good digital signal-processing texts contain a description 
of the Q1.15 numerical format.)  

The transfer function of the PID compensator in the (s) domain is: 
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 (2) 

To find out how PID gains are related to Biquad gains, let's assume that , which is an 
approximation of the bilinear transformation. Then, by substituting (z) in (2):  

 (3) 

 and by comparing (1) and (3):  

 (4) 

 (5) 

 (6) 

 (7) 

 (8) 

Equations 4 through 8 show how each of the 5-biquad filter coefficients are calculated from 
the screen PID representation in DP.D. 

To tune the current loop: 

 Make sure the motor shaft is connected to the required load, that the load is free to move and can 
move safely, and that the motor itself will not move when turning.  

CAUTION You risk damaging equipment or personnel during tuning if you do 
not ensure that the load can move safely and that the motor will not move when rotating!  

 In DP.D's navigation tree, double-click System > DPFlex ( Port ) > Current Compensator. DP.D 
displays the Current Compensator form:  

 
Figure 28: Current Compensator form 
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The Current Compensator form displays the current gains set for the target motor. It  also enables you 
to re-calculate the gains based on the motor parameters and to open DP.D's tuning tools.  

 Choose Tuning Tools. DP.D displays the Oscilloscope and the Current stimulus forms:  

 
Figure 29: DP.D Oscilloscope and Current stimulus forms 

Tip You can arrange the forms as you like and save their positions using the View > Save 
Windows command. You can restore the forms to their saved positions at any time 
(including the next time you run DP.D) with the View > Restore Windows command.  

DP.D automatically sets the controls and fields in the Oscilloscope and Current stimulus forms to 
default values appropriate for tuning the current loop, based on the values you set in the Motor 
parameters form.  

The Current stimulus form enables you to vary the current available to the motor:  

 
Figure 30 Current stimulus form 
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 The Rated Current field shows the maximum current available from the DPFlex drive.  

 The Motor Peak Current field shows the value previously set for the motor's peak current 
rating. (To change this value, see “To set motor parameters.”)  

 The Control Mode section enables you to set Current or Torque as the control mode.  

 The Stop/Start control enables you to turn the current to the motor on or off.  

 The current controls enable you to set the following characteristics:  

 The DC command sets the current to direct.  

 The Pulse command sets the current to a square wave.  

 The Frequency field and slider sets the frequency of the square wave.  

 The Maximum and Minimum fields and sliders set the maximum and minimum values of 
the current pulse as percentages of the motor peak current. These values can be negative, 
zero, or positive.  

 In the Current stimulus form:  

 Choose Current Mode.  

 Choose Pulse.  

 Set the desired values for current pulse frequency and amplitude. 

 In the Current stimulus form, choose Start to apply current to the motor.  

 In the Oscilloscope form, choose Auto to start triggering.  
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After a few seconds, the Oscilloscope form will display the current stimulus in green and the 
actual current drawn by the motor in red:  

 

You can vary the settings in the Current stimulus form, including the slider controls for the 
frequency and amplitude of the current stimulus, to see how it affects the current the motor 
draws.  

 In the Oscilloscope form, choose Auto to stop triggering.  

 In the Current stimulus form, choose Stop to cut current to the motor.  

5.11 Tuning the Velocity Loop  

Once you have configured DPFlex for the target motor, you can tune the velocity loop for the 
application.  

 Velocity Compensator Loop  

The velocity loop ensures the desired velocity setpoint is achieved and maintained. Refer to 
the block diagram in Figure 31 below. Except for the plant (a motor and its load), all of the 
blocks are parts of the drive. For the sake of simplicity, the plant is just an R-L transfer 
function of a DC motor. In the control loops, two main tasks must be achieved:  

 Keeping the output (in this case, velocity of the motor) as close as possible to the input (in 
this case, a velocity setpoint). This is called steady state response.  
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 Proper response to the change in the setpoint. This is called dynamic response.  

To achieve these two goals, a second order infinite impulse response filter (biquad 
compensator) is used to approximate a classic PID control loop.  

 
Figure 31: Velocity loop block diagram 

 Biquad Compensator  

A classic PID control loop can be approximated in the discrete time domain by a 2nd order 
IIR filter with the following (z) domain transfer function.  

 (1) 

Which has the block diagram:  

 
Figure 32: Biquad filter structure 

 Calculating Filter Coefficients  

DP.D automatically calculates the biquad filter coefficients (Bn and An ) from the on screen 
representation (gains Kp, Ki, and Kd). Biquad coefficients are values described in Q1.15 
format with exponent value. (Most good digital signal-processing texts contain a description 
of the Q1.15 numerical format.) 

The transfer function of the PID compensator in the (s) domain is: 

 (2) 
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To find out how PID gains are related to Biquad gains, let's assume that , which is an 
approximation of the bilinear transformation. Then, by substituting (z) in (2):  

 (3) 

 and by comparing (1) and (3): 

  (4)  

  (5)  

 (6)  

 (7)  

 (8)  

Equations 4 through 8 show how each of the 5-biquad filter coefficients are calculated from 
the screen PID representation in DP.D.  

To tune the velocity loop  

 Make sure the motor shaft is connected to the required load, that the load is free to move and can 
move safely, and that the motor itself will not move when turning.  

CAUTION You risk damaging equipment or personnel during tuning if you do 
not ensure that the load can move safely and that the motor will not move when rotating!  

 In DP.D's navigation tree, double-click System > DPFlex ( Port ) > Velocity Compensator. DP.D 
displays the Velocity Compensator form:  

 
Figure 33: Velocity Compensator form 

The Velocity Compensator form displays the current gains set for the target motor. It also enables you 
to re-calculate the gains based on the motor parameters and to open DP.D's tuning tools.  

 Choose Tuning Tools. DP.D displays the Oscilloscope and the Velocity stimulus forms:  
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Figure 34: DP.D Oscilloscope and Velocity stimulus forms 

Tip You can arrange the forms as you like and save their positions using the View > Save 
Windows command. You can restore the forms to their saved positions at any time 
(including the next time you run DP.D) with the View > Restore Windows command.  

Note that DP.D automatically sets the controls and fields in the Oscilloscope and Velocity stimulus 
forms to default values appropriate for tuning the velocity loop.  

The Velocity stimulus form enables you to vary the velocity stimulus to the motor:  

 
Figure 35: Velocity stimulus form 

 In the Velocity stimulus form:  

 Choose Pulse.  

 Set the desired values for starting current, maximum velocity, maximum and minimum 
velocity setpoints, and velocity pulse stimulus frequency: 
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 In the Velocity stimulus form, choose Start to apply the velocity setpoints to the motor.  

 In the Oscilloscope form, choose Auto to start triggering.  

To do this...  ...take this action  

Set the starting current.  In Starting Current, enter the starting current in  Amps. 
The starting current is the current needed to move the 
motor from an a standing still position. This current has to 
be sufficient to generate enough torque to overcome the 
static inertia of the motor plus the load.  

Set the maximum velocity.  In Maximum Velocity, enter the maximum permitted 
velocity in revolutions/minute.  

Control the velocity from DP.D.  In Control Mode, choose Host.  

Control the velocity from an external analog input.  In Control Mode, choose Analog Input.  

Set the type of stimulus.  Choose DC for a constant velocity stimulus or Pulse for a 
varying velocity stimulus.  

Set the range of the velocity pulse stimulus.  In the Maximum and Minimum fields or using their 
matching sliders, enter the maximum and minimum 
velocity pulse stimulus to percentages of the value you set 
in Maximum Velocity.  

Set the frequency of the velocity pulse stimulus.  In the Frequency field or using the matching slider, enter 
the frequency of the velocity pulse stimulus.  

Start or stop the motor.  Choose Start or Stop.  
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After a few seconds, the Oscilloscope form will display the velocity stimulus setpoints and the actual 
velocity of the motor.  

 

You can vary the settings in the Velocity stimulus form to see how it affects the actual velocity 
achieved by the motor.  

 In the Oscilloscope form, choose Auto to stop triggering.  

 In the Velocity stimulus form, choose Stop to stop the motor.  

5.12 Viewing DPFlex Inputs  

When DPFlex is connected to a PC, you can use DP.D to check the signals at the input pins.  

Note that while you are checking the inputs with DP.D, the drive is disabled.  
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To monitor DPFlex inputs  

 In DP.D's navigation tree, double-click Inputs. DP.D displays the Inputs form:  

 
Figure 36: DP.D Inputs form 

The Digital Input One and Digital Input Two indicators turns ON when signal voltage is applied 
across the corresponding inputs. The Analog Input One indicator shows the percentage of input 
voltage across the analog input.  

 Click  to close the Inputs form.  

5.13 Controlling the Digital Output (Gen2 only) 

In the generation 2 DPFlex, the output can be configured through DP.D as either a speed indicator or 
a fault indicator.  When configured as a speed indicator, the output will change state every sixty (60) 
electrical degrees.  When configured as a fault indicator, the digital output will remain low when no 
faults are present.  It is asserted high when there is a fault. 

 

 

 

5.14 Viewing and Configuring Faults  

DP.D enables you to view and configure faults while the DPFlex drive is running.  

Figure 37 
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To view and configure fault thresholds  

 In DP.D's navigation tree, double-click Faults. DP.D displays the Faults form:  

 
Figure 38: DP.D Faults form 

 Set the thresholds by entering values for temperature, current, and voltage in degrees Celsius, 
amperes, and volts, respectively.  

 Choose Apply.  

 Click  to close the Faults form. 
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To view the operational status of the drive and motor  

 In the Faults form, choose the Status tab:  

 

 Check the current status:  

 Choose Refresh to update the display with the current status.  

 Choose Clear Faults to clear the display and update the status.  

 Click  to close the Faults form.  

5.15 Deploying DPFlex Applications  

At any time during application development, you can update a connected DPFlex drive's non-volatile 
memory with the current configuration parameters. You can also save DPFlex configuration 
parameters to a file and load these parameters into a connected DPFlex drive's non-volatile memory.  

You can also define in which mode to run the motor when the drive powers up.  
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To update DPFlex with the current configuration parameters  

 In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. DP.D displays the 
Registers form:  

 

 Choose Update Registers. DP.D saves the current configuration parameters into the drive's 
non-volatile memory.  

 Click  to close the Registers form.  

To save configuration parameters to a file  

 In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. DP.D displays the 
Registers form:  

 

 Choose Save Registers. DP.D opens a browser.  

 Select the path and file name and choose Save.  

 Click  to close the Registers form.  
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To load configuration parameters from a file into DPFlex's non-volatile memory  

 In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. DP.D displays the 
Registers form:  

 

 Choose Load Registers. DP.D opens a browser. 

 Select the path and file name and choose Open. DP.D loads the parameters into the drive's non-
volatile memory. 

 Click  to close the Registers form.  

To set the drive to Auto-Start or Start on Enable Input  

 In the DP.D navigation tree, choose System > DPFlex ( Port ) > Registers. DP.D displays the 
Registers form:   
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 Select Auto Start or Start on Enable Input from the first drop-down list box. 

 

 Select from one of four motor start-up parameter from the second drop-down list box. DP·D 
displays the motor start-up parameters drop-down list box.   

 

 You can choose to start the motor using a torque or velocity set point. You can also choose a 
fixed set point or one set by the analog input.   

 If you chose to use a fixed set point, enter the required set point value in the  Fixed Velocity or 
Fixed Torque field.  
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 If you chose to use a set point set by the analog input, enter the maximum permitted set point 
value in the Maximum Velocity or Maximum Torque field.  

  

 Enter the Starting Current in amperes.  

 Choose Update Registers. DP.D saves the current configuration parameters into the drive's 
non-volatile memory.  

 Click  to close the Registers form.  

Note that you must cut power to the drive, disconnect it from the computer, and restore power to the 
drive to start using the auto-start function. 
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Appendix A 
Mounting Guidelines for Stand-Alone  
DPFlex Controller PCB Assembly 

A.1 Introduction 

DPFlex is a fully operational sensorless BLDC motor controller that requires a functional heatsink to 
realize the full product power rating. This document has been written to provide guidance to OEM 
designers who desire to incorporate the DPFlex controller within packaging of their own design so that 
the product will achieve maximum mechanical robustness and greatest electrical performance. 

The section is organized into two sections that focus on the mechanical clearances and the electrically 
insulated thermally conductive interface. 

 Mechanical Integration 

The DPFlex BLDC sensorless controller assembly has been designed to allow OEM installation of 
the controller with minimum skilled technical involvement. There are three items to be aware of 
during the design of the mounting surface for the PCB assembly: 

 Mechanical clearance between the printed circuit board (PCB) and surrounding areas must be 
checked to ensure that interferences do not occur at maximum PCB tolerances as this might 
induce unexpected stresses on the PCB that could affect component reliability. 

 Mechanical clearances between the mounting planar surface and specified PCB locations must 
meet minimum required regulatory agency specifications for electrical clearances or 1.0mm 
(0.0394in). 

 The mechanical mounting surface designated as the thermal transfer surface must meet specified 
flatness specifications to prevent raised surfaces from interfering with heat transfer. 

To address the mechanical clearance requirements between the mounting area and the edge of the 
PCB, it is recommended that provisions be made to allow a minimum of 1.0mm (0.0394in) of 
clearance from the edge of the PCB to the area surrounding the PCB mounting location. The DPFlex 
PCB will typically have a tolerance of +0.762mm (0.030in)/-0.0mm (0.0in) on the outer edge 
dimensions. Please refer to Figure A.1 for details on clearance and tolerance requirements. By 
providing the recommended clearance, it will accommodate any variations in manufacturing process 
that might occur and will facilitate the installation of the PCB during assembly while ensuring PCB 
reliability. 
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Figure A.1: DPFlex PCB dimensions 

In addition to the clearance requirement on the edge of the PCB board, there is a minimum supporting 
outer edge requirement that is necessary for proper mechanical support of the assembly. Failure to 
include this edge may lead to additional stresses being placed on the PCB, which could cause 
component failures. 

A maximum of 0.635mm (0.025in) supporting edge must extend underneath the PCB starting from 
the nominal board edge location. This edge must not extend any further under the PCB or risk of an 
electrical short may occur, and minimum creepage and clearance specifications may be breached for 
specified regulatory agencies. Please refer to Figure A.2 for details on edge dimensions and 
tolerances.  Note that the supporting edge requirement is optional for the two edges that are 
perpendicular to the connector side edge of the PCB, so the use of an economical extrusion can be 
used to decrease manufacturing costs if desired. 
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Figure A.2: DPFlex PCB edge dimensions and tolerances 

Because the primary reason for providing a mounting surface is to give an adequate path for heat 
removal from the PCB, the surface directly beneath the power semiconductors located between the 
two mounting hole locations must maintain flatness and spatial dimensional as listed in the figures 
listed in this document. Please refer to Figure A. 3 for these details. 

Failure to meet the flatness specification will lead to a poor thermal heat transfer out of the PCB, and 
may lead to premature shutdowns of the drive or complete failure of the assembly. Adequate 
thermally conductive material beneath the drive is essential for proper operation of the product. 
Failing to provide either increased surface area capable of dissipating the maximum expected power 
dissipation or a sufficient bulk thermally conductive material will require the de-rating of the DPFlex 
for reliable operation. 

Please refer to the power dissipation curve for the product assembly that the mounting surface is 
being designed for. Please note that the recommended minimum thermal area is only for meeting the 
thermal transfer requirements.  This surface can be extended to the outer edges of the PCB along the 
centerline of the mounting holes. If this extension is made, the thermal interface material will need to 
be extended to those additional areas as well. 
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Figure A. 3: DPFlex PCB mounting surface considerations 

In addition to observing the constraints on the mechanical clearances and interface surfaces as 
explained above, it is necessary to use a thermally conductive, electrically isolating interface material 
inserted between the PCB located at the specified thermal transfer surface underneath the PCB, and a 
compression clip to guarantee proper operation of the DPFlex. 

The thermal interface material must be selected to have a low thermal resistance while filling in all 
voids between the mounting surface and the PCB, and providing 1100VDC of electrical isolation. 
Allied Motion recommends using the Berquist GAP PAD GPVOS-0.020-AC, 0.5mm (0.02in) thick 
thermal interface material. The material must extend pass the mounting surface by a minimum of 
1.27mm [0.05in] or the PCB edge, whichever is less, to ensure that no contact will occur between the 
PCB traces and the thermally conductive mounting surface. The thermal interface material should 
provide close fit clearance holes for the mounting screws to allow sufficient insulation material 
around those locations. 

Once the thermal interface material has been installed, a compression clip must be fitted on top of the 
PCB board above the power MOSFETS to ensure that adequate pressure is maintained on the PCB 
board to minimize thermal resistance and to provide mechanical restraint. An example design of a 
compression metal clip can be found in Figure A. 4 and the compression rubber strip in Figure A. 5. 

Alternately, mounting hardware kits can be ordered from Allied Motion, which contain the 
compression clip, the Berquist thermal interface material, and two #6-32 3/16 inch machine screws. 
When mounting the DPFlex, care must be taken that no more than 113 N-cm [10 in-lb] of torque be 
applied to the screws during assembly. 
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Figure A. 4: Compression metal clip design considerations 

 
Figure A. 5: Compression rubber strip dimensions 

 Testing: 

After completing the integration of the DPFlex into the target location, an insulation test should be 
performed to verify that the electrical insulation has not been breached. Further functionally tests can 
be done for verification of the thermal interface in addition to the insulation tests. 
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Appendix B 
Compliance 

A.2 EMC Related Installation Instructions 

In order to maintain compliance with the EMC Directive, 2004/108/EC, in EN 55011 Class A Industrial 
and Commercial environments, the following guidelines must be observed: 

 The signal cables for J1 must be less than 1m in length.  

 Drive dc power supply cables connected to J3/J4 should be made as short as possible and should be 
twisted together using one (1) twist or more per cm.  

 Motor cables connected to J5/J6/J7 should be as short as possible and should be twisted together 
using one (1) twist or more per cm.  

 An additional electrolytic capacitor placed as close as possible to the J3/J4 power connectors is 
recommended. Approximate sizing for this capacitor is 30μF per amp. Wiring for the added capacitor 
cables connected to J3/J4 should be made as short as possible and should be twisted together using 
one (1) twist or more per cm. If extra capacitance is used, it is highly recommended that a pre-charge 
circuit be used to limit the inrush current required to charge this capacitance. The limiting resistor 
should then be shorted out using a relay or other appropriate means.  

 If not using the DPFlex aluminum cover, an alternative enclosure providing similar or better 
attenuation between 30 MHz and 1 GHz must be used.  

Use of this product in environments other than those defined as EN 55011 Class A may require the user to 
apply additional EM suppression techniques to meet the EMC requirements of the final installation 
environment. 

NOTE: This equipment has been tested and found to comply with the limits for a Class A 
digital device, pursuant to part 15 of the FCC Rules. These limits are designed to provide 
reasonable protection against harmful interference when the equipment is operated in a 
commercial environment. This equipment generates, uses, and can radiate radio frequency 
energy and, if not installed and used in accordance with the instruction manual, may cause 
harmful interference to radio communications. Operation of this equipment in a residential 
area is likely to cause harmful interference in which case the user will be required to correct 
the interference at his own expense.  

 

This ISM device complies with Canadian ICES-001. 
Cet appareil ISM est conforme à la norme NMB-001 du Canada.  
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This device complies with part 15 of the FCC Rules. Operation is subject to the following two 
conditions:  
(1) this device may not cause harmful interference, and (2) this device must accept any 
interference received, including interference that may cause undesired operation. 
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