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1 Introduction

MCE is an experimental program for 3D and 2D voxel map visualization and for placing
atoms into the loaded voxel map. The software is mainly focused on visualization of ELD
maps calculated from the X-ray diffraction data of small unit cells, but it also works for small
proteins. It is compiled for Microsoft Windows systems (Windows 95, 98, NT 4, Win 2000,
Win XP, Win 7).

The code is written in Microsoft Visual C++. MFC library and OpenGL library was used.
MCE runs on PC with at least a Pentium-class or equivalent processor. This code does not
need special device or special PC configuration. For most of the work suffice the 12000MHz
CPU, 256MB RAM and 3D graphic card with OpenGL HW accelerator.

2 File format support

2.1 Voxel maps input file formats

MCE can read files from different crystallographic or other software:
e Oxford CRYSTALS

e SHELX/WinGX

e GSAS

e XD

« JANA2006

o the general .3d ASCII file

2.2 Atom positions input file formats

o Crystallographic file format *.cif

2.3 output file formats

pov-ray: *.pov

bitmap: *.bmp

VRML: *.wrl

Peak list: ASCII file with atoms coordinates
Fragment position

Restraints for Jana2006
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3 Menu

3.1 File

Open Primary Model: See 2.1 for supported file formats.

Open Secondary Model: MCE can read second voxel map which is overlapped with
the first one. The first and second map must have the same number of lines, columns
and sections! Note: if you load primary and secondary map, only atoms included in the
primary map (if any) are used. You can load for example difference map with void
map, etc.

Load Atoms: Load Atoms from *.cif file. Voxel map has to be loaded before using
this option. Note that the unitcell in the cif file and voxel map should be the same!
Import Fragment: Insert fragment from *.cif file. The content of the asymmetric part
is inserted to the scene. The centre of mass of all inserted atoms is calculated and the
model is placed to the 0 0 O position.

Load Cavities: Import cavities as a balls, see the details about the file format on the
MCE pages http://www.vscht.cz/min/mce/versions.html

Save BMP: It is possible to save screen as bitmap picture (better than CTRL+Print
Screen)

Save POV-ray input: Pov-ray is a special file format, which enables scene rendering.
For more details visit http://www.povray.org/

Save VRML input: VRML is a general file format, which enables to visualize scene
in external software.

Save Peaks: It saves inserted atoms as a ASCII file which is compatible with
CRYSTALS software.

Save Fragment: It saves selected part of the scene as a ASCII file (the same file
formats as "Save Peaks").

Save restraints for JANA2006: It generates distance and angle restraints file
according the actual scene (useful for organic compounds).

3.2 Edit

Add new peak: If MCE is in “add-atom mode” you can place a gold atom by clicking
right-mouse button somewhere to the map. If there is more than one unitcell visible,
only the area of the original unitcell (unitcell with zero translation vector) is working
properly. It is possible to change its position, use right-mouse button again. If there are
atoms in the scene, the distances to the nearest atoms are shown up to 3 A, by default
The actual value can be changed in the menu - > Preferences -> General Setup. If you
place it to the correct position, you can add this atom by using (“Add new peak”)
menu item - it makes "gold atoms". After this you can place another one.

Clear peak list: It deletes all already added gold atoms.

Save map settings: This item saves map iso-levels. If you load another map in the
future, it will start the map with the saved iso-levels. (See 3.3 “Display style” how to
enable this functionality).

3.3 Preference

Amination: Drag and move - scene will rotate

General setup: It changes projection mode (perspective or orthographic) and picking
mode (2D or 3D). Note: If you draw 2D map (how to draw 2D map see 3.5) and if you
want to place the gold atom, you should change picking mode to 2D! There is also
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option for changing the default max. distance for showing the distances of nearest
atoms during placing the new atom, see 3.2 Add new peak.

Display style: In this window it is possible to change how to show atoms, bonds,
maps, unit cell, etc. Be careful if you want to change ball or cylinder size or
resolution.

o In ELD map display style it is possible to check “use previous map settings”.

If you want to load several similar maps one after another, you can check this
setting. It means that if you load some map and you press “Save map settings”,
it saves maps iso-levels. After this, if you load another map, it starts this map
with the saved iso-levels.

o Data type: If you check organic it will not calculate inter molecules bonds.
Color settings: In this window it is possible to change background color and primary
and secondary map color.

Periodic table: It shows periodic table.

o Left mouse click: change atoms colors

o Right mouse click: change atoms properties
Add-atom mode: In this mode it is possible to use right mouse click for placing an
atom to the map
Info mode: In this mode it is possible to use right click to select some molecule. Note:
if you select some molecule, you can delete it. Press “d” for deleting.

3.4 Tools

SG setup: If you load file with crystallographic information, you can select the correct
space group. It is possible to draw several unit cells together - use “from” and “to” edit
boxes.

3.5 View

Level control primary map: If you load some map, you can change its properties and
isolevel in this window. It is possible to visualize map as contour lines, surface or its
combination. Use scroll bars to set the isolevel which you want to display or set the
correct number to the “layer value” edit box (mostly faster). If you want to show 2D
map, tick the 2D map check box and select “height”. If you want to place atom to the
2D map see 3.3 “General Setup” and 3.2 how to do it. Note: You can place atom to the
red map only! If you want to change maps colors see 3.3 “Color Settings”.

Level control secondary map: If you load secondary map, you can change map
properties see “level control primary map”.
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4 Examples

4.1 Load primary map and change map setting — CsE
(Example file is in “Program files\ICT\MCE\Examples\Crystals\CsE.fou”, by default)

1. Load CsE.fou file

S Untitled - MO
BH Edit Preferences Tooks View. Help

Open primany map data fie

3. MCE shows CsE file.
L= Untitled - MCE
| Epe Edit Preferences Tool  View  Help

Rty
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4. If you want to change map settings use menu->View->"Level control primary map”
or use * icon on toolbar and change map isolevel

: : SEX
File Edit Preferences Tools VYiew Helg
S G IEEY K
-~ X
tdimimumn b aximumn
-7.681247 75083813
Map mode
" Contour lines O Surface
O ContourkSurface © None

Surface settings
Reverse nomals Surface like lines
Scroll Bar's mode

v Linear I~ Exponencial

Carntour line cortrol
Surface contral
Layer wizsible aver value

v Laperl | pa72n

] ]
T . 2]
v Lapei3 | 49.4618
Al L |
20 map control
2D map Height |0
Apply | (1]:8 [ Cancel

Ready
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4.2 Loading Primary and secondary map, change map properties
and color settings

(Example file is in “Program files\ICT\MCE\Examples\Crystals\Primary_model.fou”)

1. Load Primary model:

= Unfitled - MCE
B0 Edit Praferences Tools View. Help

Opedn primary map data fie

2. Primary map loaded
S Unitled - MCE

Ele Et Ereferences Took Wew Hep

e i A T g . eyl
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3. Load Secondary map
5 Unitled - MCE
Efe Edt Preforerces Took Yiew  Hep

@;_-'- S AE W T oA T

Obdaa hiecibend: | () Crptals

! 3
___:;’ Frimary_model
o T
ety

b strdang Sacorulay Sl

Souby g Moo B [ fow.” prd, " lob, " ded " ol " phe, "2 =
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5. Primary and secondary maps are loaded

Primary map is electron density and secondary map is void map

U5 Untitled - WICE
Ele Edn Prefessnce: Took &

& e

i ady

FEI

6. Use menu->View->"Level control primary map” or use

icon on toolbar and

menu->View->"Level control secondary map” or use _# _icon on toolbar.

a. Uncheck Layerl in primary map — green map is dumb...

b. Check Contour&Surface in Secondary map — it shows the first layer (Layer 1) as a surface

and Layerl, Layer2 and Layer3 as a contour maps.
c. Check Reverse normals — it paints surface inside.
d. UnCheck Layer2 and Layer3 — it is now more synoptical.

This picture shows solvent butan-2-ol in void space in the crystal structure of CsE.

L] Comtral Primmisry Map m Level Coptrol Secondony Map -

Mirsraam M Hararwm 1 s
4 430507 Frke sl 6N 2 000
Map mode _’E:‘:‘b_\,'d:_.—._\_\_\___\_
=+ Lonioes re Sudsen [ Contow lred Surface -
ContourdSurses Morw * ConmtoslSurace Hona )
_\__|_-—'_'_'-'_-F

Sarface peltngs

Reverie nomsh Surlace le ey {J@
Sl Bar's moda SolTars mods

o Liroa E ipreridayl v Linear Exporanas
LCard iun bred Covdicd Comnbou e conidl
Surlsce cortiol Sarlace contnal

it = L vinhsm L vt “winiiblen
’ B

W ¥ L2 gruam
T T

200 i il
imap Heght 0
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4.3 Placing atoms into the map

1. load primary and secondary map (use prim_4_3.fou-primary and sec_4_ 3.fou-
secondary files)

red, green, blue — eld map

yellow, cyan and violet — void map

(e P |
e G Preieesce Tem fws S
&= =& AR AT AN

Py e x
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3. Open secondary map control and set properties

Level Control Becondans Map, =
Mirirem

1. TETRE 20T

Map mode:
Conbous
ConbouriSulace e
+ R romish )

Serol Bae's mode
o Linaa Exponencial
Coonbour ke contind
Suface coninal
L i
¥ Law 003
v Lapsd 4231

W v Lywd | e

20 msp coningl
Dmap Heghe 0

Appke iy Cancel

4. Find green peaks in the void space as shows the picture

Eir [t Preferercss Took Yiew Hep

& s 2N
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5. Set the red map (primary map, Layer3).
If you want to place atoms to the map, primary-Layer3 has to be visible!

Leseel Canteal Fri MFaTY Map =

130 e50e1 2
Bl ercde
= Corbour ires Seelace
ConbourdSufacs Hore

Surface ssifirgs
Fimveite nosmals Surince B e
Scroll Bar's mods
¥ Linesr Exponercial

Corbous fire contol
Surfscs contiol
Lapa vizble
B v Lagen

B v Lawe? 218524

6. Check if you are in "Add atom mode™ (Preferences->Add atom mode).

Click on some red peak in the map (use right mouse button) and place gold atom.
Repeat right click until the gold atom is in the correct position.

Right click places atoms only to the maximum!!! Not to the minimum... For placing
atoms to the other places use 2D map picking (see 4.3.10)

Eds Edit Profersncer Toos View Hep

EES . 2N L
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7. If you find the position correct select menu->Edit->"Add new peak”
pirm_4_3- MCE

Fie Bl Preferences Tools  View Heip

A e ek iy R BT AT the current oursor posstion

8. Repeat step 6. and 7. to place all gold atoms to the map

Ede Et Prefarences Took View Help

EE8d D 4

13|Page



9. If you think that these positions are incorrect, select menu->Edit->"Clear peak list”. It

erases all gold atoms.
“ipinm, A 3- MCE
Fie B5IY Preferences Took  View Help

10. If you have problem with placing atoms to the map or if you would like to place atoms
to the minimum, you should use 2D picking. Set in menu->preferences->"General

General selup

1l4|Page



11. Open “Level control primary map”. Set 2D map and set the correct height of 2D map.

Level Control Primany Map

23958612 3 I = g 9
Map mads
* Conlow nes
ContoustSantsce Mone
Surlace seltingt
Rerved e naomalz Sumlace Bop lnes
Secroll Bar's mode
¥ Linear Exponsncial
Crordour bre coninol
Surdace coninol
Lapen visiie
B v Ly

W v L

B v Layen

13. Now, you can place atoms to the 2D map. This setting allows you to place atoms

anywhere in the 2D map.
pirm_A4_3 - MCE

Fie Edit Preferences Tools Wiew Hep

sEd8d D A= & i

14. If you think, you placed atoms correctly, you can export theirs coordinates.
File->"Save peak list”
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< pirm_4 3 - MCE
BN Edst Preferences Tookk Yiew Haip
Open Primary Model,..  Ctried
Opeeny Secondary slodel
Sane B
Save POV-Ray input
Save VRML inpurt

Sl pask lirh

Exit

Save pogition of peaks in CRYSTALS compatible farmat

15. file output:

#EDIT

ATOM Q 1 X= 0.921841 Y= 0.254516 Z= 0.873093
ATOM Q 1 X= 0.941712 Y= 0.185850 Z= 0.830249
ATOM Q 1 X= 1.044382 Y= 0.186113 Z= 0.790634
END

16. Write "#use newatoms.dat™ to the CRYSTALS command line to import this file into
the CRYSTALS
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4.4 Use previous maps iso-levels and maps settings

1. Use example 4.2 to set maps iso-levels and settings as shows the picture:

Level Control Primany, Map | Level Coptrol Secondany Map . &
Mrwram M gt SR
FL =R 1673 4 onom
M mode M
* Contou lrws Siracn <"' Contour ines )
ContourtSuloen  Mors Efu —
Sanfach palings - =
Revers normash Surlics Bea frag < v Pevene nomadh
.
Scrod Bar'y moda STt mads
v Lesa E ipvesricay

¥ Linear Exporancis

Coordons ket coniral Contour ine coniol

Suslce cortol Sartace cornal

AT Ly vahss L'w-gi_.m:x_\
' 1 80918 = Lol | 0475

WV L2 p2um

i
P @3 22
L] . - L
20 map coninal 20 mresp Conbsod

Mmap Heght 0 20 map Heght 0

Appls oK. Cancel Agply [als Cancel

& = & Bk W& T a9

Bl pom 0z Bl sppchation
Cilinder size |06 Crader rmsolubion
Sealed Fachor Scaled ball resoltion

Hondy Diaplay shie
*  Colorad waith hwo colois -
Borads haves orly ons colol

ELD s chiplay shila

* ELD meeip 85 vy Hine s

_ELD mop a3 odingery  Cilinder size
= T
v Use prevsouy map settegn _)

e —

Setup vinkdity

¥ Lind ool winble | Lne oo 13

Lo defalt

By

HLIM
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3. Menu->Edit->Save map settings

4. Load another map or close MCE and load another map. Map(s) will be loaded with
saved settings.

il Edie  Beefarances Teedi aw Halp
o - FaE T ool T

Eaady HUM
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4.5 Erase atoms and bonds
1. Do example 4.2

Livel Contral Primary Map m Level Coptrol Secondony Map
Miritaam e Hramm M asaresm
L0807 bk e 1660173 4.(onom
Map mode Mpmede o
» Carioor ens T [ Contow ines Sufece
Contoalbulses Hora * ContoualSudpce Mona -
—\__‘_._,_o—"_-
Suslgin ety g

Reven# nomash Surlace ke neg < v Rvene nomdh

b
Scrod Bar'y mods Sl Tt mode
¥ Lras E ey w Linba Exporsncisl

Coorsdons ks Corirol Conbour finé contedl

Susfece corhiod Sartace contrd

T T Lot vihun LW'EE_,_.M\\_\
' 3 88 =% Lyl | g

W ¥ Ly G2mm

B v Loped T @13 2 2060

20 map cowniral 20 map conbol
Mmep Heght 0 Dmap Hege 0

Apph ok Cancel

File Edit Preferences Tools ‘Wiew Help

~

= =S e

G| e
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3. Check if you are in "info mode"! Select atom you want to delete (atom get yellow) and
press "d". Continue with selecting and delete all needed objects (atoms or bonds).
Press "b" to go back step by step or press "r" to restore all deleted objects
e Untitled - M NER

File Edit Preferences Tools Wiew Help

= =& i g

Feeady UM

20|Page



4.6 How to erase the yellow dummy atom?

1. If you place an incorrect or dummy yellow atom into the view as shown on the
screenshot, you have to firstly add this atom (Edit->Add new peak) and then erase it (Edit-
>Clear peak list).

File Edit Preferences Tools Wiew Help

= =S S i

Delete all peaks From peak list
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