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Getting started with STM32CubeF4 firmware package
for STM32F4 Series

Introduction

The STMCube™ initiative was originated by STMicroelectronics to ease developers life by
reducing development efforts, time and cost. STM32Cube covers the STM32 portfolio.

STM32Cube Version 1.x includes:

e The STM32CubeMX, a graphical software configuration tool that allows to generate C
initialization code using graphical wizards

e A comprehensive embedded software platform, delivered per series (such as
STM32CubeF4 for STM32F4 series)

— The STM32Cube HAL, an STM32 abstraction layer embedded software, ensuring
maximized portability across the STM32 portfolio

— A consistent set of middleware components such as RTOS, USB, TCP/IP and
graphics

—  All embedded software utilities coming with a full set of examples.
This user manual describes how to get started with the STM32CubeF4 firmware package.
Section 1 describes the main features of STM32CubeF4 firmware, part of the STMCube™
initiative.
Section 2 and Section 3 provide an overview of the STM32CubeF4 architecture and
firmware package structure.
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STM32CubeF4 main features

STM32CubeF4 gathers together, in a single package, all the generic embedded software
components required to develop an application on STM32F4 microcontrollers. In line with
the STMCube " initiative, this set of components is highly portable, not only within the
STM32F4 series but also to other STM32 series.

STM32CubeF4 is fully compatible with STM32CubeMX code generator that allows the user
to generate initialization code. The package includes a low level hardware abstraction layer
(HAL) that covers the microcontroller hardware, together with an extensive set of examples
running on STMicroelectronics boards. The HAL is available in an open-source BSD license
for user convenience.

STM32CubeF4 package also contains a set of middleware components with the
corresponding examples. They come with very permissive license terms:
e Full USB Host and Device stack supporting many classes.
— Host Classes: HID, MSC, CDC, Audio, MTP
— Device Classes: HID, MSC, CDC, Audio, DFU
e  Graphics:

—  STemWin, a professional graphical stack solution available in binary format and
based on the emWin solution from ST's partner SEGGER

— LibJPEG, an open source implementation on STM32 for JPEG images encoding
and decoding.

e CMSIS-RTOS implementation with FreeRTOS open source solution
e  FAT File system based on open source FatFS solution

e TCP/IP stack based on open source LwIP solution

e  SSL/TLS secure layer based on open source PolarSSL

A demonstration implementing all these middleware components is also provided in the
STM32CubeF4 package.
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Figure 1. STM32CubeF4 firmware components
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2 STM32CubeF4 architecture overview

The STM32CubeF4 firmware solution is built around three independent levels that can
easily interact with each other as described in the Figure 1 below:

Figure 2. STM32CubeF4 firmware architecture

Level 2

Level 1

Level 0

Eval board and Discovery Kit demonstration

A/

Applications

L)

Library and protocol based components (FatFS, FreeRTOS, USB

Host, USB Device, Ethernet...)

Examples

11

HAL peripheral drivers

Low level Driver Core (optional)

BSP drivers

HAL

MSv34531V1

Level 0: This level is divided into three sub-layers:

e Board Support Package (BSP): this layer offers a set of APIs related to the hardware
components on the hardware boards (Audio codec, I/O expander, Touchscreen, SRAM
driver, LCD drivers. etc...) and composed of two parts:

Component: is the driver related to the external device on the board and not
related to the STM32, the component driver provides specific APIs to the BSP
driver’s external components and can be ported to any board.

BSP driver: it enables the component driver to be linked to a specific board and
provides a set of user-friendly APIs. The APl naming rule is
BSP_FUNCT_Action(): ex. BSP_LED_Init(),BSP_LED_On()

It's based on a modular architecture that allows it to be ported easily to any hardware
by just implementing the low level routines.

e Hardware Abstraction Layer (HAL): this layer provides the low level drivers and the
hardware interfacing methods to interact with the upper layers (application, libraries
and stacks). It provides generic, multi instance and function-oriented APIs which allow
to offload the user application implementation by providing ready-to-use processes. For
example, for the communication peripherals (12S, UART...) it provides APIs allowing to

3
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initialize and configure the peripheral, manage data transfer based on polling, interrupt
or DMA process, and manage communication errors that may raise during
communication. The HAL Drivers APIs are split in two categories, generic APIs which
provides common and generic functions to all the STM32 series and extension APIs
which provides specific and customized functions for a specific family or a specific part
number.

Basic peripheral usage examples: this layer contains examples of basic operation of
the STM32F4 peripherals using only the HAL and BSP resources.

Level 1: This level is divided into two sub-layers:

Middleware components: a set of Libraries covering USB Host and Device Libraries,
STemWin, LIbJPEG, FreeRTOS, FatFS, LwIP, and PolarSSL. Horizontal interactions
between the components of this layer are done directly by calling the feature APIs while
the vertical interaction with the low level drivers is done through specific callbacks and
static macros implemented in the library system call interface. For example, the FatFs
implements the disk I/O driver to access microSD drive or the USB Mass Storage
Class.

The main features of each Middleware component are as follows:
USB Host and Device Libraries
—  Several USB classes supported (Mass-Storage, HID, CDC, DFU, AUDIO, MTP)

—  Supports multi packet transfer features: allows sending big amounts of data
without splitting them into max packet size transfers.

— Uses configuration files to change the core and the library configuration without
changing the library code (Read Only).

— Includes 32-bit aligned data structures to handle DMA-based transfer in High-
speed modes.

—  Supports multi USB OTG core instances from user level through configuration file
(allows operation with more than one USB host/device peripheral).

— RTOS and Standalone operation

—  The link with low-level driver is done through an abstraction layer using the
configuration file to avoid any dependency between the Library and the low-level
drivers.

STemWin Graphical stack

— Professional grade solution for GUI development based on Segger’'s emWin
solution

—  Optimized display drivers

—  Software tools for code generation and bitmap editing (STemWin Builder...)
LibJPEG

—  Open source standard

—  Cimplementation for JPEG image encoding and decoding.

FreeRTOS

Open source standard

—  CMSIS compatibility layer

Tickless operation during low-power mode

Integration with all STM32Cube Middleware modules

3
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FAT File system

FATFS FAT open source library

Long file name support

Dynamic multi-drive support

RTOS and standalone operation

Examples with microSD and USB host Mass-storage class

LwIP TCP/IP stack

Open source standard
RTOS and standalone operation

e Examples based on the Middleware components: each Middleware component
comes with one or more examples (called also Applications) showing how to use it.
Integration examples that use several Middleware components are provided as well.

Level 2: This level is composed of a single layer which is a global real-time and graphical
demonstration based on the Middleware service layer, the low level abstraction layer and
the applications that make basic use of the peripherals for board-based functions.
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STM32CubeF4 firmware package overview

Supported STM32F4 devices and hardware

STM32Cube offers a highly portable Hardware Abstraction Layer (HAL) built around a

generic and modular architecture allowing the upper layers, Middleware and Application, to
implement its functions without in-depth knowledge of the MCU being used. This improves
the library code re-usability and guarantees an easy portability from one device to another.

The STM32CubeF4 offers full support for all STM32F4 Series devices. You only have to
define the right macro in stm32f4xx.h.

Table 1 below lists which macro to define depending on the STM32F4 device you are using
(this macro can also be defined in the compiler preprocessor).

Table 1. Macros for STM32F4 series

Macro defined in .
stm32f4xx h STM32F4 devices
STM32F405xx STM32F405RG, STM32F405VG and STM32F4052G
STM32F415xx STM32F415RG, STM32F415VG and STM32F4152G
STM32F407VG, STM32F407VE, STM32F407ZG, STM32F407ZE,
STM32F407xx STM32F407IG and STM32F407IE
STM32F417VG, STM32F417VE, STM32F417ZG, STM32F417ZE,
STM32F417xx STM32F417IG and STM32F417IE
STMB32F427VG, STM32F427VI, STM32F427ZG, STM32F427ZI,
STM32Fa27xx STM32F4271G and STM32F427II
STM32F437VG, STM32F437VI, STM32F4372G, STM32F437ZI,
STM32F437xx STM32F437IG and STM32F437Il
STM32F429VG, STM32F429VI, STM32F429ZG, STM32F4297I,
STM32F429xx STM32F429BG, STM32F429BI, STM32F429NG, STM32F439Nl,
STM32F4291G and STM32F429I|
STM32F439VG, STM32F439VI, STM32F439ZG, STM32F4397I,
STM32F439xx STM32F439BG, STM32F439BI, STM32F439NG, STM32F439NI,
STM32F439IG and STM32F439l|
STM32F401CB, STM32F401CC, STM32F401RB, STM32F401RC,
STM32F401xC STM32F401VB and STM32F401VC
STM32F401CD, STM32F401RD, STM32F401VD, STM32F401CE,
STM32F401xE STM32F401RE and STM32F401VE
STM32F411CC, STM32F411RC, STM32F411VC, STM32F411CE,
STM32F4T1xE STM32F411RE and STM32F411VE
CTM32EA46x¢ STM32F446MC, STM32F446ME, STM32F446RC, STM32F446RE,
STM32F446VC, STM32F446VE, STM32F446ZC, STM32F446ZE
STM32F469AI, STM32F469I1, STM32F469BI, STM32F469NI,
STM32F469AG, STM32F469IG, STM32F469BG,
STM32F469xx
STM32F469NG, STM32F469AE, STM32F469IE, STM32F469BE,
STM32F469NE

3

DoclD025922 Rev 6




UM1730

STM32CubeF4 firmware package overview

3

Table 1. Macros for STM32F4 series (continued)

Macro defined in
stm32f4xx.h

STM32F4 devices

STM32F479Al, STM32F479Il, STM32F479BI, STM32F479NI,

STM32F479xx STM32F479AG, STM32F4791G, STM32F479BG, STM32F479NG
STM32F410Rx STM32F410R8, STM32F410RB
STM32F410Cx STM32F410C8, STM32F410CB
STM32F410Tx STM32F410T8, STM32F410TB

STM32CubeF4 features a rich set of examples and demonstrations at all levels making it
easy to understand and use any HAL driver and/or Middleware components. These
examples can be run on any of the STMicroelectronics boards as listed in Table 2 below:

Table 2. Evaluation and Discovery boards for STM32F4 series

Board

STM32F4 devices supported

STM324x91_EVAL

STM32F429xx and STM32F439xx

STM324xG_EVAL

STM32F407xx and STM32F417xx

STM32F4-Discovery

STM32F407xx

STM32F401-Discovery

STM32F401xC

STM32F429I-Discovery

STM32F429xx

STM32F401RE-Nucleo

STM32F401xE

STM32F411RE-Nucleo

STM32F411xE

STM32446E-EVAL

STM32F446xx

STM32F446E-Nucleo

STM32F446xx

STM324691-EVAL

STM32F469xx

STM32F469I-Discovery

STM32F469xx

STM32F410x-Nucleo

STM32F410xx

STM32F429ZI-Nucleo

STM32F429Z7|

STM32F446ZE-Nucleo

STM32F446ZE

STM32F411E-Discovery

STM32F411xE

STM32F4 supports both Nucleo-64 and Nucleo-144 boards, these boards support Adafruit
LCD display Arduino™ UNO shields which embed a microsSD connector and a joystick in

addition to the LCD.

The Arduino™ shield drivers are provided within the BSP component. Their usage is
illustrated by a demonstration firmware.

The STM32CubeF4 firmware is able to run on any compatible hardware. This means you
can simply update the BSP drivers to port the provided examples to your own board, if it has
the same hardware functions (LED, LCD display, pushbuttons...etc.).
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3.2 Firmware package overview

The STM32CubeF4 firmware solution is provided in a single zip package with the structure
shown in Figure 3 below.

Figure 3. STM32CubeF4 firmware package structure

STM32Cube_FW_F4_VXY.Z
Contains &), _himresc
STM32F4xx -- Diocumentation
CMSIS files that B | Drivers
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preconfigured projects. - | WIN32 o
W Utliies 4_/ utilities
WIN32 directory -1 cpu
contains Windows- Fonts
based simulation Log
project for STemWin. Media
PC_Software
2] packagexml MSv34533V2
~| Release_Motes.html

For each board, a set of examples are provided with preconfigured projects for EWARM,
MDK-ARM, TrueSTUDIO and SW4STM32 toolchains.

Figure 4 shows the project structure for the STM324xG-EVAL board. The structure is
identical for other boards.

3
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The examples are classified depending on the STM32Cube level they apply to, and are
named as follows:

e Examplesin level 0 are called Examples, that use HAL drivers without any Middleware
component

e Examples in level 1 are called Applications, that provide typical use cases of each
Middleware component

e Examples in level 2 are called Demonstration, that implement all the HAL, BSP and
Middleware components

A Template project is provided to allow you to quickly build any firmware application on a
given board.

All examples have the same structure,

¢ \Inc folder that contains all header files

e \Src folder for the sources code

e \EWARM, \MDK-ARM, \TrueSTUDIO and \SW4STM32 folders contain the
preconfigured project for each toolchain.

e readme.txt describing the example behavior and the environment required to make it
work

3
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Figure 4. STM32CubeF4 examples overview
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Table 3 provides the number of examples, applications and demonstrations available for

each board.
Table 3. Number of examples available for each board
Board Examples Applications Demonstration

STM324x91_EVAL 83 53 1
STM324xG_EVAL 69 50 1
STM32F4-Discovery 23 2 1
STM32F401-Discovery 20 2 1
STM32F401RE-Nucleo 3 NA NA
STM32F411RE-Nucleo 4 NA 1
STM32F411E-Discovery 20 2 1
STM32F429I-Discovery 25 10 1
STM32F429ZI-Nucleo 25 7 1
STM32446E-EVAL 68 33 1
STM32F446ZE-Nucleo 25 6 1
STM324691_EVAL 92 40 1
STM32469I-Discovery 41 24 1
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Getting started

How to run your first example

This section explains how simple it is to run a first example with STM32CubeF4. As an
illustration let's consider to run a simple LED toggling example running on the STM32F4-
Discovery board:

1.

L

After downloading the STM32CubeF4 firmware package, unzip it into a directory of
your choice, you just need to ensure that the package structure is not modified (as
shown in Figure 3 above).

Browse to \Projects\STM32F4-Discovery\Examples.
Open \GPIO, then the \GPIO_EXT] folder.

Open the project with your preferred toolchain.

Rebuild all files and load your image into target memaory.

Run the example: each time you press User button 4, the LEDs will toggle (for more
details, refer to the example readme file).

You will get a quick overview of how to open, build and run an example with the
supported toolchains.

EWARM

a) Under the example folder, open the \EWARM subfolder.
b) Open the Project.eww workspace®.

¢) Rebuild all files: Project->Rebuild all.

d) Load project image: Project->Debug.

e) Run program: Debug->Go(F5).

MDK-ARM

a) Under the example folder, open the \MDK-ARM subfolder.
b) Open the Project.uvproj workspace®.

¢) Rebuild all files: Project->Rebuild all target files.

d) Load project image: Debug->Start/Stop Debug Session.
e) Run program: Debug->Run (F5).

TrueSTUDIO

a) Open the TrueSTUDIO toolchain.

b) Click on File->Switch Workspace->Other and browse to the TrueSTUDIO
workspace directory.

c) Click on File->Import, select General->'Existing Projects into Workspace' and then
click “Next”.

d) Browse to the TrueSTUDIO workspace directory, select the project.

e) Rebuild all project files: Select the project in the “Project explorer” window then
click on Project->build project menu.

f)  Run program: Run->Debug (F11).
SW4STM32
a) Openthe SW4STM32 toolchain.

b) Click on File->Switch Workspace->Other and browse to the SW4STM32
workspace directory.
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c) Click on File->Import, select General->'Existing Projects into Workspace' and then
click "Next".
d) Browse to the SW4STM32 workspace directory, select the project.
e) Rebuild all project files: Select the project in the "Project explorer" window then
click on Project->build project menu.
f)  Run program: Run->Debug (F11).
4.2 How to develop your own application

This section describes the required steps needed to create your own application using

STM32CubeF4.

1. Create your project: to create a new project you can either start from the Template
project provided for each board under \Projects\<STM32xx_xxx>\Templates or from
any available project under \Projects\<STM32xx_xxx>\Examples or
\Projects\<STM32xx_xxx>\Applications (<STM32xx_xxx> refers to the board name, ex.
STM32F4-Discovery).

The Template project provides an empty main loop function, this is a good starting point
to allow you to get familiar with the project settings for STM32CubeF4. It has the
following characteristics:
a) It contains sources of the HAL, CMSIS and BSP drivers which are the minimum
required components to develop code for a given board
b) It contains the include paths for all the firmware components
c) It defines the STM32F4 device supported, allowing to have the right configuration
for the CMSIS and HAL drivers
d) It provides ready-to-use user files preconfigured as follows:
- HAL is initialized
- SysTick ISR implemented for HAL_Delay() purpose
- System clock is configured with the maximum frequency of the device
Note: If you copy an existing project to another location, then you need to update the include
paths.
2. Add the necessary Middleware to your project (optional): available Middleware

stacks are: USB Host and Device Libraries, STemWin, LibJPEG, FreeRTOS, FatFS,
LwlIP, and PolarSSL. To find out which source files you need to add to the project files
list, refer to the documentation provided for each Middleware, you can also have a look
at the applications available under \Projects\STM32xx_xxx\Applications\<sMW_Stack>
(<MW _Stack> refers to the Middleware stack, for example USB_Device) to get a better
idea of the source files to be added and the include paths.

Configure the firmware components: the HAL and Middleware components offer a

set of build time configuration options using macros declared with “#define” in a header
file. A template configuration file is provided within each component, which you have to
copy to the project folder (usually the configuration file is named xxx_conf_template.h.
The word “_template” needs to be removed when copying it to the project folder). The
configuration file provides enough information to know the effect of each configuration

a. The workspace name may change from one example to another

3
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option. More detailed information is available in the documentation provided for each
component.

4. Start the HAL Library: after jumping to the main program, the application code needs
to call HAL_Init() API to initialize the HAL Library, which does the following:

a) Configures the Flash prefetch, instruction and data caches (user-configurable by
macros defined in stm32f4xx_hal_conf.h)

b) Configure the SysTick to generate an interrupt every 1ms. The SysTick is clocked
by the HSI (default configuration after reset)

c) Sets NVIC Group Priority to 4

d) Calls the HAL_Msplnit() callback function defined in user file
stm32f4xx_hal_msp.c to do the global low level hardware initialization

5. Configure the system clock: the system clock configuration is done by calling these
two APIs

a) HAL_RCC_OscConfig(): configures the internal and/or external oscillators, PLL
source and factors. You can choose to configure one oscillator or all oscillators.
You can also skip the PLL configuration if there is no need to run the system at
high frequency

b) HAL_RCC_ClockConfig(): configures the system clock source, Flash latency and
AHB and APB prescalers

6. Peripheral initialization

a) Start by writing the peripheral HAL_PPP_Msplnit function. For this function,
proceed as follows:

—  Enable the peripheral clock.

—  Configure the peripheral GPIOs.

—  Configure DMA channel and enable DMA interrupt (if needed).

—  Enable peripheral interrupt (if needed).

b) Edit the stm32f4xx_it.c to call the required interrupt handlers (peripheral and
DMA), if needed.

c) Write process complete callback functions if you plan to use peripheral interrupt or
DMA.

d) Inyour main.c file, initialize the peripheral handle structure, then call the function
HAL_PPP_Init() to initialize your peripheral.

7. Develop your application process: at this stage, your system is ready and you can
start developing your application code.

a) The HAL provides intuitive and ready-to-use APIs for configuring the peripheral,
and supports polling, interrupt and DMA programming models, to accommodate
any application requirements. For more details on how to use each peripheral,
refer to the rich examples set provided.

b) If your application has some real-time constraints, you can find a large set of
examples showing how to use FreeRTOS and integrate it with all Middleware
stacks provided in STM32CubeF4, it can be a good starting point for your
development.

Note: In the default HAL implementation, the SysTick timer is the timebase source. It is used to

generate interrupts at regular time intervals. If HAL_Delay() is called from peripheral ISR
process, the SysTick interrupt must have higher priority (numerically lower) than the
peripheral interrupt. Otherwise, the caller ISR process is blocked. Functions affecting
timebase configurations are declared as __ Weak to make override possible in case of other

18/23
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implementations in user file (using a general purpose timer for example or other time
source). For more details please refer to HAL_TimeBase example.

Using STM32CubeMX for generating the initialization C code

Another alternative to Steps 1 to 6 described in Section 4.2 consists in using the
STM32CubeMX tool to easily generate code for the initialization of the system, the
peripherals and middleware (Steps 1 to 6 above) through a step-by-step process:

1. Selection of the STMicroelectronics STM32 microcontroller that matches the required
set of peripherals.

2. Configuration of each required embedded software thanks to a pinout-conflict solver, a
clock-tree setting helper, a power consumption calculator, and an utility performing
MCU peripheral configuration (GPIO, USART...) and middleware stacks (USB,
TCP/IP...).

3. Generation of the initialization C code based on the configuration selected. This code is
ready to be used within several development environments. The user code is kept at
the next code generation.

For more information, please refer to “STM32CubeMX for STM32 configuration a(nd
initialization C code generation” user manual (UM1718).

How to get STM32CubeF4 release updates

The STM32CubeF4 firmware package comes with an updater utility: STM32CubeUpdater,
also available as a menu within STM32CubeMX code generation tool.

The updater solution detects new firmware releases and patches available from st.com and
proposes to download them to the user’'s computer.

How to install and run the STM32CubeUpdater program

e Double-click SetupSTM32CubeUpdater.exe file to launch the installation.
e Accept the license terms and follow the different installation steps.

Upon successful installation, STM32CubeUpdater becomes available as an
STMicroelectronics program under Program Files and is automatically launched.

The STM32CubeUpdater icon appears in the system tray:

e Right-click the updater icon and select Updater Settings to configure the Updater

connection and whether to perform manual or automatic checks (see STM32CubeMX
User guide - UM1718 section 3 - for more details on Updater configuration).
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What is the license scheme for the STM32CubeF4 firmware?
The HAL is distributed under a non-restrictive BSD (Berkeley Software Distribution) license.

The Middleware stacks made by ST (USB Host and Device Libraries, STemWin) come with
a licensing model allowing easy reuse, provided it runs on an ST device.

The Middleware based on well-known open-source solutions (FreeRTOS, FatFs, LwIP and
PolarSSL) have user-friendly license terms. For more details, refer to the license agreement
of each Middleware.

What boards are supported by the STM32CubeF4 firmware package?

The STM32CubeF4 firmware package provides BSP drivers and ready-to-use examples for
the following STM32F4 boards: STM324x9I_EVAL, STM324xG_EVAL, STM32446E_EVAL,
STM32F4-Discovery, STM32F401-Discovery, STM32F429I-Discovery, STM32F4xx-Nucleo,
STM324691_EVAL STM32469I-Discovery, STM32F446E-Nucleo, STM32F410xx-Nucleo,
STM32F429Z1-Nucleo, STM32F446ZE-Nucleo, STM32F411E-Discovery.

Is there any link with Standard Peripheral Libraries?
The STM32Cube HAL Layer is the replacement of the Standard Peripheral Library.

The HAL APIs offer a higher abstraction level compared to the standard peripheral APls.
HAL focuses on peripheral common functionalities rather than hardware. The higher
abstraction level allows to define a set of user friendly APIs that can be easily ported from
one product to another.

Existing Standard Peripheral Libraries will be supported, but not recommended for new
designs.

Does the HAL take benefit from interrupts or DMA? How can this be
controlled?

Yes. The HAL supports three APl programming models: polling, interrupt and DMA (with or
without interrupt generation).

Are any examples provided with the ready-to-use toolset projects?

Yes. STM32CubeF4 provides a rich set of examples and applications (140 for
STM324x91_EVAL). They come with the preconfigured project of several toolsets: IAR, Keil
and GCC.

How are the product/peripheral specific features managed?

The HAL offers extended APIs, i.e. specific functions as add-ons to the common API to
support features available on some products/lines only.

How can STM32CubeMX generate code based on embedded software?

STM32CubeMX has a built-in knowledge of STM32 microcontrollers, including their
peripherals and software. This enables the tool to provide a graphical representation to the
user and generate *.h/*.c files based on user configuration.
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How to get regular updates on the latest STM32CubeF4 firmware releases?

The STM32CubeF4 firmware package comes with an updater utility, STM32CubeUpdater,
that can be configured for automatic or on-demand checks for new firmware package
updates (new releases or/and patches).

STM32CubeUpdater is integrated as well within the STM32CubeMX tool. When using this
tool for STM32F4 configuration and initialization C code generation, the user can benefit
from STM32CubeMX self-updates as well as STM32CubeF4 firmware package updates.

For more details, refer to Section 4.4.

3
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Table 4. Document revision history

Date

Revision

Changes

17-Feb-2014

1

Initial release.

25-Jun-2014

Added support for STM32F411xD/E part numbers.
Updated Section 1: STM32CubeF4 main features.
Added LibJPEG in Section 2: STM32CubeF4
architecture overview.

Updated Table 2: Evaluation and Discovery boards for
STM32F4 series, Table 3: Number of examples
available for each board, Figure 3: STM32CubeF4
firmware package structure.

Updated Section 4.2: How to develop your own
application and Section 4.3: Using STM32CubeMX for
generating the initialization C code.

10-Mar-2015

Updated Figure 1: STM32CubeF4 firmware

components.

Added support for STM32F446xx devices:

— Updated Table 1: Macros for STM32F4 series and
Table 2: Evaluation and Discovery boards for
STM32F4 series and Table 3: Number of examples
available for each board.

— Updated Section 5: FAQ.

19-May-2015

Added support for SW4STM32 toolchain.

21-Sep-2015

Added support for STM32F469xx STM32F410xx.

Updated Table 1: Macros for STM32F4 series and
Table 2: Evaluation and Discovery boards for STM32F4
series.

12-Nov-2015

Added support for STM32F411xE

Updated Table 1: Macros for STM32F4 series, Table 2:
Evaluation and Discovery boards for STM32F4 series
and Table 3: Number of examples available for each
board.
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IMPORTANT NOTICE — PLEASE READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST") reserve the right to make changes, corrections, enhancements, modifications, and
improvements to ST products and/or to this document at any time without notice. Purchasers should obtain the latest relevant information on
ST products before placing orders. ST products are sold pursuant to ST's terms and conditions of sale in place at the time of order
acknowledgement.

Purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or
the design of Purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.

Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

ST and the ST logo are trademarks of ST. All other product or service names are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2015 STMicroelectronics — All rights reserved
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