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IVTVision Enterprise Health Manager (IVTEHM) allows you to remotely monitor certain parameters and events on IVTVision Servers 
with Enterprise licenses. IVTEHM is a Client/Server application. The IVTEHM Server runs as a service on any computer with a network 
connection to the monitored IVTVision Servers and a database connection. The IVTEHM Client only requires connectivity to the 
database. IVTEHM can run as part of a multi-user platform connected to a MySQL or Microsoft SQL (MS SQL) database, or on a 
standalone Client/Server workstation using an SQLite database that is created by the IVTEHM Server. 
 

The following diagram shows how IVTEHM communicates with the database server and IVTVision systems. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
NOTE: In the Multi-User example, IVTEHM and the database can run on the same server. 
 
NOTE: In the Standalone example, IVTEHM, SQLite, and the IVTEHM Client must all run on the same workstation (even an 
IVTVision client computer). Clients from remote machines cannot connect to the SQLite database in the 
standalone installation. 
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The following drawing shows the approximate bandwidth used by the various IVTEHM connections. 

 

 

 

 

 
See http://www.inaxsys.com/en/products/ivtvision-software/ivtvision-enterprise-health-manager.html for a complete list of IVTVision 
Server and IVTEHM Server requirements. 
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NOTES: 
 IVTEHM Server can be installed on a Linux or Windows platform. 
 IVTEHM Client can be installed on a Linux, Windows, or Mac platform. 
 In Windows, the Client can be installed by itself or with the Server. 
 In Linux, the Client and Server must be installed separately. 
 If IVTEHM will connect to a new MySQL database, see Appendix A before starting the procedure in this section. 

 
To install Enterprise Health Monitor Server, complete the following steps: 

1. Run the IVTVisionHealthClientAndServer.exe file and follow the onscreen prompts. 
2. When the database types appear, select the type as follows: 

 MySQL (appropriate for most installations) 
 ODBC (select only if the database type is MS SQL) 
 SQLite (select if the IVTEHM client will be run only on the IVTEHM server) 

 
3. Configure the IVTEHM database connection to match your database. If IVTEHM and the database are located on the same 

server, enter 127.0.0.1 as the hostname, as shown in the following example. 
 

 
 

 
4. If IVTEHM will connect to an existing SQL server, select Write Schema File and provide the file to the database administrator 

for manual configuration. Otherwise, select the Update Database Schema During Installation to have the installation process 
take care of this for you. 
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By default, IVTEHM Client opens to the Active Events tab if the connection to the database is successful. Otherwise, 
you must select Open Database Connection from the File menu and select a database from the pop-up window: 
 

 

NOTE: The SQLite option is not available when running IVTEHM Client on a Mac platform. 

 
To close a connection with a database, select Close Database Connection from the File menu. To open a 
connection with a different database, select Open Database Connection from the File menu to open the Database 
Connection window. Then select the new database and click OK. 
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Tabs 
You can open the following tabs from the View menu: 

 Unacked Events. This tab shows all active events that have not been acked. 
 Active Events. This tab shows all monitored events that are still in progress or haven’t been resolved. This 

                   can include events that have been acknowledged (acked). 
 All Events. This tab shows all events regardless of whether they are active, inactive, acked, or unacked. 
 Systems. This tab shows a list of all monitored servers and their status. 
 Options. This tab allows you to modify EHM parameters. 

 

 
To close a tab, click on the X next to the tab’s title. You can open multiple tabs simultaneously. To view more than 
one tab at a time, click and drag a tab title to an empty part of the screen. You can then resize a tab as desired by 
clicking and dragging its borders. 
 
Each tab is described in greater detail the following sections. 
 
NOTE: Information on all IVTEHM tabs is displayed in columns. To add or remove a column from a tab, right-click any 
column title and select a column name (columns with check marks next to them are displayed in the tab). You can 
also re-sort entries by clicking a column title. 
 
Also, after the IVTEHM Client verifies that the IVTEHM Server is connected, the IVTEHM Server version number is displayed 
at the bottom of the IVTEHM Client window. 
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Adding Systems 
The first thing you should do when you run IVTEHM is add a server that you want to monitor. Open the Systems tab 
and select Add System from the Edit menu to display the System Information pop-up window. Enter a valid 
username as configured on the system, a password, the password again, the IP address of the system, and the port 
number through which the system communicates on the network. Click OK when finished. 
 

 
 
When you select a line on the Systems tab, the Edit menu also contains an Edit System and a Delete System menu 
item. You can use these to modify system information or remove a system from IVTEHM monitoring. 
 
The Systems tab contains the following columns: 

 
 System ID. This is a sequential number assigned to each server. The first system is 1, and each successive 

                   server is the next available number. If a system is deleted from the list, all systems maintain their original 
                   System ID. 

 Address. The IP address of each server (not the address of an IP camera). 
 Port. The port number through which the server communicates over the network. 
 Username. The account through which the user is logged in to the server. 
 Password. The password that the account used to log in to the server. 
 System Name. The name of the server as it is identified on the network. 
 Serial Number. The serial number of the system as assigned during manufacturing 
 Status. The current status of IVTEHM monitoring on the system. 
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Viewing and Managing Monitored Events 

By default, the Active Events, Unacked Events, and All Events tabs contain the following columns: 
 

 Event ID. This is a sequential number assigned to each event. The first event is 1, and each successive 
                   event is the next available number. 

 Event Start Time. This is the date and time of the start of the event. 
 Event Type. See the “Options Tab” section of this document to see the types of events that can be 

                   monitored. 
 Event Details. This shows the camera affected by the event or the name of an activated trigger. 
 Description. This is the server on which the event occurred. 

 
The ActiveEvents and All Events tabs also include the following columns: 

 
 Ack Timestamp. The time that the event was acked (if applicable). 
 Ack Name. The name of the person or account that acked the event. 
 Ack Comment. Any optional information about the ack. 

 

 

 

To ack an event, double-click its entry (or select Acknowledge Event from the Edit menu) to open the Acknowledge 
Event window. Enter an identification and comment about the ack, and then click OK. To modify an ack, double- 
click the event entry again (or select Edit Acknowledgement from the Edit menu) and modify the information in 
the pop-up window. To delete an ack, highlight its entry and select Delete Acknowledgement from the Edit menu. 

 

 

NOTE: Acking an event does NOT remove it from the Active Events list; it simply means that the event has been 
noted. The event is removed from the Active Events list only when it has an actual Event End Time. 
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The All Events tab also includes the following columns:  

 Event End Time. The date and time of the end of the event. 
 Address. The IP address of the server on which the event occurred. 
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Options Tab 

The Options tab allows you to modify IVTEHM parameters and select which event types IVTEHM monitors. The Options 
tab contains the following tabs: 
 

 Database. This tab allows you to configure the following options: 
 Database Change Poll Interval (Seconds). This determines how often IVTEHM checks the database 

                   for events. 
 Failed Database Op Retry Interval (Seconds). This determines how soon IVTEHM tries to reconnect 

                   to the database server when a connection to the server is lost. 
 

 

 Events. This tab allows you to choose whether to create a log entry or send an email notification for each 
                   of the following events: 

 
Option on Events tab Definition 
Device Failure A device has failed. 
Input Trigger Discrete input on a hybrid server (or IP camera with alarm input) activated. 
IP Camera Not Connected Network cannot connect to an IP camera. 
License Expiry Notices License expiration information. 
Motion Camera has detected motion. 
Server Connection Error Error when connecting to server. 
Soft Trigger Signal sent from Client to server. 
Storage Alarm Drive capacity threshold reached. 
Temperature Temperature threshold exceeded. 
Video Loss Analog video signal lost. 
Throttle Alarm Disk throughput threshold exceeded. 
Fan Alarm Fan has failed. 

 
Select the appropriate checkboxes for each event type. You can select one logging option, both logging options, or neither logging 
option for each event separately. The Events tab also allows you to configure events older than a certain number of days and configure 
how often those events are purged. 
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 Email. This tab allows you to configure the email notification feature. Enter the email server address, username, password, 

and timeout (in seconds). Also enter the information that will be included in the email, such as the name of the email’s 
sender, the email’s recipients, and the email’s subject line. Also select the maximum number of events that can be included 
in a single email and how often email notifications should be sent (in minutes). 

 
NOTE: A username and password are not required if authentication is not required on the mail server. 

NOTE: Notifications are sent for active events that have occurred since the most recent notification. Notifications are not sent for 
cleared events. 
 

 
 

 Logging. This tab allows you to configure the maximum number of days of event information to include in the log file, which 
is saved to the IVTEHM server and inaccessible from the IVTEHM Client. 
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An IVTEHM log file created on the server daily in \Program Files\IVTVision\Health\logs (default location) can help you determine the 
cause of various issues. Following are common issues that can be identified using the log file: 
 

Issue: IVTEHM Server does not start. 
Cause: Database connection error. 
Log file entry: “Failed to open DB.” 
Resolution: Contact the database administrator for information about database credentials. 

 
Issue: IVTEHM Client shows no data. 
Cause: IVTEHM Server unable to write event data to database. 
Log file entry: “Failed to update system status into DB” and “… server has gone away.” 
Resolution: Contact the database administrator for information about database credentials. 

 

The following issue can also appear in the IVTEHM Client: 
 
Issue: This message appears: “Enterprise Health Manager is not connected to this database. Please 

                   contact your system administrator.” The title bar of the IVTEHM Client also displays the message “Enterprise 
                   Health Manager Server is not connected.” 
                   Cause: In normal operation, the IVTEHM Server increments a heartbeat counter in the database. This 
                   message indicates the heartbeat counter is not changing. 
                   Resolution: Contact the database administrator to determine why the IVTEHM Server is not writing to the database. 
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If IVTEHM will connect to a new MySQL database, complete these steps before starting the procedure in the “Installation” section of 
this document: 
 

1. Download the most recent version of MySQL from www.mysql.com. 
2. Run the MySQL installer. This might require additional software upgrades to support MySQL on your 

                   server. 
3. On the Choosing a Setup Type screen, select Server Only or Full. (Do not select Client Only.) 

 

 

 

4. When prompted to select the type of configuration on the MySQL Server Configuration screen, select 
                   Server Machine. (Do not select Developer Machine.) 
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5. When prompted to specify the network, Windows, and security settings on the MySQL Server Configuration screen, take 
note of all the information that you enter because you will need it in the next step and during IVTEHM installation. 

 

 

6. After the MySQL installation is complete, create the IVTEHM database in MySQL. To do this, complete the following steps: 
a) Start the MySQL command line application. 
b) Enter “create database xxxxx ;,” where “xxxxx” is the Windows service name created in step 5. 

 

                   NOTE: A return of “Query OK, 1 row affected” indicates a successful database creation 

c) Type “exit” and press Enter to close the command line application. 
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7. By default, Windows Firewall blocks database access to remote users. Either disable Windows Firewall, or configure an 
exception for the SQL port. 

 

 

 

8. By default, MySQL does not grant user access to remote clients. Add each user account to MySQL as follows: 
 
a. Start the MySQL command line application. 

     b. Enter the following: 
 

grant all privileges on [dbname].* to [user]@’[IP address] identified by ‘[Password]’; 

 [dbname] is the database name created in step 5. 
 [user] is either the database username created in step 5, or the first of each username to be created. 
 [IP address] is the IP address of the user. If multiple IP addresses are possible (such as with DHCP), use the % wildcard 

symbol as shown here: 
 

 
 [Password] is the database password of the [user] account. 

 
NOTE: The special characters (dot-asterisk, apostrophes, and semicolon) are all required. If a “Query OK” message is not received 
after pressing Enter, the privilege was not added. 

 

9. Continue with the procedure in the “Installation” chapter of this document. 
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Creating a DSN 

In a Windows deployment where the database backend will be SQL server, the database connection will be via 
ODBC. Before installing either the Client or the Server on a computer, a data source name (DSN) must be created. 
This DSN is used to inform both IVTEHM Server (evHealthServer.exe) and IVTEHM Client (evClientServer.exe) where to 
find the database. Creating a DSN is done via Start->Settings->Control Panel->Administrative Tools->Data Sources 
(ODBC). If this computer will run the IVTEHM Server, ensure that the DSN created is a System DSN, not a User DSN. 
This is selected on the first tab of the ODBC Data Source Administrator dialog. 
 

Service Control Manager 

The Windows IVTEHM Server installer registers evHealthServer as a service. It sets the recovery operations to retry 
the service first and then reboot the system upon service failure. These recovery options can be edited using 
Windows Service Control Manager (Start->Run->services.msc). There is no dependency set against the SQL Server 
because it is possible that the SQL Server will be running on a different computer. Upon startup, the IVTEHM Server 
will continue trying to connect to the SQL Server periodically until it successful. 
 

IVTEHM Client Database Permissions 
The IVTEHM Client user must have database credentials giving permission for certain operations: 

 
For true read only access to the data, 
SELECT ON [healthdbname].* 
 
For the ability to acknowledge alarms 
SELECT, INSERT, UPDATE, DELETE ON [healthdbname].EVH_Acks 
 
For the ability to add/remove systems 
SELECT, INSERT, UPDATE, DELETE ON [healthdbname].EVH_Systems 
 
For the ability to change settings 
SELECT, INSERT, UPDATE, DELETE ON [healthdbname].EVH_Options 
 

If a user without sufficient permissions attempts an operation, a message box will be displayed containing the SQL 
error from the database. 
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Server Database Configuration 
The IVTEHM Server always reads evHealthServer.ini from its current directory. If the INI file is missing or invalid, the service defaults to 
a SQLite database evHealth.db in its immediate directory. The INI file is expected to contain the following: 
 

 Group "[DatabasePrefs]". 
 Required property "Engine" is "SQLite", "ODBC", or "MySQL". 
 Required property "Name" is the relative/full path to a SQLite database file, an OBDC DSN, or a MySQL schema name. 
 Property "Username" is ignored by SQLite, optional for ODBC, and required for MySQL. 
 Property "Password" is ignored by SQLite, optional for ODBC, and required for MySQL. 
 Property "Hostname" is ignored by SQLite and ODBC, and required for MySQL. 
 Property "Port" is ignored by SQLite and ODBC and optional for MySQL (the default MySQL port 3306 is hard-coded in 

the service). 
 
Client Database Configuration 
The IVTEHM Client must use the same database as the IVTEHM Server. The Client is pointed to that database in the 
following order: 

 
 Command Line parameters: 

     o /I, --ini=<str>INI file to use, defaults to “evHealthServer.ini” 
     o /s, --sqlite=<str> sqlite database to open, defaults to “evHealth.db” 
     o /m, --mysql=<str>mysql database to open, defaults to “evHealth” 
     o /o, --odbc=<str> odbc database to open, defaults to “evHealth” 
     o /u, --username=<str>username for database connection (not used for SQLite) 
     o /p, --password=<str>password for database connection (not used for SQLite) 
     o /a, --address=<str>mysql host address or name (not used for SQLite or ODBC) 
     o /t, --port=<str>mysql host port or name (not used for SQLite or ODBC) 

 evHealthServer.ini in the current directory with the same format specified for the IVTEHM Server. 
 Windows Registry entries in HKEY_CURRENT_USER\Software\evHealthClient. In Linux or MacOS, the /Conf or /Pref files are 

used. 
 An SQLite database called evHealth.db in the current directory. 
 Open blank and force the user to 'File | Open Database Connection'. 
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Server Command Line Parameters 
The Windows Server installer will invoke evHealthServer as appropriate to register the IVTEHM Server as a service and 
update database schema as necessary. A Linux IVTEHM Server installation must perform these operations manually. 
 

 evHealthServer /registerService /displayName="exacqVision Health Service" -- (Windows) Service recovery options are 
configured and sets the description. 

 evHealthServer /unregisterService -- (Windows) Unregister service and exit. 
 evHealthServer --daemon --pidfile=/var/run/whateveryouwant.pid -- (Linux) Run as daemon. 
 evHealthServer /updatedb (Windows), evHealthServer –updatedb -- (Linux) The database is validated at startup, and any 

necessary changes are attempted. If any change fails (for example, if the database user doesn't have change permissions), 
regardless of whether the field is *required* or *optional*, an error code (non-zero) is returned, and a short error message 
is returned on stdout. Otherwise, a success code (zero) is returned. 

 evHealthServer /writeschema=FILENAME (Windows), evHealthServer --writeschema=FILENAME -- (Linux). The database is 
validated at startup, and the SQL statements for any necessary changes are written to the specified file. 
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Installation 
To install MySQL in Linux, complete the following steps: 
 

1. Enter the following command in a Terminal prompt: 
 
sudo apt-get install mysql-server 
 
Alternatively, you can install mysql from Synaptic package manager. 

 
NOTE: During the installation process, you will be prompted to enter a password for the MySQL root user. 

 

2. After the installation is complete, MySQL server starts automatically. To verify that the server is started, enter the following: 
 
sudo netstat -tap | grep mysql 

 
This command should return something similar to this: 
 
tcp00 localhost:mysql*:* LISTEN2556/mysqld 
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Configuration 
To configure MySQL in Linux, complete the following steps: 

 

1. Log in to mysql issuing the following command in Terminal, followed by the root password: 
 

mysql -u root –p 

2. To create the database, enter the following: 
 

CREATE DATABASE exacqEVHM_1; 
 

3. To create user, enter the following: 
 

CREATE USER username; 

4. To select a password, enter the following: 
 

SET PASSWORD FOR username= PASSWORD("passwordgoeshere"); 
 

5. To grant the user all privileges over the database, enter the following: 
 

GRANT ALL PRIVILEGES ON exacqEVHM_1.* TO username IDENTIFIED BY "passwordgoeshere"; 
 

6. To open Gedit and modify my.cnf, enter the following: 
 

sudo gedit /etc/mysql/my.cnf 
 

7. To search for "Bind address" and comment out the line, enter the following: 
 

# bind-address=127.0.0.1 
 

8. Type exit to close Terminal. 
 


