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Foreword 

Appointment of 
This paper describes the software NEVOD, which graphical interface offers a range of 
opportunities to work with structured and unstructured data: description of the subject area of 
the problem to be solved, data entry, integration of data from various sources, the search report 
generation, building link diagrams. 

Paper can be used to work with any version of NEVOD. 

To whom it may concern 
The document is intended for users of all types: administrators and designers of databases, 
programmers and end users. 

The preliminary knowledge 
To work with NEVOD necessary to be able to work with the operating system at the level of an 
experienced user. 

Used notation 
Notation  Example  Meaning 
Italics  bitmap is a picture…  New term in the text 
Boldface font  You need save All  Marking text 
Underlined font  More details you can take on the 

site www.relex.ru. 
 URLs 

Strings separated by ⇒  Choose menu item 
View ⇒ Properties 

 Sequence of commands 

Strings in brackets < > separated 
by + 

 <Ctrl>+<C>  <Keyboard button name>  
symbol + orders to press 
buttons simultaneously 

Text on gray background marked 
by  

  To start input choose at first a 
document that is not pushed into 
DB. 

 Comments 

 

http://www.relex.ru/


 

2 NEVOD user manual                

NEVOD glossary 
Term Value 

Annotation Text (up to 60 symbols) that describes the object with some detail. The level of detail 
is usually chosen sufficient, in most cases, to distinguish objects without. Annotation 
(summary) built by concatenating the attribute values identified in schema as 
annotated. 

Attribute A property of an object. Every attribute have a type (data type). Attribute may have 
one value (single valued attribute) or lots of values (multivalued attribute). 

Audit Security control, independent examination of the system records and actions with aim 
to the check adequacy of NEVOD established policies and working procedures as 
well as to detect breaches in security and to make of recommendations how to change 
policies and procedures. 

Binary 
connection 

Link between two instances of objects that have different types. Type linked objects is 
chosen during input, not during schema building. 

Link diagram Visualization of semantic network as a graph of linked objects. 

Document Computer model of data source. Document contains an instance of integration object 
and lots of linked instances of simple objects that describe semantic of data source. 

Query Search process containing, in general, the desired tree of objects and attributes. For 
each node of the tree is set a tree of conditions. Conditions imposed upon the attribute 
values and united by logical operators AND, OR, NOT. 

Identification Search of similar objects. 

Integration 
object 

The object containing information about source of data: paper document, database 
input session, which is a part of the business, etc. 

Subject area  The knowledge area characterized by the concepts and terms understandable to those 
who work in this area. 

Identification 
mask 

A set of attributes, the match of which said the similarity of objects. 

Multigroup A group of attributes. It can not be selected by query, in other cases it behaves like 
object. 

Implicit link Chain of linked objects. 

Simple object Model of entity of the real world. 

Color of link Text (up to 30 symbols) that describes a semantic of link. 

Schema Result of modeling of the subject area – set of types of objects. 

Similar 
objects 

Objects modeling one entity with a high degree of probability. 

Data stage 
area 

Place of data before publishing. Data may be edited. After pushing into DB editing of 
data is forbidden. 

Semantic A semantic network is often used as a form of knowledge representation. It is a 
directed graph consisting of vertices (objects or multigroups in terms of NEVOD), 
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network which represent concepts, and edges (links in terms of NEVOD), which represent 
semantic relations between the concepts. 

Reference Direct link between two objects with specified type (type of linked object is defined 
by schema). 

Type of object Class. 
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NEVOD purpose 
NEVOD used for data input, storage and analysis. 

NEVOD, unlike transactional systems, is an analytic system designed to support decision-
making. 

NEVOD is Data warehouse. Bill Inmon (one of the earliest and most influential practitioners) 
defined a data warehouse as follows: Subject-oriented, Time-variant, Non-volatile, Integrated. 

NEVOD is designed to automate the operation of the security forces and other units of 
government and commercial organizations, whose functions include: 

• accumulation of information; 

• ad hoc querying; 

• reporting, including statistics; 

• visualization accumulated structured information. 

Examples of the organizations that could meet these functions and that should use NEVOD: 

• security departments of banks and other commercial structures; 

• structures of the Ministry of Internal Affairs; 

• municipalities, integrate information resources of the various agencies; 

• private detective agencies; 

• election campaign headquarters; 

• insurance companies; 

• real estate firms; 

• public employment services; 

• marketing departments; 

• personnel departments; 

• address, passport and other offices. 
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Environment 
NEVOD used on computers Intel architecture and the Microsoft Windows. 

NEVOD works in multiuser mode (client-server architecture). To use NEVOD in desktop mode 
you should setup server and client at one computer. 

For client side we recommend to use MS Windows 2000 or MS Windows XP.  

For server side we recommend to use MS Windows 2000, MS Windows 2003 Server or 
MS Windows XP. 

There are special versions that can use as a server: Linux (different versions and hardware 
platforms), Solaris (different versions and hardware platforms), Mac OS X, BSD (OpenBSD, 
FreeBSD, BSDI, NetBSD), UnixWare, IRIX, AIX, SINIX, QNX, USIX, VxWorks, OS-9, OS-
9000, OC2000, VMS. 

RDBMS LINTER is used at server side. 

There are special versions that can use as a RDBMS: Oracle, MS SQL Server and other 
widespread relational databases. 

In addition to NEVOD are available modules developed on order. 

In order to carry out most of the operations is required an operator with user level competence. 
To manage security and metadata required experienced user. 

One of the conditions of NEVOD is the lack of malicious software (viruses) on the computer 
with a NEVOD. 

You may not modify the schema and use Semantic Net Visualizer simultaneously. Please restart 
Semantic Net Visualizer after updating of schema. 

As data source you may use unstructured and structured text, multimedia files, dbf-files, XML, 
ODBC sources. 
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NEVOD architecture 

Short list of NEVOD facilities 
Schema describing 

All information is stored in the form of interconnected objects characterized by the attributes. 

Input 
Adding and editing information in the forms, customizable by user or administrator. 

Data integration 
The information available in the system from a variety of sources, compared with the already 
existing (the identification), and only new data is added to the already existing ones, and 
duplicate are removed. 

Search 
The visual editor helps to make (without programming) unplanned (ad hoc) queries with any 
complexity. At any given time previously saved query and snapshots may be viewed and 
executed. 

Reports 
Query results may be saved in file. View of this information is defined by edited form or XSL 
template. Statistical report is an electronic spreadsheet. 

Semantic network visualization 
Objects appear as rectangles. Relationship between objects and references appear as lines 
connecting rectangles. There are lots of opportunities to improve obviousness. 

Import/export of schema and data 
The schema and the data can be exported to XML and can be loaded from the file of the same 
format. Supported import data from other formats. 

Security 
Implemented as security access to data (up to the attributes), and security access to the modes 
of work. There is audit of work. NEVOD could be certified to practice the highest level of 
security. 
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NEVOD composition 
NEVOD consists of a server and client-side parts. Server is a database. Programs 
“Administrator” and “Semantic Net Visualizer” are used as clients. 

“Administrator” is used to define schema, to manage event log, user log, dictionaries, masks of 
identification. 

“Semantic Net Visualizer” applied to the input of data, design and implementation of search 
requests, generating reports (including statistics) and the analysis diagrams links, export and 
import data, search for similar objects and merging them object. 

The client can be run as a separate computer, and on the same computer, which runs server 
side. 

The typical way of interaction “Administrator” and “Semantic Net Visualizer” and DB 
represented at Fig. 1. 

 

Рабочие станции 
Рабочие станции 

Server 

DB 

Administrator 

Workstations 

Semantic Net 
Visualizer 

 
Fig. 1. Interaction of NEVOD parts 

 Launch Administrator and Semantic Net Visualizer only sequentially. 

Model of data representation 
Data represented to user as linked objects and their attributes. 

Objects are models of entities of the real world. Attributes are properties of these objects. Links 
are relationships between these objects. 

For example, to input data about Ivan Ivanov it is necessary create type of objects PERSON 
and fill out fields FIRST NAME = Ivan, LAST NAME = Ivanov. He may be married to 
Svetlana Ivanova. It can be reflected by creation of one more instance of PERSON and by 
creation of binary link MARRIED COUPLE. 

Links in NEVOD may be directed and bidirected. For example, MARRIED COUPLE is 
bidirected, but VATHER is directed. 
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Links are established between objects of any type. If you want to define type of linked object 
during schema building, you have to add an attribute that is reference to object with required 
type. 

Model of data storage 
Information about each object type (all instances) is stored in the table with a name beginning 
with the letter “O”. After “O” in the name follows unique identifier (ID). Primary key tables 
types of objects called OBJ_EL_ID. 

Attribute values stored in tables with the name beginning with “ATR_”. The title is a unique ID 
attribute. Primary key tables attributes called VAL_EL_ID. Field OG_EL_ID points to an 
instance of the object to which this attribute belongs (at the primary key in the table “O”). The 
value is stored in a field, the title of which starts with “VALUE_” and ends ID attribute. If a 
single attribute is created, the table “ATR_” not created, and the “VALUE_” added to the table 
“O”. 

Provided herein model data storage need to know if you need to configure the NEVOD to use 
other, the existing database. Sometimes it is necessary to create views with described above 
structure. 

Methodology implemented in NEVOD 
To input data enter in NEVOD you have to formalize information, that is, extract entities, their 
properties, their relations (links). In some attributes permitted to store unstructured information. 

The methodology using NEVOD is that it is impossible to enter data without reference to data 
source. Source can be a paper document, a database input session, which is part of the business. 
Each such source organizes a NEVOD document. 

Properties of source should be input into a special object called integration object. All other 
objects being in a paper called simple. 

In one NEVOD document can be created only one integration object. 
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Installation/uninstallation of NEVOD 

Structure of the distribution 
NEVOD software is a set of files, one of which is executable file Setup.exe.  

The distribution includes the server and the client parts of NEVOD, and the test case (a 
demonstration). Demonstration base contains a collection of objects and attributes required by 
the credit manager. 

Order of installation 
To install NEVOD from the distribution (on a server or client computer), you have to run 
Setup.exe. This will open window “Installation NEVOD” and the wizard will display the 
license agreement. To continue the installation, you must accept the license agreement. To 
confirm the license agreement please push Yes button. 

If the license agreement accepted, it is necessary to: 

1.  Select catalogue, which will be NEVOD installed, and click Next. 
2.  In case of installation on server side, choose “Full installation” (on the computer will be 

installed all modules NEVOD, modules LINTER and demonstration base) and click Next. 
3.  In case of multiuser mode, when on the server side “Full installation” comleted, and 

installation of client side is required, choose “Client installation” and click Next. 
4.  Enter name of program group (by default NEVOD 3.7) and click Next. 
5.  Click please Finish after installation process completion. 

There are 3 labels in the folder NEVOD 3.7: «Administrator», «Semantic Net Visualizer», 
«Manual» (Fig. 2). 

 
Fig. 2. Composition of the NEVOD folder after installation 

Order of deinstallation 
To install NEVOD run please Setup.exe included into the distribution. 
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Use of «Administrator» 

Launching 
To start “Administrator” click please label “Administrator”. 

The first time after NEVOD installation required input of User Name, Company Name and 
Serial Key (Fig. 3). 

These data are provided by NEVOD passport that came with NEVOD distribution and license 
agreement. To use a trial version NEVOD necessary data can be found in the file serial.txt 
located in a directory which was NEVOD installed. 

 Input of serial key is required after some configuration changes too. 

 
Fig. 3. Input of serial key 

User registration 
“Administrator” can be used only by: 
• administrator of DB with name SYSTEM; 

• administrator of NEVOD with name NEVOD. 

To start working the user must go through a process of identification and authentication 
(Fig. 4). 
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Fig. 4. Window of the user identification 

If DB choice is not required (DB is chosen) it is necessary: 

1.  Enter user name (SYSTEM or NEVOD) in the text field Name. 
2.  Enter password of corresponding in the text field Password. 
3.  Click OK. 

 Characters in Name and Password fields converted to upper case automatically. 

 In demo DB user NEVOD has empty password and user SYSTEM has password MANAGER. 

DB choice 
After installation the DB DEMO is chosen by default. If other DB required please do 
following: 

1.  Click Extended. 
2.  Choose required DB from list box (Fig. 5). 

 
Fig. 5. Window of DB choice 

If required DB is absent in the list, it is necessary to add it. For that please do following: 

1.  Click Add DB. 
2.  In opened window (Fig. 6) enter alias of DB in the text field DB name. 
3.  Enter port number in the teat field Port. 
4.  If DB located at the current computer (Local DB), please enter path to existed DB files or 

to DB files that will be created if select Create new DB. 
5.  If DB remoted (Remote DB), please enter network address of the computer with remoted 

DB. 
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6.  Click ОК. 

 
Fig. 6. Window of DB addition 

As you can see at Fig. 5, DB can be Started. To stop it click Stop DB. After that DB status will 
be changed to Stopped, and button name will be Start DB. 

To delete DB from list of available DBs please click Exclude DB. This button does not delete 
DB files. 

DB configuration may be corrected by DB properties click. 

 Before the new database creation make sure that the directory, which chosen for new DB files, is empty.  

 New DB has users: SYSTEM with password MANAGER and NEVOD with empty password. Please 
change this passwords during the first run. 

 If “Administrator” launched remotely from DB, it can not to stop DB. 

View of schema  
By default after “Administrator” launching the mode is View of schema. 

Schema is a set of object types with attributes (Fig. 7). 
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Fig. 7. Window of the Schema view 

Object types in “Administrator” are shortly called objects (Fig. 7), but instances of these 
objects should be created by “Semantic Network Visualizer” during of input. Integration 
objects are presented by icon , simple objects are presented by icon . 

Single valued attributes are presented by , multivalued attributes are presented by . If an 
attribute is included into annotation it becomes blue icon, for example: . 

Window of Schema view contains nodes: Objects, Domains, Multigroups, Dictionary 
objects, System objects. 

Node Domains contains created data types.  

Node Multigroups contains special objects that are groups of attributes. 

Node Dictionary objects о contains created dictionaries. 

Addition of object or miltigroup 
To create a new object or multigroup please do following: 

1.  Select any object in object tree or any multigroup in multigroup tree. 
2.  Choose menu item Edit ⇒ Add object or click icon Add object  on toolbar or choose 

context menu item Add object. 
3.  In opened window (Fig. 8) enter name of object or multigroup in the text field Name. 
4.  If case of object creation (not multigroup) it is necessary to select Integration object or 

Simple object (accounting object) will be created. 
5.  Click ОК. 
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Fig. 8. Window of object addition 

 Names of objects and multigroups must be uniques. 

Addition of attribute 
To create a new attribute please do following: 

1.  Select necessary object in object tree (new attrribute will be created at end of attribute list) 
or select necessary attribute (new attribute will be created after selected attribute). 

2.  Choose menu item Edit ⇒ Add attribute or click icon Add attribute  on toolbar or choose 
context menu item Add attribute. 

3.  In opened window (Fig. 9) enter name of attribute in the text field Name. 
4.  Set necessary check boxes: Annotation trigger (value of attribute will be included into the 

annotation of object), Not null attribute (form focus change will be forbidden while value not 
be entered), Multivalued attribute (it will be possible to enter some values). 

5.  Set data type: text (up to 512 characters), multigroup (reference to a group of attributes), 
reference (to an object), dictioonary (text, selectable from directory), integer (long), real, 
fixed point, date, time, multimedia (blob). 

6.  Set properties of data type (necessary for some data types) by button  and/or field 
Numeral (symbol). 

7.  Click ОК. 
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Fig. 9. Window of attribute addition 

A context menu item Select reference dictionary is available when dictionary attribute created. 
This command allows select an attribute which value (during input) will be used to define a 
node to show in a hierarchic dictionary. For example, with this option you may have in street 
list only Voronezh (Russia) streets when attribute CITY have the value VORONEZH.  

 You may order attributes by drag&drop operation. 

 Names of attributes must be uniques in of object bounds. 

Multimedia adjustment 
Each multimedia attribute can contain values with different formats. Depending on the format 
of the multimedia attribute (in practice there are dozens of photo formats) you may use 
different program to view and to edit value of this attribute. The program should support a 
command line parameter that means name of the file with saved value. 

To start multimedia adjustment choose menu item Tools ⇒ Media types configuration or click 
icon Media types . The following window Fig. 10 will be opened. 
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Fig. 10. Window of multimedia data type list 

To change a rule for determinate format type please do following: 

1.  Select necessary string. 
2.  Click Change. 
3.  Edit fields in opened window Fig. 11 (symbol $ determines a place of file name). 
4.  Click ОК. 

 
Fig. 11. Window of multimedia data type adjustment 

To delete a rule for determinate format type please do following: 

1.  Select necessary string. 
2.  Click Delete. 
3.  Confirm deletion of selected rule. 

To add a rule for determinate format type please do following: 

1.  Click Add. 
2.  Filled out fields in opened window (Fig. 11). 
3.  Click ОК. 

To finish multimedia adjustments please click OK in window of multimedia data type list. 
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Adjustment of identification masks 
Users of “Semantic Net Visualizer” are able to search similar objects (identification) and merge 
them. Objects are similar if they have the same values of certain attributes (masked). 

To adjust identification masks chose menu item Tools ⇒ Identification mask or click icon 
Identification mask . The following window Fig. 12 will be opened. 

You may define some sets masked attributes for every object. To switch them use menu items 
Edit ⇒ Right / Edit ⇒ Left or by button  /  clicks. 

To include an attribute to the list of masked attributes please do following: 

1.  Select necessary attribute in the tree of objects. 
2.  Chose a menu item Edit ⇒ Mask or click icon . 

To finish editing identification masks chose menu item File ⇒ Exit or click icon Exit  

 
Fig. 12. Window of adjustment of identification masks 

Work with dictionaries 
To start to work with dictionaries please choose menu item Tools ⇒ Dictionaries or click icon 
Dictionaries . The following window Fig. 13 will be opened. 
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Fig. 13. Window of dictionary list 

In this window some options are available: Extendible (users may add new values),  Fixed (list 
of values may be changed only by “Administrator”), Confirm deletion и Confirm addition. 

To edit list of values please click Edit. The following window Fig. 14 will be opened. 



Use of  “Administrator” 

NEVOD user manual 19 

 
Fig. 14. Window of dictionary value list 

To switch the mode of view use icons: 

Icon  Action 

  Show linear list of values 
  Show as a tree of synonyms 
  Show in the form of a tree that reflects the hierarchical structure of the dictionary 

All values in the dictionary are sorted alphabetically. 

Field Value is to lookup. Input of every new symbol in this field results selecting the first value 
starting at the inputted set of characters. 

To change a dictionary value please do following: 

1.  Select necessary value. 
2.  Click Change. 
3.  Change the value. 
4.  Click Change or <Enter>. 

To delete a dictionary value please do following: 

1.  Select necessary value. 
2.  Click Delete. 
3.  Confirm a deletion of selected value. 

To add a dictionary value please do following: 

1.  Input new value. 
2.  Click Add. 
3.  Confirm an addition of value. 

Only hierarchical view allows to create two similar dictionary values. In this case similar 
values should be placed under different nodes. Node is a dictionary value that have a child.  
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To create a child drag&drop a value to other one. Every child element you may return to first 
level by context menu item Basic. value. 

To create nodes in hierarchical dictionary you may copy values from other dictionary by button 
Copy reference dictionary (this button is available only in «Semantic Net Visualizer»). 

To finish work with dictionaries click Exit in window showed at Fig. 13. 

Work with several schemas 
Different departments of one company may work with different subject areas that can be 
overlapped. 

A window showed at Fig. 7 have list of objects. This list may be split. Every part is named.  

To edit schemas please choose menu item Tools ⇒ Schema editor or click icon Schema editor 
. The following window Fig. 15 will be opened. 

Fig. 15. Window of editor of schemas 

To create a new named subschema please do following: 

1.  Click New. 
2.  Enter name of subschema in opened window. 
3.  Click ОК. 

To rename or delete subschema use Rename and Delete correspondingly. 

At first time when a new subschema is created it is empty. To add objects and multigroups 
replace them from pane Available to pane Included entities (Fig. 15). 
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To replace objects and multigroups use following icons: 

Icon  Action 
 or   Replace one selected element 

 or   Replace all elements from one pane to other 
 or   Replace one selected element with all dependences 

 User who have an empty subschema could not input data. 
 

User management 
To start manage users please choose menu item Tools ⇒ Users or click icon Users . The 
following window Fig. 16 will be opened. 

 
Fig. 16. Window of user management 

To open user editor double click on necessary user (Fig. 17). 
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Fig. 17. User editor 

System name is login. Full name is showed name. 

User with administrator level has access to all data. User with user level has access only to his 
data and to shared data. 

To set access to alien data choose please Open access to data of… at window Fig. 16. 

At window Fig. 16 you may limit access to some objects or attributes (double click on 
necessary object or attribute under node «Access to objects» Fig. 18). 
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Fig. 18. Access to objects 

Click  to exit Fig. 16. 

 Information about NEVOD is read only. 

 Information about SYSTEM is absent in user list. 

 To change password of user NEVOD please choose menu item 
Access ⇒ Change system admin. password. 

 To change password of user SYSTEM please choose menu item 
Access ⇒ Change DB admin. password (you have to be logged as SYSTEM). 

Work with event log 
To start work with event log please choose menu item Tools ⇒ View audit or click icon 
Audit . The following window Fig. 19 will be opened. 
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Fig. 19. Window of work with audit 

To finish work with audit click . 

Audit options 
To start view and manage audit rules please choose menu item File ⇒ Audit settings or click 
icon Audit settings  (Fig. 20). 

Fig. 20. Window of view and management of audit rules 

To add a new rule please do following: 

1.  Choose menu item Tools ⇒ Add string or click icon . 
2.  Set properties in string added to the end of rules list. 

To delete a rule please do following: 

1.  Select necessary string. 
2.  Choose menu item Tools ⇒ Delete string or click icon . 

Event log 
To start view of event log please choose menu item File ⇒ Audit view or click icon Audit view 

 (Fig. 21). 
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Fig. 21. Window of event log view 

To save registered events into file please do following: 

1.  Choose menu item File ⇒ Save or click icon Save . 
2.  Enter file name. 
3.  Click Save. 

To print registered events please do following: 

1.  Choose menu item File ⇒ Print or click icon Print . 
2.  Set print options. 
3.  Click ОК. 

To filter out registered events please do following: 

1.  Choose menu item Edit ⇒ Filter or click icon Filter . 
2.  Set filter options. 
3.  Click ОК. 

Monitoring 
To start monitoring (viewing of connected user list) please choose menu item 
File ⇒ Worked users or click icon Active users  (Fig. 22). 

Fig. 22. Window of list of active users 

To interrupt work of user please do following: 

1.  Select a user who must be disconnected. 
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2.  Choose menu item Tools ⇒ Stop user or click icon Stop . 
3.  Confirm disconnection. 

Export of schema 
To export of schema please do following: 

1.  Choose menu item Tools ⇒ Save schema to file or click icon Save schema to file . 
2.  Enter file name. 
3.  Click Save. 
4.  Set export options (Fig. 23). 
5.  Click ОК. 

 
Fig. 23. Window of schema export options 

 Schema saved in XML format. 

Import of schema 
To import of schema please do following: 

1.  Choose menu item Tools ⇒ Load schema from file or click icon 
Load schema from file . 

2.  Enter file name. 
3.  Click Open. 

Schema export file format 
Schema export file has following characteristics: 

• format: XML; 

• encoding: UTF-8; 

• file extension: .xml; 

• default name: SubjArea. 

Programs for schema export file processing: 

• view: Internet browser; 

• edit: text editor, supported UTF-8. 

File begins with description: 
<?xml version="1.0" encoding='UTF-8'?> 
<!DOCTYPE schema [ 
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<!ELEMENT schema (object|domen|dictionary|link-pair|media-types|mask)*> 
<!ATTLIST schema 
  xml-document    CDATA    #REQUIRED 
  version         CDATA    #REQUIRED 
> 
<!ELEMENT object (attribute)*> 
<!ATTLIST object 
  type            (simple|multigroup|integration|link|dict)    #REQUIRED 
  name            CDATA    #REQUIRED 
  properties      CDATA    #REQUIRED 
  owner           CDATA    #REQUIRED 
  table           CDATA    #REQUIRED 
  column_id       CDATA    #REQUIRED 
  xml-element     CDATA    #REQUIRED 
>... 

Then comes the content, which begins with a description of objects and their attributes: 
<schema xml-document="nevod-profile" version="2"> 
    <object name="ACCOUNTING INFORMATION" type="integration" 
properties="0x00000000" owner="NEVOD" table="O1021" column_id="OBJ_EL_ID" xml-
element="uchetnaya_informaciya1647"> 
    <attribute name="$ANNOTATION" type="char" properties="0x00010080" length="60" 
order="1" owner="NEVOD" table="O1021" column="PSEUDO" column_id="OBJ_EL_ID" 
column_parent="OBJ_EL_ID" xml-element="_annotation1648" /> 
    <attribute name="SUBJECT" type="dict" properties="0x00100014" length="100" 
order="2" ref_object="dictionary-tema1650" owner="NEVOD" table="ATR_1107" 
column="VALUE_1107" column_id="VAL_EL_ID" column_parent="OG_EL_ID" xml-
element="tema1657" /> 
... 

Next is a description of: 

• dictionaries: 
    <object name="DICTIONARY-BRANCH" type="dict" properties="0x00000000" 
owner="NEVOD" table="D1050" column_id="DIC_EL_ID" xml-element="dictionary-
otraslevaya_prinadlezh1381"> 
    <attribute name="VALUE" type="char" properties="0x00010080" length="100" 
order="1" owner="NEVOD" table="D1050" column="VALUE" column_id="DIC_EL_ID"  
column_parent="DIC_EL_ID" xml-element="value1382" />... 
 

• system objects (ATTRIBUTES, DOCUMENTS, DOMENS, OBJECTS, USERS): 
    <object name="ATTRIBUTES" type="simple" properties="0x00000002" owner="NEVOD" 
table="DB_ATTRIBUTE" column_id="ID" xml-element="sys-attribute"> 
    <attribute name="ID" type="integer" properties="0x000000C0" length="0" 
order="1" owner="NEVOD" table="DB_ATTRIBUTE" column="ID" column_id="ID" 
column_parent="ID" xml-element="id" />... 
 

• domains: 
    <domen name="BRANCH" type="dict" length="100" ref_object="dictionary-
otraslevaya_prinadlezh1381" owner="NEVOD" table="V1050" column_attr="ATR_ID" 
column_parent="OG_EL_ID" column_value="VALUE" column_id="VAL_EL_ID" xml-
element="DOM0008001050" /> 
 

• multimedia settings: 
    <media-types> 
     <mediatype id ="1" name="UNICODE Text" inpstr="notepad.exe $" 
outstr="notepad.exe $" extn="TXT" mime="text/plain" /> 
     <mediatype id ="2" name="Photo"   extn="JPG" mime="image/jpeg" /> 
     <mediatype id ="3" name="RTF Text" inpstr="wordpad.exe $" outstr="wordpad.exe 
$" extn="RTF" mime="text/rtf" /> 
     <mediatype id ="4" name="Р¤Р°Р№Р» .pdf" inpstr="AcroRd32.exe $" 
outstr="AcroRd32.exe $" extn="PDF" mime="" /> 
    </media-types> 
 

• dictionary values: 
    <dictionary obj_parent="dictionary-otraslevaya_prinadlezh1381"> 
    <dict-value value="AGRICULTURE" dic_el_id="1" dic_mn_id="1" id="2" 
parent_id="2" max_child_id="2" /> 
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   <dict-value value="LIGHT AND FOOD INDUSTRY" dic_el_id="2" dic_mn_id="2" id="3" 
parent_id="3" max_child_id="3" /> 
   <dict-value value="HEALTH, EDUCATION" dic_el_id="3" dic_mn_id="3" id="4" 
parent_id="4" max_child_id="4" /> 
   <dict-value value="WHOLESALE" dic_el_id="4" dic_mn_id="4" id="5" parent_id="5" 
max_child_id="5" /> 
   </dictionary> 
 

• links: 
  <link-pair> 
  <link object1 ="adres1023" object2="uchetnaya_informaciya1647" lnk_el_id="1" /> 
  <link object1 ="fizicheskoe_lico1033" object2="uchetnaya_informaciya1647" 
lnk_el_id="1" />... 
 

• masks: 
    <mask object="fizicheskoe_lico1033"> 
        <mask_attribute id="data_rozhdeniya1173" /> 
        <mask_attribute id="familiya1518" /> 
        <mask_attribute id="imya1519" /> 
        <mask_attribute id="otchestvo1520" /> 
        <mask_attribute id="region_rozhdeniya1257" /> 
    </mask> 

Deletion of objects and attributes 
Deletion of objects (types of objects) and attributes is available only for empty them. 

If object or attribute is not empty (there is an instance) the following message will be showed: 
«Attribute is used. Can not delete this attribute». 

To delete an object or attribute please do following: 

1.  Select necessary object or attribute in object tree. 
2.  Choose menu item Edit ⇒ Delete or choose context menu item Delete or click icon 

Delete . 
3.  Confirm deletion. 

Edition of objects and attributes 
Some of properties of objects and attributes can be edited even after their instance creation. If a 
property is read only, you should delete corresponding object or attribute and create it with 
required properties. 

Edition of object and attribute names 
To edit name of object or attribute please do following: 

1.  Select necessary object or attribute in the object tree. 
2.  Choose menu item Edit ⇒ Rename or choose context menu item Rename or click icon 

Rename . 
3.  Edit name of object or attribute in opened window (Fig. 24). 
4.  Click ОК. 
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Fig. 24. Window of object renaming 

 

Edition of XML tags 
XML-tag names, for example, region_rozhdeniya1257, are generated automatically, but may be 
edited manually.  

To edit names of XML tags please do following: 

1.  Select necessary object or attribute in the object tree. 
2.  Choose menu item Edit ⇒ Properties or choose context menu item Properties or click icon 

Properties . 
3.  Switch a pane Extended in opened window (Fig. 25). 
4.  Edit Value of XML_ELEMENT. 
5.  Click ОК. 

 
Fig. 25. Window of edition of XML tag names 

Edition of annotation structure 
Length of annotation is 30 symbols. 

To toggle annotation flag for attribute please do following: 

1.  Select necessary attribute in the object tree. 
2.  Choose menu item Edit ⇒ Annotation or choose context menu item Annotation or click 

icon Annotation . 
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Work with system dictionary 
System dictionary is set of metadata. 

It is necessary to update system dictionary when a new version of NEVOD is used. 

To recreate the system dictionary please do following: 

1.  Choose menu item Tools ⇒ Recreate dictionary or click icon Recreate dictionary . 
2.  Set options in opened window. 
3.  Click ОК. 

Configuring fonts 
To change used by “Administrator” fonts please do following: 

1.  Choose menu item Файл ⇒ Шрифт. 

2.  Select fonts by  button in opened window. 
3.  Click ОК. 

Data correctness check 
To check and restore database integrity please do following: 

1.  Choose menu item Tools ⇒ Data correctness check. 
2.  Set options in opened window (Fig. 26). 
3.  Click ОК to start. 
4.  After finish of process click ОК. 
5.  View report file if this option was activated. 
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Fig. 26. Window of data correctness check 
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Use of «Semantic Net Visualazer» 

Launching 
To start “Semantic Net Visualizer” click please label “Semantic Net Visualizer”. 

User registration 
“Semantic Net Visualizer” can be used by any user registered by “Administrator”. 

User registration is equal to user registration for “Administrator”. 

DB choice 
DB choice is equal to DB choice for “Administrator”. 

Main window 
When is the user login in the main screen. 

A main window is shown to user after registration. 

The main window is a window with set of buttons (Fig. 27): Input, Queries, Documents 
Statistics, Diagrams, Exit. 
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Fig. 27. Main window 

Input 
There are two ways to input. 

Input for beginners 
To start input please do following: 

1.  Click Input at the main window. 
2.  In opened window (Fig. 28) select integration object. 
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Fig. 28. List of integration objects 

3.  Click Type in or double click on selected integration object (demobase contains only one 
integration object). 

4.  Input data in opened input form (Fig. 29). 

Fig. 29. Input of integration object 

5.  Click icon Object list  or choose menu item Form ⇒ Object list or push <Alt>+<X>. 
6.  In opened window (Fig. 30) select an object required to input. 
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Fig. 30. Object list 

7.  Click Type in or double click on selected object. 
8.  Input data in opened input form (Fig. 31). 

Fig. 31. Input of object 

9.  Return to the list of objects, for that close input form or click on icon Object list  or 
choose menu item Form ⇒ Object list or push <Alt>+<X> (Fig. 32). 
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Fig. 32. Return to the list of objects 

10.  Repeat steps 7. 8. 9.  necessary tymes to input required objects. 
11.  Choose menu item Document ⇒ Push document to DB or click on icon 

Push current document to DB . 
12.  Return to the main window. 

Input for advanced users 
Advanced users may input data into input forms. To open input form click on: 

• saved form (pane Resources at System Bar); 
• object (pane Schema at System Bar). 

The current Document should be not pushed into DB, it should be places in data stage area. To 
choose a current document select it in combo-box at Document Bar. 

In current document you may: 

• input data addition to placed in DB data; 

• set binary links. 

To input additional data please do following: 

1.  Select an object by query. 
2.  Input necessary values in requred attributes. 

Edition of pushed in DB objects is forbidden. So if you have an additional data, input it as new 
value. 

To set a link between two objects (Object1 and Object2) please do following: 

1.  Open form with Object1. 
2.  Open form with Object2 (it may be the same form). 
3.  Set focus at Object1 (click on Object1). 
4.  Click icon Set first joint object . 



Use of «Semantic Net Visualazer» 

NEVOD user manual 37 

5.  Set focus at Object2 (click on Object2). 
6.  In opened window (Fig. 33) select type of link for creation (by default bidirectional link is 

set) and click Add Color. 

 
Fig. 33. Window of set of links 

7.  In opened dictionary LINK COLOR select necessary value and click ОК. 
8.  Repeat steps 6. 7.  necessary times to set required links. 
9.  Close window of set of links by click on Close. 

There are other ways to set links: 

• by buttons INCOMING LINKS and OUTGOING LINKS at the input form; 

• by node New link in tree of links (it place left of the input form). 

Work with input/output forms 
Every input form may be used as output form. 

Objects, references on objects, multigroups, multimedia attributes, links are presented at input 
form as buttons. A such button have a caption with annotation. Attributes are presented as text 
fields. In some cases these fields may be read only (for example, not set current document 
placed in data stage area; data are inputted in document placed in DB, etc.). 

To navigate instances of objects, attributes and links please do following: 

• click ; 

• click <Page Up> or <Page Down>; 

• open list of values by <F4>; 

• use navigator . 

To input a current date click <F11>. 

To input reference on inputted object click <Ins> or <Ctrl>+<Ins> (it depends on place of 
object: in DB or in Data stage area). 

Input form has some modes: 

• Input mode ; 

• View mode ; 

• Update mode ; 

• Form based query mode . 

For every mode is available Form edit mode . 
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In form edit mode you may edit form elements (add, delete, change design) by items of context 
menu. 

To save changed form please click Save . 

Query building and execution 
To create and execute a question please do following: 

1.  Click Query at the main window. 
2.  In opened window (Fig. 34) click New query. 

 
Fig. 34. List of saved queries 

3.  In opened window (Fig. 35) enter query mane (up to 40 symbols) and click ОК. An empty 
query will be created with typed name. 

 
Fig. 35. Window of input of query name 

4.  In opened window (Fig. 36) build query according Query tree building and Condition tree 
building. 
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Fig. 36. Window of query builder 

5.  Execute built query by choose menu item Query ⇒ Execute query or click on icon Find 
. 

Query tree building 
Query builder includes two areas: tree of query and tree of conditions (under query tree). As 
you open query builder, System Bar  with pane Schema is opened automatically. 

To build a query tree (Fig. 37) please do following: 

1.  Drag target objects from schema and drop them at the query tree area. To select linked 
objects you should drop object at necessary node in the query tree. 

2.  Drag attributes that should be showed from the schema and drop them to the query tree. If 
you need all attributes please do not drag&drop any attribute. 
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Fig. 37. Query tree building 

For example, a query tree built at Fig. 37 selects every person with not empty name and only 
following attributes will be showed: LAST NAME, FIRST NAME, VIN of car and MODEL of 
car. The attribute AUTOMOBILE may be empty in the result of execution of this query. 

As you see above attributes in query tree may be interpreted as conditions. If you want to select 
objects with not empty attribute you may use such visual link:  (it used by default). If you do 
not want to make restrictions you may change visual link to  by choosing context menu item 
Inner join. 

 A result of query execution strongly correspond to query tree. So be careful during query tree building. 
If you are not advanced user please use  or do not drag&drop any attributes (select all attributes). 

Condition tree building 
For every node of query tree you may set a condition tree. This condition tree includes 
elementary conditions as nodes. 

To create an elementary condition please do following: 

1.  Select necessary node in the query tree. 
2.  In schema tree select attribute of selected object. 
3.  Drag selected attribut to the area of condition tree. 
4.  In opened window (Fig. 38) select required type of condition. 
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Fig. 38. List of types of condition 

5.  Select appropriate variant (Fig. 39) and input value(s): 

Fig. 39. Input of condition 

• Value. Input value manually or select it from dictionary: ; 

• Parameter. Input name of parameter (the value of this parameter will be asked at the 
execution time) or select it from list: Parameter List; 

• List. Input value in the text field Value and add it into the list: <-Add; 

• Attribute. Select attribute of the same object: Select. 

The condition type «…BETWEEN…» requires input values twice (these values are boundaries 
of the interval). 

The condition type «…IS A…» allows set dictionary node as value. In this case you may select 
all dictionary values under selected dictionary node. 

The condition type «…TEMPLATE…» allows set a template for the operator LIKE (for users 
who know SQL). 
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To build a condition tree you may create elementary conditions and bind them by logical 
operators AND, OR, NOT using a context menu. 

If you make a condition tree for an object (an object selected in the query tree), it restricts 
object selection. If you make a condition for an attribute (an attribute selected in the query 
tree), it restricts only representation of the query execution result (all instances of object will be 
selected according to a condition tree for this object). 

Be careful during condition tree building, watch at target place when drag&drop is used. For 
example, Fig. 40 shows two queries. In the left query STREET was dropped at ACTUAL 
RESIDENCE. In the right one STREET was dropped at previously added operator AND. 

  
Fig. 40. Differences in binding by AND 

In this example the left query is executed faster, but the result is the same: every person resides 
in Voronezh in the Lenin street. Furthermore, when you build query according to the right type, 
it is easier to make mistake and get result that you do not expect. 

Search for implicit links 
To search for implicit links between objects please do following: 

1.  Drag&Drop Object1 to the query tree area and build a condition tree if it is necessary. 
2.  Drag&Drop Object2 at Object1 and build a condition tree if it is necessary. 
3.  In context menu for  schoose item Implicit link ( ). 
4.  Execute built query. 

At Fig. 41 is shown the query selects implicit links between Petrov and Fedorov. 
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Fig. 41. Example of query with search for implicit links 

At Fig. 42 is shown the result of execution of this query. Despite the fact that demonstration 
base contains only one Petrov and one Fedorov, field <#1#> NATURAL PERSON contains lots 
of Fedorovs. It means that there are lots of chains of links between Petrov and Fedorov. Objects 
of every chain are presented in field CHAIN. 

Fig. 42. Result of search for implicit links 

To present chains clearly use please link diagram. 

 Implicit links includes links and references. 

Search for linked objects with defined color of link 
To search for linked objects with defined color of link please do following: 

1.  Drag&Drop Object1 to the query tree area and build a condition tree if it is necessary. 
2.  Expand in the schema area node Links under Object1. 
3.  Drag&Drop Object2 from node Links at Object1 and build a condition tree if it is 

necessary. 
4.  Expand in the schema area node Object2 and select COLOR. 
5.  Drag&Drop selected COLOR to the condition tree area and set a condition at color of link 

between Object1 and Object2. 
6.  Execute built query. 

An example of query with condition at color of link is presented at Fig. 43. 
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Fig. 43. An example of query with condition at color of link 

 Search for linked objects with defined color uses only links (not references). 

Statistics 
To create a statistic report please do following: 

1.  Build and save queries (with parameters) that will bw used to obtain data from DB. 
2.  Click Statistics at the main window. 
3.  In opened window with a list of saved statistics click New statistics. 
4.  In opened window enter statistics name (up to 40 symbols) an click ОК. An empty 

spreadsheet will be created with typed name. 
5.  In opened window enter necessary strings, numbers, expressions and do other required 

actions. 

The format of exchange through the clipboard is equal to MS Excel. 

Most of operations are like in MS Excel. 

NEVOD supports following functions: SUM, COUNT, AVG, MIN, MAX, and following 
function: 

Function  Action 
QUERY_COUNT  Return count of objects selected by specified query 
QUERY_RESULT  Return annotation of the first object selected by specified query  
QUERY_TREERESULT  Return the first value of the attribute (should be provided a sequence 

number of this attribute in the query tree) that belongs to the first 
object selected by specified query 

Presented here functions have the same format: Name_of_function + comma separated 
parameters in round brackets (strings should be in quotes). The first parameter is the name of 
the query. The second parameter is the name of the query execution result ("" is used to execute 
the specified query once statistics is opened). The next parameters are optional: the name of the 
query parameter and address of cell witch value should be assigned to the parameter. 
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QUERY_TREERESULT requires after the result name to provide the level of the attribute in 
the query tree (query tree should includes this necessary attribute). 

For example of call of QUERY_COUNT see Fig. 44. 

 
Fig. 44. Example of statistics 

To show dictionary values automatically please choose menu item Table ⇒ Summary table. 

To edit cell value please click on this cell second time (the first click selects the cell). For 
example, after the first click on the cell contains an expression you may choose context menu 
items Dupe ⇒ Along column and Dupe ⇒ Along row to duplicate expression. 

Link diagram 
To create a link diagram please do following: 

1.  Click Diagrams at the main window. 
2.  In opened window (Fig. 45) with a list of saved diagrams click New diagram. 

 
Fig. 45. List of saved diagrams 

3.  In opened window enter diagram name (up to 40 symbols) an click ОК.. An empty diagram 
will be created with typed name. 
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4.  Open an input form or query result that contains objects wich should be placed at link. 
5.  Set focus on necessary object and choose context menu item: Insert object into diagram or 

Insert objects into diagram. 
6.  In opened window (Fig. 46) select one of the opened diagrams or New and click OK. 

Fig. 46. List of opened diagrams 

7.  Repeat steps 4. 5. 6.  necessary times to add required objects. 
8.  If it necessary apply to the diagram saved analyse rule package: 

• open System Bar; 

• open pane Resources; 

• select required analysis rule package (such resource has the icon ) and Drag&Drop it to 
the diagram. 

9.  If it necessary select required saved link filter in combo-box Semantic Net Bar 

. 
10.  If it necessary expand links by double click on required objects (a context menu may be 

used too). 
11.  If it necessary delete from diagram superfluous objects: 

• select necessary object; 

• select necessary filter; 

• click icon Apply current filter  or choose context menu item Filter links or choose menu 
item Diagram ⇒ Neighbor filter. 

12.  If it necessary delete from diagram objects that not linked into chains: 
• select necessary objects with <Shift>; 

• click icon Delete objects not linked into chains  or choose menu item 
Diagram ⇒ Links filter. 

13.  Arrange objects on diagram by drag&drop operations to make the diagram convenient for 
decision making. 
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Adjustment of analysis rule packages 
To adjust an analysis rule package (it should be created as user defined resource) please do 
following: 

1.  Open pane Object analysis (Fig. 47). 

 
Fig. 47. Window with list of rules for object analysis 
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2.  Click Create to create a new rule or click Properties to edit a rule selected in the list 

Created analysis. 
3.  In opened window (Fig. 48) select Condition: 

• Any object to apply this rule to every object at the diagram; 

• Selected by type to apply this rule to every object with specified type; 

• Selected by query to apply this rule to every object selected by specified by  query (do 
not forget to specify type of object in the Query structure). 

 
Fig. 48. Window of adjustment of object analysis – Condition pane 
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4.  Select pane Style (Fig. 49) and set: 

• Background color (click on the corresponding button Change); 

• Caption color (click on the corresponding button Change); 

• Caption font (click on the corresponding button Change); 

• Roundness (enter a number from 0 to 100 or click ) 

 

 
Fig. 49. Window of adjustment of object analysis – Style pane 
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5.  Select pane Picture (Fig. 50) and set picture: 

• No (by default); 

• Fixed (select the necessary file with picture by Load from file); 

• From attribute (it is allowed id selected type of objects includes multimedia attribute; select 
the necessary attribute in the corresponding combo-box and set Multimedia type); 

• From collection (select the necessary file with picture by Change); 

• If it is necessary check Scale picture size and set Width and Height. 

 
Fig. 50. Window of adjustment of object analysis – Picture pane 
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6.  Select pane Caption (Fig. 53) and adjust showed caption (by default an annotation is 

shown): 
• select in Attribute list an attribute wich value should be shown; 

• click  (selected attributed will be moved to the right list: Selected); 

• check in the right list attributes that should be showed with the name of the attribute; 

• make necessary order of attributes in the right list by  and . 

 
Fig. 51. Window of adjustment of object analysis – Caption pane 

7.  Close the Window of adjustment of object analysis by OK and change Rule name. 
8.  Repeat 2 – 7 to create all necessary rules for analysis of objects. 

9.  Click  and  to set necessary order of rules execution (the next rule overlaps the 
previos one if they are applied to the same object). 

10.  Select pane Link analysis and adjust rules for links similarly. 
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Adjustment of link filters 
To adjust the link filter (it should be created as user defined resource) please do following: 

1.  Select the type of object for that should be adjusted links or click Create to show full list of 
objects (Fig. 52). 

2.  Check links that should be shown (manually or by Show all / Hide All / Invert). 
 

 
Fig. 52. Window of adjustment of link filter 

 

Reports 
To create a based on form report choose menu item Form ⇒ Create form based report and 
select the format: Text file, RTF file, HTML file. 

To create an XSL based report choose context menu item Report for object (to make a report 
for current object) or Report for objects (to make a report for every object) or choose menu 
item Form ⇒ Make report for object (to make a report for current object) or 
Form ⇒ Make report for all (to make a report for every object). 
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User defined resources 
Every created by user input/output form, query, report, link diagram, etc is an user defined 
resource. They are presented at Resource pane of System Bar.  

Queries, statistics and diagrams created by buttons at the main window are added to the root of 
the resource tree. 

To manage resources as a tree you may create folders. And you may create your resources 
directly in the resource tree: 

1.  Select a folder that should contain a new resource. 
2.  Choose context menu item Create or choose menu item File ⇒ Create new resource. 
3.  In opened window (Fig. 53) select type of new resource and click Create. 

 
Fig. 53. Choice of resource type 

4.  In opened window (Fig. 54) enter name of new resource and click ОК. 

 
Fig. 54. Window of input of resource name 
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Loading data from other DBs 
To load data from other databases please do following: 

1.  Start input in common manner, i.e. input integration object (a document automatically will 
be created and set as current) and open object list. 

2.  Choose menu item Document ⇒ Import… 
3.  In opened window of import wizard select Import from dbf-file or Import from ODBC Data 

Source and click Next. 
4.  Select .dbf file or ODBC-source from that should be loaded data. 
5.  Select a target object and select an expand level (the target structur should include every 

target attribute) 
6.  Check objects that should be linked as a result of loading and click Next. 
7.  Set encoding and click Next. 
8.  Set matches between source and target. If it is necessary you may specify a number of value 

part (every text value may be sepereted by space on parts). 
9.  Click Finish. 

 



 

 

Questionnaire 
The aim of this questionnaire is to refine this manual. Please fill out and send us by any way: 
• post: 394000, Russia, Voronezh, P.O.Box 137. 

• fax: +7 (4732) 711–711. 

• e-mail: market@relex.ru. 
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Question Answer 
Is this information useful? Yes   /   No 
Is this information easy accessible? Yes   /   No 
Is this information easy understandable? Yes   /   No 

 
Your request: 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Name:  

Position:   

Company:  

Address:  

Phone:   

е-mail:   

mailto:swpubs@emass.com


 

 



 

 

For notes 
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