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1  INTRODUCTION

Software Overview
Design Tools consists of a suite of integrated software packages developed to provide solutions for
designers in many different areas.  The PCB elements of the Design Tools Suite are PCB Design
and PCB Make.  These may be supplied separately as individual packages, though most users will
have them supplied together as one integrated package - PCB Design and Make.  

PCB Design
This is an easy to use PCB draughting layout and
editing program.  Its clear and logical interface make
it ideal for the inexperienced user, whilst its advanced
editing facilities give it the power to tackle very
sophisticated circuit board layouts.

PCB Make
This is dedicated PCB manufacturing software.  It can produce manufactured outputs to two dis-
tinct types of machines, vinyl cutting machines and engraving/milling machines.

The output to vinyl cutting machines (eg.,
Roland CAMM 1, STIKA, etc.), allows the
circuit to be “cut” out of Cutronics self-adhe-
sive copper foil.  The foil circuits can then
easily be transferred to any suitable substrate,
eg., card, wood, plastic, etc.  This is an ideal
quick and cheap way to make simple circuits
with relatively large pads and tracks.  It also
creates interesting new design opportunities.
Projects can be created that require no sepa-
rate circuit board - the circuit could be
applied directly to the case, for example.
The creation of ‘flexible’ circuits or circuit
elements, is now possible.  
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The output to engraving/milling machines (eg.,
Roland CAMM 2, CAMM 3, MODELA, etc.),
creates a circuit by engraving around each cir-
cuit path with a fine point tool onto convention-
al copper clad PCB board.  If suitable tools are
available on the machine, the software will also
allow the holes to be drilled and the circuit
board profile to be milled out.  Thus it is possi-
ble to take a fully finished board from the
machine, drilled and ready to solder up.

2  INSTALLATION
The software can be installed on any computer running Windows 95, 98, NT4, 2000, etc.  The
installation set supplied consists of a CD ROM and a floppy disk.  The floppy disk contains your
registration details and will be required during installation.  Keep this disk safe, as it may be
required for future upgrades.

The release CD ROM allows direct installation onto your target computer.  If your target computer
does not have a CD ROM drive fitted, the CD may be used with any computer that does have a
suitable drive, to create an installation set of floppy disks.  These floppy disks can then be used to
install the software on the target computer.

On insertion of the CD into the drive, the installation program will normally auto-start.  If the
installation disk fails to start automatically, choose Start > Run, then type d:\setup (adapt this as
appropriate if using a CD ROM drive other than d) and press ENTER.

When the install program starts, a splash window similar to that below will be displayed.

If installing directly onto the computer in use, choose the Install NOW from CD button, then follow
the on-screen prompts.
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If you wish to create a floppy disk installation set, choose the Create floppy install disksbutton
then follow the on-screen prompts.  When the floppy disk set has been created, install the software
as follows:

1. Insert disk 1 in a floppy drive.
2. Choose Start > Run.
3. Type a:\setup (adapt this as appropriate if using a floppy drive other than a) and press ENTER.
4. Follow the on-screen instructions. 

3  STARTING THE PROGRAM
Choose Start> Programs> TechSoft Design Tools> PCB Design and Make (or Make or Design),
or use the desktop shortcut icon.

Users of PCB Design can omit chapter 7 - PCB Make.
Users of PCB Make can omit chapters 5 - PCB Design Tutorialsand6 - PCB Design Notes.
Users of PCB Design & Make should read all chapters.

4  DESIGN TOOLS HELP
Help is a standard Windows feature supported by a wide range of software packages.  Design Tools
Help gives you easy access to detailed information on every menu item, tool, dialog box, button
and feature in PCB Design & Make.

You can access Help in the following ways:

1. Use Help > Help Topics.
2. Click on the Help button in a dialog box for help on that dialog box.
3. With any menu item highlighted, press the F1 key to see a Help window describing that menu

item.
4. Press Shift + F1 to display the Help cursor.  Then click on any tool to see a Help window

describing it.
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5  PCB DESIGN TUTORIALS

TUTORIAL 1 - Screen Layout, Menu Selection, etc.
The PCB Design program window provides a clear view of the current layout, various information
areas, and a selection of icons with tools to cover the most common design, editing and display
functions.  The main features of the program window are shown below.  Although most users will
stay with the standard layout, it is possible to use Setup> Customiseto change not only the appear-
ance, but also the operation of many of the software's features.  For example, it is possible to have
larger icons, help messages and prompts, user definable screen colours, etc.  We do however rec-
ommend using the standard layout for the rest of these tutorials!

1. Start up PCB Design (see Starting the Programpage 5) and familiarise yourself with the
screen layout as shown below.

2. Menu items are normally chosen from the menu bar or the toolbox, using the mouse (although
keyboard alternatives are available).  To choose an item from the toolbox, position the pointer
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Absolute coordinates
show the position of
the cursor relative to
the drawing origin (the
bottom LH corner of
the drawing area)

Relative coordinates
show the position of the
cursor relative to the last
point located, or object
drawn (can be reset by
pressing SPACE bar)

Relocatable drawing
aids toolbox has a
range of commonly
used functions

Allows the setting of pad
sizes, hole diameters, etc.
Context sensitive

Simple prompts always
tell you what to do next

Toolbar help explains
each icon

Relocatable draw/edit
toolbox allows easy
access to all the main
draw/edit functions

Pullout toolbar.  Just
select a toolbox icon,
and hold down the LH
mouse button to open
the toolbar

Distance from last shows
the distance from the last
point located or drawn

Angle from last shows
the angle from the last
point located or drawn

Layer box allows selec-
tion of active layer, eg.,
solder, component, etc.

The white area repre-
sents the actual size of
the PCB design

Coordinate data entry
box allows accurate
positioning and draw-
ing at any time

Optional title bar help
message.  (Can be
relocated at the bottom
of the screen)

Layer display selector.
See as many or as few
layers as you wish



Page 7DESIGN TOOLS - PCB Design & Make

over the appropriate icon and click the LH mouse button.  Some items in the RH toolbox (the
Drawing Aids toolbox), such as Grid, will cause the icon to stay selected (on) until it is cho-
sen again.

3. Many items in the LH toolbox (the Draw/Edit toolbox) have pullout toolbars.  These are acti-
vated by positioning the pointer on the icon then pressing and holding the LH mouse button
for a short while.  The pointer can then be dragged along the icon bar until the required icon is
highlighted, then the mouse button released.  This selects the item, and changes the icon in the
toolbox to that chosen.

4. Most menu items, eg., grid, pads, etc., have an associated dialog box for settings.  To access
these dialog boxes, double click on the appropriate icon with the LH mouse button, or click on
the icon with the RH mouse button.  (The associated dialog box for pads and tracks can also
be accessed by clicking on the Pad Size/Track Widthbuttons on the attributes bar at the top.)

TUTORIAL 2 - Setting Up the Software to Suit Your System
It is possible to customise the look, feel and functionality of the software in many ways.  For most
users, however, the first priority is to set the PCB design size (the Board Area) and to set the cor-
rect plotting device.  This is what this tutorial deals with.  Once you have set these to suit your nor-
mal requirements, you will then save these values as the default.  

1. Start up PCB Design.  Select Setup> Drawing > Layout.  A dialog box similar to the one
shown below will open.

.
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2. Use the dialog box to set both the design size of the board (the Board Area), and the
plotter/cutter/miller you will be using most often.  (The plotter/cutter/miller is only relevant to
PCB Make users.)  

Most users will want to work on a “sensible” sized board, 4 x 3 inches is the default value.  It
is, however, possible to set the Board Areato match the printer or plotter to be used.  This is
particularly useful if making a lot of small circuits so that they may be “fitted onto” the maxi-
mum size available.  For tutorial purposes, ensure that the Board Areais set to 4 x 3 inches.

When using Set plotting deviceto set your particular plotter/cutter/miller, the dialog box will
change to reflect the plotting device chosen.

3. You may wish to investigate some of the other options under Setup > Drawingor Setup >
Customise.Any of the options set may be saved as default values in the next step.  At this
stage however, it is probably better to leave these options, and to come back to them after
working through the other tutorials.

4. Select Setup> Set As Default.  Click OK on the warning dialog box.  Close down the software
completely, then restart it.  You will see that it starts up with the Drawing Layoutsettings you
have made.  (Any other settings made from the Setupmenu, eg., the type of grid, will also
have been saved.)

You may wish to use more than one setup, eg., if you have two or more different output devices.
For example if using both a CAMM 1 and a CAMM 2, you could set up for your CAMM 1, then
instead of using Set As Default,you could choose Setup > Save Setup, and give the setup a name
such as “Setup for CAMM 1”.  You could then save a suitable setup for the CAMM 2 in the same
way.  On subsequently loading the software, the first action would be to load the correct setup for
the work in hand using Setup > Load Setup.

N.B.  If you ever wish to return to the factory default settings, select Help > Restore Factory
Defaults, then Setup > Set As Default.
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TUTORIAL 3 - Basic Circuit Drawing

1. Choose the Round Padicon.
Move the cursor around, over the white board guide.  Notice the changing coordinates at the
bottom of the screen.  Move the cursor to a position where you wish to position a pad, and
click the LH mouse button.  Repeat, dropping a few more pads here and there.

2. Choose the Grid Lock icon.
Now draw a few more round pads.  The pads will now be fixed to grid positions (the small
crosses on screen).  As the default grid spacing is 1inch, the movements will be in very large
steps.

3. Choose the Step Lockicon.
Now draw a few more round pads.  The pads will now be fixed to step positions (the small
dots on screen).  These are set by default to 0.1inch.  For most PCB design work it is suggest-
ed that the Step Lockis permanently set on.  Double click on the Step Lockicon with the LH
mouse button and a dialog box will appear.  This allows the grid and step spacing to be
changed.  Many other icons have dialog boxes accessed in the same way.  (Alternatively, dia-
log boxes may be accessed by clicking the icon with the RH mouse button.)

4. Choose the Square Padicon and position a few more pads.  
Note that when any pad icon is chosen, the pad size is displayed at the top of the screen.
Click on the Pad Size button to open the Pad Sizedialog box.  In this dialog box you may
select pre-set sizes or choose Customand set your own size.  (You may also access the Pad
Sizedialog box by double clicking on the pad icon with the LH mouse button, or by single
clicking with the RH mouse button.) 

5. Move the pointer over the Horizontally Elongated Padicon.   
Press and hold the LH mouse button.  This will activate the pullout toolbar.  The toolbar con-
tains a number of similar pads.  Slide the pointer along the toolbar to highlight each pad type
in turn.  The toolbar help above the toolbar describes each pad type.  Choose a pad type by
highlighting its icon, then releasing the mouse button.  The chosen pad type will now be active
in the main toolbox, and may be chosen as normal.  Draw a few horizontally elongated pads
of different types.  

There are other pad shapes namely Vertically Elongated Pads and Edge Connectorsin the
main toolbox - you might also like to experiment drawing some of these.

6. Choose the Linear Trackicon. 
Click the LH mouse button to start a track.  Move the mouse to a new position and click



again.  Move the mouse again and click.  To complete a track, double click the LH mouse but-
ton (to fix the moving track) or click the RH mouse button (this will finish at the last fixed
track).  Note that when any track icon is chosen, the track width is displayed at the top of the
screen.  Click on the Track Widthbutton to open the Track Widthdialog box.  You may select a
standard width or enter any width you wish.  (You may also access the Track Widthdialog box
by double clicking on the track icon with the LH mouse button, or by single clicking with the
RH mouse button.)

7. Choose the Zoom Inicon.
Note the prompt reading Locate one corner of zoom box.  Move the cursor approx. 0.5inch
above and to the left of any “corner” that you have drawn, then click the LH mouse button.
The prompt will change to Locate opposite corner of zoom box.  Move the mouse to pull out a
box down and to the right, about 1inch square, then click the LH mouse button.  That area will
now be redrawn to fill the screen. Try drawing some more tracks.  Working “zoomed in” can
be very helpful when working on small details.  

8. Move the pointer over the Zoom icon.
Press and hold the LH mouse button to activate the pullout toolbar.  Slide the pointer along the
toolbar to the Zoom Lasticon then release it.  This will restore the previous zoom level, in this
case the full drawing screen.  (You might like to try the effects of the other items in the Zoom
toolbar, and also the Zoom+and Zoom-icons in the RH toolbox at this point.)

9. Choose the Radial Lockicon.
Draw some more tracks.  It will be seen that the track being drawn is constrained to 45° steps
(by default).   Choose the icon again to turn Radial Lockoff. 

10. Move the pointer over the Linear Trackicon.
Press and hold the LH mouse button to activate the pullout toolbar.  Slide the pointer along the
toolbar to the Compound Trackicon then release it.

When you choose this icon a new toolbox will appear in the bottom right of   
your screen.  The first icon in this toolbox functions in a similar way to the Linear tracktool.
The next two icons allow curved tracks and arcs to be drawn.  It is possible to change the style
mid track by simply choosing the appropriate icon.  Experiment to see how versatile these
track drawing tools are.

11. Choose the Linear Track Area icon.
Draw a simple shape such as a rectangle.  Click the LH mouse button to fix each corner and
either double click the LH mouse button or single click the RH mouse button to finish.
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12. Choose the Compound Track Area icon from the pullout toolbar.  
This will activate a similar toolbox to Compound Tracks,facilitating complex shapes.        

If you draw a shape, then you choose the right most icon in this toolbox, by continuing draw-
ing you can create an ‘island’, ie., an empty space within the shape.  Have a try.

13. Choose the Componenticon.
The Load Componentdialog box will open.  Load the component “Dil08” from the “Dils”
library directory.  Dil08 is the pin layout and schematic for an 8 pin dual in line chip (eg., 555,
741, etc.).  The DIL will initially be coloured pink, and will be surounded by a dotted box
with several small yellow handles (a marquee box).  The fact that it is pink shows that it is
“selected”.  Click on the centre handle.  As the mouse is moved the DIL will move with it.
Move the DIL to a clear part of the screen, then click the LH mouse button to “drop” the DIL
at its current position.  To “de-select” the DIL move the cursor to a clear area of the screen
away from the DIL and click the LH mouse button.  (More details of the functions of the mar-
quee box, including simple moving, mirroring and rotating, are given in Tutorial 6.) Once de-
selected you will note that the pads are coloured blue, whereas all pads drawn before are red.
These colours denote whether the pads (or tracks) are drawn under or on top of the board (see
Tutorial 4 for further details). 

14. By now your screen may be rather cluttered so this is a good time to look at deleting.  
Simple mistakes may be undone by clicking on the Undo Last icon in the RH toolbox.  This
undoes the last operation, either drawing, transforming or deleting.  Once undone, the icon
becomes Redo Last.  Choosing this effectively undoes the last undo.  Redo Lastis cleared by
any further drawing or deleting operation.  Also in the RH toolbox is Delete Last.  This
deletes back one object each time it is selected.  Undo Last restores a deleted object, but only
the last one deleted!  Most other delete functions are in the LH toolbox, where there is Delete
Any, Delete Part, and Delete Inside Box.  Delete Anyallows you to point to an object and
delete it.  Delete Part deletes any part of a track, line, arc, etc., back to the closest intersection
points to the locating point.  Finally, pressing Ctrl + Deleteon the keyboard deletes the cur-
rent selection (selection will be dealt with in Tutorial 6), pressing  ALT + Deleteon the key-
board deletes the whole of the current drawing.  Try some of the Deleteoptions now.
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TUTORIAL 4 - Layers
So far, most of the work done will consist of red pads and tracks.  Red is used to denote objects
which are on the underside of the board, referred to as the ‘Solder Side’.  In order to design more
complex layouts and include information other than pads and tracks, you will have to work with
layers.  Remember, whatever layer you are working on, your viewpoint is un-changed.  You are
always seeing the board from above, referred to as the ‘Component Side’.  It may help to think of
the board as a piece of glass and the layers as acetate sheets either side of it.  Double sided boards
have tracks and pads on both Solder Side and Component Side layers.  The example below will
illustrate the use of different layers.

1. Choose File > Closeto clear any work you have done so far, then choose File > Newto start a
new drawing. 

2. Choose any Pad icon then click on the downward arrow on the 
attributes bar and select a layer.  You can opt to place pads on either side of the board, or both.
Pads on the component side of the board are shown green and those on both sides, blue.  You
can also place tracks on either side, (but you cannot draw tracks on both layers at the same
time), these too are coloured red or green accordingly.  Try drawing some pads and tracks on
different layers.

3. Choose File > Closeto clear any work you have done so far, then choose File > Open  and
load the file “PCBTutor1.dtb” from the Tutorial directory.

4. This drawing is made up of several layers.  You will see that initially all the layers
are visible.  Use the Visible Layerstoolbox in the bottom LH corner to turn them
on and off individually to get a clearer view of each.  Any layer with a line
through, like the Picture layer shown opposite, will be invisible.  (N.B.  Not all
layers have any drawing on them.)



As you can see with this sample file, there are other details you might wish to include in a PCB
Design in addition to pads and tracks.  These can be placed on a selection of other layers:

The Board Profile layer is used to show the outline of the PCB and details things such as slots,
mounting holes, etc.  When using PCB Make to manufacture the board, drawing elements on this
layer are used as the tool path for cutting out the board.

The Silk Screen layer shows the position of the components on the board.  Silk screen printing is
often used in industrial practice to show assembly workers where components should be positioned
and to add company identifiers, serial numbers, product codes, etc.   In school project work the Silk
Screen layer can be printed onto paper to act as a guide to assembly.

The Drawing layer can be used to show other details related to the PCB, details of the enclosure, or
adjacent objects for example.  It can also be used to show drawings imported from 2D Design, etc.

The Schematiclayer can be used to display the schematic diagram of the circuit alongside the PCB
to facilitate checking, fault finding, etc.

The Picture layer can be used to show realistic illustrations.  

If all the information is displayed at the same time the screen can be very confusing.  The great
advantage of using layers is that they can be turned on and off at will so that you only see what you
need to see.  
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TUTORIAL 5 - Drawing Tools
Drawing tools can be used to create the board outline, show the size, shape and position of compo-
nents or add other details to your PCB such as mounting holes.  They can also be used to show
related objects such as enclosures and ‘off board’ components.

1. Choose File > Closeto clear any work you have done so far, then choose File > Newto start a
new drawing. 

2. Choose the Single Lineicon.
Note that the Layerhas changed automatically to Silk Screen.  If you wish to draw on a differ-
ent layer, you may change it, but note that you cannot draw on either the Solder Side or
Component Sidelayers.  Try drawing a few lines.

3. Position the pointer over the Single Lineicon then press and hold the LH mouse button to
activate the pull out toolbar.  

Experiment with the other drawing tools.  The drawing tool functionality should be self
explanatory if you follow the prompt messages.

The tools here are actually some of the more commonly used drawing tools from Design Tools -
2D Design.  If you need more elaborate drawing facilities then remember you can use 2D Design to
create your drawing then bring it into PCB Design.   See Importing Drawingspage 41.
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TUTORIAL 6 - Object Selection and the Marquee Box
As you will see in this tutorial, selection is carried out using normal Windows methods.  Selected
objects may be dragged, rotated, flipped, resized or copied quickly and easily.

1. Choose File > Closeto clear any work you have done so far, then choose File > Open and
load the file “PCBTutor2.dtb” from the Tutorial directory.

2. Choose the Selecticon.
Move the cursor above and to the left of the circuit.  Press the LH mouse button, drag a box
around the whole circuit, then release (alternatively Select Allusing the keyboard shortcut Crtl
+ A).  The circuit will be redrawn in pink, and surrounded by a dotted box (a marquee box)
with yellow handles.  

3. Ensure that Step Lockis on, then click on the yellow handle in the centre of the marquee box
with the LH mouse button.  As the mouse is now moved, the circuit will be moved around the
screen.  To “drop” the circuit, click the LH mouse button again. 

4. Familiarise yourself with the marquee box functions, as described below.

Clicking on the top diamond handle will “mirror” the circuit left right.  Clicking on the left
diamond handle will “mirror” the circuit up down.

Clicking on the bottom “overlapping sheets” handle will produce a quick copy of the circuit.

Clicking on the circular handle to the right will rotate the circuit.  With Radial Lockon, this
will be in fixed steps (45 deg. by default).

Clicking on any of the edge or corner square icons will stretch, expand, or contract the circuit
as appropriate.  (Warning - moving these handles may alter the aspect ratio of the circuit and
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will alter the spacing of pads (including items such as Dils).  These functions should only be
used with great caution.  If they are used accidentally,Undo Lastwill restore the drawing.)

5. An individual object (track, pad, etc.,) can be selected by moving the pointer near it and click-
ing the LH mouse button.  Clicking on another object in the same way will select the new
object (de-selecting the first object).  Clicking on a second object with the RH mouse button
(or SHIFT +LH mouse button) will “add” or “remove” the object from the selection by tog-
gling its select state.

Multiple objects can be selected by dragging a select box around them with the LH mouse
button.  Dragging another select box in the same way will create a new selection (cancelling
the first).  Dragging a select box with the RH mouse button (or SHIFT + LH mouse button),
will toggle the select state of the objects.

To de-select objects, move the pointer outside the marquee box and click the LH mouse but-
ton.  Individual objects may be de-selected using the RH mouse button (or SHIFT + LH
mouse button) as described above.

Try all of the above options to get the feel of the selection process.  

N.B.  You will notice that when any part of the DIL is selected, the whole thing is automati-
cally selected.  This is because the DIL is grouped.  This means that it will be treated as a sin-
gle object.  This makes such items much easier to move around, etc.  To group objects, first
select every object to be grouped, then use Edit > Group(or Ctrl+G).   To ungroup objects
first select them, then use Edit > Ungroup(or Ctrl+U ).
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TUTORIAL 7 - Transformations
You have already tried simple transformations using the marquee box in Tutorial 6.  There are
other transformations available in the LH toolbox,Move/Copy, Mirror Image, Rotate, Rectangular
Array and Circular Array.  All these operate in a similar way.  First you must select the objects to
be transformed using the Selectoption.  Then choose the appropriate transform option (the objects
will stay selected but the marquee box will disappear).  Set/check the variables in the dialog box
that appears, then follow the screen instructions.  The following example illustrates the general
principles of their use.  

1. Choose File > Closeto clear any work you have done so far, then choose File > Openand re-
load the file “PCBTutor2.dtb” from the Tutorial directory.  Choose Edit > Select Allto select
the whole circuit.  

2. Choose the Rectangular Arrayicon from the Transformtoolbar.
The following dialog box will open.

Ensure that No. columnsis set to 3,No. rowsto 2,X spacingto 1.3in and Y spacingto 1.5in.
Click OK on the dialog box.  The circuit will be repeated as shown below.

Now take a few minutes to investigate the operation of the other transformation options.
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TUTORIAL 8 - Advanced Editing of Tracks
PCB Design has some very sophisticated (but simple to use) editing functions.  These can best be
demonstrated by working on an existing design.

1. Choose File > Closeto clear any work you have done so far, then choose File > Open and
load the file “PCBTutor3.dtb” from the Tutorial directory.

2. There are some ‘deliberate mistakes’ in this design, let’s look at how to correct them.  You can
see that one of the tracks is cut by a mounting hole.  As the hole cannot be moved, the track
layout will have to be changed.

3. Choose the Selecticon.
Point to the track to be edited (see arrow in the diagram above) and click the LH mouse button
to select it.  Note that the bottom part of the track is also selected.  This is because the track
was originally drawn in one operation.

4. Notice the Property/Start Edittoolbox in the bottom RH corner of the screen.
Choose Start Edit.  The track will turn grey and ‘nodes’ (coloured circles) appear.
The green node indicates the start of the track, the orange node(s) the intermediate
point(s) and the red node the end of the track.



You should also notice that the Property/Start Edit toolbox has been replaced by the longer
Edit Modetoolbox (initially all buttons will be greyed out).  This will be used later.

Move the cursor over the orange node, click the LH mouse button, and move the node to a
new position.  To fix it in its new position click the LH mouse button again, or to return to its
original position click the RH mouse button.  (If multiple objects are selected and if two or
more nodes are coincident (eg., two tracks meet at a pad), as you move coincident nodes, all
connected objects will move together.)

5. In this case moving the node will avoid the hole, but will produce a ‘messy’ circuit
board.  A better plan is to add more nodes to the track.  First click on the Undo
Last icon to restore the track to its original position.  Then click on the track
between nodes with the LH mouse button to sub-select it (the original locating
point will be fine).  At this point the appropriate buttons in the Edit Modetoolbox
will become active.  Choose Add Node.  A new node will appear mid way along
the selected track.  Click off the drawing once so that the tracks revert to grey, then
click on the new node and position it as shown below.

6. This is better but not very elegant. To improve things further, sub-select another part of the
track and add another node.  Repeat the process until the circuit looks like the layout below.
(N.B.  If you move a node which connects a sub-selected (pink) section and a normal grey
section, they will separate.  This can sometimes be used to good effect to ‘break’ tracks.
However if it is done by mistake,Undo Lastwill re-connect the sections.)
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7. For an even more elegant solution, delete the two LH nodes by sub-selecting them (drag a box
around them), and clicking on the Del Nodeicon.  Click on the remaining section of track
between the nodes to sub-select it and click on the To Arc icon.  This will enable you to curve
the track neatly round the hole as shown below.

8. To remove the nodes, click “off” the drawing (twice, if objects are sub-selected), or click on
End Edit.  This will return the marquee box.  Click off again to de-select.

N.B.  All the same editing routines can be used on all types of drawing objects, lines, arcs, etc.
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TUTORIAL 9 - Changing Track Width, Pad Properties and Layers
PCB Design allows very simple editing of track and pad properties.  This is best demonstrated by
working on an existing design.

1. Choose File > Closeto clear any work you have done so far, then choose File > Openand
load the file “PCBTutor4.dtb” from the Tutorial directory.  

2. Look at the track connecting to pin 3 on the integrated circuit (see arrow in the diagram
below).  This track has been drawn too wide and is touching pin 2.  Select the offending track,

then click on the Change Tracksbutton at the top of the screen.              
Reset the track width to 0.03in from the drop down list, (or type in this value), then click OK.

3. It is possible to change any number of tracks simultaneously.  Look at the tracks in the middle
of the board.  You will see several that are unnecessarily fine.  Select the fine tracks.  If you do
this by dragging a box around them, the four pads in the middle of the tracks will also be
selected.  This is fine, as changing the track width will not affect the pads.

Once you have selected the tracks click on the Change Tracks button.    
Set the track width to 0.05in, then click OK.

4. Selected pads may also easily be edited.  Look at the battery connection pads (top right).  The
pads are unnecessarily large, so large that they extend beyond the edge of the board.  Select

both pads.  Click on the Change Pads button.                                           
Set the Pad Typeto Square and the Pad Sizeto Medium, then click on OK.
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Changing the pad properties will change all the selected pads, but notice that you can choose
the type of pads to change.  Thus, if you wish to change all the square pads for example,
rather than try to select each individually, drag a select box across the whole board, click on
the Change Padsbutton and untick All Pads, and tick Square Pads.  When you now set a new
pad parameter, only the selected square pads will be changed.

5. There are times when working with double sided boards that you may      
wish to move pads and/or tracks from the Solder Side to theComponent Side layer or vice
versa.  To do this, select the pads/tracks as before and click on the Change Layer button. It is
also possible to transfer drawing data from one layer to another, but it is not possible to trans-
fer track data to a drawing layer or vice-versa.

6. Whenever a single object (pad, track, line, shape or piece of text) is selected the
Property/Start Edit toolbox appears in the bottom right hand corner of the screen.
We have already looked at the use of Start Editto modify tracks.  Property is an
extremely useful tool, which PCB Design shares with 2D Design.  Put simply, the
Propertiesdialog boxes will tell you everything you might wish to know about an object, and
give you the opportunity to change any of its parameters.  There are too many variations to go
into here, we suggest you experiment to find out just what can be done with this versatile tool.
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TUTORIAL 10 - Text
The PCB Design text facility can be used to add text to any layer.  Text fonts used are Windows
TrueType format.  

1. Choose File > Closeto clear any work you have done so far then choose File  > Newto start a
new drawing.  For the purposes of this tutorial only, choose Help > Restore Factory Defaults.

2. Choose the Text icon.
Choose the layer you wish to work on from the drop down list in the attributes bar.  Position
the cursor and click where you intend the text to be.  You need not be precise, the text can be
moved later.  The following dialog box will open.

Enter any short text phrase, then click on the Settings button.  In the Text Settings dialog box
(see below), you may select any True Type font installed on your computer, and apply a range
of effects to the lettering.  

There are too many options to go into in depth, so leave the default settings for now (remem-
ber to come back and experiment later!).

Click OK on this dialog box and also on the Text Entry dialog box to return to the design
screen.  Note, if you are putting text on the Solder Sidelayer it will appear mirrored.  This is
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correct, (remember you are looking at a transparent board with the design and text on the
back).

Once entered, text may be treated like any other object and dragged around or transformed using
any of the transformation tools.  To quickly re-size a piece of text to fit in a space, select it then
click on one of the corner handles of the marquee box with the RH mouse button.  Once posi-
tioned click again.  This will preserve the text aspect ratio and correct spacing, whilst changing the
size.  If you want to distort the text aspect ratio then click on a corner handle and move with the
LH mouse button.
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6  PCB DESIGN NOTES

Working with Component Libraries
Perhaps more than any other design activity, electronics is frequently a matter of piecing together
building block circuits.  Even when designing totally from scratch, the components used are usually
standard items.  It makes sense then to have these standard components and building blocks ready
drawn so they can be dropped into your design, rather than drawing each one when you need it.
With so many components and building blocks, a library system is needed to keep things where
you can find them. 

PCB Design uses the standard Windows filing system.  All the basic components and building
block circuits are kept in sub-directories of the ‘PCBLib’ directory.  The names of most of the sub-
directories are self-explanatory.  Components are imported into the drawing using File > Load
Component, and arrive ‘grouped’.  Grouping keeps the various pads, tracks, lines, etc., which make
up a component, together so you can easily move them into place in your circuit.  If you wish to
adapt a component, first select it then choose Edit > Ungroup.  

Creating your own libraries
You can add your own components or building block circuits to the library very easily.  Once you
have created the object, Choose File > Save As Component.  The drawing will be saved as a com-
ponent.

Although a range of standard components is supplied, it is likely that you will wish to amend or
add to the components.  Some items such as transistor packages, have been designed to manufac-
turer’s specifications and therefore not all pins sit on a 0.1 inch grid (usually 0.05inch).  All drilled
holes in components are also to manufacturer’s specifications, so, for example, DIL pads are drilled
to 0.8mm.  School users may wish to standardise on one drill size, eg., 1mm to simplify drilling
operations.

You can modify components by choosing File > Load Component, making any alterations required,
then saving again using File > Save As Component.  It is probably best not to overwrite the sup-
plied libraries but to create a new directory where all your own components are saved together.

Creating New Pads
There are a number of pad sizes pre-defined in PCB Design and at any time you may enter your
own custom values for the pad you are working on.  However there may be occasions when you
need a special pad repeatedly and wish to have it added to the standard list.  To do this choose
Setup > Drawing > Define Pads.Choose the pad type you want then click on Add new.
Now simply enter the name for your pad and its parameters.  The new pad will be saved with the
current drawing, or may be saved as part of a setup.  (See Setups and Customisationpage 42.)
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Printing
PCB Design will print a high quality image via any Windows inkjet or laser printer.  First set the
Windows printer driver up in the normal way then use File > Print.  The PCB Print Optionsdialog
box will open.

The Print Graphicallyoption will print in full colour on a suitable printer, or greyscale on a mono-
chrome printer.

The Print solder layer photo maskoption will print the solder side layer only as a solid black
image.  This option should be used if a master image is required for a photo-reproduction process.

The Print component layer photo maskoption will print the component side layer only as a solid
black image.  This option should be used if a master image is required for a photo-reproduction
process.

The Centre option is ticked by default and the Scaleis set to 100%.   The default values ensure that
the design is printed the correct size in the centre of the page.

When suitable parameters have been set, click on OK to proceed with printing.

N.B. By choosing Setup> Drawing > Layoutthen selecting Match print areaof your printer, you
can match the PCB board area to the maximum print area if desired.  This may help when laying
out a drawing to be printed.
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7  PCB MAKE
This section applies equally to users who have created or modified a layout in PCB Design, and
those who have imported a layout into PCB Make.

This manual is not intended to provide an in depth guide to the operation of individual machines.
It assumes user familiarity with the output device.  If this is not the case, this manual should be
read in conjunction with the appropriate TechSoft or manufacturer’s user guide for the machine.

PCB Make can be used to drive various pen plotters, Roland vinyl cutters (CAMM 1, Stika, etc.),
and Roland milling/routing/engraving machines (CAMM 2, 3, Modela, etc.).  

OUTPUTTING USING PEN PLOTTERS
Flat bed plotters can be used as an alternative to printers for preparing a conventional photo etch
mask.  There are built in drivers for the Roland and Graphtec ranges of plotters.  If your plotter is
not listed it may well work with the General HPGL plotterdriver.  

As an alternative to photo etching, many plotters can be fitted with oil based pens which are etch
resistant.  These can be used to plot the resist direct onto the copper clad board.  TechSoft sell a
special thin PCB board for this process which fits easily under the arm of most plotters.  

Output - Step 1
Before outputting it is important to set up the correct driver for the machine to be used.  This can
be done “on the fly” at the time of output, but it is much better done even before any designing
takes place using Setup> Drawing > Layout.  A dialog box similar to the one shown below opens.

Page 27DESIGN TOOLS - PCB Design & Make



Board layout: This section of the dialog box allows users to set a suitable size for the Board Area
displayed on screen (the white area).  Most users will want to work on a “sensible” sized board (4 x
3 inches is the default value).  It is, however, possible to set the Board Areato match the plotter to
be used.  This is particularly useful if making a lot of small circuits so that they may be “fitted
onto” the maximum plotting area available.  

Plotting device:This section allows the plotter type to be selected, and the actual material and its
orientation, fitted to the plotter to be specified.  

The layout and plotting device chosen can be saved in a setup file using Setup> Save Setupor
Setup> Set As Default.  (See Setups and Customisationpage 42.)

Output - Step 2
When you are ready to output, choose File > Make PCB.The Make PCBdialog box will open.
Check the parameters and options detailed below.

.

Production Method
Solder side only:This option allows only the solder side tracks to be drawn.  It is the default
option and should always be set for single sided boards.

Component side only:This option allows only the component side tracks to be drawn.  

Pens/Tools 
This is where parameters such as pen speed and diameter are set.  The default values should work
adequately.  However the dialog box which opens allows full user control if required.

Connection
The Connectionmay be Direct to port, or Via Generic / Text Only Printer driver.  By default, con-
nection is set to Direct to port.  In this mode all data is transmitted directly to the plotting device.
This is the simplest option to set up, but will cause the computer to be tied up until output is com-
pleted.  The Via Generic / Text Only Printer driveroption makes use of the Windows print buffer-
ing capabilities.  The Generic / Text Onlyprinter driver is a neutral printer driver which allows plot-
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ter commands to pass directly through it.  It therefore allows direct control of the plotting device,
whilst maintaining the advantages of the windows background printing and queueing facilities.
Before using this option, however, the Generic / Text Onlydriver must be loaded and set as the cur-
rent printer driver.  The Generic / Text Onlyprinter driver is installed from Windows using Start >
Settings> Printers> Add Printer... Manufacturer“Generic”.  The driver itself is supplied on the
Windows installation discs.  The Generic / Text Only printer driver’s setup should have the
appropriate output port set and also: Paper size - A4, Paper feed - Continuous, No Page
break.   If using a serial connection (eg.,. COM1, COM2), the printer driver’s protocol should
normally be set to 9600 baud, 8 data bits, 1 stop bit, No parity, Hardware flow control.

N.B.  If you wish to change the Connectionpermanently, the appropriate changes should be made,
and then the setup saved using Setup> Set As Defaultor Setup> Save Setup.

Output - Step 3
When all parameters have been checked, click on OK in the Make PCBdialog box.  There will be a
pause whilst the computer calculates the tool path.  This is normally just a few seconds, but with a
slow computer and a complex circuit it could take some while - don’t panic, be patient!  (Once the
tool path has been calculated it will be stored with the circuit, so repeat tool path generation will be
instant.)  Only objects on the Solder Side, Component Side, Both Sidesand/or Board Profilelayers
will be included in the toolpath.  (The Board Profilelayer is normally used to show the outline of
the PCB, slots, mounting holes, etc.)

The drawing screen will change to show the toolpath and you will be asked ‘Plot (whichever) side
now?’ Check that the machine is ready to go, with material in place, then choose Yes. Follow the
screen instructions carefully to completion.
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OUTPUTTING USING VINYL CUTTERS
All Roland vinyl cutting machines (CAMM 1, ColorCAMM and STIKA, other than SCP-85) can
be used to cut Cutronics copper foil to make simple ‘chunky’ circuits.  Once cut, the circuit is
‘weeded’ and transferred to a suitable substrate using application tape.  (The application tape can
be the same as is used with self adhesive vinyl for sign writing.)  Alternatively, complex circuits
may be easier to weed if the application tape is applied before weeding, the full copper removed
from the backing paper, and the excess copper weeded from the application tape. 

Output - Step 1
Before outputting it is important to set up the correct driver for the machine to be used.  This can
be done “on the fly” at the time of output, but it is much better done even before any designing
takes place using Setup> Drawing > Layout.  A dialog box similar to the one shown below opens.

Board layout: This section of the dialog box allows users to set a suitable size for the Board Area
displayed on screen (the white area).  Most users will want to work on a “sensible” sized board (4 x
3 inches is the default value).  It is, however, possible to set the Board Areato match the cutter to
be used.  This is particularly useful if making a lot of small circuits so that they may be “fitted
onto” the maximum cutting area available. 

Plotting device:This section allows the cutter type to be selected, and the actual material and its
orientation, fitted to the cutter to be specified.  

The layout and plotting device chosen can be saved in a setup file using Setup> Save Setupor
Setup> Set As Default.  (See Setups and Customisationpage 42.)
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Output - Step 2
When you are ready to output, choose File > Make PCB.The Make PCBdialog box will open.
Check the parameters and options detailed below.

Production method
Solder side only:This option allows only the solder side tracks to be cut.  It is the default option
and should always be set for single sided boards.

Component side only:This option allows only the component side tracks to be cut.  

Pens/Tools
This is where parameters such as cutter speed and diameter are set.  The default values should work
adequately.  However the PCB Plot Setupdialog box allows full user control if required.

N.B.  If Penis chosen, rather than Cutter, the machine will be treated as a “Pen Plotter” (see
Outputting Using Pen Plotterspage 27.)

Connection
The Connectionmay be Direct to port, or Via Generic / Text Only Printer driver.  By default, con-
nection is set to Direct to port.  In this mode all data is transmitted directly to the plotting device.
This is the simplest option to set up, but will cause the computer to be tied up until output is com-
pleted.  The Via Generic / Text Only Printer driveroption makes use of the Windows print buffer-
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ing capabilities.  The Generic / Text Onlyprinter driver is a neutral printer driver which allows plot-
ter commands to pass directly through it.  It therefore allows direct control of the plotting device,
whilst maintaining the advantages of the windows background printing and queueing facilities.
Before using this option, however, the Generic / Text Onlydriver must be loaded and set as the cur-
rent printer driver.  The Generic / Text Onlyprinter driver is installed from Windows using Start >
Settings> Printers> Add Printer... Manufacturer“Generic”.  The driver itself is supplied on the
Windows installation discs.  The Generic / Text Only printer driver’s setup should have the
appropriate output port set and also: Paper size - A4, Paper feed - Continuous, No Page
break.   If using a serial connection (eg.,. COM1, COM2), the printer driver’s protocol should
normally be set to 9600 baud, 8 data bits, 1 stop bit, No parity, Hardware flow control.

N.B.  If you wish to change the Connectionpermanently, the appropriate changes should be made,
and then the setup saved using Setup> Set As Defaultor Setup> Save Setup.

Output - Step 3
When all parameters have been checked, click on OK in the Make PCBdialog box.  There will be a
pause whilst the computer calculates the tool path.  This is normally just a few seconds, but with a
slow computer and a complex circuit it could take some while - don’t panic, be patient!  (Once the
tool path has been calculated it will be stored with the circuit, so repeat tool path generation will be
instant.)  Only objects on the Solder Side, Component Side, Both Sidesand/or Board Profilelayers
will be included in the toolpath.  (The Board Profilelayer is normally used to show the outline of
the PCB, slots, mounting holes, etc.)

The drawing screen will change to show the toolpath and you will be asked ‘Plot (whichever) side
now?’ Check that the machine is ready to go, with material in place, then choose Yes. Follow the
screen instructions carefully to completion.
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OUTPUTTING USING ENGRAVERS/MILLERS
Isolation engraving of PCBs is a technique used in the electronics industry for making prototypes
and one-off boards.  This method allows the board to be manufactured straight off the screen using
just one machine.  It is possible to just engrave the tracks and pads, centre dotting all holes using a
vee cutter.  Optionally a slot drill may be used to rout the board profile, and up to four PCB drills
may be used for holes in the pads.

N.B. For best quality results, all users engraving tracks should refer to the section - Engraving
Hints and Tips, page 40.

Output - Step 1
Before outputting it is important to set up the correct driver for the machine to be used.  This can
be done “on the fly” at the time of output, but it is much better done even before any designing
takes place using Setup> Drawing > Layout.  A dialog box similar to the one shown below opens.

Board layout: This section of the dialog box allows users to set a suitable size for the Board Area
displayed on screen (the white area).  Most users will want to work on a “sensible” sized board (4 x
3 inches is the default value).  It is, however, possible to set the Board Areato match the
engraver/miller to be used.  This is particularly useful if making a lot of small circuits so that they
may be “fitted onto” the maximum machining area available. 

Plotting device:This section allows the engraver type to be selected.  

The layout and plotting device chosen can be saved in a setup file using Setup> Save Setupor
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Setup> Set As Default.  (See Setups and Customisationpage 42.)

Output - Step 2
When you are ready to output, choose File > Make PCB.The Make PCBdialog box will open.
Check the parameters and options detailed below.

.

Production Method
Solder side only:This option allows only the solder side tracks to be machined.  It is the default
option and should always be set for single sided boards.

Component side only:This option allows only the component side tracks to be machined.  

Double sided board:This is the standard option for double sided boards. The process initially
machines the solder side of the circuit.  User prompts then ask for the board to be turned over
(flipped left/right).  This must be done very accurately to be successful.  The software assumes that
the physical PCB is exactly the same size as the Board Area.  (To ensure accurate flipping it may
be convenient to fix a piece of waste material to the front left corner of the bed, and to machine an
internal corner in it.  Depending on the machine type, to work correctly, either the machine’s X/Y
origin (Home) is re-set to this corner, or the tool set point must be set to this point as appropriate.)

Laminated board:This is an alternative method of double sided board production.  It involves
machining two single sided boards then fitting them together back to back.  (TechSoft’s special thin
(0.8mm) board is ideal for this purpose.)  This sounds difficult, but is probably easier to achieve
than the standard method as it does not require any accurate lining up when machining.  Although
the normal soldering operations should hold the two boards together, it may be a good idea to put
in some dummy pads in the corners of the board and to solder some wire through these first.  The
board can then be handled more easily.

Full copper removal:This will engrave away all the copper except the tracks, rather than simply
outlining the tracks.  This is far slower and is rarely necessary from a practical point of view.
However it may be useful for producing a ‘cosmetically’ correct board.
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Pens/Tools 
This is the most important of the output settings dialog boxes for day to day use.  It is where most
settings to do with control are found, such things as speeds, depths, offsets, etc. 

The default setting uses an engraving tool to engrave the tracks and ‘centre spot’ the holes.  If you
wish to cut out the board (Board Profilelayer) tick the Slot Drill box and check that the settings
match your tool and board.  If you wish to drill, tick the appropriate drill boxes.  Note, the default
drill sizes in this dialog box match the standard size pads in PCB Design.  If you have used Custom
sizes you may need to edit the drill table.  Most of the settings in this box are self explanatory, with
just a couple of points worthy of special mention.

Tool diameter: If the engraving tool followed the exact edge of, say, a track, then it would cut into
the track by the radius of the cutter.  If it was a thin track, this could leave no track at all!  The soft-
ware actually engraves around the track offset by half the tool diameter value.  As a tapered cutter
is used, the diameter will change with the depth.  Thus, if engraving deeper than normal for some
reason, the diameter value should be increased.

The default values should work fine, but bear in mind that they have been set to ‘safe’ values.  With
some experience you should be able to increase the feed rates significantly.

Connection
The Connectionmay be Direct to port, or Via Generic / Text Only Printer driver.  By default, con-
nection is set to Direct to port.  In this mode all data is transmitted directly to the plotting device.
This is the simplest option to set up, but will cause the computer to be tied up until output is com-
pleted.  The Via Generic / Text Only Printer driveroption makes use of the Windows print buffer-
ing capabilities.  The Generic / Text Onlyprinter driver is a neutral printer driver which allows plot-
ter commands to pass directly through it.  It therefore allows direct control of the plotting device,
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whilst maintaining the advantages of the windows background printing and queueing facilities.
Before using this option, however, the Generic / Text Onlydriver must be loaded and set as the cur-
rent printer driver.  The Generic / Text Onlyprinter driver is installed from Windows using Start >
Settings> Printers> Add Printer... Manufacturer“Generic”.  The driver itself is supplied on the
Windows installation discs.  The Generic / Text Only printer driver’s setup should have the
appropriate output port set and also: Paper size - A4, Paper feed - Continuous, No Page
break.   If using a serial connection (eg.,. COM1, COM2), the printer driver’s protocol should
normally be set to 9600 baud, 8 data bits, 1 stop bit, No parity, Hardware flow control.

N.B.  If you wish to change the Connectionpermanently, the appropriate changes should be made,
and then the setup saved using Setup> Set As Defaultor Setup> Save Setup.

Output - Step 3
When all parameters have been checked, click on OK in the Make PCBdialog box.  There will be a
pause whilst the computer calculates the tool path.  This is normally just a few seconds, but with a
slow computer and a complex circuit it could take some while - don’t panic, be patient!  (Once the
tool path has been calculated it will be stored with the circuit, so repeat tool path generation will be
instant.)  Only objects on the Solder Side, Component Side, Both Sidesand/or Board Profilelayers
will be included in the toolpath.  (The Board Profilelayer is normally used to show the outline of
the PCB, slots, mounting holes, etc.)

The drawing screen will change to show the toolpath and you will be asked ‘Plot (whichever) side
now?’ Check that your machine, material and tools have been set ready to go then choose Yes.

Machine preparation and what happens next depends on the machine being used, for -

CAMM 2 refer to page 37.
CAMM 3 / MDX-500 refer to page 37.
MODELA MDX-3 refer to page 38.
MODELA MDX-15/20 refer to page 39.
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CAMM 2
Ensure that each tool to be used has been set up and datumed (see below).  Follow the on screen
instructions carefully to completion of the machining process.

Tool setting and datuming
Before proceeding, ensure that you have sufficient top collets for all the tools you intend to use
(Extra top collets are available directly from TechSoft).  With the material stuck to the machine
bed, move the cutter head over the material, then lower the cutting head to the Z0 position.  Fit
each tool to be used in turn, lowering it until it rests on the work before attaching a top collet.
Remove each tool, with its top collet still attached so that each may be quickly re-fitted when need-
ed.  If you do a lot of PCB work the tools can be stored like this between jobs.  

CAMM 3 / MDX-500
Ensure that each tool to be used has been set up and datumed (see below).  Follow the on screen
instructions carefully to completion of the machining process.

Tool setting and datuming
As the CAMM 3 and MDX-500 do not have an indexable collet system as standard, some thought
needs to be put into the practicalities of tool changing, if multi-tool operations are to be carried out.
TechSoft recommend the use of tools and collets as used with the Roland Modela MDX-15 (see the
TechSoft Price List for further details).  These collets have a 6mm shank and can easily be inserted
into the standard CAMM 3/MDX-500 collet.  The procedure is as follows:

Fit a Modela collet into the CAMM 3/MDX-500 and push it up tight to the bottom of the machine
collet.  Fit an engraving tool into the Modela collet with as little stickout as possible.  Move the
material under the tool and lower the cutter head to allow sufficient clearance between the bottom
of the Modela collet and the workpiece for the stickout of the longest tool to be used (usually about
30mm).  Set the Z0 position on the machine at this point, (key strokes vary on different models, see
your machine’s User Manual for details).  

Loosen the screw in the Modela collet and lower the tool onto the surface of the material, then re-
tighten the screw.  Raise the cutter head and remove the Modela collet with the tool still fixed to it.
Repeat this operation for all other tools to be used,(but now lowering the head to the same Z0
each time). If you do a lot of PCB work the tools can be stored like this between jobs.  

Set the tool change position in the PCB Engrave Setupdialog box (see page 35), to be far enough
above the board in Z (say 75-100mm) to ensure that tools can easily be removed and replaced.
When subsequently changing tools ensure that the Modela collet is pushed up tight to the bottom of
the machine collet as it is tightened.  
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MODELA MDX-3 
Ensure that each tool to be used has been setup and datumed (see below).  Follow the on screen
instructions carefully to completion of the machining process.

Tool setting and datuming
Before proceeding, ensure that you have sufficient top collets for all the tools you intend to use
(Extra top collets are available directly from TechSoft).  As the Modela has a large vertical (Z axis)
travel, a built-up bed is necessary to avoid excessive tool stick out which will lead to vibration.  A
suitable bed can be made from layers of MDF, with a plastic top sheet (eg., ABS or acrylic).  This
can be assembled and stuck to the existing bed with double sided tape.  The new bed should be
about 30-35mm thick. 

The standard method of zeroing tools with Modela (jogging the tool down to touch the work) is not
sufficiently accurate for PCB work and does not allow for tool changing.  TechSoft have therefore
developed a more sophisticated method using software control.  

Stick a piece of PCB material to the machine bed.  Remove any tools from the Modela and switch
it on.  Press [VIEW] so that the machine head moves to the front LH corner and the VIEW light is
off.  With a PCB drawing on screen, proceed to maunfacture as normal.  Before the actual machin-
ing takes place the following dialog box will open.

Click on Move to tool set point.  Once the machine has finished moving, check that it is a suitable
position for fitting tools, if not change the tool set point values accordingly and click Move to tool
set pointagain.  When you are happy with the position, fit each tool in turn lowering it until it rests
on the work before fitting the collet.  Remove each tool, with its collet still attached so that each
may be quickly re-fitted when needed.  If you do a lot of PCB work the tools can be stored like this
between jobs.  Once all the tools are set, return to the computer and either click Make PCB, or
Cancelas appropriate.  Once the tooling has been set successfully, use Setup> Save Setup or Set
As Default.  The Tool Set Pointwill then be saved with the setup and will in future only need to be
checked on the way to outputting.  (See Setups and Customisationpage 42.)  
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MODELA MDX-15 / 20
Ensure that each tool to be used has been setup and datumed (see below).  Follow the on screen
instructions carefully to completion of the machining process.

Tool setting and datuming
Before proceeding, ensure that you have sufficient top collets for all the tools you intend to use
(Extra top collets are available directly from TechSoft).  As the Modela has a large vertical (Z axis)
travel, the cutter head must be set to the lowest position to avoid excessive tool stick out.

The standard method of zeroing tools with Modela (jogging the tool down to touch the work) is not
sufficiently accurate for PCB work and does not allow for tool changing.  TechSoft have therefore
developed a more sophisticated method using software control.  

Stick a piece of PCB material to the machine bed.  Remove any tools from the Modela and switch
it on.  Fit the tool setup override, then press [VIEW] so that the machine head moves to the front
LH corner and the VIEW light is off.  With a PCB drawing on screen, proceed to manufacture as
normal.  Before the actual machining takes place the following dialog box will open.

Click on Move to tool set point.  Check that it moves to a suitable position for fitting tools (the cut-
ter head 25-30mm from the bed).  If not, change the tool set point values accordingly and click
Move to tool set pointagain.  When you are happy with the position, click on the Raise Tool button.
The cutter head will move to its maximum vertical position.  Fit an engraving tool into a TechSoft
collet, such that the stickout is minimal.  Click on Move to tool set pointagain to move the cutter
head back down.  Loosen the collet screw to drop the tool onto the work surface, then re-tighten the
screw.  If multiple tools are to be used, raise the tool head and remove the tool with its collet
attached, fit the next tool and repeat the procedure until all tools have been datumed on the work
surface.  If you do a lot of PCB work the tools should be stored like this between jobs.  Once all
the tools are set, remove the tool setup override, fit the cover, then return to the computer and either
click Make PCB, or Cancelas appropriate.  Once the tooling has been set successfully, use Setup>
Save Setup or Set As Default.  The Tool Set Point will then be saved with the setup and will in
future only need to be checked on the way to outputting.  (See Setups and Customisationpage 42.) 
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ENGRAVING HINTS AND TIPS
PCB board is normally available in two grades, FR2 and FR4.  FR2 board uses a paper substrate,
FR4 board uses a glass fibre substrate.  In practice, for most circuits, there is little to choose
between them, though the FR4 board is ultimately stronger and more durable.  However, the FR2
board is far less abrasive when machined, and is strongly recommended to preserve tool life.

Engraving tools are available with H.S.S. (high speed steel), or carbide tips.  Due to the abrasive
nature of PCB board, TechSoft only recommend the use of carbide tools.  Some Roland machines
have an engraving tool supplied with them by the manufacturer.  These tools are normally H.S.S.

TechSoft can supply both PCB materials and replacement cutters.  The standard vee point engrav-
ing tool supplied by TechSoft has a 40 degree included angle with the tip ground to a flat, produc-
ing an effective tip radius of 0.1mm.

When an engraving tool is fitted to a machine, the normal manufacturing tolerances of both
machines and tools, may cause the tool to rotate very slightly off centre (normally no more than a
few hundredths of a millimetre).  Because of the nature of the cutter geometry this may cause the
cutter to rub, and rather than cut cleanly, a ragged cut or poor finish may result.  This is normally
remedied as follows:

When first using a new tool, arrange to take a small test cut (just a single short track should do).  If
the cut is not clean, turn the tool through 90 degrees in the machine spindle and try again.  Repeat
until the cleanest cut is obtained.  Mark the position of the tool so that when it is re-inserted, it can
be lined up correctly.  A simple way of doing this is illustrated below for the CAMM 2.  Users of
other machines will be able to adapt this method to their own requirements.

A marker pen has been used to draw a line on the top of the machine spindle.  A corresponding line
has been drawn on the tool top collet.  When the tool is inserted, the marks are simply lined up.

Soldering onto Engraved Tracks
This should not prove a problem as long as fine tipped pointed soldering irons are used with fine
(22swg) solder.   If this is the case bridging is unlikely to occur as the solder will not readily jump
the vee groove created when engraving.

Page 40 DESIGN TOOLS - PCB Design & Make



8  COMBINING DESIGNS
Drawings are normally loaded and saved using the standard Windows filing system options File >
Open/Save/Save As.When a drawing is saved all the settings in Setup> Drawing, eg., layout, ori-
gin, etc., are saved with it.  When a drawing is loaded via File > Open, its settings are loaded with
it. 

PCB designs are often quite small and considerable savings in time and materials can be made if
several layouts are combined together to be printed/plotted/manufactured simultaneously.  This can
easily be achieved as follows.  

Designs are created and saved as normal.  Load one file as normal, or start a new PCB Design file.
Set the appropriate Board Areausing Setup> Drawing > Layout, then load each additional design
in turn using File > Add.  Once added, designs can be moved around the screen to obtain the ‘best
fit’ prior to outputting.  Files ‘added’ to a drawing do not change any drawing settings.

9  LINKS WITH OTHER SOFTWARE
For users who wish to autoroute circuits, or who wish to have the ability to produce PCB’s from
Crocodile Clips schematics, TechSoft have developed a link with PCB Wizard. 

Having created your layout in PCB Wizard (Version 2.5 or later) choose File > Make > Output to
CAD/CAM.  This will transfer the data to the Windows clipboard.  Start PCB Design/Make, and
choose Edit > Paste. N.B. Only the Solder Side, Component Side and Both Sides layers are trans-
ferred.

Once transferred, PCB Wizard designs can be treated in exactly the same way as designs created in
PCB Design.  

Importing Drawings
Drawing data, including commercial clipart, can be imported into PCB Design.  A variety of for-
mats will be accepted, eg.,dtd (Design Tools drawings), wmf (Windows metafile), dxf (Data
Exchange format),etc.  (N.B. PCB Design will only accept vector data, eg., lines, arcs, etc.  It will
not accept bitmap (raster) data.  Formats such as WMF can hold both vector and bitmap data.
When loading these type of files the bitmap data will be ignored.) 

The data can be imported using File > Import.  Alternatively, in the other application,Copythe
drawing to the clipboard then in PCB design use Edit > Pasteto import the drawing.
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10  SETUPS AND CUSTOMISATION
It is easy to reconfigure the user interface to suit individual requirements or preferences.  All the
options under Setupare saved in a setup file. These options allow a great deal of choice over both
the layout, and the look and feel of PCB Design.    

Using Setup > Drawing, it is possible to set the output device type, the size of the drawing area, the
units to be used, etc.

Using Setup > Customise,it is possible to remove items in the display, eg., the Layer button, indi-
vidual coordinate displays, etc., thus simplifying it.  It is possible to change the method of opera-
tion, eg., change the method of selecting the pull out toolbar from hold and slide, to a simple pick.
It is also possible to customise the menu.  Any menu item (and its associated icon) may be toggled
on/off, etc.

Using Setup > Plotting Devicesit is possible to setup the current tooling options, etc., for milling
systems and vinyl cutters.

Thus, using setups, it is possible to tailor your software to your exact requirements as a ‘turn on
and go’ system, with no need to make any further system changes as you work.  Several named
setup files may be saved so that individual users may have their own named setups, or setups may
be created to suit different projects or machine output types. 

To save a setup choose Setup > Save Setup.  Removing the tick from the Save Setup Options dialog
box will ensure that the Save Setupoption is automatically removed from the saved setup.  This
will prevent users of such setups from saving new setups and possibly overwriting existing setups.
This may be of particular interest to educational users.

It is, of course, possible to manually remove theSetup> Load Setupoption using menu customisa-
tion.  Again this may be of interest to educational users.  However, if such a setup is saved as the
default setup (see below), it will be impossible to change setups in the conventional way.  The only
way back to the standard configuration then is via Help > Restore Factory Defaults.

By selecting Setup > Save as Default, the current setup may be saved as the default, so that on sub-
sequently re-loading the software, it will automatically come back set up exactly as you wish. 

When a drawing is saved, all the settings available under Setup> Drawing (and the current plotting
device settings chosen in Setup> Drawing > Layout), together with all the current settings such as
pad size, track width, text height, etc., are saved with the drawing.  When the drawing is loaded
normally using File > Open, all the settings saved with the drawing are restored.  If you wish to
load a drawing without changing the current settings, use File > Add.
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