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Imagine an ideal world where you can create completely new fonts 
without ever drawing a thing. Picture yourself in this “Font Utopia,” 
creating new weights of your font, new small caps versions, and new 
oblique typefaces—without drawing a line, placing a point, or 
manipulating a curve. Does the very concept sound so far-fetched as to 
be beyond belief? Well, it’s not...because Fontographer lets you create 
completely new fonts by modifying your existing fonts. 

Why would you want to modify a font instead of buying a new one? 
The answer is simple: You’ve invested a lot of money in the typefaces 
you own. Although many talented people create their own from 
scratch, the easiest way to create a completely new typeface is by 
modifying the fonts you already have. Fontographer makes it so easy 
to modify your existing typefaces, that you practically don’t even have 
to think about it. So, if you don’t have to think about it...what’s the 
point of this section? This section gives you some quick ways to make 
modifications. Hopefully, it will encourage you to create some 
outstanding typefaces of your own.

Steps to modifying your font



1. Open a font.

2. Modify it; for example, you can simply change the weight.

3. Save the file (Optional).

4. Generate an installable font.

5. Install the font.

6. Put it to work!

Opening a font
You start Macromedia Fontographer the same way you start other 
applications—by double-clicking the program icon. In a few seconds, 
Fontographer’s About box appears. Choose “Open Font” from the File 
menu to open one of the fonts in your System, a folder, a file server, or 
a disk (or you can use one of the fonts provided in the Sample Fonts 
folder).

The standard file selection dialog works in the normal fashion, so you 
can change drives or directories, open a file, or cancel. You can also 
specify which types of font file formats you want to display. On the 
Macintosh you can eject disks as well. 

Once the selection dialog is open, you can select a font file by clicking 
on its name and then “Open,” or simply by double-clicking on its 
name.

One or more progress dialogs will appear before Fontographer 
displays the Font Window. To cancel progress dialogs, type 
Command-period on the Macintosh, or Esc on the PC. 



Changing the character’s weight
You can quickly create a heavier or lighter version of your character 
(or the entire font) by using Fontographer’s Change Weight command.

To change weight:

1. Go to the Font Window and double-click on the “v” to open it.

2. Choose “Change Weight” from the Element menu.

The “Change Weight” dialog appears.

3. Enter “30” in the “Change by” text edit box and click “OK.”

Fontographer increases the weight of the “v” by 30 em units. 

Fontographer also gives you the option of changing the weight of your 
character (or entire font) without affecting the vertical or horizontal 
size of the character.

Go back to the “v” and select “Undo Change Weight” from the Edit 
menu to undo the changes you performed in the last exercise. Repeat 
the exercise above, but check the “Don’t change vertical size” option 
before you click “OK.”

Look at the difference in the two options. You can try the option with 
the “Don’t change horizontal size” option next.

Now try the exercise with both options checked.



You can now apply the desired weight to the entire font, or just 
selected characters. From the Font Window, use the pointer tool to 
click and Shift-click on the desired characters. (You can choose them 
all by choosing “Select All” from the Edit Menu.) Then repeat the 
procedure above to apply the selected changes to the desired 
characters.

Naming your font
You can name your font by choosing “Font Info” (-General on the PC) 
from the Element menu. The Font Information dialog appears. For this 
exercise, name your font something simple like “Garamond-Fat.” 
(Don’t forget the hyphen before the Style Name.) For more 
information about naming your font, refer to the section “The menu 
name” in Chapter 7, “Generating and Exporting Fonts.”

If you want to use a custom style name, be sure to let Fontographer 
assign a standard style name first and then re-assign your custom 
name. So, if you want to call your bold-italic version of a font “fat 
slanted,” use the pull-down menu and select “bold italic” first, then 
change the style name to “fat slanted.” 

This will allow Fontographer to recognize and assign the proper style 
to your custom name. 

Be sure to name your font before you save your database file and 
generate a font. Otherwise your fonts will end up with unusable names 
like “Untitled.ttf”  (for a TrueType font), and you’ll have to start over.



Saving your work
You save Fontographer database files via the Save or Save As 
commands in the File menu. The database file is where Fontographer 
stores all the parts needed to construct any font. Just like you save 

documents in Microsoft® Word, or graphics in Macromedia® 
FreeHand™, the database is where you save your fonts in 
Fontographer.

The standard file saving dialog appears. You can name your databases 
anything you like, because there’s no relationship between the name of 
the actual font you’ll use in your programs and the name of the 
database itself.

1. Choose “Save as” from the File menu.

Macintosh users have the option of creating and naming a new folder 
to store a font in. You can save your font directly to another folder, 
drive, or directory on all platforms.

2. Type in “MyFatFont.”

PC users will note that Fontographer automatically gives you the 
name “MyFatFon.fog” if you also named it “MyFatFont” in Font 
Info.

Generating your font
After you save the file, it’s time to generate an installable font. You 
will have to do this if you want to use the font in another application 
besides Fontographer.

Fonts are composed of different files which you will need to install 
before you can use the font. For more about installing fonts, refer to 
Chapter 9, “Installing and Removing Fonts.”

1. Choose “Generate Font Files” from the File menu.

The Generate Font Files dialog offers a number of options (including 
the ability to generate fonts for several computer platforms), but for 
the purposes of this exercise you’ll use the Easy mode. Choose the 
computer you’re generating fonts for and select TrueType for the 
Format. We’ve typed some commonly used bitmap sizes in our 
example and you can do the same. However, bitmaps are only 



necessary if you’ll be using a PostScript font on the Macintosh.

The Set Folder/Directory button gives you the option of generating 
your fonts directly into a specific folder. This saves you the extra 
step of moving files into folders later.

The Overwrite existing files option lets you replace an existing file 
(that has the same name) with a new file. If you don’t choose this 
option (and have a font with the same name), Fontographer will 
create a new font with the same name followed by a bullet (•), on the 
Macintosh, or a dollar sign ($) on the PC.

Installing the font
Since installing fonts is different depending on the platform and 
operating system you’re using, we can’t really cover this in a quick 
“how-to” here. If you need more information about installing fonts, 
refer to Chapter 9 or your System’s User’s Manual.

Using the font
Once you’ve installed the font, go to the application of your choice, 
type some text, and select your font (just like you would any other 
font) from the Font menu.

Creating an oblique font
By using Fontographer’s Skew feature, you can create your own 
oblique font. You can consider this an easy way to make an oblique 



typeface. Actually, it’s sort of like cheating since an oblique font is 
just a right-slanted version of a Roman typeface; a true italic typeface 
has redesigned characters that compliment the face. But, skewing is a 
really easy way to create a new typeface that can add emphasis to your 
text.

Again, Fontographer allows you to skew one, several, or all characters 
at once. As in our previous example, we recommend that you try out 
your modifications on one character before you apply the 
transformation to the entire font.

Follow the steps given in the “Change Weight” exercise to open your 
font.

To skew a character:

1. Go to the Font Window and double-click on the character “k” to 
open it.

2. Choose “Transform” from the Element menu.

3. Drag down in the “First transformation” pop-up menu until you’ve 
selected the Skew option and made sure the other pop-up menus 
say: “Do nothing.”

Fontographer defaults to a horizontal skew value of -12 degrees (the 
appropriate angle for an oblique font, depending on who you ask).

4. Click the Transform button, and Fontographer skews the “k.”

Fontographer gives you the option of applying other transformations at 
the same time you skew the character. 

To apply more than one transformation:

1. Double-click on the “k” and select “Undo Transform” from the Edit 
menu to undo your last move.

2. Select “Skew” from the Transform dialog and enter -12 degrees 
Horizontal (leave Vertical at 0).



3. Then select “Scale” and enter “80” in the Horizontal text box.

4. Select “Basepoint” from the Center Transformations around 
pop-up menu.

5. Click “Transform.”

Fontographer skews and condenses the “k” at the same time.

Try some of the other transformation options to see what effects they 
have on your character. 

Once you’ve finished trying out all the options, you can apply the 
transformation to several characters or the entire font, by selecting 
groups of characters in the Font Window.

Skewing multiple characters

You can skew, scale, flip, or move either a single character or a range 
of characters. Select more than one character in the Font Window by 
holding down the Shift key while clicking on characters. Select a 
range of characters by dragging through the characters. In this way you 
can apply transformations to one, several, or all characters.

Creating a fraction using composite characters



Have you ever checked out how many fractions are in your font? If 
you have, you know that most commercial fonts have a small number 
of fractions, if any. Historically, if you wanted to type the fraction 3/8, 
you had to type the 3, the forward slash, and the 8, and even then the 
fraction didn’t look so hot! Fontographer makes it extremely easy to 
add composite characters made up of more than one character 
combined in a single character slot to your font. So you can now have 
traditional fractions in all your fonts!

To create a fraction:

1. Go to the Font Window and double-click on the “3” to open it.

2. Click on the “8” character slot in the Font Window (it’s not 
necessary to open the Outline Window to copy the character) and 
then select “Copy Reference” from the Edit menu.

3. Click on the “3” Outline Window and choose “Paste” from the Edit 
menu.

Fontographer pastes the number “8” on top of the “3.”

4. Select everything in the Outline Window by choosing “Select All” 
from the Edit menu.

5. Go to the Transform menu, select “Scale Uniformly” as your first 
transformation, enter 60%, and make sure all the other 
transformation pop-ups say “Do nothing.”

Fontographer scales both characters to 60% of their original size.

6. Position your pointer away from the characters, and click on 
nothing to deselect everything (or simply press the tab key, which 
always deselects everything). Then click the mouse on the outline 
of the “8.”

A box will appear around the number “8” (this represents the 
composite character’s bounding box). Composite characters do not 
show the points you normally see. (You cannot edit points in a 
composite character unless you first choose “Unlink Reference.”)



7. Drag the box containing the “8” toward the lower right-hand 
corner. 

8. Double-click on the path or on any point on the number “3” to 
select all of it, and then move the “3” toward the top left corner.

You can create the divisor line by copying the forward slash into 
your character. You can also draw the divisor line if you prefer. 
However, it is often much easier to use existing characters to create 
parts.

9. Select the forward-slash character in the Font Window.

10. Choose “Copy” from the Edit menu.

11. Paste the forward-slash character into the “3” character slot.

To change a reference character:

1. Open the Outline Window for the actual character “8.”  

2. Modify some part of it.

You’ll see any changes you make to the original eight reflect in the 
denominator you created in your fraction character.

Unlinking a reference character

Fontographer also lets you remove the link from any composite 
character. This gives you access to the points in the character as well 
as removing the link to the original character.

To unlink a reference character:

1. Click on the fraction you created (in the “3” character slot).

2. Choose “Unlink Reference” from the Edit menu. 

As you can see in our illustration, the character’s points are now 
visible and you can move them individually, or together as a group.



Creating a ligature

A ligature is a character made up of one or more characters. Most 
commercial fonts have some commonly used ligatures like “æ,” and 
“œ.” However, Fontographer makes it easy to create ligatures of your 
own without drawing a thing.

To create a ligature:

1. Open the Outline Window for the “f.”

2. Choose “Select All” and then choose “Duplicate” to create another 
“f.” 

3. Move the new “f” to the right.

4. Go back to the Font Window.

5. Copy the “l” into the same window using the “Copy Reference” 
command from the Edit menu.

6. Move the referenced “l” to the right of the second “f.”

7. Choose “Unlink Reference” from the Edit menu.

8. Choose “Remove Overlap” from the Element menu.

Changing the character width
You probably noticed the vertical line that runs through the second 
“f.” This is the character width line. Width is a moveable vertical line 
which specifies the width of each character. (Width is covered in more 
detail in Chapter 5.) When you print a line of text, the origin line of 
the next character is placed on top of the width line of the current 
character. Since you changed the contents of this particular Outline 



Window, it’s important that you change the width as well. 

To change the character’s width:

1. Make sure you still have the Outline Window for the “f” open. 

2. You can choose “Preview” and turn off Show Points from the View 
menu to get a better look at the character if you like.

3. Move the width line with the selection pointer.

That’s all there is to it! So, if your font doesn’t contain the ligature you 
want, you now know how to create your own with Fontographer.

In some word processing and page layout programs you can set the 
preferences to automatically substitute curly quotes for straight ones, 
or the fl ligature if you type “fl.” For the substitutions to occur, you’ll 
need to be sure to use an Adobe encoded font.

Creating a condensed character or font
Fontographer has the ability to modify character images to produce 
interesting special effects. You can create these effects in either the 
Outline Window (on one particular character) or the Font Window (on 
the whole font). For example, you can create an oblique font by 
selecting all the characters in the Font Window and skewing them -12 
degrees (like we did in the earlier exercise “To skew a character”). Or 
you can create an extended font, by increasing the horizontal scaling 
factor of the font. Your options are limitless.

You can also create a condensed font by scaling the character 80% 
horizontally. Condensed versions of a font are the same height as their 
counterparts, but are narrower to fit into a more compact space. 

To create a condensed character:

1. Click on the Font Window to make it active, and then press and 
hold the mouse button while you drag through the characters “a” 
through “e.”

2. Choose “Transform” from the Element menu.

The Transform dialog appears.



As you can see from the screen shots on this page, Fontographer scales 
the characters horizontally without changing their height.



Setting the basepoint
The baseline is the line upon which the letters sit. The baseline 
position is always at a vertical location of zero. The dot at the 
intersection of the origin line and baseline is the basepoint.

The basepoint is used to accurately and quickly align points and 
characters. The basepoint is generally at the character’s origin (where 
the origin line and the baseline intersect at 0,0); but, you can position 
the basepoint anywhere. Fontographer allows you to set each 
character’s basepoint differently. It can be moved as needed by 
selecting the pointer tool and dragging it to a new location, or by 
entering a specific horizontal and vertical location.

For precise numeric entry, choose “Set Basepoint” from the Points 
menu. To reset the basepoint back to the origin point, choose “Reset 
Basepoint” from the Points menu.

If you select one point and choose “Set Basepoint,” Fontographer will 
move the basepoint to that point. However, if you select more than one 
point, Fontographer will set the basepoint to the center of selection. 

In the position display in the Outline Window, distance from the 
basepoint is continuously updated as the pointer moves within the 
drawing area. This on-screen measuring tool makes it easy to measure 
character parts. Just place the basepoint on a reference point of the 
character and watch the position display as you move the pointer. 



Horizontal or vertical alignment of points is very easy to check; set a 
basepoint on one point then drag the other until the horizontal or 
vertical delta is zero.


