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Welcome to the world of TK-850. 
This document described as part of the TK-850/SG2A evaluation kit using 
sample programs. 

 

 

 

 

 

 

 

 

 

TK-850/SG2A Evaluation Kit  

Tutorial Guide  

Date published April. 2008 (1st Edition) 
 

© NEC Electronics Corporation 2008 



 Introduction 
Target Readers This document is intended for users who will use for the first time the V850TM series development tools. 

A basic knowledge of microcomputers, C language, assembles, and WindowsTM operating is 

assumed. 

 

Purpose This document is designed to give readers an understanding of the basic operation methods for the 

V850 Series development tools provided with the TK-850/SG2A evaluation kit. 

Readers will be able to further their understanding by actually using the development tool while reading 

this document. 

 

How to Use this Manual   This PDF file should be read with AdobeTM AcrobatTM Reader 5.0 or later.  

 

Organization         This manual consists of the following contents. 

 

CHAPTER1  PREPARATIONS

->This chapter provides an outline of the V850 series development tools used in this guide and 

describes the sample program installation method. 

CHAPTER2  PRACTICALS 

->This chapter allows the reader to experience the basic operations of PM + and the monitor-version 

integrated debugger using sample programs.  

CHAPTER3 OTHER

->This chapter describes how to create a new PM + workspace (project), how to use the monitor 

program, and gives an outline of the sample programs. 

                       

 

Cautions       -This contents of this document are subject to change without prior notice. 

      -No part of this document may be reproduced without the prior written permission of NEC Electronics 

Corporation. 

                       -NEC Electronics Corporation does not make any guarantees nor does if grant any license regarding 

intellectual property rights or any other right of NEC Electronics Corporation or third parties pertaining to 

the use of the products and the use of the information described in this document. NEC Electronics 

Corporation shall not be held liable for problems related to the rights of third parties that arise from the 

above uses. 

-The circuits, software, and appurtenant information described in this document is provided solely for the 

sake of semiconductor device operation examples or application examples. Therefore, in case these 

circuits, software, and/or information items are to be used for a customer’s equipment, the design of 

said equipment shall be the responsibility of the customer. NEC Electronics Corporation declines any 

and all responsibility for damages arising from the use of such circuits, software, and/or information by 

a customer of a third party. 
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Trademark Microsoft and Windows are either registered trademarks or trademarks of Microsoft Corporation in the 

United States and/or other countries. 

Adobe and Acrobat are trademarks of Adobe Systems Incorporated (Adobe System Incorporated). 

Other company names and product names that appear in this document are the registered trademarks or 

trademarks of their respective companies. 

 

 



 CHAPTER1 PREPARATIONS 

This chapter provides an outline of the development tools used in this document and describes how to install the sample 

programs. 

The sample program function only for the development tools listed as included in the TK-850/SG2A evaluation kit in this 

document. 
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 Used development tools 

This section outlines the development tools used in this document. 
The name of the development tools and their main function are as follows. 

 
- Device file DF703283 V2.11 

Since the device file contains the device-specific information, this file is required for using the development tools. 

The sample used in this document has been created as a V850ES/SG2A program. 

 
- Integrated development environment PM + V6.11 

This is an integrated development environment platform that operates on Windows. 

An editor with an idea processor function is provided as the Edit window, allowing efficient development linked with 

development tools such as a compiler and a debugger. 

 
- C compiler package CA850 W3.10 (Size restriction Version) 

This product generates execution code that can be executed in the V850 Series from C source programs and 

assembler source programs. 

CA850 W3.10 in software development tools are put restrictions on object size (to 128Kbyte).  

If you already have release to manufacture (V version), please don’t install CA850 in this product. 

 
- Monitor-version integrated debugger ID850-TK V1.04 

This is Windows-based software that runs on a host PC. 

It is integrated debugger that achieves debug at source level C. 

Source debug of the reference, the change in the variable, and the step execution, etc. by such source line can be 

done easily and efficiently. 

 
- Program for writing to on-chip flash memory of microcontroller PG-FPL 

This a Window-based software used to write programs to the on-chip flash memory of a microcontroller. 

It is possible to write/delete it to a built-in flash memory of TK-850/SG2A by connecting TK-850/SG2A with the PC 

with an attached USB cable. 

 

 

The above-listed development tools must be installed in order to operate the sample programs described in this document. For 

the installation method, refer to the “TK-850/SG2A User’s Manual Software version ”(¥DOC¥TK850¥TK-850SG2A_SW_E.pdf). 

Also refer to the TK-850/SG2A User’s Manual for the restrictions on the development tools. 

The documentation assumes that the name of the installation destination folder is “C:¥Program Files¥NEC Electronics Tools”. 
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 Sample environment 
 
This section describes the preparations for the sample programs used in this document. The preparations consist of installing the 

sample programs in the customer’s environment. 

To uninstall the sample programs, delete the folder that was specified as the installation destination. 

The installation method and the installation destination are described below. 
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CHAPTER 1  PREPARATIONS 

- Installing the sample programs 

Insert the CD-ROM disk provided as part of the TK-850/SG2A evaluation kit in the CD-ROM drive. The [NEC Electronics 

Microprocessor Development Tools Setup] screen automatically appears. (If this screen does not appear automatically, 

start setup. exe from Explorer. etc.) 

Press the Sample Program button to start the WWW browser, and then click the [TK-850 Sample Programs] link. 

   

 
When [TK-850/SG2A Sample Program ] is clicked, the following download confirmation window appears. 

 

The WWW browser 
start up. 

Click the [TK-850/SG2A Sample 

k. you can also downloard the Program] lin

[Tutorial Guide]. 

Press the Save button. 
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After specifying the download destination folder, press the Save button. The self-extraction sample program set 

(TK850.exe) is copied to the specified folder. When TK850.exe file is executed, the “TK850” folder is created. Also, a folder 

containing the various sample programs are created below  
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- Folder structure of sample programs 
When the sample program set is decompressed, the files are organized according to the following folder structure. 

 

 

 

 

 

 

 

 

 

 

 TK850 

SAMPLE_SG2A  

  SAMPLE_SG2A.prw  Workspace file 
main.c   Source file  
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 CHAPTER2 PRACTICALS 
 

This chapter lets the reader experience the operation of the completed V850ES/SG2A program using the 

monitor-version integrated debugger (ID850-TK). 

This is a program in which pressing SW2 on the CPU board of the TK-850/SG2A evaluation kit causes 

7segLED to count up, and pressing SW1 causes the counting up interval to become longer and stop. 

This chapter is designed to give an understanding of the concrete operation method of the development tools 

(PM +, ID850-TK) and the outline of the project files required when creating application programs, through 

building of sample programs and operating ID850-TK. 
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CHAPTER 2  PRACTICALS 

 

The overall flow is as follows. 

 

 

Starting integrated debugger (ID850-TK)

Executing program

Stopping program

Verifying operation

Exiting integrated debugger (ID850-TK)

Loading workspace (project)

Creating execution format

Closing PM +

Starting PM +
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 Starting PM + 

Let’s now actually use the development tools. 

First, start PM +. 

In the Windows Start menu, select [Program] -> [NEC Electronics Tools] -> [PM+ V6.11]. 

 

PM + starts up. 
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 Introduction to PM + 

In PM +, application programs and environment setting are handled as a single project, and series of actions 

such as program creation using the editor, source management, build, and debugging are managed. 

Also, one or more project files are managed together as a workspace. 

 

 

 

Menu bar 
Tool bar 

Project window 
Output window 

 

 

 

 

Project window:    A window in which project names, source files, and include files are displayed using a 

tree structure 

Output window:     A window in which the build execution status is displayed.  

 

    For details regarding menu bars and tool bars, refer to the PM + User’s Manual. 
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What is a project? 

A project is the unit in which PM + executes management, and refers to an application system 

and environment development based on PM + 

    PM + compiles project information and saves it in a “project file”, from which it is then referenced. 

 

What is a project file? 

A project file is a file to which information such as the source file to be used in the project, the 

device name, the tool options for compiling, and the editor and debugger to be used have been 

saved as “project information”. 

The file name format is “ΔΔΔΔ.prj”. 

Project files are created in folders that are set when creating new workspaces. 

 

What is a project group? 

A project group is a group comprised of a number of projects in an application system. 

The target devices of each project that can be registered to one project group must be the 

same. 

 

What is a workspace? 

A workspace is the unit used to manage all the projects or project groups required for one 

application system. 

The file names of multiple project files are saved to a workspace file for referencing. 

The file name format is “ΔΔΔΔ.prw”. 
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CHAPTER 2  PRACTICALS 

 
In this chapter, you will use an already created workspace. 

The method for creating a new workspace is described in CHAPTER3 OTHER. 

The source file name of the 7seg LED count up program and the V850ES/SG2 setting emulated with 

ID850-TK are saved to the workspace used in this chapter.  

In the PM + menu, select [File] -> [Open Workspace…] and specify “SAMPLE_SG2A.prw”. 

If you have not set an environment, refer to “Sample Environment”. 

 

 

 

Open the folder in which 

the sample program is 

located. 

Loading workspace (project) 

Click “SAMPLE_SG2A.prw” and then press the Open button. 
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CHAPTER 2  PRACTICALS 

The “SAMPLE_SG2A.prw” 

workspace file is read. 

 

 

 

 Workspace file name: SAMPLE_SG2A.prw 

 

 

 

Project group 

Project 

 

Only one “SAMPLE_SG2A” project is included in the “SAMPLE_SG2A.prw” workspace file. 

The operations described below are done in relation to this “SAMPLE_SG2A” project. 
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 Creating execution format 

Let’s create the project’s execution format. This action is called build. 

Enter press PM +’s Build button , or select [Build] -> [Build] from the menu. 

 

 

Build processing is 

executed 

 

 

 

 

Build processing has been normally completed. 
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CHAPTER 2  PRACTICALS 

 

What is build? 

Build is a function that creates an executable file, etc., from a source file registered to a project. 

PM + automatically performs compiling, assembling, linking, and other processing actions. 

On the second and subsequent build, PM + also automatically detects files that have been updated 

from the previous build processing, and complies and assembles only the relevant files, thereby 

reducing the time required for build processing. 

 

 

What is rebuild? 

Build compiles and assembles only the source files that have been updated since the previous time, 

whereas rebuild compiles and assembles all the source files. 

When setting, such as compiler options, have been changed, not build, but rebuild, must be 

selected. 
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 Verification operating 

The integrated debugger is provided as user application execution environments (debuggers) 

in the ID850-TK.  

In this document, the integrated debugger（ID850-TK）is started and the operation is checked using this 

debugger. 

 
 

What is the integrated debugger ID850-TK ? 

The integrated debugger is Windows-based software used for debugging that performs communication 

with on chip debug function interface in a development environment where the host machine and the  

target system are connected.  

Debugging can be performed either at the C source level or at the assembler level. 

It is possible in real time to execute, and to verify it by using on the chip debug function. 
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 Starting integrated debugger(ID850-TK) 

 

To use ID850-TK, it is necessary to connect TK-850/SG2A’s CPU board to the host machine with an  

USB cable, and power it on. After checking that the CPU board is powered, start ID850-TK. 

 
Select the Debug button  of PM +, or in the menu, select [Build(B)]→[Debug(D)]. 

 

 

 

If the debug button is not displayed, in the menu, select [Tool]→[Debugger Setting...]“ID850-TK V1.04 

Integrated Debugger (ID850-TK for TK-850)” 

 

 

  

 

 

ID850-TK starts, and “Configration” 

screen is displayed 
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Press the OK button. 

“Load Module File” download confirm 

message is displayed 

 

 

 

 

 

Press the YES button, and “Load Module File” download begins. 
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Compiled “Load Module File” are 

downloaded to the flash memory with 

built-in CPU 

 

When download ends normally, the 

program source is displayed. 
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Normally, if communication with the CPU, the following error messages are output. 

 

 

 

If these errors occur, check the following items. 

 

 
Verification items: 
１．The CPU board is connecting to USB port on host machine correctly? 
２．Please confirm the switch on the board is set as follows. 

 
  SW3 
 

Bit 1 ON 

Bit 2 ON  

Bit 3 ON 

Bit 4 OFF 

 
 
 
 
 

 
３．Is JP1 made 1-2 short and does power indication light LED1 light? 
４．Is the COM port number set by the COM port and "Portconfig for ID850-TK" allocated in 

TK-850/SG2A corresponding? 
 JP1 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
SW3  LED1 

 
After checking the above items, start ID850-TK again. 
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When the ID code is wrong, the following messages are displayed.  

Also, this message can be displayed at first start up.  

In that case, Please input “FFFFFFFFFFFFFFFFFFFF”[20 of F ] in “ID code”. 

 

 

 

The following "Configuration" screen is displayed when OK is pushed and input a correct ID code, please. 

 

 

 

When the ID code is forgotten, it is necessary to delete all flash memories with built-in CPU. 

 Please delete the flash memory by installing "PG-FPL" from CD of the attachment. 

 Please refer to Chapter 3 for the usage of "PG-FPL". 

 －24－



CHAPTER 2  PRACTICALS 

 

 
 
 

ID850-TK displayed the CPU core’s internal status and controls monitor program execution in the main 

window. 

The initial screen of ID850-TK is as follows. 

 

< Main window > 

 

 

 

 

 

Status bar

Menu bar 

Window display area

Tool bar 

Introduction of integrated debugger(ID850-TK) 

Select [Browse] -> [Other] -> [2 List] in the menu. Then the list of Source file is displayed. 
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Select [Browse] -> [Source Text] in the menu. Then the program Source file is displayed. 

 

 

 

 

For details about the various areas, the menu bar and the tool bar, refer to the “ID850-QB Integrated 

Debugger Operating Manual” 
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 Executing program Executing program 

Next, execute the program 

Select the ID850-TK’s restart button  , or select [Run(R)]→[Restart(R)] 

The LED count up program is executed. 
 

 

 

 

The status bar changes to red during program execution. 

Execute the program
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Next, when you pushed SW2 on the CPU board of TK-850/SG2A, 7seg LED starting count up.  

When you pushed SW1, the count up interval becomes longer and confirm the stop. 

 

 
SW1

SW2 

 

 

 

7SegLED Reset SW 

 

 

Press SW2 to start counting up of 7segLED. 

7segLED counts up to 0 -> 1 -> 2 -> …… 9 -> 0. 

 

Press SW1 to stop counting up of 7segLED. 

The count-up interval becomes longer and finally stops. 

 

 

         The above-described procedure checks that the 7seg LED count up program functions normally. 
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 Stopping program 

Stop the program. 

Press the ID850-TK’s Stop button , or in the menu, select [Run] -> [Stop]. 

 

 

 

Stop the program. 

 

When the program stops, the status bar changes back to its original color.
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 Exiting monitor-version integrated debugger (ID850-TK) 

In the ID850-TK menu, select [File] -> [Exit]. 

 

 

The Exit confirmation dialog box is 

displayed. 
 

 

 

 

Press the Yes button. The current environment is saved and then ID850-TK ends. 

ID850-TK ends without preserving a present environment if No are pushed.   
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In the PM + menu, select [File] -> [Exit PM +]. 

 

 

Closing PM + 

 

PM + ends. 
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 CHAPTER 3 OTHER 

This chapter describes how to create a new PM + workspace (project) required for debugging using the 

monitor-version integrated debugger (ID850-TK), and how to use the PG-FPL. 

 

 

 

Creating a new PM + workspace (project) 

 

 

Registering additional source files  

 

 

How to use PG-FPL 
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CHAPTER 3  OTHER 

 

 Creating a new PM + workspace (project) 
 

 

 
Create a new workspace and project. 

With PM +, a project that includes the basic items required for build can easily be created by inputting each of 

various items step by step. 

In the PM + menu, select [File] -> [New Workspace…]. 

   

<Description of items> 

Workspace File Name: 
 -> Specify the name of the workspace file that 

manages the project files. 
.prw is automatically suffixed as the file 
type. 
A project file (.prj) of the same name is 
simultaneously created. 

Folder: 
 -> Specify the folder for saving the workspace 

file by writing its absolute path. 
    This item can be selected from a reference 

dialog box by pressing the Browse… 
button. 

Project Group Name: 
 -> Specify this item if wishing to manage 

multiple projects together in function units. 
If nothing is specified, this item is the same 
as the workspace file name. 

Series Name: 
 -> Specify the series name of the device to be 

used. 

Device Name: 
 -> Specify the name of the device to be used. 

 

The dialog box for creating 

new workspace is displayed.

 

 

 

The concrete information set here is 

described on the following pages. 
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Press the Next > button. 

 

 

 

 
 Press the YES button.  

 

 

Input the workspace information settings 
as follows. 

Workspace File Name: 
 -> test 

C:¥TK850¥test 
Folder:  

->
    (Press the Browse… button.) 
 
Project Group Name: 
 -> Don’t input this item. 

Series Name: 
 -> 

Device Name: 
 -> 

 

V850 Series 

uPD70F3281Y 

Press the Detail Setting.. button. 
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Please select each tool 

version as follows. 

 

CA850  : W3.10 

ID850-TK : V1.04 

Press the OK button. 
 

 

Press the Next > button. 
 

 

Press the Next > button. 

TK-850 does not use RTOS. 
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Press the Next > button. 
 

 
 

Select the “Copy and Use the 

Sample file”. 

Select the “ 32-Register Mode”. 

Press the Next > button. 
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Press the Next > button. 

 

 

 

 

Select the “Create and Use the 

sample file” 

Press the Next > button. 
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Press the Next > button. 

 

  

 

 
Press the Finish button. 

Check the project information 

setting contents. 

Select the “ID850-TK V1.04” 
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This completes workspace and project creation. 

Additional source files can be registered at any time thereafter. 

For details, refer to “Registering additional source files”. 

 

 

Next, setup the security ID 

In the PM +, [Tool] → [Compiler common Options...] is selected. 

 

The “test” project has been 

registered. 
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The actualities of 
 "FFFFFFFFFFFFFFFFFFFF"(20 of F) 
are taken if there is no problem in the 
value of ID in security. 

Click the “Device” tab. 

 

 

 

 

Compiler Common 

Options setting is open.

Press the OK button. 

 

Security ID settings are complete. 
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 Registering additional source files 

The method for registering additional source files to a project is described below. 

The following example shows the additional registration of source files “b.c” and “c.c” with source file “a.c” already 

registered. 

Place the cursor on the source file in the Project window of PM +, and select [Add Source Files…] displayed in the 

right-click menu. 

 

 

 

 

Select source files “b.c” and “c.c” and 

then press the Open button. 

 

 Multiple source files can be selected by clicking the desired source files while pressing Ctrl key. 
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Source files “b.c” and “c.c” 
are additionally registered 

to the project. 
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How to use PG-FPL  

 

 

 

It explains the method of deleting the flash memory with built-in V850ES/SG2A by using PG-FPL. 

When security ID etc. are forgotten and ID850-TK cannot be connected, PG-FPL is used. 

PG-FPL cannot be installed from an integrated installer. Please execute and install 

 ¥FPL¥fpl_v150¥Setup.exe  

from the Explorer etc. Please refer to "PG-FPL user's manual" for details of the installation method. 

However, it is not necessary to install hardware (driver). As for TK-850/SG2A, the hardware of PG-FPL is built 

in. 

 

 

The switch of TK-850/SG2A is set as follows, and it connects it with the PC.  
    SW3 

Bit 1 ON 

Bit 2 OFF 

Bit 3 ON 

Bit 4 ON 

 
   

Please select → [Programs] → [NEC Tools32] → [PG-FPL] of the Windows start menu. 

 

The initial screen of PG-FPL 

 

  
Push the「Setup」button. 
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Push the「PRM File Read」button. 

 

 

¥PRM¥PRM70F3288_V111¥70F3281_CSI0.prm of attachment CD is selected. 

 

  

"Port" selects the COM port number where TK-850 is allocated. 

※Only the COM port number that the personal computer has is displayed in this pull- 

down menu. 

Please select as follows. 

「Speed」38400、「Frequency」5.00、「Multiply rate」4.00 

Push the  OK . 
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"Erase" The deletion of the flash memory begins when the button is pushed. 

 

  

If "chip erase finish" is displayed, the deletion of the flash memory is completed. 

Please end PG-FPL. 

 

It returns based on the set switch and completion. 

    SW3 

Bit 1 ON 

Bit 2 ON  

Bit 3 ON 

Bit 4 OFF 
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