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Introduction

The ST7 ICP is an ST7 microcontroller-based programming platform. The ICP can program all ST7 devices
manufactured by INNCOM.

Product Identification

INNCOM ST7324 IN CIRCUIT PROGRAMMER COMPOENT LIST

Version Description
02-9492 Rev 2.1 PCBA, INNCOM ST7324 ICP
62-1507 CABLE, RIBBON 10P10W DBO05 ISP—used on products with JTAG programming header. Example products:
X05, TCT, TCC
62-1515.60 CABLE, ASSY ST7 ICP W/60mm SHEATH—Example products: MCM1, 3035, S217
04-4040 REGULATED P.S. 110-240V/12VDC/1A
04-1030 RS232 SERIAL CABLE 7' DB9 (MALE) / DB9 (FEMALE)

04-6061.B PLASTIC HOUSING TCx, BOTTOM

Device Characteristics

Symbol Parameter and Conditions Min Typ. Max
ST7 ICP—Input Voltage 12vDC
ST7 ICP—Current Consumption @ 12VDC 19mA

Installing Software on PC

v Download flashbash-2.51.exe from FTP: T:\FTP\Eng_Data\Products\PC\INNCOM ST7 ICP\PC Software\Flashbash ST7 PC
Software\FlashBash 2.51

\/ Double click on execute file and follow instructions to install on hard-drive.

vy Done

Programming Methodology

The ICP can be used as a desktop device for programming a target through the PC and also can be used as an
independent standalone device. There are three possible scenarios for programming the target device: first-time
programming of the target from the PC, updating the target from the PC with revised software, and programming
the target in Key Fob mode.

Each of the three scenarios requires different steps. These major steps are outlined in separate sections throughout
this document. Use the three templates below and refer to the appropriate sections for desired functionality.
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First-time programming from the PC

This is typically done in manufacturing. There are two steps required:
e Downloading into Target
e Setting Option Bytes

Updating target software from the PC

This is performed when there is a new feature release or bug fix. This only requires one step:
¢ Downloading into Target

Programming the target in Key Fob mode

This is done by downloading target software directly into the programmer and disconnecting the device from the
PC and its power supply. At this point, the device is capable of programming both first-time and revision targets
completely independent of the PC. This only requires two steps:

e Loading the Programmer for Key Fob mode use

e Programming the target with Key Fob

Downloading into Target
(In this example, the device that is being programmed is an X05.)

‘/ Connect INNCOM ST7 ICP to serial port and
12VDC power supply.

‘/ Start FlashBash program.

V' Select View > Program Options from menu ]

igw  Programmer I Feset Dela_l,ll

Serial Port

" Comm 3
" Comm 4

ak I Cancel | Apply Help

‘/ Press the “Test” button for communication test. x|

L ] ‘: Test Passed
-

\/ Connect programming cable and power-up target.
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‘/ Select target: Micro from dropdown menu.

Refer to the option bytes section at the
end of this document for micros used by
device. Most use ST7F324BJ6.

‘/ Select Flash Tab

‘/ Load target software: File > Open... > xxxxx.s19

‘/ Write to target device: Write > Current or click
highlighted button

‘/ Reset target: Advanced > Micro Run

Skip this step if option bytes are to be set.
Reset target after setting option bytes.

‘/ Updated programming is done.

# FlashBash - [ST72F324B16] =10 x|

# FlashBash - [ST72F32466] 1ol x|

File Yiews Read Write Werify Adw ob  Help
D|==| & 5| [sT72F 328806 [Z]& ala| €|%|e I{a‘|@||
L N BJG
[ PLasH | _eeerom ST72F324BK
[ET] FF FF FF FF Fl5T72F224BKE _ | FF FF FF FF FF P ﬁl
008010 FF FF FF FF F|gT72F32442 FF FF FF FF FF
008020 FF FF FF FF FlgT72F324)4 FF FF FF FF FF
008030 FF FF FF FF F|gT72F324J6 FF FF FF FF FF
008040 FF FF FF FF Fl5T72F324K2 FF FF FF FF FF
008050 FF FF FF FF F|gT72F324K4 ~| FF FF FF FF FF
o0soe0 FF FF FF FF FF FF FF FF FF FF IF FF FF FF FF FF
ooeozo FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

File Wiew Read Write Werify Advanced geyfob Help

O|E|E| 3| s|%|%|sreee - [7(6 al6] s[%|e el@]

COPTIONS

FF FF FF FF FF FF FF FF FF FF FF FF e ﬁ
o0soi1o FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF e -

n0sozo FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
008030 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
00s040 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
o00sos0 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
00060 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

# FlashBash - [ST72F324B16] =10l x|

File Yiew Read Write Verify Advanced Keyfob Help

[sT72F324B06 = [Z]e al|a] %%l R"|@||

OPTIONS

onsaon FE CC D4 E7 00 00 9E &6 00 00 00 00 01 FF 00 01
nosnio 80 1A 00 00 80 26 80 1E 80 20 02 00 01 79 00 00
oosozo FF FF 00 00 0O 00 00 04 02 0O 07 DO OB B2 00 01
onsos0 03 07 01 00 06 00 92 86 88 84 8C 8E 90 00 00 4F
008040 C?7 03 OF 16 03 10 03 1E 32 14 05 81 1F 32 15 05

+* FlashBash - [ST72F324B16] = Ellil
File ‘iew Read ‘Write Verify | Advanced Keyfob Help
= Micro R Ctrl+R
NEEERD G | %% 23]
v Supply Oscillatar
| FLASH I EEFRGM I QPTIOMNE
+ Perform Erase Cycle
008000 BB CC DA E7 0o 01 -
00ga1n 20 14 00 00 Bratect RCCH Values (FLASH) 0o oo
oogozo FF FF 00 00| Fratec: RCCR Valuss (EERROM) 0o o1
oogozo 03 07 01 00 00 4F
Oons040 C7 03 0F 16 Update FlashBash Firrnware. .. Chrl4+U 15 0%
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Setting Option Bytes

(In this example, the device being programmed is an ST72F324BJ6 micro device.)

v Select Options Tab and set option bytes. In =lolx|
. . File Wiew Read Write Verify Advanced Keyfob Help
this example the option bytes are i =
OXE7-0x87 Dis(@] & slsle|[srens 1 [Flo ala] slwle| el
' ' Fuasn | =o' | opmions 1)
Check the settings by viewing the bottom B e
menu bar. ) ) & Resonator Dscilator € LP Resonator 1-2MHz) I Full Memers Protect
Refer to the option bytes section at the € Evieinsl AC Oseiatior " MP Resonator (2-4MHz) I Hetdwars Watchdog E
. &l & nabled
end of this document for correct € Intemal RC Oscillator € MS Resonator (4-8MHz) S
: . sge € Extemnal S & HS Resonator (8-16MH v Reset On Entering
settings. Settings specific to selected i S R
nal
micro chip. VD Confg ) ReselPhase
" LVD and AVD Off " 256 Cycles
(% Highest Vohage Thieshold (Ol

" Medium Voktage Threshold
" Lowest Voltage Threshold

Ready [DevID 000:0 [Chksum:0x00 2F324B06

V. Write to target device: Write > Current or -5
click highlighted button. File Yew Read Write Verfy Advanced Keyfob Help

D|@|H|§| @ ST72F324BJ6 =l [Fle el €| \!?|E,I||

 DOscillator Type—————— [ Dscillator Range
@ Resonator Oscillator © LP Resonator [1-2MHz) I~ Full Memory Pratect
" External BE Dsoilattor " MP Resonator [2-4hHz]
; [~ Hardware Watchdog Enabled
" Internal RC Dscillator " M5 Resonator (4-8MHz]
" Ewtemal Source ¥ HS Resonator [8-16MHz) [V Reset On Entering Halt
[™ Clack Filer Enafled
LD Config — Rezet Pha: ] L Fies
hahles
YD and 4D Off " 256 Cycl
" Highest Voltage Threshold
" Medium Yoltage Threshold
" Lowest Yoltage Threshold

Ready DevID 000:0 [Chksum:0x0000 [0xE7:0x67 [STP2F324816 4
v Reset target: Advanced > Micro Run. # FlashBash - [5T72F324516] P ]
File View Read Write Verify | ddvanced Keyfob Help
~ Micro R
D[] S| %] %] M 6|a| 5[%|%| w|m]
v Supply Oscillator
| FLASH I EEPR.OM I OPTIONE
w Perform Erase Cycle
oosoon BE CC D4 E7 oo 01 s
008010 80 1a 00 0O Frofech RECA Valies (FLASH) 00 00 ....E.. L.
oogozn FF FF 00 00 Protect RCCH Yalues (EERROM), oo 01 P
oos03n 03 07 01 00 00 4F 4]
nnanan 7 N NF 16 linrate FlashBash Firmware,,,  CtrHU 15 0% 22

~ Programming of Option Bytes is done.
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Loading Programmer for Key Fob Mode Use
(In this example, the device being programmed is an X05.)

‘/ Connect INNCOM ST7 ICP to serial port and 12VDC
power supply.

‘/ Start FlashBash program.

‘/ Select View > Program Options from menu. Program Options x|

Vigw  Programmer | Reset Delay |

Senal Port

" Comm 3

" Caomm 2 = Carm 4

Test |
QK. I Cancel | Lapply Help

‘/ Press the “Test” button for communication test. X

L) E Tesk Passed
-

‘/ Connect programming cable and power-up target.

1ol
. File 4 Read ‘Write Werify Ad b Hel
v Select target Micro: from dropdown menu. JE]I-‘ETETGQI—”E -E”;l - — e lERIss] I@”
. . . = ST72F324BJ6 7l alé& | w2
Refer to the option bytes section at the end of this S FITIT:
document for micros used by device. Most use [ Fas [_ecpron J72F324B
oogono FF FF FF FF F. FF FF FF FF FF [ .. -
ST7F324BJ6. 008010 FF FF FF FF F §H§E§§:§!}B —\ FF FF FF FF FE ... ...... .. ﬂ
008020 FF FF FF FF Fl§T72F324J4 FF FFFF FFFE  ............
008030 FF FF FF FF FlGT72F32406 FF FF FF FE FF  ...... ......
008040 FF FF FF FF FI5T72F324K2 FF FF FF FF FF
008050  FF FF FF FF F|5T72F324K4 ~| FF FF FF FF FF
008060 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
oos070 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

# FlashBash - [§T72F324636] =10] x|

'\l Select Flash Tab Fle Yew Read Write Aerify Adwanced Keyfob Help

D[R] 8| sl srazss = [F]e ala] s|wle| (@]

OPTIONS

]

nognio FF FF FF FF FF FF FF FF FF FF FF FF e
oosozo FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF e
oosoz0 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF e
ooso4do FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF e
onsoso FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

008060 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF e

‘/ Load target software: File > Open... > Xxxxx.s19.
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N Select Options Tab and set option bytes. In g [= ]
this example the option bytes are: OXE7:0x87. = b
Check the settings by viewing the bottom EIEIE] % Mhnzrazms I (76 ala| s|v|| \ﬂ@”

= ~
menu bar. [[Frash | eevronf | opmions |)
Refer to the option bytes section at the end ~Oscillstor Type———— 1~ Oscillstor Range:
of this document for correct settings. & Resonator Oscillstor P Resonator (1-2MHz) I | Full Memory Protect
Settings specific to selected micro chip. € Eptemsl RC Oscilatior € MP Resonator [2-4MH2) I Hordware Welchdag Enabled
€ Intenal RC Oscilator ' M5 Resonatar (4-8MHz)
€ Evtemal Source & HS Resonator (16MHz) | ¥ Reset On Entering Halt
I Clock Fiter Enabled
~LVD Config ~Reset Phase P
€ LVD and AVD Off " 256 Cycles
= Highest Voltage Threshold ' 14096 Cycles
€ Medium Yoltage Threshold
" Lowest Vokage Threshold

Resty s ik oron Yrrn

v write to Key Fob: Keyfob > Write. # Flashiiash = [STZ202HIG] =10l
Eile W¥ew Read Write vYerify Advanced _Ey'Fnh el
LED on ICP will light green while downloading D@l & |_F5T72F Read = ala
is in progress. When LED goes off, disconnect |=6| 5] »ivle| irice I_" [71o] 4| &v|s| R’-’I@H
programmer from power and serial cable. [ rasti [ cesron | opmions | \_verty

Oscillator Type: Oscillator Range
% Resonator Oscillator 1~ LP Resonatar [1-2MHz) I Full Memary Pratect
| External BE [soilattar " MP Resonator [2-4hHz) — _

‘/ Programmer is now ready to be used to
program target.

Programming the Target with Key Fob

‘/ Programming target device:

Power target. Connect ICP cable (refer to
appropriate photo for cable connection to
target).

‘/ Momentarily press button on ICP for
approximately 1 second until green LED
lights. Release button.

\/ Green LED will stay lit for the complete
programming cycle.

‘/ After programming cycle ends, LED will blink Picture shows connection to X05 using 62-1507 cable and push button.

GREEN for success and RED for failure.

‘/ Press button on ICP until GREEN or RED light
goes out.

INNC == g
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‘/ To reset target, remove ICP cable connection
from programmer and reconnect. LED on
target will begin rapid blinking.

‘/ Remove cable from target after rapid blinking
stops.

‘/ Programming is done

¥ PR,

Picture shows connection to MCM1 using 62-1515.60 cable and push button.

Option Bytes

Microcontroller

Option byte settings

Products

ST72C104G1/G2 O0xFC:0x8B

X05

Notes on PCB board
versions:

# FlashBash - [ST72C104G1]

File View Read MWrite Werify Advanced Kewfob Help

=101 x|

Rev CO0 and below use

ST72C104G1

D|=|E| 2| %|%|%| [sT72c10061

=l Fle| &la] €]vle 23]

microprocessor.
Rev C1 and above use

| FasH | eeeeom | opmions |

ST72C104G2

microprocessor. — Ozcillatar Caonfig

" External Clock [Stand-by]
™ Intemnal RC [4kHz]

" Euternal FC [1-14kHz]
" Low Power Resonator
" Medium Power Resonator

" Medium Speed Resonator

o)

High Speed Resonator

— WD Config
LD Off

% Highest Valtage Threshald

" Medium Yaltage Threshald

" Lowest Voltage Threshald

— Part C Intermipt
& PCE-PCOon IMTO

" PCEPCO on INT1

Ready

[~ Full bemary Protect

™ Hardware Watchdog Enabled

¥ Feset On Entering Halt

[ Clock Filter Enabled

[DevID 000:0 |Chksum:0x000ff |0xFC:0x88

T7ECI04G1 7
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Microcontroller Option byte settings Products

ST72F324BJ6 OXE7:0x87 CD564, X05B, MCM1D254, S217, 3035, TCS, TCT, TCC,
L207RF, GDA Speakerphone, GDA CommCard,
MCM1_VAV2, B564, D254_DIN, X06_DIN, S55x%, Glass
Series, MCM4, P564, P563, X05R, X05W, X07, X08

# FlashBash - [ST72F324B16] =10 x|

File ¥iew Read Write Verify Advanced Keyfob Help

DR = ﬁ]z[$| [sT72F324B06 =l [7]o && ¢|%|% k‘?l@”

eepron | opTions |
\-——-/‘
Oscillator Type - 1 Dscillator Range
(% Resonator Dscillator " LP Resonator (1-2MHz) I Full Memosy Protact
€ Evternal RC Oscilsttor " MP Resonator [2-4MHz) I | Hevcheies Welehidoo Enatlad
(" Intemal RC Oscillator " MS Resonator (48MHz) SanEE
" Estemal Source (' HS Resonator (8-16MHz) IV Reset On Entering Halt
- [~ Clock Filter Enabled
VD Config———— [ Reset Phase
[~ PLL Enabled
" LVD and AVD Off
' Highest Voltage Threshold

" Medium Voltage Threshold
" LowestVoltage Threshold

Ready [DevID 000:0 |Chiksum:0x008g, [0xE7:0x87 [gf72F324816

Troubleshooting Guide

Problem Possible solution
Writing to target while programming from the PC causes this e  Check that target is powered and programming cable is
dialog box to popup: securely inserted.
x| e Intermittent operation may suggest that the programming cable
' Failed to Upload Booktram, IS faUIty'
. Check Device Connections and Correct Device has been Selected.

e  Test with different programmer, target, and cables.

Attempting to multitask while writing to the target may cause a e Suspend activity on PC while writing to target.
failure:

x

L] E Failed To 'Write Flash
[ ]
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Honeywell

Improper use of programming cables may cause programmer L] There are currently 2 cables for use with the programmer.
to fail. Refer to 1.1 Product Identification at the beginning of this
document for cable part numbers. Refer to photos below for
additional identification of JTAG cable.

Correct Cable—notice Wrong Cable—notice
keys are on the right keys on opposite sides
with cable colors with cable colors

. matching.
matching.
Pending Features
Date Feature
04-Oct-2005 Add single button to Flashbash user interface to refresh current file and execute download into target.
16-Nov-2005 Add option to Flashbash user interface for enabling /disabling writing of option bytes while in Key Fob mode.
Document Revision History
Date Description
07-Jul-2005 First draft
03-Oct-2005 Updated for programming in Key Fob
16-Nov-2005 Made document corrections for consistency and added Troubleshooting Guide section.
14-Jan-2010 Added notes and screen captures to note typical ST7324J6 Micro; reformatted to new template.
12-Nov-2013 Changed micro to ST7324BJ6; updated photos; formatted to Honeywell style.
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