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 Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, 
due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other 
documentation. National Instruments will, at its option, repair or replace software media that do not execute programming 
instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not 
warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of 
the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of 
returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed 
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to 
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult 
National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages arising out of 
or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL  INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY 
WARRANTY OF MERCHANTABILITY  OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’ S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR 
NEGLIGENCE ON THE PART OF NATIONAL  INSTRUMENTS SHALL BE LIMITED  TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL  
INSTRUMENTS WILL  NOT BE LIABLE  FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR 
CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of National Instruments will 
apply regardless of the form of action, whether in contract or tort, including negligence. Any action against National Instruments 
must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in 
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, 
malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or 
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or 
surges, fire, flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including 
photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written 
consent of National Instruments Corporation.

Trademarks
DAQCard™, DAQMeter™, National Instruments™, ni.com™, NI-DAQ™, SCXI™, and VirtualBench™ are trademarks of 
National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL 
OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL 
COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE 
EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS 
CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL 
POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE 
FITNESS, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, 
INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR 
FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC 
SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF 
THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER 
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD 
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) 
SHOULD NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM 
FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE 
REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO 
BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS 
FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER 
MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT 
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS 
ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL 
INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A 
SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND 
SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Conventions

The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click on in the software, 
such as menu items and dialog box options. Bold text also denotes 
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 
to a key concept. This font also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
Welcome to VirtualBench

The VirtualBench suite of tools is a high-performance, easy-to-use virtual 
instruments application program for Windows NT/2000/98/95. This 
manual gives you step-by-step instructions on how to use each instrument. 
It also includes a description of the front panel of each instrument.

This chapter lists the minimum system requirements for VirtualBench, 
explains how to install VirtualBench, and tells you what the setup program 
installs.

Minimum System Requirements
To run VirtualBench, you must have the following:

• Microsoft Windows NT 4.0 or higher, Microsoft Windows 2000, 
Windows 98, or Windows 95

• Personal computer using at least a 66 MHz 486 or higher 
microprocessor with floating-point capability (National Instruments 
recommends a Pentium 60 or higher microprocessor with 
floating-point capability.)

• VGA resolution (or higher) video adapter

• Minimum of 32 MB of RAM

• 40 MB free hard disk space

• Microsoft-compatible mouse

• NI-DAQ 6.7 or later 
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Installing VirtualBench
You must install VirtualBench with NI-DAQ driver software.

Note National Instruments recommends you close other applications before you install 
VirtualBench.

Complete these steps to install VirtualBench:

1. Insert your VirtualBench Installation CD into your CD-ROM drive.

2. Wait several seconds. On most computers, the AutoRun utility on the 
CD automatically launches the VirtualBench Installation CD  
dialog box.

3. If the VirtualBench Installation CD  dialog box does not appear, use 
theStart button in the Windows taskbar to select Run and type 
d:\setup  in the input box, where d is your CD-ROM drive. 
Click OK . 

4. Click Install VirtualBench  in the VirtualBench Installation CD  
dialog box.

Note Read the VirtualBench readme.txt  file on the VirtualBench Installation CD for the 
latest information about installing and using VirtualBench.

What the Setup Program Installs
The VirtualBench setup program installs the following virtual instruments, 
with online help for each instrument:

• Oscilloscope (Scope)

• Dynamic signal analyzer (DSA)

• Function generator (FG)

• Logger

• Arbitrary waveform generator (Arb)

• Waveform editor (Arb)

• Device calibrator (CAL)

• Counter
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Installing on a Network 
Contact National Instruments for licensing information if you plan to run 
VirtualBench on a network.

Connecting Signals to Your Data Acquisition Device
Refer to the user manual for your National Instruments DAQ device for 
instructions on connecting signals to your device.
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2
VirtualBench-Scope

This chapter explains the VirtualBench-Scope (oscilloscope) front panel 
features and how to acquire data with the oscilloscope.

Launching VirtualBench-Scope
To launch VirtualBench-Scope, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-Scope.

Front Panel Features
This section explains the features of the VirtualBench-Scope front panel, 
shown in Figure 2-1.
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Figure 2-1.  Front Panel of VirtualBench-Scope

The front panel of VirtualBench-Scope has the following features:

• Channel Selector—Selects a waveform for display on the graphics 
display.

• Channel Settings

– Channel—Selects the active channel.

– Volts/div —Adjusts the vertical sensitivity of the active channel.

– Coupling—Selects AC or DC input coupling.

– V. Position—Moves the active channel vertically on the graph.

• Timebase—Controls the timebase setting. Turning the knob 
clockwise reduces the time period that appears in the graphics display. 
Each horizontal division represents one time period.

• Trigger Cursor—Changes the trigger level and position. Move the 
trigger cursor by clicking and dragging the cursor on the display.

Channel Selector

Timebase

Zoom Controls

Channel
Settings

Trigger
Settings
Group

Main Control Bar

Graphics
Display

Trigger Cursor Vertical Sliders

Maximize/Minimize
Graphics Display
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• Graphics Display—Displays waveforms, channel information, 
cursor, and waveform measurements.

• Maximize/Minimize Graphics Display—Maximizes the graphics 
display so that it fills the entire window.

• Vertical Sliders—Adjust voltage offset for each channel. Use a slider 
when you want to adjust multiple waveforms in the graphics display.

• Trigger Settings Group—Controls the conditions required for signal 
acquisition; for example, whether to wait for a digital trigger before 
acquiring data or whether to acquire data in free-run mode 
(no triggering).

• Main Control Bar Buttons

– Run—Acquires data continuously. Deselection of this button 
places the VirtualBench-Scope in idle mode.

– Single—Instructs VirtualBench-Scope to perform a single 
acquisition.

– Auto Setup—Configures the scope for the best timebase, volts 
per division, and trigger setting for each channel currently 
selected with the channel selector.

– Mode—Sets the mode of the scope to volts versus time or X 
versus Y mode.

– Select—Selects a subset of the waveform for further analysis or 
for saving to disk.

• Zoom Controls—Adjusts the view of your display data.

– Scroll Bar—Adjusts zoom view.

– Zoom In—Zooms in on display data. Each zoom increases the 
view by a factor of two.

– Zoom Out—Zooms out to full X scale.

Note Refer to the VirtualBench-Scope Online Reference for more information about the 
front panel items.
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Acquiring Data
When you launch VirtualBench-Scope, it operates in continuous run mode. 
Complete the following steps to start acquiring signals with 
VirtualBench-Scope:

1. If you are using a DAQ device, connect a signal to the Channel 0 input 
of your device. Refer to the user manual of your DAQ device for 
details. For example, on a 68-pin MIO E-series device, connect a signal 
to pins 68 (ACH0) and 67 (AIGND) for a referenced single-ended 
input.

If you are using an IVI device, connect a signal to the appropriate 
channel of your device. Refer to Chapter 4, Configuring Your System, 
in the IVI Driver Library User Manual for more information about 
configuring your IVI virtual instrument.

2. Configure VirtualBench-Scope.

a. Select Edit»General Settings on the front panel.

b. Select the National Instruments DAQ or IVI instrument you want 
to use from the Acquire tab of the Scope Settings dialog box, 
shown in Figure 2-2. If a device does not appear in the Instrument 
list, make sure you have properly configured the instrument using 
the Measurement & Automation Explorer or you have configured 
an IVIScope virtual instrument in the Measurement & 
Automation Explorer. Refer to Chapter 4, Configuring Your 
System, in the IVI Driver Library User Manual for more 
information about configuring your IVI virtual instrument.
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Figure 2-2.  General Tab of VirtualBench-Scope Settings Dialog Box

c. Click OK  to use these settings.

Note When you launch VirtualBench-Scope, it automatically uses the settings of your 
previous VirtualBench-Scope session.

3. Enable the button for the connected channel in the Channel Selector 
group. Disable all other channels.

4. To start, click Auto Setup on the main control bar.

5. To change the trigger position, drag the trigger cursor (the small green 
cursor in the center of the graph).

6. Click Run to stop the acquisition.

Note Refer to the VirtualBench-Scope Online Reference for information about 
configuring VirtualBench-Scope for your specific application.
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3
VirtualBench-DSA

This chapter explains the front panel features of the VirtualBench dynamic 
signal analyzer (DSA) and how to acquire and measure signals. 

Launching VirtualBench-DSA
To launch VirtualBench-DSA, use the Start button in the Windows taskbar 
to select Programs»VirtualBench»VirtualBench-DSA.

Front Panel Features
This section explains the features of the VirtualBench-DSA front panel, 
shown in Figure 3-1.
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Figure 3-1.  Front Panel of VirtualBench-DSA

The front panel of VirtualBench-DSA has the following features:

• Display Settings Controls—Provides individual control of the 
measurements VirtualBench-DSA performs on each display. You can 
select the channels, function, magnitude/phase mode, magnitude unit, 
log/linear mode, phase unit, and markers for a display.

• Main Control Bar Buttons —Contains the Run, Single, and Pause 
controls.

– Run—Acquires data continuously. Deselecting this button places 
VirtualBench-DSA in idle mode.

– Single—Acquires a single frame of data.

– Pause—Pauses the acquisition. Pausing does not clear the 
averaging buffers. 

• Measurement Displays—Displays measurements, reference 
waveforms, and markers for marker measurements.

Note Refer to the VirtualBench-DSA Online Reference for more information about the 
front panel items.

Display Settings 
Controls

Measurement 
Displays

Main Control Bar

Display Settings 
Controls
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Acquiring and Measuring Signals
Complete the following steps to start acquiring and measuring signals with 
VirtualBench-DSA:

1. Connect a signal to the Channel 0 or 1 input of your DAQ device. Refer 
to the user manual of your DAQ device for details.

2. Configure the DSA.

a. Select Edit»Input Settings on the front panel.

b. Select the Input tab from the DSA Settings dialog box, shown in 
Figure 3-2.

Figure 3-2.  Input Tab of DSA Input Settings Dialog Box

c. Select the device you want to use for the data acquisition. The 
Device list displays only devices you have configured successfully 
in the Measurement & Automation Explorer.
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d. Click the Triggering  tab in the DSA Settings dialog box, shown 
in Figure 3-3.

Figure 3-3.  Triggering Tab of DSA Input Settings Dialog Box

e. Set the Trigger Type to none. This setting puts the acquisition in 
free-run mode.

f. Click OK .

g. Select Edit»Frequency Settings on the front panel.

h. Select the Span tab in the Frequency Settings dialog box, shown 
in Figure 3-4.
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Figure 3-4.  Span Tab of DSA Frequency Settings Dialog Box

3. Select a Baseband Span that is appropriate to the signal you are trying 
to measure. Click OK .

4. In the upper display on the front panel, select Time Waveform in the 
Waveform Type pop-up menu. Choose Linear Magnitude in the 
Scale pop-up menu. 

5. Select Markers None in the Markers  pop-up menu.

6. In the lower display on the front panel, select Power Spectrum in the 
Waveform Type pop-up menu. Choose Log Magnitude in the Scale 
pop-up menu.

7. Click the Single button. VirtualBench-DSA displays a single frame of 
data. If no data is visible, click the Autoscale Y-axis button (the button 
that contains a “Y” and up/down arrows) in the display control. Check 
your signal connections if data still does not appear.

8. Click Run. VirtualBench-DSA continuously acquires and displays 
frames of data.

9. Click Run again to stop acquisition.

Note Refer to the VirtualBench-DSA Online Reference for more information about 
configuring VirtualBench-DSA for your specific application.
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4
VirtualBench-Logger

This chapter explains the VirtualBench-Logger front panel features and 
how to acquire data with the logger.

Launching VirtualBench-Logger
To launch VirtualBench-Logger, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-Logger.
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Front Panel Features
This section explains the features of the VirtualBench-Logger front panel, 
shown in Figure 4-1.

 

Figure 4-1.  Front Panel of VirtualBench-Logger

The front panel of VirtualBench-Logger has the following features:

• Strip Chart Display—Displays the logged data.

• Y Axis Select Controls—Selects which channel’s Y scale to display 
on either the left or right Y-axis of the strip chart display.

• Status Display—Shows the current time, start time, and stop time of 
the current data acquisition.

• Channel Select Control—Selects which channels to display on the 
strip chart display. You can use the Labels/Values radio buttons below 
the channel select control to switch between the channel labels and the 

Y Axis
Select Control

Status
Display

Strip Chart
Display

Acquire Data Controls

Legend
Control

Channel
Select
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channel values. When you select Labels, you can click a label to 
change which channel the system displays on that plot. When you 
select Values, you can click the value to change the number of decimal 
places the system displays for that channel.

• Legend Control—Changes the trace attributes of each display 
channel. Clicking a trace in the legend control displays a menu that 
allows you to make changes to the point style, line style, interpolation 
method, and color of the trace.

• Acquire Data Controls—Contains Logging On/Off, Clear Chart, 
Start, Stop, and Pause controls.

– Logging On/Off—Enables or disables logging data to disk when 
you run the instruments.

– Clear Chart—Clears the strip chart display. Clicking this button 
does not affect the acquisition of data.

– Start—Starts the acquisition of data and data logging when 
enabled using the current logger configuration.

– Stop—Stops the acquisition of data and data logging when 
enabled.

– Pause—Temporarily stops the flow of data to the strip chart and 
log file when enabled.

Note Refer to the VirtualBench-Logger Online Reference for more information about the 
front panel items.

Acquiring Data
Complete these steps to start acquiring data with VirtualBench-Logger:

1. Connect several known voltage signals to the input channels of your 
DAQ device. Refer to the user manual of your DAQ device for details. 
National Instruments recommends you use known reference signals to 
verify proper operation of VirtualBench-Logger and your DAQ device.

2. Configure VirtualBench-Logger.

a. Select Edit»Settings on the front panel.

b. Select the device and SCXI module that you want to use 
in the Logger Settings dialog box, shown in Figure 4-2. 
VirtualBench-Logger disables the SCXI Module list when 
no SCXI modules are configured for the selected device. The 
Device list displays only devices you have configured successfully 
in the Measurement & Automation Explorer.
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Figure 4-2.  Logger Settings Dialog Box

Note The options on the Logger Settings dialog box vary slightly if you use an NI 435x 
Series board. Refer to the VirtualBench-Logger Online Reference for more information.

c. Set the Start Channel and End Channel controls appropriately 
for the channels that you connected signals to in Step 1.

d. Set the channel attributes for each channel from the start channel 
to the end channel. 

– Select 0-Md1 Ch0 in the textbox.

– Select the Transducer. The six transducer measurement 
types are VDC, Thermocouple, RTD, Current, Thermistor, 
and Resistance.

– Give each channel an appropriate Label for easy 
identification on the strip chart display.

– Select a Range for the specified channel.

e. Click the File Config button. In the File Configuration dialog 
box, shown in Figure 4-3, specify the name of the log file where 
VirtualBench-Logger stores the logged data on disk. To specify 
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the location of this file, use the Browse button. Select Enable 
Logging and Begin Logging on Start. Click OK .

Note If you have not previously specified a log file, VirtualBench-Logger automatically 
displays a Save as dialog box.

Figure 4-3.  File Configuration Dialog Box

f. Click the Timing Config button. In the Timing Configuration  
dialog box, as shown in Figure 4-4. Set the Start Timing and Stop 
Timing to start and stop manually. Set the Time Interval  control 
to 1.00  seconds. Set Log to Disk Every n Time Intervals to 1. 
Set the Display Length to 1 minute. Click OK . 
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Figure 4-4.  Timing Configuration Dialog Box

g. Click OK  in the Logger Settings dialog box to return to the front 
panel.

Note  Refer to the VirtualBench-Logger Online Reference for more information about 
configuring VirtualBench-Logger for your specific application.

3. Select the channels you want to display on the strip chart using the 
channel select control.

4. Click the right or left Y-axis controls to select which channel’s Y-scale 
you want to display on the strip chart.

5. Click Start in the acquire data controls area. VirtualBench-Logger 
begins acquiring and logging data to disk at 1-second intervals and 
displays it on the strip chart. If no data appears, check the signal 
connections to your DAQ device or check the Range limits for the 
channels you selected in the Logger Settings dialog box.

6. Click the Stop button to stop the acquisition.
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5
VirtualBench-FG

This chapter explains the VirtualBench function generator (FG) front panel 
features and how to generate a waveform.

Launching VirtualBench-FG
To launch VirtualBench-FG, use the Start button in the Windows taskbar 
to select Programs»VirtualBench»VirtualBench-FG.

Front Panel Features
This section explains the features of the VirtualBench-FG front panel, 
as shown in Figure 5-1.

Figure 5-1.  Front Panel of VirtualBench-FG

Display Window Range Selector Function Selector

Waveform Modifier ControlsFrequency KnobOn Play
List

Step
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The front panel of VirtualBench-FG has the following features:

• Display Window—Shows the actual waveform frequency 
VirtualBench-FG generates.

• Range Selector—Selects the frequency range of VirtualBench-FG.

• Function Selector—Selects which type of waveform 
VirtualBench-FG generates.

• Frequency Knob—Controls the frequency of the waveform within 
the range you specify with the range selector.

• Waveform Modifier Controls —Modifies some of the properties of 
the waveform.

– Duty Cycle—Adjusts the duty cycles of the sine wave, square 
wave, and triangle wave.

– Offset—Adjusts the DC offset of the waveform.

– Amplitude —Adjusts the peak amplitude of the generated 
waveform.

• On—Starts or stops waveform generation.

• Play List—Outputs waveforms as specified in the frequency list. 
ThePlay List button appears only with 54xx devices.

• Step—Steps through the frequency list. The Step button appears only 
with 54xx devices.

Note Refer to the VirtualBench-FG Online Reference for more information about the 
front panel items.

Generating a Waveform
Complete the following steps to configure VirtualBench-FG to generate a 
waveform:

1. Configure the output.

a. Select Edit»Settings on the front panel.

b. Select the instrument you want to use for waveform generation in 
the VirtualBench-FG Settings dialog box, as shown in 
Figure 5-2. The Instrument list displays only devices that you 
have configured successfully in the Measurement & Automation 
Explorer. Refer to Chapter 4, Configuring Your System, in the 
IVI Driver Library User Manual for more information about 
configuring your IVI virtual instrument.
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Figure 5-2.  VirtualBench-FG Settings Dialog Box

c. Set the Channel, Update Rate, Use FIFO, and Buffer Size 
controls.

d. Click OK .

2. Connect a device or scope to the output of the analog output device that 
you specified in Step 1. Refer to your DAQ device user manual or 
instrument manual for details.

3. Click On. VirtualBench-FG continuously generates an analog 
waveform at the output pin.

4. Click On again to stop the waveform generation.

Note Refer to the VirtualBench-FG Online Reference for more information about 
configuring VirtualBench-FG for your specific application.
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6
VirtualBench-DMM

This chapter explains the VirtualBench digital multimeter (DMM) and how 
to measure a signal with the DMM.

Launching VirtualBench-DMM
To launch VirtualBench-DMM, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-DMM .

Front Panel Features
This section explains the features of the VirtualBench-DMM front panel, 
shown in Figure 6-1.

Figure 6-1.  Front Panel of VirtualBench-DMM
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The front panel of VirtualBench-DMM has the following features:

• Measurement Display—Displays measurements.

• Function Selector—Selects which measurement mode you want to 
use. The modes, from left to right, are as follows:

– Volts AC—Measures the AC component of a voltage signal.

– Volts DC—Measures the DC component of a voltage signal.

– Current AC —Measures the AC component of a current source.

– Current DC —Measures the DC component of a current source.

– Ohms—Measures resistance.

– 4-Wire Ohms—Measures resistance using four-wire method.

– Diode—Measures the voltage drop across a diode.

– Temperature—Measures temperature. 

• Resolution Control—Selects the number of digits of resolution.

• Range Selector—Determines the measurement range. This range is 
different for each measurement mode. AutoRange mode selects the 
best range to fit the input signal.

• Main Control Buttons

– Run—Starts or stops the DMM acquisition.

– Single—Acquires a single measurement.

– Log—Enables logging.

• Math Control Buttons

– Null —Selects relative mode. When you click this button, all 
subsequent measurements become relative to the measurement 
made when you pressed this button.

– Max/Min —Displays the maximum and minimum values since 
you first clicked the button.

– mX+B—Manipulates normal display readings (X) according to 
the calculation mX+B.

– dB—Displays the decibel value of your signal.

– dBm—Displays the decibel power level with respect to 1 mW.

– %—Displays the current value as a percentage of a reference.

Note Refer to the VirtualBench-DMM Online Reference for more information about the 
front panel items.
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Measuring a Signal
Complete the following steps to start measuring signals with 
VirtualBench-DMM:

1. Configure VirtualBench-DMM.

a. Select Edit»Settings on the front panel.

b. Select the General tab, shown in Figure 6-2.

Figure 6-2.  General Tab of VirtualBench-DMM Settings Dialog Box

c. Select the instrument you want to use. VirtualBench-DMM hides 
the SCXI Module list when no SCXI modules are configured for 
the selected device. The Instrument list displays only devices you 
have configured successfully in the Measurement & Automation 
Explorer. Refer to Chapter 4, Configuring Your System, in the 
IVI Driver Library User Manual for more information about 
configuring your IVI virtual instrument.

d. Set the channel to the source of your signal.

e. Click OK .

2. Measure voltage. VirtualBench-DMM measures AC and DC voltage 
without any external hardware.

a. Connect a signal to the channel input that you specified in Step 1. 
Refer to the user manual of your DAQ device for details.
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b. Click the Volts AC or Volts DC button in the Function selector. 
VirtualBench-DMM continuously acquires and displays voltage 
measurements in the display window.

c. If the DMM display shows +CLIP or –CLIP, confirm the input 
signal does not exceed the range of your DAQ device and the input 
signal does not exceed the selected range.

d. Click Run to stop the measurement.

3. Measure current. If you are using an NI 4060 PCI/PXI-based 
multimeter or an IVI instrument, skip to Step 3g.

If you are using any other device, VirtualBench-DMM requires a 
precision external shunt resistor to measure current. Complete these 
steps to configure your precision external shunt:

a. Connect a precision shunt resistor across the input of the channel 
you specified in Step 1. Refer to the user manual of your DAQ 
device for details.

b. Connect your current signal to the same terminals.

c. Select Edit»Settings on the front panel.

d. Select the Current and Resistance tab, shown in Figure 6-3.

Figure 6-3.  Current and Resistance Tab of VirtualBench-DMM Settings Dialog Box
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e. Enter the value of the shunt resistor in the Current Shunt 
Resistor control.

f. Click OK .

g. Click the Current AC  or Current DC  button in the Function 
selector, depending on which type of voltage you connected. 

h. Click Run. VirtualBench-DMM continuously acquires and 
displays current measurements in the display window.

i. If the DMM display shows +CLIP or –CLIP, confirm the input 
signal does not exceed the range of your DAQ device or IVI 
instrument and the input signal does not exceed the selected range.

j. Click Run again to stop the measurement.

4. Measure resistance. If you are using an NI 4060 PCI/PXI-based 
multimeter, a DAQMeter DAQCard-4050, or an IVI device, skip to 
Step 4g. 

If you are using any other device, you must use a precision external 
current source to measure resistance. Complete these steps to 
configure your current source:

a. Connect a precision current source to the channel you specified in 
Step 1. Refer to the user manual of your DAQ device for details.

b. Connect the resistor you want to measure across the same 
terminals.

c. Select Edit»Settings on the front panel.

d. Select the Current and Resistance tab.

e. Enter the value of the current source in the Current Source 
control.

f. Click OK .

g. Click the Ohms button in the Function selector.

h. Click Run. VirtualBench-DMM continuously acquires and 
displays resistance measurements in the display window.

i. If the DMM display shows +CLIP or –CLIP, confirm the input 
signal does not exceed the range of your DAQ device or IVI 
instrument and the input signal does not exceed the selected range.

j. Click Run again to stop the measurement.
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5. Measure temperature. VirtualBench-DMM requires a thermistor, 
IC sensor, or thermocouple to make precise temperature 
measurements. Because DAQMeter DAQCard-4050 or 
NI 4060 PCI/PXI-based multimeter does not support making 
temperature measurements, you cannot use VirtualBench-DMM to 
make temperature measurements for these boards.

a. Connect a precision temperature sensor to the channel you 
specified in Step 1. Refer to the user manual of your DAQ device 
for details.

b. Select Edit»Settings on the front panel.

c. Select the Temperature tab, shown in Figure 6-4.

Figure 6-4.  Temperature Tab of VirtualBench-DMM Settings Dialog Box

d. Select the type of sensor from the Temperature Sensor list you 
connected to the channel specified in Step 1a. 

e. Select the Temperature Units you want for the temperature 
display.

f. Select the cold junction sensor type from the TC Cold Junction 
Source list when you use a thermocouple. Select the channel to 
which the cold junction sensor is connected.

g. Click OK .

h. Click the Temperature button in the Function selector.
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i. Click Run. VirtualBench-DMM continuously acquires and 
displays temperature measurements in the display window.

j. If the DMM display shows +CLIP or –CLIP, confirm the input 
signal does not exceed the range of your DAQ device and the input 
signal does not exceed the selected range.

k. Click Run again to stop the measurement.

6. Measure a diode. If you are using a DAQMeter DAQCard-4050 or an 
NI 4060 PCI/PXI-based multimeter, you can measure the voltage drop 
across a diode, up to 2 V. If you are using an IVI instrument, you can 
also measure diode voltage if the instrument supports this.

a. Connect the diode to the terminals of the DAQCard-4050 or 
NI 4060 PCI/PXI-based multimeter.

b. Click the Diode button in the Function selector.

c. Click Run.

d. Click Run again to stop the measurement.

Note Refer to the VirtualBench-DMM Online Reference for more information about 
configuring VirtualBench-DMM for your specific application.
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7
VirtualBench-Power Supply

This chapter explains the front panel features of the VirtualBench-Power 
Supply and how to turn on VirtualBench-Power Supply.

Launching VirtualBench-Power Supply
To launch VirtualBench-Power Supply, use the Start button in the 
Windows task bar to select Programs»VirtualBench»
VirtualBench-Power Supply.

Note VirtualBench-Power Supply is for use only with IVI instruments.

Front Panel Features
This section describes the VirtualBench-Power Supply front panel.
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Figure 7-1.  Front Panel of VirtualBench-Power Supply

The front panel of VirtualBench-Power Supply has the following features:

• Graphics Display—Shows real-time voltage and current 
measurements if your instrument supports these measurements. If your 
device does not support these measurements, the display shows your 
current settings. OVP indicates the over-voltage protection circuitry 
has tripped. OCP indicates the over-current protection circuitry has 
tripped.

• Volts DC—Allows you to set the power supply to a specified DC 
voltage.

• Volts AC—Allows you to set the power supply to a specified AC 
voltage, with optional settings such as waveform shape, frequency, 
amplitude, DC offset, and start phase.

• Limits —Allows you to specify upper and lower voltage limits and a 
current limit, and enable over-voltage or over-current protection 
circuitry.

• Apply—Commits changes you have made to front panel controls.

• Output On/Off —Enables output of the Power Supply.
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Note Refer to the VirtualBench-Power Supply Online Reference for more information 
about the front panel items.

Turning on the Power Supply
When you launch VirtualBench-Power Supply, it always launches in a 
power off state. Complete the following steps to configure 
VirtualBench-Power Supply before using it:

1. Connect a load to one of the output channels of your power supply.

2. Configure VirtualBench-Power Supply.

a. Select Edit»Settings on the front panel.

b. Select the IVI instrument logical name you want to use. If you 
have not already configured a logical name for your instrument, 
VirtualBench-Power Supply has already created one for you with 
the same name as the virtual instrument installed in your system. 
Refer to Chapter 4, Configuring Your System, of the IVI Driver 
Library User Manual for more information about changing items 
to which another item refers.

c. Select the channel you want to use, as shown in Figure 7-2.

Figure 7-2.  Power Supply Settings Configuration

d. Click OK  to use these settings.
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Complete these steps to generate a DC power signal:

1. Click the Volts DC button to select DC volts mode, as shown in 
Figure 7-3.

Figure 7-3.  Front Panel with Volts DC Button Selected

2. Enter a voltage in the Voltage control.

3. Click Apply  to commit to the change. If a red error button appears in 
the display window, click the button to display the cause of the error. 
Adjust the voltage level if necessary.

4. Click Output  to enable the power supply.
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Complete these steps to generate an AC power signal:

1. Click the Volts AC button to select AC volts mode, as shown in 
Figure 7-4.

Figure 7-4.  Front Panel with Volts AC Button Selected

2. Enter the appropriate settings for your AC signal.

3. Click Apply  to commit to the change. If a red error button appears in 
the display window, click the button to display the cause of the error. 
Adjust the settings if necessary.

4. Click Output  to enable the power supply.

To exit VirtualBench-Power Supply, select File»Exit. VirtualBench-Power 
Supply saves your current settings for the next session.
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8
VirtualBench-Switch

This chapter explains the VirtualBench-Switch front panel features and 
how to make signal connections.

Launching VirtualBench-Switch
To launch VirtualBench-Switch, use the Start button in the Windows 
taskbar to select Programs»VirtualBench»VirtualBench-Switch.

Note VirtualBench-Switch is for use only with IVI instruments.

Front Panel Features
This section explains the features of the VirtualBench-Switch front panel, 
as shown in Figure 8-1.
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Figure 8-1.  Front Panel of VirtualBench-Switch

The front panel of VirtualBench-Switch has the following features:

• Instrument Selector—Allows you to select the IVI instrument you 
want to use.

• Channel Selection Group—Allows you to choose two channels to 
connect.

• Connection List—Allows you to view details and disconnect any 
existing connection.

• Status Display—Displays the connection path of the selected 
connection; channel information, such as maximum current, voltage, 
and power capacity; information on why two channels cannot be 
connected; and any error information.
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Note Refer to the VirtualBench-Switch Online Reference for more information about the 
front panel items.

Making Connections
Complete these steps to make signal connections:

1. Connect signals to two or more channels on your switch instrument.

Select the IVI instrument logical name you want to use. If you have not 
configured a logical name for your instrument, VirtualBench-Switch 
has already created one for you with the same name as the virtual 
instrument installed in your system. Refer to Chapter 4, Configuring 
Your System, of the IVI Driver Library User Manual for more 
information about changing items to which another item refers.

2. Select two channels you want to connect in the Channel Selection 
Group. 

3. Click Connect to connect the two channels.

4. Highlight the connection in the connection list to view information 
about the connection.

To disconnect a signal connection, highlight the connection in the 
connection list and click Disconnect.

To save a group of connections, select Edit»Save Settings. Enter the name 
of the file you want to save, such as MySetup.swh .

To exit VirtualBench-Switch, select File»Exit. VirtualBench-Switch saves 
your current settings for the next session.



© National Instruments Corporation 9-1 Getting Started with VirtualBench

9
VirtualBench-Arb and 
VirtualBench-Waveform Editor

This chapter explains the VirtualBench-Arb front panel features, the 
Waveform Editor front panel features, and how to generate a waveform.

Launching VirtualBench-Arb
To launch VirtualBench-Arb, use the Start button in the Windows taskbar 
to select Programs»VirtualBench»VirtualBench-Arb .

Waveform Generator Front Panel Features 
This section explains the features of the VirtualBench-Arb Waveform 
Generator front panel, as shown in Figure 9-1.

Figure 9-1.  Front Panel of VirtualBench-Arb Waveform Generator
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VirtualBench-Arb has the following key features:

• Waveform Name/Load Waveform Control—Shows the name of 
the waveform file, if any, for VirtualBench-Arb to generate. Select this 
control to load a waveform from a file.

• Update Rate—Controls the update rate of the waveform. This control 
does not affect the play speed of waveform files (.wfm ) but does affect 
waveform quality. With text, binary, and sound (.wav ) files, the update 
rate determines the play speed by controlling the number of samples of 
the waveform VirtualBench-Arb plays per second.

• Step—Steps through the stages in a waveform sequence. 
VirtualBench-Arb enables this button only for 5411 devices.

• Mode—Plays the waveform continuously. Deselecting this button 
plays the waveform only once.

• Amplitude Control —Scales the waveform by the specified amount.

• Play/Stop Control—Starts or stops waveform generation for one 
channel.

Generating a Waveform
Complete the following steps to start generating waveforms with 
VirtualBench-Arb:

1. Configure VirtualBench-Arb.

a. Select Edit»Settings on the front panel.

b. Select the Channels tab, shown in Figure 9-2.
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Figure 9-2.  Channels Tab of VirtualBench-Arb Settings Dialog Box

c. Select the device you want to use for waveform generation. 
The Instrument list displays only devices you have configured 
successfully in the Measurement & Automation Explorer. Refer to 
Chapter 4, Configuring Your System, in the IVI Driver Library 
User Manual for more information about configuring your IVI 
virtual instrument.

d. Select the corresponding DAQ device channels to map to the 
VirtualBench-Arb alphabetical channel names.

e. Click OK .

2. In the front panel of the Waveform Generator, click the Load 
Waveform button to invoke the File name: dialog box. Select a 
waveform file.

3. Click the Play button (the button with a green triangle) to begin 
waveform generation.

4. Click the Stop button (the button with a red square) to end signal 
generation.

Note Refer to the VirtualBench-Arb Online Reference for more information about 
configuring VirtualBench-Arb for your specific application.
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Creating a New Waveform

1. Creating a new waveform.

a. Enter the duration of the waveform in the Duration  control to set 
the duration of the first segment.

b. Click New Component. By default, every time you click New 
Component, VirtualBench-Arb adds a new library component to 
any existing waveform. 

c. Select the type of component: Library , Expression, or Sketch. 
The following steps further describe how to use these options.

2. Create a waveform using the library functions.

a. Confirm you selected Library  in the component type control.

b. Select a waveform from the library and modify the parameters if 
necessary.

c. Click New Component again to add a new component. This 
component adds to the first to produce the final segment. Change 
the Function selector to perform subtraction, multiplication, 
division, or frequency modulation.

d. Click on New Segment to add additional waveform segments to 
the end of the waveform.

3. Create a waveform from a mathematical expression.

a. Click New Segment to create a new segment.

b. Click New Component to create a new component in the 
segment.

c. Select Expression from the component type control.

d. Enter an expression in terms of variable x  in the f(x)= box. 
VirtualBench-Arb indicates any error in red, with the character 
position of the error in parentheses.

e. Enter the range for x  in the From:  and To: input boxes. 
VirtualBench-Arb evaluates the expression over this range. 

f. To change the number of cycles of the waveform, change the 
Cycles control.

4. Create a waveform from a freehand sketch.

a. Click New Segment to create a new segment.

b. Click New Component to create a new component in the 
segment.

c. Select Sketch from the component type control.
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d. Click Draw. Notice this changes from View to Component mode 
so VirtualBench-Arb displays only the current component.

e. Click and drag over the graph using the mouse to create a 
waveform. Click the Mode button to change the mode to line. This 
mode allows you to draw straight lines.

f. Click Draw again to finish editing.

5. Select File»Save As to save your waveform.

a. Select Binary File . Click Next.

b. Enter 50 kHz for the Sample Rate. Click Next.

6. Save the file.

7. Close the Waveform Editor front panel.
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Waveform Editor Front Panel Features
This section explains the features of the VirtualBench-Waveform Editor 
front panel, as shown in Figure 9-3.

Figure 9-3.  Front Panel of VirtualBench-Arb Waveform Editor

The Waveform Editor front panel of VirtualBench-Arb has the following 
features:

• View Control —Selects the waveform view to display on the graph. 
Waveform displays the entire waveform. Segment displays the 
selected segment. Component displays the selected component.

• X Axis Control —Selects the X-axis units. Time displays the 
waveform as a function of time. Frequency displays the power 
spectrum of the waveform.

• Units Control —Selects the active units you are currently using for the 
display and control values.

• Style Control—Changes the graph attributes.
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• Segment List Box—Selects the segment or component you want to 
edit. A number precedes a segment and indicates a unique section of 
the waveform. The value in parentheses indicates the segment length. 
Indented text in the list box represents a waveform component.

• New Segment Button—Inserts a new waveform segment 
immediately after the current selection.

• New Component Button—Inserts a new component immediately 
after the current selection.

• Component Type Control—Selects the type of component. 
A waveform Library  function is one of 20 predefined waveform 
patterns. An Expression is a single-variable function evaluated over 
an interval. A Sketch is a waveform you draw with a mouse.

• Component Parameters—Shows the parameters for each 
component.

Note Refer to the VirtualBench-Arb Online Reference for more information about the 
front panel items.
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10
VirtualBench-Device Calibrator

This chapter explains the VirtualBench-Device Calibrator front panel 
features and how to calibrate a DAQ device.

Launching VirtualBench-Device Calibrator
To launch the VirtualBench-Device Calibrator, use the Start button in the 
Windows taskbar to select Programs»VirtualBench»VirtualBench Cal.

Front Panel Features
This section explains the front panel features of the 
VirtualBench-Device Calibrator, as shown in Figure 10-1.

Figure 10-1.  Front Panel of VirtualBench-Device Calibrator
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The front panel of the VirtualBench-Device Calibrator has the following 
features:

• Device List—Shows all the devices installed in your computer that are 
self-calibrating and the last calibrated date. The device list displays 
only devices you have configured successfully in the Measurement & 
Automation Explorer.

• Calibrate Button —Begins the calibration process.

You can use the VirtualBench-Device Calibrator to calibrate the 
analog input circuitry of the following DAQ devices: E-series, 
AT-MIO-16F-5, AT-MIO-64F-5, AT-MIO-16X, and PC-LPM-16. 
Special connections are not necessary; VirtualBench-Device Calibrator 
automatically accesses the calibration features of these devices.

Calibrating a DAQ Device
Complete these steps to calibrate your device with VirtualBench-Device 
Calibrator:

1. To allow your system to reach normal operating temperatures, wait at 
least 15 minutes after you turn on both your computer and device 
before calibrating your device.

2. Select the device you want to calibrate from the Device List.

3. Click Calibrate. Calibration of your device may take up to 
20 seconds.

4. The screen displays Calibrating ... please wait  when the 
system calibrates your device. Wait for calibration to complete before 
using any other VirtualBench instrument. 

Note Refer to the VirtualBench-Device Calibrator Online Reference for more 
information about configuring VirtualBench-Device Calibrator for your specific 
application.
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11
VirtualBench-Counter

This chapter explains the VirtualBench-Counter and how to measure a 
signal with the Counter.

Launching VirtualBench-Counter
To launch VirtualBench, use the Start button in the Windows taskbar to 
select Programs»VirtualBench»VirtualBench-Counter.

Front Panel Features
This section explains the features of the VirtualBench-Counter front panel, 
as shown in Figure 11-1.

Figure 11-1.  Front Panel of VirtualBench-Counter.
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The front panel of VirtualBench-Counter has the following features:

• Measurement Display—Displays the measurements, including the 
type and units of the measurement.

• Measurement Mode Selector—Selects which measurement mode 
you want to use, from left to right:

– Frequency—Measures the frequency of the unknown signal.

– Totalize (Count Edges)—Counts rising edges and accumulates 
the total.

– Period—Measures the period of an unknown signal.

– High Pulse Width—Measures the positive pulse width of an 
unknown signal.

– Low Pulse Width—Measures the negative pulse width of an 
unknown signal.

– Duty Cycle—Measures the percentage of time that an unknown 
signal is high versus its period.

– Time Between 2 Edges—Measures the amount of time between 
a rising edge on one input and a rising edge on another input.

– Phase Angle—Measures the phase difference between two 
unknown signals of the same frequency.

– Frequency Ratio—Measures the ratio of one frequency to 
another.

– Encoder-Position—Monitors the relative position and number of 
revolutions of a motion encoder.

– Encoder Speed—Measures the speed at which a motion encoder 
moves.

• Main Control Buttons—The main control buttons include Run, 
Single, and Reset:

– Run—Starts or stops the Counter acquisition.

– Single—Acquires a single measurement.

– Reset—Resets the Totalize (Count Edges) value or 
Encoder-Position to 0.

• Maximum Measurement Time (seconds)—Determines the time 
taken during a frequency measurement or the amount of time to wait 
before timing out for the other measurements.
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• Number of Samples per Measurement—Determines the number of 
measurements to take during a given measurement time. If the system 
takes more than one measurement, it displays the average of the 
measurements.

Note Refer to the VirtualBench-Counter Online Reference for more information about the 
front panel items.

Measuring a Signal
Complete these steps to start measuring signals with 
VirtualBench-Counter:

1. Configure VirtualBench-Counter.

a. Select Edit»Settings on the front panel.

b. Select the General tab, as shown in Figure 11-2.
 

Figure 11-2.  General Tab of VirtualBench-Counter Settings Dialog Box.

c. Select the device you want to use. The Device list displays only 
devices you have configured successfully in the Measurement & 
Automation Explorer.

d. Select the Counter to measure your signal.

e. Click OK .

2. Measure frequency, totalize, period, high pulse width, low pulse width, 
or duty cycle. This feature works with devices that have either 
DAQ-STC or NI-TIO based counters.
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a. Connect a signal to the SOURCE input of the counter that you 
specified in Step 1. Refer to the user manual of your DAQ device 
for details or select Windows»Connections on the front panel for 
the correct pin numbers.

b. Click the Frequency, Totalize, Period, High Pulse Width, Low 
Pulse Width, or Duty Cycle button in the measurement mode 
selector. VirtualBench-Counter continuously acquires and 
displays the measurement in the display window.

c. If the counter display shows Timeout, confirm that the amount of 
time to take the number of samples you want is not greater than 
your measurement time. If the counter display shows Overflow, 
confirm that your measurement time is short enough to limit the 
number of edges the counter receives to less than its maximum 
value (2number of bits).

d. Click Run to stop the measurement.

3. Measure time between two edges. This feature works only with 
devices that have NI-TIO based counters.

a. Connect the starting signal to the AUX_LINE/UP_DOWN input 
of the Counter that you specified in Step 1, and connect the 
stopping signal to the GATE input of the counter you specified in 
Step 1. Refer to the user manual of your DAQ device for details or 
select Windows»Connections on the front panel for the correct 
pin numbers.

b. Click the Time Between 2 Edges button in the measurement 
mode selector. VirtualBench-Counter continuously acquires and 
displays the measurement in the display window.

c. If the counter display shows Timeout, confirm that the amount of 
time to take the measurement you want is not greater than your 
measurement time. If the counter display shows Overflow, 
confirm that your measurement time is short enough to limit the 
number of edges the counter receives to less than its maximum 
value (2number of bits).

d. Click Run to stop the measurement.
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4. Measure phase difference. This feature works only with devices that 
have NI-TIO based counters.

a. Connect the first signal (A) to the AUX_LINE/UP_DOWN input 
of the counter that you specified in Step 1 and connect the second 
signal (B) to the GATE input of the counter you specified in 
Step 1. Refer to the user manual of your DAQ device for details or 
select Windows»Connections on the front panel for the correct 
pin numbers.

b. Click the Phase Difference button in the measurement mode 
selector. VirtualBench-Counter continuously acquires and 
displays the measurement in the display window.

c. If the counter display shows Timeout, confirm that the amount of 
time to take the number of samples you want is not greater than 
your measurement time. If the counter display shows Overflow, 
confirm that your measurement time is short enough to limit the 
number of edges the counter receives to less than its maximum 
value (2number of bits).

d. Click Run to stop the measurement.

5. Measure frequency ratio. This feature works with devices with either 
DAQ-STC or NI-TIO based counters.

a. Connect the first signal (A) to the SOURCE input of the counter 
that you specified in Step 1 and connect the second signal (B) to 
the SOURCE input of the other counter in the counter pair of the 
counter that you specified in Step 1. Refer to the user manual of 
your DAQ device for details or select Windows»Connections on 
the front panel for the correct pin numbers.

b. Click the Frequency Ratio button in the measurement mode 
selector. VirtualBench-Counter continuously acquires and 
displays the measurement in the display window.

c. If the counter display shows Timeout, confirm that the amount of 
time to take the number of samples you want is not greater than 
your measurement time. If the counter display shows Overflow, 
confirm that your measurement time is short enough to limit the 
number of edges the counter receives to less than its maximum 
value (2number of bits).

d. Click Run to stop the measurement.

6. Measure position or speed. This feature works with devices with either 
DAQ-STC or NI-TIO based counters.

a. Connect the A Channel of the Encoder to the SOURCE input of 
the counter that you specified in Step 1 and connect the B Channel 
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of the Encoder to the UP_DOWN/AUX_LINE input of the 
counter that you specified in Step 1. If you use an NI-TIO counter 
and an encoder with a Z Index, connect it to the GATE of counter 
you specified in Step 1. Refer to the user manual of your DAQ 
device for details or select Windows»Connections on the front 
panel for the correct pin numbers.

b. Select Settings from the Edit menu on the front panel.

c. Select the Encoder tab, as shown in Figure 11-3.
 

Figure 11-3.  Encoder Tab of VirtualBench-Counter Settings Dialog Box

d. Select the Encoder Type.

e. If using a rotary encoder, select the Rotary Encoder Type and the 
number of Pulses per Revolution. If using a linear encoder, select 
the number of pulses per centimeter or inch.

f. Choose whether to use Z Indexing, the Z Index Reload Value, and 
when to reload the counter.

g. Click OK .

h. Click the Position or Speed button in the Measurement Mode 
selector. VirtualBench-Counter continuously acquires and 
displays the measurement in the display window.

i. Click Run to stop the measurement.

7. Setting the value of the Custom selection of Measurement Time and 
Number of Samples.

a. Select Edit»Settings on the front panel.
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b. Select the Time/Samples tab, as shown in Figure 11-4.
 

Figure 11-4.  Time/Samples Tab of VirtualBench-Counter Settings Dialog Box

c. Enter the values you want to use for Custom Measurement Time 
and Custom Number of Samples.

d. If the times you want to measure are greater than 0.8 seconds for 
DAQ-STC based counters or greater than 53.7 seconds for NI-TIO 
based counters, check the box at the bottom of the Time/Samples 
tab so the Counter uses the slower internal timebase instead of the 
maximum.

Note Checking this box causes less accurate readings. However, it allows for longer time 
measurements and period measurements of lower frequencies. This is beneficial mainly for 
DAQ-STC based devices because it has 24-bit counters that exceed their maximum value 
in less than a second when you use the maximum timebase of 20 MHz.

e. If you are using an NI-TIO based counter, the system can divide 
the incoming signal before it reaches the counter. This allows for 
measuring faster signals. Use the Divide Input Frequency and 
Totalize control to determine by what factor to divide incoming 
signals for frequency, totalize and frequency ratio measurements.

f. Click OK  and continue with your measurements.
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8. Set the filter for input lines. This feature works only with devices with 
NI-TIO based counters.

a. Select Edit»Settings on the front panel.

b. Select the Filter  tab, shown in Figure 11-5.
 

Figure 11-5.  Filter Tab of VirtualBench-Counter Settings Dialog Box

c. Choose the Filter  setting you want to use.

d. If you use the Custom Filter, you must choose a counter to 
generate the filter clock. Also, you must specify the size pulses to 
allow to pass.

e. With the built-in or custom filters, pulses greater than or equal to 
the specified value are guaranteed to pass. Pulses half the size 
specified are guaranteed to be blocked. Pulses between these sizes 
may pass, depending on their phase with the filter clock. Refer to 
the user manual of your DAQ device for more details.

f. Click OK  and continue with your measurements.

Note Refer to the VirtualBench-Counter Online Reference for more information about 
configuring VirtualBench-Counter for your specific application.
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12
VirtualBench-Logic Analyzer

This chapter explains the VirtualBench-Logic Analyzer front panel 
features and how to use it to acquire data.

Launching VirtualBench-Logic Analyzer
To launch VirtualBench-Logic Analyzer, use the Start button in the 
Windows taskbar to select Programs»VirtualBench»
VirtualBench-Logic Analyzer.

Front Panel Features
This section explains the features of the VirtualBench-Logic Analyzer 
front panel, as shown in Figure 12-1.
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Figure 12-1.  Front Panel of VirtualBench-Logic Analyzer.

The front panel of VirtualBench-Logic Analyzer has the following features:

• Bus Selector—Selects the buses you want to display and the color for 
each bus.

• Measurements Display—Displays the values of all the buses selected 
by the measurement cursor.

• Timebase Control—Selects the interval of time the system acquires.

• Trigger Control —Selects the type of triggering the system uses.

• Data Pattern and Mask controls—When you use pattern triggering, 
these controls select the pattern on which the system triggers and the 
bits that it ignores.

• Run and Single Acquisition buttons—The Run button acquires data 
continuously when selected. The Single Acquisition button instructs 
VirtualBench-Logic Analyzer to perform a single acquisition.
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• Zoom and Scroll controls—Adjust the view of your display data.

– Scroll Bar—Adjusts zoom view.

– Zoom In button—Zooms in on the displayed data. Each click 
increases the view by a factor of two.

– Zoom Out button—Restores the display to show the entire buffer 
of data.

• Graphics Display—Displays waveforms. When triggering, you can 
move a trigger cursor on the display to select the trigger position. In 
addition, you can use a measurement cursor to display the value of the 
buses at a particular position on the display.

• Status Display—Displays information such as the sample rate and 
cursor positions.

Note Refer to the VirtualBench-Logic Analyzer Online Reference for more information 
about the front panel items.
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Acquiring Data
Complete the following steps to start acquiring data with 
VirtualBench-Logic Analyzer:

1. Connect a signal to a DAQ device. Refer to the user manual of your 
DAQ device for details.

2. Configure VirtualBench-Logic Analyzer.

a. Select Edit»Acquisition Settings on the front panel.
 

Figure 12-2.  Settings of VirtualBench-Logic Analyzer.

b. Select the National Instruments device you want to use in the 
Device ring control, as shown in Figure 12-2. If your device does 
not appear in the device list, make sure you have properly 
configured the device using the Measurement & Automation 
Explorer.

c. Click OK  to use the settings.
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d. Select Edit»Bus settings on the front panel. Refer to the Bus 
settings dialog box as shown in Figure 12-3.

Figure 12-3.  Bus Settings of VirtualBench-Logic Analyzer.

e. Enter the bus names and bits you want to select for each bus.

f. Click OK  to use the settings.

g. On the front panel of the VirtualBench-Logic Analyzer, click Run 
to start acquiring data.

Note Refer to the VirtualBench-Logic Analyzer Online Reference for more information 
about configuring VirtualBench-Logic Analyzer for your specific application.
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A
Technical Support Resources

This appendix describes the comprehensive resources available to you in 
the Technical Support section of the National Instruments Web site and 
provides technical support telephone numbers for you to use if you have 
trouble connecting to our Web site or if you do not have internet access.

NI Web Support
To provide you with immediate answers and solutions 24 hours a day, 
365 days a year, National Instruments maintains extensive online technical 
support resources. They are available to you at no cost, are updated daily, 
and can be found in the Technical Support section of our Web site at 
www.ni.com/support

Online Problem-Solving and Diagnostic Resources
• KnowledgeBase—A searchable database containing thousands of 

frequently asked questions (FAQs) and their corresponding answers or 
solutions, including special sections devoted to our newest products. 
The database is updated daily in response to new customer experiences 
and feedback.

• Troubleshooting Wizards—Step-by-step guides lead you through 
common problems and answer questions about our entire product line. 
Wizards include screen shots that illustrate the steps being described 
and provide detailed information ranging from simple getting started 
instructions to advanced topics.

• Product Manuals—A comprehensive, searchable library of the latest 
editions of National Instruments hardware and software product 
manuals.

• Hardware Reference Database—A searchable database containing 
brief hardware descriptions, mechanical drawings, and helpful images 
of jumper settings and connector pinouts.

• Application Notes—A library with more than 100 short papers 
addressing specific topics such as creating and calling DLLs, 
developing your own instrument driver software, and porting 
applications between platforms and operating systems.
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Software-Related Resources
• Instrument Driver Network —A library with hundreds of instrument 

drivers for control of standalone instruments via GPIB, VXI, or serial 
interfaces. You also can submit a request for a particular instrument 
driver if it does not already appear in the library.

• Example Programs Database—A database with numerous, 
non-shipping example programs for National Instruments 
programming environments. You can use them to complement the 
example programs that are already included with National Instruments 
products.

• Software Library —A library with updates and patches to application 
software, links to the latest versions of driver software for National 
Instruments hardware products, and utility routines.

Worldwide Support
National Instruments has offices located around the globe. Many branch 
offices maintain a Web site to provide information on local services. You 
can access these Web sites from www.ni.com/worldwide

If you have trouble connecting to our Web site, please contact your local 
National Instruments office or the source from which you purchased your 
National Instruments product(s) to obtain support.

For telephone support in the United States, dial 512 795 8248. For 
telephone support outside the United States, contact your local branch 
office:

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, 
Brazil 011 284 5011, Canada (Calgary) 403 274 9391, 
Canada (Ontario) 905 785 0085, Canada (Québec) 514 694 8521, 
China 0755 3904939, Denmark 45 76 26 00, Finland 09 725 725 11, 
France 01 48 14 24 24, Germany 089 741 31 30, Greece 30 1 42 96 427, 
Hong Kong 2645 3186, India 91805275406, Israel 03 6120092, 
Italy 02 413091, Japan 03 5472 2970, Korea 02 596 7456, 
Mexico (D.F.) 5 280 7625, Mexico (Monterrey) 8 357 7695, 
Netherlands 0348 433466, New Zealand 09 914 0488, 
Norway 32 27 73 00, Poland 0 22 528 94 06, Portugal 351 1 726 9011, 
Singapore 2265886, Spain 91 640 0085, Sweden 08 587 895 00, 
Switzerland 056 200 51 51, Taiwan 02 2528 7227, 
United Kingdom 01635 523545
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