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Stockbook Quick Start Guide 
 

The hardest part about using new software is getting started. This Quick Start 

Guide offers the quick way to begin using and understanding Practical Systems’ 

Stockbook. 
 

Quick Start Guide Icons 
 
Learn a bit 

 

 Do a bit


 Important information






1 How to Install Stockbook 
 

There are two ways to install our programs: 

1.   Practical Systems website   www.practicalsystems.com.au 

Go to Customers > Login and log in using your client ID and password. 

Install the full program or update your existing program through our website. 
 

 
2.   Install from the installation disk. 

 Insert the Installation CD into your CD drive. 

The CD will run automatically and open the Installation Screen. 
 

 
 

 Use your mouse to select the program you wish to install and follow the onscreen prompts. 
 

1.2 The opening screen for Demonstration Herd 
From this screen select your main livestock type, type of operation and herd/flock size and click OK. 

Stockbook will now recommend which level of the program best suits your operation and allows you 

to view and use that particular level of Stockbook.  Eg if you select the setting below you will have 

access to the Stockbook Stud unlimited herd size with report writer and embryo transfer whilst you 

are in the demonstration herd or trial period. 

http://www.practicalsystems.com.au/
http://www.practicalsystems.com.au/
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1.3 Registration 
To register your purchased copy of Stockbook after installation, please phone Practical Systems on 

1800 624 688 for your unique unlock code. 
 





2 Finding help when you need it 
 

Help and Electronic Documents 
 
By going to the Help menu you will find a comprehensive set of resources to assist you 

including a full Stockbook manual and a search function for quick access to help on a 

particular subject. 
 

  Go to Help > Manual. 

Additional instructions can be found by going to 

Help > Program Documentation. 
 
 
 

2.1 On Screen Help 
  To summon help from within a particular area of the program relevant to the screen 

you are on: 

  Press the F1 key or click the  button at the bottom right of the screen. 
 
 
 

2.2 Demonstration Data 
The  demonstration  data  in  Stockbook has been  created so that you  can  start viewing, 

editing or manipulating information straight away.  This allows you to make entries of your 

own, amend and  delete items - all to help you explore and understand the features of 

Stockbook. 

  Go to File > Demonstration Herd. 
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2.3 Practical Systems Software Support Desk. 
 Keeping your Annual Subscription up to date will ensure: 

 

  Your software is always current. Your Annual Subscription entitles you to program updates 
and upgrades. 

  Help is always at hand.   Annual Subscription provides you with telephone support during 
business hours (8.30am to 5.30pm Monday to Friday AEST) to help you through any queries 
or problems you may have. Use of this service is unlimited for your period of cover. 

 

Phone: 1800 624 688 

  You are provided with regular Practical Tip emails in the form of a step by step guide that 
will help you keep getting the most from your software and newsletters. 

 
 



3 Getting Started 
 

 As mentioned previously, the hardest part about using new software is getting 

started. 

The two basic steps to get started are: 

  Step 1. Enter setup information via the Setup Menu or Setup Wizard; 

  Step 2. Enter your animals. 

Don't forget to use the demonstration herd to assist you to view and/or practice using the 

program. 

 The following illustrates how to setup a commercial operation.  If you have 

purchased the  Stud edition  you will also be required to complete the Part 5 

“additional setup for Stud users” in this quick start guide. 

Setup is strongly recommended before adding your animals. 
 

 
Before we proceed please make sure you are in the main herd.  If you are not, please go to 

  File > Main herd. 

 

As Stockbook is a multi species program, select the livestock type you wish to set up first by 

going to: 

  File > Select livestock type or press F5 on your keyboard. 
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Select a livestock type from the list and your main screen of Stockbook will now change to 

reflect the livestock type you have selected. 

 

 
 

 

If you are already in the correct livestock type, click on <No Change> 
 
 

 
3.1 Options for Initial Stockbook Setup 

 There are two methods to choose from for the initial Stockbook setup - 
 

Option One – Use the Setup Wizard 

The set up wizard offers a quick way of getting started. You will complete 5 simple (optional) screens 

which allows you to setup basic information such as properties, paddocks, mobs and groups prior to 

adding your  animals.   Please use this quick start guide to assist you or the full manual for more 

detailed set up information. 

 Go to Setup > Setup Wizard  or use Ctrl+Alt+Z on your keyboard. 
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 Please follow the prompts using this Quick Start Guide to assist you.  Once you have 

entered your basic setup you can use the setup menus to add, edit or delete setup 

information. 
 

 
 

Option Two - Entering setup information using the setup menus 

 Mobs, groups, properties, paddocks, treatment and products etc can be entered into a drop- 

down list to save time typing and to speed up data entry. 
 

 

 
 

 

 You can also add to the setup lists through the use of the   plus button which can be 

found throughout the data entry screens as you use the program (add on-the-fly). 

 
 

 
If the selection that you require is not in your dropdown list, click on the (plus button) and 

enter the required information, this will now be added to your dropdown list.(add on-the-fly) 

 We suggest that you set-up most of the initial information from the menu items.  This will 

speed-up  the adding of animals in the first instance.   Additions to the list can then be 

added on-the-fly as new items are required. 



8 

© <2012> … Practical Systems 

 

 

 
 

3.2 Setup Backup Preferences 
 
 

 Before we start working our way through the suggested setup lists it is important 

to first setup your backup preferences. 

 Backing up is fundamental to managing your Stockbook data. 
 

 

  Go to Setup > Backup Preferences. 

 

 
 

 
 

Select your preferences by ticking or unticking the series of tick boxes. 
Click on the yellow folder (browse) in the backup location and select a location for your backups. 

 
Note: If you would like it to default to a memory stick please insert the memory stick into your 
computer and you will be able to set this location for all your backups. 

 
Backing up is vital and cannot be over-emphasized please see section 3.5 for how to backup. 

Relevant 
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3.2.1  Data Warehouse Setup 
Backing up your data is the most important part of using Practical Systems software. It is also 

important to have a Backup that is external to your computer and possibly even in another location 

away from your office or home, in case of any unforseen event. 
 
 

The Practical Systems Data Warehouse is a secure, off-site data storage service, located on the 

Practical Systems server at our office. 
 

 

 Click on Data Warehouse Admin. 
 

 

 
 

 

 the first time you login, your password will be YOUR CLIENT ID, You will then be prompted 

to change your password 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 You can change your password at any time by logging in via Data Warehouse Admin and 

selecting Change Password from the drop down list 
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3.3 The Setup Menus 


The following outlines suggested lists to setup prior to adding your animals. 

Each setup list follows the same basic rules and allows you to do the following: 

Add a new item: 

  Go to Setup and select desired list (e.g. Setup > Mobs). 
Click on Add. 
Enter a (unique) code (if code required) and description. 
Click on OK to accept the data and prepare for another entry, or click on Cancel/Exit to close 
the screen without any changes to the database. 

Edit an item: 

  Go to Setup and select desired list. 
Highlight the item to be edited and click on Edit or double click on the item. 
Modify details as required, or make inactive (for items you no longer want to appear in the 
list). 

 

Delete an item: 

  Go to Setup and select desired list. 
Highlight the item to be deleted. 
Click on Delete. 
Confirm the deletion. 

 
Note: You cannot delete an item that still contains at least one active animal within the selected list. 

 The following outlines suggested lists to setup prior to adding your animals.  Keep in mind 

any items can be added on-the-fly by using the  plus button next to the drop down list 

on the appropriate screens. 
 

 
 

3.3.1  Setup Mobs 

 Mobs are a convenient method of organising animals, normally corresponding to physical 

mobs in paddocks.  A mob can, however, be split over several paddocks, and can be used as 

a wider grouping method than a paddock. 
 

 

Example of Mob Setup First page of Stockbook filter - by clicking ‘More’ 

allows you to access another 3 pages of filter 

options. 
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You may choose to setup your mobs as e.g. sale bulls, young bulls, autumn calvers, Rams etc. or use 

the year drop as the mob name.  It’s purely a personal preference, but keep in mind how you would 

like to find/search  for these animals in the future by using the filter within Stockbook. The filter 

allows you to filter/search  on  criteria such as mob, group, paddock through to more advanced 

criteria such as weights, carcass feedback, and fleece data. (See sample on first page of Stockbook 

filter). 

Animals can be in several different mobs or groups over their lifetime but can only be in one mob or 

group at any one given time.  You can make a mob inactive or delete it.  If you wish to view inactive 

mobs tick include inactive box. 

Note: A mob cannot be made inactive or deleted if there are currently active animals in that mob. 

 Go to Setup > Mobs menu option.  A list of current active mobs will be displayed.  Note:  This 

will be blank the first time.  From this display you can: Add a new mob, Edit a mob or Delete a 

mob. 
 
 

 
3.3.2  Set up Groups 

 

 
 Groups are a convenient method of organising animals outside a paddock or mob.  A group 

could be set up for a particular management purpose e.g. breeding cows, sale bulls etc.  You 

may decide not to put animals into a group initially and only move some into a group if the 

need arises at a later date. 

 

 

Example of Group Setup 

  Go to Setup > Groups.  A list of current active groups will be displayed. 

Note this will be blank the first time. From this display you can: 

Add a new group, Edit a group or Delete a group. 
 

 

3.3.3 Setup Properties 
Every animal on file can be assigned to a paddock. Every paddock must be linked to a property. 

  Go to Setup > Properties menu option. 

A list of active properties will be displayed. To include inactive properties, tick the Include 

Inactive box.  From this display you can: 

Add a new property, Edit a property or Delete a property. 
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3.3.4  Setup Paddocks 
Paddocks relate to a physical paddock, however if you do not wish to use paddocks you can 

add a paddock that has the same name as your property. 

Paddocks are used to record paddock treatments from a quality control perspective, animal 

grazing history and assist with filtering and reporting. 
 

 

  Go to Setup > Paddocks menu option. From this display you can: 

Add a new Paddock, Edit a paddock, Delete a paddock or Add Paddock Treatments. 
 

 

 

Example of Paddock Setup 
 

 
 

Understanding the Paddocks List 

 This list presents basic details of every paddock in your database. 

Important colour coding: 

Dark Green Background:  Indicates the paddock you have selected.  To select paddocks in a 

continuous group – click on the first paddock hold down the Shift key and then click the last 

paddock.   Individual paddocks may be selected or deselected by holding down the Ctrl key 

and click on the paddocks required. 

Maroon italic: Indicates the paddock is inactive. 

Red text:   Indicates the paddock is currently in a withholding period due to a previous 

chemical treatment. 
 
 
 

3.3.5  Setup Treatments 

 Treatments are operations carried out on animals or paddocks where a specific product is 

used.  A description of the treatment type must be setup before they can be used. 
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Animal Treatments 

Define your own treatment names for animal treatments.  We suggest using a general description 

rather than a treatment method. E.g. ‘Internal Parasites’ rather then ‘Drench’ or ‘External Parasites’ 

rather than ‘Pour-on’, ‘Vaccination’ rather than ‘5 in 1’etc 

 

  Go to Setup > Treatments/Animal. From this display you can: 

Add a treatment, Edit a treatment or Delete a treatment. 
 

 

 
 

 

Example of Animal Treatments 
 
 
 

Paddock Treatments 

Define your own treatment names for paddock treatments.  Again we suggest using a general 

description rather than a treatment method. E.g.  ‘Weed Control’ rather than ‘Spray’. 

  Go to Setup > Treatments/Paddock.  From this display you can: 

Add a treatment, Edit a treatment or Delete a treatment. 
 

 

 

Example of Paddock Treatments 
 
 

 
3.3.6  Setup Products 

 

 

 Products for use in animal and paddock treatments can be entered via the setup menu. E.g. 

5 in 1. When adding a product, the Used in Treatment field can be selected from the 

dropdown list you created when you setup treatments. 
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  Go to Setup > Products or Products > Setup.   Both will take you to the same Products 

screen.  From this display you can:  Add a new product, Edit a product or delete a product. 
 

 

 
 

 

Example of Products setup Example of Add Products screen 
 

 
Note:   After you add the withholding period in days, whenever that product is applied during a 

treatment the withholding period is added to the treatment date, giving a release date.  The animal 

or paddock will be displayed in red text indicating it is in a withholding period.  An attempt to sell this 

animal  will  give  a  warning,  as  will  attempting  to  move  animals  into  a  paddock  that  is  in  a 

withholding period. 
 

 
3.3.7  Setup Veterinary Activities 

  Veterinary Activities relate to procedures that are of a general nature and do not require the 

use of a product. (E.g. Brucellosis Testing, Eye Operation, Feet Trimming).  You can define as 

many different activities as you like. 

  Go to Setup > Veterinary Activities.  From this display you can: 

Add a new veterinary activity, Edit a veterinary activity or Delete a veterinary activity. 
 

 

 
 

 

Example of Veterinary Activities’ 
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3.3.8  Setup Cost Events 

 Cost Events are descriptions that you can setup as standard descriptions for recording 

animal costs eg. Transport, yard dues, commissions etc.  You will notice there is already an 

extensive list setup in this area of the program. 

 

  Go to Setup > Cost Events. From this display you can: 

Add a new cost event, Edit a cost event or Delete a cost event. 
 

 

 
 

 

Example of Cost Events 
 

3.4 Setup User Options 
User options allow you to customise parts of Stockbook. 

 Go to Setup > User Options 

The six user option tabs are: 
   General 
   Options 
   Screen 
   User Fields 
   Colours 
   Animal Display 
Suggested areas to setup initially are: 

 Go to General tab – Enter your trading name.  This is the name you would like to appear at 

the top of any reports generated through Stockbook. 

Installation type must be set on “Normal” (Both for Stud and Commercial users) unless the 

program is being operated by a Breed Society. E.g. You are an actual Breed Society. 

Performance Recording System is only used if you submit data to a performance recording 

system. You do not need to do this if you are enrolled in Breedplan. 

 Go to Options tab – select your preferences by ticking or unticking the boxes. 

 Go to User Fields tab – This allows you customise/change the labels on the ‘Basic Animal 

Details’ screen;  it is advisable to keep alternate ID and NLIS ID as is. 

 Go to Animal Display tab – This allows you customise your main animal display screen. 

Put a tick in the box beside each field you would like to have displayed. 
When you have completed choosing the fields you wish to have displayed, click Assign and 
then click OK. 
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Note : The weight option displays the last weight taken for that animal. The Micron option (for 
sheep producers) displays the last Micron measured. 

 

 
 
 

Now you have completed your setup you have a great head start to minimizing data entry. 
 
 

  For Stud operations, please complete the section “Additional setup for 

Stud Operations” in Part 5 of this quick start guide. Setting up Stud 

information is strongly recommended before adding your animals. 
 

 
 

3.5 Backing Up 

 FOLLOW THE STEPS BELOW AND BACKUP YOUR DATA SO FAR, BEFORE ADDING 

ANY ANIMALS. 
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 If you chose to Send a copy of the backup to the Practical Systems Data Warehouse: 

 Once you click OK to complete the local backup you will be required to login to the 

Data Warehouse using you Client ID and Password (the first time you login your 

password will be you Client ID, and you will be prompted to set a new one, see 

section 3.2.1) 

 

 Once you’ve successfully logged onto the serve, you have the option to Password 

Protect the backup. This is completely optional, click Next to continue 

 Enter a backup file description, such as the date of the backup or the activity that 

you completed in Stockbook that session. 
 

 

 
 

3.6 Restoring a Backup 

 In the event of things “going pear shaped while adding your animals” you can simply restore 

your backup that you made prior to adding animals and try adding animals again. If restoring 

from the Practical Systems Data Warehouse please refer to the User Manual. 
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






4 Adding your animals Into Stockbook 
 

 There are various methods of adding your existing animals for the first time.   The 

following illustrates how to manually add animal details. 
 

 

 For a full list of methods for adding animals refer to section 4.5 of this quick start 

guide. 
 

 
 

4.1 Manually Adding Animals into Stockbook 
 

 
There are a few options for manually adding animals – 

 

 
Option one – Use the Add button from the main animal screen (see section 4.2) 

Option two – Use the Add animal wizard (see section 4.3) 

Option three – Use  Multi-Add (see section 4.4) 
 

 

 
 

 

Example of where to find the various ways of manually entering animals 
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4.2 Using the Add button 

 Manual data entry allows you to enter as little or as much information as you require. 

If you do not add a Primary Id (visual ID) Stockbook will generate one for you. 
 

 

 

Example of option one – Using Add button 
 

 
 

4.3 Using the Add Animal Wizard 

  Using the add animal wizard steps out the process of adding an animal over a series of 

4 screens.  If you do not add a primary Id (visual ID) Stockbook will generate one for 

you. 
 
 

 

Example of option two – Using the Add Animal Wizard 
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4.4 Using the Multi-Add 

 Multi-Add  allows you to add a number of animals either by allocating a specific 

Visual ID range or by retrieving tags numbers from an unallocated tag list. 
 

 

 

Example of option three – Using the multi-add 
 

 
 

4.5 Methods for Entering Animals Into Stockbook 

  As mentioned there are various methods of adding your existing animals for the first time. 

The following table illustrates the various options for entering animals into Stockbook. Use this 

table to help you decide the easiest way to enter your animals based on your type of operation, 

equipment and animal information you have. 
 

 
Method of entry into 

Stockbook 

Equipment Needed Recommended for Ease of use 

Manual Data Entry via the 

add animal, add animal 

wizard or Multi add 

screen. Starting at your 

oldest animal first. 

Stockbook 

computer 

Visual Id numbers and 

animal details 

This method is recommended for 

small herds/flocks. 

Easy 

Data Extraction from your 

Breed Society. 

Data Extraction forms 

are available from 

Practical Systems. 

This method is recommended for 

setting up Stud animals. 

Easy 

CSV Import or import 

from data collector file. 

Stockbook 

Computer 

Excel file converted to a 

CSV file 

or 

Data collector file 

If you have animal information in 

excel spread sheets (note this will 

need to be saved as CSV files 

before importing into Stockbook. 

You can also import files that 

been created from data collectors. 

Moderate 

knowledge 

of excel & 

CSV files 

required 
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Import data direct from 

collector 

Stockbook 

Computer 

Data collector 

This allows you to import direct 

from your weigh scales 

Moderate 

knowledge 

of hardware 

required 

Transfer data from reader Stockbook 

Computer 

Reader with storage 

This allows you to add animals by 

downloading direct from your 

reader 

Moderate 

knowledge 

of hardware 

required 

Using the laptop screen Stockbook & laptop 

computer to use in 

yards – readers and 

scales can be directly 

plugged into the laptop 

but are not essential for 

using the lap top 

screen. 

This option offers a quick effective 

method of adding animals. 

Ability to 

operate lap 

top 

computer 

and 

hardware in 

the yards. 

Download a tag bucket 

file from NLIS database 

Stockbook 

Computer with internet 

access. 

This method allows you to 

download existing animals and 

unassigned tags assigned to your 

PIC  from the NLIS database. This 

information can then be imported 

into Stockbook. 

 

 

Moderately 

computer 

literate 

 
 
 
 
 

4.6 Animal Types 
 

 
Once your animals are entered your animals into Stockbook they can be seen by clicking on the 

Animals icon. 
 

 

 
 

 

You will notice there are three types of animals in Stockbook: 

1.   Current Animals - The current animals are ones on your farm at this moment. 

2.   Inactive Animals - The inactive animals are those animals that have been disposed of, (either 

sold or died). You can still view these animals on the main data base, look up their history 

and include them in reports.  (These animals can be viewed by putting a tick in the Show 

Inactive box. 

3.   Archived Animals - Animals that have been made inactive can be archived. This procedure 

removes the animals from the current animal list and moves them to an archived database. 

The benefit of this procedure is to reduce your current animal list.  Archived animals can be 

returned to the current animal list if needed. 
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 To adjust your main animal display screen, click on change display located at the bottom 

left of the main animal screen. 

 
 
 
 










5 Additional Setup for Stud Users 
 

 This additional setup is done primarily to facilitate the transfer of data to and from 

Sheep Genetics, ABRI and Breed Societies. 

We have outlined the necessary steps to enable this function. 
 
 
 

5.1 Society and Stud Setup for Stud Cattle 
 

 

 Complete the steps below to enable data import and export facility between Stockbook, 

your Breed Society and ABRI. 

 Complete steps 1 – 4 as pictured below 
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 Go to Setup > Society Details &Follow steps 1 – 8 as pictured below 
 

 

 
 
 
 

5.1.2  Setup Performance Recording for Cattle 
 

 

 Complete the steps below to Setup your Trait Analysis System for Cattle 

 Go to Setup > Performance > Trait Analysis System 
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 Follow the steps 1-3 below 
 

 
 

 
 

 
 

 You must select a minimum of one and a maximum of 19 EBV’s, 

at least one Breed Object and a maximum of 6. 
 

 
 
 

This completes the Society and Stud Cattle Setup 
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5.2 Flock and Performance Recording Setup for Stud Sheep 
 

 

 Please complete the steps below to enable data the transfer of data  between 

Stockbook, Sheep Genetics and your Breed Association. 

 Go to Setup > User Options > Follow steps 1 – 5 
 

 

 
 

 

 It is also advised to review your settings in the options tab 
 

 
 

Setup Flock Details 

 Go to Setup > Flock Details > Follow Steps 1 to 5 
 

 

 
 

 

 If you are registering your lambs with a Breed Association please continue. 
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 Complete steps 1 & 2 below: 
 
 

 
 

 

 Complete steps 1-3 below: 
 

 

 
 
 

 If your flock is registered with ABRI, please complete the following 
 
 

 Complete steps 1 & 2 below: 
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5.2.1  Setup Performance Recording for Sheep 

 Complete the steps below to Setup your Trait Analysis System for Sheep 

 Go to Setup > Performance > Trait Analysis System 

 
 

 

 Complete Steps 1- 3 
 

 

 
 

 

 You must select a minimum of one and a maximum of 19 ASBV’s, 

at least one Breed Object and a maximum of 6. 
 

This completes the setup for Stud Sheep. 



 

 

 


