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Introduction  
 

In this set of activities, students will gain experience with advanced capabilities of the Ansoft/Ansys 

Maxwell 3D software, enabling them to analyze the behavior of an electric generator. Specifically, 

students will create a model of the Southwest Windpower Air-X generator (Figure 1, a 400 W system 

used to charge batteries in off-grid settings) and will simulate the open-circuit voltage it produces under 

specified conditions. The simulation results will then be compared to actual measurements, and 

students will select and analyze the effects of changes to the generator’s design. An understanding of 

several electromagnetics concepts will be required for and enhanced by these activities, the most 

important concept being magnetic induction. The Motor Application Note in the Ansoft/Ansys Maxwell 

v14 User’s Guide was used as a reference for these activities, and it along with other sections of the 

User’s Guide provide examples of additional functions that may be useful to an electric motor / 

generator designer. These activities were developed for educational purposes, independently from 

Ansoft/Ansys and Southwest Windpower. 

It is recommended that these activities be conducted in teams of 2 students. There are three sessions, 

with each session expected to take approximately two hours. Each team should submit a report after 

the final lab session, in a format and at a time specified by the instructor. The report should contain all 

requested data and interpretations, usually emphasized in the procedures by italicized text. Concept and 

design questions are asked throughout the procedures and are summarized at the end of each session. 

Students should discuss these questions with each other and the instructor during the in-class sessions 

but may choose to write their reports outside of class, to ensure that the simulations are completed 

during the allotted time.  

 

 
Figure 1. Southwest Windpower Air-X wind generator (http://windenergy.com) 

http://windenergy.com/


Session I – Modeling the Air-X Rotor and Stator 

2 

 

Session I - Modeling the Air-X Rotor and Stator 

Creating a Model of the Rotor 

The rotor of the Air-X generator (Figure 2) is connected to the Air-X blade-hub assembly and rotates 

along with that assembly when it’s windy. The rotor has 12 permanent magnets with alternating 

magnetic field directions distributed around its perimeter. When the rotor spins, these rotating magnets 

will create a changing magnetic field through the stator coils. This changing magnetic field will induce an 

EMF (i.e., voltage) across the coils’ terminals, providing power when a load is connected across the coils. 

 
Figure 2. Rotor of Southwest Windpower Air-X wind generator.  

(From http://store.windenergy.com) 
 

Initializing Global Variables 

To model the rotor, first start the Maxwell 3D software. (Select “OK” to any warnings about 

WebUpdate.) Set the following global options, ignoring the other options on each tab for now: From the 

pull-down menus at the top of the main software window, select Tools->Options->Maxwell3D Options. 

Under the General Options tab, check “Duplicate boundaries/mesh operations with geometry” and then 

select OK. Next, select Tools->Options->Modeler Options. Under the Operation tab, select 

“Automatically cover closed polylines.” Under the Display tab, make sure that “Highlight selection 

dynamically” is not checked. On the Drawing tab, select “Edit property of new primitives,” and then 

select OK. Finally, set the default units to mm via the Tools->Options->General Options->Default Units 

tab (you may have to scroll upward in the Length pull-down list to find mm). 

From the main pull-down menus, select Project->Insert Maxwell 3D Design. A default outline for this 

design type will appear in the Project Manager window, in the upper-left corner of the main software 

window. The first item in this window, the Project’s name, will be changed when you save the file (File-

>Save As). To change the second item in the list, the Design’s name, you may right-click on the default 

name and use the Rename option. Select Maxwell 3D->Solution Type and check the “Transient” option 

(in the “Magnetic” category) to complete the initial setup. Next you’ll create a model of the Air-X rotor. 



Session I – Modeling the Air-X Rotor and Stator 

3 

 

Importing and Editing “User Defined Primitives” of the Rotor 

Fortunately, Maxwell contains a library of common rotor and stator models. These models were created 

in a companion program called RMXprt and can be imported directly into Maxwell. So, instead of 

starting from scratch, you can use one of these existing models and change a few parameters to get a 

reasonably close fit to your system. Select Draw->User Defined Primitive->Syslib->RMxprt and notice 

the range of existing models. Most models with the word “core” in the name could be used to create 

either a rotor or a stator, depending on the parameter values.  

Select a rotor (i.e., core) type that looks interesting, and review the descriptions of the default 

parameters that pop up. You may need to expand the pop-up window and change the column sizes to 

see the entire description of each parameter, as shown in Figure 3. Select OK to create the object using 

the default parameters, save a screen shot of the resulting graphic image (Edit->Copy Image in Maxwell 

and then CNTL-V in Microsoft Word), record the name of the rotor type, and then delete the rotor object 

(Edit->Delete or the Delete key) after you’ve captured its image. If you have trouble deleting the object, 

try selecting its graphic or its name in the list to the left of the graphing area (known as the “Model 

Tree”), such that the graphic is highlighted in pink, and then try to delete it again.  

 

Figure 3. Parameters for the SquirrelCage model, an example User Defined Primitive in Ansoft/Ansys Maxwell.   
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Save screenshots of the graphical representations of three different core types, and describe a few 

technical differences between the cores you selected. The differences you discuss should be something 

that engineering and physics students would have enough knowledge and training to understand, but 

the general public may not. For example, a comment that “Core X was bigger than Core Y” (assuming no 

additional, more advanced discussion) would not receive many points.  

 

 

We’ll use the User Defined Primitive called PMCore (“Permanent Magnet Core”) to model the Air-X 

rotor. One instance of this primitive will be used to model the non-PM components of the rotor, and a 

duplicate instance will create the magnets, or vice versa. Go ahead and create the PMCore object with 

the default parameters, so that you can see the effect when you change each parameter. After you’ve 

created the object, select the Command tab in the Properties window, located along the middle-left 

side of the main software window. (If you don’t see this tab, or don’t see any values listed in the 

Properties window, expand the “Model Tree” to the left of the graphing area, and select 

Tips & Tricks: Changing the view of your model 
 

 Try the different pan & zoom modes that have toolbar shortcuts located near the top-
right corner of the main Maxwell window, starting with the hand icon  . 

 If you get stuck in one of the pan or zoom modes, press the ESC key. 

 Holding the shift key and the left mouse button while moving the mouse is a handy 
shortcut for panning the view. 

 As a shortcut for zooming in and out, left-click on the location you want to zoom, then 
rotate the mouse track ball forward or backward. 

 If you’re having a difficult time rotating an object in the direction you want, try 
zooming out first. The following represent example ways to then rotate your object: 

o To rotate the object so that it can be viewed from the top or bottom, try 
selecting the “Rotate around current axis” icon, then left-clicking in the lower-
center area of the graphing window and moving the mouse up or down while 
holding down the mouse button.  

 Alternatively, selecting the Alt key and then double-clicking in the 
upper-center of the graphing window will change the view so you’re 
looking down on the object, while Alt-double-clicking in the lower-
center of the window will help you view the object from below. 

o To rotate the object around the Z-axis, select the “Rotate around current axis” 
icon, click in the left-center of the graphing window, and move the mouse 
right or left. 

o To rotate the x-y plane, select the “Rotate around current axis” icon, click in 
the right-center of the graphing window, and move the mouse up and down. 

 To return to the default view, select the Alt key and double-click in the upper-right 
corner of the graphing window. 
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“CreateUserDefinedPart” under the “PMCore1” entry.) Change DiaGap, the diameter of the rotor to the 

gap between it and the stator as shown in Figure 4, to 89.2 mm. Change DiaYoke to 0 mm, since we 

essentially have a solid rotor, and notice how the graphic changes. The rotor’s Length (in the Z-direction) 

should be 12.8 mm.  

As seen in Figure 4, the Air-X generator has 12 permanent magnets around its perimeter. The magnets 

are created so that some have their north pole on the curved side, and others have their south pole on 

that side. The magnets are then placed around the rotor to produce 12 alternating magnetic poles (or 6 

N-S pole-pairs) facing the stator, so that the magnetic field through the stator coils will alternate 

periodically as the rotor spins. Therefore, set the PMCore parameter named Poles to 12. 

 

Figure 4. Example parameters of the Air-X rotor.   

 

The Maxwell software is currently showing you the non-PM portion of the rotor, and if slots have been 

cut into the rotor for magnets, you will see them as blank sections within the rotor. However, if the 

magnets are to be placed along the rotor’s perimeter, as in the Air-X case, you can’t currently see the 

default geometry for the magnets. Change InfoCore (the very last parameter in the Properties window, 

Command tab) to 1, so the graphing window will show you the rotor’s magnets. Now try entering 

different values for PoleType (back near the top of the list), to see the various options for the magnets’ 

locations and geometries in this User Defined Primitive. The PoleType option #3 appears to be the best 

fit for the Air-X magnets’ geometry. 

 

Continuing down the PMCore’s parameter list, the Embrace parameter represents the fraction of the 

rotor’s circumference covered by magnets. Set its value to 0.8, and notice how the graphic of the rotor 

changes. Then enter 6.3 mm for ThickMag, the magnet’s maximum thickness. The parameter WidthMag 

is used only for PoleTypes 4 and 5; in our case, the magnet’s width is determined internally by the 

Embrace parameter, so the value entered here doesn’t matter. Enter a value of 20 mm for Offset, and 

note the effect. If you drew a vector that represented the magnet’s radius of curvature, the offset would 

represent the difference between the rotor’s origin and this vector’s origin, as shown in Figure 5. 

DiaGap 

Length 

N 

S 
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Figure 5. Visual representation of the PMCore “Offset” parameter (from the RMXprt User’s Guide).   

 

The PMCore’s Bridge and Rib parameters do not apply to our PoleType, so leave the default values. 

(Note that although the User Defined Primitives are very handy and descriptions of their parameters 

might be found in the RMXprt software or its documentation, new users can expect to have some 

difficulties understanding at least some of each object’s parameters. So, when you are modeling a 

different electric motor / generator for another project at work or school, you may well need to follow 

the process demonstrated above, patiently selecting different models and exploring their parameter 

options until you find something that fits your project’s needs.) 

 

Now you’ll check whether the parameters entered above fit with a few actual measurements of the Air-

X rotor. Zoom in to view two magnets from the +Z direction, as shown in Figure 6. (For example, try Alt-

double click at the top center of the graphing window to look at the magnets from above, and then use 

the  icon to zoom into a selected area.) Then select Modeler->Measure->Position, as you need to 

measure the distance between two points on the graph. Click on the inner corner of one magnet, and 

then move the mouse (without clicking) to the corner of the adjacent magnet, as shown in Figure 6a. 

Note that the mouse icon changes to a square when it is at an object’s corner. The icon changes to a 

triangle when the mouse is at the center of an object’s edge. The meanings of other shapes can be seen 

by right-clicking on the graphing window and then selecting Snap Mode. Record your measured distance 

between the two magnets, and press the ESC keep to exit the measurement mode. The actual 

measurement for the gap between the magnets on the Air-X rotor is approximately 1 mm. Alter the 

rotor model’s Embrace parameter slightly until the gap measurement on your model is a better fit to the 

actual measurement. (If you don’t see the relevant parameters in the Properties window, select the 

“CreateUserDefinedPart” item in the Model Tree, to the left of the graphing area, under Solids-

>vacuum->PMCore1.) Record your final Embrace value and the associated measurement on your model.  

 

Next, measure the edge thickness of a magnet, as shown in Figure 6b, and update the Offset value until 

this measurement is approximately equal to the measured value of 5.0 mm. Record your final Offset 

value and the associated measurement of the model magnet’s edge thickness. Remember to save your 

model occasionally. 
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                                                         (a)                                                                                                            (b)  

Figure 6. Measuring (a) the distance between two magnets on the Air-X rotor and (b) the magnet’s edge thickness.   

 

 

Select the Attribute tab in the Properties window (if you don’t see this tab, select the “PMCore1” entry 

from the Model Tree, under the “Solids” category), and change the name of this object from “PMCore1” 

to “Magnets” by clicking on the PMCore1 value next to Name. You may also want to change the object’s 

graphed color or transparency; those parameters are located at the bottom of the Attribute tab.  

Now type CNTL-C to copy your version of this User Defined Primitive, and then type CNTL-V to paste a 

second instance of it, since you still need to create the non-magnetic section of the rotor. The new 

object should appear under the “Solids” list in the Model Tree. Rename the new object from 

“Magnets1” to “Rotor” and select the + sign next to the “Rotor” listing in the Model Tree. If you then 

select “CreateUserDefinedPart” under the “Rotor” listing, the dimensions and other parameters that 

you recently specified for the magnets will be displayed in the Properties window. Similarly, you could 

double-click on “CreateUserDefinedPart” to get a pop-up window containing these parameters. Change 

InfoCore (the last property in the list) back to 0 to show the non-magnetic section of the rotor, and your 

entire graphic should now look similar to Figure 7 when viewed from the +Z axis. (To get the same view 

as Figure 7, Alt-double-click in the top-center section of the graphing window, and then select the “Fit all 

the contents in the view” toolbar icon.)  

Don’t worry if it looks like the rotor core intersects with the magnets; the software program graphically 

represents smooth curves as segments to save time, but it resolves the objects at a finer level during 

processing. You can select View->Curved Object Visualization, Absolute Deviation, Apply to see this 

more detailed resolution.  

Before proceeding, you may want to double-check your rotor’s (and similarly, your magnets’) parameter 

entries with those shown in Figure 8. 
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Figure 7. Ansoft/Ansys Maxwell 3D model of the Air-X rotor.   

 

Defining Materials 

Select “Rotor” from the Solids list again, and the Attribute tab should be shown in the Properties 

window. Select the entry that currently shows “vacuum”, and select “Edit” from the pull-down menu. 

(You can also access the materials pull-down menu from the toolbar, where you see “vacuum”.) Either 

search by name or scroll through the materials until you find stainless steel, which the Air-X rotor 

appears to be made of. Select stainless steel (“steel_stainless”) and then OK. If you no longer see the 

rotor in the graphic window, double-click on your project’s name in the Project Manager window. 

The Air-X generator uses nickel-plated neodymium magnets, specifically NdFeB 40H magnets, where ‘40’ 

implies a maximum magnetic energy product, BHmax, of 40 MGOe and ‘H’ indicates a maximum 

operating temperature of 120° C. (More information about these advanced magnets can be found on a 

variety of internet sites, including http://www.kjmagnetics.com.) In Maxwell, assign the material 

NdFe35 to the Air-X magnets as a good approximation, noting that you can create new material listings 

in Maxwell if needed for advanced projects. You’ll specify the north/south direction of the magnets 

later, in the next session. Save your model. Save a screen capture of your complete rotor model for your 

report. 

 

http://www.kjmagnetics.com/
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Figure 8. Maxwell 3D parameters for the Air-X rotor. (Some parameters shown in the list do not apply to PoleType.)  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Additional Rotor Concept and Design Questions 

 The Air-X wind generator is often used in off-grid applications. Given this constraint, why 
might permanent magnets be a better design choice for creating the rotor’s magnetic field, 
rather than electromagnets? What is an application where electromagnets might be the 
better choice? Explain. 

 

 Describe one benefit and one drawback of using neodymium magnets in this design, rather 
than another type of permanent magnet. 

 

 In what country are most of the rare earth magnets, such as those used by the Air-X, made? 
Find and briefly summarize a recent article that discusses issues with using rare earth 
magnets in electric generators, which may or may not relate to the magnet’s country of 
origin. 

 

 As shown in Figure 4, a band wraps around the magnets. The band is screwed into the rotor 
on the far side. What do you think is the purpose of this band? 

 

 What is the effect of attaching the magnets to a stainless steel rotor core? How is stainless 
steel different from, say, copper in terms of its behavior around magnets? 
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Creating a Model of the Stator 

Next you’ll create a model for the stator (i.e., the stationary part) of the Air-X generator. As shown in 

Figures 9 and 10, the stator contains the coils across which EMF will be induced when the rotor spins. 

There are three sets of coils representing the three phases. The coils associated with one phase are 

located on the outer edge of the stator, the second phase is shifted over by one slot and is coiled at a 

slightly smaller radius, and the third phase is in the next set of slots and is closest to the rotor.  

 

 

Figure 9. Side view of the Air-X stator, with the lower steel laminations pulled apart for educational purposes. 

 
  

 

Figure 10. Overhead view of a section of the Air-X stator. 
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Importing and Editing “User Defined Primitives” for the Stator Core and Coils 

Creating the Core 

To help you focus on the stator, first select View->Active View Visibility from the main pull-down menu. 

Uncheck the Visibility box for the “Magnets” and “Rotor” objects, and then select Done. The rotor 

objects should no longer be visible in the graphing area, but don’t worry, they haven’t been deleted. 

Next, import (by using “Draw”) the User Defined Primitive called SlotCore. Go ahead and create the 

object with the default parameters so that you can analyze the effects of changing each parameter.  

After creating the object, select the Command tab in the Properties window to access the following 

parameters. Set DiaGap, the diameter of the side facing the rotor, to 91.3 mm. Set DiaYoke, 

representing the outer diameter of the stator, to 133.8 mm, and observe the effect of making DiaYoke 

greater than DiaGap, which essentially informs Maxwell that you’re modeling a stator rather than a 

rotor. Set the Length to 12.8 mm, the same value that was used for the rotor. The Air-X stator is not 

skewed, but change the Skew to 45°, as you will come across skewed slots in practice. Change the view 

to better see the skewed stator slots, for example by Alt-double-clicking in the upper-right corner of the 

graphing window, and then clicking in the graphing area to de-select the stator. Save a screenshot of the 

skewed stator slots, and conduct an internet search to find one application of a skewed core. 

Select the “CreateUserDefinedPart” item under “SlotCore1” in the Model Tree to access the stator’s 

parameters via the Properties window again, and change the Skew back to 0°. Set the number of Slots 

to 36. Zoom in to a few slots on the graphing window, and see the effects of changing the SlotType 

parameter (values 1-7). For the Air-X model, we’ll use SlotType #4, which will provide a close although 

approximate representation. Save a screenshot of an interesting SlotType other than #4, and then reset 

the value to 4 before proceeding. 

The next several parameters represent details of the stator slot’s geometry. The description for each 

parameter was found in the pop-up window when the object was first created and can be accessed 

again by double-clicking on the appropriate “CreateUserDefinedPart” item in the Model Tree. The 

associated diagram shown in Figure 11 was found in the RMXprt User’s Guide. As you enter the 

following values, you may want to try larger or smaller numbers on occasion to magnify the effect and 

further clarify what the parameter represents. Your final stator slot should look similar to the real Air-X 

slot (with coils removed) shown in Figure 12a. The model image shown in Figure 12b used the View-

>Curved Object Visualization option to more accurately show the stator’s outer edge. 

 Hs0, Slot opening height = 0.8 mm 

 Hs01, Slot closed bridge height = 0 mm 

 Hs1, Slot wedge height = 0.8 mm 

 Hs2, Slot body height = 10.5 mm 

 Bs0, Slot opening width = 2.5 mm  

 Bs1, Slot wedge maximum width = 5.9 mm 

 Bs2, Slot body bottom width, 0 for parallel teeth = 0 



Session I – Modeling the Air-X Rotor and Stator 

12 

 

 Rs, Slot body bottom fillet = 2 mm 

 FilletType, 0: a quarter circle; 1: tangent connection; 2&3: Arc Bottom = 0 

 HalfSlot, 0 for symmetric slot, 1 for half slot = 0 

 SegAngle, Deviation angle for slot arches (10~30, <10 for true surface) = 5 deg 

 LenRegion, Region length = 200 mm (default) 

 InfoCore, 0: core; 100: region = 0  

 

 

Figure 11. Diagram of the stator slot parameters (from the RMXprt User’s Manual)  

  

                                  

 

 
              

 

 

 

                                                                        (a)                                                                      (b)  

Figure 12. (a) Actual and (b) Simulated slots for the Air-X stator. 

 

In the Properties window, Attribute tab (also accessed by selecting “SlotCore1” from the Model Tree, 

Solids category), change the object’s name to “Stator” and change the color and transparency if you 

wish. Next, edit the material. Most cores are made of a “soft” magnetic material with a high relative 

permeability. (Explain why in your report.) Sort the list of available materials according to the magnitude 

of their relative permeability, by selecting the “Relative Permeability” column label in the material 

selection window a couple times. Choose the material with the highest relative permeability, which will 

likely be a type of steel. Select the View/Edit Materials button at the bottom of the material selection 

window, and then select the BH Curve button on the pop-up window to see a section of this material’s 

hysteresis curve. Save a screen shot of this curve for your report (Alt-PrntScrn on the keyboard, then 

CNTL-V in Microsoft Word), and discuss whether the data indicates that the material has linear or non-
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linear magnetic properties, and whether it is a soft or hard magnetic material. Note that you can input 

or edit the H-B entries to fit a different magnetic material, when precision is needed. 

Select “OK” to return to the View / Edit Material window. Select the steel’s Composition Value, and 

change it from Solid to Lamination, as the Air-X core is composed of laminated sheets of steel rather 

than a solid steel block (see Figure 9). Change the Stacking Factor, defined as the proportion of steel to 

insulation in a given direction, to 0.94, and set the Stacking Direction to V(3), the Z-direction. In your 

report, explain the rationale for using laminated sheets for the stator’s core, and explain in terms of 

physics phenomena why stacking the sheets in the Z-direction is the best option. Also discuss why 

engineers often construct larger cores from a specialized form of steel, labeled M19, even though it’s 

more expensive. (Conduct a simple web search about M19 steel to aid in your interpretation.) Select 

“OK” to finalize the stator’s material, and save your model. 

 

Creating the Coils 

When you look at the list of User Defined Primitives, you’ll find four coil models: ConCoil (Con => 

concentric), LapCoil, TransCoil (Trans => transformer), and WaveCoil. Find an image of a lap coil and a 

wave coil for your report. In the case of the Air-X generator, the ConCoil option appears to be the best 

fit. For each phase of the Air-X stator, a person hand-winds a coil around the first pair of appropriate 

stator slots, then changes from clockwise to counter-clockwise rotation (or vice-versa) while winding the 

next coil for that phase in the next set of designated slots, and so on using one long wire, so that the 

EMF produced by each coil in the series will add in-phase while the alternating magnetic poles rotate 

past. This stator coil arrangement is often used in car alternators as well.  

Select Draw->User Defined Primitive->SysLib->RMxprt->ConCoil, and select OK to create the coil with 

the default parameters. You may want to change the viewing angle to see the coils better. Enter the 

same parameter values that you used in creating the stator core, until you reach the coil-specific values 

(starting with LayerLoc). Then enter the following values, observing how each entry affects the coil: 

 LayerLoc, (0: whole; 1: middle; 2: top; 3: bottom) = 3 

 CoilPitch, Coil pitch measured in slots = 3 

o The coil will loop through the 3rd slot from the starting slot. The two intermediate slots 

will be used for the other two phases. 

 EndExt, One-side end extended length = 3.6 mm 

o The plastic inserted into the slot extends about this far above (and below) the stator 

core 

 LayerExt, Span layer extension in the axial direction = 2 

o Multiplication factor for how far the coil extends from the rotor axially 

 LayerDiff, Span layer difference in the radial direction = 0 

 AltEnd, 0: same end layers, 1: alternate end layers = 1 

 InfoCoil, (0: coil; 1: terminal1; 2: terminal2; 100: region) = 0 
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You may wish to check your entries against the coil parameters listed in Figure 13. Select the Attribute 

tab (or “ConCoil1” from the Model Tree, Solids list), change the object’s name to “PhaseA_Coil”, change 

the material to copper, and set the color and transparency values as desired. Do select a unique color 

for this coil, as it will help to distinguish the three phases later. 

 

 

Figure 13. ConCoil parameters used to model an Air-X stator coil. 

 

You will duplicate this example coil to create the starting coils for Phases B and C, and then these coils 

will be duplicated to create a series of coils for each phase. If the existing “PhaseA_Coil” object is not 

already selected (i.e., highlighted in pink), click on its name in Model Tree. Type CNTL-C to copy the 

object, then CNTL-V to paste a duplicate of it. Rename the duplicate to “PhaseC_Coil”, and change its 

color to something unique in your model. Then select “CreateUserDefinedPart” under the “PhaseC_Coil” 

entry in the Solids list, to access the object’s other parameters. Change the LayerLoc entry to 1 (middle), 
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to wrap this coil next to the Phase A coil. Select the Phase C coil by either clicking on its graphic or 

selecting its name in the Solids list. Then select Edit->Arrange->Rotate, and rotate the coil around the Z-

axis by 10°. (Since the Air-X stator has 36 slots, moving from one slot to the adjacent one represents a 

rotation of 360/36 = 10 degrees.) Repeat the process to create the first Phase B coil: Copy and paste a 

duplicate of the PhaseC_Coil object; change its name to PhaseB_Coil; assign it a unique color; change its 

LayerLoc parameter to 2 (top); and then select the coil and rotate it around the Z-axis by 10°. Your stator 

model should now look similar to the one shown in Figure 14. 

 

 

Figure 14. Ansoft/Ansys Maxwell 3D model of the Air-X stator, at the point where each phase has one coil. 

 

Now you’ll create the rest of the coils in each phase. In the Air-X stator, the second coil in each phase 

starts three slots from the beginning of the first coil. (The end slot of the first coil is actually the starting 

slot of the second coil – that is, one slot will contain wires from two coils in a series, as shown in Figures 

9 and 10.) This shift of three slots corresponds to a 30° rotation around the Z-axis. Therefore, you will 

create a duplicate of the first coil and rotate it by 30° to create the second coil in each phase, and so on 

around the stator. Luckily, there is a shortcut for this operation. Pressing the CNTL key so that you can 

select multiple items, select PhaseA_Coil, PhaseB_Coil, and PhaseC_Coil from the Solids list. Then select 

Edit->Duplicate->Around Axis and enter the following values:  Axis: Z, Angle: 30°, and Total number: 12. 

Select OK, and the remaining coils in each phase will be created. That function saved some time! As 

another time saver, you do not have to create a layer of insulation between the coils and the stator core 

in this model – the conductivities of the copper and steel are so different that Maxwell automatically 

considers their boundary to be a non-conductive path.  

Select View->Show All->All Views to see the rotor components as well, and then select the “Fit all the 

contents in the view” icon from the toolbar. The result should look similar to the actual and simulated 

Air-X generators shown in Figure 15. Save your model. Save screen captures of a couple different views 

of your completed electric generator model for your report. 
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(a)                                                                                                        (b) 

Figure 15. (a) Actual and (b) Modeled Air-X generators. 

 

 

Summary of Specific Information Requested for the Lab Report 

From the Ansoft/Ansys Maxwell 3D Software: 

 Screen shots and comparisons of three cores from the list of User Defined Primitives. 

 Measurement of the gap between two magnets when the rotor’s Embrace parameter is 0.8, and 
the final Embrace value which made the gap approximately 1.0 mm, along with the final gap 
measurement. 

Additional Stator Concept and Design Questions 

 The Air-X stator coils appear to be made of 16-gauge copper wire, approximately 1.3 mm in 
diameter. List one advantage and one disadvantage of using a smaller diameter (larger 
gauge) wire in a coil. 

 

 Magnet wire, such as the wire used for the Air-X stator coils, is coated with enamel, and the 
entire coil assembly of the Air-X stator is covered with an additional, thicker coat of enamel. 
Discuss the rationale for these design choices. 

 

 As shown in Figure 9, a plastic insert is placed around each slot before the coils are wound. 
Why are these inserts needed? 

 

 As shown in Figure 10, a plastic insert is placed into each slot opening after all of the coils 
have been completed. What is the purpose of this plastic insert? 
 

 One end each phase’s wire is connected to the Air-X circuit board, while the other ends of 
the three coils are soldered together. What is the name for this type of three-phase 
connection? 
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 The value of the rotor’s Offset value which made the magnets’ edge thickness approximately 5.0 
mm, and the model’s measurement of that thickness. 

 Screen shot of your rotor model. 

 Screen shot of a SlotCore SlotType other than #3. 

 Screen shot and example application of skewed slots (or skewed coils). 

 Screen shot of your selected ferromagnetic material’s hysteresis curve. Discuss whether the 
data indicates that the material has linear or non-linear magnetic properties, and whether it is a 
soft or hard magnetic material. 

 Two screen shots showing different views of your combined rotor / stator model. 

Additional Concept and Design Questions: 

 Why might permanent magnets be a better design choice for creating the Air-X rotor’s magnetic 
field, rather than electromagnets? What is an application where electromagnets might be the 
better choice? Explain. 

 Describe one benefit and one drawback of using neodymium magnets in the Air-X design, rather 
than another type of permanent magnet. 

 In what country are most of the rare earth magnets, such as those used by the Air-X, made? Find 
and briefly summarize a recent article that discusses issues around using rare earth magnets in 
power generation, which may or may not relate to the magnet’s country of origin. 

 What do you think is the purpose of the band that wraps around the Air-X magnets? 

 What is the effect of attaching magnets to a stainless steel rotor core? How is stainless steel 
different from, say, copper in terms of its behavior around magnets? 

 List one advantage and one disadvantage of using a smaller diameter wire in a coil. 

 Discuss the rationale for coating magnet wire and coils with enamel. 

 Why are plastic inserts placed around each slot in the stator? Why is a plastic insert placed into 
the slot’s opening? 

 One end each phase’s wire is connected to the Air-X circuit board, while the other ends of the 
three coils are soldered together. What is the name for this type of three-phase connection? 

 Most stators are made of a “soft” magnetic material with a high relative permeability. Explain 
why. 

 In your report, explain the rationale for using laminated sheets for the stator’s core, and explain 
in terms of physics phenomena why stacking the sheets in the Z-direction is the best option. 
Also discuss why engineers often construct larger cores from a specialized form of steel, labeled 
M19, even though it’s more expensive. 

 Include a picture of a lap coil and a wave coil for reference. 
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Session II – Setting the Initial Simulation Parameters 

In this session, you will use Maxwell’s symmetry option to significantly reduce your model’s size and 

therefore its simulation time, but without affecting the final results. You will then establish the settings 

needed to conduct an initial simulation of the Air-X generator and will analyze the results. You may want 

to save a copy of your current model as a backup before proceeding. 

Reducing the Model Size through Symmetry 

The Ansoft/Ansys Maxwell 3D program has a powerful option which allows you to conduct simulations 

on the smallest symmetric section of a model, and then expand the results to obtain the complete 

solution much faster. The Air-X rotor as 12 magnets representing 6 pole-pairs; therefore, the rotor’s 

geometry and magnetic fields repeat every 60 degrees. The coil geometry repeats every 30 degrees, so 

the stator will also be symmetric at 60 degrees. Therefore, we can simulate a 60-degree slice of the 

generator to determine its output, while reducing the simulation time by a factor of 6. We will also slice 

the generator in half, in the XY plane (making upper and lower halves), taking advantage of that 

symmetry as well. As a result, 1/12 of the original volume will be simulated. 

To begin sectioning the model, select Edit->Select All. Then select Modeler->Boolean->Split and enter 

the following parameters: Split plane: XZ (Read that carefully), Keep fragments: Positive side, Split 

objects: Split entire selection. The “Delete invalid objects…” entry should be checked. Select OK. Save a 

screen shot of the result. Did the result seem to fit with the parameters you set in the Split window? (If 

not, the undo button may be handy  ) 

Now rotate the section you want to keep into the negative XZ plane, as follows:  Assuming all objects are 

still highlighted, select Edit->Arrange->Rotate. Rotate around the Z-axis in the negative direction, -60 

degrees in our case. Select Modeler->Boolean->Split, with entries Split Plane: XZ, Keep fragments: 

Negative side (Read that carefully), and Split objects: Split entire selection. Then rotate the remaining 

section, representing 1/6 of the original, around the Z-axis by +60 degrees to get back to the starting 

point. Finally, split the model along the XY plane, keeping the +Z side. The result should look similar to 

that shown in Figure 16. Save a screen shot of your reduced model. 

In the Model Tree, Solids list (in the copper group), select each coil name in turn so that you can see the 

coil sections remaining in the reduced model. When put together, the coil sections should create two 

complete coils for each phase. Unfortunately, from the Maxwell software’s perspective, there are areas 

where these two coils are occupying the same space, so the simulation cannot be conducted with the 

existing coil models. However, we can delete one of the two coils in each phase and double the 

simulation results to get the proper values, due to symmetry. For example, look at the alignment of the 

two Phase A coils with the magnets, and note their symmetry: Assuming that one magnet has its north 

pole aligned toward the stator and the adjacent magnet has its south pole facing the stator, when one of 

the Phase A coils sees an increasing magnetic field, the adjacent coil will see the same magnitude of 

change in the magnetic flux, but in the opposite direction. Assuming that the adjacent coils are wound in  
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Figure 16. Symmetric section of the Air-X model. 
 

opposite directions (i.e., clockwise vs. counter-clockwise), the EMF produced in these two coils will be 

equal in magnitude and will add in-phase. Therefore, you should delete coil sections until just one 

complete coil from Phase A remains, and you will later compensate for this change in the final analysis 

settings. Repeat the process for Phase B, so that only one coil remains. Unfortunately, from Maxwell’s 

perspective, the Phase C coils intersect with the others, so all of the Phase C coils must be deleted 

before the computation can proceed. The Phase B coil will still allow you to see the phase shift from 

Phase A, however, and Phase C will be identical except for an additional 120-degree phase shift. Your 

model should now look similar to Figure 17. 

 

 

Figure 17. Symmetric section of the Air-X model with intersecting coils removed. 

Specifying the Magnets’ Fields 
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Now that you’re down to just two magnets, it will be easier to define the direction of the magnetic field 

created by each magnet. To start the process, you’ll need to separate the magnets into two unique 

objects. Select the existing “Magnets” object from the Solids list (NdFe35 section), and then select 

Modeler->Boolean->Separate bodies. The two magnets should now be separate objects. Rename the 

“Magnets” object to “Magnet_S” and rename the “Magnets_Separate1” entry to “Magnet_N”.  

Select the “Magnet_N” object, and edit its material. With “NdFe35” selected in the materials window, 

click on the View/Edit Materials button. Since the magnetic field shown in Figure 18 appears to be 

somewhat spherical in nature, select “Spherical” from the Material Coordinate System Type pull-down 

menu in the upper-right corner of the View/Edit Material window. Then select OK, respond “Yes” to the 

pop-up window, and select OK on the main materials window. Now select the “Magnet_S” object and 

edit its material. With “NdFe35” selected, click on the Clone Material(s) button. Name the material 

“NdFe35_S”, verify that it has a spherical coordinate system, and set the Rho Component parameter to -

1, where the negative sign indicates that the field will be directed inward (southward) along radial lines. 

Select OK a couple times to finish the process. 

 

 

 

 

 

 

(a)                                                                                             (b)  

Figure 18. (a) Overhead and (b) Side views of iron filings indicating the magnetic field produced by an Air-X magnet. 

 

Currently, the magnets’ materials are associated with the Global coordinate system, as seen by the 

Orientation parameter on the Properties window, Attribute tab. This means that the magnets’ field lines 

will be aligned with spherically radial vectors emanating from the origin. Although this does not 

perfectly represent the magnets’ actual fields, we’ll use this setting as a decent and not-too-complicated 

initial value and will refine these fields later if needed.  

 

Defining the Region where Electromagnetic Fields will be Calculated 

Now you will define the region where the software program should calculate electromagnetic fields. A 

large region will result in long computation times, but on the other hand, important information may be 

missed if the region is too small. In the case of an electric motor/generator, we care more about the 

fields within the structure than around it, so the region does not need to extend much beyond the 

device. In addition, we must pay attention to the symmetry of the problem, keeping the analysis region 
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out of areas that, in reality, would contain more sections of the generator. In our case, this means that 

the region will be pie-shaped, so some of the Maxwell shortcuts for creating regions (e.g., the 3D box 

and cylinder shortcuts shown in the toolbar) can’t be used. Instead, a 2D rectangle will be swept around 

the Z-axis to create the pie shaped region. 

To begin, select Modeler->Grid Plane->XZ, and rotate the view so that you can see the XZ plane from 

the negative Y-axis (e.g., Alt-double-click on the middle left side of the graphing window). Then select 

Draw->Rectangle, and do not click anything in the graphing window. Instead, notice that entry boxes for 

X, Y, and Z have appeared in the very lower-right corner of the Maxwell 3D window, with the default 

units listed in the lower-right corner. Since you need to start the rectangle (and the pie-shaped region) 

at the origin, enter 0 for the starting X value. Then tab into the entry box for Y, and enter 0. Tab and 

enter 0 for the Z location, and then hit the Enter key. Note that if you move the mouse, it may change 

the numbers in the <X, Y, Z> entry boxes, so try to just use the keyboard when entering these numbers. 

Next, you may enter the stopping location for the plane graphically, by clicking on a point that appears 

on the XZ grid to extend slightly beyond the size of the generator, or you could manually enter dX=70, 

dY = 0, dZ = 30 mm. Say OK to any pop-up windows. The resulting rectangle (after rotating back to the 

default view) is shown in Figure 19. 

Make sure that the rectangle is highlighted, and then select Draw->Sweep->Around Axis. Enter the 

following parameters: Sweep axis: Z, Angle of sweep: 60 degrees, Number of segments: 8. Select OK. 

You should now have a pie-shaped region which defines the volume where Maxwell will analyze the 

electromagnetic fields. In the Properties window, Attribute tab, change the name of the object from 

“Rectangle1” to “Region”, and select the “Display Wireframe” checkbox to more easily see the other 

objects. The result should look similar to Figure 20. Remember to save your model frequently. 

 

 

Figure 19. XZ rectangle used to define the computation region. 
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Figure 20. The pie-shaped computation region for the Air-X Maxwell 3D simulation. 

 

Clarifying Edge Symmetries through Master/Slave Boundaries 

To utilize Maxwell’s symmetry options fully, you will need to set the planes where symmetry occurs, 

known in this case as the “Master” and “Slave” planes. To begin, select Edit->Select->Faces, or press ‘f’. 

Select the original rectangle that you constructed while creating the region, i.e., select the face of the 

region that lies in the XZ plane and faces the negative Y-axis. (Be sure to select the “outside” face.) Then 

select Maxwell 3D->Boundaries->Assign->Master, and in the resulting window, select U Vector->New 

Vector. Click the origin of the global coordinate system (i.e., the lower-left corner of the rectangle from 

this view) to represent the start of this vector, and click the lower-right corner of the rectangle as the 

end of the vector. Select the “Reverse Direction” checkbox for V-Vector, and then select OK. Expand the 

lists in the Project Manager window until you see the entry for the Master1 boundary (you may have to 

use the window’s scrollbar), and select that boundary. The result should look similar to Figure 21. 

 

 

Figure 21. Master plane used for symmetry computations by the Maxwell 3D software. 
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Now rotate to the other side of the pie piece and select the outer face of the region’s ending rectangle, 

which will serve as the symmetric “Slave” boundary. Select Maxwell 3D->Boundaries->Assign->Slave, 

and set the following parameters: Master Boundary: Master1, U Vector: New Vector (start at the origin, 

and end at the outer edge of the rectangle, as you did for the Master boundary), V Vector: Unchecked 

(not reversed), and Relation: Hs = Hm. The result should look similar to Figure 22. One effect of these 

master / slave boundaries pertains to the coils that were broken into separate segments after you cut 

the original model into the 60-degree section: Currents that flow out of a coil into one boundary will 

flow into the associated coil on the other boundary. Select the Boundaries heading in the Project 

Manager window (upper-left area of the main window) to clear the boundary graphics in preparation 

for the next section. Also select ‘o’ to return to the object rather than face selection mode, and return to 

the standard viewing angle (e.g., Alt-double-click in the upper-right corner of the graphing window). 

 

 

Figure 22. Slave plane used for symmetry computations by the Maxwell 3D software. 
 

Defining the Rotor’s Rotation 

Now you will define aspects of the Air X’s rotation. First, you will need to establish which components 

will rotate. You will accomplish this by creating another region, this time called a “Band”, which encloses 

the rotating elements. As with the region, you must be mindful of maintaining the underlying object’s 

symmetry, so in this case the Band will also be pie-shaped. Select Modeler->Grid Plane->XZ (the 

software relies on this grid plane when determining which type of rectangle to create, and will give 

errors if the numeric entries don’t fit within this plane). Then select Draw->Rectangle, or alternatively 

click on the 2D rectangle icon on the toolbar, and enter <0, 0, 0> into the <X,Y,Z> entries at the lower-

right corner of the main software window, remembering to Tab between the entry boxes and press 

Enter when all three values are correct. The ending X value for this rectangle, which is also dX since we 

started at the origin, will represent the line separating the rotating and non-rotating components and 

should therefore be located in the airgap between the rotor and stator. Since the rotor had an outer 
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radius of 89.2 ÷ 2 ~ 44.6 mm (= DiaGap, the diameter of the rotor facing the air gap ÷ 2) and the stator 

had an inner radius of 91.3 ÷ 2 ~ 45.6 mm (also DiaGap ÷ 2), the edge of the rotation region should fall 

within these values. We’ll use a location near the stator, dX = 45.5 mm, for meshing purposes (discussed 

later), dY = 0 mm by definition of an XZ plane, and dZ = 30 mm to match the surrounding Region. Enter 

these values into the boxes at the lower-right corner of the main Maxwell software window, and press 

Enter. Select OK to any pop-up window.  

As with the Region, you’ll sweep this rectangle to create the symmetric pie-piece Band enclosing objects 

that will rotate. Assuming that the starting rectangle is highlighted, select Draw->Sweep->Around Axis, 

and enter the following values: Axis: Z, Angle of sweep: 60 degrees, Number of segments: 0. In the 

Properties window, Attribute tab, change the name of this object to “Band”, and select the “Display 

Wireframe” checkbox. Rotate so that you’re looking at the system from above, and ensure that your 

band encloses the rotor but does not go into the stator, keeping in mind that Maxwell is displaying the 

Band’s curve as segments for now. The result should look similar to that shown in Figure 23. Save a 

screenshot of your view of the Band object for your report. Save your model. 

 

 

Figure 23. “Band” region used by Maxwell 3D to identify objects that will rotate. 

 

Ensure that the “Band” object is still highlighted, and select Maxwell 3D->Model->Motion Setup-

>Assign Band. (If you don’t see the Model option in the pull-down menu, select Maxwell 3D->Solution 

Type and ensure that Magnetic->Transient is selected.) In the Type tab, enter the appropriate settings to 

have the rotor rotate around the Z-axis:  Motion Type: Rotation, Rotation Axis: Global:Z, and Positive, 

but don’t press OK yet. In the Mechanical tab, set the Angular Velocity to 1000 rpm and then press OK. 

(If you make a mistake and need to change your motion setup, you can access this information through 

the Project Manager window, by expanding lists until you find Model->MotionSetup1.) Note that range 

of operable rotation rates for the Air-X is approximately 300-1700 rpm. Save your model. 
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Setting Coil-Specific Simulation Parameters 

In order for Maxwell 3D to calculate some of the information we need for this application, such as the 

EMF produced across the Air-X coils, a few additional simulation parameters will be needed. For 

example, as described in more detail below, you will need to create “Winding” excitations and associate 

them with the Phase A and Phase C coils. Even though the Air-X coils don’t have an excitation (other 

than the changing magnetic field), this entity within the software is where important information such 

as the number of turns per coil are identified. To create an excitation, you must first create another 

entity called a “terminal”, which essentially defines a cross-section of the coil as the reference point for 

calculating induced voltage and current. This procedure will be defined next. 

The terminal needs to be offset (i.e., internal to) the simulation’s bounding region, so an offset 

coordinate system needs to be created. Select Modeler->Coordinate System->Create->Relative CS-

>Offset. Using the entry boxes at the bottom-right of the software window, enter <X,Y,Z> = <0,0,10> 

mm. Then, using the CNTL key, select both “PhaseA_Coil” and “PhaseB_Coil” from the Solids list in the 

Model Tree. Then select Modeler->Surface->Section, set the Section Plane to XY and press OK. This will 

create the cross-section terminal through which Maxwell can calculate the induced EMF and current. 

However, two terminals were created, while Maxwell will just need one. So, open the Sheets list to the 

left of the graphing window, and select the Phase A Section that was just created. Select Modeler-

>Boolean->Separate Bodies to separate the two sheets / terminals. Keep the section that is closest to 

the XZ plane (select each Phase A section in the Sheets list to see where it’s located), rename it as 

PhaseA_Terminal, and delete the other section. Repeat the process for the Phase B coil: Separate the 

two sheets, rename the section that’s closest to the XZ plane, and delete the other section. The 

remaining terminals should look similar to those highlighted in Figure 24.  

Before proceeding, change the coordinate system back to the Global one, for example by opening the 

Coordinate Systems list in the Model Tree and selecting “Global”. This will help to clarify subsequent 

visualizations. 

 

 

Figure 24. Highlighted “terminals” for each coil in the Air-X simulation. 
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The next step in the process is to create a “winding” entity for each coil and to associate that winding 

with the proper terminal. Select Maxwell 3D->Excitations->Add Winding, and set the following 

parameters:  Name: PhaseA_Winding, Type: Current, Stranded, Current: 0 Amps. Select OK, and then 

select the “PhaseA_Terminal” entity in the Model Tree. In the Project Manager window at the upper-

left section of the main window, expand the list until you see the “PhaseA_Winding” under Excitations. 

Right click on it and select Assign Coil Terminal. (If you get an error message, select “PhaseA_Winding” 

in the Model Tree again.) Change the Number of Conductors to 8, as each Air-X coil contains 8 loops of 

wire, but don’t press OK yet. Select Swap Direction to define the default current direction at this 

terminal to be in the positive Z-axis direction, as shown by the vector in the graphing window and in 

Figure 25. Note that this option could be used to clarify a coil’s winding direction. Select OK. Repeat the 

process for Phase B: Create a new winding (“PhaseB_Winding”), associate the new PhaseB_Winding 

with the PhaseB_Terminal, and assign 8 conductors to the winding. 

 

 

Figure 25. Direction of Phase-A terminal, seen after associating a “winding” entity with the terminal. 

 

Setting up Miscellaneous Simulation Parameters 

Select Maxwell 3D->Design Settings. In the Symmetry Multiplier tab, set the symmetry multiplier to 24 

and select OK. This is due to the fact that we cut the model into a 1/6 pie-piece around the Z-axis, then 

divided that piece by half in the XY plane, and then removed one of the two coils used in each phase. 

You now need to set the time step at which the software will create a new set of calculations. You want 

at least several samples for each cycle of the AC signal generated by the Air-X, to clarify the shape of the 

waveform, yet you don’t want the simulation to take forever. Given 12 magnets, or 6 pole-pairs, 6 cycles 

of EMF will be induced with each rotation of the rotor. At 1000 rpm, this corresponds to 6000 cycles per 

minute, or 100 cycles per second. So, 100 samples per second (i.e., a time step of 0.01 s) would give one 

sample per cycle, a time step of 0.001 s would give 10 samples per cycle, etc. For now, we will use a step 

of 0.001 sec = 1 ms, and we’ll stop the simulation at 20 ms to capture two cycles. To implement this, 

select Maxwell 3D->Analysis Setup->Add Solution Setup. In the General tab, enter Stop time: 20 ms 



Session II – Setting the Initial Simulation Parameters 

27 

 

(use the units pull-down menu to select ms) and Time step: 1 ms, but don’t press OK yet. In the Save 

Fields tab, select the following: Type: Linear Step, Start: 0 ms, Stop: 20 ms, Step Size: 1 ms. Then select 

“Add to List” so that you can see the fields at each step of the simulation. Select OK, and save your 

model. 

Select Maxwell 3D->Validation Check to make sure there aren’t any errors with your simulation. One 

expected warning will be associated with “Boundaries and Excitations”, and a more detailed explanation 

will be listed in the Message Manager box in the lower-left corner of the main software window, but 

this warning is not a problem. Notify your instructor if you have any other errors.  

 

Running the Simulation! 

At last, select Maxwell 3D->Analyze All. You can check the status of the simulation in the Progress 

window, in the lower-right area of the main software window. The time step will update as the 

simulation proceeds. One nice capability of the Maxwell software is the ability to start analyzing results 

as soon as one time step is complete. So, you can begin the next subsection as soon as the output file 

associated with the first time step is saved. When the simulation is completely finished (about 10 

minutes for this configuration), you should see a “Normal completion of simulation on server” notice in 

the Message window. If your simulation is taking much longer than other people’s, or you think that 

something’s wrong, check with the instructor. To stop the simulation, click the right-directed arrow in 

the Progress window, and select Abort for an immediate stop, or Clean Stop to finish at the end of the 

current time step. The Clean Stop option will save the data acquired so far. 

 

Obtaining Initial Simulation Results 

Now you’ll view the generator’s magnetic fields. First, select a time step at which you want to view the 

fields, by selecting View->Set Solution Context, which is at the very bottom of the View pull-down 

menu. Select a non-zero time step and press OK. Hold the CNTL key while selecting (using the Model 

Tree) the objects on which you want to see the magnetic fields, such as the rotor, stator, and magnets. 

Then select Maxwell 3D->Fields->Fields->B->Mag_B, check the option “Plot on the surface only”, and 

select Done. Save a screen capture of this visualization. For fun, select Maxwell 3D->Fields->Animate 

and press OK to see an animation of the magnetic fields as the rotor spins. Remember that the software 

is using the symmetry you specified, so even though you see your North and South facing magnets 

rotating away from the coils, the software knows that other pairs of N-S poles continue around the 

rotor, and you can see the magnetic fields induced on the stator by those “invisible” magnets. 

In the Project Manager window, expand the lists until you see the Field Overlays->B visualization that 

you just created. Select the ‘B’ item and press the Delete key so that you can see the next visualization 

more clearly. Select the rotor, stator, and magnets again, and then select Maxwell 3D->Fields->Fields-

>B->B_Vector to see a vector representation of the magnetic field. As before, select “Plot on the surface 

only” to obtain a clearer visualization. To change the characteristics of the vectors, right click on the 
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graph’s scale (the B[Tesla] colorbar) and select Modify. Select the Marker/Arrow tab, and try changing 

some of the parameters (e.g., the Arrow options->Size) to improve the visualization. Options on some of 

the other tabs may help as well. Save a screen shot of your best vector visualization, and interpret the 

image. For example, where are the fields strongest, and does that make sense; do the vector directions 

meet your expectations, given the magnets’ specified directions, etc. You may want to animate the 

vectors as well, to see how the magnetic fields through the coils change in time. 

To clarify the next visualization, select Modeler->Grid Plane->XY and then delete the Field Overlays->B 

item in the Project Manager window again. Select View->Active View Visibility, uncheck everything 

except the magnets, and press Done. Using the CNTL key, select both “Magnet_N” and “Magnet_S” in 

the Model Tree (or select both objects in the graphing window), and then select Maxwell 3D->Fields-

>Plot Mesh and press Done to see the underlying elements used in Maxwell’s numerical analysis 

routines. Alt-double-click in the upper-right area of the graphing window to return to the default view, 

and save a screen capture of the magnets’ mesh at this stage. 

Return to View->Active View Visibility and select the stator, rotor, and coils along with the magnets. 

Press Done. Using the CNTL key, select all of these objects in either the graphing window or the Model 

Tree list. Select Maxwell 3D->Fields->Plot Mesh and then Done to see the mesh on the other objects as 

well. Save screenshots of a couple different views of the underlying mesh. In the Project Manager 

window, delete the MeshPlots entry. Return to View->Active View Visibility and uncheck everything 

except the Stator object. Select Maxwell 3D->Fields->Plot Mesh one last time, and rotate around the 

stator until you can see the meshing on the rotor’s teeth, as shown in Figure 26. Save a screenshot of 

your view of the stator mesh. In your report, interpret the meshes; for example, explain in terms of the 

underlying electromagnetics why the mesh needs to be finer in some areas. 

 

 

Figure 26. The stator mesh created by Maxwell 3D in the Transient solution mode. 
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To see the voltage induced in the coils as the rotor spins, select Maxwell 3D->Results->Create Transient 

Report->Rectangular plot. Set the following values in the subsequent window: Category: Winding, 

Quantity: FluxLinkage(PhaseA_Winding) and (using the CNTL key) InducedVoltage(PhaseA_Winding). 

Then select New Report. Save a screen capture of the plot. This plot probably doesn’t look like the 

sinusoidal AC waveforms that you may have expected, but it is a promising initial result that does show 

the mathematical relationship between the magnetic flux through a coil and the EMF induced across 

that coil. What is that mathematical relationship? In the next session, you will use advanced techniques 

to refine the simulation and obtain a more accurate representation of the EMF induced in the Air-X coils. 

 

Summary of Specific Information Requested for the Lab Report 

From the Ansoft/Ansys Maxwell 3D Software: 

 Screenshot and discussion of the model after splitting it across the XZ plane.  

 Screenshot of the final reduced model, 1/12 of the original model. 

 Screenshot of the Band object. Discussion of the purpose of the Band object. 

 Screenshot of the visualization showing the magnitude of the generator’s magnetic fields. 

 Screenshot and interpretation of the visualization showing the magnetic field vectors. 

 Screenshots of the underlying numerical meshes used in this simulation. There should be one 

screenshot that focuses on the magnets’ faces, another that focuses on the rotor’s teeth, and a 

couple different views of the mesh across the entire model. Interpret the variations in these 

meshes; for example, explain in terms of the underlying electromagnetics why the mesh needs 

to be finer in some areas. 

 Screenshot of the plot showing the magnetic flux through the Phase A coil and the resulting EMF 

induced across that coil as a function of time. Description of the mathematical relationship 

between the magnetic flux through and the EMF induced across a coil, and a discussion of 

whether / how the plot demonstrates that relationship. 
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Now that you have a decent model of the Air-X generator, you can start altering some of the simulation 

settings to obtain more accurate results, at the expense of additional computation time of course. Since 

the focus in this case is on the EMF produced in the Air-X stator coils as the rotor spins, we need to pay 

close attention to the aspects of the model and simulation settings that affect the magnetic flux passing 

through the coils. As seen in the magnetic field plots that you obtained in the last session, the magnetic 

flux is much stronger in the rotor’s teeth (i.e., the steel components) than in the slots, so we will refine 

settings that affect this flux.  

 

One important consideration involves mimicking the device’s material properties and shapes as closely 

as possible, which we did in the previous sessions since the computation time was still reasonable. As an 

example, a stator core with different permeability could make a huge difference in the magnetic flux. In 

addition, you may have noticed that the Air-X manufacturers took special care to smooth sharp edges in 

the magnets and stator slots (see Figures 12 and 18). Why do you think this is important? These rounded 

edges were reproduced in the previous sessions whenever possible, and it would be difficult to alter or 

compensate for the remaining sharp edges, so we will try other improvements in this session. 

 

Another important factor is the time step. While viewing the magnetic flux and induced EMF plots in the 

last session, you probably knew intuitively that the time step was so large, because the plots were so 

choppy. Approaching the problem more analytically, each time step in the last session resulted in a large 

rotation – the magnet passed one of the stator’s teeth which each time step, resulting in a huge change 

in magnetic flux through that tooth. The time step certainly must be refined to improve the simulation 

results. 

 

The underlying mesh represents another important factor in determining the magnetic flux through the 

stator’s teeth, since the magnetic field and other parameters are calculated for each element in the 

mesh. The faces of the magnets and stator teeth facing the airgap between the rotor and stator are 

especially important, since the fields are changing rapidly there. The meshes you recorded in the 

previous session were quite good for a first pass but can be improved.  

 

Finally, the magnetic fields produced by the magnets were not identical to the fields we specified in the 

last session. Although difficult to achieve, some improvements will also be attempted to improve this 

factor. 

 

In the next few sections, you will be guided through making some of the improvements listed above and 

analyzing the effects. You will then experiment with a desig change of your own choice. You may want 

to save a backup copy of your current simulation before you start. 
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Reducing the Time Step 

Reducing the time step is probably the easiest and most significant refinement to the settings used in 

the last session. Expand the list in the Project Manager window until you see the Analysis->Setup1 item. 

Select and delete “Setup1”, and then select Maxwell 3D->Analysis Setup->Add Solution Setup. Set the 

Stop time to 10 ms and the Time step to 0.5 ms in the General tab. We’ll ignore the Save Fields option 

for now to reduce the simulation time. Select OK, save your model, and then select Maxwell 3D-

>Analyze All to run the simulation. (Note that you could have accessed and altered the existing time 

parameters by double-clicking on Analysis->Setup1 in the Project Manager window, but the software 

doesn’t appear to know that the solution needs to be recalculated when those variables are changed. If 

you change something else, such as one of the object’s parameters, Maxwell will receive the trigger to 

conduct a new simulation and will then use your altered time setup.) 

You may select Maxwell 3D->Results->Create Transient Report->Rectangular Plot to see the results as 

Maxwell processes them. Recall that on the pop-up window, you will select “Winding” as the Category 

and then use the CNTL button while clicking each item that you want to analyze from the Quantity list. 

This time, select both the Phase A and Phase B “FluxLinkage” and “InducedVoltage” parameters, and 

then select New Report and Close. In the resulting plot, Phase A should lead Phase B by 120 degrees, as 

expected for this 3-phase design. Note that you may click and drag the “Curve Info” box to see the 

traces better. You may want to work on your report while the simulation runs (~15 minutes). When the 

simulation finishes, use Edit->Copy Image to copy the plot, then CNTL-V to paste the plot into your 

report. Discuss the differences between the plot you obtained in the previous session with a time step of 

1.0 ms, the plot you obtained in this session, and the plots shown in Figure 27, representing time steps of 

0.2 and 0.1 ms. Note that the simulation using a time step of 0.2 ms took approximately 30 minutes, 

while the 0.1 ms simulation took ~50 minutes. For the remainder of this lab, therefore, you may keep 

the 0.5 ms time step as a good compromise between accuracy and computation time. 

 

Refining the Underlying Numerical Meshes 

Many numerical analysis techniques, including those used by the Ansoft/Ansys Maxwell 3D software, 

divide an object into several discrete pieces and solve each variable associated with that piece (e.g., the 

magnetic field strength and direction) at each time step. The smaller these pieces are, the better the 

simulation results will be, as the object then appears to be more continuous than discrete. However, 

smaller pieces also cause longer simulation times, so as always, people try to find a balance between 

realistic results and faster simulation times. 

Other solution types within Maxwell that don’t include motion, such as the Magnetostatic solution type, 

have an adaptive meshing routine that automatically refines an object’s mesh until a specified level of 

accuracy is achieved in the results. In addition, this meshing routine and the underlying numerical 

approach allow for a finer mesh in areas where variables are changing quickly and a courser mesh in 

other areas, to maximize efficiency while obtaining accurate results. Unfortunately yet understandably, 

the Transient option being used in this analysis, which allows for motion, does not automatically refine  
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 (a) 

 

 

(b) 
 

Figure 27. The calculated magnetic flux through and induced EMF across a Phase A and Phase B coil  

when the time step is (a) 0.2 and (b) 0.1 ms. 

 

the mesh (it uses the mesh found after one pass) as the iterative refinements after each motion step 

would take far too much time. 

There are ways that you could alter the mesh of different objects within the Transient solution method. 

Under the Maxwell 3D->Mesh Operations pull-down menu, for example, you could specify the 

maximum number of elements for an object or the maximum size of an element within an object. In 

general, though, it’s difficult through these approaches to get the fine resolution needed in areas where 

the fields are changing quickly without simultaneously obtaining an unreasonably large number of 

elements in the rest of the object. Therefore, we’re going to use a trick where we will switch the 
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solution type to Magnetostatic create a refined mesh, and then input that mesh into the Transient 

design. 

To begin, save a version of your model under a new name. Then select Maxwell 3D->Solution Type, 

change the setting to Magnetostatic, and select OK. If you no longer see the graphical display of your 

model, double-click on your project’s name in the Project Manager window. You’ll soon run the 

Magnetostatic simulation to create the refined mesh, plus check the magnetic fields created by your 

magnets. First, select Maxwell 3D->Analysis Setup->Add Solution Setup to specify a few required 

simulation parameters. In the General tab, set the Maximum Number of Passes to 5 and the Percent 

Error to 5. Many analysts would consider this to be a small number of passes and a large error, but these 

options will demonstrate the benefits of adaptive meshing without taking an unreasonable amount of 

lab time. Select OK, and then select Maxwell 3D->Analyze All to run the simulation.  

When the simulation is completed (~10 minutes, depending on the computer), you should obtain 

screenshots of meshes to compare with those obtained in the previous session, which essentially 

represented one adaptive pass. To begin, go to View->Active View Visibility, uncheck everything except 

the magnets, and select Done. Rotate and zoom to see the curved side of the magnets well. Holding the 

CNTL button, select both magnets from the graphing window or the Model Tree list, so that they are 

highlighted in pink. Then select Maxwell 3D->Fields->Plot Mesh, press Done, and the magnets’ mesh 

under these new conditions should be displayed. Save a screenshot of this mesh. Make the rotor, stator, 

magnets, and coils visible; select those objects in the Model Tree; and plot their meshes as well. Save a 

couple screenshots showing different views of these meshes, and then delete the “MeshPlots” item 

under the Field Overlays list in the Project Manager window. Make only the stator visible, and plot its 

mesh. Rotate and zoom so that you can clearly see the “teeth” of the stator which face the magnets, 

and save a screen shot of the stator’s mesh before deleting its “MeshPlots” item. In your report, 

compare these meshes to those obtained in the previous session. Select View->Show All->All Views to 

show the entire model again, then Alt-double-click in the upper-right corner of the graphing window, 

and select the “Fit all the contents in the view” to return to the default view. Save this model. 

In the Project Manager window, select the name of the current design; it should have “Magnetostatic” 

in the name. Then type CNTL-C to copy the design, and click on the ‘-‘ icon to collapse / hide the list of its 

components. Select the overall Project name, and type CNTL-V to paste a copy of the design. Double-

click on the name of the copied design, and expand the list of its components. Then select Maxwell 3D-

>Solution Type and check the Transient option to allow motion again. Select Maxwell 3D->Analysis 

Setup->Add Solution Setup. In the General tab, change the Stop time back to 10 ms, and the Time step 

to 0.5 ms. In the Advanced tab, select Import Mesh, to import the refined mesh that you just created in 

the Magnetostatic version. Select the “Use This Project” checkbox in the pop-up window, and make sure 

that the name of your Magnetostatic design is listed in the “Source Design” pull-down. Select OK twice 

to accept this setup. 

Unfortunately, a few other settings were deleted when the design was edited in the Magnetostatic 

mode, so you’ll need to recreate the current excitations and the motion setup. Select Maxwell 3D-

>Excitations->Add Winding. Set the name to PhaseA_Winding, click on the Stranded option, and select 
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OK. Expand the list in the Project Manager window until you see the “PhaseA_Winding” entry under 

Excitations. Then expand the Model Tree until you can select the “PhaseA_Terminal” item under Sheets. 

Go back and right click on “PhaseA_Winding” in the Project Manager window, select Assign Coil 

Terminal, set the Number of Conductors to 8, select Swap Direction, and click on OK. Create the 

PhaseB_Winding excitation with the same parameters, and associate it with the PhaseB_Terminal. 

To reset the motion, select the “Band” object in the Model Tree, under the Solids->vacuum list. Select 

Maxwell 3D->Model->Motion Setup->Assign Band. In the Type tab, specify positive rotation about the 

Z-axis, enter 1000 rpm in the Mechanical tab, and press OK. Finally, select Maxwell 3D->Model->Set 

Symmetry Multiplier, select the Symmetry Multiplier tab, enter a value of 24 to account for the various 

symmetries, and press OK. Save your model, and run the Transient simulation with the new-and-

improved mesh by selecting Maxwell 3D->Analyze All. As before, you may see the results as Maxwell 

computes each time step. Select Maxwell 3D->Results->Create Transient Report->Rectangular Plot, and 

then select the Winding category and the relevant PhaseA Quantities before creating a New Report. 

While this simulation progresses, you can start another instance of the Maxwell 3D program and work 

on the next section, which starts on the next page. Once the simulation finishes (approximately 40 

minutes), save a screenshot of the magnetic flux and induced EMF plots, and compare it to the data you 

obtained in the previous section. The data for the time step of 0.1 ms and the mesh that was refined by 5 

adaptive meshes is shown in Figure 28 (compare to Figure 27b). For reference, that simulation took 

approximately 1.5 hours to complete. To obtain a more accurate result, the time step would be further 

reduced and the underlying mesh would be refined by additional adaptive passes in the Magnetostatic 

simulation to reach a lower specified error. Such a precise simulation would clearly take a long time to 

complete and should only be done once all other aspects of your model have been precisely defined and 

tested. 

 

 

Figure 28. The calculated magnetic flux through and induced EMF across a Phase A and Phase B coil when the  

time step was 0.1 ms and the mesh was refined by five adaptive passes. 
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Changing the Coordinate System Associated with the Magnets 

In Session II, we specified in Maxwell that the permanent magnets on the Air-X rotor had spherical fields 

emanating from the origin (i.e., the center of the rotor). However, looking at the iron filings around the 

actual magnets, shown in Figure 18, it appears that the origin of the magnets’ spherically oriented fields 

is much closer to the magnets, and the fields also appear to decay toward the magnets’ edges. We 

would need more information to create a precise model of these magnetic fields, but as a first step 

toward improving the fields’ accuracy (and to gain experience with a valuable tool in Maxwell), you will 

create new coordinate systems that will serve as the basis for the magnets’ field lines. These coordinate 

systems will rotate along with the magnets.  

To start, go back to the model version that you used when changing the time step – the model with the 

less precise mesh and the time step of 0.5 ms – but edit Analysis->Setup1 in the Project Manager 

window to increase the Stop time to 20 ms. Alt-double-click in the lower-center portion of the graphing 

window to view the model from below, and ensure that the Global coordinate system is selected in the 

Model Tree. Press the ‘f’ key to select faces, and click on the rotor. Then click on the “Create face CS” 

toolbar icon . In the lower-right corner of the software window, change the pull-down from 

Cartesian to Spherical, ensure that Absolute is selected in the adjacent pull-down menu, and enter the 

following values (remember to Tab between entries and press Enter when you’re done): Rho = 20 mm, 

Theta = 90 deg, Phi = 15 deg. Then click on the center of the magnet face above this point (the cursor 

should turn into a triangle, and the entry boxes at the bottom of the screen should read dRho = 18.3 cm, 

dTheta = 90 deg, and dPhi = 15 deg). Expand the Coordinate Systems list in the Model Tree to see your 

new coordinate system, called “FaceCS1”. Select it, and change its name to “North_CS”. Then select the 

north magnet’s name in the Objects list, “Magnet_N”, and via the Properties window (Attribute tab) 

change the north magnet’s Orientation to North_CS. The magnet’s spherical field vectors will now be 

associated with this offset coordinate system. 

Select the “Global” coordinate system from the Model Tree, and repeat the process for creating the 

south magnet’s coordinate system: Select the face of the rotor, press the “Create face CS” toolbar icon; 

make it a Spherical coordinate system; set Rho = 20 mm, Theta = 90 deg, and Phi = 45 deg; click on the 

bottom-center of the other magnet (dRho = 18.3 mm, dTheta = 90 deg, dPhi = 45 deg); rename the new 

coordinate system from “FaceCS1” to “South_CS”; and assign the Orientation of the “Magnet_S” object 

to the new “South_CS” coordinate system. The new coordinate systems should look similar to those 

shown in Figure 29. (You can see the coordinate systems by selecting their associated items on the 

Model Tree while pressing the CNTL key.) Save a screenshot of your magnets’ coordinate systems. Select 

the Global coordinate system, press the ‘o’ key to return to the object rather than the face selection 

mode, and Alt-double-click on the upper-right corner of the graphing window to return to the default 

view. 

Select Maxwell 3D->Analyze All to run this simulation, save a screenshot of the resulting magnetic flux 

and induced voltage plots, and compare the result of altering the magnets’ coordinate systems to your 

previous results. 
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Figure 29. Revised coordinate systems for the north and south magnetic poles in the reduced Air-X model. 

 

Altering the Air-X Design 

Make a list of several parameters that you could change in the Air-X model or the simulation settings, 

and predict the effect that each of these changes would have on the final result. Implement one of these 

changes in your Maxwell 3D model of the Air-X generator, and run the simulation. Try to pick different 

modifications than other students, and compare your findings with each other. Record and interpret 

your results. Congratulations, you’re done with the simulations!  

 

Summary of Specific Information Requested for the Lab Report 

From the Ansoft/Ansys Maxwell 3D Software: 

 Screenshot of the plot showing the magnetic flux through and the induced EMF across the Phase 

A and Phase B coils when the time step is 0.5 ms. Comparison between this plot, the plot 

generated in Session II with a step of 1.0 ms, and the plots shown in Figure 27 of the procedures 

which show time steps of 0.2 and 0.1 ms. 

 Obtain screenshots of objects’ meshes after 5 adaptive passes. There should be one screenshot 

focusing on the curved side of the magnets, one screenshot focusing on the side of the rotor 

teeth facing the magnets, and a couple screenshots showing the combined coils, stator, rotor, 

and magnets. Discuss how these meshes differ from those obtained in the previous session. 

 Obtain a screenshot of the plot of the magnetic flux through and EMF induced across the Phase 

A coil as a function of time, when the refined mesh is used and the time step is 0.5 ms. Compare 

this result to the one obtained in the previous section, where the time step was 0.5 ms but the 

mesh was not as refined. 
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 Save a screenshot of your magnets’ altered coordinate systems, as well as a screenshot of the 

resulting magnetic flux through and voltage induced across the Phase A coil after the magnets’ 

coordinate systems have been altered. Compare this plot to those obtained previously. 

 List several parameters that you could change in the Air-X model or the simulation settings, 

along with your predictions of the effects that each of these changes would have on the final 

result. Try one of these changes, and obtain and interpret a screenshot of the resulting 

simulation’s output. Compare these and the earlier results to actual Air-X measurements. 

 

Additional Concept and Design Questions: 

 Why do you think that the Air-X manufacturers took special care to smooth sharp edges in the 

magnets and stator slots?  

 


