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1 NeoSuck RT Setup

NeoSuck RT (real time) is used to record and analyze data associated with the non-nutritive
suck (NNS), including signals related to Suck Pressure, EMG OOS-R, EMG OOS-L, EMG OOI-
R, EMG OOI-L, which are recorded from 5 channels of NI DAQ 6052E PCI multifunction board
installed in the acquisition PC with 3 kHz sampling rate on 16-bits vertical resolution. We
currently apply this software and hardware system to test and re-analyze the suck pressure and
signals from other channels for premature and term baby. The analysis tools in NeoSuck RT
include histogram analysis, FFT analysis, bad block screening, digital signal processing, generate

output ASCII files for time and frequency domain, etc.

1.1 Hardware

The Hardware for this testing equipment includes:
- A CPU with 1 GB RAM running Windows XP
- NI DAQ 6052E and BNC 2110 or BNC 2090
—> Bridge Amplifier
- AC PreAmplifiers (4)
-> Sensors: pressure sensor and EMG Ag/AgCl sensors

The hardware listed above is configured up according to Figure 1, and baby’s suck pressure
and EMG signal sampled from the Soothie™ silicon nipple receiver is input to NeoSuck RT for

real time digitization, signal processing, and waveform display.
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Figure 1. Hardware configuration for NeoSuck RT

1.2 Software

This software is coded by Visual Basic.Net (17,265 coding lines) according to the structure
shown in Figure 2. The function of this software includes real-time data acquisition, histogram

processing, FFT analysis, ASCII file generation, and export desired data to .txt file.
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Structure Plot of NeoSuck [ New frmMain.vb  mnuFileNew(): Name a new .dat file

— Open frmMain.vb mnuFileOpen():Open an existing .dat file

——e File —— Page Setup frmMain.vb mnuFilePageSetup()
. frmPrintSelection.vb | . . . .
M Print rmrTintetection v ¢ frmMain.vb  mnuPrintAmplitudeHist(), etc.

— Exit  frmMain.vb mnuFilePageSetup()
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— DAQ lfrmSettingsDAQ.vt? 8*Al calibration settings for DAQ board
—_——_— —
— Graph lffm—senESG:ph-\Tb‘ Y Axis scale setting for 8*Al plots
—e Settings — =—===
= Histgram [ ffmSettingSHiSt-VL scale setting for Histogram of Amplitude, Pause, and Burst Period
T | . .
~— Suck Pr Analysis lfrmSettlngsPeak.\g Peak selection settings for suck pressure plot
NeoSuck e—e .
}EMEFVb] — Select Baseline —_———
| Amplitude lfrmAmp“tUdEHiSt'B Histogram plot of cumulative amplitude
— Histogram ~E Pause Period FrmBurstPauseHist.va Histogram plot of cumulative bust
Burst Period l frmDerivative.vb3 Histogram plot of cumulative pause
M—e Tools — -—— — =

M— Bad Block List frmAddRemoveBIocks..v_bJ Bad block list selection dialog

M— Generate Histogram Files

amplitude, bust and pause

—e Help r frmAbout.Vbj

— — —

Figure 2. Coding structure plot for NeoSuck RT

1.3 Program installation

Filter IfrmSuckFFTSettingsFiIter.vbJ leFF:F
Settings —_—— — — —
o [ frmSuckFFTSettin Scale
gsGraph.vb X
— SUCkFFT frmSuckFFT.vb Graphl_ cFFTSettingsGraph.vt) settings

Tools@—» Generate Composite
— Create ASCII Blocks ~ frmMain.vb mnuToolsCreateASCII():Create data file in .txt for every block

frmMain.vb mnuToolsGenHistFiles():Create data file in .txt for histogram of

M— Generate Amp-Period ASCII File frmMain.vb mnuToolsGenAmpPeriodFile():Create data file in .txt for?

— Convert Old Format to New Format frmMain.vb mnuToolsConvertOldToNew(): Create .txt file for?

Nov 17, 2005 by Joan

1. Uninstall any previous installed versions of NeoSuck RT using Control Panel >

Add/Remove Programs.

2. Install NeoSuck RT by running setup.exe from the installation package.
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Figure 3. BNC-2090

Note: Normally, it works with BNC-2090 interface (Figure 3).
To work with the BNC-2110 (Figure 4) please make the following change:

Figure 4. BNC-2110

For BNC-2110

To work with BNC-2110, the terminal configuration has to be in differential mode.
Terminal configuration can be set to differential mode by modifying the parameter value of
“terminalConfig” to “1” under <systemConstants> section in the file NeoSuckRT.exe.config
located in C:\Program Files\Neuro Logic\NeoSuck RT\. Here is the line from
NeoSuckRT.exe.config that shows this parameter value:

<add key="terminalConfig" value="1" />

“terminalConfig” can have the following values:
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value="1" for Differential
value="2" for Referenced single ended
value="3" for Nonreferenced single ended

By default, the file NeoSuckRT.exe.config contains value="3" for “terminalConfig”. This
setting is used for the BNC-2090 signal interface. Here is the line from NeoSuckRT.exe.config
that shows this parameter value

<add key="terminalConfig " value="3" />
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2 User manual

When opening the NeoSuck RT, a blank window is shown as follows (Figure 5). User
could apply this set of software and hardware to record new data or analysis of existing data:
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Figure 5. Blank window for recording and analysis

2.1 Record new data by NeoSuck RT

To Record data for a baby, go to File=>New, then a “Save As” file dialog will pop up as
shown in Figure 6. Input the file name as «.dat file which will be used for future analysis, and
click “Save” button.
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Figure 6. Recording new data

Then user can press the “Start” to begin the recording, or “Pause” button to halt it.



NeoSuck RT

2.2 Analyze existing data by NeoSuck RT
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Based on the data collected (described in section 2.1, Record new data by NeoSuck), user

can systematically apply analysis tools in NeoSuck RT to investigate more detailed properties of

the human infant NNS.

2.2.1 Basic analysis

Click File=>Open, an open file dialogue will pop up (Figure 7) to enable the user to

designate the name and path of the target data file.
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Figure 7. Opening an existing data file

Figure 8 shows the initial NeoSuck RT data analysis window. The three histogram

windows on the right display the histogram plots for NNS Amplitude, Pause Periods, and NNS

Burst Periods for each block that the user has selected. If the user is only interested in the analysis

10
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of data from 8 channels displayed in the main window, then these three histogram windows can be
closed by the user.
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Figure 8. Open NeoSuck RT window for data analysis

The User can also call these windows by clicking desired window in Tools=>Histogram as
shown in Figure 9. Furthermore, the displayed histograms can also be exported to «.txt file by
clicking Tools>Generate Histogram Files for future analysis. Those files will be saved under
C:\Program Files\Neuro Logic\NeoSuck RT\Data.

11
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Figure 9. NeoSuck window without Histogram analysis

Similar to the recording process, NeoSuck RT analyzes data in successive blocks (30
seconds for each block). User can scroll among different blocks by clicking the “Previous” and

“Next” buttons in the lower part of the window as shown in Figure 9.

NeoSuck RT is mainly for suck pressure analysis, which is shown as the last graph in the
first column. NeoSuck RT can automatically recognize the peak in suck pressure, which is marked

by small diagonal red lines in suck pressure plot.

2.2.2 Fourier transform of suck pressure

NeoSuck RT can be used to calculate the FFT of suck pressure. In order to get the
frequency property of suck pressure, the user can click Tools=>Suck FFT to call up the “FFT-

Suck Pressure” window. In this analysis window, the user will find the time domain and

12
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frequency domain plot of the currently displayed block in the main NeoSuck RT window (Figure

10). The first and second graphs are both for current block, while the third graph, named as

composite FFT, shows the mean FFT for all the blocks that have been analyzed by the FFT

subroutine. User could either click “Update FFT Plot/Save FFT” button, or go to

Tools>Generate Composite in this window to periodically update the composite FFT.
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Figure 10. Suck pressure FFT analysis
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In the setting menu, user could set the filter parameters (cutoff frequencies for Low Pass

filter and High Pass filter) to plot the desired frequency property (Figure 11). In addition, the

graph setting (Figure 12) enables the user to define the minimum and maximum values for both x-

axis and y-axis for each of the three graphs shown in this window.
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2.2.3 Other analysis tools

There are some other analysis tools embedded in NeoSuck RT to either display graphs or

export «.txt files which could be used for extended analyses using other commercial software like
Minitab™, LabVIEW™, MATLAB™, MS Excel™, etc.

1. Tools->Bad Block List (Figure 13) enables the user to delete bad blocks from the
entire data set, and thus generate clean analysis data for both exported data and

Fourier transform analysis.

Bad Block List )

Add/Remove Bad Blocks

Block List: Ead Block List:

Add 34
Add All 33>
<<< F\ Bmoe
g Hamove Al

mma-wml

Figure 13. Bad Block List

2. Tools>Create ASCII Blocks (Figure 14) performs the function of exporting
recorded «.dat file to .txt file block by block. The ~.dat is a binary file which can be
read by Visual Basic. The purpose of transforming data into «.txt file is to make the

recorded data readable by 3" party commercial graphics and statistical software.

Open a

Look in: | £ K5_033004 - e @k E-

My Documents
-
%8
Iy Computer
= | 5
by Network File marne: K6_033004.dat < Open
Places

Files of type: |Data files [*.dat:™ pra) j Cancel

Figure 14. Create ASCII blocks for .dat file

3. The “Generate Histogram Files” and “Generate Amp-Period ASCII Files” will
generate «.txt files for future analysis.
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Some other setups in Setting of the NeoSuck RT menu bar enable the user to set and

modify analysis criteria for data acquisition, graphs, histogram plots, and FFT analysis.

Figure 15 is the DAQ setting dialog where the user can adjust the minimum and maximum

acquisition limits, as well as calibration parameters. Once the DAQ parameters are set, sampled

data files will assume the format established in the DAQ set-up. Thus, these setup parameters

should not be modified unless the specific intent is to change file structure and sampling

rates.
DAQ Device!
&) Channels
Motor Pulse LvDT Load Cel Suck Pressure
&) Channel [acin =] 21 Charel et | A Channel: [ermz <] Al Channek [acmz ]
Physical Uit [1 v Physical Unit— [5 mm Physical Lni 05 M Physical Unit. ~ [10° cmH20
Voliage: 1 Y Yoltage 0.56 ¥ Voltage 0,454 v Voltage: o v
/D Min 5 W ALD Min 1 v A/D Min [ v AD Min ST
A/D Max 5 W AD Man i v A/D Ma [ v A/ Ma [l v
EMG 00S-H EMG 0054 EMG 001 EMG 00I-L
Al Channet [ache =] Al Channel [acis =] Al Channel [ecve =] Al Channel [schs =]
Physical Unit: ~ [100° v Physical Urit.— [100 Physical Uit 100 ¥ Physical Unit 100 ¥
WYaltage: 2 ¥ Woltage P Woltags: P ‘altags: P
4D Wi 10 ALD Min: 0 W A/D Mirc 10 440 Wi 10
A Mk o % AT Max [lo v A1 M [0 v AAD Ma: flo v
Block
Sample Rate: [oom
Sample Time: EC
No. of Samples o0
Down Sample: foo Carcal

Figure 15. DAQ board settings

The Graph and Histogram settings (Figure 16) include the dialog windows for lower and

upper limit selection according to user’s preference.
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Figure 16. Graph and Histogram setting dialogue

The “Suck Pr Analysis” setting (Figure 17) defines parameters for peak selection, and suck

pressure threshold value for recording, etc.

Settings - Suck Pressure Analysis

Derivative Peak Settings

Threshald:

—
E—
o

Peak ‘alid Range:

Peak Period:

Suck Pressure Threshald:
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Skip Samples [Display):
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Cancel |

Figure 17. Suck Pr Analysis setting

17



NeoSuck RT CNL U of Kansas

3 References

Estep, M., Barlow, S.M., Stumm, S. Fees, M., Finan, D., Seibel, L. Poore, M., Cannon, S. (2005).
Non-nutritive Suck Burst Parametrics in Preterm Infants, Society for Pediatric Research,
2141.

Seibel, L., Barlow, S.M., Vantipalli, R., Finan, D., Urish, M., Carlson, J. (2005). Spectral
Dynamics of Non-Nutritive Suck in Preterm Infants, Society for Pediatric Research, 2139.

Stumm, S., Barlow, S.M., Vantipalli, R. Finan, D., Estep, M., Seibel, L., Urish, M., & Fees, M.
(2005). Amplitude/Burst Dynamics of the Non-Nutritive Suck in Preterm Infants. Society
for Pediatric Research, 2632.

Zimmerman, E., Barlow, S.M., Seibel, L., Poore, M., Stumm, S., Estep, M., Chu, S., Fees, M.,
Urish, M., Gagnon, K., Cannon, S., Carlson, J. (2006). Pacifier stiffness alters the
dynamics of the suck central pattern generator. Society Pediatric Research, 5571:393.

Stumm S, Barlow S, Vantipalli R, Finan D, Estep M, Seibel L, Urish M, Fees M, Poore M, Chu S,
Zimmerman E, Cannon S, Gagnon K, Carlson J. (2006) Amplitude-Burst dynamics of the
non-nutritive suck in preterm infants. J Clinical Nursing, (under revision).

Estep M, Barlow SM, Stumm S, Fees M, Finan D, Seibel L, Poore M, Cannon S. (2006). Non-
nutritive Suck Burst Parametrics in Preterm Infants with Respiratory Distress Syndrome.
Biol Neonate, submitted.

18



