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9
Browsers
Browsers are special kinds of windows that let you see a lot of information about 
files at once. Browsers typically have two panes: one pane lets you select a file, 
the other displays detailed information about the file (often its contents). If you 
have performed a Find All search, you have already seen an example of a 
TextWrangler browser.
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Browser Overview
All TextWrangler browsers share the same basic structure and behavior. All 
browsers have a toolbar, a file list, and a text pane. You can either edit files 
directly in any browser window, or open them separately.

List Pane
The top pane of a browser lists the items available in the browser. This pane 
shows different information for different kinds of browsers:

You can open both files and folders from the list pane. When you double-click a 
folder name, TextWrangler replaces the file list pane with the contents of the 
folder. When you double-click a file name, TextWrangler opens the file in an 
editing window. If the file list pane also included a line number, TextWrangler 
scrolls to that line.

Browser File List pane contains

Disk browser Files and folders that TextWrangler can open

Search results File and line number of each match

Error results (or) 
general results

File, line number, and status message for each 
condition
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Controls above the list may allow you to determine what kinds of items are displayed in the 
list. For example, in disk browsers, there is a popup menu that lets you choose to display 
text files, all files, or other types of files, and another that lets you return the browser to a 
parent directory of the current folder. In error browsers, checkboxes allow you to hide or 
show all errors, warnings, or notes. 

For results browsers, TextWrangler shows a hierarchical listing, where all the results 
associated with a particular file are grouped under that file, using disclosure triangles 
similar to those in the Finder’s list views to reveal or hide the results list.

To remove items from the display list, select them and press the Delete key, or choose Clear 
from the Edit menu.

In results browsers, you may Control-click on items in the list to bring up the contextual 
menu with relevant commands, such as “Copy”.

Toolbar
The browser toolbar is like the toolbar in editing windows. Some browsers have additional 
buttons and controls in the status area as well.

These standard items—the pencil icon; the Function, Text Options, Mark, Path popup 
menus; and the Info buttons—should already be familiar to you, since they appear on 
TextWrangler document windows by default. See “Window Anatomy” in Chapter 4 for an 
explanation of these standard TextWrangler functions.

Text View Pane
When you click on a file name in the list pane, TextWrangler displays that file in the text 
view pane, and you can edit the file just as if it were open in a document window.

Splitter
You can change the size of the file list pane or the text view pane by dragging the double 
line that separates them. Double-clicking on the splitter bar will collapse the text view pane 
completely, and double-clicking on it again (in the bottom of the browser window) will 
restore the text pane to its previous proportions. You can also choose the Hide Editor or 
View Editor commands in the View menu to hide or display the text view pane.
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Disk Browsers
Use a disk browser to explore the contents of a disk or a folder without opening each file 
one at a time.

To open a disk browser, pull down the File menu and choose Disk Browser from the New 
submenu. TextWrangler opens a new disk browser that starts in your home directory, but 
you can navigate to any desired location:

The name and path of the file (if any) and directory currently being viewed are displayed in 
the title bar of the window. The file list pane displays all the items in the current folder. 
Click on a file in the file list pane to open it in the text pane, or double-click to open the file 
into a text window.

Disk Browser Controls
The menus at the top and bottom of the file list pane let you create new files and folders, 
open existing files and folders, reveal them in the Finder or navigate to them in the 
Terminal, limit the kinds of files to show in the list pane, and navigate through your disks 
and folders.

Directory Menu
The Directory popup menu at the top of the file list pane always shows the currently active 
folder. You can use this menu to “back out” of any folder you are currently in to a higher-
level folder (as you can by Command-clicking the name of a folder in the Finder). 
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Action Menu
The commands on the Action (gear) popup menu at the bottom of the file list pane allow 
you to open the selected items, reveal them in the Finder, copy their paths, navigate to their 
location in the Terminal, move them to the Trash, or create a new file or folder.

Filter Menu
The Filter (magnifying glass) popup menu at the bottom of the file list pane lets you specify 
what kinds of files TextWrangler should display:

• All Available: All files which TextWrangler recognizes, including its own 
document types. This includes text files, images, text factories, and so on.

• Text Files Only: Only files which TextWrangler recognizes as text files.

• Everything: All items present, including invisible files and folders.

You can also select a file filter to further limit what files TextWrangler should display. (You 
can define additional file filters in the Filters panel of the Setup window.)

Toggle Editor Button
Click this button to collapse or expand the browser’s text view pane. (This button has the 
same effect as choosing the View/Hide Editor command in the View menu.)

Contextual Menu Commands
If you select one or more items in the file list pane and bring up the contextual menu, 
TextWrangler will offer a variety of commands including those available from the Action 
menu.

Dragging Items
You can select and drag files and folders from a disk browser’s file list to any location, 
either within TextWrangler or elsewhere, which can accept file or folder drags. For 
example, you can drag a file from a disk browser to an editing window to insert its 
contents, or to a folder in the Finder to copy or move it.

Using the List Pane in Disk Browsers
The list pane of a disk browser displays disks, files, and folders. When you are at the 
computer level, the list shows all mounted volumes.

When you click a folder or disk in the list pane, TextWrangler displays the names of all the 
files it can open in the text pane, subject to the criteria specified by the Show and Filter 
menus.

When you click a file name in the list pane, TextWrangler displays that file in the text pane.

To open a folder or disk and display its contents in the file list pane, you can either double-
click it, or Select it and press Command-Down Arrow.

To go up one level to the enclosing folder or disk, you can either choose the enclosing 
folder from the directory popup menu, or press Command-Up Arrow

You can also use Quick Look to examine any non-text file by selecting it and pressing the 
spacebar.
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Note When the list pane has input focus, the browser window’s AppleScript “selection” 
property will return a list of the files currently selected. See “Getting and Setting 
Properties” on page 214 for further details.

Search Results Browsers
If you selected the Batch Find option when performing a multi-file search, TextWrangler 
displays every occurrence of the search string in the searched files in a search results 
browser.

The items at the top of the window tell you how many matches TextWrangler found in the 
set of files you specified, as well as whether any error conditions or warnings were 
generated during the search. The list pane lists each line that contains the matched text. 
Every match is identified by file and line number. To choose whether to display the search 
errors, warnings, and results, use the checkboxes at the top of the browser.

To open the file which contains a particular match, just click on that match in the results 
list. After you have opened a file, you can use the Search menu commands to continue 
searching it. (See Chapter 7 for more information on searching.)

The Open button opens the selected items using TextWrangler. To open the selected items 
using the Finder, hold down the Option key while clicking the Open button.
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Error Results Browsers
When you check the syntax of a Unix script, or run a script which generates any errors, 
TextWrangler will open an error results browser to list those errors.

Each entry in the list pane corresponds to an error, warning, or note. You can use the 
checkboxes for each type of item to suppress or display the associated results as desired.

If you click on a entry in the file list, TextWrangler will open the corresponding file in the 
text display pane and select the section of text related to the error.
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Preferences
You can use the Preferences command to customize much of TextWrangler’s 
behavior. You can decide which windows are open when you launch 
TextWrangler, set the default options for windows, set the default options for 
searches, and so on. This chapter describes TextWrangler’s extensive preference 
options.

In this chapter
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The Preferences Window
The Preferences window provides control over many aspects of TextWrangler’s 
behavior. You can decide which actions TextWrangler should perform when you 
launch it, set default options for editing behavior, examine and set or modify 
keyboard shortcuts, create and apply text color schemes, and so on.
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To open the Preferences window, choose the Preferences command from the TextWrangler 
(application) menu.

To select a preference panel, click its name in the list at the left side of the window. The text 
area at the top of the Preferences window gives you a brief description of the options 
provided by the currently displayed preference panel.

TextWrangler’s Preferences window is non-modal: you can leave it open and change 
preference settings while you work, or close it at any time by clicking its close button or by 
choosing Close Window from the File menu. Any changes you make to preference options 
take effect immediately unless otherwise indicated. 

IMPORTANT TextWrangler employs the standard system preferences mechanism to store your 
preference settings. Accordingly, you can modify preference options directly by issuing 
“defaults write” commands. However, if you choose to modify your preferences by means 
of “defaults write” commands other than those documented in this manual or the “Expert 
Preferences” page of TextWrangler’s built-in Help book, without explicit advice from Bare 
Bones Software technical support, you take responsibility for any adverse effects.

If you discard your TextWrangler preferences file, you will need to re-select any 
customized preference options you may have chosen.
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Searching the Preferences
You can perform keyword searches to quickly locate preference options in the Preferences 
window. To do this, just click in the search field below the list of preference panels, and 
type a word or partial word into the field. As you type, TextWrangler will search for 
instances of the current term and display all the panels which contain it. You can then select 
any of the listed panels to view and change the options within it. For example, here is the 
Preferences window with an active search for the term “gutter”.

Restore Defaults
Each of TextWrangler’s preference panels contains this button, which you can click to reset 
all preference options within the current panel to their factory default settings.

Appearance Preferences
The Appearance preferences let you choose which control and display elements appear in 
text windows and in other windows which include text panes.

Toolbar
When any of the listed options are on, TextWrangler displays the toolbar (see page 63). You 
can also show or hide the toolbar independently in any editing window.

Text options
When this option is on, TextWrangler displays the Text Options popup in the toolbar (see 
page 63).


