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WHY AFTER EFFECTS?

AfterEffects creates stand alone movies.  With so many programs out there that create stand alone
movies to choose from, how can we help a user pick the best one to fit their needs?

AfterEffects is an advanced motion graphics and visual effects program.  The final outcome of
AfterEffects is a movie file such as a QuickTime movie.  Because of this it is necessary to distin-
guish AfterEffects from digital video editing software.  AfterEffects does not edit video, but rather
takes video clips and creates special effects and/or adds movement to the clip- along with sound
files, still images, text, etc.

Final Cut Pro is a professional quality digital video editing program.  Final Cut Pro offers some
effects, but has relatively few options when compared to AfterEffects.

Macromedia Flash also has the ability to create web sites and movies that can be published to the
web using a separate FTP program or burned to a CD as a projector of the movie.  The advantages of
Flash is the ability of increased interactivity and animation.   Flash movies can be very small in size
and can be placed in Dreamweaver along with other information on a web page.  Flash is the choice if
interactivity and advanced animations are important to you or your web site.

Macromedia Director can also be used like a Flash movie as an interactive web site, but is mostly
useful if creating stand alone projectors for movies, interactive games, and animations on CDs, web
sites, and Kiosks.

Footage file:  is any sound, movie or picture file (such as .aif, .mov or .tif) that After Effects supports.

Object:  is a footage file that has been placed into the Composition and Timeline windows.

Layer:  Objects are placed in a stacking order, each one on a layer, in the Composition and Timeline
windows.

Manipulate:  To manipulate an object is to apply any transform, mask or effect to it; objects are
manipulated over time.

Transforms:  are used to change an object’s position, scale, opacity and/or rotation within the compo-
sition and over time.

Masks:  are created to block out and/or reveal portions of the composition. They are an outline, that
modifies a layer's alpha channel. Use a mask when you want to draw areas of transparency in After
Effects. A mask belongs to a specific layer, but each After Effects layer can contain multiple masks.

Effects:  are another, more advanced way to manipulate objects.

A movie file (ex. a QuickTime file) will be the final outcome of using After Effects.

ESSENTIAL TERMS AND CONCEPTS
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EXPLORING THE INTERFACE

The interface consists of three main windows: the Project window, the Composition window, and the
Timeline window.  In addition there are palettes: tools, info, time controls, and audio.

Project Window

Composition
Window

Timeline
Window

Tool Palette

Info Palette

Time Controls/
Audio Palettes

Steps:

1. Create a new composition window by
selecting Composition > New
Composition. The Composition
Settings window will appear.

2. Name the composition in the Com-
position Name box.

3. Set the Preset (i.e. frame size) to
720 x 480 and NTSC DV, 720 x 480.

4. Set the Pixel Aspect Ratio to D1/
DV NTSC

EXERCISE 1: EXPLORING THE INTERFACE

5. Set Resolution to Full.

6. Set Frame Rate to 29.97 frames per second.

7. Set Duration to the expected duration of your project (i.e. Hours : Minutes : Seconds :
Frames). This can be changed later if necessary.  Click OK.
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As you work with compositions, you also use three other types of windows: Footage windows,
Layer windows, and Effect Controls windows.

Footage Windows: are useful for viewing and evaluating footage items in their original form.
Layer Windows: To view a layer's original source independently of other layers or to trim footage,
you can open a Layer window.
Effects Control Windows: As you work with effects, you use the Effect Controls window to modify
and animate the effects.

THE INTERFACE IN DEPTH

A

B C

D

A. Source Footage B. Project Window C. Composition Window D. Timeline Window
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EXERCISE 2: IMPORTING FILES

1. A keyframe marks the point in time (in the Timeline window) where one specifies a value for a
layer property (for instance, its position).
2. Animation of any kind requires at least two keyframes (i.e. an initial value and a final value).
Change begins at the first keyframe and continues until it reaches the second keyframe.
3. Given two or more keyframes, AfterEffects interpolates transition frames (the frames between
the keyframes) automatically.
4. You will be setting keyframes in the Timeline window for each desired property (ex. position,
scale, etc.) of every object you wish to animate.

These are the basic principles of keyframes and how to use them. Though this is only a model
created for this lesson, the principles can be directly applied to After Effects, or any program that
uses keyframes.

KEYFRAMING

Steps:

1. Click File > Import > File.  A location window will
appear

2. Locate and select the footage file you wish to
import

3. Click Import.  For this workshop, the folder on the
hard drive is called AEWorkshop.  Import the files in
this folder

Note: If importing more than one file: choose Multiple
Files option.  A location window will appear.  Locate and
select the footage files you wish to import onto the
computer, one at a time.
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EXERCISE 3: COMPOSITING

Steps:

1. Drag the footage files that you will be using from the Project window to the Timeline window.
They will appear as a list of objects once moved.

2. Expand properties of item by pressing on the triangle and then expanding the Transform option as
well.

3. Set a numeric value for any transform property by doing one of the following:

♦ Click and hold on the blue number to the right of the property. While holding down the
mouse button, you will be able to increase or decrease the property’s value by scrolling
right or left, respectively.

♦ Set both position and scale, using the selection tool. For position, click the center of
the object in the Composition Window and drag to the desired position. For scale, click
and drag the handles at the corners or sides of the object.

♦ Set the rotation property by using its tool. Select the rotation tool  in the Tools window. In
the Composition window, click on the desired object. Then rotate the object using the
handles.

EXERCISE 4: MASKING

Steps:

1. Select the layer in the Timeline window that you wish to add a mask to.

2. Click Layer > Mask > New Mask. A new mask named "Mask 1" will appear under the
Masks section.

3. Click on the triangle to the left of "Mask 1" to reveal the mask’s properties. You will see
Mask Shape, Mask Feather, Mask Opacity, and Mask Expansion.
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Mask Shape controls the shape and size of the mask.
Mask Feather dithers the edges of the mask (for less noticeable edges).
Mask Opacity controls the transparency of the mask.
Mask Expansion scales the mask.

4. Change the Mask Opacity to 41%

5. Change Mask Feather to 5 pixels

To adjust the values of any of the four
mask properties, click on the numbers
or words to the right of the property’s
name and enter a value or click, hold
and scroll (the same way transform
properties are adjusted).

The tools from the Tools window (used
on the transform properties) can also be
used to manipulate masks such as
moving the position of the mask using
the Selection Tool.

EFFECTS

When you apply an effect to a layer, the Effect Controls window opens; the effect is listed there.
Each layer to which you apply effects appears on its own tab in the Effect Controls window. The
effect is also listed in the Effects section under the layer name in the Timeline window.

 If you apply additional effects to the layer, they are listed under the first effect in the Timeline
window. You change the order in which effects are rendered by dragging the effect name to a new
position in the list.
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EXERCISE 5: EFFECTS

Steps:

1. Select the layer in the Timeline
window that you wish to add an effect
to.

2. Select the desired effect(s) by going to
Effect at the top of the screen. For
example, click Effect > Blur & Sharpen
> Directional Blur.  The Effect Con-
trols window will appear.

3. In the Effect Controls window, adjust
the values (in this example, Direction
and Blur Length) as desired. The
values can also be set in the Timeline
window by changing the numeric value
to the right of the property (the same
ways as described before for transform
and mask properties).

SET KEYFRAMES AND SAVE WORK

Set keyframes to animate objects:

Activate the time-vary stopwatch (circled)
for the layer you wish to animate. Do this by
clicking on the stopwatch-shaped icon located
to the left of the layer property (ex. to the left of
position)

When the time-vary stopwatch is activated,
a keyframe (circled) will be appear wherever
the current-time marker (red line) is currently
located.

To add an additional keyframe, place the
current-time marker in a new position and
set the property’s value any of the ways
discussed before (i.e. setting a property’s
initial value). Another keyframe automatically
appears and another diamond will appear
along the timeline once a new keyframe
has been set.
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To remove a keyframe, highlight the keyframe by clicking on it once, then press the delete key.

To remove all keyframes for a given layer property, deactivate the time-vary stopwatch by clicking
on it.  If you accidentally get rid of your keyframes this way, choose Edit > Undo.

To show the animation between the keyframes press play on the Time Controls Palette or press the
spacebar with the Current Time Marker at the beginning point of the animation.

Be sure to save your work often. It is also advisable to save various versions of your work as you
progress. This way, if a mistake is made and then saved, an older version can be recalled. Saving
options are found under the File menu.

When saving work to removable media (ex. Zip disk, CD-R or CD-RW), be sure to copy the
AfterEffects project file as well as all source media (i.e. footage files). The file After Effects creates
when you save only keeps track of the manipulations you make to your media. The media is only
referenced from the original image, movie and sound files.

EXERCISE 6: SET KEYFRAMES AND SAVE WORK

Steps:

1. Add a keyframe by activating the time-vary stopwatch for a particular property, placing
the cursor on a new point in time and changing the property’s value.

2. Remove a keyframe by highlighting it and pressing delete and replace it in another
location on Timeline.

3. Deactivate the time-vary stopwatch to remove all keyframes for a particular layer, then
Undo.

4. Save the project to the hard drive by going to File > Save As. . .

EXERCISE 7: EXPORT FROM AFTER EFFECTS

Steps:

1. Click Composition > Add To
Render Queue. The Render
Queue window will appear.

2. The composition you have been
creating will be highlighted in
black in the Render Queue
window.   Click the triangle to
the right of Render Settings:
and select Best Settings.
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3. Double click on Output Module to bring up
the Output Module Settings window. Set
Format to QuickTime Movie.

4. Make sure the Video Output box is
checked.

5. Under Video Output, click Format Options.
The Compressor Settings window will appear.

6. For Compressor, select None and Millions
of Colors+.  Set the Quality slider to Best.

7. Click OK.

8. If your composition does not have audio,
make sure the Audio Output box is not
checked. If your composition does have
audio, place a check in the Audio Output
box.

9. Click on Format Options. The Sound Settings window will appear.  Select the following
values:

♦ Compressor: None
♦ Rate: 44.100
♦ Size: 16 bit
♦ Use: Mono or Stereo (*depends on your specific audio source)

Click OK

10. Click OK to close the Output Module Settings window.

11. Click on Not Yet Specified to the right of
Output To: to set your file’s saving destina-
tion and name. The Output Movie To:
window will appear.

12. Name the movie file and select an output
destination on the hard drive.

13. Click Save.

14. Click Render to begin rendering your composition into a movie file. When finished, the
movie will appear as a file in the location you saved it to.
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CRITERION TEST:
20 min

Write the answers to the following questions:

1. What is After Effects used for?

2. What is a footage file?

3. What is an object?

4. What are the four primary Transform properties?

5. What are masks used for?

6. How are effect properties set compared to Masks or Transforms?

7. What will the final product of After Effects be?

8. Which of the following lab clients should use After Effects?

A. Someone wanting to digitize and edit video
B. Someone wanting to create an interactive web page containing video
C. Someone wanting to animate titles and audio into a video

Complete the following tasks. Have the instructor verify that the task was successfully completed
before moving to the next task:

1. Open After Effects 5.

2. Create a new composition and set the correct initial values.

3. Import footage files from the “AE5 Module Media” folder on the desktop into the Project window of
After Effects.

Show the instructor what you have done before proceeding.

Write the answers to the following questions about keyframing:

1. What is a keyframe used for?

2. What information is contained in a keyframe?

3. How many keyframes must be set to animate objects?

4. How are the frames between keyframes calculated?


