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Getting started with Dymola

1.1

Modeling

Introduction

“y® Simulation

This chapter will take you through some examples in order to get you started with Dymola.
For detailed information about the program, you are referred to the on-line documentation
and the user’s manuals. The on-line documentation is available in the menu Help >
Documentation. The tool tips and the What's this? features are fast and convenient ways to
access information. Please see section “Help and information” on page 84 for more
information.

Start Dymola. The main Dymola window appears. A Dymola main window operates in one
of the two modes:

e Modeling for finding, browsing and composing models and model components.

e Simulation for making experiments on the model, plotting results, and animating behav-
ior.

Dymola starts in Modeling mode. The active mode is selected by clicking on the tabs in the
bottom right corner of the Dymola window.

The operations, tool buttons available and types of sub-windows appearing depend on the
mode and the user’s choice. Dymola starts with a useful default configuration, but allows
customizing.

GETTING STARTED WITH DYMOLA 5



Dymola main
window

B pymola - Dynamic Modeling Laboratory - [Diagram]
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1.2

Simulating a model —

industrial robot

This first example will show how to browse an existing model, simulate it, and look at the
results. If you want to learn the basics first, you can skip to a smaller example in the next
section 1.3 “Solving a non-linear differential equation” on page 20.

1.2.1 Investigating the robot in modeling mode

We will study a model of an industrial robot. To view the industrial robot model, use the
File > Demos menu and select Robot.




Opening a demo exam-
ple.

The robot demo.

Dymala - Dynamic Maodeling Laboratery - [Diagram]

File | Edit Simulation Plot  Animaticn Commands Window Help Linear analysis
O New Si=ReRvar-S | m]
_ @ Open Bl Unnamed  [X] |
o & Load Ctrl+Shift=0 -

; Libraries 3 ‘

: Demos s || Robot |,
Save Ctrl+5 Motar I:,‘rri\.rlej“F
Save As... Furuta pendulum
Save All Coupled clutches
Save Total... Meodelica Synchronous Tutorial
Version 3 Automotive Demos Library
Clear Al Il

Dymola starts loading the model libraries needed for the robot model and displays it. The

following will be displayed:

-
fullRebot - Modelica.Mechanics.MultiBody.Examples.Systems.RobotR3 fulRebot (Read-Cnly) - [Diagram]
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About to view the me-
chanical structure of
the robot.

The package browser in the upper left sub-window displays the package hierarchy and it is
now opened up with the robot model selected and highlighted. The model diagram in the
edit window (the sub-window to the right) shows the top-level structure of the model. The
model diagram has an icon for the model of the robot with connected drive lines for the
joints. The reference angles to the drive lines are calculated by a path planning module
giving the fastest kinematic movement under given constraints.

The edit window displays by default the model diagram (“diagram layer™) but the user can
select other information (other layers) to be displayed instead, e.g. documentation or
Modelica text. For more information, please see the chapter “Developing a model”.

The component browser in the lower left sub-window also shows the components of the ro-
bot experiment in a tree structured view.

To inspect the robot model, select the icon in the edit window (red handles appear, see
below) and right-click (press the button to the right on the mouse). A menu pops that
contains a selection of actions that can be made for the selected object (a context menu).
From the context menu, select Show Component.

iuI\Robot—Modellca.Mechanlcs.MuItlEody.ExampIes.Systems.RobotRS‘fulIRoth (Read-Only) - [Diagram] | ] e
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A2 Rotated0

It is not necessary to select the robot component explicitly by first clicking with the left
button on the mouse on it to access its menu. It is sufficient to just have the cursor on its
icon in the edit window and right-click. The component browser also gives easy access to




the robot component. Just position the cursor over “mechanics” and right-click to get the
context menu for “mechanics”. The component browser provides a tree representation of the
component structure. The edit window showing the diagram layer and the component
browser are synchronized to give a consistent view. When you select a component in the
edit window, it is also highlighted in the component browser and vice versa. The diagram
layer of the edit window gives the component structure of one component, while the
component browser gives a more global view; useful to avoid getting lost in the hierarchical
component structure.

The edit window now displays the mechanical structure consisting of connected joints and
masses. The component browser is opened up to also show the internals of the mechanics
model component.

- r
The mechanical struc- fullRebot - Modelica.Mechanics. MultiBody Examples. Systems. RobotR3 fullRobot (Read-Cnly) - [Diagram] = | O i
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Modelica.Mechanics.MultiBody.Examples. Systems.RobotR3.Components.Mechanical Structure | Modeling | ¥ Simulation |

m

Double-click on, for example, rl at the bottom of the edit window. This is a revolute joint.
The parameter dialog of that component appears. The parameter dialog can also be accessed
from the right button menu. Double-clicking the left button selects the first alternative from
the right button menu.
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Parameter dialog.

Selectable display unit.

mechanics.r1 in Modelica.Mechanics.MultiBody. Examples. Systems.RobotR3. fullRobot

Animation | Advanced

Component lzon

RELT echanics. Reveluts

Comment 'H-ﬂ'
Model n=

Path todelica Mechanics MultiBody.J aints. A evolute

Comment Revolute joint [1 rotational degree-of-freedom, 2 potential states, optional axis flange]
Parameters

uzeduisFlange » = true, if axiz flange iz enabled

animation W = true, if animation shall be enabled [show asiz as cylinder)

n v ¥ 1 Axiz of rokation resolved in frame_a [= same as in frame_b)
Initishization

phi.ztart i ¥ deg Relative rotation angle from frame_a to frame_b

v shart iz ¥ radds  First derivative of angle phi [relative angular velocity)

a.shart [ ¥ rad/s2 Second dervative of angle phi [relative angular acceleration)

[ Info l [ Close ]

The parameter dialog allows the user to inspect actual parameter values. In demos the
parameter values are write-protected to avoid unintentional changes of the demo example —
then the dialog just has a Close button (and an Info button). When the parameter values can
be changed there is one OK button and one Cancel button to choose between. The values
are dimmed to indicate they are not given at the top-level model, but somewhere down in
the component hierarchy.

A parameter dialog may have several tabs. This dialog has the tabs: General, Animation,
Advanced and Add modifiers. In a tab the parameters can be further structured into groups
as shown. It is easy for a model developer to customize the parameter dialogs. (More
information about customization can be found in the chapter “Developing a model”, section
“Advanced model editing”, sub-section “Parameters, variables and constants”). Graphical
illustrations can be included to show meaning of parameters.

If prepared for, display units can be selected in the dialog. Units that have alternatives are
marked by white background (here phi.start and w.start have selectable display units). By
resting the cursor over such a unit a button is displayed,

Initialization
phistatt [ » Relative ratation angle from frame_a to frame_b
wstart [ » radds irst derivative of angle phi [relative angular velocity)
astat [ ¥ radds ive of angle phi [relative angular acceleration)

and by clicking on that the selection can be made:
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Alternatives of

selectable display unit.

Edit

Edit Text
Copy Default
k’) View Parameter Settings

Insert Component Reference

8, Insert Function Call

Choices for n.

3

Initialization
phistat [ > elative rotation angle from frame_a to frame_b
wostat [ ¥ 950 st derivative of angle phi [relative angular velocity]
astatt [ » rad/sd  Second denivative of angle phi [relative angular acceleration)

Next to each parameter field is a triangle, this gives you a set of choices for editing the pa-

rameters. Edit gives a matrix editor/function call editor; Edit Text gives a larger input
field, etc. An example is that for the first parameter useAxisFlange the command Edit Text
can be used to enter an expression (that should be true in order for the axis flange to be

enabled). If such an expression is entered, the checkbox will be displayed as [m]
Some parameters have a list of choices where you can select values instead of writing them.

One example is the parameter n, which defines the axis of rotation. The value for this
revolute joint is {0, 1, 0}, i.e. the axis of rotation is vertical.

Paramneters
uzehizisFlange ¥ = true, if axiz flange iz enabled
animation (¥ = true, if animation shall be enabled [shaw axis az cylinder]
n b » Auxiz of ratation rezolved in frame_a (= same ag in frame_b)
Initialization {1 0.0} awis”
phi.ztart {0,100 "y avis” deg Relative ratation angle from frame_a to frame_b
0,01} "z awis™ ) . . ) .
- rad/s
v zkart (10,0 "regative ¢ axis” Firzt derivative of angle phi [relative angular velocity)
a.ztark 10,10} "negative v awis" rad’s2  Second derivative of angle phi [relative angular acceleration)
0,01} "regative z awis"

To learn more about the component, select Info. An information browser is opened to show
the documentation of the revolute joint. Links in the document makes it easy to navigate to
e.g. the description of the package containing the revolute joint. Now please close the
browser and press Close in the parameter dialog to leave it.

(If you want to see the documentation without going via the parameter dialog, right-click on
the component in the diagram and select Info.)

Let us now inspect the drive train model. There are several possible ways to get it displayed.
Press the Previous button (the toolbar button with the bold left arrow) once to go to the
robot model and then put the cursor on one of the axis icons and right-click. Please, note that
robot.mechanics also has components axisl, ..., axis6, but those are just connectors. You
must inspect for example robot.axis1 (see figure below).
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Displaying the
components of axis 1.

-
fullRokot - Modelica.Mechanics. MultiBody Examples. Systems RobotR3 fullRobot (Read-Only) - [Diagram)] = | B e

File Edit Simulation Plot  Anirmation  Commands Window Help  Linear analysis RS

D-2eHdA& N /OO0y ABL-&-Ffs | 0[Z- -« +»=BHEE ~
() fulRobot Parameters -
[F ]
Package Browser 8 x | Show Component |
N Open Class be
—-E‘Mechanlcs Open Class in New Tab
T MUIhEOdY Open Class in New Window
3 : Fody Li... [ thP
=+ 0Users Guide of MultiBody Li... ‘,—:‘ pathPlanr| View Attributes
AT = o'
\ Varid 8| Change Class...
-| I |Examples 6 axes|
E‘ % Cut Cirl+X
-\E‘E\ementary 156 2
axish| By
'\E‘LDDPS axisControlBus8 | Copy Ctrl+C
Past Ctrl+V
- [ |Rotational3DEffects B Paste o
axiss| 2| Delete Del
BConstra\nis axisControlBuss | . .
—Esystems i uplicate trl+
= BB < » 3 - axied| di| Rotate 90 Ctrl+R
=1 wisControlBus4 - |
—— e £ E |= 2k Rotate -90 Ctrl+Shift+R
A P g . axis3 Aky Flip Horizontal H
+ 15 axisControlBus3 | S| Flip Vertical v
i Info
* b0 axizZ
# bl axisControlBus2 | View Annotation
+ b2 . Split Model...
+ b3 axis 1 2
i Show Diagram
4 b : axisControlBus1 | 3 9
+ b5 T
+ b6 =
+ load b
+ pathPlanning
+- axisl
+ ayic? S
Show the diagram layer instead of the icon layer for the icon. | Medeling | ¥ Simulation |

Another convenient way is to use the component browser. Put the cursor on top of the
wanted component in the browser and right-click to get the context menu. Select Show
Component as shown in the figure below. (In this case also care must be taken not to select
any axes of the module mechanics. The component browser has been enlarged in the figure
to illustrate this.) Since Show Component is the first menu option, double-clicking will
yield the same result. Please recall that double-clicking on a component in the edit window
pops up the parameter dialog (compare the two menus in the figure above and below!).

12



I Compaonent Bro

. . 2 axish
Dlsplaylng the T — ~ axisCortrolBusE  om—— .
components of axis 1. =|[Modelica.Mechanics. MulliBody. Examples...| h - meChanICS
=l mechanic: ) s
ControlBusS  I—
§< sxisControlBus: . \
Grisz? h . L g
W axis3 @ ) R
sxisControlbus4  ER—
M axizd 8 o —— @4
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1

#rl
i
#13
+id
H15
HiG
+ b0
+ b1
+b2
+/b3

axizControlBus2

axisControlfus1

Whatever method is used, the result will be the following figure in the edit window:
The robot drive train in

Axis 1.
i angleSensar
awizl |
L] angle
Lo_
speedSenzor
speed
oy
acCSenzor
acceleratipn
cartraller
muotor flangs
%

SNg|0UOOSHE

inttializeFlange

angle_ref

speed_ref
const

7

The drive train includes a controller. A data bus is used to send measurements and reference
signals to the controller and control signals from the controller to the actuator. The bus for
one axis has the following signals:
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The robot controller in
the robot drive train.

controller

g=

Name Description

motion_ref true, if reference motion is not in rest
angle_ref reference angle of axis flange

angle angle of axis flange

speed_ref reference speed of axis flange

speed speed of axis flange

acceleration_ref reference acceleration of axis flange
acceleration acceleration of axis flange
current_ref reference current of motor

current current of motor

motorAngle angle of motor flange

motorSpeed speed of motor flange

The bus from the path planning module is built as an array having 6 elements of the bus for
an axis.

The figure below is displayed by selecting the controller and showing the components of it.

gain2
k=ratio
waint P add3 Pl
feedba... |
W e e
. -1
k=ratio k=kp T=Tz=

axisCortrolBus

o =y
LS

The controller of an axis gets references for the angular position and speed from the path
planning module as well as measurements of the actual values of them. The controller out-
puts a reference for the current of the motor, which drives the gearbox.

The motor model consists of the electromotorical force, three operational amplifiers, resis-
tors, inductors, and sensors for the feedback loop.
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The robot motor. el

rriatar

d 5
057=H

=1

T THOST)

Jmatar flange_. .

1P

: axizCprirolBus
' L] L]
k=k \, . .-'

View the component gear in a similar way as for the other components. It shows the gearbox
and the model of friction of the bearings and elasticity of the shafts.

The robot gearbox. . )
flange of joint axis

gear flange of motor axis
bearingF ricti . gear
4.:‘ 1 flange_a Eal%fon sprin -i' flange_kb
¢ o = leo—()
d=d
1.2.2 Simulation

Let us simulate the robot model. To enter the Simulation mode, click on the tab Simulation
at the bottom right of the main window. Please note that selecting Simulation mode is not
the same as simulating the robot; it however gives the possibility doing so — the needed
menus are available in this mode.

Modeling @ Simulation
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Simulating the demo
(by running a script).

Animated 3D view of
the robot.

Simulating/manipulating with given values

The Simulation menu contains commands to setup and run simulations. Shortcut buttons are
also available. However, the demo has also been prepared with a command script that will
simulate the model. The script is executed selecting Commands > Simulate. Please use that

command.

-
fullRebot - Madelica.Mechanics.MultiBody. Examples.Systems.RobotR3fullRoket (Rea

=i File Edit Simulation Plot  Animation | Commands | Window Help Line

D-BeHQA& Ny O Smite [

2 r Plot result of al)/("?;B + animate

: : Add C d... =
= = x| omman

— Organize Commands

{2 el Marhanice A|

The model is now translated and simulated automatically. The script also contains some
setting of a plot window and an animation window. After enlarging the Dymola main

window it will look the following:

fullRobot - Modelica.Mechanics.MultiBody Examples.Systems.RobatR3.fullRobot (Rezd-Only)

[ESSEE=>=)

File Edit Simulation Plot Animation Commands

Window Help Linear analysis

N-@=lQE R« o - iB-e-»00H H-SE(00KEE A|&£-

Ep Il M 444l > P [Time: 0

Disueed:1v

Variable Browser

% * B plot1]

Varigbles values
=) & fuilRobot
Cmioad
[rLoad[1]
[rLoad[7]
[rLoad[3]

Og
[refstartTime
[CrefswingTime
[startAngle1
[startangle2
[startangle3
[startangle4
[startangles
[lstartangles
[JendAngle1
[endanglez
[lendangle3
[lendangle4
[lendangles
[endangles
[refSpeedMax([1]
[refspeedMax(2]
[refSpeedMax(3]
[refspeedMax[4]
[refSpeedMax(5]
[refspeedMax(s]
[refaccMax[1]
[refAccMax(2)
[refaccMax[3]
[refaccMax(4)
[refaccMax[s]
[refaccMax(s)
Oip1

[ks1

« n

F controlBus.axisControlBus3.speed_rel

[=E=I0E=]

controlBus.axisControlBus3.speed

radis]
=
i

00

Animation

Advanced

x

Preformatted  ~  Courier New

,_|E'|.9:

= rue

= rue

Selected object: mlozd

Selected object: mechanics b3.shapel Form

<

n

s

Commands

1B Modeling | Y Simulation ‘
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Animation toolbar.

Let us start to animate the robot. Start the animation by selecting Animation > Run or
clicking the Run button on the toolbar (the leftmost button)

Pl M AW Tine[D ] g

This toolbar contains the usual buttons of running, pausing, rewinding, and stepping forward
and backward, respectively. Also the time flow is shown and there is a possibility to set the
speed of the animation (higher figures means higher speed)

Please note that the Animation window can be maximized in the main window in the usual
way.

If the Animation window by mistake is deleted, a new can be displayed using the command
Animation > New Animation Window.

Direct manipulation of the view in the animation window using the mouse has been
implemented. The view can be moved, rotated and zoomed using mouse movements in
combination with Meta keys:

Operation Meta key Mouse move Arrow keys
(dragging)
Moving none Up/Down/Left/Right Up/Down/Left/Right
up/down/left/right
Tilt (Rotate around | Ctrl Up/Down Up/Down
X-axis)
Pan (Rotate around | Ctrl Left/Right Left/Right
y-axis)
Roll (rotate around Ctrl+Shift Clockwise/Counter- Left/Right
Z-axis) clockwise
Zoom in/out Shift Up/Down Up/Down
Zoom in/out none Wheel
Zoom in/out Citrl Wheel
Zoom in/out Ctrl Right mouse button
Up/Down

To set the rotation center on a selected component, use the context menu of the object and
select Current Object > Set Rotation Center.

The arrow keys pan and tilt in fixed increments of 5 degrees, in addition page up/page
down tilt 45 degrees. The Home key resets viewing transformation.

Let us now look at the plot window. The plot shows the speed reference and actual speed of
the third joint.

A very convenient way to display the variables for a certain component that is of interest is
to use the diagram layer of the edit window also in Simulation mode. The diagram layer
enables the user to follow a simulation by displaying variables and to control it by setting
parameters. The user can descend into any level of the model in order to plot or display
variables.

GETTING STARTED WITH DYMOLA 17



L Push the Diagram layer button = in the diagram layer toolbar to show the diagram. The
result might look like:

The diagram layer in S fullRobot - Modelica.Mechanics.MultiBody. Examples.Systems. RobotR3, fullRobot [AEE

Fle Edi Simulstion Plob Animation Commands Window Help

Simulation mode. SHQS W ¢80 VBV @SSR B I KA Db» me T st T )
* |y pigt [17] A=k ]
I S T EEs)
[=fullFobat 1 cortrolBus axisCortrolBus3.speed_ref [rad’s] cortrolBus.axisControlBus3 speed [rad)s]
ClmLoad [ 15kks 0s
[iload(] m
[iloadiz] m
[iload(3 m 005
Os —1
[refStanTime s
[refSwingTime 05)s 054
[startnglel 0 de;
[startngle2 20 de 10
[startngle3 90 de -1
[starangled de Diagram
[starténgleS 10 de 15
[startangled de
[endbngel B0 de
[endéngle? B 20 \/
[endbnge? 36 de
[endbngled 45 de.
[endéngles 0 de 25 ! 1 ;
[endéngles 45 |de 00 05 10 1.5 20
[lrefSpeedilas(1] ra — ——
CrefSpeedhan(z] 75 ac Animation [- [B]X]
CrefSpeedhanz] v N
[l refSpeedilas(4] 3T rac i
[refS peedi ax(5] 31 rag Al
[refSpeedialé] 41 ra i
DrefceMax(1] ra o
[refaccMax(2] rac o
[refAcchax(3] rac
[refAcchax(4] rac
[refAcch (5] rac
[refAcchax(6] rac
[kpt
kst 05
01 005 |
[kp2
[ks2 0.
OTs2 005 |
[kp3
[ks3 0.
OTs3 005 |
[kt
kst 0.
OTsa 005 |
Llkps : T
< i i > 2
P = — ]
o -~
v
{1 >
Modelica, Mechanics, MuliBody Examples, Systems  RobotR 3.Components. AxisTypel ‘ (B Modeling | T simulation ‘
Parometers Now the diagram layer is visible. You can now navigate exactly the same way as in the
Show Component 1 1 1 H
[E Modeling mode — right-click on the component you want to look into and select Show
Open Clas in N Tab Component to look into it.

Open Class in New Window

Show Variables

View Atbuies You go back using the Previous € button in the diagram layer toolbar . .

%) Change Class...
e kX If you want the diagram layer to show more of an overview; e.g. the whole robot, you have

to go back to Modeling mode and change what is displayed in the Edit window. Then you
can go back to Simulate mode.

When having reached the interesting component, right-click on it and select Show
Variables, which will open and highlight the selected component instance in the variable
browser. In the figure below, the variables of the motor in Axis 1 is displayed in this way.
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Please note that if the diagram layer window is active, selecting another component in the
variable browser will also change the selection in the diagram layer window.

Changing and saving start values

Using the variable browser you can change values, and then simulate again. It is possible to
save changed start values directly into the model, see section “Saving changed start values
to the model” on page 67 for more information about this possibility.

1.2.3 Other demo examples

Other demo examples can be found under the File > Demos menu. After selecting an exam-
ple, it can be simulated by running a corresponding script file as was done for the robot ex-
ample. The exception is the demos in Automotive Demos Library. It contains several
demos, and the relevant demo has to be opened first by expanding the package “Examples”
in the package browser by clicking the + before it, and then double-clicking on the relevant
demo to open it. Please note that to run any of the Automotive Library demos you have to
have a number of licenses for commercial libraries. Please see the description presented
when opening the library for more information.
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1.3

A pendulum.

The first step to
create a new model.

Solving a non-linear differential equation

This example will show how to define a simple model given by an ordinary differential
equation. We will simulate a planar mathematical pendulum as shown in the figure.

|

|phi

|
|
mg

The variable m is the mass and L is the distance from the support to the center of mass. Let
us assume the string is inextensible and massless, and further, let us neglect the resistance of
the air and assume the gravitational field to be constant with g as the acceleration of gravity.
The equation of motion for the pendulum is given by the torque balance around the origin as

J*der(w) = -m*g*L*sin(phi)
where J is the moment of inertia with respect to the origin. Assuming a point mass gives
J = m*L"2

The variable w is the angular velocity and der(w) denotes the time derivative of w, i.e., the
angular acceleration. For the angular position we have

der(phi) = w

Start Dymola or if it is already started then give the command File > Clear All in the
Dymola main window.

Click on the tab Modeling at the bottom right. Then select File > New > Model....

r Dymaola - Dynamic Modeling Laboratory - [Diagram]
File | Edit Simulation Plot  Animation Commands Window Help Lin
) New 3 Model... CtrlvshifteM ||
@ Open. Ctrl+0 Connector.
Pa = Load.. Ctrl+Shift+0 Record...
[T | Libraries 3 Block...
:. Demos 3 Function...
3 [ Save Ctrl+5 Package... Ctrl+Shift+P
{ Save As... Duplicate Class...  Ctrl+5hift+D |
Save Al I ' ' '

(You can also perform the opening command either by clicking the arrow on the New

command button and select Model..., or click the command button New directly (Model... is
the default selection in that case.))
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The dialog to name a
new model component.

7

Dymala - Dynamic Modeling Laboratory

File Edit Simulation Plot  Anim:

DB QE K
Model... % Ctrl+Shift+M
R
P Connector... Dymaola - Dynamic Moc
B Record... e Edit Simulatio
7 2
1 Block.. EedqQ
+ Function... | New i
Package... Ctrl+Shift+P Package Browser
Duplicate Class...  Ctrl+Shift+D #[_|DymolaCommands
+1#WModelica Reference

Having several alternatives doing the same thing is not uncommon in Dymola.)

A dialog window opens. Enter Pendulum as the name of the model.

Create New Model

Mame of new maodel:

Pendulum
Description:
[] Partial
Extends [optiohal):
Insert in package [optional):
C
[ ok ] [ Cancel ]

Click OK. You will then have to Accept that you want to add this at the top-level. You
should in general store your models into packages, as will be described later.

Since you use the New command, a new tab will be opened with the new model. The tabs
work like working areas in for example Internet Explorer.

A model can be inspected and edited in different views. When specifying a behavior directly
in terms of equations, it is most convenient to work with the model as the Modelica Text;
that is, working in the Modelica text layer of the edit window.

To display this layer, press the Modelica Text toolbar button (the second rightmost tool
button). The edit window can now be used as a text editor.
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The model presented
in the Modelica text
layer.

.
Pendulum - Pendulum - [Modelica Text] = | B ||

File Edit Simulation Plot  Animation Commands Window Help  Linear analysis — | &%

Dr-2=EdQAS8 R /OO ANRZL &[] Z- B-¢9mBAEE »
Unnamed Pendulm  [EJ -

Package Browser g X

+ DDymolaCommands model Pendulum

£ €9Modelica Reference )

} DModelica equaticn

E--Unnamed end Pendulum;

“Pendulum

el & | ¢« |

Component Browser F X

|Pandu|um |

To declare the parameters and the variables, enter as shown the declarations for the parame-
ters m, L and g, which also are given default values. The parameter J is bound in terms of
other parameters. Finally, the time varying variables phi and w are declared. A start value is
given for phi, while w is implicitly given a start value of zero.

model Pendulum
parameter Real m=1;
parameter Real L=1;
parameter Real g=9.81;
parameter Real J=m*L"2;
Real phi(start=0.1);

Real w;
equation

der(phi) = w;

J*der(w) = -m*g*L*sin(phi);
end Pendulum;

New text will be syntax highlighted (color coded) as you type, except types; e.g. Real. To
get also types color coded, right-click and select Highlight Syntax or press Ctrl+L. Apart
from implementing color codes for types, the command will also give a message if the
syntax is not correct. It is a good idea to use the command regularly. The command does
not, however, change the formatting of the text (tabs etc.). Such change is implemented by
selecting the part of the text that should be reformatted, and then right-clicking and selecting
Reformat Selection (or press Ctrl+Shift+L).

The color codes are:

blue keywords

red types, operators etc.

black values, variables, parameters etc.
green comments

22



Declaration of parame-
ters, variables and
equations.

Check of model.

If the text seems too small to work with, the text size can be changed using the Edit >

is a good idea to set it back afterwards.

Options... command and temporary changing the Base font size in the Appearance tab. It

Pendulum - Pendulum - [Modelica Text]

| B e

FI|E Edit Simulation Plot  Anirmation  Commands  Window Help  Linear analysis

O-2eHQ8 N OO0 ANSL S

— |[ =] %

B-¢drmsAEHE >

| pendiom [ | -
Package Browser 5 X
;—éDDymolaCommands model Pendulum ks
+ € ¥Modelica Reference parameter Real m=l;
) parameter Rezl L=1;
T'@mda"ca parsmetar Resl g=9%.81;
i~Unnamed parameter Rezl J=m*L~Z;
“Pendulum Rezl phi{start=0.1);
Real w;
eguation
der(phi) = w;
J*der (w] = -m*g*L*sin(phi);
end Pendulum;
omn
B B [« ] » [ K]

Since the model should be simulated, it should be checked before saved. The check
command performs some symbolic and syntactic checks that will capture a number of errors
that might have been introduced by the user. The check can be made clicking on the Check
icon or by selecting the command Edit > Check or by using the F8 function key. The result

of a check of the above text looks the following:

-

Dymala Messages

—

-

5 |

Syntax Error Translation | Dialog Error I Simulation |

| ) 0Errors || 1, 0 Warnings || [i) SMEssages|

Clear

(i) Chedk of Pendulum:
(i) The model has the same number of unknowns and equations: 2
(i) Check of Pendulum successful,

The model is now ready to be saved. Select File > Save. Call the file pendulum and keep the

file extension to .mo and place it in a working directory.

-

GETTING STARTED WITH DYMOLA
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Modeling W Simulation

—

t 1,

Selecting Setup in the
Simulation menu.

1.3.1 Simulation

Now it is time to simulate. To enter the simulation mode, click on the tab Simulation at the
bottom right of the main window. The simulation menu is now activated and new tool bar
buttons appear.

To set up the simulation select Simulation > Setup... or click directly on the Setup toolbar
button.

.
Pendulurm - Pendulum
File Edit Simulati0n|l3|0t Animation  Cemmands  Window Help _ Linear anal
Seript 4 r 100% =~ &~ W ﬁ @
b Il || Translate  * | |Time: o |:| Speed: 1
Variable Brow: _¢°| Simulate & X
Variables Vi Continue ¥ scription Plot [17]
Stop 1.0
Linearize
ﬁ Setup...
TS 0.8
Show Leg

The simulation setup menu will be displayed:

24



The Simulation Setup
menu.

-
Simulation Setup

A=)

General Translation Cutput I Debug Compiler Realtime | FML |

Experiment

Mame  Pendulum

Simulation interval
Starttime 0

Stop time 1

Cutput interval
) Interval length 0

@ Mumber ofintervals 500

Integration
Algorithm [Dassl M ]
Tolerance 0.0001

Fixed Integrator Step |0

o ) [ e

Set the Stop time to 10 seconds. Click OK.

To run the simulation select Simulation > Simulate or click directly on the Simulate

toolbar button.

GETTING STARTED WITH DYMOLA
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Selecting Simulate in
the Simulation menu.

-
Pendulum - Pendulum

Dymola first translates and manipulates the model and model equations to a form suitable
for efficient simulation and then runs the simulation. (You may explicitly invoke translation
yourself by selecting Simulation > Translate or click on the Translate toolbar button.)

You will get a warning that the initial conditions are not fully specified. (The warning can
be seen in the Translation tab of the Message window that will pop.) However, Dymola will
select default initial conditions, so the simulation will work. We will discuss how to get rid
of the warnings later. For now, you can just close the Message window.

When the simulation is finished, the variable browser displays variables to plot. To see the
plot better, maximize the plot window in the edit window. Then click in the square box in

File Edit | Simulation | Plet Animation Commands Windo Help  Linearar
= = FEl scipt r 100% o ml
b || —E—Fronsiet s Time: 0 Speed:
Variable Brdwe| ¥*  Simulate & x
Varizbles | V4 COMHTIE Lo ription Plot [17]
Stop 1.0
Linearize
ﬁ Setup...
il Visualize 08
Show Leg

front of phi to get the angle plotted as shown below.
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Plotting the angle.

Pendulum - Pendulum, - [Plot]

7l File Edit Simulation Plob Animation Commands ‘Window Help (=& [0
wHQE Wie¢Rlen [Beyon @ 88K TLH
R N i —t
i x
—— phi
‘Wariables Walues Lnit 045
(= Pendulurn 1
Cm 1
L 1
[Ca 9.81 040
A
el phi
[ deriphi]
S — 08+
[ derfw)
0.00
-0.05 |
-0.10 o
£ 2 015
-d T T T T T T T T T
Advanced o N 4 s s 10
= true ~
P = true T
gsimulateModel { "Pendulwun”, stopTime=10, method="dass1l", resultFile="Pendulum"}); _3
= true v
Modeling | “y* Simulation |

Let us study a swing pendulum with larger amplitude and let it start in almost the top posi-
tion with phi = 3. It is easy to change initial conditions. Just enter 3 in the value box for phi
and click on the Simulate tool button.

You can also change start values and parameters by typing in the command window; e.g.
type phi=3 (followed by carriage return) for a change of phi.
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Pendulum angle when
starting in almost the
top position.

Pendulum - Pendulum, - [Plot] |Z||E|fz\

[l File Edit Simulation Flob Animation Commands ‘Window Help
wEHQE NieFen [[HeyOS @EFERX EHOH
I N i e e
ls B x
W aniables Walues Unit
[ Pendulurn 1
(= Pendulum 2
I 1 |
N 1
Ca 9.81 2

sk 1
[ derfphi]
[

[ derfw) B

(=& X

)

| ‘
=
=

Advanced j T j T j T j J j

phi = 3;

plot({"phi"});:

simulateModel { "Pendulum", stopTime=10, method="dass1l",
= true

X
|

regultFile="Pendulum");

]

<

B Madelng | WP Simulation |

The results of previous simulations are available as the experiment Pendulum 1 in the
Variable browser. We can open it up and have phi of the two runs plotted in the same

diagram by expanding “Pendulum 1” in the variable browser and check the checkbox for
“phi”.
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Results from two
simulations.

Pendulum - Pendulum, - [Plot]

E]File Edit Simulation Plot  Animation Commands  Window Help L= X
EHQAS Wi Boen HBsvOoln @ F2XK EOE
S Il M 44 Al PP Tine b Speed| 1w

I “Wariable Browser

——phi ——phi
W aniables Walues Unit

(= Pendulurn 1

[ derfw)
= Pendulum 2 B

[CIm 1
L 1
Ca 351 J
[

phi 3 14
[ derfphi]

[Tw 0

[ derfw) -2

Advanced j T j T j T j J j

phi = 2; ~
P plot ({"phi"});

i< simulateModel ("Pendulum", stopTime=10, method="dassl", resultFile="Pendulum"}:

true e

Modelng | Y Simulation

Values of parameters are changed in a similar way. To simulate another length of the
pendulum, just enter a new value for L and click on the simulate button.

1.3.2 Improving the model

Using pre-defined physical quantities

The parameters and variables are more than real numbers. They are physical quantities. The
Modelica standard library provides type declarations for many physical quantities. Using
these instead of declaring variables/parameters yourself gives two advantages:

e The declarations will be faster.
o Additional features will automatically be present; e.g. units and limits.

So let us change the model, using ready-made physical quantities. The starting point is the
Pendulum model built previously. (If Dymola is not started, start it and use File > Open to
open Pendulum.mo.)

Press the Modelica Text toolbar button (the second rightmost tool button) to show the
Modelica text layer.
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Adding a physical type.

Mark the declarations of variables/parameters in the text and delete them. Do not delete the
equation, that one we will keep. The result will be:

,

Pendulum - Pendulum - [Modelica Text]

File Edit Simulation Plot Animaticn Commands Window Help

N ZeHQAS N /OO ANRL2-E

Pendulum
s x[E

model Pendulum

Linear anal

Package Browser

Packages
+ - DD\;moIaCommands

i " equation

?-GModellca Reference der (phi) = w;

+1- 7| Modelica J*der(w) = -m*g*L*sin(phi);
‘-Unnamed end Dendulum;

Pendulum

Open Modelica.Slunits in the package browser by first expanding the Modelica package by
clicking on the + in front of it and then expanding “Slunits” by clicking on the + in front of
it. Now a number of physical types should be visible.

What is to be done is to redo the declaration part of the model presented on page 22 using
the physical types available in Modelica.Slunits. The mass is the first one to be declared. To
find “Mass” in the package browser, click on the package “Slunits” (to get a good starting
point) and then press m on the keyboard. The first physical type starting with “m” will be
displayed. Pressing m again will find the next physical type starting with “m” and so on.
(Another way to find it fast is by clicking on the header “Packages” of the package browser,
that will sort the physical types in alphabetical order.)

Once “Mass” is found, drag it to the component browser. The following menu will pop up:

Pendulum - Pendulum - [Modelica Text] = & ES
File Edit Simulation Plot  Animation Commands Window Help Linear analysis - & =
N-FeHAS N /Y O00FARL D - -4 malHEEL-~
[ penduim 3 | v
Package Browser g X E
Packages o model Pendulum g
PowerLevelDitterence
-DampingCoefficent B equation
LogarithmicDecrement der(phi) = w;
- AttenuationCoeffident J*der(w) = -m*g*L*siniphil;
PhaseCoefficient B =
g ~
-PropagationCoeffident Dropped Class PR
Damping
- Mass Dropped cass: Modelica.SIunits.Mass
Density
--RelativeDensity
Specificvolume Actions
oo
i} 58 ’ [ Change dass of component
Component Browser :| a Add component
|F' Tl (71 Add dass parameter
Encuium replaceable type name =
Modelica.S5Iunits.Mass;
Add base dass
\
|
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Declaring a variable.

The choice to add a component is pre-selected. Click OK. A menu to declare a variable pops

up:
P ~
Mew Variable @I—Jih
Dedaration | Type Prefix I Annotations
Type and name
[:] Modelica. SIunits. Mass A ::’ [ 1= '
Description
Modelica: Modelica,SIunits.Mass ;
[ OK ] [ Cancel ]

Now we can specify the type prefix (parameter), the name, value and description etc. (By
keeping the cursor on top of an input field for a while a tooltip text pops up explaining the

field.) Complete the description in the following way:

p
Mew Variable

Dedaration | Type Prefix I Annotations

Type and name

Description

:] Modelica. Slunits. Mass - % o [ ] = 1+

Masz of pendulum

Modelica:  Modelica,5Iunits.Mass m =1 "Mass of pendulum™ ;

[ OK ]’ Cancel ]

Click OK and the text appearing in the bottom row is inserted into the Modelica text

window.

You can also declare variables by using menu commands. Let us define the next parameter
by right-clicking in the Modelica Text layer and select New Variable....
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Pendulum - Pendulum - [Modelica Text]

=38

Package Browser

~LogarithmicDecrement
-AttenuationCoeffident
-PhaseCoeffident

~PropagationCoeffident

-Damping

~Mass

-Density
~RelativeDensity
~Specificviolume
-LinearDensity
-SurfaceDensity
-Momentum

Pendulum

File Edit Simulation Plot  Animation Commands Window Help Linear analysis

- aWQ8 W /OOy ARZL-&-Ff]S 0 = B-¢+»=2H

B B | €

Component Browser

» [ & ]

|Pendu|um

2

EX
A

model Pendulum

Modelica.

equation
der (phi)
J*deriw)
a

Slunits.Mess m=l "Mass of pendulum”;

# Cut
Copy

= wi
= -m*g*L*sin(phi);

end Pendulum;

The result is the declaration dialog, just as before:

R Paste

I
ta

e

Find and Replace...
Go To...

Expand

Highlight Syntax
Reformat Selection
Comment Selection

Settings

Insert Component Reference
Insert Local Class Reference

Insert Function Call...

Insert Type...

Insert Statement

New Variable...

-
Mew Variable

Dedaration | Type Prefix

Annotations |

Type and name

Description

Modelica: Real ;

]

- 0
Bt

OK ] [ Cancel

LS

Edit Function Call
Selected Class

Ctrl+X
Ctrl+C
Ctrl+V
Ctrl+F
Ctrl+3

3
Ctrl+L
Ctrl+Shift+L
Ctrl+K

2

3

3
Ctrl+W

3
Ctrl+M
Ctrl+U

3

After having selected “parameter” from the dropdown menu, we realize that the default type
“Real” is not what we want in this case; neither are any of the other dropdown alternatives
relevant for us. What we really would like is some “length” type. However, we can browse
for any type available in the package browser by the browse button. And, on top of that, we
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can type in the Search input field. The search is dynamically updated while typing. This is
illustrated in this figure:

Mew Variable ? 22

Dedaration | Type Prefix I Annotations |

Type and name

=ROE AR »
s il ‘h h
Description - Select Type P

Search: leng

Packages 1

=) E‘Modelica
;'SIUHHE CK ] [ Cancel

E-"Lengih
— E-"PaihLengﬂ'l
E-"Wavelengh
“Wavelenght
ompton\Wavelength
owingDownlLength
i-DiffusionLength
E-"MigraﬁonLengm
“-Coherencelength

Modelica: parami

[ Ok l[ Cancel ]

This was exactly what we wanted. It is sufficient to click OK to get the type, since it is
preselected. (If we wanted another of the displayed types, we could have selected that before
clicking OK.)

It should be noted that the way above is available also when the Modelica Text layer is not
displayed; the command Edit > Variables > New Variable... is always available.

The other quantities are defined in analogue ways. (It is a good idea to try both ways above
to see which one you like the best.) When coming to the variables “phi” and “w”, they are
variables, not parameters. Nothing should be entered in the type prefix input field for those.

When completing the form to declare the angle phi, the start value of the angle is defined by
clicking on the small triangle to the right of the value field and selecting Edit. A submenu
pops up. Enter 0.1 for start. The result will look like:
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Enterlng a start value. Variakle Declaration in Pendulum l D eS|

General

Model

Path Modelica.SIunits. Angle
Comment

Parameters

displayUnit +
min +

max +

start 0.1
fixed v b
nominal 4

stateSelect v

Click OK.
The following result is displayed:

The result. model Pendualum

parameter Modelica 5Tunits Mass m=1 "Mass of pendulum";

parameter Modelica. STunits. Length L=1 "Lenght of the pendualum";
parameter Modelica STunits_ Acceleration g=9%_.81 "Grawvity of acceleration";
parameter Modelica.  STunits Moment0fInertia J=w*L"*Z "Moment of inertia";
Modelica. 8Iunits_ Angle phi(start=0_1) "Pendulum angle";
Modelica. BEIunits. AnomlarWelocity w "Anemlar welocity";

equation
deriphi) = w;
J*deriw) = -m*g*L*siniphi);
Gl

end Penduluam;

The “+” in the margin to the left of the text and the icon almost at the end of the text
indicates the presence of graphical information or annotations. It may be displayed. This can
be done in two ways, either by clicking on the “+” or on the icon, or by right-clicking to get
the context menu, and then select Expand > Show Entire Text. Either way, it is revealed
that the annotation is an annotation documenting which version of the Modelica standard
library was used. Dymola uses this information to check if compatible versions of libraries
are used and to support automatic upgrading of models to new versions of libraries. A model
developer can provide conversion scripts that specify how models shall be upgraded
automatically to new versions of a library.

Please note that if any parameter/variable should be changed later on, the command Edit >
Variables can be used to select the variable that should be edited.
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Example of defining a
3 x 3 matrix Real
parameter.

(Another way of inserting pre-defined physical quantities is to recognize that these are
types. Types can be inserted in the code by right-clicking to pop the context menu and then
selecting Insert Type. The menu that pops enables searching by typing in names. The
advantage is that all types in all open packages are searched. It will be easy to find a known
type even if it located in another package. However, to also get help from the Declare
variable menu as above, the user has to

o Insert the type on an empty line

e Enter a space and the name of the variable

e Conclude with a semicolon

e Use Edit > Variables and select the new variable)

Note (outside the example) the ease of defining arrays/matrices using Edit > Variables >
New Variable.... In the Declare Variable dialog that is displayed, an “Array dimensions”
field is present after the “Variable Name” field. By entering “3” in this field, an array
containing 3 elements is defined, entering “:” defines an expandable array. Entering “3,3”
defines a 3 x 3 matrix, entering “:,:” defines an expandable matrix.

New Variable (-2 e

Dedaration | Type Prefix I Annotations |

Type and name

parameter = | Real + B MyMatrixdn [33 1= D

Description

A 3x3 matrix as parameter MyMatrixIn

Modelica: parameter Real MyMatrixIn [3,3] "A 3x3 matrix as parameter MyMatrixIn® ;

[ Ok ] | Cancel |

w y

To enter values or/and define the size, click on the arrow after the last field (see red marking

in the figure above), then on the Edit command . You will get a dialog to enter the
values.

Handling of warnings

When simulating, we still get a warning that the initial conditions are not fully specified. By
clicking on the Translation tab in the Message window and scroll to the top the following
can be seen (when you have expanded “the warning” node by clicking on the “+” before it):
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Dymala Messages o S

Syntax Error Translation | Dialog Error I Simulation |

| ) 0Errors || 1\ 1 Warnings || 1) 12 Messages | Clear

(i) Translation of Pendulum:
L) The DAE has 2 scalar unknowns and 2 scalar equations.

= /B The initial conditions for variables of type Real are not fully specfied.
Dymola has selected default initial conditions.

1) Assuming fixed start value for the continuous states:
phi(start = 0.1)
1) Assuming fixed default start value for the continuous states:

w(start = 0.0)
+- (i) Statistics
+-(1) Selected continuous time states
L) Finished
_!) WARNING: 1 warning was issued
L) Finished

In order to have sufficient number of initial conditions, Dymola look at the possibility to use
variables as states and attribute fixed start values to such states. (For more information,
please see chapter “Introduction to Modelica”, section “Initialization of models” and (more
advanced) the manual “Dymola User Manual VVolume 27, chapter “Advanced Modelica
support”, section “Means to control the selection of states”.)

Dymola presents in the warnings what variables have been selected as states with fixed start
values.

Dymola assumes fixed start values phi=0.1 and w=0. We have set the start value of phi to
0.1 (above), while the start value of w was implicitly given a start value of zero (default).
However, the attribute fixed is the problem. Fixed=true means that the start value is used to
initialize the model; it must be satisfied during initialization. Fixed=false means that the
value is just a guess-value for a non-linear solver. For variables fixed is default false. Since
the intention was to use these variable values as initialization values, the best is to explicitly
set the fixed-attribute to true — and also explicitly specify the start value of w to zero. The
resulting code (generating no warnings) will be:

model Pendulum
parameter Modelica. 2lunits.Mass m=1 "Mass of the pendulun”;
prarameter Modelica. ZTunits.Length L=1 "Lenght of the pendualum";
parameter Modelica. 8Iunits. hoceleration g=9_.81 "Gravity of acceleration";
parameter Modelica ETunits MomentOfInertia J=m*L*E "Moment of inertia";
Modelica. BIunits. Angle phiistart=0_1, fixed=true) "Pendulum angle";

Modelica. 8Tunits. AncularWelocity wistart=0, fixed=true) "Ancular welocity";

equation
deri{phi) = w;
J*der{w) = -n*g*L*sin(phi):
=

end Perndulam;
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1.4 Using the Modelica Standard Library

Motor drive built with
standard components.

In this example, we will show how a model is built up using components from the Modelica
Standard Library. The task is to model a motor drive with an electric DC motor, gearbox,
load, and controller.

controller gearbox
positionerror rnotar B lnad
_ .—- _ L
}—t )—D—’ L | =o———&=
- ratib3 —
Ti=Ti =10

peojiyd

yd

As when building a real system, there are several approaches. One extreme approach is to
build the system from scratch. However, it is often a difficult and time-consuming task. An-
other approach is to investigate if the system already is available on the market or if there is
some product that easily can be adapted or modified. If not, build the system from compo-
nents available when possible and develop only when necessary.

The idea of object oriented modeling is to support easy and flexible reuse of model
knowledge. Modelica has been designed to support reuse of model components as parts in
different models and to support easy adaptation of model components to make them
describe similar physical components. The design of Modelica has also been accompanied
by the development of model libraries.

1.4.1 The Modelica Standard Library

We will now have a look at the Modelica Standard Library to see what is available and how
we access the model components and their documentation. To open the library, double-click
on Modelica in the Package browser.
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Opening the Modelica
Standard Library.

The sub-libraries of
the Modelica Standard
Library.

-
Dymala - Dynamic Modeling Laboratery - [Diagram]

File Edit Simulation Plot Animation Commands Window Help
BerHQAS W /YOO ARL-2-FR
Package Browser & x|

Packanes
éﬂModeIica Reference

- ﬁl\‘lodeliﬁ

“nnamed
Modelica <Mot yet opened>

Dymola reads in the library. The Modelica Standard Library is hierarchically structured into
sub-libraries.

-
Dymala - Dynamic Modeling Laboratory - [Diagrar

File Edit Simulation Plot Animation Cc
FeEHA8 W OO0/

Package Browser B X |

Packages
F+-4¥Modelica Reference

=1 2 Modelica
[+]- 6 User's Guide
& B Blocks

[+]: ComplexBlocks
[+ ESEU&Graph
[+]- @Electrical

[+ @Magneﬁc

[+]- @Mechanics

[+ e Fluid

[+]- @Media

[+ @Thermal

& [y Math

[+ ComplexMaﬂﬂ
- (3] Utilities

[+-| ™ |Constants

[+ Elcons

+I- ko] STunits
-Lnnamed

As shown by the package browser, the Modelica Standard Library includes
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e Blocks with continuous and discrete input/output blocks such as transfer functions,
filters, and sources.

e ComplexBlocks provides basic input/output control blocks with complex signals. (This
library is especially useful e.g. in combination with the library
Modelica.Electrical.QuasiStationary in order to build up very fast simulations of
electrical circuits with periodic currents and voltages.)

o StateGraph for modeling of discrete events and reactive systems by heretical state
machines. Please note that a more advanced library is available using the command
File > Libraries > State Graph. For more information about this library, please see
section “Libraries available in the File menu by default” starting on page 82.

o Electrical provides electric and electronic components (for analog, digital, machines and
multi-phase models) such as resistor, diode, DC motor, MOS and BJT transistor.

e Magnetic contains magnetic components to build especially electro-magnetic devices.

¢ Mechanics includes one-dimensional and 3-dimensional translational, rotational and
multi-body components such as inertia, gearbox, planetary gear, bearing friction and
clutch.

e Fluid contains components to model 1-dimensional thermo-fluid flow in network of
vessels, pipes, fluid machines, valves and fittings. All media from Modelica.Media can
be used. A unique feature is that the component equations and the media models as well
as pressure loss and heat transfer correlations are decoupled from each other.

e Media includes property models of media.
e Thermal provides models for heat transfer and thermo-fluid pipe flow.

e Math gives access to mathematical functions such as sin, cos and log and operations on
matrices (e.g. norm, solve, eig, exp).

e« ComplexMath contains complex mathematical functions (e.g. sin, cos) and functions
operating on complex vectors.

o Utilities contain functions especially for scripting (operating on files, streams, strings
and systems).

e Constants provide constants from mathematics, machine dependent constants and con-
stants from nature.

e Icons provide common graphical layouts (used in the Modelica Standard Library).

e Slunits with about 450 type definitions with units, such as Angle, Voltage, and Inertia
based on ISO 31-1992.

To get documentation for the entire Modelica Standard Library, place the cursor on Modeli-
ca, right-click and select Info. An information browser is directed to an HTML file
containing documentation for Modelica. This documentation has been generated from the
Modelica description of the library. There is basic information such as the content of the
library, conventions and conditions for use.
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Opening Modelica.Me-
chanics.

Dymola comes also with other free model libraries. A list of these libraries is given by the
command File > Libraries.

The package menu gives direct access to the sub-libraries. We will need components from
various sub-libraries. We will need rotational mechanical components as well as electrical
components for the motor.

To open the Modelica.Mechanics, double-click on Mechanics in the Package browser. The

documentation layer of the library will be shown. (If not, click on the |g| in the upper
toolbar.)

Mechanics - Modelica.Mechanics (Read-Only) - [Documentation] =NasN X )

File Edit Simulation Plot Animation Commands Window Help Linear analysis = || &)=
D-&@wHdQA&S N/ OO0 A NS D Z- H-¢ ) mBSEBEE

= Mechanics A

K

Package Browser g X iﬁ: ﬁw'}u ‘E" fei
* €¥Modelica Reference “| Library of 1-dim. and 3-dim. mechanical components (multi-body, rotational, translational)
= @Mode\ica

Information

: 0 User's Guide

This package contains components to model the movement of 1-dim. rotational, i-dim. translational, and 3-dim.
mechanical systems.

Mote, all dissipative components of the Modelica Mechanics library have an optional heatPort connector to which the

T-EstateGraph dissipated energy is transported in form of heat. This connector is enabled via parameter "useHeatPort”, If the
o /aElectrical - | heatPort connector is enabled, it must be connected, and if it is not enabled, it must not be connected. Independently,
whether the heatPort is enabled or not, the dissipated power is available from variable “lossPower” (which is positive if

= ][ 282 [ ‘ ] * [ K ] heat s flowing out of the heatPort).
Component Browser g X
=[Modelica.Mechanics

W Package - Modelicalcons.Package Package Content
Name Description

Extends from Modelica.Icons. Package {Icon for standard packages).

MultiBody Library to model 3-dimensional mechanical systems

Rotational  |Library to model 1-dimensional, rotational mechanical systems

Translational |Library to model 1-dimensional, translational mechanical systems

MName: Mechanics

Path: Modelica, Mechanics

Filename: E: /Program Files (x&5)/[Dymola 2016 Beta 3/Modelica/Library/Modelica 3.2. 1/Mechanics
Version: 3.2.1, 2013-08-14, build 2 (2013-08-14 08:44:412)

Uses:Complex {version="3.2,1%), ModelicaServices (version="3.2.17)

| Mndeling | * Simulation |

~

To get documentation on Modelica.Mechanics (as previously demonstrated) place the cursor
on Mechanics, right-click and select Info.

Besides using the package browser of the Dymola window, it is also possible to open a li-
brary window that also contains a browser. It can be done in two ways. If the library
window should contain the Mechanics package, select “Mechanics” in the package browser
and right-click to get a menu. Select Open Library Window. If the window should contain
the “top package” in the browser (Modelica in this case), use the toolbar to select Window >
New Library Window. Using the latter, selecting Modelica in the Package browser in the
upper part of the window (and adapting the window) will display the following:
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A library window dis-
playing the Modelica
Standard Library.

[ ™
Dymola Libraries E‘Elg

- DDymoIaCommands -
Modelica Reference

gavse
[ 0 User's Guide

[+ |2 |Blocks

[+ | (81| ComplexBlocks

[+ ESEEGraph

= feea|Electrical

[+ @Magnetic

[ E‘Med’wanlcs

- [ Fuid

& [ Media

[+ @‘Tﬁermal

1+ [y|Math

[+ CamplexMaﬂw

3 @Uﬁhﬁes

£ ﬂConsianis

[+ E‘Imns

= [KgStunits o

-Unnamed 7

O 2 =28 0= x5 7

m

UsersGuide Blocks ComplexBlocks StateGraph Electrical Magnetic Mechanics Fluid Media
s O G 26 (n) ) kg i
- B ! = Il m# J > 3 —

s J

A Library window includes a package browser, where the components of the selected sub-
library are displayed in a part of the window.

By closing the package browser by toggling the button to the bottom left, double-clicking on
the icon for Modelica and adapting the window to the content the following will be
displayed. Please note that now the name of the package will be displayed in the window
title bar.
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A library window dis-
playing the compo-
nents of the Modelica
Standard Library.

The rotational mechan-
ics library window.

Modelica - package Modelica

Uzers.. f
=) g =5 El s B

UsersGuide Blocks Stateicraph Electrical IMagnetic Mechanics Fluid
Library Librany ) Libirary H [ka...
Media Thermal Math Ukilities Constants Icons SIunits
2 I 8 I < I » I L3

By using the right button at the bottom it is possible to go up in the package hierarchy and
by double-clicking on the icons in the window it is possible to go down in the hierarchy.
The left and right arrow buttons allow going back and forth as in an ordinary web browser.

Open Modelica.Mechanics.Rotational in the library window by first double-clicking on the
icon for Mechanics and then on the icon for Rotational. The package Rotational contains
components for rotating elements and gearboxes, which are useful for our modeling of the
electrical motor drive.

Rotational - package Modelica. Mechanics. Rotational E”E”'S__q

LzersG..

Likrary |__J Pam m Library

UszersGuide Examples Components Sources Sensors Interfaces

= I B2 I ¢ J » ( 3

The Info for Modelica.Mechanics.Rotational contains important information on the package
content.

By navigating in the packages/libraries present here (using double-clicking and left arrow)
we will find a number of components that might be of interest to us. As examples, this is
how the libraries Components and Sensors will look like:
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The Components
library.

The Sensors library.

Components - package Modelica. Mechanics.Rotational. Components

L b |
e = == e o o[l‘]:v[j—‘
e — = o {g[jo 0
Fized Inertia Dize Spring Dramper SpringDamper  ElastoBacklash
| . | . i — .
A SR
= [ 1] L1 T_ '_T L '_T
o @ 0 S0 |
BearingFriction Brake Clutch One'w’ayClutch ldealGear LozsyGear |dealPlanetary
et
@ 2
vk ® O l— = n a start
Gearbox ldealGearR2T  IdealRolingwheel IritislizeFlange  RelativeStates
= I = I < J » K

Sensors - package Modelica.Mechanics.Rotational Sensors

R S S A

phi_rel
AngleSensor SpeedSensor AccSenzor ReltngleSensor  RelSpeedSenzor  RelbccSensor  TorqueSensor
I piver
Powers enzor
2 I = I < J » 3

us.

A quick scan of the Component library indicates that the model Inertia may be of interest for

Right-click on Inertia for a context menu. Select Info to get documentation for the model.
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The context menu for
a component.

Mathematical defini-
tion of a rotational in-
ertia.

Components - package Modelica.Mechanics.Rotational. Components

ica

Fized

L

Edit
™ 57 Check

Q Search,,

% 'E Parametegs

BeanngFriction Brake Clutch OnetwdapClutch

Gearbox

ldealGearR2T  IdealRolingwheel  InibalizeFlange

COpen Class in Mew Wlndow ,\/LO .—‘:I:_O .I%IO

it Dramper

N |
e o 4]

o

|dealGear
e-{5:-0

RelativeStates

e

SpringDamper  ElastoBacklazh

= |

#
ol -
5 .

LozayGear |dealFlanetany

[ . I B I * ]

> 3

To get a model window for Inertia select Open Class in New Window in the same context

menu. A window for the model Inertia

is created. Switch to the Modelica Text

representation, where you find Euler’s equation as the last equation.

-
Inertia - Modelica.Mechanics.Rotational ComponentsInertia (Read-Only) - [Modelica Text]

=[5 [t |

File Edit Sirmulstion  Plot  Animation  Commands  Window Help  Linear analysis

OUsers Guide of Rotational L... |7| b
[ |Examples parameter SI.Inertia J{min=0
-@Componenlﬁ

i~ g Fixed 4 a7

end Inertia;

= [l & >

D-2eldA&S R /OO0 ARSL-2-[FRS |0 |Z- -« +»mcHEE »
Package Browser ERENE

.Rotahonal |+ mpdel Inertia "lD-rotaticnzl component with inertia™ -

, sStart=l)
parameter StateSelect stateSelect=S5tateSelect.default
"Driority to use phi and w as states™

: 5I.2ngle phi(stateSelect=stateSelect)

S5I.A&ngulzrVelocity wistateSelect=stateSelect)

e "Absclute angular velocity of component (= dexr(phi))™
o S
BB e » (8], >
Component Browser 8 x SI_Angulsricceleration a
"Absclute angular acceleration of component (= der({w))™
—|MDdelica‘Mechanics.RotationaI.Compo... 3 a:
B flange_a
B flange_b equation
phi = flange_=.phi;
phi = flange b.phi;
w = der(phi);
2 = deriw);
J*z = flange_a.tau + flange_b_tau;
L

"Moment of inertia";

"Ebsclute rotaticn angle of component™

If wanted, it is possible to look at the content with equations rendered with mathematical

notation. Click the command button Mathematical
Modelica text pane. The result will be:

Notation in the toolbar above the
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Displaying using
mathematical notation.

Creating a new Modeli-
ca package.

1 Inertia
ax B

Rotatinnal i
o User's Guide of Rotational L...

-BExamples

-Componenis

Package Browser

model Inertia "1D-rotational component with inertia”

parameter SI.Inertia J{min=0, start=1) "Moment of inertia™;
parameter StateSelect stateSelect=5StateSelect. default
“Priority to use phi and w as states™;

SL Angularvelocity w(stateSelect=stateSelect)

"Absolute angular velocity of component (= der(phi))";
SI.AngularAcceleration a

"Absolute angular acceleration of component (= der{w))";

B €] % [ cooon

]
¢ = flange, ¢
Component Browser g X
2 ¢ = flange, ¢
—|MDdelica‘Mechanics.RotationaI.Compo...
de
B flange_a w = ar
M flange b
a =AW
d¢

J-a = flange,.r+flange, r

end Inertia

-

Inertia- Modelica.Mechanics.Rotational. ComponentsInertia (Read-Only) - [Mathematical Notation] = B S
File Edit Simulation Plot  Animation Commands Window Help Linear analysis =&
D-SeEHQAS N N0 ARL - Z- B-¢»mSHAEE -
-

5L Angle phi(stateSelect=stateSelect) "Absolute rotation angle of component™;

After this introduction of how to access model components and documentation of a library,
we will continue by actually building a model for an electric DC motor. This task will give

us more experience.

1.4.2

Itis a good idea to insert developed components into a library.

Creating a library for components

It is a good way to keep track

of components and it supports also the drag and drop feature when you will use the models
as components. Let us collect all developed components in a library called DriveLib. Go to
the Dymola window, and select File > New... > Package. This will pop the dialog:

Create New Package

MName:

Drivelib

Description:

[ partial

Extends (optional):
+ﬂ
)

Inzertin package (optional):
+a

fel

Save contents of package in one file

[ OK ” Cancel ]

2. |

Enter DriveLib as the new name of the package and click OK, and Accept in the informa-

tion window.

GETTING STARTED WITH DYMOLA
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Drivelib created.

A package DriveLib is created and made visible in the package browser (if scrolled). Select

Modelica text to get the Modelica representation, which at this stage just specifies a package
with no contents.

The layer shown in the package created (Modelica Text layer, Diagram layer etc) depends
on what layer was shown when creating the package. From the result below it is obvious
that the Modelica Text layer was shown when this package was created. The layer shown
can easily be changed by buttons in the toolbar in the upper right of the window.

Drivelib - Drivelib - [Modelica Text]

i e |

File Edit Simulation Plot  Animation Commands Window Help Linear analysis == %

[-& @ H Q&N /OO0 ANS-2-Ef 7. B-ermSAHE -~

Drivelib -

Package Browser q X
Packages package Drivelib 1
%—%DDymolaCommands ) .
é—-OMode\ica Reference end Drivelib;
+ DMode\ica
é--Unnamed
[ JriveLib

Bl E (€] » [ K]

Component Browser g X
| Drivelib
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An electrical DC
motor.

1.4.3 Creating a model for an electric DC motor

Fa La

flange_k1

=
3

A model of the complexity indicated above will be developed for the electric DC motor. For
simplicity the voltage supply is included in the motor model. The model includes an ideal
controlled voltage source. The electric part of the motor model includes armature resistance
and armature inductance. The electromotive force (emf) transforms electrical energy into ro-
tational mechanical energy. The mechanical part includes the mechanical inertia of the mo-
tor.

Let us start building the motor model. Select in the Dymola window File > New... > Model.
Enter Motor as name of the new model. To have the Motor model being a part of DriveL.ib,
we need to enter DriveLib for Insert in package. This can be done in several ways. Dymola
provides alternatives to be selected from and DriveLib is an available alternative. There are
no other alternative because all other open packages are write protected. It is also possible to
use the drag and drop feature and drag DriveLib into the slot. In the package browser, put
the cursor on DriveLib and press the left mouse button. While keeping it pressed, drag the
cursor to the slot for Insert in package (optional), release the button and the text DriveLib
will appear in the slot. It is also possible to browse for a package where to insert the model,
clicking on the browser symbol to the right.
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Inserting Motor in

DrivelLib.

An empty Motor
model.

Create Mew Model [ 7 ﬁl

Mame:

Motar

Description:

[ Partial
Extends (optional):

e
L1

Insert in package (optional):

5
L1

Drivelib - e,

oK l [ Cancel

L #

Click OK.

The package browser shows that DriveLib has a component Motor as desired. The picture
below shows the model with the diagram layer displayed (compare with the package created
above).

Motor - Drivelib.Motor - [Diagram] = is-‘
File Edit Simulation Plot  Animation Commands Window Help  Linear analysis — || & =
N-F2HQA8 R YOO ARL-5-Fffs 0 Z- ®-¢+aEHEE >
DriveLib Mator B v
Package Browser 5 X

Packanes
+ DDymoIaCommands
f—-OModahca Reference

+ DModahca

“Unnamed

= DDrlveLlh

f\’lnmr

Bl E (€] 9 [ K ]

Component Browser g X

|DriveLib.Mator |
I

The model window now contains an empty Motor model. The edit window has a gray frame
and grid to indicate that the component is not write-protected. It is possible to toggle the
grid using the toolbar button.

Before building the motor model, please note that selecting a package in the package
browser by just clicking on it does not mean that it is the one that is displayed in the edit
window (and component browser). Yes, it is indicated in the package browser by blue (or
red if not saved), but the one displayed stays the same (and is indicated by a blue frame in
the package browser, the name in the window header, the top name in the component
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browser and the name in the bottom left in the window). By double-clicking or right-
clicking on the package in the package browser the displayed package is changed, however.

We will now start building the motor model. To make it easier to follow the instructions, the
result is displayed below:

The finished motor
model with all compo-
nents.

Ha La

Wl M Jm flange_k
' :I —
L J=0.001

=
5

We need a model component for a resistor. It can be found in Modelica.Electrical.Ana-

log.Basic. The basic approach is to use drag and drop. You can drag and drop from the
package browser or from a library window.

To drag from package browser, open in turn Modelica, Electrical, Analog and Basic. Note
that title of the Dymola window is still DriveLib.Motor and also the component browser has
DriveLib.Motor as top level to indicate that we are editing the motor model.

AbOUt to drag a reSis' r Maotor - Drivelib.Motor - [Diagram] =rhE] ﬁ1
tor from the package File Edit Simulation Plot  Animation Commands Window Help Linear analysis - = =
browser. N-BeEQA& N YOOCANRL-2-Ffl2 0 Z- -« »aBHBE L~
Drivelib Motor B -
Package Browser q X
E‘ackaues
i -Basic
<+ Ground
q.j-HE1 Resistor - Ideal linear electrical resistor i
—=Conductor
h -—:—-Capadtur

(You can also drag from a library window.)

Drag a resistor from Basic to the Motor window and place it as shown above. The compo-
nent browser displays that Motor has a component Resistorl.
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Inserting a resistor
component.

The parameter dialog
of a resistor with de-
fault settings.

Motor - Drivelib.Motor - [Diagram] = | B |
File Edit Simulation Plot  Animation Commands Window Help  Linear analysis - |5 %
D-2=HdA& R /Yy OOy ARL-&-Ffs 0= -4« =ESHEE -
| Drivelib | Motor [ | -
Package Browser g X
Packaces o
Basic A n
a b resistor
- = Ground
- eResistor R=
" ]
-azieHeatingResistor
'-\?-Cunduchjr

When inserting a component it is given an automatically generated name. The name may be
changed in the parameter dialog. (The class name begins with an upper-case character,
component instances begins with a lower-case character.) Double-click on the component,
to get its parameter dialog. The parameter dialog can also be reached by placing the cursor
on the component, right-clicking and selecting Parameters.

resistor, in Drivelib.Motor

Zeneral | Add modifiers
Camponent Icon
Marme | resiskar |
Resistar
Comment | | ._|:|_u
F=
Model "
Path Modelica Electrical. Analog. Basic. Fesistor
Comment Ideal linear electrical resistor
Parameters
R l:| v Ohm Resistance R_ref at terperature T_ref
T_ref l:l v degC Reference temperature
Temperature coefficient of resistance (R_actual = R_ref*{1 + alpha*{heatPort.T -
N O
useHeatPort [ 3 =true, if HeatPort is enabled
T l:l v degC Fixed device kemperature if useHeatPort = False
[ oK l [ Info ] ’ Cancel ]

Change the component name to Ra. The parameter dialog allows setting of parameter val-
ues. To set the resistance parameter, R, select the value field of parameter R and input 0.5.
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The parameter dialog
of a resistor with new
settings.

resistor in Drivelib.Motor

zeneral Add modifiers
Cornponenk Icon
arme Ra
Resistor
Cornrnenk "|:|’”
R=
Maode n
Path Modelica Electrical, Analog.Basic.Resistor

Comment Ideal linear electrical resistor

Parameters

R 0.5 COhm Resistance R_ref at temperature T_ref
T_ref v deaC Reference temperature
.. . = *, * -
alpha vk Temperature coefficient of resiskance (R _actual = R_ref*{1 + alpha*(heatPort. T
T_ref))
useHeatPort [ 3 =true, if HeatPort is enabled
T v degiC Fixed device temperature if useHeatPort = false
oK ] ’ Info ] ’ Cancel
Click OK.

Similarly drag an inductor to the Motor window. Name it La and set the inductance, L, to
0.05.

Drag a ground component into the motor model. Name it G. The ground component is as
important as in real electrical circuits. It defines the electrical potential to be zero at its con-
nection point. As in the real world, never forget to ground an electrical circuit.

Drag an electromotive force, EMF, component into the motor model. Keep the name emf.
(The component is grounded, meaning that the component has a support, where the support
connector is fixed to the ground. Please keep in mind the difference from electrical
grounding.)

A voltage source is to be found in Modelica.Electrical. Analog.Sources. Use a library win-
dow or package browser to locate it. Select SignalVoltage and drag it to the model window
of Motor. Name it Vs. Let Vs be selected and use Edit > Rotate 90 to turn the signal input,
Vs.inPort, from a top position to a left position.

SignalVoltage produces, between its two electrical pins, p and n, a voltage difference, p.v-
n.v, that is equal to the signal input. (This info can be displayed by right-clicking on the icon
and selecting Info.). To get the proper sign we would like to have pin p in the top position.
Since the pin p (“+”) is the filled blue square, we must flip the component. To do that, use
Edit > Flip Vertical.

A rotating inertia component is to be found in Modelica.Mechanics.Rotational. Components.
Drag and drop such an inertia component. Name it Jm and set the inertia parameter, J, to
0.001.
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Now all model components are in place. Components are connected by drawing connections
between connectors. Connect the resistor to the inductor by pointing at the right connector
of the resistor (the small white square), press the left mouse button and keep it pressed while
dragging it to the left connector of the inductor. The resistor and the inductor are now
connected and the graphical result is a line between them. When connecting the voltage
source and the resistor, break the line by clicking at an intermediate point. There is a
possibility to obtain automatic Manhattanize of connections (non-endpoints of the
connections are moved to make all line segments horizontal or vertical). Select the
connection, right-click and select Edit > Manhattanize. Draw all connections. Note that we
could have drawn a connection between two components as soon as we have the
components and we have not to wait until all model components are in place. The points of
the connectors can be moved, and new points can be inserted using the context menu of the
connector.

Finally, we have to introduce a signal connector for the voltage control and a flange connec-
tor corresponding to the shaft of the motor so the motor can be connected to an environment.
We would like to place the icon of the connectors at the border of the grid of the drawing
pane, because the icon of a model component also includes the connectors. The connector
inPort must be compatible with the connector of Vs.inPort. There is a simple way to get a
connector inPort that is a clone of Vs.inPort. Start drawing a connection from Vs.inPort and
go to the left until you reach the border of the grid. Then you double-click and select Create
Connector from the menu popped up. The connector flange_b is created in a similar way. If
you would like to adjust the position of a connector it is easy to get into connect mode. This
can be avoided by toggling the toolbar button Toggle Connect Mode (when the background
is white it is in connect mode).

Click on Icon toolbar button to look at the icon layer. You will see the icons for the
connectors. Let us draw an icon for the motor model. One design is shown below. (The
thicker line to the right symbolizes the physical axis from the motor. It is a good idea to
select that line and use the context menu Order > Send to Back to prevent any case where
the axis seems to be lying outside the motor.)
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The icon of the electri-
cal DC motor.

Toolbar for editing.

name

To draw it, we will use the toolbar for editing graphics.
NOOARZL-S- 0|2 0 =~

Start by drawing the big red cylinder (shaded rectangle); Click the Rectangle button
(vellow rectangle) and draw a rectangle. Let it be selected. Click on the arrow to the right of
the Fill style button. Select Colors... and then select a red color. Click OK. To select the
gradient, click once again on the arrow to the right of the Fill style button. Select Gradient >
Horizontal. Draw the rest of the parts using Rectangle or Polygon in an analogous way. To
enter the text, click the Text button (the button labeled A) and lay out a rectangle that is as
long as the cylinder and one grid squares high. In the window prompt for the string
enter %name and click OK. The % sign has the magic function that when the model is used,
the actual component name will be displayed.

1.4.4 Documenting the model

We have now edited the icon and the diagram. It is also important to document the model.
When creating the model, the dialog has a slot Description. It is possible to edit this after-
wards. Select Edit > Attributes... to open the dialog.
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Model attributes. Change attributes for, Motor,

General | Graphicz | Verzion

Drescription

|A bazic model of an electrical motor

Restricted class

() Class () Block

® Model () Function

() Connector () Package

() Recard () Expandable connectar
Properties

[] Encapsulated

[] Partial

[] Protected
[] Replaceable
Stare as ane file

Dynarmic: typing
(® Marmal
) Inner
) Outer

I 1] l ’ Cancel

Enter a description and click OK.

|E| A longer documentation can be provided in the following way. Click on the toolbar button
S for Documentation (the button between the Diagram button and the Modelica Text button).

Documentatlon View- Motor - Drivelib.Motor - [Documentation]

File Edit Simulation Plot  Animation Commands Window Help Linear analysis
N-2#eEdAEG R OO0 ANL &

g Motor

B = B <>
e
H - - N
+ 5 Media A basic model of an electrical motor
. [§| Thermal Information

; Mam
: Comp\exMath
[F€Jutities | connectors
Consiants Type Hame Description
f-E‘Icons | input Reallnput |v1 Violtage between pin p and n (= p.v - n.v) as input signal
+ Slunns =| |Flange b flange_b1 |Right flange of shaft
-Unnamed Name: Motor

Filename: E: Experiment/Drivelib.mo
« | Uses:Modelica (version="3.2,17)

= [ JoriveLib —| Path: Drivelib Motor
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Documentation editor.

=
To enter a description, click the command button Info Editor inft in the toolbar on top of
the documentation layer. You now have access to a documentation editor for the
model/class with text-editing possibilities as well as link creation and image insertion. After
insertion of some text, an image and a link the result can look like:

The corresponding
html source code.

The final result.

[E] Motor - DriveLib.Motor - [Info Editor] o
E File Edit Simulation Plot Animation Commands Window Help Linear analysis - || & %
D-@wHAS NN OOCANS- [ Z- %-¢suSABEE o
R Motor -
Bl <> 2 <>
Package Browser 5 x| [ P
e p— —
5 [ vath “| Normal + (Default) v efad) + B I U x, x* | A~ v é 2 == W e=
[ ComplexMath This is & simple motor model.
* @Uﬁ“hes This documentation can certainly be extended using e.q. links and images of this editor. An image of the toolbar above illustrates the image possiblility:
+:| 7 |Constants = = = | = s= | 1= i—
;E Normal - (Defaul) - pefu) - B Z O x x |A-S-|[EE==EE == (E = Bl
+ Imns
4 SIunns _ || For more information about this editor, please see chapter Developing a model” in this manual.
Unnamed Mare information about Dymola in general is found in_ www.Dymola, com,
—-BDrivEL\b
= F

The created source code in html formatting can be viewed clicking Info Source 8 in the
toolbar on top of the documentation layer.

f 5
Motor - Drivelib.Motor - [Info Source] = | B |t
File Edit Simulation Plot  Animation Commands Window Help  Linear analysis - | &=

N-Z2eHAS N /YOOy ARZL-2-FN Z- H-¢ s ma=ABEL -

L3 Mator -

H:Z = <=

info |info| rev rew

<html>

<p>This is a simple motor model. </p>

<p>This documentation can certainly be extended using e.g. links and images of this
editor. 2n image of the toolbar above illustrates the image possiblility:</p>
<p><img sro="modelica://Drivelib/Rescurces/Images/Toolbar png"/></p>

<p>For more information about this editor, please see chapter GQUOT;Developing a
model&QUOT; in this manual.</p>

<p>More information sbout Dymola in general is found in<a href="http://www.Dymola.com”>
wWw.Dymola. coms/a>. </p>

</html>

X

Package Browser =]
T L s

CDmpIexMaih
[F€utiities

E‘Cnnstanm

m

5 DDrlvele

By clicking and selecting Formatted Documentation H in the toolbar on top of the
documentation layer, the result will be shown:
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Motor - Drivelib.Motor - [Documentation]

=NAC X

File Edit Simulation

Package Browser

Plot

N-ZedASNi/O0 ¢ AR ZL- -

E <> E <>
g x |nfu infa rev rew

]

Math
ComplexMaih
+ @Uhlmes

mlcuns
SIun\ts

+Unnamed

5[ Jorivetio

Component Browser

-

F X

| DriveLib.Mator

+ Ra
+ G
4 emf
+ Vs
+ Jm
+La
v
M flange_bl

Checking the model.

Window Help Linear analysis

[ |02 -« 2B =2

@  Motor -

Animation  Commands

A basic model of an electrical motor
Information

This is @ simple motor model.

This documentation can certainly be extended using e.g. links and images of this editor. An image of the toolbar above ilustrates the image possiblility:
- Defal) + B I U % x| A~ B~

For more information about this editor, please see chapter "Developing a model™in this manual.

+ (Default)

MNormal

More information about Dymola in general is found in www.Dymela, com,

Connectors

Type Name
input Reallnput |v1
Flange b flange_b1

Description
Voltage between pin p and n (= p.v - n.v) as input signal
Right flange of shaft

Name: Maotor

Path: Drivelib.Motor

Filename: E:/Experiment/Drivelib.mo
Uses:Modelica (version="3.2.17

The link can now be clicked; by hovering on it the URL is shown in the status bar of
Dymola main window (bottom of window; not shown in figure above).

The revision information can be edited in a similar way using Revisions editor.

We have now created the model. Save it.

1.4.5 Testing the model

It is possible to check the model for syntactic semantic and structural errors. Select Edit >
Check. Hopefully your model will pass the check and you will get the following message:

i N
Dymaola Messages I. = | 5 ﬁl
Syntax Error Translation | Dialog Error I Simulation |
|QUEnors||_ﬁUWmhgs||-.j)3Messages| Clear
(i) Check of Drivelib.Motor:
(1) The model has the same number of unknowns and equations: 43
(i) Check of Drivelib.Motor successful,
4 }
&

The connector inPort defines the voltage reference, and should be defined for the complete
model, but is viewed as a known input to the model.
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Signal sources.

W Simulation

'

It is important to test all models carefully, because that eliminates tedious debugging later
on. Let us connect the motor to a voltage source. Create a model called TestMotor and insert
it into DriveLib. The easiest way is to use the command File > New... > Model. It is good
practice to keep testing models. Drag a Motor component from the package browser into the
diagram layer of TestMotor. We need a source for the signal input to the motor. Signal
sources are to be found in Modelica.Blocks.Sources.

Sources - package Modelica.Blocks.Sources

= I N I — /_
FealExpreszion  IntegerExpression BooleanE spression Clock Consztant Step Famp
Sine ExpSine Exponentials Pulze SawTooth Trapezoid KinematicPTP
q
Lt B B ol A g lg
q...
i
KinematicPTPZ2 TimeT able CombiTimeTable BooleanConstant  BooleanStep BoaoleanPulze SampleT riager
By | — L
BooleanTable  IntegerConstant IntegerStep
B I B I < I » I 3

Drag, for example, over Step to the model window and connect it to the motor.

ztep

matar

start Time=0

Now it is time to simulate. Click on the tab for Simulation. This will change the mode from
Modeling mode to Simulation mode. To simulate the model click on the toolbar button
Simulate. (Please note the difference.)

Some warnings will be presented. Please see next section on how to get rid of them.
However, they are warnings, so the simulation will work anyway.

To inspect the result, we will first look at the angular position of the motor,
motor.flange_b.phi. Open motor in the variable browser by clicking on the + sign. Open the
flange_b and tick phi.
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Angular position.

X Il

=] TestMotor, - Drivelib. TestMotor - [Plot [1*]]

ol=le

[ File Edit Simulabon Plot Animation Commands Window Help =& ]
wHQSE R ¢80 [ HevOon @ SEK ELH
Sl A T j Speed| 1 v
u motar.flange_b1 phi
Wariables Values Urit 50
= Testhotor 1
[=lrmator
L] 50
#G
et
#Ys
Em 404
#la
[ W
=flange_b1 30~
[ phi rad o
[Jtau N.m h=2
[ step 20
10 H
0+
< 4
-10 T — — 7T —T———— ————
aanced 000 025 050 078 1.00

| simulateModel ("DriveLib.TestMotor", method="dassl", resultFile="TestMotor"):
= true w

BiModsling | ¥ Simulation

First, we may establish that a positive input signal makes angular position increase. The plot
looks almost like a straight line. However, there are some wriggles in the beginning. Zoom
in; use the mouse to stretch a rectangle over that portion of the curve you would like to see.
We may also plot the angular velocity motor.Jm.w; there is an oscillation which dies out and
the velocity becomes constant. There is much to be done to validate the model. However,
model validation is out of the scope for this introduction to Dymola.

It is possible to show several curves in the same diagram. Simply tick the variables to be
plotted. A curve is erased by ticking once more. The toolbar button Erase Curves (white
rectangle) erases all curves in the active diagram. It is also possible to have several
diagrams. To get a new diagram, select Plot > New Diagram or click on the toolbar button.
The new diagram becomes active. Selecting a diagram makes it active. (Selecting Plot >
Delete Diagram removes the diagram.)

(In addition to the above, there are numerous options in the plot window, e.g. you can

o Display dynamic tooltips (and copy the values to clipboard if needed).

o Display tooltip for the legend to see more information about the corresponding signal.
o Display tooltip for the x-axis and the y-axis.

e Moving and zooming (one way of zooming is to just drag a rectangle over the area that
is of interest).

58



e Change time unit on x-axis.

e Change the display unit of a signal.

o Display signal operators.

o Plot general expressions.

o Plot dependencies.

o Select multiple curves in a diagram (for e.g. copying the curve values to Excel).
o Display a table instead of curves, or create tables from curves.
e Plot parametric curves.

o Display Boolean and enumeration signals.

e Change color, line/marker style and thickness of a signal.

e Set diagram headings and axis titles and ranges.

o Insert and edit text objects in the plot.

e Change the appearance, layout and location of the legend.

e Display the component where the signal comes from in a new window containing the
diagram layer.

e Go back to a previously displayed plot window (or any other window previously
displayed.)

For more information about these options, please see chapter “Simulating a model”.)

Using the option of adding a new diagram and ticking motor.Jm.w the result shown below
is obtained.
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Angular velocity.

151 TestMotor, - Drivelib. TestMotor - [Plot [1*]]

E]Fi\e Edit  Simulation Plot  Animation Commands  MWindow  Help
EHQEG N eI [CH>»OT == R e B [
R N o B e

x

motor flange_b1 phi

Wariables Walues Unit 50
= Testhator 1
[=Imatar an |
HRa
=G =
memf & P+
FYe
Edm o
#iflange_s
#iflange_b 0
T E T — T T T T T T T T — T T T — T
S‘Ijjh\ :;gdmz 0.00 025 0.50 07s 1.00
Clderohi .. rads
" P s 5 etor dmaw
[ derfw] rads.
Oa 1ad/s, 1
#la
Clwt v 1
flange_bl £
[CIphi 1ad £ |
[Jtau MN.m
[Hstep o
< | >
T — T T T T T T T T — T T
ahanced 000 025 050 078 1.00

= true
| simulatelodel ( "Drivelib.TestMotor", method="dassl", resultFile="TestMotor");

=11

= true

>

B Madeiing ‘:\!Simu\atiun ‘

1.4.6 Handling the warnings

When simulating the TestMotor, warnings can be seen by looking at the Translation tab of
the Message window (you have to expand the first warning to see the submessages of that

warning):

60



Dymala Messages =NNEN X

Syntax Error Translation | Dialog Error I Simulation |

| ) 0Errors || 1\, 2 Warnings || 1) 12 Messages | Clear

(i) Translation of Drivelib. TestMotor:
(L) The DAE has 50 scalar unknowns and 50 scalar equations.

= /B The initial conditions for variables of type Real are not fully specfied.
Dymola has selected default initial conditions.

1) Assuming fixed start value for the continuous states:
maotor.La.i(start = 0)

1) Assuming fixed default start value for the continuous states:
mator, Jm.phi(start = 0.0)
motor, Jm.wistart = 0.0}

+-(1) Statistics
+- (i) Selected continuous time states

_ﬂ, The following parameters don't have any value, only a start value:
motor.emf kistart = 1)

Finished
WARNING: 2 warnings were issued
Finished

OOEC

Two types of warnings are present for this example; a warning that initial conditions are not
fully specified (at the top of the tab) and a warning that a parameter does not have any value,
only a start value (at the bottom of the tab).

The first type of warning has been described previously, see section “Handling of warnings”
on page 35. The difference here is that we can use the graphical user interface to set the
variables to fixed; we do not have to enter code.

Looking at the warnings, they all have to do with components inside the Motor model. By
double-clicking on the Motor in the package browser we return to this model.

The first variable of the upper warning section is located in the inductance component La.
Double-clicking on this component will however not display any Initialization section. But
since the variable is known, we can click on the tab Add modifiers and enter the text
i (Fixed=true) and press OK.
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La in Drivelib. Motor,

General Add modifiers |

Add new modifiers here, e.g. phi{start=1}, wistart=2)
| iffixed=true)

o J[ wo [ conesl |

When having clicked OK, the General tab will change to present the new initialization
information. Double-clicking again on the inductance component will result in:

LLa in Drivelib. Motor,

Cornponent Tcon

Mame |La| |

Inductor

Camment | | e
Model L=

Path Modelica,Electrical. Analog.Basic, Inductar

Comment Ideal linear electrical induckar
Parameters

L | 005+ H  Inductance
Initialization

i.start v I:I L Current Flowing from pin p ko pin n

I oK ] [ Info ] [ Cancel ]

The two last warnings in this part have to do with the inertia Jm. Double-clicking on this
component brings up the parameter dialog for it, and in the Initialization section phi and w
are found. By clicking on the little square in front of each of these variables, a menu pops
where we can select fixed=true. The final result will be:




Jmin Drivelib. Motor

General | Advanced add modifiers
Component Icon
Mame |Jm |
Inertia
| ]
Comment | | = O
=7
fodel J=
Path Madelica, Mechanics Ratational . Companents, Inertia
Comment 1D-rotational component with inertia
Parameters
3 | 0.001 [ kgmz  Moment of inertia
Initialization
phi.start [w l:l v odeg Absoluke rotation angle of component
w.skart W l:l booradfs Absolute angular velocity of companent (= der(phii)
a.start [ l:l v radfsz  Absolute angular acceleration of component (= der{w))
[ oK l ’ Info ] ’ Cancel

Click OK to confirm the changes.
If simulated again, the upper warnings in the Translation tab will not be present any more.

The lower warning states that the parameter motor.emf.k(start=1) only has a start value
(start=1) but no value.

The warning implies that this parameter value is generic and that it ought to be set by the
user. (More about such warnings can be read in chapter “Developing a model”, section
“Advanced model editing”, sub-section Parameters, variables and constants”.)

The way to handle this is to double-click on the emf component and set the value of k to 1.
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emf in DriveLib.Motor,

General Add madifiers
Zamponent Icon
Mame ernf

Camment ;g?
Model E..

Path Modelica Electrical. Analog. Basic. EMF

Comment Electromotaric Force {electric/mechanic transformer)

Parameters

usesupport [ 3 = true, if support flange enabled, otherwise implicithy grounded
k 1|* N.mfa  Transformation coefficient
(2] l ’ Infa ] [ Cancel

Click OK to confirm the change.

When simulating again, no warnings will be given.

1.4.7 Creating a model for the motor drive

The task was to build a model for a motor drive and it ought now to be a simple task to com-
plete the model. We will just give a few hints. Note that the full names of the components
are given in the component browser at the lower left.

Give the model the name MotorDrive — we will refer to that name later on. Put it in
DriveLib.

To generate the position error, you may use the model component Modelica.Blocks.-
Math.Feedback. For the controller, there is Modelica.Blocks.Continuous.PID.

In this simple example we can select the component Modelica.Mechanics. -
Rotational. Components.ldealGear as gearbox. For the meaning of ratio for the gearbox
model please consult Info for the model. Set ratio to 3 as indicated. It means that the motor
load rotates 3 times slower than the DC motor. The library Modelica.Mechanics. -
Rotational.Sensors contains a sensor for angles.

Inserting a load was dealt with when building the motor model.
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McatorDrive - Drivelib.MotorDrive - [Diagram] = | B |

File Edit Simulation Plot  Animation Commands Window Help Linear analysis

EeEHQAE& R Y OoCARS-2-f2S 0 =2- Bh-¢«»mBAEE -

Package Browser 5 X

Padkages
+-4¥Modelica Reference

%-E‘Modelica

é---Llnnamed
= (Jorivelib

- rgeMotor
i TestMotor

é--MomrDrive
“-MotorDriveTest
controller gearbox
pesitionerror
h—O—D—h/
e A
Bl E | €] * [ K ] Ti=Ti
Component Browser F X
Components

I Drivelib.MotarDrive
+ positionerror

+ gearbox
+ load

+ controller
5

5

phiload
motor

| Modeling | ¥ Simulation |

To test the model MotorDrive for normal operation, we need to define a reference for the
position. This can be done in different ways. A simple approach is to add a signal source di-
rectly to MotorDrive. However, we may like to use MotorDrive also for other purposes. If
we would like to use the drive as a component we could add a connector for the reference as
we did for the electric DC motor model. However, here we will take the opportunity to show
another useful way, namely use of extends. We will develop a new class, say Motor-
DriveTest, which extends MotorDrive. Select MotorDrive in the package browser and select
Edit > Extend From... in the context menu. This gives the same dialog as File > New... >
Model, but with several fields filled out. (It extends from MotorDrive and is inserted in the
same package, DriveLib.) Enter MotorDriveTest as the name of the model. Click OK. The
result is a model window, where the diagram layer looks exactly like that of MotorDrive.
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Tuning the controller.

However, the components cannot be edited. Try to move or delete a component. It has no
effect. Drag a component Step from Modelica.Blocks.Sources to the edit window and
connect it. Save the model.

(It is valuable to give some thoughts comparing “extend” to “copy/paste+add”. The former
strategy allows a far more clean structure, where an object can be reused in a number of
locations. If that object is further refined, all objects extended from that one will gain from
that refinement.)

A model can be used for different tasks. One is tuning the controller manually. Click on the
tab for Simulation. Translate the model MotorDriveTest by clicking on the Translate
button. (Also delete one of the plot windows and delete the previous curve.) The PID
controller has four parameters: k, Ti, Td and Nd.

(There will be some warnings when translating. We will take care of those later.)

One way to tune a PID-controller is by first disabling the integrator and derivative parts.
This is achieved by setting a large value for Ti and a small value for Td. Set k=2, Ti=1000,
and Td=0.001 and simulate for 5 seconds. (Use Simulation > Setup... to change the stop
time.) As can be observed, the step response is very slow. Increase k to find out what
happens. Make sure to also investigate the magnitude of the control signal, controller.y. The
result will be:

MotorDriveTest - Drivelib.MotorDriveTest - [Plot]

[ File Edit Simulation Plot  Animation Commands  Window Help =&
il QS WRieB . |[[EHe OV @id=ER O
Sl AW TineD j Speed:| 1 »
I Wariable Browser  phlasdphi stepy
“ariables Walues Linit # )
[+ posthionenon
[ contraller
[u rad 10
[y Y
Ok 2
i 1000 |z
[Td 0.001 |z
[INd 10 ne
CinitType:
[l wi_start 0 rad
[ wd_start 0 rad
[y _start 0w 06 -
®=F
=l =
D £
HGain
whdd 04
[#Hmotar
[# gearbox
[#/load
[=Iphiload oz
[#flange
[w] phi rad
[Sstep
I height 1 |rad
[ rad 0.0
[ nffsrt Mrad ¥
4 ¥
Advanced 1 j 1' j 2' j é j A j 5
phiload.phi in MokorDriveTest, mat Modeling ® Simulation
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Tuning result.

The interested reader may next proceed to tune the controller parameters to obtain a nice
step response. For example, aim at a rise time around 0.4 seconds, a settling time around 1
second, maximum overshoot of 10 percent, and a maximum control signal magnitude of 100.
Enforce the last constraint by adding a Modelica.Blocks.Nonlinear.Limiter component
between the controller and the motor in the MotorDrive model. Set uMax=100 and uMin=
-100 for the limiter. (We will not show this component in the code.) The result might be
something like:

MotorDriveTest - Drivelib.MotorDriveTest - [Plot [1*]]

[l File Edit Simulation Flot Animation Commands Window Help =& X
SHQS RieB o [fEe O @:FER TLH
AP Timelo J Speed| 1w
“ariable Browset oot o u
—— phiload phi ey
‘ariables Walues Uit 12
T
SMotorDriveTest 2 i
[# pogitioneror
[ controller 10
[#l motor :
[# gearbox
[#lnad
[= phiload
Hflange 0.8 4
v phi rad
[ limiter
=step
[T height 1 |rad 06 4
Wy rad T
[ offset 0 |rad =
[ startTime 0ls
04 -
0.2
0.0
4 »
T T T T T T T T T
Advanced N T K ] : .
Modeling “y® Simulation

Saving changed start values to the model

Having tuned values in simulation mode like the interested reader above, it is a big
advantage to be able to directly save them in the model (changing the Modelica code). This
can be done by right-clicking on the result file in the variable browser and selecting Save
Start Values in Model like below (on purpose the wanted values are hidden under the menu,
not to destroy the challenge of finding better values in previous section):

GETTING STARTED WITH DYMOLA 67



MaotorDriveTest - MotorDriveTest (Read-Only)

File Edit Simulation Plot Animation Commands Window Help Linear analysi:

Qs R €@ 0% Ly | @
P Il [ 4 44 4l P M [Time: 0 Speed: 1 -

: Variable Browser g X
Variables ’ Values Unit Description - Plot [17]
J}Mob:rDriveTest 1
1.2-
Collapse All Radius of load
|| -
[CIm Keep Result Mass of load 10-
+imotor
a:rgearbox Export Result As... c 0.8-
Fload Close Result
+flange_a 05-
+flange_b Save Start Values iwodel E‘
, I:|J Animate Moment of inertia = 04-
[ Iphi o Absolute rotation :
I E"Dder[phi) Animate Together der(absolute rotat 0.2-
i I -~ 1 -l [ '

Handling the warnings

There will be some warnings when translating. The principal handling of these warning has
been dealt with previously. The only thing that ought to be mentioned here is that in order to
make the variable controller.D.x(start=controller.D.x_start) fixed, you have
to double click on the MotorDrive, then select the controller, right-click and select Show
component. Now you can double-click on the D component to see the parameter dialog,
and since no x is available you have to select the Add modifier tab, enter x(fixed=true)
and press OK.

The rest of the warnings can be handled like described in a previous section.

1.4.8 Parameter expressions

Modelica supports parameter propagation and parameter expressions, which means that a
parameter can be expressed in terms of others. Assume that the load is a homogeneous cyl-
inder rotating long its axis and we would to have its mass, m, and radius, r, as primary pa-
rameters on the top level. The inertia is

J=05*m?*r"2

We need to declare m and r in MotorDrive. Open MotorDrive. Activate the Modelica Text
representation; press the Modelica Text toolbar button (the second rightmost tool button).

The parameters and variables are more than real numbers. They are physical quantities. The
Modelica standard library provides type declarations for many physical quantities. Select
Open Modelica.Slunits by clicking on it in the package browser (note, do not open it;
MotorDrive should still be open). For the parameter r, which is a radius, it is natural to
declare it as being of type Radius. To find it enter r and the browser goes to the first
component starting with r/R. If it is not the desired one, press r once again and so on to find
it.
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Declaration of
parameter r.

Parameter declara-
tions added to motor
drive.

When you have found Radius, drag it to the component browser below. The choice to add a
component is pre-selected. Click OK. A menu to declare a variable pops up. Complete the
declaration (do not forget to change to a parameter):

r Mew Variable l ? ﬂh‘

Dedaration | Type Prefix I Annotations |

Type and name

Modelica,5Iunits.Radius - 3?, r [ 1= 0.5+

Description

Radius of load

Modelica: parameter Modelica, SIunits. Radius r =0.5 "Radius of load™ ;

[ oK ][ Caneel ]

Click OK and the text appearing in the bottom row is inserted into the Modelica text win-
dow. The parameter m (being 80 kg if the resulting inertia should be the same as previously)
is defined in an analogue way.

MotorDrive - Drivelib.MotorDrive - [Modelica Text]

B File Edt Commands ~ Window  Help -8 X
[ 5 =
HQAE W /OO ARL D Z H-ermBAEZE o
Package Browser g X model MotorDrive
Packages -~ =
W avenUmoer =
parameter Modelica.3Iunits.RBadius r=0.5 "Radius of load";
- Circularwavelumber K K
) parameter Modelica.SIunits.Mass wm=80 "Mass of load";
- amplitudeLevelDifference .
} squation
- PowerlevelDifference Hh,
- DampingCoefficient end MotorDrive:
- LogarithmicDecrement
- AttenuationCoefficient
-PhaseCoefficient
- PropagationCoefficient
- Darnping
~Mass ¥
oo
(B (€] » [(&]

In Modelica Text representation above, the components and connections are indicated by
“+” in the margin to the left of the text, and icons in the text. It is possible have them
expanded textually in two ways.

One way is to work with individual annotation. It is possible to click on the “+” or the
corresponding icon to expand that annotation but no other. If “sub-annotations” are present,
new “+” and icons will be visible, which in turn can be expanded. (Of course they can also
be compressed using “-“.)

The other way is to work with all annotations at the same time. If that is wanted, right-click
and select Expand > Show components and connect. It is also possible to expand the
annotations such as the graphics for the icon of the model, the positions and sizes of the
icons of the components, the path of the connections etc. This is done by right-clicking and
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selecting Expand > Show entire text. However, we refrain from showing it in this
document.

Below the Modelica text as a result of first selecting select Expand > Show components
and connect and then the annotation for Motor has been individually expanded by clicking
on a corresponding “+” in the margin (which means that now a “-* is shown, indicating the
possibility to compress that annotation individually).

Expanded text MotorDrive - DriveLib.MotorDrive - [Modelica Text]
represe“tatlo“' E File  Edit Commands  Window  Help
~ =
EHQAE N YOO AEL D Z- i h-e»mBAEHE 0w -
Package Browser X model MotorDrive
Packages b . . : .
o avenUTDEr Modelica. Mechanics. Botational. Components. IdealGear gearboxiratio=3)
- Circularitavehlumber 2 . X :
) . Modelica.Mechanics. Botational | Sensors.Anglefensor phiload 3;
- AmplitudeLevelDifference
" L evelDiff. Motor motor &;
awerlevelierence - Modelica.Mechanics. Botational. Conponents. Inertia load({J=10)
- DampingCoefficient a:
“LogarithmicDecrement Modelica. Blocks.Math Feedback positionerror
- AiktenuationCoefficient a;
-PhaseCoefficient Modelica Elocks.Continuous. PID controller (D(x({fixed=true)))
- PropagationCoefficient a;
- Damping a;
- Mass o parameter Modelica ZTunits Badius r=0_.5 "Radius of load":
T parameter Modelica.28Iunits.Mass n=80 "Mass of load";
Rl E €] » (] .
= A
Component Browser 8 x connect (positionerror.y, controller.u) 3;
connect (motor. flange bl, gearbox. flange_a) a3;
Components connect (gearbox. flange_b, load. flange_a) &;
Elprivelib MotorDrive commect (load. flange b, phiload. flange) a;
[Flgearbox connect {phiload_ phi, positionerror.u2) §;
: connect {controller.y, motor.vl) a;
end MotorDriwve;
[+ positionerror
Heontroller

Ok, now activate the diagram representation. Double-click on the load icon to open the
parameter dialog.
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Binding a parameter to
an expression.

load in Drivelib. MotorDriveTest

General |Advanced Add madifiers

Component lzon
MName |I0ad |
Inertia
Comment | | L.
[= ==
—
todel TJTT
Path Modelica techanics Ratational Components. Inertia

Comment 1D-ratational compaonent with inertia

Parameters
J | i} 5"m“r"2|> kgmz  Moment of inertia
Iriitialization
phistatt [ | |’ deg Absalute rotation angle of compohent
wostat [ | |> rad®s  Absolute angular velocity of component (= derlphi])
astart [ | |> rad/s2  Absolute angular acceleration of component [= der(w])

[ ok [ we [ Conce |

Click in the value field of J and enter the expression for J. Click OK. The model window
now displays the expression for the load inertia. When entering the expression, you are
sometimes not sure about the exact name of the variables names, for example is the radius
called r, rO or r1? The problem is even more pronounced when you would like to reference a
variable a bit down in the component hierarchy. Dymola can assist you. First you enter 0.5*
and then you click on the small triangle to the right of the value field. Select Insert
Component Reference and then m.
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Using Component load in Drivelib. MotorDrive

Reference to enter a Gereral | advanced | Add modifiers
formula.

Companent Icon

Marne | load |

Inertia

Comment | | é_ép
=

Model J=

Path Modelica.Mechanics, Rokational, Components, Inertia

Comment 1D-rotational component with inertia

| |
Parameters ozl

] 0. Edit

Initialization Edit Text

Copy Default
phi.start [ v deg Absolute rotation ang

? View Parameter Setkings
w.start [ v oradfs Absolute angular velo

Propagate
a.start [ |:|> radfsz  Absolute angular acce

final
I OK| Insert Component Reference ¥ gearbox 3
8| Insert Function Cal phiload 3
rotar 3
load 3

positionerrar » ——

| Mod

controller 3

r

You have now 0.5*m in the value field for J. Enter *. Use the menus to get a reference to r.

Complete the expression with the square. Click OK. The model window now displays the
expression for the load inertia.

The component’s pa-

N controller gearbox
rameter definition is positionerrar motor F_n load "
visible in the model. _NTHE L
>_f i—p—’ —o—
B
T wJ=05"m 2
=
=
=3
a
o
=

Open MotorDriveTest and switch to Simulation mode.
P, 4] Translate.
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A bound parameter
cannot be changed in-
teractively.

MotorDriveTest - Drivelib. MotorDrive Test

File: Simulation  Plok Animation Commar
EEHCES K 43 o E
P Il M 444 Ir P Time: 0

Variable Browser F X

Wariables Walues it
+MotorDriveTest 1
=MokorDriveTast 2

+ gearbo

+ phiload

+ makar

+ load

+ positionerrar

+ controller

S 0.5 |m
“Cm a0 |kg
istep

The parameters r and m can be set interactively between simulation runs, but not the
parameter load.J because it is no longer a free parameter; an expression is now binding it to
rand m.

1.4.9 Documenting the simulation

The command window can be used to document the simulation. Text (also headers), images,
links, and mathematical expressions can be inserted and edited using the tools that are
available in the toolbar in the top of the command window.

Plot results can also be inserted in the command log (together with the corresponding plot
command) by using the context command Show In > Command Window. (Note that you
must not right-click on a curve etc., but in an empty area of the window, to get the general
context menu.)

Now the content in the command log pane can be edited to document the simulation in a
good way. Commands given and output results will be automatically be included.

An example of documenting better values of the PID controller could be:
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x
=

Commands

Preformatted ~ Courier Mew * Default) -~ B 7 U X, x° é &

—

i
il
i
L]
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¥

—

Selecting better values than the original ones for the PID

controller_k = 15;

controller . Ti = 1000;
controller . Td = 0_4;

aimilateModel ("Drivelib. MotorDriveTeat", stopTime=5, resultFile="MotorDriveTeat");

= true

plot{{"atep.¥","philecad phi"}, celors={{255,0,0},{0,0,2585}});

70

step.y —— phiload.phi

50

40

30+

[deg]

20+

104

-10 T

e

Note! The owvershoot is now too big, but that is because the limiter component is not yet included.

Some comments:

This example is just a minor example of what can be done. More about using the
command log pane to document simulations can be read in chapter “Simulating a model”
in the manual. Note that math rendering of equations etc. is supported, including
indexing and Greek letters.

The command log pane is enlarged; the command window can also be undocked instead
using the Undock button.

The header and the last line are entered by the user.

The simulation command is output from the system: including “true” in the following
line, indicating success (assuming the user has given a simulate command).
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Commai

Advanced.

e The plot command and plot image are added the following way:
0 The variables are plotted in a plot window.

0 To get the plot command in the plot window (really not needed for
documentation, but for scripting), the user clicked the command input line
of the command window — that echoed the underlying plot command in
the command log.

0 To add the image, the user right-clicked an empty space in the plot
window, and selected Show In > Command Window.

0 The user removed the rather long createPlot command that was added
together with the image.

e The content of an animation window can also be included using a flag; the below shows
how to set this flag to true by typing in the command input line of the command
window. This is a typical example of setting a flag; using flags is not unusual in Dymola.

e I

ScriptingWindow.Includeinimstion=true

Modeling W Simulation

e Sections of the command log pane can of course be copied to e.g. Microsoft Word for
further work.

e The content of the command log pane can be saved as a command log in Dymola, in
various formats (and including various contents).

1.4.10 Scripting

Scripting makes it possible to store actions, for various reasons. Examples might be:
e The script can be used to run a demo.

e The script can be used for testing of e.g. different parameter sets.

e The script can be used as an action that can be included in other models.

The first item can be solved creating a script file; while the last one is best solved creating a
function that can be included in other models.

Creating functions is not treated here, please see chapter “Simulating a model” in the
manual for more about scripting, in particular using functions.

If the simple example here should be saved as a script file, the easiest way is to do the
following (assuming that the models have been saved):

1. Go to Modeling mode, clear everything using the command File > Clear All.
2. Clear the content of the command log pane using the command File > Clear Log.

3. Reopen the DriveLib package using File > Recent Files.
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4. Open MotorDriveTest, and simulate it.
5. Set wanted values of controller. Simulate again.

6. Plot phiload.phi and step.y. (If those are already selected, you may have to deselect
them and select them again to get the below item to work.)

7. Force a plot command in the log by clicking the command input line.

8. Save the command log using File > Save Log.... Select saving it as a Modelica Scripts
(*.mos) file by selecting that alternative in the Save as type input field. Save the script
where the model resides. Give it a name, e.g. MyScript.

The saved script can be opened (and edited) using the Dymola script editor. (A general text
editor, e.g. Microsoft Notepad can also be used, but the script editor contains more
facilities.)

=1 C\Users\UWM\Desktop' MyTest\MyScript.mos - Script Editor EI@

O P | Mysoaptmes £

'/ Script generated by Dymola Fri Feb 28 14:34:15% Z014

simulateModel ("Drivelib.MotorDriveTest"™, stopTime=5, method="dassl", resultFile="MotorDriveTest");
controller.k = 15;

controller.Ti = 1000;

controller.Td = 0.4;

similateModel ("Drivelib.MotorDriveTest", stopTime=5, method="dassl", resultFile="MotorDriwveTest");

plot({"phiload.phi", "step.y"}, colors={{0,0,255},{255,0,0}}1;7

Note the difference between the saved log and the content in the command log pane. By
saving as a .mos file only executable commands are saved.

Note also that the plot command echoed in the command log does not include features like
plot header etc.; but for simple plot handling this is sufficient — more advanced commands
can be used to fully restore a plot window using scripting.

To run the script, you have to be in Simulation mode. The command Simulation > Script >
Run Script... (or corresponding command button) can be used to open (execute) the script.

Some comments:

e This script file is very simple, just showing the idea of a script file rather than being a
good example.

o Realizing how saving a script file works, it is not necessary to start all over to create the
file, the total simulation can be saved, and afterwards the script file can be edited to keep
only the wanted parts of the simulation. However, it is important to test it if created that
way.

e More information about script files is available in the chapter “Simulating a model” in
the manual for more information.
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e Working with scripting using functions is even smarter, for more information please see
the manual.

1.5 Building a mechanical model

We will now develop a more complex model, a 3D mechanical model of a pendulum called
a Furuta pendulum. It has an arm rotating in a horizontal plane with a single or double
pendulum attached to it, see below.

The Furuta pendulum.

Start Dymola. Open Modelica Standard Library. In the package Mechanics open the sub-
package MultiBody. This package includes 3D mechanical components such as joints and
bodies, which can be used to build a model of the Furuta pendulum.

To build the Furuta pendulum, you will need to use the Parts and Joints sub-packages. If you
open them in library windows by right-clicking on them in the package browser and using
the command Open Library Window (and adapting the window) they will look the

following:
.I_-he Part_s sub-package Parts - package Modelica.Mechanics. MultiBody.Parts ['._]E|§|
library window. e
T TN ¥
SH — =@ P @ mm
Fixed FixedTranslation  FixedRokation Biody BiodyShape BiodyEox BiodyCylinder
.—_
° N _ ._l _
e =0 e | =0
£ = -
PaintMass Mounting 1Dy RotorlD BevelGearlD Rolingwheel  RolingWheslSet
[ & I A I < I » I 3 ]
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The Joints sub- Joints - package Modelica. Mechanics.MultiBody. Joints

package library -
window. Al J,
[
@ P AR
Fismatic Revolute RevolutePlanarla. .. Cylindrical Universal Planar
. ]
s -
0= =|>[|q o0 (La it
a aunnn a[c DL a :)b a .:un
Sphetical FreeMotion  SpheticalSpherical UniversalSpherical GearConstraint  RolingWwhesl
@ Library Library
RollingWheelSet Assemblies Internal
= I i I ¢ ] » L3

Select File > New... > Model and give the name Furuta.

The first step in building a MBS (MultiBody System) model is to define an inertial system.
Drag the component World from the package browser (Multibody package) into the Furuta
edit window. The default parameters need not be changed. (The gravity of acceleration is set
to 9.81 and pointing in the negative direction of the y axis).

We then need a revolute joint. Drag the model Joints.Revolute onto the Furuta window. You
can either drag from the package browser or the library window. Select Edit > Rotate 90.
This just changes the appearance of the icon. Double-click on the icon.

Change the name to R1. The axis of rotation is set as the parameter n. We would like to have
a vertical axis of rotation; use the list of choices and select “y axis”. Click OK. Connect the
connector of world to the bottom connector of the revolute joint.
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revolute in Unnamed

General | Animation | Advanced | Add modifiers

Component lzon
RELT R1 Reveluts
Comment 'H-ﬂ'
Model n=

Path todelica Mechanics MultiBody.J aints. A evolute

Comment Revolute joint [1 rotational degree-of-freedom, 2 potential states, optional axis flange]

Parameters

usedsisFlange [ » = true, if axiz flange iz enabled

animation W = true, if animation shall be enabled [show asiz as cylinder)

n Az of rotation rezolved in frame_a (= zame as in frame_b)
Initishization 10,00 " avis”

phi.ztart 4010 "y awis™ . Relative rotation angle from frame_a to frame_b

10,013 "z axis" . . . . .
o radds
v shart 11,00 "regative ¥ axis” First denvative of angle phi relative angular velocity)
a.shart {0,-1.00 "riegative p axis" rad/s2  Second denvative af angle phi [relative angular acceleration)

10.0.-1} "negative z axis"

[ ok J[ wo ][ Cancel |

A bar is then connected to the revolute joint. There is one bar which has the visual appear-
ance of a box during animation, called BodyBox in the Parts library. Drag such a component
to the edit window. Double-click on the icon. Name it B1. We would like the bar to be 0.5
long and initially horizontal and pointing in the positive x direction. This is specified by
setting the vector r between the two ends of the body to {0.5, 0, 0}. Click on the Edit icon
just to the right of the value field of r and a vector editor pops up. Enter 0.5 in the first field,
0 in the following two fields (you must specify the values since no default values are shown,
otherwise you later will get an error message). Click OK. The width and height will be 0.1
by default.

To get nicer animation, you can set different colors for the bars. For example, use the list of
choices of color to make the bar red.

From the bar B1, we connect another revolute joint, R2, having a horizontal axis of rotation,
n={1, 0, 0} and a BodyBox, B2, (rotated -90), with r={0, -0.5, 0} and a different color than
the first bar.

When simulating, the start values of R2 are interesting. Looking at the parameter dialog for
R2 the initial value of the angle (phi.start), the initial velocity (w.start) and the relative
angular acceleration (a.start) can be specified in the dialog. The idea is of course to specify
values when simulating, but we have to specify what type of start values we want to use.
This is done by clicking on the box after each start value. The choices are:
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Choices for start
values.

The diagram of the Fu-
ruta pendulum.

W Sirulation

A
a0l

Fixed
True: stark-value is used to initialize
False: start-value is only a guess-value
v Inherited: (False; start-value is only a guess-value)

Actually we don’t need to change anything, Dymola will itself take care of this, but we will
have warnings when translating. In order to avoid these warnings, phi.start and w.start
should be set to fixed=true using the menu above for all joints.

To get a double pendulum, create another similar joint and another BodyBox and connect
them. This is accomplished easily by selecting the two components already present and
choosing Edit > Duplicate. (The selection of the start value type for phi.start can be
removed from R3 if wanted.)

You should now have arrived at a model that is similar to the following.

B R2
r={0.5,0,0} n={1.0,0}
i
- <
= 2 o
: =
world IRSE %
i l i H- h
n={10.0}

{0's°0-"0k=
cd

Now it is time to simulate. To enter the Simulation mode, click on the tab at the bottom
right. The simulation menu is now activated and new tool bar buttons appear.

When building 3D mechanical models, it is possible to get visual feedback to check that the
mechanical system is put together as intended. Click on the toolbar button Visualize. The
animation window shows the initial configuration of the system.
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Initial configuration of >
system. ‘

Translate the model. In the variable browser, open R2 by clicking on the + in front of it and
enter a value for phi_start, say 1 rad, and simulate for 5 seconds (use the command
Simulation > Setup... to change the stop time). View the pendulum in the animation
window; you may want to adjust the perspective when working with the robot (please see
section “Simulation” on page 15 for tools used). It will be nicer to present it by e.g. moving
it to the following position:

Initial configuration of N
system rotated around A
y axis.

Zq_l

h)

(The representation of the revolute joints as cylinders can be changed using the parameter
animation; if that is set to false the joint cylinders are not shown.)

Change parameters and study the different behavior.
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Try to control the pendulum in such a way as to get a stable upright position. (A trick is to
use a “mechanical PD controller”, i.e. a spring and damper attached to the tip of the second
bar and to a high position.)

1.6

Libraries available
when no optional
library is installed.

Other libraries

1.6.1 Libraries available in the File menu by
default

Using the command File > Libraries in a Dymola program with no extra libraries installed
will at present display the following:

l Dymola - Dynamic Modeling Laboratory - [Diagram]

=] FiIe|Edit Simulation  Plet  Animation Commands Window |

{ | New b ARZ- -
pa (= Open.. Ctrl+0
pg B Load... Ctrl+5Shift+ 0
+a Libraries L\\S s Medelica Reference
+ Demos b Medelica Standard Library
1 E Save Ctrl+5 DymelaCommands
Save As.., ModelManagement
Save All DataFiles
Save Total... Design
Version 4 UserInteraction
Clear All Plot3D
Q Search... Modelica_LinearSystems2
Change Directory... Modelica_StateGraph2
Print... Ctrl+P Modelica_Synchronous
Import ¥ Modelica_DeviceDrivers
Export ¥ Optimization
Save Log.. Vehiclelnterfaces

Modelica Reference is the documentation of classes, operators etc from the Modelica
Language Specification. There are no components that can be dragged from this library to
the edit window, it is purely documentation. This library is free.

Modelica Standard Library has been dealt with earlier in this chapter. This library is free.

DymolaCommands contains selected commands (built-in functions). They are grouped in
the same way as they are documented in chapter 5 in this manual (section “Scripting”, sub-
section “Built-in functions in Dymola”). Note that this library is automatically opened when
opening Dymola.
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Model Management deals with version management, model dependencies, encryption,
model and library checking (including regression testing of libraries), model comparison
and model structure. It cannot be used free, it demands a license. For more information,
please see the manual “Dymola User Manual VVolume 27, chapter “Model Management”.

DataFiles contains functions for reading and writing data. For more information, please see
chapter “Developing a model”, section “Advanced model editing”, sub-section “Using data
from files”.

Design deals with four main areas:

e Model calibration makes it possible to calibrate and assess models. The Model
Calibration option is required for problems with more than one tuner. For more
information, please see the manual “Dymola User Manual VVolume 2”, chapter “Model
calibration”.

e Model experimentation gives the user possibility to vary parameters of the system to
get an intuitive knowledge of the behavior of the model. Monte Carlo analysis is
included. This part of the library is free. For more information, please see the manual
“Dymola User Manual Volume 27, chapter “Model Experimentation”.

e Design optimization is used to determine improved values of model parameters by
multi-criteria optimization based on simulation runs. The Optimization option is required
if used on more complex models. For more information, please see the manual “Dymola
User Manual Volume 27, chapter “Design optimization”. Note that a newer library is
available also; please see “Optimization” below.

e Model validation supports validation and regression testing of a specified model. The
idea is to compare the simulation result against reference data to check if for example
changes in model libraries change the result. The reference data is assumed to be stored
as trajectory files, which is the data format used by Dymola to store simulation results.
When developing a model it is very natural and recommended to provide it with
carefully checked reference simulation results. Please also compare the library “Model
Management” where model validation and regression testing is supported on a larger
scale.

UserInteraction enables changing parameters and inputs by numbers, sliders etc., as well as
animation of simulation results. Please see the documentation in the package for more
information.

Plot 3D is used to visualize models in 3D. This library is free.

Modelica_LinearSystems?2 is a free library from Modelica Association providing different
representations of linear, time invariant differential and difference equation systems, as well
as typical operations on these system descriptions. See the documentation inside the package
for details.

Modelica_StateGraph2 is a free library from Modelica Association providing components
to model discrete event, reactive and hybrid systems in a convenient way with deterministic
hierarchical state diagrams. It can be used in combination with any Modelica model. It has
larger power than the package StateGraph in the Modelica Standard Library. See the
documentation inside the library for details.
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Modelica_Synchronous library is a free library from Modelica Association to precisely
define and synchronize sampled data systems with different sampling rates. The library has
elements to define periodic clocks and event clocks that trigger elements to sample, sub-
sample, super-sample, or shift-sample partitions synchronously. Optionally, quantization
effects, computational delay or noise can be simulated. Continuous-time equations can be
automatically discretized and utilized in a sampled data system. The sample rate of a
partition needs to be defined at one location only.
All  Modelica libraries designed so far for sampled systems, such as
Modelica.Blocks.Discrete or Modelica_LinearSystems2.Controller are becoming obsolete
and instead Modelica_Synchronous should be utilized.

Modelica_DeviceDrivers is a free library that allows accessing some external devices in
Modelica models. Such external devices are input devices, communication devices, shared
memory, analog-digital converters and else. This is achieved by using the Modelica external
C interface to call the appropriate C driver functions provided by the underlying operating
system. Currently Microsoft Windows and Linux are supported.

Vehiclelnterfaces is a free library providing standard interface definitions for automotive
subsystems and vehicle models to promote compatibility between the various automotive
libraries. See the documentation inside the library for details.

Optimization is a newer version of the Design optimization package in the Design library
(see above). It contains much more functionality and should be used for new applications
rather than the old one. For more information, see the manual for the library, which is
available using the command Help > Documentation.

1.6.2 Libraries that can be added

There are a number of libraries available, both free and commercial ones. For an overview
of them, please see http://www.modelica.org/libraries.

1.7

Help and information

1.7.1 Reaching compressed information

The What’s This? command/button etc

The What's This? command is used to display information about many things. The
command is activated in three different ways depending on where is should be used.
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In the Main Dymola window

ymola - Dynamic Modeling,
File Edit Simulation Plob  Animat

Tl
Packages

If more information should be obtained for e.g. a button or a symbol in the Dymola main
window, the easiest way is to click on the What's This? button and then click on the symbol
that is of interest. (The Help menu can also be used to activate this function.)

Please note that this button does not work in the Edit window.

In any dialog

Dymola

r [ [ o o~

In any dialog the What's This? is reachable using the ? in the upper corner of the window.
Click on the ? and then on the field of interest. Please note that sometimes the information
concerns (only) exactly what has been clicked on, sometimes the information concerns a
group of signals etc.

In any menu

When displaying any menu, help for a certain entry is available by resting the cursor on it
and then pressing Shift+F1.

Tooltips

By resting the cursor on any component or button a tooltip text is shown. For buttons it will
be the name of the button, for components it will be the name of the component + the path
to it.

The Search command/button

The search functionality can be reached either using the command File > Search or clicking
the Search button. See chapter “Developing a model”, section “Editor command reference -
Modeling mode”, sub-section “Main window: File menu”, command “File > Search” for
more information.
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1.7.2 Reaching more extensive information

The Info command/button

If any component is selected in the Edit window or in the package or component browser,
right-clicking will take up a context menu where the command Info is available. Inside a
dialog a button Info is available instead.

The Help menu

The Help menu can be used to display manuals and to go to the Dymola website. The help
menu also contains the license handling. The help menu is described in chapter “Developing
a model”, section “Editor command reference - Modeling mode”, sub-section “Main
window: Help menu”.

The Search command/button
The search functionality can be reached either using the command File > Search or clicking
the Search button. For reference, please see the corresponding section above.

The documentation layer of Edit window

This layer can be used to display more extensive information about packages and
components. Please see chapter “Developing a model”, section “Basic Model editing”, sub-
section “Documentation” for more information. This type of documentation can also be
exported to HTML files etc.

Books etc

Manuals are available for Dymola and a number of libraries used, as well as for the
Modelica language.
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1.8 Shortcuts

Shortcuts are available for a number of commands. The following is an overview of
available shortcuts. Please note that very common shortcuts, e.g. Ctrl+C for Copy and
Ctrl+V for Paste can be found in more locations than the one specified below.

File menu

Command Shortcut
New Model Ctrl+Shift+M
New Package Ctrl+Shift+P
Duplicate Class Ctrl+Shift+D
Open Ctrl+O

Load Ctrl+Shift+O
Save Ctrl+S

Save All Ctrl+Shift+S
Print Ctrl+P

Edit menu

Command Shortcut
Undo Ctrl+Z

Redo Ctrl+Y

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V
Delete Del
Duplicate Ctrl+D
Select All CtrlI+A

Find Ctrl+F
Replace Ctrl+H
GoTo Ctrl+G (text editor)
Align to grid Ctrl+G (diagram/icon layer
Manhattanize Ctrl+M
Rotate 90 Ctrl+R
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Rotate -90 Ctrl+Shift+R
Flip Horizontal H

Flip Vertical \Y

Check F8
Simulation menu

Command Shortcut
Translate F9
Translate FMU Ctrl+F9
Simulate F10
Continue F11

Stop F12
Animation menu

Command Shortcut
Run F3

Pause F4
Rewind F7
Reverse Shift+F6
Backstep F6

Step Forward F5
Forward Shift+F5
Dymola main window

Command Shortcut
Modeling Ctrl+F1
Simulation Ctrl+F2
Package browser

Command Shortcut
Move Up Ctrl+Up
Move Down Ctrl+Down
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Copy Path Ctrl+C
Diagram/icon layer

Command Shortcut
Fit to Window Ctrl+T
Modelica Text editor

Command Shortcut
Hide All Annotations Ctrl+1
Show Components and Connections Ctrl+2
Show Entire Text Ctrl+3
Highlight Syntax Ctrl+L
Reformat Selection Ctrl+Shift+L
Comment/Uncomment Selection Ctrl+K
Insert Function Call Ctrl+W
New Variable Ctrl+N
Edit Function Call Ctrl+U

Documentation layer: Info/revision editor + Command window

Command Shortcut
Bold Ctrl+B
Italic Ctrl+l
Underline Ctrl+U
Subscript Ctrl+=
Superscript Ctrl++
Default shortcuts for text editor in Qt

Action Shortcut
Move one line up Up
Move one line down Down
Move one character to the left Left
Move one character to the right Right
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Move one (viewpoint) page up

PageUp

Move one (viewpoint) page down PageDown
Move to the beginning of the text Home
Move to the end of the text End

Scroll the page horizontally Alt+Wheel
Zoom the text Ctrl+Wheel
Select all text Ctrl+A
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2 Index

A

animation, 17
animation window, 16
moving view, 17
pan view, 17
roll view, 17
rotate view, 17
scroll view, 17
tilt view, 17
zooming, 17
array
defining an array, 35

B

bound parameter, 68
browser
component, 8, 9
package, 8

C

class

documentation, 53

extend, 65
component

browser, 8. 9

library, 45

reference, 71

context menu, 8
creating a model, 47

D

DC motor, 37
declarations, 22
demo, 6

der(...) operator, 20
diagram layer, 17
documentation

editor. See editor - documentation

manuals, 86

of class, 53

of model, 53

of simulation, 73
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E

edit
documentation (of class), 55
documentation (of simulation), 73
edit window, 8
editor
documentation (of class), 55
documentation (of simulation), 73
examples
DC motor, 37
Furuta pendulum, 77
pendulum, 20
experiment setup. See simulation setup
extend, 65

F

fixed attribute of start value, 36
font

size, 23
Furuta pendulum, 77

H
highlight syntax, 22

|
info button, 11

L
library, 45

M

manhattanize, 52
matrix

defining a matrix, 35
mode

Modeling, 5

Simulation, 5
model

documentation, 53
Modelica Standard Library, 37
Modelica text layer

font size, 23
Modeling mode, 5

moving
animation view, 17
plot window, 58

P

package
browser, 8
hierarchy, 8
pan
animation view, 17
parameter
dialog, 10
propagation, 68
pendulum, 20
plot
window, 16
window options, 58
propagation of parameters, 68

R

robot demo, &
roll

animation view, 17
rotate

animation view, 17
run script, 16

S

script, 16, 75
scroll

animation view, 17
setting parameters, 29
shortcuts

list of shortcuts, 87
simulate model, 26
simulation, 15

documentation, 73

setup, 24
Simulation mode, 5
start values

fixed, 36

save to model, 67
starting Dymola, 5
syntax check, 22
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T

translate model, 26

w

warnings, 35, 60, 68, See also errors
window
animation, 16

diagram layer, 17
Dymola Main, 5
edit, 8

plot, 16

Z

zooming
animation window, 17
plot window, 58
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