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SOFTWARE LICENSE AGREEMENT 
Honeywell International Inc. 

165 Eileen Way, Syosset, NY  11791 
.

You should carefully read the following terms and conditions. If you do not 
consent to be bound by this License Agreement, you must promptly return 
the unopened package to the person from whom you purchased it within 
fifteen (15) days from date of purchase and your money will be refunded to 
you by that person.  If the person from whom you purchased this Software 
fails to refund your money, contact HONEYWELL immediately at the 
address shown above.  
Important: This Software is security related. Access should be limited to 
authorized individuals. 

1. GRANT OF LICENSE.  Subject to all terms and conditions hereof of Honeywell 
International Inc. acting through its Security group  ("HONEYWELL") does hereby 
grant to the purchaser (the "Licensee") upon payment in full of the published 
license fee, or other license fee agreed to in writing (the "License Fee") a 
nontransferable, non exclusive license to use the enclosed software ("Licensed 
Programs") provided herewith in Licensee's own business on a single computer 
for a term commencing on the date of payment in full of the License Fee and 
continuing in perpetuity unless terminated in accordance with the terms hereof. 

2. PROPRIETARY RIGHTS.  License hereby acknowledges that the Licensed 
Programs including the algorithms contained therein are proprietary to 
HONEYWELL.  Licensee shall not sell, transfer, disclose, display or otherwise 
make available any Licensed Programs or copies or portions thereof to any other 
entity.  Licensee agrees to secure and protect the Licensed Programs so as to 
maintain the proprietary rights of HONEYWELL therein, including appropriate 
instructions to and agreements with its employees. 

3. DOCUMENTATION.  The documentation supplied with the Licensed Programs 
is the copyright property of HONEYWELL.  Licensee shall not under any 
circumstances divulge or permit to be divulged such documentation to any other 
entity. 

4.  COPIES.  Licensee shall not copy in whole or in part the Licensed Programs 
or documentation provided however that Licensee shall be permitted to make one 
(1) copy of the Licensed Programs solely for backup purposes provided that all 
proprietary notices are reproduced thereon.  Any such copy shall remain part of 
the Licensed Programs and shall be subject to this agreement. 

5.  OBJECT CODE.  Licensee understands and acknowledges that the Licensed 
Programs consist of object code only and that HONEYWELL shall not supply 
source code versions of the Licensed Programs.  Licensee shall not create or 
attempt to create by de-compilation or otherwise, the source code for the 
Licensed Programs, or any part thereof. 

6.  SECURITY.  Licensee acknowledges that the Licensed Programs are security 
related and access to the Licensed Software should be limited to authorized 
individuals.  Licensee assumes full responsibility for use of the Licensed 
Programs whether by authorized or unauthorized individuals.  Licensee agrees 
that the License Fee has been set in reliance upon the limitation on liability 
contained herein and that such provisions are fair and not unconscionable. 

HONEYWELL does not represent that the Licensed Programs may not be 
compromised or circumvented, that the Licensed Programs will prevent any 
personal injury or property loss by burglary, robbery, fire or otherwise, or that the 
Licensed Programs will in all cases provide adequate warning or protection.   
Licensee understands that a properly installed and maintained alarm may only 
reduce the risk of burglary, robbery or fire without warning, but is not insurance or 
a guarantee that such will not occur or that there will be no personal injury or 
property loss as a result. 

7. DISCLAIMER OF WARRANTIES.  HONEYWELL does not warrant that the 
Licensed Programs will meet your requirements, that operation of the Licensed 
Programs will be uninterrupted or error-free, or that all Licensed Programs’ errors 
will be corrected.  The entire risk as to the quality and performance of the 
Licensed Programs is with you.  THE IMPLIED WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT ARE DISCLAIMED.  NO ORAL OR WRITTEN 
INFORMATION OR ADVICE GIVEN BY HONEYWELL, ITS EMPLOYEES, 
DISTRIBUTORS, DEALERS, OR AGENTS SHALL INCREASE THE SCOPE OF 
THE ABOVE WARRANTIES OR CREATE ANY NEW WARRANTIES.  SOME 
JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED 
WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU.  IN 
THAT EVENT, ANY IMPLIED WARRANTIES ARE LIMITED IN DURATION TO 
NINETY (90) DAYS FROM THE DATE OF DELIVERY OF THE LICENSED 
PROGRAMS.  This warranty gives you specific legal rights.  You may have other 
rights, which vary from state to state.   

8.  LIMITATION OF REMEDIES.  Licensee's exclusive remedy shall be either the 
replacement of any diskette or other media not meeting the limited warranty set 
forth above and which is returned to HONEYWELL with a copy of Licensee's paid 
invoice or, if HONEYWELL is unable to deliver a replacement that is free of 
defects, Licensee may terminate this Agreement by returning the Licensed 
Programs and thereupon the License Fee shall be refunded.  HONEYWELL shall 
have no obligation under this Agreement if the Licensed Programs are altered or 
improperly repaired or serviced by anyone other than HONEYWELL factory 
service.  For warranty service, return Licensed Programs transportation prepaid, 
to HONEYWELL Factory Service, 165 Eileen Way, Syosset, New York  11791. 

9.  LIMITATION OF LIABILITY.  REGARDLESS OF WHETHER ANY REMEDY 
SET FORTH IN THIS AGREEMENT FAILS OF ITS ESSENTIAL PURPOSE, IN 
NO EVENT WILL HONEYWELL OR ITS SUPPLIERS BE LIABLE TO YOU FOR 
ANY SPECIAL, CONSEQUENTIAL, INDIRECT OR SIMILAR DAMAGES, 
INCLUDING ANY LOST PROFITS OR LOST DATA ARISING OUT OF THE USE 
OR INABILITY TO USE THE LICENSED PROGRAMS OR ANY DATA 
SUPPLIED THEREWITH EVEN IF HONEYWELL OR ANYONE ELSE HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY 
CLAIM BY ANY OTHER PARTY.  THIS PROVISION IS INCLUDED FOR THE 
BENEFIT OF HONEYWELL AND ITS LOCAL REPRESENTATIVES, AND IS 
ENFORCEABLE BY EACH OF THEM. 

SOME JURISDICTIONS DO NOT ALLOW THE LIMITATION OR EXCLUSION 
OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE 
ABOVE LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU. 

IN NO CASE SHALL THE LIABILITY OF THE LICENSED PROGRAMS’ 
PROVIDERS OR OF HONEYWELL EXCEED THE PURCHASE PRICE PAID 
FOR THE PRODUCT. 

10.  REGISTRATION.  In order to qualify to receive notification of HONEYWELL 
updates to the Licensed Programs,  Licensee must complete and return a 
Registration Form to HONEYWELL within twenty (20) days from date of 
purchase.  Notwithstanding, HONEYWELL is under no obligation to release 
updates to the Licensed Programs. 

11.  TERMINATION.  Upon the breach or non-compliance with any term or 
provision of this agreement, HONEYWELL shall have the right to terminate the 
license granted hereby by written notice to Licensee.  Upon such termination 
Licensee shall immediately turn over to HONEYWELL all copies of the Licensed 
Programs and any documentation supplied in connection therewith.  Such 
remedy shall be in addition to and cumulative to any other remedies 
HONEYWELL may have at law or in equity with respect to such breach or non-
compliance. 

12.  GENERAL.  This agreement is the complete and exclusive statement of the 
understanding of the parties hereto with respect to the transaction contemplated 
hereby and supersedes any and all prior proposals, understandings and 
agreements.  This Agreement may not be modified or altered except by a written 
instrument signed by Licensee and an authorized representative of 
HONEYWELL, its rights, duties or obligations under this Agreement to any person 
or entity, in whole or in part.  If any provision of this Agreement is invalid under 
any applicable stature or rule of law it is to that shall be governed by the laws of 
the State of New York and the sole venue for suit shall be in an appropriate state 
or federal court located in the State and City of New York.  The failure of 
HONEYWELL to exercise in any respect any rights provided for herein shall not 
be deemed a waiver of such right or any further Agreement may be brought more 
than two (2) years after the date such cause of action shall have arisen.  
HONEYWELL shall have the right to collect from Licensee any expensed incurred 
including attorneys' fees in enforcing its right under this agreement.  
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CHAPTER 1: 
INTRODUCTION 

1.1 OVERVIEW OF MAXMON 

MaxMon is a utility that provides user interface to monitor and communicate with the 
MAXPRO-Net Server.  MaxMon can be installed on a local or remote networked laptop or 
desktop computer to connect to the MAXPRO-Net Server.  MaxMon utility is designed to 
control all menu options and view all log data together in multiple windows. 

Using MaxMon, you will be able to view the initial configuration data from MAXPRO-Net 
Server as configured in SetMax.  You can monitor log data and also view the status of 
video inputs/outputs devices, alarms, keyboards, and monitors.  

1.2 INSTALLING THE MAXMON UTILITY 

1. Download the MAXPRO-Net software package to your computer. 

2. Select and double-click the Setup.exe from the MAXPRO-Net Folder to start the 
installation. The Choose Setup Language dialog appears. 

 

3. Select a language for the installation program. 

4. Click OK. The Question dialog appears. 

 

5. Click Yes to proceed with the installation. If you click Yes, skip steps 6 to 19 and 
proceed onto step 20 to continue with the installation. Click No, if you want to stop 
the installation and change the installation program language. 

6. If you click No in the Question dialog, the MAXPRO-Net InstallShield Wizard dialog 
appears. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

7. Click OK. The InstallShield Wizard Complete screen appears. 

 

8. Click Finish and then change the operating system language. 

Changing the operating system language 

9. Choose Start  Settings  Control Panel. 

10. Double-click Regional and Language Options. The Regional and Language 
Options dialog appears. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

11. In the Select an item to match its preferences, or click Customize to choose 
your own formats: box, select a language for the operating system. 

12. Under Location, select the location where the MAXPRO-Net is being installed. 

13. Click Apply. 

14. Click Advanced tab. The Advanced Settings for Regional and Language Options 
appears. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

15. In the Select a language to match the language version of the non-Unicode 
programs you want to use: box, select a language for the non-Unicode programs. 

16. Under Code page conversion tables, select all the items. 

17. Click Apply. 

18. Click OK. 

19. Select and double-click the Setup.exe, in the MAXPRO-Net Folder to re-start the 
installation. Refer steps 2 to 4 in this section. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

20. If you click Yes in the Question dialog, the Welcome screen appears. 

 

21. Click Next. The Select Features screen appears. 

 

22. Select the features to install. 

Note: If MAXPRO-Net Server is selected, the setup installs Microsoft SQL Server Desktop 
Engine on your computer. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

23. Click Browse. The Choose Folder dialog appears. 

24. Select a folder where the features are to be installed. 

25. Click OK to close the Choose Folder dialog. 

26. Click Next on the Select Features screen. If you have selected MAXPRO-Net Server 
on the Select Features screen, the Choose Destination Location screen appears. 

 

27. Click Browse. The Choose Folder dialog appears. 

28. Select a folder where Microsoft SQL Desktop Engine is to be installed. 

29. Click OK to close the Choose Folder dialog. 

30. Click Next on the Choose Destination Location screen. The Database Server Login 
screen appears. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

31. In the Login ID box, type the SQL User Login ID. 

32. In the Password box, type the SQL User Password. 

33. Click Next. The User Information screen appears. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

34. In the Select Language box, select the language to be used for MAXPRO-Net. 

Note: Refer to MAXPRO-Net Translation Editor User Manual.pdf (Revision 1.0), having 
the part number 900.0675, if you want to add support for other languages in 
MAXPRO-Net. 

35. Click Next. The Start Copying Files screen appears. 

 

36. Click Next. The Microsoft SQL Server Desktop Engine installation dialog appears. 

 

Note: The computer restarts after Microsoft SQL Sever Desktop Engine is installed. 

The SQL Server Network Utility screen appears after the Microsoft SQL Server 
Desktop Engine installation is completed. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

37. In the Disabled protocols box: 

a. Select Named Pipes and click Enable. 

b. Select TCP/IP and click Enable. 

38. Click OK to close the SQL Server Network Utility screen. The SQL Server Network 
Utility dialog appears. 

 

39. Click OK. The computer restarts and the Choose Setup Language dialog appears. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

40. Select a language for the installation program. 

41. Click OK. The Question dialog appears. 

 

42. Click Yes. The Start Copying Files screen appears. 

 

The Install Shield Wizard Complete screen appears after the installation is 
completed. 
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1.2 INSTALLING THE MAXMON UTILITY, CONTINUED 

 

43. Click Finish to complete the installation. 
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1.3 STARTING THE MAXMON UTILITY 

You can start MaxMon using the Start -> Programs -> Honeywell Video Systems 
menu or using the MaxMon icon on the desktop. The MaxMon main window appears 
with the default MAXPRO-Net Server connected as shown in the following illustration. To 
connect to other MAXPRO-Net Server, select File -> Connect from the main menu. 

 

The status bar shows the server address to which MaxMon is connected and the 
product license information.  

 

NOTE:  This window appears only if the MAXPRO-Net 
Server is running on the same machine. If MAXPRO-Net 
Server is not running in the local machine, MaxMon fails 
to connect to the server and shows the message “Could 
not connect to MAXPRO-Net Server <IPAddress>.” 
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CHAPTER 2: 
GETTING STARTED 

2.1 OVERVIEW 

MAXPRO-Net’s Ethernet functionality allows users from different locations connect to 
MAXPRO-Net Server at the customer site and monitor the configuration.  

Using the system IP login, you can gain access to SetMax and configure MAXPRO-Net 
Server. If you want to monitor the server, you can do so from the current location itself 
using this remote diagnostic tool.   

MaxMon supports the following functionalities: 

• Dynamic live updates 

• Keyboard emulation 

• Status information  

• Alarms 

• Input/Output control 

• Camera test mode 

• Log messages 

 

After you start MaxMon, you need to connect to the MAXPRO-Net Server to view the 
device status.  This section includes: 

• Setting the Preferences 

• Connecting to the Max Server 

• About Help Commands 
 

2.2 SETTING THE PREFERENCES 

To define the communication preferences for MaxMon, perform the following steps.  

1. Select File -> Preferences from the main menu to define the preferences. The following 
dialog appears with the default settings shown: 
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2.2 SETTING THE PREFERENCES, CONTINUED 

 

2. On the Communications tab, you can view the communication details as described in the 
upcoming steps. 

3. The fields under Server Default provides the following information: 

• Server IP/Name – This indicates the MAXPRO-Net Server IP address. 

• Server Port – This refers to the port used for server communication. This is a 
read-only field. 

4. The fields under DB Service Default provides the following information: 

• Service IP/Name – This specifies the IP address of the DB server. 

• Service Port – This refers to the port used for DB communication. 

5. The field under Log Configuration provides the following information: 

• Ethernet Log – Enable this option if you want to receive all Ethernet related 
messages. 

6. The fields under Mail Configuration provides the following information: 

• Email Host – Specify the e-mail server name for mailing the log messages. 

• Port – Specify the port address used for e-mail communication. 

7. Click OK to close the Preferences dialog. 
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2.3 CONNECTING TO THE MAXPRO-NET SERVER  

To connect to the server that is running at the remote location, perform the following 
settings: 

1. Select Start -> Programs -> Honeywell Video Systems -> MaxMon. The MaxMon main 
window appears. 

2. Select File -> Connect from the main menu. The following MAXPRO-Net Server 
Configuration dialog appears: 

 

Note: By default, MaxMon tries to connect to the MAXPRO-Net Server configured in 
preferences section. If you want to connect to the different server, you need to 
disconnect and select File->Connect menu or click on Connect toolbar button. 
The last used Server IP/Name will be updated into the preference. 

3. The Connect dialog shows Server IP and Port number as defined in the Preferences 
dialog. 

If the preferences are not configured, MaxMon takes the local system’s IP address 
and port number. 

4. Click OK to connect to the MAXPRO-Net Server. The status “Connected” is shown in the 
status bar along with the IP address of the server to which the MaxMon is connected.  

You can connect multiple instances of MaxMon services to a single MAXPRO-Net 
Server. 
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2.4 ABOUT HELP COMMANDS 

MaxMon provides a list of commands used to select and control different 
monitors/cameras, to operate scan sequences, and other functionalities. These 
commands are executed through function keys. 

To view help commands, select Help -> Commands from the main menu.  The 
commands are listed in notepad, as shown in the following illustration: 

 

 

To view camera setup commands, select Help -> Camera Setup Commands from the 
main menu.  The commands are listed in the notepad, as shown in the following 
illustration: 
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2.4 ABOUT HELP COMMANDS, CONTINUED 
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Notes:
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CHAPTER 3: 
FUNCTIONS AND BASIC OPERATIONS 

3.1 OVERVIEW 

MaxMon is the tool that allows user to view the status of a server to which it is 
connected. Also, it provides the details of devices that are connected as inputs and 
outputs. 

This section includes, 

• Viewing the Log Data 

• Viewing the Status of Video Inputs 

• Viewing the Status of Video Outputs 

• Viewing the Status of Alarm Inputs 

• Viewing the Status Information 

• Porting the Log Messages 

• Copying the Log Messages 
 

3.2 VIEWING THE LOG DATA 

MaxMon utility allows the user to connect to MAXPRO-Net sever and view the log 
messages of various devices.  

To view different log messages, perform the following steps.   

 

1. After connecting to the MAXPRO-Net Server, you can view log messages using Log menu 
of the main window. 

2. Select a log type from the Log menu of MaxMon window or use the toolbar icon to view 
single log window at a time. The selected log data appears. 

3. Select Log -> Open all log windows from the main menu of MaxMon window or use the 
toolbar icon to view all the logs messages in a single screen. Multiple log windows are 
displayed, as shown in the following illustration: 
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3.2 VIEWING THE LOG DATA, CONTINUED 

 

 

Note: If you are in different log view, select Window -> Tile from the main menu to 
arrange log windows, as shown in the above illustration. 

4. You can select any log type (such as RX Data, TX Data, Execution Macros, Macro Trails, 
Errorlog Messages, Printer Messages, Video Switch Selection, and Video Source Control) 
from the Log menu and view the messages in the respective log window.   

Also, you can use shortcut icons from the tool bar. 

5. Select Window -> Cascade from the main menu to view different log windows in the 
cascaded form, as shown in the following illustration: 
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3.2 VIEWING THE LOG DATA, CONTINUED 

 

 

6. Select Window -> Close to close the active log window. 

7. Select Window -> Close All to close all the log windows. 

8. Select Window -> Clear All to clear all the log messages displayed in selected window. 

9. Select Log -> Freeze all log windows or use the tool bar icon to freeze log messages of 
the selected window. 

10. Select Log -> Resume all log windows or use the tool bar icon to resume log messages 
of the selected window. 
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3.3 VIEWING THE STATUS OF VIDEO INPUTS  

The Video Inputs dialog displays all the information related to input devices such as 
cameras, VCRs, standard devices, and smart devices.  

To view the status of video inputs, perform the following steps. 

1. Select View -> Video Inputs from the main window. The following dialog appears with the 
Camera tab selected as default: 

 

 

The Video Input dialog displays all possible video inputs that are connected to the 
MAXPRO-Net Server along with the device status. 

2. The device (Camera, Recorders, Standard Devices, and Smart Devices) tabs display the 
following information: 

• Ref No – This is a reference number of video input device.  

• Device Number – This refers to physical and logical representation of video 
input for the device identification. 

• Description – A brief description about the video input device that is being 
connected.  

• Type – This refers to the type of device connected. This option is available only 
for the Camera input. The type of the camera input can be Fixed or PTZ. 

• Lock/Unlock – This shows the camera state as lock or unlock.  

• Status – This indicates the status of video input whether the device is currently 
enabled or disabled. 

3. Select the Camera tab to view the status of camera inputs. 
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3.3 VIEWING THE STATUS OF VIDEO INPUTS, CONTINUED 

4. On the Camera tab, select a camera and press the right mouse button.  From the right- 
click context menus, 

• Select Lock or Unlock to change the lock state of a camera appropriately. 

• Select Enable or Disable to change the state. 

• Select Refresh to get the updated status after the live update is made using 
SetMax. 

5. Similarly, select other tabs like Recorders, Standard Devices, and Smart Devices to view 
or modify the device status. 

6. To find any information in Video Inputs dialog easily, select Edit -> Find from the main 
window or use Ctrl+F keys. The following dialog appears: 
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3.4 VIEWING THE STATUS OF VIDEO OUTPUTS  

The Video Outputs dialog displays all the information related to output devices such as 
monitors, VCRs, standard devices, and smart devices.  

To view the status of video outputs, perform the following steps. 

1. Select View -> Video Outputs from the main window. The following dialog appears with 
the Monitors tab selected as default: 

 

The Video Output displays all possible video outputs that are connected. 

2. The device (Monitors, Recorders, Standard Devices, and Smart Devices) tabs display the 
following information: 

• Ref No – This is a reference number of video output device.  

• Device Number – This refers to physical and logical representation of video 
output for the device identification. 

• Description – A brief description about the video output device that is being 
connected.  

• Lock/Unlock – This shows the state of a monitor as lock or unlock. 

3. Select the Monitors tab to view the status of monitor outputs. 

4. On the Monitors tab, select a monitor and press the right mouse button.  From the right- 
click context menus, 

• Select Lock or Unlock to change the lock state of a monitor appropriately. 

5. Select Refresh to view the updated status. 

6. Similarly, select the other tabs like Recorders, Standard Devices, and Smart Devices to 
view or modify the device status. 

7. To find any information in Video Outputs dialog easily, select Edit -> Find from the main 
window or use Ctrl+F keys. 
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3.5 VIEWING THE STATUS OF ALARM INPUTS 

Alarm Inputs are external inputs to the CCTV System. The CCTV equipment monitors 
these inputs continuously. When there is any change in the alarm state, the system 
operators are notified on this shift and the selection of camera or VCR input takes place 
accordingly.  

1. Select View -> Alarm Inputs from the main window. The following Alarm Input dialog 
appears: 

 

2. The Alarm Input tab displays the following details: 

• Alarm ID – This refers to the alarm identification number. 

• Description – This shows the description of an alarm input. 

• State – This shows whether the alarm state is enabled or disabled.  

• Configuration – This shows the status of the configuration. 

3. To find any information in Alarm Inputs dialog easily, select Edit -> Find from the main 
window or use Ctrl+F keys. 
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3.6 VIEWING THE STATUS INFORMATION 

The Status Information dialog provides the details about input devices that are 
connected to the MAXPRO-Net system, keyboards and their operators, cameras 
assigned to each monitor/VCR, and the configuration summary of the devices 
connected. 

To view the status, perform the following steps. 

1. Select View -> Status Information from the main window. The following dialog appears 
with the Keyboard Locations tab selected as default: 

 

2. The Keyboard Locations tab shows the information such as identify number of the CCTV 
keyboard, description, and operators who are operating the keyboard. 

3. Select the Monitors Channels tab to view the status of monitors and the channels, as 
shown in the following dialog: 
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3.6 VIEWING THE STATUS INFORMATION, CONTINUED 

The tab includes the list of monitors, keyboards corresponding to these monitors, 
cameras from where the input is received, and the channel information. 

4. Select the VCR Channels tab to view the list of VCR channels and source channels. 

 

5. Select the Other Channels tab to view other channels and their source information. 
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3.6 VIEWING THE STATUS INFORMATION, CONTINUED 

6. Select the Configuration Summary tab to view the details (currently loaded data files) of 
the devices that are connected.  

 

This dialog shows all the device details that are connected to the server. 

7. To find any information in Status Information dialog easily, select Edit -> Find from the 
main window or use Ctrl+F keys. 
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3.7 PORTING THE LOG MESSAGES 

You can send log messages through e-mail, which will be saved in the .htm text format. 

To port/send log messages through e-mail, perform the following steps. 

1. Ensure that the required log window is activated.  

2. From the MaxMon main window, select File -> Send To -> Mail Recipient menu. The 
following dialog appears: 

 

The selected log file is attached in the .htm format, as shown in the above dialog. 

Note:The two options (Mail Recipient and File) under File -> Send To menu will be 
enabled only if you have any log window opened.  

3. Enter the receiver mail ID in To field to whom you want to send the log report. 

4. Use CC field to copy mails to more users, if applicable. You can enter multiple e-mail IDs 
separated by semicolon. 

5. You can write any e-mail content in the text box provided after the Attachment field. 

6. Click Send to send the e-mail along with the attachment to the targeted user. 
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3.7 PORTING THE LOG MESSAGES, CONTINUED 

7. To save log files on the local system directly, select File -> Send To -> File menu. The 
following dialog appears: 

 

The File name field indicates the name of the log that is being selected in the MaxMon 
window. 

The Save as type field shows the default format in which the log files will be saved. 

8. Select the folder where you want to save the log file and click Save. The file will get saved 
in the selected location. 

For example, the final log report appears as follows: 
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3.8 COPYING THE LOG MESSAGES 

You can copy log messages using the Copy menu. 

To copy log messages to the desired location, perform the following steps. 

1. Ensure that the required log window is activated.  

2. From the log window, select the message and then choose Edit -> Copy menu. Use 
Shift+Arrow key to select multiple messages or Ctrl+A key to select all the messages from 
the selected log window.  

The selected messages are saved in the clipboard and you can paste it in a 
notepad. 

3. You can also copy the log messages using the right-click context menu options, as shown 
in the following dialog: 

 

 

4. Select Clear from the right-click context menus to clear all the log messages from the 
selected window. 

5. Select Freeze from the right-click context menus to freeze the log messages in the 
selected window. 
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Notes: 
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CHAPTER 4: 
ABOUT KEYBOARD EMULATION 

4.1 OVERVIEW 

Keyboard Emulation is a MAXPRO-Net equivalent of system keyboard. You need an 
operator login to use this keyboard. 

The users who have login access to keyboard emulation can connect to different 
monitors and different cameras for the status. Also, it allows you to do the PTZ 
operations of the selected camera and get status of the location that the camera is 
focused.  

This section includes, 

• Signing On to the Keyboard Emulation 

• Signing Off from the Keyboard Emulation 

• Using the Camera Setup Command 

• Using the Auto Device Numbering 

• Saving the New Default POWER-ON Settings 

4.2 SIGNING ON TO THE KEYBOARD EMULATION 

The operators use the Keyboard emulation feature of MaxMon to connect to the 
MAXPRO-Net Server and also to a particular camera for the updated status. You need to 
have the user login to utilize this function. 

To use the keyboard utility to send commands/receive data, perform the following steps. 

1. Select Tools -> Keyboard Emulation from the main menu. The following Sign On dialog 
appears: 

 

2. Select the operator name using the Operator Name drop-down list. 

3. Enter four digits Personal Identification Number in the Pin Number box. 



 

Rev. B 34 HMXMU001144 
  31-Mar-06 

4.2 SIGNING ON TO THE KEYBOARD EMULATION, CONTINUED 

4. Click OK to activate the keyboard. The keyboard window appears at the bottom of the 
main window, as shown below: 

 

5. You can send commands using the Keyboard Emulation window. 

6. Enter “m1” in the keyboard to select Monitor 1 of a server.  

 

The task bar shows the details of monitor that is being selected. 
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4.2 SIGNING ON TO THE KEYBOARD EMULATION, CONTINUED 

7. Enter “c1” in the keyboard to switch Camera 1 to Monitor 1. 

8. Similarly, you can select to different monitors or cameras using the commands m1, m2, 
m3….  and c1, c2, c3… and so on, appropriately.  

The camera can be controlled using the following PTZ (Pan, Tilt, and Zoom) 
commands: 

• Panning can be done by using left and right arrow keys on the system 
keyboard. 

• Tilting can be done by using up and down arrow keys on the system keyboard. 

• Zooming-in can be done by using the Ctrl+up arrow keys on the system 
keyboard. 

• Zooming-out can be done by using the Ctrl+down arrow keys on the system 
keyboard. 

 

4.3 SIGNING OFF FROM THE KEYBOARD EMULATION 

To sign off from the keyboard emulation, select File – Sign Off. The confirmation dialog 
appears to confirm signing off from MaxMon. Click Yes to close the keyboard window on 
the MaxMon utility.   

4.4 USING THE CAMERA SETUP COMMAND 

Camera Setup Command option allows you to use the function keys on the keyboard 
and connect to a particular camera. Using these modes, you can change the camera 
settings/mode and get the status from different points/areas. This option is enabled only 
when the keyboard is activated. 

To use the Camera Setup Commands, perform the following steps. 

1. After you activate the keyboard, select Tools -> Camera Setup Command. The Camera 
Setup Mode appears at the bottom of the window, as shown below: 

 

This option is enabled only when the Keyboard is activated. 

2. Use the function keys (F1, F2, F3, and so on) of Camera Setup Mode to view the status. 
The function keys on the keyboard are mapped to different modes of a camera. 
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4.5 USING THE AUTO DEVICE NUMBERING 

Select Tools -> Auto Device Numbering to enable the device numbering. When 
enabled, the device (Camera or Monitor) number will be displayed in the keyboard along 
with the description. 

 

4.6 SAVING THE NEW DEFAULT POWER-ON SETTINGS  

To save any changes made to the configuration through MaxMon, perform the following 
steps.   

1. To save any changes made to the configuration in MaxMon, select Tools -> Save the 
New Default POWER-ON Settings. The following confirmation dialog appears to confirm 
saving the current data in Max files: 

 

Note: 

You can save the configuration changes only if the Setmax is not connected to 
MAXPRO-Net Server. 

2. Click Yes to save the data in Max files. The following message appears: 
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CHAPTER 5: 
DISCONNECTING MAXMON UTILITY 

5.1 DISCONNECTING MAXMON FROM THE MAXPRO-NET 

MaxMon utility can be stopped when it is not in use. 

To disconnect MaxMon from the MAXPRO-Net Server, perform the following steps.  

1. On the MaxMon window, select File -> Disconnect from the main menu or click the 
Disconnect icon on the toolbar. The following message appears: 

 

 

2. Click Yes to disconnect the MaxMon utility from MAXPRO-Net. 
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