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1 Introduction

1.1 What is EPAS Desktop?

PolyLogic’s EPAS Desktop Software enables the operating parameters of the DC
Electronics EPAS Lite ECU to be viewed in real time. EPAS Desktop also provides
facilities for configuring and re-programming the EPAS Lite ECU via the serial port of the
host PC.

With PolyLogic’s EPAS Desktop Software you can:

e View real-time data for:
= Battery voltage
Current consumption
Applied steering torque
Steering motor duty
Control switch setting
e Read ECU serial number, firmware version and system type
e Configure the EPAS Lite ECU via the serial port of the host PC
e Update the firmware of the EPAS Lite ECU via the serial port of the host PC

1.2 About This Manual

This User Manual is intended to complement the help files built into the EPAS Desktop
application. The chapters are presented in an order intended to help new users
understand the program as quickly as possible. Be aware, however, that this manual and
the program’s help file assume that you are comfortable using the Microsoft Windows
98/2000/Me/NT4/XP operating system. If you are new to Windows you may find the
Windows Online Help file useful. To access Microsoft Windows Help choose Help from
the start menu on your Windows desktop.
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1.3 Typographical Conventions
Please be aware of the following typographical conventions when reading this manual:

e Menu items that you are instructed to choose appear with an arrow (=) symbol
separating each menu level. For example, if you if you are instructed to choose
the Parameters command in the Setup menu it will appear as Setup »
Parameters.

e Where a button or other control needs to be clicked the name of the button or
control will be shown in bold text.

1.4 Getting Technical Support
For technical support with EPAS Desktop please contact:

support@polylogic.co.uk

In addition, there are pages dedicated to support issues with PolyLogic’s products on the
PolyLogic web site.

The table below lists the ways to contact PolyLogic:

Contact Method Address or Number
Website: www.polylogic.co.uk
Email: support@polylogic.co.uk
Telephone: +44 (0) 5601 140733
Fax: +44 (0) 5601 140733
Mail: PolyLogic Limited

47 Old Forge Drive
West Haddon
Northampton

NN6 7ET

UK
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2 Getting Started

EPAS Desktop is supplied on a CD-ROM which is used to install the program onto the hard
disk of your computer.

2.1 System Requirements

Before attempting to install EPAS Desktop, make sure that your computer meets the
following minimum system requirements shown in the table below:

Component Requirement

Processor Pentium class processor or equivalent
Operating System | Microsoft Windows 98/Me/NT4/2000/XP
Hard Disk Space 10Mb

System Memory 32Mb (64Mb recommended)

Other Drives CD-ROM

Monitor/Display Super VGA (800 x 600) or higher resolution with 256 colours
Serial Port One serial port or USB port with USB-serial adapter
Pointing Device Microsoft Mouse or compatible pointing device

2.2 Installing EPAS Desktop

Before you can run EPAS Desktop you must install it on the hard disk of your computer.

Follow these steps to install the software:

e Switch on your computer and log on in the normal way.

Insert the EPAS Desktop CD into the CD drive. The EPAS Desktop Setup Wizard
dialog will appear automatically.

Click Next.

Choose the installation folder for the software and click Next.

Click Next again to complete the installation.

Click Close once the installation is complete.

The installation process places shortcuts to EPAS Desktop on the computer’s
desktop and Start menu.

NOTE: If the EPAS Desktop installation process does not start automatically, you can
start it manually by using My Computer or Windows Explorer to navigate to the
contents of the CD and then double-clicking the file SETUP.EXE.
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2.3 Uninstalling EPAS Desktop
EPAS Desktop can be removed from your computer by selecting the Add and Remove

Programs option within Windows Control Panel. Find EPAS Desktop in the list of
installed software, select it, and then click Remove.

This will remove the EPAS Desktop software together with its shortcuts and configuration
entries.

2.4 Using Online Help

Once EPAS Desktop is running you can view items in the Help menu at any time. To
display the online Help file press choose Help » Help Topics from the main menu.

2.5 Starting EPAS Desktop

Start EPAS Desktop by either double clicking the shortcut on the computer’s desktop or
by selecting Programs = PolyLogic » EPAS Desktop from the Start button on the
desktop’s toolbar.

2.6 Exiting EPAS Desktop
You can exit EPAS Desktop using any of the following methods:
e Choose File » Exit from the main menu, or
e Click the close button [XI in the upper right corner of the title bar, or

e Press the key combination Alt + F4.
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3 Getting to Know EPAS Desktop

This chapter provides an overview of the EPAS Desktop user interface. It describes the
main window, menu, and other important features. To help you better understand the
program and become familiar with its features, please review this chapter thoroughly
prior to connecting a PC to an EPAS Lite ECU.

3.1 Tour of the EPAS Desktop User Interface

When you start EPAS Desktop the main program window appears as shown below.

@ EPAS Desktop
File Setup Help
~WYoltage - ' Current

00V  0.0A

— Torque — Motor Duty
0 0%

 Switch Position
0%

Connect sconnect I

Figure 1 - EPAS Desktop Main Screen (Inactive)

At the top of the main program window a menu provides access to a majority of the
program’s features.

3.2 Main Menu

@ EPAS Desktop
File Setup Help

Figure 2 -EPAS Desktop Main Menu
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The Main Menu (Figure 2), which is directly below the title bar, displays the menu
headings. Click a menu heading to open the menu and choose a command.

Use either of the following methods to choose a menu command:
e Open the menu and click the command, or

e Open the menu, use the Up arrow or Down arrow key to highlight a command, and
then press <Enter>.

In addition, each menu may be opened by pressing the <Alt> key and then pressing the
key associated with the required menu. Section 3.3 lists all the available menu
commands.

3.3 Command Reference

The following commands are available:

Menu Command Keyboard Shortcut | Section
File Menu Alt + F
Exit Alt + F, X 2.6
Setup Menu Alt +S
Serial Port Alt +5, S 5.1
Firmware Alt +S, F 5.2
Parameters Alt +S, P 5.3
Help Menu Alt + H
Help Topics Alt +H, H
About Alt + H, A
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4 Viewing EPAS Lite ECU Status

This chapter describes how EPAS Desktop allows you to connect to an EPAS Lite ECU and
view its status.

4.1 Connecting to EPAS Lite ECU

The status of an active EPAS Lite ECU can be viewed in the following way:

1. Connect the serial port connector on the PC to the serial port connector on the
EPAS Lite ECU using a suitable cable.

2. Click the Connect button on the main screen.

3. The current status of the EPAS Lite ECU will be displayed in the various panels on
the main screen and these will be updated every 250ms.

@» EPAS Desktop

File Setup Help

~ Woltage - | Current -
13.2V 2.4A
Torque  Motor Duty

-61 -33%
— Switch Position
S/N: D00D-DEFD-5829

Code: V1.0 MS_Race 4 O %

Disconnect l

Figure 3 - EPAS Desktop Main Screen (Active)
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4.2 Main Screen Displays

The panels on the main screen display the following information:

Iltem Description

Voltage Displays instantaneous EPAS Lite ECU supply voltage in Volt.
Resolution is 0.1Volt and maximum reading is 25.5V.

Current Displays instantaneous EPAS Lite ECU current consumption in
Amp. Resolution is 0.5Amp and maximum reading is 25.5A.

Torque Displays instantaneous applied steering torque in bits.
Resolution is 1bit and maximum reading is 255 bits. This value
is positive when the applied steering torque is in the clockwise
direction.

Motor Duty Displays instantaneous motor duty in %. Resolution is 1%. A
value of 100% indicates that the motor is operating at full
power.

Switch Position | Displays instantaneous steering control position in %. Resolution
is 1%. A value of indicates that the control is at its maximum
position, i.e. fully clockwise.

S/N Unique 64-bit serial number of EPAS Lite ECU.

Code Firmware version and system type.

4.3 Disconnecting from EPAS Lite ECU

To stop viewing the status of an active EPAS Lite ECU click the Disconnect button on the
main screen.

NOTE: It is important to disconnect in this way, rather than just closing the EPAS
Desktop application, as otherwise the connection to the EPAS Lite ECU will remain
active and any attempt to reconnect will fail unless the EPAS Lite ECU is reset first.
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5 Configuration

EPAS Desktop provides facilities for the EPAS Lite ECU to be configured via the serial
port.

This chapter describes how this configuration is carried out.

NOTE: Configuration changes can only be made whilst EPAS Desktop is not actively
communicating with an EPAS Lite ECU. Disconnect any active connection, by clicking the
Disconnect button on the main screen, before attempting to make changes to the
configuration.

5.1 Serial Port

To alter the serial port that EPAS Desktop uses to communicate with the EPAS Lite ECU
do the following:

1. Choose Setup » Serial Port from the main menu. The Setup Serial Port Dialog
(Figure 4) appears.

Setup Serial Port

Figure 4 - Setup Serial Port Dialog
2. Select the new serial port from the list.

3. Click OK to update the serial port or Cancel to leave it unchanged.

5.2 Firmware
The firmware of the EPAS Lite ECU can be re-programmed via the serial port.
The Setup » Firmware option from the main menu has been provided to enable this.

IMPORTANT: Do not attempt to upload a hex file to the EPAS Lite ECU without first
contacting DC Electronics and obtaining the correct file for your system and application.

5.3 Parameters

The operating parameters of the EPAS Lite ECU can be viewed and altered via the serial
port in the following way:
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1. Select the Setup » Parameters option from the main menu. The Setup
Parameters dialog (Figure 5) is displayed.

@» Setup Parameters §|
Torque deadband (bits) |4—:|
Torque zera [bits] 128 =
Steering control range (bits) l@
Curent limit [x100mg)] 200 -

o]

Figure 5 - Setup Parameters Dialog

2. The Setup Parameters dialog displays the current values of all the user
configurable parameters of the EPAS Lite ECU.

3. Make any changes that are required and click Apply or Cancel to leave the
parameters unchanged.

WARNING: Care must be observed when changing EPAS Lite ECU parameters. Using the
wrong values could damage both the EPAS Lite ECU and the steering unit.
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6 Troubleshooting

Problem
Cause
Action

Cause
Action

Cause
Action

Cause
Action

Cause
Action

Issue 1.10

I can’t connect to the EPAS Lite ECU or read/write its parameters.
The EPAS Lite ECU is not powered up.
Turn on the Master switch, and the ignition switch (if necessary).

The serial lead is not connected.

Connect the EPAS Lite ECU to the serial port of the host computer
using the correct cable and try again.

The lead is not making a good connection.

Ensure both connectors are fully home and that the lead is not
damaged in any way.

The serial port is not configured correctly.

Choose Setup » Serial Port from the main menu and select the correct
serial port. If you are using a USB to serial adapter use Windows Device
Manager to determine the COM port number.

A previous connection was not disconnected correctly.
Reset EPAS Lite ECU and try again.
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7 Error Messages

One of the following error messages will be displayed whilst trying to connect to an EPAS
Lite ECU using EPAS Desktop when the EPAS Lite ECU fault light is lit:

Message Error 100 : Low battery voltage

Meaning The battery supply voltage has fallen below a preset threshold and the
EPAS Lite ECU cannot continue to operate safely.

Message Error 101 : Torque sensor not connected

Meaning The torque sensor is not responding either because it is faulty or
because it is not connected correctly.

Message Error 102 : Torque sensor fault

Meaning The reading from the torque sensor is incorrect either because it is
faulty or because it is not connected correctly.

Message Error 103 : Current sensor fault

Meaning The reading from the internal current sensor is incorrect.

Message Error 104 : Motor power fault

Meaning The power drawn when the motor power relay is energised is higher

than expected.

Message Error 105 : Motor not connected

Meaning The power steering motor is not drawing enough current indicating
that it may not be connected.

Message Error 106 : Motor is shorted or stalled

Meaning The power steering motor is drawing too much current indicating that
it is either shorted or stalled.

Message Error 107 : Clutch not connected
Meaning The motor clutch is not drawing enough current when energised
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indicating that it may not be connected.

Message Error 108 : Clutch is shorted or stalled

Meaning The motor clutch is drawing too much current when energised
indicating that it is either shorted or stalled.

Message Error 109 : Over current condition detected
Meaning The internal current limit has been exceeded.
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