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9.2 Configuring and compiling Kernel and Windows CE 6.0 bootloader

Because Windows CE6 kernel configuration is more complex, vulnerable configuration
does not compile result, we all know Windows CE platform compilation use a long time, we
deliberately use two kernel project samples for reference, the user according to the following
steps can be compiled, and CD-ROM images\wince6.0 directory corresponding compiled

kernel image file.

Be noted that BSP compile kernel can't larger than the 30MB, Tencent QQ have
relatively large, so we have two sample : mini2440 and mini2440-with-QQ, the former contains
some common configuration options, which remove the SQL-related components, add the
Tencent QQ, the other part is most of the same, the user can compare. We recommend users to
use mini2440 (This is referred to the default kernel example), install the development board;

Tencent QQ is just the common test.

9.2.1 Introduction to the default Kernel

The default kernel configuration options the user some common features, along the

following lines:

9.2.2 Compile default Kernel sample project

Now, we start to compile just installed VS2005 mini2440 BSP, V52005, when you first

start to take note of some issues, the following steps:
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Step 1: Click "Start > Programs > Microsoft Visual Studio 2005 > Microsoft Visual Studio
2005" (referred to VS2005), as shown in figure.

© Microsoft Visual Studic 2005 Do
" Microsoft Visual Studio 2005 EREHETE
| Visual Studio Remote Tools

| Microsoft Visual Studio 2005 U e

BE: | A0
B

. Windows Embedded CE 6.0 EREEE
P

Step 2: Tip window will appear below, please do not click "Continue", where Microsoft
recommends that you use to run the program as an administrator, so the click of "Exit Visual

Studio" to exit.

#icrodnlt

Visual Studio 2005

Administrator permissions are recommended for running Visual Studio 2005
SP1

Some Visual Studic 2005 tasks and scenarios will not work without Administrator

permissions. We recommend that you use 'Run as administrator' to launch Visual
Studio.

Choose Check for Updates from the Help Menu to ensure you have the latest
updates,

Click here to learn more about using Visual Studio on Windows Vista

Always show this message

~ Exit Visual Studio ]
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Step 3: We first V52005 is set to administrator permissions, click "Start > Programs >

VS2005 > VS2005", then right click the menu shown, click "Properties”.
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Step 4: Figure window appears, click "Compatibility" tab, and check as shown in figure,

click "OK" to return.
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Step 5: At this time click "Start > Programs > V52005 > VS2005", will just tip window

appear, as shown, click "Continue", at this time will be run VS2005 as administrator.

’ flicrodalt
&

Visual Studio 2005

@ Administrator permissions are recommended for running Visual Studio 2005
SP1

Some Visual Studio 2005 tasks and scenarios will not work without Administrator
permissions, We recommend that you use 'Run as administrator' to launch Visual
Studio,

Choose Check for Updates from the Help Menu to ensure you have the latest

updates,

Click here to learn more about using Visual Studio on Windows Vista

[] Always show this message

i | [ Exit Visual Studio

Step 6: In figure interface, this interface is the work of VS2005, this is no longer

repeating the arguments the interface, please refer to the user data can be used VS2005.

File Edit View Project Target Tools
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‘ Device: CE Device O e | B2 8
Solution Explorer ~ 1 X //"srPag@ * X
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o Visual Studio 2005
( Visuastuﬂi Developer News

There is no content available yet. Content will be
downloaded once a connection to the internet is
established.

Window Community Help

Oinen: Droiert | Weh Site o]
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Step 7: Click File > Open > Project/Solution ...” shown in figure.

File | Edit View Project Target Tools Window Community Help

New rhoo -2 ] al v
| Open [* |5 Project/Solution.. Cirlsshifs0 | J

f— kd
Close = Web Site...
: File...

et Windows Embedded Pa
] C p Tue, 22 Jan 2008 14:56:5:
. and your business by cot

Exit

Distributors, and Microse

T
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Step 8: File selection window appears, find the default kernel mini2440 project files

(path: C:\WINCEB00\OSDesigns\Mini2440), click "Open", shown in figure.

Open Project +
Lookin: | 1l Mini2440 [x] @ ~& |0 X *Toals ~
' = #iaE =R Foh
-] L Mini2440
Desktop | EWiini 3440 5in =
My Projects
B
LY
My
Computer
File name; IZ' Open
| Files of type: iﬁ.ll Project Files (*.sln*.dsw:* vow: *.csproj;*wbpr| = Cancel
| £ L
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Step 9: Wait a moment, mini2440 default kernel project workspace is loaded, the

interface in figure.

Fle Edit View Project Build Debug Target Tools Window Community Help
s R e R I J B9 -0~ E-5
‘ Device: CE Device v Bm Su |

P Mini2440 AF v Platform Builder (TGTC v | [#

=
1 E olution 'Mini. ' roject -~ ‘. MiUE‘SUﬂ‘ .
e « Visual Studio 2005

- 4 C/WINCEBOO

B D _PLATFORM Recent Projects A MSDN: Windows Embedded Developer Center H
[ [3§ ARUBABOARD

F+J % CEPC [Eminiza40 Windows Embedded Partner Program
IB 51 COMMON Tue, 22 Jan 2008 14:56:53 -0800 - Accelerate your sc

[ [%1 DEVICEEMULATOR and your business by connecting with partners, OEM
IB [ HASAMPLE Distributors, and Microsoft.
r+_1 [5 MAINSTONEII D load Wind Embedded CE 6.0 Platform B
B (54 Mini2440 Thu, 1.7 May 2007 20:55:06 +0000 - You can now do
B Paramister Fles the Windows Embedded CE 6.0 Platform Builder Ser
: Lath bib Pack 1 that was announced during MEDC 2007 in La
L plaﬂorm'd‘ I Qpen: Project.. | Web Site... Mobilize: Explore The New Features In Windows |
| | platform.da . i i
= Pl R L Create:  Project.. [Web Site.. ) Mon, 7 May 2007 18:36:03 +0000 - Paul Vao presen
% X - .
| overview of Windows Embedded CE 8.0
- @] platform.reg - A
: ) Getting Started -
ESalution Explarer |@ Catalog Ttems \-’iew“ﬂ Class View [« | n | (3
Code Definition Window > 1x
Ho definition selacted ,
=i

Step 10: Click "Build > Advanced Build Commands > Clean Sysgen" to compile the

kernel, as shown, this process is longer, please waiting.

File Edit View Project | Build | Debug Target Tools Window Community Help

JA- i -Eda s Build Selution F7 ‘orm Builder ( TGTC ~ | [#
 Device: CE Device - Rebuild Solution Ctrl+Alt+F7
Solot Exploner CMimaa%0 Clean Solution
Build Mini2440
[5] Solution 'Mini2440' (1 pr. Rebuild Mini2440 : o
- @) Mini2440 Clean Mini2440 Jal StUd'O 2005
& ‘ C:/WINCEG0D Advanced Build Conm ds 3 | Sysgen
=~ 3 PLATFORM -
- [31 ARUBABOA [[ cleansysgen |
[ CEPC = 1 All Subprojects Build and Sysgen rt
+- (3 COMMON Build All SDKs... Rebuild and Clean Sysgen
E . : n
(3§ DEVICEEMU Capy Files to Release Directory Build Current BSP and Subprojects 6
g 34;]?:?_:;; Make Run-Time Image Rebuild Current BSP and Subprojects b
£33 Mini2440 B¥ Open Release Directory in Build Window Thu, 17 May 2007 20:55:06

the Windows Embedded C
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overview of Windows Emb
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Step 11: Compilation completed, the results shown at this time would be to build the

kernel image file NK.bin and NK.nb0, and the path is as follows.

CAWINCEBOO\OSDesigns\Mini2440\Mini2440\RelDir\Mini2440_ARMV4|_Release.

File Edit View Project Build Debug Target Tools Window Community Help

P-4 B9 E -5 b Mini2440 AF > Platform Builder (TGTC ~ | @
‘Device: CE Device - 85 2 | ﬁ
| Solution Explorer - Mini2440 v 1 X || start Page|

Solution 'Mini2440' (1 project) » Microsoft:
] a

o Visual Studio 2005

=- & C/WINCES00

=2 D PLATFORM Recent Proects MSDN: Windows Embedded Developer Center
+- (31 ARUBABOARD

- F3 CEPC [EMini2440 windows Embedded Partner Program

5 COMMON Tue, 22 Jan 2008 14:56:53 -0800 - Accelerate your sc
31 DEVICEEMULATOR and your business by connecting with partners, OEN
. P HASAMPLE Distributors, and Microsoft.

load Wind. Embedded
23 MAINSTONENT ] CE 6.0 Platform B

-

3 salution Explarer I@ Catalog Items Viewlg Class View A ¥

Show output from: Build YRR | ==

makeimg: Change directory te C:\WINCEEOD. )

makeimz: run command:_emd /T C:\HINCEGOO'\publicheonmontoskini se'pbpostmakeing
WEheE © AR

FHIFESSE A89F-9511

C:WWINCEBOONOSDesigneiMiniZ440 Mini 24404 RelDir WiniZ440_ARMV4I_Releaze FIEF

2009701726 17:01 30, 482, 591 HE bin
1 3t 30, 462, 591 3
0 4B 79,042,859, 008 AIEETS

ELDDEMO: MiniZ440 build complete.

MiniZd40 - 0 error (s), 64 warning(s)

__________ Build: | succeeded or up-to-date, 0 failed, O skipped s==s====== @

[ |
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i~ & netui.pdb 2009/1/26 16:43 Program Debug
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9.2.3 Kernel compiled with Tencent QQ example projects

Compile the kernel with Tencent QQ project and support similar to the steps above, but

do not have to reset the V52005 "administrator permissions" of the property, as follows.

Step 1: Click "Start > Programs > VS2005 > VS2005", open the VS2005 working

interface.

Fle Edit Miew Project Target Tools Window Community Help
- d B9 F-5 b -
 Device: CE Device > 5m %n | BT | ﬁ
Solution Ex..w & X

_~Start Page - X

. r-dicrEJsuh' .
o Visual Studio 2005

Recent Projects MSDN: Windows Embedded Developer Center

= Mini2440 Windows Embedded Partner Program

Tue, 22 Jan 2008 14:56:53 -0800 - Accelerate your sclutions |
and your business by connecting with partners, OEMs,
Distributors, and Microsoft.

Download Windows Embedded CE 6.0 Platform Builder...
Thu, 17 May 2007 20:55:06 +0000 - You can now download

Fs.. [@c. [Ba. [«[
Show output from: Windows CE Debug

4

[ Code Definition Window |23 Call BrowserlE] Duiputi
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Step 2: Click “File > Open > Project/Solution ...” shown in figure.

File | Edit View Project Target Tools Window Community Help

New dl RARP-0a=AN al y
| Open [ Project/Solution... Cirl+Shift+0 | ]

Close = Web Site...
: File...

et Windows Embedded Pa
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Exit
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Step 3: File selection window appears, find the default kernel mini2440 project files

(path: C:\WINCEB600\OSDesigns\Mini2440-with-QQ), Click "Open", shown in figure.

-
Open Project
-
I Lookin: | b Mini2440-with-00 x| @ ~@ | X i ~Tools~
EFR e mE ] A Tl
| -] L Mini2d440-with-QQ
Deskiop | EEMini2440 with-00.sin :
"
My Projects
| ™
A
My
Computer
File name: IZ' Open I
Files of type: Eﬁ.ll Project Files (*.sln;*.d5w;*.vcw;*.csprcrj;*.vbpr|z! Cancel
1 -
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Step 4: Wait a moment, mini2440 default kernel project workspace is loaded, the

interface in figure.

Fle Edit View Project Build Debug Target Tools Window Community Help
BA-E-EHe % s < 4o 21 20| b Mini2440 AF v Platform Builder (TGTC « | [#

| -|| o @ | a2 ik g
5ty B E

‘ Device: CE Device

. ‘Start Page |

. Micrs:scfr .
« Visual Studio 2005

Recent Projects MSDN: Windows Embedded De

= 3 PLATFORM
[31 ARUBABOARD
3 CEPC

m

% COMMON (& Mini2a40-with-QQ Windows Embedded Partner Pre |
31 DEVICEEMULATOR ﬁ Mini2440 Tue, 22 Jan 2008 14:56:53 -0800 -
33 H4SAMPLE and your business by connecting
%3 MAINSTONEII Distributors, and Microsoft.
o D load Wind Ermbedded
3 Mini2440 o
@ 3 Parameter Files Thu, 1.7 May 2007 20:55:06 +0000
- T sre the Windows Embedded CE 6.0 PI
_ Pack 1 that was announced durinc
- 4 PRIVATE T, Open: Project... |Web Site... Vanas
4| ] | s Create: Project... |Web Site.., ~ .
S solution Ex.. |@ Catalog lte.. |%C|as:— View |4 ] 1L G
Output > 1 %
Show output from: Windows CE Debug 3| @5 | =x|E
1 b
F&Code Definition Window 22 Call Browser“g Dutputi
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Step 5: Click "Build > Advanced Build Commands > Clean Sysgen" to compile the

kernel, as shown, this process is longer, please waiting.

File Edit Wiew Project | Build l Debug Target Tools Window Community Help

R E-Ead % Build Solution 2 ll‘form Builder (TGTC + | (% &
| Rebuild Solution Ctrl+Ale+F7 '
i . . Clean Solution
- Device: CE Device - 50
Build Mini2440-with-QQ
-
Rebuild Mini2440-with-QQ =
Mini2440-with-QQ Clean Mini2440-with-QQ
4 C/WINCEGDD | Advanced Build Commands 4 | Sysgen
& I_j PLATFORM Build All Subprojects | Clean Sysgen
QER:CBABOA Rebuild All Subprojects Build and Sysgen
COMMON Build All SDKs... Rebuild and Clean Sysgen |
% DEVICEEMY Copy Files to Release Directory Build Current BSP and Subprojects
HA4SAMPLE Make Run-Time Image Rebuild Current BSP and Subprojects
[ MAINSTON . . ) ) OO, ST TSSO
o i B Open Release Directory in Build Window Download Windows Embedded
F Bl Paramet Global Build Settings v Thu, 17 May 2007 20:55:06 +0000
Taracted Build Settinas i the Windows Embedded CE 6.0 PI
. - Bl 3 2 Pack 1 that was announced during
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Step 6: Compilation completed, the results shown at this time would be to build the
kernel image file NK.bin and NK.nb0, the path is as follows: C:\WINCE600\OSDesigns\Mini2440-
with-QQ\Mini2440-with-QQ\RelDir\Mini2440_ARMV4|_Release.

File

Edit
@l S A& 0 B s - - S5 | b Mini2440 AF v Platform Builder (TGTC ~ | [
‘ Deviee: CE Device 58 o | n
Solution Explorer - Mini2440with-03 « 2 X || ¢
B @ Mini2440-with-QQ - » Microsoft: <N

& 4 CwINCES0D « Visual Studio 2005

- 3 PLATFORM

View Project Build Debug Target Tools Window Community Help

L

B ARUBABOARD Recent Projects MSDN: Windows Embedded De
7 3 CEPC
- %3 COMMON [ZE Mini2440-with-QQ Windows Embedded Partner Pre
. [ (3§ DEVICEEMULATOR - [ Miniza40 Tue, 22 Jan 2008 14:56:53 -0800 -
< m | r and your business by connecting " _

[ L PSS O STy %

| 3

Clsolution Ex.. |@ Catalog fe... I%Class\l’iew 4[5

Show output from: Build
E ARG 2R p3aF-95D01 %

C:AWINCEBO0A0S Desi gns'ilin 2440-wi th-00\Mini 2440-%i th-004RelDi r'Mini 2440_ARMYAT Release MIEFR

2009/01/26 17:32 24,739,219 FE bin
1 -3t 24,739, 219 =%
0 --EF 78,387, 200, 112 AIAEH

BLIDEMO: MiniZ2440-with-08 build complete.

MiniZ440-with-QQ - 0 error (z), BB warning(s) L
____________________ =

—————————— Euild: 1 zueceeded or up-to-date_, 1] failed_, 0 ckipped ==========

[FA Code Definition Window 2 Call Browser||§ Qutput I
Build succeeded

S ERE

"~ ] netres.map 2000/1/26 17:18 Linker Address .

m =T |-_| netres.rel 2009/1/26 17:18 REL =7{%

H @ netres.res 2009/1/26 17:18 Compiled Resou

| ERAERER -
: & ; @] netuidll 2000/1/26 1732 RESTER
l _ 5] netuimap 200971726 17:15 Linker Address .

- = @& netuipdb 2009/1/26 17:15  Program Debug

B | | netui.rel 2009/1/26 17:15  REL 37f# B
| = BR @ Metwork 2009/11/515:25  HUEATL

[ o ||| NK.bin 2000/1/26 17:32  BIN =it

o =F 7 nk.exe 2009/1/26 17:31 AEE
| | Bl nkmap 2009/1/26 1731 Linker Address

. ||| NK.nb 2000/1/26 17:32  NBO =%
& nk.pdb 200971726 17:31 Prograr Debug =
| B sk N |_ fr | +
CiEE 2 I SHEER: 2009/1/26 17:32 SIEEEE: 2009/1/26 17:32
| Zlv 53.5 MB
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9.2.4 Compiling and burning Nboot Bootloader

Note: We provide Nboot can also apply to Windows CE 5/6, so the CD all the Nboot
project source code is the same, but for the convenience of the organization to use, specifically

increased the copy, and were placed in a different directory.

Compile Nboot integrated development environment to use ADS, the detailed steps, see
chapter 4 of this manual, the Windows 7 system, you can install Windows XP mode to create a

Windows XP environment.

Nboot is a very simple bootloader, its size less than 4K, usually programmed into the
Block 0 position of NAND Flash to start the WinCE kernel, Nboot reason to Samsung, we have

done a lot of improvements, currently has the following features:

® Adaptive support 64M/128M/256M/1G for mini2440/micro2440

Support rapid start-up screen display

Support dynamic load WinCE kernel progress bar

Start WinCE only 5-10 seconds, depending on the size of the kernel

Note: Nboot do not have the programming capabilities, it can only read the
programming process has been well documented: the boot screen (Boot Logo) and WinCE

kernel.

Nboot has convenient customization, you can modify the splash screen header file
defines the display position, background, and the progress bar color, position, length, and

width, these definitions are located in “option.h” file, as follows:

/1 By changing the definition, select the appropriate LCD nodel s,
where the default choice WB5, said Wang Ping WB5 (LQO35QLDE06)
/| #define LCD _N35

/| #define LCD_L80

/| #define LCD T35

/I #define LCD X35

#define LCD WB5

/I #define LCD _A70

/1 #define LCD VGA1024768

/1 Set the background col or

#defi ne BACKGROUND R 0x00

#def i ne BACKGROUND_G 0x00

#def i ne BACKGROUND B 0x00

/|l Set nroaoaress<s bar col ors
1-—et—pPr-ogr-ess—bal-—-Co1-0F-S
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#defi ne PROGRESS BAR R OxFF
#defi ne PROGRESS BAR G OxFF
#defi ne PROGRESS BAR B 0x00

/1 Set the location of the boot inmage
#define LOGO POS TOP O
#define LOGO POS LEFT O

/1l Set start position and | ength and wi dth of the
#defi ne PROGRESS BAR TOP 260

#def i ne PROGRESS BAR _LEFT 20

#def i ne PROGRESS_BAR_W DTH 200

#defi ne PROGRESS BAR HEI GHT 12

Here Nboot compilation methods and steps:

Compile Nboot

The CD "WindowsCEG6.0" directory folder "NBOOT" folder into hard disk of a directory
(in this case D:\work), remove the read-only attribute, running ADS1.2 integrated development

environment, click “File > Open ...” to open nboot.mcp file, as shown.

Netrowerks Code¥arrior for AEN Developer Suite wl. 2

File Edit ¥iew Search Project Debug Window Help

AEFEcx<ha A A AAmERsEREBE

i@ nboot. mcp

IﬂRelease ji@&’@@b

Files |Lir|l': Order I Targets I

% | File | Code | Data |9
B P44x_init. s 506
Bl 244 _1ib. o 444
B nand. e 1034
B HEOOT. « 1016

B nand s s 280

5 files

/ A\
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At this click the menu “Project > Make” or press the F7 key to start compiling nboot

project, compile completed as shown:

i Netrowerks Code¥Warrior for ARN Developer Suite wl.?2 l:”iwzl

File Edit ¥iew Search Froject Debug Hindow Help

AEFgEH v <BHAAAN EEWRERR

B

ey &5 > E

Files IL'irul': Order l Tarzets I

l ) Releasze

w | File | Code | Data [4E | =
M 244x_init. s 508 0« = =
B 244X _lib. 444 o oe = ==
B nand. c 1054 4 « =
fR WBOOT. = 1016 200« =
B nand_=. = 260 o« =

mErrors & Warnings

Ol Al EBEn

E_El Translation to Plain binarvy format successful.

EErrors and warnings for $Ehoot.)

®

In D:Awork\NBOOT\nboot_Data\DebugRel directory will generate nboot.bin executable

file, as shown.

& D:\workinbootinboot Data‘Releasze I=](53
THE HEE TEW Ywme TAD #Ehow -
QFE- O @ Omx =rEx @
Hitk (00 |D I wworkimbootinboot_Data‘Release el | 3]
A @m - x| %8
NS - [Ci0bjectlode ik
Cpineg ®|nboot, axf 4 KB ABM exect
= Efﬁgl‘\z [k = sok. 4 KB BIN L4
@ BRI T I 4 Ta.rget[lata'l'l'indows. tdt 82 KB TOT Jrig
) EfbTIeE ]
@ XA
2 B e e o
[ _l
o e
HEkE
u_ﬂ nboot_Tllata
E HATIR g | Il [ >
#ER - BTH it ERZEER: 2009-T-18 23:58 A 30327 KB o At i
[ N\
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The NBOOT programmed into the development board NAND Flash

(1) Connect the development board power supply, serial cable, USB cable, and set the
toggle switch S2 to start the system in NOR Flash, respectively, to open the serial

port and HyperTerminal DNW, power on the development board.

(2) USB driver has been installed (previously described in detail the USB driver
installation method), then you can see DNW's title bar displays [USB: OK], if not

installed drivers will display [USB: x] , as shown:

-/ DN¥ vi. 504 REZBHRHR OINEHTIE)  [CoM:xl [UsB:0E1 [T |[B)X]

Serial Fort USE Port Configuration Help

RN

S
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(3) When the BIOS functions in the HyperTerminal menu, select the function [n], USB

download wait message appears:

IHEE) FRIEE EE W E ) fEEa R

=

0O =

5 DB

[%]
[v]
[k]
[y]
[a]
[n]
[1]
[w]
[d]
[z]
[g]
[f]
[b]
[s]
[u]
[r]
[q]

it FriendlyARM BIOS for 2440 fit#id

bon part
Download
Download
Download
Absolute
Download
Download
Download
Download
Download
Boot 1lin
Format t
Boot the
Set the

Backup HAND Flash to HOST through USB{upload)

Restore
Goto she

Enter your selection: n
USB host is not connected yet.
USE host is connected. Waiting a download.

8 328k 2368k
vivi

linux kernel
root_yaffs image
User nApplication
Hboot

WinCE boot-logo
WinCE HK_bin

& Run

zImage into RAH
ux from RAH
he nand flash
system
boot parameters

MAND Flash from HOST through USB
11 of vivi

i

<

LTS 0:00:1¢ ANSIW 115200 8-F-1

(4) Click DNW program "USB Port > Transmit", as shown in figure choose just compile

out of the image file (CD-ROM "images\wince6.0" directory has been compile

executable file), This will start the download, and instantly you can download is

complete, supervivi it will automatically be programmed into the NAND Flash in the

starting block 0; the S2 switch to NAND side, select start from the NAND Flash

system; if the system has been good programming WIinCE kernel boot image files

and image files, it will immediately boot screen and progress bar, wait a moment to

see the wince started. Use NBOOT start WinCE serial information is as follows:

i
O

tty50 — iEHEEE
=+ F) #RIE(E) ZHEF N FIEC) EEI) #FEEh

load Windows CE Image..

I
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9.2.5 Modifying the BSP LCD type and serial output

Note: We provide the BSP currently supports the following models of LCD screen:

® Horizontal 3.5-inch LCD screen with touch (LQ035Q1DG06 or compatible, referred to as
W35)

® NECS3.5-inch screen with touch

® TPO 3.5-inch LCD with touch

® Sharp 8-inch LCD (or compatible) with touch
® [nnolux 7-inch screen with touch

® \/GA display output module, resolution of 1024x768

By modifying the mini2440\Src\Inc\options.h header file LCD_TYPE definition, you can

select the appropriate type of LCD:

/1# define LCD N35 for NEC3.5 "LCD

// # define LCD_L80 for Sharp 8 "LCD (or conpatible)

// # define LCD T35 for TPO 3.5 "LCD

// # define LCD_X35 for Sony 3.5 "LCD (LQ035QLDG06 or
conpatible, referred to as W85)

#define LCD W85 for horizontal screen 3.5 "LCD

// # define LCD_A70 group record for 7 "LCD

// # define LCD VGA1024768 for LCD2VGA nodule with a
resolution of 1024x768

Tip: The default LCD model CD-ROM is LCD_T35.

In options.h file, the user can modify the serial output functions: as ordinary serial port

functionality or debugging output (only serial port 1 and 2), defined as follows:

#defi ne KI TL_NONE

/ | #define Kl TL_SERI AL_UARTO
/| #define Kl TL_SERI AL_UART1
/| #defi ne Kl TL_USBSERI AL

/[ #define KI TL_ETHERNET

The default is defined here as ordinary serial port functions, serial port 1 if you want to

use as a debugging information output, should be defined as:

/[ #define KITL_NONE
#define KITL_SERI AL_UARTO
/| #define Kl TL_SERI AL_UART1
/| #defi ne Kl TL_USBSERI AL

/[ #define KITL_ETHERNET
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9.2.6 Create and Modify the Windows CE boot logo
In the previous chapter, we mentioned:

Windows CE system's boot process, there are two logo: BootLogo and StartLogo.
One BootLogo shown by Nboot loaded, the user can modify the Nboot source code to adjust
BootLogo display location and background color; StartLogo belongs to a part of BSP, which is
an array file (StartLogo.c), located in the "mini2440\Src\Kernel\Oal "directory from the directory
init.c file to achieve load display, StartLogo.c file by this CD StartLogoMaker.exe tool

production.

StartLogoMaker FriendlyARM developed by the Linux Logo Maker LogoMaker (running
on Fedora 9) transplant, this is a "green software", it does not require installation, directly copied
to the Windows XP/Vista platform to run, use it to bmp, jpg, and png format images converted to
an array of needed mini2440 BSP file StartLogo.c, using the new file to replace the BSP
generated files the same name, you can replace the Windows CE start screen, StartLogo.c the

head of the array as follows:

/1 Automatic generated by StartlLogo.exe from Friendl yARM Co. ,
Ltd.

static const unsigned short StartLogoData[] = {

240, 320,

0x965, 0x945, 0x164, O0x9C4, 0x1246, O0x22CA, 0x22A8, O0x2AA7,

Here is StartLogoMaker.exe production StartLogo.c steps:
r A\
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Step 1: Double click the "windows platform tools\StartLogoMaker" in StartLogoMaker.exe

program, open the as shown in figure interface:

A& FriendlyARN Windows CE Start—-Logo Naker
File Help

s
¢
e _an

Logo conwerted

SBE DE FERENT

¥
At -

Step 2: Click File > Open to open a picture file, you can also click icon in the toolbar to

open the file selection window:

LEx

& FriendlvARN ¥Windows CE S5tart-Logo Naker
File Help

Aas

ALTOBOTS

ROLL ODUT

Picture loaded

Friendly
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Step 3: Click “File > Convert”, or click the toolbar icon. Open the file output options

window:

Select the directory of the Logo file

) ADS1.2
=) cER Rl USEIE=D
) dnw
[C5) GIVEID
) H-TTas
O i ERERT EE_+
[ 5TF2440
b StartlogoMaker
() tftpboot

e W HETG—L

< i |

(3

[ #remEw | | ®wmE || BE |

Step 4: Click "OK" in the appropriate directory will generate StartLogo.c file:

= D:imini?d40-2009061 6 \windowsF 5L Hi5tartLogolaker
I HRIBE) EE00 WEEG THAT R
QFE - O ¥ Pux Dxax M-

Hidik () |D T Ymini2440-200906 18 windows T & T B \Star tLogoMaler v
el

E StartLogoMaker. exe

NS

s Eegi e
oy BEnE

= R L R TN
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Step 5: Replace the generated files the same name in the BSP file (located in the
mini2440-BSP\Src\Kernel\Qal directory), recompile the kernel, and programmed to run the

board, you can see yourself making of WinCE startup screen:

@ C:\WINCES00\PLATFORN\mini2440\Src\EKerneli0al M=
IEE FEE EFN W@ TEO HBEBE i
ORE - o T P oanx [

Y FTNCEE00\FLATFORM n i 2 440 S o erzel \Dal v | B3 =3

&
o)
o)

TS
@ Efﬁ-‘gﬁ"’l\iﬁ: ok args. o bitmap. = Buld leg
(B BELETIE
g | @ @ @
@ ﬁ]};\z”l\iﬁ:ﬁﬁﬁj = debug. = init.c intr. o ioctl. 2
(3 K EPb R RE
Fir e :
X MR E E ﬂ
kitl. e kitlser.c lkitlusbs. .. makefile
H [c]
Sources Startlogo.c  startup. s
W |
ZERL: C Sowrce file (ERZHER: 2009-T-8 15:31 4 497 1487 KB o HEADAER

s N
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SDK for development only when installed VS2005 on the host, but did not install the

Windows CE 6.0 Platform Builder plug-in, when developers want to develop mini2440 VS2005

application, you need an SDK, which is similar to Embedded Visual C++, required the SDK.

When you compiled the default kernel, this step created by VS2005 platform

corresponding SDK, Note: This only applies to V52005 SDK development environment, it can’t

install EVC, can't install VS2008, the following are the detailed steps to create SDK.

Step 1: Run V52005 and open the default kernel has been compiled sample project mini2440,

find the location as shown in figure, and right-click "Mini2440-CE6-SDK" menu appears, and

click to start creating SDK Build.

Fle Edit

E-E-EEa

‘ Device: CE Device

e

> 5m %o | BB

View Project Build Debug Target Tools

Window Community Help
P Mini2440 AF v Platform Builder (TGTC ~ | [#

.|| ‘startPage, X I

i RS N O o O ) D = M
L e e - e - e e )

@-
- [ oal
- 3 PRIVATE
#- 3 PUBLIC
- % Favorites
- [ Parameter Files

t; wdt

- &1 pom
- (3] pwrbutton
- [ SDHC
- (3] serial
- 21 touch
- % usb
- (21 UserKey

wavedev

. Micrysaﬁ‘ .
o Visual Studio 2005

" MSDN: Windows Emedded Deyll

Windows Embedded Partner Pr¢
Tue, 22 Jan 2008 14:56:53 -0800 -
and your business by connecting
Distributors, and Microsoft.

D 1 Fos e

Thu, 17 May 2007 20:55:06 +0000
the Windows Embedded CE 6.0 P
Pack 1 that was announced durinc

Recent Projects

Mini2440
Mini2440-with-QQ

A Wind

Project... |Web Site..,
= Create: Project... |Web Site...

Vegas.

(=2 SDKs

4 I

... fm Cubhnrnicrte

W
- = L
- = What's Mew in Platform Builder + i

‘ Open:
Mobilize: Explore The New Feati

Meon, 7 May 2007 18:36:03 +0000
overview of Windows Embedded

|t . J/

Al
Solution Ex... | Cata i fiew |« i 2
| :@7& Properties I |
Show output from: Windows CE Debug = | g 22 = | &=

& Code Definition Window 22 Call Browser“g Dutputi

Ready
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Step 2: Wait a moment, SDK has been created, shown in the figure.

Ele Edit View Project Build Debug Target Tools Window Community Help

Fe B A G s s 9 e - Z- | b Mini2440 AF v Platform Builder (TGTC + | [#

8 * =

‘ Device: CE Device ~ 55 %n | |

. Micrgscﬂ‘ "
o Visual Studio 2005

¢ Favorites
i E: Paiameter Files Recent Projects MSDN: Windows Embedded De
(=3 SDKs
== | Mini2440-CE6-5DK [Emini2440 Windows Embedded Partner Pre
i... B Subprojects E Mini2440-with-QQ Tue, 22 Jan 2008 14:56:53 -0800 -
- and your business by connecting
4 | m | b [~ VEL, BT (NR— Y S S
S Solution Ex... I@ Catalog Ite... l%ﬂlass View |4 [, | ¥
Show output from:  Build - | g "ﬁ B ==
Cabinet file successfully created: C:\WINCEAOOW0SDesizns'MiniZ440'\Mini2440\SDE=ASDE] obj zdkfiles. cab
Committing database changes
Exported SDE to: C:\WINCEGOO'OSDesigzns'MiniZ440'Wini24404%30K= 50K \Mini?440-CEE-SDK. m=i
C:\WINCEBOO4WSD esigns \Mini 24404Mini 24404 SDE \SDELASDEL. sdlefz - 0 error(s), 0 warning(s)
========== Fuild: 1 succeeded or up—to-date, O failed, 0 skipped ========== D
< | 1 ] ¢ i
[FaiCode Definition Window |38 Call Browser|i§ Dutputi I
|| Build succeeded j

Step 3: In the C:\WINCEB00\OSDesigns\Mini2440\Mini2440\SDKs\SDK1 directory, you can see

Mini2440-CE6-SDK.msi installation files has been generated.

L}

as— = E EwAs s
b = | ohj 2000/1/26 18:20  Sridss
B = [ﬁ! Mini2440-CE6-5SDK. msi 2009/1/26 1820 Windows Install...
I T EEsEe || sDKLsdkefg 2009/11/516:35  SDKCFG 3/
H = =
|l B wem
| =mEs
I
- BF
|
|| HER
-~ ik i ] 0
Mini2440-CE6-SDK.msi E£7EER: 2009/1/26 18:20 SIEEHER: 2009/1/26 18:20
: E Windows Installer BF8 Fv 4.67 MB
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Mini2440 through VS2005 to develop applications, you need to install just the production

of the SDK, as follows

Step 1: Double click Mini2440-CE6B-SDK.msi, there is interface, click "Next" to continue.

4l Mini2440 Setup

2]’

@ Welcome to the Mini2440
Setup Wizard

The Setup Wizard will install Mini2440 on your computer,
Click Mext to continue or Cancel to exit the Setup Wizard.

< Bac Mext = J [ Cancel

Step 2: As shown in figure, select "Accept”, click "Next" to continue.

E-j Mini2440 License Agreement

===

End-User License Agreement

Be sure to carefully read and understand the following end-user license agreement, @
and then indicate whether you accept or do not accept the terms of the agreement.

This software will not be installed on your development warkstation unless you accept the
terms of the end-user license agreement. For your future reference, you can print the text of
the end-user license agreement by dicking the PRINT button. N

SOFTWARE LICENSE TERMS -

WINDOWS EMBEDDED CE 6.0 CUSTOMIZED OEM SOFTWARE
DEVELOPMENT KIT for

Miniz440, 6.0.0

__Press the PAGE DOWM key to see more text.
i b et
< Back || Hext = ] [ Cancel
ko = = = d
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Step 3: Appear in figure interface, enter the user name and company name, click "Next" to

continue.

rﬁ! Mini2440 Setug - ﬁ

Customer Information —
Please enter your customer information %

User Mame:
[tom

Oroanization:

IITIS

<gack || Mextz | [ cancel

N —— =

Step 4: Appear in figure interface, click "Complete" and “Next” to continue.

- I
1) Mini2440 Setup =5
Choose Setup Type — I
Choose the setup type that best suits your needs %
Custom
Allows users to choose which program features will be installed |
and where they will be installed. Recommended for advanced
users.
Complete
Al program features will be installed. {Reguires most disk
| space) .
||
< Back Mext > ' Cancel
W S T T e
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Step 5: Appear in figure interfaces, click "Next" to continue.

r T
8] Mini2440 - Destination Folders =5

Destination Folders |
Click Mext to install to this folder, or dick Change to install to a different folder.

IIJI. j Install Mini2440 to:
Ct\Program Files\Windows CE Tools\wee600Mini2440-CES-SDKY ‘

T T

Step 6: Appear in figure interfaces, click "Install" to continue.

o = ==
) Mini2440 Setup [
Ready to Install — I‘
The Setup Wizard is ready to begin the Complete installation 5
Click Install to begin the installation. If you want to review or change any of your I
installation settings, did: Back, Clid: Cancel to exit the wizard.

Ll
|
<Back || Instal | | cancel
 N— e — = e d
d N\
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Step 7: Installation progress screen appears as shown in figure, wait a moment.

[ 14 Mini2440 Setup ==

Installing Mini2440 @
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Please wait while the Setup Wizard installs MiniZ440, This may take several
minutes.

Status:  Copying new files

——

Step 8: At the end of the installation interfaces, click "Finish". SDK has been installed.

[ 2] Mini2440 Setup .

@ Completing the Mini2440
Setup Wizard

Click the Finish button to exit the Setup Wizard.

< Badh | Finish | Cancel
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