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Chapter 

1 
Introduction 

CADA Administration Tool (SAT) was developed for the Orange County 
Sanitation District (OCSD) Plant Automation Group (PAG).  The software 
is designed to allow PAG personnel and designated subcontractors to 

create, modify, and administer tag databases used by the plant SCADA system. 

The SCADA system at OCSD consists of CRISP software connected to Modicon 
Quantum PLCs programmed with Taylor software.  By allowing designated 
subcontractors to prepare specific tag databases and forward the files to the 
PAG for incorporation, the system can be maintained in a more timely and 
efficient manner. 

SAT uses Microsoft Access database files for data storage; and provides various 
import/export tools, data manipulation and retrieval, and static reporting features. 

Minimum System Requirements 
SAT is designed to operate on a PC running Windows 98 (2nd Edition), Windows 
NT 4.0 (with Service Pack 5 or higher) or Windows 2000 as the operating 
system, with the following minimum hardware configuration: 

• 200 MHz Pentium (or equivalent) processor 
• 192 MB RAM (256 MB recommended) 
• CD-ROM drive (or network access to a remote CD-ROM drive) 
• 20 MB hard drive space for program installation 

Note: Additional hard drive space may be required for the Event Log and Version 
Control Journal files, database files, archived database files, and CRISP and 
Taylor Export files. 

Installation 
To install SAT, insert the SAT installation CD into the computer’s CD-ROM drive.  
If the Setup program does not start automatically, use My Computer or Explorer 
to open the CD-ROM and run the Setup.exe program.  The Setup program will 
prompt the user for any required information, such as the desired installation 
location.  The setup program copies all application, library, and help files to the 
hard drive.  Once installation is complete, the CD is no longer required to run the 
application, or to view on-line help. 
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Note: The installation CD also contains a softcopy of this SAT User Manual in 
Microsoft Word 2000 format.  This file will not be copied to the hard drive during 
installation.  You may print this file if you wish to view the SAT User Manual in a 
hardcopy form. 

Following is a list of files installed to the hard drive. 

• SAT.exe – Main application program 
• SAT.chm – Online help file in HTML format 
• SATZip.exe – External application used to compress archived database files 
• RSCSys.dll – Library file required by SAT.exe 
• Quickbar.ocx – ActiveX file required by SAT.exe 
• Other miscellaneous support files (including Microsoft Access and Excel 

libraries) 
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2 
Chapter 

2 
Launching SAT 

nce the installation is complete, select SAT from the Start menu to 
launch the program.  While SAT is running, it will display a faucet icon in 
the system tray.  The user can access some of SAT’s main features by 

right clicking on the faucet icon in the system tray and selecting an item in the 
popup menu.  The user can access more features by double clicking on the 
faucet icon to open the SAT Console window. 

O 

System Tray Icon 
As soon as SAT is launched, a faucet icon will appear in the system tray, just to 
the left of the time. 

 
Figure 1 – System Tray Icon 

The animation of the faucet icon and the icon’s tool tip indicate SAT’s status.  
While SAT is loading, the faucet remains idle.  When SAT has finished loading, 
the faucet begins to drip.  When a database is loaded in SAT, the icon’s tool tip 
displays the name of the currently open database.  The user can view the tool tip 
by hovering the mouse over the faucet icon.  If the user runs more than one copy 
of SAT at one time, a separate faucet icon will appear in the system tray for each 
copy of SAT.  The user may determine which icon represents which copy of SAT 
by viewing the tool tips for each faucet icon. 

If a default database is specified, SAT will automatically load that database when 
SAT is launched.  Depending on the size of the database, SAT may take several 
seconds to load.  While the database is loading, the faucet icon will remain idle, 
and the right click menu will remain inactive.  Once the database is loaded, the 
faucet icon will begin to drip, and the right click menu will become active.  If no 
default database is specified, then SAT will load quickly, and the right click menu 
will be available almost immediately. 

For information about how to select a default database, please refer to the 
General Settings section in Chapter 7 - Options. 
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Popup Menu 
When the user right-clicks on the faucet icon in the system tray, a menu is 
displayed.  From this menu, the user may perform many of SAT’s most frequently 
used functions.  These features will be explained later in this document. 

 
Figure 2 – System Tray Icon Popup Menu 

To gain access to SAT’s main user interface, the user can select Open SAT 
Console from the popup menu, or simple double-click on the faucet icon in the 
system tray.  For more information about the SAT Console, please refer to 
Chapter 3 - SAT Console.  To shutdown SAT, the user may select Shutdown 
from the popup menu.  After SAT has closed any open databases and finished 
unloading, the faucet icon in the system tray will disappear.  If the icon does not 
disappear immediately, the user may move the cursor over the system tray area, 
and the system tray will be refreshed. 

Note: If a database is open when the user selects Shutdown from the popup 
menu, SAT will prompt the user to annotate changes made to the open database 
before closing the database.  For more information about closing a database, 
please refer to the File Operations section in Chapter 3 - SAT Console. 
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Chapter 

3 
SAT Console 

he SAT Console is SAT’s main user interface.  The user may open the 
SAT Console window by double clicking on the faucet icon in the system 
tray, or by right clicking on the icon, and selecting Open SAT Console 

from the popup menu. 
T 

 

Figure 3 – SAT Console 

The SAT Console interface uses a Microsoft Outlook style.  It contains a menu 
bar, three toolbars, a shortcut bar, a status bar, and a main display area. 

The SAT Console contains a menu with the following menu options: File, Edit, 
View, and Help. 

The SAT Console contains three toolbars: Main, Tools, and Database.  The Main 
toolbar contains buttons that correspond to the most commonly used options in 
the File, Edit, View, and Help menus.  The Tools toolbar contains buttons that 
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correspond to the options in the Tools menu.  The Database toolbar contains a 
dropdown list that allows the user to select from the last databases open.  All of 
the buttons in each toolbar contain tool tips.  The user may also customize the 
toolbars. 

The SAT Console contains a shortcut bar that contains three tabs: SAT, 
Explorer, and My Shortcuts.  The SAT tab contains navigation shortcut icons that 
correspond to the options in the Go To submenu in the View menu.  The 
Explorer tab contains shortcut icons to common folders.  The My Shortcuts tab is 
empty, and is designed to contain the user’s custom shortcuts.  The user may 
customize the shortcut bar, but cannot delete or make changes to the SAT tab. 

The status bar displays the status of SAT, and has a progress indicator that is 
active when loading a database or refreshing tables and reports.  If “Error” 
appears in the status bar, the user may obtain more information by viewing the 
Event Log. 

The main display area changes based on the current view, which may be one of 
the following: Data Table, Query Table, Pivot Table, Report, and Related Files.  
For specific information about how to select and use these views, please refer to 
Chapter 4 - Views. 

File Operations 
The user can find most of the file operations in the File menu of the SAT 
Console. 

 

Figure 4 – File Menu 

The user may create a new database, open a database, save a database as an 
Access file or as an Excel file, close the currently open database, view properties 
for the current view, print the contents of the current view, or close the SAT 
Console window. 

Whenever the user opens a database that has not yet been opened in the 
current session of SAT, the path and filename of the database is added to the 
dropdown list in the Database toolbar.  To quickly reopen the database, the user 
may select the database from the dropdown list. 
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When the user closes the currently open database, the user is prompted to enter 
annotation information that describes the changes that have been made to the 
database.  For more information about the annotation, please refer to the Version 
Control section in Chapter 7 - Options. 

 

Figure 5 – Save Database (Edit Annotation) 

Edit Operations 
The user can perform most of the edit operations on the object that is currently in 
the main display area, by selecting one of the options in the Edit menu of the 
SAT Console.  The action that SAT takes for each edit function is based on the 
type of object in the main display area. 

 

Figure 6 – Edit Menu 
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View Operations 
The user may perform many operations that change the appearance of the SAT 
Console.  Most of these options can be found in the View menu of the SAT 
Console.  The user may show and hide toolbars, the shortcut bar, and the status 
bar, by selecting the appropriate option in the View menu.  The user may refresh 
the current object in the main display area by selecting Refresh in the View 
menu. The user may abort the refresh by selecting Stop in the View menu. 

The user may change which object is displayed in the main view area by clicking 
on the View menu, clicking on the Go To menu, and selecting the desired view.  
For more information about selecting and using different views in the main 
display area, please refer to Chapter 4 - Views. 

 

Figure 7 – View Menu 

Tools 
The user may perform import/export operations, launch utilities, and view and 
edit SAT settings by clicking on the Tools menu and selecting the appropriate 
option.  For more information about the import/export operations, please refer to 
Chapter 5 - Import / Export.  For more information about the utilities, please refer 
to Chapter 6 - Utilities.  For more information about viewing and setting SAT 
settings, please refer to Chapter 7 - Options. 
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Figure 8 – Tools Menu 

Help 
The user may obtain online help in HTML format by clicking on the Help menu 
and selecting Help Topics.  The content of the online help is similar to the 
contents of this document.  The user may also obtain version and license 
information about the currently installed version of SAT by selecting About SAT 
from the Help menu. 

 

Figure 9 – Help Menu 
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4 
Views 

he user has many objects from which to display in the main view area.  
Available views include: Data Table, Query Table, Pivot Table, Reports, 
and Explorer.  The user may select a view in two ways.  The user may 

click on the View menu on the SAT Console, click the Go To menu, and select a 
view.  Alternatively, the user may double click on an icon in the shortcut bar on 
the left of the SAT Console window that corresponds to the desired view. 

T 

 

Figure 10 – Go To Submenu 
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Data Table 
The user may select the Data Table view by selecting Data Tables from the Go 
To menu in the View menu on the SAT Console, or by double clicking on the 
Data Tables icon in the shortcut bar. 

 

Figure 11 – Data Table View 

The Data Table view uses a data grid similar to that found in Microsoft Access to 
allow the user to display and edit data.  The user may select the desired table by 
right clicking on the small table icon in the upper right of the main display area.  
The user may choose from Real and Derived tables. 
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Query Table 
The user may select the Query Table view by clicking on Query Tables in the 
Go To menu of the View menu on the SAT Console, or by double clicking on the 
Query Tables icon in the shortcut bar. 

 

Figure 12 – Query Table View 

The Query Table view is implemented with a Query Table inserted in an Excel 
OLE.  To edit the contents of the Query Table, right click on the Query Table and 
select Edit from the popup menu.  Then resize the OLE window to the desired 
size.  Note that when editing the Excel OLE, the menu on the SAT Console 
changes to that of Microsoft Excel.  The user may select another view, or click in 
the gray area surrounding the Excel OLE to restore the standard SAT menu.  
Please refer to the Microsoft Excel User Manual for help using Microsoft Excel. 
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Pivot Table 
The user may select the Pivot Table view by clicking on Pivot Tables in the Go 
To menu of the View menu on the SAT Console, or by double clicking on the 
Pivot Tables icon in the shortcut bar. 

 

Figure 13 – Pivot Table View 

The Pivot Table view is implemented with a Microsoft Pivot Table control.  The 
Pivot Table allows the user to create custom table views quickly, that can be later 
converted to Derived tables for permanent use in SAT.  To select a table on 
which to operate, the user may right click on the small Pivot Table icon in the 
upper right of the main display area.  Since the Pivot Table only operates on Real 
tables and not on Derived tables, only Real tables will be displayed in the popup 
menu.  To manipulate the columns of the table, the user may right click on the 
Pivot Table, and select Field List from the popup menu.  The user may then 
drag table columns from the Field List dialog box into different areas of the Pivot 
Table.  Please refer to the Pivot Table section of the Microsoft Excel User 
Manual for more information about using Pivot Tables. 

Reports 
The user may select the Report view by clicking on Reports in the Go To menu 
of the View menu on the SAT Console, or by double clicking on the Reports icon 
in the shortcut bar. 
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Figure 14 – Report View 

The user may select a report by right clicking on the small Report icon in the 
upper right of the main display area. 

Explorer 
SAT will display the Explorer view any time the user selects a view that displays 
files.  To view the files in the folder in which the currently open database exists, 
the user may select Relates Files in the Go To menu of the View menu on the 
SAT Console, or the user may double click on the Relates Files icon on the SAT 
tab of the shortcut bar.  In addition, the user may double click on any of the icons 
in the Explorer or My Shortcuts tab in the shortcut bar. 
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Figure 15 – Explorer View 

If the user double clicks on a folder in the Explorer view, that folder will be 
opened in its own window.  Please refer to Microsoft Windows Explorer 
documentation for more help on using the Explorer view. 
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5 
Import / Export 

he user may perform an import/export operation by clicking on the Tools 
menu on the SAT Console and selecting the desired import/export 
function.  There are four import/export operations: Taylor Import, Taylor 

Export, CRISP Import, and CRISP Export. 
T 
After the user executes an import/export operation, SAT generates a report.  SAT 
maintains copies of only the last report generated for each operation.  For 
information about how to view these reports, please refer to the Reports section 
in Chapter 4 - Views.  For information about how to set a default report, please 
refer to the General Settings section in Chapter 7 - Options. 

If the user attempts to perform any of the import/export operations without first 
having a database open, then SAT rejects the request. 

Taylor Import 
To perform a Taylor Import, the user may click the Tools menu, and select 
Taylor Import.  SAT will prompt the user for the name of the Taylor (*.fil) file that 
the user wishes to import.  The selected Taylor file may be a file created either by 
an export in SAT or an export in the Taylor software.  By default, SAT will display 
files in the Default Taylor Folder.  For more information about how to set the 
Default Taylor Folder, please refer to the General Settings section in Chapter 7 - 
Options. 
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Figure 16 – Taylor Import File Selection 

SAT will then prompt the user for the name of the drop to which the data will be 
merged.  If data for the specified drop already exists in the database, SAT will 
warn the user that continuing with the import may cause data to be deleted or 
modified. 

 

Figure 17 – Taylor Import Drop Selection 

SAT reads all of the lines in the specified file that are formatted property, and 
imports the data into memory.  SAT then examines the data for errors.  If any 
duplicate registers are found, SAT lists the entries with duplicate registers in the 
Taylor Import Report, marks the status of the import as failed, and aborts the 
import.  If no duplicate registers are found, SAT generates the Taylor Import 
Report, marks the status of the import as passed, and merges the data into the 
currently open database. 

If the specified drop does not already exist in the database, then all entries in the 
specified file are added to the database.  If the drop already exists, then entries 
that exist in the file but not in the database are added to the database, entries 
that exist in the database but not in the file are deleted form the database, and 
entries that exist both in the file and in the database are updated in the database.  
The list of added, deleted, and modified entries are written to the Taylor Import 
Report.  If any of the tag descriptions in the file are blank, these are written to the 
database as “(NULL)”, and these entries are listed in the Taylor Import Report. 
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Figure 18 – Taylor Import Report 

Taylor Export 
To perform a Taylor Export, the user may click the Tools menu and select 
Taylor Export.  SAT will prompt the user for the desired drop to export, and for 
the name of the file to which the exported data will be written.  By default, SAT 
will save the file in the Default Taylor Folder.  For more information about how to 
set the Default Taylor Folder, please refer to the General Settings section in 
Chapter 7 - Options. 

SAT finds all entries in the database for the specified drop and writes them to the 
specified file using the same format that the Taylor software uses for its exported 
files.  SAT generates the Taylor Export Report that contains a view of the data as 
written to the file.  Export files created by SAT may be imported by SAT or by the 
Taylor software. 
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CRISP Import 
To perform a CRISP Import, the user may click the Tools menu and select 
CRISP Import.  SAT will prompt the user for the name of the CRISP file that the 
user wishes to import.  Alternatively, the user may select a CRISP Import Batch 
File that contains the path and filenames of files to be imported.  By default, SAT 
will display files in the Default CRISP Folder.  For more information about how to 
set the Default CRISP Folder, please refer to the General Settings section in 
Chapter 7 - Options. 

SAT imports the data from the specified file into the database and writes the 
results to the CRISP Import Report 

CRISP Export 
To perform a CRISP Export, the user may click the Tools menu and select 
CRISP Export.  SAT will prompt the user for the path in which the exported files 
will be created.  By default, SAT will select the Default CRISP Folder.  For more 
information about how to set the Default CRISP Folder, please refer to the 
General Settings section in Chapter 7 - Options. 

SAT creates several files during the export with extensions “.dat” and “.csv”, and 
writes the results of the export to the CRISP Export Report. 
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Utilities 

he user may access the utilities by clicking the Tools menu, and selecting 
the name of the desired utility.  The user may open the Tools menu from 
the SAT Console menu or from the right-click menu of the task tray faucet 

icon.  Available utilities include: Table Builder, Report Builder, Roles & Users, 
Version Control, and Event Log. 

T 
Table Builder 
The Table Builder utility allows the user to create, delete, and modify table 
names, links, and queries.  The user may open the Table Builder utility by 
clicking on the Tools menu and selecting Table Builder. 

 

Figure 19 – Table Builder 

There are two types of tables: Real and Derived.  Real tables are tables that 
actually exist in the database.  Derived tables are tables that are constructed 
(derived) from data in other tables by an SQL query. 

To delete, rename, or edit a table, the user may select a logical table name from 
the Select Table dropdown list.  If the user selects a Real table, the table’s real 
name (the name of the table in the database) is displayed in the edit field below.  
If the user selects a Derived table, the SQL query that constructs the table is 
displayed in the edit field below. 
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The user may delete the currently selected table by clicking the Delete button.  
Deleting a table simply deletes the logical table.  If the deleted table is a Real 
table, the actual table to which the logical table refers will not be deleted.  In 
other words, deleting a table deletes it from SAT, but not from any database. 

The user may rename the currently selected table by clicking the Rename 
button.  Renaming the table simply changes the logical name of the table.  If the 
renamed table is a Real table, the actual table to which the logical table refers 
will not be renamed.  In other words, renaming a table renames it in SAT, but not 
in any database. 

The user may edit the table type by clicking the Real or the Derived option 
button, and editing the contents of the Real Table Name or Query edit field.  If 
the table is Real, the contents of the edit field must contain the name of a table in 
the database.  If the table is Derived, the contents of the edit field must contain a 
valid SQL query.  If an SQL query is specified for a Real table, or if a table name 
is specified for a Derived table, an error will occur when the user attempts to 
open that table. 

The user may create a new table by clicking on the New button.  Before creating 
a new table, SAT will prompt the user for the logical name of the table.  SAT will 
create a new table with the name specified, of type Derived, and with a blank 
SQL query. 

Report Builder 
The Report Builder utility allows the user to create, delete, and edit custom 
reports fashioned from logical tables.  The user may open the Report Builder 
utility by clicking on the Tools menu and selecting Report Builder. 

 

Figure 20 – Report Builder 

Currently, the Report Builder utility is not implemented. 
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Roles & Users 
The Roles and Users utility allows the user to create, delete, and edit roles and 
users used in the Roles & Users security model.  For more information about 
selecting a security model, please refer to the Security Settings section in 
Chapter 7 - Options.  The user may open the Roles & Users utility by clicking on 
the Tools menu and selecting Roles & Users. 

 

Figure 21 – Roles & Users 

Currently the Roles & Users utility is not implemented. 

Version Control 
The Version Control utility allows the user to review changes made to each 
database, and to role-back to a previous version of a database.  The user may 
open the Version Control utility by clicking on the Tools menu and selecting 
Version Control. 

 

Figure 22 – Version Control 

The Version Control utility displays the contents of the Version Control Journal.  
Whenever the user closes a database, SAT prompts the user to enter an 
annotation to the journal entry that describes the changes that the user made to 
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the database.  This information is recorded in the journal, along with the date and 
time that the database was closed, the user that closed the database, the path 
and filename of the database, the path and filename of the archive file that 
represents the database before any changes were made, and the date and time 
the archive file was created. 

To view the annotation recorded for a given entry in the journal, the user may 
double click on the journal entry, or select the entry in the journal, and click the 
View button. 

 

Figure 23 – View Annotation 

To modify the annotation that was previously entered for a given entry, the user 
may select the desired journal entry and click the Edit button. 

To role-back a database to a previous version, the user may select the journal 
entry that corresponds to the version of the database to be restored, and click the 
Revert button. 

For information about setting options related to Version Control, please refer to 
the Version Control Settings section in Chapter 7 - Options. 
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Event Log 
The Event Log utility allows the user to display the contents of the Event Log.  
The user may open the Event Log utility by clicking on the Tools menu and 
selecting Event Log. 

 

Figure 24 – Event Log 

The information that is recorded about each event includes the date and time in 
which the event occurred, the severity of the event, a short description of the 
event, the event ID, and the name of the user that triggered the event. 

When errors occur, SAT notifies the user with a message box containing a short 
description of the error, and records the error in the Event Log with a severity of 
Error or Fatal Error. 

 

Figure 25 – Error 

To receive more detailed information about the error, the user may open the 
Event Log utility and double click on the related entry.  The Event Details dialog 
will open and display detailed information about the event. 
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Figure 26 – Event Details 

Following is a list of the events that may be recorded to the Event Log. 

List of Events 
ID Severity Description 

101 Note SAT Started 
102 Note SAT Shutdown 
103 Warning General Setting(s) Changed 
104 Warning Event Log Setting(s) Changed 
105 Warning Version Control Setting(s) Changed 
106 Warning Security Setting(s) Changed 
107 Note Database Opened 
108 Note Database Closed 
109 Note Database Saved 
110 Warning Table Added 
111 Warning Table Deleted 
112 Warning Table Modified 
113 Warning Report Added 
114 Warning Report Deleted 
115 Warning Report Modified 
116 Error Error ID and message 
117 Fatal Error Error ID and message 

Figure 27 – List of Events 

The user may select which of theses events are recorded in the Event Log.  For 
information about selecting events, please refer to the Event Log Settings section 
in Chapter 7 - Options. 
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7 
Options 

he user may open the SAT Options dialog by clicking on the Tools menu 
and selecting Options.  From the SAT Options dialog, the user may adjust 
General settings, Event Log settings, Version Control settings, and 

Security settings.  Each computer on which SAT is installed retains a separate 
copy of these settings.  These settings are not user specific; however, only users 
with the required security priviledges can modify these settings. 

T 

 

Figure 28 – Options Dialog 
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General Settings 
The user may view and modify the General settings by selecting the General tab 
in the SAT Options dialog. 

The Default Database specifies the path and filename of the database that SAT 
will automatically load when SAT starts.  If no path and filename is specified, 
then SAT will not load a database when starting.  If the user frequently opens the 
same database each time the user runs SAT, it would be appropriate for the user 
to set that database as the Default Database.  The Default Database is blank by 
default. 

The Default View is the view that SAT displays when the SAT Console is first 
opened.  It is appropriate for the user to set the default view to the most 
commonly used view.  One of the following may be selected as the Default View: 
Data Table, Query Table, Pivot Table, Reports, and Related Files.  By default, 
the Default View is set to Data Table.  For more information about the different 
views, please refer to Chapter 4 - Views. 

The Default Table is the name of the table that SAT first displays when in Data 
Table, Query Table, or Pivot Table view.  It is appropriate for the user to set the 
Default Table to the most frequently used table.  The user may select from a list 
of Real or Derived tables.  Note: If the user selects Pivot Table as the Default 
View, the user should not select a derived table as the default table, because 
pivot tables cannot operate on derived tables.  By default, the Default Table is set 
to ‘Main (Raw)’. 

The Default Report is the name of the report that SAT displays when in Report 
view.  It is appropriate for the user to set the Default Report to the most 
frequently viewed report.  The user may select any of the reports listed.  By 
default, the Default Report is set to ‘I/O Totals’. 

The Taylor Working Folder is the name of the default path used by SAT to import 
and export Taylor files.  It may be appropriate to set this to the Taylor Working 
Folder to the folder used by the Taylor software for importing and exporting.  If no 
path is specified, the Taylor Working Folder is set to the SAT application folder.  
By default, no Taylor Working Folder is specified. 

The CRISP Working Folder is the name of the default path used by SAT to 
import and export CRISP files.  It may be appropriate to set the CRISP Working 
Folder to a folder that shares network access between the PC and VAX.  If no 
path is specified, the CRISP Working Folder is set to the SAT application folder.  
By default, no CRISP Working Folder is specified. 

The VMS Transfer Folder is the path used by SAT to create a copy of the last 
CRISP export file.  It is intended that a VMS script move this file to the VAX 
network, and distribute it to the appropriate VAX station(s).  If no path is 
specified, then SAT will not make a separate copy of the last CRISP export file.  
By default, no VMS Transfer Folder is specified. 

 27



 

Event Log Settings 
The user may view and modify settings related to the Event Log by selecting the 
Event Log tab in the SAT Options dialog. 

The Clear Log at Startup setting instructs SAT to clear the Event Log every time 
SAT is loaded.  This option is useful if the user wishes to record events only for 
the current SAT session.  By default, this setting is disabled. 

The Limit Size of Log File setting forces SAT to keep the Log File from growing 
beyond the specified size.  By default, this setting is disabled. 

The Filename setting specifies the path and filename that SAT uses to record 
events.  If no filename is specified, then SAT does not record events.  SAT reads 
the Filename setting only upon loading, so changes to this setting do not take 
effect until the next time that SAT is started.  By default, events are recording in a 
file named ‘SAT.log’ in the SAT application folder. 

The Record These Events setting specifies which events that SAT records.  By 
default, SAT records all events. 

Version Control Settings 
The user may view and modify settings related to Version Control by selecting 
the Version Control tab in the SAT Options dialog. 

The Journal setting specifies the path and filename of the file used to record 
Version Control information.  If no filename is specified, then SAT does not 
record Version Control information.  By default, Version Control information is 
recorded in a file named ‘SAT.jrn’ in the SAT application folder. 

The Archive Folder setting specifies the folder to which SAT creates archived 
databases.  If no path is specified, then SAT does not create archived databases.  
By default, SAT creates archived databases in the SAT application folder. 

The Compress Archive setting instructs SAT to compress archived databases.  
SAT performs the compression using a single pass PKZip format.  This setting 
will not force SAT to compress already existing archived databases.  Only newly 
created archived databases will be compressed.  Compressed archived 
databases can be unzipped using any standard Zip software.  By default, the 
Compress Archive setting is disabled. 

Security Settings 
The user may view and modify settings related to Security by selecting the 
Security tab in the SAT Options dialog. 

The Security Model setting specifies the type of security that SAT uses to restrict 
access to SAT settings and to restrict access to SAT databases.  There are two 
security models from which to choose: Encryption and User/Role Based. 
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The Encryption model does not place any restrictions on users to modify SAT 
settings or SAT databases, but it does allow SAT users to modify SAT databases 
that would normally not be accessible through other applications such as 
Microsoft Access.  The Encryption based security model is intended to keep 
others from modifying SAT databases from external applications.  When 
implementing this security model, the user must make sure that the password 
supplied in the Password field matches the password used to lock the database 
in Microsoft Access. 

The User/Role Based model is designed to restrict users from modifying SAT 
settings, and from modifying SAT databases from within SAT.  This model uses 
the current Windows or Windows NT username, but this username may be 
overridden by supplying a new username and password in the Username and 
Password fields.  For more information about setting up and using the User/Role 
Based security model, please refer to the Roles & Users section in Chapter 6 - 
Utilities. 

By default, the Security Model setting is set to Encryption.  The default Username 
and Password are blank. 
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