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1 Notes on this Manual
1.1 Validity
This manual is valid for Sunny Explorer from the software version 1.2.

1.2 Target Group
This manual is aimed for users of Sunny Explorer and qualified personnel who are commissioning the 
PV plant with SMA Bluetooth devices.

1.3 Additional Information
Additional information on SMA Solar Technology's Bluetooth® Wireless Technology can be found in 
the download area at www.SMA.de/en.



SMA Solar Technology AG Notes on this Manual

User Manual ExplorerSW12-BEN101412 7

1.4 Symbols Used
The following types of safety instructions and general information appear in this document as 
described below:

1.5 Terminology
In this manual the term "photovoltaic system" will be abbreviated to "PV system"

DANGER!

"DANGER" indicates a hazardous situation which, if not avoided, will result in death or 
serious injury.
WARNING!

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.
CAUTION!

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.
NOTICE!

NOTICE indicates a situation that can result in property damage if not avoided.
Information
Information provides tips that are valuable for the optimal installation and operation of 
your product.

Formatting Meaning
[Save] Buttons are displayed in square brackets [ ].
"Menu1" Menu items are displayed in quotation marks.
"Menu1 > Menu2" Menu paths are given in quotation marks. Individual menus are separated 

by an angle bracket .
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2 Sunny Explorer
2.1 Appropriate Usage
You can visualize and manage data from your Bluetooth PV plant using the Sunny Explorer software. 
You can also configure single devices or entire classes of devices of your PV plant.
The connection to the devices is established via Bluetooth. The computer must be equipped with 
Bluetooth (i.e., via an integrated Bluetooth module or via a USB Bluetooth stick).
Sunny Explorer is a network-forming device (master device). Master devices are communication 
products which create a Bluetooth network, display devices, and collect and analyze device data.
The number of devices which Sunny Explorer can manage depends on the number of master devices 
in the Bluetooth network with the same NetID. Providing that Sunny Explorer is the only master in the 
Bluetooth network, it can manage up to 50 devices. If 2 masters are present in the Bluetooth network 
(e.g. Sunny Explorer and Sunny Beam with Bluetooth), a maximum of 25 devices can be managed 
with Sunny Explorer.
Using the Sunny Explorer, you can change the safety-related parameters of SMA inverters (i.e., SMA 
Grid Guard Parameter). Incorrectly set parameters can damage or destroy the inverter. Do not alter 
these safety-relevant parameters only after prior consultation with your electric power company 
operating the grid into which your plant feeds.
Unauthorized changes to the SMA Grid Guard parameters void the PV plant's operating license.
Do not use the data from Sunny Explorer for billing purposes.
Read the relevant instructions to your Bluetooth devices and use Sunny Explorer only for the purpose 
described in this manual.

2.1.1 Supported Products
Sunny Explorer supports the following SMA product:

• SMA inverters with integrated Bluetooth
– Software package 2.06: SB 3000TL-20 / SB 4000TL-20 / SB 5000TL-20
– SB 2000HF / SB 2500HF / SB 3000HF
– STP 10000TL-10 / STP 12000TL-10 / STP 15000TL-10 / STP 17000TL-10

• SMA inverters with upgraded SMA Bluetooth Piggy-Back from the software version 
02.00.00.R. A list of the supported inverters can be found in the SMA Bluetooth Piggy-Back 
manual.

•  SMA Bluetooth Repeater
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2.1.2 Target Group
Sunny Explorer is intended for private and industrial use. When you log in to Sunny Explorer there 
are 2 user groups at your disposal, "Installer" and "User". The "Installer" user group may only be used 
by qualified personnel who are authorized to make changes to network parameters for the connected 
devices.
Certain parameters are further protected by SMA Grid Guard and can only be altered with the 
appropriate authorization. For further information on SMA Grid Guard please refer to Section 
5.2.2 ”SMA Grid Guard” (page 29).

2.2 Function Overview
The most important Sunny Explorer functions are:

• Wireless control of the PV plant using Bluetooth Wireless Technology
• Supports inverters with Bluetooth from SMA Solar Technology:

– SMA inverters with integrated Bluetooth using software package 2.06 and higher
– SMA inverters with SMA Bluetooth Piggy-Back upgrade. A list of supported inverters can be 

found in the SMA Bluetooth Piggy-Back manual.
• Support of up to 50 devices by 1 master. If 2 masters are present in the Bluetooth network (e.g. 

Sunny Explorer and Sunny Beam with Bluetooth), a maximum of 25 devices can be managed 
with Sunny Explorer.

• Quick overview of PV plant current status.
• Graphic display of key PV plant data
• Configuration of individual devices or of an entire class of devices
• Easy diagnosis due to display of device events
• Secure data transmission with the SMA password concept
• Data export of inverter energy values and events in CSV format
• Graphic display of daily, monthly and yearly energy values for each device
• Support of device updates via Bluetooth

2.2.1 New Functions
The Sunny Explorer software version 1.2 features the following new main functions:

• Graphic display of daily, monthly and yearly energy values for the entire PV plant
• Report function for simpler failure search when service is needed



Sunny Explorer SMA Solar Technology AG

10 ExplorerSW12-BEN101412 User Manual

2.3 System Requirements
Supported operating systems

• Microsoft Windows XP SP2 and higher, Pentium III 800 MHz, 512 MB RAM
• Microsoft Windows Vista (32-Bit and 64-Bit), Pentium IV 1 GHz, 1 GB RAM
• Microsoft Windows 7 (32-Bit and 64-Bit), Pentium IV 1 GHz, 1 GB RAM

Recommended screen resolution:
Minimum: 1024 Pixel x 768 Pixel
Recommended Bluetooth sticks:

• FreeTec Bluetooth Mini-USB adapter; Bluetooth 2.0; Class 1
• Longshine USB Bluetooth Adapter (LCS-8147); Bluetooth 2.0; Class 1

USB Bluetooth sticks manufactured by AVM are not supported.
Supported Bluetooth stacks:

• Microsoft with Service Pack 2 or higher
• Toshiba
• BlueSoleil
• Broadcom

Supported languages:
German, English, Italian, Spanish, French, Greek, Korean, Czech, Portuguese, Dutch

Installing Bluetooth sticks
Install the USB Bluetooth stick directly via Windows. Use the software provided with the 
USB Bluetooth stick only if specifically required.
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3  Installation
3.1 Installation Instructions
In the following sections you will find instructions on how to install Sunny Explorer in Windows XP, 
Windows Vista, and Windows 7. Read the section which is relevant to the operating system of your 
computer. Please note the system requirements in section 2.3 ”System Requirements” (page 10).

3.2 Installing Sunny Explorer in Windows XP

Proceed as follows to install the software in Windows XP.
1. Open the "SunnyExplorerSetup.exe" file.

☑ The language option window opens.
2. Select the desired language for installation. The language of the Sunny Explorer user interface 

can be changed later, as described in Section 5.6 ”Changing Languages” (page 34).
3. Select [OK].

☑ The Sunny Explorer Installation Assistant opens.
4. Follow the "Installation Assistant" instructions.

☑ The installation routine runs.
☑ Sunny Explorer is now installed.

3.3 Installing Sunny Explorer in Windows Vista
Proceed as follows to install the software in Windows Vista.
1. Open the "SunnyExplorerSetup.exe" file.
2. Confirm the Windows Vista security question.

☑ The language option window opens.
3. Select the desired language for installation. The language of the Sunny Explorer user interface 

can be changed later, as described in Section 5.6 ”Changing Languages” (page 34).
4. Select [OK].

☑ The Sunny Explorer Installation Assistant opens.
5. Follow the "Installation Assistant" instructions.

☑ The installation routine runs.
☑ Sunny Explorer is now installed.

Sunny Explorer requires ".NET Framework 2.0"
In the event that .NET Framework version 2.0 or higher is not installed on your computer, 
this will be installed by the Sunny Explorer Installation Assistant. You must have the relevant 
authorization for the installation of .NET Framework onto your computer. If necessary, 
please contact your administrator.
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3.4 Installing Sunny Explorer in Windows 7
Proceed as follows to install the software in Windows 7.
1. Open the "SunnyExplorerSetup.exe" file.
2. Confirm the Windows 7 security question.

☑ The language option window opens.
3. Select the desired language for installation. The language of the Sunny Explorer user interface 

can be changed later, as described in Section 5.6 ”Changing Languages” (page 34).
4. Select [OK].

☑ The Sunny Explorer Installation Assistant opens.
5. Follow the "Installation Assistant" instructions.

☑ The installation routine runs.
☑ Sunny Explorer is now installed.
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4 Commissioning (Installer)
4.1 Information on Commissioning

4.2 Bluetooth PV System
Once you have determined a free NetID for your Bluetooth PV plant and set this up for the devices, 
you can enter a new plant in Sunny Explorer, as described in Section 6.2 ”Setting Up a New Plant in 
Sunny Explorer” (page 36).
If you have not yet determined a free NetID for your Bluetooth PV system, please read Section 
4.2.1 ”Determining a Free NetID” (page 13).

4.2.1 Determining a Free NetID

All devices must be set to the same NetID so that the SMA Bluetooth devices in a PV plant can 
communicate with each other. PV systems with SMA Bluetooth operating in close proximity to one 
another are distinguished by their individual NetID.
To make sure that you do not set up a NetID which is already used by another Bluetooth PV system 
in the vicinity, you need to determine a free NetID prior to commissioning your Bluetooth PV system.
You can determine a free NetID with the following mobile devices:

• Laptop with Bluetooth and Sunny Explorer
• Sunny Beam with Bluetooth

If you are using the Sunny Beam with Bluetooth to determine a free NetID, please refer to the 
user manual of the Sunny Beam with Bluetooth.

Commissioning of a Bluetooth PV plant always with 1 master only
Never commission a Bluetooth PV plant with more than 1 master (e.g. Sunny Explorer, 
Sunny Beam with Bluetooth) As soon as the Bluetooth network is up and running, you can 
introduce further masters into the Bluetooth network.

The Bluetooth devices of your PV system must be turned off.
In order to determine a free NetID, all the inverters and SMA Bluetooth repeaters in your 
system must be switched off.
There is no need to determine a free NetID for Bluetooth PV plants with Sunny 
Explorer and a single inverter.
You may leave the default NetID set to 1 in your inverter if your Bluetooth PV plant consists 
of the following products: 

• 1 inverter
• Up to 2 computers with Bluetooth and Sunny Explorer software

If you are using an SMA Bluetooth Repeater or a Sunny Beam with Bluetooth, you must 
determine a free NetID.



Commissioning (Installer) SMA Solar Technology AG

14 ExplorerSW12-BEN101412 User Manual

Determining a free NetID with a Laptop and Sunny Explorer
Proceed as follows to determine a free NetID using a Bluetooth-enabled laptop and Sunny Explorer. 
1. Switch off inverters and any SMA Bluetooth repeaters which may be present.
2. Position the laptop near a Bluetooth device of your PV plant.
3. Start Bluetooth on your laptop.
4. Start Sunny Explorer.

or
In the menu bar of the Sunny Explorer select "File > New ..." and in the plant assistant choose 
"Enter a new plant".

5. Enter the desired name for the plant in the "Plant Name:" field. This name can be freely selected 
and will be used as the file name for the plant data.

6. Click on the [...] button in the "Directory:" field to configure another directory in which the plant 
file will be saved.

7. Select [Next].
☑ The system search will begin.
☑ The NetIDs of the Bluetooth PV plants detected 

within wireless range are displayed in the field 
"Plants found" (e.g. NetID 4 and NetID A). All 
the NetIDs listed here are reserved and cannot 
be used.

8. Repeat the plant search sequence for each 
Bluetooth device of the PV system, and also run the 
sequence at the actual location of the computer 
with Sunny Explorer. In larger-scale PV plants, it is sufficient to carry out the plant search just on 
the devices which are located on the periphery of the plant. There is no need to run the system 
search on devices which are surrounded by other devices.
Select [Repeat search].
Newly found Bluetooth PV plants are added to the list of "Plants found" and do not need to be 
noted.
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9. When the plant search routine has been run on each device, choose a NetID which is not yet 
reserved (e.g., NetID E in the figure).

Please refer to the following table for a list of possible NetIDs and their functions:

☑ The free NetID is determined.
Commissioning of the Bluetooth PV System can now take place, as described in Section 
4.2.2 ”Commissioning a Bluetooth PV System” (page 16).

NetID Allocation
NetID Function Display in Sunny Explorer
0 Bluetooth is switched off.
1 Bluetooth is switched on. The device can 

link with a maximum of 2 SMA Solar 
Technology communication products 
with NetID set to 1.

Devices with NetID 1 are 
listed separately under 
"Plants found".

2, 3, 4, 5, 6, 7, 
8, 9, A, B, C, D, 
E, F

Bluetooth is switched on. The device can 
link with Bluetooth devices with the same 
NetID.

All devices with identical 
NetID will be displayed in 
the "Plants found" list under 
the plus symbol [+] of the 
relevant NetID. 
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4.2.2 Commissioning a Bluetooth PV System
1. Set the NetID on the inverters and available SMA Bluetooth Repeaters, as described in the 

respective manual.
2. Commission the inverters and available SMA Bluetooth Repeaters as described in the 

respective manual.
☑ Commissioning of the Bluetooth PV system is now complete.

Now you can connect to your Bluetooth PV plant with Sunny Explorer, as described in Section 
4.2.3 ”Connecting to Your Bluetooth PV Plant” (page 16).

4.2.3 Connecting to Your Bluetooth PV Plant
1. In Sunny Explorer, select [Repeat search].

☑ The system search will begin.
☑ Sunny Explorer searches for all Bluetooth PV plants within wireless range and lists the NetIDs 

of the Bluetooth PV plants detected in the field "Plants found".
– If Sunny Explorer does not list the NetID of your Bluetooth PV plant, please refer to section 

10 ”Failure Search” (page 48).
Selecting point of access
The device (access point) through which Sunny Explorer will connect to the entire Bluetooth PV plant 
can either be specified by you or selected automatically by Sunny Explorer. If you are not sure which 
option to choose, select the NetID of your PV plant.
2. Selecting point of access:

– Automatic: : For Sunny Explorer to select the 
access point automatically, select the NetID of 
your PV plant.

– Specific device: when Sunny Explorer should 
use a specific device as the point of access, 
select the serial number of the device from the 
list under the NetID of your PV plant.

3. Select [Next].
☑ The connection to the PV plant is established 

and the login window opens.
4. Select the user group in the "User group" field. The "Installer" user group can only be used by 

qualified personnel who are familiar with setting security-relevant parameters of PV plants.
5. In the "Plant password" field, enter the password belonging to the user group selected.
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6. Select [Next].
☑ Sunny Explorer will now establish the connection to all devices with the selected NetID.
☑ The Sunny Explorer user interface opens in the screen option of the chosen user group.

☑ The connection to your Bluetooth PV plant is now established.
NOTICE!
Unauthorized access to your PV plant

The system password protects your PV system from unauthorized access to your devices. 
• After initial login to a new plant, the standard password for both user groups (User/

Installer) should be changed.



Sunny Explorer Basics SMA Solar Technology AG

18 ExplorerSW12-BEN101412 User Manual

5 Sunny Explorer Basics
5.1 User Interface
The user interface permits quick access to all important information about the PV plant and its devices.

Position Description Meaning
A Menu bar The basic functions of Sunny Explorer can be controlled with the 

menu bar.
B Icon bar The icon bar gives you quick access to Sunny Explorer's main 

functions.
C Plant tree In the plant tree, all devices in a PV plant are represented as a tree 

structure. 
D Device menu The device menu enables you to retrieve information and 

undertake the configuration of devices selected in the plant tree.
E Contents section The contents section shows the actual contents. The contents are 

determined by the device menu.
F Status bar The status bar displays the current software status. Here, you will 

find the user group currently logged in, the software version and 
the connectivity status of your plant.
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5.1.1 Menu bar
The menu bar contains the following items:
Menu item Entries Meaning
File New... This item enables you to enter a new plant in 

Sunny Explorer.
Open... This item opens a file choice dialog box which 

allows you to load an existing plant into Sunny 
Explorer.

Last used This item opens a sub-menu displaying the last 10 
plants which have been opened in Sunny 
Explorer.

Exit This item allows you to quit Sunny Explorer. 
Options Language The program language may be set via this item.

Change user group... This item opens the log-in dialog with which you 
can change the user group.

SMA Grid Guard® ... This item opens the "SMA Grid Guard" dialog. 
You can enter your personal access code for 
SMA Grid Guard here. 
This item is visible to the "Installer" user group 
only.

Set plant time... This item opens the "Plant time" dialog. Here you 
can set the plant time.

Repeat establishment of 
connection

This item enables you to re-establish a (lost) 
connection to the devices of your PV plant which 
has been interrupted.

Extras Export data... This item opens the "Data export" dialog. Here 
you can export the data of the devices.

Device update This item opens the "Device update" dialog. This 
enables you to carry out updates on the devices 
of your PV plant.

Help Contents Here you can open the Sunny Explorer program 
help.

Generate report... This entry enables you to generate a report.
Licensing agreements This item opens the Sunny Explorer licensing 

agreements in a small dialog window
Info This item gives you information on the present 

software installation in a small dialog window.
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5.1.2 Icon Bar
The icon bar gives you quick access to Sunny Explorer's main functions.

5.1.3 Plant Tree
From the plant communication perspective, a PV plant is made up of several devices which are 
connected to each other via the same communication type (e.g. SMA Bluetooth).
View of a Bluetooth plant

In Sunny Explorer the physical structure of the plant (A) is represented by means of the plant tree. In 
addition, all devices in a plant (including Sunny Explorer) are displayed underneath the plant name 
(B). The plant is generated by Sunny Explorer from a plant communication perspective.
The plant tree in Sunny Explorer
In general, a distinction is made between the Plant View 
(B) and the Device View (C).

• See Section 6 ”Plant View” (page 36).
• See Section 7 ”Device View” (page 41).

Symbol Meaning
The "Settings" button opens the Sunny Explorer configurations. The Sunny Explorer 
settings can also be adjusted via the plant tree "Sunny Explorer" / "Settings".

The "Help" button opens the Sunny Explorer program help.
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5.1.4 Device Menu
The device menu shows the setting options and spot values of a given device. The device must first be 
selected in the plant tree. The menu items change according to the device selected.

Tabs Meaning
Overview The overview page provides information about the devices or plants 

selected in the plant tree. Here you will find a short overview of the key 
device data, as well as the actual status display. 

Spot values The spot values provide current data about the selected device depending 
on the particular user group.

Settings Depending on your user group, you can use the settings option to look at 
and adjust various parameters. 

Events The events page displays the events that have occurred in a device. The 
events displayed depend on your user group.
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5.1.5 Overview
The page "Overview" displays the key data of the entire PV plant or of a particular device.
Device view
When a device has been selected in the plant tree, the overview page provides a summary of the 
most important values for that device. 
When a inverter is selected in the plant tree, the yield and output values of that device are also 
displayed in diagrams on the overview page. There are 4 diagrams which you can access via the 
following tabs:

Click the mouse on a point of the graph to call up a display. 
The display shows the precise value at that particular point 
as well as the time and date.
Scroll down to the next time period using the arrows. Use 
the calendar symbol to directly select a time.
Plant view
When a plant is selected in the plant tree, the overview 
page provides a summary of the most important values for the entire PV plant.
The yield and output values of the entire PV plant (all inverters) are also displayed in diagrams. There 
are 4 diagrams that can be accessed via the following tabs:

You can access detailed information similar to the diagrams on the device overview using the mouse.

Tabs Meaning
Day Displays the device output during the course of a day.
Month Displays the daily yield of the device over one month.
Year Displays the monthly yield of the device over one year.
Total Displays the annual yield of the device over the last 10 years.

Tabs Meaning
Day Displays the total output of the PV plant during the course of a day.
Month Displays the daily yield of the PV plant during the course of a month.
Year Displays the monthly yield of the PV plant during the course of a year.
Total Displays the annual yield of the PV plant over the last 10 years.
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5.1.6 Spot Values
The "Spot Values" page displays all spot values of the device or plant selected in the plant tree. The 
specific user group determines which values are displayed. All values are collected into groups 
(parameter groups) and subgroups.
Device view
When a device is selected in the plant tree, the "Spot Values" page displays the values for that 
particular device.
Plant view
When a plant is selected in the plant tree, the "Spot Values" page displays the values for entire device 
classes. When you click on the parameter group, the device classes are displayed separately (e.g., 
solar inverters and communication products).
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Certain values from the individual devices in a device class are combined (e.g., total power (A)).

Depending on the type of value, a meaningful aggregate for the device class is displayed:

The aggregate value can be opened to reveal additional information.

Symbol Meaning
Total

Average value

e.g., 20 .. 50 °C Smallest and greatest value

Position Meaning
B Lowest power value of the 10 devices
C Greatest power value of the 10 devices
D Sum of power values of the 10 devices
E Mean power for the 10 devices.
F Number of devices in the device class.
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5.1.7 Settings
All parameters of the device or plant selected in the plant tree are displayed in the device menu 
"Settings". The display of specific parameters depends on the particular user group. All parameters 
are summarized in groups (parameter groups) and subgroups.
Device view
When a device is selected in the plant tree, you can modify the parameters of that device on the 
"Settings" page.
Plant view
If you have selected the plant in the plant tree, you can modify the parameters for the entire device 
class on the "Settings" page. All devices in the device class are then set to the new parameter value. 
When you click on the parameter group, the device classes are displayed separately (e.g., solar 
inverters and communication products).
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If different values are set for devices in the same device class, this is indicated in editing mode by an 
empty field (A). 
The different options are shown in selection menus. The number of devices set to each option is shown 
in brackets. See (B) and (C). Select and save one option to set all devices in the device class to this 
value.

With text fields, an empty field will appear in which you should enter the new value for all devices.

5.1.8 Events
Sunny Explorer can display the events which have occurred in individual devices. Sunny Explorer 
retrieves the event list directly from the devices.

Position Meaning
A Filter for event categories
B Filter for the time period of the events displayed
C Priority of event
D Type of event
E Event in clear text and event number in brackets
F Group of parameters involved (parameter group)
G Date on which the event occurred
H Time at which the event occurred
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Priority of events
The event priorities are as follows:

Types of event
There are 3 different types of event which will be displayed in Sunny Explorer by symbols.

• Information
• Warning
• Error

Symbols and meaning of event types
Events can have 3 different statuses:

• Incoming: the event is occurring
• In progress: the event has existed for some time and could not yet be automatically remedied.
• Outgoing: the event has come to an end.

Symbol Meaning
This type of event can only be remedied by intervention of the installer at the device. 
Please contact your installer and advise the device serial number and the event number.
Please contact your installer with the device serial number and the event number.

Symbol Meaning
Error

Error incoming

Error outgoing

Warning

Warning in progress

Warning outgoing

Information

Information incoming

Information outgoing
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5.2 User Groups and Security Concept
SMA Solar Technology provides a comprehensive security concept that protects your PV plant from 
unauthorized access. 

• Securing the PV plant by means of a plant password for the respective user group (user/
installer).

• Controlled access via SMA Grid Guard

5.2.1 Basics
As a rule, SMA Solar Technology distinguishes between two user groups: users and installers. 
Installers can also undertake additional settings on devices after entering the SMA Grid Guard code. 
The user groups have the following rights:

Plant password
The plant password for the respective user group is the same for all devices in a plant. After logging 
in with the plant password (user/installer), you can simultaneously configure more than one device 
at your plant. If the device password is not the same as the plant password, for example in the case 
of a new device in an existing plant, the device is depicted with a lock in the plant tree.

User group Right
User This user group allows the user to read all display-relevant 

information, such as spot values and parameter settings. Function-
sensitive settings can not be modified.
The user can freely select the plant password for the "User" user 
group. 

Installer Inn addition to the rights available to users, this user group may 
also set or change plant parameters that affect functionality. 
In addition, this user group may reset the user's plant password, 
and may undertake additional settings to devices after entering the 
SMA Grid Guard code.

Installer with SMA Grid Guard 
rights

The installer can change SMA Grid Guard parameters for devices

Unauthorized access to your PV plant
The plant password protects your plant from unauthorized access to the plant devices. 

• After initial login to a new plant, the standard password for both user groups (User/
Installer) should be changed.

System password at delivery
All devices are delivered with the user password: 0000 and the installer password: 1111.
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5.2.2 SMA Grid Guard
SMA Grid Guard is a security concept for country-specific settings in the inverter, which determine the 
network behavior within a grid system. These settings (Grid Guard parameters) are pre-installed in the 
devices and can only be configured with the SMA Grid Guard password.
In order to change SMA Grid Guard parameters, you will need to be logged in as an installer and 
you will need your personal SMA Grid Guard password, which you can obtain from SMA Solar 
Technology. The application form for the personal access code is located in the download area at 
www.SMA.de/en, in the "Data sheet" category for each inverter.

5.2.3 Change User Group
The user group can be changed by following these steps:
1. Select "Options > Change user groups ..." in the menu bar.

☑ The login dialog will open.
2. In the "User group" field, select the user group you wish to log in to.
3. In the "Plant password" field, enter the appropriate password for the user group you have 

selected.
4. Select [Next].
☑ You have now changed the user groups.
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5.2.4 Lost Password
If you have lost your password, you can unlock the device using a Personal Unlocking Key (PUK). 
You can obtain a PUK for the User/Installer user group from the SMA service line. 

5.2.5 Password Quality
Check the quality of your password, and change it if necessary. In order to increase the security of 
your password, please note the following points when selecting a password:

• Use passwords with a minimum length of 8 characters. The longer the password, the more 
secure it is. A maximum of 12 characters are possible. Blank passwords are not permitted.

• Do not use names or terms from dictionaries (e.g dog, cat, house).
• Do not use data related to your person as passwords (e.g. names of persons or pets, personal 

or ID numbers, car license plates).
• Do not repeat names or terms (e.g househouse, catcat).
• Use a combination of upper and lower case letters, special characters and numbers. The 

following special characters are permitted:   ? _ ! - .
• Do not use number and letter combinations which are consecutive on a keyboard (e.g. 12345, 

qwerty).

Unauthorized access to your PV plant
The plant password protects your plant from unauthorized access to the plant devices. 

• After initial login to a new plant, the standard password for both user groups (User/
Installer) should be changed.

Plant password at delivery
All devices are delivered with the user password: 0000 and the installer password: 1111.
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5.3 Symbols
Symbols for access rights
The individual devices are depicted with a symbol for the access right in the plant tree. If no symbol 
is displayed after a device, you have access rights to the device that correspond to the user group 
which is logged in.

Device symbols
Device symbols are displayed in the plant tree and on the device's overview page. Devices will have 
a specific status, which is displayed by a symbol.

Symbol Meaning
You do not have access to the device. The device password differs from the current plant 
password.
You are authorized to change the SMA Grid Guard parameters.

Symbol Meaning
Plant

Sunny Explorer

Inverter

Unknown inverter

Unknown device

Sunny SensorBox with SMA Power Injector with Bluetooth®

SMA Bluetooth® Repeater



Sunny Explorer Basics SMA Solar Technology AG

32 ExplorerSW12-BEN101412 User Manual

Group symbols for spot values and settings
Group symbols are used for specific parameter groups.
Symbol Meaning

Status
General values that describe the status of the device. The status of other components in 
the device (e.g., modems) are not listed here.
Type plate
All values that describe the device/the plant.

Device
Values which apply to the device directly and which do not fall into any of the special 
categories (e.g., DC side, AC side, plant communication, etc.).
User rights
All values that affect the access protection for the device.
DC side
Values affecting the DC side of the device (e.g. PV modules).
AC side
Values affecting the grid side of the device.

Grid monitoring
Includes parameters that affect the grid and which in part are protected by the personal 
SMA Grid Guard password.
Plant and device control
Includes parameters for devices that must fulfill special requirements for feeding into the 
medium voltage level. The parameters are protected by the personal SMA Grid Guard 
password.
Plant communication
All values which define communication between communication devices and the plant.

Data recording
All values that affect data recording for the device (storage location, storage intervals, 
storage format).
Device components
Includes parameters and measured values relating to the components of a device. This 
group is a kind of "expanded type plate". For example, it files the version numbers of 
the system components.
Meteorology
Includes all measured values of the connected sensors (e.g., temperature, irradiation, 
wind speed).
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Other symbols
Symbol Meaning

Bluetooth plant

Bluetooth device with NetID 1

Hour glass
The hour glass displays when values are being saved in a device.
Average value
The average number refers to an average value.

Total
The total number displays the summed values.

Maximum
Displays the maximum of a value.
Minimum
Displays the minimum of a value.

Updating
This symbol indicates that data is being uploaded from the device.

Alarm
The alarm symbol indicates that values are more than 30 minutes old.

Calendar function
Opens a calendar for selecting a date, a start date, or an end date.
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5.4 Start Sunny Explorer
To start Sunny Explorer, proceed as follows:
1. On the computer, open the file "SunnyExplorer.exe".

☑ The plant assistant opens.
☑ Sunny Explorer starts.

If you have already entered a plant in Sunny Explorer, you can now open it as described in Section 
6.3 ”Open Existing Plant” (page 38).
If you have not yet entered a plant in Sunny Explorer, you can now enter a new plant as described 
in Section 6.2 ”Setting Up a New Plant in Sunny Explorer” (page 36).

5.5 Quit Sunny Explorer
To quit Sunny Explorer, proceed as follows:
1. In the menu bar, select "File > Exit".
☑ This quits Sunny Explorer.

5.6 Changing Languages
To change the language of the Sunny Explorer user interface, proceed as follows:
1. Select "Options > Language" in the menu bar.
2. Select the desired language.
☑ The language has been changed.
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5.7 Command Line Parameters
You can start Sunny Explorer via the command line and store collected plant data on the computer if 
desired. 
After starting, Sunny Explorer collects the PV plant data and stores them in CSV files in the selected 
directory. Use the following parameters:

Example: Command to download events in the time period from 04/06/2010 to 04/08/2010 of 
the existing pv plant "My PV plant 1.sxp“:
C:\Programs\SMA\Sunny Explorer\SunnyExplorer.exe c:\My“PV plant“1.sxp -userlevel Installer -
password 1111 -exportdir c:\SMA -exportrange 20100406-20100408 -export energy5min

5.8 Generate Report
You can generate a report that the SMA service line may use for troubleshooting. The report file is 
stored in ZIP format in the selected directory, and contains information about your PV plant. No access 
data is stored in the report.

1. Select "Help > Generate report..." in the main menu of Sunny Explorer.
☑ The "Generate report" dialog opens.

2. Select the directory via the button [...] in the "Save in" field.
3. Enter a precise description of the error or other information in the "Comment" field.
4. To add the entire object database to the report file, activate "Export full object database".
5. Select [OK].
☑ The report file is stored in the selected directory.

Parameters Meaning
--userlevel [User|Installer] Login with the corresponding user group but in 

conjunction with the relevant password.
--password [Password] Login with the corresponding password, but in 

conjunction with the relevant user group.
--exportdir [Directory name] Indicates the director in which the files are to be 

saved.
--exportrange [YYYYMMDD]-[YYYYMMDD] Indicates the date range for which the files are to 

be saved.
--export [energy5min|energydaily|events] Indicates which data is to be saved.
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6 Plant View
6.1 Plant Status

6.2 Setting Up a New Plant in Sunny Explorer
This section describes how to enter a new plant in Sunny Explorer if you have already determined a 
free NetID for your Bluetooth PV plant and set this up for the devices.
1. Select "Enter a new plant" in the plant assistant.

or
In the menu bar of Sunny Explorer, select "File > New ..." and in the plant assistant choose "Enter 
a new plant".

2. Enter the desired name for the plant in the "Plant name:" field. This name can be freely selected 
and will be used as the file name for the plant data.

3. To configure a different directory in which the plant file will be saved, click on the [...] button in 
the "Directory:" field.

4. Select [Next].
☑ The system search will begin.
☑ Sunny Explorer searches for all Bluetooth PV plants within wireless range and lists the NetIDs 

of the Bluetooth PV plants detected in the field "Plants found".
– If Sunny Explorer does not list the NetID of your Bluetooth PV plant, please refer to section 

10 ”Failure Search” (page 48).

Symbol Status Meaning
Neutral The status of the plant is unknown and is currently being updated.

OK All plant devices are operating without error.

Warning At least one device in the plant is displaying the "Warning" status. No 
device is displaying the "Error" status.

Error At least one device in the plant is displaying the "Error" status.
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Selecting point of access
The device (access point) through which Sunny Explorer will connect to the entire Bluetooth PV plant 
can either be specified by you or selected automatically by Sunny Explorer. If you are not sure which 
option to choose, select the NetID of your PV plant.
5. Selecting point of access:

– Automatic: select the NetID of your PV plant if 
you want Sunny Explorer to select the access 
point automatically.

– Specific device: when Sunny Explorer should 
use a specific device as the point of access, 
select the serial number of the device from the 
list under the NetID of your PV plant.

6. Select [Next].
☑ The connection to your PV plant is established and the login window opens.

7. Select the user group in the "User group" field. The "Installer" user group can only be used by 
qualified personnel who are familiar with setting security-relevant parameters of PV plants.

8. In the "Plant password" field, enter the password belonging to the selected user group that has 
been input for the devices.

9. Select [Next].
☑ Sunny Explorer will now establish the connection to all devices with the selected NetID.
☑ The Sunny Explorer user interface opens in the screen option of the chosen user group.

☑ The connection to your Bluetooth PV plant is now established. A new plant has been set up in 
Sunny Explorer.

NOTICE!
Unauthorized access to your PV plant

The system password protects your PV system from unauthorized access to your devices. 
• After initial login to a new plant, the standard password for both user groups (User/

Installer) should be changed.
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6.3 Open Existing Plant
Your settings for a plant are stored in a plant file on your computer. If you have already entered a 
plant in Sunny Explorer and filed it on your computer, you can reload this file. Proceed as follows:
1. Select "Open an existing plant" in the plant assistant.

or
In the menu bar, select "File > Open".

2. Select the desired plant file.
☑ The login dialog will open.

3. In the "User group" field, select the user group under which you wish to log in.
4. In the "Plant password" field, enter the appropriate password for the user group you have 

selected.
5. Select [Next].
☑ The selected plant is opened in the selected user group.

6.4 Change Plant Name
The plant name is assigned via the settings in Sunny Explorer. The plant name is identical for all user 
groups.

To change the plant name, proceed as follows:
1. Select "Sunny Explorer" in the plant tree and "Settings" in the device menu.

or
Select "Settings" on the icon bar. 

2. Select the "Type plate" parameter group.
3. Select [Edit].
4. In the "Plant name" field, enter the name you have selected for your plant.
5. Select [Save].
☑ The plant name has been changed, and is displayed in the plant tree.
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6.5 Set Parameters for a Device Class
A device class refers to devices of the same type. You can configure all the devices in a device class 
simultaneously. It is not possible to configure different device classes simultaneously. Save the 
changes made to one device class before processing another device class.
To configure all the devices in a device class, proceed as follows:
1. Select the plant in the plant tree.
2. Select "Settings" in the device menu.

☑ The parameter groups for the entire plant are displayed.
3. Select the parameter group that contains the parameter which is to be configured.

☑ The individual device classes are listed. It may take a moment for all the data to be read from 
the devices.

4. Select [Edit] below the relevant device class.
5. Change the desired parameters.
6. Select [Save].

☑ The settings will apply to all devices in the device class.

☑ The parameters for a device class have been set.

6.6 Change Plant Password
In order to ensure full password protection, you must allocate a plant password for every user group 
(User / Installer). Change the standard plant password after the initial startup.

1. Select the plant in the plant tree.
2. Select "Settings" in the device menu.
3. Select the "User rights (all devices)" parameter group. 
4. Select [Edit].
5. Change the password.

Saving of data when parameters are adjusted
An hour glass displays the saving process. After the changes have been saved in Sunny 
Explorer, the data is transmitted to the device. The setting process can sometimes take 
several hours if the device (e.g., an inverter) is in night mode. When the device is started, 
the data is transmitted to the main memory, and the hour glass is no longer displayed.

Permitted password characters and length
The password can be a maximum of 12 characters. The following special characters are 
permitted:   ? _ ! - . Blank passwords are not permitted.
Requirements for a secure password
Obtaining a secure password is described in Section 5.2.5 ”Password Quality” 
(page 30).



Plant View SMA Solar Technology AG

40 ExplorerSW12-BEN101412 User Manual

6. Select [Save].
☑ The plant password will be changed for all devices in the plant for which you have rights.

☑ The plant password is changed.

6.7 Change Plant Time
The plant time refers to the date and time entered for a PV plant.
When commissioning your PV plant with a communication product (e.g., Sunny Explorer, Sunny Beam 
with Bluetooth), the devices of the PV plant automatically assume the plant time of the communication 
product. When additional communication products are added to the PV plant, the new 
communication products automatically assume the existing plant time. All devices in the PV plant will 
thus display the same plant time.
You will only need to change the plant time in Sunny Explorer if it is not correct. When changing the 
plant time in a communication product, all inverters immediately apply the new plant time. Additional 
communication products in the plant apply the plant time only after some time (7 hours max. later).

To change the plant time of all devices in the PV plant, proceed as follows:
1. In the menu bar, select "Options > Set plant time".

☑ The "Plant time" dialog opens.
2. Select the current date in the "Date" field.
3. Select the current time in the "Time" field.

By activating "Daylight saving time" an hour will be added to the normal time (UTC + time zone).
4. Select the time zone in which the system is located in the "Time zone" field.
5. Select [OK].
☑ The plant time is set.

You can synchronize the plant time with the current time of your computer via the [Apply operating 
system time] button.
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7 Device View
7.1 Device Status
The device has a specific status. The status is displayed via the symbols in the plant tree and on the 
device's overview page.

7.2 Set Device Parameters
You can configure a device via its parameters. Setting parameters for a device is dependent on the 
user group.
To change device parameters, proceed as follows:
1. Select the corresponding device in the plant tree.
2. Select "Settings" in the device menu.

☑ The existing parameter groups for the device are displayed.
3. Select the parameter group that contains the desired parameter.

☑ Reading the values may take a moment because the values are queried directly from the 
device.

4. Select [Edit].
5. Change desired parameter.
6. Select [Save].
☑ The device parameter is set.

Symbol Status Meaning
Neutral The status of the device is currently being updated.

OK The device is ready for operation and is operating without 
error.

Warning The device is not operating properly. It may be possible to 
automatically remedy the error.

Error The device is in error condition. There is a problem with the 
device. Check the device.

Communications fault The device can not communicate at present. This may happen 
at night, for example, when the inverter is not operating.

Saving of data when parameters are adjusted
An hour glass displays the saving process. After the changes have been saved in Sunny 
Explorer, the data is transmitted to the device. The setting process can sometimes take 
several hours if the device (e.g., an inverter) is in night mode. When the device is started, 
the data is transmitted to the main memory, and the hour glass disappears.
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7.3 Entering SMA Grid Guard Code

You can configure the SMA Grid Guard parameters for devices. To do this, proceed as follows:
1. In the menu bar, select "Options > SMA Grid Guard® ..."

☑ This opens SMA Grid Guard dialog.
2. Enter your password in the "Individual access code" field. You can obtain the password from 

SMA Solar Technology.
3. Select [Next].
☑ The SMA Grid Guard code is set. 

The devices that can be processed in SMA Grid Guard mode are identified with the Grid Guard 
symbol: 
Exit Grid Guard mode
To exit Grid Guard mode, you must close Sunny Explorer. Proceed as follows:
1. Select "File > Exit".
☑ Sunny Explorer will exit the SMA Grid Guard mode.

7.4 Changing the Device Name

You may change the device name for a device. Proceed as follows:
1. Select the device in the plant tree.
2. Select "Settings" in the device menu.
3. Select the "Type plate" parameter group.
4. Select [Edit].
5. Enter the desired name in the "Device name" field.
6. Select [Save].
☑ The new name is saved in the device.

DANGER!
Danger to life through changing the inverter's internal safety specifications.

Unauthorized changes to the SMA Grid Guard parameters cause the operating license to 
become void.

• Only change SMA Grid Guard parameters with express permission of the utility 
operator.

24 characters for the device name
A maximum of 24 characters are permitted for the device name.
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7.5 Add Device
To add a new device to your Bluetooth PV plant, proceed as follows:
1. Set your Bluetooth PV plant NetID on your new device as described in the device manual.
2. Start up the new device by following the instructions for that device.
3. Depending on whether or not the new device has the same plant password as your Bluetooth 

PV plant, proceed as follows:

☑ The device is displayed without a lock in the plant tree. The device has been added to your 
plant.

7.6 Delete Device
In order to ensure that a device is no longer displayed in Sunny Explorer, for plant communication 
purposes you must delete it from the PV plant. Proceed as follows:
1. Set Bluetooth device to a different NetID as described in the manual for the respective device.
2. In Sunny Explorer, select "Options > Change user groups ..." and log in again.
☑ The device is no longer listed in the plant tree.

7.7 Setting the Device Password to the Plant Password
If the password of a device is different from the plant password, the device will be displayed with a 
lock in the plant tree. This may occur, for example, when a new device is added to an existing plant. 
To set the new device to the plant password, proceed as follows:
1. Enter a new plant in Sunny Explorer, as described in Section 6.2 ”Setting Up a New Plant in 

Sunny Explorer” (page 36), and log in with the plant password of the new device.
You can uninstall the plant later and use your usual plant in Sunny Explorer.

2. Select the plant in the plant tree.
3. Select "Settings" in the device menu.
4. Select the "User rights (all devices)" parameter group.

☑ The parameter group is opened. 
5. Enter the plant password of your existing plant for the corresponding user group. If you are 

logged in as an installer, you can also change the password for the "user" user group if you 
know that password.

If Then
The new device has a different plant 
password than your Bluetooth PV plant.

• Set your Bluetooth PV plant password as 
your new device password as described in 
Section 7.7 ”Setting the Device Password 
to the Plant Password” (page 43).

The new device has the same plant 
password as your Bluetooth PV plant.

• Open your plant in Sunny Explorer and log 
in as usual using the plant password of your 
Bluetooth PV plant.
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6. Select [Save].
☑ The settings are saved to the new devices.

7. Open your usual plant in Sunny Explorer and log in using the plant password of your Bluetooth 
PV plant.

☑ The device is displayed without a lock in the plant tree. The device password is set to the plant 
password.

7.8 Updating a Device
You can update the devices of your PV plant using Sunny Explorer. The update file is located in the 
download area of www.SMA.de/en.
1. Download the update file from the download area of www.SMA.de/en, and save the file to 

your computer.
2. In the main menu of Sunny Explorer, select "Tools > Device update...".

☑ This opens the "Device update" dialog.
3. In the "Update file" field click on the [ ... ] button.

☑ The window to select the file on the computer opens.
4. Select update file.
5. Select [Open].

☑ Sunny Explorer displays that the update file has been saved successfully, and displays 
information about the update file.

6. Select [Next].
☑ The update dialog will open. The update starts.

☑ The device update is complete.
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8 Exporting Data
8.1 Save System Data on the Computer
With Sunny Explorer, you can save your PV plant's yields and events on your computer. The data is 
saved in CSV files.

To save the system data to the computer, proceed as follows:
1. In the menu bar of Sunny Explorer, select "Tools > Export data...".

☑ This opens the "Data export" dialog.
2. Select the files you wish to save. The following options are available for selection:

3. In the field "from:" and "to:", select the time period for which the data is to be recorded.
4. In the field "Directory:", click on the [ ... ] button.
5. Select the directory where you wish to save the files.
6. Select [Next].

☑ Sunny Explorer reads the data from the devices and generates the files.
7. Select [Next].
☑ The system data is now saved on the computer.

Existing files with plant data will be overwritten
If the selected directory already contains files with plant data Sunny Explorer will overwrite 
the files. This ensures that the data in the files is always complete and up-to-date.

Selection Generated file Meaning
Daily files Daily file with the total yield 

of the PV plant
A file is saved for each day in the selected time 
frame.
The file contains the total yield of the PV plant, 
which is saved every 5 minutes from the inverters.

Monthly files Monthly file with daily yields 
of the PV plant.

A file is saved for each month in the selected time 
frame.
The file contains the daily yields of the PV plant.

Events File with PV plant events A file is saved that contains the PV plant events for 
each day in the selected time frame.

Monthly files
When you set the time period for monthly files, Sunny Explorer rounds off the time period 
to the full month (start of the month to end of the month).
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8.1.1 CSV File
The CSV files can be opened in Microsoft Excel and used to create charts.
File name
The name of the file is always the plant name and the date on which the device data was generated.
The file name of the event files also includes the user group. Sunny Explorer only stores the event files 
that can be viewed by the respective user group.

CSV file components
The table below describes the CSV file columns in Microsoft Excel.

File File name components Example:
Day file Plantname-YYYYMMDD.csv MyPlant-20091017.csv
Monthly file Plantname-YYYYMM.csv MyPlant-200910.csv
Event file For installer user group:

Plantname-Installer-Events-
YYYYMMDD-YYYYMMDD.csv

For user user group:
Plantname-User-Events-
YYYYMMDD-YYYYMMDD.csv

MyPlant-Installer-Events-
20091017-20091018.csv

MyPlant-User-Events-
20091017-20091018.csv

1 Information about CSV file for the programs
2 Empty line
3 Name of device 1 (serial 

number or changed name)
Name of device 2 (serial 
number or changed name)

4 Model of device 1 Model of device 2
5 Serial number of device 1 Serial number of device 2
6 Name of the values Name of the values
7 Date and time format Value unit Value unit
8 Time (date and time) when 

the device generated the 
value.

Value for device 1 Value for device 2

9 ... ... ...
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9 Uninstalling Sunny Explorer
9.1 Notes
This section describes how to uninstall Sunny Explorer under Windows XP and Windows Vista. Read 
the section which is relevant to the operating system of your computer.

9.1.1 Uninstalling Sunny Explorer in Windows XP
1. Under Windows, select "Start > Settings > Control Panel > Software".
2. Select "Sunny Explorer" from the list, and click [Delete].

☑ Sunny Explorer will be uninstalled from your computer.
☑ Sunny Explorer is uninstalled.

9.1.2 Uninstalling Sunny Explorer in Windows Vista
1. Under Windows, select "Start > Computer".

☑ The "My computer/Computer" window opens.
2. Select "Uninstall or change program".

☑ The "Uninstall or change program" window opens.
3. Select "Sunny Explorer" from the list, and click [uninstall/change].

☑ Sunny Explorer will be uninstalled from your computer.
☑ Sunny Explorer is uninstalled.

9.1.3 Uninstalling Sunny Explorer in Windows 7
1. Under Windows, select "Start > Computer".

☑ The "My computer/Computer" window opens.
2. Select "Uninstall or change program".

☑ The "Uninstall or change program" window opens.
3. Select "Sunny Explorer" from the list, and click [uninstall/change].

☑ Sunny Explorer will be uninstalled from your computer.
☑ Sunny Explorer is uninstalled.



Failure Search SMA Solar Technology AG

48 ExplorerSW12-BEN101412 User Manual

10 Failure Search
Bluetooth connection
No. Problem Cause and solution
1 System search

Connection to the Bluetooth 
plant failed. 

• The connection to the Bluetooth plant is too weak. 
– Reduce the distance to the devices and try to 

reconnect. 
• There are already 4 masters connected to the 

Bluetooth plant.
– Remove one master and try to reconnect.

• There are already 2 participators connected to the 
device through which you want to connect to the 
Bluetooth plant.
– Select another device or remove another 

communication device, and try to reconnect.
2 System search

The displayed device names 
and NetIDs are not current.

• Depending on the Bluetooth stack in use, it is 
possible that changes to the NetID or the device 
name are not correctly recognized at an inverter. 
– Proceed as follows:

1. If present, close the Bluetooth stick software.
2. Briefly remove and reinsert the Bluetooth stick.
3. If required, start the Bluetooth stick software.
4. Carry out system search in Sunny Explorer again.

3 System search
The device address is displayed, 
but the device name is not 
displayed.

• Sunny Explorer has not finished reading the device 
name from the device.
– Select "Repeat search" so that Sunny Explorer 

updates the device name. 
4 Inverter is not accessible

After setting parameters for 
communication via Bluetooth, 
the inverter is not accessible for 
a longer period.

• When setting parameters that regulate the 
Bluetooth connection (e.g. parameters for the 
transmitting power and country parameters), the 
communication via Bluetooth is interrupted for some 
time because the inverter is carrying out a reboot of 
the communication interface. 
– Wait until the inverter has completed a restart. 

The inverter is then accessible again.
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User interface display
Sunny Explorer reads the data directly from connected devices so that you can view inspect current 
data on the user interface. Depending on the size of the PV plant, displaying the data can take some 
time.
No. Problem Cause and solution
5 User interface

The user interface is not being 
displayed properly.

• Occasionally, display errors may arise on the user 
interface (e.g. defective layout, white screen).
– Push the F5 key to have Sunny Explorer update 

the user interface.
6 Performance diagram

The performance diagram has 
gaps.

• The transmission of device data is not yet complete. 
– Wait until the transmission of device data has 

been fully completed.
7 Performance diagram

The performance diagram is not 
updated.

• Updating the performance diagram can take up to 
30 seconds. Device data is directly read out by the 
connected devices. Depending on the 
communication hierarchy, reading out the data can 
take some time.
– Wait until the data is fully uploaded.

8 No monthly and yearly 
energy values
In inverters with SMA Bluetooth 
Piggy-Back upgrade, no monthly 
and yearly energy values are 
displayed.

• You have an inverter with an SMA Bluetooth Piggy-
Back upgrade with a software version below 
02.00.00.R. Configuring parameters and graphic 
display of monthly and yearly energy values is not 
supported.
– Update the Bluetooth Piggy-Back (see 

7.8 ”Updating a Device” (page 44).
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General
No. Problem Cause and solution
9 Sunny Explorer will not start • In some cases, Sunny Explorer will not start when 

Sunny Explorer did not shut down properly because 
the computer was in standby mode. 
– Quit Sunny Explorer manually using the 

Windows Task Manager. You can then restart 
Sunny Explorer.

10 Unknown device 
in plant tree
An unknown inverter 
is displayed in the 
plant tree.

• The system tree shows all devices which share the 
same NetID. If a PV plant with an SMA Bluetooth 
using the same NetID is located in the vicinity, the 
devices of this plant will also display in your plant in 
Sunny Explorer. 
– Request a free NetID and set the free NetID in 

your devices as described in the respective 
manuals.

11 Own inverter as 
unknown device 
in plant tree
Own inverter with 
integrated Bluetooth is 
displayed as an unknown 
device.

• An old version of the software package is installed 
on this inverter with integrated Bluetooth. 
– Update the software package version of your 

inverter to version 2.0 or higher or use Sunny 
Data Control to read out the inverter.

12 Own inverter as 
unknown device 
in plant tree
Even though the 
plant password was entered 
correctly, some of your own 
devices are displayed as an 
unknown device in the plant 
tree.

• Packages were lost during data transmission, which 
caused Sunny Explorer to be unable to log in 
properly with the devices.
– Log in again by selecting "Options > Change 

user group" and logging in again under your 
user group.

13 New inverter is missing in 
plant tree

• Sunny Explorer constantly updates the system tree. 
– Check the items below:

– The inverter has not been set to and put into 
operation under the same NetID as your 
plant. Set the inverter to your plant's NetID as 
described in the inverter's manual.

– The connection may have been interrupted. 
Retry setting up a connection. Select "Options 
> Repeat establishment of connection".
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14 Lost plant password – If you have lost your plant password, you can 
unlock the device using a Personal Unlocking 
Key (PUK). You can obtain a PUK for the User/
Installer user group from the SMA service line.

15 No Grid Guard 
rights
You do not have Grid Guard 
rights even though the Grid 
Guard symbol is displayed.

• The inverters did not automatically return the Grid 
Guard right after 10 hours. The Grid Guard right no 
longer exists, but the symbol is still being displayed 
in error.
– Enter the Grid Guard code as described in 

Section7.3 ”Entering SMA Grid Guard Code” 
(page 42).

16 Grid Guard mode
The symbol for Grid 
Guard mode is no longer being 
displayed.

• If an installer has logged into Grid Guard mode, the 
inverters automatically reset the Grid Guard mode 
after 10 hours to avoid unauthorized access. You 
can also exit Grid Guard Modus by closing Sunny 
Explorer.

17 Changed parameters were 
adopted for only 1 device 
class.

• Each device class has its own interface for 
processing and storing settings. Sunny Explorer only 
stores changes for the device class that is assigned 
to a particular interface. Changes from other device 
classes that are still open for processing will not be 
saved.
– Save the changes made to one device class 

before processing another device class.
18 Inputting parameters with a 

smaller unit
• Sunny Explorer saves an entered value using the 

unit that is specified next to the input field. 
– If you wish to input values from a smaller or 

larger unit, you must convert the value to the 
specified unit. Sunny Explorer automatically 
adapts the unit. Example: if you want to change 
a parameter from 20 MWh to 900 kWh, you 
must input 0.9. Sunny Explorer automatically 
adapts the input unit and saves the parameter as 
900 kWh.

No. Problem Cause and solution
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19 Parameters can not be 
processed

• You do not possess the necessary parameter rights.
– Change the user group.

• You have an inverter with an SMA Bluetooth Piggy-
Back upgrade with a software version below 
02.00.00.R. Configuring parameters and graphic 
display of monthly and yearly energy values is not 
supported.
– Update the Bluetooth Piggy-Back (see 

7.8 ”Updating a Device” (page 44).
20 Events are not sorted

The events are not properly 
sorted according to date and 
time.

• Sunny Explorer sorts the events using the same 
consecutive number that the device uses to store the 
events. The advantage is that the events will always 
be listed in the order in which they arose in the 
device.
The events will only be sorted improperly if the time 
or the date of the plant was changed (e.g., when 
switching from summer to winter daylight savings 
time).

21 Values are marked as out of 
date even though they are 
current.
Values are marked as 
current even though they are 
out of date.

• This problem may arise if the computer clock was 
changed during Sunny Explorer operation.
– Restart Sunny Explorer.

No. Problem Cause and solution
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11 Contact
If you have technical problems with our products, please contact the SMA service line. We require 
the following information in order to provide you with the necessary assistance:

• Sunny Explorer software version
• PV plant communication type
• Sunny Explorer report file

SMA Solar Technology AG
Sonnenallee 1
34266 Niestetal, Germany
www.SMA.de

SMA Serviceline 
Inverters: +49 561 9522 1499
Communication: +49 561 9522 2499
Fax: +49 561 9522 4699
E-Mail: Serviceline@SMA.de 
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The information contained in this document is the property of SMA Solar Technology AG. Publishing its content, either partially or 
in full, requires the written permission of SMA Solar Technology AG. Any internal company copying of the document for the 
purposes of evaluating the product or its correct implementation is allowed and does not require permission.

Exclusion of liability
The general terms and conditions of delivery of SMA Solar Technology AG shall apply.
The content of these documents is continually checked and amended, where necessary. However, discrepancies cannot be 
excluded. No guarantee is made for the completeness of these documents. The latest version is available online at www.SMA.de 
or from the usual sales channels.
Guarantee or liability claims for damages of any kind are excluded if they are caused by one or more of the following: 
• Damages during transportation
• Improper or inappropriate use of the product
• Operating the product in an unintended environment
• Operating the product whilst ignoring relevant, statutory safety regulations in the deployment location
• Ignoring safety warnings and instructions contained in all documents relevant to the product
• Operating the product under incorrect safety or protection conditions
• Altering the product or supplied software without authority
• The product malfunctions due to operating attached or neighboring devices beyond statutory limit values
• In case of unforeseen calamity or force majeure
The use of supplied software produced by SMA Solar Technology AG is subject to the following conditions:
• SMA Solar Technology AG rejects any liability for direct or indirect damages arising from the use of software developed by 

SMA Solar Technology AG. This also applies to the provision or non-provision of support activities.
• Supplied software not developed by SMA Solar Technology AG is subject to the respective licensing and liability agreements 

of the manufacturer.

SMA Factory Warranty
The current guarantee conditions come enclosed with your device. These are also available online at www.SMA.de and can be 
downloaded or are available on paper from the usual sales channels if required.

Trademarks
All trademarks are recognized even if these are not marked separately. Missing designations do not mean that a product or brand 
is not a registered trademark.
The Bluetooth® word mark and logos are registered trademarks owned by Bluetooth SIG, Inc. and any use of such marks by SMA 
Solar Technology is under license.
SMA Solar Technology AG
Sonnenallee 1
34266 Niestetal
Germany
Tel. +49 561 9522-0
Fax +49 561 9522-100
www.SMA.de
E-Mail: info@SMA.de
© 2004 to 2010 SMA Solar Technology AG. All rights reserved
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