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Information in this document is subject to change without notice and does not represent a 

commitment on the part of the manufacturer. The software described in this document is 

furnished under license agreement or nondisclosure agreement and may be used or copied 

in accordance with the terms of the agreement. It is against the law to copy the software on 

any medium except as specifically allowed in the license or nondisclosure agreement. No 

part of this manual may be reproduced or transmitted in any form or by any means, 

electronic or mechanical, including photocopying, recording, or information storage and 

retrieval systems, for any purpose other than the purchaser’s personal use, without prior 

written permission. 

 

Every effort was made to ensure the accuracy in this manual and to give appropriate credit 

to persons, companies and trademarks referenced herein. 

 

© Embedded Systems Academy, Inc. 2005 

All Rights Reserved 

 

Microsoft® and Windows™ are trademarks or registered trademarks of Microsoft 

Corporation. 

PC® is a registered trademark of International Business Machines Corporation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For support contact support@esacademy.com 

 

For the latest news on CANopen Architect EDS visit the web site at 

 

www.canopenmagic.com 

 

 

 

Embedded Systems Academy provides training and consulting services, 

specializing in CAN, CANopen and Embedded Internetworking. For more 

information visit 

 

www.esacademy.com 
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About This Manual 
 

This manual follows some set conventions with the aim of making it easier to read. The 

following conventions are used: 

 

0x  Hexadecimal (base 16) values are prefixed with “0x”. 

italictext Replace the text with the item it represents 

[ ]  Items inside [ and ] are optional 

a | b  a OR b may be used 

…  One or more items may go here. 

 

This manual frequently uses CANopen terminology as defined by the CANopen standard 

DS301 (see www.can-cia.org for more info). Readers that are not yet familiar with all the 

CANopen terms may want to consider reading a book like www.canopenbook.com or the 

official standard to update their knowledge on CANopen technology and terminology. 
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Chapter 1 – Introduction 
 

1.1 About CANopen 

CANopen is a higher layer protocol that runs on a CAN network. The CAN specification 

defines only the physical and data link layers in the ISO/OSI 7-layer Reference Model. This 

means that only the physical bus and the CAN message format is defined, but not how the 

CAN messages should be used. CANopen provides an open and standardized but 

customizable description of how to transfer data of different types between different CAN 

nodes. This allows off the shelf CANopen compliant nodes to be purchased and plugged into 

a network with the minimum of effort. It also can be used in place of an in-house 

proprietary higher layer protocol development. 

 

The development of CANopen is supervised by the CAN in Automation User's Group and is 

being turned into an international standard. Use of CANopen does not require the payment 

of any royalties and the specification may be expanded or altered to suit if closed networks 

are being developed. 

 

Typical applications for CANopen include: 

 

� Commercial Vehicles 

� Medical Equipment 

� Maritime Electronics 

� Building Automation 

� Light Rail Systems 

 

1.2 About CANopen Architect EDS 

Electronic Datasheets (EDS) are files which describe the capabilities of CANopen nodes, and 

are therefore central to CANopen. EDS files are most commonly used when CANopen 

modules are sold or made available to third parties. They provide a standardized and easy 

to use format for describing how CANopen nodes can be integrated into networks. They can 

also serve as an in-house documentation of the node. 

 

CANopen Architect EDS allows quick and easy generation and editing of EDS files. Files can 

be built from scratch or based on one of the versions in the included library. The user 

interface presents the contents of the EDS file in a tree view, allowing quick and easy 

editing of any aspect. 

 

CANopen Architect EDS also supports the creation and editing of Device Configuration Files 

(DCF). DCFs are the same as EDS files but contain real settings from a specific node. Unlike 

many other EDS editors, CANopen Architect EDS supports the editing of data that is specific 

to DCFs. 
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CANopen Architect EDS supports the use of third party EDS checkers, including a free 

checker available from the CAN in Automation Users Group. EDS checkers validate the EDS 

files and provide error and warning information. 

 

1.3 CANopen Architect EDS Features 

The following is a list of features in CANopen Architect EDS. The list is not exhaustive by 

any means, but does give a good overview of the abilities of CANopen Architect EDS. 

 

� Add, edit and delete entries 

� Add a single entry or an entry with multiple subentries in one step 

� Automatic generation of subentry zero for entries with more than one subentry 

� Specify names for the entry and subentries 

� Support for compact subentries 

� Can be easily toggled on or off for entries with no subentries 

� Cut, copy and paste any data to the window clipboard 

� Allows quick copy of data between multiple EDS or DCFs 

� Can copy non-entry data, such as device information 

� Paste As allows pasting of clipboard data to specific entry indexes, using specific 

names, allowing duplicates of entries to be quickly created 

� Specify file information 

� Device information, file information, etc. 

� Supports the configuration of device commissioning 

� Smart save 

� Analyses data and determines if it should be saved as EDS or DCF 

� Force save into a specific file format 

� Supports third party EDS checkers 

� Customizable command line provides flexibility 

� Compatible with free EDS checker from CAN in Automation 

� Outputs to a window which supports copying to clipboard for use in reports 

� EDS checkers inform of warnings or errors in data 

 

CANopen Architect EDS also has some limitations 

 

� No support for compact subentry names 

� No support for object links 

� No support for modules 
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Chapter 2 – Installation and Setup 
 

2.1 Installation 

Minimum Requirements 
The following is a list of the recommended minimum requirements for running CANopen 

Architect EDS. 

 

� Pentium II 400MHz 

� Windows 98 

� Pointing device (mouse, trackball, etc.) 

� 3Mb of disk space 

� 64Mb of RAM 

 

Install CANopen Architect EDS 
To install CANopen Architect EDS, simply run the installation executable. An installation 

wizard will guide you through the steps necessary to install the software. 

 

2.3 Example EDS Files 

A set of example EDS files are supplied with the installation, and are available from the start 

menu in Windows or the help menu in the application, under the name "EDS Library". To 

open a file simple double-click on the file or choose Open from the File menu. 
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Chapter 3 – Overview 
 

3.1 User Interface Tour 

Upon starting the application the main window will be displayed. The layout is very 

straightforward. 

 

 
 

Across the top are the menus and the toolbar. The toolbar provides access to the most 

commonly used features of the software. 

 

On the left is a tree view of the current data, similar to the tree view of a collection of 

folders and files. Folder icons indicate a collection of pieces of data and file icons indicate 

the data itself. 

 

On the right is the area where the data is edited. As different items are selected in the tree 

view, the options on the right change to match the currently selected item. For example, if 

the Information item in the File folder is selected, then the options for the file information 

are displayed. If the Comments item in the File folder is selected then the options for the 

file comments are displayed. 

 

As data is entered into the right side it is automatically stored. There is no need to click on 

any confirmation buttons. 
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Sections on the right that have headings in red indicate that the data in that section is only 

used in DCFs, and is not included in EDS files. For example, in the File Information section, 

the EDS field under the Additional Information heading is only present in a DCF. 

 

If any DCF only data is entered and an attempt is made to save the data as an EDS file, a 

warning is given that not all the data will be saved. When saving as an EDS file, DCF only 

data is ignored. No warning is given if nothing has been entered in any of the DCF sections. 

 

3.2 The Tree View 

A minimal tree is always present, even in new files with no data. This is because some items 

are mandatory and always included in EDS files and DCFs. For example, there is always a 

File Information and Comments section, and always a Device Information and 

Commissioning section. 

 

For new files the Object Dictionary section of the tree will be empty, except folders which 

divide the tree up into groups. As entries are created they will automatically appear under 

the correct group. 
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Chapter 4 – Adding, Editing, Deleting 
 

Self explanatory sections are not described here. Instead please refer to the EDS 

specification, available for free from CAN in Automation. 

 

4.1 File Information 

Editing 
Click on the Information item in the File folder in the tree view to edit the data. 

 

 
 

The creation date and time is when the file was first created. If this field shows "Never" then 

the current date and time will be inserted when the file is saved. To ensure this happens on 

the next save, click on Reset, otherwise the creation date and time will be preserved. 

 

The modification date and time shown is the date and time when the file was last modified. 

On every save this is updated to the current date and time. 

 

4.2 Entries 

Adding 
Methods for adding a new entry: 
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� Choose Add Entry from the Edit menu. 

� Click on the Add Entry toolbar button. 

� Right click over the tree view and choose Add Entry from the menu. 

 

The Add Entry dialog window will be displayed. 

 

 
 

Enter the index of the new entry in hexadecimal, followed by the name of the entry. If the 

entry has subentries, enter the number of subentries. If the subentries are compact 

subentries, then check the Compact box. Select the data type for the subentries. 

 

Note that entries with two or more subentries will automatically have a data type of 

UNSIGNED8 for subentry zero. 

 

Click on Add Entry to add the entry, and it will appear in the tree view under the appropriate 

group for the index. 

 

Editing with no Subentries/Compact Subentries 
To edit an entry simply select it in the tree view. Depending on whether the entry has 

subentries or not, the options will be different. 

 

If an entry does not have any subentries (or has one subentry or compact subentries) then 

the options for the entry will be displayed. 
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Enter the appropriate settings for the entry. As they are entered they are automatically 

stored. 

 

Editing – Subentries 
To edit an entry simply select it in the tree view. Depending on whether the entry has 

subentries or not, the options will be different. 

 

If an entry has subentries then the options for the entry will be displayed. 
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To change the number of subentries, enter the new value. Because this setting can cause 

the deletion of data it does not automatically take effect. Instead it must be confirmed by 

clicking on the Confirm Change button. Deleted subentries cannot be undeleted. 

 

Deleting 
To delete an entry first select it then use one of the following methods: 

 

� Choose Delete from the Edit menu. 

� Click on the Delete toolbar button. 

� Right click over the entry and choose Delete from the menu. 

 

4.3 Subentries 

Adding 
To add a new subentry, first select the entry to be added to. Methods for adding a new 

subentry: 

 

� Increase the number of subentries on the right side by one and click on Confirm 

Change. The new subentries will be duplicates of the last subentry. 

� Choose Add Subentries from the Edit menu. The Add Subentries dialog window will 

open. 

� Click on the Add Subentry toolbar button. The Add Subentries dialog window will 

open. 

� Right click over the entry and choose Add Subentries from the menu. 
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The Add Subentries dialog window allows configuration of the subentries to be added. 

 

 
 

Enter the subindex of the entry to add, along with the subentry name. It is possible to add 

multiple subentries starting at the specified subindex by increasing the number of 

subentries to be added. All subentries will have the same name. 

 

Editing 
To edit a subentry simply select it in the tree view. The options will be displayed on the right 

side. 

 

 
 

Enter the appropriate settings for the subentry. As they are entered they are automatically 

stored. 
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Deleting 
To delete a subentry, first select the subentry then use one of the following methods: 

 

� Choose Delete from the Edit menu. 

� Click on the Delete toolbar button. 

� Right click over the entry and choose Delete from the menu. 

� Select the entry for the subentry then edit the number of subentries on the right 

side. 

 

4.4 Cut, Copy and Paste 

 

All data may be copied to and pasted from the Windows clipboard. This allows data to be 

transferred between multiple copies of CANopen Architect EDS. Entries and subentries can 

also be cut to the clipboard. 

 

Cut and Copy 
To place an item on the clipboard simply select in the tree view and use one of the following 

methods: 

 

� Choose Cut or Copy from the Edit menu. 

� Click on the Cut or Copy toolbar buttons. 

� Right click over the item and choose Cut or Copy for the menu. 

 

Paste 
To paste any data except for subentries, use one of the following: 

 

� Choose Paste from the Edit menu. 

� Click on the Paste toolbar button. 

� Right click anywhere over the tree view and choose Paste from the menu. 

 

To paste a subentry, first select an entry to paste to. Then the same methods as just listed 

may be used to paste the subentry. 

 

Paste As 
Choosing Paste As instead of Paste allows a customized copy of the clipboard data to be 

pasted. Not all data can use Paste As, for example File Information. Paste As does not 

modify the data on the clipboard, it only modifies the pasted copy. 

 

Choosing Paste As opens the dialog for configuring the pasted copy. 
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Enter the new index (for entries) or subindex (for subentries), along with a new name and 

the number of consecutive copies starting at the index or subindex to paste. 

 

Leaving the rename field blank will result in the name of the item on the clipboard being 

used, i.e. no change. 

 

 

 



CANopen Architect EDS User Manual 

Page 17 

Chapter 5 – Loading and Saving 
 

5.1 Loading 

To load an EDS file or DCF simply choose Open from the File menu, or click on the Open 

toolbar button. 

 

Select the file to open. Only valid EDS files and DCFs are supported. 

 

5.2 Saving 

There are three options to save the current data. 

 

Choosing Save from the File menu, or clicking on the Save toolbar button will overwrite the 

file currently being edited. If the current data has never been saved, then a save dialog 

window will appear, prompting for a location and name to save to. 

 

The Save option is a smart save. If the current data can be saved as an EDS file, then that 

file format will be chosen. However if the current data contains any DCF only items, then 

the data will be saved as a DCF. 

 

To force saving of the data in a specific file format, choose Save as Electronic Datasheet or 

Save as Device Configuration File from the File menu. If the data contains any DCF only 

items and Save as Electronic Datasheet is chosen, then a warning will be given indicating 

that not all the data will be saved. 
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Chapter 6 – EDS Checking 
 

6.1 Overview 

An EDS checker can check that an EDS file is correct, which helps to confirm that the file 

will be understood by other CANopen tools. 

 

CANopen Architect EDS does not come with an EDS checker, instead third party checkers 

can be used. The rest of this section describes a free EDS checker available from CAN in 

Automation. 

 

6.2 Installation and Configuration 

The following steps will install a free EDS checker and configure CANopen Architect EDS to 

use it. 

 

� Open the Preferences window by choosing Preferences from the Options menu, or 

clicking on the Preferences toolbar button. 

� Download the EDS checker zip file from http://www.can-

cia.org/downloads/files/?1119 by clicking on the link. 

� Open the zip file. 

� Copy the contents of ChkEDS.zip into the EDSChecker subfolder. The subfolder may 

be opened by clicking on Open Subfolder. 

� Click on the Reset button to ensure the preferences are correct for this configuration. 

� Click on OK.  

 

It is possible to extract the EDS checker to any folder desired, simply change the path in the 

Preferences dialog window to match. 

 

The EDS checker allows several options on the command line, which can be entered into the 

Preferences window. Whenever "#E" is encountered, the full path and name of the current 

EDS file is inserted. 

 

Using any options that redirect the output to a file will result in no output in the CANopen 

Architect EDS user interface. 

 

6.3 Running the EDS Checker 

The current EDS file must first be saved. Once saved start the checking by either choosing 

Check Current Electronic Datasheet from the Tools menu, or click on the Check EDS toolbar 

button. An output window will open showing the results of the check. 
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To run the check again, click on Check Again. To cancel the current check, simply close the 

window. 

 

To copy the results to the clipboard, right click over the results and choose Select All. Next, 

right click over the results again and choose Copy. 

 


