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Overview

Agisoft PhotoScan is an advanced image-based 3D modeling solution aimed at creating professional
quality 3D content from still images. Based on the latest multi-view 3D reconstruction technology, it
operates with arbitrary images and is efficient in both controlled and uncontrolled conditions. Photos can
be taken from any position, providing that the object to be reconstructed is visible on at least two photos.
Both image alignment and 3D model reconstruction are fully automated.

How it works

Generaly the final goal of photographs processing with PhotoScan is to build a textured 3D model. The
procedure of photographs processing and 3D model construction comprises four main stages.

1. Thefirst stageiscameraalignment. At this stage PhotoScan searchesfor common pointson photographs
and matches them, as well as it finds the position of the camera for each picture and refines camera
calibration parameters. As aresult a sparse point cloud and a set of camera positions are formed.

The sparse point cloud represents the results of photo aignment and will not be directly used in
the further 3D model construction procedure (except for the sparse point cloud based reconstruction
method). However it can be exported for further usage in external programs. For instance, the sparse
point cloud model can be used in a 3D editor as areference.

Onthecontrary, the set of camerapositionsisrequired for further 3D model construction by PhotoScan.

2. The next stage is building dense point cloud. Based on the estimated camera positions and pictures
themselves a dense point cloud is built by PhotoScan. Dense point cloud may be edited and classified
prior to export or proceeding to 3D mesh model generation.

3. Ancther stage is building mesh. PhotoScan reconstructs a 3D polygona mesh representing the object
surface based on the dense point cloud. Additionally there is a Point Cloud based method for fast
geometry generation based on the sparse point cloud alone. Generally there aretwo al gorithmic methods
available in PhotoScan that can be applied to 3D mesh generation: Height Field - for planar type
surfaces, Arbitrary - for any kind of object.

Having built the mesh, it may be necessary to edit it. Some corrections, such as mesh decimation,
removal of detached components, closing of holes in the mesh, etc. can be performed by PhotoScan.
For more complex editing you have to engage external 3D editor tools. PhotoScan allows to export
mesh, edit it by another software and import it back.

4. After geometry (i.e. mesh) isreconstructed, it can be textured and / or used for orthophoto generation.
Severa texturing modes are available in PhotoScan, they are described in the corresponding section
of this manual.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these
operations are carried out automatically according to the parameters set by user. Instructions on how to
get through these operations and descriptions of the parameters controlling each step are explained in the
corresponding sections of the Chapter 3, General workflow.

In some cases, however, additional actions may be required to get the desired results. In some capturing
scenarios masking of certain regions of the photos may be required to exclude them from the cal cul ations.
Application of masks in PhotoScan processing workflow as well as editing options available are
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described in Chapter 5, Editing. Camera calibration issues are discussed in Chapter 4, Referencing and
measurements, that also describes functionality to reference the results and carry out measurements on
the model. While Chapter 6, Automation describes opportunities to save up on manual intervention to the
processing workflow, Chapter 7, Network processing presents guidelines on how to organize distributed
processing of the imagery data on several nodes.

It can take up quite along time to reconstruct a 3D model. PhotoScan allows to export obtained results
and save intermediate datain aform of project filesat any stage of the process. If you are not familiar with
the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can also find instructions on the PhotoScan installation procedure and basic rules for
taking "good" photographs, i.e. pictures that provide most necessary information for 3D reconstruction.
For the information refer to Chapter 2, Capturing photos and Chapter 1, Installation.

Vi



Chapter 1. Installation

System requirements

Minimal configuration

» Windows XP or later (32 or 64 bit), Mac OS X Snow Leopard or later, Debian / Ubuntu (64 bit)
¢ Intel Core 2 Duo processor or equivalent

+ 2GB of RAM

Recommended configuration

» Windows XP or later (64 bit), Mac OS X Snow Leopard or later, Debian / Ubuntu (64 bit)
* Intel Corei7 processor

* 12GB of RAM

The number of photos that can be processed by PhotoScan depends on the available RAM and
reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPx, 2GB
RAM is sufficient to make a model based on 20 to 30 photos. 12GB RAM will alow to process up to
200-300 photographs.

OpenCL acceleration

PhotoScan supports accel erated depth maps reconstruction due to the graphics hardware (GPU) exploiting.
NVidia
GeForce 8xxx series and later.

ATI
Radeon HD 5xxx series and later.

PhotoScan is likely to be able to utilize processing power of any OpenCL enabled device during Dense
Point Cloud generation stage, provided that OpenCL driversfor thedeviceare properly installed. However,
because of thelarge number of vari ous combinations of video chips, driver versionsand operating systems,
Agisoft isunableto test and guarantee PhotoScan's compatibility with every device and on every platform.

The table below lists currently supported devices (on Windows platform only). We will pay particular
attention to possible problems with PhotoScan running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

NVIDIA AMD

GeForce GTX Titan Radeon R9 290x
GeForce GTX 980 Radeon HD 7970
GeForce GTX 780 Radeon HD 6970
GeForce GTX 680 Radeon HD 6950
GeForce GTX 580 Radeon HD 6870




NVIDIA AMD

GeForce GTX 570 Radeon HD 5870
GeForce GTX 560 Radeon HD 5850
GeForce GTX 480 Radeon HD 5830

GeForce GTX 470
GeForce GTX 465
GeForce GTX 285
GeForce GTX 280

Although PhotoScan is supposed to be able to utilize other GPU models and being run under a different
operating system, Agisoft does not guarantee that it will work correctly.

£ Note

« OpenCL acceleration can be enabled using OpenCL tab in the Preferences dialog box. For each
OpenCL device used one physical CPU core should be disabled for optimal performance.

» Using OpenCL acceleration with mobile or integrated graphics video chipsis not recommended
because of the low performance of such GPUs.

Installation procedure

Installing PhotoScan on Microsoft Windows

To install PhotoScan on Microsoft Windows simply run the downloaded msi file and follow the
instructions.

Installing PhotoScan on Mac OS X

Open the downloaded dmg image and drag PhotoScan application to the desired location on your hard
drive.

Installing PhotoScan on Debian/Ubuntu

Unpack the downl oaded archive with a program distribution kit to the desired location on your hard drive.
Start PhotoScan by running photoscan.sh script from the program folder.

Restrictions of the Demo mode

Once PhotoScan is downloaded and installed on your computer you can run it either in the Demo mode
or in the full function mode. On every start until you enter a serial number it will show a registration
box offering two options: (1) use PhotoScan in the Demo mode or (2) enter a serial number to confirm
the purchase. The first choice is set by default, so if you are still exploring PhotoScan click the Continue
button and PhotoScan will start in the Demo mode.

The employment of PhotoScan in the Demo modeis not time limited. Several functions, however, are not
available in the Demo mode. These functions are the following:

 saving the project;
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* exporting reconstruction results (you can only view a 3D model on the screen);
» some Python commands.

To use PhotoScan in the full function mode you have to purchaseit. On purchasing you will get the serial
number to enter into the registration box on starting PhotoScan. Once the serial number is entered the
registration box will not appear again and you will get full accessto all functions of the program.




Chapter 2. Capturing photos

Before loading your photographs into PhotoScan you need to take them and select those suitable for 3D
model reconstruction.

Photographs can be taken by any digital camera (both metric and non-metric), aslong as you follow some
specific capturing guidelines. This section explains general principles of taking and selecting pictures that
provide the most appropriate data for 3D model generation.

IMPORTANT! Make sure you have studied the following rules and read the list of restrictions before you
get out for shooting photographs.

Equipment

Use adigital camera with reasonably high resolution (5 MPix or more).

Avoid ultraswide angle and fish-eye lenses. The best choice is 50 mm foca length (35 mm film
equivalent) lenses. It isrecommended to usefocal length from 20 to 80 mm interval in 35mm equivalent.
If a data set was captured with fish-eye lens, appropriate camera sensor type should be selected in
PhotoScan Camera Calibration settings prior to processing.

Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to
minimal value during the entire shooting session for more stable results.

Camera settings

Using RAW data losslessly converted to the TIFF files is preferred, since JPG compression induces
unwanted noise to the images.

Take images at maximal possible resolution.
ISO should be set to the lowest value, otherwise high 1 SO values will induce additional noise to images.

Aperture value should be high enough to result in sufficient focal depth: it isimportant to capture sharp,
not blurred photos.

Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Object / scene requirements

Avoid not textured, shiny, mirror or transparent objects.

If still have to, shoot shiny objects under a cloudy sky.
Avoid unwanted foregrounds.

Avoid moving objects within the scene to be reconstructed.

Avoid absolutely flat objects or scenes.

Image preprocessing

PhotoScan operates with the original images. So do not crop or geometrically transform, i.e. resize or
rotate, the images.
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Capturing scenarios

Generally, spending some time planning your shot session might be very useful.

Number of photos: more than required is better than not enough.

Number of "blind-zones' should be minimized since PhotoScan is able to reconstruct only geometry
visible from at least two cameras.

In case of aerial photography the overlap requirement can be put in the following figures: 60% of side
overlap + 80% of forward overlap.

Each photo should effectively use the frame size: object of interest should take up the maximum area.
In some cases portrait camera orientation should be used.

Do not try to place full object in theimage frame, if some partsare missing it isnot aproblem providing
that these parts appear on other images.

Good lighting is required to achieve better quality of the results, yet blinks should be avoided. It is
recommended to remove sources of light from camerafields of view. Avoid using flash.

If you are planning to carry out any measurements based on the reconstructed model, do not forget to
locate at least two markers with aknown distance between them on the object. Alternatively, you could
place aruler within the shooting area.

In case of aerial photography and demand to fulfill georeferencing task, even spread of ground control
points (GCPs) (at least 10 across the area to be reconstructed) is required to achieve results of highest
quality, bothin terms of the geometrical precision and georeferencing accuracy. Y et, Agisoft PhotoScan
is able to complete the reconstruction and georeferencing tasks without GCPs, too.

The following figures represent advice on appropriate capturing scenarios:

Facade (Incorrect) Facade (Correct)
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In some cases it might be very difficult or even impossible to build a correct 3D model from a set of
pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

PhotoScan can process only unmodified photos as they were taken by a digital photo camera. Processing
the photos which were manually cropped or geometrically warped is likely to fail or to produce highly
inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

To estimatethe field of view for each photo PhotoScan uses the information saved in the EXIF part of each
picture. If EXIF data are available you can expect to get the best possible 3D reconstruction. However
3D scene can aso be reconstructed in the absence of EXIF data. In this case PhotoScan assumes that
focal length in 35 mm equivalent equals to 50 mm and tries to align the photos in accordance with this
assumption. If the correct focal length value differs significantly from 50 mm, the alignment can give
incorrect results or even fail. In such casesit isrequired to specify initial camera calibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are

given in the Camera calibration section.
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Lens distortion

The distortion of the lenses being used to capture the photos should be well simulated with the Brown's
distortion model. Otherwise it is most unlikely that processing results will be accurate. Fisheye and
ultra-wide angle lenses are poorly modeled by the common distortion model implemented in PhotoScan
software, so it is required to choose proper cameratype in Camera Calibration dialog prior to processing.




Chapter 3. General workflow

Processing of images with PhotoScan includes the following main steps:
* loading photos into PhotoScan;
* inspecting loaded images, removing unnecessary images,

« aligning photos;

building dense point cloud;

building mesh (3D polygona model);
» generating texture;
* exporting results.

If you are using PhotoScan in the full function (not the Demo) mode, intermediate results of the image
processing can be saved at any stage in the form of project files and can be used later. The concept of
projects and project filesis briefly explained in the Saving intermediate results section.

Thelist above represents all the necessary steps involved in the construction of atextured 3D model from
your photos. Some additional tools, which you may find to be useful, are described in the successive
chapters.

Preferences settings

Before starting a project with PhotoScan it is recommended to adjust the program settings for your needs.
In Preferences dialog (General Tab) available through the Tools menu you can indicate the path to the
PhotoScan log file to be shared with the Agisoft support team in case you face any problems during the
processing. Here you can a so change GUI language to the onethat is most convenient for you. The options
are: English, Chinese, French, German, Portuguese, Russian, Spanish.

On the OpenCL Tab you need to make sure that all OpenCL devices detected by the program are checked.
PhotoScan exploits GPU processing power that speeds up the process significantly. If you have decided
to switch on GPUs for photogrammetric data processing with PhotoScan, it is recommended to free one
physical CPU core per each active GPU for overall control and resource managing tasks.

Loading photos

Before starting any operation it is necessary to point out what photos will be used as a source for 3D
reconstruction. In fact, photographs themselves are not loaded into PhotoScan until they are needed. So,
when you "load photos’ you only indicate photographs that will be used for further processing.

Toload a set of photos

L Select Add Photos... command from the Workflow menu or click Add Photos toolbar button on

the Workspace pane.

2. In the Add Photos dialog box browse to the folder containing the images and select files to be
processed. Then click Open button.

3. Selected photos will appear on the Workspace pane.
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4 Note

« PhotoScan accepts the following image formats: JPEG, TIFF, PNG, BMP, PPM, OpenEXR
and JPEG Multi-Picture Format (MPQO). Photos in any other format will not be shown in the
Add Photos dialog box. To work with such photos you will need to convert them in one of the
supported formats.

If you have loaded some unwanted photos, you can easily remove them at any moment.

Toremove unwanted photos
1. Onthe Workspace pane select the photos to be removed.

2. Right-click on the selected photos and choose Remove Items command from the opened context

menu, or click X Remove Items toolbar button on the Workspace pane. The selected photos will be
removed from the working set.

Camera groups

If al the photos or a subset of photos were captured from one camera position - camera station, for
PhotoScan to process them correctly it is obligatory to move those photos to a camera group and mark
the group as Camera Station. It is important that for all the photos in a Camera Station group distances
between camera centerswere negligibly small compared to the camera-object minimal distance. 3D model
reconstruction will require at least two camera stations with overlapping photos to be present in a chunk.
However, it is possible to export panoramic picture for the data captured from only one camera station.
Refer to Exporting results section for guidance on panorama export.

Alternatively, camera group structure can be used to manipulate the image data in a chunk easily, like
applying Disable / Enable functions to the whole cameras in a group at once.

To move photosto a camera group
1. Onthe Workspace pane (or Photos pane) select the photos to be moved.

2. Right-click on the selected photos and choose Move Cameras - New Camera Group command from
the opened context menu.

3. A new group will be added to the active chunk structure and selected photos will be moved to that
group.

4. Alternatively selected photos can be moved to a camera group created earlier using Move Cameras
- Camera Group - Group_name command from the context menu.

Tomark group as camerastation right click on the cameragroup nameand select Set Group Type command
from the context menu.

Inspecting loaded photos

L oaded photos are displayed on the Workspace pane along with flags reflecting their status.
The following flags can appear next to the photo name:

NC (Not calibrated)
Notifies that the EXIF data available is not sufficient to estimate the camerafocal length. In this case
PhotoScan assumes that the corresponding photo was taken using 50mm lens (35mm film equival ent).
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If the actual focal length differs significantly from this value, manual calibration may be required.
More details on manual camera calibration can be found in the Camera calibration section.

NA (Not aligned)
Notifies that external camera orientation parameters were not estimated for the current photo yet.

Images loaded to PhotoScan will not be aligned until you perform the next step - photos alignment.

=)
Notifies that Camera Station type was assigned to the group.

Multispectral imagery

PhotoScan supports processing of multispectral images saved as multichannel (single page) TIFF files.
The main processing stages for multispectral images are performed based on the master channel, which
can be selected by the user. During orthophoto export, al spectral bands are processed together to form a
multispectral orthophoto with the same bands as in source images.

The overall procedure for multispectral imagery processing does not differ from the usual procedure for
normal photos, except the additional master channel selection step performed after adding images to the
project. For the best results it is recommended to select the spectral band which is sharp and as much
detailed as possible.

To select master channel

1. Add multispectral images to the project using Add Photos... command from the Workflow menu or
Add Photos toolbar button.

2. Select Set Master Channel... command from the chunk context menu in the Workspace pane.

3. Inthe Set Master Channel dial og select the channel to be used as master and click OK button. Display
of images in PhotoScan window will be updated according to the master channel selection.

4 Note

e Set Master Channel... command is available for RGB images as well. You can either indicate
only one channel to be used as the basis for photogrammetric processing or leave the parameter
value as Default for al three channels to be used in processing.

Multispectral orthophoto export is supported in GeoTIFF format only. When exporting in other formats,
only master channel will be saved.

Aligning photos

Once photos are loaded into PhotoScan, they need to be aligned. At this stage PhotoScan finds the camera
position and orientation for each photo and builds a sparse point cloud model.

Toalign a set of photos
1. Select Align Photos... command from the Workflow menu.
2. Inthe Align Photos dialog box select the desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

10
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Alignment having been completed, computed camera positions and a sparse point cloud will be displayed.
You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches
between any two photos use View Matches... command from a photo context menu in the Photos pane.

Incorrectly positioned photos can be realigned.

Torealign a subset of photos

1. Reset aignment for incorrectly positioned cameras using Reset Camera Alignment command from
the photo context menu.

2. Set markers (at least 4 per photo) on these photos and indicate their projections on at least two
photos from the already aligned subset. PhotoScan will consider these pointsto be true matches. (For
information on markers placement refer to the Setting coordinate system section).

3. Select photosto berealigned and use Align Sel ected Cameras command from the photo context menu.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

When the alignment step is completed, the point cloud and estimated camera positions can be exported
for processing with another software if needed.

Image quality

Poor input, e. g. vague photos can influence alignment results badly. To help you to exclude poorly
focused images from processing PhotoScan suggests automatic image quality estimation feature. Images
with quality value of less than 0.5 units are recommended to be disabled and thus excluded from
photogrammetric processing, providing that the rest of the photos cover the whole scene to be

reconstructed. To disable a photo use @ Disable button from the Photos pane toolbar.

PhotoScan estimates image quality for each input image. The value of the parameter is calculated based
on the sharpness level of the most focused part of the picture.

To estimate image quality

1 Switch to the detailed view in the Photos pane using ‘==Details command from the Change menu

on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the
context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be
displayed in the Quality column on the Photos pane.

Alignment parameters

The following parameters control the photo alignment procedure and can be modified in the Align Photos
dialog box:

Accuracy
Higher accuracy setting helps to obtain more accurate camera position estimates. Lower accuracy
setting can be used to get the rough camera positions in a shorter period of time.While at High

11
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accuracy setting the software works with the photos of the original size, Medium setting cause image
downscaling by factor of 4 (2 times by each side), and at Low accuracy source files are downscaled
by further 4 times.

Pair preselection

Thealignment process of large photo sets cantake along time. A significant portion of thistime period
is spent on matching of detected features across the photos. Image pair presel ection option may speed
up this process due to selection of asubset of image pairsto be matched. Inthe Gener i ¢ preselection
mode the overlapping pairs of photos are selected by matching photos using lower accuracy setting
first. Inthe Ref er ence preselection mode the overlapping pairs of photos are selected basing on the
measured cameralocations (if present). For obliqueimagery it isrecommended to set Ground altitude
value in the Settings dialog of the Reference pane to make the presel ection procedure more efficient.
Ground altitude information must be accompanied with yaw, pitch, roll datafor cameras to be input
in the Reference pane as well.

Additionally the following advanced parameters can be adjusted.

Key point limit
The number indicates upper limit of feature points on every image to be taken into account during
current processing stage. Using zero value allows PhotoScan to find as many key points as possible,
but it may result in abig number of lessreliable points.

Tiepoint limit
The number indicates upper limit of matching points for every image. Using zero value doesn't apply
any tie point filtering.

Constrain features by mask
When this option is enabled, features detected in the masked image regions are discarded. For
additional information on the usage of masks please refer to the Using masks section.

[ Note

« Tie point limit parameter allows to optimize performance for the task and does not generally
effect the quality of the further model. Recommended value is 1000. Too high tie-point limit
value may cause some parts of the dense point cloud model to be missed. The reason is that
PhotoScan generates depth maps only for pairs of photosfor which number of matching pointsis
abovecertain limit. Thislimit equalsto 100 matching points, unless moved up by thefigure"10%
of the maximum number of matching points between the photo in question and other photos,
only matching points corresponding to the area within the bounding box being considered.”

« The number of tie points can be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. As aresults sparse point cloud will be thinned, yet
the alignment will be kept unchanged.

Point cloud generation based on imported camera data

PhotoScan supportsimport of external and internal camera orientation parameters. Thus, if for the project
precise camera data is available, it is possible to load them into PhotoScan along with the photos, to be
used asinitial information for 3D reconstruction job.

Toimport external and internal camera parameters
1. Select Import Cameras command from the Tools menu.

2. Select the format of the file to be imported.
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3. Browsetothefile and click Open button.

4. The datawill be loaded into the software. Camera calibration data can be inspected in the Camera
Calibration dialog, Adjusted tab, available from Tools menu. If theinput file contains some reference
data (camera position datain some coordinate system), the datawill be shown on the Reference pane,
View Estimated tab.

Cameradatacan beloaded in one of thefollowing formats: PhotoScan *.xml, BINGO *.dat, Bundler *.out,
VisionMap Detailed Report *.txt.

Once the data is loaded, PhotoScan will offer to build point cloud. This step involves feature points
detection and matching procedures. As aresult, a sparse point cloud - 3D representation of the tie-points
data- will begenerated. Build Point Cloud command isavailablefrom Tools- Tie Points menu. Parameters
controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

Building dense point cloud

PhotoScan alows to generate and visualize a dense point cloud model. Based on the estimated camera
positions the program calculates depth information for each camera to be combined into a single dense
point cloud. PhotoScan tends to produce extra dense point clouds, which are of almost the same density,
if not denser, as LIDAR point clouds. A dense point cloud can be edited and classified within PhotoScan
environment or exported to an external tool for further analysis.

To build a dense point cloud

1 Check the reconstruction volume bounding box. To adjust the bounding box usethe % Resize Region
and 2?’ Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to
the desired positions.

2. Select the Build Dense Cloud... command from the Workflow menu.

3. Inthe Build Dense Cloud dialog box select the desired reconstruction parameters. Click OK button
when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Reconstruction parameters

Quality
Specifiesthedesired reconstruction quality. Higher quality settings can be used to obtain more detailed
and accurate geometry, but require longer time for processing.I nterpretation of the quality parameters
here is similar to that of accuracy settings given in Photo Alignment section. The only differenceis
that in this case Ultra High quality setting means processing of original photos, while each following
step implies preprocessing image size downscaling by factor of 4 (2 times by each side).

Additionally the following advanced parameters can be adjusted.

Depth Filtering modes
At the stage of dense point cloud generation reconstruction PhotoScan cal cul ates depth mapsfor every
image. Due to some factors, like poor texture of some elements of the scene, noisy or badly focused
images, there can be some outliers among the points. To sort out the outliers PhotoScan has several
built-in filtering algorithms that answer the challenges of different projects.
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If the geometry of the scene to be reconstructed is complex with numerous small details on the
foreground, then it isrecommended to set M | d depth filtering mode, for important features not
to be sorted out.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable to
chose Aggr essi ve depth filtering mode to sort out most of the outliers.

Moder at e depth filtering mode brings results that are in between the Mild and Aggressive
approaches. Y ou can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Di sabl ed. But this option is not recommended as the resulting
dense cloud could be extremely noisy.

Building mesh

To build amesh

1 Check the reconstruction volume bounding box. To adjust the bounding box usethe PResize Region
and %Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to
the desired positions. If the Hei ght fi el d reconstruction method isto be applied, it isimportant
to control the position of the red side of the bounding box: it defines reconstruction plane. In this case
make sure that the bounding box is correctly oriented.

2. Select the Build Mesh... command from the Workflow menu.

3. Inthe Build Mesh dialog box select the desired reconstruction parameters. Click OK button when
done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Reconstruction parameters

PhotoScan supports several reconstruction methods and settings, which help to produce optimal
reconstructions for a given data set.

Surfacetype

Ar bi t rary surface type can be used for modeling of any kind of object. It should be selected
for closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of
the object modeled, which comes at a cost of higher memory consumption.

Hei ght fi el d surface type is optimized for modeling of planar surfaces, such asterrains or
bas-reliefs. It should be selected for aerial photography processing asit requires lower amount of
memory and allows for larger data sets processing.

Sour ce data
Specifies the source for the mesh generation procedure. Spar se cl oud can be used for fast 3D
model generation based solely on the sparse point cloud. Dense c¢l oud setting will result in longer
processing time but will generate high quality output based on the previously reconstructed dense
point cloud.

Polygon count
Specifies the maximum number of polygons in the final mesh. Suggested values (High, Medium,
Low) are calculated based on the number of pointsin the previously generated dense point cloud: the
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ration is 1/5, 1/15, and 1/45 respectively. They present optimal number of polygons for a mesh of a
corresponding level of detail. Itisstill possible for auser to indicate the target number of polygonsin
thefinal mesh according to hischoice. It could be done through the Custom val ue of the Polygon count
parameter. Please note that while too small number of polygonsis likely to result in too rough mesh,
too huge custom number (over 10 million polygons) is likely to cause model visualization problems
in external software.

Additionally the following advanced parameters can be adjusted.
I nterpolation

If interpolation mode is Di sabl ed it leads to accurate reconstruction results since only areas
corresponding to dense point cloud points are reconstructed. Manual hole filling is usually
required at the post processing step.

WithEnabl ed (def aul t) interpolation mode PhotoScan will interpolate some surface areas
within acircle of a certain radius around every dense cloud point. As aresult some holes can be
automatically covered. Y et some holes can still be present on the model and areto befilled at the
post processing step. Enabl ed ( def aul t) settingisrecommended for orthophoto generation.

In Ext r apol at ed mode the program generates holeless model with extrapolated geometry.
Large areas of extra geometry might be generated with this method, but they could be easily
removed later using selection and cropping tools.
Point classes
Specifies the classes of the dense point cloud to be used for mesh generation. For example, select

only "Ground Points" to produce aDTM as opposed to aDSM. Preliminary dense cloud classification
should be performed for this option of mesh generation to be active.

4 Note

« PhotoScan tendsto produce 3D model swith excessive geometry resolution, soitisrecommended
to perform mesh decimation after geometry computation. Moreinformation on mesh decimation
and other 3D model geometry editing toolsis given in the Editing model geometry section.

Building model texture

To generate 3D model texture
1. Select Build Texture... command from the Workflow menu.

2. Select the desired texture generation parameters in the Build Texture dialog box. Click OK button
when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Texture mapping modes

The texture mapping mode determines how the object texture will be packed in the texture atlas. Proper
texture mapping mode selection helps to obtain optimal texture packing and, consequently, better visual
quality of the final model.
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Generic
The default mode isthe Gener i ¢ mapping mode; it allows to parametrize texture atlas for arbitrary
geometry. No assumptions regarding the type of the scene to be processed are made; program tries
to create as uniform texture as possible.

Adaptive orthophoto
In the Adapti ve orthophot o mapping mode the object surface is split into the flat part and
vertical regions. Theflat part of the surfaceistextured using the orthographic projection, whilevertical
regions are textured separately to maintain accurate texture representation in such regions. When in
the Adapt i ve orthophot o mapping mode, program tends to produce more compact texture
representation for nearly planar scenes, while maintaining good texture quality for vertical surfaces,
such aswalls of the buildings.

Orthophoto
In the Ot hophot o mapping mode the whole object surface is textured in the orthographic
projection. The Ort hophot 0 mapping mode produces even more compact texture representation
than the Adapt i ve ort hophot o mode at the expense of texture quality in vertical regions.

Spherical
Spher i cal mapping modeisappropriate only to acertain class of objectsthat have aball-likeform.
It allows for continuous texture atlas being exported for this type of objects, so that it is much easier
to edit it later. When generating texture in Spherical mapping mode it is crucial to set the Bounding
box properly. The whole model should be within the Bounding box. The red side of the Bounding
box should be under the model; it defines the axis of the spherical projection. The marks on the front
side determine the O meridian.

Single photo

The Si ngl e phot o mapping mode allowsto generate texture from a single photo. The photo to be
used for texturing can be selected from 'Texture from' list.

Keep uv
The Keep uv mapping mode generates texture atlas using current texture parametrization. It can
be used to rebuild texture atlas using different resolution or to generate the atlas for the model
parametrized in the external software.

Texture generation parameters

The following parameters control various aspects of texture atlas generation:

Texturefrom (Single photo mapping mode only)
Specifies the photo to be used for texturing. Available only inthe Si ngl e phot o mapping mode.

Blending mode (not used in Single photo mode)
Selects the way how pixel values from different photos will be combined in the final texture.

Mosai ¢ - givesmore quality for orthophoto and texture atlas than Aver age mode, since it does not
mix image details of overlapping photos but uses most appropriate photo (i. e. the one where the pixel
in question is located within the shortest distance from the image center). Mosaic texture blending
mode is especially useful for orthophoto generation based on approximate geometric model.

Aver age - uses the average value of al pixels from individual photos.
Max | ntensity - the photo which has maximum intensity of the corresponding pixel is selected.

M n | ntensity - the photo which has minimum intensity of the corresponding pixel is selected.
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Texturesize/ count
Specifies the size (width & hight) of the texture atlas in pixels and determines the number of files
for texture to be exported to. Exporting texture to severa files allows to archive greater resolution of
the final model texture, while export of high resolution texture to a single file can fail due to RAM
limitations.

Additionally the following advanced parameters can be adjusted.

Enable color correction
The feature is useful for processing of data sets with extreme brightness variation. However, please
notethat color correction processtakes up quitealong time, soit isrecommended to enabl e the setting
only for the data sets that proved to present results of poor quality.

[ Note

* HDR texture generation requires HDR photos on input.

To improve result texture quality it may be reasonable to exclude poorly focused images from processing
at this step. PhotoScan suggests automatic image quality estimation feature. Images with quality value of
less than 0.5 units are recommended to be disabled and thus excluded from texture generation procedure.

To disable a photo use @ Disable button from the Photos pane toolbar.

PhotoScan estimates image quality as a relative sharpness of the photo with respect to other images in
the data set. The value of the parameter is calculated based on the sharpness level of the most focused
part of the picture.

To estimate image quality

1 Switch to the detailed view in the Photos pane using ‘==Details command from the Change menu

on the Photos pane toolbar.
2. Select all photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the
context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be
displayed in the Quality column on the Photos pane.

Saving intermediate results

Certain stages of 3D model reconstruction can take along time. The full chain of operations could easily
last for 4-6 hours when building a model from hundreds of photos. It is not always possible to finish all
the operations in one run. PhotoScan allows to save intermediate resultsin a project file.

PhotoScan project files may contain the following information:
« List of loaded photographs with reference paths to the image files.

» Photo alignment data such as information on camera positions, sparse point cloud model and set of
refined camera calibration parameters for each calibration group.

» Masks applied to the photosin project.
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» Depth maps for cameras.
» Dense point cloud model with information on points classification.

* Reconstructed 3D polygona model with any changes made by user. This includes mesh and texture
if it was built.

 List of added markers aswell as of scale-bars and information on their positions.
* Structure of the project, i.e. number of chunksin the project and their content.

Y ou can save the project at the end of any processing stage and return to it later. To restart work simply
load the corresponding file into PhotoScan. Project files can also serve as backup files or be used to save
different versions of the same model.

Notethat since PhotoScan tendsto generate extradense point cloudsand highly detailed polygona models,
project saving procedure can take up quite along time. Y ou can decrease compression level to speed up the
saving process. However, please note that it will result in alarger project file. Compression level setting
can be found on the Advanced tab of the Preferences dialog available from Tools menu.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file
to another location do not forget to move or copy photographs with all the folder structure involved as
well. Otherwise, PhotoScan will fail to run any operation requiring source images, although the project
file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store
absolute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

PhotoScan supports export of processing resultsin various representations; sparse and dense point clouds,
camera calibration and camera orientation data, mesh, etc. Orthophotos and digital elevation models (both
DSM and DTM) can be generated according to the user requirements.

Point clouds and camera calibration data can be exported right after photo alignment is completed. All
other export options are available after the 3D model is built.

If you are going to export the results (point cloud / mesh / DEM / orthophoto) for the model that is not
referenced, please note that the resulting file will be oriented according to adefault coordinate system (see
axesin the bottom |eft corner of the Model view), i. e. the model can be shown differently from what you

e 1Y
seein PhotoScan window. To align the model orientation with the default coordinate system use ““<Rotate
object button from the Toolbar.

In some cases editing model geometry in the external software may be required. PhotoScan supports model
export for editing in external software and then allows to import it back, asit is described in the Editing
model geometry section of the manual.

Main export commands are available from the File menu and the rest from the Export submenu of the
Tools menu.

Point cloud export

To export sparse or dense point cloud
1.  Select Export Points... command from the File menu.

2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.
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In the Export Points dialog box select desired Type of point cloud - Sparse or Dense.

Specify the coordinate system and indicate export parameters applicable to the selected file type,
including the dense cloud classes to be saved.

Click OK button to start export.

The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Split in blocks option in the Export Points dialog can be useful for exporting large projects. It is available
for referenced models only. Y ou can indicate the size of the section in xy plane (in meters) for the point
cloud to be divided into respective rectangular blocks. The total volume of the 3D sceneis limited with
the Bounding Box. The whole volume will be split in equal blocks starting from the point with minimum
x and y values. Note that empty blocks will not be saved.

In some casesit may be reasonableto edit point cloud before exporting it. To read about point cloud editing
refer to the Editing point cloud section of the manual.

PhotoScan supports point cloud export in the following formats:

Wavefront OBJ
Stanford PLY

XYZ text file format
ASPRSLAS

ASTM E57

u3D

potree

PhotoScan OC3

PDF

4 Note

« Saving color information of the point cloud is supported by the PLY, E57, LAS and TXT file
formats.

¢ Saving point normalsinformation is supported by the OBJ, PLY and TXT file formats.

Tie points data export

To export matching points

1

2.

Select Export Matches... command from the Tools menu.
Browse the destination folder, choose the file type, and print in the file name. Click Save button.

In the Export Matches dialog box set export parameters. Precision value sets the limit to the number
of decimal digitsin the tie points coordinates to be saved.
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4. Click OK bhutton to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

PhotoScan supports matching points data export in the following formats:

* BINGO (*.dat) - saves origina intrinsic and extrinsic camera data along with matching points
coordinates.

« ORIMA (* .txt)
« PATB (*.pth)

Matching points exported from PhotoScan can be used as a basis for AT procedure to be performed in
some external software. Later on estimated camera data can be imported back to PhotoScan (using Import
Cameras command from the Tools menu) to proceed with 3D model reconstruction procedure.

Camera calibration and orientation data export

To export camera calibration and camera orientation data select Export Cameras... command from the
Tools menu.

To export / import only camera calibration data select Camera Calibration... command from the Tools
menul.

PhotoScan supports camera data export in the following formats:
» PhotoScan structure file format (XML based)

* Bundler OUT file format

* CHAN file format

* Boujou TXT file format

» Omega Phi Kappatext file format

» PATB Exterior orientation

» BINGO Exterior orientation

» AeroSys Exterior orientation

* Inpho project file

4  Note

» Cameradata export in Bundler and Boujou file formats will save sparse point cloud datain the
samefile.

« Cameradataexport in Bundler file format would not save distortion coefficients k3, k4.
Panorama export

PhotoScan is capable of panorama stitching for images taken from the same camera position - camera
station. To indicate for the software that loaded images have been taken from one camera station one
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should move those photos to a camera group and assign Camera Station type to it. For information on
camera group refer to Loading photos section.

To export panorama
1. Select Export - Export Panorama... command from the Tools menu.
2. Select camera group which panorama should be previewed for.

3. Choose panoramaorientation in the file with the hel p of navigation buttonsto the right of the preview
window in the Export Panorama dial og.

4. Set exporting parameters: select camera groups which panorama should be exported for and indicate
export file name mask.

5. Click OK button

6. Browsethe destination folder and click Save button.
3D model export

To export 3D model
1. Select Export Model... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. Inthe Export Model dialog specify the coordinate system and indicate export parameters applicable
to the selected file type.

4. Click OK button to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

£ Note

« If the model is exported in local coordinates, PhotoScan can write a KML file for the exported
model to be correctly located on Google Earth.

If amodel generated with PhotoScan is to be imported in a 3D editor program for inspection or further
editing, it might be helpful to use Shift function while exporting the model. It allows to set the value to
be subtracted from the respective coordinate value for every vertex in the mesh. Essentialy, this means
trandlation of themodel coordinate system origin, which may be useful since some 3D editors, for example,
truncate the coordinates values up to 8 or so digits, while in some projects they are decimals that make
sense with respect to model positioning task. So it can be recommended to subtract a value equal to the
whole part of acertain coordinate val ue (see Reference pane, Camera coordinates val ues) before exporting
the model, thus providing for areasonable scale for the model to be processed in a 3D editor program.

PhotoScan supports model export in the following formats:
» Wavefront OBJ
» 3DSfileformat

* VRML
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 COLLADA

» Stanford PLY

* STL models

+ Autodesk FBX

* Autodesk DXF

» Google Earth KMZ
» U3D

» Adobe PDF

Some fileformats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in aseparatefile. The
texture file should be kept in the same directory as the main file describing the geometry. If the texture
atlas was not built only the model geometry is exported.

Orthophoto export

Orthophoto export is normally used for generation of high resolution imagery based on the source photos
and reconstructed geometry. The most common application is aerial photographic survey processing, but
it may be also useful when a detailed view of the object is required. Orthophoto is often accompanied by
the digital elevation model (see the next section).

In order to export orthophoto in the correct orientation it is necessary to set the coordinate system for
the model first. Since PhotoScan uses original images to build an orthophoto, there is no need to build
atexture atlas.

To export Orthophoto
1. Select Export Orthophoto... command from the File menu.
2. Inthe Export Orthophoto dialog box specify coordinate system to georeference the Orthophoto.

3. Select Blending mode to be used for texture mapping (for details please see the Building model
texture section).

4. Check Write KML file and / or Write World file options to create files needed to georeference the
orthophoto in the Google Earthand / or aGIS.

5. Click Export button to start export.
6. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

7. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

* Write KML file option is available only if the model is georeferenced in WGS84 coordinate
system due to the fact that Google Earth supports only this coordinate system.

» World file specifies coordinates of the four angle vertices of the exporting orthophoto. This
information is already included in GeoTIFF file, however, you could duplicate it for some
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reason. If you need to export orthophoto in JPEG or PNG file formats and would like to have
georeferencing data this informations could be useful.

PhotoScan allows to export Orthophoto in different planar projections as well. To export Orthophoto in a
planar projection choose Planar Projection Type in Export Orthophoto dialog. Y ou can select projection
plane and orientation of the Orthophoto. PhotoScan provides an option to project the model to a plane
determined by a set of markers (if there are no 3 markersin a desired projection plane it can be specified
with 2 vectors, i. e. 4 markers).

If the export file of afixed sizeis needed, it is possible to to set the length of the longer side of the export
filein Max. dimension (pix) parameter. The length should be indicated in pixels.

Split in blocks option in the Export Orthophoto dialog can be useful for exporting large projects. You
can indicate the size of the blocks (in pix) for the orthophoto to be divided into. The whole area will be
split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will
not be saved.

To export a particular part of the project use Region section of the Export Orthophoto dialog. Indicate
coordinates of the bottom left and top right corners of the region to be exported in the [eft and right columns
of the textboxes respectively. Estimate button allows you to see the coordinates of the bottom left and top
right corners of the whole area.

Default value for pixel size in Export Orthophoto dialog refers to ground sampling resolution, thus, it is
uselessto set asmaller value: the number of pixelswould increase, but the effective resolution would not.
If you have chosen to export orthophoto with a certain pixel size (not using Max. dimension (pix) option),
it isrecommended to check estimated Total size (pix) of the resulting file to be sure that it is not too large
to be correctly saved to the targeted file format.

4 Note

« Colour correction feature is useful for processing of data sets with extreme brightness variation.
However, please note that color correction process takes up quite a long time, so it is
recommended to enable the setting only for the data sets that proved to present results of poor
quality before.

The following formats are supported for orthophoto export:
« JPEG

* PNG

TIFF

» GeoTIFF

Multiresolution Google Earth KML mosaic.

4 Note

* Multispectral orthophoto export is supported in GeoTIFF format only. When exporting in other
formats, only master channel will be saved.

4 Note

* While exporting (Geo) TIFF file LZW compression is applied. If you need an original file or, on
the contrary, more compressed file, you should use external software to do the transformation.
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However, one should be careful with the selected tool not to lose georeferencing information (in
case of GeoTIFF file) during compression/decompression procedure.

DEM (DSM / DTM) export

Digita elevation models (DEMSs) represent the model surface as aregular grid of height values, and are
often used for aerial photographic survey data. Digital elevation model can be combined with orthophoto
to produce a 3D model of the area.

PhotoScan allows to export both a digital surface model (DSM) and a digital terrain model (DTM). A
DSM can be exported if you have previously built mesh based on all point classes (default DEM export).
A DTM can be exported for a mesh based on ground points only.

4 Note

« DEM export isavailable only for referenced models. So make sure that you have set a coordinate
system for your model before going to DEM export operation.

Toexport DSM
1. Select Export DEM... command from the File menu.
2. Inthe Export DEM dialog box specify coordinate system to georeference the DEM.

3. Check Write KML file and / or Write World file options to create files needed to georeference the
DEM inthe Google Earth and / or a GIS.

4. Click Export button to start export.
5. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Toexport DTM

1. Reference dense point cloud model. For guidance on Setting coordinate system please go to Setting
coordinate system

2. Classify Ground Points using the command available from the Dense Cloud submenu of the Tools
menu.

3. Buildmeshbased on Gr ound Poi nt s classonly. See Advanced settingsin the Build Mesh dialog.
4. Select Export DEM... command from the File menu.
5. Inthe Export DEM dialog box specify coordinate system to georeference the DEM.

6. Check Write KML file and / or Write World file options to create files needed to georeference the
DEM in the Google Earth and / or aGIS.

7. Click Export button to start export.
8. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

9. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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4 Note

Write KML file option is available only if the model is georeferenced in WGS84 coordinate
system due to the fact that Google Earth supports only this coordinate system.

Worldfile specifies coordinates of thefour angle verticesof theexporting DEM. Thisinformation
isalready included in GeoTIFF elevation dataaswell asin other supported file formatsfor DEM
export, however, you could duplicate it for some reason.

PhotoScan allowsto export DEM in different planar projectionsin the sameway asit isdonefor orthophoto
export. (See Orthophoto export section.)

If the export file of afixed sizeis needed, it is possible to to set the length of the longer side of the export
filein Max. dimension (pix) parameter. The length should be indicated in pixels.

Unlike orthophoto export, it is sensible to set smaller pixel size compared to the default value in DEM
export dialog; the effective resolution will increase. If you have chosen to export DEM with a certain pixel
size (not using Max. dimension (pix) option), it is recommended to check estimated Total size (pix) of the
resulting file to be sure that it is not too large to be correctly saved to the targeted file format.

£ Note

Export DEM dialog alows to crop invalid DEM (i. e. DEM parts corresponding to the areas
visible on less than 2 source photos). The values for the points of the grid that couldn't be
calculated will be set to the value indicated in no-data val ue box.

Split in blocks option in the Export DEM dialog can be useful for exporting large projects or
meeting special DEM requirements. (See Orthophoto export section for details.)

To export a particular part of the project use Region section of the Export DEM dialog. (See
Orthophoto export section for details.)

The following formats are supported for DEM export:

» GeoTIFF elevation data

Arc/Info ASCII Grid (ASC)
Band interleaved file format (BIL)
XYZ fileformat

Sputnik KMZ

Extra products to export

In addition to main targeted products PhotoScan allows to export several other processing results, like

 Undistort photos, i. e. photosfree of lensdistortions (Undistort Photos... command avail able from Export
submenu of the Tools menu).

» Depth map for any image (Export Depth... command available from photo context menu).

* Model intiles, i. e. mesh split in blocks of acertain size (Export Tiles... command available from Export
Model submenu of the File menu).
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PhotoScan supports direct uploading of the modelsto the Sketchfab and Verold resources. To publish your
model online use Upload Model... command from the File menu.

Processing report generation

PhotoScan supports automatic processing report generation in PDF format, which contains the basic
parameters of the project, processing results and accuracy estimates.

To generate processing report
1. Select Generate Report... command from the File menu.

2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

PhotoScan processing report represents the following data:
 Orthophoto and digital elevation model sketch.

» Camera parameters and survey scheme.

* Image overlap statistics.

» Camera positioning error estimates.

» Ground control point error estimates.

4 Note

e Complete processing report can be exported only after geometry is reconstructed and
georeferenced. However, Report with information on the alignment procedureresultsisavailable
for export right after the corresponding processing step.

< For comments on types of errors indicated in the processing report please refer to Optimization
of camera alignment.
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Chapter 4. Referencing and
measurements

Camera calibration

Calibration groups

While carrying out photo alignment PhotoScan estimates both internal and external camera orientation
parameters, including nonlinear radial distortions. For the estimation to be successful it is crucial to apply
the estimation procedure separately to photos taken with different cameras. Once photos have been loaded
in the program, PhotoScan automatically divides them into calibration groups according to the image
resolution and/or EXIF metadata like cameratype and focal length. All the actions described bel ow could
and should be applied (or not applied) to each calibration group individually.

Calibration groups can be rearranged manually.

To createanew calibration group

1. Select Camera Calibration... command from the Tools menu.

2. Inthe Camera Calibration dialog box, select photos to be arranged in a new group.
3. Intheright-click context menu choose Create Group command.

4. A new group will be created and depicted on the left-hand part of the Camera Calibration dial og box.

To move photos from one group to another
1. Select Camera Calibration... command from the Tools menu.
2. Inthe Camera Calibration dialog box choose the source group on the left-hand part of the dialog.

3. Select photos to be moved and drag them to the target group on the left-hand part of the Camera
Calibration dialog box.

To place each photo into a separate group you can use Split Groups command available at the right button
click on acalibration group name in the | eft-hand part of the Camera Calibration dialog

Camera types

PhotoScan supports three major types of camera: frame camera, spherical camera, and fisheye camera.
Cameratype can be set in Camera Calibration dialog box available from Tools menu.

Fr ame caner a. If the source datawithin acalibration group was shot with aframe camera, for successful
estimation of camera orientation parameters the information on approximate focal length (pix) isrequired.
Obviously, to calculate focal length valuein pixel it is enough to know focal length in mm along with the
sensor pixel sizein mm. Normally this datais extracted automatically from the EXIF metadata.

Fi sheye caner a. If extrawide lenses were used to get the source data, standard PhotoScan camera
model will not allow to estimate camera parameters successfully. Fish Eye camera type setting will
initialize implementation of adifferent cameramodel to fit ultra-wide lens distortions.
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Spheri cal canera. In case the source data within a calibration group was shot with a spherical
camera, camera type setting will be enough for the program to calculate camera orientation parameters.
No additional information is required except the image in equirectangular representation.

In case source images lack EXIF data or the EXIF datais insufficient to calculate focal length in pixels,
PhotoScan will assume that focal length equalsto 50 mm (35 mm film equivalent). However, if theinitial
guess values differ significantly from the actual focal length, it islikely to lead to failure of the alignment
process. So, if photosdo not contain EXIF metadata, it is preferable to specify focal length (mm) and sensor
pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools menu.
Generally, this data is indicated in camera specification or can be received from some online source. To
indicate to the program that camera orientation parameters should be estimated based on the focal length
and pixel size information, it is necessary to set the Type parameter on the Initial tab to Auto value.

Camera calibration parameters

Once you have tried to run the estimation procedure and got poor results, you can improve them thanks
to the additional data on calibration parameters.

To specify camera calibration parameters
1. Select Camera Calibration... command from the Tools menu.

2. Select calibration group, which needs reestimation of camera orientation parameters on the left side
of the Camera Calibration dialog box.

3. Inthe Camera Cdlibration dialog box, select | ni ti al tab.

4. Modify the calibration parameters displayed in the corresponding edit boxes.
5. Set the Typeto the Precdlibrated value.

6. Repeat to every calibration group where applicable.

7. Click OK button to set the calibration.
4 Note

 Alternatively, initia calibration data can be imported from file using Load button on the Initial
tab of the Camera Calibration dialog box. In addition to PhotoScan calibration file format it is
possible to import data from Australis, PhotoModeler, 3DM CalibCam, CalCam.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos
processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera
Calibration dialog box.

If very precise calibration dataisavailable, to protect it from recal cul ation one should check Fix calibration
box. In this caseinitia calibration datawill not be changed during Align Photos process.

Adjusted camera calibration data can be saved to file using Save button on the Adjusted tab of the Camera
Calibration dialog box.

Calibration parameters list

fx, fy
Focal length in x- and y-dimensions measured in pixels.
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CX, cy
Principal point coordinates, i.e. coordinates of lens optical axis interception with sensor plane.

skew
Skew transformation coefficient.

k1, k2, k3, k4
Radia distortion coefficients.

pl, p2
Tangential distortion coefficients.

Setting coordinate system

Many applications require data with a defined coordinate system. Setting the coordinate system also
provides a correct scaling of the model allowing for surface area and volume measurements and makes
model loading in geoviewers and geoinformatics software much easier. Some functionality like digital
elevation model export is available only after the coordinate system is defined.

PhotoScan supports setting a coordinate system based on either ground control point (marker) coordinates
or camera coordinates. In both cases the coordinates are specified in the Reference pane and can be either
loaded from the external file or typed in manually.

Setting coordinate system based on recorded camera positions is often used in aerial photography
processing. However it may be also useful for processing photos captured with GPS enabled cameras.
Placing markersisnot required if recorded camera coordinates are used to initialize the coordinate system.

In the case when ground control points are used to set up the coordinate system the markers should be
placed in the corresponding locations of the scene.

Using camera positioning data for georeferencing the model is faster since manual marker placement is
not required. On the other hand, ground control point coordinates are usually more accurate than telemetry
data, allowing for more precise georeferencing.

Placing markers

PhotoScan uses markersto specify locations within the scene. Markers are used for setting up a coordinate
system, photo alignment optimization, measuring distances and volumes within the scene as well as for
marker based chunk alignment. Marker positions are defined by their projections on the source photos.
Themore photos are used to specify marker position the higher isaccuracy of marker placement. To define
marker location within a scene it should be placed on at least 2 photos.

£ Note

« Marker placement is not required for setting the coordinate system based on recorded camera
coordinates. This section can be safely skipped if the coordinate system is to be defined based
on recorded camera locations.

PhotoScan supports two approaches to marker placement: manual marker placement and guided marker
placement. Manual approach implies that the marker projections should be indicated manually on each
photo where the marker is visible. Manual marker placement does not require 3D model and can be
performed even before photo alignment.
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In the guided approach marker projection is specified for a single photo only. PhotoScan automatically
projects the corresponding ray onto the model surface and calculates marker projections on the rest of
the photos where marker is visible. Marker projections defined automatically on individual photos can be
further refined manually. Reconstructed 3D model surfaceis required for the guided approach.

Guided marker placement usually speeds up the procedure of marker placement significantly and also
reduces the chance of incorrect marker placement. It is recommended in most cases unless there are any
specific reasons preventing this operation.

To place amarker using guided approach
1. Open aphoto where the marker is visible by double clicking on its name.

2 Switch to the marker editing mode using ”Q?Edit Markers toolbar button.

3. Right click on the photo at the point corresponding to the marker location.

4. Select Create Marker command from the context menu. New marker will be created and its projections
on the other photos will be automatically defined.

4 Note

« If the 3D model is not available or the ray at the selected point does not intersect with the model
surface, the marker projection will be defined on the current photo only.

« Guided marker placement can be performed in the same way from the 3D view by right clicking

on the corresponding point on the model surface and using ”:BCreate Marker command from the
context menu. While the accuracy of marker placement in the 3D view isusually much lower, it
may be still useful for quickly locating the photos observing the specified |ocation on the model.

To view the corresponding photos use H@Fi Iter by Markers command again from the 3D view
context menu. If thecommand isinactive, please make surethat the marker in question is selected
on the Reference pane.

To place amarker using manual approach

1 Create marker instance using “%Add marker button on the Workspace pane or by Add Marker

command from the Chunk context menu (available by right clicking on the chunk title on the
Workspace pane).

2. Openthe photo where the marker projection needsto be added by doubl e clicking on the photos name.

Switch to the marker editing mode using ”Q?Edit Markers toolbar button.

4. Right click at the point on the photo where the marker projection needsto be placed. From the context
menu open Place Marker submenu and select the marker instance previously created. The marker
projection will be added to the current photo.

5. Repeat the previous step to place marker projections on other photos if needed.
To save up time on manual marker placement procedure PhotoScan offers guiding lines feature. When a

marker is placed on an aligned photo, PhotoScan highlights lines, which the marker is expected to lie on,
on the rest of the aigned photos.

30



Referencing and measurements

4 Note

« If a marker has been placed on at least two aligned images PhotoScan will find the marker

projections on the rest of the photos. The calculated marker positions will be indicated with }
icon on the corresponding aligned photosin Photo View mode.

Automatically defined marker locations can be | ater refined manually by dragging their projections on the
corresponding photos.

Torefine marker location

1. Open the photo where the marker is visible by double clicking on the photo's name. Automatically

placed marker will be indicated with ":t?i con.

Switch to the marker editing mode using P?Edit Markers toolbar button.

3. Movethe marker projection to the desired location by dragging it using left mouse button. Once the

marker location is refined by user, the marker icon will change to ”‘—‘D

4 Note

* To list photos where the marker locations are defined, select the corresponding marker on the
Workspace pane. The photos where the marker is placed will be marked with a":t? icon on the

Photos pane. To filter photos by marker use ﬂ%iFiIter by Markers command from the 3D view
context menu.

In those cases when there are hesitations about the features depi cted on the photo, comparative inspection
of two photos can prove to be useful. To open two photos in PhotoScan window simultaneously Move to
Other Tab Group command is available from photo tab header context menu.

To open two photos simultaneously

1. Inthe Photos pane double click on one photo to be opened. The photo will be opened in a new tab
of the main program window.

2. Right click on thetab header and choose Move to Other Tab Group command from the context menu.
The main program window will be divided into two parts and the photo will be moved to the second
part.

3. Thenext photo you will choose to be opened with a double click will be visualized in the active tab
group.

PhotoScan automatically assignsdefault |abelsfor each newly created marker. Theselabel s can be changed
using the Rename... command from the marker context menu in the Workspace / Reference pane.

Assigning reference coordinates

To reference the model the real world coordinates of at least 3 points of the scene should be
specified. Depending on the requirements, the model can be referenced using marker coordinates, camera
coordinates, or both. Real world coordinates used for referencing the model aong with the type of
coordinate system used are specified using the Reference pane.
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The model can be located in either local Euclidean coordinates or in georeferenced coordinates. For
model georeferencing awide range of various geographic and projected coordinate systems are supported,
including widely used WGS84 coordinate system. Besides, amost all coordinate systems from the EPSG
registry are supported as well.

Reference coordinates can be specified in one of the following ways:
 Loaded from a separate text file (using character separated values format).
» Entered manually in the Reference pane.

» Loaded from GPS EXIF tags (if present).

Toload reference coordinates from a text file

1 Click r!Import toolbar button on the Reference pane. (To open Reference pane use Reference

command from the View menu.) Browse to the file containing recorded reference coordinates and
click Open button.

2. IntheImport CSV dialog set the coordinate system if the data presents geographical coordinates.

3. Select theddimiter and indicate the number of the datacolumn for each coordinate. Indicate columns
for the orientation data if present.

4. Click OK button. The reference coordinates data will be loaded onto the Reference pane.

4 Note

« Inthe datafile columns and rows are numbered starting from O.

« If reference coordinates of amarker / camera position for aphoto are not specified in the loading
file the current value will be kept for them.

* Anexample of acoordinates datafilein the CSV format is given in the next section.

To assign reference coordinates manually

1 Switch to the View Source mode using EVi ew Source button from the Reference pane toolbar. (To

open Reference pane use Reference command from the View menu.)
2. Onthe Reference pane double click on x/y/z cells to assign values to corresponding coordinates.
3. Repeat for every marker / camera position needed to be specified.

4. To remove unnecessary reference coordinates select corresponding items from the list and press Del
key.

Click 'TI'UU pdate toolbar button to apply changes and set coordinates.

Toload reference coordinates from GPS EXIF tags

Click E.Import EXIF button on the Reference pane. (To open Reference pane use Reference
command from the View menu.) The reference coordinates data will be loaded into the Reference
pane.
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After reference coordinates have been assigned PhotoScan automatically estimates coordinatesin alocal
Euclidean system and cal cul ates the referencing errors. To see the results switch to the View Estimated or

View Errors modes respectively using EView Estimated and Lj!_Vievv Errorstoolbar buttons. Thelargest
error will be highlighted.

To set a georeferenced coordinate system
1. Assign reference coordinates using one of the options described above.

2 Click ‘@5 Settings button on the Reference pane toolbar.

3. In the Reference Settings dialog box select the Coordinate System used to compile reference
coordinates data if it has not been set at the previous step.

4. Specify the assumed measurement accuracy.

5. Indicate relative camera to GPS system coordinates if present in Camera Correction section of the
Reference Settings dialog box.

6. Click OK button to initialize the coordinate system and estimate geographic coordinates.

Rotation angles in PhotoScan are defined around the following axes: yaw axis runs from top to bottom,
pitch axis runs from left to right wing of the drone, roll axis runs from tail to nose of the drone. Zero
values of the rotation angle triple define the following camera position aboard: cameralooks down to the
ground, frames are taken in landscape orientation, and horizontal axis of the frame is perpendicular to the
central (tail-nose) axis of the drone. If the camera s fixed in a different position, respective yaw, pitch,
roll values should beinput in the camera correction section of the Settings dialog. The senses of the angles
are defined according to the right-hand rule.

[ Note

e Step 5 can be safely skipped if you are using standard GPS system (not that of superhigh
precision).

In Select Coordinate System dialog it is possible to ease searching for the required georeferencing system
using Filter option. Enter respective EPSG code (e.g. EPSG::4302) to filter the systems.

To view the estimated geographic coordinates and reference errors switch between the View Estimated

and View Errors modes respectively using EView Estimated and LT'!_View Errors toolbar buttons. The
largest error will be highlighted. A click on the column name on the Reference pane sorts the markers and
photos by the data in the column. At this point you can review the errors and decide whether additional
refinement of marker locations is required (in case of marker based referencing), or if certain reference
points should be excluded.

To savethe errorsand / or estimated coordinates use Export toolbar button on the Reference pane.

To reset a chunk georeferencing use Reset Transform command from the chunk context menu on the
Workspace pane. [R] indicator of achunk being georeferenced will be removed from the chunk name.

4  Note

« Unchecked reference points on the Reference pane are not used for georeferencing. Use context
menu to check / uncheck selected items.
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» After adjusting marker locations on the photos, the coordinate system will not be updated

automatically. It should be updated manually using ElullﬂUpdate toolbar button on the Reference
pane.

» PhotoScan allows to convert the estimated geographic coordinates into a different coordinate
system. To calculate the coordinates of the camera positions and / or markers in a different

coordinate system use | Convert toolbar button on the Reference pane.

Example of a reference coordinates file in CSV format
(*.txt)

Thereference coordinates can beloaded onto the Reference pane using character separated text fileformat.
Each reference pointisspecified in thisfile on aseparateline. Sample reference coordinatesfileis provided
below:

# <l abel > <> <y> <z>

I MG_0159. JPG 40. 165011 48.103654 433. 549477
I MG_0160. JPG 40. 165551 48.103654 434.724281
I MG_0161. JPG 40. 166096 48.103640 435. 630558

Individual entries on each line should be separated with at ab (space, sem col on, comm, etc)
character. All lines starting with # character are treated as comments.

Records from the coordinate file are matched to the corresponding photos or markers basing on the
| abel field. Camera coordinates |abels should match the file name of the corresponding photo including
extension. Marker coordinates |abels should match the label s of the corresponding markersin the project
file. All l1abels are case insensitive.

4 Note

» Character separated reference coordinates format does not include specification of the type of
coordinate system used. The kind of coordinate system used should be selected separately.

» PhotoScan requires z value to indicate height above the ellipsoid.

Optimization of camera alignment

PhotoScan estimates internal and external camera orientation parameters during photo alignment. This
estimation is performed using image data alone, and there may be some errorsin the final estimates. The
accuracy of the final estimates depends on many factors, like overlap between the neighboring photos, as
well as on the shape of the object surface. These errors can lead to non-linear deformations of the final
model.

During georeferencing the model is linearly transformed using 7 parameter similarity transformation (3
parameters for trandation, 3 for rotation and 1 for scaling). Such transformation can compensate only a
linear model misalignment. The non-linear component can not be removed with this approach. Thisis
usually the main reason for georeferencing errors.
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Possible non-linear deformations of the model can be removed by optimizing the estimated point cloud
and camera parameters based on the known reference coordinates. During this optimization PhotoScan
adjusts estimated point coordinates and camera parameters minimizing the sum of reprojection error and
reference coordinate misalignment error.

To achieve greater optimizing results it may be useful to edit sparse point cloud deleting obviously
mislocated points beforehand. To read about point cloud editing refer to the Editing point cloud section
of the manual.

Georeferencing accuracy can be improved significantly after optimization. It is recommended to perform
optimization if the final model isto be used for any kind of measurements.

To optimize camera alignment

1. Setthemarker and/ or camera coordinates to be used for optimization (if not done yet).

2 Click ‘“ESetti ngstoolbar button on the Reference pane and set the coordinate system (if not done yet).

3. In the Reference pane Settings dialog box specify the assumed accuracy of ground control
measurements, as well as the assumed accuracy of marker projections on the source photos.

4. Indicate relative camera to GPS device coordinates if present in Camera Correction section of the
Reference pane Settings dialog box.

5. Click OK button.

Click # Optimizetoolbar button. In Optimize CameraAlignment dial og box check additional camera
parameters to be optimized if needed. Click OK button to start optimization.

7. After the optimization is complete, the georeferencing errors will be updated.

4 Note

e Step 4 can be safely skipped if you are using standard GPS (not that of superhigh precision).

« The model data (if any) is cleared by the optimization procedure. Y ou will have to rebuild the
model geometry after optimization.

Generally it isreasonableto run optimization procedure based on markersdataonly. It isdueto thefact that
GCPs coordinates are measured with significantly higher accuracy compared to GPS data that indicates
camera positions. Thus, markers data are sure to give more precise optimization results. Moreover, rather
often GCP and camera coordinates are measured in different coordinate systems, that also prevents from
using both cameras and markers data in optimization simultaneously.

In case optimization results does not seem to be satisfactory, you can try recal culating with lower values
of parameters, i.e. assuming ground control measurements to be more accurate.

Scale bar based optimization

Scale bar is program representation of any known distance within the scene. It can be a standard ruler or
a specialy prepared bar of a known length. Scale bar is a handy tool to add supportive reference data to
your project. They can prove to be useful when there is no way to locate ground control points al over
the scene. Scale bars alow to save field work time, since it is significantly easier to place several scae
bars with precisely known length, then to measure coordinates of afew markers using special equipment.
In addition, PhotoScan alows to place scale bar instances between cameras, thus making it possible to
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avoid not only marker but ruler placement within the scene as well. Surely, scale bar based information
will not be enough to set a coordinate system, however, the information can be successfully used while
optimizing the results of photo alignment. It will also be enough to perform measurements in PhotoScan
software. See Performing measurements.

To add a scale bar

1.

Place markers at the start and end points of the bar. For information on marker placement please refer
to the Setting coordinate system section of the manual.

Select both markers on the Reference pane using Ctrl button.

Select E&Create Scale Bar command form the Model view context menu. The scalebar will be created
and an instant added to the Scale Bar list on the Reference pane.

Switch to the EView Source mode using the Reference pane toolbar button.

Double click on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

To add a scale bar between camer as

1

Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the
cameras can be selected in the Model view window using selecting tools from the Toolbar.

Select EEiCreate Scale Bar command form the context menu. The scale bar will be created and an
instant added to the Scale Bar list on the Reference pane.

Switch to the EView Source mode using the Reference pane toolbar button.

Double click on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

Torun scale bar based optimization

1

2.

On the Reference pane check all scale bars to be used in optimization procedure.

Click ‘“ESetti ngs toolbar button on the Reference pane. In the Reference pane Settings dialog box
specify the assumed accuracy of scale bars measurements.

Click OK button.

Click # Optimizetoolbar button. In Optimize CameraAlignment dialog box check additional camera
parameters to be optimized if needed. Click OK button to start optimization.

After the optimization is complete, cameras and markers estimated coordinates will be updated as well as
all the georeferencing errors. To analyze optimization results switch to the View Estimated mode using
the Reference pane toolbar button. In scale bar section of the Reference pane estimated scale bar distance

will be displayed.
To deletea scale bar
1. Select the scale bar to be deleted on the Reference pane.
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2. Right-click on it and chose Remove Scale Bars command from the context menu.

3. Click OK for the selected scale bar to be deleted.
What does the errors in the Reference pane mean?

Cameras section
1. Error (m) - distance between the input (source) and estimated positions of the camera
2. Error (deg) - root mean square error calculated over al three orientation angles.

3. Error (pix) - root mean square reprojection error calculated over al feature points detected on the
photo.

Markers section
1. Error (m) - distance between the input (source) and estimated positions of the marker.

2. Error (pix) - root mean sguare reprojection error for the marker calculated over al photos where
marker isvisible.

Scale Bar s section

»  Error (M) - difference between the input (source) scale bar length and the measured distance between
two cameras or markers representing start and end points of the scale bar.

If the total reprojection error for some marker seems to be too large, it is recommended to inspect
reprojection errors for the marker on individual photos. The information is available with Show Info
command from the marker context menu on the Reference pane.

Working with coded and non-coded targets

Overview

Coded and non-coded targets are specially prepared, yet quite simple, real world markers that can add up
to successful 3D model reconstruction of a scene. The difference between coded and non-coded targets
is that while a non-coded target |ooks like an ordinary full circle or afigure (circle / rectangular) with 4
segments, the coded target has aring parted in black and white segments around the central full circle.

Coded targets advantages and limitations

Coded targets (CTs) can be used as markersto define local coordinate system and scale of the model or as
true matches to improve photo alignment procedure. PhotoScan functionality includes automatic detection
and matching of CTson source photos, which allowsto benefit from marker implementation in the project
while saving time on manual marker placement. Moreover, automatic CTs detection and marker placement
is more precise then manual marker placement.

PhotoScan supports three types of circle CTs: 12 bit, 16 bit and 20 bit. While 12 bit pattern is considered
to be decoded more precisely, 16 bit and 20 bit patterns allow for a greater number of CTs to be used
within the same project.

To be detected successfully CTs must take up a significant number of pixels on the original photos. This
leadsto anatural limitation of CTsimplementation: while they generally prove to be useful in close-range
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imagery projects, aerial photography projects will demand too huge CTs to be placed on the ground, for
the CTsto be detected correctly.

Coded targets in workflow

Sets of all patterns of CTs supported by PhotoScan can be generated by the program itself.

Tocreatea printable PDF with coded tar gets

1. Select Print Markers... command from the Tools menu.

2. Specify the CTstype and desired print parameters in Print Markers dial og.
3. Click OK.

Once generated, the pattern set can be printed and the CTs can be placed over the scene to be shot and
reconstructed.

When the images with CTs seen on them are uploaded to the program, PhotoScan can detect and match
the CTs automatically.

To detect coded tar gets on sour ce images

1. Select Detect Markers... command from the Tools menu.

2. Specify parameters of detector in Detect Markers dialog according to the CTstype.

3. Click OK.

PhotoScan will detect and match CTs and add corresponding markers to the Reference pane.

CTs generated with PhotoScan software contain even number of sectors. However, previous versions of
PhotoScan software had no restriction of the kind. Thus, if the project to be processed contains CTs from
previousversions of PhotoScnasoftware, it isrequired to disable parity check in order to make the detector
work.

Non-coded targets implementation

Non-coded targets can al so be automatically detected by PhotoScan (see Detect Markersdialog) . However,
for non-coded targets to be matched automatically, it is necessary to run align photos procedure first.

Non-coded targets are more appropriate for aerial surveying projects due to the simplicity of the pattern
to be printed on a large scale. But, looking alike, they does not allow for automatic identification, so
manual assignment of an identifier is required if some referencing coordinates are to be imported from
afile correctly.

Performing measurements

PhotoScan supports measuring of distances between control points, aswell as of surface areaand volume
of the reconstructed 3D model.

Distance measurement

PhotoScan enabl es measurements of direct distances between the points of the reconstructed 3D scene. The
points used for distance measurement must be defined by placing markers in the corresponding locations.
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Model coordinate system must be also initialized before the distance measurements can be performed.
Alternatively, themodel can be scaled based on known distance (scale bar) information to become suitable
for measurements.

For instructions on placing markers, refining their positions and setting coordinate system please refer to
the Setting coordinate system section of the manual. Scale bar concept is discribed in the Optimization
of camera alignment section.

To measure distance

1.

Place the markers in the scene at the locations to be used for distance measurement. For information
on marker placement please refer to the Setting coordinate system section of the manual.

Select both markers to be used for distance measurements on the Reference pane using Ctrl button.

Select EfiCreate Scale Bar command form the 3D view context menu. The scale bar will be created
and an instant added to the Scale Bar list on the Reference pane.

Switch to the estimated values mode using @View Estimated button from the Reference pane
toolbar.

The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

To measur e distance between camer as

1

Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the
cameras can be selected in the Model view window using selecting tools from the Toolbar.

Select EECreate Scale Bar command form the context menu. The scale bar will be created and an
instant added to the Scale Bar list on the Reference pane.

Switch to the estimated values mode using @View Estimated button from the Reference pane
toolbar.

The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

Note

* Please note that the scale bar used for distance measurements must be unchecked on the
Reference pane.

Note

» The distance values measured by PhotoScan are displayed in meters.

Surface area and volume measurement

Surface area or volume measurements of the reconstructed 3D model can be performed only after the scale
or coordinate system of the scene is defined. For instructions on setting coordinate system please refer to
the Setting coordinate system section of the manual.
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To measure surface area and volume
1. Select Measure Areaand Volume... command from the Tools menu.

2. Thewhole model surface areaand volume will be displayed in the Measure Areaand VVolume dialog
box. Surface areais measured in square meters, while mesh volume is measured in cubic meters.

V olume measurement can be performed only for the models with closed geometry. If there are any holes
in the model surface PhotoScan will report zero volume. Existing holes in the mesh surface can be filled
in before performing volume measurements using Close Holes... command from the Tools menu.
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Using masks

Overview

5|

Masks are used in PhotoScan to specify the areas on the photos which can otherwise be confusing to
the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of
processing:

» Alignment of the photos

* Building dense point cloud
* Building 3D model texture
» Exporting Orthophoto

Alignment of the photos
Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts
of the photos are not taken into account while estimating camera positions. This is important in the
setups, where the object of interest is not static with respect to the scene, like when using aturn table
to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In
this case a small number of useful matches can be filtered out mistakenly as a noise among a much
greater number of matches between background objects.

Building dense point cloud
While building dense point cloud, masked areas are not used in the depth maps computation process.
Masking can be used to reduce the resulting dense cloud complexity, by eliminating the areas on the
photos that are not of interest.

Masked areas are always excluded from processing during dense point cloud and texture generation
stages.

Let'stake for instance a set of photos of some object. Along with an object itself on each photo some
background areas are present. These areas may be useful for more precise camera positioning, so it
is better to use them while aligning the photos. However, impact of these areas at the building dense
point cloud is exactly opposite: the resulting model will contain object of interest and its background.
Background geometry will "consume" some part of mesh polygons that could be otherwise used for
modeling the main object.
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Setting the masks for such background areas allows to avoid this problem and increases the precision
and quality of geometry reconstruction.

Building texture atlas
During texture atlas generation, masked areas on the photos are not used for texturing. Masking areas
on the photos that are occluded by outliers or obstacles helps to prevent the "ghosting" effect on the
resulting texture atlas.

Loading masks

Masks can be loaded from external sources, as well as generated automatically from background images
if such datais available. PhotoScan supports loading masks from the following sources:

» From aphachannel of the source photos.

» From separate images.

» Generated from background photos based on background differencing technique.
* Based on reconstructed 3D model.

Toimport masks
1. Select Import Masks... command from the Tools menu.
2. Inthe Import Mask dialog select suitable parameters. Click OK button when done.

3. When generating masks from separate or background images, the folder selection dialog will appear.
Browse to the folder containing corresponding images and select it.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

The following parameters can be specified during mask import:

Import masksfor
Specifies whether masks should be imported for the currently opened photo, active chunk or entire
Workspace.

Current phot o - load mask for the currently opened photo (if any).
Acti ve chunk - load masksfor active chunk.
Entire wor kspace - load masksfor all chunksin the project.

Method
Specifies the source of the mask data.

From Al pha - load masks from alpha channel of the source photos.
From Fi | e - load masks from separate images.

Fr om Backgr ound - generate masks from background photos.

Fr om Model - generate masks based on reconstructed model.

Mask file names (not used in Fr om al pha mode)
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:
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{fil enane} - filename of the source photo without extension.
{fil eext} -extension of the source photo.

{caner a} - cameralabel.

{frame} - frame number.

{filenunt -sequential number of the mask being imported.

For example, {filename} _mask.png template can be used if masks are available in PNG format and
havea_mask suffix.

Tolerance (Fr om Backgr ound method only)

Specifies the tolerance threshold used for background differencing. Tolerance value should be set
according to the color separation between foreground and background pixels. For larger separation
higher tolerance values can be used.

Editing masks

Modification of the current mask is performed by adding or subtracting selections. A selection is created
with one of the supported selection tools and is not incorporated in the current mask until it ismerged with
amask using Add Selection or Subtract Selection operations.

To edit the mask

1

Open the photo to be masked by double clicking on its name on the Workspace / Photo pane. The
photo will be opened in the main window. The existing mask will be displayed as a shaded region
on the photo.

Select the desired selection tool and generate a selection.

Selection to subtract the selection from the mask. #* | Invert Selection button allows to invert current
selection prior to adding or subtracting it from the mask.

The following tools can be used for creating selections:

-1

L_1 Rectangle selection tool

Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools
were applied.

Ll ntelligent scissorstool

Intelligent scissorsis used to generate a selection by specifying its boundary. The boundary isformed
by selecting a sequence of vertices with a mouse, which are automatically connected with segments.
The segments can be formed either by straight lines, or by curved contours snapped to the object
boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the
selection, the boundary should be closed by clicking on the first boundary vertex.

% ntelligent paint tool

Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image
regions, bounded by object boundaries.
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M agic wand tool

Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic
Wand tool, click inside the region to be selected.

The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower
tolerance valuesthe tool selects fewer colors similar to the pixel you click with the Magic Wand tool.
Higher value broadens the range of colors selected.

[{ Note

e Toadd new areato the current selection hold the Ctrl key during selection of additional area.

» To reset mask selection on the current photo press Esc key.

A mask can be inverted using Invert Mask command from the Photo menu. The command is active in
Photo View only. Alternatively, you can invert masks either for selected cameras or for all camerasin a
chunk using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be
masked out on all photos, where that object appears.

Saving masks

Created masks can be also saved for external editing or storage.

To export masks

1.

2.

3.

4.

Select Export Masks... command from the Tools menu.
In the Export Mask dialog select suitable parameters. Click OK button when done.
Browse to the folder where the masks should be saved and select it.

The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

The following parameters can be specified during mask export:

Export masksfor

Specifies whether masks should be exported for the currently opened photo, active chunk or entire
Workspace.

Current phot o - save mask for the currently opened photo (if any).
Act i ve chunk - save masks for active chunk.

Entire workspace - save masksfor al chunksin the project.

Filetype

Specifies the type of generated files.
Si ngl e channel mask i mage - generates single channel black and white mask images.

I mage wi t h al pha channel - generatescolor imagesfrom source photos combined with mask
datain aphachanndl.
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Mask file names
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{fil ename} - filename of the source photo without extension.
{fil eext} -extension of the source photo.

{caner a} - cameralabel.

{frame} -frame number.

{filenunt - sequential number of the mask being exported.

For example, { filename} _mask.png template can be used to export masksin PNG format with _nmask
suffix.

4 Note

« When importing/exporting mask for the current photo only, PhotoScan will prompt for the actual
image instead of image folder. Mask file names parameter will not be used in this case.

Editing point cloud

The following point cloud editing tools are available in PhotoScan:

» Automatic filtering based on specified criterion (sparse cloud only)

» Automatic filtering based on applied masks (dense cloud only)

» Reducing number of pointsin cloud by setting tie point per photo limit (sparse cloud only)

» Manual points removal

4 Note

« Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit
menu.

Filtering points based on specified criterion

In some casesit may be useful to find out where the points with high reprojection error are located within
the sparse cloud, or remove points representing high amount of noise. Point cloud filtering helps to select
such points, which usually are supposed to be removed.

PhotoScan supports the following criteriafor point cloud filtering:

Reprojection error
High reprojection error usualy indicates poor localization accuracy of the corresponding point
projections at the point matching step. It is also typical for false matches. Removing such points can
improve accuracy of the subseguent optimization step.

Reconstruction uncertainty
High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small
baseline. Such points can noticeably deviate from the object surface, introducing noise in the point
cloud. While removal of such points should not affect the accuracy of optimization, it may be useful
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to remove them before building geometry in Point Cloud mode or for better visual appearance of the
point cloud.

Image count

PhotoScan reconstruct all the points that are visible at least on two photos. However, points that are
visible only on two photos are likely to be located with poor accuracy. Image count filtering enables
to remove such unreliable points from the cloud.

Toremove points based on specified criterion

1.

Switch to Point Cloud view mode using 28 Point Cloud toolbar button.
Select Gradual Selection... command from the Edit menu.

In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold
level using the slider. Y ou can observe how the selection changes while dragging the slider. Click
OK buitton to finalize the selection.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on applied masks

To remove points based on applied masks

1.

Switch to Dense Cloud view mode using =:5Dense Cloud toolbar button.
Choose Select Masked Points... command from the Dense Cloud submenu of the Tools menu.

In the Select Masked Points dialog box indicate the photos whose masks to be taken into account.
Adjust the edge softness level using the dlider. Click OK button to run the selection procedure.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Tie point per photo limit

Tie point limit parameter could be adjusted before Align photos procedure. The number indicates upper
limit of matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment processwith Tie Points- Thin Point Cloud
command available from Tools menu. As a results sparse point cloud will be thinned, yet the alignment
will be kept unchanged.

Manual points removal

Incorrect points can be also removed manually.

Toremove pointsfrom a point cloud manually

1.

Switch to Sparse Cloud view mode using 88 Point Cloud toolbar button or to Dense Cloud view mode

using =5 Dense Cloud toolbar button.
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2 Select points to be removed using ] Rectangle Selection, -» Circle Selection or h_ﬂ Free-Form
Selection tools. To add new points to the current selection hold the Ctrl key during selection of
additional points. To remove some points from the current selection hold the Shift key during
selection of pointsto be removed.

3.

To delete selected points click the Pt Delete Selection toolbar button or select Delete Selection

command from the Edit menu. To crop selection to the selected points click the ﬁ Crop Selection
toolbar button or select Crop Selection command from the Edit menu.

Classifying dense cloud points

PhotoScan allows not only to generate and visualize dense point cloud but also to classify the pointswithin
it. There are two options: automatic division of all the points into two classes - ground points and the rest,
and manual selection of agroup of points to be placed in a certain class from the standard list known for
LIDAR data. Dense cloud points classification opens way to customize Build Mesh step: you can choose
what type of objects within the scene you would like to be reconstructed and indicate the corresponding
point class as a source data for mesh generation. For example, if you build mesh based on ground points
only, it will be possible to export DTM (as opposed to DSM) at the next step.

Automatic classification of ground points

For the user to avoid extramanual work PhotoScan offersfeature for automatic detection of ground points.

To classify ground points automatically
1. Select Classify Ground Points... command from the Dense Cloud submenu of the Tools menu.

2. Inthe Classify Ground Points dialog box select the source point datafor the classification procedure.
Click OK button to run the classification procedure.

Automatic classification procedure consists of two steps. At the first step the dense cloud is divided into
cellsof acertain size. In each cell the lowest point is detected. Triangulation of these points givesthe first
approximation of the terrain model.

At the second step new point is added to the ground class, providing that it satisfies two conditions: it lies
within a certain distance from the terrain model and that the angle between terrain model and the line to
connect this new point with a point from a ground class is less than a certain angle. The second step is
repeated while there still are points to be checked.

The following parameters control automatic ground points classification procedure

Max angle (deg)
Determinesoneof the conditionsto be checked whiletesting apoint asaground one, i.e. setslimitation
for an angle between terrain model and the line to connect the point in question with a point from a
ground class. For nearly flat terrain it isrecommended to use default value of 15 deg for the parameter.
It isreasonable to set a higher value, if the terrain contains steep slopes.

Max distance (m)
Determinesoneof the conditionsto be checked whiletesting apoint asaground one, i.e. setslimitation
for a distance between the point in question and terrain model. In fact, this parameter determines the
assumption for the maximum variation of the ground elevation at atime.
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Céll size (m)
Determines the size of the cells for point cloud to be divided into as a preparatory step in ground
points classification procedure. Cell size should be indicated with respect to the size of the largest
area within the scene that does not contain any ground points, e. g. building or close forest.

Manual classification of dense cloud points

PhotoScan allows to associate all the points within the dense cloud with a certain standard class (see
LIDAR data classification). This provides possibility to diversify export of the processing results with
respect to different types of objects within the scene, e. g. DTM for ground, mesh for buildings and point
cloud for vegetation.

Toassign a classto agroup of points

1 Switch to Dense Cloud view mode using using &= Dense Cloud toolbar button.

2. . . LT Ty .
Select points to be placed to a certain class using .- Rectangle Selection, -+ Circle Selection or

-;_ﬂ Free-Form Selection tools. To add new points to the current selection hold the Ctrl key during
selection of additional points. To remove some points from the current selection hold the Shift key
during selection of points to be removed.

3. Seect Assign Class... command from the Dense Cloud submenu of the Tools menu.

4. Inthe Assign Class dialog box select the source point data for the classification procedure and the
targeted class to be assigned to the selected points. Click OK button to run classification procedure.

Dense point cloud classification can be reset with Reset Classification command from Tools - Dense Cloud
menul.

Editing model geometry

The following mesh editing tools are available in PhotoScan:
* Decimation tool

* Close Holestool

» Automatic filtering based on specified criterion

e Manual polygon removal

* Fixing mesh topology

More complex editing can be done in the external 3D editing tools. PhotoScan allows to export mesh and
then import it back for this purpose.

4 Note

 For polygon removal operations such as manual removal and connected component filtering it
is possible to undo the last mesh editing operation. There are Undo/Redo commands in the Edit
menu.

Please note that undo/redo commands are not supported for mesh decimation and this operation
cannot be undone.
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Decimation tool

Decimation is atool used to decrease the geometric resolution of the model by replacing high resolution
mesh with a lower resolution one, which is still capable of representing the object geometry with high
accuracy. PhotoScan tends to produce 3D model s with excessive geometry resolution, so mesh decimation
isusually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands polygons. While it is acceptable to work with
such acomplex modelsin 3D editor tools, in most conventional tools like Adobe Reader or Google Earth
high complexity of 3D models may noticeably decrease application performance. High complexity also
resultsin longer time required to build texture and to export model in pdf file format.

In some casesit isdesirable to keep as much geometry details as possiblelikeit is needed for scientific and
archive purposes. However, if there are no special requirementsit is recommended to decimate the model

down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in
Google Earth and aike toals.

To decimate 3D mode
1. Select Decimate Mesh... command from the Tools menu.

2. Inthe Decimate Mesh dialog box specify the target number of polygons, which should remain in the
final model. Click on the OK button to start decimation.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

[ Note

e Textureatlasisdiscarded during decimation process. Y ou will have to rebuild texture atlas after
decimation is complete.

Close Holes tool

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a
mesh with several holes, due to insufficient image overlap for example.

Some tasks require a continuous surface disregarding the fact of information shortage. It is necessary to
generate a close model, for instance, to fulfill volume measurement task with PhotoScan.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction

with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum
size of ahole to be covered with extrapolated data.

Toclose holesin a 3D model
1. Select Close Holes... command from the Tools menu.

2. IntheClose Holesdialog box indicate the maximum size of aholeto be covered with the slider. Click
on the OK button to start the procedure.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.
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4 Note

* Thedlider alowsto set the size of aholein relation to the size of the whole model surface.

Polygon filtering on specified criterion

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding
the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select
polygons, which usually are supposed to be removed.

PhotoScan supports the following criteriafor face filtering:

Connected component size
This filtering criteria alows to select isolated fragments with a certain number of polygons. The
number of polygonsin al isolated components to be selected is set with a dider and is indicated in
relation to the number of polygons in the whole model. The components are ranged in size, so that
the selection proceeds from the smallest component to the largest one.

Polygon size
This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be
selected is set with adider and is indicated in relation to the size of the whole model. This function
can be useful, for example, in case the geometry was reconstructed in Smooth type and thereis aneed
to remove extra polygons automatically added by PhotoScan to fill the gaps; these polygons are often
of alarger sizethat the rest.

Toremove small isolated mesh fragments
1. Select Gradua Selection... command from the Edit menu.
2. Inthe Gradual Selection dialog box select Connected component size criterion.

3. Select the size of isolated components to be removed using the dlider. You can observe how the
selection changes while dragging the slider. Click OK button to finalize the selection.

To remove the selected components use Delete Selection command from the Edit menu or click X
Delete Selection toolbar button (or simply press Del button on the keyboard).

Toremovelarge polygons
1. Select Gradua Selection... command from the Edit menu.
2. Inthe Gradual Selection dialog box select Polygon size criterion.

3. Select thesize of polygonsto beremoved using the slider. Y ou can observe how the selection changes
while dragging the slider. Click OK button to finalize the selection.

To remove the selected components use Delete Selection command from the Edit menu or click X
Delete Selection toolbar button (or simply press Del button on the keyboard).

Note that PhotoScan always selects the fragments starting from the smallest ones. If the model contains
only one component the selection will be empty.

Manual face removal

Unnecessary and excessive sections of model geometry can be also removed manually.
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Toremove part of the mesh polygons manually

1.

-1

Select rectangle, circle or free-form selection tool using . - . Rectangle Selection, {_? Circle Selection

or 'l_g Free-Form Selection toolbar buttons.

Make the selection using the mouse. To add new polygons to the current selection hold the Ctrl key
during selection of additional polygons. To remove some polygons from the current selection hold
the Shift key during selection of polygons to be excluded.

To delete selected polygons click the X Delete Selection toolbar button or use Delete Selection

command from the Edit menu. To crop sel ection to the selected polygonsclick the tlf- Crop Selection
toolbar button or use Crop Selection command from the Edit menu.

Togrow or shrink current selection

1

To grow current selection press PageUp key in the selection mode. To grow selection by even alarger
amount, press PageUp while holding Shift key pressed.

To shrink current selection press PageDown key in the selection mode. To shrink selection by even
alarger amount, press PageDown while holding Shift key pressed.

Fixing mesh topology

PhotoScan is capable of basic mesh topology fixing.

To fix mesh topology

1. Select View Mesh Statistics... command from the Tools menu.

2. In the Mesh Statistics dialog box you can inspect mesh parameters. If there are any topological
problems, Fix Topology button will be active and can be clicked to solve the problems.

3. The progress dialog box will appear displaying the current processing status. To cancel processing

click on the Cancel button.

Editing mesh in the external program

To export mesh for editing in the external program

1

2.

Select Export Model... command from the File menu.

In the Save As dialog box, specify the desired mesh format in the Save astype combo box. Select the
file name to be used for the model and click Save button.

In the opened dialog box specify additional parameters specific to the selected file format. Click OK
button when done.

Toimport edited mesh

1

2.

Select Import Mesh... command from the Tools menu.

In the Open dialog box, browse to the file with the edited model and click Open.
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4 Note

 PhotoScan supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY,
Autodesk FBX, Autodesk DXF, OpenCTM and U3D fileformats only. Please make sureto select
one of these file formats when exporting model from the external 3D editor.

* Please be awarethat it isimportant to keep reference information for the model if any.
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Using chunks

When working with typical datasets, automation of general processing workflow allowsto perform routine
operations efficiently. PhotoScan allows to assign several processing steps to be run one by one without
user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even
further dueto 'multiple chunk project’ concept, each chunk to include onetypical data set. For aproject with
several chunks of the same nature, common operations available in Batch Processing dialog are applied to
each selected chunk individually, thus allowing to set several data setsfor automatic processing following
predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to
generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount
of photographs is too large to be processed at a time. To overcome this difficulty PhotoScan offers a
possibility to split the set of photos into several separate chunks within the same project. Alignment of
photos, building dense point cloud, building mesh, and forming texture atlas operations can be performed
for each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using PhotoScan following the general workflow. In fact,
in PhotoScan always exists at least one active chunk and all the 3D model processing workflow operations
are applied to this chunk.

To work with severa chunks you need to know how to create chunks and how to combine resulting 3D
models from separate chunks into one model.

Creating a chunk

To create new chunk click on the “2Add Chunk toolbar button on the Workspace pane or select Add
Chunk command from the Workspace context menu (available by right-clicking on the root element on
the Workspace pane).

After the chunk is created you may load photosinit, align them, generate dense point cloud, generate mesh
surface model, build texture atlas, export the models at any stage and so on. The models in the chunks
are not linked with each other.

The list of al the chunks created in the current project is displayed in the Workspace pane along with
flags reflecting their status.

The following flags can appear next to the chunk name:

R (Referenced)
Notifies that 3D model in the chunk was referenced. Also will appear when two or more chunks are
aligned with each other. See information on how to reference the model in Setting coordinate system.

S (Scaled)
Notifiesthat 3D model in the chunk was scal ed based on scal e barsinformation only, with no reference
coordinates data being present. See information on scale bar placement in Optimization of camera
alignment section.

To move photos from one chunk to another simply select them in thelist of photos on the Workspace pane,
and then drag and drop to the target chunk.
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Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs,
aligning them, generating dense point cloud, building mesh, building texture atlas, exporting 3D model
and so on.

Note that all these operations are applied to the active chunk. When anew chunk is created it is activated
automatically. Save project operation savesthe content of all chunks. To save selected chunks as aseparate
project use Save Chunks command from the chunk context menu.

To set another chunk as active
1. Right-click on the chunk title on the Workspace pane.

2.  Select Set Active command from the context menu.

Toremove chunk
1. Right-click on the chunk title on the Workspace pane.

2. Select Remove Items command from the context menu.

Aligning chunks

After the "partial” 3D models are built in several chunks they can be merged together. Before merging
chunks they need to be aligned.

To align separate chunks
1. Select Align Chunks command from the Workflow menu.

2. Inthe Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-
click. Set desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

Aligning chunks parameters

Thefollowing parameters control the chunksalignment procedure and can be modified inthe Align Chunks
dialog box:

Method
Defines the chunks alignment method. Poi nt  based method aligns chunks by matching photos
across all the chunks. Mar ker based method uses markers as common points for different chunks.
Thedetails on using markers are avail able in the Setting coordinate system section. Caner a based
method is used to align chunks based on estimated camera locations. Corresponding cameras should
have the same label.

Accuracy (Point based alignment only)
Higher accuracy setting hel psto obtain more accurate chunk alignment results. L ower accuracy setting
can be used to get the rough chunk alignment in the shorter time.

Point limit (Point based alignment only)
The number indicates upper limit of feature points on every image to be taken into account during
Poi nt based chunks alignment.




Automation

Fix scale
Option is to be enabled in case the scales of the models in different chunks were set precisely and
should be left unchanged during chunks alignment process.

Preselect image pairs (Point based alignment only)
The alignment process of many chunks may take a long time. A significant portion of this time is
spent for matching of detected features across the photos. Image pair preselection option can speed
up this process by selection of a subset of image pairs to be matched.

Constrain features by mask (Point based alignment only)
When this option is enabled, features detected in the masked image regions are discarded. For
additional information on the usage of masks refer to the Using masks section.

[ Note

¢ Chunk alignment can be performed only for chunks containing aligned photos.

« Thereis no need to perform chunk alignment for georeferenced chunks, as they are already in
the same coordinate frame.

Merging chunks
After aignment is complete the separate chunks can be merged into a single chunk.

To merge chunks
1. Select Merge Chunks command from the Workflow menu.

2. Inthe Merge Chunks dialog box select chunks to be merged and the desired merging options. Click
OK button when done.

3. PhotoScan will mergethe separate chunksinto one. The merged chunk will be displayed in the project
content list on Workspace pane.

Thefollowing parameters control the chunks merging procedure and can be modified in the Merge Chunks
dialog box:

Mer ge dense clouds
Defines if dense clouds from the selected chunks are combined.

Merge models
Defines if models from the selected chunks are combined.

Merge markers
Defines if markers from the selected chunks are merged (only markers with the same labels would
be merged).

Chunks merging result (i.e. photos, point clouds and geometry) will be stored in the new chunk and it may
be treated as an ordinary chunk (e.g. the model can be textured and/or exported).

Batch processing

PhotoScan allowsto perform general workflow operations with multiple chunks automatically. It isuseful
when dealing with alarge number of chunks to be processed.
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Batch processing can be applied to al chunks in the Workspace, to unprocessed chunks only, or to the
chunks selected by the user. Each operation chosen in the Batch processing dialog will be applied to every
selected chunk before processing will move on to the next step.

Batch processing can perform the following operations:
 Align Photos

* Optimize Alignment
* Build Dense Cloud
 Build Mesh

 Build Texture

» Decimate Mesh

e |Import Cameras

* Import Masks

» Export Points

» Export Model

» Export Texture

» Export Orthophoto

* Export DEM
 Align Chunks

* Merge Chunks

» Save Project

» Save project after every completed operation

To start batch processing
1. Select Batch Process... command from the Workflow menu.
2. Click Add to add the desired processing stages.

3. Inthe Add Job dialog select the kind of operation to be performed, the list of chunks it should be
applied to, and desired processing parameters. Click OK button when done.

4. Repeat the previous steps to add other processing steps as required.
5. Arrange jobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.
6. Click OK button to start processing.

7. Theprogressdialog box will appear displaying thelist and status of batch jobs and current operation
progress. To cancel processing click the Cancel button.
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4D processing

Overview

PhotoScan supports reconstruction of dynamic scenes captured by aset of statically mounted synchronized
cameras. For this purpose multiple image frames captured at different time moments can be loaded for
each camera location, forming a multiframe chunk. In fact norma chunks capturing a static scene are
multiframe chunks with only a single frame |oaded. Navigation through the frame sequenceis performed
using Timeline pane.

Although aseparate static chunk can be used to process photosfor each time moment, aggregate multiframe
chunks implementation has several advantages:

» Coordinate systems for individual frames are guaranteed to match. There is no need to align chunksto
each other after processing.

» Each processing step can be applied to the entire sequence, with a user selectable framerange. Thereis
no need to use batch processing, which simplifies the workflow.

» Accuracy of photo alignment is better due to the joint processing of photos from the entire sequence.
» Markers can be tracked automatically through the sequence.
* Intuitive interface makes navigation through the sequence pretty simple and fast.

Multiframe chunks can be also efficient (with some limitations) for processing of disordered photo sets of
the same object or even different objects, provided that cameras remain static throughout the sequence.

Managing multiframe chunks

Multiframe layout is formed at the moment of adding photos to the chunk. It will reflect the data layout
used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance.
The following data layouts can be used with PhotoScan:

a. All framesfrom corresponding camera are contained in a separate subfolder. The number of subfolders
is egual to the number of cameras.

b. Corresponding framesfrom all cameras are contained in aseparate subfolder. The number of subfolders
isequal to the number of frames.

c. All frames from corresponding camera are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of cameras.

d. Corresponding frames from all cameras are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of frames.

Once the data is properly organized, it can be loaded into PhotoScan to form a multiframe chunk. The
exact procedure will depend on whether the multifolder layout (variants a and b) or multilayer (variants
¢ and d) layout is used.

To create a chunk from multifolder layout

L Select “—@Add Folder... command from the Workflow menu.
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4,

In the Add Folder dialog box browse to the parent folder containing subfolders with images. Then
click Select Folder button.

In the Add Photos dial og select the suitable datalayout. For layout a) above select " Create multiframe
cameras from folders as cameras'. For layout b) select "Create multiframe cameras from folders as
frames'.

Created multiframe chunk will appear on the Workspace pane.

To create a chunk from multilayer images

1

4.

Select Add Photos... command from the Workflow menu or click Add Photos toolbar button.

In the Add Photos dialog box browse to the folder containing multilayer images and select files to
be processed. Then click Open button.

Inthe Add Photos dial og sel ect the suitable datalayout. For layout ¢) above select " Create multiframe
camerasfromfilesascameras'. For layout d) select " Create multiframe camerasfrom filesasframes”.

Created multiframe chunk will appear on the Workspace pane.

It isrecommended to inspect the loaded frame sequence for errors. This can be done by scrolling the frame
selector in the Timeline pane and inspecting thumbnails in the Photos pane during scrolling.

After multiframe chunk is created, it can be processed in the same way as normal chunks. For multiframe
chunks additional processing parameters allowing to select the range of frames to be processed will be
provided where appropriate.

Tracking markers

PhotoScan allows to automatically track marker projections through the frames sequence, provided that
object position doesn't change significantly between frames. This greatly simplifies the task of labeling of
amoving point if the number of framesislarge.

Totrack markersthrough the frame sequence

1. Scroll frame selector inthe Timeline paneto the 1st frame. Add markersfor the 1st frame as described
in the Setting coordinate system section.

2. Select Track Markers... command from the Tools menu.

3. Adjust the starting and ending frameindicesif necessary. Default val ues correspond to tracking from
the current frame to the end of sequence. Click OK button to start tracking.

4 Check tracked marker locations. Automatically tracked markers will be indicated with ":E?icons. In
case of a placement error at some frame, adjust the wrong marker location within the frame where
the failure occurred. Once the marker location is refined by user, the marker icon will changeto “IJ

5. Restart tracking from that frame using Track Markers... command again.

£ Note

* If the ending frame index is smaller than the starting index, tracking will be performed in the
backwards direction.
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« Automatic marker tracking is likely to fail in case when structured light is used to add texture
details to the object surface, as the light pattern will not be static with respect to the moving
object surface.

Python scripting

PhotoScan supports Python API, using Python 3.3 as a scripting engine.
Python commands and scripts can be executed in PhotoScan through one of the following options:

» PhotoScan Console pane can serve as standard Python console;

* Click [4¥Run Script button on Console pane toolbar or use l4#Run Script... command from the Tools
menu to run a Python script.

For details on PhotoScan functionality accessible through Python scripts please refer to Python API
Reference document available on AgiSoft official website (http://www.agisoft.com/downloads/user-
manuals/).
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Chapter 7. Network processing

Overview

Agisoft PhotoScan can be configured to run on a computer cluster where processing is distributed on
several computer nodes connected to alocal network. In such configuration multiple PhotoScan instances
running on different processing nodes can work on the same task in parallel, effectively reducing the total
processing time needed.

By default processing is divided between the nodes on a chunk by chunk, frame by frame basis (with the
exception of camera alignment and optimization, where each chunk is processed as a whole on asingle
node). In addition a more fine grained distribution can be enabled for photo alignment and dense cloud
generation, in which case processing of individual chunks/frames is further subdivided between several
processing nodes.

Communication between processing nodes, server and clients is performed using TCP connections. In
addition, shared network storage accessible for all processing nodes and clients is used for storing the
source data and intermediate processing results.

Cluster components

Client 1 Processing node 1

Server
TCP TCP

Client 2

\ 4
A

Processing node 2

Client n

Processing node n

Network storage

Server

The server node coordinates operation of all processing nodes, maintaining a task queue for all projects
scheduled for processing. A separate interface is provided for clients, which can connect to the server to
start new processing tasks or monitor progress of existing ones.

The server itself doesn't perform any processing and can easily run on slow hardware. The server
component is critical for operation of the cluster, and is not fault tolerant. Measures should be taken to
ensure continuous operation of the server node.

The server node accepts TCP connections from processing nodes and clients on 2 separate interfaces,
which can be attached to different physical network interfacesif necessary. The server node doesn't initiate
any TCP connections itself.
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Processing nodes

Processing nodes perform actual calculations, and thus need to be run on fast hardware. Each processing
node connects to the server on startup and waits for atask to be assigned. Once the task is available, the
node starts processing, informing the server about the progress. When processing is finished, the results
are stored on shared network storage, and the server isinformed about completion. Then a node switches
to the next task when it becomes available.

Processing nodes can be added or removed from the cluster as needed. Abnormal shutdown of processing
node doesn't cause cluster failure in most cases. Nevertheless, it is highly recommended to stop particular
nodes using Agisoft Network Monitor before disconnecting them from the cluster.

Clients

Clients can connect to the server nodeto control cluster operation or to monitor its status. New tasks can be
submitted for processing using Agisoft PhotoScan software configured as a network client, while cluster
monitoring is performed using Agisoft Network Monitor. Multiple clients can be connected to the server
node simultaneously.

Cluster setup

Before proceeding to the following steps please make sure that shared network storage is accessible from
all processing and client nodes using the same absol ute path. 1t should be either mounted to the same folder
on all nodes (Linux), or should have the same UNC network path (Windows). In case such configuration
isnot possible (for example in mixed Windows/Linux cluster), a path prefix can be specified on each node
to compensate for the differences.

Starting server

It is recommended to configure server with a static |P address, not dynamically assigned one. This IP
address will be needed for each processing node and client.

The server process can be started by executing PhotoScan with the following command line arguments:
photoscan --server --control <ip>[:port] --dispatch <ip>[:port] [--root pr€fiX]

--server parameter specifies that PhotoScan should be started in a server mode.

--contr ol parameter specifiesthe network interface to be used for communication with clients. In case port
value is omitted, the default port 5840 is used.

--dispatch parameter specifiesthe network interface to be used for communication with processing nodes.
In case port value is omitted, the default port 5841 is used.

--root parameter can be used to specify network storage mount point or prefix path in case it is not the
same across network.

Example:
photoscan --server --control 10.0.1.1 --dispatch 10.0.1.1

In this case PhotoScan will use the same interface for both clients and processing nodes with default port
values.

Starting network nodes

The processing node can be started by executing PhotoScan with the following command line arguments:
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photoscan --node --dispatch <ip>[:port] [--r oot prefix]

--node parameter specifies that PhotoScan should be started as a processing node.

--dispatch parameter specifies IP of the server to connect. In case port value is omitted, the default port
5841 is used.

--root parameter can be used to specify network storage mount point or prefix path in case it is not the
same across network.

Example:
photoscan --node --dispatch 10.0.1.1

This command will start processing node using 10.0.1.1 as a server |P with default port 5841.

Checking cluster status

Start Agisoft Network Monitor application. In the host name field enter server IP used for client
connections (10.0.1.1 in our example). Modify port values in case non-default port was specified. Click
Connect button when done.

A list of available network nodes currently connected to the server will be displayed in the bottom part of
the window. Please make sure that all started processing nodes are listed.

The top part lists tasks currently being processed (finished tasks are removed from the list as soon as they
are completed). The task list will be empty if no processing was started yet.

Starting network processing

1

Configure Agisoft PhotoScan for network processing.
Start Agisoft PhotoScan on any computer connected to the cluster network.

Open Preferences dialog using Preferences... command from the Tools menu. On the Network tab
make sure Enable network processing option is turned on, and specify the server IP used for client
connection in the Host name field. In case non-default port was configured on a server, modify the
port value accordingly.

In case you are going to process a few single-frame chunks with large number of photos, we
recommend to enable fine-level task distribution for all supported operations (Match Photos, Align
Cameras, Build Dense Cloud). In case you are going to process a large number of small chunks, or
chunks with large number of frames, fine-level task distribution can be left in disabled state.

Press OK button when done.
Prepare project for network processing.

Opentheproject fileto be processed. Click Save As... command from the File menu and resave project
to afolder on a shared network storage in PhotoScan Unpacked Project (*.psx) format. Alternatively
you can save only particular chunks using Save Chunks... command from the Chunk context menu
in the Workspace pane.

Important! Please make sure that source images are located on shared network storage and not on a
local hard drive. Otherwise processing nodes will be unable to load them.

Start processing.
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Start processing using corresponding command from the Workflow menu, or using Batch Process
command to execute a command sequence. A network progress dialog should appear displaying
current progress.

4. Wait for processing to complete.

You can disconnect from the server at any time using Disconnect button in the Network Progress
dialog in case you need to work on other projects. Processing will continue in the background.

To see processing status after you have disconnected from the server simply open corresponding .psx
project on the network storage. Alternatively you can use Agisoft Network Monitor to see processing
status for all projects being processed.

5. Saveprocessing results as normal .psz project.

Once processing is finished, you can resave the project in normal .psz format. In case you have
disconnected from the server, you need to open .psx project first using Open... command from the
File menu. Then save it to a desired location using Save As... command from the File menu, and
selecting PhotoScan Project Files (*.psz) file type.

Cluster administration

Adding processing nodes

New processing nodes can be added by starting Agisoft PhotoScan on additional computersin the network
node mode, as outlined in the Starting network nodes section above.

Removing processing nodes

Aborting or disconnecting processing node during cluster operation is not absolutely safe, and can lead to
project corruption if performed during final project update at the end of processing. Although the chances
of this situation are relatively low, we strongly recommend against such approach. To safely disconnect
processing node from the cluster you need to stop processing on this node using Agisoft Network Monitor
first.

1. Start Agisoft Network Monitor. Make sure the server IPis properly configured in the host namefield
and click Connect button.

2. In the bottom list of network nodes identify the node to be removed. From the node menu select
Pause command to stop the node after it finishes current job, or Stop command to abort processing
immediately.

3. Wait until the Batch # and Progress items for a selected node become empty. This indicates that the
node has finished processing. The status of the node should be Paused.

4.  Now you can safely disconnect the node by aborting PhotoScan process.
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Appendix A. Graphical user interface
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Model view

General view of application window.

Model view tab is used for displaying 3D data as well as for mesh and point cloud editing. The view of
the model depends on the current processing stage and is also controlled by mode selection buttons on

the PhotoScan tool bar.

Model can be shown as a dense cloud, with class indication or without, or as a mesh in shaded, solid,
wireframe or textured mode. Along with the model the results of photo alignment can be displayed. These
include sparse point cloud and camera positions visualised data.
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PhotoScan supports the following tools for navigation in the 3D view:

Tool Keyboard modifier
Rotation Tool Default

Pan Tool Ctrl key pressed
Zooming Tool Shift key pressed

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the

+ Navigation toolbar button.

4 Note

e Zooming into the model can be also controlled by the mouse wheel.

Photo view

Photo view tab is used for displaying individual photos aswell as markers and masks on them.

Photo view is visible only if any photo is opened. To open a photo double-click on its hame on the
Workspace, Reference or Photos pane.

Workspace pane

On the Workspace pane all elements comprising the current project are displayed. These elements can
include:

e List of chunksin the project

 List of cameras and camera groups in each chunk
* List of markersin each chunk

* List of scale barsin each chunk

 Tiepointsin separate chunks

» Depth mapsin separate chunks

» Dense point clouds in separate chunks

» 3D modelsin separate chunks

Buttons located on the Workspace pane toolbar allow to:

Add chunk

Add photos

Add marker
» Enable or disable certain cameras or chunks for processing at further stages.

* Removeitems
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Each element in the list is linked with the context menu providing quick access to some common
operations.

Photos pane

Photos pane displays the list of photos/ masksin the active chunk in the form of thumbnails.
Buttons located on the Photos pane toolbar allow to:

» Enable/ disable certain cameras

* Remove cameras

* Rotate selected photos clockwise / counterclockwise

* Reset current photo filtering option

» Switch between images and masks thumbnails

* Increase/ decreaseicons size or display detailed information on photos including EXIF data

Console pane

Console paneis used for:

» Displaying auxiliary information
 Displaying error messages

» Python commands input

Buttons located on the pane toolbar allow:
» Savelog

e Clearlog

» Execute Python script

Reference pane

Reference paneis designed for:

» Displaying cameraand / or marker coordinates

» Displaying scale bars lengths

 Displaying camera orientations

 Displaying estimation errors

Buttons located on the pane toolbar allow:

* Import / export reference coordinates

» Convert reference coordinates from one system to the other

» Optimize camera alignment and update data
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» Switch between source coordinates, estimated coordinates and errors views

* Indicate coordinate system and measurement accuracy to be assumed through Settings dialog

Timeline pane

Timeline paneis designed for:

» Working with multi-frame chunks
Buttons located on the pane toolbar allow:
» Add/ remove frames from chunk

» Play / stop frame sequence

» Adjust frame rate through Settings dialog

4 Note

« To open any pane select a corresponding command from the View menu.

Menu commands

FileMenu
[ New Creates an empty PhotoScan project.
Open... Opens PhotoScan project file.
Append... ?uprlrag?:f neéisti ng PhotoScan project file to the
H Save Saves PhotoScan project file.
Save As... Saves PhotoScan project file with a new name.
Export Model... Saves 3D model.
Export Points... Saves sparse / dense point cloud.
Export Orthophoto... ;See;rire?r? orthophoto based on the reconstructed
Export DEM... gﬁgi gggzlo 21 (:t/re;/tfon model based on the
Generate Report... E)?:nearma.ﬁes PhotoScan processing report in pdf
Upload Model... ;r;: sgdﬁtsege\ilcvzgs:;ged model to one of the
Exit Quitsthe appl ication. Prompts to save any unsave
changes applied to the current project.
Edit Menu
“} Undo Undo the last editing operation.

67



Graphical user interface

Edit Menu
™ Redo

;’{ Delete Selection

t{- Crop Selection
Invert Selection
Grow Selection
Shrink Selection

Gradual selection...

View Menu

28 Point Cloud

Dense Cloud

#1 Dense Cloud Classes

4> shaded

& solid

<> wireframe

< Textured
Full Screen

82 show Cameras

% show Markers
Show Region
Show Trackball

'@' Show Info

Predefined views

Perspective/Orthographic
Stereo Mode

= Workspace
& Timeline

Redo the previously undone editing operation.

Removes selected faces from the mesh or selected
points from the point cloud.

Crops selected faces/ points.
Inverts current selection.
Grows current selection.
Shrinks current selection.

Selects faces / points based on the specified
criterion.

Displays sparse point cloud reconstructed during
photo alignment.

Displays dense point cloud.

Displays dense point cloud colored by point
classes.

Displays 3D model in the shaded mode.
Displays 3D modél in the solid mode.
Displays 3D model in the wireframe mode.
Displays 3D model in the textured mode.
Switchesto / from Full Screen mode.

Shows or hides camera positions estimated during
image alignment.

Shows or hides marker positions.
Shows or hides region selector.
Shows or hides the trackball.

Shows or hides the mesh information on-screen
display.
Switches viewport to one of the predefined views.

Switches visualisation view between Perspective
and Orthographic.

Enable/disable stereo view mode accoridng to the
parameters specified in Preferences dial og.

Shows or hides Workspace pane.

Shows or hides Timeline pane.
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View Menu
% Reference
Photos

| Console

Toolbar

Workflow Menu

Add Photos...
& Add Folder...

Align Photos...
Build Dense Cloud...
Build Mesh...

Build Texture...
Align Chunks...
Merge Chunks...

Batch Process...

ToolsMenu
Decimate Mesh...
Close Holes...
View Mesh Statistics...
View Mesh UVs...
Measure Areaand Volume...

Classify Ground Points...

Assign Class...
Reset Classification...
Select Masked Points...

Build Point Cloud...

Thin Point Cloud...

Shows or hides Reference pane.
Shows or hides Photos pane.
Shows or hides Console pane.

Shows or hides Toolbar.

L oads additional photos to be processed by
PhotoScan.

L oads additional photos from folders to be
processed by PhotoScan.

Generates camera positions and sparse point cloud.
Generates dense point cloud.

Generates polygona model.

Generates 3D model texture.

Aligns multiple chunks.

Merges multiple chunks into the single chunk.

Opens Batch Process dialog box.

Decimates mesh to the target face count.
Closes holes on the model surface.

Collects and displays mesh statistics.

Displays mesh UV mapping.

Displays surface area and volume of the model.

Classifies dense point cloud based on the user
defined settings.

Assigns class to the selected points.
Resets assigned classes.
Selects masked dense cloud points.

Builds sparse point cloud based on the estimated
camera parameters available.

Thin point cloud by reducing the number of
projections on the individual photos to the given
limit.
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ToolsMenu

Detect Markers...

Track Markers...

Print Markers...
Import Mesh...
Import Texture...
Import Cameras...
Import Markers...

Import Masks...

Export Texture...
Export Cameras...
Export Markers...
Export Matches...
Export Masks...
Export Panorama...

Undistort Photos...

Camera Calibration...
Optimize Cameras...

Reset Region

Preferences...

4% Run Script...

Photo Menu

Open Next Photo

Open Previous Photo

- Navigation

r—-

1 1
L—a

=

Rectangle Selection

Intelligent Scissors

% Intelligent Paint

Creates markers from coded targets on photos.

Tracks marker locations across the frame
sequence.

Generates printable PDF file with coded targets.
Imports edited mesh from the external program.
Imports edited texture from the external program.
Imports camera positions and orientation data.
Imports marker projections.

Imports masks or creates mask from model or
background.

Exports model texture.

Exports camera positions and orientation data.
Exports marker projections.

Exports tie point measurements.

Exports masks.

Exports spherical panoramafor camera stations.

Removes nonlinear distortions by warping source
photos.

Shows camera calibration dialog box.
Shows camera alignment optimization dialog box.

Resets reconstruction volume selector to default
position based on the sparse point cloud.

Shows preferences dialog box.

Opens Python Run Script dialog box.

Opens next photo from the list in the Photos pane.

Opens previous photo from the list in the Photos
pane.

Switches to navigation mode.
Rectangle selection tool.
Intelligent Scissors selection tool.

Intelligent Paint selection tool.
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Photo Menu

S Magic Wand

I Add Selection

L] Subtract Selection

Invert Selection
Invert Mask
% Reset Mask...

Turn Shading On/Off
% Eit Markers

oo )
oo View Points

Help Menu
57 Contents

Check for Updates...
Activate Product...

@ About PhotoScan...

Toolbar buttons

General commands
D New
Open

HSave

3D view commands
“} Undo
™ Redo

* Navigation
P Rectangle Selection
(_J Circle Selection

'l_g Free-Form Selection

Magic Wand selection tool.

Adds current selection to the mask.
Subtracts current selection from the mask.
Inverts current selection.

Inverts mask for the current photo.

Resets mask for the current photo.

Turns mask shading on or off.

Switches to marker editing model.

Shows detected features used for alignment of the
current photo.

Displays help contents.

Checks if PhotoScan updateis available for
download.

Activates / deactivates the product using the
activation key.

Displays program information, version number and
copyright.

Creates a new PhotoScan project file.
Opens a PhotoScan project file.

Saves a PhotoScan project file.

Undo the last editing operation.

Redo the previously undone editing operation.
Navigation tool.

Rectangle selection tool.

Circle selection tool.

Free-form selection tool.
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3D view commands
- Resize region
82’ Rotate Region
-"-:f_c" Rotate Object
Pt Delete Selection
ﬁ Crop Selection
3D view settings

oo .
oo Point Cloud

=

a5 Dense Cloud

#1 Dense Cloud Classes

4> snaded
& solid

<> Wireframe
& Textured

82 show Cameras
"37 Show Markers

£ Show Aligned Chunks
"3 Reset View

Photo view commands
“1 Undo

™ Redo

“I Navigation

L-. Rectangle Selection
% Intelligent Scissors
% Intelligent Paint

N Magic Wand

“../ Add Selection

..... Subtract Selection

Volume selection tool.

Volume rotation tool.

Model rotation tool.

Removes selected faces / points.

Crops selected faces/ points.

Displays sparse point cloud reconstructed during
image alignment.

Displays dense point cloud model.

Displays dense point cloud coloured by point
classes.

Displays 3D modél in the shaded mode.
Displays 3D model in the solid mode.
Displays 3D model in the wireframe mode.
Displays 3D modé in the textured mode.

Shows / hides camera positions, reconstructed
during image alignment.

Shows/ hides positions of markers placed on the
model.

Shows / hides aligned chunks.

Resets model view.

Undo the last mask editing operation.

Redo the previously undone mask editing
operation.

Switches to the navigation mode.
Rectangle selection tool.
Intelligent scissors tool.

Intelligent paint tool.

Magic wand tool.

Adds current selection to the mask.

Subtracts current selection from the mask.
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Photo view commands
Inverts current selection.

Invert Selection

A .
I Rotate Ri ght Rotates the photo clockwise.

JE Rotate L eft Rotates the photo counterclockwise.
.!.{ Zoom In Increases magnification.
:i Z00mm Out Decreases magnification.
Turn Shading O/Off Turns mask shading on or off.
"Q? Edit Markers Switches to marker editing mode.
22 \View Points Shows/ hides feature points used for alignment of
the photo.
Hot keys
General
Create new project Ctrl + N
Save project Ctrl +S
Load project Ctrl +O
Full Screen F11
Model View

Undo (only for Delete, Assign Class/ Classify Ctrl +Z
Ground Points,Masking and Close Holes

operations)

Redo (only for Delete, Assign Class/ Classify Ctrl +Y
Ground Points,Masking and Close Holes

operations)

Switch between navigation and any other Space
previously selected mode

Switch to stereoview mode 9

Switch between orthographic and perspective view 5

modes

Change the angle for perspective view Ctrl + mouse wheel
Assign dense cloud class (only if some pointsare  Ctrl + Shift + C
selected)

Predefined Views

Top 7

Bottom Ctrl +7

Right 3
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Predefined Views

Left Ctrl +3

Front 1

Back Ctrl +1

Rotate View

Rotate Up 8

Rotate Down 2

Rotate L eft 4

Rotate Right 6
Photo View

Next photo (according to Photos pane order) Page Up

Previous photo (according to Photos pane order)  Page Down
Navigation mode Y
Selection Tools

Rectangle selection M

Intelligent scissors L

Intelligent paint P

Magic wand w

Add selection Ctrl + Shift + A
Subtract selection Ctrl + Shift + S
Invert selection Ctrl + Shift + 1
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Appendix B. Supported formats
Images

Input formats
JPG

TIFF

PNG

BMP
OpenEXR
PGM, PPM
MPO

SEQ

Camera calibration

Import formats

PhotoScan/Lens Calibration (*.xml)
Australis Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CalibCam Camera Parameters (*.txt)
CaCam Camera Calibration (*.cal)

Camera flight log

GCP

Input for mat

JPG EXIF metadata
Character-separated values (* .txt)
MAVinci CSV (*.csv)
TopoAxistelemetry (*.tel)
C-Astral Bramor log (*.100)

locations

Input format
Character-separated values (* .txt)
PhotoScan structure (*.xml)

Undistort formats
JPG

TIFF

PNG

BMP

OpenEXR

Export formats

PhotoScan/Lens Calibration (*.xml)
Australis Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CalibCam Camera Parameters (*.txt)
CaCam Camera Calibration (*.cal)

Estimated positions
Character-separated values (* .txt)
PhotoScan structure (*xml)

Estimated positions
Character-separated values (* .txt)
PhotoScan structure (*.xml)

Intrinsic and extrinsic camera parameters

Import camera positions
PhotoScan (*.xml)

Export camera positions
PhotoScan (*.xml)




Supported formats

Import camera positions
BINGO (*.dat)

Bundler (*.out)

VisionMap Detailed Report (*.txt)

Tie points

Import not available

Sparse/dense point cloud

Import not available

Mesh model

Import mesh

Wavefront OBJ (*.obj)

3DS models (*.3ds)
COLLADA (*.dae)

Stanford PLY (*.ply)

STL models (*.stl)
Autodesk DXF (*.dxf)
Autodesk FBX (*.fbx)
Universal 3D models (*.u3d)

Export camera positions

Bundler (*.out)

CHAN files (*.chan)

Boujou (*.txt)

Omega Phi Kappa (* .txt)

PATB Exterior Orientation (*.ptb)
BINGO Exterionr Orientation (*.dat)
AeroSys Exterior Orientation (*.orn)
Inpho Project File (*.prj)

Export matches
BINGO (*.dat)
ORIMA (*.txt)
PATB (*.ptb)

Export formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
XYZ Point Cloud (*.txt)
ASPRSLAS (*.las)
ASTM E57 (*.657)
Universal 3D (*.u3d)
potree (*.zip)

PhotoScan OC3 (*.oc3)
Adobe PDF (*.pdf)

Export mesh

Wavefront OBJ (*.obj)

3DS models (*.3ds)
COLLADA (*.dae)

Stanford PLY (*.ply)

STL models (*.stl)
Autodesk DXF (*.dxf)
Autodesk FBX (*.fbx)
Universal 3D models (*.u3d)
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Import mesh Export mesh
OpenCTM models VRML models (*.wrl)
Adobe PDF (*.pdf)

Texture
Import texture Export texture
JPG JPG
TIFF TIFF
PNG PNG
BMP BMP
OpenEXR OpenEXR
PGM, PPM PGM, PPM

Orthophoto

Export orthophoto
GeoTIFF

JPG

PNG

Google Earth KML/KMZ

Digital elevation model (DSM/DTM)

Export DEM

GeoTIFF elevation (*.tif)

Arc/Info ASCII Grid (*.asc)

Band interleaved file format (*.bil)
XYZ (*.xyz)

Sputnik KMZ (*.kmz)

Tiled models

Export tiles
PhotoScan Model Tiles (*.tls)
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Appendix C. Camera models

Agisoft PhotoScan supports several parametric lensdistortion models. Specific model which approximates
best a real distortion field must be selected before processing. All models assume a central projection
camera. Non-linear distortions are modeled using Brown's distortion model.

A cameramodel specifiesthe transformation from point coordinatesin the local camera coordinate system
to the pixel coordinatesin the image frame.

Thelocal camera coordinate system has origin at the camera projection center. The Z axis points towards
the viewing direction, X axis pointsto theright, Y axis points down.

The image coordinate system has origin at the top left image pixel, whith the center of the top left pixel
having coordinates (0.5, 0.5). The X axis in the image coordinate system points to theright, Y axis points
down. Image coordinates are measured in pixels.

Equations used to project a points in the local camera coordinate system to the image plane are provided
below for each supported camera model.

The following definitions are used in the equations:

(X,Y, Z) - point coordinates in the local camera coorinate system,

(u, v) - projected point coordinates in the image coordinate system (in pixels),
(fx, fy) - foca lengths,

(Cx, Cy) - principal point coordinates,

K1, Ko, K3, K4 - radial distortion coefficients,

Py, P, - tangential distortion coefficients,

skew - skew coefficient between the x and the y axis,

width - image width in pixels,

height - image height in pixels.

Frame cameras

x=X/Z

y=Y/Z

r = sgrt(x? + y?)

X' = X(1 + Kqr? + Kor* + Kar® + Kar®) + Py(r2+2x2) + 2Pyxy
y' = Y(L+ Kar? + Kor® + Kar® + Kgr®) + Py(r?+2y?) + 2Poxy
U=y + X'y +y'skew

V:(:y+y'fy
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Cameramodels

Fisheye cameras
Xo=X/1Z
Yo=Y /Z
o = SOrt(xo” + yo’)
X=Xo* tan'lrol ro
y =Yo* tan'ro/ 1o
r = srt(x? + y?)
X' = X(1+ Kar? + Kar* + Kar® + Kgr®) + Py(r+2¢) + 2Pyxy
' = y(L+ Kar? + Kor® + Kar® + Kgr®) + Py(r2+2y?) + 2Pxy
U=y + X'y +y'skew
v=oy +yfy

Spherical cameras (equirectangular projection)
u=cy +fy * tan’ (X / 2)
v=cy +fy* tan (Y [ sgri(X * X + Z* Z))
where:
Cx = width* 0.5
¢y = height * 0.5
fy = width/ (2* pi)
fy = height / pi
4 Note

» Spherica (equirectangular) camera model doesn't support distortions. All distortions should be
corrected before loading images in PhotoScan.

* In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to
process original images in PhotoScan using camera station function instead of stitching them in
external software.
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