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1. Introduction 
FARO® is pleased to announce the release of SCENE 5.0, SCENE LT 5.0, and SCENE 
WebShare 5.0, and would like to thank all users who gave valuable input for the 
improvement of the former release and during the beta test phase. With this release 
we deliver a new version of the FARO Laser Scanner software that will improve your 
ability for productivity, your mobility and ease of use in many directions. 
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2. Differences Between the Members of the SCENE Software 
Family 

2.1. SCENE 
SCENE is a comprehensive 3D point cloud processing and managing software tool for 
the professional user. It is specially designed for the viewing, administration, and 
working with extensive 3D scan data obtained from high resolution 3D laser scanners 
like the FARO Focus3D. SCENE processes and manages scanned data both highly 
efficiently and easily by offering a wide range of functions and tools, like filtering, 
automatic object recognition, scan registration and positioning as well as automatic 
scan colorization. Once SCENE has prepared the scan data, you can commence 
evaluation and further processing right away. For this, it offers functions from simple 
measuring to 3D visualization through to meshing and exporting your scan data into 
various point cloud and CAD formats. With SCENE WebShare your scan projects can 
then be published on the Internet and viewed with a standard Internet browser. 

2.2. SCENE LT 
SCENE LT is a free point cloud viewing software to provide to your partners together 
with your scan data. It is specifically designed for all FARO laser scanner scan data 
and allows viewing and evaluating scanning projects which have been prepared with 
SCENE. Also importing CAD models in VRML format in order to compare them with the 
scan points, exporting scan data into various point cloud formats as well as the Draw-
To-CAD link to FARO Cloud for AutoCAD are available. SCENE LT may also be used to 
view 3D point clouds which have been downloaded from SCENE WebShare over the 
Internet. SCENE LT doesn’t offer functionality to filter scans, to perform scan 
placement, to colorize scan points, to administer scan projects, or to export your scan 
data to SCENE WebShare. 

2.3. SCENE WebShare 
After creating WebShare data from your scan project in SCENE, the SCENE WebShare 
software allows you to provide your data on a web server in order to share your 
scanning work with partners, contractors and customers. WebShare allows you to 
view scan projects within any Internet browser that has the Adobe® Flash® player 
installed. It allows viewing the scans in panoramic scan images, performing 
measurements, or downloading the workspace and the scans to your local hard disk. 
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3. New Features 
This is a list of the most important new features of SCENE 5.0. For more detailed 
descriptions, please refer to the user manual or the online help of SCENE. 

3.1. SCENE 

3.1.1. Scan Project Concept 
SCENE 5.0 is further extending the concept of scan projects to handle scans and 
related data. 

Scan projects offer an easy way of working with the scan data. A scan project is a 
central storage which contains all the shared data of a project. It consists of the 
project workspace (the hierarchical structure of scans and objects as defined during 
scanning and throughout the registration process) and all the point data of the 
project. 

With the introduction of the scan project concept, SCENE offers tools for collaborative 
work, change management, sharing and publishing data. As a powerful tool for data 
handling, a scan project is offering revisions and a project history. Revisions allow for 
sharing a state of work with other users of the same project. If there have been 
changes made to a project mistakenly, they may be undone by reverting the project 
to an older revision. 

In addition to the shared project data, private and non-shared data owned and 
maintained by individual users can be maintained. This is done by the means of local 
workspaces which are linked to the related scan project. When working collaboratively 
on a scan project, modifications are typically first done on the basis of the local 
workspace. From time to time these local modifications may then be shared with the 
centrally provided scan project and thus among all project collaborators. Each sharing 
of local modifications will update the project workspace and the scans or point clouds 
maintained in the scan project and will create a new revision of the scan project. 

3.1.2. Support for Compass and Altimeter 
The new compass and altimeter which have been introduced with the latest Focus3D 
scanner models is now supported by SCENE 5.0. The information recorded during scan 
time may be used for scan placement. 

The related switches to control the use of the new sensors may be found at Tools > 
Options > Matching. 

Please note that the measurement accuracy of the compass is easily affected by 
disturbing sources of magnetism, like electronic devices, power lines or magnets. To 
get reliable compass readings when capturing the scans, please make sure to position 
the scanner far enough away from such disturbing sources (one to two meters should 
be sufficient, depending on the strength of the magnetic interference). 

3.1.3. Support for GPS Coordinates 
With SCENE 5.0 you may now add GPS coordinates, e.g. measured by a GPS device, 
to certain reference objects in the scans. This information will then be used for 
correspondence search and scan placement. 
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3.1.4. Automatic Feature Recognition 
There have been numerous internal modifications to improve the performance of 
SCENE when working with natural features for the scan placement instead of artificial 
features (like spheres or checkerboard targets). 

The quality of feature detection has been improved to avoid too many detected 
features. 

With former versions of SCENE, repeating structures like tiled floors or ceiling liners 
could have resulted in a large number of detected features which may have led to 
ambiguous situations for the scan placement algorithms. To relax this kind of 
situations, SCENE 5.0 is searching for repetitive patterns and is not creating features 
in such areas. 

3.1.5. Fine Registration 
Fine Registration is a new functionality to further improve the quality of scan 
placement. In particular with the automatic detection of natural features one faced the 
fact that the same object is seen differently by the scanner looking at it from different 
positions. This leads to the effect that the automatically detected features in different 
scans might not reside on the exact same position on the scanned object. These 
differences may have led to not satisfying remaining tension during the scan 
placement procedure. 

The new fine registration is an addition to the usual registration calculations and 
meant to overcome this problem. 

During the fine registration, SCENE is using pairs of corresponding features. Around 
each feature a predefined volume of scan points is taken from the 2 scans. These sets 
of scan points are used to determine the transformation which would be required to 
achieve a best fit of the scan point samples. The determined transformation is finally 
used to move one of the features into a position which will lead to an improved scan 
placement result. 

This process is carried out for all corresponding features of the current scan cluster. 

The fine registration is an iterative process which will stop automatically as soon as an 
additional iteration would not result in an improvement of the scan placement. After a 
given maximum number of iterations SCENE will stop as well in case there is no 
minimum deviation achievable. 

Although fine registration is primarily meant to optimize the scan placement when 
using natural features, it may also be applied for spheres and checkerboard targets. 

The evaluated radius of scan points as well as the maximum number of iterations may 
be defined at Tools > Options > Matching. 

3.1.6. Point Clouds 
Point Clouds are a new way of storing scan data in SCENE 5.0. Unlike the scan files as 
they come from the scanner, a point cloud uses a spatial approach to store the scan 
data. This makes it much faster in accessing points at a certain spatial position. The 
scan points of a point cloud are automatically loaded and visualized on demand based 
on camera position and point visibility. 

Point clouds can be created for single scans and for the entire project. 

The main means of data handling in SCENE 5.0 is the so-called Project Point Cloud 
which contains all scan points from all scan positions. This will allow a user to view a 
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certain portion of the scanned area without the need to know in which scans the area 
of interest has been captured. 

In terms of the over-all workflow, creating the project point cloud will be the last step 
in the process. Before that, the scans need to be placed correctly, filtered and 
colorized. Thus the project point cloud will be the final deliverable for the majority of 
scanning projects. 

Modifying the project point cloud is possible, but due to the necessary time effort, it is 
recommended to avoid frequent updates. 

3.1.7. 3D Viewing Improvements 
As 3D viewing is becoming a main access to 3D scan data, there have been a set of 
improvements made to the 3D view. 

SCENE 5.0 is now providing dedicated buttons in the 3D view tool bar to determine 
the point size and turning on/off the clear view as well as the gap filling feature. 
Additionally there are tools to align the view to a certain surface and to move the view 
camera to a specific position in the point cloud. Furthermore there is a variable grid 
(orthogonal and radial) which can be shown in the 3D view and allows the user to 
quickly estimate dimensions and areas. 

Some of the new features in 3D view may only apply to point clouds while others may 
be used for point clouds and conventional scan data. 

3.1.8. Measurements in 3D 
SCENE 5.0 is now supporting point-to-point and object measurements in the 3D view. 
Previously, this was limited to the planar view and the quick view. Measurements 
made in the 3D View are only visible in the 3D View. They are not linked to any 
individual scan. 

3.1.9. Stereo Vision 
Provided your computer is equipped with a capable graphics card (for example NVIDIA 
Quadro® or better), it is now possible to render the 3D view for stereo vision. To use 
this ability a suitable viewing device, like a modern 3D TV set or a 3D projector is 
required as well. 

3.1.10. Overview Map 
The overview map in SCENE 5.0 provides an overview of your complete scan project 
and helps orient you in it. The overview map is available in SCENE as soon as 
WebShare data has been created for your scan project. 
 

Revised: 20 March 2012
© 2012 FARO EU-EN-03REF050.pdf



SCENE Version 5.0 
Release Notes 

6 

 
 
The overview map in SCENE has nearly the same functionality as the overview map 
you might already know from SCENE WebShare. For example, it also supports Point-
to-point measurements and area measurements. Measurements created in the 
overview map of SCENE are added as a child to the “Overview Map” object in the 
structure view of the workspace. The circular icons represent the various scanner 
positions. Double-clicking these icons will open the quick view of the related scans. 

3.1.11. Auto Save 
SCENE 5.0 has now an auto save functionality that helps to recover unsaved changes 
which have been lost due to an unplanned application exit such as an application or 
system crash or a power outage. Changes, like scan registration, object operations or 
project structure changes are covered by the auto save functionality. Auto save does 
not cover changes to the point data itself, like deleting scan points, filtering or 
colorization. Therefore you should use the regular save command in frequent intervals 
in order to preserve all the changes you have applied to your current workspace. 

3.1.12. E57 File Format Support 
SCENE 5.0 is supporting the import and export of scan data using the so-called E57 
file format. This file format has been defined as ASTM 2807 standard in 2010 and is 
meant to become a standard exchange format for point cloud data. 
For further details on this new file format, please refer to http://libe57.org/. 

3.1.13. Export of Intensity and Color Values 
When exporting scan points to different file formats, you may now select to export 
color (RGB) and intensity values for each scan point. RGB and intensity export is 
available for the file formats E57, XYZ text, POD (Pointools), PTX and PTS. 

3.1.14. Apps 
SCENE 5.0 is offering an application programming interface (API). This interface 
provides the opportunity to integrate your own functionality into SCENE. This API 
allows anyone to create custom applications (Apps) which integrate seamlessly into 
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the SCENE user interface. Developers are free to share their Apps with others (for free 
or for sale), so that everybody can benefit from them. 

3.1.15. WebShare Upload 
Once WebShare data has been created from your scan project, you may now use the 
WebShare upload which has been integrated into SCENE 5.0 to transfer this data to a 
WebShare server. You may find the WebShare upload under View > View > Upload 
View. 

3.2. SCENE WebShare 

3.2.1. Improved Visualization of Panoramic Images 
With SCENE WebShare 5.0 the mapping accuracy of the panoramic images has been 
improved. In particular, this should eliminate the problem of straight lines appearing 
as wavy lines in the pole regions. 

3.2.2. Units of Length and Units of Area 
Users of SCENE WebShare 5.0 may now change the displayed units of length and 
units of area in the control panel on the left. 
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4. Computer System Recommendations 
Processing scan data is a demanding task for both the software and the computer 
system. To allow SCENE 5.0 to act as a high performance system, the computer 
hardware needs to comply with these requirements. 

Although SCENE 5.0 is able to work on 32-Bit versions of Windows with low 
performance but it is not recommended. FARO recommends the following hardware 
specifications: 

• 64-Bit operation system. Windows 7 is preferred. 

• At least 8 GB of RAM 

• SSD mass storage for the current project data 

• Conventional HDD mass storage for archiving projects 

• Dedicated graphics card with at least 512 MB memory and OpenGL2.0 support 
and ability to control a 3D output device. 
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5. Known Issues 
• There may be issues with the 3D view when using certain AMD/ATI graphics 

cards. In case you observe a strange behavior of the 3D view and you are using 
an AMD/ATI graphics card, you may check whether disabling the Offscreen 
Rendering option, which is enabled by default, solves this problem. The 
Offscreen Rendering option can be disabled in the Tools > Options > View 
dialog. 

• Sometimes, the progress bar dialog might appear in the background behind the 
main SCENE window. Especially, when performing time-consuming processes, 
e.g. creating a project point cloud, this may lead to confusion because it seems 
as if SCENE is not responding anymore. In such cases, please do not force 
SCENE to close and wait until the process is complete. 

• There is a known issue with the performance of the 3D views when working on a 
system with NVIDIA Quadro FX Drivers. Users running NVIDIA QuadroFX and 
QuadroFx Mobile graphics cards may encounter performance issues in 3D views. 
To avoid this problem, please set the NVIDIA Quadro driver profile to “3D App – 
Game Development”. The driver profile options can be found in the NVIDIA 
Control Panel. All users running QuadroFX hardware should compare 3D view 
performance with and without the profile set to “3D App – Game Development” 
to make sure SCENE can deliver 3D view content at maximum performance. 

• Due to compatibility reasons, customers who would like to control the Focus3D 
scanner with their self-developed applications based on the FARO LS SDK 5.0 
need a scanner firmware upgrade. This upgrade will be available soon. Please 
contact customer service for more information. 
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FARO Technologies, Inc. 

250 Technology Park 
Lake Mary, FL 32746 

800-736-2771 U.S. / +1 407-333-3182 Worldwide 
E-Mail: support@faro.com 

 
FARO Europe GmbH & Co. KG 

Lingwiesenstrasse 11/2 
D-70825 Korntal-Münchingen, Germany 

FREECALL +800 3276 7378 / +49 7150/9797-400 
FREEFAX +800 3276 1737 / +49 7150/9797-9400 

E-Mail: support@faroeurope.com 
 

FARO Singapore Pte. Ltd. 
3 Changi South Street 2 

#01-01 Xilin Districentre Building B 
SINGAPORE 486548 

TEL: 1800 511 1360, +65 6511.1350 
FAX: +65 6543.0111 

E-Mail: salesap@faro.com 
 

FARO Japan Inc. 
716 Kumada, Nagakute-Cho 

Aichi-Gun, Aichi-Ken 
480-1144 JAPAN  

TEL: +800 6511 1360, +81 561 63 1411 
FAX:+81 561 63 1412 

E-Mail: support_japan@faro.com 
 

FARO (Shanghai) Co., Ltd. 
Floor 1, Building 29 

No. 396 Guilin Road 
Shanghai, 200233 

CHINA 
TEL: +800 6511 1360, +86 21.6191.7600 

FAX: +86 21.6494.8670 
E-Mail: chinainfo@faro.com 

 
FARO Business Technologies India Pvt. Ltd. 

B-1, D-5, Mohan Cooperative 
Industrial Estate, Mathura Road 

New Delhi - 110 044 
INDIA 

TEL: 000800 650 1397, +91 11.4167.6330/1 
FAX: +91 11.4167.6332 

E-Mail: infoindia@faro.com 
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