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Introduction  
Sooner or later any PC user faces the problem of modifying the hard disk structure. One day you realize that 
your hard drive cannot meet your requirements any more. Either its capacity is insufficient and it is time to 
think about a little upgrade, or you are to carry out some partitioning operations. Whatever the problem is, it 
requires solution. 
 
Our program is a fast, convenient and reliable solution of disk copying, upgrading and configuring needs. It 
provides a wide-range functionality in the field of managing disk layout structures. The key features of the 
program are listed in the special chapter. 
 
Setting up major operations is accomplished by using practical wizards. Each step of the wizard includes in-
depth information in order to allow the user to make the right choice. Graphical representations of the data 
help the user to gain a better understanding. 
 
In this manual you will find the answers to many of the technical questions, which might arise while using 
the program. 
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Key Features  
Let us list some of the key features:  
 
� User friendly interface. Easily understood icons accompany all functions of the program. 
� Previewing the resulting layout of hard disks before actually executing operations (so-called 

virtual operations). 
� Basic functions for initializing, partitioning and formatting hard disks. Instead of the standard 

Windows disk tools, the program supports all file systems. 
� Carrying out advanced partitioning operations such as redistribution of available disk space or 

merging of adjacent partitions of NTFS, FAT or FAT32 file systems with the help of easy-to-
use wizards. 

� Boot Manager Setup Wizard to easily manage several operating systems on one computer. 
� Hot Resize NTFS upward allows the user to enlarge NTFS partitions (system, locked) without 

rebooting Windows and interrupting its work. 
� Copy Partition/Hard Disk Wizards that enable to successfully transfer all on-disk information 

including standard bootstrap code and other system service structures, thus maintaining the 
operating system’s working capability, and that even beginners may understand. 

� Non-destructive modification of partitions parameters, providing the ability to successfully 
migrate operating systems to larger hard disks. 

� Effective tools for file system optimization. Defragmentation of FAT and NTFS file systems 
will help improve the hard disk performance while working with these systems. 

� Conversion of FAT and NTFS file systems without reformatting. 
� Recovering of any accidentally deleted partition by using the Undelete Partitions Wizard. 
� Shutdown After Apply function enables to set the computer to automatically switch off on the 

successful accomplishment of any operation. 
� Volume Explorer utility allows the user to browse and export contents of the local 

mounted/unmounted volumes of any file system as well as 7Tools backups. 
� Build external recovery media that help the user to restore the system even when the current 

operating system cannot boot anymore. 
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Installation  
This chapter provides information which is needed to perform the correct installation of the program, and in 
addition, checks if the current installation is working correctly.  

Package Contents  
The installation package includes the following components:  
 
� Launcher (with an embedded HTML browser)  
� Partition Management 
� Hard Disk Management 
� Copy Partition/ Hard Disk Wizards 
� Boot Manager 
� Recovery Media Builder 

Extra Functionality � 

Minimum System Requirements  
To use the program on a computer satisfactorily, ensure that it meets the following minimum system 
requirements: 
  
� Operating systems: Windows 98/NT/2000/XP/Vista and XP/Vista 64-bit  
� Internet Explorer 5.0 or higher  
� Intel Pentium CPU or its equivalent, with 300 MHz processor clock speed  
� 128 MB of RAM  
� Hard disk drive with 40 MB of available space  
� SVGA video adapter and monitor  
� Mouse  

Installation Procedure 
The installation process consists of the following steps: 
 
1. Run Setup Application 
From the folder, where the setup files are kept, run the SETUP.EXE file. This application will guide the user 
through the process of the program installation. The setup utility is compiled with the InstallShield SDK, 
hence it contains the standard user interface and set of installation steps. 
 

 
In case there is some previous version of the program installed on the computer, the program 
will offer the user to uninstall it first. 

 
2. Starting Setup 
The Welcome page informs that the application is being installed. Click the Next button to continue. 
 
3. Confirm License Agreement 
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The License Agreement page displays the Paragon License Agreement. Read the agreement and then click 
the Yes button to accept. If the user does not agree with any conditions stated there, the installation process 
will be interrupted. 
 
4. Select an Installation Folder 
The Destination Location page allows the user to choose the folder where the program will be installed. By 
default, the installation folder will be created as: 
 
C:\Program Files\Paragon Software\7Tools Partition Manager. To select another folder, click the 
Browse button. 
 
After you have selected the required folder, click the Next button to continue. 
 

 
Do not install the program on network drives. Do not use Terminal Server sessions to install 
and run the program. In both cases, the program functionality will be limited. 

 
5. Select a Program Group 
 
The Program Folder page enables the user to select the application's program group for the Start Menu. By 
default, it will be the program group: 
 
Start > Programs > 7Tools Partition Manager. 
 
Click the Next button to continue. 
 
6. Verify Setup Settings 
 
The Start Copying page allows the user to verify settings, which have already been made and correct them if 
necessary. Press the Back button to return to the previous page and modify the installation settings. Click the 
Next button to complete the installation process. 
 
7. Copying Files 
 
The Setup Status page shows the overall progress of the installation. Click the Cancel button to abort the 
setup. 
 
8. Finishing the Installation 
 
The Final page reports the end of the setup process. 
 

 
To accomplish online copy of locked partitions/hard disks the program uses a kernel mode 
hotcore driver, thus the system reboot is required to complete the installation procedure. 
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Basic Concepts  
This chapter explains terms and ideas that show how the program works. To understand these helps to obtain 
a general notion of the operation performance and makes it easier for the user to operate the program. 

Drive Partitioning 
As you probably know a hard drive is to be split into one or more partitions, since it cannot hold data until it 
is carved up and space is set aside for the operating system. Until recently most PCs used to have just one 
partition, which filled the entire hard disk and contained the OS. The situation has changed however, thanks 
to new cost-effective high capacity hard drives, thus opening up numerous possibilities for PC users, such as 
editing video, archiving music, backing up CD images, etc. Huge increase in space is great, but it poses a 
number of problems, most important of which are effective data organization and speed. 
 
Large drives are always going to take longer to search than smaller volumes, and an operating system is 
going to have its work cut out both finding and organizing files. It is for this reason that many people decide 
to invest in multiple hard drives, but there is an easy solution – drive partitioning. Partitioning lets you 
divide a single physical drive into a number of logical drives, each of which servers as a container with its 
own drive letter and volume label, thus enabling the operating system to process data more efficiently. 
Besides partitioning makes it possible to organize data so that it is easy to find and manage. You can set 
aside, for instance, 40 GB of a 160 GB hard drive for the OS, 70 GB for storing video and another 50 GB for 
your favorite music collections to provide transparent data storage. 
 
It is also worth mentioning to that with a hard drive properly partitioned, such routine operations as files de-
fragmentation or consistency check will not be that annoying and time-consuming any more. 
 
By detaching the OS from the rest of the data you can tackle one more crucial issue – in case of a system 
malfunction, you can get the system back on track in minutes by recovering it from a backup image located 
on the other partition of the hard drive. 
 
But that is not all drive partitioning may be used for. If you are willing to play games in Windows while 
browsing the Internet in Linux, 100-percent sure that no virus will attack your PC, drive partitioning is a 
necessity. In order to run several OSs on a single hard drive you are to create a corresponding number of 
partitions to effectively delineate the boundaries of each OS. 
 
All of the above-mentioned partitioning applications are implemented in the program. And all the necessary 
actions are performed by using the system of convenient wizards. This means that the user simply has to 
follow easy step-by-step instructions to make the appropriate settings.  

64-bit Support 
The bulk of software today is written for a 32-bit processor. It can meet the requirements of almost any end 
user. However that is not the case when dealing with servers processing large amounts of data with complex 
calculations of very large numbers. That is where 64-bit architecture comes into play.  
 
It can boast improved scalability for business applications that enables to support more customer databases 
and more simultaneous users on each server. Besides a 64-bit kernel can access more system resources, such 
as memory allocation per user. A 64-bit processor can handle over 4 billion times more memory addresses 
than a 32-bit processor. With these resources, even a very large database can be cached in memory.  
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Although many business applications run without problems on 32-bit systems, others have grown so 
complex that they use up the 4 GB memory limitation of a 32-bit address space. With this large amount of 
data, fewer memory resources are available to meet memory needs. On a 64-bit server, most queries are able 
to perform in the buffers available to the database. 
 
Some 32-bit applications make the transition to the 64-bit environment seamlessly others do not. For 
instance, system-level utilities and programs that provide direct hardware access are likely to fail. Our 
program offers a full-fledged support of the 64-bit architecture providing fault-tolerant work for such system 
dependent modules as Hot Processing. 

Copy Operations 
Hard drive duplication nowadays is becoming highly popular among PC users. That is due to some definite 
advantages it can offer. First of all, many people clone hard disks just to back up data for security reasons. 
The present day copy utilities enable to successfully transfer all on-disk information including standard 
bootstrap code and other system service structures, thus maintaining the operating system’s working 
capability. In case of a system malfunction, the user can get the system back on track in minutes. No 
additional configuration is required, what is very convenient. 
 
The second possible application is the upgrade of a hard disk to a new one. The capacity of a modern hard 
drive doubles every two years, thus opening up new possibilities for software developers. As a result 
programs become more complicated and require considerable amount of free space. One day the user 
realizes that there is no more free space left on the hard disk and the only way out is to upgrade. Usually that 
means that besides purchasing a new hard disk, the user is to face a large re-installation procedure spanning 
several days of tedious work. But all of this can be avoided just by copying the contents of the old hard disk 
to a new one proportionally resizing the partitions. 
 
And the last but not least is the copying of hard disks for cloning purposes. It may be of great use when 
setting up similar computers. There is no need for a system administrator to install an operating system from 
scratch on every one of them. It is enough just to configure one and then clone it to the others. 
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Interface Overview  
This chapter introduces the graphical interface of the program to the user. The design of the interface 
precludes any mistake being made on the part of the user. Most operations are performed through the system 
of wizards. Buttons and menus are accompanied by easy understandable icons. Nevertheless, any problems 
that might occur while managing the program can be tackled by reading this very chapter. 

General Layout  
When the user starts the program, the first component that is displayed is called the Launcher. It enables the 
user to run wizards and utilities, to specify program settings, to visualize the operating environment and the 
hard disk configuration. 

The Launcher’s window can be conditionally subdivided into several sections that differ in their purpose and 
functionality: 

1. Main Menu  
2. Tool Bar  
3. Virtual Operations Bar  
4. Common Tasks Bar  
5. Explorer Bar  
6. List of Partitions 
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7. Disk Map  
8. Legend Bar 
9. Status Bar  
 
Some of the panels have similar functionality with a synchronized layout. The program enables the user to 
conceal some of the panels to simplify the interface management. 
 
All panels are separated by vertical and horizontal expandable sliders, allowing the user to customize the 
screen layout. 

Main Menu  
The Main Menu provides access to the entire functionality of the program. The available functions are as 
listed below: 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 

MENU ITEM  FUNCTIONALITY  
Tools     
Send Log Files Compress and send the log to the 7Tools Support Team 
Boot Manager… Manage several operating systems on one computer 

Recovery Media Builder… Restore the system even when the current operating system cannot boot 
anymore 

Settings... Edit the general settings of the program  
Exit  Exit the program  
Changes  
Undo "the last virtual 
operation" Cancel the last virtual operation on the List of Pending Operations 

Redo "the last virtual 
operation" Cancel the last undo virtual operation on the List of Pending Operations 

View Changes… Display the List of Pending Operations 
Apply Changes Launch the real execution of virtual operations 
Discard All Changes Cancel all virtual operations on the List of Pending Operations 
Reload Disk Info  Refresh the current information about disks  
Wizards    
Create Partition… Create a partition of any file system 
Format Partition… Format a partition of any file system 
Delete Partition… Delete a partition of any file system 
Copy Hard Disk…  Create a hard disk copy  
Copy Partition…  Create a partition copy 
Merge Partitions… Merge adjacent partitions of NTFS, FAT or FAT32 file systems 
Redistribute Free Space… Redistribute available disk space of existed partitions 
Undelete Partitions… Recover any of accidentally deleted partition 
Hard Disk  
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Update MBR Update MBR (Master Boot Record) of the selected hard disk 
Change Primary Slots… Modify the primary partitions enumeration for the selected hard disk 
Edit/View Sectors… View/edit sectors of the selected hard disk 
Properties… Get in-depth information on the properties of selected hard disk 
Partition  
Create Partition… Create a partition of any file system with the Create Partition dialog 
Format Partition… Format a partition of any file system Format Partition dialog 
Delete Partition… Delete a partition of any file system Delete Partition dialog 
Move/Resize… Move/Resize the selected partition 
Convert File System… Convert file system of the selected partition 
Assign Drive Letter… Assign drive letter to the selected partition 
Remove Drive Letter… Remove drive letter for the selected partition 
Hide Partition… Make the selected partition unavailable for the operating system 
Unhide Partition… Make the selected partition available for the operating system 
Mark Partition as Active Make the selected partition bootable by default 
Mark Partition as Inactive Make the selected partition non-bootable by default 
Change Cluster Size… Change cluster size of the selected partition 
Change Boot Size… Change boot size of the selected partition 
Change Root Size… Change root size of the selected partition 
Change Volume Label… Change volume label of the selected partition 
Change Serial Number… Change serial number of the selected partition 
Change Partition ID… Change identifier of the selected partition 

Decrease version of the selected NTFS partition 
Make Partition Primary… Make the selected partition Primary 
Make Partition Logical… Make the selected partition Logical 
Defragment Partition… Defragment data on the selected partition 
Defragment MFT… Defragment MFT (Master File Table) of the selected NTFS partition 
Test Surface… Test surface of the selected partition/block of free space 
Check File System 
Integrity… Check the selected partition for possible file system errors 

Edit/View Sectors… View/edit sectors of the selected partition 
Properties… Get in-depth information on the properties of selected partition 
View     

Toolbar  Manage the Tool Bar representation: show / hide standard and navigation 
buttons, text labels and large icons.  

Status Bar  Display the Status bar  
Common Tasks Bar  Display the Common tasks bar  
Disk Map Legend Display the Disk map legend 

Downgrade NTFS version…
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Properties and Commands Display the Explorer bar 

Disk Map Location  Select whether the Disk map will be located on the top of the main 
window or at the bottom  

Choose Columns… Select properties to display on the List of partitions 
Help     
Help  Open the Help system  
About  Open the dialog with information about the program  
 

 
The Main Menu contents available at the moment may vary depending on the selected object.

Tool Bar  
The Toolbar provides fast access to the most frequently used operations: 

BUTTON FUNCTIONALITY  

 
Create a partition 

 
Copy a partition 

 
Copy a hard disk 

 
Format a partition 

 
Delete a partition 

 
Open the Help system 

Virtual Operations Bar  
The program supports previewing the resulting layout of hard disks before actually executing operations (so-
called virtual mode of execution). In fact, when the virtual mode is enabled, the program does not 
accomplish operations immediately, but places them on the List of Pending Operations for later 
accomplishment. 
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Cancel the last undo virtual operation on 
the List of Pending Operations 

 Display the List of Pending Operations 

 
Launch the real execution of virtual 
operations 

 
Cancel all virtual operations on the List of 
Pending Operations 

 

 

Virtual mode is an effective way of protection from any troubles, since no operations will be 
executed until clicking the Apply button for confirmation, thus giving a second chance to 
weigh all pros and cons of this or that particular operation. The program politely reminds the 
user that there are unsaved changes by showing the following window: 

 

Common Tasks Bar  
The Common Tasks Bar is located on the left side of the main window. It is intended for easy access to the 
program's wizards that provide all the functionality needed to manage copy operations. 

The bar contains several tabs named Basic Partitioning Tasks, Advanced Partitioning Tasks, Copy Tasks, 
Tools and News and Documentation. Each of these contains a separate button bar which can be folded by 
clicking it. 

Basic Partitioning 
Tasks     

 
Starting the Create Partition Wizard. The Create Partition Wizard assists the 
user to create partitions of any file system. 

 

Starting the Format Partition Wizard. The Format Partition Wizard allows 
formatting existing partitions to one of the file systems supported by the 
program. 

 
Starting the Delete Partition Wizard that enables to delete partitions of any file 
system. 

Advanced Partitioning 
Tasks     

 
Starting the Merge Partitions Wizard. The Merge Partitions Wizard allows 
merging adjacent partitions of NTFS, FAT, FAT32 file systems. 

 
Starting the Redistribute Free Space Wizard that enables to redistribute 
available disk space of existed partitions. 
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Starting the Undelete Partitions Wizard that helps to recover accidentally 
deleted partitions. 

Copy Tasks  

 
Starting the Copy Hard Disk Wizard that helps to make an exact copy of a hard 
disk. 

 
Starting the Copy Partition Wizard that helps to make an exact copy of a 
partition. 

Tools  

 
Starting the Boot Manager Setup Wizard that enables to easily manage several 
operating systems on one computer. 

News and 
Documentation     

 
Opening the page which contains information about the program. This page 
will be displayed in the Explorer bar. 

 Launching the Help system. 

Disk Map  
The Disk Map is displayed in the Explorer bar when the Disk View tab is selected. It is located either at the 
top or at the bottom of the window, depending on the state of the Disk Map Location option (Main menu: 
View > Disk Map Location). The user can change the current location of the map with this option. 
 
As the name infers, the Disk Map displays the layout of physical and logical disks. Physical disks are 
represented with rectangle bars that contain small-sized bars. These small-sized bars represent logical disks. 
Their color depends on the file system of the appropriate partition. 
 

 
 
Large-sized bars display the following information about physical disks: 
� Manufacturer, 
� Model. 

 
Small-sized bars display the following information about logical disks: 
� Serial number, 
� Drive letter, 
� Total size, 
� File system. 
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Disk Map is synchronized with the Explorer bar. When the user selects a disk on the Disk Map the Explorer 
bar displays detailed information of the selected disk. 
 

 

The user can click a large-sized bar to display information about the appropriate physical 
disk in the Explorer bar. A click on a small-sized bar will lead to displaying information 
about the appropriate logical disk. 

Explorer Bar 
The Explorer Bar is located in the center of the main window which emphasizes its importance. The bar 
displays reference information including: 
 

� User Manual, 
� Information about the program consisting of the product's name, the version of the program and a list 

of helpful links, 
� Detailed information about disks selected on the Disk Map, 
� Volume Explorer utility, 
� Disk Editor utility. 

 
According to these categories the Explorer bar has several tabs: 
 

� Disk View, which offers the user the following options: 
- Disk Editor to view/edit sectors of the selected partition/hard disk; 
- Volume Explorer to browse and export contents of the selected partition/hard disk; 
- Properties to view detailed information on the selected partition/hard disk in the bright graphical 
form. 

� Help System, which contains the User Manual and information about the program. 
 
The user is able to access the desired information by clicking on the appropriate tab. 
 
The Explorer Bar is a fully-functional embedded HTML browser, which enables the user to address, for 
example, our company's website to look through important technical notes or download the latest updates 
without having to close the program. The Help System of the program is HTML-oriented. The user can read 
the user manual and follow external links from to get additional information. 
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To easily navigate through browsed pages, the program provides the following functionality: 
 
BUTTON FUNCTIONALITY  

 Return to the previously browsed page  

 Open the next browsed page  

 Stop loading the current page  

 Refresh the contents of the current page  

List of Partitions 
The List of Partitions is another helpful tool that enables the user to get a clear-cut picture of the current 
state of the system hard disks/partitions. Partitions are sorted according to their starting position. For every 
item of the list there is the possibility to call the context-sensitive popup menu with available operations. 
Besides, the program provides detailed information on all hard disks/partitions found in the system including 
the following properties: 
 
   - Name, 
   - Volume label (if exists), 
   - Partition type (Primary/Extended /Logical), 
   - File system type, 
   - Size, 
   - Amount of used and unused (free) space, 
   - Start/End cylinder, 
   - Start/End head, 
   - Start/End sector 
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   - Free size in sectors/bytes 
   - Active/Inactive attribute 
   - Hidden/Unhidden attribute 
 
The user may customize the outlook of the List of Partitions with the appropriate Main menu item: View > 
Choose Columns… 
 

 
 
By marking checkboxes the user can choose whether the required item will be displayed or not. 
 
Furthermore, the List of Partitions is synchronized with the Explorer bar and the Disk Map. 

Legend Bar 
The Legend Bar explains the color scheme used for disk and partition presentation. The user can hide (or 
show) the bar with the appropriate Main menu item: View > Disk Map Legend. When it is activated it can be 
found at the bottom of the Explorer bar.  
 
The program distinguishes between the following types of known file systems: 
 
   - FAT16/32,  
   - NTFS, 
   - Linux Ext2/3,  
   - Linux ReiserFS. 

Status Bar  
This is the bottom part of the main window. The status bar displays menu hints, for each item the cursor 
points to. 
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The user can hide (or show) the bar with the appropriate Main menu item: View > Status bar. 
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Settings Overview 
The Settings dialog is available from the Main menu: Tools > Settings. All the settings are grouped into 
several sections of which the functions are described in the following paragraphs. The list of sections is 
placed on the left side of the dialog. By selecting a section from the list, the user opens a set of options. 

General Options  

 
 
This section contains a set of general options that will be taken into account during all the operations carried 
out with the program. The user can switch between the following modes: 

� Verify data written. If this option is marked, every write-to-disk action is followed by the 
read-and-compare action. This feature may be helpful in case of running an unstable hard 
disk, however it will negatively affect the overall performance. 

� Enable data loss protection. Activate the option to force the program to work in the fail-safe 
mode (also referred to as data-loss protection mode), which ensures more safety for 
operations by maintaining the special journal of operations’ progress. In case of hardware 
malfunction, power outages or operating system failure, the modified partition may become 
corrupted and non-operable. However, the program will be able to complete the interrupted 
operation, thus "reviving" the partition. 

If the system has crashed during the operation in the fail-safe mode, insert the bootable 
Recovery CD and restart the computer. The program will automatically detect the journal of 
the interrupted operation and complete the operation. 
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� Try to access non-BIOS disk cylinders. The option works only under Windows 95, 98, ME. 

When activated, the program performs a special procedure to define the disk capacity and does 
not use the value that is returned by BIOS. 

General Copy and Backup Options  

 
 
This section contains a set of options that will be taken into account during copy and backup operations. The 
user can switch between the following modes: 
 

� HDD raw processing. Activate the option to copy a hard disk in the sector-by-sector mode to 
successfully process unknown file systems. However it is not recommended to enable this option 
when working with supported file systems as it takes more time to accomplish the operation. 

� Partition raw processing. Activate the option to copy a partition in the sector-by-sector mode to 
successfully process unknown file systems. However it is not recommended to enable this option 
when working with supported file systems as it takes more time to accomplish the operation. 

� Perform incremental copy. Once the complete copy of a hard disk is created, it can be used as a 
base for the incremental copy. Mark the option to make the program perform the exact bit-wise 
comparison of the previous data (saved in the parental copy) with the current data (that is actually the 
hard disk itself). After that only most recent information will be processed. It considerably decreases 
the amount of data written. 

Hot Processing Options  

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



  
7Tools Partition Manager ™ 2009 22 User Manual 

   
 

 
 
This section contains a set of options that will be taken into account in case the Hot Processing mode 
is enabled. The Hot Processing mode is a part of the copy operation that allows the program to 
process a disk without restarting the computer. The program forces the system to restart to obtain 
exclusive access to the processing data. The Hot Processing mode may be used to process locked 
partitions or any copy operation. The user defines the method in this section. 
 
The user can also set a Temporary drive. This option defines a partition (by default – C:) for the Hot 
Processing temporary file. The temporary file will be deleted when the hot copy is performed which 
may require a large amount of disk space. Should there not be enough space on drive C:, then 
another drive needs to be selected. 

Partitioning Options 
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This section contains a set of options that will be taken into account during partitioning operations. The user 
can activate the following modes: 
 

� 64 KB cluster size for FAT16 partitions. Only Windows NT 4.0/2000/XP/2003 support 64 KB 
clusters. 

� Request confirmation before partition deletion. 
� Request confirmation when converting FAT16 to FAT32 during such partitioning operations as 

copy disk/partition, restore disk/partition. 
� Surface test level. The option affects the following operations: format partition, copy partition, 

restore partition, retest the surface. While performing the surface test, the program detects corrupted 
sectors and marks them as unusable. 

Virtual Mode Options 
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� Allow virtual mode. In this section the user can choose whether to allow operations to carry out 
immediately or to place them on the List of Pending Operations for later execution. Just mark the 
option to enable virtual operations. 

� Close progress dialog automatically. Mark the option to automatically close the progress dialog 
when the required operation(s) is completed. 

File System Conversion Options  
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This section contains a set of options that will be taken into account while converting file systems. By 
default, the program takes locale (regional) settings from the system. However, the user can customize 
default locale settings such as: time zone and language of file names. 
 
These parameters affect the conversion of file systems "FATxx ->NTFS" and "NTFS -> FATxx". The 
problem lies in the use of different standards for file names and file time stamps (Created, Modified and Last 
access time) of NTFS and FATxx file systems. 
 
Initially, the program displays the default locale settings, which may be changed: 

� Time zone. Specify the time zone to use during a file system conversion. NTFS keeps file 
timestamps in GMT (Greenwich Mean Time) while FAT uses the unadjusted local date and 
time. The program takes proper account of the difference between internal formats of file 
timestamps and enables to use the time zone information to adjust the timestamp values.  

 
In some cases incorrect use of the time zone may lead to inability to run certain software. 

� Language for file names. Choose the correct code page value. NTFS stores file names in 
Unicode while FAT/FAT32 file systems use ANSI encoding for saving short filenames (also 
called DOS aliases). The code page information is required for correct conversion of non-
English filenames from Unicode to ANSI and vice versa.  

 
Incorrect settings will result in corruption of non-English filenames. 

� Request confirmation of settings before NTFS < - > FAT/FAT32 conversion. Mark the 
option to automatically display the dialog of the locale settings confirmation every time the 
Convert file system operation is performed. 

E-Mail Options 
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This section contains a set of options that will be taken into account during the Send log files and Send e-
mail notification operations. The user can define: 
 

� Outgoing mail server (SMTP). To send messages by using the built-in mail client, it is necessary to 
have access to a computer running an SMTP (Simple Mail Transfer Protocol) server. All outgoing 
messages are first sent to the SMTP server, which in its turn delivers them to the required recipients. 
The address may be represented as a traditional Internet host name (e.g.: mail.com) or as an IP 
numeric address (e.g. xxx.xxx.xxx.xx). 

� User e-mail address. Specify an e-mail address that has been assigned by the Internet Service 
Provider or organization's e-mail administrator. 

� My outgoing server requires authentication. Activate the option to allow the program to make 
authentication on the server before sending messages. 
- User name. Enter the name that will be used to log in to the e-mail account. 
- Password. Enter the password that will be used to access the mail server. 
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Getting Information about Disks 
The user is able to view in-depth information on the properties of hard disks. The main tools to extract this 
information are the Disk Map and the List of Partitions. The two represent the actual state of the computer’s 
hard disks. 
 
Generally the hard disks are represented on the map by rectangular bars, which also contain small-sized 
bars. The small-sized bars represent logical disks (partitions). When the user selects a large-sized bar, the 
Explorer bar displays information about the disk in a bright, graphical form.  
 

 
 
The model and serial number of the disk serve as the title of the browsed page. The disk layout is shown in 
form of a circular graph, where the color of a sector corresponds to a file system of an appropriate partition. 
On the right the user may see a table, which contains the following information: 
 

� Type of hard disk (basic or dynamic), 
� Total size (in GB), 
� Information on geometry of the disk (amount of sectors per track, heads and cylinders). 

 
Below there is a list of wizards available for the user. If the user clicks a corresponding record the 
appropriate wizard will be started. All default values for the operation parameters will correspond to the 
disk’s settings. The list of wizards contains a detailed description of tasks that can be performed by the 
wizard. This nullifies the possibility of selecting the wrong wizard. 
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When the user selects a small-sized bar (i.e. corresponding to a logical disk), the Explorer bar will display 
information on it as well. The page title will contain a drive letter, which is assigned to the disk. The disk 
layout graph will be colored in accordance with the volume ratio of the used space to the free space (the 
light colored sector). The table on the right will contain the following information: 
 

� Volume label (if available), 
� Type of the logical disk, 
� File system (represented by the color of the graph and the selected bar), 
� Total size, used space and free space (in GB or MB). 

 
Below there is a list of wizards, which may be called for this disk. All default values of parameters will 
correspond to the disk settings. 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



  
7Tools Partition Manager ™ 2009 29 User Manual 

   
 

Partition Management 
In this chapter you will find all the information necessary to carry out partitioning operations supported by 
the program. 

Basic Partitioning Operations 
Here you can learn how to accomplish basic partitioning operations (create, format, delete) supported by the 
program. To meet the requirements of any user these operations can be accomplished either with the help of 
easy-to-use wizards or through the corresponding dialogs. 

Create Partition 

The program provides the ability to create new partitions by using the DOS partitioning scheme. 

Restrictions 
1. Do not use the Create Partition function in order to undelete the last deleted partition. 
2. The program cannot create new partitions on Dynamic Disks. The current version of the program supports 
only hard disks that use the DOS partitioning scheme (in Windows 2000 and XP these disks are named 
Basic Disks). 
3. According to the rules of the DOS partitioning scheme, the following combinations of partitions cannot be 
created: 
� Two Extended Partitions on one hard disk 
� Five or more Primary partitions on one hard disk 
� If there is an Extended Partition on the disk, only three Primary partitions are allowed 

 
4. The program allows creating new partitions only within blocks of unpartitioned space. It cannot convert a 
free space on an existing partition to a new partition. 

Starting Wizard 

There are several ways to start the Create Partition Wizard: 
 

� In the Main menu: select Wizards > Create Partition… 
� On the Common Tasks bar: click the Create Partition item of the Wizards menu. 
� In the Toolbar: click the Create Partition button. 

 

After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
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Starting Dialog 

In order to start the operation the user should take the following steps: 
 
1. Select a block of free space on the Disk Map. 
 
2. Call the Create Partition dialog to define appropriate settings: 

 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Create Partition. 

Settings 

Despite different work algorithms, both the Create Partition Wizard and the Create Partition dialog provide 
the same level of functionality, thus let us just take as an example the dialog version of the operation. 
 
Define the future partition parameters with the Create Partition dialog. Initially the program suggests some 
consistent values for all parameters. In most cases, the user can just press the Yes button to confirm the 
operation. 
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� Define whether the partition will be Primary, Extended or Logical. Select the desired type of the 
new partition from this pull-down list. As a matter of fact, the available alternatives fundamentally 
depend on the type of the selected block of free space - within the Logical free space, only Logical 
partitions can be created; Within the Primary free space, both Primary partitions or the Extended 
Partition can be created. 

� Partition Size. Define the size (in MB) of the new partition. 
� Free space before. Define the position (in MB) of the new partition relative to the beginning of the 

block of free space. 
� Free space after. Define the amount of trailing free space (in Mb) at the end of the new partition. 

 

 

Partition size and position may also be defined by using the drag-and-drop technique. To do 
that, just carry out the required operation on the Disk Map. The virtual operations are to be 
available. 

 
� File system for new partition. From the pull-down list select a file system the newly created 

partition will be formatted to, otherwise the partition will remain unformatted (so that it will not be 
ready to use). 

 
In addition, there is the possibility to make further detailed settings (although the default values will do in 
most cases). To activate the advance mode, the user needs to click the More options button at the foot of the 
dialog page. Depending on the file system, the following options become available: 
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� Whether the surface test will be performed. Mark the option to make the program perform the 
surface test on the formatted partition. In this case, the program will find bad and unstable sectors 
and mark them unusable in the file system metadata. 

� The amount of sectors per boot. This parameter is available exclusively for FAT16 and FAT32 file 
systems. Set the number of sectors to be reserved for the boot area on the partition with this spinner 
control. 

� The amount of root entries. This parameter is available exclusively for FAT16 file system. Set the 
maximum amount of files/directories to be placed in the Root Directory on the FAT16 partition. 

� The amount of sectors per cluster. Define the Cluster Size for the formatted partition with this 
spinner control. 

Results  
After the operation is completed the user receives a fully functional partition. 

Format Partition  

Any partition should contain some file system to be used for keeping data. The process of installing a file 
system is commonly known as formatting. A huge variety of file systems have been developed these days. 
The program provides the ability to format existing or newly created partitions of the following file systems: 
 
   - FAT12 & FAT16 
   - FAT32 
   - NTFS 
   - Ext2 
   - Ext3 
   - ReiserFS 
   - Linux Swap v. 2 
   - HPFS 

Starting Wizard 
There are several ways to start the Format Partition Wizard: 
 

� In the Main menu: select Wizards > Format Partition… 
� On the Common Tasks bar: click the Format Partition item of the Wizards menu. 
� In the Toolbar: click the Format Partition button. 
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After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
 

 

Starting Dialog 
In order to start the operation the user should take the following steps: 
 
1. Select a block of free space on the Disk Map. 
 
2. Call the Format Partition dialog to define appropriate settings: 

 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Format Partition. 

Settings 
Despite different work algorithms, both the Format Partition Wizard and the Format Partition dialog 
provide the same level of functionality, thus let us just take as an example the dialog version of the 
operation. 
 
Define parameters of the formatting operation with the Format Partition dialog. Initially the program 
suggests some consistent values for all parameters. In most cases, the user can just press the Format button 
to confirm the operation. 
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� File system. Select the desired file system type from this pull-down list. In fact, the program displays 
only file systems that can be correctly placed to the selected partition, taking the capacity of the 
selected partition into account. 

� Volume label. Enter a label for the selected partition in this textual field. The Volume label is an 
irrelevant parameter of a logical drive that can be used for drive identification. 

 
In addition, there is the possibility to make further detailed settings (although the default values will do in 
most cases). To activate the advance mode, the user needs to click the More options button at the foot of the 
dialog page. Depending on the file system, the following options become available: 
 

 
 

� Use OS built-in routine. Mark the option to restrict the available values according to the used OS. 
� Whether the surface test will be performed. Mark the option to make the program perform the 

surface test on the formatted partition. In this case, the program will find bad and unstable sectors 
and mark them unusable in the file system metadata. 

� The amount of sectors per boot. This parameter is available exclusively for FAT16 and FAT32 file 
systems. Set the number of sectors to be reserved for the boot area on the partition with this spinner 
control. 

� The amount of root entries. This parameter is available exclusively for FAT16 file system. Set the 
maximum amount of files/directories to be placed in the Root Directory on the FAT16 partition. 

� The amount of sectors per cluster. Define the Cluster Size for the formatted partition with this 
spinner control. 

Results  
After the operation is completed the user receives a fully functional partition formatted to the file system 
specified. 

Delete Partition 

The program allows the user to delete partitions on hard disks partitioned with the DOS partitioning scheme. 
The program removes references to the partition from the Partition Table, so that the information from the 
deleted partition becomes inaccessible. The resulted disk space can be used to create new partitions.  
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Contents of the deleted partition do not disappear from the disk but merely are unavailable for the operating 
system. 

Starting Wizard 
There are several ways to start the Delete Partition Wizard: 
 

� In the Main menu: select Wizards > Delete Partition… 
� On the Common Tasks bar: click the Delete Partition item of the Wizards menu. 
� In the Toolbar: click the Delete Partition button. 

 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
 

 

Starting Dialog 
In order to start the operation the user should take the following steps: 
 
1. Select a block of free space on the Disk Map. 
 
2. Call the Delete Partition dialog to define appropriate settings: 

 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Delete Partition. 

Settings  
Despite different work algorithms, both the Delete Partition Wizard and the Delete Partition dialog provide 
the same level of functionality, thus let us just take as an example the dialog version of the operation. 
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� Enter the volume label to confirm deleting. To confirm the deletion of the selected partition, enter 
its Volume Label. The actual Volume Label value is displayed above. 

� Do not ask volume label next time. Mark the option to inhibit confirmation of the partition deletion. 

Results 
The deletion of a partition takes only a fraction of a second. However, the program waits until Windows 
completes the modification of the disk layout. 

Advanced Partitioning Operations 
Here you can learn how to accomplish advanced partitioning operations (merge, redistribute free space, 
undelete, etc.) supported by the program. 

Merge Partitions 

The Merge Partitions Wizard enables to consolidate the disk space, which originally belongs to two adjacent 
partitions, into a single, larger partition. The order, in which two partitions have been chosen, is important 
since the contents of the second selected partition will be placed in the folder of the first selected partition. 
 
The program provides the ability to merge only NTFS, FAT16 or FAT32 partitions. 

Starting 

There are several ways to start the Merge Partitions Wizard: 
 

� In the Main menu: select Wizards > Merge Partitions… 
� On the Common Tasks bar: click the Merge Partitions item of the Wizards menu. 

 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
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Settings 
The Merge Partitions Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 
 

� The partition to expand. Select a partition that will be expanded to take contents of an adjacent 
partition. 

� The partition to merge with. Choose the second partition for the merge operation, the contents of 
which will be placed in the folder of the first selected partition. By default the program automatically 
offers a folder name to store files of the second partition, which however can be customized by the 
user. 

 

 
Be particularly careful when selecting system partitions to process, since the incorrect order, 
in which two partitions have been chosen, will result in inability to boot the operating system. 

Results 
After the operation is completed the disk space of the two adjacent partitions will be consolidated. 

Redistributing Unused Space between Partitions 

The Redistribute Free Space Wizard helps to increase free space on one partition at the expense of unused 
space on others. By default, the wizard adds to the target partition the 50% of unused space of other 
partitions, which have been selected to donate space. The user can manually control what part of unused 
space will be left on a partition. The wizard automatically recalculates the positions of the partitions and 
moves their contents to new locations. 

Starting 
There are several ways to start the Redistribute Free Space Wizard: 
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� In the Main menu: select Wizards > Redistribute Free Space… 
� On the Common Tasks bar: click the Redistribute Free Space item of the Wizards menu. 

 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
 

 

Settings 
The Redistribute Free Space Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 
 

� The partition to enlarge. Select a partition, the size of which will be increased at the expense of 
other partitions. Blocks of free space, if any will be automatically added to the target partition. 

� The partition to donate. Choose any partition (not only adjacent) to donate free space if available. 
By default, the program leaves 50% of the unused space on a partition and removes another 50% to 
add it to the target partition, however the size to take can be customized by moving the slider at the 
bottom of the page. 

Results 
After the operation is completed free space of the specified partition will be increased at the expense of 
unused space of the others. 

Undelete Partition 

When deleting a partition, disk management software only removes references to it in the Partition Table so 
that a previously deleted partition can still be recovered (in case of valid restoration of the record in the 
Partition Table). The program provides the ability to find and recover these partitions. This function 
minimizes the hazard of occasional partitions deletion and is usually known as undelete. 
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A restored partition will be fully functional, as long as other partitions were not created, moved or exceeded 
the disk space occupied by the partition. That is why the program enables the Undelete Partition function 
only for blocks of free space. 
 
The operation can be accomplished with the Undelete Partition Wizard. 

Starting 
There are several ways to start the Undelete Partition Wizard: 
 

� In the Main menu: select Wizards > Undelete Partitions… 
� On the Common Tasks bar: click the Undelete Partition item of the Wizards menu. 
� Select a disk on the Disk map and click the Recover Lost Partitions item on the page that appears in 

the Explorer bar. 
 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed. 
 

 

Settings 
The Undelete Partition Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 
  

� Free blocks to scan for lost partitions. Choose a free block from a tree-like list of available disks 
and their partitions. 
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� Manual setting of search criteria. Activate the advance mode 

 to manually specify: 
- A particular file system to look for; 
 

 
 
- Required search criteria. 
 

 
 

 
To use the advance mode, a good knowledge of hard disk structure is required. 

Results 
After the operation is completed the user receives a fully functional partition. 

Move & Resize Partition 

The Move & Resize Partition function allows the user to modify the size and position of partitions on the 
hard disk keeping all on-disk information intact. 
Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



  
7Tools Partition Manager ™ 2009 41 User Manual 

   
 
 
In order to move/resize a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Move/Resize Partition dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Move/Resize Partition … 
� On the Explorer bar: click on the current total size value. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Move/Resize Partition… 
 
3. Define parameters of the operation with the Move/Resize Partition dialog. 
 

 
 

� Partition preview. The disk map displays the resulting disk layout after the move/resize operation is 
completed. 

� Partition size. Define the size (in Mb) of the modified partition. 
� Free space before. Define the position (in Mb) of the partition relative to the beginning of the 

available range of disk space. 
� Free space after. Define the amount of trailing free space (in Mb) at the end of the available range 

of disk space. 
 

 

Partition size and position may also be defined by using the drag-and-drop technique. To do 
that, just carry out the required operation on the Disk Map. The virtual operations are to be 
available. 

 
In addition, there is the possibility to make further detailed settings (although the default values will do in 
most cases). To activate the advance mode, the user needs to click the More options button at the foot of the 
dialog page. The following options become available: 
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� Verify write operation. Define whether the Writing Verification test will be accomplished during 
the operation or not. 

� Sector to sector move. Activate the sector-to-sector mode (allows to process any file system, even 
unknown one). 

� Surface test level. Select from the pull-down list the level of the surface test. 
 

 

When resizing a FAT16 partition beyond the 2GB limit (maximum file system size), the 
partition will be automatically converted to FAT32. 
 
The program enables to enlarge NTFS partitions (system, locked) without rebooting 
Windows and interrupting its work providing 100 percent guarantee that your data is kept 
intact. 

 
4. The operation will be performed immediately after confirmation. 

Convert File System 

The program provides the ability to change the file system type without destroying data. While performing 
the operation, the program first checks for consistency the current file system and then verifies whether the 
on-partition data meet the requirements of the desired file system or not. After having passed the testing, the 
program re-organizes the file system metadata and user files. 
 
The program enables to convert the following file system types: 
 
- FAT16 > NTFS, FAT32 
- FAT32 > NTFS, FAT16 
- NTFS > FAT16, FAT32 
- Ext2 > Ext3 
 
In order to convert file system of a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Convert file system of partition dialog to define appropriate settings: 
 

� Select in the Main menu: Partition > Convert file system… 
� On the Explorer bar: click on the current file system type. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Convert File System… 
 
3. Define parameters of the operation with the Convert file system of partition dialog. Initially the program 
suggests some consistent values for all parameters. In most cases, the user may just press the Convert button 
to confirm the operation. 
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� Current file system. The dialog allows the user to get information on the selected partition. 
� New file system. The pull-down list contains file systems to convert to. The program only displays 

available variants, taking into account current parameters of the selected partition and the file system 
limitations. 

� Convert options. 
- New cluster size.  Define the Cluster Size for the partition to convert. 

 

 

The option is only available for FAT16>NTFS and FAT32>NTFS conversion.  
 
The user can only decrease the current cluster size. 

 
- Surface test level. Select from the pull-down list the surface test level. 

 
4. The operation will be performed immediately after confirmation. 

Change Cluster Size 

Cluster Size is one of the important parameters of any file system. The Cluster Size value affects implicitly 
the performance of the files input-output activity since it defines the size of the file system metadata. 
Besides, the so-called waste space factor also depends on the Cluster Size value. 
 
The program provides the ability to change the Cluster Size to any available value without destroying data.  
 
In order to change the cluster size of a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Cluster Size dialog to define appropriate settings: 
 

� Select in the Main menu: Partition > Modify > Change Cluster Size… 
� On the Explorer bar: click on the current sectors per cluster value. 

 
3. Define a new value with the Change Cluster Size dialog. 
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Sectors per cluster. Select a new cluster size value from the pull-down list. 
 

 
The Cluster Size value is expressed in Sectors Per Cluster. To get the Cluster Size in Kbytes, 
divide it into half. 

 
4. The operation will be performed immediately after confirmation. 

Make Logical/Make Primary 

The program provides the ability to include a Primary Partition in the Extended Partition, or exclude a 
Logical Partition from the Extended Partition, without partition duplication. 
 
In order to change a partition type the user should take the following steps: 
 
1. Select a primary or logical partition on the Disk Map. 
 
2. There are several ways to Make Partition Logical/Primary: 
 

� Select in the Main menu: Partition > Modify > Make Partition Logical/Primary. 
� On the Explorer bar: click on the current partition type. 

 

 
 

 

The Make Primary > Logical option is only available when the selected partition is adjacent to 
the Extended partition and vice versa. 
 
The Make Primary > Logical option of the system partition will result in inability to boot the 
operating system. 

 
3. The operation will be performed immediately after confirmation. 

Changing Partition Attributes 
This chapter explains how the user can change partition attributes (Active flag, Hidden flag, Partition ID, 
Volume Label, etc.). 
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Mark Partition Active/Inactive 

The program enables to set Active/Inactive flag for primary partitions of the hard disk. By default the 
operating system will boot from the active (bootable) partition at startup. 
 
In order to mark partition Active/Inactive the user should take the following steps: 
 
1. Select a primary partition on the Disk Map. 
 
2. There are several ways to Mark Partition Active/Inactive: 
 

� Select in the Main menu: Partition > Mark Partition Active/Inactive. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Mark Partition Active/Inactive. 
 

 
 

 
There can only be one active partition on a hard disk, otherwise the operating system will fail 
to boot. 

 
3. The operation will be performed immediately after confirmation. 

Hide/Unhide Partition 

The program allows the user to Hide/Unhide primary and logical partitions. The operating system does not 
mount hidden partitions, thus preventing access to their contents. 
 
In order to Hide/Unhide a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
2. There are several ways to Hide/Unhide partitions: 
 

� Select in the Main menu: Partition > Hide/Unhide Partition. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Hide/Unhide Partition. 
 

 
It is strongly recommended not to hide the system partition, otherwise the operating system 
will fail to boot. 

 
3. The operation will be performed immediately after confirmation. 

Set Label of a Partition 
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The Partition Label is a small textual field (up to 11 characters) that is located in the partition's boot sector. 
This value is detectable by any partitioning tool; it is used for notification purposes only. 
 
In order to change a partition label the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Volume Label dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Change Volume Label. 
� On the Explorer bar: click on the current volume label. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Change Volume Label. 
 
3. Define the label of the partition with the Change Volume Label dialog: 
 

 
 
New volume label. Enter the new value of the Partition Label. The length of the Label is limited to 11 
characters. 
 
The dialog also displays the current partition label.  
 
4. The operation will be performed immediately after confirmation. 

Change Partition ID 

Partition ID is an identifier of a file system that is placed in the partition. Partition ID is saved in the 
Partition Table; it is used to quickly detect partitions of supported types. By manually changing the Partition 
ID value, it is possible to manipulate the accessibility of partitions. 
 
In order to change a Partition ID the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Partition ID dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Change Partition ID… 
� On the Explorer bar: click on the current partition ID. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Change Partition ID… 
 
3. Define the ID of the partition with the Change Partition ID dialog: 
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� Predefined ID. Select from the pull-down list ID values for various file systems. 
� Enter ID manually. The textual field contains a hexadecimal presentation of the Partition ID. 

Generally, the Partition ID should be presented as 1-2 digits hexadecimal number; only hexadecimal 
digits {0..9, A..F} are allowed to be used. 

 
4. The operation will be performed immediately after confirmation. 

Change Serial Number of a Partition 

FAT16, FAT32, HPFS and NTFS file systems include the Serial Number parameter. The partition's Serial 
Number is saved in the boot sector; its value is generated while formatting a partition. 
 
The program enables to modify the partition's Serial Number on formatted FAT16, FAT32, HPFS and NTFS 
partitions without re-formatting. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Change Partition Serial Number dialog to define appropriate settings. There are several ways to 
do it: 
 

� Select in the Main menu: Partition > Modify > Change Serial Number. 
� On the Explorer bar: click on the current serial number. 

 
3. Define the parameter value with the Change Partition Serial Number dialog. 
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4. The operation will be performed immediately after confirmation. 

Change Boot Size 

Major file systems use initial sectors of a partition to store the bootable code of an operating system. This 
area of a partition is generally known as the Bootable Area, or the Boot Sector (actually it takes up several 
sectors). 
 
The program provides the ability to modify the Bootable Area size of the FAT formatted partitions without 
destroying data. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a FAT partition on the Disk Map.  
 
2. Call the Change Boot Size dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Change Boot Size… 
� On the Explorer bar: click on the current sectors per boot value. 

 
3. Define parameters of the operation with the Change Boot Size dialog. 
 

 
 
Sectors per boot. Specify a new Boot Size value. 
 
4. The operation will be performed immediately after confirmation. 

Change Root Size 

The maximum capacity of the Root Directory is an essential parameter of old FAT12 and FAT16 file 
systems. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a FAT partition on the Disk Map.  
 
2. Call the Change Root Size dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Change Root Size… 
� On the Explorer bar: click on the current root entries value. 
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Root entries. Specify a new Root Directory Size value. 
 
4. The operation will be performed immediately after confirmation. 
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Hard Disk Management 
This chapter lists various scenarios of hard disk operations which may be accomplished by the program. 

Update MBR 
The program allows the user to overwrite the current bootable code in the MBR (Master Boot Record) by 
the standard bootstrap code.  
 
This feature can repair corrupted bootable code on a hard disk as a result of boot virus attacks or 
malfunction in the boot managing software. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a hard disk on the Disk Map.  
 
2. There are several ways to run the operation: 
 

� Select in the Main menu: Hard Disk > Update MBR. 
� Call the popup menu for the selected hard disk (right click of the mouse button) on the Disk Map, 

then select the menu item: Update MBR. 
 

 
 
3. The operation will be performed immediately after confirmation. 

Change Primary Slot 
Operating systems use the following partitions enumeration: 
 
In Linux: 
In Linux, every partition has a special symbolic name that encodes a hard disk containing a partition, and a 
partition itself. Partitions are addressed and accessed by using their symbolic names. Symbolic names are 
automatically generated by Linux in accordance with the order of hard disks in BIOS and the order of 
partition records in the Partition Table. The modification of primary partitions enumeration can lead to the 
changing of paths to some important resources. 
 
In DOS: 
The last versions of MS-DOS use a rather sophisticated algorithm for drive letters assignment. A drive letter, 
which is assigned to a partition, depends on the order of records in the Partition Table. The modification of 
primary partitions enumeration affects the drive letters assignment. In early versions of  
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The program provides the ability to change the enumeration of primary partitions. This feature allows the 
user to fix problems concerning the inappropriate order of partitions. 
 
In order to modify the enumeration of partitions the user should take the following steps: 
 
1. Select a hard disk on the Disk Map.  
 
2. Call the Change Primary Slot dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Hard Disk > Change Primary Slot. 
� Call the popup menu for the selected hard disk (right click of the mouse button) on the Disk Map, 

then select the menu item: Change Primary Slot. 
 

 
 
3. The dialog displays the actual enumeration of Primary Partitions in the Partition Table (it exhibits the 
order of appropriate records, which refer to primary partitions in the primary part of the Partition Table 
referencing records. The top part of the dialog displays the enumeration order of partitions with the 
parameters that can help to distinguish partitions: 
   - Slot 
   - Volume 
   - Partition type 
   - File system 
   - Partition size  
   - Volume label 
 
There are two buttons on the right of the list of primary partitions, which allow the user to move the selected 
partition up and down within the primary part of the Partition Table. 
 
4. The operation will be performed immediately after confirmation.  
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Copy Tasks  
This chapter lists various scenarios of copy operations which may be accomplished by the program. 

Copy Hard Disk 
The program provides the ability to clone hard disks of any file system. During the hard disk copying 
process, the program moves controlling records of used partitioning scheme, the bootstrap code and on-disk 
partitions. This operation cannot be substituted by simply copying all on-disk partitions.  
 
The operation can be accomplished with the Copy Hard Disk Wizard. The wizard is so well designed that 
the user simply needs to follow its easy instructions to make an exact copy of the disk.  

Starting  

There are several ways to start the Copy Hard Disk Wizard: 
 

� In the Main menu: select Wizards > Copy Hard Disk… 
� On the Common Tasks bar: click the Copy Hard Disk item of the Wizards menu. 
� In the Toolbar: click the Copy Hard Disk button. 
� Select a disk on the Disk map and click the Copy Hard Disk item on the page that appears in the 

Explorer bar. 
 

After following one of the above mentioned actions, the Welcome page of the wizard is displayed.  
 

 
 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 
Settings 



  
7Tools Partition Manager ™ 2009 53 User Manual 

   
 
The Copy Hard Disk Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 

� The hard disk to copy. Select a hard disk you want to copy 
� Copy parameters. The Copy Hard Disk Wizard allows the user to specify the following 

options:  
 

 

- Copy options. This section enables to switch between two options:  
HDD raw copy (allows to copy a hard disk in the sector-by-sector mode to successfully process 
unknown file systems). 
Partition raw copy (allows to copy a partition in the sector-by-sector mode to successfully process 
unknown file systems). 
Perform incremental copy (once the complete copy of a hard disk is created, it can be used as a base 
for the incremental copy. Mark the option to make the program perform the exact bit-wise 
comparison of the previous data (saved in the parental copy) with the current data (that is actually the 
hard disk itself). After that only most recent information will be processed. It considerably decreases 
the amount of data written). 
- Resize options. This section enables to switch between two options: 
Remove free blocks between partitions. If this option is activated, the program does not keep blocks 
of free space between partitions on the targeted hard disk. 
Copy data and resize partitions proportionally. If this option is activated, the program proportionally 
changes the size of partitions keeping their relative order intact. The option can be useful when 
upgrading the hard disk to a larger one. 
- Verification options. This section allows the user to define whether the Surface test and/or the 
Writing Verification test will be accomplished during the operation. 

Results 

Depending on the user’s choice the Copy Hard Disk Wizard: 
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� starts the operation 
� reconsiders it 

 
After the operation is completed the user receives a fully functional duplicate of the existing hard disk. 

Copy Partition 
The copying of partitions can be used either for cloning sample partitions or for making backup copies of 
working partitions.  
 
The user can duplicate partitions to protect oneself from downtime in case of a system malfunction. The 
partition can be copied back to the original place within a few minutes or can be used simply for copying 
separate files.  
 
The program duplicates all usable partition data including files, the exact structure of directories and file 
system metadata: location of files, security information, access quotas and so on. The program allows to 
copy partitions only to blocks of free space. 

Starting  

There are several ways to start the Copy Partition Wizard: 
 

� In the Main menu: select Wizards > Copy Partition… 
� On the Common Tasks bar: click the Copy Partition item of the Wizards menu. 
� In the Toolbar: click the Copy Partition button. 
� Select a disk on the Disk map and click the Copy Partition item on the page that appears in the 

Explorer bar. 
 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed.  
 

 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



  
7Tools Partition Manager ™ 2009 55 User Manual 

   
 
Settings  

The Copy Partition Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user sets the parameters of the operation defining: 
 

� The partition to copy. Select a partition you want to copy 
� Destination disk. Select a hard disk with free space enough for performing the copy partition 

operation 
� Copy parameters. The Copy Partition Wizard allows the user to specify the following options: 

 
- Copy the partition with resize. This option gives the possibility to copy the partition to a block of 
free space, which is smaller than the partition itself.  
- Partition size. Define the size (in Mb) of the copied partition.  
- Free space before. Define the position (in Mb) of the copied partition relative to the beginning of 
the available range of disk space.  
- Free space after. Define the amount of trailing free space (in Mb) at the end of the available range 
of disk space.  
 

 

Results 

Depending on the user’s choice the Copy Partition Wizard: 
 

� starts the operation 
� reconsiders it 

 
After the operation is completed the user receives a fully functional duplicate of the existing partition. 
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Boot Management 
Our program enables to easily manage several operating systems on one computer with the help of the Boot 
Manager Setup Wizard. Among the key features of the wizard the following should be mentioned: 

 
� Up to 16 operating systems on one PC; 
� Secure adding/removing of the BootManager startup record to/from the MBR; 
� Auto Boot option to automatically start up the previously chosen OS after a cerain time period; 
� Hiding of any primary partition except seleted at the moment. 

 
The wizard is so well designed that the user simply needs to follow its easy instructions to properly 
configure the startup process. 

Starting  

There are several ways to start the Boot Manager Setup Wizard: 
 

� In the Main menu: select Tools > Boot Manager… 
� On the Common Tasks bar: click the Boot Manager Wizard item of the Wizards menu. 

 
After following one of the above mentioned actions, the Welcome page of the wizard is displayed.  
 

 

Settings  

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



  
7Tools Partition Manager ™ 2009 57 User Manual 

   
 
The Boot Manager Setup Wizard allows the user to configure the settings and then start the operation in 
accordance with the entered parameters. Here the user should set the following parameters: 

� Hiding other primary partitions. By marking this option the program will automatically 
assign the hidden flag to all primary partitions of the hard disk(s) except the one selected to 
boot. This will help to avoid any problems when dealing with different operating systems or 
different versions of one and the same OS, as they will be unaware of each other. 

 

� Boot menu options. In this section the user can switch between the following modes: 

- Normal mode. Choose this mode to display the boot menu every time the computer starts up 
and define a timeout on the expiry of which the program will automatically select the 
previously chosen item of the menu. 

- Hidden mode. Choose this mode not to display the boot menu until pressing a hot key. For this 
mode the user should define a hot key used to enable the Boot Manager and a time period in seconds 
the startup message will be displayed. 

 

� Deactivating/Configuring the Boot Manager. These two options will only be available once the 
wizard has been completed and launched again. Select the Deactivate option to remove the Boot 
Manager from the MBR (Master Boot Record) or Configure to modify the previously set parameters 
of the startup process. 

 

 

Results  

After the Boot Manager Setup Wizard is completed the program updates the original record in the MBR to 
get control of the booting process and to be able to display the boot menu. 

 
The operation will be performed immediately after confirmation. No virtual mode is 
available. 

Creating Dual Boot Systems  
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Release of Windows Vista has given a new impetus to the problem of establishing a dual boot system. In 
this connection we decided to consider two the most frequently used situations a rank and file user may face, 
i.e. Windows Vista + Windows XP and Windows XP + Windows Vista. Please note that for reasons of 
better security and system independence these operating systems will be installed on different partitions. 
That is why we need to hide the first system partition before installation of the second OS. 

Windows Vista + Windows XP 

Suppose you have got Windows Vista coming with your brand new computer. Everything is great except 
one thing – your favourite applications simply reject to work correctly on it. Software updates are expected 
to release in the near future, but you cannot wait any more. Thus the best way out is to leave Windows Vista 
intact and install the time-proved Windows XP. 
 
Most likely you have only one hard disk with only one partition (the only partition is always system). To 
install the second operating system you need to repartition your drive first, as it requires a separate primary 
partition. If this the case, the following scenario is just what you need: 
 

 
This scenario implies that operating systems will be installed on different partitions to 
provide better security and system independence. 

 
1. In the main window of Partition Manager select your hard disk on the Disk Map to make a block 

of free space on it; 
 

 
 

2. Release some free space (not less than 10 GB to install Windows XP) from the partition. To do 
that, please call the context menu for the selected partition (right click of the mouse button) and 
launch the Move/Resize dialog; 
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3. In the opened dialog shift the edge of the partition to the left by the drag-and-drop technique. 
While doing this, free space from the partition will be released (displayed in aqua-green). You can 
also do it manually by entering the exact size of free space. Click the Yes button to continue; 
 

 
 

 
The Move/Resize dialog offers a number of additional parameters that can also be of help. 
However here we pay attention on the most relevant to fulfill our task. 

 
4. Now the user has a block of free space sufficient in size to hold a new partition; 

 

 
 

5. Create a new partition to install Windows XP. To do that, please call the context menu for a 
newly created block of free space (right click of the mouse button) and launch the Create Partition 
dialog; 
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6. Define parameters of the future partiton. By all means it has to be primary and since we are going 
to install Windows XP, the most preferable file systems are NTFS and FAT32. Click the Yes button 
to continue; 
 

 
 

 
The Create Partiton dialog offers a number of additional parameters that can also be of help. 
However here we pay attention on the most relevant to fulfill our task. 

 
7. As a resul of the operation we have got a newly created FAT32 partition just enough in size to 

comfortably work with Windows XP; 
 

 
 

8. Hide the Windows Vista partition to avoid writing any data on it during the Windows XP 
installation, as it is the best way to provide system independence. To do that, please call the context 
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menu for it (right click of the mouse button) and launch the Hide Partition dialog. Click the Yes 
button to continue; 

 

 
Hiding of the system partition will make OS non-bootable, what is quite normal. 

 

 
 

9. Apply all introduced changes. By default, Partition Manager works in the virtual mode of 
execution, so you have to confirm all operations to let the program accomplish them. To do that, just 
click the Apply button on the Virtual Operations Bar; 
 

 
 
To perform the pending operations the program will need to restart the system into a special mode of 
execution. 
 

 

After all the operations are completed you will not be able to restart the system, what is quite 
normal. Nevertheless if you do try it, the following error will occur: 

 
 
All the mentioned above operations can be accomplished with the help of the Linux/DOS 
Recovery CD. 

 
10. Install Windows XP on the newly created partition. We won’t go into details as for its 

installation, as you can find all the necessary information in documentation that comes with the 
product. However to avoid any problems, we consider it necessary to draw your attention on the 
following issues: 
- You need a bootable distributive CD of Windows XP to install it; 
- To automatically start your computer from this CD, make sure the on-board BIOS is set up to boot 
from CD first or press F12 during startup to select a bootable device; 
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- Do not forget to select the newly created partition as destination. 
 

 
 

 
Installation of Windows XP will make Windows Vista non-bootable. 

 
11. Launch the Boot Manager Setup wizard. As your Windows Vista is non-bootable any more, you 

need to install Partition Manager 2009 once again, but this time in Windows XP to activate Boot 
Manager. 

12. To launch the Boot Manager Setup wizard, please click the Boot Manager Wizard item of the 
Wizards menu; 
 

 
 

13. Set up the Boot Manager wizard. The most relevant option here is the possibility to hide other 
primary partitions except the one selected to boot and it is by all means should be activated to make 
Windows Vista and Windows XP unaware of each other. The rest of the parameters offered by 
default will do in our case, so just complete the wizard and it will automatically find the two 
operating systems and update the MBR. 
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14. Now restart the computer to make sure you have got a dual boot system. 

Windows XP + Windows Vista  

If you’ve got Windows XP and are willing to try the latest Windows Vista but not sure your favorite 
applications will flawlessly work on it, the best way out is to leave the time-proved Windows XP intact and 
install Windows Vista for studying purposes. 
 
As this very situation is very close to the previous one, please use the Windows Vista + Windows XP 
scenario but taking into consideration a number of peculiarities: 
 

1. Besides hiding of the system partition before installation of the second OS you need to make it 
inactive as well. To do that, please call the context menu for it (right click of the mouse button) and 
launch the corresponding dialog. Click the Yes button to continue; 

 

 

Reviving the System Partition 

In case you are not able or not willing to complete the mentioned above scenarios, but have already reached 
the point when all changes are apllied and everything is ready to install the second OS, simply do the 
following to make your system bootable once again: 
 

1. Insert 7Tools Linux/DOS Recovery CD (the BIOS must be enabled to boot the system from the 
CD/DVD device). 

2. Restart the computer. 
3. Select the Partition Manager 2009 item of the main menu. 
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4. In the main window of Partition Manager select your non-bootable Windows partition on the 
Disk Map; 

 

 
 

5. Unhide the partition by calling the context menu for it (right click of the mouse button) and then 
selecting Unhide; 
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6. Only for the Windows XP + Windows Vista scenario you need to make the system partition active as 
well by calling the context menu for it (right click of the mouse button) and then selecting Set 
Active; 

 

 
 

7. You will be notified after the operations are completed. 
 

 
 
8. Restart the computer. 

 
As a result your Windows becomes bootable once again. 
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Build Recovery Media  
The program provides the possibility to prepare a set of recovery tools on external media (CD, DVD or 
floppy disks). The tool set can be of assistance in case of operating system corruption, which means that the 
user is able to boot the computer even when the operating system is not able to do so. Creation of such 
recovery tools is performed with the Recovery Media Wizard.  

Starting  

To start the Recovery Media Wizard the user needs to select the Recovery Media Builder item of the Wizards 
menu on the Common Tasks bar. Then the Welcome page of the wizard is displayed. 
 

 

Settings  

The Recovery Media Wizard allows the user to configure the settings and start the operation in accordance 
with the entered parameters. In our case we set the parameters of the future recovery tool by defining: 
  

� Type of the recovery media the user is creating. The recovery tools can be placed either on a 
CD/DVD disc or on a floppy disk. 

 

 
 

� Contents of the recovery set. The recovery tools can include the standard Recovery Media image 
(included in the installation package) or software defined by the user. In the last case the user can 
record a prepared image by setting the path to the image file on the disk. 

Copyright© 1994-2008 Paragon Software Group. All rights reserved. 



  
7Tools Partition Manager ™ 2009 67 User Manual 

   
 

 

 
 

� A recording device. The appropriate external media (CD/DVD or a floppy disk) needs to be inserted 
into the selected device. 

� CD/DVD writing parameters (in case the user selects this kind of media). Writing parameters 
include writing speed (maximum or minimum) and the ability of ejecting the recorded disc after 
completing the operation. 

 

 
 
The program supports CD-R, CD-RW, DVD-R, DVD+R, DVD-RW, DVD+RW and also DVD-R, DVD+R 
double layer discs. If the inserted disc is not empty, the Wizard suggests the user erasing its contents. When 
the user confirms the operation, the program deletes the re-writable disc's contents and begins the recording 
process.  

Results  

The Recovery Media Wizard starts the operation after completing the settings mentioned above. As a result, 
the user receives recovery media, which can be used in most emergencies. 
 
When purchasing the program online, Recovery Media is available as ISO-image files. The Recovery Media 
Builder can then write these files onto physical CD/DVDs.  
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Extra Functionality 
This chapter describes the supplementary functionality available in the program. 

View Partition/Hard Disk Properties 
The program enables to obtain in-depth information on the properties of hard disks/partitions. Besides the 
general information, such as capacity, used space or file system type it provides the possibility to get info on 
a hard disk geometry, cluster size, exact partition location, etc. 
 
In order to view properties of a partition/hard disk the user should take the following steps: 
 
1. Select a partition/hard disk on the Disk Map. 
 
2. Call the popup menu for the selected partition/hard disk (right click of the mouse button) on the Disk Map 
or on the List of Partitions, then select the menu item: Properties… 
 

 
 
3. The provided information is grouped according to its properties, thus select the required tab and get the 
information you need. 

Volume Explorer 
Volume Explorer is a special tool providing the ability to browse and export contents of the local 
mounted/unmounted volumes formatted to FAT16, FAT32, NTFS, Ext2FS, Ext3FS, ReiserFS file systems. 
Besides it allows the user to access 7Tools backups as regular folders to explorer their contents or to retrieve 
certain files. 
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To launch the Volume Explorer the user should click Disk View tab in the Explorer Bar and then choose 
Volume Explorer: 
 

 
 
 
Call the popup menu for the selected file/folder (right click of the mouse button) to export it to some other 
location (local or network drive, etc.). 
 

 

Mount Partition 
The program allows the user to assign or remove drive letters of existing formatted partitions. 

Assign Drive Letter 

In order to mount a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Add Drive Letter dialog to define appropriate settings. There are several ways to do it: 
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� Select in the Main menu: Partition > Assign Drive Letter… 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Assign Drive Letter… 
 
3. Define a drive letter for the selected partition with the Add Drive Letter dialog. Initially the program 
suggests some consistent value for this parameter. So the user may just press the Yes button to confirm the 
operation. 
 

 
 
Assign the following drive letter. The pull-down list contains vacant drive letters that can be associated 
with the selected partition. Assign a drive letter to a non-mounted partition, or change the existed drive letter 
for already mounted partition. 
 
4. The operation will be performed immediately after confirmation. 

Remove Drive Letter 

In order to unmount a partition the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Remove Drive Letter dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Remove Drive Letter. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Remove Drive Letter. 
 

 
 

 

Modifying drive letter of the system partition will result in inability to boot the operating 
system. 
 
After having processed partitions with installed software, some programs may not run 
properly. 

 
3. The operation will be performed immediately after confirmation. 
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Partition Defragmentation 
Defragmentation is the process of rewriting parts of a file to contiguous sectors on a hard disk to increase the 
speed of access and retrieval. When files are updated, the computer tends to save these updates on the largest 
continuous space on the hard disk, which is often on a different sector than the other parts of the file. When 
files are thus fragmented, the computer must search the hard disk each time the file is opened to find all of 
the file's parts, which slows down response time. 
 
The program provides the necessary tool for the defragmentation of NTFS and FAT partitions. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a partition on the Disk Map.  
 
2. Call the Defragment Partition dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Defragment Partition… 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Defragment Partition… 
 
3. Define parameters of the operation with the Defragment Partition dialog. Initially the program suggests 
some consistent values for all parameters. In most cases, the user may just press the OK button to confirm 
the operation. 
 

 
 

� Directories Placement. From the pull-down list select the way how to sort directories. 
� Sort by size. Sort files according to their size. 
� Sort by time. Sort files according to the last time of update. 
� Skip auxiliary files. Mark the option to ignore contents of the PAGEFILE.SYS and HIBERFIL.SYS 

system files. These files are used temporarily in the operating system. 
 
4. The operation will be performed immediately after confirmation. 

MFT Defragmentation 
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The MFT (Master File Table) is an NTFS system file that contains in-depth information on files, including 
size, time and date stamps, permissions, and data contents. In the course of time the MFT file can also be 
fragmented, thus slowing down the speed at which data is accessed. 
 
The program offers its users a special tool to defragment the MFT file. 
 
In order to start the operation the user should take the following steps: 
 
1. Select an NTFS partition on the Disk Map.  
 
2. Call the Defragment MFT dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Defragment MFT… 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Defragment MFT… 
 

 
 
3. The operation will be performed immediately after confirmation. 

Downgrade NTFS Version 
The program provides the ability to decrease version of existed NTFS partitions. This feature can be 
particularly useful when, for instance, dealing with different versions of the Windows NT family operating 
systems. 
 
In order to start the operation the user should take the following steps: 
 
1. Select a partition on the Disk Map or on the List of Partitions. 
 
2. Call the Downgrade NTFS Version dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Modify > Downgrade NTFS Version… 
� On the Explorer bar: click on the current NTFS version. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Downgrade NTFS Version… 
 
3. Define parameters of the operation with the Downgrade NTFS Version dialog. 
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Select new NTFS version. The program enables to select the required NTFS version from the pull-down list 
of available versions. 
 
4. The operation will be performed immediately after confirmation. 

Test Surface 
The program allows performing additional surface tests on existing partitions and blocks of free space.  
 
In order to start the surface test the user should take the following steps: 
 
1. Select a partition or a block of free space on the Disk Map.  
 
2. Call the Test Surface dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Test Surface… 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Test Surface… 
 

 
 
Surface test level. Choose the level of the test procedure. 
 
3. The operation will be performed immediately after confirmation. 

Check File System Integrity 
The program can check the file system integrity on existing partitions. This function can be used for 
detecting file system errors before performing operations on a partition. 
 
Most useful operations require the targeted partition to have a valid file system to be processed. 
 
In order to start the system integrity check the user should take the following steps: 
 
1. Select a partition on the Disk Map or on the List of Partitions.  
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2. Call the Check File System Integrity dialog to define appropriate settings. There are several ways to do it: 
 

� Select in the Main menu: Partition > Check File System Integrity. 
� Call the popup menu for the selected partition (right click of the mouse button) on the Disk Map or 

on the List of Partitions, then select the menu item: Check File System Integrity. 
 
3. The operation will be performed immediately after confirmation. 

Edit/View Sectors 
With the built-in Edit/View Sectors tool the program enables to view/edit sectors on existing partitions/hard 
disks providing the possibility to directly access and modify sectors, save and restore sectors from specified 
files, navigate through the system metadata, etc. 
 
In order to start the Edit/View Sectors operation the user should take the following steps: 
 
1. Select a hard disk/partition on the Disk Map or on the List of Partitions.  
 
2. Call the Edit/View Sectors dialog to define appropriate settings. There are several ways to do it: 
 

� Click the Disk View tab and then choose Disk Editor. 
� Select in the Main menu: Partition/Hard Disk > Edit/View Sectors. 
� Call the popup menu for the selected partition/hard disk (right click of the mouse button) on the Disk 

Map or on the List of Partitions, then select the menu item: Edit/View Sectors. 
 

 
 

 
Careless use of the Edit Sectors function may result in the irreversible data corruption. 
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Send Log Files 
The program allows the user to simplify the procedure of sending support requests to the 7Tools Support 
Team. In case of having difficulties with handling the program, the user, with the help of this very function, 
can address the company support engineers and provide them with all the information they need such as disk 
layout, performed operations, etc. in order to tackle the encountered problem. Information of that kind is 
stored in Log files. 
 
In order to start the operation the user should take the following steps:  
 
1. Call the Send Log Files dialog in the Main menu: Tools > Send Log Files 
 
2. Give a detailed description on the encountered problem. 
 

 
 
By clicking the Send button the built-in mail client will generate a template request with attached 
compressed log files and then send it to the 7Tools Support Team. 

Log Files 

Log files are simple textual files that can be opened by any text editor. There are several log files 
automatically generated by the program: 
 

Stubact.log Contains in-depth information on parameters and 
performance of all operations carried out by the program 

Pwlog.txt Besides brief overview on operations it also contains 
detailed information about the state of all hard disks 

Cdb.log Contains low-level information on the CD/DVD devices 
used in the system 

BioNTlog.txt 
or 
Bio95log.txt 

It is an OS-dependent supplementary log file derived from 
Bioxx.dll. It may contain valuable information on Windows 
family operating systems 
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e-mail address are properly set. To learn more about it please consult the Settings Overview 
chapter. 

Glossary  
Active Partition is a partition from which an x86-based computer starts up. The active partition must be a 
primary partition on a basic disk. If you use Windows exclusively, the active partition can be the same as the 
system volume.  
 
In the DOS partitioning scheme, only primary partitions can be active due to limitations of the standard 
bootstrap. 
 
The term backup originates from the time when the best way to protect valuable information was to store it 
in form of archives on external media. It’s become now a general notion to mean making duplications of 
data for protection purposes. 
 
Bootable Archive is created by adding a special bootable section when backing up the data to CD/DVDs. 
Thus you will be able to restore the data from these archives without having to run the program, but by 
simply booting from these CD/DVDs. 
 
Cluster is the smallest amount of disk space that can be allocated to hold a file. All file systems used by 
Windows organize hard disks based on clusters, which consist of one or more contiguous sectors. The 
smaller the cluster size, the more efficiently a disk stores information. If no cluster size is specified during 
formatting, Windows picks defaults based on the size of the volume. These defaults are selected to reduce 
the amount of space that is lost and the amount of fragmentation on the volume. A cluster is also called an 
allocation unit. 
 
Extended Partition is a partition type you create only on a basic MBR (Master Boot Record) disk. 
Extended partition is used if you want to create more than four volumes on a disk, since it may contain 
multiple logical drives. 
 
File System Metadata. The servicing structures of a file system, which contain information about allocating 
files and directories, security information etc, are named the file system metadata. It is invisible for users and 
regular applications because its accidental modification usually makes a partition unusable. 
 
Hard Disk Geometry. Traditionally, the usable space of a hard disk is logically divided into cylinders, 
cylinders are divided into tracks (or heads), and tracks are divided into sectors. 
 
The triad of values {[Sectors-per-Track], [Tracks-per-Cylinder], [Amount-of-Cylinders]} is usually named 
the Hard Disk Geometry or C/H/S geometry. 
 
Tracks and cylinders are enumerated from "0", while sectors are enumerated from "1". These disk 
parameters play an essential role in the DOS Partitioning scheme. 
 
Modern hardware uses an advanced scheme for the linear addressing of sectors, which assumes that all on-
disk sectors are continuously enumerated from “0”. To allow backward compatibility with older standards, 
modern hard disks can additionally emulate the C/H/S geometry. 
 
Hidden Partition. The concept of a "hidden" partition was introduced in the IBM OS/2 Boot Manager. By 
default, an operating system does not mount a hidden partition, thus preventing access to its contents. 
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A method of hiding a partition consists in changing the partition ID value saved in the Partition Table. This 
is achieved by XOR-ing the partition ID with a 0x10 hexadecimal value. 
 
Master File Table (MFT) is a relational database that consists of rows of file records and columns of file 
attributes. It contains at least one entry for every file on an NTFS volume, including the MFT itself. MFT is 
similar to a FAT table in a FAT file system. 
 
MBR & 1st track of the hard disk is the 0th sector of the disk. MBR (Master Boot Record) contains 
important information about the disk layout: 
- The used partitioning scheme; 
- The starting records of the Partition Table; 
- The standard bootstrap code (or the initial code of boot managers, disk overlay software or boot viruses). 
 
Generally, the 0th sector is used for similar purposes in all existing partitioning schemes.  
 
The MBR capacity is not sufficient to contain sophisticated boot programs. That’s why the on-boot software 
is allowed to use the entire 0th track of the disk. For example, boot managing utilities such as LILO, GRUB 
and Paragon Boot Manager are located in the 0th track. 
 
Partition ID (or File system ID) is a file system identifier that is placed in the partition. It is used to quickly 
detect partitions of supported types. A number of operating systems completely rely on it to distinguish 
supported partitions. 
 
Partition ID is saved in appropriate entries of the Partition Table and takes only 1 byte of space. 
 
Partition Label (or Volume Label) is a small textual field (up to 11 characters) that is located in the 
partition's boot sector. This value is used for notification purposes only. It is detectable by any partitioning 
tool including the DOS FDISK utility. 
 
Modern operating systems save it within a file system, e.g. as a special hidden file. Thus it is able to contain 
a relatively large amount of text in multiple languages. 
 
Partitioning Scheme is a set of rules, constraints and format of the on-disk structures to keep information 
on partitions located on a hard disk. 
 
There are known several partitioning schemes. The most popular of them is the so-called DOS partitioning 
scheme. It was introduced by IBM and Microsoft to use multiple partitions in the disk subsystems on IBM 
PC compatible computers. 
 
Another popular partitioning scheme is the so-called Logical Disks Model (LDM) that originates from the 
UNIX mainframe systems. Veritas Executive accommodates a simplified version of LDM to the Windows 
2000 operating system. 
 
Windows 2000 and XP support two quite different partitioning schemes: the old DOS partitioning scheme 
and the new Dynamic Disk Management (DDM). The problem is that earlier versions of Windows do not 
support DDM. In addition, most hard disk utilities do not support it as well. 
 
Recovery Media is a CD/DVD disc, a USB flash card or even a floppy disk from which you can boot for 
maintenance or recovery purposes. 
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Root Directory is the top-level directory of a formatted logical drive to include other files and directories. 
In modern file systems (Ext2/Ext3, NTFS and even FAT32) it does not differ from other directories. This is 
not the case for old FAT12 and FAT16 file systems. 
 
Serial Number. In the DOS partitioning scheme, every hard disk and every partition has a 32-bit serial 
number represented by an 8-figure hexadecimal value. It is stored in the MBR and its value is assigned when 
the MBR sector is initialized by Microsoft standard disk managing tools, such as Windows Disk 
Administrator and the FDISK utility. 
 
In fact, a hard disk's serial number is not important for most operating systems and software. It is known that 
Windows NT, 2000 and XP store its value in the database of assigned drive letters. 
 
A partition's serial number is stored in its boot sector (in FAT16, FAT32 and NFTS file systems). Its value is 
assigned when the partition is formatted. It does not play an important role for most operating systems and 
software as well. 
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