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Introduction 

 
The software package "Oil Spill dKart Explorer" (version 4.24), based on Geographic Information 

Systems GIS technology, was developed in collaboration by the Technical University of Catalonia UPC 
(Barcelona, Spain) and MORINTECH Ltd. (Saint Petersburg, Russia) during the period of 2006 – 2007. All 
rights, authorship, responsibility and other issues regarding this software are described in the "Customized 
Development Agreement No 97-07/2006". 
 
The scientific development group was included: 
 
Spanish part – Prof. José Manuel Redondo (Project leader) and Alexei Platonov (Senior Researcher, RyC -
2003), both from the UPC, Applied Physics Department. 
 
Russian part – Andréy Dmítriev (Project leader) and Eugeny Murishkin (Programmer) both from the 
MORINTECH Ltd. 
 
 
Contact information: 
 
Technical University of Catalonia UPC 
Jordi Girona 31, E-08034 – Barcelona - Spain 
 
 
MORINTECH Ltd. 
27 block 1 Morskaya nabereznaya, 199155 – Sain Petersburg – Russia 
Phone/Fax +7 812 3254048. 
http:/www.dkart.com  
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Oil Spills dKart Explorer v. 4.24 in General 

Purpose 
The Oil Spills dKart Explorer 4.24 software provides Geographic Information System (GIS) 

functionalities for monitoring, geo-referencing, normalization and storing of satellite raster images. These are 
combined with functionalities for analysis of marine pollution objects and other phenomena on the sea surface, 
such as oil spills and spots, oil seeps, sewage water river plumes, ship wakes, etc., and dynamical 
marine/atmospheric surface features (currents, eddies and rings, internal waves, fronts, convergence zones, 
convective cells, etc.)  
 

Normalization and Geo-referencing Principles 
The Oil Spills dKart Explorer 4.24 software prepares satellite raster images for use with GIS application 

and analysis. Processing of an image involves eliminating errors caused by technical problems in processing of 
raw data and assigning physical geographical coordinate values to each pixel of the image. These are the 
routines referred to below as normalization and geo-referencing, respectively. Eventually, the new corrected 
raster image file can be saved as a GEO TIFF or special dKart Raster format for further analysis and storage.  

Purpose of Normalization and Geo-referencing 
Technical and man-made errors occur as a raw graphic file is processed, which cause distortions of the 

image. As a result, pixels of the scanned image loose references to their original physical coordinates. 
The purpose of normalization and geo-referencing is to restore the image to the original view and 

reference to physical geographical coordinates. 

Basic Assumptions 
The following assumptions underlie the normalization and geo-referencing routine in Oil Spills dKart Explorer: 

• Geodetic parameters of the source image are assumed to be known. So, whatever the distortions, 
there always are at least four points, whose coordinates are known exactly - these are the four corners 
of the image. 
In addition, corners of the coordinate grid can also act as such. 

• Although the distortion distribution within the image is unknown, it still can be approximated by a chain 
of linear segments. 
This means that the entire picture can be broken into normalization quadrangles having vertices, or 

control points, with known coordinates. Within each quadrangle, a linear distribution of distortions is assumed 
to calculate the correct coordinates of the pixels. 

By breaking the image into an increasing number of normalization quadrangles, the distortion 
distribution law, however complex, can be approximated accurately enough. 

Normalization Routine Step-by-step 
The normalization procedure using dKart Oil Spills dKart Explorer 4.24 software includes the following steps, 
Table 1. 

Table 1. Normalization routine step-by-step 
 

Action Reference 

1. Assigning raster geodetic parameters – 
projection, scale, datum, resolution, etc. 

“Setting Normalization Parameters”, p.24 

2. Drawing normalization quadrangles Beginning from “Building Control Points” p.22 and below in 
this Chapter 

3. Running image transformation routine and 
saving the results. 

“Saving Normalization Image” p.26  
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Supported Raster Formats 
dKart Oil Spills dKart Explorer 4.24 supports the following raster file formats at input: 

• .BMP - Windows Bitmap files (indexed color, up to 256 colors) 
• .PCX files, 2 colors. 
• ._PX, ._BP - dKart raster file formats 
• GIF 
• TIF/TIFF (optional TFW “world” file)  
• JPG/JPEG (optional JGW “world” file1) 
• OZI Explorer files (*.map) 
• BSB files (*.kap) 
Oil Spills dKart Explorer 4.24  outputs data in dKart Raster format (._BP) and GEO TIF/TIFF. 

Supported Projections 
Oil Spills dKart Explorer 4.24 is able to normalize raster data of the following projections: 

• Mercator. 
The main latitude must be additionally defined. 
• Gauss-Krueger and UTM. 
The main longitude or zone width / number and axis offset must be additionally defined. 
Each projection combines with any horizontal datum and scale. Oil Spills dKart Explorer supports over 200 
horizontal datum (ellipsoids). For all the projections, coordinates in degrees (geographical coordinates) are 
supported. For UTM and Gauss you can use meters as well. 

Installation of the Program 
The section below describes how to install and run Oil Spills dKart Explorer 4.24. 

System Requirements  
Oil Spills dKart Explorer 4.24 runs on a Microsoft Windows operating system. Before you install the 

software, make sure your equipment meets the following requirements: 
• Microsoft Windows NT 4.0 Service Pack 6, Microsoft Windows 2000, XP. 
• 2 GHz CPU at the minimum; 
• 256 MB of RAM at the minimum; 
• 200 MB of free HDD space; 
• 1024x768 resolution, 256 color monitor required 

Installing Oil Spills dKart Explorer 4.24 

Checking the Hardlock 

1. Make sure that your hardlock matches your installation. 
2. Insert the hardlock into a free LPT or USB port on the machine. 

Installation Routine 
To install Oil Spills dKart Explorer 4.24 software: 

1. Log on with administrative rights. 

2. Insert the Oil Spills dKart Explorer 4.24 installation CD in your CD-ROM drive. 

3. Double click “Setup.exe” installer icon in Explorer window - the Installation Wizard starts. 

4. Follow the instructions from the Wizard that will appear on the screen. 
If the Hardlock driver has not already been installed on your machine, the program will offer to install it 
now. 

5. Click the Yes button in this window to install the hardlock driver. 

6. Restart the computer. 
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7. Uninstalling Oil Spills dKart Explorer 4.24 
To remove the program from the hard disk: 

1. Run Microsoft Windows uninstall utility by selecting its shortcut from Windows “Start” menu.(Start > 
Settings > Control Panels > Add/Remove Programs) or select the shortcut Start > Programs > 
dKart Office > dKLook  > Uninstall dKLook 

2. Follow instructions on the screen. 

Starting/Exiting Oil Spills dKart Explorer 4.24 

Start-Up 
To start the Oil Spills dKart Explorer 4.24 for the first time after installation: 

1. Make sure that the hardlock is securely plugged into a free LPT or USB port. 

2. Run the program by selecting its shortcut from Windows “Start” menu.(Start > Programs > dKart 
Office  > dKLook.exe by default)  

Exiting the Program 
To exit the program, do one of the following: 
• Run the File > Exit menu command. 

• Click close window button at the upper-right corner of the program main window. 

• Press Alt-F4. 
 
 

User’s Interface 

Main Window Layout 
The main window of the program with its major features is shown in Figure 1. 
The key elements of the window are: 
The main menu (1), the “Standard” (2) and other (3- 5) toolbars. 

In the menu and on the toolbars the user gets access to the most frequently used functionalities of the 
program. 

The Charts/Images panel (6) 
Various charts are shown on this panel, which is the key function of the program. 

The Detected Object panel (7) 
On this panel, the user gets access to the functionalities for working with Detected objects. 

Auxiliary panels, both those shown in Figure 1 and not. 
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Figure 1. The main window layout 

 

Main Window Customization 

Showing/ Hiding Panels and Toolbars 
Run one of the menu commands to show/ hide a main or a panel/ toolbar in the main window of the program 
according to Table 2. 

Table 2. Showing/ Hiding panels and toolbars 
 

Command Panel/ Toolbar Reference 
Window > Bird’s eye view Shows/ Hides the Bird’s Eye View panel “Bird’s Eye” View of the Observation 

Area” on page 19 
Window > Chart Folio Shows/ Hides the Chart Folio panel, on 

which functionalities are provided for 
chart folio management 

“Adding a Chart to the Collection” on 
page 14 

 
Window > Found List 

Shows/ Hides the Found List panel 
holding the list of objects under the 
cursor 

“Info on Objects on Charts of the 
Collection (The Found List Tool)” on 
page 20 

Window > Geo-editor table Shows/ Hides the coordinate table in a 
geo-query mode 

“Using the Coordinate Table” on page 
32 and others 

Window > Measuring tool Shows/ Hides the Measurements  panel “Measurements on the Chart” on page 
18 

Window > System 
Messages 

Shows/ Hides the system message 
panel 

In this section 

Window > Detected Object Shows/ Hides the Detected/UPC 
Objects panel 

“Detected/UPC Objects Panel” on page 
27 

Window > dKart Image Shows/ Hides the dKart Image panel “Opening a Raster” on page 22 
View > Toolbars > Enable Shows/ Hides the Measurements “Measurements on the Chart and 
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measurement tool toolbar Image” on page 18 
View > Toolbars > Standard Shows/ Hides the Standard toolbar “The “Standard” Toolbar” on page 15 
View > Toolbars > Geo-
query 

Shows/ Hides the Geo-query toolbar “Geo-query Toolbar” on page 34 

View > Toolbars > Geo-
editor 

Shows/ Hides the Geo-editor toolbar “Editing Geometry of a Detected 
Object” on page 32 

View > Toolbars > Detected 
Object 

Shows/ Hides the Detected Object 
toolbar 

“Detected Object Toolbar” on page 
27  

View > dKart Image Shows/ Hides the dKart Image toolbar “dKart Image Toolbar” on page 20 

Re-docking Panels 
To dock a panel e.g. to the upper edge of the window: 

Drag it holding the title bar with the left mouse button held down onto the “◊”-wise control in the upper part of 
the window (the blue shaded stripe covers the upper part of the window) and drop, Figure 2. 

Figure 2. Re-docking a panel: case 1 

 
The panel will be stretched across the main window. 
To dock a panel e.g. to the upper edge of the Chart/Image panel: 

Drag it holding by the title bar with the left mouse button held down onto the “◊”-wise control in the middle of 
the Chart/Image panel (the blue shaded stripe covers the upper part of the panel) and drop, Figure 3. 
 

Figure 3. Docking a panel: case 2 

 
The panel is early stretched across the Chart/Image panel now. 
To convert an independent panel into a tab on another panel: 

Drag it holding by the title bar with the left mouse button held down onto the “◊”-wise control in the middle of 
the panel - the panel gets shaded in blue - and drop, Figure 4. 
 

Figure 4. Making a tab 
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Customizing Default Menus and Toolbars 
To rearrange the default toolbar button and menu items, use the drag-and-drop technique with the Customize 
window open. 
To add a command/button to a default menu/menu item/toolbar: 

1. Run the View > Toolbars > Customize menu command to open the Customize window, Figure 5. 
Figure 5. Adding a command  to a default menu 

 
 
2. Drag and drop the command/ button from the list in the Commands text box on the Commands tab in 

the Customize window onto the default menu/menu item/ toolbar as illustrated in Figure 5. 

Creating User’s Toolbars 
Figure 6. Creating user’s toolbar: step 1. 

1. On the Toolbars tab in the 
Customize window press the 
New button - the New Toolbar 
window opens, Figure 6. 

2. Enter the new toolbar name in 
this window and press the OK 
- the new toolbar appears on 
the screen. 

3. Fill in the new toolbar with 
buttons and commands using 
the drag-and-drop technique 
as shown in Figure 5. 

4. If necessary, dock the new 
toolbar properly in the main 
window of the program using 
the drag-and-drop technique. 

 
To return to the default view of a 
toolbar/menu, press the Reset All button 
on the Toolbars tab. To delete a non-
default toolbar, highlight it in the list of 
toolbars and press the Delete button. 

Drag e.g. Scale 
and drop it onto 
the main menu 
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Graphic Interface Style 
 
Graphic interface elements can be styled in one of the MS design styles. To do so, runs the View > 
Application look … menu command and select the style from the sub-menu that will then open. 

Complete Command and Tool Reference 
See the complete list of the main menu commands and tools a brief explanation of the effects of each 

and references to more detailed descriptions in the tables in this section below. 

 
File 

Table 3. The File menu 

Command Effect Reference 

Print 

Page set up 

Print set up 

Print preview 

Prints out a fragment of a chart 

 
“Information Output to a Printer” on 
p. 20 

Exit Exits the program “Starting/Exiting” on p. 7 

 
View 

Table 4. The View menu 
 

Command Effect Reference 

Overview Overviews the World map “World Map Overview” on p.16 

Zoom in Zooms in on an area on the chart 

Zoom out Zooms out on an area on the chart 

Scale Sets a user-defined chart presentation scale 

 
“Rescaling a chart” on p.16 

Toolbars > … Shows/ Hides toolbars in the main window of 
the program 

“Showing/Hiding Panels and 
Toolbar” on p.8 

Status bar Shows/ Hides the status bar In this section 

Application look > … Sets the graphic interface style “Graphic Interface Style” on p.11 

Dragging mode Sets the continuous chart dragging mode 

Panning mode Sets the “center at cursor” chart panning mode 

“The Pan/Drag Chart Modes” on 
p.17 

 
Tools 

Table 5. The Tools menu 
 

Command Effect Reference 

“Toolbar_name” > … Duplicates a button on the “toolbar name” toolbar In relevant section of the Manual 

Options Opens the program settings window “Program Settings” on p.12 

The Window Menu 
Show/ Hide panels in the main window of the program as listed in Table 2. 
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Program Toolbars 
 
Toolbars of the program will be illustrated below in relevant chapters of the Manual. 

Program Settings 
Program settings are places on the tabs in the Options window opened by running the Tools > Options menu 
command. 
See the list of setting groups, brief explanations of effects they produce and references to the related topics in 
the text on this Manual in Table 6 below. 

Table 6. Program settings 

Tab Effect Reference 

Presentation Adjusts chart presentation according to S-
52 

“Adjusting Chart Presentation” on 
p.17 

Chart Layers Shows/ Hides chart layers “Showing/Hiding Chart Layers” on 
p.17 

Format Setting the format of coordinates as shown 
on the screen 

“Format and Coordinates” on p.12 

Measurements Customizes EBRL tool colors “ERBL Tool Colors” on p.18 

Bird’s eye view Background chart file location on the HDD “Bird’s Eye” View of the 
Observation Area on p.20 

Geography conversion Coordinate conversion settings “Conversion Coordinates” on p.13 

Format of Coordinates 
Specify the format of coordinates on the screen on the Format tab in the Options window, Figure 7. 

- If you wish to display the coordinate values as ‘degrees / minutes / seconds’ select the GGG0 MM’ SS.SS” 
option. 

- If you wish to display the coordinate values as ‘degrees / minutes’ select the GGG0 MM.MMMM’ option. 
- If you wish to display the coordinate values as degrees select the GGG.GGGGGG option. 

- Switch on one of the “2”/ “3”/ “4” radio boxes to specify the number of decimals in the coordinate value. 

Figure 7. The Format table in the Options window 
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Conversion of Coordinates 
 
Coordinate values can be expressed not only in degrees but in the units of length measured in a projection as 
well. To do so, switch on the Use conversion option and specify the projection and projection parameters on 
the Geography conversion tab in the program settings window, Figure 8. 

Figure 8. The Geography Conversion tab in the program settings window 

 
 
For instance, to see coordinate values expressed in meters in a UTM projection: 
Select “Meters” option from the Coordinates list, Figure 9. 
Select “UTM” from the Projection list to see the list of the UTM projection parameters opens in the Geodetic 
parameters box below. Specify the projection parameters in this list and press OK. 
For instance, to set a center longitude value, click in the Center Lon line and enter the value, Figure 10. 
 

Figure 9. Setting coordinate value units Figure 10. UTM projection parameters 
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Configuring the Program to Work with a Nationally-Specific NtM Database 
There is no internationally valid standard for the format of NtM, i.e. each Agency produces Notices in 

its own format. So, the program needs to be given a tool to provide compatibility with a nationally specific NtM 
database, and Notices in it. This tool comes in the form of a macro supplied with the program itself.  

After the first start-up, the programs must be “told”, what NtM database it is going to work with, and 
what macros to use for this purpose. To do so: 
1. Run the Tools > Options menu command to open the program settings window on the NtM options tab, 

Figure 11. 
2. Select the NtM producing agency from the list. 

Figure 11. The NtM Options table in the program settings window 

 
 
The program treats this as an instruction about what national-specific macros to use for work with the 
database. 

Work with Charts and Images 
Chart Collection Management 

The dKart Image user can compile the Collection of charts and images which are easy to access 
directly from the main window of the program. Functionalities are provided on the Collection Manager panel for 
chart collection management and display control. 

A chart/image once added to the Collection stays in it during all later program sessions until the user 
explicitly excludes it. 
 
Chart/Image Formats 
The list of data formats available for browsing using ABF ODU includes: 
-Encrypted/ Unencrypted dKart Charts (*.dcf) 
-S-57 edition 3 (*.000) 
-dKart Raster (*._bp) 
-GeoTIFF (*.tif, *.tiff) 
-Chart Catalogues (*.030, *.031) 
-Multi-charts (*.mlc) 
-OZI Explorer (*.map) 

Adding a Chart to the Collection 
The program can display electronic charts and raster images from the Collection. The Collection 

management functionalities are provided on the Chart Folio panel. To open the window, run the Window  > 
Chart Folio menu command,  Figure 12. 
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Figure 12. 

 
To add a chart/image to the Collection: 
1. Press the Add Charts button in this window, Figure 12 - the standard Open window opens. 
2. In this window, specify the full chart file name and press the Open button. 
See the new chart/image name and parameters have appeared in the table in the lower part of the window.  

Select the name of a chart/image in this table with a left click - the chart/image frame gets highlighted 
on the background of the World Map in this window. To take a closer look at the picture, manipulate the control 
buttons in this window (Priority, Transparent, Top Level, etc.), which produce the same effects as those of the 
same appearance on the standard toolbar. 
To exclude a chart/image from the Collection, select its name in this table with a left click and press the Del 
Charts button. 
 
Chart/Image Display Control 
 
Use buttons on the “Standard” toolbar and menu commands to control chart display according to Table 7. 

The “Standard” Toolbar 
Table 7. The Standard toolbar 

Button Effect Command 

 Overviews the World Map Tools > Standard > Overview 

 Increase the presentation scale twice (zoom in) Tools > Standard > Zoom In 

 Decrease the presentation scale twice (zoom out). Tools > Standard > Zoom Out 

 Sets the “center-click” chart panning mode Tools > Standard > Panning mode 

 Sets the continuous chart dragging mode Tools > Standard > Dragging mode 

 Returns to the previous chart position and presentation scale Tools > Standard > Position back 

 
Undoes returns to the previous chart position and presentation 
scale Tools > Standard > Position forward 

  
and like 

Pans the chart to the left/ right/ etc. Tools > Standard > Move view point 

left/ right/ etc. 

 Opens the print out settings window  

 Opens the Help window Help > Help topics 
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Opening a Chart/Image in the Collection 
Use dynamic menu commands of Figure 12 to open and view a chart/image in the Collection: 
1. Overview - to display the chart/image in an overview mode. 
2. Original scale - to display the chart/image at the compilation scale. 
3. Overview bounds 

World Map Overview 

To overview the World map, press the  toolbar button or run the View > Overview menu command. 

Rescaling a chart/image 

- To scale a chart in/out twice, click the  or  toolbar buttons, or run the View > Zoom in/out menu 
command. 

- To set a user-defined chart presentation scale, run the View > Scale menu command to enter the scale value 
in the window of the view of Figure 13 that will then open. 

Figure 13. Entering a user-defined scale value 

 

Select the value from the drop list or enter on the keyboard. 

-To zoom in on a region of a chart/image, drag the cursor across it with left mouse button held down. 
-To continuously change the presentation scale, rotate the mouse wheel. 

-To change presentation scale one step back/ forward, press the  or  toolbar button, respectively. 
-To display a chart in an Overview mode, run the Overview command in the dynamic menu of Figure 12. 
If the presentation scale needed to display the chart in an Overview mode is small enough, only the chart 
frame will be shown and not separate objects on the chart/image. 
-To display a chart/image at the compilation scale, run the Original scale command in the dynamic menu of 
Figure 12. 

The Pan/ Drag Chart/Image Modes 

With the  toolbar button pressed click on a point on the chart to center the point of the click on the Chart 
panel. 

With the  toolbar button pressed drag the cursor over the chart/image with left mouse button pressed to see 
the chart/image continuously following the cursor. 

Adjusting Chart Presentation 
To adjust presentation of a chart according to S-52 requirements, run the Tools > Options menu 

command to open the Options window and set necessary settings on the Presentation tab in this window, 
Figure 14. 
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Figure 14. The Presentation tab in the Options window 
 

 

Showing/ Hiding Chart Layers 
Features on a chart can be grouped into “layers”, e.g. bathymetric data, natural/ cultural features, etc. Switch 
on/ off layers to show/ hide on a chart on the Chart Layers tab in the program settings window, Figure 15. 

 
Figure 15. The Chart Layers table in the program settings window 

 

 



 18 

Services for Browsing Charts 
Measurements on the Chart and Image 
Running the ERBL Tool 

Run the Window > Measuring tool menu command to show the Measurements panel in the main 

window of the program, Figure 16, or press the  button on the “Enable measuring tool” toolbar, or run the 
Tools > Enable measuring tool > Measuring tool menu command. 

Figure 16. The Measurements panel 

 
 
To show the “Enable measuring tool” toolbar, run the View > Toolbars > Enable measuring tool menu 
command. 

ERBL Tool Colors 
The program offers the Electronic Ruler and Bearing Line (ERBL) tool for measurements on the 

chart/image.  The operator uses it to build auxiliary points and lines on the chart/image to measure lengths, 
distances angles, etc. as described in “Measurements on the Chart and Image” on page 24. Colors and widths 
of these points (markers) and lines can be customized by the user on the Measurements tab in the Options 
window, Figure 17. 

Figure 17. The Measurements tab in the program settings window 

 
 
Specify marker and ruler line colors and widths in the respective fields on this tab. 

Measuring Distance and Bearing 
1. Switch on the B, D radio box. 
2. Click on the first point with left mouse button. 
3. The marker stays on the chart. 
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Marker color can be customized as described in “ERBL Tool Colors”. 
4. Move the cursor towards the other point.  

Observe that the cursor is permanently connected to the maker with the bearing line during the motion 
and a circle is drawn automatically representing all points of the chart equally distant from the marker, 

5. Place the cursor exactly over the other point and read the distance from the marker in the D field and the 
bearing in the B field. 

Measuring Route Length 

1. Switch on the Sum radio box. 
2. Place the cursor on the beginning of the route and click left mouse button. 

The marker stays at the position of the click. 
3. Move cursor to the next waypoint of the route and click again. 
Another marker stays there and a leg is built connecting these points. 

Leg color can be customized as described in “ERBL Tool Colors”. 

4. Continue in the same way at all other waypoints. 
5. Once the opposite end of the line / route’s is reached, read its overall length in the Sum field. 
Press the Delete last button to break off the “rubber string” and bind the cursor to the last but one marker. 
Further pressing this button will erase the markers one-by-one binding the cursor to the previous marker. 
Press the Delete All button to erase the entire chain of markers at once. 

“Bird’s Eye” View of the Observation Area 
On the “Bird’s Eye View” panel, see the area currently shown on the Chart panel (the observation area) 

located relatively a smaller scale chart, Figure 18. 

Figure 18. The “Bird’s Eye” view of the observation area 

 
 
Specify this smaller scale chart on the “Bird’s Eye” View tab in the program settings window, Figure 19. 

Figure 19. The “Bird’s Eye” View table in the program settings window 

 
To do so, press “…” specify the full background chart file name in a standard Open window that will then open. 
The observation area is marked with an arrow if the current presentation scale is big enough, or with a frame if 
it is small enough. 
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 “Reciprocal” chart display control functionalities are provided on this panel: 
- Drag the cursor across an area on the “Bird’s Eye” View panel to display this are on the Chart panel. 
- Click on “Bird’s Eye” View panel to shift the observation area in a “center-click” manner. 

 
Info on Objects on Charts of the Collection (The Found List Tool) 

To open the Found List panel, run the Window > Found List menu command. Right click on a point on 
a chart - a list appears of objects on the charts in the Collection located in close vicinity to the point of the click, 
and their attributes on the Found List panel, Figure 20. 

Figure 20. Found List panel 

 
 
Highlighting of an object in the list makes the object itself highlighted on the chart. 

Information Output to a Printer 
There is a program function to print out the main window of the program in its current view. To do so: 

Run the File > Page set-up menu command and set the required settings as to page orientation, margin width, 
etc. in a Page Set up window that will then open. 

Run the File > Print menu command - the standard Print window opens. 
Set the required print settings in this window, and print. 

 
Geo-referencing of a Raster Image 
 
dKart Image Toolbar 

 
Run the View > Toolbars > dKart Image menu command to show the toolbar of the same name in the 

main window of the program, Table 8. 

Table 8. The dKart Image toolbar 

Button Function Reference 

 
Builds a control point “Building the Control Points” p.22 

 
Builds a control line “Building the Control Lines” p.23 

 
Deletes a control line “Deleting the Control Lines” p.23 

 
Enters a grid editing mode “Moving a Control Point to a New Pixel with 

New Geographic Coordinates” p.24 

 
Builds normalization grid “Showing / Hiding the Normalization Grid” p.24 
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Deletes normalization grid “Deleting the Normalization Grid” p.24 

 
Opens normalization 
parameter window 

“Setting Normalization Parameters” p.25 

 
Runs normalization routine 

 
Breaks normalization routine 

“Running Normalization” p.27 

 
Saves normalization results 

 
Undoes normalization results 

“Saving Normalized Image” p.27 

 
Closes the raster “Closing a Raster Image” p.23 

 
Opening a Raster Image 

 
To open a raster image for further referencing:  

1.Press Browse on the dKImage panel - the standard Open window opens. 

Figure 21. The dKart Image panel 

 
2. In this window, specify the full raster file name and press Open. 
The raster gets shown on the Chart panel in the view of e.g. Figure 22. 

Figure 22. 

 
Drag the raster image in a continuous manner “holding” it by the green cross at the centre. 
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Viewing Coordinates of the Chart Corners 

Press the  button on the dKart Image toolbar - the program builds the simplest normalization grid, 
that is the raster frame, and shows coordinates of the loaded raster image corners in the coordinate table of 
the Geo-editor panel, Figure 23. 

Figure 23. 

 
To show the Geo-editor panel in the main window of the program run the Window > Geo-editor 
menu command. 

Closing a Raster Image 

To close a raster image press the  button  on the dKart Image toolbar. 

Building the Control Points 
To build a control point: 

1. Press the  button on the dKart Image toolbar. 
2. Left click at the location of the control point - the New Reference Point window opens, Figure 24 and the 

raster displays in a transparent view. 
Figure 24. The New Reference Point window 

 
3. Enter the exact coordinates of the point in the window and press OK - the program immediately rebuilds the 
current normalization grid by adding two extra lines to it lying across the new point as shown in Figure 25. 

Figure 25. 

 

The new 
grid line 1 

The new 
grid line 2 

The new 
control point 
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At the same time the  button displays pressed on the dKart Image toolbar. 
 
4. Release this button and repeat the routine to build the net control point, etc. 

Showing/ Hiding the Normalization Grid 

To show/ hide the normalization grid press/ release the  button on the dKart Image toolbar. 

Deleting the Normalization Grid 

To delete the existing normalization grid and start building a new one from the very beginning, press the  
button on the dKart Image toolbar. 

Building the Control Line 
 
There is a service function of the program to keep a pre-defined line (the control line, in the terms of 

this Manual) on the raster highlighted while you are building control points. To build a control line: 

1. Press the  button on the dKart Image toolbar. 

2. Move the cursor along the line on the chart clicking at its vertices. 

Note that coordinates of the vertices appear in the in the coordinate table on the Geo-editor panel. 

3. Having reached the end of the line, right click. 

Deleting the Control Line  

To delete the control line, press the  button on the dKart Image toolbar. 

Editing the Normalization Grid 

Moving a Control Point at a Pre-defined Pixel to New Geographic Coordinates 
 
By using this program function you can move a control point at a fixed predefined pixel (e.g. (X100; Y100) 

to a new geographic location (e.g. from 30oN; 60oW to 31oN; 61oW). 

1. With the  button pressed on the dKart Image toolbar, point the cursor onto a control point and left click. 
2. Move the cursor to a new location and click again to see the grid rebuilt as Figure 26 schematically 

illustrates. 

Figure 26. 

 
 
The program also rebuilds the entire raster accordingly. 

Left click at 
a control 
point 

Move the 
cursor to a 
new location 
and click 
again 
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Moving a Control Point to a New Pixel with New Geographic Coordinates 
By using this program function you move a control point to a new pixel e.g. from  (x100; y100) to (x200; y200) with 
new geographic coordinates (e.g. from 30oN 60oW to 31oN 61oW). 

1. Release the  button pressed on the dKart Image toolbar. 

2. Press the  button on the same toolbar. 
3. Point the cursor onto a control point and left click. 
4. Move the cursor to a new location and lick again to see the grid rebuilt as Figure 27 schematically illustrates. 

Figure 27. 
 

 
 
The program also rebuilds the entire raster accordingly. 

Setting Normalization Parameters 
 
If the program fails to find the *.prj and *.**w files accompanying a raster in the same directory, the user 

should manually specify geodetic parameters of the original raster and output image. This can be done either 
by reading these from the *.prj, if it exists in the other directory or entering from the keyboard. 

1. Press the  button on the dKart Image toolbar - the Transformation parameters window appears, Figure 28. 

Figure 28. The Transformation Parameters window 

 

2. To read the parameters from a *.prj file, press the Load from PRJ-file button and navigate to this file in a 
standard Open window that will then open. 

Move the 
cursor to a 
new location 
and click 
again 

Left click at a 
control point 
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Otherwise, enter these parameters manually from the keyboard as described below. 

3. Specify the output image projection and scale in the fields of the same names in this window. 

If the Gauss or UTM projection is selected, the Degrees/Meters switch appears in the window to the 

right of the Projection field of the view , see step 4 below. 

3.1  Press the switch to select degrees or meters as coordinate units on the output chart of the Gauss or UTN 
projection. 

4. In the Horizontal Datum group of options: 

4.1 Select the source chart datum from the list in the Source field, or select “unknown” in this list, if 
the datum is unknown. 

4.2 Select the output image datum in the Destination field 

If you plan to produce an electronic chart, in the future on the basis of the output image, select 
one of these: 

? “Unknown”, if the input chart datum is unknown. 

? WGS84, in all other cases. 

5. In the Projection Parameters group of options, specify parameters of the selected projection of the output 
image, see step 2 above. 

The list of parameters to specify differs for different projections, Table 9. 

Table 9. Projection parameters 

 
6. Enter the output image pixel size into the Resolution field expressed in millimeters or dots per inch with the 

 switch pressed accordingly. 
7. If the output or input image datum is unknown, enter the output image datum shift with respect to that of the 

input image into the Shifting Parameters Lat/Lon fields expressed in minutes or seconds with the 

. 
If both data are known, press the Calculate button to make the program calculate the shifts.  
The calculation is possible with at least one control point built as described in “Building Control Points”. The 
calculated shift values will be reported in the window: 

Figure 29. Calculated shifts 

 
 

7.1 Press the Set Shifting Values button in this window to set the proposed values or press the Close 
button to reject them and enter other values manually. 
These values will be added to the coordinates entered by the user when building control points, etc., 
see   “Building Control Points” option. For instance, the coordinates of a point of (0, 0) will be 
transformed to (-4.931069”, 3.992925”) in the example of Figure 29. 

None Mercator, Polyconic, Stereo Lambert Gauss, UTM 

No Main Lat Main Lat 
Main Lat 1 
Main Lat 2 

Main Lat 
Zone Width 
Y offset, if coordinates are measured in meters, see step 3.1  
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Running Normalization 

To run the normalization routine, press the  button on the dKart Image toolbar. To break the routine, press . 

Saving Normalized Image 
To save a normalized image: 

1. Press the  button on the dKart Image toolbar - the standard Save as window opens.  
2. In this window specify the output file type and full name and press Save. 

To cancel normalization results and start a new round of normalization, press  . 

 
Working with Detected Objects 
 

The user can build new detected objects on raster images using the Oil Spills dKart Explorer 4.24 
software. Also the user can view and edit existing ones. Relevant functionalities are provided on the Detected 
Object panel and toolbar. 

Detected Object Panel 
 
Run the Window > Detected Object menu command to open the panel of the same name in the main 

window of the program, Figure 30. 

Figure 30. The Detected Object panel 

 

Detected Object Toolbar 
 
Run the View > Toolbars > UPC Object menu command to show the toolbar of the same name in the main 
window of the program. See brief descriptions and relevant references for each tool in Table10. 

Table 10 The Detected Object toolbar 

Button Effect Reference 

 
Builds a new oil spot “Building an Oil Spot” p.29 

 
Builds a new eddy “Building an Eddy”p.30 

 
Builds a new oil spill or ship wake  “Building an Oil Spill (Ship Wake)” p.30 

 

Builds a new extra object “Building an Extra Object”  p.31 

Image name 

Year of 
acquisition of 
the image 

Type of the Detected Object 
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Open the Detected Object Information 
window 

“Viewing Raster Frames, Raster and Detected 
Objects in the Database” p.28 

 

Shows/Hides the Oil Spills dKart 
Explorer menu 

“Oil Spills dKart Explorer Menu” p.27 

 

Oil Spills dKart Explorer General Menu 

Press the  button on the Oil Spills dKart Explorer toolbar to open the window of Figure 31. 

Figure 31. The Oil Spills dart Explorer Principal Menu 

 
 

Then follow a link in this window: 

Open raster chart - to open raster charts and images as described in “Adding a Raster to the Database”. 

Query database - to run query-aided search for Detected Objects in the database as described in “Query-
aided Search for Detected Objects and Rasters”. 

Exit program - to exit the program. 

Database of Detected Objects and Rasters 
The program records all detected objects ever built by the user on all rasters, and rasters themselves 

in a database. The entire content of the database is shown on the Detected Objects panel structured as shown 
in Figure 30 at each program start. 

The structure units are: 
All 

\ Raster observation year (e.g. “2007” in Figure 30) 
\ Raster name (e.g. “011097_423_2781_1” in the same figure). 

\ Detected object type (e.g. “Spills”). 
\ Specific objects of the type. 

4.24 
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Adding a Raster to the Database 
To add a new raster image to the database, run the Open raster chart dynamic menu command as 

shown in Figure 30 and specify the full raster image file name in a standard Open window that will then open. 
The raster (image or map) is displayed on the Chart panel and at the same time the raster name 

appears in the database tree of under an Unsorted root node, Figure 32.  

Figure 32 

 
 
Then enter the raster (image) observation date to include it in a collection of raster images of a year. 

Entering Raster Image Observation Year 
To enter the observation year of a newly added raster, run the Image Properties dynamic menu command and 
enter the observation year/ date/ time and textual comments into the Image Properties window that will then 
open. After that the raster name will move under the year root node in the database tree. 

Viewing the Properties of Raster in the Database 
Use the same Image Properties dynamic menu command to view properties of a raster in the database. 

Building the Frame Around a Raster 
 
To build the frame of a newly added raster image: 
Run the Edit object command in the dynamic menu of Figure 32. 
Run the Image area command in the same dynamic menu. 

Viewing Raster Frames, Rasters and Detected Objects in the Database 
 

* To view all frames of all rasters in the database, set flag to the “Queried Objects” check box in the 
database tree, Figure 30; to view frames of all rasters observed in e.g. 2007, set flag to the “2007” 
check box, etc. 

The frame of a raster can only be shown if it has ever been built as described in “Building the Frame 
Around a Raster”. 

* To view the raster itself, run the Load chart dynamic menu command as shown in Figure 30. 
* To view all objects on a raster run the Edit objects command in the dynamic menu of Figure 30. 

 
To hide a displayed objects on a remove the take off flag in the respective check box. 

To view properties of a detected object on this raster in the window of Figure 34, just select it in the database 

tree and run the Object information as shown in Figure 33 or press the  button on the Detected Object 
toolbar. 
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Figure 33. 

 

Export of Information about Detected Objects to a Text File 
Information about Detected objects on a raster (their sizes, other attribute values, etc.) can be exported 

to a text file. To do so, run the Export command in the dynamic menu of Figure 32 and specify the output text 
file name in a standard Save as window that will then open. 

Building an Oil Spot 
 
Run the Load chart dynamic menu command as shown in Figure 30 to load the raster image on which a new 

oil spot is going to be built. 
Run the Edit objects command in the same dynamic menu. 

Press the  button on the Detected Object toolbar. 

Move the cursor along the border of the spot clicking at its vertices. 

Having built the last vertex, right click - the oil will then be built and a window opens, holding new spot 
information, Figure 34a. 

Figure 34a. Detected Oil Spot  information window 

 
Enter relevant information in this window and close it. 
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Building an Eddy 

Figure 34b. Detected Eddy  information window 

 
Run the Load chart dynamic menu command as shown in Figure 30 to load the raster image on which a new 

oil whirl is going to be built. 

Run the Edit objects command in the same dynamic menu. 

Press the  button on the Detected Object toolbar. 

Move the cursor along the border of the eddy clicking at its vertices. 

Having built the last vertex, right click - the eddy will then be built and a window opens, contouring the new 
eddy information, (Figure 34b), i.e. cyclonic rotation +, anticyclonic -. The azimuth (of the bigger axis) 
may be +/- 900 respecting to North direction.  

Enter any relevant information in this window and close it. 

Building an Oil Spill or Ship Wake 

Run the Load chart dynamic menu command as shown in Figure 30 to load the raster image on which a new 
oil spill or a ship trace is going to be built. 

Run the Edit objects command in the same dynamic menu. 

Press the  button on the Detected Objects toolbar. 

Move the cursor along the spill or ship wake from the end to a more recent part clicking on its bends. 

Having reached the end of the trace, right click. - The trace will then be drawn on the chart, and a window like 

Figure 34c opens. Figure 34c. Detected Oil spill and Ship wake  information window 
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Enter any relevant information in this window and close it. 

Building an Extra Object 
Run the Load chart dynamic menu command as shown in Figure 30 to load the raster image on which 

a new objects detected on the sea surface (internal waves, fronts, oil seeps, pollution plume from river, 
convection cells and other extra objects) are going to be built. 

Run the Edit objects command in the same dynamic menu. 

Press the  button on the Detected Object toolbar. 
Move the cursor along the border of the detected extra object clicking at its vertices. 
Having built the last vertex, right click - the extra object will then be built and a window opens, holding new 

extra object information, Figure 34d. 
Enter relevant information in this window and close it. 

Figure 34d. Detected Extra Object  information window 

 
Editing a Detected Object 
Editing Attributes of a Detected Object 
 
To edit attributes of a Detected Object: 
1. Run the Load chart dynamic menu command as shown in Figure 30 to load the raster image on which a 

Detected object is going to be edited. 
2. Run the Edit objects command in the same dynamic menu. 
3. Select the object in the database tree with a left click. 

4. Run the Object information as shown in Figure 33 or press the  button on the Detected Object toolbar - 
the window of Figure 34 (a,b,c,d)  opens holding current object attribute values. 
5. Enter new attribute values in this window and close it. 

Editing Geometry of a Detected Object 
 
For quick access to geometry editing functions use buttons on the Geo-editor toolbar according to Table 11. To 
display the toolbar in the main window of the program run the View > Toolbars > Geo-editor menu command. 

Table 11. The Geo-editor toolbar 

Button Function Reference 

 
Shows/ Hides the coordinate table on the 
Geo-editor panel 

“Using the Coordinate Table” 

 
Selects an object to edit In this section below 

 
Deletes an object “Deletion of a Detected Object” p.32 
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To edit geometry of a Detected Object: 
 
1. Load the raster image, on which it is present as described in “Viewing Raster Frames, Rasters and Detected 

Objects in the Database”. 

2. Select the object in the database tree with a left click, or press the  button on the Geo-editor toolbar and 
click the object on the Chart panel - the object gets surrounded with a frame on the chart. 

3. Continue as described in one of the sections below depending on the type of editing you intend on doing. 

Moving a Detected Object as a Whole 
4. Click anywhere within the frame. 
5. Move the cursor to a new location and click again - the object moves to the new location too. 

Moving a Vertex 
4. Point the cursor to the vertex to be moved and click. 
5. Move the cursor to a new location of the vertex, Figure 35, and click again - the vertex moves to the new 

location too. 
 

Figure 35. Moving a vertex Figure 36. Adding a vertex onto an 
edge 

Figure 37. Changing the radius of an 
eddy 

   

Adding a Vertex onto an Edge 
4. Point the cursor to the edge, on which an extra vertex is going to be added, and left click. 
5. Move the cursor to the location of the extra vertex (Figure 36) and click again - the extra vertex will then be 

built, and the edge changes its shape accordingly. 

Changing the Radius of a Whirl 
4. Left click at the center of the eddy.  
5. Move the cursor as shown schematically, thus changing its radius (Figure 37), and click again. 

Using the Coordinate Table 

You can also edit coordinates in numeric form. To do so, press the  button on the Geo-editor toolbar to 
open the coordinate table, and enter new coordinate values directly into this table. 

Exit from Editing Mode and Saving Changes 

To quit the object editing mode and save the changes made, right click. 

Deletion of a Detected Object (UPC Object) 
To delete a Detected Object: 
1. Repeat steps 1 - 2 in “Editing Geometry of a Detected Object”. 
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2. Press the  button on the Geo-editor toolbar. 
Another technique is to run the Delete command in the dynamic menu of Figure 38.  

Figure 38. Deletion of a Detected object 

 

Query-aided Search for Detected Objects and Rasters 
Detected Objects can be found in the Detected Object database matching pre-defined conditions by 

means of a query. 

Query Conditions Upon Coordinates 
The program provides functionalities to build a geometry figure on the chart and then to find Detected 

Objects in the database overlapping it. This figure may be a point (or a set of isolated points), a rectangle, a 
broken line, etc. Build a figure using the buttons on the Geo-query toolbar according to Table 12. 

Geo-query Toolbar 

Run the View > Toolbars > Geo-query to display the toolbar of the same name in the main window of the 
program, Table 12. 

Table 12. The Geo-editor toolbar 

Button Function Reference 

 Builds a point or a set of isolated points “Building a Point (Point Set)” p.33 

 Builds an Area “Building an Area”p.34 

 Builds a circle “Building a Circle” p.34 

 Builds a sector “Building a Sector” p.34 

 Builds a broken line “Building a Broken line” p.34 

 Saving changes 

 Undoing changes 
 

Building a Point (Point Set) 

1. Press the  button on the Geo-editor toolbar.  

2. Click on the locations of the points on the chart panel. 

3. Press the  button on the Geo-editor toolbar to save the changes you have made. Press   to undo the 
changes. 
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Building an Area 

1. Press the  button on the Geo-editor toolbar. 

2. Continue as described in “Building an Oil Spot”. 

3. Press the  button on the Geo-editor toolbar to save the changes you have made. Press  to undo the 
changes. 

Building a Circle 

1. Press the  button on the Geo-editor toolbar. 

2. Continue as described in “Building a Circle”. 

3. Press the  button on the Geo-editor toolbar to save the changes you have made. Press  to undo the 
changes. 

Building a Broken Line 

1. Press the  button on the Geo-editor toolbar. 

2. Continue as described in “Building an Oil/Ship Trace”. 

3. Press the  button on the Geo-editor toolbar to save the changes you have made. Press  to undo the 
changes. 

Building a Sector 

1. Press the  button on the Geo-editor toolbar. 
2. Click on the center of the sector 
3. Move the cursor onto the arc of the sector and click again. Figure 38, left. 
4. Move the cursor along the sector arc thus “cutting” the required sector angle, Figure 38, center. 
5. Having reached the end of the arc, click again, Figure 38, right. 

 

Figure 39. Building a sector 
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Query Conditions Upon Attributes 
1. Into the Detected Objects  window  run the Query dynamic menu command (right button) as shown in 
Figure 40a,  

Figure 40a. 

 
the Query object  window opens, Figure 40b 

2. Set the required attribute values in this window. 
Figure 40b. 

 

Running a Query 
 
1. If you are planning a coordinate-based query, build a geometry figure as described in “Query Conditions 
Upon Coordinates”. 
2. Formulate conditions upon attributes as described in “Query Conditions Upon Attributes”. 
3. If you are planning a coordinate-based query, do not forget to set the Use geometry option to “Yes” in this 
window. 4. Press OK in the Query Objects Information window. 

Studying Query Results 
Detected Objects returned by a query are shown on the Detected Object panel in the same view as the 

entire data base, see “Data base of Detected Objects and Rasters”. 
To return to a complete display of the database contents, run the Cancel query command in the 

dynamic menu of the Figure 40a. 
 

Export of Information about all or a part of the Queried Objects to a General Text File 
Information about all or a part of the Queried Objects on a raster images (type of the detected objects, 

their sizes, other attribute values, etc.) can be exported to a general text file. To do so, run the Export 
command in the dynamic menu of Figure 40a and specify the output text file name in a standard Save as 
window that will then open (example of the Figure 41). 
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Figure 41. 

 

Viewing Maps, Images and Detected Objects on the Web 
 

Contents of the image and detected object database can be shown on the Web through a web 
representative, called dKart Explorer Web Server. 

Installation of dKart Explorer Web Server 
 

1. Make sure IIS Web Server software is installed on the server. 

2. Unpack the “DWS” archived file into the c:\inetpub\wwwroot directory. 

3. Set the “read-write” access rights for the IUSR_IIS*** user to the c:\inetpub\wwwroot\dws directory. 

4. Set the “read-write” access rights for the IUSR_IIS*** user to the program folder. 

5. Refresh virtual catalogues using the IIS console to make sure the “DWS” catalogue has appeared. 

Viewing an Image and Objects on It 
 

1. See the contents of the image and object database on the front page of dKart Explore site structured as 
shown in the Figure 42. 

Figure 42 

 
Image frames are always shown on the world map in the same window,Figure 43 

2. Left click an image in the tree of to open the image information table on the Object Information panel as 
shown in Figure 43. 

3. In that table press Load to load the image itself, Figure 43, with all objects on it. 

4. Press: 

Unload – to unload the image. Overview – to overview it. 
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Figure 43 

 

 
Viewing Object Properties 
 
1.Click an object in the tree of Figure 42 as shown in Figure 44 to open the Detected Object properties table.  
2.Press Highlight to highlight the object in red and surround it with a green frame on the chart, Figure 44.  

 
Figure 44 

 

Left click here … 

… to open the 
image 
information table 
here. 

Press here… 

… to view the 
image itself on 
the background 
of the World Map 

Left click here … 

… to open the 
object 
information table 

Press here … 

… to highlight 
the object on the 
chart. 


