
                  
 

 
 

 
 
 
 
 
 
 

 
 
 
 

 
Dimension Raman System 

 
User Manual 

 
 

 
 
 
 
 

DRS-RS1.4-UM-2010-10-26 

 
 
 



                  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The information in this manual is furnished for your use only and is subject to change without notice. 
Lambda Solutions, Inc. (“LSI”) assumes no responsibility or liability for any errors or inaccuracies that may 
appear in this manual. This documentation is the property of LSI and its licensors, and it contains 
proprietary information of LSI. 
 
Dimension-P1, Dimension-P2, Dimension-M1, Dimension-M2, Vector Raman Probe, RamanSoft, 
SpectrumSearch, SpectrumPredict, and the LSI logo are registered trademarks or trademarks of Lambda 
Solutions, Inc. in the United States. All other brand and product names are trademarks, service marks, 
registered trademarks, or registered service marks of their respective owners. 
 
Copyright © 2004, 2005 Lambda Solutions, Inc. All rights reserved. 
 
Copying, modifying, or distributing this documentation in violation of a license agreement, confidentiality 
agreement, United States Copyright Law, or the copyright of any applicable foreign jurisdiction is 
expressly prohibited. 
 

 
 
 



i 

Contents 
 
 

1 Introduction ................................................................................. 1 
 

Overview of Features .......................................................................................................................1 
How This Document Is Organized ...................................................................................................2 

Manual Organization ................................................................................................................ 2 
Safety Related Symbols Used in this Manual .......................................................................... 3 

Optional Documents.........................................................................................................................3 
System Safety ..................................................................................................................................3 

Grounding and Safety .............................................................................................................. 3 
Precautions .............................................................................................................................. 4 
Laser Safety ............................................................................................................................. 4 

System Maintenance........................................................................................................................5 
Cleaning of the Optical Surfaces.............................................................................................. 6 

 
2 System Setup............................................................................... 7 

 

System Components........................................................................................................................7 
Standard Components ............................................................................................................. 8 
Optional Components............................................................................................................... 9 

System Requirements......................................................................................................................9 
Environmental Requirements................................................................................................... 9 
Ventilation................................................................................................................................. 9 
Power ..................................................................................................................................... 10 
Computer and USB 2.0 Protocol............................................................................................ 10 
Setting up a USB 2.0 Interface............................................................................................... 10 

Setting up the Dimension-P1 Raman System ...............................................................................11 
Setting up the Dimension-P2 Raman System ...............................................................................13 
Setting up the Dimension-M Raman Microscope System .............................................................14 
System Start-up Procedure............................................................................................................16 
Using the Dimension-P Raman System.........................................................................................16 
Using the Dimension-M Raman Microscope System ....................................................................17 
Switching between Macro-sampling and Micro-sampling..............................................................18 
System Shut-down Procedure .......................................................................................................18 
Trouble Shooting............................................................................................................................19 

How to Replace Fuse............................................................................................................. 19 
Send Unit Back to Manufacture For Repairs ......................................................................... 19 

 
3 Installing RamanSoft................................................................. 21 

 

RamanSoft and PVCAM® Installation ............................................................................................21 
Setting up the LSI Laser control board USB 2.0 Interface.............................................................32 
Default Directories..........................................................................................................................33 

 
4 A Quick Tour .............................................................................. 34 

 

Starting Dimension-P Raman ........................................................................................................34 
Starting RamanSoft........................................................................................................................34 
Acquiring a Spectrum.....................................................................................................................37 

Setting Laser Power............................................................................................................... 37 
Setting CCD Integration Time ................................................................................................ 38 
Setting Acquisition Parameters .............................................................................................. 38 

DRS-RS1.4-UM-2008-09-23 
 

 



Contents                                               ii 

Setting File Preferences......................................................................................................... 39 
Acquiring a Spectrum............................................................................................................. 40 

Saving a Spectrum.........................................................................................................................42 
Using a system-generated file name...................................................................................... 42 
Using a user-specified file name............................................................................................ 43 

Spectrum Processing / Analysis ....................................................................................................44 
Smoothing .............................................................................................................................. 44 
Normalization ......................................................................................................................... 45 
Background Removal ............................................................................................................. 46 
Peak Identification / Intensity Ratio ........................................................................................ 47 
Peak Area / Area Ratio........................................................................................................... 49 
Spectrum Overlay................................................................................................................... 51 

System Automation ........................................................................................................................52 
RamanSoft Report .........................................................................................................................54 
Spectrum Searching.......................................................................................................................55 

Launching the SpectrumSearch Application .......................................................................... 55 
Creating a New Library .......................................................................................................... 56 
Acquiring a Library Spectrum................................................................................................. 56 
Adding a Spectrum to the Library........................................................................................... 58 
Selecting and Viewing Library................................................................................................ 59 
Setting Search Configuration ................................................................................................. 60 
Performing a Spectrum Search.............................................................................................. 60 
Viewing Search Results ......................................................................................................... 61 

Predicting a Spectrum....................................................................................................................62 
Building a Calibration File ...................................................................................................... 62 
Launching the SpectrumPredict Application .......................................................................... 63 
Configuring Prediction Settings.............................................................................................. 63 
Configuring Spectrum Acquisition Parameters ...................................................................... 64 
Loading Calibration File and Performing Spectrum Prediction .............................................. 64 
Viewing Prediction Results..................................................................................................... 65 

Monitoring a Process in Real Time ................................................................................................67 
Launching Real Time Monitoring Application......................................................................... 67 
Setting Acquisition Parameters .............................................................................................. 68 
Setting Real Time Monitoring Configuration .......................................................................... 68 
Starting Real Time Monitoring................................................................................................ 69 
Saving Monitoring Results ..................................................................................................... 69 

Exiting RamanSoft .........................................................................................................................70 
Turning off Dimension-P Raman....................................................................................................71 

 
5 RamanSoft Basic Functionalities............................................. 72 

 

Upon RamanSoft Start-up..............................................................................................................72 
Selecting a Configuration File ................................................................................................ 72 
CCD Operating Temperature Warning Window..................................................................... 72 
Laser Power Stabilizing Window............................................................................................ 72 
System Test Prompting Window ............................................................................................ 73 

The Main Menu, System Toolbars, and Frame Status Bar............................................................73 
The Main Menu ...................................................................................................................... 73 
System Toolbars .................................................................................................................... 73 
Frame Status Bar ................................................................................................................... 74 

The File Menu ................................................................................................................................75 
Open....................................................................................................................................... 75 
Save As .................................................................................................................................. 76 
Save ....................................................................................................................................... 77 
Preferences ............................................................................................................................ 77 
Print / Print Preview................................................................................................................ 77 

DRS-RS1.3-UM-2006-06-26 
 
 



Contents                                               iii

The Edit Menu................................................................................................................................78 
The System Menu..........................................................................................................................79 

Instrument .............................................................................................................................. 79 
Laser Setting .......................................................................................................................... 81 
CCD Configuration ................................................................................................................. 83 
System Test ........................................................................................................................... 84 
Calibration .............................................................................................................................. 86 
Live Video Configuration ........................................................................................................ 97 
SpectrumSearch..................................................................................................................... 98 
SpectrumPredict..................................................................................................................... 98 
Automation ............................................................................................................................. 99 

The Acquisition Menu...................................................................................................................100 
Setup .................................................................................................................................... 101 
Acquire ................................................................................................................................. 103 
Continuous Acquire / Stop Acquire ...................................................................................... 104 
Dark Current......................................................................................................................... 105 
Background .......................................................................................................................... 105 

The Analysis Menu.......................................................................................................................109 
Algorithm Setup.................................................................................................................... 109 
Single Spectrum & Spectrum Overlay.................................................................................. 121 
Spectrum Subtraction........................................................................................................... 123 
Smoothing ............................................................................................................................ 126 
Normalization ....................................................................................................................... 126 
Background Removal ........................................................................................................... 126 
Peak Identification................................................................................................................ 127 
Peak Area............................................................................................................................. 127 

The Tools Menu ...........................................................................................................................127 
The View Menu ............................................................................................................................127 

X Axis ................................................................................................................................... 127 
Analysis Window .................................................................................................................. 128 

The Help Menu.............................................................................................................................129 
Exiting RamanSoft .......................................................................................................................130 
RamanSoft Trouble Shooting.......................................................................................................131 

CCD Camera Communication Failure.................................................................................. 131 
Laser Power Status Warning ............................................................................................... 132 
Laser Status Warning........................................................................................................... 132 
White Noise Spectrum Acquired .......................................................................................... 133 
Turning Laser On From RamanSoft..................................................................................... 133 

 
6 The SpectrumSearch Module................................................. 135 

 

Overview ......................................................................................................................................135 
Launching the SpectrumSearch Application................................................................................135 
The SpectrumSearch User Interface ...........................................................................................135 
The File Menu ..............................................................................................................................136 

Save Search Results............................................................................................................ 136 
Print Search Results............................................................................................................. 137 
Exit........................................................................................................................................ 137 

The Library Management Menu...................................................................................................137 
Library Creation Setup ......................................................................................................... 137 
View Library.......................................................................................................................... 138 
Create New Library .............................................................................................................. 140 
Add New Spectrum .............................................................................................................. 141 
Delete a Spectrum................................................................................................................ 142 
Delete Library from List ........................................................................................................ 143 
Add Library to List ................................................................................................................ 144 

DRS-RS1.3-UM-2006-06-26 
 
 



Contents                                               iv 

The Library Search Menu.............................................................................................................145 
Spectrum Search Setup ....................................................................................................... 145 

Acquiring a Spectrum for Library Creation...................................................................................147 
Spectrum Search Configuration...................................................................................................148 
Acquiring/Loading Spectrum for Library Searching .....................................................................150 

Acquiring a New Spectrum................................................................................................... 150 
Passing an Existing Spectrum from RamanSoft .................................................................. 152 
Opening an Existing SPC File.............................................................................................. 153 

Viewing Search Results ...............................................................................................................154 
SpectrumSearch Troubleshooting ...............................................................................................156 

Library Already in the Library List......................................................................................... 156 
SpectrumSearch Application Already Started...................................................................... 156 
Two SpectrumSearch Application Interfaces ....................................................................... 157 
No Action Occurred After Pressing Save Spectrum or Start Search ................................... 157 
SpectrumSearch Application Warning ................................................................................. 157 
Invalid File Path/Name of SpectrumSearch Executable ...................................................... 158 
No Spectrum Selected ......................................................................................................... 158 
Run-time Error...................................................................................................................... 158 
Unknown Error Conditions ................................................................................................... 159 
Restarting the SpectrumSearch Application ........................................................................ 159 

 
7 The SpectrumPredict Module................................................. 160 

 

Overview ......................................................................................................................................160 
Launching the SpectrumPredict Application ................................................................................160 
The SpectrumPredict Interface ....................................................................................................160 
The File Menu ..............................................................................................................................161 

Open..................................................................................................................................... 161 
Save ..................................................................................................................................... 161 
Exit........................................................................................................................................ 162 

The Configuration Menu...............................................................................................................162 
SpectrumPredict Settings..................................................................................................... 162 

Performing a Spectrum Prediction ...............................................................................................165 
Loading a Calibration File .................................................................................................... 165 
Acquiring/Loading a Spectrum for Prediction....................................................................... 166 

Viewing the Prediction Results ....................................................................................................168 
Prediction Results Report .................................................................................................... 170 

SpectrumPredict Troubleshooting................................................................................................171 
SpectrumPredict Application Already Started ...................................................................... 171 
Two SpectrumPredict Application Interfaces ....................................................................... 171 
No Action Occurred After Pressing Predict .......................................................................... 172 
SpectrumPredict Application Warning.................................................................................. 172 
Invalid File Path/Name of SpectrumPredict Executable ...................................................... 172 
Missing Output File Name Error........................................................................................... 173 
Invalid File Format Error....................................................................................................... 173 
Prediction Error .................................................................................................................... 173 
Run-time Error...................................................................................................................... 174 
Unknown Error Conditions ................................................................................................... 174 
Restarting the SpectrumPredict Application ........................................................................ 175 

 
8 The Real Time Monitoring Module ......................................... 176 

 

Overview ......................................................................................................................................176 
Launching the Real Time Monitoring Module ..............................................................................176 
The Real Time Monitoring User Interface ....................................................................................176 
The File Menu ..............................................................................................................................177 

DRS-RS1.3-UM-2006-06-26 
 
 



Contents                                               v

Load ..................................................................................................................................... 177 
Save ..................................................................................................................................... 177 
Print ...................................................................................................................................... 178 
Exit........................................................................................................................................ 178 

The Configuration Menu...............................................................................................................178 
Performing a Real Time Monitoring Measurement ......................................................................180 
File Operations.............................................................................................................................182 

 
9 Virtual RamanSoft ................................................................... 185 

 

Overview ......................................................................................................................................185 
Using Virtual RamanSoft..............................................................................................................185 

 
Appendix I  System Specifications ........................................... 186 

 
Appendix II  Mercury Lamp Peaks for Wavelength Calibration 187 

 
Appendix III The Maximum Peak of Cyclohexane for Laser 
Wavelength Calibration ................................................................ 191 

 
Warranty & Service ....................................................................... 193 

 

Limited Warranty ..........................................................................................................................193 
Basic Limited One (1) Year Warranty .................................................................................. 193 
Basic Limited One (1) Year Warranty on Standard & Optional Accessories ....................... 193 
Princeton Instruments PIXISTM CCD Camera...................................................................... 193 
User Manual and Troubleshooting ....................................................................................... 193 
Buyer’s Responsibility .......................................................................................................... 194 
Single End-User License Agreement and Warranty for RamanSoftTM ................................ 195 
Software Limited Warranty................................................................................................... 195 

Contact Information......................................................................................................................196 
 

Index .............................................................................................. 197 
 

DRS-RS1.3-UM-2006-06-26 
 
 



vi 

This page is left blank. 
 
 
 
 
 
 
 

DRS-RS1.4-UM-2008-09-23 
 

 



1 

1 Introduction 
 
 
This document describes the operation of the Dimension Raman systems, and the functionalities of its 
operating software RamanSoft.  
 
 

Overview of Features 
 
The Dimension Raman Systems are high performance Raman spectrometer systems achieved 
through the integration of proprietary optics and unique software solutions. The high sensitivity of 
its proprietary fiber bundle probe system and the high light throughput spectrometer, combined 
with unsurpassed performance provided by Princeton Instrument TE-cooled CCD, yield the 
sensitivity and resolution needed to confidently use Raman to answer critical QA/QC and 
analytical questions.  
 
A Dimension-P Raman System comes with the LSI Vector Raman Probe, an internal sample cell 
(for Dimension-P1 Raman System), and an External Sampling Module. It is currently operated at 
785 nm laser line. The system is available as a standard resolution (SR) (wavenumber coverage: 
150 - 3300 cm-1) or high resolution (HR) (150 - 2100 cm-1; nominal resolution: 3 cm-1) model. 
 
A Dimension-M Raman Microscope System consists of a Dimension-P Raman System and the 
Raman Microscope Adaptor, which permits the user to convert a Nikon Model L-150 into a 
Raman microscope. The Nikon L-150 is an epi-illuminated reflectance microscope with infinity 
corrected optics allowing for analysis of surfaces as well as subsurface regions in translucent 
material. With a Dimension-M Raman Microscope system, the user can save both microscope 
images and Raman spectra of discrete sample regions and in the mean time make full use of the 
functionalities of the corresponding Dimension-P Raman system. 

 
A Dimension Raman System is operated through RamanSoft, LSI’s proprietary software for data 
acquisition, data processing, and data analysis for its Dimension Raman systems. This software 
functions as an instrument control center permitting user to set CCD temperature and integration 
time, control the laser shutter and laser power. In addition, RamanSoft has user-friendly 
interfaces for system calibration and system testing.  
 
The program provides a comprehensive suite of data handling features designed to expedite data 
processing and analysis. These include several spectral smoothing algorithms for noise 
reduction, the ability to normalize spectra to different spectral features and/or to laser power, and 
LSI’s proprietary algorithm for background removal to enable the user to obtain consistent spectra 
across different background conditions. These features along with quantitative procedures for 
peak intensity and peak area provide a full range of processing and analysis features.  
 
RamanSoft is integrated with Thermo Electron Corporation’s Spectral ID® for seamlessly 
performing spectrum acquisition and spectral library searching to identify unknown samples. The 
integrated system allows for setting experimental parameters, acquiring spectra to build a new 
library or add a spectrum to an existing library, and performing spectral identification of unknown 
samples.  
 
RamanSoft is also integrated with Thermo Electron Corporation’s IQ PredictTM  for seamlessly 
performing spectrum acquisition and spectral analysis using both qualitative methods such as 
Principal Component Analysis and Discriminant Analysis, and quantitative methods like Principal 
Component Regression and Partial Least Squares analysis. 
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The Real Time Monitoring module is designed to meet the need to monitor processes in real time. 
The program tracks up to five peaks either by peak intensity or peak area, and can monitor 
processes as fast as 25 msec. 

 
 

How This Document Is Organized 
 

Manual Organization 
 

This manual provides the user with all the information needed to set up and operate a Dimension 
Raman System.  

 
● Chapter 1, “Introduction”, provides an overview of the Dimension Raman System. 

 

● Chapter 2, “System Setup”, provides an overview of the hardware components, the 
instructions for setting up a Dimension Raman System, and the procedures for starting up 
and shutting down the instrument. 

 

● Chapter 3, “Installing RamanSoft”, gives a detailed description on how to install the software 
on your computer.  

 

● Chapter 4, “A Quick Tour”, gives a quick tour of the operation and functionality of the 
Dimension Raman System. 

 

● Chapter 5, “RamanSoft Basic Functionalities”, details the basic functionalities of RamanSoft, 
which includes data acquisition, data processing, and data analysis. 
 

● Chapter 6, “The SpectrumSearch Module”, details the RamanSoft SpectrumSearch 
functionality in creating a spectral library, performing online one-step spectrum acquisition 
and library searching or off-line spectral library searching of an existing spectrum through the 
integrated SpectrumSearch interface for Thermo Electron Corporation’s Spectral ID®. 

 

● Chapter 7, “The SpectrumPredict Module”, details the RamanSoft SpectrumPredict 
functionality in performing one-step spectrum acquisition and qualitative and/or quantitative 
spectrum prediction through the integrated SpectrumPredict interface for Thermo Electron 
Corporation’s IQ PredictTM. 

 

● Chapter 8, “The Real Time Monitoring Module”, details the RamanSoft functionality in 
monitoring a process in real time. 

 
● Chapter 9, “Virtual RamanSoft”, describes the operation of RamanSoft independent of the 

operation of a Dimension Raman System. 
 
● Appendix I, “System Specifications’. 

 

● Appendix II, “Mercury Lamp Peaks for Wavelength Calibration”.  
 

● Appendix III, “The Maximum Peak of Cyclohexane for Laser Wavelength Calibration”. 
 

● Warranty & Service contains the warranty and customer support contact information. 
 
 
 
 
 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 1. Introduction                                              3

Safety Related Symbols Used in this Manual 
 
Caution! The use of this symbol on equipment indicates that one or more nearby 
items should not be operated without first consulting the manual. The same symbol 
appears in the manual adjacent to the text that discusses the hardware item(s) in 
question. 
 

Warning! Risk of electric shock! The use of this symbol on equipment indicates 
that one or more nearby items pose an electric shock hazard and should be regarded 
as potentially dangerous. This same symbol appears in the manual adjacent to the 
text that discusses the hardware item(s) in question. 

 

 
 

 
Caution! The use of this symbol on equipment indicates that the laser should not 
be operated without first consulting the manual. The same symbol appears in the 
manual adjacent to the text that discusses the hardware item(s) in question.  

 

Optional Documents 
 

GRAMS/AITM User’s Guide, PLSplus IQTM User’s Guide, and Spectral ID® User’s Guide from 
Thermo Electron Corporation. 
 
 

System Safety 
 

Grounding and Safety  
 

Before plugging in or turning on power supply, the ground prong of the power cord plug must be 
properly connected to the ground connector of the wall outlet. The wall outlet must have a third 
prong, or must be properly connected to an adapter that complies with these safety requirements. 
   
WARNING!  
 
 
 
 

 
Inspect the supplied power cord. If it is not compatible with the power socket, replace the cord 
with one that has suitable connectors on both ends. 

 
WARNING!  
 
 
 

If the equipment is damaged, the protective grounding could be disconnected. Do 
not use damaged equipment until its safety has been verified by authorized 
personnel. Disconnecting the protective earth terminal, inside or outside the 
apparatus, or any tampering with its operation is also prohibited. 

Replacement power cord or power plugs must have the same polarity as that of 
the original ones to avoid hazard due to electrical shock. 

 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 1. Introduction                                              4 

Precautions 
 

To prevent permanently damaging the system, please observe the following precautions: 
 
• Do not remove the instrument cover without turning the system power off and disconnecting 

the power cord and USB cable. In general, disconnecting cables inside the instrument is not 
recommended. 

 
• If you are using high-voltage equipment (such as an arc lamp) with the Dimension Raman 

system, be sure to turn the system power ON LAST and turn the power OFF FIRST. 
 

• Use caution when triggering high current switching devices (such as an arc lamp) near your 
system. The CCD can be damaged by transient voltage spikes. If electrically noisy devices 
are used nearby, an isolated, conditioned power line or dedicated isolation transformer is 
highly recommended. 
 

• The Laser Fiber and Signal Fiber cables should be placed to allow them to follow their natural 
curvatures. Bending or pressing the Laser cables on sharp edges or angles could have them 
permanently damaged. 
 

• Do not place liquids or solvents on top of the Dimension-P Raman unit. 
 
• Do not store unit at temperatures above 50°C. 
 
• Do not operate unit for more than one hour continuously at ambient temperatures above 

40°C. 
 
• Never prevent the free flow of air through the equipment by blocking the air vents and fan 

vent of the Dimension-P Raman unit. 
 

• Allow ambient room around the Dimension-P Raman unit and place the unit in such a way 
that it is easy to unplug the power cord from the back of the Dimension-P Raman unit to 
remove power to the unit in case of a fire hazard. 

 

 Laser Safety 
 

The system employs a Class IIIB 785 nm (see labels below) diode laser (please refer to system 
specifications in Appendix I for laser-related parameters) for excitation. This wavelength is not as 
sensitive to human eyes as visible light. Therefore, the laser beam is more powerful than you see! 
Direct eye contact or prolonged exposure to the skin may cause injury and therefore should be 
avoided. 
 

Class 3B 785nm cw laser < 500mw 
(IEC60825-1:1993+A1+A2) 

Laser safety label: 
 
 
 
 
 
 
 
 
 
 
   

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 1. Introduction                                              5

Raman probe label:  

 

  

 
Lase

Exposure 

r 

Caution!
 ►

 VECTOR Raman Prob 

   LASER
PORT

 
 
 
 SIGNAL 
PORT

 

e 
 Model: RP785 

 S#: RP785-0002
 Made in USA

 
Lambda Solutions, I c

Waltham, MA 02452 
www.lambdasolutions.com

n 
 

 
 
 
 
 
 
 
 
 
 
Access panel label: 
 
 
 
 
 
 
Before the laser power key switch on the Dimension-P Raman unit is turned on, one end of the 
laser fiber should be firmly attached to the laser aperture (i.e., Laser Out port) on the front panel 
of the Dimension-P Raman unit, and the other end should be firmly connected to the Laser Port 
of the Vector Raman Probe (or of the Raman Microscope Adaptor). Place the Vector Raman 
Probe in the internal sample cell or the External Sampling Module and make sure to close the lid.  

 
Before operation, make sure that the laser emission aperture is not pointing towards anyone's 
eye, or onto any surface that may cause reflection into anyone's eye. During operation, avoid 
direct viewing of the laser beam or any specular reflection of the laser beam. To lower the risk of 
injury to the eye, make sure everyone in the room is wearing laser safety goggles while the laser 
is operating. 
 
Turn the Laser Key to OFF position on Dimension-P Raman unit if the laser fiber needs be 
detached or reconnected. Detach or reconnect the fiber while the laser is on could injure people. 
 
Do not remove internal laser housing compartment. 
 
Caution!    Use of controls or adjustments or performance of procedures other than those 

specified herein may result in hazardous radiation exposure.  
 
 
 
Interlock: 
 
The system is also equipped with an interlock in the back of the instrument panel (see figure 
below for P1, its exact position on the back panel for P2 is slightly different from the figure).  The 
user is recommended to connect the interlock to his/her lab laser safety warning system 
according to his/her lab safety requirements.   
 
The interlock is set as follows.  When the pin 1 and pin 6 of the 6-pin phone plug is connected 
(shorted), the laser power is allowed to be turned on/off by the laser power key switch.  If the key 
is turned on, the green LED in the front panel is on.  When it is not connected (open) the laser 
power cannot be turned even if the key switch is turned on.    
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System Maintenance 
 

Cleaning of the Optical Surfaces 
 

 
WARNING!  Turn off all power to the equipment and secure all covers before cleaning the 

units. Otherwise, damage to the equipment or injury to you could occur.  
 

 
Optical surfaces may need to be cleaned due to the accumulation of atmospheric dust. We 
advise that the drag-wipe technique be used. This involves dripping a clean cellulose lens tissue 
into clean anhydrous methanol, and then dragging the dampened tissue over the optical surface 
to be cleaned. Do not allow any other material to touch the optical surface. 
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2 System Setup  
 
 
 

 

To minimize risk to us
 
 
 
 

e s or to system components, turn the Dimension Raman r
unit OFF before any cables are connected or disconnected. 

 
 

System Components 
 

Upon unpacking, check that you have all the components to set up a Dimension Raman system. 
A complete system consists of: 

 
● Dimension-P1 Raman or Dimension-P2 Raman  
 
● Vector Raman Probe 
 
● External Sampling Module 

 
● Laser Fiber (thin black cable) 
 
● Signal Fiber (thick black cable) 
 
● Power cord for Dimension-P Raman  
 
● Laser Power Key 
 
● Sealed cyclohexane standard sample 

 
● USB 2.0 cable  
 
● RamanSoft CD-ROM 
 
● Dimension Raman System User Manual 

 
● Internal Sample Cell Handle (for switching sample compartments of the internal sample cell 

of Dimension-P1 Raman) 
 
● (Optional) Microscope, Raman Microscope Adaptor, Calibration Kit 

 
● (Optional) Additional Software - GRAMS/AITM 7.0 with PLSplus/IQ add-on (or IQ PredictTM), 

Spectral ID®, and their corresponding user manuals. 
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Standard Components 
 
 

   OR     
Dimension-P1 Raman            Dimension-P2 Raman  

 

                  
Vector Raman Probe     Laser Fiber   Signal Fiber 

 
 

          
          

        
 

 
          Internal Sample Cell Handle        Dimension Raman-P 

External Sampling Module      (for Dimension-P1)          Power Cord       
  and Laser Power Key 

  
 

 
 
 
 
 
 
 
 

Sealed Cyclohexane  USB 2.0 Cable 
Standard Sample 

 
Dimension Raman System 
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User Manual and RamanSoft 
CD-ROM 

 

Optional Components 
 

 
 

                                                                                  
Calibration Kit 

 
                    Raman Microscope Adaptor  
                        (microscope not shown) 

 
 
 

 

 
 

Thermo GRAMS software  
& manuals 

 
 

System Requirements  
 

Environmental Requirements 
  

Storage temperature: 55°C ≤
 
Operating environment temperature: 5°C to +30°C; the environment temperature range over 
which system specifications can be guaranteed is +18°C to 23°C. 
 
Relative humidity 50%; non-condensing ≤
 
 
 

Note: For TE-cooled cameras, the cooling temperature may degrade if the room 
temperature is above +23°C.

 
 

Ventilation 
 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 2.  System Setup 10 

Allow at least one inch clearance for the side air vents and at least three inches clearance for the 
back fan vents of the Dimension Raman spectrometer. 

 

Power 
 

Power Input: AC 100 – 250 V, 2 – 4 Amps, 50/60 Hz 
Fuse: 250 V, 2 A, 5 x 20 mm 
Max Power Consumption: 

Dimension-P1 Raman: 95 W 
Dimension-P2 Raman: 75 W 

 

Computer and USB 2.0 Protocol  
 

• Computer with Pentium 3 processor, or better, at 1 GHZ or above. 
 

• Windows® XP (with Service Pack 1), Windows® 2000 (with Service Pack 4) or later operating 
systems. 

 
• Native USB 2.0 support on the mother board or USB Interface Card (orange Micro 

70USB90011 USB2.0 PCI is recommended for desktop; SIIG, Inc. USB 2.0 PC card, Model 
US2246 for laptop). 

 
• Minimum of 256 MB of RAM. 

 
• CD-ROM drive. 

 
• Hard disk with a minimum of 10 GB available. A complete installation of the program files 

takes about 20 MB.  
 

• Supper VGA monitor and graphics card supporting at least 256 colors with at least 1 MB of 
memory. Memory requirement is dependent on desired display resolution. 

 
• Mouse or other pointing device. 

 

Setting up a USB 2.0 Interface 
  

Administrator privileges are required under Windows 2000 and Windows XP to install RamanSoft. 
The advantages of the USB2.0 interface are that it uses a much higher data transfer rate than 
many common serial data formats and it simplifies the connection to external devices. USB 
supports “Plug and Play”, i.e., the user does not need to be heavily involved in the setup process. 
  

 USB 2.0 Limitations 
 

• Maximum cable length is 5 meters (16.4 feet) 
 

• 1 MHz is currently the upper digitization rate limit for PIXISTM camera.  Large data sets and/or 
long acquisition times may be subject to data overrun because of host computer interrupts 
during data acquisition. 
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Note: If you are installing the USB 2.0 interface on a laptop, you need to perform all of the 
operations described in this section.  In addition, if you are using the recommended 
USB Interface Card (USB 2.0 PC Card, Model US2246, SIIG, Inc.), you must replace 
the OrangeUSB USB 2.0 Host Controller driver installed for that card with the 
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. 

 
  
 

Updating the OrangeUSB USB 2.0 Driver 
  

This procedure is highly recommended when a laptop computer will be used to communicate with 
the PIXISTM camera.  As stated before, we recommend the USB 2.0 PC Card, Model US2246 
from SIIG, Inc. if USB 2.0 is not native to the laptop’s motherboard.   

 
1. Download and install Microsoft Service Pack 4 (for Windows 2000) or Service Pack 1 (for 

Windows XP) if the service pack has not been installed. 
 
2. From Windows Start menu, select Control Panel. 

 
3. Select System and then System Properties. 

 
4. Select the Hardware tab and click on Device Manager button. 

 
5. Expand Universal Serial Bus Controllers. 

 
6. Right-mouse click on OrangeUSB USB 2.0 Host Controller and select Properties. 

 
7. On the Driver tab, click on the Update Driver… button. You may have to wait a minute or so 

before you are allowed to click on the button. 
 

8. When the Update Device Driver Wizard appears, click on Next. Select the Search for a 
suitable driver… radio button. 

 
9. On the next screen select the Specify a Location checkbox. 

 
10. Browse and select the location. Click on OK. 

 
11. In the Driver Files Search Results window, check the Install one of the other drivers 

checkbox. 
 
12. Select the NEC PCI to USB Enhanced Host Controller B1 driver. Click on Next and the 

installation will take place.  When the Completing the Upgrade Device Driver Wizard window 
appears, click on Finish. You will then be given the choice of restarting the computer now or 
later.  The hardware associated with the driver will not work until you restart computer. 

 
 

Setting up the Dimension-P1 Raman System 
 

 
 Unplug or switch off the power switch of Dimension-P1 Raman and the computer 

before connecting or disconnecting the USB 2.0 cable.  
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Signal Port 

Laser Power Key

Vector Raman Probe 

 
 
 
 
 
 

Probe 
Adaptor for 
Internal 
Sample Cell 
 Laser Out port 
 
 
 
 External  

Sampling 
Module  

 
 
 
 

 

1. Connect the thin black Laser Fiber to the Laser Out port, and the Fiber Slit Assembly end of the 
thick black Signal Fiber to the Signal Port on the lower right front panel of Dimension-P1 Raman. 

 
 

Note: Make sure that the two set screw holes on the Fiber Slit Assembly face upwards and 
that the screw mechanisms for both the Laser Fiber and Signal Fiber are finger tight 
for proper focus. 

 
 
 

 
 
2.  Connect the other end of the Laser Fiber and Signal Fiber to the Laser Port and the Signal Port 

on the Vector Raman Probe, respectively.  
 

Note: Make sure that the screw mechanisms for both the Laser Fiber and Signal Fiber are 
finger tight for proper focus. 

 
 
 
 
3.  If using the internal sample cell, unscrew loosely the Probe Adaptor on the upper left corner of 

Dimension-P1 Raman. Insert the Vector Raman Probe into the Sample Compartment Port 
through the Probe Adaptor. Make sure that the Vector Raman Probe is inserted till the probe 
head touches the end of the Sample Compartment Port. Screw finger tight the Probe Adaptor.  

 
If using the External Sampling Module, place the Vector Raman Probe into the desired probe hole 
on the External Sampling Module. Make sure to tighten the screw in the screw hole of the 
External Sampling Module so that the Vector Raman Probe is in leveled position (instead of being 
tilted due to the weight of the probe head). 

 
4. Connect the Dimension-P1 Raman (USB 2.0 port at the back panel of the unit)  to your computer 

with the USB 2.0 cable.  
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 Power Switch 
 

Fuse Compartment 
 

Power Cord Inlet USB 2.0 port  
5. Plug in the power cord of the Dimension-P1 Raman and of the computer, respectively. 
 
6. Insert the Laser Power Key into the Laser Power keyhole on Dimension-P1 Raman. Leave it in 

OFF position. 
 

 

Setting up the Dimension-P2 Raman System 
 

 
 
 Unplug or switch off the power switch of Dimension-P2 Raman and the computer 

before connecting or disconnecting the USB 2.0 cable.  

 
 
 
 
 
 
 
 Laser Power Key 
 Signal Port  
 

Laser Out port 
External Sampling 
Module  

 
 Vector Raman Probe 
 
 
 
 
 
 

 

 
 

1. Connect the thin black Laser Fiber to the Laser Out port, and the Fiber Slit Assembly end of the 
thick black Signal Fiber to the Signal Port on the lower right front panel of Dimension-P2 Raman. 

 
 Note: Make sure that the two set screw holes on the Fiber Slit Assembly face upwards 

and that the screw mechanisms for both the Laser Fiber and Signal Fiber are finger 
tight for proper focus. 

 
 
 
 
2. Connect the other end of the Laser Fiber and Signal Fiber to the Laser Port and the Signal Port 

on the Vector Raman Probe, respectively.  
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 Note: Make sure that the screw mechanisms for both the Laser Fiber and Signal Fiber are 

finger tight for proper focus.  
 

 
3. Place the Vector Raman Probe into the desired probe hole on the External Sampling Module. 

Make sure to tighten the screw in the screw hole of the External Sampling Module so that the 
Vector Raman Probe is in leveled position (instead of being tilted due to the weight of the probe 
head). 

 
4. Connect the Dimension-P2 Raman (USB 2.0 port at the back panel of the unit) to your computer 

with the USB 2.0 cable.  
 
 
 
 

Fan vent  
 Fuse Compartment
 
 

Power Switch  
 
 
 
 USB 2.0 port Power Cord inlet  

 
5. Plug in the power cord of the Dimension-P2 Raman and of the computer, respectively. 
 
6. Insert the Laser Power Key into the Laser Power keyhole on Dimension-P2 Raman. Leave it in 

OFF position. 
 

 

Setting up the Dimension-M Raman Microscope System 
 

 
 
 Unplug or switch off the power switch of Dimension-P Raman, the Nikon L-150 

Epi Microscope, and the computer before connecting the USB 2.0 cable.  

 
 
 

1. Mounting the Raman Microscope Adaptor 
 

a. Place the Raman Microscope Adaptor on the microscope. The Video Mount Receptacle 
of the adaptor should match the mounting receptacle on the microscope. 
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b. Tighten the adaptor in place with a 5/64 Allen-wrench or hex driver by inserting the 

wrench in the mounting groove. 
 
 

Signal PortLaser Port

Video Mount 

Mounting 
Groove 

 
 
 
 
 
 
 
 

 
 

 
 
 
 
 

 
2. Mounting the Infinity 1 CCD Camera (or camera of your choice) 
 

a. Place the Video Mount on the Video Mount Receptacle of the adaptor, tighten with the 
Set Screw.  

 
b. Install the C mount-lens which comes with the Infinity 1 CCD camera (or a camera of 

your choice). 
 
3. Connect the thin black Laser Fiber to the Laser Out port, and the Fiber Slit Assembly end of the 

thick black Signal Fiber to the Signal Port on the lower right front panel of Dimension-P Raman. 
 
 
 
 
   

 
4. Connect the Laser Fiber to the Laser Port, and Signal Fiber to the Signal Port, respectively, of 

the Raman Microscope Adaptor.  

Note: Make sure that the two set screw holes on the Fiber Slit Assembly face upwards 
and that the screw mechanisms for both the Laser Fiber and Signal Fiber are finger 
tight for proper focus. 

Note: Make sure that the screw mechanisms for both the Laser Fiber and Signal Fiber are 
finger tight for proper focus. 

 
 
 
 
 

5. Connect the Dimension-P Raman (USB 2.0 port at the back panel of the unit) to your computer 
with the USB 2.0 cable.  

 
7. Plug in the power cord of the Dimension-P Raman,  the Nikon L-150 Epi Microscope, and of the 

computer, respectively. 
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8. Insert the Laser Power Key into the Laser Power keyhole on Dimension-P Raman. Leave it in 

OFF position. 
 

9. The following figure shows an assembled Dimension-M1 Raman Microscope system (Dimension-
P1 Raman with Raman Microscope Adaptor and Nikon L-150 Epi Microscope. Note: the 
computer shown in the picture is not included in the system.) 

 

 
 
 

System Start-up Procedure 
 
● Turn on the power of the Dimension-P Raman (the power switch is on the back panel of the unit). 
 
● Turn the Laser Power Key to ON position.  
 
● Turn on the computer and launch RamanSoft. If RamanSoft is not installed on your computer yet, 

please do so by following the instructions in Chapter 3, “Installing RamanSoft”. Also, install 
optional software (such as Thermo Electron Corporation’s software). 

 
● For a Dimension-M Raman Microscope system, turn on the microscope lamp. Also, install the 

software that comes with the Infinity 1 CCD camera (or a camera of your choice). 
. 

 

Using the Dimension-P Raman System 
 

• Place a sample, in vial or cuvette, in the appropriate sample compartment in the internal sample 
cell or the External Sampling Module. Make sure to close the lid of the internal sample cell or the 
External Sampling Module. If a surface or object is to be analyzed, place the External Sampling 
Module on top of the sample and insert the Vector Raman Probe downwards into the large round 
hole till the probe head touches the stopper of the External Sampling Module.  
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• Make sure the Laser Power key is at the ON position. 

 
• Set data acquisition parameters to acquire spectrum (Acquire or Continuous Acquire, accessed 

through RamanSoft main menu Acquisition->Acquire or Acquisition->Continuous Acquire, or by 

clicking on icon  or , respectively, from the RamanSoft Acquisition Toolbar) and access 
RamanSoft function modules as described in Chapter 4, “A Quick Tour”. For Detailed 
functionalities, see Chapters 5 -8. 

 
 

Using the Dimension-M Raman Microscope System 
 

● Focus the laser beam. To focus the beam, the user must visualize the beam with the Infinity 1 
CCD Camera (or the camera of your choice). 

 
a. Place a sample on the microscope stage. 
  
b. Start RamanSoft and set the laser power to 30 mW (see Chapter 4, “A Quick Tour”). This 

low setting is required so as not to over-saturate the Infinity 1 CCD Camera and therefore 
be able to obtain a true assessment of optimal (i.e., smallest diameter) beam size.  

 
c. Start the Infinity 1 Live Video Capture software. Use default setting for frame size and 

resolution.  
 

d. Toggle back on to RamanSoft and start continuous acquisition (accessed through 

RamanSoft main menu Acquisition->Continuous Acquire, or by clicking on icon  from 
the RamanSoft Acquisition Toolbar. See Chapter 4, “A Quick Tour”). 

 
e. The beam can be seen on live video. Adjust the focus until the laser beam is the 

smallest.  
 

f. Turn off continuous acquisition by pressing the  button on the RamanSoft Acquisition 
Toolbar (See Chapter 4, “A Quick Tour”). 

 
● Visualize the sample. Locate the region of interest. 

 
a. Turn on the microscope lamp and adjust the microscope stage until the field of interest is 

in the view. 
 

b. Turn the microscope lamp to the lowest setting that still allows visualization of the 
sample. 
 

c. Start continuous acquisition and make sure that the sample is centered under the beam.  
 

d.  Turn off the microscope lamp and re-focus the laser beam if necessary.  
 

e. Turn off continuous acquisition. 
 

• Acquire sample spectrum 
 
a. Increase the laser power and restart continuous acquisition. 
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b. Optimize other acquisition parameters (See Chapter 5, RamanSoft Basic functionalities) 
by taking and comparing spectra obtained at different acquisition parameter settings. 

 
c. Acquire spectrum (accessed through RamanSoft main menu Acquisition->Acquire or by 

clicking on icon  from the RamanSoft Acquisition Toolbar) and access RamanSoft 
function modules as described in Chapter 4, “A Quick Tour”. For Detailed functionalities, 
see Chapters 5 -8. 

 
 

Switching between Macro-sampling and Micro-sampling 
 

The difference between the Dimension-P Raman System and the Dimension-M Raman 
Microscope System lies in the different sampling method. For a Dimension-P Raman System, the 
sampling is performed using the External Sampling Module, and in the case of Dimension-P1, an 
additional internal sample cell is provided; the size of the laser beam is approximately 0.2 mm, 
and such sampling is termed as macro-sampling. For a Dimension-M Raman Microscope 
System, the sampling is performed using the microscope stage, where the microscope objective 
can focus the laser beam to 20 – 100 μm with current multimode laser fiber (when a single mode 
laser fiber is used, the laser spot will be focused smaller), and thus sampling can be performed 
on even smaller distinct sub-regions of the sample. Such sampling is termed micro-sampling. 

 
The user is able to switch between macro-sampling and micro-sampling during a RamanSoft 
session. To do this, proceed with the following procedure: 
 

1. Check whether there is a continuous acquisition currently active, if so, click on Acquisition 

-> Stop Acquire or press  to stop the continuous acquisition. 
 
2. Turn the Laser Power Key on the Dimension-P Raman to OFF position. 

 
3. Disconnect the Laser Fiber and the Signal Fiber from the Laser Port and the Signal Port 

of the Vector Raman Probe (or Raman Microscope Adaptor), respectively, and connect 
them to the corresponding port of the Raman Microscope Adaptor (or Vector Raman 
Probe), respectively. 

 
 

Note: Make sure that the screw mechanisms for both the Laser Fiber and Signal 
Fiber are finger tight for proper focus. 

 
 
 

4. Turn the Laser Power Key on Dimension-P Raman to ON position. 
 

5. Follow the procedure in “Using the Dimension-M Raman Microscope System” (or “Using 
the Dimension-P Raman System”) to proceed with the switched sampling system. 

 
 

System Shut-down Procedure 
 

● Exit each of the RamanSoft function modules, if used, and then exit RamanSoft. Turn off the 
computer. 

 
• Turn the Laser Power key to the OFF position. 
 

 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 2.  System Setup 19

● Turn off Dimension-P Raman (power switch to “0” position on the back panel). 
 
● Turn off the microscope lamp if Dimension-M Raman Microscope is used. 
 
 
 

Trouble Shooting 
 
 

 
 
  

Do not open unit without taking safety precautions! (see Chapter 1, section 
“System Safety”). 

 
 

 

How to Replace Fuse 
 

If the Dimension-P Raman failed to turn on (as indicated by the absence of sound from the fan) 
after the power cord is plugged in and the power switch is at “1” position, the fuse(s) may need be 
replaced. 
 
The AC power in-let module on the back panel of the system has a fuse compartment containing 
two fuses. To replace one or both fuses, proceed with the following procedure. 
 
1. Turn the Dimension-P Raman off (i.e., turn the power switch on the back panel of the unit to 

“0” position). 
 
2. Unplug the power cord of the Dimension-P Raman unit. 

 
3. Open the fuse compartment using a flat screw driver or a similar tool. 

 
4. Replace the fuse(s) and close the fuse compartment. 

 

Send Unit Back to Manufacture For Repairs 
 

Upon any other hardware failure, including: 
 
1. The fan does not function as indicated by the fact that there is no air circulation near the fan 

vent at the back panel of the instrument. 
 
2. The laser does not function as indicated by a zero power reading  no matter how you adjust 

the laser power through the laser adjustment sliding bar (see Chapter 5, section “Laser 
Setting”->”Power Adjustment” for more details). 

 
3. The CCD camera does not function as indicated by the fact that  

 
a. The CCD cooling temperature cannot reach the target temperature (-70 °C for 

Dimension-P1 Raman and -15 °C for Dimension-P2 Raman); 
 
b. No signal of the sealed cyclohexane standard sample can be acquired. To make sure 

that this is indeed a CCD camera failure instead of a communication failure between 
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the CCD and RamanSoft, check to make sure that the USB 2.0 cable is plugged both 
to the USB 2.0 port of the Dimension-P Raman unit and the USB port of your 
computer. If the problem persists, proceed to follow the directions in Chapter 5, 
section “RamanSoft Troubleshooting”->”CCD Camera Communication Failure”. A yet 
still persisting problem indicates that the CCD camera does not function. 

 
You may need to send the unit back to manufacture for repairs. Before sending any product or 
parts for service or repairs, please contact Lambda Solutions, Inc. or your authorized 
representative or distributor (see Warranty & Service at the end of this manual for more details).
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3 Installing RamanSoft 
 

RamanSoft and PVCAM® Installation 
 

RamanSoft must be installed under Windows. It can not be installed on a computer only running 
DOS, or from a DOS shell. 

 
RamanSoft Installation is normally provided on a CD that contains a single setup executable file 
(Setup,exe). By double clicking on the Setup.exe or by typing in Setup.exe in the Run command 
window, RamanSoft InstallShield will start the installation process and will run until the completion 
of the installation.  
 
 
 
 
 

Note: When RamanSoft is installed, it modifies the Windows Registry file.  If for any 
reason, a user reinstalls Windows, the Registry file may be replaced, and 
RamanSoft may not run correctly. Reinstall RamanSoft to correct this problem. 

 
 
 
 
 
 
 

Note: If Installing under Windows XP, 2000, and NT, the user must be logged on as 
administrator.  Certain changes are made to the Registry during the installation.  If 
the user didn’t log in as administrator, the Registry changes cannot be made and 
installation will fail. 

Take the following steps to install RamanSoft onto your computer. 
 

• Exit any software currently running. 
 

• Insert the RamanSoft Installation CD into your CD drive.  Windows will detect the CD and the 
installation will begin automatically.   
 
 
 
 
 
 

 

  

Note: If the auto-start feature has been disabled on your computer, click the desktop Start 
menu, select Run, type in or browse to D:\Setup.exe (where “D” is the letter 
designating your CD drive, as shown below) and press OK, the installation will 
begin. 

 
The Preparing Setup screen will appear indicating that the InstallShield setup program is loading. 

DRS-RS1.4-UM-2008-09-23 
 

 



Chapter 3.  Installing RamanSoft 22 

 
 

• The RamanSoft Installation welcome screen will appear as shown below. To quit without 
installing the software, click Cancel. To continue installing the RamanSoft, click on Next. 
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• Click Next to continue. The Software License Agreement screen appears next. Click Yes to 

continue. Click No to abort the installation or press Back to return to the previous screen. 
 

 
 
• Next the Choose Destination Location screen appears. This dialog box allows the user to specify 

the directory where RamanSoft files are to be installed. A default location, C:\LSI, is 
recommended. 

 

 
 
• To specify a different location, click on Browse. Then either select new directory or enter the path 

and name in the entry box and click OK. 
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• Click on Next to bring up the Select Program Folder screen. Select either an existing folder or 
type in the name of a new folder. 

 

 
Note: This is not the folder where the files are to be installed, but rather the Start menu 

folder from which RamanSoft can be launched. 
 
 
 

 
 
 

• The current folder setting screen will appear next (shown below). It lists the destination folders. 
Click on Next to initiate the actual installation in which the files will be decompressed and placed 
in the specified directory. Click on Back to make any changes or click on Cancel to exit the 
procedure. 
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• The Installation Setup Status screen (shown below) appears next. The names of the individual 
files appear in the message box as they are loaded and the installation progress in percent is 
continuously displayed. 

 

 
 

• After file installation, the RamanSoft InstallShield will start to register the DLLs which RamanSoft 
has incorporated into the Windows’ Registry. The following message box will appear after the 
Windows’ registration is succeeded and finished. 
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• Next, the InstallShield will automatically start the installation of Princeton Instruments’ PVCAM® 

(Programmable Virtual Camera Access Method), a library that can be used to control and acquire 
data. The following Setup window appears. 

 

 
 

• Click on Next, PVCAM License Agreement Window appears. Click on Yes to accept the 
agreement and continue the installation. 

 

 
 

Next, the Customer Information dialog box appears. To continue, enter your name and 
organization. Then click Next. 
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• You are next asked to confirm your registration information via the following dialog box. Select 

Yes if the displayed information is correct and you want to continue. Click No to return to the 
Customer Information window to make necessary changes. 

 

 
 

• Next, the Choose Destination Location dialog box appears. This dialog box allows you to specify 
the directory where you would like the PVCAM files to be installed. A default location, C:\Program 
Files\Roper Scientific\PVCAM, is suggested. 
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• To specify a different location, click on Browse. Then either select a new directory or enter its 
name (with path information) in the entry box and click OK. If the name of the directory does not 
exist, the installation will offer to create it for you. 

 

 
 

• Next, the Setup Type dialog box appears. You are given the following choices: 
 
  Standard: Install DLLs and PCI interface driver. 
  Custom: Allows user to choose files to be installed. 
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• Choose either Standard or Custom setup and click on Next to bring up the Select Program Folder 
dialog box. You can either select an existing folder or type in the name of a new one. 

 
 Note: This is not the folder where the files are to be installed, but rather the Start Menu 

folder from which RamanSoft can be launched.  
 
 

 
 

• The Start Copying Files dialog box appears next. It lists User information, the Destination 
Folder(s), the Setup Type and the Program Folder. Click on Next to initiate the actual installation 
in which the files will be decompressed and placed in the specified directory. Click on Back if the 
user wishes to make any changes, or click on Cancel to exit the procedure. 
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• The Setup Status screen (shown below) appears next. The names of the individual files appear in 
the message box as they are loaded and the installation progress in percent is continuously 
displayed. 

 

 
 

• After the files are installed, an information dialog about PVCAM.ini file location and RSConfig 
program appears. 
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• Finally, the RamanSoft Setup Complete dialog appears and asks you to restart the computer now 
or later. Before you can use the newly installed the RamanSoft, the computer has to be restarted. 

 

 
 

● Click on Finish to restart the computer and finish the RamanSoft installation. 
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Setting up the LSI Laser control board USB 2.0 Interface 
 

Administrator privileges are required under Windows 2000 and Windows XP to install the 
RamanSoft interface control for the Dimension Raman System’s hardware.   

 
Once the user finished the RamanSoft Installation, and when the USB 2.0 cable is connected to 
the computer for the first time, the following Found New Hardware Wizard window will appear. 

 

 
 

For the first time, the user should choose Install from a list or specific location as shown above. 
Then click Next. 

 

 
 

On the window shown above, the user should choose Search for the best driver in these locations 
and browse to C:\LSI\USBI2IO\drv_dll folder as shown above. Click on Next 
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Default Directories 
 

A full installation of RamanSoft will create directories and copy files as listed below.  The local 
drive is assumed to be C:. 

 
C:\LSI\RamanSoft 
 

 This directory contains following folders: 
 

• The Calibration folder stores the calibration files whenever a calibration is performed on 
the system. 

 
• The Configuration folder contains the configuration files which store file settings, 

configuration parameters, and system settings that user creates. A default configuration 
file is created when RamanSoft is installed. 

 
• The Dll folder contains all the DLL files required to run RamanSoft that are installed into 

windows system file.   
 

• The Exe folder contains all the executable RamanSoft files. There are three of them. 
RamanSoft.exe is the file that is run when user clicks on the RamanSoft icon. 
SpectrumPredict.exe and SpectrumSearch.exe are macro executable files ran by 
RamanSoft to perform spectrum search and spectrum predict. 

 
• The Init folder contains all the system init files that RamanSoft requires. These files are 

also installed in Windows directory. The files in the init folder serve as a backup in case 
these important system init files were corrupted. In this case the user can copy these files 
back to the Windows directory. 

 
• The Log folder contains all the log files that the system registers for every active 

RamanSoft session.   
 

C:\LSI\RamanData 
 
 This is the Default directory for data files.  This directory contains following folders: 
 

• The CalibrationData folder contains all the calibration spectrum data when a system 
calibration is performed.  

 
• The SystemTest folder contains all the system test spectrum data when a system test is 

performed. 
 

C:\LSI\ USBI2CIO 
 
 This directory contains all drivers and dlls required for LSI Laser Control  Board USB Interface.  It 
 contains the following folders: 
 

• The drv_dll folder contains driver and dlls.   
• The Firmware folder contains the firmware of LSI USB Laser Control Board. 
• The Utils folder contains the recovery system files. 
 

C:\LSI\ RunIQPredict 
 
This directory contains all sample .Cal files and .iqs files for running SpectrumPredict in 
RamanSoft. 
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4 A Quick Tour 
 
 
This chapter gives a quick tour on how to use the Dimension-P Raman system with the operating 
software RamanSoft. The purpose of this chapter is to familiarize the user with the tools for spectrum 
acquisition, spectrum processing and analysis. In addition, this Tour introduces and demonstrates the use 
of spectral library search, qualitative and quantitative spectral analysis, and real time process monitoring. 
Please refer to the reference chapters (Chap. 5 – 8) for a comprehensive description of the RamanSoft 
functionality. 
 
Throughout this chapter, we refer to the sealed cyclohexane standard sample that comes with the 
instrument for illustrative purposes. The Tour is demonstrated with Dimension-P1 HR Raman System, 
and the data are stored in C:\LSI\RamanData\Tour and they come with the system.  
 
 

Starting Dimension-P Raman 
 

● Turn on the power switch of the Dimension-P Raman (on the back panel of the instrument).  
 
● Turn the Laser Power key to ON position.  
 
● Turn on the computer. 
 
 

Starting RamanSoft 
 

● From Windows® start menu, go to All Programs and choose LSI->RamanSoft. Or create a 
shortcut for RamanSoft from C:\LSI\RamanSoft\exe and place it on the desktop, double click the 
RamanSoft shortcut icon. 

 
● Choose the default configuration file by clicking on the Default.rcf file icon, and click Open. 
  

 
 

● Wait till the Laser Power Stabilizing Progress Window and the CCD Temperature Warning 
Window disappear (takes 15 seconds and 2-3 minutes, respectively). 
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● Press OK on the System Test Prompting Window to perform a system test.  
 

 
 

The System Test window outlines the steps for performing the system test. Check Step 1, and put 
the sealed cyclohexane standard sample in the internal sample cell or the External Sampling 
Module. If the External Sampling Module is used, be sure to close the lid. 
 

 
 

Press Run Test. The system starts to acquire the spectrum for the sealed cyclohexane standard 
sample, and the test results appear in the Test Report group box of the System Test widow. 
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If the system test is passed, click OK to continue the tour. If the test fails, a re-calibration of the 
instrument is then necessary. Please refer to section “Calibration” of Chapter 5, “RamanSoft 
Basic Functionalities”, to re-calibrate the system. 

 
 

● The RamanSoft user interface appears as follows: 
 

Acquisition Window  

  

File View Window 

 
Analysis Window 
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 The Acquisition Window displays the acquired raw spectrum (of cyclohexane), the Analysis 

Window displays the processed spectrum (here the background-removed and normalized 
cyclohexane spectrum – see later sections on RamanSoft Data Processing methods), and the 
File View Window displays Raw Data files and the Processed Data files for the current 
RamanSoft session. Double clicking any of these files places that raw or processed spectrum in 
the Analysis Window. 

 
 

Acquiring a Spectrum 
 

Before a spectrum is acquired, the user needs to set up acquisition parameters which include 
setting up the laser power, the CCD integration time, the number of frames to average in one 
measurement, the file name and directory etc. (Note that for the system test as shown above, 
these parameters are automatically set by the system). 

 

Setting Laser Power 
 

● From the main System menu of RamanSoft, 
 

 
 
● choose System->Instrument. Make sure that On Line is checked. 

 

 
 

● Go to Laser Setting, make sure that Laser On is checked.  
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● Go to Power Adjustment…, the Laser Power Adjustment window appears: 
 

 
 

Set the laser power to the desired value (100 – 200 mW is recommended) by dragging the bar in 
the Adjusting Laser Power (0.0 – 2.5 V) group box, or by entering a number between 0 and 2.5 in 
the text entering box. The adjusted laser power is displayed in the Current Reading of Current 
Power Reading group box. Click OK.  

 

Setting CCD Integration Time 
 

● From System, choose CCD Configuration…, the CCD Camera Parameter Setup window 
appears: 

 

 
 
Set the New Integration Time to be what is desired (1 second is usually sufficient and 
recommended for most solid and solvent samples, longer integration time is recommended for 
aqueous samples). Signal intensity may also be adjusted with the Gain Setting, with 3 yielding the 
highest signal. Leave CCD Acquisition Speed as Normal Speed (default).  

 

Setting Acquisition Parameters 
 

● From the main menu, choose Acquisition->Setup, the Acquisition Setup window appears: 
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The Frames Per Measurement in the Averaging group box can be left as default (1, i.e., no 
averaging). Type in appropriate information in the text boxes for Operator Name, Path (the name 
of the folder set up within the RamanData folder), Sample Name, Sample Info, and File Prefix. 
Note that by installing RamanSoft, you have already have the directories C:\LSI\RamanData 
created on your computer. For your tour purpose, you are recommended to create a subfolder 
\Tour2 to store your actual tour data so as not to overwrite the sample tour data in 
C:\LSI\RamanData\Tour that comes with your system. To do this, type in “C:\ 
:\LSI\RamanData\Tour2” in the Path field and the program will automatically create the subfolder 
“\Tour2” within \RamanData. 

 

Setting File Preferences 
 

● From the main menu, choose File->Preferences, the File Save Preferences window appears: 
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By default, each acquired spectrum is saved in LSI Format (*.raw for raw spectrum, *.pro for 
processed spectrum), Text Format (*.txt), and GRAMS Format (*.spc) so as to conveniently 
import data to Thermo Electron Corporation’s GRAMS software suite such as GRAMS/AITM . For 
this tour, we’ll only save the data in the default LSI Formats and the Text Format by deselecting 
the checkbox for GRAMS Format (*.spc). 
 

 
 

Acquiring a Spectrum 
 

Before acquiring a spectrum and saving it into a file, it is helpful to view the spectrum under 
current acquisition settings and probe working distance first, and if desired, the acquisition 
settings can be adjusted according to the quality of the spectrum. This can be done through the 
Continuous Acquire function of RamanSoft. 

 
Getting Ready 

 
● Put the sealed cyclohexane standard that comes with the instrument into the internal sample cell 

or the External Sampling Module. If the External Sampling Module is used, be sure to close the 
lid. 
 

● Click anywhere within the Analysis Window, the Analysis Window Toolbar appears in the system 
toolbar panel, which is below the main menu items but above the Acquisition Window: 
 
 Clear Spectrum in Analysis Window Apply Smoothing  View Cursor Grid On / Off 
 
 

 
 

 
Zoom  Apply Peak Area Calculation  Algorithm Setup 

 Apply Peak Identification  Apply Normalization  
 Apply Background removal

Click on  to clear the spectrum in the Analysis Window from the system test. 
 

Continuous Acquiring 
 
● From the main menu, choose Acquisition, the Acquisition submenu appears. 
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● Click Continuous Acquire. Alternativley, the continuous acquire function can easily  be invoked by 

pressing  on the Acquisition Window Toolbar (click anywhere in the Acquisition Window to 
bring up the Acquisition Window Toolbar). 

 
 

 View CCD Image 

 Grid On / Off 
 Stop Continuous Acquiring

Zoom View Cursor Acquire Continuously Acquisition Start 

 
● In case the Laser Power Status Warning Window appears as below,  
  

 
 

click Yes. Wait till the Laser Power Stabilizing Window disappears. Note that this window 
sometimes appears as the system automatically turns off the laser if the system has been idle for 
more than 30 minutes. 

 
● If you have gone through the above step to turn on the laser, you need to click on Acquire -> 

Continuous Acquire or press  again. The program first acquires a dark current and 
subsequently the Cyclohexane spectrum is acquired and displayed in the Acquisition Window, 
and it is updated every 1 second.  
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Note that in the continuous acquisition mode, the  button on the Acquisition Window Toolbar 

becomes active. Click Acquisition -> Stop Acquire or press  to exit the continuous acquisition 
mode.  

 
Acquiring a Spectrum 
 

● To acquire a spectrum, click Acquisition -> Acquire or press  on the Acquisition Window 
Toolbar, the spectrum is displayed in the Acquisition Window. 

 
 

Saving a Spectrum 
 

A spectrum can be saved using either a system-generated file name or a user-specified file 
name.  

 

Using a system-generated file name 
 
● From the main menu, choose File->Save…, the spectrum is then saved in the folder specified by 

the Path field, using the system generated filename, i.e., the File Prefix that the user has put in 
the Acquisition Setup window (see section “Set Acquisition Parameters”) followed by a computer 
generated date and time string. For example, the file for this tour is saved as 
C:\LSI\RamanData\Tour\cyclohexane0203101325.raw. Note that the saved spectrum is displayed 
in the Analysis Window and the filename is added onto the “Raw Data” list in the File View 
Window. 
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Using a user-specified file name 
 

● Alternatively, the user can save the acquired spectrum using a user-specified filename. From the 
main menu, click File->Save As->Acquisition Window: 

 

 
 
Choose a desired directory, and input the file name. The file extension “.raw” (stands for “raw 
data”) is already there. Replace the “*” with the user-specified file name.  For this tour, save it as 
“Cyclohexane.raw”. Note that the filename is added onto the “Raw Data” list in the File View 
Window. (Note that your raw data file may not take the Adobe Photoshop file icon as in the figure 
below. See section “Save As” in Chapter 5 for an explanation). 
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Spectrum Processing / Analysis 
 
To perform data processing/analysis (smoothing, normalization, background removal, peak 
identification, peak area calculation, and spectrum subtraction) on the acquired spectrum, click on 
Analysis from the main menu.  

 

 
 

By default, a data processing/analysis method is applied to one spectrum at a time (note that 
Single Spectrum is checked by default). To set up a particular algorithm to use for each method, 
click Algorithm Setup…. The Analysis Setup window appears. Click on the page tab to bring up 
the algorithm setup page for a desired method. 

 

Smoothing 
 
● Click on the Smoothing tab in the Analysis Setup window to bring up the Smoothing Algorithms 

page. 
 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 4.  A Quick Tour 45

 
 

● Click on  in the Analysis Window Toolbar to clear the Analysis Window. In the File View 
Window, double click on the file name “Cyclohexane.raw” in the Raw Data list to bring the 
spectrum to the Analysis Window. 

 
● Click Apply to apply the default Savitzky-Golay smoothing algorithm to the spectrum. The 

smoothed spectrum is now displayed in the Analysis Window. 
 
● To save the smoothed spectrum, click File->Save As->Analysis Window: 

Save the smoothed spectrum as “CyclohexaneS.pro”. Note that this filename is added onto the 
“Processed Data” list in the File View Window. 
 

 
 

Normalization 
 
● Click on the Normalization tab to bring up the Normalization Settings page. 
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● Click on  in the Analysis Window Toolbar to clear the Analysis Window. In the File View 
Window, double click on the file name “Cyclohexane.raw” in the Raw Data list to bring the 
spectrum to the Analysis Window. 

 
● Click Apply to apply the default In Full Range normalization algorithm to the spectrum, which 

normalizes the spectrum to the maximum peak intensity. The normalized spectrum is now 
displayed in the Analysis Window. Note that the maximum intensity is scaled to 100 (arbitrary 
units) for a normalized spectrum. 

 
● To save the normalized spectrum, click File->Save As->Analysis Window and save the 

normalized spectrum as “CyclohexaneN.pro”.  
 

Background Removal 
 
● Click on the Background Removal tab to bring up the Background Removal Algorithms page. 
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● Click on  in the Analysis Window Toolbar to clear the Analysis Window. In the File View 
Window, double click on the file name “Cyclohexane.raw” in the Raw Data list to bring the 
spectrum to the Analysis Window. 

 
● Click Apply to apply the default Automatic algorithm to the spectrum, which automatically 

removes the background from the raw spectrum. The background-removed spectrum is also 
efficiency-corrected, and is now displayed in the Analysis Window. Note that the “baseline” of the 
spectrum is more flatly aligned up with the x-axis. 

 
● To save the normalized spectrum, click File->Save As->Analysis Window and save the 

background-removed spectrum as “CyclohexaneB.pro”. 
 

Peak Identification / Intensity Ratio 
 
● Click on the Peak ID tab to bring up the Peak Identification Algorithm page: 
. 
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● Click on  in the Analysis Window Toolbar to clear the Analysis Window. In the File View 
Window, double click on the file name “Cyclohexane.raw” in the Raw Data list to bring the 
spectrum to the Analysis Window. 

 
● Click Apply to apply Custom chosen peaks algorithm with 1% of peak threshold to the spectrum. 

This means that all peaks 1% or greater than the largest peak will be identified. The peak labeled 
spectrum is now displayed in the Analysis Window. Note that a peak table is also displayed, 
listing the peak position and peak intensity values along with an index number for each peak. 
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● To obtain the peak ratio of the identified peaks, click on the Intensity Ratio radio button under the 

Peak Ratio Calculation group box. The default algorithm is the ratio of the intensity of each peak 
to that of the first peak. Click Apply.  

 

 
 

Note that in the Peak List table, a Ratio column lists the intensity ratio values.  
 
● The user can save the peak list by clicking Save on the Peak List Window. Click Save to save it 

into a text file. A default name (e.g., Cyclohexane-PL.txt) is provided by the program. 
 

 
 

Peak Area / Area Ratio 
 
● Click on the Peak Area tab to bring up the Peak Area Algorithm page: 
.  
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● Click on  in the Analysis Window Toolbar to clear the Analysis Window. In the File View 
Window, double click on the file name “Cyclohexane.raw” in the Raw Data list to bring the 
spectrum to the Analysis Window. 

 
● Manual is the default method for peak area calculation. Click Apply, use cursor to draw a line at 

the base of the peak that the user regards as the baseline of the peak. Do the same to some 
other peaks. Right mouse click then gives a list of all the peaks labeled in the Analysis Window 
and all the areas are tabulated in the Peak Area List window. 
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● To obtain the peak ratio, click the Area Ratio radio button. The default algorithm is the ratio of the 
area of each peak to that of the first peak. Click Apply. 

 

 
 

Note that in the Peak Area List table, a Ratio column lists the area ratio values.  
 

● To save the peak area data listed in the Peak Area List window, click Save to save it into a text 
file. A default name (e.g., Cyclohexane-PA.txt) is provided by the program. 

 

Spectrum Overlay 
 

Spectrum Overlay allows multiple spectra to be plotted and viewed in the Analysis Window 
simultaneously.  

 
● From Analysis menu, check Spectrum Overlay. 
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● Click on  in the Analysis Window Toolbar to clear the Analysis Window. From the Raw Data 
list in the File View Window, click on files “Cyclohexane.raw”, “CyclohexaneS.raw”, 
“CyclohexaneN.raw”, “CyclohexaneB.raw”. The spectra are overlaid using different colors. 

 
● The overlaid spectra can be processed simultaneously using the smoothing or the normalization 

methods. Click  on the Analysis Window Toolbar to apply normalization to the spectra. All the 
spectra should be normalized to the maximum peak (the normalization algorithm used can be 

checked and changed by clicking  on the Analysis Window Toolbar and go to the 
Normalization page). 

  

 
 

● Note that on the Analysis Window Toolbar, only  and  are available. Click  to clear the 
Analysis Window, and click Analysis->Single Spectrum to switch back to the single spectrum 
display mode. 

 
 

System Automation 
 

All the data processing and analysis methods can be automated so that once a spectrum is 
acquired and displayed in the Acquisition Window, the pre-configured data processing/analysis 
method(s) can be applied to the acquired spectrum, and the processed spectrum is 
simultaneously displayed in the Analysis Window. 

 
● From Acquisition->Setup, change the filename prefix to “cycloSA”. 
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● From Analysis->Algorithm Setup, configure the algorithms desired. Set Background Removal and 
Peak ID algorithms as those in Section “Spectrum Processing / Analysis”. 

 
● From System->Automation->Setup, check Background Removal and Peak Identification, and 

click OK. 

 
 

● Click  on the Acquisition Window Toolbar to acquire a spectrum. If the Acquisition Window 
Toolbar is absent, click anywhere in the Acquisition Window to bring it up. 

 
● The raw spectrum is displayed in the upper Acquisition Window, and the background-removed 

and peak-labeled spectrum is displayed in the lower Analysis Window. 
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● Note that the processed spectrum is automatically saved with the filename prefix “cycloSA”, 
followed by a date and time string, and then by letter “B”, where “B” stands for background 
removal.  

 
 

RamanSoft Report 
 

The user can generate a hard-copy report of a data acquisition by printing out the spectrum and 
the system parameters associated with the data acquisition. 

 
● Click on File->Print Preview, the Print Selection window appears: 
 

 
 

 
● Check Print Analysis Window radio button, and click OK. The report is then shown in the print 

preview page. 
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● Press “Print” to print the report to your designated printer. 
 

Spectrum Searching 
 
To identify an unknown spectrum through the integrated RamanSoft and GRAMS Spectral ID® 
use the SpectrumSearch interface. The spectrum can be searched against a spectral library 
containing spectra of known materials.  

 

Launching the SpectrumSearch Application 
 

● From the main menu, click Tools->SpectrumSearch.  
  

 
 

Alternatively, the user can click on the SpectrumSearch icon  on the Function Toolbar: 
 

 
 

SpectrumPredict  
 Real Time Monitoring 
 File Open File Save Print Help SpectrumSearch 

 
● The SpectrumSearch user interface appears. 
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Note: For users who want to skip the library creation procedure and instead go directly to 

search a library, please proceed to section “Select and View Library”. 
 
 

 

Creating a New Library 
 
● Create a subfolder \Lib within the \Tour folder: C:\LSI\RamanData\Tour\Lib. 
 
● From SpectrumSearch main menu, click Library Management->Create New Library. 

 
● Browse to C:\LSI\RamanData\Tour\Lib and enter the name of the library “TourLib”. 
 

 
 
● Now the library is created but empty. The name of the library is displayed in the top right section 

of the SpectrumSearch user interface. 
 

 
 

Acquiring a Library Spectrum 
 

The spectra for library creation can be acquired either from RamanSoft main interface (see 
Section “Acquire a Spectrum” in this Tour) or from the SpectrumSearch interface. This section 
describes the method to acquire a library spectrum from the SpectrumSearch interface. 

 
● From RamanSoft main menu, choose System->CCD Configuration. Set the desired integration 

time. 
 
● From RamanSoft main menu, choose Acquisition->Setup. Set the desired repeats for each 

acquisition in the Frames Per Measurement textbox. In the Path field under File Auto Save, enter 
C:\LSI\RamanData\Tour\Lib\LibData. Enter sample name and file prefix. Note that the files in 
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\LibData are not used for library creation, but as they are in LSI format, they can serve as a future 
reference for the library spectra. 

 
● From RamanSoft main menu, choose Analysis->Algorithm Setup. Go to the Background Removal 

page. Make sure that the Automatic radio button is checked.  
 
● From RamanSoft main menu, choose System->Automation->Setup. Make sure that (only) the 

Background Removal checkbox is checked. This is to ensure that the spectra acquired and 
entered into the library will have a flat background. 

 
● In Spectrum Acquisition and Search window, choose Acquire New Spectrum. 

  

 
 
● In the Chemical Name field, enter the name of the sample, for example, Cyclohexane. Be sure to 

enter a meaningful name for the sample, as this is the name of the sample that is to be stored in 
the library when the spectrum is added to the library and that is to be retrieved from the library 
when a search is performed.  

 
● In Save Spectrum As File Name field, enter the file name and path where the library spectrum is 

going to be saved, for e.g., C:\LSI\RamanData\Tour\Lib\Cyclohexane.spc. The saved SPC files 
are to be used for library creation. 

 
● In Spectrum Acquisition and Search group box, click Save Spectrum. The spectrum is acquired 

and saved.  
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● Repeat this procedure to acquire other library spectra. 
 

 

Adding a Spectrum to the Library 
 
● Click on Library Management->Add New Spectrum. Browse to C:\LSI\RamanData\Tour\Lib where 

the library spectra were saved. Select the filename (in GRAMS SPC format), and click OK.  
 

 
 
● The Select Library window appears. Highlight the library where the spectrum is going to be 

added. 
 

 
 
● The spectrum is now added to the library. On the top right section of the SpectrumSearch 

interface, only a Row Status is shown. 
 

● Repeat this procedure to add the rest of the spectra into the library. 
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Selecting and Viewing Library 
 

● From the main menu of SpectrumSearch module, choose Library Management->View Library. 
 

● The Select Library window appears. Highlight the library item C:\LSI\RamanData\Tour\Lib 
\tourlib.lib. Click OK. 

 

 
 
 
 
 
 

Click OK, go to Library Management->Add Library to List, browse to the directory 
C:\LSI\RamanData\Tour\Lib, select file “TourLib”, and click Open. 

 
 

Note: For users who skipped Library Creation and had proceeded directly to here from 
subsection “Start SpectrumSearch Application”, the following window may appear. 

 
 
 
 
 
 
 
 
 
 
 

 
● All the library entries are displayed on the top right hand section of the SpectrumSearch interface. 
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Setting Search Configuration 
 

● In the Spectrum Search section of the SpectrumSearch main interface, select the desired 
algorithm (the default algorithm is Correlation algorithm) to perform a full spectrum Search, leave 
other options in their default settings. 

 

 
 

Performing a Spectrum Search 
 
● Put an “unknown” sample (e.g., cyclohexane as supplied or any other sample) into the internal 

sample cell or External Sampling Module. From RamanSoft main menu, set acquisition 
parameters such as CCD integration time (this can be left as 1 sec). From System->Automation-
>Setup, check Background Removal. Uncheck other options. In Acquisition->Setup, set the 
number of frames to repeat (this can be left as 1). Type in file Path as “C:\LSI\RamanData\ 
Tour\Lib\LibData”, Sample Name as “Unknown Sample”, File Prefix as “UnknSample”. 

 
● Under Spectrum Acquisition and Search, type in Chemical Name as “Unknown Sample”. 
 

 
 
 Note: The laser may turn off automatically if the system has been idle for more than 30 

minutes. Make sure that the laser is on by checking System->Laser Setting->Laser On 
before pressing Start Search. 

 
 
 
 
● Press Start Search to start spectrum acquisition followed by spectrum searching, in one-step. 
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Viewing Search Results 
 

● On the SpectrumSearch interface, the top right section lists the matched library items in a 
decreasing “goodness-of-match” order. The middle right section displays the spectrum of the 
unknown sample (top plot) and the spectrum of the best match library spectrum (lower plot). In 
the lower right section, other matched spectra can be viewed through the Library Hit Spectrum 
Selection pull-down selection, along with the score (Hit Quality), as well as the Chemical Name of 
the matched library spectrum. The figure shows the search results of the “unknown” sample 
cyclohexane. Note that in the Type Raw scoring scheme, the lower the score, the better the 
match. For the tour example shown below, the match score was 4.747449E-03, or ~ 0.005, which 
indicates an excellent match. 

  

 
 
● The search results are also saved in a text file located in the same folder as the library spectrum. 

For e.g., C:\LSI\RamanData\Tour\Lib\UnknSample.txt. 
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● From SpectrumSearch interface, Click File->Exit to exit the SpectrumSearch application. 
 
 

Predicting a Spectrum 
 

To predict an unknown spectrum either qualitatively (find a match to a known group of samples) 
or quantitatively (find the composition of a sample of known ingredients) using the integrated 
RamanSoft and GRAMS IQ PredictTM interface SpectrumPredict, a calibration file needs to be 
pre-established through GRAMS/AITM with PLSplus/IQTM add-on.  An unknown sample spectrum 
can then be acquired and predicted through SpectrumPredict. 

 

Building a Calibration File 
 

● For the tour purpose, a calibration file (Cal file) has been pre-built (this is also necessary for 
customers who opt to get Thermo Electron’s IQ PredictTM alone instead of the full package of 
GRAMS/AITM with PLSplus/IQTM add-on). The Cal file, along with the training data set that was 
used to build the Cal file, is located at C:\LSI\RamanData\Tour\Predict. The training data set 
consists of 11 samples of cyclohexane (Constituent 1) and methylene chloride (Constituent 2) at 
various proportions. Note that for real applications, much larger sample sizes (25 samples or 
above) are recommended to create more refined calibration files and thus to obtain more precise 
predictions. 

 
● For users who would like to build their own calibration file, please refer to Thermo Electron’s 

PLSplus/IQTM User Guide to do so. 
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Launching the SpectrumPredict Application 
 

● From RamanSoft main menu, click Tools->SpectrumPredict.  
 

 
  

Alternatively, the user can click on the SpectrumPredict icon  on the Function Toolbar: 
 
 

 
SpectrumPredict  

 Real Time Monitoring  File Open File Save Print Help SpectrumSearch 
 

 
● The SpectrumPredict user interface appears: 

  

 
 

Configuring Prediction Settings 
 

● From the SpectrumPredict menu, choose Configuration->SpectrumPredict Settings.  The 
SpectrumPredict Configuration window appears. Accept the default settings by clicking OK. 
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Configuring Spectrum Acquisition Parameters 
 
● From RamanSoft main menu, choose System->CCD Configuration. Set the desired integration 

time. For the tour, the integration time can be left as 1 sec. 
 
● From RamanSoft main menu, choose Acquisition->Setup. Set the desired number of frames to 

repeat (can be left as 1) for each acquisition in the Frames Per Measurement textbox. In the Path 
field under File Auto Save, enter C:\LSI\RamanData\Tour\Predict. Type in Sample Name and File 
Prefix as “Sample”. 

 
● From RamanSoft main menu, choose Analysis->Algorithm Setup. Click on the Background 

Removal page tab. Make sure that the Automatic radio button is checked, and click the Apply 
button. 

 
● From RamanSoft main menu, choose System->Automation->Setup. Make sure that the 

Background Removal checkbox is checked (and that no other options are checked). This is to be 
consistent with the fact that the Cal file is built with the automatic background removal feature 
turned on. 

 
● From SpectrumPredict interface, check Acquire New Spectrum under Spectrum Acquiring  / 

Loading. Type in the file path/name as C:\LSI\RamanData\Tour\Predict\Sample.spc. 
 

 
 

Loading Calibration File and Performing Spectrum Prediction 
 

● From SpectrumPredict interface, click Browse button under IQ Predict (Select Cal File). 
 
● The Select Cal File Name window appears. Browse to C:\LSI\RamanData\Tour\Predict to locate 

the calibration file (CHMCB.cal). Click Open. 
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● The calibration methods (experiments) built in the calibration file are loaded and displayed in the 

text window. 
 

 
 

 
 
 
 
 

Note: The laser may turn off automatically if the system has been idle for more than 30 
minutes. Make sure that the laser is on by checking System->Laser Setting->Laser On 
before pressing Predict. 

 
● Put the “unknown composition” sample cyclohexane (or a mixture of cyclohexane and methylene 

chloride if they both are available; please note these are volatile solvents and thus care should be 
taken in order to prepare defined compositions) in the internal sample cell or External Sampling 
Module. Press Predict to perform spectrum prediction.  

 

Viewing Prediction Results 
 

● The prediction results are displayed in the SpectrumPredict main interface.  
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The top right section shows the itemized prediction results for each constituent in the sample by 
each calibration method. The bottom right section displays the sample spectrum (top panel) and 
the residual spectrum (bottom panel). The bottom left section displays all the prediction results for 
each item, where an item corresponds to a row in the top right section of the interface. 

 
● The prediction results can also be viewed by pressing Report on the SpectrumPredict interface. 

The results can be saved as Rich Text File (RTF) or as plain text file (.txt), or can be printed out.  
  

 
 
● From SpectrumPredict interface, click File->Exit to exit the SpectrumPredict application. 
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Monitoring a Process in Real Time 
 

To monitor a process in real time, a peak (or up to five peaks) of interest need to be identified first 
from the spectrum of the sample of interest. Either the peak intensity or the peak area can then 
be followed as a function of time. 

 

Launching Real Time Monitoring Application 
 

● From the main menu, choose Tools->Real Time Monitoring…. 
 

 
Alternatively, the user can click on the Real Time Monitoring icon  on the Function Toolbar: 
 

 
 

SpectrumPredict  
 Real Time Monitoring 
 File Open File Save Print Help SpectrumSearch 

 
 

● The Real Time Monitoring main interface appears as follows. 
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Setting Acquisition Parameters 
 

● From RamanSoft main menu, choose System->CCD Configuration. Set the desired CCD  
integration time. For the tour, the integration time can be left as 1 sec. 

 
● From RamanSoft main menu, choose System->Automation->Setup. Uncheck the Background 

Removal option or other options. 
 
● From RamanSoft main menu, click System->Automation->On. This is to enable auto file saving 

when no option is selected in the Automation Setup window. 
 
● From RamanSoft main menu, choose Acquisition->Setup. Set the desired frames to average for 

each acquisition in the Frames Per Measurement textbox as 1. In the Path field, enter 
C:\LSI\RamanData\Tour\RTM. This is the directory where the real time monitoring data will be 
saved. Enter Sample Name and File Prefix as “Cyclohexane”.  

 
● Put the sealed cyclohexane standard sample in the sample cell. Click Acquisition->Acquire or  

 on the Acquisition Window Toolbar to acquire a cyclohexane spectrum. 
 
● Find the start and end positions of the peaks to be monitored. 
 

Setting Real Time Monitoring Configuration 
 

●  From the Real Time Monitoring main menu, choose Configuration->Configuration Setup.  
 

● Enter the Sample Name, select the Number of Peaks to follow, and enter the Peak Start Pos and 
Peak End Pos for each peak. Use Default Speed as the acquisition speed.  

 
● Enter # of Time Points as 20, Time Interval as 0 seconds. Type in the core file name in the Input 

Core File Name textbox. This core file name is to be followed by an index number at each time 
point, which together makes up the filename for the spectrum at each time point. Check the Peak 
Intensity and Peak Ratio radio buttons. As the time interval between consecutive monitoring 
points is zero, it is recommended that the Keep Shutter on During Measurement is checked.  
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Starting Real Time Monitoring 
 

● From the Real Time Monitoring interface, press Start. 
 
● The progress of the monitoring process can be viewed through the progress bar. The peak 

intensity ratio values for each of the monitored peaks are tabulated in the text window with the 
Index indicating the sequential time points and Time Elapsed displaying the actual time elapsed 
since the monitoring was initiated. The peak intensity ratio values for each of the monitored peaks 
are plotted in the bottom plot window at each time point 

  

 
 

● Note that at the end of the real time monitoring, RamanSoft takes one additional acquisition of the 
sample using the settings prior to Real Time Monitoring application to restore the parameter 
settings for RamanSoft. 

 

Saving Monitoring Results 
 

● When the real time monitoring session is finished, the user is prompted to save the monitoring 
results (the peak intensity/area values vs. time elapsed) into a text file. 

 

 
 
 

This text file can later be loaded into the Real Time Monitoring interface to view the results.  
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● Click on Yes to save the results in the same folder as the Real Time Monitoring data file, for e.g., 
C:\LSI\RamanData\Tour\RTM\CHRTM.txt. 

 

 
 
● From the Real Time Monitoring menu, choose File->Exit to exit the Real Time Monitoring 

application. 
 
 

Exiting RamanSoft  
 

● Make sure that all three function modules (SpectrumSearch, SpectrumPredict, and Real Time 
Monitoring) are exited.  

 
● From RamanSoft main menu, choose File->Exit. The user is asked whether to save the 

configuration used in the RamanSoft session Using Current File Name (i.e., Default.rcf) or Using 
a New File Name. 
 

 
 

● Check Using a New File Name radio button to save the configurations as your personal 
configuration file to be used for a future RamanSoft session. 
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● Press Save. The Save As window appears. Browse to C:\LSI\RamanSoft\Configuration (where 
the Default.rcf configuration file is located), and input the new configuration file name. 

 
● Click Save in the Save As window. The new configuration file is then created and RamanSoft is 

exited. 
 

 

Turning off Dimension-P Raman 
 
• Turn off the computer. 
 
• Turn the Laser Power key to the OFF position. 
 

 

● Turn off the power switch of Dimension-P Raman on the back panel of the unit. 
 

DRS-RS1.3-UM-2006-06-26 
 
 



72 

5 RamanSoft Basic Functionalities 
 
 

Upon RamanSoft Start-up 
 

Selecting a Configuration File 
 

When RamanSoft is first started, it asks the user to select a RamanSoft configuration file (.rcf 
file). This file contains settings that the user had previously used in RamanSoft, such as the 
configurations for data acquisition, data processing, and data analysis. If the user hasn’t had a 
configuration file yet, the Default.rcf file can be used. Default.rcf contains default settings pre-
configured by the program. Upon exiting RamanSoft, the user can save the configurations used in 
the RamanSoft session into a new file.   

  

 
 

CCD Operating Temperature Warning Window 
 

When RamanSoft is first started or when a new demand temperature is set, a temperature 
progress status bar will appear to inform the user when the desired temperature is reached. 

 

 
 

Laser Power Stabilizing Window 
 

When the system is first started or when the laser is turned on, a Laser Power Stabilizing 
Progress Window is brought up to warn the user to wait (for about 15 seconds) for the laser to 
stabilize. Note that RamanSoft automatically turns the laser off when the system has been idle for 
more than 30 minutes. The system automatically turns the laser on when an acquisition starts. 
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System Test Prompting Window 
 

When the system is first started, the System Test Prompting Window appears. A system test 
checks whether the instrument needs to be recalibrated or not by comparing the acquired 
spectrum from the sealed cyclohexane standard sample to the standard cyclohexane spectrum 
stored in the system. The user can opt to perform or skip the system test.  

 

 
 

If the user clicks OK , a system test dialog window will then appear to allow the user to perform a 
system test, and the user will get test results instantly to decide whether the system needs to be 
recalibrated or not (for details, see Section “System Test” in this chapter). If the user clicks Skip, 
the user can then proceed to use the system assuming that the system stays calibrated and do 
not need a re-calibration. 

 
 

The Main Menu, System Toolbars, and Frame Status Bar 
 

The Main Menu 
 

The main menu contains File, Edit, System, Acquisition, Analysis, Tools, View, and Help menu 
items. The function of each is described in detail in the following sections. 

 

 
 

System Toolbars 
 

The full system toolbar includes the Function Toolbar, the Acquisition Window Toolbar, and the 
Analysis Window Toolbar. 

 

 
 

 
 Analysis Window Toolbar Function Toolbar  Acquisition Window Toolbar 
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The Function Toolbar 
 
The Function Toolbar consists of standard Windows® tools such as file open, save, and print, as 
well as the RamanSoft system tools SpectrumSearch, SpectrumPredict, and Real Time 
Monitoring. 
 

 
 

SpectrumPredict  
 Real Time Monitoring 
 File Open SpectrumSearch File Save Print 
 

Help 

 
The Acquisition Window Toolbar 
 
The Acquisition Window Toolbar is active after clicking anywhere in the Acquisition Window.  

 
 

 
View CCD Image  

 Stop Continuous AcquiringGrid On / Off 
Zoom  Acquire Continuously View Cursor  Start Acquisition 

 
 

The Analysis Window Toolbar 
 
The Analysis Window Toolbar is active after clicking anywhere in the Analysis Window. 
 
 Clear Spectrum in Analysis Window Apply Smoothing  View Cursor Grid On / Off 
 
 

 
 

Apply Normalization  
Algorithm Setup 

Zoom  
 

Apply Peak Area Calculation  
 Apply Peak Identification  

Apply Background removal

 

Frame Status Bar 
 

The frame status bar which appears at the bottom of the user interface gives the x, y-coordinates 
of a point on a spectrum that is displayed in the Acquisition Window or in the Analysis Window. 
This point is identified by applying the View Cursor from the Acquisition Window Toolbar or 
Analysis Window Toolbar. 
 

 
 
The x-coordinate of the spectrum point can be displayed by its pixel, wavenumber, or wavelength 
value. When it is displayed in wavenumber or wavelength, the units are in “cm-1” and “nm”, 
respectively. The y-axis is the intensity value in arbitrary unit. The above figure gives an example 
of the frame status bar when the x-axis is displayed in wavenumber. 
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The File Menu 
    

The File menu consists of Open, Save As, Save, Preferences, Print, Print Preview, Print Setup, 
and Exit sub-menu items.   

 
 

Open 
 

This allows the user to open the raw spectrum files (*.raw) or the processed spectrum files (*.pro). 
Raw spectrum files and processed spectrum files, also termed collectively as “LSI formatted”, are 
in binary file format; they are the two fundamental file types of RamanSoft. 
 

 
 

(Note that if one of the raw spectrum files in the directory was opened by double-clicking on the 
file name while the Adobe Photoshop program is active on the desktop, all the raw data files will 
be displayed in the Adobe Photoshop icons.) 
 
The user can select and open multiple files from the same directory: 
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and bring the files onto the Raw Data list or the Processed Data list on the RamanSoft File View 
Window. One of the files is automatically displayed on the Analysis Window. 
 

 
 

Save As  
 

This allows the user to save a spectrum displayed in the Acquisition window as a raw spectrum 
file (*.raw), or save a spectrum displayed in the Analysis Window as a processed spectrum file 
(*.pro).  
 

 

 
 

Note that a spectrum displayed in the Analysis Window can also be saved as a raw spectrum file 
(*.raw). This accounts for the need that when the user opens a raw spectrum file, the raw 
spectrum will be displayed in the Analysis Window, and the user can save the spectrum without 
doing any data processing but just wanting to save it into a different file name (in .raw). 
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Save 
 

When the user clicks on the Save submenu, the raw spectrum displayed in the Acquisition 
Window will be saved with a system-generated filename consisting of a header (defined by the 
user as File Prefix in Acquisition->Setup), and a trailer (date + time, i.e., hours + minutes + 
seconds) generated by the system when the data was acquired. For example, 
“cyclohexane0203101325.raw”. The saved spectrum is displayed in the Analysis Window and the 
filename is added onto the “Raw Data” list in the File View Window. 

 

Preferences 
 

The Preferences submenu allows the user to choose the file save formats. By default, all the file 
formats, which includes LSI Format (*.raw/*.pro), Text Format (*.txt), and GRAMS Format (*.spc), 
are selected. The LSI Format is a binary file format, and the Text Format is a plain text format 
allowing the user to import the spectrum data into any program that supports this file format.  
 

 
 

Saving files in GRAMS Format (*.spc) allows these files to be directly opened by a Thermo 
Galactic software such as GRAMS/AITM 7.0, Spectral ID®, etc. We recommend that all spectra be 
saved in .spc so that they will be readily available for all GRAMS functionalities, however, the 
program allows the user to choose not to save the files in GRAMS SPC file format. To do this, 
just deselect the checkbox for GRAMS Format (*.spc). 

 

Print / Print Preview 
 

When File->Print or File->Print Preview is chosen, the Print Selection window will appear.  
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Print Acquisition Window allows for printing the spectrum displayed in the Acquisition Window, 
along with the system parameters and file information such as CCD temperature, CCD integration 
time, date/time, file name and path, operator name, sample name/info.  
 
Print Analysis Window allows for printing the spectrum displayed in the Analysis Window, along 
with system parameters, file info, and analysis results if Peak Identification or Peak Area analysis 
methods were chosen. 
 
Print Log Report allows for printing the log file (a log file records all user activities for the current 
RamanSoft session). 

 
If the user has chosen File->Print Preview and clicked OK in the Print Selection window, the print 
preview window will appear. The following figure shows the print preview of a peak-identified 
spectrum in the Analysis Window, along with the identified peak positions and peak intensities. 

 

 
 

 

The Edit Menu 
 

The Edit menu contains two submenu items, Copy Acquisition View and Copy Analysis View.  It 
allows for copying the spectrum displayed in the Acquisition Window or in the Analysis Window to 
other applications, such as Microsoft Word, Adobe Photoshop, Microsoft PowerPoint etc. 

 

 
 

The following figure is generated by clicking on Edit->Copy Analysis Window and then pasting 
(ctrl+V) it here in this Word document: 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 5.  RamanSoft Basic Functionalities 79

 

 
 
 

The System Menu 
 

The System menu contains the following submenu items: Instrument, Laser Setting, CCD 
Configuration, System Test, Calibration, Live Video Configuration, SpectrumSearch, 
SpectrumPredict, and Automation. 

 

 

Instrument 
 

The graphic user interface (GUI) for RamanSoft has two modes: the On Line mode and the Off 
Line mode.  

 

 
 

On Line 
 

In the On Line mode, the acquired data is displayed in the upper Acquisition Window, and the 
processed data achieved through system automation is simultaneously displayed in the lower 
Analysis Window.  
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Acquisition Window  
 

  

File View Window 

 Analysis Window 
 

The On Line mode contains three view panels as shown above. The Acquisition Window displays 
the raw spectrum, the Analysis Window displays the processed spectrum when system 
automation is turned on, or a spectrum retrieved from the file system through File->Open. The 
File View Window displays the lists of raw and processed spectrum files in the current RamanSoft 
session. The ToolTip (mouse pointing to a filename) shows file info such as date, time, CCD 
temperature, integration time etc. The On Line mode is designed to provide the user with the 
options to acquire a spectrum and perform data processing simultaneously, or to perform data 
processing/analysis on previously acquired spectrum in the Analysis Window and in the mean 
time to acquire new spectrum in the Acquisition Window. 
 
Off Line 
 
In the Off Line mode, only the File View Window and the Analysis Window are available; the 
Analysis Window occupies a larger screen area for better data display compared to that in the On 
Line mode. 
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Analysis Window 
 

 

File View Window 

 
The Analysis Window displays the spectrum retrieved through File->Open, and the File View 
Window displays the raw or processed spectrum file lists with ToolTip showing file info such as 
file date, time, CCD temperature, integration time etc. 

 

Laser Setting 
 

The Laser Setting submenu items provide the user with the convenience of switching laser on/off, 
shutter on/off, adjusting laser power, and calibrating laser power.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 Laser On 

  
The user can turn the laser on or off by clicking on the Laser On submenu item, providing that the 
Laser Key is at the ON position on the front panel of the Dimension-P Raman unit. A check mark 
to the left of Laser On indicates that laser is turned on. The absence of this check mark (by 
clicking on Laser On again) indicates that the laser is turned off.. 

 
Shutter On 
  
The laser shutter can be turned on/off by checking or un-checking the Shutter On submenu item. 
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Power Adjustment 
  
The Power Adjustment submenu activates the Laser Power Adjustment window. It displays the 
current laser power reading and the laser status, and provides switching On/Off the laser shutter. 
The user can adjust the laser power by using the slide bar or by entering the voltage value in the 
textbox under Adjusting Laser Power group box. Note that the user needs to make sure that the 
On radio button for Laser Shutter is checked while resetting the laser power. 

 

 
 

Power Calibration 
  
The Power Calibration submenu item lets users calibrate the laser power versus voltage input 
readings by checking the Enable Calibration radio button. Once this radio button is checked, it 
enables the user to enter up to ten input voltages (V) and power (mW) value pairs. The laser 
voltage is entered through the Reset To edit box under Set Laser Voltage group box, and the 
corresponding laser power should be read directly off the power meter that the user uses. Once 
done, click on the Calibrate button and RamanSoft recalibrates the laser power as a function of 
the input laser voltage. Note that in order to get power readings from the power meter during the 
calibration process, Laser Shutter has to be at On position. 
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CCD Configuration 
 

Choosing CCD Configuration from System menu activates the CCD Camera Parameter Setup 
window, which contains all controls for operating the CCD camera. 
 

 
 

 
CCD Temperature Control 
 
The temperature can be set as low as –80°C. But for practical purposes and for the speed of 
cooling we suggest -70 – -75°C as the lowest target temperature. 
  
CCD Integration Timer Control 
 
This permits the user to set the integration time over which a spectrum is acquired. For most 
samples, an integration time of 1 second provides a good spectrum. 
 
CCD Acquisition Speed 
 
This lets the user choose Normal Speed versus Fast Speed. At Normal Speed, the CCD 
digitization rate is set at 100 kHz, whereas at Fast Speed, the CCD digitization rate is set at 2 
MHz. Normal Speed is the default choice for CCD Acquisition Speed; it gives better signal-to-
noise ratio, but it imposes greater overhead time which is mainly caused by the CCD readout time 
which, in turn, is dependent on the digitization rate.  
 
For Real Time Monitoring applications this overhead time will affect fast process monitoring. An 
integration time of 50 milliseconds and above at 100 kHz yields acceptable linearity (for e.g., 200 
milliseconds integration time yields 4 times the intensity of that of 50 milliseconds). Thus for high 
speed monitoring we recommend the Fast Speed. While the Fast Speed mode does not give the 
maximal signal-to-noise characteristics as that of the Normal Speed mode, it reduces the 
overhead time and makes monitoring at acquisition times below 50 milliseconds more practical. 
At 2 MHz, linearity can be achieved down to 10 milliseconds. The user is encouraged to see more 
details on “Acquisition Speed” in Chapter 8, the Real Time Monitoring Module. 
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Camera Gain Settings 
  

The CCD camera gain settings can be set from 1 to 3, with 3 being the highest gain. The readout 
intensity is reduced by approximately 2 fold for each decrement in gain. By default, gain setting 3 
is used. The user may wish to use a lower gain when at a given integration time when the 
intensity values are close to or above the maximum CCD readout value (i.e., 65,536, or 216 for a 
raw spectrum), especially for samples with strong fluorescence background. 

 

System Test 
 

Every time RamanSoft is started the user is prompted with the System Test Window. In addition, 
the System Test menu item provides the user an opportunity to perform a system test at any time 
during a RamanSoft session. It is recommended that the user perform system test daily to make 
sure that the instrument remains calibrated so that any data acquired are accurate. 
 

 
 

To Skip System Test 
 
Press Skip, the three-window panel RamanSoft GUI then appears and the user is ready to use to 
system assuming that the system stays calibrated..  
 
To Perform System Test 
 
1. Press OK. The System Test… window appears. 

 
2. Put the sealed cyclohexane standard sample into the internal sample cell or External 

Sampling Module, and check Step 1 checkbox. 
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3. Press Run Test button in Step 2 group box. The system takes the cyclohexane spectrum, 

identifies the cyclohexane peaks, and updates the System Test window with test results. 
 
System Test for Dimension-P1 HR Raman System. 

 
 

System Test for Dimension-P1 SR Raman System. 
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4. View Test Report. The program uses 8 cyclohexane peaks for the system test of Dimension-
P1 High Resolution (HR) models and the first 10 cyclohexane peaks for the system test of 
Dimension-P1 Standard Resolution (SR) models, respectively, as labeled in the above 
figures. It compares the position and intensity of each peak to those of the cyclohexane 
standard spectrum stored in the system. The differences in the peak position and peak 
intensity (Delta Wavenumber, Delta Intensity, the second and third column in the Test Report 
panel) are calculated for each of the seven peaks. If any of the Delta Wavenumber values is 
larger than the Wavenumber Tolerance set by the system, the system test is judged as 
“Failed” and the user is suggested to perform the Wavelength Calibration and Laser 
Wavelength Calibration, the two of the three calibration procedures that ensure correct x-
positions of the peaks in the System Calibration routine (please refer to section “Calibration” 
for details on System Calibration) (see below figure).  Likewise, if any of the Delta Intensity 
values is larger than the Intensity Tolerance set by the system, the system test is also judged 
“Failed” and the user is suggested to perform the Intensity Calibration, the procedure that 
ensures the correct intensity values of the peaks. If both failed, then the user is suggested to 
perform all three system calibration routines. 

 

 
 

Calibration 
 

Choosing Calibration from the System menu brings up the System Calibration window, which 
outlines the three calibration steps.  
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System calibration is performed with the LSI Calibration Kit. To do this, the user needs to insert 
the Vector Raman Probe into the LSI Calibration Kit as shown below, turn the adjustable aperture 
to allow highest (but not saturated) signal intensity.  
 

 
 

Wavelength Calibration 
 
The user can choose a Mercury/Argon lamp to perform auto wavelength calibration or any other 
standard lamp to perform manual wavelength calibration with the Vector Raman Probe and the 
Calibration Kit.   

 
Auto Wavelength Calibration 
 
1. From the main menu, choose System->CCD Configuration to set the New Integration Time to 

be 1 second. 
 
2. Check Wavelength Calibration checkbox in the System Calibration window, and check Use 

Mercury/Argon Lamp radio button. Press the Calibrate button. 
 

3. The program starts the acquisition of the mercury/argon lamp spectrum, and automatically 
identifies the mercury lamp peaks used for auto wavelength calibration. 
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Mercury Lamp Calibration Peaks for Dimension-P1 HR Raman System. 

 
 

For Dimension-P1 high resolution (HR) models, the program uses 12 standard 
Mercury/Argon peaks (as labeled in the above figure and tabulated in the Wavelength 
Calibration Window below) to perform the wavelength calibration (see Appendix II for a full-
page view of the above figure where the 12 standard peaks can be clearly discerned, and a 
table for the mercury/argon lamp peak wavelengths). 
 
Mercury Lamp Calibration Peaks for Dimension-P1 HR Raman System. 

 
 

For Dimension-P1 standard resolution (SR) models, the program uses 14 standard 
Mercury/Argon peaks (as labeled in the below figure and tabulated in the below Wavelength 
Calibration Window) to perform the wavelength calibration (also see Appendix II for a full-
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page view of the below figure where the 14 standard peaks can be clearly discerned, and a 
table for the mercury/argon lamp peak wavelengths). 
 
Mercury Lamp Calibration Peaks for Dimension-P1 SR Raman System. 

 
 

 
 

Mercury Lamp Calibration Peaks for Dimension-P1 SR Raman System. 
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The pixel position of each peak as identified by the program is displayed in the Pixel column 
in the Wavelength Calibration Window. To increase the calibration accuracy, the program 
employs a cubic spline interpolation procedure to improve peak symmetry and thus obtain 
true peak positions. The fractional pixel number in the Pixel column results from this 
interpolation procedure. The corresponding standard wavelengths (in nm) of the mercury 
lamp peaks are displayed in the Lambda column. If all the peaks are correctly identified (after 
user’s verification), the user can press Continue and the system automatically finishes the 
wavelength calibration. 
 
 
 

Note: Note that the pixel numbers in the above figure and in Appendix II serve as a 
guide. The exact pixel numbers will depend on a specific instrument calibration. 

 
 
We recommend that the user change the aperture setting on the Calibration Kit, press the 
Clear All button on the tabulation screen, and repeat the auto wavelength calibration 
procedure. Statistics indicates that auto wavelength calibration at the top three aperture 
settings yields identical and correct results for >98% of the time. 
 
Manual Editing During Auto Wavelength Calibration 
 
If the program identifies wrong or extra peaks, i.e., it misses or assigns extra pixel numbers in 
the Pixel column, the user can use the Insert or Delete button to insert/delete the correct pixel 

numbers for those missing/extra peaks (use View Cursor  in the Analysis Window Toolbar 
to manually identify those peaks first), and then press Continue to finish the wavelength 
calibration.    
 
For example, the following figure shows a scenario where an extra peak (Peak 10 or 11) has 
been assigned to the Pixel column. 
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By zooming in to the peak 10 and peak 11 region as shown in the below figure, we can 
identify that the extra peak is peak 10. 
 

 
 
Highlight or hold the left mouse button down in the Peak 10 Pixel column as shown below, 
 

 
 
and click on Delete button, the extra peak 10 is then deleted from the Pixel column. The next  
pixel value, 588, which is the correct pixel corresponding to wavelength 866.794 nm, is 
shifted up.  
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The user can then press the Continue button, and the system automatically finishes the 
wavelength calibration. 
 
If a peak is not identified by the program and thus is not displayed in the Pixel column, the 
user can use the same procedure as described above to add the missed pixel number in. 
First, highlight or hold the left mouse button down in the peak textbox right after the missing 
peak, click on the Insert button, a new textbox with the same pixel number will then be 
inserted. Type in the right peak pixel number of the missing peak in the textbox. Once the 
user has confirmed all the peak readings, the user can then click on the Continue button, and 
the system will automatically finish the wavelength calibration. 
 

 
Manual Wavelength Calibration 
 
1. From the main menu, click on System->CCD Configuration to set CCD Integration Time to be 

1 second.  
 
2. Check Wavelength Calibration checkbox in the System Calibration window, choose Use 

Other Lamp. Press the Calibrate button. 
 

3. RamanSoft will start acquiring the lamp spectrum and performing peak identification on the 
spectrum in the Analysis Window. 

 
4. A dialog window will appear as shown below, which allows the user to manually enter the 

pixel numbers and the corresponding wavelength (in nm) values of the peaks that the user 
chooses to use for the calibration. The maximum number of peaks that can be used for the 
manual wavelength calibration is 20. 
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5.  Once finished, the user can click on the Continue button, and RamanSoft will perform the 
calibration accordingly. 

 
 

Intensity Calibration 
 

The intensity calibration can be performed with the LSI Calibration Kit and Vector Raman Probe 
according to the following steps: 

 
1. Check the Intensity Calibration checkbox in the System Calibration window. 
 
2. Turn on a NIST traceable blackbody radiator (e.g., LS-1-Cal calibration lamp from Ocean 

Optics) for 20 to 30 minutes to allow it to reach equilibrium.  
 

3. Attach the calibration lamp and the Vector Raman Probe to the LSI Calibration Kit. 
 

4. From the main menu, click on System->CCD Configuration to set CCD Integration Time to  
be 1 sec.  

5. Click on Acquire->Continuous Acquire (or click  on the Acquisition Window Toolbar) so 
that the calibration lamp spectrum is displayed continuously in the Acquisition Window.  
 

6. Adjust the aperture of the Calibration Kit to obtain the optimum Intensity level for the 
calibration lamp spectrum (maximum intensity without saturation). Once the calibration lamp 
spectrum reaches the optimum Intensity level, click on Acquisition->Stop Acquire or press 

 to stop the continuous acquisition. 
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Continuous acquisition of the LS-1-Cal (Ocean Optics, Inc.) calibration lamp spectrum on 
a Dimension-P1 HR Raman System. 

 
 

The LS-1-Cal (Ocean Optics, Inc.) calibration lamp spectrum on a Dimension-P1 SR 
Raman System. 

 
 

7. Click on the Calibrate button in the System Calibration window, RamanSoft acquires the 
calibration lamp spectrum and performs the Intensity calibration automatically.   
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Laser Wavelength Calibration 

  
Laser wavelength calibration can be performed in auto mode (with user validation) using the 
sealed cyclohexane standard sample or in manual mode using any other standard sample that 
the user chooses.  
 
Auto Laser Wavelength Calibration 
 
1. Check the Laser Wavelength Calibration checkbox in the System Calibration window. 
 
2. Put the sealed cyclohexane standard sample in the sample holder. Click on System->CCD 

Configuration to set the New Integration Time to be 1 sec. 
 
3. Click on the Calibrate button. RamanSoft starts to acquire the cyclohexane spectrum and 

identifies the pixel position of the maximum peak, which are shown below and also in full-
page view in Appendix III. 

 
The maximum cyclohexane peak identified on a Dimension-P1 HR Raman System.  
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The maximum cyclohexane peak identified by Dimension-P1 SR Raman. 

 
 

4. The Laser Wavelength Calibration… window appears displaying the identified pixel number 
and the corresponding Raman shift of the maximum peak of cyclohexane (801.1 cm-1). 
Similar with the Wavelength Calibration, the program utilizes cubic spline interpolation 
procedure to improve calibration accuracy, and thus the pixel number might be fractional. 

 
The pixel position and the Raman Shift of the maximum cyclohexane peak identified on a 
Dimension-P1 HR Raman System. 

 
 

The pixel position and the Raman Shift of the maximum cyclohexane peak identified on a 
Dimension-P1 SR Raman System. 
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5. Click on Continue button once the user has confirmed the Pixel Number reading of the 

maximum cyclohexane peak, RamanSoft will then perform the laser wavelength calibration.  
 
Manual Laser Wavelength Calibration 

 
1. Put the user-chosen standard sample into the sample holder. Click on System->CCD 

Configuration to set the New Integration Time to be 1 sec. 
 
2. Check the Laser Wavelength Calibration checkbox in the System Calibration window. 

Choose Other Sample in the pull-down selection menu. 
 
3. Click on the Calibrate button. RamanSoft starts to acquire standard sample spectrum and 

identifies the maximum peak position. 
 
4. The Laser Wavelength Calibration… window appears. Both the Pixel Number and the 

corresponding Raman Shift value must be entered manually. 
 

 
 
The calibrated wavelength, wavenumber, and efficiency correction through intensity calibration 
are saved in C:\LSI\RamanSoft\Calibration. The file is named using the system date and time 
(including year, e.g., 20050228084333). This is a text file with .cal extension.  
 
In addition, spectrum data for wavelength calibration (e.g., mercury lamp spectrum), intensity 
calibration (e.g., halogen calibration lamp spectrum), and laser wavelength calibration (e.g., 
cyclohexane spectrum) are saved in C:\LSI\RamanData\CalibrationData. These are files in LSI 
.raw format and also text format with filenames such as WL0228084148.raw for wavelength 
calibration data, INT0223154319.raw for intensity calibration data, and LW1223154320.raw for 
laser wavelength calibration data. The numbers stands for the system date and time. 

 

Live Video Configuration 
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The Live Video Configuration menu provides the settings to configure for acquiring and displaying 
a CCD image. This is an essential tool for an system engineer to adjust alignment of fiber optics 
in the Raman spectrometer system. 

 
 

The Pixel Binning group box provides an option for the user to set the horizontal or vertical 
binning factors for CCD imaging acquisition and display. The Data Display Range has from 8 Bits 
to 16 Bits data format for user to choose. The higher the bits, the better the image contrast, but 
sensitivity is reduced and the acquisition will be slower. 
 
To use the live video mode, put a sample of interest into the sample cell, set CCD integration time 

and gain setting in System->CCD Configuration. Activate the live video mode by clicking on  
on the Acquisition Window Toolbar. The video image for the spectrum is then displayed in the 

Acquisition Window. Clicking on  the second time to quit the live video image mode. 
 
 
 
 

Note: The Live Video mode is mainly for field engineers. Users are not recommended to 
use this functionality.  

   
 

SpectrumSearch     
                                                                                                                                       

The SpectrumSearch submenu allows the user to locate the executable SpectrumSearch.exe 
from your computer hard disk for performing SpectrumSearch application (see Chapter 6 for 
details on the SpectrumSearch Module). This is used only when the SpectrumSearch module has 
been moved from its default location at C:\LSI\RamanSoft\exe when RamanSoft is first installed. 
 

 
 
The Clear Flag check box allows the user to clear any errors before re-starting the 
SpectrumSearch module in the event the module crashes due to a run time error or any other 
error source.  

 

SpectrumPredict 
                                                                                                                                                   

The SpectrumPredict submenu allows the user to locate the executable SpectrumPredict.exe 
from your computer hard disk for performing SpectrumPredict application (see Chapter 7 for 
details on the SpectrumPredict Module). This is used only when the SpectrumSearch module has 
been moved from its default location at C:\LSI\RamanSoft\exe when RamanSoft is first installed.  
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The Clear Flag check box allows the user to clear any errors before re-starting the 
SpectrumSearch module in the event the module crashes due to a run time error or any other 
error source.  

 

Automation 
 

The automation function of RamanSoft allows the user to apply data acquisition/ processing/ 
analysis methods during the spectrum acquisition process.  
 
Automation Setup 
 
Clicking on Automation->Setup activates the System Automation Setup window, where the user 
can activate various data acquisition / processing / analysis methods. 
 

 
 

The Background Subtraction function allows the user to subtract a background spectrum from the 
spectrum data during acquisition. Configuration of a specific Background Subtraction method can 
be achieved through Acquisition->Setup. Refer to the subsections “Setup” and “Background” 
under “The Acquisition Menu” section in this chapter for details. 

 
The Smoothing allows users to apply a smoothing algorithm to the acquired spectrum. 
Configuration of which smoothing algorithm to apply (Adjacent Average, Savitzky-Golay, FFT 
Filter) can be achieved through the Analysis->Algorithm Setup->Smoothing tab page. Refer to the 
subsection “Algorithm Setup” under “The Analysis Menu” section in this chapter for details. 
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Normalization allows users to apply a normalization algorithm to the acquired spectrum. 
Configuration of which normalization algorithm to apply (normalize to laser power, to maximum 
peak intensity in full spectrum range or a user defined range, or to the intensity at a specific 
spectrum point) can be achieved through the Analysis->Algorithm Setup->Normalization tab 
page. Refer to the subsection “Algorithm Setup” under “The Analysis Menu” section in this 
chapter for details. 
  
Background Removal allows the user to apply a background removal algorithm to the acquired 
spectrum. Configuration of which algorithm to apply (automatic, semi-automatic, manual) can be 
achieved through the Analysis->Algorithm Setup->Background Removal tab page. Refer to the 
subsection “Algorithm Setup” under “The Analysis Menu” section in this chapter for details. 
 
Peak Identification allows the user to perform peak labeling to the acquired spectrum. Configure 
which algorithms to apply (default, customer chosen peaks) from the Analysis->Algorithm Setup-> 
Peak Identification tab page. Refer to the subsection “Algorithm Setup” under “The Analysis 
Menu” section in this chapter for details. 
 
Peak Area allows the user to perform peak area calculation to the acquired spectrum. To 
automate peak area calculation, the user needs to configure “Auto” mode in the Analysis-
>Algorithm Setup->Peak Area tab page. Refer to the subsection “Algorithm Setup” under “The 
Analysis Menu” section in this chapter for details. 

 
Auto File saving 

 
If there is one or more than one data acquisition/ processing/ analysis methods checked in the 
System Automation Setup window, the system automation is turned on and both the raw and the 
processed spectra are automatically saved according to the Path and File Prefix fields set up in  
the Acquisition Setup window.  
 
If no data acquisition/ processing/ analysis methods is checked in the System Automation Setup 
window but the user would like to save the raw spectrum automatically with the system-generated 
filename, the user needs to explicitly make sure that the Automation->On is checked.  
 

 
 

The Acquisition Menu 
 

The Acquisition menu contains Setup, Acquire, Continuous Acquire, Stop Acquire, Dark Current, 
and Background submenu items. Acquire, Continuous Acquire and Stop Acquire are more easily 
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accessed from the Acquisition Window Toolbar buttons as discussed in the beginning of this 
chapter. 

 

 
  

Setup  
 

The Acquisition Setup window allows for setting up acquisition parameters before data acquisition 
is initiated.  
 

 
   

Efficiency Calibration 
 
The efficiency calibration (i.e., efficiency correction obtained through intensity calibration) can be 
chosen to be On or Off. This gives users the option to view the spectrum in the Acquisition 
Window with or without efficiency correction. The default setting is Off. Note that if the user has 
chosen Background Removal from the System->Automation->Setup, the efficiency correction is 
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then automatically applied and the process and efficiency-corrected spectrum is displayed in the 
Analysis Window. 
 
Background Subtraction 
 
The user can choose Current Background or Specific Background. To select a background 
subtraction method, click on the Current Background or Specific Background radio button. Click 
on the radio button the second time to de-select this background subtraction method. 

 
If Current Background is chosen, the user is then asked to acquire a background spectrum by 
choosing Acquisition->Background immediately prior to acquiring the sample spectrum. This 
current background spectrum will then be subtracted from the acquired sample spectrum. Note 
that the background data buffer is always updated with the most recent background spectrum 
acquired through Acquisition->Background.  
 
If Specific Background is chosen, the user can then browse to choose a background spectrum 
that has been previously acquired and saved into a file. To acquire a specific background 
spectrum and save it into a file, the user takes the same steps that would be used to acquire and 
save the spectrum of a real sample. 

 
A background spectrum is a spectrum from a sample that produces (mainly) the fluorescence or 
reflected light background of an actual sample of interest. For example, the spectrum of water in 
a glass vial can be used as a background spectrum for dilute aqueous samples in the same type 
of glass vials. Appropriate background subtraction increases spectrum quality, and it is 
recommended that the background spectrum is taken with the same acquisition/processing 
parameters as the spectrum of the actual sample from which this background spectrum is to be 
subtracted. 
 
Averaging 

 
Averaging is controlled through Frames Per Measurement in which the user can set the number 
of frames to be averaged for each acquisition. Frame averaging is used to increase the signal-to-
noise ratio of a sample with a low-Raman signal spectrum. Usually, an averaging of 3 to 5 frames 
would be enough. For very low-Raman signal spectrum, an averaging of up to 10 or 15 frames 
may be needed to provide good signal-to-ratio.  
 
Operator Name 
 
In the Operator Name field, the user can type in the name of the operator for this data acquisition.  
 
File Auto Save 
 
The File Auto Save group box allows the user to set up the file path/name for the spectrum data 
files to be saved.  
 
We recommend that data are saved in the folder C:\LSI\RamanData, and create subfolders for 
each individual users. Note that the program can auto-generate a subdirectory on your computer 
hard disk specified on the Path field. Thus, if the user types in “C:\LSI\RamanData\User1” in the 
Path field, the program will create a subfolder “User1” within C:\LSI\RamanData, and the user 
does not need to actually go to C:\LSI\RamanData folder and create the “User1” folder.  
 
Note that the program can only create one layer of new subdirectory. For example, it cannot 
create “C:\LSI\RamanData\User2\Chemicals” if the \User2 subfolder is not created yet. 
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The information that the user inputs in the Sample Name, Sample Info, and File Prefix fields, as 
well as that in the Frames Per Measurement, Operator Name, Path fields will all be included in 
the file header and in the report header.  
 
Note that the spectrum data file name is generated by attaching a system date and time string 
(hour, minute, second) to the file name prefix that the user inputted in the File Prefix field. The 
program also attaches a numerical number “-1” at the end of the file name (also see Multiple File 
Settings below). If automation is activated through System->Automation, then the processed 
spectrum files are simultaneously saved with the same file name as the raw spectrum files, but 
with additional letters added: “BKSUB” for a background-subtracted spectrum, “B” for a 
background removed spectrum, “S” for a smoothed spectrum, and “N” for a normalized spectrum. 
For example, “cyclohexane0121124043-1.raw” is the filename for a raw spectrum file acquired in 
January 21, at 43 seconds past 12:40 pm, with the file prefix “cyclohexane”. 
“cyclohexane0121124043B-1.pro” is the filename for the background-removed spectrum file 
corresponding to the above raw spectrum file. 

 
The Multiple File Settings group box offers the functionality of continuously acquiring and saving 
multiple spectra. The user can specify the number of files to be saved in Number of Files to Save 
field, and the interval between two consecutive acquisitions in File Interval fields. In this mode, 
the program attach a numerical number “-1”, “-2”, “-3”, …, for the multiple files as a file index. 

 

Acquire  

When the user clicks on the Acquire submenu, or clicks on the   button on the Acquisition 
Window Toolbar, the system starts the data acquisition. The acquired spectrum will appear in the 
Acquisition Window, while the processed spectrum (if chosen through System Automation Setup) 
will be displayed in the Analysis Window. 
 
Note that if frame averaging (see above subsection “Setup”) is used, i.e., the number of frames 
per measurement is more than 1, a Measurement Status window will appear to inform the user 
the progress of the data acquisition. 
 

 
 
 

Acquiring with Efficiency Calibration On/Off 
 
In the Acquisition Setup window, if the Efficiency Calibration is turned Off,  

 

 
 
the spectrum acquired is a “truly” raw spectrum without efficiency correction, i.e., the intensity 
values are the raw counts from CCD camera readout without being corrected with the system 
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response (or, system efficiency). The following figure shows the cyclohexane spectrum in the 
Acquisition Window with efficiency calibration turned Off. 
 

 
 
 
If the Efficiency Calibration is turned On,  
 

 
 
the acquired spectrum is then efficiency corrected, i.e., the intensity values are corrected with the 
system response. The following figure shows the cyclohexane spectrum in the Acquisition 
Window with efficiency calibration turned On. 
 

 
 
 
Note that the efficiency-calibrated spectrum appears noisier towards the higher wavenumber end 
of the spectrum (as well as in the beginning of the spectrum, but to a less degree). This is due to 
the fact that the system efficiency is “bell-shaped” (see section “Calibration”->”Intensity 
Calibration”), which means that calibrated spectrum is applied with increasingly larger 
multiplication factors towards the two ends, and thus the constant noise level in the raw spectrum 
is magnified towards the two ends.   

 

Continuous Acquire / Stop Acquire 
 

When the user clicks on Continuous Acquire submenu, the system starts to acquire the spectrum 
continuously, using the same CCD integration time for each acquisition. To stop continuous 

acquisition, click on the Stop Acquire submenu or press the  button on the Acquisition 
Window Toolbar. Note that in the continuous acquire mode, the spectra are not saved. These 
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spectra are generally used to obtain preliminary data while adjusting intensity or probe working 
distance. 
 
Note: The acquisitions obtained through Continuous Acquire are single acquisitions; they are not 
multiple frames used for averaging (see Acquisition Setup). 
 

Dark Current  
 

When the user clicks on the Dark Current submenu, the system closes the laser shutter and 
performs a dark current measurement for the integration time and frames per measurement 
chosen. The shutter is turned on after the dark current is taken. Note that every time the CCD 
configuration (CCD temperature, integration time, acquisition speed, gain setting) and/or frame 
averaging are changed the system automatically re-takes the dark current prior to a data 
acquisition. The following figure shows a dark current spectrum. Here the first few pixels read 
lower dark current, and this is a characteristic of this specific CCD camera. 
 

 
 

Background  
 

The Background submenu allows the system to acquire a spectrum and save it into the 
background data buffer. This spectrum can also be saved into a file. If the Background submenu 
is clicked multiple times, the background data buffer is updated with the most recent background 
acquisition. 
 
Acquiring a Spectrum with Current Background Subtraction 
 
To acquire a sample spectrum and subtract a current background spectrum from the acquired 
sample spectrum, do the following: 
 
1. Put the “background sample” into the sample cell. In the Background Subtraction group box 

of the Acquisition Setup window, choose Current Background. Set other acquisition 
parameters such as laser power, CCD integration time, frame averaging. 
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2. Click Acquisition->Background. The background spectrum is acquired and displayed in the 
Acquisition Window. The following figure shows an acquired background spectrum from 
water in a glass vial. 

 

 
 

 
 
 
The user is asked whether to save this background into a file. 
 

 
 

The user can click No to not to save the background, or click Yes to save it into a file for 
future use (for e.g., the saved background file can be used as Specific Background to be 
subtracted from other sample spectra. See next topic on “Acquire a Sample Spectrum with 
Specific Background Subtraction).  

 

 
 
3. Put the sample of interest into the sample cell. In the Acquisition Setup window, set Sample 

Name, Sample Info, File Prefix. Be sure not to change other acquisition parameters (laser 
power, CCD Configuration, frame average) that you set up for acquiring the background.  

 

4. Click Acquisition->Acquire or click on  on the Acquisition Window Toolbar. The 
background subtracted spectrum is displayed on the Acquisition Window. 
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For the user’s comparison, the original spectrum (10% aqueous acetone in glass vial) prior to 
background subtraction is shown in the following figure. In the above figure, the dip between 1000 
– 1600 cm-1 could be due to an incomplete match between the measured sample and the 
background sample. 
 

 
 

  
Acquiring a Spectrum with Specific Background Subtraction 
 
To acquire a spectrum and subtract a specific background from it, take the following steps. 
 
1. In the Background Subtraction group box of the Acquisition Setup window, click on Specific 

Background radio button. The textbox field beneath it becomes available. 
 

 
 

2. Press the browse button (…) to the right of the textbox field to locate a file that contains a 
background spectrum that the user intends to use. This background spectrum is acquired and 
saved into a file previously either through Acquire->Background or through an acquisition 
session just like with regular samples. 
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Note that the file that contains the background spectrum should be a raw spectrum file, i.e., of 
file extension .raw, since the program is to subtract this raw background spectrum from the 
acquired raw sample spectrum. 

 
3. Click Open. The selected background spectrum file is shown in the text field. 

 

 
 
4. Set acquisition parameters. It is strongly recommended that the user set the acquisition 

parameters (laser power, CCD configuration, frame average) as close as possible to those 
used when the background spectrum was taken. Set Sample Name, Sample Info, File Prefix. 

 
5. Put the sample to be measured in the sample holder, click Acquisition->Acquire or press the 

 button on the Acquisition Window Toolbar. The acquired spectrum is background-
subtracted and it is displayed in the Acquisition Window. 

 

 
 

Note that if a spectrum is acquired with background subtraction from either current 
background or specific background, the spectrum is saved with both the original raw intensity 
data and the background intensity data, thus the raw spectrum and the background spectrum 
can be reconstructed from the saved data if desired. 
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The Analysis Menu 
 

The Analysis menu includes the basic RamanSoft data processing and data analysis functions. 
 

 
 

Some of these functions can alternatively be accessed through the Analysis Window Toolbar. 
 

 
 

“A” stands for Algorithm Setup, “S”  stands for Smoothing, “N” stands for Normalization, “B” 
stands for Background Removal, “PI”  stands for Peak Identification, “PA”  for Peak Area, and “C” 
clears the Analysis Window. 

 

Algorithm Setup 
 

The Algorithm Setup menu allows the user to configure one of the several available algorithms to 
apply for a particular data processing or data analysis function.  

 
Smoothing 

 
The smoothing algorithms include Savitzky-Golay (S-G) smoothing, Adjacent Averaging 
smoothing, and FFT Filter smoothing. 
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For applying S-G smoothing on Raman peaks, a Polynomial Order of  4, and both the number of 
Points to the Left and number of Points to the Right of 6 are recommended to maintain the 
original peak shape.  
 
For Adjacent Average smoothing, a Number of Points of 3 or 5 is recommended so as not to 
distort the peak shape severely.  
 
For FFT Filter smoothing, the range of Cut Off Frequency is from 0 to 1, where 0 provides the 
most filtering of the high frequency noises and 1 provides none. The Start and End gives the 
starting point and the ending point of the range of the spectrum where the FFT smoothing will be 
applied on.  
 
The program sets the appropriate units (i.e., nm or cm-1) for the Start and End points based on 
the x-axis display (set through View->x axis) in the analysis window. 

 
 Normalization 
 

There are four normalization options available. Normalize to Laser Power (as displayed in the 
Laser Power Reading field, this is the laser power at which  the spectrum was taken); Normalize 
to Maximum Peak Intensity over the entire range of the spectrum (In Full Range); normalize to 
the maximum peak intensity in the customer chosen (x-axis) range (Custom Range); or normalize 
to the intensity value at any customer chosen spectrum point (Normalize to Arbitrary Point). Note 
that a spectrum can only be normalized to the laser power once. 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 5.  RamanSoft Basic Functionalities 111

 
 
  

Background Removal 
 

There are three background removal methods: Automatic, Semi-Automatic, and Manual methods.  
 

 
 
 
Automatic and Semi-automatic Background Removal 
 
The Automatic method performs the default background removal automatically; the Semi-
Automatic method gives the user two choices of algorithms to use: Method 1 and Method 2. 
Method 1 removes less background while retaining more small noisy peaks. Method 2 performs 
more aggressive removal of background, but may remove some small peaks. In the Automatic 
method, Method 1 is chosen if the intensity of the raw spectrum is less than 10,000, and Method 
2 is chosen if the intensity of the raw spectrum is greater than 10,000. Once an algorithm is 
chosen, click the Apply button.  
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Display Options 
 
There are five display options after a spectrum is background-removed: 
 
Option 1: Do Not Apply. Under this option only the original spectrum is displayed in the Analysis 
Window. This is equivalent to the fact that no background removal algorithm is applied. This 
display option can be used to reverse an earlier background removal action. 
 
Option 2: Background Removed Spectrum Only. Only background-removed spectrum is 
displayed in the Analysis Window. 
 
Option 3: Original & Background-removed Spectra. Both the original spectrum and the 
background-removed spectrum are displayed in the Analysis Window. 
 
Option 4: Original Spectrum and Background Only. Both the original spectrum and the 
background generated either automatically under Automatic or Semi-Automatic mode or manually 
under Manual mode (see next topic “Manual Background Removal”) are displayed in the Analysis 
Window. 
 
Option 5: Original, Background, and Background Removed Spectra. Under this option, the 
original spectrum, the background either generated automatically under Automatic or Semi-
Automatic mode or generated manually under the Manual mode (see subsection Manual 
Background Removal), and the background-removed spectrum are all displayed in the Analysis 
Window. The following figure shows such a display after an automatic background removal. 
 

 
 

Manual Background Removal 
 

The Manual background removal method gives users the option to perform background removal 
entirely manually.  
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1. On the File View Window, click on the filename on the Raw Data list to display the 

spectrum to be manually background removed in the Analysis Window. 

2. Click on Analysis->Algorithm Setup->Background Removal page tab; or click on  on 
the Analysis Window Toolbar and then click on the Background Removal page tab. 

  
3. Check the Manual radio button, press Clear Bkgrd (a previous background will appear if 

there is one in the buffer), and click on the Apply button (this clears any previous 
background from the buffer). 

 
4. Set the display option to Option 2: Background Removed Spectrum Only (or any other 

display options except  the option Do Not Apply). Click on the Apply button. 
 

5. Click left mouse at the start of the spectrum. The first point of the spectrum is 
automatically set as the first point of the background. Move the cross-line cursor to draw 
the background. When done, right-click the mouse. If the user right-clicked the mouse 
before the background was fully drawn till the end of the spectrum, the rest of the 
background will take the same Y-axis values as that of the last background point. 

 

 
 

6. The background-removed (and also efficiency-corrected) spectrum is displayed in the 
Analysis window. 
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7. If unsatisfied, click on Clear Bkgrd button to clear the background, press Apply, and re-
draw the background. 

 
8. If the display option is set to Option 2, 4, or 5, the user can save the background-

removed spectrum. Go to File->Save As->Analysis Window, and save it into a desired 
folder. It is recommended to add “_MB” to the end of the original file name to signify that 
the spectrum has been processed with the manual background removal method.  

 
9. The user can also save the background itself into a file. To do this, choose the display 

option to be Option 3: Original Spectrum and Background Only. Go to File->Save As-
>Analysis Window, and save it into a desired folder.  

 
10. The user can set to other display options to display the original spectrum, the 

background, and the background-removed spectrum.  
 

The Clear for Each Acq checkbox gives users the option to clear the manually-drawn background 
from the buffer. If this is not checked, and the Manual background removal method is chosen, 
then this background will be subtracted from all subsequently acquired spectrum.  
 

 
 
 

Note: All background-removed spectra are automatically applied with efficiency correction. 
Thus, Background Removal should not be applied to a background-removed spectrum. 

 
 
 

Note: If a data processing method (Smoothing, Normalization, Background Removal) is 
applied to a spectrum manually instead of through system automation while the 
spectrum was being acquired, the processed spectrum needs to be manually saved by 
choosing File->Save As->Analysis Window and entering a file name. 

 
 
 
 
 Peak Identification / Intensity Ratio 
 

For peak labeling, the user can choose Default or Custom chosen peaks under the Peak 
Identification Algorithm group box. In the default mode, all peaks with an intensity greater than 
5% of the maximum peak intensity will be identified. The user can choose other cut-off thresholds 
through the Custom chosen peaks option (such as 1%).  
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The following figure shows a peak-identified spectrum. 
 

 
 

To obtain the peak ratio of the peaks, click on the Intensity Ratio radio button. The default ratio is 
to Peak 1; the user can change to any other peak through the arrow buttons or by typing in the 
peak index.  
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The contents (Index, Position, Intensity, and if intensity ratio is applied, the Ratio) of the Peak List 
table can be saved into a text file by clicking on the Save button. A filename is automatically 
generated, which is the name of the spectrum file with a “-PL” suffix. 
 

 
 
 
 Peak Area / Area Ratio 

 
There are two ways of performing peak area calculation: the Manual method and the Auto 
method. The Manual method is the default method.  
 
In the manual method, the user uses the cursor to click on the start and end points under a peak 
on the spectrum. In the auto method, the user inputs the start and end positions of peaks. These 
positions could have been saved into an Area List file, which could be loaded later for peak area 
calculation. 
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The user can choose to calculate Raw or Net area. The Raw area of a peak is the summation of 
all the intensity values of the spectrum points between the peak Start point and the peak End 
point on the x-axis. The Net area of a peak is the raw peak area minus the summation of all the 
intensity values of the baseline points, where a baseline is defined as the straight line that 
connects the peak Start point to the peak End point. The Net area type is set as the default area 
type. 
 
To obtain peak ratio by peak area, click on the Area Ratio radio button. The default ratio is to the 
first peak; the user can change to calculate the ratio to any other peak.  

 
Manual Peak Area / Area Ratio Calculation 
 
1. Click on the Manual radio button, set the Area Type as Raw or Net, and click on the Apply 

button. 
 
2. Define the peak start point and peak end point using left mouse click. When both the start 

point and the end point are set, a yellow line is drawn to connect the start point and end point, 
and an index number is marked under the peak. The calculated area of the chosen peak is 
displayed in the Peak Area List window.  

 
3. Repeat step 2 to calculate the peak area of other peaks of interest. For each peak calculated, 

a row is added to the Peak Area List window, with each row consisting of an index number 
and the peak area value. 
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4. To remove a peak from the peak area calculation, the user can select the row that 
corresponds to that peak (as identified by the peak index) by clicking anywhere on the row in 
the Peak Area List window, and then press Delete button. This row is then removed from the 
Peak Area List window, and the corresponding peak is de-labeled in the Analysis Window. 
The remaining peaks are re-ordered in their index numbers. The below figure shows that 
peak 2 in the above figure is deleted. 

 

 
 
5. To remove all peaks from the peak area calculation, press Clear All button.  
  
6. All information displayed in the Peak Area List window (peak index, peak start position, peak 

end position, and peak area, and area ratio) can be saved into a text file. Click Save button. 
The program generates a default file name, which is the filename of the spectrum, plus a “-
PA” suffix.  
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Auto Peak Area / Area Ratio Calculation - Input Peak Positions 
 

1. Click on the Auto radio button, set the Area Type as Raw or Net, check Area Ratio radio 
button, and click the Apply button. 

 
2. In the “Enter Peak Start/End Positions” group box, enter the peak start position and peak end 

position into the Start and End text box. Click Add. The peak start and end positions, along 
with an index number automatically assigned, is displayed in the lower text window. Repeat 
this procedure for other peaks of interest. 

 
3. Click Apply. The peaks are labeled in the Analysis Window with the peak Start and peak End 

points connected with yellow lines. The calculated areas are displayed in the Peak Area List 
window. 

 

 
 

4. To remove a peak from the peak area calculation, the user can select a row in the Peak 
Start/End Positions group box by clicking anywhere on the row in the text window to highlight 
this row, press Delete button, then click Apply. This row is then removed from the text window 
as well as the Peak Area List window, and the corresponding peak is de-labeled in the 
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Analysis Window. Alternatively, the user can select the row that corresponds to that peak by 
clicking anywhere on the row in the Peak Area List window to highlight this row, and then 
press Delete button on the Peak List Window. The remaining peaks are re-ordered with new 
index numbers. The figure below shows that peak 2 in the above figure is deleted. 

 

 
 
5. To remove all peaks from the peak area calculation, press Clear button in the Peak Area tab 

page or press Clear All button in the Peak Area List window. 
 

6. To save the peak area calculation information, click Save button in the Peak Area List 
window to save the peak index, peak start position, peak end position, peak area, and area 
ratio into a text file. The program generates a default filename, which is the filename of the 
spectrum, plus a “-PA” suffix.  

 
7. To save the peak start and peak end positions into a file (for future use), click Save in the 

Peak Area tab page. It can be saved with the same filename as that of the spectrum, but with 
a “*.al” extension (Area List file). This file can later be loaded into the text window of the Peak 
Area tab page for peak area calculation. 
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Auto Peak Area / Area Ratio Calculation – Load Area List File 

 
1. From the Peak Area tab page, choose Auto method. Choose Raw or Net under the Area 

Type group box. 
 
2. Click Load. Browse to locate the area list file that was previously saved (see above section 

Auto Peak Area / Area Ratio Calculation – Input Peak Positions on how to create an area list 
file), and click Open on the file Open window. 

 
 

 
 

3. The peak start and end positions are listed in the text window of the Peak Area tab page. 
 

 
 
4. Follow Step 3 – 7 of the previous section Auto Peak Area / Area Ratio Calculation - Input 

Peak Positions to apply the peak area calculation. 
 

Single Spectrum & Spectrum Overlay 
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In the Single Spectrum analysis mode (figure on the left below), only one spectrum can be 
displayed in the Analysis Window. All functions under the Analysis menu are available in the 
Single Spectrum mode. In the Spectrum Overlay mode (figure on the right below), up to six 
different spectra can be simultaneously displayed in the analysis window with each spectrum 
displayed in different colors. In this mode, only smoothing and normalization functions are 
available.  

 

      
                      
      

The following figure displays an overlay of four spectra. The legend and the filename of each 
spectrum is displayed in the upper right corner of the analysis window.   
 

 
 

Note that on the Analysis Window Toolbar, only the smoothing and the normalization functions 

are available. To apply these functions, click on  to bring up the Analysis Setup window. Click 
on the Smoothing or the Normalization page tab to configure the smoothing or normalization 
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algorithm, and press the Apply button. The configured algorithm is then applied to all the spectra 
displayed in the analysis window. 
 
The following figure shows the result of applying normalization “In Full Range”, i.e., each 
spectrum is normalized to its maximum peak. 

 
 

Spectrum Subtraction 
 

This function allows the user to subtract one spectrum from another, a point-by-point subtraction 
of the intensity values of the second spectrum from that of the first one. 
 

 
 
The spectrum to be subtracted from is the spectrum that is already displayed in the Analysis 
Window, and the spectrum to be subtracted can either be a currently acquired spectrum (Current 
Spectrum) being displayed in the Acquisition Window, or a spectrum retrieved from a file (Specific 
Spectrum).  
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Subtracting a Current Spectrum 
 
1. Acquire a spectrum that is to be subtracted. This spectrum is displayed in the Acquisition 

Window. 
 

 
 
 
2. Retrieve the spectrum to be subtracted from and display it in the Analysis Window. 
 

 
 

3. From the Select Spectrum to be Subtracted window, click the Current Spectrum radio button, 
and click OK. 

 

 
 

4. The subtracted spectrum is displayed in the Analysis Window. 
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Subtracting a Specific Spectrum 
 

1. Retrieve the spectrum to be subtracted from and display it in the Analysis Window. 
 

 
 
2. From the Select Spectrum to be Subtracted window, click the Specific Spectrum radio button, 

and click OK. 
 

 
 

3. Click on the Browse button, a file open window is brought up to allow user to choose the 
specific spectrum file that was previously saved.   
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4. Once the user has selected the spectrum file, and clicked Open, the selected filename and 

path then appears in the “Select Spectrum to be Subtracted” window. 
 

 
 

5. Click OK. The chosen “specific spectrum” is then subtracted from the original spectrum 
displayed in the Analysis Window. 

 

 
 

Smoothing 
 

The smoothing functions can be user-configured through the Algorithm Setup -> Smoothing tab 
page. Click on Analysis -> Smoothing to apply the configured smoothing algorithm to the 

spectrum displayed in the Analysis Window. Alternatively, the user can click on  on the 
Analysis Window Toolbar to apply the smoothing function. 
 

Normalization 
 

The normalization functions can be user-configured through the Algorithm Setup -> Normalization 
tab page. Click Analysis -> Normalization to apply the configured normalization algorithm to the 

spectrum displayed in the Analysis Window. Alternatively, the user can click on  on the 
Analysis Window Toolbar to apply the normalization function. 

 

Background Removal 
 

The background removal functions can be user-configured through Algorithm Setup -> 
Background Removal tab page. Click on Analysis -> Background Removal to apply the 
configured background removal algorithm on the spectrum displayed in the Analysis Window. 

Alternatively, the user can click on  on the Analysis Window Toolbar to apply the background 
removal function. 
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Peak Identification 
 

The peak identification functions can be user-configured through Algorithm Setup -> Peak ID tab 
page. Click on Analysis -> Peak Identification to apply the configured peak labeling threshold on 

the spectrum displayed in the Analysis Window. Alternatively, the user can click on  on the 
Analysis Window toolbar to apply the peak identification function. 

 

Peak Area 
 

The peak area functions can be user-configured through Algorithm Setup -> Peak Area tab page. 
Click on Analysis -> Peak Area to perform peak area calculation on the spectrum displayed in the 

Analysis Window. Alternatively, the user can click on  on the Analysis Window toolbar to 
apply the peak area function.  
 

 

The Tools Menu 
 

The three function modules, SpectrumSearch, SpectrumPredict, and Real Time Monitoring, are 
accessible through the Tools menu. 

 

 
 

These modules can alternatively be accessed through the System Toolbar (  for 

SpectrumSearch,  for SpectrumPredict,  for Real Time Monitoring). Please refer to 
Chapters 6, 7, and 8 for the detailed functionalities of these modules, repectively. 
 

 

The View Menu 
 

The View menu allows for configuration of various information display options. 
 

 

X Axis 
 

This option allows for displaying a spectrum in the Acquisition Window and/or a spectrum in the 
Analysis Window in different x-axis options; the spectrum can be displayed in Pixel Number, in 
Wavelength (nm), or in Wavenumber (cm-1). 
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The following figure shows the cyclohexane spectrum displayed pixel number in the Acquisition 
Window, and in wavelength in the Analysis Window. 
 

 
 

Analysis Window 
 

This option allows for displaying the spectrum in the Analysis Window after subtracting the 
background data saved in the file (if background subtraction was used when the spectrum was 
acquired – see subsection “Background” under section “Acquisition” in this chapter). 

 

 
 

To use this feature, proceed with the following: 
 
1. Open a file which has background data saved in it, and display it in the Analysis Window. 
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2. Click View->Analysis Window->Subtract Background (a check mark will appear to the left of 

the Subtract Background submenu item). The spectrum displayed in the Analysis Window is 
now background-subtracted. 

 

 
 

3. To revert to view the original spectrum without subtracting the background, click View -> 
Analysis Window->Subtract Background again to uncheck the Subtract Background submenu 
item. The original spectrum without the background being subtracted will now be displayed in 
the Analysis Window. 

 
 

The Help Menu 
 

Currently the Help menu only contains one submenu item: About RamanSoft, which displays 
RamanSoft version/ copyright info. On-line help menu will be available for future versions. 
Registered users will be notified and updated. 
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Exiting RamanSoft 
 

The user can exit RamanSoft by choosing File->Exit, or simply by closing the window. 
 
When the user exits RamanSoft, the user is prompted to save the configurations used in the 
current RamanSoft session into the same configuration file or to save it in a new file. The default 
setting is to save it into the same configuration file. 

 

 
 
Exiting RamanSoft Without Saving Configuration 
 
Press Exit to exit RamanSoft without saving the configurations.  

 
 Saving Configuration Into Current File 
 

Since this is the default setting, just click Save to save the configurations into the same file name 
as displayed in the Using Current File Name textbox. RamanSoft is then exited. 
 
Saving Configuration Into a New File 

 
1. Click the Using a New File Name radio button. Press Save.  
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2. The Save As window appears. Browse to C:\LSI\RamanSoft\Configuration (where the 
Default.rcf configuration file is located), and input the new configuration file name. 

 

 
 
3. Click Save. A new configuration file is then created (in the above figure, a new configuration 

file “MyRCF.rcf” is created). The program is exited. 
 

If a user chooses the Default.rcf when starting RamanSoft, it is recommended that the user save 
the configurations into a new file so that the user can conveniently retrieve his/her own preferred 
settings for data acquisition, processing, and analysis in a future RamanSoft session. 

 
 

RamanSoft Trouble Shooting 
 

This section describes the trouble shooting protocols for the RamanSoft basic functionalities. 
 

CCD Camera Communication Failure 
 
If the CCD Camera Initialization Warning Window appears when RamanSoft is first started: 
 

 
 
The USB 2.0 cable between the Dimension-P Raman unit and the computer may not be properly 
connected. Connect the USB 2.0 cable, make sure that the two ends of the USB cable is push-
tight, and restart RamanSoft. 
 
If the USB 2.0 cable is connected properly, and the above window still appears, there could be 
one RamanSoft application already started, in which case there should be two RamanSoft icons 
displayed on the Windows task bar. Close the second RamanSoft application.  
 
If the second RamanSoft application is used to acquire data despite the CCD camera 
communication failure warning, no data will be acquired (as the CCD can only communicate to 
one active RamanSoft application), and the Acquisition Window would display the following: 
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Note that if the USB 2.0 cable is disconnected during a RamanSoft session and the CCD Camera 
Initialization Warning Window appears, the user needs to exit the program and restart RamanSoft 
application to reinitiate the communication between the CCD camera and the computer. 

 

Laser Power Status Warning 
 

If the system has been idle (i.e., without acquisition action) for more than 30 minutes, the system 
turns the laser off automatically. A subsequent acquisition action would invoke the Laser Status 
Warning Window.  

 

 
 

Click Yes to turn the laser on (the Laser Power Stabilizing Progress Window will appear), and 

then click  or  to continue the acquisition action. 
 

Click No to remain at the laser power off status. A spectrum taken without laser on would appear 
like white noise spectrum (see the figure in subsection “White Noise Spectrum Acquired”). 
 

Laser Status Warning 
 

If the Laser Status Warning Window shows up (most often when the user first start RamanSoft 
but forgot to turn the Laser Key to ON position),  

 

 
 

The warning indicates that the laser is not turned on yet, i.e., the Laser Power key is at OFF 
position (on the front panel of the Dimension-P Raman).  
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Click OK on the Laser Status Warning Window, turn the Laser Power Key to ON position on 
Dimension-P Raman. 
 
Note: If the Laser Key Switch is at ON position and nonetheless the Laser Status Warning 
Window appears (clicking OK in the Laser Status Warning Window and subsequent acquisition 
action will keep bringing up the Laser Power Status Warning Window and the Laser Status 
Warning Window), there could be a loss of communication between the computer and the 
Dimension-P Raman, such as a disconnection of the USB 2.0 cable. In this case, exit RamanSoft, 
connect the USB 2.0 cable, and restart RamanSoft. 
  

White Noise Spectrum Acquired 
 

If the spectrum acquired appears to be a white noise spectrum in the Acquisition Window, 
 

 
 

and the sample is placed properly in the internal sample cell or the External Sampling Module 
and that it is believed to have a Raman signal, the laser might be off (the program turns the laser 
off automatically if the system has been idle for more than 30 minutes). Go to System->Laser 
Setting, and make sure that Laser On is checked. If not, click on System->Laser Setting->Laser 
On to turn the laser on. See the following section “Turn Laser On From RamanSoft” for more 
details. 

 

Turning Laser On From RamanSoft 
 

Even if the Laser Power key switch is in the ON position, there may still be no laser power output. 
The laser is turned on automatically in the following two cases: a. When the Laser Power key 
switch is turned to ON position before RamanSoft is launched. b. When there is an acquisition 
(either through Acquire or Continuous Acquire). The system automatically turns the laser off if 
there has been no acquisition for the past 30 minutes. 
 

 To turn laser on from RamanSoft, go to System->Laser Setting, and make sure that Laser On is 
 checked. If not, click on System->Laser Setting->Laser On again to turn the laser on. 
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6 The SpectrumSearch Module 
 

Overview 
 

The SpectrumSearch module is an integration of RamanSoft with the Thermo Electron 
Corporation’s Spectral ID® functionality for seamlessly performing sample spectrum acquisition 
and spectral library searching in one step in order to rapidly identify unknown samples. The 
integrated system allows the user to set up experimental parameters, acquire spectra to build a 
new library or add a spectrum to an existing library, and perform spectral identification in such a 
way so that the user only needs to work through the RamanSoft SpectrumSearch interface. 
Acquisition parameters such as CCD integration time and frame averaging are set up in the 
RamanSoft main menu (see Chapter 5, RamanSoft Basic Functionality). 
 

 

Launching the SpectrumSearch Application 
 

The SpectrumSearch module can be launched through the Tools->SpectrumSearch menu of the 
RamanSoft main menu. 

 

 
 

It can also be started by clicking on the SpectrumSearch icon  on the Function Toolbar. 
 

 
 

SpectrumSearch 
 
 

 
 

The SpectrumSearch User Interface 
 

The main user interface for the SpectrumSearch module appears as follows:
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The selections on the left panel of the interface may differ every time you start the 
SpectrumSearch application as it depends on the saved contents of the configuration file and 
thus reflects information from a prior session.  
 
The main menu of the SpectrumSearch module consists of File, Library Management, and Library 
Search. 
 

 
 
The function of each menu is described in the following sections, together with the Spectrum 
Acquisition and Search functions that can be configured through the SpectrumSearch interface. 
 

 

The File Menu 
 

The file menu contains Save Search Results, Print Search Results, and Exit menu items. 
 

 
 

Save Search Results 
 
This allows for saving the library search results as a text file. Note that the search results are 
already automatically saved (as a text file) each time a search session is commenced. The Save 
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Search Results menu gives the user an option to save the file using any other filename/location in 
addition to the automatically saved file.  

 

Print Search Results 
 

This allows for printing the search results saved in the text file to a printer.  
 

Exit 
 

This exits the SpectrumSearch module. 
 
 

The Library Management Menu 
 

The Library Management menu contains all functionalities for creating and maintaining a library.  
 

 
 

Library Creation Setup 
 

The Library Creation Configuration Setup window lets the user configure the parameters for 
creating a new library. 
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X Range and Number of Points 
 
The Start Position and End Position specify the starting and ending wavenumbers for all the 
spectra in the library. The default setting uses the full spectral range. This is usually desired and it 
is also recommended when the library is first created. If the user wants to match a limited spectral 
region of the unknown sample spectrum to the spectra in the library, the user can choose to 
search a specified region of the library spectra through the Select Search Spectrum Region 
function in Library Search->Spectrum Search Setup. 

 
Data Resolution 

 
The Data Resolution specifies the resolution of the spectra stored in the library. 8 bit resolution 
means that the intensity values of a spectrum is rescaled from 0 to 255. Usually, 8 Bit Resolution 
is sufficient but 16 and 32 bit resolution can be chosen. The higher the resolution, the more 
precision is retained in the spectral data, but the slower the search would be. In SpectrumSearch, 
16 bit is set as default. 
 
When an unknown spectrum is searched against the library, the unknown spectrum is scaled 
according to the same resolution as the library spectra. 

 
XY Unit Selection 
 
The XY Unit Selection allows for the selection of x-axis and y-axis units. “Raman Shift (cm-1)” is 
the default for the X Coordinate Unit, and “Intensity” is the default for the as Y Coordinate Unit. 

 
Data Source Type 

 
The default mode for Data Source Type is Optical Spectrum Data. For SpectrumSearch, do not 
select Mass Spectrum Data. 

 
Other Configuration Settings 
 
If Apply Baseline Correction radio button is checked, the GRAMS’ Auto Level Baseline Correction 
algorithm is applied to each spectrum when it is added into the library. This method fits a best 
straight baseline to the non-peak areas of data. Thus it can only remove a linear (slope) 
background, and it cannot remove arbitrary background shapes. 
 
Please Remember not to check this option if RamanSoft Automatic Background Removal is 
enabled.  
 
The user can choose to use Peak Search Double Side search algorithm for Peak Search. The 
default algorithm is Single Side Peak Search algorithm, in which the peaks from the unknown 
sample spectrum are compared to the peaks in a library spectrum with only the ascending side of 
the peak. For Double Side Peak Search, the peaks are compared with both the ascending side 
and the descending side. Double side peak search should give more accurate match between the 
unknown spectrum and the library spectra.  

 

View Library 
 

When Library Management->View Library is chosen, the Select Library window appears, which 
lets the user choose a library to be viewed. Note that there could be more than one library listed 
in Select Library window (if more than one library is added to the library list – see Section “Add 
Library to List”), choose the one that is to be viewed by clicking anywhere on that item to highlight 
it. 
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Click OK. All the entries in this library are then listed in the top right section of the 
SpectrumSearch interface. 
 

 
 

The above table contains the following information for each library entry: 
 

RowStatus The status of the entry. 1 indicates “OK” status, “4” indicates a “Deleted” 
status, i.e., the spectrum has been deleted from the library. 

 
Memo The text information that the user inputs in the Chemical Name field of 

the SpectrumSearch interface when the spectrum is first acquired to be 
added to the library. 

 
Spectrum The actual spectrum of the library entry. Displayed as “|||” (i.e., not 

displayed) in SpectrumSearch. 
 
TextInfo The text information for the library entry, consisting of the contents in the 

memo field, plus information such as “Add a New One”, which is not 
displayed when the TextInfo field of a library entry is clicked.  

 
PeakInfo The peak positions and relative intensities (on a scale of 0 to 9) of all the 

peaks of a library spectrum extracted by SpectrumSearch (Spectral ID®).  
 
CopyRight The copyright info if the library or library spectrum is imported from a 

copyrightable source. 
 
MolFile The molecular structure file related to the library entry.  
 
DBPointer The related database source. 
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Create New Library 
 

From Library Management, choose Create New Library.  Browse to a folder into which the library 
is to be placed and enter a name for the library. 
 

 
 
Click Open. The new library is created but empty. The name of the library is displayed in the top 
right section of the SpectrumSearch user interface. 
 

 
 

Note that the program lists all the libraries that are currently on the library list. When a new library 
is created, this library is automatically added to the library list (see “Add to Library List” in this 
section). If another library (“TourLib.lib” in the above figure) is previously added to the library list 
and not deleted from the library list (see “Delete Library From List” in this section), then this library 
still remains on the library list. 
 

LibName The file name of the library 
 
LibPath The file path of the library 
 
Technique The technique (“Raman”) employed in the hardware system. 
 
XUnits X coordinate unit. “13” corresponds to “Raman Shift (cm-1)” 
 
YUnits Y coordinate unit. “12” corresponds to “Intensity” 
 
FFP The x coordinate of the first point in the library spectra 
 
FLP The x coordinate of the last point in the library spectra 
 
Comment The comments for the library. Currently fixed as “Test Library”. 
 
Selected, LibRows These fields are left empty.  
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Some of the above columns (XUnits, YUnits, FFP, FLP) display the settings configured in the 
Library Creation Configuration Setup window (see Section “Library Creation Setup”).. 
  
Note that when the library is created, a set of files (*.idx, *.ipl, *.isl, *.itl, .lib) is created along with 
the library file (.lib) and these files are located in the same directory as the lib file. These files are 
required for library management and library searching.  However, the user only needs to use the 
lib file. 

 

Add New Spectrum 
 

This allows for adding a new spectrum to a library that is already created. The library could be 
empty (like when it is first created) or could already have other spectra in it. 
 
From Library Management, choose Add New Spectrum. Browse to the folder where the spectrum 
(in .SPC format) is located, select the spectrum and click Open.  

 

 
 

The Select Library window appears. Highlight the library where the spectrum is going to be 
added, and click OK. 
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The spectrum is now added to the library. On the top right section of the SpectrumSearch 
interface, the newly added spectrum is displayed as the only entry in the library list, and only a 
RowStatus column is shown. 
 
To confirm that the newly added spectrum is in the library, go to Library Management->View 
Library, highlight the library path/name, and click Ok in the Select Library window. The newly 
added library spectrum is shown as the last entry (row), after other entries for spectra that are 
already in the library. 
 

 
 

Delete a Spectrum 
 

This allows for deleting a spectrum from a library. Deleting a spectrum from a library requires 
knowing the “LibIndex” number for this spectrum in the library. LibIndex is a sequential integer 
number (starting from 0) assigned to the spectrum when it is first added to the library. This 
number can be found when the library is being searched, as shown in the highlighted LibIndex 
column in the below figure.  
 

 
 

Once the LibIndex for the spectrum is known, click on Library Management->Delete a Spectrum 
to bring up the Select Library window, highlight the library in which the spectrum is going to be 
deleted. Click OK.  
 
The Select Spectrum to Delete window appears. Enter the LibIndex number associated with that 
spectrum in the textbox.  
 

 
 

Click OK. The spectrum is then deleted. To confirm, go to Library Management->View Library, 
highlight the library path/name, click OK. The deleted spectrum row is empty except showing a 
RowStatus = 4 (which means “Deleted”). 
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Delete Library from List 
 

This allows for deleting a library from the library list. To do this, click Library Management->Delete 
Library from List. The Select Library window appears, which lists all current libraries on the library 
list. Highlight the library path/name from the Select Library window. 
 

 
 
Click Ok, the library selected is then removed from the library list. 
 
To confirm that the library is removed from the library list, go to Library Management->View 
Library. The library that was deleted from the library list is now not listed in the Select Library 
window. 
 

 
 
Note that once a library is deleted from the library list it will not be used in future library search 
sessions unless it is added back onto the library list again. 
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Add Library to List 
 

This allows for adding a library to the library list. To do this, first make sure that the library is not 
on the library list yet by going to Library Management->View Library and inspecting whether the 
library to be added has already been listed in the Select Library window. 
 

 
 

If not, click Library Management->Add Library to List, browse to the directory where the library is 
located. Select the library name, and click OK. 
 

 
 

To confirm that the library is added to the library list, go to Library Management -> View Library.  
The library that was added to the library list is now listed in the Select Library window. 
 

 
 

Note: Do not add an empty library to the library list. Empty libraries may cause 
SpectrumSearch to crash when a search is commenced. 

DRS-RS1.3-UM-2006-06-26 
 
 



Chapter 6.  The SpectrumSearch Module 145

 

The Library Search Menu 
 

The Library Search menu contains the Spectrum Search Setup menu item. 
 

 
 

Spectrum Search Setup 
 

The first step in performing spectrum search is to configure the search parameters. These 
parameters operate on all the libraries that have been chosen (i.e., that are added to the library 
list) for the search session being carried out. 

 

 
 

Note that the spectrum search parameters are saved in the configuration file (the same 
configuration file that the user has selected to use when RamanSoft is first started, for example, 
Default.rcf), and they need to be changed, if necessary, when a new search session is 
commenced. Such change is particularly important if a very restricted region or spectral feature 
had been chosen in the previous search session. 

 
Select Search Spectrum Regions 
 
This allows for choosing the full spectrum range or selecting a region or regions of interest within 
the full spectral range to perform the library search. 
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The Full Spectrum Region allows for searching the library using the entire spectral range. The 
Start X Pos and End X Pos fields display the start wavenumber and end wavenumber of the 
spectral range of the library. These are the same numbers as the Start Position and End Position 
in the Library Creation Configuration Setup window.  
 
Selected Spectrum Search Regions allows for searching the library by user-chosen sub-regions. 
Up to four regions can be specified and used for a search session. The textbox fields of each 
region are dynamically available when the previous region is selected. 
 

 
 

The numbers displayed in the textbox of the Start Position and End Position fields are those 
saved in the configuration file and used in the previous search session, and they may need to be  
modified for the current search session. 
 
Other Search Configuration Setup 

 
Apply Baseline Correction is to use GRAM/AI’s Auto Level Baseline Correction algorithm. This 
method fits a best straight baseline to the non-peak areas of data. Thus it can only remove a 
linear (slope) background, and cannot remove more complex background profiles. 
We recommend that if the library spectra were acquired using the RamanSoft automatic 
background removal feature, then this feature also be used in the search session, and that Apply 
Baseline Correction be not selected.  
 
Show Spectrum Search Progress enables the display of the searching progress.  
 
Normalize the Unknown Spectrum to Library Spectrum Resolution allows for normalizing the 
unknown spectrum intensity to the library spectrum resolution (8 bit, 16 bit, or 32 bit) set in the 
Library Creation Configuration Setup window. If this option is not chosen, the unknown spectrum 
is then displayed with its original intensity values. 
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Acquiring a Spectrum for Library Creation 
 

The spectra used to create a library can be acquired from RamanSoft main interface or from the 
SpectrumSearch interface. If acquired from the RamanSoft main interface, the user needs to 
make sure that the “GRAMS Format (*.spc)” checkbox is checked in the File Save Preferences 
window, accessed through “File”->”Preferences”. If acquired from the SpectrumSearch interface, 
the user needs to set the acquisition parameters from the RamanSoft main menu. This section 
describes how to acquire spectrum from the SpectrumSearch interface for library creation. 

 
1. Set up acquisition parameters from RamanSoft main menu: 

 
a. Set up CCD integration time and other CCD camera parameters through System -> 

CCD Configuration. 
 
b. Set up Frames Per Measurement, Sample Name, Sample Info, File Prefix, and file 

Path through Acquisition->Setup. Note that even though the files saved here are not 
used for library creation, it is recommended that these files be saved so that the 
spectra can be retrieved and displayed in RamanSoft for future reference. 

 
c. If automated data processing methods are desired, set them through System-

>Automation->Setup. 
 

d. Configure data processing algorithms through Analysis->Algorithms Setup for the 
chosen data processing methods in c. Remember to click Apply button on the 
Algorithm Setup page after an algorithm is configured. 

 
Note: If no data processing methods is chosen in the System Automation Setup 

window, the user needs to make sure that System->Automation->On is 
checked so that the acquired data can be passed to the SpectrumSearch 
interface. 

 
 
 
 

 
 

2. In Spectrum Acquisition and Search group box, choose Acquire New Spectrum. 
  

 
 

3. In the Chemical Name field, enter the name of the sample. Be sure to enter a meaningful 
name, as this is the name of the sample that is to be stored in the Memo field in the library 
when the spectrum is added to the library. This field is also retrieved from the library when a 
search is performed.  

 
4. In the Save Spectrum As File Name field, enter the file name and path where the library 

spectrum is to be saved. The user can use the Browse button to browse to an existing 
directory/filename so that the file path/name is conveniently populated to save some typing. 
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5. Put the sample in the sample cell. If the External Sampling Module is used, make sure to 
close the lid. 

 
6. Click Save Spectrum. The spectrum is acquired, displayed in the upper panel of the 

Spectrum Display group box of SpectrumSearch interface, and saved. 
 

 
 

Note that the acquired spectrum is also displayed in the RamanSoft Acquisition Window and 
Analysis window, and saved according to settings in step 1b. 

 
 

Spectrum Search Configuration 
 

There are three search types for performing a spectrum search: Full Spectrum Search, Peak 
Search, and Text Search. The default search type is Full Spectrum Search. 
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The Number of Hits displays the number of library matches to be displayed on the upper right 
panel of the SpectrumSearch interface. The default number is 10, but the user can choose 
between 1 and 40.  
 
The HQI Type is the “Hit Quality Index” for the matched library items. It has two scoring schemes, 
Type Raw and Type Scaled for both full spectrum search and peak search. For text search, no 
scores are reported. 

 
Full Spectrum Search 
 
Seven algorithms are available for Full Spectrum Search: Correlation, Least Squares, Absolute 
Value, Euclidian Distance, 1st Derivative Absolute Value, 1st Derivative Least Squares, and 1st 
Derivate Correlation. Please refer to Spectral ID® User’s Guide from Thermo Electron Corporation 
for more details on these algorithms. The default algorithm is the Correlation Algorithm. It gives 
better search results in most cases.  

 

 
 

Under the Type Raw scoring scheme, a number close to “0” means a good “Hit Quality” and a 
number close to “1” (or “1.414”, depending on the algorithm used) means a poor hit for full 
spectrum search algorithms. Under the Type Scaled scoring scheme the opposite is true. 

 
Peak Search 

 
The Peak Search uses a peak matching algorithm to identify library matches. A peak table is 
created from the unknown spectrum and compared to the peak table for each entry stored in the 
library. The default peak search algorithm is the single side peak search where the peaks of the 
unknown sample spectrum are compared to the peaks in the library spectra with only the 
ascending side of the peak. The user can choose Peak Search Double Side in the Library 
Creation Configuration Setup window so that the unknown spectrum peaks are compared with 
both the ascending side and the descending side of the library spectra peaks. Double side peak 
search should give more accurate search results. 
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Under the Type Raw scoring scheme, a number closer to “100” means a good hit quality and a 
number closer to “0” means a poor match for peak search. Under the Type Scaled scoring 
system, a number closer to “-100” indicates a good match, and a number closer to “0” indicates a 
poor match. 
 
 
Text Search 
 
Text Search can be used to search each library entry by what is stored in its memo field. This 
search mode does not require an unknown spectrum to be loaded. It is used to quickly locate a 
library spectrum using the information in the memo field of the library. 
 

 
 
 

Acquiring/Loading Spectrum for Library Searching 
 

There are three spectrum search modes: acquiring a new spectrum, opening an existing 
spectrum from RamanSoft, or opening an existing SPC file to perform library searching.  

 

Acquiring a New Spectrum 
 
This is the RamanSoft “on-line” search mode. To acquire and search an unknown spectrum in 
one-step, proceed with the following procedure, most of which are the same as that for “Acquire 
Spectrum for Library Creation”. To achieve better search results, it is recommended that the 
acquisition parameters and configuration settings are as identical to those used for acquiring 
spectrum for library creation as possible. 

 
1.  Set up acquisition parameters from RamanSoft main menu: 

 
a. Set up CCD integration time and other CCD camera parameters through System -> 

CCD Configuration. 
 
b. Set up Frames Per Measurement, Sample Name, Sample Info, File Prefix, and file 

Path through Acquisition->Setup. Note that the files saved here are not used for 
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library search, but the user can opt to save it so that the spectra can be retrieved and 
displayed in RamanSoft for future reference. 

 
c. If automated data processing methods are desired, set them through System -> 

Automation->Setup. 
 

d. Configure data processing algorithms through Analysis->Algorithms Setup for the 
methods chosen in c. Remember to click Apply button on the Algorithm Setup page 
after an algorithm is configured. 

 
 Note: If no data processing methods is chosen in the System Automation Setup 

window, the user needs to make sure that System->Automation->On is 
checked so that the acquired data can be passed to the SpectrumSearch 
interface. 

 
 
 

 
 

2. In Spectrum Acquisition and Search group box, choose Acquire New Spectrum. 
  

 
 
3. In the Save Spectrum As File Name field, enter the file name (e.g., UnknSample.spc) and 

path where the acquired unknown sample spectrum (in SPC format) is to be saved.  
 

4. Put the sample in the sample cell. If the External Sampling Module is used, make sure to 
close the lid. 

 
5. Set search configurations (see Sections “The Library Search Menu” and “Spectrum Search 

Configuration”). 
 
6. Press Start Search button. After a transit window disappears,  the unknown sample spectrum 

is acquired, displayed in the Acquisition Window and Analysis Window, and in the upper plot 
(in red) of the Spectrum Display panel of SpectrumSearch interface. The best-matched library 
spectrum is displayed (in green) in the lower plot. 
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7. The search results are saved in a text file with the same filename as the spectrum (SPC) file 
(e.g., UnknSample.txt). 

 
 

Passing an Existing Spectrum from RamanSoft 
 
This is for searching a spectrum that has previously been acquired and saved in RamanSoft (files 
with *.raw or *.pro extensions), or a spectrum that was acquired and displayed in the Analysis 
Window.  
 
1. If a spectrum has not been displayed on the Analysis Window yet, go to File->Open to open 

an existing spectrum and display it the Analysis Window. 
 
2. Check the Pass Spectrum from RamanSoft radio button. 

 

 
 

3. In the Save Spectrum As File Name field, enter the file name (e.g., UnknSample2.spc) and 
path where you want the spectrum to be saved by the Spectrumsearch module. The user can 
use the Browse button to browse to an existing directory/filename. 
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4. Set search configurations (see Sections “The Library Search Menu” and “Spectrum Search 
Configuration”). 

 
5. Press Start Search. After a transit window disappears, the search results are displayed in the 

SpectrumSearch interface. 
 

6. The search results are saved (as a text file) with the same filename as that had been entered 
in the Save Spectrum as File Name field (e.g., UnknSample2.txt). 

 

Opening an Existing SPC File 
 
The SPC file can be saved from either RamanSoft main interface or from SpectrumSearch 
interface.  
 
1. Check the Open Existing SPC File radio button.  
 

 
 
2. Set search configurations (see Sections “The Library Search Menu” and “Spectrum Search 

Configuration”). 
 
3. Press Start Search. Browse to select the SPC file to be searched.  
 

 
 
4. Click Open. The search starts. After a transit window disappears, the results are displayed in 

the SpectrumSearch interface. 
 
5. The search results are saved as a text file with the same filename as the name of the 

spectrum being searched (e.g., sample.txt). 
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Note that in this search mode, SpectrumSearch does not save an additional SPC file for the 
unknown sample spectrum during the search session.  

 
 

Viewing Search Results 
 
On the SpectrumSearch interface, the top right section lists the matched (Hit) library items in a 
decreasing “goodness-of-match” order. More information about each hit item can be viewed by 
scrolling to the right of the window.  
 

 
 

Hit   An integer number for the matched library item ordered in decreasing 
“goodness-of-match” according to the hit quality listed in the Quality column. 
“1” indicates the best matched item. 

 
Quality A numerical number for the hit score, which depends on the search type and 

HQI type. In the Type Raw scoring scheme for full spectrum search, this 
number ranges from 0 to 1 or 1.414; the lower the score, the better the match 
(as shown in the above figure). 
 

Memo The chemical name of the sample that the user puts in the Chemical Name 
field of the Spectrum Acquisition and Search group box of the 
SpectrumSearch interface when acquiring a spectrum for library creation. 

 
LibName The name of the library that the spectrum belongs to. 
 
LibPath The file path of the library. 
 
LibIndex The index number for the library spectrum. This number is the sequence 

number when the spectrum is first added to the library. The first item added 
has a LibIndex number “0”, the second item “1”, and so on. 

 
Spectrum The actual spectrum of the library item. Not displayed in SpectrumSearch. 
 
TextInfo The comment field (i.e., Memo field) for the library item and other information 

such as how the spectrum is added to the library (e.g., by Adding New 
Spectrum). 

 
PeakInfo The peak table for the library item. The peak table is a table of values where 

each entry consists of the X axis value of a local maximum in the spectral 
data followed by the relative intensity of the peak on a scale of 0 to 9. Entries 
are separated by the symbol “||”. 

 
CopyRight The copyright of the library spectrum if it is from a commercial database. This 

column is empty in SpectrumSearch. 
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MolFile The filename for the molecular structure of the sample that produced the 
library spectrum. This column is empty in SpectrumSearch. 

 
RecType The record type. “1” indicates valid record type. 
 
ErrNum The error number for the library item. 
  
ErrDescription The error description for the ErrNum. 

 
The Spectrum Display panel displays the unknown sample spectrum (top plot, red) and the 
spectrum of the best matched library spectrum (lower plot, green). 
 

 
 
Other matched library spectrum can be viewed on the lower plot of the Spectrum Display panel 
through the Library Hit Spectrum Selection pull-down selection menu. The Hit Quality(i.e., the 
score), and the Chemical Name (i.e., the memo field) of the selected library entry are also 
displayed. 
 

 
 

The saved search results (in a text file) contain the Hit Number, Hit Quality, Chemical Name, and 
Library Path & Name of all the library hit items configured in the Number of Hits  field in the 
SpectrumSearch interface. 
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SpectrumSearch Troubleshooting 
 

Library Already in the Library List 
 
If a library to be added to the library list is already on the library list, the following window will 
appear: 
 

 
 
Click OK to exit the SpectrumSearch program, and proceed to the following section “Restarting 
SpectrumSearch Application”. 

 

SpectrumSearch Application Already Started 
 
If the SpectrumSearch application is already started, and the user clicks on RamanSoft Tools -> 

SpectrumSearch or the SpectrumSearch icon  on the Function Toolbar, the following warning 
window will appear: 
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Click Ok, and locate the current SpectrumSearch application window. 
 

Two SpectrumSearch Application Interfaces 
 
This might occur if the user has clicked OK on the SpectrumSearch Application Warning window 
(see above topic “SpectrumSearch Application Has Already Started”) and then proceeded to 
restart SpectrumSearch application (see “Restarting the SpectrumSearch Application” in this 
section). In this case, the user can launch a second SpectrumSearch interface without being 
warned again. Close the newly started SpectrumSearch application. 

 

No Action Occurred After Pressing Save Spectrum or Start Search 
 

The laser might be off, as the system automatically turns the laser off if there is no acquisition 
action for 30 minutes. Click on System->Laser Setting->Laser On to turn the laser on from the 
RamanSoft main menu (see section “RamanSoft Trouble Shooting” in Chapter 5 for more 
details). 
 

SpectrumSearch Application Warning 
 

If the following window appears after pressing the Save Spectrum or Start Search button,  
 

 
 
The laser might be off, as the system automatically turns the laser off if there is no acquisition for 
30 minutes. Click on Switch To… button. The Laser Power Status Warning Window will appear.  

 
 
Click on Yes to turn the laser on. Wait for the laser power to stabilize (the progress bar of the 
Laser Power Stabilizing Progress Window reaches the end). Click Save Spectrum or Start Search 
to continue. 
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Invalid File Path/Name of SpectrumSearch Executable 
 
If the invalid file path/name of SpectrumSearch.exe occurs, 

 

 
 

The SpectrumSearch executable might be relocated from its default location in 
C:\LSI\RamanSoft\exe\SpectrumSearch.exe. Proceed to “Restarting Spectrum Search 
Application” and browse to locate SpectrumSearch.exe from the right folder. 

 

No Spectrum Selected 
 

If the search mode is Open SPC File and the user clicked Cancel on the file Open window, the 
following warning window will appear: 
 

 
 

Click on Ok. The Spectrum Display window on the SpectrumSearch interface displays a green 
line on the horizontal axis of the lower plot with an un-scaled y-axis (to stand for an “empty” 
spectrum in the library). Re-select the right file and press Start Search to continue. 
 

 
 

Run-time Error 
 
If a run-time error of any type occurs, such as 
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The SpectrumSearch module needs to be restarted. Click OK, and proceed to the following  
subsection “Restarting the SpectrumSearch Application”.  

 

Unknown Error Conditions 
 

If the SpectrumSearch module crashes, or any other error conditions arise from this module, 
proceed with “Restarting the SpectrumSearch Application”. 
 
Upon any other error conditions, exit both programs (exit SpectrumSearch first and then exit 
RamanSoft), and re-launch RamanSoft.  
 
If neither of the above two procedures works, restart the computer.  

 

Restarting the SpectrumSearch Application 
 
 Go to RamanSoft System->SpectrumSearch, check the Clear Flag checkbox. 
 

 
 
Click OK, and then restart the SpectrumSearch module by clicking on RamanSoft Tools -> 

SpectrumSearch or the SpectrumSearch icon  on the Function Toolbar 
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7 The SpectrumPredict Module 
 

Overview 
 

The SpectrumPredict module is an integration of RamanSoft with the Thermo Electron 
Corporation’s IQ PredictTM for seamlessly performing sample spectrum acquisition and sample 
prediction using multivariate Chemometric methods. This includes both qualitative methods like 
Principal Component Analysis (PCA), Discriminant Analysis for quality control/assurance 
application, and quantitative methods like Principal Component Regression (PCR), Partial Least 
Squares (PLS) analysis for quantitative concentration prediction applications. Users need to have 
Thermo Electron Corporation’s GRAMS/AITM with PLSplus IQTM add-on to create calibration files; 
the RamanSoft SpectrumPredict interface allows for using these calibration files to perform 
spectrum prediction online or offline. Please refer to “PLSplus IQTM User Guide” for a thorough 
introduction to Spectroscopic Qualitative Analysis and Spectroscopic Quantitative Analysis. This 
manual assumes a working knowledge of the Chemometrics methods introduced in the “PLSplus 
IQTM User Guide”. 

 
 

Launching the SpectrumPredict Application 
 

The SpectrumPredict module is launched through Tools->SpectrumPredict from RamanSoft main 
menu. 

 

 
 

 
The  module can alternatively be launched by clicking on the SpectrumPredict icon on the System 
Toolbar. 

 

 
 

SpectrumPredict 
 
 

 
 

The SpectrumPredict Interface 
 

The main interface for the SpectrumPredict module appears as follows: 
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The main menu of the SpectrumPredict interface consists of File and Configuration menu items. 
 

 
 
 

The File Menu 
 

The file menu consists of Open, Save, and Exit menu items: 
 

 
 

Open 
 

This opens a previously saved prediction result file in either RTF format or Text format, and 
displays the prediction results in the SpectrumPredict Report window. 

 

Save 
 

This allows the user to save the prediction results into a RTF file or a plain text file directly from 
the File menu after the results are obtained in a SpectrumPredict session.  
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The alternative way to save the prediction results is to click on the Report button on the 
SpectrumPredict interface, and press the Save button on the SpectrumPredict Report window. 
See section “View Prediction Results” for more details. 

 

Exit 
 

This exits the SpectrumPredict module. 
 
 

The Configuration Menu 
 

This menu configures the parameters for spectrum prediction.  
 

 
 

SpectrumPredict Settings 
 

The SpectrumPredict Configuration window allows user to configure Prediction Type, Report 
Settings for the report file, and specify the Data Range for spectrum and residual display on the 
SpectumPredict interface. 
 

 
 
Prediction Type 
 
You may choose from Classify, Quantify, Combined, or Select. The type you choose determines 
how the calibration models are used when predicting unknowns. 
 
Classify 
 
If the prediction type is set to Classify, only discriminant analysis is performed on all of the 
selected calibration models. For PCA, PCR, PLS-2, or Discriminate models, a single Mahalanobis 
distance value will be returned for each calibration model selected along with the Pass/Fail 
results determined from the model. For PLS-1, a Mahalanobis distance will be returned for each 
component since PLS-1 builds a separate model for each component. 
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Quantify 
 
In this mode, quantitative results will be reported on all of the selected calibration models. If the 
one selected is a PCA or discriminate model, only the distance statistics will be reported (since 
there is no quantitative information in these models).  
 
Combined 
 
This mode first uses classification (Discriminant Analysis) to determine if the unknown is within 
the selected model(s) specified by the Mahalanobis distance. If so, it will calculate the quantities 
and report them. If not, quantitative information is not reported for that model. This allows a 
calibration file to be built with numerous models which will automatically select the correct model 
to use (if any) and report the results. 
 
Select 
 
This mode performs the predictions of spectra against the selected calibrations, but only reports 
the results for those calibrations that pass the Mahalanobis Distance test (either Pass (P) or 
Possible (?)). This allows the user to select multiple calibrations and let the prediction program 
figure out which calibrations best match the sample. Be aware that in some cases, none of the 
calibrations may match and an empty report will result. 
 
Validation 
 
This mode performs unknown sample validation. The following parameters must match for a 
sample to be considered "valid" for use with a given calibration: data point spacing, first X value 
(must be on or outside the calibration limit), last X value (must be on or outside the calibration 
limit), X and Y axis units. 
 
If the sample is validated, spectrum prediction is then performed on the sample using the same 
statistics as those of the Combined prediction type. 

 
Report Settings  
 
The report settings allow for selecting the report format and the various statistics to use for 
generating the report. 
 
Predicted Quantities 
 
Select whether to report the predicted quantities (for quantitative models). Normally, quantities 
will always be reported when you set the prediction type to Quantify. You can use this option to 
exclude quantities from the report, and only the selected statistics will be reported. 
 
Actual Quantities 
 
Choose whether to report the actual quantities of the sample. This item would only appear in the 
report when the prediction type is set to Validation. 
 
Percent Difference 
 
Select whether to report the percent difference between the predicted quantities and the actual 
quantities. This item would only appear in the report when the prediction type is set to Validation. 
 
Sample Match 
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Choose whether to report the result of match/mismatch between the model and the sample. 
 
Mahalanobis Distance 
 
Select whether to report the Mahalanobis Distance metric. 
 
Spectral Residual 
 
Choose whether to report the value of the spectral residual. 
 
F-Ratio 
 
Choose whether to report the F-Ratio values on the spectral residual. 
 
F-Test 
 
Choose whether to report the calculated F-Test values on the spectral residual. 
 
Limit Tests 
 
Choose whether to report the Pass/Fail tests on various statistics: 
 
Scores The calculated factor scores for the sample are checked to insure that they are 

within the range of scores of the training data set data for the model. 
 
F-test An F-test is applied to the spectral residual to check that it is statistically similar 

to the training set data for the model. Samples that have F-test values greater 
than 0.99 fail the test. 

 
M. Distance The calculated Mahalanobis Distance for the sample is compared to the M Dist. 

Accept and M Dist. Reject levels that were set when the calibration was saved 
(i.e., when the calibration file is created). Samples below the M. Dist. Accept level 
will pass. Sample between the two levels are given a “Possible” rating. Any 
samples above the M. Dist. Reject level will fail the test. 

 
Concentration The predicted concentration values, if applicable, are checked to insure that they 

are within the range of concentration for each constituent in the original training 
set for the selected model. 

 
Report Grouping 
 
Choose the grouping method to generate the report. 
 
By Sample This is to group the prediction results organized by sample (Note: this feature 

would be most useful if multiple spectra could be loaded for prediction in the 
same time. In SpectrumPredict, however, only one spectrum can be predicted at 
one time). 

 
By Constituent This is to group the prediction results organized by constituent. When a training 

data set is created, the constituents of the samples are specified. The 
corresponding constituents in the unknown sample are then predicted. 

 
By Calibration This is to group the prediction results organized by calibration type. A  
type  calibration file (Cal file) contains experiments built from one of the five calibration 

types: PLS-1, PLS-2, PCR, PCA, and Discriminate.  
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Data Range 

 
Start Wavenumber The start wavenumber for the sample spectrum and the spectral residual 

(i.e., the difference between the sample spectrum and the predicted 
spectrum) plot. 

 
End Wavenumber The end wavenumber for the sample spectrum and the spectral residual 

plot. 
 
Note that the data range is only used for displaying the spectrum and residual on the 
SpectrumPredict interface. If the user intends to use selected regions of the spectrum for 
prediction, the user needs to create a calibration file with the selected regions. Please refer to 
“PLSplus IQTM User’s Guide” for how to do so. 

 
 

Performing a Spectrum Prediction 
 

Loading a Calibration File 
 

The calibration file is created using Thermo Electron Corporation’s GRAMS/AITM with PLSplus/IQ 
add-on. Please refer to the “Reference Guide” chapter of the “PLSplus IQTM User’s Guide” for 
creating a calibration file. Once the calibration models, or experiments, are set up in the 
calibration file, RamanSoft can load those experiments to perform on-line or off-line prediction of 
a sample spectrum.  
 
A calibration file can contain several experiments, with each experiment containing one of the five 
calibration types: PLS-1, PLS-2, PCR, PCA, and Discriminate. These calibration types can be 
combined with other model building conditions (please refer to “PLSplus IQTM User’s Guide” for 
details) to build a specific experiment. 
 
1. In the IQ Predict (Select Cal File) group box of the SpectrumPredict interface, click Browse 

button.  
 
2. The Select Cal File Name window appears. Browse to locate the calibration file, and click 

Open. 
 
3. The experiments created in the calibration file are then loaded in the text window under the 

IQ Predict (Select Cal File) group box. The user can choose any or all of the available 
experiments for prediction (here all four are chosen).  
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Acquiring/Loading a Spectrum for Prediction 
 

There are three ways that the user can perform a spectrum prediction: the user can acquire a 
spectrum and perform prediction on line; the user can pass an existing spectrum displayed in the 
RamanSoft Analysis Window, or the user can pass a spectrum that was previously acquired and 
saved in the GRAMS SPC file format, to perform spectrum prediction off line. 

 
Acquiring a New Spectrum 
 
1. From the Spectrum Acquiring/Loading group box, choose Acquire New Spectrum. Type in the 

file path and name where the acquired spectrum is to be saved in SPC format from the 
SpectrumPredict interface (e.g., “Sample.SPC”). The user can also click the Browse button to 
conveniently browse to a desired directory to save the file. 

 

 
 
2. Set up acquisition parameters from RamanSoft main menu through the following menu items: 

a. System->CCD Configuration,  
b. Acquisition->Setup, 
c. System->Automation->Setup, 
d. If c, then Analysis->Algorithms Setup. 
 

The important parameters to set up are the CCD integration time, number of frames to 
average, background subtraction, or other data processing methods, if these methods were 
used to create the original training set (Note: it is recommended that that sample spectrum be 
acquired with as much the same experimental conditions with those for acquiring the training 
data set as possible). Input Sample Name, Sample Info, and File Prefix in the Acquisition 
Setup window. It is recommended that the files from RamanSoft and from SpectrumPredict 
interface be saved in the same directory for easier future reference.  
 
 
 
 
 

Note: If no data processing methods is chosen in the System Automation Setup window, 
the user needs to make sure that System->Automation->On is checked so that 
the raw spectrum can be displayed in the Analysis Window and passed to the 
SpectrumPredict interface.  

 
 
3. Put the sample in the sample cell. Make sure that the laser is on by determining that System -

> Laser Setting->Laser On is checked. If not, click on Laser On to turn the laser on. 
 

4. Press the Predict button. The spectrum is acquired and the prediction results are displayed 
on the SpectrumSearch interface. Note that the spectrum is also displayed on the Acquisition 
Window and Analysis Window as well. 
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Passing an Existing Spectrum 
 
This option can be used on any spectrum displayed in the RamanSoft Analysis Window.  
 
1. From Spectrum Acquiring/Loading group box, choose Pass Existing Spectrum. Type in the 

file path and name where you want the spectrum to be saved in SPC format from the 
SpectrumPredict interface (e.g., “Sample2.SPC”). The user can also click the Browse button 
to conveniently browse to a desired directory to save the file. 

 

 
 

2. Open a spectrum file from RamanSoft and display it in the Analysis Window. 
 
3. Press the Predict button. The spectrum and the prediction results are displayed on the 

SpectrumSearch interface. 
 

Opening a Saved SPC File 
 
1. From Spectrum Acquiring/Loading group box, choose Open SPC File.  

 
2. Browse to locate the SPC file saved either through the SpectrumPredict interface or through 

RamanSoft (Note that in RamanSoft if “GRAMS Format (*.spc)” is checked in the File Save 
Preference window, the acquired spectrum will also be saved in SPC format in addition to the 
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LSI format and the text format. We recommend that all spectra be saved in SPC as well in 
RamanSoft so that they will be readily available for all GRAMS functionalities). 

 

 
 

3. Press the Predict button. The prediction results are displayed on the SpectrumSearch 
interface. 

 
 

Viewing the Prediction Results 
 

The prediction results are listed on the upper right section of the SpectrumPredict interface in a 
table form. Each row constitutes a prediction item. If a sample is composed of two constituents 
(Constituent 1, Constituent 2), there will be two line items (rows) for each experiment selected for 
quantitative predictions such as PLS-1, PLS-2, and PCR.  For qualitative prediction method 
Discriminate Analysis, only one row is generated. 

 

 
 

More prediction results and statistics can be viewed by scrolling to the right of the window. Note 
that the columns list all available result information/statistics. These columns are not configurable 
(Note: the configurations set in the SpectrumPredict Configuration window are for the report file 
only, not for the prediction results as tabulated as above on the SpectrumPredict interface). 

 
Sample  The filename for the sample spectrum. 
 
Calibration  The calibration type (i.e., the experiment loaded from the Cal file) 
 
Match Whether the unknown sample matches the calibration samples 

(Yes/No/Possible) 
 
Constituent The constituents of the sample (defined when the training data file (.tdf file) is 

established) 
 
Pred Value The predicted concentration value of the constituent 
 
Actual Value The actual value of the constituent. For Validation calibration type only. 
 
Percent Diff The percent difference between the Pred Value and the Actual Value. For 

Validation calibration type only. 
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M Distance The Mahalanobis Distance between the unknown sample and the calibration 

samples. 
 
Limit_Tests This statistics contains four Pass/Fail tests: Scores, F-Test, M. Distance, 

Concentration. 
 
Scores Test The calculated factor scores for the sample are checked to insure that they 

are within the range of scores of the training data set data for the model. 
 
Residual Test The calculated residuals for the sample are checked to insure that they are 

within the range of residuals of the training data set data for the model. 
 
M-Dist Test The calculated Mahalanobis Distance for the sample is compared to the M 

Dist. Accept and M Dist. Reject levels that were set when the calibration was 
saved (i.e., when the calibration file is created). Samples below the M. Dist. 
Accept level will pass. Sample between the two levels are given a “Possible” 
rating. Any samples above the M. Dist. Reject level will fail the test. 

 
Conc Test The predicted concentration values, if applicable, are checked to insure that 

they are within the range of concentration for each constituent in the original 
training set for the selected model. 

 
Spec Residual The summed spectral residual of the constituent. 
 
F-Ratio The F-ratio value on the spectral residual 
 
F-Test  The F-test value on the spectral residual 
 
Error Description of error if there is an error condition. 
 
SampleSpectrum Sample spectrum. Not displayed in this column. It is displayed in the 

upper plot (in red) of the Spectrum and Residual Display group box. 
 
ResidualSpectrum Residual spectrum. Not displayed in this column. It is displayed in the 

lower plot (in green) of the Spectrum and Residual Display group box. 
 
SampleOrder The order in which the sample being predicted. Note that in 

SpectrumPredict, only one sample can be predicted at a time. 
 
CalibrationOrder The order in which the calibration type (i.e., experiment) is created. 
 
ConsituentOrder The order in which the constituent is established when the training data 

file is created. 
 

The prediction results for each prediction item (i.e., each row displayed in the Prediction Results 
group box) is also displayed in Prediction Results for Item group box on the lower left of the 
SpectrumPredict interface for easy viewing, as shown below. 
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Prediction Message 
 

The text message from a predict session is displayed in the Prediction Message group box of the 
SpectrumPredict interface: 
 

 
 

Upon error conditions, an error message will be displayed, which is the same as that in the Error 
column of the Prediction Results listing.  

 
Spectrum and Residual Display 

 
The sample spectrum and its spectral residual are displayed in the Spectrum and Residual 
Display group box of the SpectrumSearch interface. The residual spectrum is the difference 
between the sample spectrum and the “predicted spectrum”, a spectrum constructed from the 
prediction values.  

 

 
 

Prediction Results Report 
 

The prediction results can be viewed by pressing the Report button on the SpectrumPredict 
interface. The contents in the report is configured through the SpectrumPredict Configuration 
window. 
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Press Save to save the prediction results as Rich Text File (RTF) or as plain text file (.txt). Press 
Print to print the report. Press Close to close the SpectrumPredict Report window. 

 
 

SpectrumPredict Troubleshooting 
 

SpectrumPredict Application Already Started 
 
If the SpectrumPredict application is already started, and the user clicks on RamanSoft Tools -> 

SpectrumPredict or the SpectrumPredict icon  on the Function Toolbar, the following warning 
window will appear: 
 

 
 
Click Ok, and locate the current SpectrumPredict application. 

 

Two SpectrumPredict Application Interfaces 
 
This might occur if the user has clicked OK on the SpectrumPredict Application Warning window 
(see “SpectrumPredict Application Has Already Started” in this section) and then proceeded to 
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restart the SpectrumPredict application (see “Restarting the SpectrumPredict Application” in this 
section). In this case, the user can launch a second SpectrumPredict interface without being 
warned again. Close the newly started SpectrumPredict application. 

 

No Action Occurred After Pressing Predict 
 

The laser might be off, as the system automatically turns the laser off if there is no sample 
acquisition for 30 minutes. Click on System->Laser Setting->Laser On to turn the laser on from 
the RamanSoft main menu (See section “RamanSoft Trouble Shooting” in Chapter 5 for more 
information). 

 

SpectrumPredict Application Warning 
 

If the following window appears after pressing Predict on the SpectrumPredict interface,  
 

 
 
The laser might be off, as the system automatically turns the laser off if there is no acquisition for 
30 minutes. Click on Switch To… button. The Laser Power Status Warning Window will appear.  
 

 
 
Click Yes to turn the laser on. Wait for the laser power to stabilize (the progress bar of the Laser 
Power Stabilizing Progress Window reaches the end). Press Predict to continue. 

 

Invalid File Path/Name of SpectrumPredict Executable 
 
If the invalid file path/name of SpectrumPredict.exe error occurs as shown below: 
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The SpectrumPredict executable might have been relocated from its default location in 
C:\LSI\RamanSoft\exe\SpectrumPredict.exe. Proceed to “Restarting the SpectrumPredict 
Application” and browse to locate SpectrumPredict.exe from the right folder. 

 

Missing Output File Name Error 
 

When passing an existing spectrum for prediction and there is no file name/path in the text field, 
the following error would appear: 
 

 
 

Click OK to close the application, and proceed to the trouble shooting topic “Restarting the 
SpectrumPredict Application”. Enter the file path/name to save the unknown sample spectrum in 
SPC format from the SpectrumPredict interface, and press Predict to continue. 

 

Invalid File Format Error 
 

In saving prediction report through File->Save, if the user presses on Cancel button, the following 
error might occur: 

  

 
 
Click OK to close the application, and proceed to the trouble shooting topic “Restarting the 
SpectrumPredict Application”.  

 

Prediction Error 
 

If a prediction error occurs, the error message will appear in the Prediction Message group box. 
The Match column in the Prediction Results listing will display “Error”, and the residual spectrum 
will not be plotted as the sample spectrum is not predicted. The following figure shows a 
prediction error resulted from the fact that the training data set files and the sample spectrum 
differ in their x-axis scale. 
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Run-time Error 
 

If run-time error occurs, such as 
 

 
 

Press OK, and proceed to trouble shooting topic “Restarting the SpectumPredict Application”. 
 

Unknown Error Conditions 
 

If the SpectrumPredict module crashes, or any other error conditions arise from this module, 
proceed with “Restarting the SpectrumPredict Application”. 
 
Upon any other error conditions, exit both programs (exit SpectrumPredict first and then exit 
RamanSoft), and re-launch RamanSoft.  
 
If neither of the above two procedures works, restart the computer.  
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Restarting the SpectrumPredict Application 
 
 Go to RamanSoft System->SpectrumPredict, and check the Clear Flag checkbox. 
 

 
 
Click OK, and then restart the SpectrumPredict application by clicking on RamanSoft Tools -> 

SpectrumPredict or the SpectrumPredict icon  on the Function Toolbar. 
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8 The Real Time Monitoring Module 
 
 

Overview 
 

The Real Time Monitoring Module is designed to meet the need to monitor a process in real time. 
For example, in a chemical reaction process, the concentration of each reactant or the product 
may change as a function of the reaction time. When the Dimension Raman system is set to 
acquire the spectrum of the chemical reaction system, the characteristic peak intensities in the 
acquired Raman spectrum will change dynamically in response to the reaction process. The Real 
Time Monitoring module can monitor up to five peaks simultaneously either in peak intensity or in 
peak area as a function of time. 

 
 

Launching the Real Time Monitoring Module 
 

To start the Real Time Monitoring module, click on Tools->Real Time Monitoring from RamanSoft 
main menu. 
 

 
 

Alternatively, you can start the Real Time Monitoring module by clicking on  from the Function 
Toolbar.  

 

 

Real Time Monitoring 
 

 
 

 
 

The Real Time Monitoring User Interface 
 
Upon module start-up, the Real Time Monitoring user interface appears as follows. The interface 
consists of the main menu, the Measurement Window, the Tabulation Window, and the Plot 
Window. 
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Measurement Window

Tabulation Window

Plot Window 

 
The main menu consists of the File and Configuration menu items. 
 

 
 
 

The File Menu 
 

The File menu contains Load, Save, Print, and Exit submenu items. 
  

 
 

Load 
 

This allows for loading the previously saved real time monitoring results and displaying them on 
the Real Time Monitoring interface.  
 
Click File->Load, browse to the directory where the final Real Time Monitoring results are saved 
(Text files), choose a filename in the file Open window. Click Open. The previously saved results 
will be loaded and listed in the Tabulation Window and displayed in the Plot Window. 
 

Save 
 

This allows for saving the real time monitoring results into a text file.  
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After a Real Time Monitoring session has completed and the monitoring results have been 
displayed on the Real Time Monitoring interface, click File->Save. Type in a file name, and click 
the Save button. The results are saved in a text file. 
 
 The saved results can later be loaded into the Real Time Monitoring interface through File -> 
Load. 

 

Print 
 

This allows for printing the real time monitoring results onto the default printer that your computer 
connects to. 
 

Exit 
 

This exits the Real Time Monitoring module. 
 
 

The Configuration Menu 
 

The Configuration menu contains only one menu item, the Configuration Setup. 
 

 
 

Click on Configuration->Configuration Setup to bring up the Real Time Monitoring Configuration 
window.   
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Selection of Spectrum Peaks for Monitoring 
  
Enter the Sample Name for the sample to be monitored, and specify the Number of Peaks to be 
monitored. As many as 5 peaks can be monitored at the same time. The selection of the Number 
of Peaks will dynamically enable or disable the edit boxes for Peak Start Pos and Peak End Pos. 
Enter the peak start and peak end position values for the peaks of interest. Acquire a spectrum of 
the sample of interest and display it on the RamanSoft Acquisition Window or Analysis Window 
and use the cursor to locate the peak start and peak end positions. Click OK each time after 
entering the numbers before going back to RamanSoft Acquisition Window or Analysis Window to 
identify other peaks so that the entered information is saved by the program. 

 
Monitoring Parameters  
 
Enter the number of time points to monitor and the time delay between consecutive time points in 
the # of Time Points and Time Interval edit boxes, respectively. The maximum number of time 
points is 1024.   
 
Enter the core filename in the Input Core File Name text field. For processes that are not time-
critical, RamanSoft appends a sequential integer number to the core file name to form a filename 
for the spectrum at each time point and save it into the specified data folder (specified through 
RamanSoft main menu Acquisition->Setup). For time-critical processes (i.e., when Disable All 
Data Processing During Measurement is checked at the Advanced Options group box), only a 
multifile is saved, using the core file name appended with the total number of time points as the 
filename. 

 
Select either the absolute peak intensity or the peak area for monitoring, or the peak ratio 
calculated either by peak intensity or peak area. The Peak Intensity is the maximum peak 
intensity between the peak start position and the peak end position. The Peak Area is calculated 
by summing all the intensity values of the spectrum points between the peak start position and 
the peak end position. The Peak Ratio is the ratio of the peak intensity or peak area values to that 
of the peak specified in To Peak selection box.  

 
Acquisition Speed 
 
This allows the user to choose fast or standard (or, default) CCD digitization speed, each of which 
has different overhead times (data readout time). The Fast Speed gives shorter overhead time 
but lower signal-to-noise ratio. It is recommended for acquisition times less than 50 milliseconds. 
Default Speed gives longer overhead time but better signal-to-noise ratio. The overhead time 
from CCD readout delay is displayed in the Overhead Time textbox in the Monitoring Parameter 
group box.  
 
Note that the Acquisition Speed option shown here is the same as that in the CCD Camera 
Parameter Setup window accessed from RamanSoft main menu System->CCD Configuration. 
But for Real Time Monitoring applications, this speed needs to be configured here to be effective. 
 
Advanced Options 

 
Disable All Data Processing During Measurement. Check this option to disable all data 
processing including file saving and data displaying during real time monitoring in order to 
achieve minimum overhead time for time-critical processes. When this option is chosen, no data 
display is available and only the Real Time Monitoring progress bar is active. The data 
processing, file saving, and data displaying are performed at the end of the real time monitoring 
process.  
 
Note that when this option is chosen, only a multifile is saved at the end of the real time 
monitoring process. No individual files (i.e., single files) are saved for each time point. 
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Disable Data Display in Acquisition/Analysis Windows Only. Check this option to disable data 
display in the RamanSoft Acquisition Window and Analysis Window only. The Real Time 
Monitoring interface remains active, i.e., it displays the tabulated intensity or area data in the 
Tabulation Window and the plotted data in the Plot Window. This option allows for a lower 
overhead time for a real time monitoring process. 

 
Disable Data Display in Real Time Monitoring Only. Check this option to disable data display in 
the Real Time Monitoring interface only. Disable this data display to give less overhead time. 
 
Keep Shutter on During Measurement. Check this option to keep shutter on all the time during the 
real time monitoring process. This is recommended for process monitoring with small time delays 
(i.e., Time Interval) between measurement points (e.g., < 1 s). This would help to minimize the 
mechanical wearing of the shutter by keeping it from frequent opening and closing. 

 
 

Performing a Real Time Monitoring Measurement 
 

Proceed with the following steps to perform a real time monitoring measurement: 
 
1. Set up real time monitoring configurations in the Real Time Monitoring Configuration window. 
 
2. Set up acquisition parameters from RamanSoft main menu: 

 
a. Set up CCD integration time and other CCD camera parameters through System -> 

CCD Configuration. 
 
b. Set up file Path through Acquisition->Setup. This is where all the files from Real Time 

Monitoring as well as from RamanSoft are saved. Input sample name, sample info, 
and file prefix. 

 
c. Set up data processing methods through System->Automation->Setup. 

 
d. Configure data processing algorithms through Analysis->Algorithms Setup for the 

chosen methods in c. Remember to click Apply button on the Algorithm Setup page 
after an algorithm is configured. 

 
 
 

Note: If no data processing methods are configured in System Automation Setup 
window, the user needs to make sure that System->Automation->On is checked 
so that the individual files can be saved for each measurement point during the 
Real Time Monitoring process. 

 
 
 
3. Put the sample to be monitored in the sample cell.  
 
4. Press Start button on the Real Time Monitoring interface. The progress bar displays the 

measurement progress. At each measurement point, the program acquires one spectrum and 
display it in the Acquisition Window, as well as in the Analysis Window if System-
>Automation->On is checked. The calculated peak intensities or peak areas or peak ratios 
are tabulated in the Tabulation Window and displayed in the lower Plot Window of the Real 
Time Monitoring interface (Note: the data display depends on the configuration of the 
Advanced Options in the Real Time Monitoring Configuration window). 
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The vertical axis of the plot is either the peak intensity or the peak area depending on the 
selection of parameter to monitor. The scale of the vertical axis will be dynamically adjusted 
at each measurement point so that the vertical display range covers all the data points. The 
horizontal axis of the plot is “Time Elapsed” (in seconds). The range of the horizontal scale is 
calculated and updated for each real time monitoring configuration.   
 
The “Time Elapsed” quantity is defined as following: 
 
TElapsed (i)  =  CCD_Integration_Time * (i + 1) + Time_Interval * (i) + Overhead_Time *(i+1) 
 
Where i = 0, 1, 2, ….n - 1 and n is the total number of time points. For the first time point, i = 
0. 
 

5. During the real time monitoring measurement, you are able to abort the measurement any 
time by clicking on the Abort button (Note: Please be patient after clicking the Abort button. 
The program needs a delay time to respond to the abort action. This is especially the case if 
the CCD integration time at each measurement point is long (e.g., > 3 seconds), or the time 
interval between each data point is large (e.g., > 10 seconds) ). 

 
6. When the monitoring process is completed (the progress bar reaches the end), RamanSoft 

automatically takes one additional acquisition and saves the spectrum in the location and with 
the filename as configured in Acquisition->Setup. This action resets RamanSoft 
configurations to the values prior to the Real Time Monitoring application so that the system 
is ready for next regular RamanSoft acquisition. 

 
7. The user is prompted to save the results into a text file. 
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The user can save the results by pressing Yes, and input a filename. The user can also 
choose File->Save to save the results into a text file. Either way, the saved file contains the 
system parameters as well as configuration settings in the file header, and columns of data 
entries: the time point index, the time elapsed (in seconds), and peak intensity or peak area 
for each monitored peak. 

 

 
 
 

File Operations 
 
There are several sets of files generated and automatically saved for a Real Time Monitoring 
application; the exact number of sets depends on the configuration settings. The following figure 
shows the files generated in a none time critical real time monitoring process in which no data 
processing methods are selected (so that there are no *.pro files saved for each time point). 
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1. Individual files (also termed “single files”) for each measurement point. These files are named 

using the Core File Name appended with an index number for each time point, and they are 
regular RamanSoft files (i.e., *.raw files,  *.pro files if any data processing methods are 
configured through System->Automation, *.txt files, and *.spc files if GRAMS Format option is 
checked in File->Preferences). In the above figure, files CHRTM-1…CHRTM-10 are such 
files. 

 
Note that for time critical process (i.e., the Disable All Data Processing During Measurement 
option is checked in the Real Time Monitoring Configuration window), these single files are 
NOT saved. 

 
2. A multifile for the RTM application. This file (in LSI “.pro” file format) contains all the spectral 

data at each measurement point. In the above figure, CHRTM-10M.pro is such a file. The “M” 
in CHRTM-10M.pro indicates that this is a multifile; this file contains all the spectral data for 
10 measurement points. 
 
To open a multifile, go to RamanSoft File->Open, browse to the directory where the multifile 
is located, choose the filename, and click Open. The multifile is automatically displayed as 
single files, each of which contains the spectral data at one measurement point. These files 
are listed in  the File View Window, and the last one is displayed in the Analysis Window. 
Note that the program appends a sequential integer number to the multifile filename to form 
the filename for each temporary single file. 
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Double click on a filename in the File View Window, the spectrum will then be displayed in 
the Analysis Window. The user can save this file by clicking on File->Save As->Analysis 
Window. 
 
Note that these single files are temporary files stored in C:\RamanData\Temp. When 
RamanSoft is exited, the entire Temp folder is deleted. 

 
3. Regular RamanSoft files (they are also single files) acquired at the end of the real time 

monitoring process. These files take the filenames using the File Prefix in the Acquisition 
Setup window appended by a time string (e.g., cyclohexane0213193812-1.raw, 
cyclohexane0213193812-1.txt). 

 
4. The Real Time Monitoring result file. This is a text file that the user saved at the end of the 

real time monitoring process and can later be loaded into the Real Time Monitoring interface 
to be viewed (e.g., CHRTM.txt.
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9 Virtual RamanSoft 
 
 

Overview 
 

This chapter briefly describes how to operate RamanSoft without turning on the Dimension 
Raman System. This can be used, for example, performing offline data analysis. 
 

 

Using Virtual RamanSoft 
 

1. From Windows® start menu, go to All Programs and choose LSI->RamanSoft, or double 
click the RamanSoft shortcut icon on the desktop. 

 
2. Choose the configuration file, and click Open. 

 
3. The CCD camera initialization would fail, since the Dimension Raman System is not 

turned on for RamanSoft to communication with the camera. 
 

 
 

4. Click on OK to accept the hardware status. 
 

5. RamanSoft would start, and a warning would appear to warn the user that a log file will 
not be able to be created. 

 

 
 

6. Click OK to accept the fact that no log file will be created for the offline RamanSoft 
session. 

 
7. Proceed to use RamanSoft to perform data analysis. Note that in this offline mode, no 

data acquisition action can be performed. 
 

8. Exit RamanSoft by choosing File->Exit, the user can choose to save the configuration file 
before exiting. 
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Appendix I  System Specifications 
 

Dimension-P1™ Dimension-P2™
 

Raman Systems SR Model HR Model SR Model HR Model 
Spectrometer 
Optics 85 mm, f/1.8 lens-based, Czerny-Turner spectrograph 

Nominal Resolution 2.5 cm-1 /pixel 1.5 cm-1/pixel 3 cm-1/pixel 2 cm-1/pixel 

Coverage 150 - 3300 cm-1 150 - 2075 cm-1 150 - 3000 cm-1 150 - 1950 cm-1 

Sensitivity(@100 mW 
w/785 nm laser)  

>10,000 counts at 992 cm-1 of Na2SO4       
@ lowest of 3 available gain settings        

>5,000 counts at 992 cm-1 of Na2SO4  
 

Detector 
CCD 1340 ×  100 pixels, 20 μm ×  20 μm 1024 ×  124 pixels, 24 μm ×  24 μm 

TE Cooling < -70°C < -15°C 

Digitization Rate 
(16 bits) 

100 kHz, 2 MHz 100 kHz 

Excitation Lasers 
Laser 785 nm  (other wavelengths at 632.8 nm and 532 nm available) 

Laser Power Up to 700 mW  (0 - 350 mW to the sample) -  Stability  ±1% 

Sampling 
Probe LSI Vector Raman ProbeTM, 1 meter fiber cable standard (other lengths available) 

Sample Cells 4-position internal sample cell and multi-

purpose External Sampling Module 

Multi-purpose External Sampling Module 

Software 
RamanSoft™ Control of laser power, CCD settings, data acquisition, processing & analysis including 

quantification, Real-Time Monitoring, SpectrumSearch™ , SpectrumPredict™ 
Dimensions 
L ×  W ×  H 52 cm  39 cm × ×  20 cm 39 cm ×  25 cm ×  15 cm 

Weight 18.5 kg 10 kg 

Options 
Microscope Nikon and Olympus Microscopes, other brands available 

Microscope Adapter Raman Microscope Adapter to microscopes 

Calibration Kit Sources and tools for wavelength and instrument response calibration. Sealed sample for 
laser wavelength calibration 

Add’l Software GRAMS/AI™ 7 with PLSplus/IQ™ add-on, or IQ PredictTM; Spectral ID® 
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Appendix II  Mercury Lamp Peaks for 
Wavelength Calibration 
Figure IIA. Mercury Lamp Peaks Identified by a Dimension-P1 HR Raman System. 
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Table IIA. The Standard Mercury/Argon Lamp Peaks for Auto Wavelength Calibration for 

Dimension-P1 HR Raman System. 
 

Peak 
Index 

Pixel Number 
 

Wavelength 
(nm) 

1 3 794.82 
2 47 800.616 
3 54 801.479 
4 122 810.369 
5 131 811.531 
6 249 826.452 
7 366 840.821 
8 379 842.465 
9 460 852.144 
10 588 866.794 
11 1028 912.297 
12 1141 922.45 

 
This table lists the 12 mercury/argon lamp peaks used for the auto wavelength calibration on a 
Dimension-P1 HR Raman System. The Peak Index column lists the peak number, the Pixel 
Number column lists the approximate pixel positions of the peaks, and the Wavelength column 
lists the standard wavelength (in nm) for each corresponding peak. 
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Figure IIB. Mercury Lamp Peaks Identified by a Dimension-P1 SR Raman System. 
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Table IIB. The Standard Mercury/Argon Lamp Peaks for Auto Wavelength Calibration for 

Dimension-P1 SR Raman System. 
 

Peak 
Index 

Pixel Number 
 

Wavelength 
(nm) 

1 6 794.82 
2 35 800.616 
3 39 801.479 
4 84 810.369 
5 89 811.531 
6 164 826.452 
7 236 840.821 
8 244 842.465 
9 292 852.144 
10 365 866.794 
11 592 912.297 
12 643 922.45 
13 863 965.778 
14 1113 1014 

 
This table lists the 14 mercury/argon lamp peaks used for the auto wavelength calibration on a 
Dimension-P1 SR Raman System. The Peak Index column lists the peak number, the Pixel 
Number column lists the approximate pixel positions of the peaks, and the Wavelength column 
lists the standard wavelength (in nm) for each corresponding peak.
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Appendix III  The Maximum Peak of 
Cyclohexane for Laser Wavelength Calibration 
Figure IIIA. Maximum Cyclohexane Peak Identified by a Dimension-P1 HR Raman System. 
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Figure IIIA. Maximum Cyclohexane Peak Identified by a Dimension-P1 HR Raman System. 
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Warranty & Service 
 

Limited Warranty 
 

Lambda Solutions, Inc (“Lambda Solutions,” “LSI,” “us,” we, “our”) makes the following limited 
warranties. These limited warranties extend to the original purchaser (“you”) only and no other 
purchaser or transferee. LSI has complete control over these warranties, explicit or implied, and 
may alter or discontinue any or all warranties at any time. 

   

Basic Limited One (1) Year Warranty 
 

LSI warrants this product against defects in materials and/or workmanship for a period of up to 
one (1) year after shipment. In the case of lasers, this warranty is for ten thousand (10,000) hours 
or up to one (1) year whichever comes first.  LSI will repair or replace any defective part without 
charge to you. You must deliver the entire product to LSI after receiving a Return Authorization. 
You must pay for shipping to LSI and we pay for shipping back to you. For further information on 
support and returns contact us at 781-478-0174 or www.lambdasolutions.com.  Field service or 
part replacement will be performed at the discretion of LSI. In the case of international customers, 
you should contact your local authorized representative or distributor for repair information. 

 

Basic Limited One (1) Year Warranty on Standard & Optional Accessories 
 
LSI warrants all accessories, standard and optional, against defect in materials and or 
workmanship for a period of up to one (1) year after shipment. These items include the External 
Sampling Module, Vector Raman Probe and Raman Microscope Adapter. LSI will replace or 
repair items at no cost to you. You must pay for shipping to LSI and we pay for shipping back to 
you. Returns or replacements are accepted by LSI only after the issue of a Return Authorization. 
In the case of international customers, you should contact your local authorized representative or 
distributor for return or replacement information. 

 

Princeton Instruments PIXISTM CCD Camera 
 

For information on warranty for the Princeton Instrument PIXIS CCD camera unit, please refer to 
their warranty enclosed below. You must contact LSI regarding all warranty and service granted 
by Princeton Instruments. CCD repair or replacement requires shipment of the entire product to 
LSI. Failure to return CCD’s through LSI voids this limited warranty. You must pay for shipping to 
LSI and we pay for shipping back to you. In the case of international customers, you should 
contact your local authorized representative or distributor for return or replacement information. 

 

User Manual and Troubleshooting 
 

LSI has endeavored to make the User Manual comprehensive and complete with respect to the 
Dimension Raman unit (Dimension-P1™, Dimension-P2TM) and accessory hardware assembly 
and the operation of RamanSoftTM software. You should read this manual thoroughly before 
operating this product.  
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Buyer’s Responsibility 

ertain solely to Original Purchasers of this product or parts 
obtained from Lambda Solutions, Inc. or an authorized representative/distributor and are subject 
to the following terms and conditions. 

e on your Dimension-P1™ or Dimension-P2TM, you must have your 
Service Tag Number available. This number will be on your Invoice and on the back panel of 

air 

sales/distributor representative within 
r you have taken delivery of this product or a part thereof that you consider 

who have a verified claim of a “technical 
art, all invoices must be paid within (30) days of 

delivery or in accordance with a written negotiated term of sale. Failure to do so may result, 
 

 

 

ber 
(RAN). Product or parts received by Lambda Solutions without an RAN will be returned, 
freight collect. 

 
. Unless specified in the original purchase agreement, Lambda Solutions is not responsible for 

ting or 

 

llow procedures described in the User 
Manual; 

 any way or which are illegible; 

 

8. Units that have sustained physical damage or have been altered or modified are not 
rranty status and will be returned at your expense. 

 
9. All warranties implied by state law or non-U.S. laws, including the implied warranties of 

 
ns 

 seller with respect to the repair and replacement of any parts.  In no 

 
The foregoing Limited Warranties p

 
1. For repair or servic

the instrument. For optional parts and accessories purchased separately, you must retain 
your bill of sale (invoice) and submit a copy  to Lambda Solutions, Inc. upon request for rep
or part replacement.  

 
tify Lambda Solutions or your authorized 2. You must no

(30) days afte
defective. With the exception of customers 
operational issue” with the product or a p

at the discretion of Lambda Solutions, in the interruption or cancellation of your one (1) year
limited warranty and/or any other warranty, expressed or implied. 

3. All warranty service must be carried out by the LSI factory or at an authorized service center 
designated by Lambda Solutions, Inc.  

4. Prior to returning any product or parts for service or replacement, you must contact Lambda 
Solutions, Inc. or your authorized representative and obtain a Return Authorization Num

5
installation and setup. In addition, you are responsible for disassembly or for contac
contracting with Lambda Solutions or an authorized technical representative to assist you. 

6. Warranties are limited as described above and pertain only to defects in materials or 
workmanship and do not extend to product or parts that have: 

• been lost or discarded by you; 
• been damaged as a result of misuse, improper installation by you, faulty or 

inadequate maintenance or failure to fo

• had serial numbers removed or altered in
• been serviced by unauthorized personnel; 
• been damaged as the result of environmental conditions, liquid spills, fire, flood, 

radiation or other “acts of God” or conditions beyond the control of Lambda Solutions.
 

7. At the end of the warranty period you may contact Lambda Solutions, Inc. or an LSI 
authorized representative for repair information and service and/or obtain extended warranty 
and service plans. 

 

acceptable for repair regardless of wa

merchantability and fitness for a particular use are expressly limited to the duration of the 
limited warranties set forth herein.  With the exception of any warranties implied by state law
or non-U.S. laws, as hereby limited for one (1) year, the agreements, and similar obligatio
of manufacturer and
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event will Lambda Solu
defective product or part. 

tions’ liability exceed the cost of the repair or replacement of the 

 

plied warranty lasts, when an action may be brought, or 
ns 

 

ions.com

10. This limited warranty gives you specific legal rights and you may also have other rights that 
may vary from state to state and from country to country.  Some states and countries do not 
allow limitations on how long an im
the exclusion or limitation of incidental or consequential damages, so the above provisio
may not apply to you. 

11. When contacting us for technical support or service assistance, contact Lambda Solutions 
representative or distributor, or visit our technical support page or email to 
support@lambdasolut .  

 

e right to use 
TM

D LIMITATIONS  
t 

o Separation of Components. The SOFTWARE PRODUCT is licensed as a single 

rly 
eing eligible for the 

eled as 
ibility 

he 

OFTWARE PRODUCT (including but not 

O UCT are owned by Lambda Solutions, Inc and third party software suppliers. Copyright 
re, you 

 
 

 

Single End-User License Agreement and Warranty for RamanSoftTM 

Software Product License  
 
1. GRANT OF LICENSE. Lambda Solutions, Inc. (“Licensor”) hereby grants you th

one copy of the RamanSoft  software product (“Software Product”). 
2. DESCRIPTION OF OTHER RIGHTS AN

o Limitations on Reverse Engineering, Decompilation, and Disassembly. You may no
reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and 
only to the extent that such activity is expressly permitted by applicable law 
notwithstanding this limitation.  

product. Its component parts, if any, may not be separated for use on more than one 
computer.  

o Software Transfer. You may not give away, sell, rent, lease, or lend the SOFTWARE 
PRODUCT.  

3. UPGRADES. If the SOFTWARE PRODUCT is labeled as an upgrade, you must be prope
lice d ambda Solutions, Inc. as bnse  to use a product identified by L
upgrade in order to use the SOFTWARE PRODUCT. A SOFTWARE PRODUCT lab
an upgrade replaces and/or supplements the product that formed the basis for your elig
for the upgrade. You may use the resulting upgraded product only in accordance with t
terms of this agreement.  

4. COPYRIGHT. All title and copyrights in and to the S
limited to any images, photographs, animations, video, audio, music, text, and "applets" 
incorporated into the SOFTWARE PRODUCT), and any copies of the SOFTWARE 
PR D
laws and international treaty provisions protect the SOFTWARE PRODUCT. Therefo
must treat the SOFTWARE PRODUCT like any other copyrighted material except that you 
may install the SOFTWARE PRODUCT on a single computer. 

Software Limited Warranty 
 
LSI warrants all of our manufactured software disks to be free from substantial defects in 
materials and/or workmanship under normal use for a period of one (1) year of shipment.  This
software and the accompanying files (if any) are provided and sold "as is" without warranty of any
kind, either express or implied, including but not limited to the implied warranties of 
merchantability and fitness for a particular use. 
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Lambda Solutions, Inc. warrants that RamanSoftTM will perform substantially in accordance w
Lambda Solutions, Inc.'s writte

ith 
n materials accompanying it for a period of one (1) year from the 

date you first acquired the software. Some states and jurisdictions do not allow limitations on 

 on the duration of an implied warranty, so the above limitation may 
not apply to you. 

TIONS 
ILL MEET ALL YOUR REQUIREMENTS, OR THAT THE 

OPERATION OF THE SOFTWARE WILL BE UNINTERRUPTED OR ERROR-FREE.  NO ORAL 
OR WRITTEN INFORMATION OR ADVICE GIVEN BY Lambda Solutions, Inc. SOFTWARE OR 

TY OR IN 

 WHATSOEVER INCLUDING DIRECT, INDIRECT, INCIDENTAL, 
 BUSINESS PROFITS OR SPECIAL DAMAGES, EVEN IF LSI 

AS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.  

Cont
 

.com 

duration of an implied warranty, so the above limitation may not apply to you. To the extent 
allowed by applicable law, implied warranties on the SOFTWARE PRODUCT, if any, are limited 
to one (1) year. To the extent that implied warranties on the SOFTWARE PRODUCT are 
disclaimable, they are disclaimed herein below. Some states and jurisdictions do not allow 
disclaimers of or limitations

 
Lambda Solutions, Inc. SOFTWARE DOES NOT WARRANT THAT THE FUNC
CONTAINED IN THE SOFTWARE W

ANY OF THEIR AUTHORIZED REPRESENTATIVES SHALL CREATE A WARRAN
ANY WAY INCREASE THE SCOPE OF THIS WARRANTY. IN NO EVENT SHALL LSI BE 
LIABLE FOR ANY DAMAGES

ONSEQUENTIAL, LOSS OFC
H

 
   

act Information 
Lambda Solutions, Inc. 
411 Waverly Oaks Road 
Waltham, MA 02452, U.S.A. 
 
Tel:  1-781-478-0170 
Fax: 1-781-478-0175 
 
www.lambdasolutions
support@lambdasolutions.com 
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