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1.  General Information

The GADDS Software Reference Manual is 
designed to supplement the GADDS User’s 
Manual and the GADDS Administrator’s Manual. 
Information already contained in these manuals 
is not duplicated here.

See the GADDS User Manual for:

• General descriptions of the instrument: 
goniometer, stages, generator, etc.

• General operation of the instrument: power-
up, operation, shut-down, etc.

• Theory of analysis

• Geometry conventions

• Typical applications of GADDS to solve 
common diffraction problems

See the GADDS Administrator’s Manual for:

• Pre-installation, installation, alignment, and 
calibration instructions

• Flood-field, spatial, and beam center 
instructions

• Software installation and release notes

• Software customization instructions

• Test procedures

• General maintenance

• Bruker service
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1.1 Program Overview

GADDS is part of a suite of programs available 
from Bruker AXS, Inc. for using an Area Detec-
tor for powder diffraction problems. In addition to 
the GADDS software, optional packages are 

DIFFRACplus, TOPAS P, SAXS, ASTRO, etc.

The functions of these programs are briefly 
summarized as follows:

• GADDS is the essential instrument control 
and data acquisition program which controls 
all hardware functions associated with the 
multi-wire-based X-ray diffractometer sys-
tems. It contains a comprehensive set of 
online and off-line functions and algorithms 
for instrument calibration, specimen screen-
ing, and frame data acquisition. GADDS 
also includes an option to display ICDD 
PDF2 database patterns and search the 
NIST database of known unit cell dimen-
sions. These features will be described in 
detail in this manual.

• ASTRO is a supplementary utility program 
that may be used in conjunction with the 
GADDS program to optimize data collection 
strategies for single crystal type applica-
tions. Use it to minimize data collection time 
by collecting only a unique portion of the 
reflection data or to design custom data col-
lection strategies. This program is described 
in detail in the ASTRO Technical Reference 
Manual.

• TOPAS P is a profile fitting program for fun-
damental parameter and general lineshape 
fitting of diffraction spectra. This program is 

described in detail in the PROFILEplus Man-
ual.

• DIFFRACplus for GADDS is a complete set 
of integrated programs for evaluation, 
search / match, etc. on 1D spectra. Pro-

grams included in the DIFFRACplus package 
include:

EVA—Graphical evaluation package.

Diffrac File Exchange—Similar to Raw2Raw 
utility, but more limited except with UXD file 
formats.

PDF Database Maintenance—Utility to view 
and manipulate PDF database.

XRD Evaluation Program—Graphical evalu-
ation package with optional search/match 
algorithm.

XRD Quantification Program—Graphical 
quantification package.

These programs are described in detail in the 

DIFFRACplus Manual.
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GADDS may be executed in either online or off-
line mode. The online version of GADDS sup-
ports a variety of goniometer stages and other 
instrument configurations including the following 
hardware options:

• HISTAR detector and dual HISTAR detec-
tors

• D8 Discovery, Platform, Aztalan, or P4 goni-
ometers

• Phoenix (D8) or GGCS (all others) goniom-
eter controllers

• Numerous different goniometer stages

• Watlow temperature controller

• Sealed tube or rotating anode generators

• SMART rotary shutter

• Optical microscope or CCD video camera 
with zoom control and laser alignment

The online version of GADDS is a powerful and 
flexible instrument control sample analysis data 
collection package. The program couples the 
precise control of the goniometer angles and X-
ray shutters (through the GGCS controller) with 
the operation of two-dimensional, multi-wire X-
ray detectors to yield highly accurate and repro-
ducible two-dimensional images (frames) of X-
ray diffraction patterns. GADDS includes a wide 
range of instrument functions (e.g., open/close 
shutter, drive angles, etc.), calibration routines, 
sample screening options (e.g., add, rotation, 

etc.), automatic routines (e.g., scripts) and auto-
mated frame data collection. Frame data may be 
collected in a variety of modes optimized for 
individual instrument configurations or sample 
properties.

Examples of typical applications of the GADDS 
system are:

• Routine data collection on transmission of 
reflection samples

• Phase ID problems

• Micro-diffraction problems

• Texture analysis

• Stress analysis

• Crystallite size

• Percent crystallinity

• SAXS



General Information GADDS Software Reference Manual

1 - 4 M86-E01008

1.1.1 Basic GADDS Operation

1. Click on the GADDS icon to execute the 
online version of GADDS.

2. Verify that the correct project have been 
loaded.

3. Verify that the appropriate calibration files 
have been loaded and that the goniometer 
angles and the values of the distance and X 
and Y beam centers are correct. Update, if 
necessary.

4. Select the appropriate level for the experi-
ment (e.g., Level 1 [beginner] or Level 2 
[experienced]).

5. Mount the specimen and proceed with the 
experiment. Individual steps will be 
described this manual.

6. To exit from the program, drive all angles to 
zero and click on the File > Exit option. Do 
not exit from the program by clicking the 
Windows NT close button—this will cause 
abnormal termination and loss of configura-
tion data!
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1.2 Environment Variables
(Logical Names)

Under WNT, logical names are stored as envi-
ronment variables. Entering environment vari-
ables are done through Control Panel's System 
Applet. You may enter environment variables as 
either system (available to all users) or as user 
(available only to the current user).

Logical names which point to directories should 
end with a colon “:” and the translation should 
end with the directory separator “\”.

Example: Defining the GADDS$FRAMES direc-
tory

set GADDS$FRAMES:=C:\FRAMES\

To display a frame, say cor1.001, from the 
GADDS$FRAMES directory the name to enter 
in the DISPLAY /NEW panel would then be:

GADDS$FRAMES:cor1.001

If the default working directory in the GADDS 
Project > New/Edit/Copy panel is defined as 
GADDS$FRAMES:, you would need to enter 
only “cor1.001” in the File > Display > New 
panel.

In order to allow users flexibility in working with 
multiple products on the same computer (e.g., 
FRAMBO and GADDS) GADDS supports pro-
gram-specific logical names (environment vari-
ables). The program-specific names are 
GADDS$SYSTEM:, GADDS$SYSDATA:, and 

GADDS$FRAMES:, which serve the same pur-
pose as SAXI$SYSTEM: (points to executables 
and help files), SAXI$SYSDATA: (points to color 
lookup table directory) and SAXI$FRAMES: 
(points to directory containing frame and plot 
data). If the program-specific name exists, its 
translation is used. If it does not exist, the pro-
gram attempts to use the corresponding SAXI$ 
name; thus, the program remains compatible 
with earlier logical name setups.

GADDS recognizes the following logical names.

GADDS$CALIB:

This variable translates to the directory 
which contains area detector calibration 
files, such as flood-field and spatial tables.

GADDS$FRAMES:

This variable translates to the root directory 
which contains area detector frames, cali-
bration files, project files, and 1D spectra 
(raw files).

GADDS$PROJECT:

This variable translates to the full pathname 
of the file to be used as the project data-
base, for example, 
D:\frames\projects\gadds.prj.

GADDS$SCRIPTS:

If present, this optional variable translates to 
the name of the common script directory. 
Whenever a script file is specified without a 
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directory, the program will search for the 
script file in three places: current project 
directory, system data directory, and com-
mon script directory.

GADDS$SYSTEM:

This variable must translate to the name of 
the directory where the area detector pro-
grams, utility programs, new project 
defaults, and help files reside (e.g., 
C:\SAXI\GADDSnew\).

GADDS$SYSDATA:

This variable must translate to the name of 
the directory where the area detector data 
files (e.g., color lookup tables, calibration 
files, usertask.ini) reside. 
(C:\SAXI\GADDSnew\).

GADDS$TEST:

This variable must translate to the name of 
the directory where the test frames and test 
command files reside. (e.g., 
C:\SAXI\GADDSnew\TEST\).

GADDS$CDCODE:

This variable translates to the directory 
which contains the NIST journal file: 
CODENS.DAT. If missing, it defaults to 
GADDS$CDROM:\vaxind\. (e.g., D:\crys-
tal\vaxind\).

GADDS$CDF:

This variable translates to the directory 
which contains the NIST index file: CRY-
IDX.BIN. (e.g., C:\saxi\).

GADDS$CDROM:

This variable translates to the directory 
which contains the NIST database file: 
CRYSTAL.DAT. (e.g., E:\crystal\).

PROF$SYSTEM:

This optional variable translates to the name 
of the directory where the profile fitting 
package resides. (e.g., C:\TopasP\). See 
Special > Spawn, Section 9.8.

GADDS$PPF

This variable if defined, instructs GADDS to 
process pole figures in 1.0° resolution using 
bin integration and to create a partial pole 
figure ASCII file.

PDF2$IND:

This variable translates to the directory 
which contains the PDF2 index files. These 
files should be copied from slow CDROM to 
the faster hard disk. (e.g., C:\PC-PDF\).

PDF2$KEY: 

This variable translates to the directory 
which contains the PDF2 search indexes: 
PDF2.S##. (e.g., E:\PDF2\).
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PDF2$PDF:

This variable translates to the directory 
which contains the PDF2 database file: 
PDF2.DAT. (e.g., E:\PDF2\).

SAXI$ADMODEL

Sets the combination of goniometer and 
controller assumed for instrument control 
purposes by GADDS. The environment vari-
able SAXI$ADMODEL, if defined, must 
translate to:

P3X2000 for 4-circle systems

X2000 for older 3-circle systems (black 
Aztalan goniometer)

PLATFORM for 3-circle systems

T:1/4-CIRCLE for 3-circle systems with 
quarter circle in transmission mode.

R:1/4-CIRCLE for 3-circle systems with 
quarter circle in reflection mode.

D8 for new D8 Discovery systems.

If SAXI$ADMODEL is not defined, PLAT-
FORM (3-circle) is assumed. The model 
number given here is stored in the header of 
new frames saved in Bruker format.

SAXI$NAMECHARS

# characters in “NAME” part of filename

SAXI$RUNCHARS

# characters of “NAME” part used for run#

SAXI$RUNBASE

Numeric base of run # (10 or 36)

SAXI$NUMCHARS

# characters in extension, used as frame #

SAXI$NUMBASE

Numeric base of frame # (10 or 36)

These names translate to numeric values 
which establish the initial frame naming 
parameters, which can be viewed and modi-
fied on the Edit > Configure > User settings 
form. If the configuration has been saved 
from a previous run of GADDS, the values in 
the configuration file override these values 
when GADDS is restarted. Thus, these 
names are used by GADDS only if there is 
no existing GADDS._GC file.

SAXI$BIGFONT

When set to a non-zero value, gadds dis-
plays the screen using a larger character 
font.

SAXI$CURSWEIGHT

This name can be defined with an integer 
value from 2 to 7 to specify the line thick-
ness of the cursors in pixels. This is prima-
rily for use on IRIS systems, where single-
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weight lines can look very thin. If 
SAXI$CURSWEIGHT is undefined or 
assigned the value 1, the cursors appear as 
in earlier versions. The cursors drawn in the 
ZOOM and GRAPH commands are also 
affected in the same manner.

SAXI$DBGLEVEL

This variable translates to the program 
debug level that is used to determine which 
debug statements are sent to the file: std-
out.txt. This is only used to debug the pro-
gram.

0 = off

1 = serial communications, setup mes-
sages, correction tables, limits, etc.

2 = header errors, user tasks

3 = echo controller commands, general 
messages, etc.

4 = echo controller responses, detector 
messages, raw files, etc.

5 = echo flushed serial characters, sent 
ASCII codes

6 = timeouts

7 = extended debug output, callbacks, etc.

8 = COM port characters received

SAXI$NOBOXLIM

This optional variable, if defined, will 
increase the maximum Cursor > Box and 
Cursor > RBox size limit from 64 to 256 for 
diagnostic purposes.

SAXI$OLDNAMES

When set to any value, this instructs the pro-
gram to use the old frame naming conven-
tions when creating new frame files.

SAXI$ON

If non-zero, we continue command file pro-
cessing regardless of error code. If zero or 
undefined, command files stop on error 
code.

SAXI$PKZIP

If defined, it is set to the full pathname of 
PKZIP for console (version 2.50), which is 
used in the Project > Backup command.

SAXI$PRINTER

This optional variable points to the default 
GADDS print queue. A useful trick is to 
setup a GADDS print queue with typical set-
tings for GADDS printing such as landscape 
orientation.

SAXI$SITE

The site name given here is stored in the 
header of frames written in Bruker format. 
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Under WNT, this defaults to the Regis-
teredOrganization name in the Registry.

SAXI$SWCHAR

The startup command line switch character 
can be defined as the translation of this 
name. By default, SAXI$SWCHAR=/ lead-
ing to the default DOS-style parsing. You 
can set SAXI$SWCHAR=- to change to 
UNIX-style “-” switches. The command syn-
tax is otherwise the same (only the charac-
ter which precedes the qualifiers is 
changed). SAXI$SWCHAR affects interpre-
tation of only the startup command line, not 
the SLAM command line. We recommend 
that you retain the “/” switch character set-
ting.

SAXI$USERNAME

The user name given here becomes the 
default name on the GADDS Edit > Config-
ure > User settings command form. Under 
WNT, this defaults to the RegisteredOwner 
name in the Registry.

SAXI$VIDEOFORMAT

Overrides the saving of video images in 
TIFF format for Coreco or JPEG format for 
Matrox. Alternate options are:

SAXI$512MAXOVF

Restricts frame file format to contain a maxi-
mum overflow table size of 512 bytes (for 
compatibility with other, older software pack-
ages).

0 TIFF format stored with *.tif extension 
(Coreco) or MIL format stored with *.mim 
extension (Matrox)

1 BMP format stored with *.bmp extension 
(Coreco or Matrox)

2 TARGA format stored with *.tga extension 
(Coreco only)

3 JPEG format stored with *.jpg extension 
(Matrox only)
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1.3 Startup Command Qualifiers

The following qualifiers can additionally be given 
when starting GADDS. It is assumed that the 
qualifier switch character has not been changed 
from its standard value of “/”. If it has, substitute 
the appropriate switch character, e.g., “-”.

/AXES=#

Starts GADDS with support for specified 
axes. By default, GADDS is started with 
support for 2theta, omega, phi, and chi, of 
which chi may be fixed at 54.74 degrees. 
Axes are specified by using an eight bit bit-
mask with each bit representing the pres-
ence (ON) or absence (OFF) of each axis.

/COMMAND

Starts GADDS in command line mode 
instead of menu mode.

/COMMAND=@<filename> <parm1> <parm2> 
...

Starts GADDS and automatically invokes 
SLAM script file with optional parameters of 
parm1, parm2, etc.

/CONFIGURATION=<filename>

Causes GADDS to read the initial configura-
tion from <filename> rather than from 
GADDS._GC.

/DEFAULT=<filename>

Causes GADDS to read the initial configura-
tion from <filename> if the configuration file 
is either not found or creates a read error or 
the /NORELOAD switch is used.

/DEFAULT=<filename>

Causes GADDS to read the initial configura-
tion from <filename> if the configuration file 
is either not found or creates a read error or 
the /NORELOAD switch is used.

/DUAL

Allow dual detector operations.

/LEVEL1/LEVEL2/LEVEL3

Starts GADDS in requested menu level. 
Default is 1.

/LOCK

Disables the menu level commands. Useful 
for individual security situations.

/NOPROJECT

Prevents GADDS from starting in the last 
project’s working directory. Starts in icon’s 
working directory. 

Bit Value Axis Bit Value Axis

0 1 2Theta 4 16 X

1 2 Omega 5 32 Y

2 4 Phi 6 64 Z

3 8 Chi 7 128 Zoom
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/NORELOAD

Prevents GADDS from reading the configu-
ration file: gadds._nc.

/PORT=#

Specifies the goniometer controller com port 
number. Valid options are 1–4 with 1 being 
the default.

/PROJECT=<projname>

Specifies GADDS to start in the named 
project’s working directory. This is the 
project name as defined in the project data-
base. On failure to load requested project, 
the last project’s working directory is used.

/RAXES=#

Instructs GADDS that the goniometer con-
troller is reporting axes that should be 
ignored and overridden with the GADDS 
“fixed angles” command. The default is that 
all reported angles are used (see /AXES=#). 
This is mainly useful for 2-position chi 
stages with video option, where /RAXES=8 
should be used. Axes are specified by using 
an eight bit bitmask with each bit represent-
ing the presence (ON) or absence (OFF) of 
each axis.

/TCPORT=#

Specifies the temperature controller com 
port number. Valid options are 1–4 with 2 
being the default.

/THETATHETA

Modifies behavior to theta theta operation.

/X=# /Y=#

Determines GADDS window position offset 
from upper left corner in screen pixels. A 
value of -1 (default) will center GADDS in 
the screen display. 

Bit Value Axis Bit Value Axis

0 1 2Theta 4 16 X

1 2 Omega 5 32 Y

2 4 Phi 6 64 Z

3 8 Chi 7 128 Zoom
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1.4 GADDS Startup Behavior

When GADDS is started, the program goes 
through many checks to determine the operating 
state of the program.

1. Command line qualifiers and environment 
variables are used to override or set the 
default behavior. All environment variables 
must be defined prior to starting GADDS.

2. The working directory is defined. By default, 
GADDS uses the last project’s working 
directory, unless the command line qualifi-
ers, /noproject or /project=projname, are 
present. If the last project does not exist, not 
defined, an error occurred, or /noproject 
was used, then GADDS will prompt the user 
to define a new project (which includes 
defining the working directory).

3. The program default settings are defaulted 
or read. By default the configuration is read 
from the project’s working directory 
(gadds._nc). If error or /noreload is present, 
from the GADDS system directory 
(GADDS$SYSTEM:gaddsdef._nc). On 
complete failure, the hard coded defaults 
are used. The names of the normal configu-
ration file and the default configuration file 
can be changed using /configuration=<file-
name> and /default=<filename> command 
line qualifiers.

4. Diffractometer communications with the 
goniometer controller is initiated. On P4 sys-
tems, GADDS confirms the current angle 
settings.
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1.5 Dialog Box and Keyboard
Conventions

1.5.1 Dialog Boxes

GADDS has been designed with standard Win-
dows dialog boxes, so you can use standard 
methods when responding. The action buttons 
vary depending on the function of the dialog 
box. The following types of dialogs are used, 
classified according to type-of-action button:

Message Boxes

These display informational and error mes-
sages and have only an OK button. The 
ENTER key is equivalent to OK.

Yes/No Dialog Boxes

These display a message and request a Yes 
or No response. Pressing the Y key is equiv-
alent to clicking Yes. The N key is equivalent 
to No. Pressing ENTER executes whichever 
button is highlighted. The TAB key moves 
the highlight between the two buttons.

OK/Cancel Dialog Boxes

These display a message that requires an 
OK or Cancel response, or they may contain 
a series of Windows or Motif controls for 
entering data. Pressing ENTER is equiva-
lent to clicking the currently highlighted 
action button, which is initially the OK but-
ton. Pressing ESC is equivalent to clicking 
the Cancel button. The TAB and SHIFT+ 

TAB keys move to the next or preceding 
control in the dialog box, respectively. If the 
dialog box contains edit fields, you can copy, 
cut, and paste text within these fields with 
CTRL+C, CTRL+X, and CTRL+V. These 
operations use the clipboard, so you can 
also use these keys to transfer text informa-
tion among different dialogs or between pro-
grams.

Output Dialog Boxes

These display a scrolling multi-line text con-
trol; a scroll bar; and OK, Write..., and 
Print... buttons. The arrow and page keys 
allow you to scroll the output text, as does 
the scroll bar. ENTER is equivalent to click-
ing the highlighted button (initially OK). You 
can highlight text in the text control with the 
mouse or shifted arrow keys and copy it to 
the clipboard with CTRL+C. However, you 
cannot alter the text in this type of dialog. 
The Write and Print buttons allow you to 
send selected text (or all the text, if no 
selection was made) to a disk file or a 
printer, respectively. 

Edit Dialog Boxes

These display a scrolling multi-line edit con-
trol; a scroll bar; and OK, Cancel, Write..., 
Print..., and Read... buttons. The text in the 
edit control can be edited according to the 
normal system conventions. The arrow and 
page keys allow you to scroll the text, as 
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does the scroll bar. ENTER is equivalent to 
clicking the highlighted button (initially OK), 
and the TAB and SHIFT+TAB keys cycle the 
highlight (focus) over the edit control and 
buttons. ESC is equivalent to Cancel. You 
can highlight text in the text control with the 
mouse or shifted arrow keys and copy it to 
the clipboard with CTRL+C, cut to the clip-
board with CTRL+X, and paste with 
CTRL+V. However, ensure that any text you 
paste into such a dialog is correctly format-
ted, since format is not checked before a 
paste. The Write and Print buttons allow you 
to send selected text (or all the text, if no 
selection was made) to a disk file or a 
printer, respectively. The Read button allows 
you to insert text from a disk file at the cur-
rent position. As with the paste operation, 
ensure that text in the file is correctly format-
ted, since format is not checked before file 
text is inserted.

1.5.2 Keyboard Conventions

Following are definitions used by Bruker for 
common keyboard keys and key combinations. 
Note that the keys used in interactive com-
mands may also be used as menu accelerators. 
(For example, when the GADDS menu has the 
focus, CTRL+LEFT ARROW displays the next 
image in a sequence. But when a cursor com-
mand has the focus, the same key moves the 
cursor left in 10-pixel increments.)

CTRL+BREAK and CTRL+C (NT only)

CTRL+C (SGI only)

Interrupts an operation in progress. Under 
some workstation environments, CTRL+C is 
polled, so that to may need to hold the key 
combination down long enough for the pro-
gram to detect it.

ESC

Works like the Cancel button in dialogs with 
a Cancel button. Also works as a soft abort 
(stop after current frame is finished) in the 
Acquire > SingleRun, MultiRun, Hemi-
sphere, Quadrant, and Matrix commands.

ENTER

Works like the OK button in OK/Cancel dia-
logs, or executes the currently highlighted 
button in most other dialogs.

TAB

Moves to the next field in a dialog box.
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SHIFT+TAB

Moves to the preceding field in a dialog box.

UP ARROW and DOWN ARROW keys

Move through items in a menu or multi-line 
edit control. In most interactive commands, 
they can also be used to position the cursor 
as an alternative to the mouse. By default, 
they move the cursor by 1 pixel in graphic/
cursor commands (see PLUS key descrip-
tion below).

LEFT ARROW and RIGHT ARROW keys

Move non-destructively one character left or 
right when editing text in a dialog; as with 
up/down arrows, they can position the cur-
sor in interactive cursor commands.

+ plus key

Increases by a factor of 2 the number of pix-
els that a cursor is moved whenever a cur-
sor key is pressed. Values of 1, 2, and 4 are 
possible in conjunction with arrow keys, or 
10, 20, and 40 in conjunction with 
CTRL+arrow keys.

- minus key

Decreases by a factor of 2 the number of 
pixels that a cursor is moved whenever a 
cursor key is pressed (opposite of the + key, 
described above).

CTRL+ARROW keys

Move the cursor 10x faster in interactive cur-
sor commands (like Analyze > Cursor, Ana-
lyze > Cursor > Box, etc.)

PAGEUP

Move up a page in scrolling text dialogs.

PAGEDOWN

Move down a page in scrolling text dialogs.

INS

Toggles between character insert and over-
strike modes when editing a line in a dialog 
box.

DEL

Deletes forward one character when editing 
a line in a dialog box. The character under 
the cursor is deleted.

Backspace

Deletes backward one character when edit-
ing a line in a dialog box. The character to 
the left of the cursor is deleted.

HOME

Moves to beginning of line when editing a 
line in an input panel.

END

Moves to end of line.
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F2, F3, F4

In interactive commands, these are equiva-
lent to left, center, right mouse buttons, 
respectively

CTRL+C

In a dialog box edit control, copies high-
lighted text to the clipboard.

CTRL+X

In a dialog box edit control, cuts highlighted 
text to the clipboard.

CTRL+V

In a dialog box edit control, pastes from the 
clipboard.

CTRL+P

Prints main GADDS screen to currently 
selected printer. Under NT, this function 
does not work when the user is in a dialog 
box or message box; however, PRTSC will 
send a copy of the entire screen including 
GADDS window (or ALT-PRTSC for just 
active window) to the clipboard.
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1.6 GADDS Directory Organization

GADDS’s directory organization (as shipped 
from the factory) is shown below. We recom-
mend that you maintain this directory convention 
for Bruker-supplied files to minimize the effort 
required for future software updates. On PCs 
and workstations, the same logical names are 
used to point to the programs and data.

Following is the normal directory layout (shown 
schematically) for GADDS.
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C:\   Root directory, containing parent of $SAXI_ROOT system startup files on PC;
       Bruker program directories

   — C:\SAXI  — Bruker-supplied application programs (in the subdirectories).

         — C:\SAXI\GADDSnew
                          GADDS programs, utilities, and help files. The environment variables
                          GADDS$SYSTEM: and GADDS$SYSDATA: by default point to this directory.

               — C:\SAXI\GADDSnew\SRCS
                              Example source files for reading Bruker format data files.

               — C:\SAXI\GADDSnew\TEST
                               Test data for verification of proper installation and setup. The environment
                               variable GADDS$TEST: normally points to this directory.

         — C:\SAXI\PVWAVE
                         Command procedures to import Bruker data files into Precision Visual’s Wave program.

         — C:\SAXI\VIDEO32
                         VIDEO executable and help files.

        D:\FRAMES
                         Root of frame data storage. It is recommended that you use a subdirectory
                         under this root as the project working directory for each sample.

         — D:\FRAMES\CALIB — Directory where GADDS stores all calibration files for the detector.
                         The environment variable GADDS$CALIB: by default points to this directory.

         — D:\FRAMES\PROJECTS
                         Directory where GADDS project databases are maintained. Each user should define
                         the environment variable GADDS$PROJECT to point to a project database in
                         this directory.
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1.7 Frame Indexes

Frame indexes have been implemented. When a 
frame name is given in the format:

INDEXNAME#N    or    INDEXNAME##H

the program looks for a frame index file INDEX-
NAME (with the extension defaulting to .fin, for 
Frame INdex). N is a decimal number represent-
ing the line number in the index file which con-
tains the filename of the frame; H represents the 
same, only in base 36. Lines are numbered 
starting from 0. GADDS will remember the 
name of the last index specified, so that you can 
omit INDEXNAME in subsequent references; 
thus, #N and ##H become valid frame names.

The frame index is an ASCII file in the Harvard 
format, where each line contains a number 
(which is ignored by GADDS) followed by the 
frame name. The default directory for frame 
index files is the frame directory as specified in 
the CONFIGURE /EDIT panel.

In the DISPLAY commands, NEXT, PREVIOUS, 
MOVIE+, and MOVIE-, the auto increment or 
decrement will be performed on the index line 
number, not the frame name.
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1.8 Special Symbols

Throughout the various input panels, special 
symbols are reserved for special purposes.

Symbol Where used Purpose

$DATA PEAKS /LOAD To read the currently 
loaded peak table

$FRAME CORRECTIONS

DISPLAY

FRAME_INFO

POLE_FIGURE

SPATIAL

SMOOTH

To read the currently 
loaded frame image

$MASK MASK /VIEW To read the currently 
loaded active pixel 
mask

$NET (obsolete) Unused—avoid using 
$NET in filenames

$NEXT DISPLAY Display the next 
frame in a frame 
series

$NULL LOAD

MASK /READ

MASK /SAVE

POLE_FIGURE /
SCHEME

SAVE

Read or save a null 
file

Symbol Where used Purpose

$PREV DISPLAY Display the previous 
frame in a frame 
series

$RUNNEXT DISPLAY Displays the next 
frame in a run series.

$RUNPREV Display Displays the previous 
frame in a run series.

$SCAN POLE_FIG/
SCHEME

Automatically update 
the SCAN /EDIT pan-
els for multiple runs

$TITLE POLE_FIG/
POPLA

POLE_FIG/
TEXTUREAT

SAVE

When saving a file, 
keep the original title 
string
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2.  Project Management Routines

Project management is the organization of data 
files into logical groups. Typically, you will create 
a new project to start a new sample run, a new 
batch of samples, etc.; when to start a new 
project is really a user preference or a defined 
step in a laboratory procedure (for example, an 
ISO-9000 procedure).

GADDS manages and tracks all projects by 
using project files (*.prj). All users can share the 
same projects or each user can have their own 
unique projects. When GADDS was installed, 
SETUP created a system wide project file (for all 
users) and a GADDS administrator project file 
(for only the account that installed the GADDS 
software). GADDS locates the project file by 
translating the environment variable, 
GADDS$PROJECT, which contains the com-
plete file specification of the project file (for 
example, D:\frames\projects\gadds.prj). SETUP 
creates this environment variable in the System 
Variables space to create the system wide 

project file. You may override the system wide 
setting, by creating a user specific project file as 
follows:

1. Start > Settings > Control Panel > System 
applet.

2. Click on the Environment tab.

3. Click on a line in the “User Variable for 
<User>” section.

4. In the Variable: edit box, enter 
GADDS$PROJECT.

5. In the Value: edit box, enter the full file spec-
ification. The drive and directory path must 
already exist. Bruker recommends using our 
naming convention of 
D:\frames\projects\GADDS_<user-
name>.prj (you replace <username> with 
your actual user account name).

6. Click on [Apply].
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7. Click on [OK].

Because initially there is no project file, the first 
time GADDS is started, you will see several 
messages:

“Unable to open project database file for 
reading GADDS$PROJECT.”

“Unable to use last project,”

Each time GADDS is started, the current project 
database is checked for orphaned projects.

NOTE: Removed orphaned project from database.
D:\frames\20002\Oct\MyProject0\gadds._nc

Then you are automatically sent to the Project > 
New command (see Section 2.3 Project > New). 
Enter appropriate values and click [OK]. Inform 
your GADDS administrator if you get the mes-
sage:

“Can't open gaddsdef._nc. Using default 
settings. You must use Project > Overwrite 
defaults command.”

When GADDS is started, you are automatically 
sent to the last project (most recently accessed). 
You can override this default behavior by modify-
ing the GADDS shortcut with command line 
qualifiers:

/noproject

Forces GADDS to always create a new 
project when it starts.

/project=<projname>

Forces GADDS to always open into the 
same project, <projname>.

GADDS prevents offline instances from over-
writing the defaults for online operation. When 
operating in offline mode, GADDS always 
appends “_offline” to the configuration filename 
before saving. When reading the configuration, 
offline GADDS tries to read this offline version, 
but if missing, GADDS reads the online version. 
This allows you to operate online GADDS in a 
directory, while simultaneously running offline 
GADDS for processing the newly collected 
frames in the same directory (could be from a 
different computer using mapped network 
drives).
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2.1 Project > Switch • Change to a 
different, existing project

Menu Command: Project > Switch

Accelerator: None

User Level: 1

SLAM Syntax: PROJECT /SWITCH $1

Use this command to switch to an existing 
project. A scrollable, alphabetized list of all 
known projects will appear. Highlight the project 
of interest and click [OK].

Before the program switches to the requested 
project, the message appears:

“Save the current configuration before 
changing projects?”

Typically, you click [Yes] as this is the safest 
option.

The program will switch to the requested project 
by loading that project's settings, clearing the 
frame buffer, clearing the displayed frame, and 
displaying the current project settings. However, 
if the requested project is no longer valid, the 
program will display a message, restore the 
original project settings, and remove the cor-
rupted project from the project database.

2.1.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Select Project)     [first in list]

Enter the existing project name. In menu-
mode, a scrollable, alphabetized list of all 
valid projects appears and you may simply 
click the requested project. The default is 
the first project in the list.
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2.2 Project > Load • Load a configu-
ration file and create a new project

Menu Command: Project > Load

Accelerator: None

User Level: 2

SLAM Syntax: PROJECT /LOAD $1 (not recom-
mended to use in SLAM mode)

Use this command to create a project from an 
existing configuration file. You can click the 
browse button to search for an existing configu-
ration file. 

Before the program creates and switches to the 
requested project, the message appears:

“Save the current configuration before 
changing projects?”

Typically, you click [Yes] as this is the safest 
option.

The program will create and switch to the 
requested project by loading that project's set-
tings, clearing the frame buffer, clearing the dis-
played frame, and displaying the current project 
settings. However, if an error occurs, the pro-
gram will display a message and restore the 
original project settings.

Next the program automatically generates a 
project name and adds the new project to the 
project database. If the new project name 
already exists, the message appears:

“<PROJECT0> is already a project. Replace 
it?”

Click [Yes] to replace or [No] to generate a differ-
ent project name (by incrementing the sample 
number).

2.2.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Configuration Filename)     
[*._nc]

Enter the full file specification of an existing 
configuration file. The default is *._nc which 
will invoke the file browser.
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2.3 Project > New • Create a new 
project from scratch

Menu Command: Project > New

Accelerator: None

User Level: 1

SLAM Syntax:

PROJECT /NEW /CNAME=<s>
$1 /TITLE=<s> /WORKDIR=<s>
/FORMULA=<s> /MORPH=<s>
/CCOL=<s> /DENSITY=<s>
/DENSMETH=<s>

Use this command to create a new project from 
scratch. Typically, whenever you mount a new 
sample or a new batch of samples, you want to 
define a new directory for all your data files.

You must enter information in all the project 
information parameters. The sample name and 
sample number are combined to form the 
project name. If the generated project name is 
invalid, the message appears:

“Sample name and number are too long or 
contain non-alphanumeric characters. 
Name will be shortened/modified as needed 
if you continue.”

Click [Yes] to continue or [No] to return to dialog 
input box.

You must enter information in the directory infor-
mation parameters. You may enter an existing 

directory, but typically you enter a new directory 
and the program will create it. You may enter the 
special value, $PROJECT, which instructs the 
program to use the directory 
GADDS$FRAMES:YEAR\MON\<projname>, 
which is typically defined as 
D:\frames\2003\Mar\<projname>. The advan-
tage of using $PROJECT is that it automatically 
generates a directory name that should be 
unique. If you try to re-use a project directory, 
the message appears:

“Working directory already contains a con-
figuration file: gadds._nc. Choose a different 
directory or use the Project > Load com-
mand.”

The sample information parameters are all 
optional. Enter what you know and leave the rest 
set to “?”.

Before the program creates and switches to the 
requested project, the message appears:

“Save the current configuration before 
changing projects?”

Typically, you click [Yes] as this is the safest 
option.

The program will close any log and auto-script 
files before creating and switching to the new 
project.

“Closing last project's log file…”

“Closing last project's auto-script…”
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New project defaults are taken from the system-
wide default file create by the Project > Over-
write defaults command. All crystal information 
is cleared (reflection array list, orientation 
matrix, and face indices). The new project is cre-
ated by clearing the frame buffer, clearing the 
displayed frame, displaying the project settings, 
and setting all title requests in other menus to 
the sample title.

If the previous project had either the log or auto-
script enabled, you will be prompted to restart 
those features.

“Start/append log file for new project?”

“Start/append auto-script file for new 
project?”

2.3.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

/CNAME=<s>........(Sample Name)    [Unknown]

Enter the name of the sample (project name 
= sample name + number). Default is 
“Unknown.”

$1 ..........................(Sample Number)     [0]

Enter the number of the sample (negative to 
ignore). Default is 0.

/TITLE=<s> .......... (Title)     [?]

Enter a descriptive title for this project (sam-
ple). Default is “?”.

/WORKDIR=<s>... (Working Directory)     
[$PROJECT]

Enter the Drive:Directory to make current or 
the working directory. The program will 
place all data files in this directory. Or enter 
“$PROJECT” and the program will generate 
a project working directory name from the 
project name and using GADDS$FRAMES: 
as the root. Default is “$PROJECT”.

/FORMULA=<s>... (Chemical Formula)     [?]

Enter the chemical formula for this sample 
or enter “?”. Default is “?”.

/MORPH=<s>....... (Sample Morphology)     [?]

Enter a description of the physical sample or 
enter “?”. Default is “?”.

/CCOL=<s> .......... (Sample Color)     [?]

Enter a description of the sample color or 
enter “?”. Default is “?”.

/DENSITY=<s>..... (Measured Density)     [?]

Enter the measured sample density, includ-
ing units or enter “?”. Default is “?”.
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/DENSMETH=<s>.(Density Method)     [?]

Enter a description of the method used to 
measure the density or enter “?”. Default is 
“?”.

2.4 Project > Copy • Copy the 
current project to a new project

Menu Command: Project > Copy

Accelerator: None

User Level: 1

SLAM Syntax:

PROJECT /COPY /CNAME=<s> $1
/TITLE=<s> /WORKDIR=<s>
/FORMULA=<s> /MORPH=<s>
/CCOL=<s> /DENSITY=<s>
/DENSMETH=<s> /CLEAR /RESET

Use this command to create a new project using 
the current project settings as defaults. You typi-
cally use this command when mounting a similar 
sample on the goniometer or repeating a collect 
and process operation on the same sample.

Project > Copy differs from Project > New (see 
Section 2.3) in that:

• The project defaults can be taken from 
either the system-wide defaults (see Section 
2.9 Project > Overwrite defaults) or from the 
current project settings by using the Clear 
switch.

• The crystal information may be either 
cleared or retained from the current project 
settings by using the Reset switch.

• The project information defaults to stay the 
same except that the sample number is 
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incremented; however, you may override 
these defaults.

2.4.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses: Project > New argu-
ments also apply here (see Section 2.3 for 
explanations).

/CLEAR .................(Clear Crystal Info?)     [No]

Check to clear the crystal face list, reflection 
array, and orientation matrix. Default is no.

/RESET .................(Reset to Defaults?)     [No]

Check to reset program to default settings. 
Default is no.
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2.5 Project > Edit • Edit the current 
project settings

Menu Command: Project > Edit

Accelerator: None

User Level: 1

SLAM Syntax:

PROJECT /EDIT /TITLE=<s>
/FORMULA=<s> /MORPH=<s>
/CCOL=<s> /DENSITY=<s>
/DENSMETH=<s> /CLEAR /RESET

Use this command to modify the current project 
settings. Because you are not creating a new 
project, you cannot change the project's sample 
name, sample number, or working directory. But 
you may change the sample's title and the sam-
ple information parameters, reset defaults to 
system-wide default settings, and/or clear the 
crystal information.

2.5.1 Arguments

Project > New and Project > Copy arguments 
apply here (see Section 2.3 and Section 2.4 for 
explanations). Defaults are current settings.
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2.6 Project > Backup • Backup all 
files in the specified project’s 
directories

Menu Command: Project > Backup

Accelerator: None

User Level: 2

SLAM Syntax: PROJECT /BACKUP $1 $2 $3 
/NOCALIB /NOWORK

Use this command to backup all files in the 
project's working directory and/or the current 
calibration files into a single, compressed, 
archive file, which you may wish to transfer to 
tape or CD-R media for archiving purposes.

A scrollable, alphabetized list of all known 
projects will appear. Highlight the project of 
interest and click [OK]. Next a dialog of options 
appears. You must enter a filename for the 
archive file and enter the directory to place the 
archive file. Optionally, you may choose to 
exclude the calibration files or the current work-
ing files from the archive; however, typically you 
backup all your working files, but not the calibra-
tion files.

“Requesting archive file already exists. 
Update existing archive file?”

Click [Yes] to update, [No] to abort. Updating 
adds new or updates existing data files in the 
archive, but does not remove any old data files. 
If you wish to overwrite an existing archive file, 

then you must pre-delete the archive (use Win-
dows NT Explorer).

“No PKZIP file is defined: SAXI$PKZIP”

Your GADDS administrator must configure the 
console version of PKZIP for use with GADDS. 
Simply extract the PKZIP files to a directory and 
define the System Variable, SAXI$PKZIP, to 
point to the full file specification. GADDS was 
tested with PKZIP for Console version 2.50.

2.6.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Select Project)    [no default]

Enter the project's name to archive or use 
$PROJECT for current project. No default.

$2 ......................... (Archive Filename)     
[$PROJECT]

Enter the filename for the file archive. 
Default is project name.

$3 ......................... (Archive Directory)     
[GADDS$FRAMES:]

Enter the directory to store the file archive. 
Default is GADDS$FRAMES:.

/NOCALIB............. (Exclude Calibration Files?)     
[Yes]

Check to exclude all calibration files from 
the archive. Default is yes.
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/NOWORK.............(Exclude Work Files?)    [No]

Check to exclude all working directory files 
from the archive. Default is no.

2.7 Project > Remove • Remove a 
project from the project database

Menu Command: Project > Remove

Accelerator: None

User Level: 2

SLAM Syntax: PROJECT /REMOVE $1

Use this command to remove the requested 
project from the project database, but does not 
delete any data files. A scrollable, alphabetized 
list of all known projects excluding the current 
project will appear. Highlight the project of inter-
est and click [OK]. The program will remove the 
requested project.

NOTE: Because the configuration and data files 
were not deleted, you could re-add the project 
using the Project > Load command.

2.7.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Select Project)    [no default]

Enter the requested project name to remove 
from the project database. You cannot 
remove the current project. No default.
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2.8 Project > Delete • Delete all 
project files and remove from 
project database

Menu Command: Project > Delete

Accelerator: None

User Level: 2

SLAM Syntax: PROJECT /DELETE $1

Use this command to delete all data files and 
remove the requested project from the project 
database. Typically, you perform a Project > 
Backup command before doing a Project > 
Delete command.

A scrollable, alphabetized list of all known 
projects excluding the current project will 
appear. Highlight the project of interest and click 
[OK]. The message appears:

“Delete all files in data directories and try to 
remove this directory?”

Click [Yes] to continue, [No] to abort. The pro-
gram will delete all files in the working directory, 
but not any subdirectories, files in subdirecto-
ries, or the calibration files (in the calibration 
directory), then it will remove the requested 
project.

2.8.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Select Project)    [no default]

Enter the requested project name to delete 
working files and remove from the project 
database. You cannot delete the current 
project. No default.
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2.9 Project > Overwrite defaults • 
Overwrite the default configuration 
with the current settings

Menu Command: Project > Overwrite defaults

Accelerator: None

User Level: 3

SLAM Syntax: PROJECT /MAKEDEF

Use this command to define the system-wide 
default settings for projects. Typically, your 
GADDS administrator will issue this command 
whenever he changes the goniometer stage or 
other hardware option.

Before issuing this command, go through all 
menu options and define your default settings. 
The most critical settings are located in the com-
mand:

• Edit > Configure > User settings:

• Edit > Configure > Admin settings:

• Collect > Goniometer > All commands:

Double check that these settings are correct.

After issuing the Project > Overwrite defaults 
command, the message appears:

“Save the current configuration as default 
values (for new/copy/edit “reset to defaults” 
option)?”

Click [Yes] to continue, [No] to abort. The pro-
gram will save current settings in the 
GADDS$SYSTEM:gaddsdef._nc system-wide 
default configuration file. Whenever the reset to 
defaults option is checked in a Project > New, 
> Copy, or > Edit command, these system-wide 
defaults are read.

NOTE: If your GADDS administrator frequently 
changes goniometer stages, he may wish to cre-
ate a project for each stage with the appropriate 
default settings for each stage already preset. 
Then when he switches stages, he only needs 
to:
1.  Project > Switch: Switch to the project for the
     new goniometer stage (for example, Fixed-
     Chi, XYZstage, XYZstageSTRESS, Huber-
     Cradle, etc., which have already been
     defined).
2.  Project > Overwrite defaults: Save these
     settings to the system-wide defaults.

2.9.1 Arguments

1. None. Commands execute immediately 
after confirmation message.
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2.10 Project > Exit • Leave program 
and return to operating system

Menu Command: Project > Exit

Accelerator: None

User Level: 1

SLAM Syntax: EXIT

After saving the current configuration, this com-
mand terminates GADDS, returning you to the 
operating system. You may also exit GADDS by 
double clicking on the GADDS icon in the upper 
left, clicking the application close button in the 
upper right corner, pressing Alt-F4, or with the 
QUIT command (see Section 12.3 Quit), but 
these methods do not save the current configu-
ration.

If you choose EXIT from the menu, a box 
appears with OK and Cancel buttons and the 
message:

Save current configuration: Are you sure:

Normally, you want the program to save the cur-
rent settings—press OK. Occasionally, you may 
wish to ignore your project session and start 
over—press Cancel. All settings are stored in 
the project’s working directory in the file: 
gadds._nc, which will be read the next time you 
start GADDS.

Then, a box appears with OK and Cancel but-
tons and the message:

EXIT: Are you sure?

The purpose is to provide a safety net in case 
EXIT was selected by mistake. Click the OK but-
ton, or press the ENTER key to exit the pro-
gram. If you do not wish to exit at this time, click 
the Cancel button or press Esc, and you'll be 
returned to the GADDS menu.

In command mode, EXIT terminates GADDS 
after saving the current configuration, without 
displaying any prompts.

2.10.1 Arguments

None. Command executes immediately after 
confirmation message.
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3.  File Routines

3.1 File > Display > Open • Display a 
detector frame on the screen

Menu Command: File > Display > Open

Accelerator: Ctrl+D

User Level: 1

SLAM Syntax:

DISPLAY /NEW $1 /QUADRANT=<n>
/LO=<n> /HI=<n> /X=<n> /Y=<n>
/MAG=<n> /AUTOINCREMENT
/GRAPHICS_SAVE /ORIENTATION
/VIDEO /OVERLAY

Use this command to display a specified data 
file from disk, or to display or redisplay the cur-
rent contents of the frame accumulation mem-
ory.

Up to four different data files can be displayed at 
the same time using File > Display to place them 
into separate quadrants. You can also display a 

region within a frame magnified in a quadrant or 
in the full image window by setting the input 
arguments appropriately. While multiple images 
can be displayed in different quadrants at one 
time, only the image in the current quadrant is 
actually in memory. Thus, for example, the Ana-
lyze > Cursor functions work only on the image 
in the current quadrant.

GADDS will read and automatically configure 
internal parameters for imported Bruker CCD 
formats (based on the DETTYPE: frame header 
item and version 9 header items). But whenever 
the DETTYPE: is “unknown” or “other,” then 
GADDS tries to read the sub-items: PIX-
PERCM: and CMTOGRID:. On failure, GADDS 
must ask for the “Pixels per cm” and “Cm to grid” 
parameters.

When invoked from the menu, or run from the 
command line without arguments, File > Display 
displays a dialog box where you can view/edit 
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the arguments described below. Pressing the 
ENTER key or clicking the OK button starts the 
display. Pressing ESC or the Cancel button 
returns you to the menu.

Both filenames and filename patterns entered in 
the input panel are merged with the working 
directory specified in the Project > New dialog 
box before GADDS attempts to open the file.

3.1.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input Filename)  [$FRAME]

Filename of the frame to be displayed. Input 
filename defaults to *.gfrm file extension (if 
missing).The special name $FRAME (the 
default) refers to the current data in frame 
accumulation memory. Thus, $FRAME can 
be used to display the contents of accumu-
lation memory if you've acquired a frame 
suppressing display, or can be used to 
redisplay a newly acquired with different 
lower and upper limits. If you leave this item 
blank, or specify a wildcard filename pat-
tern, pressing ENTER or clicking the OK 
button will allow you to choose from a list of 
the current filenames matching the pattern, 
after which you will be returned to the input 
dialog with the selected filename filled in. If 
you leave this item blank, it is the same as 
entering a *.* wildcard pattern. Remember 

that both filenames and patterns entered 
here are merged with the Project > New 
working directory, as described above.

/QUADRANT=<n> ..... (Screen Quadrant) [0-full]

Select the quadrant in which the frame is to 
be displayed. In the dialog box, you can 
select the quadrant from a drop-down list. 
While multiple images can be displayed in 
different quadrants at one time, only the 
image in the current quadrant is actually in 
memory; thus, for example, the cursor func-
tions work only on the image in the current 
quadrant. Quadrants are 0 = full window, 1 = 
lower left, 2 = lower right, 3 = upper left, and 
4 = upper right. Default is 0.

/LO=<n> ............... (Lower Limit)     [0]

The number of counts to be mapped to zero 
in display memory. Pixel values lower than 
this are truncated to zero on display 
(although the cursor commands will still 
read the correct values). The default value is 
0; the allowed range is from -255 to 
+65,535.

/HI=<n> ................ (Upper Limit)     [63]

The number of counts to be mapped to the 
highest display memory value (currently 63; 
that is, displayed frames are shown with 64 
simultaneous colors). Pixel values higher 
then the specified value are truncated to 
that value on display (although the cursor 
commands will still read the correct values). 
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The special value -1 causes the program to 
scan the pixel values in the frame and auto-
matically pick reasonable display limits and 
contrast settings based on the result. The 
special value -2 directs the program to use 
whatever the previous limits were. The 
default value is -1; the allowed range is from 
-2 to 1,000,000.

/X=<n> ..................(X)     [256]

X-pixel coordinate to try to center in the 
specified quadrant. The range is from 0 to 
511, 1023, or 2047 (depending on the frame 
size); the default value is 256. If the magnifi-
cation is small enough that centering the 
specified X in the quadrant would leave part 
of the quadrant blank, the image is trans-
lated only far enough to place the edge of 
the frame at the edge of the quadrant.

/Y=<n> ..................(Y)     [256]

Y-pixel coordinate to try to center in the 
specified quadrant. The range is from 0 to 
511, 1023, or 2047; the default value is 256. 
If the magnification is small enough that 
centering the specified Y in the quadrant 
would leave part of the quadrant blank, the 
image is translated only far enough to place 
the edge of the frame at the edge of the 
quadrant.

/MAG=<n>............ (Magnification)     [1]

The magnification (zoom) factor, to examine 
a specific area in greater detail. The allowed 
range is from 1 to 16; the default value is 1.

/AUTOINCREMENT .. (AutoIncrement?)     [No]

This allows successive frames to be dis-
played in different quadrants; for example, 
when the “MOVIE” option is used. Check 
this option to increment quadrant 1-4 after 
display. By default it is unchecked.

/GRAPHICS_SAVE…(Preserve Graphics?) [No]

Specifies whether or not to preserve any 
overlaid graphics if you clear the screen. 
Check this option to preserve graphics if 
clearing screen. By default it is unchecked.

/ORIENTATION…(Use Orientation in Header?)   
[No]

Normally, you'll want the cursor commands 
to read out HKL's based on the orientation 
matrix computed in the last Peaks > Refl. 
Array > LeastSq command. This is the 
default setting (unchecked). However, if you 
display a frame that was stored with its own 
orientation matrix in Bruker format, you can 
override GADDS's internal orientation 
matrix with the one in the frame header, and 
read HKL's on that frame without having to 
recompute its orientation matrix. In that 
case, check this option. Note that this option 
does not overwrite the matrix from the last 
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least squares; displaying another frame with 
this item unchecked, or acquiring a new 
frame clears the override flag (but does not 
reset the check box in this dialog — don't 
leave it inadvertently set!), effectively restor-
ing the matrix from the last Peaks > Refl. 
Array > LeastSq.

/VIDEO…(Display Associated Video Image?)   
[No]

Specifies whether to automatically display 
the associated video image on the video 
program. The video program must already 
be running in a separate window. By default 
it is unchecked.

/OVERLAY.............(Add HKL Overlay?)     [No]

This option, when checked, directs the pro-
gram to draw an overlay of predicted spot 
positions on top of the image automatically 
every time a frame is displayed. The param-
eters given in the File > Display > HKLs dia-
log are used for these automatic overlays as 
well. By default, this option is unchecked. 
The overlay is computed from the current 
orientation matrix (determined in Peaks > 
Refl. Array > LeastSq) and takes into 
account any lattice centering determined in 
Peaks > Refl. Array > Bravais. You can draw 
overlays on magnified frames by entering 
the desired magnification and center in the 
File > Display panel when the image is dis-
played (the Edit > Zoom command does not 
redraw or magnify graphic overlays). Three 

types of marker characters are used to indi-
cate the difference between the scan angle 
corresponding to the centroid of the dis-
played frame and the predicted scan angle 
of a reflection:

The circle and cross can be thought of as 
the tip and tail of an arrow which points from 
the current frame to the predicted position, 
assuming a stack of frames with earlier 
frames positioned in front of the screen and 
subsequent frames positioned further into 
the screen.

3.1.2 Display Limits

The translation of pixel values to colors involves 
two separate translation steps. These steps 
allow you to view the images with nearly photo-
graphic quality and to refine the color mapping 
in real time, however, this refining makes the 
mapping process more complicated.

The mapping process is discussed in detail 
below, specifically with reference to the File > 
Display command. This command allows you to 
set both lower and upper display limits, which 
represents the most general case. Most of the 
frame acquisition commands also allow you to 
display the result according to a specified upper 
display limit exactly equivalent to the upper limit 

Predicted Scan Angle Marker

Within scan range of the current frame Box

Within scan range of a preceding frame Circle

Within scan range of a subsequent frame Cross (X)
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discussed below. However, these commands fix 
the lower limit at zero, which works well most of 
the time. While most commands recognize a few 
special values for the upper limit (-1 for auto-
matic limit setting, etc.), we ignore these special 
cases in the following discussion.

The first step is the mapping of pixel values into 
display memory. Display hardware components 
differ in the number of color levels available for 
each pixel. With GADDS, we always assume 
that the hardware can support at least 64 differ-
ent values (0-63). The /LO and /HI qualifiers in 
File > Display let you specify any linear transfor-
mation between the pixel values and the values 
written into the display hardware (with the 
mapped values clipped to the range 0 to 63, so 
that values outside this range don't show up in 
the wrong colors). Thus, if you need fine dis-
crimination within a narrow range of pixel val-
ues, you could specify /LO and /HI to cover that 
range. On the other hand, if wide latitude is 
more important, you would specify /LO and /HI 
to cover the whole range of pixel values in the 
frame.

After the pixel values have been converted and 
stored into display memory, the display memory 
values are mapped into colors with a second lin-
ear transformation, according to the current lim-
its set in the Edit > Contrast command. Display 
memory values less than or equal to the lower 
Edit > Contrast limit are shown in the color at the 
bottom of the color table (for example, black). 

And values at or above the upper Edit > Con-
trast limit are shown in the color at the top of the 
color table (for example, white). The values in 
between are linearly mapped into the colors in 
the color table. Although you enter the contrast 
limits in terms of pixel value (unless you're using 
Edit > Contrast interactively, in which case 
you’re changing the limits in real time without 
specifying explicit values), Edit > Contrast works 
internally strictly with the values in display mem-
ory.

In general, you don't have to worry much about 
display limits, since the program takes care of all 
the pixel-value/display-memory conversion 
details. For normal data collection, you should 
usually leave the lower File > Display limit set at 
zero and the upper limit at 511, or use the “auto-
matic” setting -1 described above. Anyway, pow-
ers of two make some internal calculations more 
precise, so 7, 15, 31, 63, 127, etc. are good 
general upper limit settings. If your frames look 
too dark, you can make them brighter by using a 
smaller File > Display upper limit. If they look too 
bright, use a larger File > Display upper limit. 
Since the Edit > Contrast command gives you a 
lot of extra latitude (and is much faster), use the 
display limits just for getting your images into the 
ballpark, then use Edit > Contrast for interactive 
adjustments.
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3.2 File > Display > Next and File > 
Display > Previous • Display next/pre-
vious frame in this series

Menu Command:

File > Display > Next

File > Display > Previous

Accelerator:

Ctrl+RightArrow (next),

Ctrl+LeftArrow (previous)

User Level: 1

SLAM Syntax:

DISPLAY /NEXT

DISPLAY /PREVIOUS

When data frames have been collected as part 
of a set, these commands provide a convenient 
means of specifying display of the data frame 
that comes either just before (File > Display > 
Previous) or just after (File > Display > Next) the 
one currently displayed. The next (or previous) 
sequential name in a series of frames is com-
puted according to the frame naming parame-
ters set in the Edit > Configure > User settings 
dialog box (see Section 4.1 Edit > Configure > 
User settings).

The items entered in the File > Display input dia-
log box remain in effect for the duration of the 
File > Display Next or File > Display > Previous 

subcommand, including the display quadrant 
and autoincrement qualifiers. If the specified 
quadrant is 1–4 and autoincrement is set, suc-
cessive frames will be displayed cyclically in the 
different quadrants.

When invoked from the menu or when run from 
the command line, File > Display > Next and 
File > Display > Previous start running immedi-
ately without prompting for additional input.

3.2.1 Arguments

None. Command executes immediately.
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3.3 File > Display > Movie+ and 
File > Display > Movie- • Repeatedly 
display next/previous frame until key 
is pressed

Menu Command:

File > Display > Movie+

File > Display > Movie-

Accelerator:

Alt+UpArrow (movie+),

Ctrl+DownArrow (movie-)

User Level: 1

SLAM Syntax:

DISPLAY /MOVIE+

DISPLAY /MOVIE-

These commands are used to step through a 
series of sequentially numbered data frames, 
displaying them in sequence. Successive 
frames continue to be displayed until the end of 
the series (that is, a nonexistent frame) is 
encountered or until a key or mouse button is 
pressed. The MOVIE+ option displays the 
frames in an ascending frame number sequence 
and the MOVIE- option displays them in 
descending order.

The display arguments in the File > Display dia-
log are in effect for the duration of the File > Dis-
play > Movie+ or File > Display > Movie- 

subcommand, including the display quadrant 
and autoincrement qualifiers. If the specified 
quadrant is 1–4 and autoincrement is set, suc-
cessive frames will be displayed cyclically in the 
different quadrants.

When invoked from the menu or when run from 
the command line, these commands start imme-
diately (without prompting for additional input).

The next (or previous) sequential name in a 
series of frames is computed according to the 
frame naming parameters set in the Edit > Con-
figure > User settings dialog box (see Section 
4.1). There is a 0.1 second delay between frame 
displays.

3.3.1 Arguments

None. Command executes immediately.
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3.4 File > Display > HKLs • Overlay 
predicted HKL pattern on the display

Menu Command: File > Display > HKLs

Accelerator: None

User Level: 2

SLAM Syntax: DISPLAY /HKL $1 $2 $3

These commands allow you to draw an overlay 
of predicted spot positions onto a displayed 
frame.

The /OVERLAY option in File > Display also 
allows you to automatically display the overlay 
every time a new frame is displayed. The over-
lay is computed from the current orientation 
matrix (from the last Peaks > Refl. Array > 
LeastSq command) and takes into account any 
lattice centering determined in Peaks > Refl. 
Array > Bravais. You can draw overlays on mag-
nified frames by entering the desired magnifica-
tion and center in the File > Display dialog when 
the image is displayed (the Edit > Zoom com-
mand does not redraw or magnify graphic over-
lays).

3.4.1 Arguments

File > Display > HKLs draws an overlay on the 
currently displayed frame according to three 
input arguments. Each argument is listed below 
by its SLAM command line name, followed by its 
dialog box prompt in parentheses:

$1 ......................... (Spread)     [0.75]

Width in degrees of the predicted pattern. 
Default is 0.75.

$2 ......................... (Lineweight)     [1]

Line thickness used for drawing the overlay 
markers. The drawing routine will constrain 
the input value to be from 1 to 3. Default is 
1.

$3 ......................... (Scan Angle)     [-9999]

Starting scan angle for pattern prediction, in 
degrees. The special value -9999 (the 
default) directs the program to obtain the 
starting angle from the currently displayed 
frame. The signed frame width and scan 
axis (omega or phi) are always obtained 
from the currently displayed frame. The 
scan angle range covered by the predicted 
pattern will be from A1 to A2 calculated as 
follows:

FRAME_CENTER = SCAN_ANGLE + 
FRAME_WIDTH/2.

A1 = FRAME_CENTER - SPREAD/2

A2 = FRAME_CENTER + SPREAD/2
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The /OVERLAY option in File > Display, 
when set, directs the program to draw an 
overlay automatically every time a frame is 
displayed. The parameters given in the File 
> Display > HKLs input dialog are used for 
these automatic overlays as well.

Three types of marker characters are used 
to indicate the difference between the scan 
angle corresponding to the centroid of the 
displayed frame (that is, FRAME_CENTER 
above) and the predicted scan angle of a 
reflection.

The circle and cross can be thought of as 
the tip and tail of an arrow which points from 
the current frame to the predicted position, 
assuming a stack of frames with earlier 
frames positioned in front of the screen and 
subsequent frames positioned further into 
the screen.

3.5 File > Display > Next Run and 
File > Display > Prev Run

Menu Command: File > Display > Next Run, 
File > Display > Prev Run

Accelerator: Ctrl+Shift+RightArror (next) 
Ctrl+Shift+LeftArrow (previous)

User Level: 1

SLAM Syntax: DISPLAY /RNEXT DISPLAY 
/RPREV

These commands are identical to the File > Dis-
play > Next/Prev commands, except that it steps 
through the run number instead of the frame 
number.

Predicted Scan Angle Marker

Within scan range of the current frame Box

Within scan range of a preceding frame Circle

Within scan range of a subsequent frame Cross (X)
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3.6 File > Display > Movie+ Run and 
File > Display > Movie- Run

Menu Command: File > Display > Movie+ Run, 
File > Display > Movie- Run

Accelerator: Ctrl+Shift+UpArror (moview+) 
Ctrl+Shift+DownArrow (movie-)

User Level: 1

SLAM Syntax: DISPLAY /RMOVIE+ DISPLAY /
RMOVIEW-

These commands are identical to the File > Dis-
play > Movie +/- commands, except that it steps 
through the run number instead of the frame 
number.

3.7 File > Load • Read a frame from 
disk into frame accumulation 
memory

Menu Command: File > Load

Accelerator: Ctrl+O

User Level: 1

SLAM Syntax: LOAD  $1  $2  /DISPLAY=<n> 
/SCALE=<n> /OFFSET=<n> /LOGSCALE 
/USE_CONFIG

The File > Load command copies a data frame 
from a disk into the 32-bit frame accumulation 
memory for display and evaluation. The image is 
also displayed on the screen. You can optionally 
form a linear combination of two frames, display-
ing the result. File > Load, followed by a File > 
Save command, can also be used to convert a 
frame between the XENGEN 1.3 and Bruker for-
mats, or to replace values in a frame header 
with the current values in the Edit > Configure 
panels.

When invoked from the menu or from the com-
mand line without arguments, File > Load dis-
plays a dialog box where you can view/edit the 
items described below. If you press ENTER or 
click the OK button, the load operation starts. 
Pressing ESC or the Cancel button returns you 
to the menu without performing the operation.

File > Load is closely related to the File > Dis-
play. Typically, File > Display is used much more 
often than File > Load, since it provides a more 
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flexible set of display options, for example, for 
displaying sequential frames in a series or multi-
ple frames in quadrants. However, only 
File > Load contains options for combining 
frames and modifying frame headers.

3.7.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input Filename)  [no default]

This is the name of the file to be read from 
disk, or of the first file (of two) to be read 
when performing a linear combination. The 
special name $FRAME can be used here to 
indicate that the first data set in a linear 
combination is to be the data currently 
residing in frame accumulation memory, for 
example, from the last Collect > Add com-
mand. If you leave this item blank, or specify 
a “wildcard” filename pattern, pressing 
ENTER or clicking the OK button will display 
a list of the current filenames matching the 
pattern. You can choose one from the dis-
played list by moving to it with the arrow/
page keys or mouse and pressing ENTER 
or clicking OK. You will be returned to the 
File > Load dialog with the selected file-
name filled in. If you leave this item blank, it 
is the same as entering a *.* wildcard pat-
tern. Remember that both filenames and 

patterns entered here are merged with the 
project’s working directory.

$2 ......................... (Background Filename)     
[$NULL]

This is the name of a second frame file to be 
read from disk and linearly combined with 
the first according to the scale and offset 
described below. If you leave this field blank, 
or supply the special name $NULL, only the 
first file above is read in, and no linear com-
bination is performed. In order to run File > 
Load without intervention from a command 
script, you must supply this second file-
name, and must therefore specify $NULL if 
you want to load single frame from the com-
mand line without intervention. Default is 
$NULL.

/DISPLAY=<n> ..... (Maximum Display Counts)    
[-1]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 
example, corresponding to white) on the dis-
play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -1; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
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look brighter; larger values make look 
darker.

/SCALE=<n>.........(Scale Factor)     [+n]

If you supply a second filename for the $2 
argument described above, the two files are 
combined pixel-by-pixel according to the 
equation:

P0 = P1 + P2 * A + B

where P0 is the pixel value in the resulting 
frame, P1 and P2 are the pixel values in the 
first and second input frames, A is the scale 
factor supplied here, and B is the offset, 
described below. Any resulting P0 values 
less than zero are clipped to zero. A positive 
scale factor results in a weighted addition of 
the two frames while a negative scale factor 
results in a weighted subtraction of frame 2 
from frame 1. If instead of supplying a 
numeric value for the scale factor, you sup-
ply the special characters “+n” or “-n”, the 
program weights the addition or subtraction 
according to the acquisition time ratio 

between the two frames. That is, a value of 
+n results in a scale factor of t1/t2, and -n 
results in a scale of -t1/t2, where t1 and t2 
are the respective acquisition times of frame 
1 and frame 2. 

/OFFSET=<n>...... (Offset)     [0]

Offset to be added prior to clipping negative 
values to zero. This corresponds to “B” in 
the equation given in the scale factor 
description above. This allows you to quanti-
tatively assess signed differences between 
two frames. The DIFFER.LUT color table 
can be useful for viewing signed differences.

While the linear combination capability is 
useful primarily for background subtraction 
in general diffraction applications, you can 
also use it to sum a series of frames to form 
an oscillation picture. For example, the fol-
lowing SLAM commands generated a sum 
of 8 myoglobin frames. Note the increase in 
display level as the sum grows larger:

!
! Make oscillation picture from 8 myoglobin frames
!
LOAD swmyo1.002 swmyo1.003 /DISPLAY=32 /SCALE=1.0 /OFFSET=0.0
LOAD $FRAME swmyo1.004 /DISPLAY=64 /SCALE=1.0 /OFFSET=0.0
LOAD $FRAME swmyo1.005 /DISPLAY=96 /SCALE=1.0 /OFFSET=0.0
LOAD $FRAME swmyo1.006 /DISPLAY=128 /SCALE=1.0 /OFFSET=0.0
LOAD $FRAME swmyo1.007 /DISPLAY=160 /SCALE=1.0 /OFFSET=0.0
LOAD $FRAME swmyo1.008 /DISPLAY=192 /SCALE=1.0 /OFFSET=0.0
LOAD $FRAME swmyo1.009 /DISPLAY=224 /SCALE=1.0 /OFFSET=0.0
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/LOGSCALE..........(Log Scale?)     [No]

If checked in the dialog box, or given as /
LOGSCALE, the frame image is displayed 
using a logrithmic scale. By default it is 
unchecked.

/USE_CONFIG......(Merge Config into Header?)    
[No]

If checked in the dialog box, or given as 
/USE_CONFIG on the command line, this 
qualifier replaces the following frame header 
items with the values currently in the Edit > 
Config dialog. This option always defaults to 
N (unchecked), regardless of the previous 
setting.

You can use this option to update frame 
header values, then use SAVE to save the 
frame with the new values. For example, if 
you took a brass plate image at 18 cm, but 

the Edit > Config dialog contained the wrong 
distance, you could avoid having to retake 
the image as follows:

1. Correct the distance in Edit > Config > User 
settings.

2. Read in the brass plate with LOAD 
/USE_CONFIG (or with this option checked 
in the File > Load input panel).

3. Use File > Save to save the brass plate (so 
that the disk file is also modified).

4. Use Process > Spatial > Process to com-
pute the spatial correction with the correct 
distance.

Header Item CONFIGURE/EDIT Prompt

USER User name

DISTANCE Sample-detector distance

LOWTEMP Low temp device? (Y/N)

TARGET X-ray target material

WAVELENGTHS X-ray source wavelength

SOURCEKV Source kilovolts

SOURCEMA Source milliamps

FILTER Filter / monochromator

CENTER Direct beam X, Direct beam Y

LUT Color table filename
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3.8 File > Save • Save a new 
detector frame to a disk file

Menu Command: File > Save

Accelerator: Ctrl+S

User Level: 1

SLAM Syntax:

SAVE $1 /TITLE=<s> /XENGEN
/DISPLAY=<n>

This command copies a data frame from the 
frame accumulation memory to a specified disk 
file disk for retention. In the process, it allows 
you to specify the file format and a title (up to 72 
characters) to display with the data frame. (This 
title is stored in the output frame header.)

The data to be saved must exist in the 32-bit 
frame accumulation memory. A frame currently 
displayed as a result of a File > Display, File > 
Load, Collect Menu, or Process > Spatial > New 
command can be saved. A few commands will 
destroy the contents of the accumulation mem-
ory. If you need to save a data frame, do so 
before issuing one of these (destructive) com-
mands:

Edit > Clear (if data/image memory is 
cleared)

Peaks > Refl. Array > Threshold

If you try to save data that has been overwritten 
by one of these commands, the program dis-
plays a box with the message:

DETECTOR DATA NOT YET TAKEN OR 
OVERWRITTEN

Because File > Save allows you to write a frame 
in either Bruker or XENGEN 1.3 format, you can 
use it to convert a frame from one format to the 
other. For example, you can use File > Load to 
read in a Bruker-format frame, followed by SAVE 
with the XENGEN-format option set to convert a 
frame from Bruker to XENGEN format. This 
option is rarely used.

When invoked from the menu, or run from the 
command line without arguments, File > Save 
displays a dialog box where you can view/edit 
the arguments described below. Pressing the 
ENTER key or clicking the OK button starts the 
operation. Pressing ESC or the Cancel button 
returns you to the menu. Upon saving, the pro-
gram displays the message “SAVING...” on the 
bottom status line. Saving should be completed 
within a few seconds. If the output filename 
starts with the five characters $NULL (case-
independent), the output is sent to the null han-
dler and discarded.

If the output file already exists, you are 
prompted as to whether or not you want to over-
write the file.
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3.8.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Output Filename)
[no default]

Enter filename for output frame, the default 
extension is *.gfrm, unless the old frame 
naming conventions are being used. The 
output filename is merged with the frame 
data directory in the Project > New dialog 
box. If the output filename starts with the 
five characters $NULL (case-independent), 
the output is sent to the null handler (i.e., is 
thrown away). Note: The special “$NET” is 
no longer supported by GADDS.

/TITLE=<s> ...........(Title)     [$TITLE]

Enter title for output frame (72 characters 
maximum). If you're invoking File > Save 
from the command line, you must enclose 
titles containing imbedded blanks in double 
quotes. The special “$TITLE” will default the 
title to the current title string. The default is 
“$TITLE”.

$FILE:<filename> will read up to eight 72 
character title lines from an ASCII file and 
place these title strings into the eight 
“TITLE” lines in the frame header. The for-
mat of the ASCII file is: “R#:<single line of 
title information>”, where “R#” is the run 

number, taken from the filename. Repeat up 
to eight times for each run.

/XENGEN ............. (Xengen Format? (Y/N))     
[No]

Check this option to write frame in XENGEN 
1.3 (more correctly, in the old PCS computer 
format). The default is unchecked (Bruker 
format). This option is rarely used. By 
default it is unchecked.

/DISPLAY=<n> ..... (Max Displayed Counts)     
[0]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 
example, corresponding to white) on the dis-
play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -0; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.



File Routines GADDS Software Reference Manual

3 - 16 M86-E01008

3.9 File > Logfile • Create a new log 
file and start recording

Menu Command:

File > Logfile

File > Logfile > Enabled

Accelerator: None

User Level: 1

SLAM Syntax: 

LOGFILE /NEW $1 /APPEND
LOGFILE [/ON | /OFF]

The File > LogFile commands are used to main-
tain a record of all of a user's interaction with the 
system. This record is referred to as the “log file” 
or “logfile.” Logfiles are standard ASCII text files 
that can be typed, edited, printed, etc. like any 
other text file. When you start recording to a log 
file, you have the option of appending to the file 
or overwriting it if it already exists.

The File > LogFile > Enabled command toggles 
the current state of recording to the log file. If 
logging is enabled, the command disables it. If 
logging is disabled, the command re-enables it. 
A check mark is displayed in the menu next to 
the File > LogFile > Enabled command if logging 
is currently enabled. From the SLAM command 
line, LOGFILE /ON and LOGFILE /OFF enable 
and disable scripting, respectively.

The log file records each command issued, 
along with its parameter values, a date/time 

stamp, and any non-graphic command output. 
For example, the cursor commands write the 
statistics at the final cursor position to the log 
file, Analyze > Cursor writes a copy of any 17 x 
17 pixel dumps, Process > Stress > Biaxial2D 
writes a copy of the contents of its scrollable 
output window, etc. Commands and output are 
added to the log file until the File > LogFile > 
Enabled option is turned off or the user switches 
projects, which will automatically close any open 
log file.

The File > LogFile > Enabled command does 
not actually close the log file; it just tells the pro-
gram to temporarily stop writing output to the 
file. If you need to access the current log file in 
another process while GADDS is still running, 
for example to edit it from another window, you 
should close the file first. You can close the log 
file by running File > LogFile with another file-
name. The program will close the current file 
before starting a new one.
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An example of a log file output for a CURSORS /
PIXEL command is:

Different types of output lines are prefixed with 
character sequences that make the types easier 
to separate with editors, text filters, etc. Lines 
that do not contain command information are 
prefixed with the comment character “!”. Lines 
that contain command output are prefixed with 
“!>”. Note that the cursor was at X,Y = (435,190) 
when the command started, but the user moved 
the cursor to a final position of (139,311) before 
exiting the command.

With scripting enabled, the same command pro-
duced the following output script file, containing 
just one line:

CURSORS /PIXEL 139 311 /DELAY=0.0

!====================================================
!11/22/91   15:49:03
CURSORS
      $1=435
      $2=190
      /DUMP=N
      /DELAY=0.0
      /NOERASE=N
!>
!> PIXEL Statistics:  SAXI$TEST:swmyo1.005 11/22/91  15:49:36
!> Xraw, Yraw, Counts:        139       311       596
!> X, Y (Unwarped):        142.68    309.13
!> X, Y (XENGEN):             372       200
!> DX, DY:                -113.00     66.52
!> 2-Theta, Angstroms:     21.333     4.165
!> HKL:                     20.97    -10.98     -2.97
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3.9.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its input panel 
prompt in parentheses:

$1 ..........................(Log Filename)     [frame._lg]

Filename of the log file to which output is 
directed. By convention, log files have the 
extension ._lg. If you don't supply a filename 
extension, the program will add the ._lg 
extension. If you leave this item blank, or 
specify a “wildcard” filename pattern, press-
ing ENTER or clicking the OK button will dis-
play a list of the current filenames matching 
the pattern. You can choose one from the 
displayed list by moving to it with the arrow/
page keys or mouse and pressing ENTER 
or clicking the OK button. You will be 
returned to the File > LogFile dialog with the 
selected filename filled in. If you leave this 
item blank, it is the same as entering a *._lg 
wildcard pattern.

/APPEND ..............(Append?)     [Yes]

If you check this option, output will be 
appended to the log file if the file already 
exists. If the option is unchecked (that is, 
missing from the command line or 
unchecked in the dialog box), the output file 
is overwritten if it already exists.
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3.10 File > Scriptfile • Create a new 
script file and start recording

Menu Command:

File > Scriptfile
File > Scriptfile > Enabled

Accelerator: None

User Level: 2

SLAM Syntax:

LOGFILE /SCRNEW $1 /APPEND
LOGFILE [/SCRON | SCROFF]

File > ScriptFile lets you create/record a script 
(containing a list of one or more GADDS com-
mands in SLAM format that execute sequentially 
as a group) as you interactively invoke the com-
mands of your choice. SLAM stands for “Script-
ing Lexical Analyzer and Monitor” and is the 
command language used by most Bruker pro-
grams. (See more details below under “Com-
mand and Script File Conventions” and 
“@Command.”)

The File > ScriptFile > Enabled command tog-
gles the current state of recording to the script 
file. If scripting is enabled, the command dis-
ables it. If scripting is disabled, the command re-
enables it. A check mark displays in the menu 
next to the File > ScriptFile > Enabled command 
if scripting is currently enabled. From the SLAM 
command line, LOGFILE /SCRON and LOG-

FILE /SCROFF enable and disable scripting, 
respectively.

The File > ScriptFile command can be used to 
build script files automatically. To do so, toggle 
the script feature on and operate the system 
using the exact sequence of commands that you 
want to appear in the script. To end the script, 
toggle the scripting feature off. To execute a 
script file, issue the command “@<filename>” 
from the GADDS command line, where <file-
name> represents the name you gave the script 
file. If you attempt to play back a script just 
recorded before exiting and restarting GADDS, 
you must invoke File > ScriptFile with another 
filename to close the script file before starting 
playback. File > ScriptFile > Enabled does not 
close the script file. It only disables recording. 
For the same reason, in order to access a script 
file from another process, you should close the 
script file.

3.10.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Script Filename) [script.slm]

Filename of the script file to which output is 
directed. By convention script files have the 
extension *.slm. If you don't supply a file-
name extension, the program will add the 
.slm extension. If you leave this item blank, 
or specify a “wildcard” filename pattern, 
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pressing ENTER or clicking the OK button 
will display a list of the current filenames 
matching the pattern. You can choose one 
from the displayed list by moving to it with 
the arrow/page keys or mouse and pressing 
ENTER or clicking the OK button. You will 
be returned to the File > ScrFile dialog with 
the selected filename filled in. If you leave 
this item blank, it is the same as entering a 
*.slm wildcard pattern.

/APPEND ..............(Append?)     [Yes]

If this option is checked, output will be 
appended to the script file if the file already 
exists. If the option is unchecked (that is, 
missing from the command line or 
unchecked in the dialog box), the output file 
is overwritten if it already exists.
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3.11 File > Print • Dump screen to 
printer device or file

Menu Command: File > Print

Accelerator: Ctrl+P

User Level: 1

SLAM Syntax: PRINT  $1 /FORMAT=<n> 
/THRESHOLD=<n> /GREYSCALE

This command prints a copy of the data cur-
rently loaded into memory (or on the display) on 
a designated printer, or to a disk file for later 
transfer to a printer or into a word processor pro-
gram.

Under NT, a special “native” format is available 
to specify using the native operation system's 
printer drivers. Text and border lines are printed 
in black, while the frame image is printed in 
either colors or gray-tones, depending on the 
selected printer device.

During printing, the black/white or grayscale of 
the image is approximated by the printer by 
assigning a minimum threshold for black and 
then using either white below that value or print-
ing a 25% level grayscale in landscape format. 
Color scale plots ignore the threshold value and 
print the screen in 16 colors.

When invoked from the menu, or from the com-
mand line without arguments, File > Print dis-
plays a dialog box where you can view/edit the 
following items before performing the print oper-

ation. If you press ENTER or click the OK but-
ton, printing begins. Pressing ESC or the Cancel 
button returns you to the menu. Use 
CTRL+BREAK to interrupt printing in progress.

You can also print the current display screen 
from just about anywhere in the program by 
pressing CTRL+P, allowing you to plot screens 
containing menus, input panels, etc. Don't use 
CTRL+P during real-time data collection. Timing 
of real-time operations could be compromised. 
The parameters on the PRINT input panel affect 
CTRL+P screen dumps the same way as PRINT 
command screen dumps. Note: Under NT, the 
CTRL+P option does not work when GADDS is 
in either a menu panel or a message box.

3.11.1 Arguments

Each option is listed below by its SLAM com-
mand line name, followed by its dialog panel 
prompt in parentheses:

$1…………(Output Device or Filename)     
[$default]

Enter either the filename or device which is 
to receive the printout. The default device is 
SAXI$PRINTER, which you can define as a 
logical name to point to a file or device if 
desired. For example, the DOS command 
SET SAXI$PRINTER=PRN would direct 
output to a parallel printer. Alternatively, you 
can just enter the output name directly in the 
input panel (for example, PRN). If you spec-
ify a filename, the system “prints to disk” 
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creating a file with that filename on the sys-
tem hard disk which may later be output 
directly to a printer without having to run 
GADDS. Under DOS, a command like 
COPY /B <filename> PRN would copy your 
output file to a parallel LaserJet printer.

NOTE: You cannot print to a disk file if you use 
the Native format option.

Under NT, the GADDS printer device is 
often different than the default print device. 
Thus it is a good idea to create an unique 
GADDS print queue with your favorite 
printer settings and set the environment 
variable SAXI$PRINTER equal to the 
“Printer name”. Printing to SAXI$PRINTER 
will proceed without user intervention. Print-
ing to “$DEFAULT” will default to the NT 
default printer, but will always display the 
Print Setup dialog box.

/FORMAT=<n> ......(Format)     [-1 native]

Enter the desired output format of the print 
data. Interactively under NT, valid formats 
are “native”, “BMP”, “TIFF-color”, “TIFF-
grey”, “PostScript-color”, and “PostScript-
grey”. Native refers to the native operating 
system drivers for printers.

In addition to the native NT support, the pro-
gram supports embedded drivers for certain 
printers and file formats:

TIFF and BMP files are printed in portrait 
orientation, while all other output formats 
use landscape orientation to make maxi-
mum use of the page.

/THRESHOLD=<n>…(Threshold)     [16]

Specifies the minimum number of counts to 
be plotted as black. Higher thresholds cause 
the printout to look less black; lower thresh-
olds cause it to look more black. Threshold 
is ignored for color plots.

/GREYSCALE ...... (Highest Resolution)     [Yes]

For PCL5 printers, specifies that any counts 
at or above the threshold are black. Counts 
between zero and the threshold are printed 
in a 25% greytone. If absent on the com-

Format Description

-1 Native NT driver. (default value)

0 PCL4 printers, such as the HP LaserJets.

1 Monochrome TIFF files.

2 Monochrome PostScript files and printers

3 PCL4 color printers, that is, HP PaintJets.

4 Color PostScript Level 2 files and printers, 
that is, Tektronix Phaser II and HP1200C-
PS

5 Color TIFF files.

6 BMP files.

7 Codonics printer.
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mand line or specified as “N” in the input 
panel, all counts below the threshold are 
printed as white.

For color PCL4 printers, specifies to print 
using 16 colors. If absent on the command 
line or specified as “N” in the input panel, 
prints in black/white with all counts below 
the threshold printed as white. Colors are 
approximated with the nearest RGB print-
able color (see your PaintJet manual). For 
this reason, some greytones are printed in 
either brown, olive, green, or pink colors.

For PostScript printers, specifies to print 
using 16 greyscales (FORMAT=2) or 256-
colors (FORMAT=4). If absent on the com-
mand line or specified as “N” in the input 
panel, prints in black/white (FORMAT=2) or 
16-colors (FORMAT=4).

TIFF files behave similar to monochrome 
PostScript printers. A “Y” specifies 16 grey-
scales while “N” signifies black and white 
TIFF file.

NOTE: To preview a print file without actually 
printing the file, load the color lookup table with 
PRINT.LUT (in the Edit > Config > Colors 
panel), which displays the frame in reverse 
black/white greyscale.
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4.  Edit Routines

4.1 Edit > Configure > User settings 
• Edit the current user configuration 
settings

Menu Command: Edit > Configure > User set-
tings

Accelerator: Ctrl+C

User Level: 1(view/edit), 3 (full edit)

SLAM Syntax:

CONFIGURE /EDIT /USER=<s>
/SITE=<s> /CALIBDIR=<s>
/MINCPS=<n> /TIMEOUT=<n>
/NAMECHAR=<n> /RUNCHARS=<n>
/RUNBASE=<n> /NUMCHARS=<n>
/NUMBASE=<n> /LOWTEMP
/TEMP=<n> /XBEAM=<n> /YBEAM=<n>
/FRAMESIZE=<n> /DISTANCE=<n>

Edit > Configure > User settings displays a dia-
log box where you can view/edit certain general 

setup variables, including the current sample-to-
detector distance, beam center coordinates, 
default calibration data directory, and frame 
naming conventions. Unless you are the 
GADDS Administrator, some fields are only 
viewable: calibration directory, beam center, and 
detector distance. To change a view-only field, 
see your GADDS Administrator.

4.1.1 Frame Naming Parameters

Several qualifiers (NAMECHARS, RUNCHARS, 
RUNBASE, NUMCHARS, NUMBASE) comprise 
the convention GADDS uses for generating a 
series of sequential frame names. These nam-
ing parameters are used by the Collect > Scan > 
SingleRun, MultiRun, etc. commands (which 
collect one or more series of frames), and by 
File > Display (which can display a frame series 
in sequence). Thus, to display a series of 
frames, the naming parameters must be set 
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appropriately, to match those in effect when the 
frames were written. 

New conventions:

The filename is created with the jobname, an 
underscore, the run number, an underscore, and 
then the frame number. Prior to concatenation, 
the Run # and Frame # are expanded (with lead-
ing zeros if required) to the number of charac-
ters specified by the Runchars and Numchars 
parameters. The file extension is .gfrm. For your 
convenience, GADDS generates and displays 
an example filename using the current settings.

Old conventions:

If SAXI$OLDNAMES is set, the Run # is 
appended directly to the Job Name, then the 
Frame # is added as the filename extension (it is 
concatenated after pre-pending a dot). Prior to 
concatenation, the Run # and Frame # are 
expanded (with leading zeros if required) to the 
number of characters specified by the Runchars 
and Numchars parameters. For your conve-
nience, GADDS generates and displays an 
example filename using the current settings.

4.1.2 Sample-to-Detector Distance and 
Beam Center Measurement

Your GADDS Administrator should follow the 
“269-0223xx Detector Distance and Beam Cen-
ter Calibration for GADDS” procedure (see 
GADDS Administrator’s Manual), to define the 
true detector distance and beam center parame-
ters. In general, the beam center is stable over 
long periods of time. However, if you replace or 
realign the X-ray tube, or realign the goniometer, 
your GADDS Administrator should repeat this 
procedure.

NOTE: To process frames collected before 
these settings were properly set, see the 
/Use_config argument in Section 3.7.

When you change the detector distance in menu 
mode, you will be prompted with “Reset to 
default collision limits for new distance?”. Enter 
“Y” and GADDS will read the default collision 
limits for 2θ and ω-2θ from the file: GADD$SYS-
TEM:limits.d (see Collect > Goniometer > Limits, 
Section 5.15 for more details).

When you change the low temp flag in menu 
mode on P4 systems, you are informed to set 
your new collision limits for ω and χ under Col-
lect > Goniometer > Limits (see Section 5.15). 
Otherwise, you might break your expensive 
glassware.
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4.1.3 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

/USER=<s>...........(User Name)     
[SAXI$USERNAME]

Enter the user name (default is 
UNKNOWN). If you define the environment 
variable SAXI$USERNAME, its translation 
will be taken as the default value. The name 
you supply will be stored in the header of 
any output frames created in Bruker (the 
normal) format, and in output .p4p files.

/SITE=<s>.............(Site)     [SAXI$SITE]

Enter the site name (default is UNKNOWN). 
If you define the environment variable 
SAXI$SITE, its translation will be taken as 
the default value. The name you supply will 
be stored in the header of any output frames 
created in Bruker (the normal) format, and 
in output .p4p files.

/CALIBDIR=<s> ....(Calibration Data Direc-
tory)     [GADDS$CALIB:]

The directory where calibration data are to 
be stored, such as flood field and spatial 
correction files. The default is 
“GADDS$CALIB:”, which is an environment 
variable that usually translates to 
D:\FRAMES\CALIB\. The special symbol, 
“*:”, means the current directory.

/MINCPS=<n>...... (Minimum Counts per 
Second)     [25]

Enter the minimum counts per seconds on 
scan frames. Frames collected with fewer 
cps are automatically recollected up to 3 
times. This allows correcting stuck shutter 
problems. The default is 25 cps. This is 
automatically deactivated for frames of ten 
minutes or longer.

/TIMEOUT=<n>.... (Auto/Command Mode 
Timeout)   [10]

Enter the number of seconds that you want 
the program to wait before proceeding when 
a prompt or output window displays in 
SLAM command-line mode. The default is 
10 seconds and the valid input range is 0 to 
1,000,000 seconds. A value of 0 means no 
time-out (infinite wait).

/NAMECHARS=<n>…(Characters in Base 
Frame Name)     [28]

The maximum number of characters which 
can be used in the “base” component of a 
frame filename. The base component is 
defined as the filename after removing any 
node, device, directory, extension, and ver-
sion components. NAMECHARS should be 
set to 8 for NT-FAT filenames, or 39 for NT-
enhanced FAT or NTFS (or UNIX) filena-
mes. The default is 28.
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/RUNCHARS=<n>…(Characters in Run #)     [1]

This is the number of characters to be 
appended to the Job Name as a Set Num-
ber or Run Number (that is, the number 
assigned to a series of frames taken at the 
same phi,chi setting). The Run Number is 
padded with leading zeros, if needed to fill 
RUNCHARS characters; it is not automati-
cally incremented within a scan series 
unless the Frame Number overflows. It is 
automatically incremented, however, when 
setting up an EDITRUNS array inside 
ASTRO. RUNCHARS can usually be left at 
the default value of 1; however, if you’re per-
forming more than RUNBASE runs, make 
sure that you set RUNCHARS to 2 to pre-
vent wrap-around of the Run Number, other-
wise earlier scans could be overwritten by 
later ones! For example, if RUNCHARS is 
set to 1 and RUNBASE is 10 (instead of the 
default value of 36), a Run Number of 10 in 
the EDITRUNS array will result in a Run 
Number of 0 in the output filename.

/RUNBASE=<n>…(Base of Run #)     [36]

The numeric base of the Run Number. The 
value must be 10 or 36. If the base is 10, a 
carry out of each digit is produced when the 
digit is incremented from a value of 9, and 
the digit is reset to zero. If the base is 36, 
the digit is incremented from 9 to A, then to 
B, etc. A carry is produced when the digit 
reaches Z, and the digit is reset to zero. 

RUNBASE should usually be left at the 
default value of 36.

/NUMCHARS=<n>…(Character in Frame #)     
[3]

The number of characters to be appended 
to the filename as an extension represent-
ing the number of the frame in the current 
series. The number is padded with leading 
zeros if needed to fill NUMCHARS charac-
ters. This Frame Number is automatically 
incremented by one after each frame is col-
lected during an Acquire > SingleRun, Multi-
Run, Hemisphere, Quadrant, or Matrix 
command. This value should be left at its 
default setting of 3 if you’re collecting to a 
FAT-16 formatted disk partition.

A special case occurs when NUMBASE 
(see below) is set to 10 (the default); the 
most significant digit only is treated as base-
36. Thus, the frame number following .999 
will be .a00. This special case allows up to 
3600 frames in a series when NUM-
BASE=10, while maintaining the DOS 8/3 
filename convention.

/NUMBASE=<n>…(Base of Frame #)     [10]

This value represents the numeric base to 
be used for the frame number; like RUN-
BASE, NUMBASE must be 10 or 36. When 
NUMBASE is 10, the most significant digit in 
the Frame Number is still treated as base 
36, as described above under NUMCHARS. 



GADDS Software Reference Manual Edit Routines

M86-E01008 4 - 5

Base 10 is easier to interpret, but limits the 
number of frames in a run to 3600 under 
DOS, which allows, at most, 3 characters in 
the extension. Base 36 allows a larger num-
ber (363) of frames per run under DOS. This 
parameter should usually be left at its 
default of 10, unless you’re performing 
scans which require single sweeps of more 
than 3600 frames.

/LOWTEMP...........(Low Temp Device (Y/N) ?)     
[No]

Check this box if the LT-2 low-temperature 
device is installed. Specify “N” here (or omit 
the qualifier in command-line mode) if no 
low temperature device is installed. This 
value is stored in the header of output 
Bruker-format frames. If you enter “Y”, 
GADDS fixes omega at 345° for optical 
alignment on a 4-circle goniometer (see the 
Collect > Goniom > Optical command). In 
addition, during data collection, GADDS 
rotates phi back and forth by 170° every few 
frames to help reduce possible sample 
icing.

/TEMP=<n>...........(Current Temperature)     [-1]

Enter current temperature in degrees K (-1 
= room temperature or unknown, default 
value). The Collect > Goniometer > Temper-
ature command (see Section 5.28) can also 
be used to define this parameter.

/XBEAM=<n> ....... (Direct Beam X)       [current 
value]

Unwarped X-pixel coordinate (0 to frame-
size-1) of direct beam center at 2-Theta = 0, 
in the Bruker coordinate convention with 
(0,0) at the lower left of a displayed frame. It 
is important that you enter the correct value 
here before collecting frames that will be 
analyzed with the interactive cursor com-
mands used in conjunction with the spatial 
correction or for determination of crystal ori-
entation with the Reflection Array com-
mands. These commands rely heavily on 
the value given for the beam center. The 
value is stored in the output header of 
Bruker-format frames and in output .p4p 
files. If you change the value of the FRAME-
SIZE field, the beam center position will be 
scaled and converted to the new frame size 
convention; the display will be updated 
when you tab out of the FRAMESIZE field.

NOTE: If you save frames in raw (warped) 
mode, this should be raw X-pixel coordinate.

/YBEAM=<n> ....... (Direct Beam Y)       [current 
value]

Unwarped Y-pixel coordinate (0 to frame-
size-1) of direct beam center at 2-Theta = 0, 
in the Bruker coordinate convention with 
(0,0) at the lower left of a displayed frame. It 
is important that you enter the correct value 
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here before collecting frames that will be 
analyzed with the interactive cursor com-
mands used in conjunction with the spatial 
correction or for determination of crystal ori-
entation with the Reflection Array com-
mands. These commands rely heavily on 
the value given for the beam center. The 
value is stored in the output header of 
Bruker-format frames and in output .p4p 
files. If you change the value of the FRAME-
SIZE field, the beam center position will be 
scaled and converted to the new frame size 
convention; the display will be updated 
when you tab out of the FRAMESIZE field.

NOTE: If you save frames in raw (warped) 
mode, this should be raw Y-pixel coordinate.

/FRAMESIZE=<n>…(Size of Created Frames) 
[1024]

Enter the linear frame dimension (512 or 
1024) for newly created frames. Subsequent 
frames created by commands in the Collect 
menu will have this size. If you change the 
value of the FRAMESIZE field, the beam 
center position will be scaled and converted 
to the new frame size convention; the dis-
play will be updated when you tab out of the 
FRAMESIZE field. Storage requirements 
per 512 x 512 frames range from 256K 
bytes (8 bits per pixel) to 1 Mbyte (32 bits 
per pixel). GADDS automatically com-
presses frames; this compression results in 

no data loss and usually results in storage 
close to 256K bytes, or close to 512K bytes 
if enough diffraction lines are high enough 
that it cannot be contained in 8 bits/pixel. 
1024 x 1024 frames require four times this 
amount of storage. Acquiring and process-
ing larger frames is slower, but will improve 
integration results, so it is highly recom-
mended to use 1024 frames for power dif-
fraction work.

/DISTANCE=<n>…(Sample-Detector Dis-
tance)     [current value]

Enter current nominal sample-to-detector 
distance in centimeters. The default setting 
is 12.00 cm. It is important that you enter 
the correct value here whenever you change 
the detector distance. The value is stored in 
the header of any output frames created in 
Bruker format, and is used by the flood-field 
and spatial corrections, the interactive cur-
sor commands, integration commands, and 
all the Reflection Array commands that deal 
with crystal orientation. The distance is also 
written to output .p4p files.

On systems with a motorized delta axis, use 
the Collect > Goniometer > Det. Stage com-
mand to move the detector distance.
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4.2 Edit > Configure > Admin 
settings • View/edit the current 
administrator configuration settings

Menu Command: Edit > Configure > Admin set-
tings

Accelerator: None

User Level: 2 (view), 3 (edit)

SLAM Syntax:

CONFIGURE /ADMIN /TARGET=<s>
/WAVELENGTH=<n> /ALPHA1=<n>
/ALPHA2=<n> /BETA=<n> /UNITS=<s>
/KV=<n> /MA=<n> /STANDBYKV=<n>
/STANDBYMA=<n>
/STANDBYIDLETIME=<n>
/STANDBYNOEXCLUDE 
/MONOCHROMATOR=<s> 
/OFFSET=<n>

Edit > Configure > Admin settings displays a 
dialog box where you can view/edit certain 
instrumental setup variables, including the x-ray 
source, generator, and optics. Unless you are 
the GADDS Administrator, all fields are only 
viewable. To change a view-only field, see your 
GADDS Administrator.

Whenever a GADDS configuration file is read 
(starting GADDS, switching projects, etc.), the 
program checks the Preferred generator set-
tings against the current settings and if different, 
displays the message:

Warning: Current high-voltage generator 
settings are different than user values.

When you invoke a command from the menu (or 
the command line without arguments), a dialog 
box appears. View or edit its contents (or type 
text). Then:

• Press ENTER or click the OK button to save 
your entry.

• Press ESC or click the Cancel button to 
return to the menu without saving your last 
entry.

4.2.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

/TARGET=<s> ...... (X-ray Target Material)   [Cu]

Enter the standard 2-letter chemical symbol 
for the source target material (Cu, Mo, etc.), 
if applicable. Otherwise enter a short 
description of the radiation source. The 
default target selection is Cu. If you enter 
one of the recognized target types (Cu, Mo, 
Ag, Fe, Cr, or Co), the X-ray wavelengths in 
the following fields will be updated automati-
cally. The value is stored in the header of 
output Bruker-format frames and in output 
.p4p files.
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/WAVELENGTH=<n>…(X-ray Source Wave-
length)     [1.541838]

Enter the weighted-average X-ray wave-
length in Angstroms. The default value is 
based on the default target (Cu) and is set 
at 1.541838 Å. This value is automatically 
updated when the target is re-entered if the 
target is one of the known types (Cu, Mo, 
Ag, Fe, Cr, or Co). It is important that you 
update this entry whenever the source 
wavelength is changed. The value is stored 
in the header of any output frames created 
in Bruker format and in output .p4p files. It is 
also used by the interactive cursor com-
mands, all the Reflection Array commands 
that deal with crystal orientation, Peaks 
commands, and Stress commands.

/ALPHA1=<n>.......(Alpha-1)     [1.54056]

Enter the Ka1 X-ray wavelength in Ang-
stroms. The default value is based on the 
default target (Cu) and is set at 1.54056 Å. 
This value is automatically updated when 
the target is re-entered if the target is one of 
the known types (Cu, Mo, Ag, Fe, Cr, or Co). 
It is important that you update this entry 
whenever the source wavelength is 
changed. The value is stored in the header 
of any output frames created in Bruker for-
mat and in output .raw files. It is also used 
by the interactive cursor commands, all the 
Peaks commands, and the Stress com-
mands.

/ALPHA2=<n> ...... (Alpha-2)     [1.54439]

Enter the Ka2 X-ray wavelength in Ang-
stroms. The default value is based on the 
default target (Cu) and is set at 1.54439 Å. 
This value is automatically updated when 
the target is re-entered if the target is one of 
the known types (Cu, Mo, Ag, Fe, Cr, or Co). 
It is important that you update this entry 
whenever the source wavelength is 
changed. The value is stored in the header 
of any output frames created in Bruker for-
mat and in output .raw files. It is also used 
by the interactive cursor commands, all the 
Peaks commands, and the Stress com-
mands.

/BETA=<n> ........... (Beta)     [1.39222]

Enter the Kb X-ray wavelength in Ang-
stroms. The default value is based on the 
default target (Cu) and is set at 1.39222 Å. 
This value is automatically updated when 
the target is re-entered if the target is one of 
the known types (Cu, Mo, Ag, Fe, Cr, or Co). 
It is important that you update this entry 
whenever the source wavelength is 
changed. The value is stored in the header 
of any output frames created in Bruker for-
mat and in output .raw files. It is also used 
by the interactive cursor commands and all 
the Peaks commands.
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/UNITS=<s> ..........(Units)     [angstroms]

Enter the wavelength units as either Ang-
stroms (conventional and US standard) or 
nanometers (new European standard). The 
default value is Angstroms. This value only 
affects displaying wavelengths within the 
GADDS program. All wavelengths within 
data files are always stored in Angstroms.

/KV=<n>................(Preferred Settings: 
Voltage)     [50]

Enter the preferred X-ray generator kV set-
ting (default is 50 kV). This value is stored in 
output .p4p and .raw files and in the header 
of output Bruker-format frames. If you use 
Goniom > Generator to set the X-ray gener-
ator voltage, this value will default to the cur-
rent generator setting.

/MA=<n> ...............(Preferred Settings: 
Current)     [40]

Enter the preferred X-ray generator milli-
amps setting (default is 40 ma). This value 
is stored in output .p4p and .raw files and in 
the header of output Bruker-format frames. 
If you use Goniom > Generator to set the X-
ray generator current, this value will default 
to the current generator setting.

/STANDBYKV=<n>…(Standby settings: 
Voltage)     [20]

Enter the standby X-ray generator kV set-
ting (default is 20 kV). GADDS will automat-

ically reduce the generator settings to 
standby mode whenever the program has 
been idle for 10 minutes and the time is not 
between 8a.m. and 5 p.m. on a weekday. 
(This feature fails after 16-Jan-2038).

/STANDBYMA=<n>…(Standby settings: 
Current)  [5]

Enter the standby X-ray generator milliamps 
setting (default is 5 ma). See above 
/STANDBYKV.

/STANDBYIDLETIME=<n>…(Standby settings: 
Idle time)  [30 min]

Enter the standby idle time after which the 
generator is set to standby values.

/STANDBYNOEXCLUDE…(Standby settings: 
Don't exclude weekdays 8AM to 5 PM)  [No]

Check “Y” to allow standby to occur during 
normal working hours.

/MONOCHROMATOR=<s>…(Filter / Monochro-
mator)     [parallel, graphite]

Enter a short description of filter or mono-
chromator (default is “parallel, graphite”). 
Currently this value has no effect on the 
operation of the program, but it is stored in 
the header of output Bruker-format frames.

/OFFSET=<n>...... (2-Theta Offset)     [0.0]

This only affects dual detector systems. On 
Master frame buffer, enter 0.0. On Slave 



Edit Routines GADDS Software Reference Manual

4 - 10 M86-E01008

frame buffer, enter the slave’s detector 2θ 
offset in degrees from the goniometer’s 2θ 
setting.

4.3 Edit > Configure > Read • Read a 
new configuration from a disk file

Menu Command: Edit > Configure > Read

Accelerator: None

User Level: 2

SLAM Syntax: CONFIGURE /READ $1

Use this command to restore current program 
settings from a specified disk file. These config-
uration files, which have file extensions of ._nc, 
contain the current flood file correction, spatial 
correction, and current values of nearly all input 
panel items for nearly all the GADDS com-
mands (a few exceptions).

4.3.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1…………..(Configuration Filename)     
[gadds._nc]

Enter the filename where the configuration 
is to be saved (or read). The default file is 
gadds._nc. If you omit the file extension, 
*._nc is assumed.
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4.4 Edit > Configure > Write • 
Save the current configuration to a 
disk file

Menu Command: Edit > Configure > Write

Accelerator: None

User Level: 2

SLAM Syntax: CONFIGURE /WRITE $1

Use this command to save current program set-
tings to a specified disk file for later read-in 
using the Edit > Configure > Read command. 
Typically, you would use these commands to 
save a good configuration, play around with the 
program, and if something fails, restore the good 
configuration.

These configuration files, which have file exten-
sions of ._nc, contain the current flood file cor-
rection, spatial correction, and current values of 
the input panel items for nearly all the GADDS 
commands (a few exceptions).

On startup, GADDS normally reads its configu-
ration from a file called gadds._nc in the current 
project’s working directory. You can override this 
startup behavior with a startup command line 
qualifier. (See Section 1.3, for details.) On exit-
ing, GADDS normally saves its configuration file 
into a file called gadds._nc in the current 
project’s working directory.

These commands are active and do not prompt 
before performing an operation (i.e., overwriting 
an existing file).

4.4.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1…………...(Configuration Filename)     
[gadds._nc]

Enter the filename where the configuration 
is to be saved (or read). The default file is 
gadds._nc. If you omit the file extension, 
*._nc is assumed.
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4.5 Edit > Configure > Show model • 
Display the current goniometer and 
controller type

Menu Command: Edit > Configure > Show 
model

Accelerator: None

User Level: 1

SLAM Syntax: CONFIGURE /SHOWMODEL

Use this command to display the current goni-
ometer model type, maximum frame size, cur-
rent frame size, current flood correction, current 
spatial correction, project working directory, and 
calibration directory.

Normally, the goniometer type is defined when 
the software is installed, but occasionally, when 
one changes the goniometer stage, you must 
also change the goniometer type as follows:

4.5.1 Arguments

None. Command executes immediately.

X100 Obsolete setting

X200 Obsolete setting

P3X1000 Obsolete setting

P3X2000 HI-STAR on P4 goniometer

X1000 Obsolete setting

X2000 HI-STAR on Aztalan goniometer

PLATFORM HI-STAR on PLATFORM goniometer

¼-CIRCLE Obsolete setting, use T:¼-CIRCLE

T:¼-CIRCLE PLATFORM ¼-circle in transmission mounting

R:¼-CIRCLE PLATFORM ¼-circle in reflection mounting

D8 HI-STAR on D8 DISCOVER goniometer
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4.6 Edit > Configure > Colors • 
Edit the current color 
configuration settings

Menu Command: Edit > Configure > Colors

Accelerator: None

User Level: 1

SLAM Syntax:

CONFIGURE /COLORS $1 /WINBG=<n>
/WINFG=<n> /CURSOR=<n>
/HIGHLIGHT=<n> /BORDER=<n>
/GRAPH=<n> /OVERLAY=<n>
/MATCH1=<n>

This command displays a dialog box where you 
can view or edit the colors used for the windows 
displayed by the program and the color scheme 
(called a “color table” or “color lookup table”) 
used to display detector frame pixel values.

Each window color (WINBG, WINFG, CURSOR, 
HIGHLIGHT, and BORDER) is specified as a 9-
digit decimal integer. The first three digits corre-
spond to the red level, the second three to the 
green level, the last three to the blue level. The 
range for each color is 0-255. Thus, the number 
itself has a range from 000000000 to 
255255255 (RRRGGGBBB). For example, the 
value 255000000 is bright red, 000255000 is 
bright green, 255255000 is bright yellow, 
255255255 is white, 050000050 is dark purple, 
000000000 is black, and 080080080 is gray.

The simplest way to select a color is to enter an 
asterisk (*) and let the program display a color 
table map, where you can click on any color and 
have the RGB value calculated.

When you invoke a command from the menu (or 
the command line without arguments), a dialog 
box appears. View or edit its contents (or type 
text). Then:

• Press ENTER or click the OK button to save 
your entry.

• Press ESC or click the Cancel button to 
return to the menu without saving your last 
entry.

GADDS displays the angle status in the follow-
ing color scheme:

• Non-controllable axes in border color.

• Moving axes in highlight color.

• Stationary and controllable axes in fore-
ground color.

• Axes in collision state in reverse video: 
background on highlight color.
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4.6.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(Color Table Filename) 
[bb.lut]

Enter name of the color lookup table to be 
used for frames. This entry does not affect 
the colors used for menus, windows, screen 
background, etc. Color tables are assumed 
to be located in the directory pointed to by 
GADDS$SYSDATA:, and a .lut filename 
extension is assumed if you don’t specify 
one. The following color tables are supplied 
with the program. In addition, you can sup-
ply the special value, $DEFAULT, which 
refers to a table similar to bb.lut below, 
which is not disk-resident but, rather, is 
hard-wired into the program code.

BB.LUT The default color table gen-
erated using a blackbody 
radiation model. Intensities 
are monotonically increas-
ing, but color provides better 
discrimination than a straight 
monochrome scheme.

CUSTOM.LUT Arbitrary multicolor scheme

DIFFER.LUT Red/green color table useful 
in viewing frames that are 
built from differences (for 

example a subtraction of one 
frame from another)

MONO.LUT Monochrome grayscale color 
table

PRINT.LUT Reverse monochrome gray-
scale color table. Useful for 
previewing monochrome 
hardcopy screen dumps

V16.LUT 16-level color table, using a 
scheme similar to the 
defaults on older PCS sys-
tems

V8.LUT 8-level color table, using a 
scheme similar to the 
defaults on older PCS sys-
tems

V8SYM.LUT Like V8, but with colors sym-
metrically distributed about 
the center display memory 
value

VIDEO.LUT Another arbitrary multicolor 
scheme

When using the Edit > Config > Colors dia-
log, you can select the lookup table name 
from a list of available filenames by specify-
ing a “wildcard” pattern in the COLOR 
TABLE FILENAME entry or by leaving the 
entry blank, and pressing ENTER or the left 
mouse button. The default filespec used to 
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search for available lookup tables is 
GADDS$SYSDATA:*.lut.

/WINBG=<n> ........(Window Background Color)     
[000000050]

Specifies the window background color as a 
9-digit number in RRRGGGBBB format (see 
above). This is the color of the background 
outside of the image area when the program 
is started. By default, it is dark blue 
(000000050).

/WINFG=<n>.........(Window Foreground Color)     
[255255255]

Specifies the window foreground color as a 
9-digit number in RRRGGGBBB format (see 
above). This is the color of the screen text 
you see in the status areas, menus, and 
panels. By default, it is white (255255255).

/CURSOR=<n> .....(Cursor Color)     
[000255255]

Specifies the color of the cursors that 
appear in the interactive cursor commands 
as a 9-digit number in RRRGGGBBB format 
(see above). This same color is used to 
draw graphic overlays (for example, X-Y 
plots). By default, it is cyan (000255255).

/HIGHLIGHT=<n>…(Highlight Color)     
[210000000]

Specifies the background color of “high-
lighted” text as a 9-digit number in 

RRRGGGBBB format (see above). Text 
which is highlighted includes window title 
bars, and prompts, warnings and error mes-
sages displayed on the bottom status line. 
By default, it is read (210000000).

/BORDER=<n>..... (Border Color)     
[064192200]

Specifies the color of the line drawn around 
windows and panels as a 9-digit number in 
RRRGGGBBB format (see above). By 
default, it is light cyan (064192200).

/GRAPH=<n> ....... (Raw Graph Color)     
[255255255]

Specifies the color of the graphs drawn in 
the Peaks commands as a 9-digit number in 
RRRGGGBBB format (see above). By 
default, it is white (255255255).

/OVERLAY=<n> ... (Peak Overlay Color)     
[000255000]

Specifies the color of the peak overlays 
drawn in the Peaks commands as a 9-digit 
number in RRRGGGBBB format (see 
above). By default, it is green (000255000).

/MATCH1=<n>...... (Match #1 Overlay Color)     
[000255255]

Specifies the color of the second graph 
drawn in the Peaks commands as a 9-digit 
number in RRRGGGBBB format (see 
above). By default, it is cyan (000255255).
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4.7 Edit > Clear • Erase the data 
array and/or the display screen

Menu Command: Edit > Clear

Accelerator: Ctrl+Del

User Level: 1

SLAM Syntax: CLEAR  $1 /QUADRANT=<n> 
/GRAPHICS_SAVE /IMAGE_SAVE

Analyze > Clear erases a specified region of the 
display and/or frame buffer memory. Clearing of 
the screen can be confined to just image data 
(retaining any overlaid graphics) or just graphic 
overlays (retaining the underlying image).

When invoked from the menu, or from the com-
mand line without arguments, Analyze > Clear 
displays a dialog box where you can view/edit 
the arguments described below. Pressing the 
ENTER key or clicking the OK button starts the 
operation. Pressing ESC or the Cancel button 
returns you to the menu.

4.7.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(Screen, Data, or All?)     
[ALL]

Selects either the screen, the frame buffer 
accumulation memory (data) or both are to 
be cleared. “SCREEN” = erase display, 
“DATA” = erase accumulation memory, 

“ALL” = erase both. The default value is 
“ALL”.

/QUADRANT=<n>…(Screen Quadrant)     [0]

Specifies the targeted display quadrant(s), 
to be cleared. The selection criteria are: 0 = 
all (the entire image area), 1 = first quadrant 
(lower left), 2 = second quadrant (lower 
right), 3 = third quadrant (upper left), and 4 
= fourth quadrant (upper right). The default 
value is 0 (clears everything).

/GRAPHICS_SAVE…(Preserve Graphics 
(Y/N) ?)     [No]

Specifies whether or not to preserve the 
graphics if you clear the screen. Enter “Y” to 
erase just the displayed image and retain 
any overlaid graphics, “N” otherwise. The 
default value is “N”.

/IMAGE_SAVE ..... (Preserve Image (Y/N) ?)     
[No]

Specifies whether or not to preserve the 
image if you clear the screen. Enter “Y” to 
erase only the overlaid graphics and retain 
the underlying image, “N” otherwise. The 
default value is “N”.
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4.8 Edit > Contrast • Change the 
screen brightness and contrast

Menu Command: Edit > Contrast

Accelerator: Ctrl+T

User Level: 1

SLAM Syntax: CONTRAST /LO=<n> /HI=<n>

This command performs real-time linear map-
ping of frame pixel values into the colors in the 
color lookup table currently loaded. (See Edit > 
Colors for more about color lookup tables.) 
Based on the current mouse position (or the 
specified LO and HI values if invoked from the 
command line), Edit > Contrast computes a 
lower and upper limit. All pixel values at or below 
lower limit show up as lowest color in the color 
table (for example, black). Those at or above 
upper limit appear as highest color (for example, 
white). Pixel values in between are linearly 
mapped to colors in the table.

When you invoke this command from the menu, 
or from the command line with no arguments, 
you can change the lower and upper limit with 
the mouse or arrow keys. Horizontal motion 
changes the width of the contrast window. 
Motion to the left brings the lower and upper lim-
its closer together (increasing contrast) and 
motion to the right moves the upper and lower 
limits farther apart (reducing contrast and 
increasing latitude). Horizontal motion is, thus, 
analogous to a contrast control or choosing a 

type of film according to the desired latitude. 
Vertical motion raises or lowers the upper and 
lower limits together and is analogous to a 
brightness control or to selecting the length of 
exposure of a film.

When you’re using the arrow keys to modify 
contrast, you can press CTRL simultaneously 
with an arrow key to jump in intervals ten times 
larger than the arrow key alone.

To exit and save your changes to the color map-
ping, press ENTER or the left mouse button. To 
exit and reset the mapping to default (wide-
open) levels, press ESC or the right button. 
When invoked from the command line with both 
the arguments shown below, the mapping is 
changed to the specified lower and upper limits, 
and control returns immediately to the command 
line.

SLAM arguments follow:

/LO=<n> ............... [0]

The number of counts to be mapped to the 
lowest display color. The default value is 0. 
The valid range is -255 to 65535.

/HI=<n> ................ [255]

The number of counts to be mapped to the 
highest display color. The default value is 
255. The valid range is -255 to 65535.
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4.9 Edit > Zoom • Magnify a 
specified square area on the display

Menu Command: Edit > Zoom

Accelerator: Ctrl+Z

User Level: 1

SLAM Syntax: ZOOM  $1  $2  $3

Analyze > Zoom displays the pixels surrounding 
a specified center point as a magnified image. 
Magnification is performed by pixel replication, 
with the replication factor a power of 2 from 1 to 
16, where 1 corresponds to the normal, unmag-
nified display. If the specified X or Y center 
would leave part of the image area blank, the 
image is translated only far enough to place the 
edge of the frame at the edge of the image area.

No arguments are prompted for when ZOOM is 
invoked from the menu. ZOOM displays a full-
screen crosshair; the zoom center is selected 
with the crosshair, which can be dragged with 
the mouse (or cursor keys). Once the zoom cen-
ter is selected, press ENTER or release the left 
mouse button to display the following pop-up 
menu, from which you can choose the desired 
magnification factor:

Exit

1X

2X

4X

8X

16X

Select the EXIT option to exit and return to the 
menu.

Cursor commands that return pixel values and 
positions can be used on zoomed images. Posi-
tions are reported relative to the original image; 
for example, if the magnification factor is 16, you 
would need to press the left arrow key 16 times 
in Analyze > Cursor to change from one X-pixel 
coordinate to another (assuming you start at the 
edge of an unmagnified pixel).

When invoked from the command line inter-
preter mode, the ZOOM command accepts 
three arguments.

$1 ......................... (X)     [255]

Enter X-pixel to try to center on screen. The 
range is from 0 to framesize-1.

$2 ......................... (Y)     [255]

Enter Y-pixel to try to center on screen. The 
range is from 0 to framesize-1.

$3 ......................... (Magnification)     [1]

Enter the magnification (zoom) to examine a 
specific area in greater detail. The allowed 
range is from 1 to 16.
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4.10 Edit > Frame info • View a frame 
header

Menu Command: Edit > Frame info

Accelerator: Ctrl+F

User Level: 1

SLAM Syntax: FRAME_INFO $1

Edit > Frame Info allows you to view the header 
of the currently displayed frame, or that of a 
specified frame file (very useful for detective 
work for data collection parameters).

When invoked from the menu, or run from the 
command line without arguments, Edit > Frame 
Info displays a dialog box where you enter the 
name of the frame whose header is to be 
viewed. After entering the filename, pressing 
ENTER or clicking the OK button displays the 
header in a scrollable window; pressing ESC or 
clicking the Cancel button returns you from the 
dialog to the menu without displaying the 
header.

When viewing the header, pressing the ENTER 
key or clicking the OK button terminates the 
scrollable window and returns you to the menu 
bar. You can click the Write.. button to write the 
currently selected header text (or the entire 
header, if nothing is selected to an ASCII text 
file, or click the Print... button to send the header 
text to a printer.

See Appendix A: Area Detector Frame Format: 
Headers for more information.

4.10.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ......................... (Frame Filename)     
[$FRAME]

Filename of the frame whose header is to 
be displayed. The special name $FRAME 
(the default) refers to the currently displayed 
frame. If you leave this item blank on the 
input panel, or specify a “wildcard” filename 
pattern, pressing ENTER or clicking the OK 
button will display a list of the current filena-
mes matching the pattern. You can choose 
one from the displayed list by moving to it 
with the arrow/page keys or scroll bars and 
mouse, then pressing ENTER or clicking 
OK. You will be returned to the input panel 
with the selected filename filled in. If you 
leave this item blank, it is the same as enter-
ing a *.* wildcard pattern. Remember that 
both filenames and patterns entered here 
are merged with the Crystal > New Project 
data directory (see Crystal > New Project for 
details).

See the Appendix A, Bruker Area Detector 
Frame Data Format, for details on the frame 
header.
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5.  Collect Routines

5.1 Collect > Detector > Cu bias • 
Set PDC to Cu (low) bias setting

Menu Command: Collect > Detector > Cu bias

Accelerator: Ctrl+Shift+C

User Level: 1

SLAM Syntax: DETECTOR /CU

Use this command to place the PDC and detec-
tor at the Cu (low) bias setting. The action is per-
formed immediately, with no prompt for 
additional input. The DETECTOR item in the 
goniometer status area at the lower right of the 
display is updated to reflect the new bias status.

NOTE: For the GADDS software to be able to 
change the detector bias, the PDC (position 
decoding circuit) must be in
Detector Bias - On              Source Select - Auto.

If the bias setting is incorrect when invoking 
either a Process > Flood > New, a Process > 
Spatial > New, or any Collect > Scan command, 
GADDS will prompt the user to switch to the cor-
rect bias setting before collecting the data. Fe, 
high, bias is used by Flood and Spatial, while 
Cu, low, bias is used for Scan commands.

5.1.1 Arguments

None. Command executes immediately.
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5.2 Collect > Detector > Fe Bias • 
Set PDC to Fe (high) bias setting

Menu Command: Collect > Detector > Fe bias

Accelerator: Ctrl+Shift+F

User Level: 1

SLAM Syntax: DETECTOR /FE

Use this command to place the PDC and detec-
tor at the Fe (high) bias setting. The action is 
performed immediately, with no prompt for addi-
tional input. The DETECTOR item in the goni-
ometer status area at the lower right of the 
display is updated to reflect the new bias status.

NOTE: For the GADDS software to be able to 
change the detector bias, the PDC (position 
decoding circuit) must be in
Detector Bias - On              Source Select - Auto.

If the bias setting is incorrect when invoking 
either a Process > Flood > New, a Process > 
Spatial > New, or any Collect > Scan command, 
GADDS will prompt the user to switch to the cor-
rect bias setting before collecting the data. Fe, 
high, bias is used by Flood and Spatial, while 
Cu, low, bias is used for Scan commands.

5.2.1 Arguments

None. Command executes immediately.

5.3 Collect > Detector > Y vs. X • Set 
PDC for normal positional display

Menu Command: Collect > Detector > Y vs. X

Accelerator: none

User Level: 1

SLAM Syntax: DETECTOR /YVSX

Use this command to place the PDC and detec-
tor into normal X-Y position display. The action 
is performed immediately, with no prompt for 
additional input.

5.3.1 Arguments

None. Command executes immediately.
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5.4 Collect > Detector > E vs. E • 
Set PDC for energy versus energy for 
bias calibration

Menu Command: Collect > Detector > E vs. E

Accelerator: none

User Level: 1

SLAM Syntax: DETECTOR /EVSE

Use this command to place the PDC and detec-
tor into energy versus energy for bias calibra-
tion. The action is performed immediately, with 
no prompt for additional input.

5.4.1 Arguments

None. Command executes immediately.

5.5 Collect > Detector > Add • 
Accumulate a frame with temporary 
linear flood field

Menu Command: Collect > Detector > Add

Accelerator: none

User Level: 1

SLAM Syntax:

DETECTOR  /ADD  $1  /CLEAR
/PATTERN  /COUNTS=<n>
/DISPLAY=<n>  /REALTIME
/RESET=<n>  /SHUTTER

Use this command to collect a single “still” frame 
of data at a fixed goniometer position using a lin-
ear flood field. Data is continuously acquired 
until either a specified amount of time has 
elapsed or a specified number of counts is 
reached, whichever occurs first.

You can optionally display the accumulated 
frame after it has been acquired, or update the 
display immediately as each count is recorded 
(referred to as “real-time display”). If you elect 
one of the display options, ADD also updates 
the current frame status information displayed at 
the upper right of the screen.

The frame remains in the frame buffer's accu-
mulation memory; it is not written directly to 
disk. Use the SAVE command to save the data 
to disk.
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5.5.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(Max. Seconds)     [30]

This is the maximum count time (in sec-
onds). The default value is 30; the range is 
from 1 to 65,535 seconds. Times can be 
entered in decimal seconds or in 
HH:MM:SS.SS (hours, minutes and sec-
onds) format. Data collection ends when the 
specified time has elapsed, or when the 
maximum count limit (see MAX COUNTS 
below) has been reached.

/CLEAR .................(Pre-Clear?)     [Y]

This qualifier, when set, clears memory 
before the new data frame is collected. If it 
is not set, the new data are added to the 
image already in the frame accumulation 
memory (for example, an image left over 
from a previous ADD, LOAD, or SCAN com-
mand).

/PATTERN .............(Test Pattern?)     [N]

This qualifier, when present, draws a test 
grid into the frame accumulation memory 
prior to collecting data. The test grid is used 
for factory alignment and consists of grid 
lines on a 64-pixel spacing; two circles, one 
with a 270-pixel radius and one with a 280-
pixel radius; and two crosses rotated to 45 

degrees, one linear cross, and one passed 
through the current flood field correction.

/COUNTS=<n>..... (Max. Counts)   [10,000,000]

This qualifier sets an upper limit on how 
many counts may occur before data collec-
tion is terminated. When the specified num-
ber is reached the system ends the data 
collection, saving the data frame. The 
default value is 10,000,000 counts, with a 

range from 0 to 1037 counts. Data collection 
will also be terminated if MAX SECONDS is 
reached before MAX COUNTS.

/DISPLAY=<n> ..... (Max Displayed Counts)    [7]

0 = no display, otherwise # counts corre-
sponding to white on the display. The initial 
default is 7; the allowed range is from 0 to 

106.

/REALTIME........... (Real-time Display)     [Y]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 
the frame will be automatically displayed at 
the end of the ADD if real-time display is off. 
This latter display method has no effect on 
observed data rate.

If you're not sure whether real-time display 
will affect the observed data rate signifi-
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cantly at your current incident count rate, 
check the late counts in the frame header of 
a representative frame with the 
FRAME_INFO command. If the late counts 
are more than a few percent of the total 
counts, your data collection will be more effi-
cient if real-time display is turned off. In gen-
eral, you should be able to use real-time 
display for set-up and sample evaluation, 
but you should disable it during collection of 
frame series which will be used as input to 
data reduction (see the similar SCAN com-
mand display options).

/SHUTTER ............(Open & Close Shutter?)  [N]

This qualifier, if present, causes the shutter 
to open at the start of the ADD, and to close 
at the end. Otherwise, the shutter stays in its 
current state for the duration of the ADD.

/RESET=<n>.........(Bar-Graph Hold Time)  [0.0] 

This qualifier specifies the number of sec-
onds before repetitive auto-clear of frame 
memory (0 = do not clear). The default value 
is 0; the range is from 1 to 65,535 seconds. 
This parameter is useful in conjunction with 
real-time display if you're looking for a 
change in intensity over time. For instance, 
if you're driving the goniometer manually to 
look for or maximize the intensity of a reflec-
tion, it helps to clear the screen frequently, 
for example every 1 second by setting the 
reset interval to 1.
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5.6 Collect > Detector > Reset • 
Reset to x-position vs. y-position, 
Cu bias

Menu Command: Collect > Detector > Reset

Accelerator: Ctrl+Shift+R

User Level: 1

SLAM Syntax: DETECTOR /DETRESET

Use this command to place the PDC and detec-
tor at the Cu (low) bias setting and into normal 
X-Y position display. The action is performed 
immediately, with no prompt for additional input. 
The DETECTOR item in the goniometer status 
area at the lower right of the display is updated 
to reflect the new bias status.

NOTE: For the GADDS software to be able to 
change the detector bias, the PDC (position 
decoding circuit) must be in
Detector Bias - On              Source Select - Auto.

If the bias setting is incorrect when invoking 
either a Process > Flood > New, a Process > 
Spatial > New, or any Collect > Scan command, 
GADDS will prompt the user to switch to the cor-
rect bias setting before collecting the data. Fe, 
high, bias is used by Flood and Spatial, while 
Cu, low, bias is used for Scan commands.

5.6.1 Arguments

None. Command executes immediately.

5.7 Collect > Detector > X-E vs. X • 
Set PDC for X preamp calibration

Menu Command: Collect > Detector > X-E vs. X

Accelerator: none

User Level: 2

SLAM Syntax: DETECTOR /XEVSX

Use this command to place the PDC and detec-
tor for X preamp calibration. The action is per-
formed immediately, with no prompt for 
additional input.

5.7.1 Arguments

None. Command executes immediately.
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5.8 Collect > Detector > Y-E vs. X • 
Set PDC for Y preamp calibration

Menu Command: Collect > Detector > Y-E vs. X

Accelerator: none

User Level: 2

SLAM Syntax: DETECTOR /YEVSX

Use this command to place the PDC and detec-
tor for Y preamp calibration. The action is per-
formed immediately, with no prompt for 
additional input.

5.8.1 Arguments

None. Command executes immediately.

5.9 Collect > Detector > Custom • 
Enter values to be loaded into PDC 
setup registers

Menu Command: Collect > Detector > Custom

Accelerator: none

User Level: 3

SLAM Syntax: DETECTOR /PDCCUSTOM  $1  
$2  $3

Use this command to place the PDC and detec-
tor into a custom configuration. Useful for testing 
purposes only.

5.9.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ......................... (X-ADC Source)     [0]

Enter 0 for X-position, 1 for X-energy, 2 for 
Y-position, or 3 for Y-energy.

$2 ......................... (Y-ADC Source)     [2]

Enter 0 for X-position, 1 for X-energy, 2 for 
Y-position, or 3 for Y-energy.

$3 ......................... (Bias)     [0]

Enter 0 for Cu, low BIAS, 1 for Fe, high bias.
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5.10 Collect > Goniometer > Drive • 
Move goniometer angles to specified 
positions

Menu Command: Collect > Goniometer > Drive

Accelerator: Ctrl+Shift+D

User Level: 1

SLAM Syntax:

GONIOMETER /DRIVE  $1  $2  $3  $4 $5
$6  $7  $8
or
GONIOMETER /DRIVE  $1  $2  $3  $4

Use this command to drive the goniometer 
angles and axes to a specified position. The 
default settings are the current angles/positions, 
so you only change the axes that you wish to 
drive. The minimum and maximum allowed val-
ues are taken from the current software collision 
limit settings (see Collect > Goniometer > Limits 
settings, Section 5.15), but on a ¼-circle sys-
tem, the extended limits (see Collect > Goniom-
eter > ExtLimits, Section 5.16) can restrict 
goniometer motion and detector XYZ limits (see 
Collect > Goniometer > XYZ stage, Section 
5.27) can further restrict goniometer motion.

When in the panel, pressing the ESC key or 
clicking Cancel button returns you to the main 
menu-menu. Pressing the ENTER key or click-
ing OK button initiates the drive command.

GADDS checks the specified angles against the 
current collision limits and extended limits and 
displays an error message if the requested 
angles/positions are not allowed. Otherwise, 
GADDS begins moving the goniometer to the 
specified angles/positions. During the drive the 
message appears on the bottom status line:

DRIVING—PRESS ANY KEY TO STOP...

You can halt the drive by pressing a keyboard 
key (for example, ENTER or the space bar).

On completion, the program updates the current 
goniometer angles displayed in the goniometer 
status area at the lower right of the screen.

Collect > Goniometer > Drive will try to drive any 
angle to the specified destination by the shortest 
path, unless the collision limits specifically pre-
vent it from doing so. In that case, the longer 
path will be taken. On 1/4-circle systems, Col-
lect > Goniometer > Drive will drive around 
obstacles in omega-chi space as defined by the 
Goniometer /Extlimits command, which may 
take several drives to reach the final destination.
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5.10.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(2-Theta)     [current setting]

$1 ..........................(THETA1)   [current setting]

Enter the destination 2θ angle in degrees 
(or the theta-tube angle for θ-θ systems) in 
degrees. Default is current setting.

$2 ..........................(Omega)     [current setting]

$2 ..........................(THETA2)   [current setting]

Enter the destination ω angle in degrees (or 
the theta-detector for θ-θ systems) angle in 
degrees. Default is current setting.

$3 ..........................(Phi)     [current setting]

Enter the destination φ angle in degrees. 
Default is current setting.

$4 ..........................(Chi)     [current setting]

Enter the destination χ angle in degrees. 
Default is current setting.

$5 ..........................(X)     [current setting]

Enter the destination X position in mm. 
Default is current setting.

$6 ..........................(Y)     [current setting]

Enter the destination Y position in mm. 
Default is current setting.

$7 ......................... (Z)     [current setting]

Enter the destination Z position in mm. 
Default is current setting.

$8 ......................... (Aux1)     [current setting]

Enter the destination aux position in aux 
units. Default is current setting. Typically, 
this axis is used for the video zoom option, 
thus its units are magnification factor in the 
range 1.0 to 7.0.
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5.11 Collect > Goniometer > Manual • 
Control goniometer from manual box

Menu Command: Collect > Goniometer > Man-
ual

Accelerator: Ctrl+Shift+M

User Level: 1

SLAM Syntax:

GONIOMETER /MANUAL  $1  $2  $3  $4  
$5  $6  $7  $8
or 
GONIOMETER /MANUAL  $1  $2  $3  $4  
$5
also
RATEMETER  $1  /RESET=<n>  
/SHUTTER

Use this command to operate the goniometer 
motors using the manual control box. While the 
manual control is activated, the program control 
is suspended.

When in the panel, pressing the ESC key or 
clicking Cancel button returns you to the main 
menu-menu. Pressing the ENTER key or click-
ing OK button initiates the manual command. 
The goniometer is said to be in “manual mode” 
when in this state. During manual mode, the fol-
lowing message appears on the bottom status 
line:

MANUAL MODE. ESC=EXIT, 
S=SHUTTER, T=ATTENUATOR, A=ADD, 
C=COUNT, L=LASER.

Pressing ESC (or CTRL+G) exits manual mode, 
closing the shutter (if open), and returns you to 
the main menu. Pressing the S key toggles the 
state of the X-ray shutter open/closed. Its status 
is updated in the goniometer status area at the 
lower right of the screen. Pressing the T key per-
forms the same function for the incident beam 
attenuator on systems equipped with an attenu-
ator. Similarly, pressing the L key will toggle the 
state of the laser, on systems equipped with a 
laser.

Pressing the A key displays the Collect > Add 
input dialog. After you edit the items in this dia-
log, pressing ENTER or clicking the OK button 
begins a Collect > Add operation, during which 
the goniometer remains under control of the 
manual box. This feature is most useful in con-
junction with Collect > Add's /REALTIME real-
time display option, with or without the /RESET 
periodic redisplay option, to observe changes in 
the X-ray pattern as the goniometer angles are 
changed. If you want to terminate the acquisition 
early, use CTRL+BREAK, which returns you to 
manual mode (as will the ESC key or Cancel 
button pressed while in the ADD input panel). 
(See Collect > Add, Section 5.47).

Pressing the C key displays the RATEMETER 
input panel. If you supply values for the items in 
this panel, pressing the ENTER key or left 
mouse button begins a RATEMETER operation, 
during which the goniometer remains under 
control of the manual box. This is most useful 
during instrument alignment, with or without the 
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/RESET option, to observe changes in the x-ray 
pattern in real-time as the goniometer angles 
are changed. If you want to terminate the RATE-
METER early, use the CTRL-BREAK key combi-
nation, which returns you to manual mode (as 
will the ESC key or right mouse button pressed 
while in the RATEMETER input panel).

While you're controlling the goniometer manu-
ally, the setting angles displayed in the goniome-
ter status area on the lower right of the screen 
are not updated in real time. However, if you 
press the ENTER on Phoenix controller’s or 
AXIS PRINTOUT button on the GGCS control-
ler’s manual control box, the values on the 
screen will be updated to reflect the current 
angles (VIDEO will also be updated with new 
zoom and XYZ values). On the Phoenix control-
ler, you can also press the ACVAL key to display 
the current angles on the manual control box’s 
LCD. The display is also updated automatically 
when you exit manual mode.

To operate the manual control box on the Phoe-
nix controller (D8-Discover systems), press 
SHIFT-F1, then select the requested axis by 
pressing 1 for 2θ, 2 for ω, 3 for ø, 4 for χ, 5 for X, 
6 for Y, 7 for Z, 8 for Aux1. Select drive speed by 
pressing + for fast or – for slow. To drive the axis, 
press and hold the down arrow for reverse or up 
arrow for forward. Release the arrow to stop the 
drive.

NOTE: The D8 controller will drive for 120° and 
stop; this is normal. To display axes angles and 
positions, press the ACVAL (actual values) but-
ton.

NOTE: If angles are dashes, you need to initial-
ize the drive with a home command.

To operate the manual control box on the GGCS 
controller (Platform and earlier systems), select 
the requested axis by pressing the button. If a 
non-controllable axis is selected, then the mes-
sage appears:

Bad button combination.

The buttons are labeled A, B, C, and D (also 
labeled: φ, χ, 2θ, and ω). Multiple button presses 
are required to control the additional axes: A+B 
for X, A+C for Y, A+D for Z, and C+D for Aux1.

To drive the selected axis, press and hold the 
fast forward, slow forward, fast reverse, or slow 
reverse button. To stop the drive, release the 
drive button.

NOTE: On R:1/4-circle platform goniometers, 
the chi axis will drive in the opposite direction, 
that is the forward buttons will drive chi in the 
reverse direction.
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While the Collect > Goniometer > Manual dialog 
allows you to modify the base goniometer 
angles used for optical alignment, they are not 
actually used in the course of this command. 
(See Collect > Goniometer > Optical, Section 
5.12 for more information about the base 
angles).

5.11.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(Base 2-Theta)     [varies]

$1 ..........................(Base Theta1)     [varies]

Enter the “home” 2θ or θ1 value in degrees 
for optical alignment. On most goniometers, 
this is the swing angle to which the goniom-
eter is driven to begin optical alignment. On 
θ-θ systems, this is the generator tube axis. 
Default is current setting. Typically, this 
value is 0° or -60°, which will drive the 
detector to an out-of-the-way position.

$2 ..........................(Base Omega)     [varies]

$2 ..........................(Base Theta2)     [varies]

Enter the “home” omega or θ2 value in 
degrees for optical alignment. Default is cur-
rent setting. On most goniometers, the 
microscope is mounted to the goniometer 
base at a fixed angle from the collimator. On 
D8-Discover system, this angle is user set-
table. On Platform systems, this was -30° 

(use 330°). On Aztalan systems this was -
90° (use 270°). On 4-circle goniometers, the 
microscope is mounted to the circle and one 
uses 0° or 330° for these systems, but if the 
LT device is attached, 345° is recommended 
(to avoid glassware breakage).

$3 ......................... (Base Phi)     [varies]

Enter the “home” phi value in degrees for 
optical alignment. Default is current setting. 
Typically, one uses 0° or for 4-circle sys-
tems, 30°.

$4 ......................... (Base Chi)     [varies]

Enter the “home” chi value in degrees for optical 
alignment. Default is current setting. Typically, 
one uses the fixed chi value of 54.74° (45° on 
Aztalan) or for T:1/4-circle systems, -54.74°; for 
R:1/4-circle systems, 54.74; or for 4-circle sys-
tems, 330°.

$5……………(2T/OM/PH/CH Fast:Slow Ratio)     
[14]

Enter the slew speed to slow speed ratio for 
manual control box. Default is 14. The man-
ual control box allows driving at two speeds. 
The fast speed for each axis corresponds to 
the speed set in Collect > Goniometer > 
Speeds. The slow speed will be that of the 
fast speed divided by this number. The ratio 
used is the same for each axis. This param-
eter has no effect on Phoenix controllers 
(D8 Discovery systems) which has a fixed 
slow speed.
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$6 ..........................(X/Y Fast:Slow Speed Ratio)    
[14]

Enter the slew speed to slow speed ratio for 
manual control box. Default is 14. This 
parameter has no effect on Phoenix control-
lers (D8 Discovery systems) which has a 
fixed slow speed.

$7 ..........................(Z Fast:Slow Speed Ratio)     
[14]

Enter the slew speed to slow speed ratio for 
manual control box. Default is 14. This 
parameter has no effect on Phoenix control-
lers (D8 Discovery systems) which has a 
fixed slow speed.

$8 ..........................(Aux Fast:Slow Speed Ratio)    
[14]

Enter the slew speed to slow speed ratio for 
manual control box. Default is 14. This 
parameter has no effect on Phoenix control-
lers (D8 Discovery systems) which has a 
fixed slow speed.

5.12 Collect > Goniometer > Optical • 
Perform/check optical centering of 
sample

Menu Command: Collect > Goniometer > 
Optical

Accelerator: Ctrl+Shift+O

User Level: 1

SLAM Syntax:

GONIOMETER /OPTICAL  $1  $2  $3  $4  
$5  $6  $7  $8
or 
GONIOMETER /OPTICAL  $1  $2  $3  $4  
$5

Use this command to drive the goniometer 
between a few useful pre-defined positions to 
minimize the effort required to center the sample 
crystal mounted on a goniometer head as 
viewed through the sample microscope or video 
microscope mounted on the goniometer base. 
These pre-defined positions are relative to a 
specified starting position, whose setting angles 
are referred to as the “base angles.” The pro-
gram contains suitable default values for the 
base angles for D8 3-circle, Platform 3-circle, 
older Aztalan (black) 3-circle, and 4-circle goni-
ometers; however, these base angles can also 
be modified from the input panel here, if neces-
sary. The base angles should place the phi axis 
normal to the microscope axis and one set of 
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goniometer head adjustments normal to the 
microscope axis.

It is important that the environment variable 
SAXI$ADMODEL be defined correctly for your 
goniometer type, since the alignment philosophy 
is different between D8 3-circle, Platform 3-cir-
cle, 4-circle and old 3-circle systems. You also 
need to make sure that any configuration files 
you read in correspond to the correct goniome-
ter type, since the values in the configuration file 
will be transferred to GADDS and the goniome-
ter controller on program startup. (See Edit > 
Configuration > Show Model, Section 4.5, for 
more information). 4-circle systems use settings 
at the base chi and base chi + 180 for estimating 
sample height. 3-circle systems use the base 
omega and base omega + 180.

When in the panel, pressing the ESC key or 
clicking Cancel button returns you to the main 
menu-menu. Pressing the ENTER key or click-
ing OK button initiates the optical command. 
The goniometer is said to be in “manual mode” 
when in this state. During manual mode, the 
message appears on the bottom status line:

MANUAL MODE. ESC=EXIT, 
S=SHUTTER, T=ATTENUATOR, A=ADD, 
C=COUNT, L=LASER.

The Optical command enables the manual con-
trol box for interactive control of the goniometer 
but, unlike the Collect > Goniometer > Manual 
command, it assigns a different functions to the 
ENTER button on the Phoenix’s manual control 

box and to the AXIS PRINTOUT button on the 
GGCS’s manual control box.

On the Phoenix’s manual control box, press 
SHIFT-F2, then 1 for 2θ, then press ENTER to 
drive the goniometer to the base angles. Addi-
tional presses of ENTER will drive phi by 180°. If 
you select one of the other axis buttons instead 
of 2θ, certain fixed angles are added to the base 
position, as listed in the table below. As with the 
1 (2θ). Additional presses of the ENTER button 
when in one of these other positions will drive 
phi by 180°.

On the GGCS’s manual control box, depress the 
2-THETA axis button on the manual box (all 
three others should be up), then press AXIS 
PRINTOUT to drive the goniometer to the base 
angles. Additional presses of AXIS PRINTOUT 
will drive phi 180°. If you depress one of the 
three other axis buttons instead of 2-THETA, 
certain fixed angles are added to the base posi-
tion, as listed in the following table:

As with the 2-THETA button, additional presses 
of the AXIS PRINTOUT button when in one of 
these other positions drive phi 180°.

Axis 
Button

Position
(4-Circle)

Position
(3-Circle)

2-THETA Base Position Base Position

OMEGA + 90 in phi + 90 in phi

PHI + 180 in chi + 180 in omega

CHI + 180 in chi + 
90 in phi

+ 180 in omega + 
90 in phi
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While the Collect > Goniometer > Optical dialog 
box allows you to modify the fast:slow speed 
ratio used by Collect > Goniometer > Manual, it 
is not used here. The slow speed is instead fixed 
at 30 degrees/minute. (See Collect > Goniome-
ter > Manual, Section 5.11, for more information 
about the speed ratio).

5.12.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 to $8

See Collect > Goniometer > Manual (Sec-
tion 5.11).

NOTE: This command is designed to work only 
on stages with a goniometer head.

5.13 Collect > Goniometer > Flatsam-
ple • Perform/check flat sample plane 
on XYZ stage

Menu Command: Collect > Goniometer > Flat-
sample

Accelerator: Ctrl+Shift+W

User Level: 1

SLAM Syntax:

GONIOMETER /FLATSAMPLE /X1=<n>
/Y1=<n> /Z1=<n> /X2=<n> /Y2=<n>
/Z2=<n> /X3=<n> /Y3=<n> /Z3=<n>

On systems equipped with an XYZ stage, it is 
possible to collect scans at multiple target loca-
tions. On flat samples such as wafers, one fre-
quently wishes to take scans on target positions 
laid out on a rectangular grid. Instead of manu-
ally determining the Z axis position of each tar-
get on the grid, one can pre-determine the flat 
sample plane, then lay out the target locations 
using Collect > Scan >GridTargets (see Section 
5.41) which will automatically calculate the cor-
rect Z axis value from the flat sample plane.

FLATSAMPLE works on the simple principle 
that 3 points determine a flat plane. Initially, 
these points are defaulted to form a small trian-
gle about the current goniometer position in 
XYZ. For greater accuracy, the user should 
enlarge this triangle of points.
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Next, the user will be given the option to drive to 
each point on the triangle. The program will pre-
drive to the selected point, then allow the user to 
manually drive X, Y and Z. Remember that Z is 
aligned only when the laser is positioned within 
the video cross-hairs. When all three points 
have been positioned, the flat sample plane is 
fully defined.

5.13.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

/X1.........................(X VALUE FOR POINT 1)

/Y1.........................(Y VALUE FOR POINT 1)

/Z1.........................(Z VALUE FOR POINT 1)

Enter the (X,Y,Z) coordinates for the top ver-
tex of imaginary triangle on the sample.

/X2.........................(X VALUE FOR POINT 2)

/Y2.........................(Y VALUE FOR POINT 2)

/Z2.........................(Z VALUE FOR POINT 2)

Enter the (X,Y,Z) coordinates for the second 
vertex of imaginary triangle on the sample.

/X3.........................(X VALUE FOR POINT 3)

/Y3.........................(Y VALUE FOR POINT 3)

/Z3.........................(Z VALUE FOR POINT 3)

Enter the (X,Y,Z) coordinates for the third 
vertex of imaginary triangle on the sample.
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5.14 Collect > Goniometer > Update • 
Enter observed goniometer angles

Menu Command: Collect > Goniometer > 
Update

Accelerator: none

User Level: 2

SLAM Syntax:

GONIOMETER /UPDATE  $1  $2  $3  $4  $5  
$6  $7  $8  $9
or
GONIOMETER /UPDATE  $1  $2  $3  $4

This command is used to reset the goniometer 
controller's (Phoenix’s or GGCS’s) memory to 
the correct goniometer position. That is, if the 
readings on the goniometer's angular scales are 
different from those reported by the program, 
use this command to enter the readings from 
the angular scales to the nearest 0.5°. The pro-
gram then sends these readings to the goniom-
eter controller, which very accurately maintains 
the current positions modulo 1 degree but must 
rely occasionally on this type of user input for 
the coarse absolute position.

On 4-circle, P3, style goniometers, all angles 
are entered to the nearest 0.5 degree. The pro-
gram then sends these readings to the goniom-
eter controller, which very accurately maintains 
the current positions modulo 1 degree, but must 

rely occasionally on this type of user input for 
the coarse absolute position.

On all other goniometers (for example D8, Plat-
form, or Aztalan), all angles and positions are 
entered with full fractional values. Rarely, if ever, 
does one know the exact axis setting, so typi-
cally, one performs a Collect > Goniometer > 
Home (see Section 5.25) command after updat-
ing an axis to accurately position the axis.

When invoked from the menu, or run from the 
command line without arguments, Collect > 
Goniometer > Update displays a dialog box 
where you can view/edit the arguments 
described below. Pressing the ENTER key or 
clicking the OK button updates the angles. 
Pressing ESC or clicking the Cancel button exits 
without updating the angles. On successful 
completion, the program also updates the cur-
rent goniometer angles displayed in the goniom-
eter status area at the lower right of the screen.

NOTE: To change the settings of non-controlla-
ble axes, see the Collect > Goniometer > Fixed 
axes command, Section 5.24.



Collect Routines GADDS Software Reference Manual

5 - 18 M86-E01008

5.14.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(2-Theta)     [current value]

$1 ..........................(Theta1)     [current value]

The current 2-Theta (swing) angular reading 
from the goniometer, to the nearest 0.5 
degree. On θ-θ systems, this is the Theta1, 
tube axis.

$2 ..........................(Omega)     [current value]

$2 ..........................(Theta2)     [current value]

The current omega angular reading from the 
goniometer, to the nearest 0.5 degree. On 
θ-θ systems, this is the Theta2, detector 
axis.

$3 ..........................(Phi)     [current value]

The current phi angular reading from the 
goniometer, to the nearest 0.5 degree 

$4 ..........................(Chi)     [current value]

The current chi angular reading from the 
goniometer, to the nearest 0.5 degree (leave 
this field alone if you're connected to a 4-cir-
cle goniometer).

$5 ..........................(X)     [current value]

The current X positional reading from the 
goniometer, to the nearest 0.5 mm. 

$6 ......................... (Y)     [current value]

The current Y positional reading from the 
goniometer, to the nearest 0.5 mm 

$7 ......................... (Z)     [current value]

The current Z positional reading from the 
goniometer, to the nearest 0.5 mm 

$8 ......................... (Aux1)     [current value]

The current AUX angular/positional reading 
from the goniometer, to the nearest 0.5 
degree/mm. 

$9 ......................... (Aux1)     [current value]

The current delta position reading from the 
goniometer. This is only available on sys-
tems with a motorized delta axis.
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5.15 Collect > Goniometer > Limits • 
Enter software collision limits

Menu Command: Collect > Goniometer > Limits

Accelerator: none

User Level: 2

SLAM Syntax:

GONIOMETER /LIMITS $1 $2  $3  $4  $5  
$6  $7  $8  $9  $0
or 
GONIOMETER /LIMITS $1 $2  $3  $4  $5  
$6  $7  $8  $9  $0  /XMAX=<n>  /XMIN=<n>  
/YMAX=<n>  /YMIN=<n>  /ZMAX=<n>
/ZMIN=<n>  /AMAX=<n>  /AMIN=<n>
/DMIN=<n> /DMAX=<n>

This command is used to specify the software 
collision limits for the goniometer axes. They are 
particularly useful if special devices (for exam-
ple, a He beam path) are being used or the 
detector distance has been changed from the 
factory default and you do not wish to use the 
preprogrammed defaults.

When invoked from the menu, or run from the 
command line without arguments, this com-
mand displays a dialog box where you can view/
edit the arguments described below. Pressing 
the ENTER key or clicking the OK button stores 
the limits you’ve entered. Pressing ESC or click-
ing the Cancel button exits without modifying the 
limits.

Ensure that the environment variable 
SAXI$ADMODEL is defined correctly for your 
goniometer type, since the default limits are dif-
ferent between 4- and 3-circle systems. Also, 
ensure that any configuration files you read in 
correspond to the correct goniometer type, 
since the limits in the file will be transferred to 
both the GADDS program and the goniometer 
controller program.

On three-axis systems, you might see the mes-
sage: “Warning: Possible omega cable wrap 
issue when both omega and omega-2theta lim-
its are not used. Recommend using omega-
2theta limits of -269 to 89.”

Also, you cannot enter a limit range equal to or 
exceeding 360 degrees. Obviously if you have 
360 degrees of unrestricted movement, then 
you have unlimited movement and you should 
enter 0.0, 0.0 for both limits.

Finally, whenever the detector distance setting is 
changed (see Edit > Configure > User settings, 
Section 4.1), the program will asked:

Reset to default collision limits for new dis-
tance? [yes] [No].

Answer yes and GADDS will read the ASCII file, 
GADDS$SYSTEM:limits.d for new collision lim-
its based on the goniometer type, stage, video 
option, and detector distance for the 2θ, ω, and 
ω-2θ (or θ1, θ2, and θ1+θ2) limits. Your GADDS 
administrator may wish to edit this file for your 
particular system.
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5.15.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt and 
default values in degrees. (Note that a positive 
limit is a limit on drives which proceed in the 
positive direction. A negative limit limits drives in 
the negative direction. If both the positive and 
negative limit for any angle or axis are zero, the 
program considers its motion unlimited).

Table 5.1 – D8 DISCOVER Goniometers

Defaults

Parameter Input Prompt D8 θ−θ D8

$1 Positive 2-Theta limit

Positive Theta1 limit 80.00

90.00

$2 Negative 2-Theta limit

Negative Theta1 limit -10.00

-90.00

$3 Positive Omega limit

Positive Theta2 limit 80.00

180.00

$4 Negative Omega limit

Negative Theta2 limit -10.00

-180.00

$5 Positive Omega – 2-Theta limit

Positive Theta1 + Theta2 limit 0.00

60.00

$6 Negative Omega - 2-Theta limit

Negative Theta1 + Theta2 limit 0.00

-240.00

$7 Positive Phi limit (both 0=none) 0.00 0.00

$8 Negative Phi limit (both 0=none) 0.00 0.00

$9 Positive Chi limit (both 0=none) 0.00 0.00

$0 Negative Chi limit (both 0=none) 0.00 0.00
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Table 5.2 – PLATFORM Goniometers

*First number is for transmission mounting, second is 
for reflection mounting of ¼-circle stage.

Defaults

Parameter Input Prompt Platform ¼-Circle

$1 Positive 2-Theta limit 90.00 90.00

$2 Negative 2-Theta limit -90.00 -90.00

$3 Positive Omega limit 180.00 180.00

$4 Negative Omega limit -180.00 -180.00

$5 Positive Omega - 2-Theta limit 60.00 40.00

$6 Negative Omega - 2-Theta limit -240.00 -40.00

$7 Positive Phi limit (both 0=none) 0.00 0.00

$8 Negative Phi limit (both 0=none) 0.00 0.00

$9 Positive Chi limit (both 0=none) 0.00 0.12 / 90.12  *

$0 Negative Chi limit (both 0=none) 0.00 -90.12 / -0.12  *
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Table 5.3 – Other Older Goniometers

Second numbers are for LT attachment in co-axial 
mode. Third for LT in 30° offset mode.

Defaults

Parameter Input Prompt 4-Circle 3-Circle

$1 Positive 2-Theta limit 110.00 30.00

$2 Negative 2-Theta limit -110.00 -85.00

$3 Positive Omega limit 58.00 / 45.00 180.00

$4 Negative Omega limit -58.00 / -55.00 -180.00

$5 Positive Omega – 2-Theta limit 58.00 60.00

$6 Negative Omega – 2-Theta limit -58.00 -240.00

$7 Positive Phi limit (both 0=none) 0.00 0.00

$8 Negative Phi limit (both 0=none) 0.00 0.00

$9 Positive Chi limit (both 0=none) 0.00 / 40.00 / 93.00 0.00

$0 Negative Chi limit (both 0=none) 0.00 / -90.00 / -93.00 0.00
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Table 5.4 – All Goniometers with X, Y, Z, or Aux axes

Second numbers are for D8 Discovery systems (Phoe-
nix controllers).

Parameter Input Prompt Defaults

/XMAX=<n> Positive X limit (both 0=none) 90.00

/XMIN=<n> Negative X limit (both 0=none) -90.00

/YMAX=<n> Positive Y limit (both 0=none) 90.00

/YMIN=<n> Negative Y limit (both 0=none) -90.00

/ZMAX=<n> Positive Z limit (both 0=none) 90.00

/ZMIN=<n> Negative Z limit (both 0=none) -90.00

/AMAX=<n> Positive Aux1 limit (both 0=none) 7.00 / 7.02

/AMIN=<n> Negative Aux1 limit (both 0=none) 1.00 / 0.98

/DMAX=<n> Maximum Delta limit (both 0=none) 30.0

/DMIN=<n> Minimum Delta limit (both 0=none) 6.0
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5.16 Collect > Goniometer > Extlimits 
• Display extended software collision 
limits

Menu Command: Collect > Goniometer > 
Extlimits

Accelerator: none

User Level: 2

SLAM Syntax: GONIOMETER /EXTLIMITS

This command is used to graphically draw the 
extended software collision limits between the 
omega and chi axes. Mainly used for the 1/4-cir-
cle stage where when chi is at -90 degrees, 
omega is restricted such that the stage will not 
drive into the collimator.

GADDS$SYSTEM:limits_4.*  P3 systems

GADDS$SYSTEM:limits_r.*   Reflection 
1/4-circle

GADDS$SYSTEM:limits_t.*   Transmission 
1/4-circle

The extended map limits are read from the vari-
ous files depending upon which goniometer 
model is active. To change the limits, you must 
manually edit this file. Some important consider-
ations are:

• The first and last points must be identical (to 
form a closed loop).

• Omega ranges of -180 to +180 degrees are 
special case -> no limit.

• Valid drive range is INSIDE the graphed 
region.

• These extended limits are used in addition 
to normal limits.

Any system without a controllable chi circle is 
unaffected by the extended limits command.

It is important that the environment variable 
SAXI$ADMODEL is defined correctly for your 
goniometer type, since the default limits are dif-
ferent between 4-circle and 1/4-circle systems. 
See Edit > Configure > ShowModel, Section 4.5, 
for more information.

5.16.1 Arguments

None. Command executes immediately.



GADDS Software Reference Manual Collect Routines

M86-E01008 5 - 25

5.17 Collect > Goniometer > Speeds • 
Enter slew drive speeds of axes

Menu Command: Collect > Goniometer > 
Speeds

Accelerator: none

User Level: 2

SLAM Syntax:

GONIOMETER /SPEEDS  $1  $2  $3  $4  
$5  $6  $7  $8  $9

or GONIOMETER /SPEEDS  $1  $2  $3

or GONIOMETER /SPEEDS  $1  $2

This command is used to set the maximum drive 
speeds for the goniometer axes. These speeds 
are also used as the “fast” drive speeds in man-
ual mode (see Collect > Goniometer > Manual, 
Section 5.11). 

When invoked from the menu, or run from the 
command line without arguments, Collect > 
Goniometer > Speeds displays a dialog box 
where you can view/edit the arguments 
described below. Pressing the ENTER key or 
clicking the OK button updates the drive speeds. 
Pressing ESC or clicking the Cancel button exits 
without changing the speeds.

Ensure that the environment variable 
SAXI$ADMODEL is defined correctly for your 
goniometer type, since the speed conventions 
are different among Platform, 4-circle, and older 

Aztalan (black) 3-circle systems. Also ensure 
that any configuration files you read in corre-
spond to the correct goniometer type, since the 
values in the file will be transferred to GADDS 
and the goniometer controller program. See 
Edit > Configure > Show model, Section 4.5, for 
more details.

5.17.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses. The conventions are different for 
Platform 3-circle, 4-circle, and older Aztalan 
3-circle systems and are listed separately with 
all values in degrees/minute or mm/minute, 
except for delta that is in cm/min.
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Table 5.5 – D8 DISCOVER Multi-Axes Systems

NOTE: On PHOENIX controllers, the maximum 
allowable speeds are read from the DEVICE.INI 
configuration file.

Table 5.6 – PLATFORM (beige) Multi-Axes Systems

Table 5.7 – PLATFORM (beige) 3-Circle Systems

Parameter Dialog Box 
Prompt

Default Maximum 
Allowable

$1 (2-THETA 
SPEED)

600.00 1000.00

or $1 (THETA1 
SPEED)

600.00 1000.00

$2 (OMEGA 
SPEED)

600.00 1000.00

or $2 (THETA2 
SPEED)

600.00 1000.00

$3 (PHI SPEED) 3600.00 3600.00

$4 (CHI SPEED) 600.0 600.0

$5 (X SPEED) 150.0 1600.0

$6 (Y SPEED) 150.0 1600.0

$7 (Z SPEED) 150.0 1600.0

$8 (AUX SPEED) 50.0 300.0

$9 (DELTA 
SPEED)

100.0 1000.0

Parameter Dialog Box 
Prompt

Default Maximum 
Allowable

$1 (2-THETA 
SPEED)

600.00 1000.00

$2 (OMEGA 
SPEED)

600.00 1000.00

$3 (PHI SPEED) 3600.00 3600.00

$4 (CHI SPEED) 600.0 600.0

$5 (X SPEED) 150.0 1600.0

$6 (Y SPEED) 150.0 1600.0

$7 (Z SPEED) 150.0 1600.0

$8 (AUX SPEED) 50.0 300.0

Parameter Dialog Box 
Prompt

Default Maximum 
Allowable

$1 (2-THETA 
SPEED)

1000.00 1000.00

$2 (OMEGA 
SPEED)

1000.00 1000.00

$3 (PHI SPEED) 3600.00 3600.00
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Table 5.8 – 4-Circle Systems

Table 5.9 – Older Aztalan (black) 3-Circle Systems

Although the software’s valid range for speeds is 
up to the “Maximum Allowable” values (specified 
above), increasing the slew speeds to above 
what the goniometer can handle, will result in 
lost axis position. Heavy stages, or samples, will 
result in a slower, reliable slew speed for the 
omega axis. If you increase the speeds above 
the default, please test the drives for reliability.

Parameter Dialog Box 
Prompt

Default Maximum 
Allowable

$1 (2-THETA, 
OMEGA 
SPEED)

234.375 600.00

$2 (PHI, CHI 
SPEED)

600.00 600.00

Parameter Dialog Box 
Prompt

Default Maximum 
Allowable

$1 (2-THETA 
SPEED)

150.00 150.00

$2 (OMEGA, PHI 
SPEED)

600.00 600.00
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5.18 Collect > Goniometer > Zero • 
Drive all angles to home position 
(zero degrees)

Menu Command: Collect > Goniometer > Zero

Accelerator: Ctrl+Shift+Z

User Level: 1

SLAM Syntax: GONIOMETER /ZERO 

Use this command to quickly drive the goniome-
ter to the “zero” position. The zero position is 
defined as either:

• All angles to zero degrees (non-XYZ sys-
tems)

• XYZ angles to zero degrees

• All angles to zero degrees, except omega to 
180 (omega restricted by collision from 0)

When invoked from the menu, this command 
displays one of the following prompts in a Yes/
No message box:

DRIVE ALL AXES TO ZERO: ARE YOU 
SURE?

DRIVE XYZ STAGE TO ZERO: ARE YOU 
SURE?

DRIVE ALL AXES TO ZERO & OMEGA to 
180: ARE YOU SURE?

Pressing the Y key, ENTER key, or clicking the 
Yes button will drive all the goniometer axes to 
their zero position. Pressing N, the ESC, or the 

No button will return you to the menu without 
driving the axes.

In command line mode, the action is the same, 
except that the program does not prompt before 
driving the axes to zero.

5.18.1 Arguments

None. Command executes immediately after 
confirmation prompt.
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5.19 Collect > Goniometer > 
Attenuator • Insert/remove 
attenuator

Menu Command: Collect > Goniometer > 
Attenuator

Accelerator: Ctrl+Shift+N

User Level: 1

SLAM Syntax: GONIOMETER /ATTENUATOR

When invoked from the menu, or run from the 
command line, Collect > Goniometer > Attenua-
tor immediately toggles the status of the hard-
ware beam attenuator on those systems 
equipped with an attenuator. If the attenuator is 
currently not inserted, the program opens the 
shutter (if not already open) and inserts the 
attenuator. If the attenuator is inserted, the pro-
gram removes the attenuator from the beam 
(and must briefly close the shutter to do so). The 
SHUTTER item in the goniometer status area at 
the lower right of the display is updated to reflect 
the new attenuator status.

5.19.1 Arguments

None. Command executes immediately.

5.20 Collect > Goniometer > Shutter • 
Open/close x-ray shutter

Menu Command:

Collect > Goniometer > Shutter

or Collect > Shutter

Accelerator: Ctrl+Shift+S

User Level: 1

SLAM Syntax:

GONIOMETER /SHUTTER

or SHUTTER

When invoked from the menu, or run from the 
SLAM command line, Collect > Goniometer > 
Shutter toggles the status of the X-ray shutter 
(that is, if the shutter is currently closed, the pro-
gram opens it and, if it is open, the program 
closes it). The action is performed immediately, 
with no prompt for additional input. The SHUT-
TER item in the goniometer status area at the 
lower right of the display is updated to reflect the 
new shutter status.

GADDS supports an optional high-precision 
rotary shutter. This shutter is intended for use 
with rotating anodes and synchrotron sources. 
The normal Bruker shutter on sealed tube sys-
tems is perfectly adequate for acquiring high-
quality data as is. However, in the case where 
the high-precision shutter is added to a sealed 
tube system with existing shutter, GADDS con-



Collect Routines GADDS Software Reference Manual

5 - 30 M86-E01008

trols both shutters. When shutter open/close 
commands are issued from GADDS, both shut-
ters are operated, except in the cases of Collect 
> Add, Collect > Scan > commands (SingleRun, 
MultiRun, Rotation, etc.), Process > Flood > 
New, Process > Spatial > New. In these cases, 
the safety (old) shutter is pre-opened at the start 
of the command and is closed when the com-
mand has been completed. Operations per-
formed between these two events (for example, 
collection of a frame series) open and close only 
the high-precision shutter.

5.20.1 Arguments

None. Command executes immediately.

5.21 Collect > Goniometer > Laser • 
Turn on/off the laser

Menu Command: Collect > Goniometer > Laser

Accelerator: Ctrl+Shift+L

User Level: 1

SLAM Syntax: GONIOMETER /LASER

When invoked with the LASER option from the 
master menu or when run from the command 
line GONIOMETER /LASER immediately tog-
gles the status of the hardware laser beam, on 
those systems equipped with a laser.

5.21.1 Arguments

None. Command executes immediately.
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5.22 Collect > Goniometer > 
Generator • Control the high voltage 
generator: kv and ma settings

Menu Command: Collect > Goniometer > 
Generator

Accelerator: Ctrl+Shift+G

User Level: 1

SLAM Syntax: GONIOMETER 
/GENERATOR  $1  $2  /WAIT

When invoked from the menu or when run from 
the command line without arguments, Collect > 
Goniometer > Generator displays a dialog box 
where you can view/edit the desired generator 
settings. The values in the dialog default to the 
current generator settings. When in the panel, 
pressing the ENTER key or clicking the OK but-
ton sends the entered generator settings to the 
Bruker K710D generator. Pressing ESC or click-
ing the Cancel button in the dialog returns you to 
the menu without changing the generator set-
tings. The new generator settings are displayed 
in the goniometer status window.

5.22.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (kV)     [current setting or 0]

Enter the desired kV setting for the X-ray 
generator.

$2 ......................... (mA)     [current setting or 0]

Enter the desired mA setting for the X-ray 
generator.

WAIT .................... (Wait Y/N)     [No]

Check this option to wait for the generator to 
reach the desired settings, or leave it 
unchecked to return to the GADDS menu 
immediately after sending the new settings 
to the generator.
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5.23 Collect > Goniometer > Det. 
Stage • Drive delta axis

Menu Command: Collect > Goniometer > Det. 
Stage

Accelerator: none

User Level: 3

SLAM Syntax: GONIOMETER /DETECTOR $1

Use this command to operate the delta axis 
(detector distance) on systems with a motorized 
delta axis. Only Phoenix controllers support a 
delta axis. The minimum and maximum values 
are taken from the current software collision limit 
settings (see Collect > Goniometer > Limits, 
Section 5.15).

5.23.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(Delta)     [current setting]

Enter the destination delta axis (detector 
distance) in cm.

5.24 Collect > Goniometer > Fixed 
axes • Set reported settings for non-
controllable axes

Menu Command: Collect > Goniometer > Fixed 
axes

Accelerator: none

User Level: 2

SLAM Syntax: GONIOMETER /FIXEDAXES  
$1  $2  $3  $4  $5  $6  $7  $8

Use this command to defined the current 
angles/positions of the fixed, non-controllable 
axes. Collect > Goniometer > Fixedaxes dis-
plays an input panel where you can view/modify 
the desired destination angles. The values in the 
input panel default to the current goniometer 
position. When in the panel, pressing the 
ENTER key or left mouse button, the program 
updates the current goniometer angles dis-
played in the goniometer status area at the 
lower right of the screen.

NOTE: To change the settings of controllable 
axes, see the Collect > Goniometer > Update 
command, Section 5.14.
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5.24.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(2-Theta)     [current setting]

$1 ..........................(THETA1)    [current setting]

The destination 2-Theta (swing) angle in 
degrees. Or theta1 (tube) axis.

$2 ..........................(Omega)     [current setting]

$2 ..........................(THETA2)[current setting]

The destination Omega angle in degrees. 
Or theta2 (detector) axis.

$3 ..........................(Phi)     [current setting]

The destination Phi angle in degrees.

$4 ..........................(Chi)     [current setting]

The destination Chi angle in degrees.

$5 ..........................(X)     [current setting]

The destination X position in mm.

$6 ..........................(Y)     [current setting]

The destination Y position in mm.

$7 ..........................(Z)     [current setting]

The destination Z position in mm.

$8 ..........................(Aux1)     [current setting]

The destination AUX position in aux units.



Collect Routines GADDS Software Reference Manual

5 - 34 M86-E01008

5.25 Collect > Goniometer > Home 
axis • Home goniometer axis

Menu Command: Collect > Goniometer > 
Home axis

Accelerator: none

User Level: 2

SLAM Syntax: GONIOMETER /HOME  $1  $2

When a goniometer controller is first powered 
up or power-cycled, the setting angle positions 
may be different from those reported by the con-
troller. While the Collect > Goniometer > Update 
command allows you to make sure the reported 
angles agree with those you read from the angu-
lar scales on the goniometer, it's difficult to tell if 
the reported position is off by a small amount. 
Collect > Goniometer > Home Axis allows a 
specified axis to be driven to an internal fiducial 
mark and its position to be updated so that the 
reported position is exactly consistent from 
power-up to power-up. In the case of a Platform 
goniometer, absolute fiducial marks are avail-
able (typically at +30.00° in 2-theta and -30.00° 
in omega), and the axis will seek the fiducial 
mark when homed. (Some systems, such as 
micro-diffraction systems have a modified 2-
theta fiducial position.) In the case of a P4, the 
axis seeks the degree mark nearest its current 
location.

When invoked from the menu, or run from the 
command line without arguments, Collect > 
Goniometer > Home Axis displays a dialog box 

where you can view/edit the input arguments. 
Pressing the ENTER key or clicking the OK but-
ton initiates the “homing” of the requested axis. 
The goniometer 2-theta or omega axis is driven 
to within 3° of the home position and a 6-degree 
search for the home mark is initiated. Phi and 
chi axes have a home mark every degree.

During the drive, the following message dis-
plays:

DRIVING — PRESS ANY KEY TO STOP...

You can halt the drive by pressing a keyboard 
key (for example, ENTER or the space bar). 
Pressing ESC or clicking Cancel in the input dia-
log returns you to the menu without performing 
the homing operation. On completion of homing, 
the program updates the current goniometer 
angles displayed in the goniometer status area 
at the lower right of the screen.

Aborting homing in the middle of a drive may 
result in loss of the current angle position. 
Should you abort homing, you MUST update the 
current angle and re-home the axis.
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5.25.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Axis Number)     [1]

This is the number of the axis to be homed, 
either 1 for 2-theta/theta1, 2 for omega/
theta2, 3 for phi, 4 for chi axis, 5 for X, 6 for 
Y, 7 for Z, 8 for zoom, 9 for delta (detector 
distance).

$2 ..........................(Velocity)     [250]

Velocity to drive during home search in 
steps/degree. Range 1 to 1024. On D8 sys-
tems, this parameter is ignored.

5.26 Collect > Goniometer > Park 
XYZ • Park large XYZ stage (OM=0, 
X=far right, Z=back)

Menu Command: Collect > Goniometer > 
Park XYZ

Accelerator: none

User Level: 1

SLAM Syntax: GONIOMETER /PARK

Use this command to park the XYZ stage in an 
out of the way position. When invoked with the 
PARK option from the GONIOMETER submenu 
GONIOMETER /PARK displays the following 
prompt on the bottom status line:

PARK XYZ STAGE: ARE YOU SURE?

Pressing the Y key, ENTER key, or left mouse 
button will drive the XYZ stage to the “PARK” or 
lock-down position. First, the Z-axis is driven 
back to the current negative Z collision limit (see 
GONIOMETER /LIMITS). Then, both omega 
and X are driven to 0.0 and far right limit, 
respectively. The user can then lock down the 
large XYZ stage by turning the lock screw.

Pressing N, the ESC key, or right mouse button 
will return you to the GONIOMETER submenu 
without driving the axes.

In command line mode, the action is the same, 
except that the program does not prompt before 
driving the axes to “park.”
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5.26.1 Arguments

None. Command executes immediately after 
confirmation prompt.

5.27 Collect > Goniometer > XYZ 
collision • Avoid XYZ stage collision 
with detector

Menu Command: Collect > Goniometer > XYZ 
collision

Accelerator: none

User Level: 2

SLAM Syntax: GONIOMETER /XYZ  $1  $2  $3  
$4

Use this command to define the corners of the 
detector and XYZ stage to avoid collisions 
between the two units when attempting a drive 
operation.

When invoked with the XYZ option from the 
GONIOMETER submenu or when run from the 
command line without arguments, GONIOME-
TER /XYZ displays an input panel where you 
can view/modify the desired settings.

5.27.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ......................... (Detector Distance)     
[current distance in mm]

The detector distance, in mm., is measured 
from the center of the goniometer to the 
physical face of the detector. It is the same 
detector distance which is entered in CON-
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FIGURE /EDIT menu, except in mm, not 
cm. This value defaults to the current detec-
tor distance.

$2 ..........................(Detector Half-Width)     
[115 mm]

The detector half-width, in mm., is mea-
sured from the center of the 2-theta arm to 
the edge of the detector housing.

$3 ..........................(XYZ Stage/Sample Half-
Width)     [76 mm]

The sample half-width is measured from 
center of the XYZ stage to the edge of the 
sample which can approach the detector 
face. This value is always entered as posi-
tive.

$4 ..........................(XYZ/Stage Depth 
Reference)     [0 mm]

The sample depth reference, is the Z offset 
which when added to the current Z axes set-
ting will give zero when the plane of the 
sample face touches the center of the goni-
ometer. This value is SIGNED.
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5.28 Collect > Goniometer > 
Temperature • Watlow Series 988 
Temperature Controller

Menu Command: Collect > Goniometer >
Temperature

Accelerator: Ctrl+Shift+T

User Level: 1

SLAM Syntax: GONIOMETER /TEMP  $1  
/RAMP=<n>  /HOLD=<n>  /WAIT

Operate a temperature controller using the sec-
ondary COM port, which defaults to COM2:, but 
can be specified with the command line argu-
ment: /TCPORT=#, where # is the com port 
number (1–4). Currently supported temperature 
controllers are:

• Watlow Series 988

• AntonPAAR KHR

• EuroTherm 800 series

• EuroTherm 905

• DHS-900/DCS-350 (Eurotherm 2600/2700)

Connection to the TC is only established upon 
entering the GONIOMETER /TEMP command 
and is always disconnected upon exiting this 
command. This permits a more elaborate TC 
control program to be run from either the SYS-
TEM command or as a separate and indepen-
dent program task; however, the GONIMOETER 
/TEMP command will not function if the TC port 

is already in use or allocated by another pro-
gram. You must terminate any TC control pro-
gram before executing the GONIOMETER /
TEMP command.

All temperature parameters are stored in subse-
quently created frame headers. You may over-
ride waiting for the either the ramp up to 
temperature, the hold time, or both with either 
the <Enter> or <Lf-button> and the temperature 
parameters will still be stored in newly created 
frame headers. Interrupting with <Ctrl-Break> 
will not store the new temperature settings.

5.28.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ......................... (Set Point)     [22.0]

Enter the requested temperature in degrees 
C.

/RAMP=<n>.......... (Ramp Rate)     [100.0]

Enter requested ramping rate in degrees C 
per minute.

/HOLD=<n> .......... (Hold Time)     [0.0]

Enter hold time for stabilizing in seconds. 
Whenever this value is non-zero, the pro-
gram will pause until the temperature has 
been held at the requested set point for the 
required amount of time.
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/WAIT ....................(Wait)     [Y]

“Y” to wait for ramping up to requested tem-
perature setting. If the hold time is non-zero, 
waiting for ramping up to temperature set 
point is automatically performed.

5.29 Collect > Goniometer > 
Encoders • Adjust encoder zero 
offsets

Menu Command: Collect > Goniometer > 
Encoders

Accelerator: none

User Level: 3

SLAM Syntax:

GONIOMETER /ENCODERS  $1  $2  $3  
$4

or GONIOMETER /ENCODERS  $1  
$2  $3  $4  $5  $6  $7  $8  $9

This command allows you to access the Phoe-
nix AV or GGCS EZ command without leaving 
GADDS. Because this command changes the 
zero positions of the goniometer angles, it is rec-
ommended that only the person in charge of 
your system (for example, system manager) or 
Bruker service personnel use this command. 
This command subtracts the specified amount 
to the encoder zero of the specified axis. For 
example, entering a value of 0.05 for omega will 
add 0.05 to all subsequent observed omega val-
ues.

The refined values for the omega and chi 
encoder zeros provide a general indication 
when encoder zeros need to be adjusted, BUT 
BE VERY CAREFUL. Because of the large 
number of parameters refined in the unit cell 
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least squares and the potential for coupling 
among parameters. DON'T CHANGE 
ENCODER ZEROS BASED ON THE RESULT 
OF A SINGLE LEAST SQUARES. Over time, 
you'll get a general feeling whether your data 
sets, for example, all tend to indicate that the 
omega zero is high; make adjustments based 
on average results accumulated over time. The 
least squares zero adjustments are values that 
should be added to the angle zero, so negate 
the value determined from least squares before 
entering it here.

5.29.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

$1 ..........................(2-Theta)     [0.00]

$1 ..........................(Theta1)     [0.00]

Enter the 2-theta encoder zero offset in 
degrees to be added to subsequent 2-theta 
values reported by the controller. Or theta1 
axis (tube).

$2 ..........................(Omega)     [0.00]

$2 ..........................(Theta2)     [0.00]

Enter the omega encoder zero offset in 
degrees to be added to subsequent omega 
values reported by the controller. Or theta2 
axis (detector).

$3 ......................... (Phi)     [0.00]

Enter the phi encoder zero offset in degrees 
to be added to subsequent phi values 
reported by the controller.

$4 ......................... (Chi)     [0.00]

Enter the chi encoder zero offset in degrees 
to be added to subsequent chi values 
reported by the controller.

$5 ......................... (X)     [0.00]

Enter the X encoder zero offset in mm to be 
added to subsequent X values reported by 
the controller.

$6 ......................... (Y)     [0.00]

Enter the Y encoder zero offset in mm to be 
added to subsequent Y values reported by 
the controller.

$7 ......................... (Z)     [0.00]

Enter the Z encoder zero offset in mm to be 
added to subsequent Z values reported by 
the controller.

$8 ......................... (Aux1)     [0.00]

Enter the Aux1 encoder zero offset in units 
to be added to subsequent Aux values 
reported by the controller.
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$9 ..........................(Delta)     [0.00]

Enter the Delta encoder zero offset in cm to 
be added to subsequent Delta values 
reported by the controller.

5.30 Collect > Scan > SingleRun • 
Perform a single scan series—
Resume an interrupted SingleRun

Menu Command: Collect > Scan > SingleRun

Accelerator: Ctrl+Shft+F1

User Level: 1

SLAM Syntax:

SCAN /SINGLERUN  $1  [/2THETA=<n> |
/THETA1=<n>]  [/OMEGA=<n> |
/THETA2=<n>>]  /PHI=<n>  /CHI=<n>
/X=<n.  /Y=<n>  /Z=<n>  /AUX=<n>
/AXIS=<n>  /WIDTH=<n>
/SCANTIME=<n>  /TITLE=<s>
/SAMPLE=<s>  /NUMSAMPLE=<n>  
/NAME=<s>  /RUN=<s>
/FRAMENO=<s>  /DISPLAY=<n>
/REAL TIME  /CLEAR  /OLDXENGEN
/MODE=<n>  /ROTATE  /VIDEO
/OSCILLATE=<s> /AMPLITUDE=<n>
/AUTOZALIGN

Additional SLAM Syntax for dual detector mode:

… /SNAME=<s>  /SRUN=<n>  
/SFRAME=<s>

Collect > Scan > SingleRun allows you to collect 
a scan series comprising one or more contigu-
ous frames of data starting at specified goniom-
eter setting angles. Normally, Collect > 
SingleRun stores frames as an unwarped 
image, after applying the spatial correction 
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table. It also applies the flood-field (intensity uni-
formity) correction as the counts are received.

When you invoke the command from the menu 
(or the command line without arguments), a dia-
log box appears where you can view/edit the 
arguments described below as follows:

• press ENTER or click the OK button to start 
scanning.

• press ESC or click the Cancel button to 
return to the menu.

You can interrupt a scan as follows:

• press ESC to stop after finishing collecting 
the current frame.

• press CTRL+BREAK to interrupt the scan.

• press CTRL+S to temporarily stop after fin-
ishing collecting the current frame (press 
CTRL+Q to resume).

NOTE: Unlike the Collect > Scan > MultiRun 
command, an interrupted SingleRun scan can-
not be restarted with the Collect > Scan > 
Resume command. Instead, the SingleRun 
parameters are automatically decremented after 
each frame is saved. Thus, you can simply reis-
sue a SingleRun command to resume where it 
left off. Also, Collect > Scan > SingleRun does 
not precheck the scan range for potential colli-
sion the way Collect > Scan > MultiRun does. If 
you need these capabilities, use Collect > Scan 

> MultiRun (which can perform a single series if 
desired).

When you interrupt a scan with CTRL+BREAK, 
the goniometer returns to the starting scan 
angle of the current scan. This repositioning is 
performed by backing up to the starting position 
minus one frame width (or +/-0.5° maximum), 
then driving forward to the starting position. The 
same positioning technique is used when driv-
ing to the first scan in a new series, which 
makes the positioning extremely repeatable but 
does require you to allow for an extra scan width 
at the beginning of the series when you're start-
ing close to the goniometer collision limits.

The current configuration is saved in the current 
default configuration file (usually gadds._nc) 
before starting the first scan, which makes 
recovery easier in the event of a power failure, 
etc.

The filename of the first frame is generated from 
the Job Name, Run# and Starting Frame# 
(listed below) as defined in Edit > Configure > 
User settings: Frame Naming Parameters (see 
Section 4.1.1).

Because, one typically starts a scan and walks 
away from the instrument, GADDS will pre-
check that the available disk space is sufficient 
for storing the requested number of frames in 8-
bit mode. However, if the frames are stored in 
16-bit mode, you may still run out of disk space 
during the requested scan operation.
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The CPU intensive VIDEO program is always 
set to frozen mode at the start of all scan com-
mands.

5.30.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses.

$1 ..........................(# rames)     [1]

The number of frames to be acquired in this 
series. Ensure that the generated filename 
of the last frame in the series is a valid file-
name with regard to the frame naming 
parameters in the Edit > Configure > User 
settings dialog.

/2THETA=<n> .......(2-Theta)     [0.00]

/THETA1=<n> .......(Theta1)     [0.00]

The detector swing angle (goniometer 2-
theta setting angle), in degrees, at which 
GADDS positions the goniometer at the 
start of the frame series. Valid values are -
180° to 180°, but are typically reduced by 
the current software collision limits as 
defined in Collect > Goniometer > limits 
command. Entering “@” will be automati-
cally replaced with current angle setting. On 
θ-θ systems, this is the θ1 angle (tube).

/OMEGA=<n>....... (Omega)     [0.00]

/THETA2=<n>....... (Theta2)     [0.00]

The omega angle, in degrees, at which 
GADDS positions the goniometer at the 
start of the frame series scans. If you spec-
ify a scan axis (see /AXIS=<n> below) of 2, 
omega will be scanned as each frame is 
taken. Otherwise, omega remains fixed 
throughout the frame series. Valid values 
are -360° to 360°, but are typically reduced 
by the current software collision limits as 
defined in Collect > Goniometer > limits 
command. Entering “@” will be automati-
cally replaced with current angle setting. On 
θ-θ systems, this is the θ2 angle (detector).

/PHI=<n>.............. (Phi)     [0.00]

The phi angle, in degrees, at which GADDS 
positions the goniometer at the start of the 
frame series scans. If you specify a scan 
axis (see /AXIS=<n> below) of 3, phi will be 
scanned as each frame is taken. Otherwise, 
phi remains fixed throughout the frame 
series. Valid values are -360° to 360°, but 
are typically reduced by the current software 
collision limits as defined in Collect > Goni-
ometer > limits command. Entering “@” will 
be automatically replaced with current angle 
setting.
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/CHI=<n>...............(Chi)     [0.00]

The chi angle, in degrees, at which GADDS 
positions the goniometer at the start of the 
frame series. A Platform goniometer is fixed 
at CHI=54.74°. An older Aztalan (black) 3-
circle goniometer is fixed at CHI=45°. Valid 
values are -360° to 360°, but are typically 
reduced by the current software collision 
limits as defined in Collect > Goniometer > 
limits command. Entering “@” will be auto-
matically replaced with current angle set-
ting.

/X=<n> ..................(X)     [0.00]

The X-axis position, in mm, at which 
GADDS positions the goniometer at the 
start of the frame series. Entering “@” will 
be automatically replaced with current axis 
position setting.

/Y=<n> ..................(Y)     [0.00]

The Y-axis position, in mm, at which 
GADDS positions the goniometer at the 
start of the frame series. Entering “@” will 
be automatically replaced with current axis 
position setting.

/Z=<n>...................(Z)     [0.00]

The Z-axis position, in mm, at which 
GADDS positions the goniometer at the 
start of the frame series. Entering “@” will 
be automatically replaced with current axis 
position setting.

/AUX=<n>............. (Aux)     [1.00]

The Aux1 axis position, in units, at which 
GADDS positions the goniometer at the 
start of the frame series. Entering “@” will 
be automatically replaced with current set-
ting. Typically, this axis is used for the video 
zoom lens and is entered as a magnification 
factor in the range 1.0 to 7.0.

/AXIS=<n>............ (Scan Axis #)     [2]

The number of the axis to be scanned, as 
follows: 2 for omega scans, 3 for phi scans, 
4 for chi, 5 for X, 6 for Y, or 7 for Z, N=None, 
C=Coupled, or T=Tube (on theta-theta sys-
tems). Note that while SAINT can reduce 
phi scans taken at any chi angle, some data 
reduction programs (XENGEN) may not be 
able to reduce phi-scan data unless it was 
taken at CHI=0. When using a restrictive 
data-reduction package, you must perform 
omega scans on both the Platform goniom-
eter and the older Aztalan (black) 3-axis.

/WIDTH=<n> ........ (Frame Width)     [-0.25]

The scan width, in degrees (either positive 
or negative), of each frame to be acquired. 
Thus, the starting scan angle for the Nth 
frame in the series (where the first frame is 
N=0) is OMEGA+N*WIDTH if the axis 
(above) is 2, or PHI+N*WIDTH if the axis 
(above) is 3 (where WIDTH, OMEGA, and 
PHI are the values given on the same line of 
the array). The intensity within a frame is 



GADDS Software Reference Manual Collect Routines

M86-E01008 5 - 45

uniformly distributed with respect to scan 
angle over the range WIDTH specified here 
(unless 3-circle frames are taken by oscilla-
tion, in which case the ends of the range 
have slightly higher weight, and there may 
be some overlap or underlap of successive 
frames; oscillation can however compen-
sate for other sources of error such as inten-
sity fluctuation due to an unstable source).

/SCANTIME=<n>…(Seconds/Frame)     
[1:00.00]

The accumulation time, in seconds, during 
which each frame is to be acquired. You can 
enter time in decimal seconds or in the for-
mat HH:MM:SS.SS (where HH represents 
hours, MM minutes, and SS.SS decimal 
seconds). Valid values are 0.05 to 32,767 
seconds. The default value is 60.

/TITLE=<s> ...........(Title)     [Scan frame]

Enter a title for the output frames (80 char-
acters maximum). The default entry is the 
sample title from the Project > New/Copy/
Edit dialog box (or “Scan Frame”). If you 
invoked this command from the command 
line, you must enclose any title containing 
blanks in double quotes.

$FILE:<filename> will read up to eight 72-
character title lines from an ASCII file and 
place these title strings into the eight 
“TITLE” lines in the frame header. The for-
mat of the ASCII file is: “R#:<single line of 

title information>”, where “R#” is the run 
number, taken from the filename. Repeat up 
to eight times for each run.

/SAMPLE=<s>...... (Sample Name)     [Corun-
dum]

Enter sample name, to be stored in frame 
header. If no name is specified, the default 
name of “Corundum” will be entered.

/NUMSAMPLE=<s>…(Sample Number)     [0]

Enter sample number, to be stored in frame 
header. The permitted range is from 0 to 
32,767, with a default setting at 0.

/NAME=<s>.......... (Job Name)     [NEWFRAM]

Enter the base filename for the output 
frames. The filenames for each series of 
output frames are generated by adding the 
series RUN# and an extension built from the 
series starting FRAME# to the end of this 
base name. For example, if the Job Name is 
LYS, the Run Number is 04, and the starting 
Frame Number is 000 (assuming that the 
number of characters in a Run Number is 
set to 2 and the number of characters in a 
Frame Number is set to 3 in the Edit > Con-
fig dialog), the data files would be named (in 
sequence) LYS04.000, LYS04.001, 
LYS04.002, and so forth. For more informa-
tion, see Section 4.1.1, Edit > Configure > 
User settings: Frame Naming Conventions. 



Collect Routines GADDS Software Reference Manual

5 - 46 M86-E01008

The default name if none is specified is 
NEWFRAM.

The Job Name can contain an NT drive and 
directory name, if desired, but you should 
use the project data directory instead. The 
output filename is merged with the project’s 
working directory defined in the Project > 
New|Copy|Edit dialog prior to creating the 
output frame. If you specify $NULL as the 
Job Name, the frames are sent to the null 
handler and discarded. (Note: $NET is NOT 
supported under GADDS, please do not 
use.)

/RUN=<s> .............(Run #)     [0]

This is the Run Number of the series. This is 
not actually a number, but is rather taken as 
RUNCHARS characters of ASCII text. Also, 
all characters must be valid characters to be 
used with filenames because the Run Num-
ber becomes part of the generated output 
filename. Basically, the Run Number is for-
matted and appended to the output base 
filename before the file extension. See 
Frame Naming Conventions, Edit > Config-
ure > User settings command, and Collect > 
Scan > MultiRun command for more details.

/FRAMENO=<s>…(Frame #)     [000]

This is the starting frame number for the 
series. Like the Run Number, this is actually 
taken as text of length NUMCHARS rather 
than as a numeric value. The text specified 

here will be used as the extension of the first 
output frame in the series and will be incre-
mented according to the frame naming 
parameters to form the extensions of subse-
quent frames. See Frame Naming Conven-
tions, Edit > Configure > User settings 
command, and Collect > Scan > MultiRun 
command for more details. 

/DISPLAY=<n> ..... (Max Display Counts)     [31]

Enter the number of counts to be mapped to 
the highest display memory value (that is, to 
set the display for acquiring frames). This 
value is usually white on the screen. The 
valid value range is -2 to 1,000,000. How-
ever, Three special values are defined as 
follows: 0 suppresses display of frames as 
they are acquired; -1directs the program to 
pick a reasonable value; and -2 directs the 
program to use the current level. The default 
value is 31.

/REAL TIME ......... (Real-time Display?)     [Yes]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 
the frame will be automatically displayed at 
the end of each scan if real-time display is 
off. This latter display method has no effect 
on observed data rate. Unless your data 
rate is very low, it is better NOT to use real-
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time display in the course of a SCAN com-
mand, even though the default here is “Y”. 
Note: Real-time is not permitted whenever 
display _ 0.

While real-time display is active, you can 
change the upper display limit using the plus 
key to increase or the minus key to 
decrease the current limit by a factor of two. 
(Range is 7 to 524287). Modify the contrast 
using the left and right arrow keys. Modify 
the brightness using the up and down keys. 
Holding the control key down in combination 
with any arrow key results in a greater 
change of contrast or brightness.

/CLEAR.................(Pre-Clear?)     [Yes]

This parameter specifies whether or not the 
memory will be cleared before the new data 
frame is collected. If clearing is not per-
formed, each successive frame in the series 
will be added to the counts accumulated 
before is collection is begun (effectively pro-
ducing a rotation picture). Enter “Y” to clear 
the memory, “N” otherwise. The default 
value is Y (clear).

/OLDXENGEN ......(Xengen Output Format?)     
[No]

Check this option to write frame in XENGEN 
1,3 format (more correctly, in the old PCS 
computer format). The default, is unchecked 
(Bruker format).

/MODE=<s>…(Mode (Step/Scan/Oscillate))     
[Scan]

Selects either a scan, oscillate, or stepping 
(between frames of a series) of the 
requested drive along the drive axis.

Perform sample oscillation (3-circle goniom-
eter only). Normally, scans are taken by 
continuously (actually in 0.0005 deg steps) 
driving the specified scan axis of the goni-
ometer as the data are accumulated. This 
provides a very uniform distribution of col-
lection time versus scan angle, as well as 
very good contiguity between successive 
frames. If the /MODE qualifier is set to oscil-
late, the scan angle is driven back and forth 
between the starting position and starting 
position plus the frame width approximately 
once per second. AN INTEGRAL NUMBER 
OF OSCILLATIONS IS ALWAYS PER-
FORMED IN THIS MODE -- the collection 
time per frame is adjusted as necessary to 
accommodate an integral number of ~1 s 
oscillations. The default is “Scan.”

In general, oscillation is not recommended. 
Drawbacks are that the ends of the scan 
range have anomalously high weight (since 
the goniometer must stop and restart at the 
end of each oscillation), and there may be 
some overlap or underlap of successive 
frames. Oscillation can however compen-
sate for some sources of error such as 
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intensity fluctuation due to an unstable 
source, and is therefore an option.

/ROTATE................(Rotate Sample?)     [No]

Perform sample rotation in phi. When used 
in conjunction with /MODE=OSCILLATE, an 
integer number of rotations are performed 
during each oscillation. Use of both the /
MODE=OSCILLATE and /ROTATE argu-
ments are designed for micro- diffraction 
applications, where a “random” sample is 
desired.

/VIDEO..................(Capture Video Image?)  
[No]

Capture vide image of sample with same 
name and .TIF extension. Requires a sys-
tem equipped with the video option. The 
video capture program must be running in a 
separate window.

Only on dual detector systems are addi-
tional parameters for control of the Slave 
frame buffer.

/OSCILLATE=<s>..(Sample Osc)     [None]

Select the axes to oscillate during data col-
lection. Valid entries are: “None”, “X”, “XY”, 
“XYZ”, “Y”, “YZ”, or “Z.”

/AMPLITUDE=<n> (Amplitude)     [0.0]

Enter the half amplitude of the oscillations in 
range 0 to +25 mm. Oscillation occurs 
between the starting position minus ampli-

tude and the starting position plus amplitude 
and uses a speed of half the maximum drive 
speed for that axis.

/AUTOZALIGN...... (Auto Z Align)     [No]

Check “Yes” to perform automatic sample 
height alignment using laser spot imaging. 
This feature requires VIDEO 1.3.02 or later. 
If Zoom is 1.0, you must enter a starting Z 
value that is within 3.5 mm of the true sam-
ple height. At Zoom of 7.0, starting Z must 
be within 0.5 mm of true position.

/SNAME=<s> ....... (Slave Job Name)     
[NEWFRA2]

Job name for frames collected on Slave 
frame buffer.

/SRUN=<s> .......... (Slave Run #)     [0]

Run number for frames collected on Slave 
frame buffer.

/SFRAME=<s> ..... (Slave Frame #)     [000]

Starting frame number for frames collected 
on Slave frame buffer.
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5.31 Collect > Scan > EditRuns • Edit 
parameters for MultiRun scans

Menu Command: Collect > Scan > EditRuns

Accelerator: Ctrl+Shft+F2

User Level: 1

SLAM Syntax: SCAN /EDITRUNS (interactive 
command only)

Use this command to create, read, or edit a run 
list (often called an array) of scans that you wish 
to acquire in multiple-run fashion (where one or 
more series of contiguous frames are collected 
without intervention).

Upon entering a Collect > Scan > EditRuns 
command, GADDS displays a run list with cur-
rent settings. (A typical list follows.) Each run list 
is identical in format to that in ASTRO, allowing 
you to transfer run lists between GADDS and 
ASTRO. (Use the [READ...] button in the dialog 
box to import the run list written by ASTRO.) On 
ASTRO list with an extra DeltaD column, only 
those lines with DeltaD=0.0 are read.

Typical run list:

Run# Frame# 2-Theta Omega Phi Chi Axis Width #Frames Time

0 001 -28.00 -28.00 0.00 54.74 2 -0.300 606 10.00

1 001 -28.00 -28.00 90.00 54.74 2 -0.300 435 10.00

2 001 -28.00 -28.00 180.00 54.74 2 -0.300 230 10.00

3 001 -28.00 -28.00 0.00 54.74 2 -0.300 50 10.00
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Each line of a run list defines one contiguous 
scan series. When entering the individual run 
arguments, keep in mind the following special 
considerations:

• The RUN#, FRAME#, and #FRAMES must 
conform to the frame naming parameters. 
(See Edit > Configure > User settings com-
mand.)

• The number of runs (or lines) must not 
exceed the maximum number of runs 
allowed by RUNCHARS and RUNBASE 
(see Edit > Configure > User settings com-
mand). The default maximum number of 
runs is 36. The absolute maximum is 51.

• All generated filenames must be valid and 
should not create duplicate names 
(explained later in this section).

With these considerations in mind, we recom-
mend that you always configure the frame nam-
ing conventions as follows:

• For 36 or fewer runs, set the “Base of Run 
#” (in the Edit > Configure > User settings 
dialog) to base 36, which will prevent the run 
number from wrapping from 9 to 0. The 
“Characters in Run #” should be 1. These 
are the default settings.

• For greater than 36 runs, you must set the 
“Characters in Run #” (in the Edit >Config-
ure > User settings dialog) to 2 characters. 
The “Base of Run #” can be base 10, if you 
find it more convenient.

Each line of a run list contains the following 
items:

RUN#

This is the Run Number of the series. This is 
not actually a number, but is rather taken as 
RUNCHARS characters of ASCII text. Also, 
all characters must be valid characters to be 
used with filenames because the Run Num-
ber becomes part of the generated output 
filename. Basically, the Run Number is for-
matted and appended to the output base 
filename before the file extension. See 
Frame Naming Conventions, Edit > Config-
ure > User settings command, and Collect > 
Scan > MultiRun command for more details.

FRAME# 

This is the starting frame number for the 
series. Like the Run Number, this is actually 
taken as text of length NUMCHARS rather 
than as a numeric value. The text specified 
here will be used as the extension of the first 
output frame in the series and will be incre-
mented according to the frame naming 
parameters to form the extensions of subse-
quent frames. See Frame Naming Conven-
tions, Edit > Configure > User settings 
command, and Collect > Scan > MultiRun 
command for more details. 
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2-THETA (Swing)
THETA1 (Tube)

The detector swing angle (goniometer 2-theta 
setting angle), in degrees, at which GADDS 
positions the goniometer for the frame series 
scans. Valid values are -180° to 180°, but are 
typically reduced by the current software colli-
sion limits as defined in Collect > Goniometer > 
limits command. Entering “@” will be automati-
cally replaced with current angle setting. On θ-θ 
systems, this is θ1 (tube).

OMEGA
THETA2 (detector)

The omega angle, in degrees, at which 
GADDS positions the goniometer at the 
start of the frame series scans. If you spec-
ify a scan axis (below) of 2, omega will be 
scanned as each frame is taken. Otherwise, 
omega remains fixed throughout the frame 
series. Valid values are -360° to 360°, but 
are typically reduced by the current software 
collision limits as defined in Collect > Goni-
ometer > limits command. Entering “@” will 
be automatically replaced with current angle 
setting. On θ-θ systems, this is θ2 (detec-
tor).

PHI

The phi angle, in degrees, at which GADDS 
positions the goniometer at the start of the 
frame series scans. If you specify a scan 
axis (below) of 3, phi will be scanned as 

each frame is taken. Otherwise, phi remains 
fixed throughout the frame series. Valid val-
ues are -360° to 360°, but are typically 
reduced by the current software collision 
limits as defined in Collect > Goniometer > 
limits command. Entering “@” will be auto-
matically replaced with current angle set-
ting.

CHI

The chi angle, in degrees, at which GADDS 
positions the goniometer for this frame 
series. A Platform goniometer is fixed at 
CHI=54.74°. An older Aztalan (black) 3-cir-
cle goniometer is fixed at CHI=45°. Valid 
values are -360° to 360°, but are typically 
reduced by the current software collision 
limits as defined in Collect > Goniometer > 
limits command. Entering “@” will be auto-
matically replaced with current angle set-
ting.

AXIS

The number of the axis to be scanned, as 
follows: 2 for omega scans, 3 for phi scans, 
4 for chi, 5 for X, 6 for Y, 7 for Z, or -1 for 
coupled. Note that while SAINT can reduce 
phi scans taken at any chi angle, some data 
reduction programs (XENGEN) may not be 
able to reduce phi-scan data unless it was 
taken at CHI=0. When using a restrictive 
data-reduction package, you must perform 
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omega scans on both the Platform goniom-
eter and the older Aztalan (black) 3-axis.

WIDTH

The scan width, in degrees (either positive 
or negative), of each frame to be acquired. 
Thus, the starting scan angle for the Nth 
frame in the series (where the first frame is 
N=0) is OMEGA+N*WIDTH if the axis 
(above) is 2, or PHI+N*WIDTH if the axis 
(above) is 3 (where WIDTH, OMEGA, and 
PHI are the values given on the same line of 
the array). The intensity within a frame is 
uniformly distributed with respect to scan 
angle over the range WIDTH specified here 
(unless 3-circle frames are taken by oscilla-
tion, in which case the ends of the range 
have slightly higher weight, and there may 
be some overlap or underlap of successive 
frames; oscillation can however compen-
sate for other sources of error such as inten-
sity fluctuation due to an unstable source).

#FRAMES

The number of frames to be acquired in this 
series. Ensure that the generated filename 
of the last frame in the series is a valid file-
name with regard to the frame naming 
parameters in the Edit > Configure > User 
settings dialog.

TIME

The accumulation time, in seconds, during 
which each frame is to be acquired. You can 

enter time in decimal seconds or in the for-
mat HH:MM:SS.SS (where HH represents 
hours, MM minutes, and SS.SS decimal 
seconds). Valid values are 0.05 to 32,767 
seconds.

When you invoke this command (> EditMulti), 
GADDS displays a scrollable editing window, 
listing all scan series currently in the corre-
sponding array. You can add to, delete from, or 
reorganize the list as desired using the appropri-
ate screen-editing functions (see Section 1.5, 
Dialog Box and Keyboard Conventions).

When you invoke the multirun scan command 
(Collect > Scan > MultiRun), each series will be 
acquired in the order they appear in the corre-
sponding array. GADDS generates output filena-
mes for each frame from the Job Name (in the 
Collect > Scan > MultiRun dialog box). GADDS 
also generates the Run Number (given for the 
series in the array), the starting Frame# (given 
for the series in the array), the Frame# being 
collected, and the frame naming parameters 
(defined in the Edit > Configure > User settings 
input panel). The first and last generated filena-
mes in each frame series must be valid. Also, 
the generated filenames between frame series 
should not overlap. Always check the bottom 
status line when you first start a new 
Collect > Scan > MultiRun to ensure that filena-
mes are being synthesized the way you want, to 
avoid duplication of filenames during data col-
lection (which will overwrite the previous file).
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The EditRuns command is an interactive com-
mand, meaning that you can invoke it from the 
command line, but it will not proceed without 
user intervention. And it has no built-in com-
mand-mode time-out as with other scrolling out-
put windows. Additionally, the Collect > Scan > 
MultiRun does not work well from script files, as 
you cannot define the run list in command 
mode. Thus, we recommend using the equiva-
lent SCAN/SINGLERUN script commands 
instead.

5.31.1 Arguments

None. Command executes immediate for inter-
active editing.
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5.32 Collect > Scan > MultiRun • 
Perform several series, as setup in 
the EditRuns form

Menu Command: Collect > Scan > MultiRun

Accelerator: Ctrl+Shft+F3

User Level: 1

SLAM Syntax:

SCAN /MULTIRUN $1 /TITLE=<s>
/SAMPLE=<s> /NUMSAMPLE=<n>
/DISPLAY=<n> /REAL TIME /CLEAR
/OLDXENGEN /STARTRUN=<n> 
ENDRUN=<n> /MODE=<n> /ROTATE
/VIDEO /OSCILLATE=<S>
/AMPLITUDE=<n>

Additional SLAM Syntax for dual detector mode:

… /SNAME=<s>

NOTE: As one cannot load the run list in com-
mand mode, we recommend using the equiva-
lent SCAN /SINGLERUN commands in script 
mode.

This command allows you to collect multiple 
scan series, each containing one or more con-
tiguous frames of data starting at specified goni-
ometer setting angles. Normally, Collect > 
Scan > MultiRun stores frames as an unwarped 
image, after applying the spatial correction 

table. It also applies the flood-field (intensity uni-
formity) corrections as the counts are received.

Before invoking Collect > Scan > MultiRun, you 
must set the parameters that are unique from 
series to series. (See Section 5.31, Collect > 
Scan > EditRuns command, for details on these 
settings and the generation of filenames.) Then 
use Collect > Scan > MultiRun to define those 
parameters that are the same for all the different 
scan series to be performed and start the scans.

When you invoke the command from the menu 
(or the command line without arguments), a dia-
log box appears where you can view/edit the 
arguments described below as follows:

• press ENTER or click the OK button to start 
scanning.

• press ESC or click the Cancel button to 
return to the menu.

You can interrupt a scan as follows:

• press ESC to stop after finishing collecting 
the current frame (soft abort).

• press CTRL+BREAK to interrupt the scan 
(hard abort or immediate abort).

During actual frame data collection, a small 
summary file is written and updated after each 
frame is collected. This file contains the current 
status of data collection, including the current 
run and frame number, current angle settings, 
and elapsed data collection time. This file is 
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used to resume a data set that has been inter-
rupted.

To resume acquiring data where the scan opera-
tion was interrupted (even by power failure), use 
the Collect > Scan > ResumeRuns command. 
(See Section 5.33 for more details.)

When you interrupt a scan with CTRL+BREAK, 
the goniometer returns to the starting scan 
angle of the current scan. This repositioning is 
performed by backing up to the starting position 
minus one frame width (or +/- 0.5° maximum), 
then driving forward to the starting position. The 
same positioning technique is used when driv-
ing to the first scan in a new series, which 
makes the positioning extremely repeatable but 
does require you to allow for an extra scan width 
at the beginning of the series when you're start-
ing close to the goniometer collision limits.

The current configuration is saved in the current 
default configuration file (usually gadds._nc) 
before starting the first scan, which makes 
recovery easier in the event of a power failure, 
etc.

The filename of the first frame is generated from 
the Job Name, Run# and Starting Frame# (from 
the appropriate line in the run list) as defined in 
Edit > Configure > User Settings: Frame Naming 
Parameters (see Section 4.1.1).

Because, one typically starts a scan and walks 
away from the instrument, GADDS will pre-
check that the available disk space is sufficient 

for storing the requested number of frames in 8-
bit mode. However, if the frames are stored in 
16-bit mode, you may still run out of disk space 
during the requested scan operation(s).

5.32.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses. These arguments are 
the same as the similar singlerun type scans 
and are, thus, explained in Section 5.30. See 
that section for explanations.

$1 ......................... (Job Name)     [NEWFRAM]

See /NAME=<s> in Section 5.30.

/TITLE=<s> .......... (Title)     [Scan Frame]

/SAMPLE=<s>...... (Sample Name)  [Corundum]

/NUMSAMPLE=<n>(Sample Number)     [0]

/DISPLAY=<n> ..... (Max Display Counts)     [31]

/REAL TIME ......... (Real-time Display?)     [Y]

/CLEAR ................ (Pre-Clear?)     [Y]

/OLDXENGEN...... (Xengen Output Format?)[N]

See Section 5.30.

/STARTRUN=<n>…(Sequence # of Starting 
Run)     [1]

You can collect just a specified range of the 
scan series set up in the run list using 
STARTRUN and ENDRUN. With STAR-
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TRUN you enter the first line number (not 
the RUN#) in the run list for which data col-
lection is to be performed. The lines are 
numbered 1–50. The default is 1, and the 
valid range is 1–50.

/ENDRUN=<n> .....(Sequence # of Ending Run)     
[9999]

You can collect just a specified range of the 
scan series set up in the run list using 
STARTRUN and ENDRUN. With ENDRUN 
you enter the line number (not the RUN#) in 
the run list after which data collection is to 
be terminated. The lines are numbered 1–
50. The default is 9999 (which works the 
same as 50), and the valid input range is 1–
32767.

/MODE=<s> ..........(Mode (Scan / Oscillate / 
Step))     [Scan]

/ROTATE................(Rotate Sample?)     [No]

/VIDEO..................(Capture Video Image?)     
[No]

/OSCILLATE=<s>..(Sample Osc)     [None]

/AMPLITUDE=<n> (Amplitude)     [0.0]

See Section 5.30.

Only on dual detector systems are addi-
tional parameters for control of the Slave 
frame buffer.

/SNAME................ (Slave Job Name)     
[NEWFRA2]

See Section 5.30.

Collect > Scan > MultiRun checks for possible 
collision at the extremes of all scans before 
beginning the first run. If the first or last frame in 
a run is outside the set limits, the program dis-
plays a box with the message:

PROBABLE COLLISION IN 1ST SCAN OF 
EDITRUNS LINE <line #>

or

PROBABLE COLLISION IN LAST SCAN 
OF EDITRUNS LINE <line #>

Here, <line #> represents the number of the line 
(starting at 1) in the run list which produced the 
message. You can continue with the scans or 
quit (to re-edit the run list) and try again.

The current program configuration is saved in 
the current default configuration file (usually 
gadds._nc) before starting the first scan, which 
makes recovery easier in the event of a power 
failure, etc.

For single crystal type applications, you can use 
Collect > Scan > MultiRun collect multiple scan 
series, which covers a little more than half the 
entire Ewald sphere. This strategy allows you to 
obtain the full amount of coverage needed to 
solve the structure, regardless of unit cell size or 
Laue class, without any need for preplanning 
with ASTRO.
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The default hemisphere runs require about 7.5 
hours for full data collection (with 10-seconds-
per-frame scan time) and comprise 3 runs total-
ing about 1250 frames. They are set up assum-
ing a sample-to-detector distance of about 6 cm, 
which provides full coverage out to better than 
0.93 Å (45° with Mo radiation). These default 
hemisphere runs provides the best redundancy, 
which improves the quality of the data and 
absorption corrections. For high-symmetry Laue 
groups, it’s possible to collect a full data set in 
less time (typically about 4 hours, 750 frames). 
However, the default hemisphere runs will prob-
ably produce a higher quality data set.

In addition, ASTRO is available for preplanning 
a data collection strategy that minimizes data 
collection time for a single asymmetric unit or 
asymmetric unit plus Bijvoet pairs. With this 
approach, you can often collect enough data for 

structure solution in 2 or 3 hours on crystals with 
orthorhombic or higher symmetry (again, sacri-
ficing redundancy).

Before invoking Collect > Scan > MultiRun, you 
can view/edit the runs to be performed (as 
needed) with Collect > Scan > EditRuns, 
although the default runs supplied should be 
satisfactory in most cases (unless you are using 
more restrictive collision limits).

GADDS retrieves the defaults for multirun scans 
from the gadds._nc file (located in the project 
directory). The defaults for new projects are 
taken either from the current settings or the 
gaddsdef._nc file (located in the GADDS system 
directory). Should you need to change between 
3-circle and 4-circle runs, here are the currently 
used defaults for you to enter:

Table 5.10 – Default 3-circle Hemisphere Runs

Run# Frame# 2-Theta Omega Phi Chi Axis Width #Frames Time

0 001 -28.00 -28.00 0.00 54.70 2 -0.300 606 10.00

1 001 -28.00 -28.00 90.00 54.70 2 -0.300 435 10.00

2 001 -28.00 -28.00 180.00 54.70 2 -0.300 230 10.00

3 001 -28.00 -28.00 0.00 54.70 2 -0.300 50 10.00
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Table 5.11 – Default 4-circle Hemisphere Runs

Before performing a scan with the above runs, 
ensure that they agree with the collision limits 
(see Collect > Goniometer > Limits) for your par-
ticular system.

These runs are valid for both Mo and Cu radia-
tion. However, Cu data will be complete to a 
lower resolution. For a Platform goniometer, a 
good strategy for collecting higher resolution 
shells is to swing the detector out farther and 
interleave the higher resolution scans approxi-
mately 45° in chi relative to the low resolution 
scans (putting them in the “cusps” at the outer 
edges of the low resolution scans). You will have 
to modify this strategy a little (for example, by 
trial and error in ASTRO) due to potential 
omega-2theta collisions.

Run# Frame# 2-Theta Omega Phi Chi Axis Width #Frames Time

0 001 28.00 28.00 0.00 30.00 3 .300 1250 10.00

1 001 28.00 43.00 0.00 280.00 2 -.300 100 10.00

2 001 28.00 43.00 90.00 280.00 2 -.300 100 10.00

3 001 28.00 43.00 180.00 280.00 2 -.300 100 10.00

4 001 28.00 43.00 270.00 280.00 2 -.300 100 10.00
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5.33 Collect > Scan > ResumeRuns • 
Resume interrupted MultiRun scans

Menu Command: Collect > Scan > ResumeR-
uns

Accelerator: None

User Level: 1

SLAM Syntax:

SCAN /RESUMERUNS
$1  /TITLE=<s> /SAMPLE=<s>
/NUMSAMPLE=<s>/DISPLAY=<n>
/REAL TIME /CLEAR /OLDXENGEN 
/STARTRUN=<n> /ENDRUN=<n> 
/MODE=<n> /ROTATE /VIDEO 
/OSCILLATE=<s> /AMPLITUDE=<n> $2 
/SNAME=<s> [/2THETA=<n> | 
/THETA1=<n>] [/OMEGA=<n> | 
/THETA2=<n>] /PHI=<n> /CHI=<n> 
/X=<n> /Y=<n> /Z=<n> /AUX=<n> 
/AXIS=<n> /WIDTH=<n> 
/SCANTIME=<n> /RUN=<s> 
/FRAMENO=<s> $3

This command will restart a scan sequence 
(interrupted manually, with CTRL+BREAK or 
ESC, or by power failure) where it left off. The 
command applies to scans acquired by 
Collect > Scan > MultiRun, but not those by 
Collect > Scan > SingleScan.

GADDS updates the scan parameters in a disk 
file (RESUME._TM) at the start of each scan. 

The updating procedure explicitly closes the file 
to ensure that the information is written to the 
disk drive. GADDS uses this updated parameter 
information in resume._tm to restart the 
sequence.

When invoked from the menu, or run from the 
command line without arguments, Collect > 
Scan > Resume displays a dialog box where 
you can view/edit the arguments described 
below. The displayed defaults in this panel are 
read from the RESUME._TM file and should 
correspond to the state of the system when 
scanning was interrupted (that is, they should 
correspond to the first incomplete frame). You 
should review (edit if necessary) these values 
before restarting data collection. Pressing 
ENTER or clicking the OK button resumes data 
collection. Pressing ESC or the Cancel button 
exits the dialog and returns you to the menu.

When invoked from the command line, SCAN 
/RESUMERUNS can take the arguments shown 
in the SLAM syntax description above (where 
<n> represents a numeric value and <s> repre-
sents a string value). The first 13 arguments 
correspond to those that were specified in the 
Acquire > MultiRun, Hemisphere, or Quadrant 
input dialog. The next 15 represent the values 
obtained from the run list for the interrupted 
scan.
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5.33.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses.

$1 ..........................(Job Name)     
[from resume._tm]

/TITLE<s> .............(Title)     [from resume._tm]

/SAMPLE<s> ........(Sample Name)     
[from resume._tm]

/NUMSAMPLE<s> (Sample Number)     
[from resume._tm]

/DISPLAY=<n>......(Max Display Counts)     
[from resume._tm]

/REAL TIME ..........(Real-time Display?)     
[from resume._tm]

/CLEAR .................(Pre-Clear?)     
[from resume._tm]

/OLDXENGEN ......(Xengen Output Format?)     
[from resume._tm]

/STARTRUN=<n>..(Sequence # of Starting 
Run)     [from resume._tm]

/ENDRUN=<n> .....(Sequence # of Ending Run)     
[from resume._tm]

/MODE=<n>..........(Mode (Scan/Oscillate/
Step))     [from resume._tm]

/ROTATE................(Rotate Sample?)     
[from resume._tm]

/VIDEO. ................ (Capture Video Image?)     
[from resume._tm]

/OSCILLATE=<s>. (Sample Osc)     
[from resume._tm]

/AMPLITUDE=<n> (Amplitude)     
[from resume._tm]

/SNAME................ (Slave Job Name)     
[from resume._tm]

See Section 5.30, Section 5.31, and Section 
5.32.

$2 ......................... (# Frames)     [from 
resume._tm]

Enter the number of frames remaining to be 
collected in the current scan series.

/2THETA=<n>....... (2-Theta)  [from resume._tm]

/THETA1=<n>....... (Theta1)   [from resume._tm]

Enter the detector swing angle in degrees at 
which the remaining frames in the current 
scan series are to be collected. On θ-θ sys-
tems, this is the θ1 angle (tube).

/OMEGA=<n>....... (Omega)   
[from resume._tm]

/THETA1=<n>....... (Theta1)     
[from resume._tm]

Enter the omega angle, in degrees, at which 
the goniometer will be positioned at the start 
of this frame series. If you specify a scan 
axis number (see /AXIS=<n> below) of 2, 
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omega will be scanned as each frame is 
taken. Otherwise, omega remains fixed 
throughout the frame series. On θ-θ sys-
tems, this is the θ2 angle (detector).

/PHI=<n>...............(Phi)     [from resume._tm]

Enter the phi angle, in degrees, at which the 
goniometer will be positioned at the start of 
this frame series. If you specify a scan axis 
number (see /AXIS=<n> below) of 3, phi will 
be scanned as each frame is taken. Other-
wise phi remains fixed throughout the frame 
series.

/CHI=<n> ..............(Chi)     [from resume._tm]

Enter the goniometer chi setting angle, in 
degrees, at which the remaining frames in 
the current scan series are to be collected. 
A Platform goniometer is fixed at 
CHI=54.74°. An older Aztalan (black) 3-cir-
cle goniometer is fixed at CHI=45°.

/X=<n> ..................(X)     [from resume._tm]

Enter the goniometer chi setting angle, in 
degrees, at which the remaining frames in 
the current scan series are to be collected.

/Y=<n> ..................(Y)     [from resume._tm]

Enter the goniometer chi setting angle, in 
degrees, at which the remaining frames in 
the current scan series are to be collected.

/Z=<n>.................. (Z)     [from resume._tm]

Enter the goniometer chi setting angle, in 
degrees, at which the remaining frames in 
the current scan series are to be collected.

/AUX=<n>............. (Aux)     [from resume._tm]

Enter the goniometer chi setting angle, in 
degrees, at which the remaining frames in 
the current scan series are to be collected.

/AXIS=<n>............ (Scan Axis #)     [from 
resume._tm]

Enter the number of the axis to be scanned, 
either 2 (for omega scans) or 3 (for phi 
scans). Remember that some data reduc-
tion programs cannot reduce phi-scan data 
unless it was taken at CHI=0. A Platform 
goniometer is fixed at CHI=54.74°. An older 
Aztalan (black) 3-circle goniometer is fixed 
at CHI=45°. SAINT can reduce phi scans 
taken at nonzero chi.

/WIDTH=<n> ........ (Frame Width)     [from 
resume._tm]

Enter the scan width of each frame to be 
acquired in degrees. This value can be 
either positive or negative. Thus, the starting 
scan angle for the Nth frame in the series 
(where the first frame is N=0) is 
OMEGA+N*WIDTH if AXIS above is 2, or 
PHI+N*WIDTH if AXIS above is 3, where 
WIDTH, OMEGA, and PHI are the values 
given here on this line of the array.



Collect Routines GADDS Software Reference Manual

5 - 62 M86-E01008

/SCANTIME=<n> ..(Seconds/Frame)     [from 
resume._tm]

Enter the time, in seconds, for which each 
frame is to be acquired. You can optionally 
specify long times in the format 
HH:MM:SS.SS where HH represents hours; 
MM, minutes; and SS.SS decimal seconds.

/RUN=<s> .............(Run #)     [from resume._tm]

Enter the RUN# of the interrupted scan 
series. Make sure it matches the current 
RUNBASE and RUNCHARS defined in the 
Edit > Config dialog.

/FRAMENO=<s>...(Frame #)     [from 
resume._tm]

Enter the Frame Number of first incomplete 
frame in the interrupted scan series. Make 
sure it matches the current NUMBASE and 
NUMCHARS defined in the Edit > Config 
dialog.

$3 ..........................(Interrupted Run# to 
Resume)     [from resume._tm]

Enter run (line#) to resume (0 if no run in 
progress).
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5.34 Collect > Scan > Rotation • Take 
a phi rotation picture

Menu Command: Collect > Scan > Rotation

Accelerator: Ctrl+Shft+F4

User Level: 1

SLAM Syntax:

SCAN /ROTATION $1 /TTZERO /PHI=<n>
/CHI=<n> /DISPLAY=<n> /REAL TIME
/RESET=<n>

Collect > Scan > Rotation allows you to collect a 
rotation “photo” of a sample or crystal by rotat-
ing the sample in phi while exposing it to the X-
ray beam.

When invoked from the menu, or run from the 
command line without arguments, Collect > 
Scan > Rotation displays a dialog box where 
you can view/edit the arguments described 
below. Pressing the ENTER key or clicking the 
OK button starts the operation. Pressing ESC or 
Cancel button stops the operation and returns 
you to the menu.

You can interrupt the operation by pressing 
CTRL+BREAK. Upon interruption, the goniome-
ter stays at the position where the rotation was 
interrupted.

5.34.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses.

$1 ......................... (Exposure Time)     [36.0]

Enter the requested exposure time in sec-
onds. The valid range is from X to 65535 
seconds, where the minimum is calculated 
from the maximum phi speed and the 
default value is 36.

/CLEAR ................ (Pre-Clear?)     [Yes]

See Section 5.30 for an explanation of this 
argument.

/TTZERO.............. (Zero 2-Theta, Omega 
(Y/N))     [No]

/TTZERO.............. (Zero Theta-1, Theta-2 
(Y/N))     [No]

If you check this option, 2-theta and omega 
are driven to zero before the rotation is 
acquired. Otherwise, these setting angles 
are left at their current position. The default 
is “Y” (checked). On θ-θ systems, this drives 
θ1 and θ2 to zero.

/PHI=<n>.............. (Starting Phi)     [0.00]

Enter starting phi for photo in degrees. The 
allowed range is from 0 to 360, with a 
default setting of 0.
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/CHI=<n>...............(Starting Chi)     [0.00]

Enter goniometer chi for photo in degrees. 
The allowed range is from 0 to 360, with a 
default setting of 0.

/DISPLAY=<n>......(Mzx Displayed Counts)     
[15]

See Section 5.30 for an explanation of this 
argument.

/REAL TIME ..........(Real-time Display?)     [Yes]

See Section 5.30 for an explanation of this 
argument.

/RESET=<n>.........(Reset Interval)     [0]

This qualifier specifies the number of sec-
onds before repetitive auto-clear of frame 
memory (0 = do not clear). The default value 
is 0; the range is from 1 to 65,535 seconds. 
This parameter is useful in conjunction with 
real-time display if you're looking for a 
change in intensity over time.

When you start collecting a rotation frame, if you 
checked the option to zero 2-theta and omega, 
GADDS drives the two angles to zero, otherwise 
the goniometer 2-theta and omega setting 
angles stay at their current position. Chi moves 
to the value specified on the input panel (a 3-cir-
cle goniometer is fixed at chi=54.74° or chi=45°, 
depending on the type) and phi moves to the 
starting angle specified on the input panel. After 
these goniometer movements, GADDS opens 
the shutter, performs a full rotation of phi, while 

acquiring a frame. The shutter closes once the 
exposure has been completed, then GADDS 
displays the unwarped frame. The speed of 
rotation depends on the collection time 
requested in the input panel. The requested 
time adjusts as needed to make a full phi rota-
tion. Since the maximum rotation speed is 3600 
degrees/minute (for Platform), 24 seconds is the 
shortest actual rotation exposure time (600 
degrees/minute, for P4, 36 seconds).

A rotation photo taken at a detector swing angle 
(2-theta setting angle) of zero provides the best 
method for estimating the direct beam center. 
Usually, you'll need a strongly diffracting crystal 
to see a good pattern. The rotation photo will 
contain a center of symmetry at the direct beam 
position. You can place the origin and endpoint 
of a vector cursor (see Analyze > Cursor > Vec-
tor) on two spots related by the center of sym-
metry and obtain the direct beam coordinates 
from the displayed vector midpoint values.
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5.35 Collect > Scan > HKL • 
Reciprocal space scan from starting 
HKL to ending HKL

Menu Command: Collect > Scan > HKL

Accelerator: Ctrl+Shft+F5

User Level: 1

SLAM Syntax:

SCAN /HKL $1 $2 $3 /SCANTIME=<n> 
/TITLE=<s> /SAMPLE=<s> 
/NUMSAMPLE=<n> /NAME=<s> 
/RUN=<s> /FRAMENO=<s> 
/DISPLAY=<n> /REAL TIME

SCAN /HKL will collect a frame series for later 
processing with GRAPH /HKL.

When invoked from the command line, SCAN /
HKL can take the following arguments (where 
<n> represents a numeric value and & indicates 
continuation on the next line):

5.35.1 Arguments

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses:

$1 ......................... (Starting HKL)     [-.5 1.5 1.5]

Enter starting hkl value. May be reals.

$2 ......................... (Ending HKL)     [.5 2.5 2.5]

Enter ending hkl value. May be reals.

$3 ......................... (# Frames)     [101]

Number of frames to be acquired in this 
series. Make sure it doesn't exceed the 
number permitted by FRAME# above in 
conjunction with the frame naming parame-
ters in the CONFIGURE /EDIT panel.

/SCANTIME=<n> . (Seconds/Frame)     
[1:00.00]

Time in seconds for which each frame is to 
be acquired. You can optionally specify long 
times in the format HH:MM:SS.SS where 
HH represents hours; MM, minutes; and 
SS.SS decimal seconds.

/TITLE=<s> .......... (Title)     [Scan/HKL frame]

Enter title for output frames, 80 characters 
maximum. The default entry is “Scan 
Frame.” If you invoked this command from 
the command line, you must enclose any 
title continuing embedded blanks in double 
quotes.
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$FILE:<filename> will read up to eight 72-
character title lines from an ASCII file and 
place these title strings into the eight 
“TITLE” lines in the frame header. The for-
mat of the ASCII file is: “R#:<single line of 
title information>”, where “R#” is the run 
number, taken from the filename. Repeat up 
to eight times for each run.

/SAMPLE=<s> ......(Sample Name)     [YLID]

Enter sample name, to be stored in frame 
header. If no name is specified, the default 
name of “Lysozyme” will be entered.

/NUMSAMPLE=<n>(Sample Number)     [0]

Enter sample number, to be stored in frame 
header. The permitted range is from 0 to 
32,767, with a default setting at 1.

/NAME=<s>...........(Job Name)     [HKLFRAM]

Enter the base filename for the output 
frames. The filenames for each series of 
output frames are generated by adding the 
series RUN# (see below) window) and an 
extension built from the series starting 
FRAME# (see below) to the end of this base 
name. For example, if the Job Name is LYS, 
the Run Number is 04, and the starting 
Frame Number is 000 (assuming that the 
number of characters in a Run Number is 
set to 2 and number characters in a Frame 
Number is set to 3 in the CONFIGURE 
/EDIT panel), the data files are named in 
sequence as: LYS04.000, LYS04.001, 

LYS04.002, etc.). See the description 
“FRAME NAMING CONVENTIONS” for 
more information. The default name if none 
is specified is NEWFRAM.

The Job Name for frames stored locally can 
contain a DOS drive and directory name if 
desired. The output filename is, except in 
the special cases discussed below, merged 
with the default frame directory defined in 
the CONFIGURE /EDIT panel prior to creat-
ing the output frame. See CONFIGURE 
/EDIT for a description of how this is done.

There are two special Job Name cases. The 
first, $NET is NOT supported under 
GADDS. The second special Job Name is 
$NULL. In this case, the frames are not out-
put -- they are thrown away.

/RUN=<s>............. (Run #)     [0]

The Run Number of the series. This is not 
actually a number, but is rather taken as 
/RUNCHARS characters of ASCII text 
(where /RUNCHARS is defined in the CON-
FIGURE /EDIT input panel) to be used as 
the last /RUNCHARS characters of the out-
put base filename (i.e., the last /RUN-
CHARS characters before the extension). 
Make sure that these values, and the frame 
naming parameters in CONFIGURE /EDIT 
are set the way you want before starting to 
scan, as described above.
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/FRAMENUM=<s> (Frame #)     [000]

This is the starting frame number for the 
series defined by this line of the array. Make 
sure it conforms to the frame naming 
parameters currently set in CONFIGURE 
/EDIT. Like the Run Number, this is actually 
taken as text rather than a numeric value. 
The text specified here will be used as the 
extension of the first output frame in the 
series, and will be incremented according to 
the frame naming parameters to form the 
extensions of subsequent frames.

/DISPLAY=<n>......(Max Display Counts)     [31]

0 = no display, otherwise # counts corre-
sponding to white on the display. SAVE will 
optionally display the data being saved 
using this value as the upper display limit 
(see DISPLAY /NEW for more details). The 
default value is 16; the allowed range is 

from 0 to 106 counts.

/REAL TIME ..........(Real-time Display?)     [Yes]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 
the frame will be automatically displayed at 
the end of each scan if real-time display is 
off. This latter display method has no effect 

on observed data rate. Unless your data 
rate is very low, it is better NOT to use real-
time display in the course of a SCAN com-
mand, even though the default here is “Y.”

While real-time display is active, you can 
change the upper display limit using the plus 
key to increase or the minus key to 
decrease the current limit by a factor of two 
(the range is 7 to 524287). Modify the con-
trast using the left and right arrow keys. 
Modify the brightness using the up and 
down keys. Holding the control key down in 
combination with any arrow key results in a 
greater change of contrast or brightness.



Collect Routines GADDS Software Reference Manual

5 - 68 M86-E01008

5.36 Collect > Scan > Psi • 
Take a Psi scan of 360° around 
reciprocal vector

Menu Command: Collect > Scan > Psi

Accelerator: Ctrl+Shft+F6

User Level: 1

SLAM Syntax:

SCAN /PSI $1 $2 /SCANTIME=<n> 
/TITLE=<s> /SAMPLE=<s> 
/NUMSAMPLE=<n> /NAME=<s> 
/RUN=<s> /FRAMENO=<s> 
/DISPLAY=<n> /REAL TIME

SCAN /PSI will collect a frame series for later 
processing with GRAPH /PSI. 

When invoked from the command line, SCAN 
/PSI can take the following arguments (where 
<n> represents a numeric value and & indicates 
continuation on the next line).

5.36.1 Arguments

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses:

$1 ......................... (HKL)     [022]

Enter the hkl position for psi scan.

$2 ......................... (#Frames)     [180]

Enter the number of frames to collect (deter-
mines the step size).

/SCANTIME=<n> . (Seconds/Frame)     
[1:00.00]

Time in seconds for which each frame is to 
be acquired. You can optionally specify long 
times in the format HH:MM:SS.SS where 
HH represents hours; MM, minutes; and 
SS.SS decimal seconds.

/TITLE=<s> .......... (Title)     [Scan/psi frame]

Enter title for output frames, 80 characters 
maximum. The default entry is “Scan 
Frame.” If you invoked SCAN /SINGLERUN 
from the command line, you must enclose 
any title continuing embedded blanks in 
double quotes.

$FILE:<filename> will read up to eight 72-
character title lines from an ASCII file and 
place these title strings into the eight 
“TITLE” lines in the frame header. The for-
mat of the ASCII file is: “R#:<single line of 
title information>”, where “R#” is the run 
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number, taken from the filename. Repeat up 
to eight times for each run.

/SAMPLE=<s> ......(Sample Name)     [YLID]

Enter sample name, to be stored in frame 
header. If no name is specified, the default 
name of “Lysozyme” will be entered.

/NUMSAMPLE=<s>(Sample Number)     [0]

Enter sample number, to be stored in frame 
header. The permitted range is from 0 to 
32,767, with a default setting at 1.

/NAME=<s> ..........(Job Name)     [PSIFRAM]

Enter the base filename for the output 
frames. The filenames for each series of 
output frames are generated by adding the 
series RUN# (see below) window) and an 
extension built from the series starting 
FRAME# (see below) to the end of this base 
name. For example, if the Job Name is LYS, 
the Run Number is 04, and the starting 
Frame Number is 000 (assuming that the 
number of characters in a Run Number is 
set to 2 and number characters in a Frame 
Number is set to 3 in the CONFIGURE 
/EDIT panel), the data files are named in 
sequence as: LYS04.000, LYS04.001, 
LYS04.002, etc.). See the description 
“FRAME NAMING CONVENTIONS” for 
more information. The default name if none 
is specified is NEWFRAM.

The Job Name for frames stored locally can 
contain a DOS drive and directory name if 
desired. The output filename is, except in 
the special cases discussed below, merged 
with the default frame directory defined in 
the CONFIGURE /EDIT panel prior to creat-
ing the output frame. See CONFIGURE 
/EDIT for a description of how this is done.

There are two special Job Name cases. The 
first, $NET is NOT supported under 
GADDS. The second special Job Name is 
$NULL. In this case, the frames are not out-
put—they are thrown away.

/RUN=<s>............. (Run #)     [0]

The Run Number of the series. This is not 
actually a number, but is rather taken as 
/RUNCHARS characters of ASCII text 
(where /RUNCHARS is defined in the CON-
FIGURE /EDIT input panel) to be used as 
the last /RUNCHARS characters of the out-
put base filename (i.e., the last /RUN-
CHARS characters before the extension). 
Make sure that these values, and the frame 
naming parameters in CONFIGURE /EDIT 
are set the way you want before starting to 
scan, as described above.

/FRAMENO=<s> .. (Frame #)     [000]

This is the starting frame number for the 
series defined by this line of the array. Make 
sure it conforms to the frame naming 
parameters currently set in CONFIGURE 
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/EDIT. Like the Run Number, this is actually 
taken as text rather than a numeric value. 
The text specified here will be used as the 
extension of the first output frame in the 
series, and will be incremented according to 
the frame naming parameters to form the 
extensions of subsequent frames.

/DISPLAY=<n>......(Max Display Counts)     [31]

0 = no display, otherwise # counts corre-
sponding to white on the display. SAVE will 
optionally display the data being saved 
using this value as the upper display limit 
(see DISPLAY /NEW for more details). The 
default value is 16; the allowed range is 

from 0 to 106 counts.

/REAL TIME ..........(Real-time Display (Y/N))     
[Yes]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 
the frame will be automatically displayed at 
the end of each scan if real-time display is 
off. This latter display method has no effect 
on observed data rate. Unless your data 
rate is very low, it is better NOT to use real-
time display in the course of a SCAN com-
mand, even though the default here is “Y.”

While real-time display is active, you can 
change the upper display limit using the plus 
key to increase or the minus key to 
decrease the current limit by a factor of two 
(the range is 7 to 524287). Modify the con-
trast using the left and right arrow keys. 
Modify the brightness using the up and 
down keys. Holding the control key down in 
combination with any arrow key results in a 
greater change of contrast or brightness.
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5.37 Collect > Scan > CoupledScan • 
Conventional 2θ/θ coupled scan 
(Uses AD as a point detector)

Menu Command: Collect > Scan > Coupled-
Scan

Accelerator: Ctrl+Shft+F7

User Level: 1

SLAM Syntax:

SCAN /COUPLED $1 $2 $3 /WIDTH=<n>
/SCANTIME=<n> /TITLE=<s> 
/SAMPLE=<s> /NUMSAMPLE=<n> 
/NAME=<s> /RUN=<s> /ROTATE /X=<n> 
/Y=<n> /REAL TIME

Perform a conventional 2T/T coupled scan using 
a square portion of the area detector grid as a 
point detector. The omega axis is always driven 
at half the rate of the 2-theta axis.

Scan /Coupled performs a conventional 2T/T 
coupled scan using a square portion of the area 
detector grid as a point detector. The resulting 
scan data is displayed in 1D spectra, not 2D 
frames. The 1D spectra is saved as an addi-
tional range in a DIFFRAC-AT file suitable for 
input into other software packages such as 

PROFILEplus or EVA.

Data is collected from 2T start to 2T end. You 
may collect in negative 2T space and in negative 
2T direction. The 1D spectrum is always stored 

in positive 2T direction. If both start and end 2T 
positions are in negative 2T space, the 1D spec-
trum is stored as positive 2T space.

The omega axis is always driven at half the rate 
of the 2-theta axis.

When invoked from the command line, SCAN 
/COUPLED can take the following arguments 
(where <n> represents a numeric value and & 
indicates continuation on the next line).

5.37.1 Arguments

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses:

$1 ......................... (2-Theta start)     [5.0]

Enter the starting 2-Theta in degrees 
(“@”=current setting).

$2 ......................... (2-Theta end)     [90.0]

Enter the ending 2-Theta in degrees 
(“@”=current setting).

$3 ......................... (Omega start)     [2.5]

Enter the starting omega in degrees 
(“@”=current setting).

/WIDTH=<n> ........ (Step width)     [0.1]

Enter degrees per step as a positive num-
ber.
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/SCANTIME=<n> ..(Step time)     [10.0]

Enter counting time in seconds for this 
frame.

/TITLE=<s> ...........(Title)     [Coupled scan]

Enter title for output frames (80 characters 
max).

/SAMPLE=<s> ......(Sample name)     
[Corundum]

n.y.i. Enter sample name, to be stored in 
frame header.

/NUMSAMPLE=<s>(Sample number)     [0]

n.y.i. Enter sample number, to be stored in 
frame header.

/NAME=<s>...........(Job name)     [CORUND]

Enter base name for frames.

/RUN=<s> .............(Run #)     [0]

Enter data set # (base 10 or 36—see CON-
FIGURE form).

/ROTATE................(Rotate sample Y/N)     [N]

n.y.i. Y to perform sample rotation in phi, N 
otherwise.

/X=<n> ..................(Active width)     [2.0]

Enter active detector width about center in 
mm.

/Y=<n>.................. (Active height)     [2.0]

Enter active detector height about center in 
mm.

/REAL TIME ......... (Real-time Display?)     [Yes]

Enter Y for real-time display, N otherwise.



GADDS Software Reference Manual Collect Routines

M86-E01008 5 - 73

5.38 Collect > Scan > ZonePhoto • 
Acquire a rotational photo along a 
zone (0KL, H0L, HK0)

Menu Command: Collect > Scan > Zone

Accelerator: Ctrl+Shft+F8

User Level: 1

SLAM Syntax: SCAN /ZONE $1 /WIDTH=<n> 
/SCANTIME=<n> /DISPLAY=<n>

Acquire > Zone acquires an omega-rotation pic-
ture centered on a crystallographic H0L, 0KL, or 
HK0 zone, according to the current orientation 
matrix. With a 3-circle goniometer, GADDS does 
not guarantee that all three zones will be acces-
sible. Typically, you will have two possible 
omega settings at which to observe a zone. If 
more than one solution is accessible, GADDS 
will record the one which places omega farthest 
from the detector (at swing angle zero).

NOTE: Ensure that your collision limits are set 
correctly before using this command. GADDS 
uses them to determine if a solution is accessi-
ble. If the requested zone is not accessible, 
GADDS displays a message indicating so.

The frame is not automatically written to disk. 
Use Acquire > Save after collecting the still 
frame if you want to save the data to disk.

When invoked from the menu, or run from the 
command line without arguments, Acquire > 
Zone displays a dialog box where you can view/
edit the arguments described below before per-
forming the operation. Pressing the ENTER key 
or clicking the OK button starts the operation. 
Pressing ESC or the Cancel button stops the 
operation and returns you to the menu.

You can interrupt the operation by pressing 
CTRL+BREAK.

5.38.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Zone)     [1]

Enter 1 to attempt collection of the 0KL 
zone, 2 for H0L, or 3 for HK0.

/WIDTH=<n> ........ (Frame Width)     [-5.0]

Enter the frame width as defined under 
WIDTH in Section 3.4.

/SCANTIME=<n> . (Seconds/Frame)     [30.0]

Enter the seconds per frame as defined 
under TIME in Section 3.4.

/DISPLAY=<n> ..... (Max Display Counts)     [-1]

See Section 3.7 for an explanation of this 
argument. (See Acquire > Display for more 
details.)
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5.39 Collect > Scan > Axial Image • 
Acquire a frame showing A, B, or C 
axial image

Menu Command: Collect > Scan > Axial

Accelerator: Ctrl+Shft+F8

User Level: 1

SLAM Syntax: SCAN /ZONE $1 /WIDTH=<n> 
/SCANTIME=<n> /DISPLAY=<n>

Acquire > Axial acquires an omega-rotation pic-
ture in which the crystal is rotated about the a, b, 
or c axis.

The frame is not automatically written to disk. 
Use Acquire > Save after collecting the still 
frame if you want to save the data to disk.

When invoked from the menu, or run from the 
command line without arguments, Acquire > 
Axial displays a dialog box where you can view/
edit the arguments described below before per-
forming the operation. Pressing the ENTER key 
or clicking the OK button starts the operation. 
Pressing ESC or the Cancel button stops the 
operation and returns you to the menu.

You can interrupt the operation by pressing 
CTRL+BREAK.

5.39.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Axis)     [1]

Enter 1 to attempt collection of the a axis, 2 
for b, or 3 for c.

/WIDTH=<n> ........ (Frame Width)     [-0.5]

Enter the frame width as defined under 
WIDTH in Section 3.4.

/SCANTIME=<n> . (Seconds/Frame)     [30.0]

Enter the seconds per frame as defined 
under TIME in Section 3.4.

/DISPLAY=<n> ..... (Max Display Counts)     [-1]

See Section 3.7 for an explanation of this 
argument. (See Acquire > Display for more 
details.)
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5.40 Collect > Scan > PickTargets • 
Manually drive and select target 
positions for MultiTarget list

Menu Command: Collect > Scan > PickTargets

Accelerator: Ctrl+Shft+F9

User Level: 1

SLAM Syntax: SCAN /SELECTTARGETS

SCAN /SELECTTARGETS manually select XYZ 
target position(s) and automatically enter the 
selected target into the SCAN /MULTITARGETS 
by appending the list.

When SELECTTARGETS is first entered, the 
user has the option of either clearing the target 
list or appending to the existing target list.

Pre-clear the existing target list? Y/N

The video program should already be running in 
a separate window. SELECTTARGETS will turn 
the video to “live” and turn the laser ON. Manual 
speed ratios can be selected and the program 
enters manual mode. The user then drives to a 
position where data collection is requested, 
makes sure the laser is positioned within the 
video cross-hairs, then hits <Ctrl-G> to exit 
manual mode. The current sample position can 
be automatically entered into the target list.

Do you want to enter this position in the tar-
gets list? Y/N

Additional targets may be selected before 
exiting SELECTTARGETS

Do you want to enter more positions in the 
targets list? Y/N

5.40.1 Arguments

None. Command executes immediately. This is 
an interactive command only.
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5.41 Collect > Scan > GridTargets • 
Set up grid for MultiTarget list

Menu Command: Collect > Scan > GridTargets

Accelerator: Ctrl+Shft+F10

User Level: 1

SLAM Syntax:

SCAN /GRIDTARGETS /XBEG=<n> 
/XEND=<n> /XINC=<n> /YBEG=<n> 
/YEND=<n> /YINC=<n>
/TRANSMISSION /APPEND

On systems equipped with an XYZ stage, it is 
possible to collect scans at multiple target loca-
tions. On flat samples such as wafers, one fre-
quently wishes to take scans on target positions 
laid out on a rectangular grid. Instead of manu-
ally determining the Z axis position of each tar-
get on the grid, one can pre-determine the flat 
sample plane, then lay out the target locations 
using SCAN /GRIDTARGETS which will auto-
matically calculated the correct Z axis value 
from the flat sample plane. See GONIOMETER 
/FLATSAMPLE.

NOTE: The list of targets is now optimized 
(sorted) for minimized drive between targets.

5.41.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

/XBEG=<n> .......... (X Begin)     [-5.0]

/XEND=<n> .......... (X End)     [5.0]

/XINC=<n> ........... (X Increment)     [1.0]

Enter the starting, ending, and increment in 
mm. for the grid in the X direction. The X 
begin and end values may be equal. Also, X 
end may be less than X begin.

/YBEG=<n> .......... (Y Begin)     [-5.0]

/YEND=<n> .......... (Y End)     [5.0]

/YINC=<n> ........... (Y Incremen)     [1.0]

Enter the starting, ending, and increment in 
mm. for the grid in the Y direction. The Y 
begin and end values may be equal. Also, Y 
end may be less than Y begin.

/TRANSMISSION. (Transmission mode X-Y Y-
Z)     [No]

Check for samples mount in transmission 
mode, where you wish to grid in Y & Z axes.

/APPEND.............. (Append to existing target 
list)     [No]

Check for append new grid list to end of 
existing list of targets. Unchecked will pre-
clear the target list.
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5.42 Collect > Scan > LineTargets • 
Set up line for MultiTarget list

Menu Command: Collect > Scan > LineTargets

Accelerator: None

User Level: 1

SLAM Syntax:

SCAN /LINETARGETS /XBEG=<n> 
/XEND=<n> /YBEG=<n> /YEND=<n> 
/INC=<n> /TRANSMISSION /APPEND

On systems equipped with an XYZ stage, it is 
possible to collect scans at multiple target loca-
tions. On flat samples, such as wafers, usually 
scans are taken on target positions laid out 
along a line. Instead of manually determining 
the Z-axis position of each target on the grid, 
one can predetermine the flat sample plane, 
then lay out the target locations using SCAN 
/LINETARGETS which will automatically calcu-
late the correct Z-axis value from the flat sample 
plane. See GONIOMETER /FLATSAMPLE.

5.42.1 Arguments

Each argument is listed below by its command 
line name, followed by its dialog box prompt in 
parentheses:

/XBEG=<n>.......... (X Begin)     [-5.0]

/YBEG=<n>.......... (Y Begin)     [-5.0]

Enter the starting point in mm for the line.

/XEND=<n>.......... (X End)     [5.0]

/YEND=<n>.......... (Y End)     [5.0]

Enter the ending point in mm. for the line.

/INC=<n>.............. (Y Incremen)     [1.0]

Enter the increment in mm along the line.

/TRANSMISSION. (Transmission mode X-Y Y-
Z)     [No]

Check for samples mount in transmission 
mode, where you wish to grid in Y and Z 
axes.

/APPEND ............. (Append to existing target 
list)     [No]

Check for append new grid list to end of 
existing list of targets. Unchecked will pre-
clear the target list.
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5.43 Collect > Scan > EditTargets • 
Edit parameters for MultiTarget scans

Menu Command: Collect > Scan > EditTargets

Accelerator: Ctrl+Shft+F11

User Level: 1

SLAM Syntax: SCAN /EDITTARGETS

Use this command to create, edit, or review a 
target list of sample positions that you wish to 
acquire in a single run fashion (where one 
series of contiguous frames are collected at 
each sample target position without interven-
tion).

Because target positions are unique to particu-
lar samples and to a particular mounting of that 
sample, GADDS will not automatically load any 
previous target list. However, the user can easily 
save and load target lists from within 
Collect > Scan > EditTargets using the READ 
and WRITE options. For screen editing options 
and keys, see the section under keyboard con-
ventions. Upon exiting GADDS, the current tar-
get list (if any) is saved in the file: targets.txt.

Upon entering a Collect > Scan > EditTargets 
command, GADDS displays a target list with 
current settings (a typical list follows).

Each line in the array defines one target posi-
tion. The scan series will be acquired in the 
order they appear in the array. When entering 
the individual target arguments, keep in mind 
the following special considerations:

• The RUN#, FRAME#, and #FRAMES must 
conform to the frame naming parameters. 
(See Edit > Configure > User settings com-
mand.)

• All generated filenames must be valid and 
should not create duplicate names 
(explained later in this section).

• The number of targets is limited to 2048.

• The number of runs (or lines) must not 
exceed the maximum number of runs 
allowed by RUNCHARS and RUNBASE 
(see Edit > Configure > User settings com-
mand). The default maximum number of 
runs is 36. The absolute maximum is 36*36.

With these considerations in mind, we recom-
mend that you always configure the frame nam-
ing conventions as follows:

• For 36 or fewer runs, set the “Base of Run 
#” (in the Edit > Configure > User settings 
dialog) to base 36, which will prevent the run 

Run# Frame# X Y Z

0 000 -1.0 -1.0 2.33

0 001 -1.5 -1.0 2.33

0 002 -1.0 -1.5 2.33

0 003 -1.5 -1.5 2.33
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number from wrapping from 9 to 0. The 
“Characters in Run #” should be 1. These 
are the default settings.

• For greater than 36 runs, you must set the 
“Characters in Run #” (in the Edit >Config-
ure > User settings dialog) to 2 characters. 
The “Base of Run #” can be base 10, if you 
find it more convenient and you are collect-
ing 100 or fewer targets.

Each line of the EDITTARGETS array contains 
the following items:

RUN#

This is the Run Number of the series. This is 
not actually a number, but is rather taken as 
RUNCHARS characters of ASCII text. Also, 
all characters must be valid characters to be 
used with filenames because the Run Num-
ber becomes part of the generated output 
filename. Basically, the Run Number is for-
matted and appended to the output base 
filename before the file extension. See 
Frame Naming Conventions, Edit > Config-
ure > User settings command, and Collect > 
Scan > MultiTargets command for more 
details.

FRAME# 

This is the starting frame number for the 
series. Like the Run Number, this is actually 
taken as text of length NUMCHARS rather 
than as a numeric value. The text specified 

here will be used as the extension of the first 
output frame in the series and will be incre-
mented according to the frame naming 
parameters to form the extensions of subse-
quent frames. See Frame Naming Conven-
tions, Edit > Configure > User settings 
command, and Collect > Scan > MultiTar-
gets command for more details. 

X

This is the sample X position in mm at which 
the goniometer will be positioned for this 
frame series. Entering “@” will be automati-
cally replaced with current angle setting.

Y

This is the sample Y position in mm at which 
the goniometer will be positioned for this 
frame series. Entering “@” will be automati-
cally replaced with current angle setting.

Z

This is the sample Z position in mm at which 
the goniometer will be positioned for this 
frame series. Entering “@” will be automati-
cally replaced with current angle setting.

When you select this command (> EditTargets), 
GADDS displays a “scrollable” editing window 
listing all of the targets currently in the target 
array. You can add to, delete from, or reorganize 
the list as desired by using the appropriate 
screen-editing functions.
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When you invoke the MultiTarget scan com-
mand (Collect > Scan > MultiTargets), each 
series will be acquired in the order they appear 
in the corresponding array. GADDS generates 
output filenames for each frame from the Job 
Name (in the Collect > Scan > MultiTargets dia-
log box). GADDS also generates the Run Num-
ber (given for the series in the array), the 
starting Frame# (given for the series in the 
array), the Frame# being collected, and the 
frame naming parameters (defined in the Edit > 
Configure > User settings input panel). The first 
and last generated filenames in each frame 
series must be valid. Also, the generated filena-
mes between frame series should not overlap. 
Always check the bottom status line when you 
first start a new Collect > Scan > MultiTargets to 
ensure that filenames are being synthesized the 
way you want, to avoid duplication of filenames 
during data collection (which will overwrite the 
previous file).

The EditTargets command is an interactive com-
mand, meaning that you can invoke it from the 
command line, but it will not proceed without 
user intervention. And it has no built-in com-
mand-mode time-out as with other scrolling out-
put windows. Additionally, the Collect > Scan > 
MultiTargets does not work well from script files, 
as you cannot define the run list in command 
mode. Thus, we recommend using the equiva-
lent SCAN /SINGLERUN script commands 
instead.

5.43.1 Arguments

None. Command executes immediately. This is 
an interactive command only.
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5.44 Collect > Scan > MultiTargets • 
Perform same scans on multiple tar-
gets on a single sample

Menu Command: Collect > Scan > MultiTargets

Accelerator: Ctrl+Shft+F12

User Level: 1

SLAM Syntax:

SCAN /MULTITARGETS $1
[/2THETA=<n> | /THETA1=<n>]
[/OMEGA=<n> | /THETA2=<n>] /PHI=<n> 
/CHI=<n> /AXIS=<n> /WIDTH=<n> 
/SCANTIME=<n> $2 /TITLE=<s> 
/SAMPLE=<s> /NUMSAMPLE=<s> 
/DISPLAY=<n> /REAL TIME /CLEAR 
/STARTRUN=<n> /ENDRUN=<n> 
/MODE=<n> /ROTATE /VIDEO 
/OSCILLATE=<s> /AMPLITUDE=<n> 
/AUTOZALIGN

This command allows you to collect multiple sin-
gle scan series at different target positions on 
the same sample on systems equipped with an 
XYZ stage (or multiple samples attached to the 
XYZ stage). Normally, Collect > Scan > MultiTar-
gets stores frames as an unwarped image, after 
applying the spatial correction table. It also 
applies the flood-field (intensity uniformity) cor-
rections as the counts are received.

Before invoking Collect > Scan > MultiTargets, 
you must set the parameters that are unique 

from series to series. (See Section 5.43, Collect 
> Scan > EditTargets.) Then use Collect > Scan 
> MultiTargets to define those parameters that 
are the same for all the different scan series to 
be performed and to start the scans.

When you invoke the command from the menu, 
a dialog box appears where you can view/edit 
the arguments described below as follows:

• press ENTER or click the OK button to start 
scanning.

• press ESC or click the Cancel button to 
return to the menu.

You can interrupt a scan as follows:

• press ESC to stop after finishing collecting 
the current frame (soft abort).

• press CTRL+BREAK to interrupt the scan 
(hard abort or immediate abort).

To ensure that nothing scrapes the sample sur-
face between drives, GADDS may perform a 
one mm back-drive, utilizing three separate 
drives. GADDS drives one mm down the Z-axis, 
then drives to the first target position minus one 
mm down, then drives up one mm. These extra 
drives are not performed when omega > 10 
degrees.

Unlike the MultiRuns command, a MultiTargets 
sequence interrupted by CTRL-BREAK or by a 
power failure can NOT be restarted where it left 
off with the Collect > Scan > Resume command. 
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RESUME works only with /MULTIRUN, not 
/MULTITARGETS. Instead, recollect starting at 
the scan series of the interrupted target position.

When you interrupt a scan with CTRL-BREAK, 
the goniometer returns to the starting scan 
angle of the current scan. This re-positioning is 
performed by backing up to the starting position 
minus one frame width (or +/- 0.5° maximum), 
then driving forward to the starting position. The 
same positioning technique is used when driv-
ing to the first scan in a new series. It makes the 
positioning extremely repeatable, but does 
require you to allow for an extra scan width at 
the beginning of the series when you're starting 
close to the goniometer collision limits.

SCAN /MULTITARTGETS checks for possible 
collision at the extremes of all scans before 
beginning the first run. If the first or last frame in 
a run is outside the currently set limits, the warn-
ing message

PROBABLE COLLISION IN 1ST SCAN OF 
EDITTARGETS LINE <line #>

or

PROBABLE COLLISION IN LAST SCAN 
OF EDITTARGETS LINE <line #>

is displayed, where <line #> represents the 
number of the line (starting at 1) in the 
EDITRUNS array which produced the message. 
You can choose to continue with the scans or 
quit to re-edit the run list and try again.

The current configuration is saved in the current 
default configuration file (usually GADDS._NC) 
prior to starting the first scan. This also makes 
recovery easier in the event of a power failure, 
etc.

The filename of the first frame in each series in 
generated from the Job Name described below, 
the Run# and Frame# specified for the series in 
the EDITTARGETS array, and the frame naming 
parameters set in the CONFIGURE /EDIT input 
panel. Successive names are generated by 
incrementing the filename extension, again 
according to the naming parameters in the 
CONFIGURE /EDIT panel (see CONFIGURE 
/EDIT and the separate topic “FRAME NAMING 
CONVENTIONS” for more information). Note 
that with 256 lines in the EDITTARGETS array, it 
is possible to overflow a single-character run 
number even in base 36. It is recommended that 
run numbers for the output frame files be set up 
as follows:

1. Use base 36 (0–9,A–Z) for run numbers to 
prevent them from wrapping from 9 to 0. Set 
this in the CONFIGURE /EDIT panel item 
called “Base of Run #.”

2. If you have more than 36 runs in the array, 
you MUST set the number of characters in 
the run number to at least 2. Note that for 
DOS-compatible filenames, this reduces the 
number of possible characters in the data 
set name (Job ID in the SCAN panel) to 6 (8 
characters for data set + run number). Set 
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this in the CONFIGURE /EDIT panel item 
called “Characters in Run #.” In this case, it 
should be OK to use base-10 run numbers if 
you find them more convenient.

5.44.1 Arguments

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses. These arguments are the same as 
the similar singlerun type scans and are, thus, 
explained once in Section 5.30. See that section 
for explanations.

$1 ..........................(# Frames)     [1]
/2THETA=<n> .......(2-Theta)     [0.00]
(or /THETA1=<n>..(Theta-1)     [0.00])
/OMEGA=<n> .......(Omega)     [0.00]
(or /THETA2=<n>..(Theta-2)     [0.00])
/PHI=<n>...............(Phi)     [0.00]
/CHI=<n> ..............(Chi)     [0.00]
/AXIS=<n> ............(Scan Axis #)     [2]
/WIDTH=<n>.........(Frame Widith)     [-0.25]
/SCANTIME=<n> ..(Seconds / Frame)     [1:00]

See Section 5.30.

$2 ..........................(Job Name)     [NEWFRAM]

See /NAME=<s> argument under Section 
5.30.

/TITLE=<s> ...........(Title)     [New frame]
/SAMPLE=<s> ......(Sample Name)  [Corundum]
/NUMSAMPLE=<s>(Sample Number)     [0]
/DISPLAY=<n>......(Max Display Counts)     [31]

/REAL TIME ......... (Real-time Display?)     [Yes]
/CLEAR ................ (Pre-Clear?)     [Yes]

See Section 5.30.

/STARTRUN=<n> . (Sequence # of Starting 
Run)     [1]

You can collect just a specified range of the 
scan series set up in the EDITRUNS array 
by using /STARTRUN and /ENDRUN. 
/STARTRUN specifies the first line number 
(NOT the RUN#) in the EDITRUNS array for 
which data collection is to be performed. 
The lines are numbered 1–50. The default is 
1 and valid range is 1 to 50.

/ENDRUN=<n>..... (Sequence # of Ending Run)     
[9999]

You can collect just a specified range of the 
scan series set up in the EDITRUNS array 
by using /STARTRUN and /ENDRUN. 
/ENDRUN specifies the line number (NOT 
the RUN#) in the EDITRUNS array after 
which data collection is to be terminated. 
The lines are numbered 1–50. The default is 
9999 (works the same as 50) and valid 
range is 1 to 32767.

/MODE=<n> ......... (Mode (Scan/Oscillate/
Step))    [Scan]
/ROTATE............... (Rotate Sample?)     [No]
/VIDEO ................. (Capture Video Image?)     
[no]
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/OSCILLATE=<s>..(Sample Osc)     [None]
/AMPLITUDE=<n> (Amplitude)     [0.0]

See Section 5.30.

/AUTOZALIGN ......(Auto Z Align)     [No]

See Section 5.30.

NOTE: On failure, the algorithm proceeds to the 
next target and continues collecting data.

5.45 Collect > Scan > Master • 
Place frame buffer into single
detector or dual master mode

Menu Command: Collect > Scan > Master

Accelerator: None

User Level: 3

SLAM Syntax:

SCAN /MASTER  $1  /SEND_CONFIG

SCAN /MASTER is used to select single or dual 
detector operation mode and to optionally 
update the SLAVE configuration menu.

NOTE: Invoking SCAN /MASTER on a frame 
buffer connected to a GGCS (not a SLAVE 
frame buffer) may place the GGCS in an inoper-
able mode. The most recent release of the 
GGCS software fixes this problem.

The MASTER frame buffer can function in two 
modes. The default, single detector mode mim-
ics the standard single detector system—the 
SLAVE detector becomes dead weight on the 
goniometer. Flood fields and fudicial plate 
images are collected in single detector mode. 
Alternately, the MASTER frame buffer may be 
placed in dual detector mode. Here, the MAS-
TER may send the SLAVE specific instructions: 
begin collecting data, stop collecting, save 
image, etc., as well as control the GGCS; how-
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ever, the user will only notice a few changes to 
the Scan menus.

For single run data collections on dual detec-
tors, three new options appear in the input panel 
for Scan /Singlerun. They are: 

SNAME .................(Slave Job name)     
[NEWFRA2]

Enter base name for frames.

SRUN....................(Slave Run #)     [0]

Enter data set # (base 10 or 36; see CON-
FIGURE form).

SFRAMENO..........(Slave Frame #)     [000]

Enter starting frame # (base 10 or 36; see 
CONFIGURE form).

For multirun data collections on dual detectors, 
only the job name is additional.

SNAME .................(Slave Job name)     
[NEWFRA2]

Enter base name for frames. Should be dif-
ferent from the Master's job name.

Before starting data collection, the Master will 
update the Slave with new values for: title, sam-
ple, sample number, display counts, real time, 
pre-clear, xengen output, oscillate, and name. 
Before each frame series, the Master will update 
the Slave with new values for: # of frames, time, 
set, and frame no. Finally, while collecting indi-
vidual frames, the Master communicates to the 

Slave when to prepare for next frame, queue the 
drive request, collect frame, and save frame or 
retry collecting the same frame.

The user must ensure that the frame naming 
conventions for both the Master and Slave will 
produce unique filenames. This becomes crucial 
whenever both the Master and Slave collect 
frames directly to the same host computer direc-
tory. Also, while the Master will prompt to over-
write the first frame, the Slave will always 
overwrite any existing frame files.

NOTE: This command is not available on theta-
theta systems.

5.45.1 Arguments

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses.

$1 ......................... (Num. of Detectors)     [1]

Enter number of detectors to control (not 
physical!).

/SEND_CONFIG .. (Send Config?)     [No]

Check to update configuration on Slave 
frame buffer.
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5.46 Collect > Scan > Slave • 
Place frame buffer into slave mode 
for dual detector system

Menu Command: Collect > Scan > Slave

Accelerator: None

User Level: 3

SLAM Syntax: SCAN /SLAVE

SCAN /SLAVE is used to place the frame buffer 
in “slave” mode. That is, a second frame buffer 
will take over all goniometer operations (see 
SCAN /MASTER). The MASTER frame buffer is 
attached through COM2:, while the GGCS is 
attached to COM1:. Before entering SLAVE 
mode, one should collect a flood field and fudi-
cial plate image as well as verify that the CON-
FIGURE /EDIT menu is correct (distance, angle 
offset, frame naming conventions, detector cen-
ter, etc.).

NOTE: Before running GADDS on the Master 
frame buffer, the frame buffer, which is attached 
to the GGCS, MUST BE IN SLAVE MODE.

When invoked with the SLAVE option from the 
SCAN submenu, the current bias and flood field 
settings are check, then the user is prompted for 
confirmation.

Enter SLAVE mode: are you sure?

Once in SLAVE mode, all menus disappear and 
“Frame buffer in SLAVE mode...” is printed in the 
message window. The SLAVE keyboard is dead 
with the exception of the interrupt keys: <Ctrl-
C>, <Ctrl-F>, <Ctrl-G>, and <Ctrl-Break>. The 
SLAVE frame processor accepts goniometer 
commands from the MASTER frame buffer and 
passes these through to the GGCS. When 
GGCS status reports are received, these are 
passed through to the MASTER frame buffer. 
Thus, in the default SLAVE mode, the SLAVE 
frame buffer is simply a pass through device; the 
MASTER frame buffer doesn't know or care if it's 
there. This enables the MASTER frame buffer to 
collect flood fields and fudicial plate images or to 
operate in single detector mode.

Alternately, the MASTER frame buffer may be 
placed in dual detector mode. Here, the MAS-
TER may send the SLAVE specific instructions: 
begin collecting data, stop collecting, save 
image, etc., as well as control the GGCS; how-
ever, the user will only notice a few changes to 
the Scan menus (see Scan /Master command).

Only minimal information will be displayed on 
the Slave, such as the drive, shutter and attenu-
ator status, the frame being collected, and any 
repeat frame attempts. By default, the message 
“Frame Buffer in SLAVE mode...” is displayed. 
Errors during data acquisition or frame saves 
will terminate the Slave process and typically 
create a controller timeout error on the Master 
frame buffer.
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Before exiting slave mode, terminate Gadds on 
the master frame buffer, then on the slave frame 
buffer, exit slave mode by typing <Ctrl-Break>. If 
you leave slave mode first, the master frame 
buffer will lose communication with the GGCS 
and become confused.

NOTE: This command is not available on theta-
theta systems.

5.46.1 Arguments

None. Command executes immediately after 
confirmation.

5.47 Collect > Add • Accumulate an 
area detector frame (Still frame)

Menu Command: Collect > Add

Accelerator: Ctrl+Shft+A

User Level: 1

SLAM Syntax:

ADD $1 /CLEAR /PATTERN 
/COUNTS=<n> /DISPLAY=<n> 
/REAL TIME /RESET=<n> /SHUTTER
/ATTENUATOR

Collect > Add allows you to collect a single “still” 
frame of data at a fixed goniometer position (use 
any of the Collect > Scan commands to collect 
multiple data frames). The Collect > 
Goniometer > Manual command also lets you 
acquire a still frame while operating the goniom-
eter with the manual control box. (See Collect > 
Goniometer > Manual for details.) Data are Data 
are continuously acquired until a specified 
amount of time has elapsed or a specified num-
ber of counts is reached, whichever occurs first.

You can optionally display the accumulated 
frame after it has been acquired, or update the 
display immediately as each count is recorded 
(referred to as “real-time display”). If you elect 
one of the display options, ADD also updates 
the current frame status information displayed at 
the upper right of the screen.
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The frame is not automatically written to disk. 
Use File > Save after collecting the still frame if 
you want to save the data to disk. 

When invoked from the menu, or run from the 
command line without arguments, Add displays 
a dialog box where you can view/edit the argu-
ments described below before performing the 
operation/function. Pressing the ENTER key or 
clicking the OK button starts the operation. 
Pressing ESC or the Cancel button stops the 
operation and returns you to the menu. You can 
interrupt the operation by pressing 
CTRL+BREAK.

5.47.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Max Seconds)     [30.0]

This is the maximum count time (in sec-
onds). The default value is 30; the range is 
from 1 to 65,535 seconds. Times can be 
entered in decimal seconds or in 
HH:MM:SS.SS (hours, minutes and sec-
onds) format. Data collection ends when the 
specified time has elapsed, or when the 
maximum count limit (see MAX COUNTS 
below) has been reached.

/CLEAR .................(Pre-Clear?)     [Yes]

This qualifier, when set, clears memory 
before the new data frame is collected. If it 

is not set, the new data are added to the 
image already in the frame accumulation 
memory (for example, an image left over 
from a previous ADD, LOAD, or SCAN com-
mand).

/PATTERN ............ (Test Pattern Y/N)     [No]

This qualifier, when present, draws a test 
grid into the frame accumulation memory 
prior to collecting data. The test grid is used 
for factory alignment, and consists of grid 
lines on a 64-pixel spacing; two circles, one 
with a 270-pixel radius and one with a 280-
pixel radius; and two crosses rotated to 45 
degrees, one linear cross, and one passed 
through the current flood field correction.

/COUNTS ............. (Max Counts)     
[10,000,000]

This qualifier sets an upper limit on how 
many counts may occur before data collec-
tion is terminated. When the specified num-
ber is reached the system ends the data 
collection, saving the data frame. The 
default value is 10,000,000 counts, with a 

range from 0 to 2,147,483,647 (i.e., (231)-1) 
counts. Data collection will also be termi-
nated if MAX SECONDS is reached before 
MAX COUNTS.

/DISPLAY=<n> ..... (Max Displayed Counts)     
[7]

0 = no display, otherwise # counts corre-
sponding to white on the display. The initial 
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default is 7; the allowed range is from 1 to 

106.

/REAL TIME ..........(Real-time Display?)     [Yes]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 
the frame will be automatically displayed at 
the end of the ADD if real-time display is off. 
This latter display method has no effect on 
observed data rate.

If you're not sure whether real-time display 
will affect the observed data rate signifi-
cantly at your current incident count rate, 
check the late counts in the frame header of 
a representative frame with the 
FRAME_INFO command. If the late counts 
are more than a few percent of the total 
counts, your data collection will be more effi-
cient if real-time display is turned off. In gen-
eral, you should be able to use real-time 
display for set-up and sample evaluation, 
but you should disable it during collection of 
frame series which will be used as input to 
data reduction (see the similar SCAN com-
mand display options).

While real-time display is active, you can 
change the upper display limit using the plus 
key to increase or the minus key to 

decrease the current limit by a factor of two. 
(The range is 7 to 524287). Modify the con-
trast using the left and right arrow keys. 
Modify the brightness using the up and 
down keys. Hold down the control key and 
an arrow to increase the change of contrast 
or brightness.

/RESET=<n> ........ (Reset Interval)     [0]

This qualifier specifies the number of sec-
onds before repetitive auto-clear of frame 
memory (0 = do not clear). The default value 
is 0; the range is from 1 to 65,535 seconds. 
This parameter is useful in conjunction with 
real-time display if you're looking for a 
change in intensity over time. For instance, 
if you're driving the goniometer manually to 
look for or maximize the intensity of a reflec-
tion, it helps to clear the screen frequently, 
for example every 1 second by setting the 
reset interval to 1.

/SHUTTER ........... (Open & Close Shutter)     
[No]

If present on the command line or checked 
“Y” in the dialog box, this qualifier causes 
the shutter to open at the start of Collect > 
Add, and to close at the end. Otherwise, the 
shutter stays in its current state for the dura-
tion of the exposure.
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/ATTENUATOR......(Insert Attenuator)     [No]

If present on the command line or checked 
“Y” in the dialog box, this qualifier causes 
the shutter to open with the attenuator 
inserted at the start of Collect > Add, and to 
close at the end. Otherwise, the shutter 
stays in its current state for the duration of 
the exposure.

5.48 Collect > Shutter • Open/close 
X-ray beam shutter

Menu Command: Collect > Goniometer > 
Shutter or Collect > Shutter

Accelerator: Ctrl+Shift+S

User Level: 1

SLAM Syntax:

GONIOMETER /SHUTTER  
or  SHUTTER

See Section 5.20 Collect > Goniometer > Shut-
ter.
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6.  Process Routines

6.1 Process > Flood > New • 
Acquire data to generate new flood-
field correction

Menu Command: Process > Flood > New

Accelerator: none

User Level: 3

SLAM Syntax:

FLOOD /NEW  $1  /COUNTS=<n>  
/DISPLAY=<n>  /REALTIME  /FILE=<s>  
/XMIN=<n>  /YMIN=<n>  /MAG=<n>  
/SHUTTER

This selection is used to collect a single frame of 
data for use in flood field calibration, followed by 
automatic computation and installation of a new 
flood-field correction based on that data. The 
purpose of this calibration is to produce a 
smooth detector data image from a uniform, 

spherically radiating point source, such as the 

Fe55 source supplied with the system. The cor-
rection works by slightly altering the POSI-
TIONS of counted photons according to a 
“rubber-sheet” stretching/shrinking in regions 
along the X and Y detector axes, in order to 

make the Fe55 image more uniform. It does not 
alter the recorded number of photons.

FLOOD /NEW requires you to enter the approxi-
mate source to detector distance. This distance 
should be the same as the sample to detector 
distance (since in this case, the source is at the 
sample position). Make sure to remove all 
obstructions to the detector face (such as the 
beam stop). Note that the source distance is 
measured in cm from the flat front of the detec-
tor (where the fiducial plate mounts). Usually, 
you should create a new flood-field correction 
prior to data collection on each sample, before 
the brass fiducial-plate image is taken.
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The best procedure for acquiring new flood-field 
data is to accumulate 10,000,000 counts. This 
procedure accounts for variation in activity of dif-

ferent Fe55 sources and the decrease in inten-

sity of an Fe55 source as it ages (the half-life is 
about 2.5 years). Typically, it will take about half 
an hour to accumulate 10M counts. In order to 
set up the acquisition of a new flood field in this 
manner, set the MAX SECONDS argument 
described below to a large value, for example, 

1.0x104 seconds, and set MAX COUNTS to 

1.0x107 counts.

WHEN YOU TAKE A FE55 FLOOD-FIELD 
IMAGE, BE SURE THAT THE DETECTOR 

BIAS IS SET CORRECTLY FOR FE55. Also be 
sure to reset the bias back to the correct level for 
your x-ray generator (e.g., for Cu radiation) 
when finished with flood-field and fiducial-plate 
data collection.

After running FLOOD /NEW, it is a good idea to 
take a 120 second frame to verify that you have 
a good flood-field correction. The image should 
look more uniform than a “raw” image taken with 
no flood-field correction. Remember that 
appearance of any residual lines results only 
from a bias in the POSITIONING of those 
events, not from any error in the number of 
counted photons. The SPATIAL (fiducial-plate) 
calibration will reduce or eliminate this residual 
positional error. If lines are present, they may 
have a second-order effect on integrated intensi-
ties due to resulting variation of spot shapes 

across the detector, but they are not a problem 
unless they are prominent.

FLOOD /NEW computes the flood-field table 
from an X-projection and Y-projection of the 

Fe55 image. These projection arrays are by con-
vention stored in a plottable ASCII file ending in 
a ._pj extension, in the current frame directory 
specified in the CONFIGURE /EDIT panel. The 
flood-field correction itself is stored similarly, 
except with a ._fl extension. The name of the 
current flood-field correction is shown on the 
display in the current status area at the bottom 
right of the screen. FLOOD /NEW updates this 
name when a new correction is acquired. When 
you exit FLOOD /NEW after successful comple-
tion, the new correction automatically goes into 
effect.

The /XMIN=<n>, /YMIN=<n> and /MAG=<n> 
arguments described below allow you to create 
a flood-field table that results in 512x512 or 
1024x1024 output data frames that correspond 
to a specific area of the detector rather than to 
its entire area. For this calculation, the full detec-
tor is considered to be an array of 16376 x 
16376 “bins.” Its origin is by default coincident 
with the output frame origin, and its bins are by 
default summed in 32 x 32 blocks to form a nor-
mal 512 x 512 output frame. These arguments 
allow you to choose the detector bin at which 
the output frame origin is placed, and to use a 
re-binning factor less than 32 to effectively mag-
nify a smaller detector region to cover the whole 
512 x 512 output frame. For example, /MAG=2 
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results in re-binning by 16:1 instead of 32:1. In 
general, this feature is useful only for special 
(e.g., non-crystallographic) applications, and 
these settings should be left at their defaults.

In the case of a foil, illumination by the electrical 
x-ray source causes fluorescence, creating a 
secondary point-source where the incident 
beam strikes the foil. 1-mil Fe foil is a good 
choice for a Cu source. Because the foil not only 
fluoresces, but also scatters and diffracts the 
incident beam, you need to swing the detector 
far enough in 2-theta to 1) avoid any beam-stop 
shadow or scatter and 2) eliminate any diffrac-
tion rings strong enough to affect the calibration. 
For Fe/Cu calibrations, -50 to -60 degrees 
appears to work well at a 15 cm distance with 
the 9 cm diameter detector. When illuminating 
the foil, use a collimator barrel from which all 
pinholes have been removed. This not only 
increases the intensity, but also substantially 
smooths any diffraction rings which you can't 
otherwise avoid. In order to evenly illuminate the 
detector, it is very important that the plane of the 
foil be parallel to the detector face. If your image 
does not appear uniform it is probably because 
either the foil is not centered at the instrument 
center (the foil plane must contain the 2-theta 
rotation axis) or the plane of the foil is not paral-
lel to the detector face. Prior to performing the 
calibration take an exposure with ADD to make 
sure that you're getting uniform illumination. The 
predominant low-frequency feature in the image 
should be a reasonably symmetric radial falloff. 

When the setup looks good, make sure the 
detector distance and beam center are correctly 
set in the CONFIGURE /EDIT input panel, then 
take a good 10,000,000 count flood-field image 
(with the shutter control option set to “Y”).

When invoked with the NEW option from the 
FLOOD submenu or when run from the com-
mand line without arguments, FLOOD /NEW 
displays an input panel where you can view/
modify the arguments described below. When in 
the panel, pressing the ENTER key or left 
mouse button begins collection of flood-field 
data with subsequent automatic computation 
and installation of a new flood-field correction; 
the ESC key or right mouse button returns you 
to the FLOOD submenu. You can interrupt a 
flood-field data collection in progress with the 
CTRL-BREAK key combination; however, the 
current flood-field correction at that point is 
undefined—either re-collect new data or restore 
the correction to a known state with the 
FLOOD /LOAD or FLOOD /LINEAR command.
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6.1.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Max Seconds)     [15:00]

This is the maximum count time (in sec-
onds). The default value is 900; the range is 
from 1 to 65,535 seconds. Times can be 
entered in decimal seconds or in 
HH:MM:SS.SS (hours, minutes and sec-
onds) format. Data collection ends when the 
specified time has elapsed, or when the 
maximum count limit (see MAX COUNTS 
below) has been reached.

/COUNTS=<n>......(Max Counts)     
[10,000,000]

This qualifier sets an upper limit on how 
many counts may occur before data collec-
tion is terminated. When the specified num-
ber is reached the system ends the data 
collection, saving the data frame. The 
default value is 10,000,000 counts, with a 

range from 0 to 1037 counts. Data collection 
will also be terminated if MAX SECONDS is 
reached before MAX COUNTS.

/DISPLAY=<n>......(Max Displayed Counts)     
[100]

0 = no display, otherwise # counts corre-
sponding to white on the display. The initial 

default is 100; the allowed range is from 1 to 

106.

/REALTIME........... (Realtime Display (Y/N))     
[Y]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 
the frame will be automatically displayed at 
the end of the frame collection if realtime 
display is off. This latter display method has 
no effect on observed data rate. Since the 

data rate in Fe55 source frames is not very 
high, use of /REALTIME with FLOOD /NEW 
will rarely cause any loss in counting effi-
ciency, and you can keep this set to “Y.”

While real-time display is active, change the 
upper display limit using the plus key to 
increase or the minus key to decrease the 
current limit by a factor of two. (The range is 
7 to 524287). Modify the contrast using the 
left and right arrow keys. Modify the bright-
ness using the up and down keys. Hold 
down the control key and an arrow key to 
increase the change of contrast or bright-
ness.
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/FILE= ...................(Output Filename)     
[normal._fl]

Enter the filename for the output correction 
data. By default, output files are created 
with a ._fl extension in the frame directory 
specified in the CONFIGURE /EDIT input 
panel. More specifically, the filename you 
enter here is merged with the default 
filespec Frame_root:*._fl, where Frame_root 
refers to the directory in the CONFIGURE /
EDIT panel. See CONFIGURE /EDIT for 
details on how filenames are merged. The 
intermediate X and Y projection arrays are 
stored similarly, but with a ._pj extension.

In menumode, the filename is defaulted to 
the standard naming convention of 
“SIZE_DDD._FL”, where “SIZE” is replaced 
by “0512” or “1024” and “DDD” is replaced 
by the detector distance in cm.

/XMIN=<n>............(Lower X of Corrected 
Frame)     [0]

Enter the X detector bin number to use as 
left side of corrected frame. The default 
value is 0; the range is from 0 to 16365.

/YMIN=<n>............(Lower Y of Corrected 
Frame)     [0]

Enter the Y detector bin number to use as 
bottom of corrected frame. The default value 
is 0; the range is from 0 to 16365.

/MAG=<n>............ (Magnification of Corrected 
Frame)    [1]

Enter the magnification factor of the correc-
tion table. The default value is 1; the range 
is from 1 to 32.

/SHUTTER ........... (Open & Close Shutter Y/N)     
[N]

This qualifier, if present on the command 
line or given as “Y” in the input panel, 
causes the shutter to open at the start of 
each exposure, and to close at the end. Oth-
erwise, the shutter stays in its current state 
for the duration of the command. It is used 
for the Fe foil method of generating a point 

source. Keep the shutter closed for Fe55 
sources.
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6.2 Process > Flood > Load • 
Install a disk-resident flood-field 
correction table

Menu Command: Process > Flood > Load

Accelerator: none

User Level: 2

SLAM Syntax: FLOOD /LOAD  $1 

This command is used to read and install a flood 
field calibration file that was previously created 
with FLOOD /NEW or FLOOD /REPROCESS. 
These commands compute a flood-field table 

from an X-projection and Y-projection of an Fe55 
image. By convention, each flood-field correc-
tion is stored in a plottable ASCII file ending in a 
._FL extension, in the current frame directory 
specified in the CONFIGURE /EDIT panel. 
Although you can thus keep several different 
flood-field corrections available at any time, re-
using old flood-field corrections is not really very 
useful, since your results will be better if you run 
FLOOD /NEW prior to data collection on each 
new sample.

The name of the current flood-field correction is 
shown on the display in the current status area 
at the bottom right of the screen. FLOOD /LOAD 
updates this name when the correction is 
changed.

When invoked with the LOAD option from the 
FLOOD submenu or when run from the com-
mand line without arguments, FLOOD /LOAD 

displays an input panel where you can view/
modify the arguments described below. When in 
the panel, pressing the ENTER key or left 
mouse button begins reading in the specified 
correction; the ESC key or right mouse button 
returns you to the FLOOD submenu.

6.2.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Filename)     [normal._fl]

Name of the flood-field correction to read. 
This filename is merged with the current 
frame directory specified in the CONFIG-
URE /EDIT panel before the program 
attempts to access the file. See CONFIG-
URE /EDIT for a description of how this is 
done. If you leave this field blank or specify 
a wildcard filename pattern in the FLOOD 
/LOAD input panel, the program will display 
a list of filenames from which you can select 
the desired correction (see DISPLAY /NEW 
for a more complete description of filename 
selection). The default filespec for filename 
selection is Frame_root:*._FL, where 
Frame_root is the frame directory specified 
in the CONFIGURE /EDIT panel.

The special filename of “$DEFAULT” is 
replaced with the standard naming conven-
tion of “SIZE_DDD._FL”, where “SIZE” is 
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replaced by “0512” or “1024” and “DDD” is 
replaced by the detector distance in cm.

6.3 Process > Flood > Reprocess • 
Generate a new table from previous 
projection data (on disk)

Menu Command: Process > Flood > Reprocess

Accelerator: none

User Level: 3

SLAM Syntax: FLOOD /REPROCESS  $1  $2  
/XMIN=<n> /YMIN=<n>   /MAG=<n>

This command is used to reprocess an existing 
flood field file projection file to use it with differ-
ent X, Y or magnification settings. 

The /XMIN=<n>, /YMIN=<n> and /MAG=<n> 
arguments described below allow you to create 
a flood-field table that results in 512x512 or 
1024x1024 output data frames that correspond 
to a specific area of the detector rather than to 
its entire area. For this calculation, the full detec-
tor is considered to be an array of 16376 x 
16376 “bins.” Its origin is by default coincident 
with the output frame origin, and its bins are by 
default summed in 32 x 32 blocks to form a nor-
mal 512 x 512 output frame. These arguments 
allow you to choose the detector bin at which 
the output frame origin is placed, and to use a 
re-binning factor less than 32 to effectively mag-
nify a smaller detector region to cover the whole 
512 x 512 output frame. For example, /MAG=2 
results in re-binning by 16:1 instead of 32:1. In 
general, this feature is useful only for special 
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(e.g., non-crystallographic) applications, and 
these settings should be left at their defaults.

When invoked with the REPROCESS option 
from the FLOOD submenu or when run from the 
command line without arguments, FLOOD 
/REPROCESS displays an input panel where 
you can view/modify the arguments described 
below. When in the panel, pressing the ENTER 
key or left mouse button begins computation 
installation of the new flood-field correction; the 
ESC key or right mouse button returns you to 
the FLOOD submenu.

6.3.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input Projection File-
name)     [normal._fl]

Enter the filename for input projection data 
(._PJ). The default file is NORMAL._PJ. By 
convention, these files reside in the frame 
directory specified in the CONFIGURE 
/EDIT input panel. The filename you specify 
here is merged with the default specification 
Frame_root:*._pj before the program 
attempts to access the file. See CONFIG-
URE /EDIT for details on how this merging 
is performed. If you leave this item blank, or 
specify a “wildcard” filename pattern, press-
ing the ENTER key or the left mouse button 
will display a list of the current filenames 

matching the pattern. You can choose one 
from the displayed list by moving to it with 
the arrow/page keys or mouse and pressing 
ENTER or the left mouse button. You will be 
returned to the input panel with the selected 
filename filled in. If you leave this item 
blank, it is the same as entering a *.* wild-
card pattern (which is then merged as 
described above).

$2 ......................... (Output Correction File-
name)     [zoom._fl]

Enter the filename for the output correction 
data. The default file is ZOOM._FL. conven-
tion, these files reside in the frame directory 
specified in the CONFIGURE /EDIT input 
panel. The filename you specify here is 
merged with the default specification 
Frame_root:*._fl before the program 
attempts to access the file. See CONFIG-
URE /EDIT for details on how this merging 
is performed.

/XMIN=<n> ........... (Lower X of Corrected 
Frame)     [1024]

Enter the X detector bin number to use as 
left side of corrected frame. The default 
value is 0; the range is from 0 to 4095.

/YMIN=<n> ........... (Lower Y of Corrected 
Frame)     [1024]

Enter the Y detector bin number to use as 
bottom of corrected frame. The default value 
is 0; the range is from 0 to 4095.
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/MAG=<n>.............(Magnification of Corrected 
Frame)    [2]

Enter the magnification factor of the correc-
tion table. The default value is 1; the range 
is from 1 to 8.

6.4 Process > Flood > Linear • 
Reset to linear table (i.e., no 
correction)

Menu Command: Process > Flood > Linear

Accelerator: none

User Level: 2

SLAM Syntax: FLOOD  /LINEAR

Selecting FLOOD /LINEAR with the LINEAR 
option from the FLOOD submenu or from the 
command line specifies that no flood field cali-
bration file will be used in subsequent data 
acquisition (linear scaling of event positions). 
The name of the current flood-field correction is 
shown on the display in the current status area 
at the bottom right of the screen. FLOOD /LIN-
EAR updates this name to “LINEAR.” Since you 
will in general obtain better data if a flood-field 
correction is in effect, the ADD, SPATIAL /NEW 
and SCAN commands will issue a warning if you 
start data collection with a linear flood-field cor-
rection.

FLOOD /LINEAR runs immediately without 
prompting for additional input.

6.4.1 Arguments

None. Command executes immediately.



Process Routines GADDS Software Reference Manual

6 - 10 M86-E01008

6.5 Process > Bad Pixels > Process 
• Process flood image to determine 
bad pixels

Menu Command: Process > Bad Pixels > 
Process

Accelerator: none

User Level: 3

SLAM Syntax: BADPIXELS /PROCESS  $1  $2  
$3  $4  $5  $6  $7  /LOCAL

Used by Bruker manufacturing and service engi-
neers to evaluate detector for aberrations in 
pixel sensitivity.

6.5.1 Evaluation Region

Used to determine the area of the frame to eval-
uate for bad pixels. Radius from detector center 
(not beam center) should be around 260 for 512 
frames or 520 for 1024 frames. A circle will be 
drawn at this radius, so you can visual see if 
you're off. Border pixels determine how many 
rows around the border of the frame should be 

ignored. 0=ingore only the overflow row (1st and 
last).

The algorithm will average the total pixels at 
each radius from the detector center (excluding 
border pixels) up to and including the requested 
radius, then apply a three-point smoothing func-
tion. This produces a function of the expected 
intensity versus distance from detector center. 
Alternately, one can use a local average calcu-

lated using a box (15x15 for 512 frames, 31x31 
for 1024 frames), where the center 3x3 box is 
excluded from the calculations.

6.5.2 Bad Pixel Criteria

The user enters the weakness criteria in per-
centage at the center of the detector and the 
weakness criteria at the entered radius to evalu-
ate. The program assumes the weakness crite-
ria function is linear with respect to radius from 
center. Here a pixel at the center must be within 
85% of the average intensity to be considered 
good. A pixel near the edge only needs to be 
within 75% to be considered good. At a radius of 
130, the criterion is 80%.

Hot pixels are treated similarly, with the tightest 
restriction being for the center and the least 
restrictive requirement at the edge.

6.5.3 Rejection Criteria

After all bad pixels are determined, the program 
displays the evaluation radius, the border, and 
all bad pixels as an overlay on top of the flood 
field image. Next, a table is displayed consisting 
of the bad pixels with comments and clusters 
identified. Comments include:

• >Weaker< 5% weaker than criteria

• >Hotter< 5% hotter than criteria

• >>>DEAD<<< Below 10% of expected

• >>>BURNT<<< Above 900% of expected
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Currently, we add up the total adjacent bad pix-
els around each bad pixel (number of bad neigh-
bor pixels). If this number is greater than or 
equal to the entered cluster size, then the pixel 
is identified as “Cluster.” This will not identify 
long single pixel lines of bad pixels.

6.5.4 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Radius)     [260 | 520 | 1040]

Radius, in pixels, from center pixel (not 
beam center) which defines evaluation 
region.

$2 ..........................(Border)     [0]

Border, in pixels, to exclude from evaluation 
region. 0 means to exclude only the over-
flow rows (first and last rows/columns).

$3 ..........................(Weak)     [75%]

$4 ..........................(Weak)     [85%]

Percentage of average pixel below which 
pixel is considered weak. Lower criteria is 
used for edge (at radius) and higher criteria 
is used for center. Assume linear function 
with respect to radius.

$5 ......................... (Hot)     [115%]

$6 ......................... (Hot)     [125%]

Percentage of average pixel above which 
pixel is considered hot. Lower criteria is 
used for center and higher criteria is used 
for edge (at radius). Assume linear function 
with respect to radius.

$7 ......................... (Cluster)     [3]

Number of adjacent neighbor pixels to be 
considered a cluster (excludes bad pixel in 
question). Clusters of questionable pixels at 
or above this size are flagged. Range is 0 to 
8.

/LOCAL ................ (Local average)     [Yes]

Check to calculate average pixel within a 
box of 15x15 for 512 frames, 31x31 for 1024 
frames, or 63x63 for 2048 frames. The cen-
ter 3x3 pixels are skipped as are the over-
flow rows. Uncheck to use average pixel as 
a function of radius from center.
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6.6 Process > Spatial > New • 
Acquire data and generate a new 
spatial correction

Menu Command: Process > Spatial > New

Accelerator: none

User Level: 3

SLAM Syntax:

SPATIAL /NEW $1 /COUNTS=<n> 
/DISPLAY=<n> /REALTIME /FILE=<s> 
/XENGEN /THRESHOLD=<n> /SHUTTER

This routine is used to collect a brass fiducial 
plate image at a specific detector distance and 
automatically compute and install a spatial cor-
rection for data subsequently collected at that 
distance. This will be necessary when you col-
lect a new flood field, whenever experimental 
parameters change (e.g., the detector distance 
is moved) or whenever the instrument has been 
modified (e.g., the goniometer has been 
realigned, etc.). 

Prior to running SPATIAL /NEW, make sure the 
correct value for the current sample-to-detector 
distance is entered in the CONFIGURE /EDIT 
panel (see CONFIGURE /EDIT for more infor-
mation).

The correction is computed from a frame 
acquired with the brass fiducial plate fastened to 
the front of the detector face, and with a reason-
ably uniformly radiating point source positioned 

at the center of the goniometer. The supplied 

Fe55 source is good for this purpose. You should 
acquire and compute a new spatial correction 
from such a frame before starting data collection 
on each new sample, but AFTER acquiring and 
computing a new flood-field correction (see the 
description of the FLOOD command). The sam-
ple-to-detector distance for this frame must be 
exactly the same as it will be for the frames col-
lected from the sample crystal. Usually a fiducial 
plate frame with a time cutoff of about 30 min-
utes or a count cutoff of about 100,000 counts is 
adequate (a rule-of-thumb which works well is to 
use the same collection time as for the flood-
field data plus 5 minutes, but no less than 15 
minutes).

It is essential that the brass plate be properly 
fastened to the area detector face (see figure in 
manual). The flat side of the brass plate rests 
against the detector face; the side with the 
counter-sunk holes faces the sample. Insert and 
tighten ALL the fastening screws to eliminate 
any small warpage in the fiducial plate.

Either remove the beam stop or make sure that 
the detector is swung out far enough that the 
beam stop will cast no shadow when you 
acquire the brass-plate image. Make sure that 

the Fe55 source is properly centered in the goni-
ometer, and directly faces the area detector.

The name of the spatial correction currently in 
effect is displayed in the current status area at 
the lower right of the screen. This correction is 
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used by the CURSOR commands when they 
output HKL values and “unwarped” X,Y coordi-
nates, and by all the REFL_ARRAY commands, 
which extract spots from a series of frames, 
index the diffraction pattern, and compute a 
least-squares crystal orientation matrix.

SPATIAL /NEW writes four output files, all cre-
ated in the current frame directory set in CON-
FIGURE /EDIT. The first is written in a frame file 
format. The other three output files are all ASCII 
files in PLOTSO format, which can be displayed 
with the GRAPH /FILE command.

._br File containing the brass-plate frame, 
suitable for input to data reduction pro-
grams, such as XENGEN (be sure it is 
written in the correct format).

._ix Contains the indexed fiducial spot 
positions. It can be used to restore a 
previously computed spatial correction 
when it is read in with the SPATIAL 
/LOAD command.

._if Shows the spatial correction table 
used to transform pixel X,Y coordi-
nates FROM raw to corrected values;

._it Shows the table which transforms cor-
rected coordinates TO raw coordi-
nates.

Both the ._if and ._it plot files are strictly infor-
mational—the program doesn't require them 
(since the information in them is automatically 

re-generated from the ._ix file by FRAMBO 
when SPATIAL /LOAD is used), and you can 
delete them if desired.

When invoked with the NEW option from the 
SPATIAL submenu or when run from the com-
mand line without arguments, SPATIAL /NEW 
displays an input panel where you can view/
modify the arguments described below. When in 
the panel, pressing the ENTER key or left 
mouse button begins collecting the fiducial plate 
image; the ESC key or right mouse button 
returns you to the SPATIAL submenu. You can 
interrupt acquisition in progress by pressing the 
CTRL-BREAK keyboard combination; however, 
at that point the current spatial correction is 
undefined.

Before taking data, SPATIAL /NEW displays the 
current CONFIGURE /EDIT distance and direct 
beam center on the bottom status line, and asks 
you to confirm that they are correct before pro-
ceeding. If these values don't correspond to 
your current experimental setup, run CONFIG-
URE /EDIT and correct them before acquiring 
the brass-plate data. These values are stored in 
the output frame header and are used in subse-
quent processing, for example, in the spatial 
correction. If you don't supply the correct values, 
you may not be able to auto-index your frames 
(without a lot of extra effort).

Since collected data are of higher quality when 
a flood-field correction is made, the message
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WARNING: NO FLOOD-FIELD CORREC-
TION. CONTINUE? 

is displayed on the bottom status line in the case 
where SPATIAL /NEW is run with no current 
active flood-field correction.

When acquisition of the fiducial-plate image 
begins, the progress message

COLLECTING SPATIAL CALIBRATION 
DATA...

is displayed on the bottom status line.

After the fiducial-plate image has been 
acquired, SPATIAL /NEW automatically pro-
cesses it to extract positions of the spots and, 
based on the known positions of the corre-
sponding holes in the fiducial plate, computes a 
new spatial correction. In the course of process-
ing the data, it must index the rows and columns 
(curved, due to the pincushion distortion) of fidu-
cial spots in order to match each spot with a 
hole of known position on the fiducial plate. 
When the indexing is complete, a graphic map 
of the fiducial spot positions extracted from the 
frame is drawn. This graph is actually a GRAPH 
/FILE of the plottable ASCII ._ix spatial calibra-
tion file. Dashed lines are drawn along the rows 
and columns of the indexed pattern. If a line 
jumps from one row or column to another, the 
holes have been mis-indexed, and the spatial 
calibration will not be valid.

If this happens, use the CONTRAST command 
to check the quality of the fiducial plate frame. If 

the frame looks OK, you can try re-processing it 
with SPATIAL /PROCESS with a different I/
sigma level for thresholding spots from the 
image. Another possibility is to acquire a fidu-
cial-plate image for a longer period of time. Usu-
ally, mis-indexing occurs because the I/sigma 
threshold is set too low, causing the program to 
interpret background as a spot. The default 
threshold of 4 works well on brass-plate images 
which contain 80,000 to 100,000 total counts. If 
your image contains more counts, you will prob-
ably have to raise the threshold accordingly; for 
example, if the image contains 1,000,000 counts 
(i.e., about 10 times the nominal number) 
increase the threshold by a factor of about 
sqrt(10)—12 would be a good value in this case.

6.6.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Max Seconds)     [15:00]

This is the maximum count time (in sec-
onds). The default value is 900; the range is 
from 1 to 65,535 seconds. Times can be 
entered in decimal seconds or in 
HH:MM:SS.SS (hours, minutes and sec-
onds) format. Data collection ends when the 
specified time has elapsed, or when the 
maximum count limit (see MAX COUNTS 
below) has been reached.
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Usually a fiducial plate frame with a time 
cutoff of about 30 min or a count cutoff of 
about 100,000 counts is adequate (a rule-
of-thumb which works well is to use the 
same collection time as for the flood-field 
data plus 5 minutes, but no less than 15 
minutes).

/COUNT=<n>........(Max Counts)     [150,000]

This qualifier sets an upper limit on how 
many counts may occur before data collec-
tion is terminated. When the specified num-
ber is reached the system ends the data 
collection, saving the data frame. The 
default value is 150,000 counts, with a 

range from 0 to 1037 counts. Data collection 
will also be terminated if MAX SECONDS is 
reached before MAX COUNTS.

/DISPLAY=<n>......(Max Displayed Counts)     
[100]

0 = no display, otherwise # counts corre-
sponding to white on the display. The initial 
default is 100; the allowed range is from 1 to 

106.

/REALTIME ...........(/Realtime)     [Yes]

This qualifier, when present, displays data 
as it is being collected. The display does 
require additional processing time, and will 
limit the maximum rate at which counts can 
be accumulated. If the MAX DISPLAYED 
COUNTS qualifier is given a non-zero value, 

the frame will be automatically displayed at 
the end of the frame collection if realtime 
display is off. This latter display method has 
no effect on observed data rate. Since the 

data rate in Fe55 source frames is not very 
high, use of /REALTIME with SPATIAL /
NEW will rarely cause any loss in counting 
efficiency, and you can keep this set to “Y”.

/FILE=<s>............. (Output Filename)     [brass]

Enter the base filename for the output frame 
and correction data. By default, all four out-
put files (._br, ._ix, ._if, and ._it, as 
described above) in the frame directory 
specified in the CONFIGURE /EDIT input 
panel. More specifically, the filename you 
enter here is merged with the default 
filespec Frame_root:*._br, ._ix, etc. where 
Frame_root refers to the directory in the 
CONFIGURE /EDIT panel. See CONFIG-
URE /EDIT for details on how filenames are 
merged. The default name is “brass.”

In menumode, the filename is defaulted to 
the standard naming convention of 
“SIZE_DDD._BR,” where “SIZE” is replaced 
by “0512” or “1024” and “DDD” is replaced 
by the detector distance in cm.

If you supply a filename extension here, it is 
overridden with the extensions ._br, ._ix, 
._it, and ._if as appropriate.
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If you leave this item blank, or specify a 
“wildcard” filename pattern, pressing the 
ENTER key or the left mouse button will dis-
play a list of the current filenames matching 
the pattern. You can choose one from the 
displayed list by moving to it with the arrow/
page keys or mouse and pressing ENTER 
or the left mouse button. You will be 
returned to the input panel with the selected 
filename filled in. If you leave this item 
blank, it is the same as entering a *._ix wild-
card pattern. Both filenames and patterns 
entered here are merged with the CONFIG-
URE /EDIT frame directory, as described 
above.

/XENGEN..............(Xengen Output Format 
(Y/N))     [No]

In the input panel, enter “Y” to write the out-
put ._br frame in XENGEN format (more 
correctly, in the old PCS computer format), 
“N” otherwise. The default selection is “N” 
(Bruker format). While the Bruker format will 
be used increasingly in later releases, you 
need to be sure that your data reduction 
package will support it before using it. If 
you're not sure whether your data reduction 
package will read Bruker format, it is proba-
bly safer to specify Y here.

/THRESHOLD=<n>(Threshold)     [8.0]

When extracting fiducial spots from the 
brass-plate image, the I/sigma(I) (i.e., inten-
sity divided by its standard deviation) of 

each spot is computed based on counting 
statistics. Spots with an I/sigma(I) less than 
the value specified here are considered to 
be background fluctuations and are ignored. 
The default value of 8 should be satisfactory 
for brass-plate images with 80,000 to 
100,000 total counts (see the discussion 
above). Valid range is 0.1 to 9999.

/SHUTTER ........... (Open & Close Shutter 
(Y/N))     [No]

This qualifier, if present on the command 
line or given as “Y” in the input panel, 
causes the shutter to open at the start of 
each exposure, and to close at the end. Oth-
erwise, the shutter stays in its current state 
for the duration of the command. It is used 
for the Fe foil method of generating a point 

source. Keep the shutter closed for Fe55 
sources.
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6.7 Process > Spatial > Load • 
Install a disk-resident spatial 
correction

Menu Command: Process > Spatial > Load

Accelerator: none

User Level: 2

SLAM Syntax: SPATIAL /LOAD  $1 

This command is used to read and install a spa-
tial correction that was previously created with 
SPATIAL /NEW or SPATIAL /PROCESS. These 
commands compute a spatial correction from an 

Fe55 image taken with the brass fiducial plate 
fastened to the front of the area detector. By 
convention, each spatial correction is stored in a 
plottable ASCII file ending in a ._IX extension, in 
the current frame directory specified in the 
CONFIGURE /EDIT panel. Although you can 
thus keep several different spatial corrections 
available at any time, re-using old spatial correc-
tions is really not very useful, since your results 
will be better if you run SPATIAL /NEW prior to 
data collection on each new sample. However, if 
you're analyzing frames on a different computer 
from that on which the spatial correction was 
determined, you can transfer the spatial correc-
tion by moving the ._IX file over the network (if 
necessary) and loading it with SPATIAL /LOAD.

Don't confuse SPATIAL /LOAD with the LOAD 
command on the master menu, which reads a 

detector frame instead of an ASCII spatial cor-
rection file.

The name of the current spatial correction is 
shown on the display in the current status area 
at the bottom right of the screen. SPATIAL 
/LOAD updates this name when the correction is 
changed.

When invoked with the LOAD option from the 
SPATIAL submenu or when run from the com-
mand line without arguments, SPATIAL /LOAD 
displays an input panel where you can view/
modify the arguments described below. When in 
the panel, pressing the ENTER key or left 
mouse button begins reading in the specified 
correction; the ESC key or right mouse button 
returns you to the SPATIAL submenu.

During the loading process SPATIAL /LOAD dis-
plays the progress messages:

Reading table ...

Building correction tables ...

Some computation is necessary since the ._IX 
file contains just the fiducial spot positions, not 
the correction tables themselves. Loading and 
computation of the correction tables should be 
completed in a few seconds.
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6.7.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Filename)     [brass._ix]

Name of the spatial correction to read. This 
filename is merged with the current frame 
directory specified in the CONFIGURE 
/EDIT panel before the program attempts to 
access the file. See CONFIGURE /EDIT for 
a description of how this is done. If you 
leave this field blank or specify a wildcard 
filename pattern in the SPATIAL /LOAD 
input panel, the program will display a list of 
filenames from which you can select the 
desired correction (see DISPLAY /NEW for 
a more complete description of filename 
selection). The default filespec for filename 
selection is Frame_root:*._IX, where 
Frame_root is the frame directory specified 
in the CONFIGURE /EDIT panel. 

The special filename of “$DEFAULT” is 
replaced with the standard naming conven-
tion of “SIZE_DDD._IX,” where “SIZE” is 
replaced by “0512” or “1024” and “DDD” is 
replaced by the detector distance in cm.



GADDS Software Reference Manual Process Routines

M86-E01008 6 - 19

6.8 Process > Spatial > Linear • 
Revert to linear table (i.e., no 
correction)

Menu Command: Process > Spatial > Linear

Accelerator: none

User Level: 2

SLAM Syntax: SPATIAL /LINEAR

Selecting SPATIAL /LINEAR with the LINEAR 
option from the SPATIAL submenu or from the 
command line specifies that no spatial correc-
tion will be used in subsequent data acquisition 
(linear scaling of frame X,Y coordinates). The 
name of the current spatial correction is shown 
on the display in the current status area at the 
bottom right of the screen. SPATIAL /LINEAR 
updates this name to “LINEAR.” Since you will in 
general not be able to determine HKL indices 
and crystal orientation if no spatial correction is 
in effect, the REFL_ARRAY /INDEX and /
LEASTSQ will issue a warning if you run them 
with a linear spatial correction.

SPATIAL /LINEAR runs immediately without 
prompting for additional input.

6.8.1 Arguments

None. Command executes immediately.
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6.9 Process > Spatial > Process • 
Compute correction from current 
LOADed brass plate frame

Menu Command: Process > Spatial > 
PROCESS

Accelerator: none

User Level: 3

SLAM Syntax: SPATIAL  /PROCESS $1 
/THRESHOLD=<n>

SPATIAL /PROCESS can be used to compute 
and install a spatial correction given a fiducial 
plate image collected with a previous SPATIAL 
/NEW or ADD command. The fiducial plate 
image must reside in the 32-bit frame accumula-
tion memory prior to running this command. It 
must, therefore, be left from an earlier SPATIAL /
NEW, ADD or SCAN (with no intervening com-
mands which overwrite accumulation memory 
having been issued—see the SAVE command 
description for a list of these commands), or 
must be read in with a LOAD command (not 
DISPLAY, and not SPATIAL /LOAD).

When invoked from the master menu or from the 
command line without arguments, SPATIAL /
PROCESS displays an input panel where you 
can view/edit the items described below prior to 
computing the spatial correction. If you press 
the ENTER key or left mouse button when in this 
input panel, the computation begins. The ESC 
key or right mouse button returns you from the 

input panel to SPATIAL submenu. When compu-
tation has started, SPATIAL /PROCESS dis-
plays the progress message on the bottom 
status line:

BUILDING CORRECTION TABLES...

Computations should be complete within a few 
seconds. During this process, SPATIAL /PRO-
CESS automatically extracts positions of the 
fiducial spots from the input frame and, based 
on the known positions of the corresponding 
holes in the fiducial plate, computes a new spa-
tial correction. In the course of processing the 
data, it must index the rows and columns 
(curved, due to the pincushion distortion) of fidu-
cial spots in order to match each spot with a 
hole of known position on the fiducial plate. 
When the indexing is complete, a graphic map 
of the fiducial spot positions extracted from the 
frame is drawn. This graph is actually a GRAPH 
/FILE of the plottable ASCII ._ix spatial calibra-
tion file (see below). Dashed lines are drawn 
along the rows and columns of the indexed pat-
tern. If a line jumps from one row or column to 
another, the holes have been mis-indexed, and 
the spatial calibration will not be valid.

If this happens, use the CONTRAST command 
to check the quality of the fiducial plate frame. If 
the frame looks OK, you can try re-processing it 
with SPATIAL /PROCESS with a different I/
sigma level for thresholding spots from the 
image. Another possibility is to acquire a fidu-
cial-plate image for a longer period of time. Usu-
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ally, mis-indexing occurs because the I/sigma 
threshold is set too low, causing the program to 
interpret background as a spot. The default 
threshold of 4 works well on brass-plate images 
which contain 80,000 to 100,000 total counts. If 
your image contains more counts, you will prob-
ably have to raise the threshold accordingly; for 
example, if the image contains 1,000,000 counts 
(i.e., about 10 times the nominal number) 
increase the threshold by a factor of about 
sqrt(10)—12 would be a good value in this case.

The name of the spatial correction is updated in 
the current status area at the lower right of the 
screen. This correction is used by the CURSOR 
commands when they output HKL values and 
“unwarped” X,Y coordinates, and by all the 
REFL_ARRAY commands, which extract spots 
from a series of frames, index the diffraction pat-
tern, and compute a least-squares crystal orien-
tation matrix. 

SPATIAL /PROCESS writes three output files. 
All three files are ASCII files in PLOTSO format, 
which can be displayed with the GRAPH /FILE 
command:

._ix Contains the indexed fiducial spot 
positions; can be used to restore a 
previously computed spatial correction 
when it is read in with the SPATIAL 
/LOAD command.

._if Shows the spatial correction table 
used to transform pixel X,Y coordi-
nates FROM raw to corrected values;

._it Shows the table which transforms cor-
rected coordinates TO raw coordi-
nates.

Both the ._if and ._it plot files are strictly infor-
mational—the program doesn't require them 
(since the information in them is automatically 
re-generated from the ._ix file by FRAMBO 
when SPATIAL /LOAD is used), and you can 
delete them if desired.

All three of the output files are by default created 
in the current frame directory set in the CON-
FIGURE /EDIT panel.

6.9.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Output Filename)     [brass]

Enter the base filename for the output cor-
rection data. By default, all three output files 
(._ix, ._if, and ._it, as described above) in 
the frame directory specified in the CON-
FIGURE /EDIT input panel. More specifi-
cally, the filename you enter here is merged 
with the default filespec Frame_root:*._ix, 
._if, etc. where Frame_root refers to the 
directory in the CONFIGURE /EDIT panel. 
See CONFIGURE /EDIT for details on how 
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filenames are merged. The default name is 
“brass.”

If you supply a filename extension here, it is 
overridden with the extensions ._ix, ._it, and 
._if as appropriate.

If you leave this item blank, or specify a 
“wildcard” filename pattern, pressing the 
ENTER key or the left mouse button will dis-
play a list of the current filenames matching 
the pattern. You can choose one from the 
displayed list by moving to it with the arrow/
page keys or mouse and pressing ENTER 
or the left mouse button. You will be 
returned to the input panel with the selected 
filename filled in. If you leave this item 
blank, it is the same as entering a *._ix wild-
card pattern. Both filenames and patterns 
entered here are merged with the CONFIG-
URE /EDIT frame directory, as described 
above.

/THRESHOLD=<n>(# Sigmas Spot Thresh-
old)     [8.0]

When extracting fiducial spots from the 
brass-plate image, the I/sigma(I) (i.e., inten-
sity divided by its standard deviation) of 
each spot is computed based on counting 
statistics. Spots with an I/sigma(I) less than 
the value specified here are considered to 
be background fluctuations and are ignored. 
The default value of 8 should be satisfactory 
for brass-plate images with 80,000 to 

100,000 total counts (see the discussion 
above). Valid range is 0.1 to 9999.
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6.10 Process > Spatial > Unwarp • 
Apply spatial correction and write 
unwarped output frame(s)

Menu Command: Process > Spatial > Unwarp

Accelerator: Ctrl+U

User Level: 1

SLAM Syntax:

SPATIAL /UNWARP $1 $2 $3 
/DISPLAY=<n> /NOBEAMCENTER

SPATIAL /UWWARP writes an output data 
frame generated by spatially remapping the 
specified input frame to correct the inherent 
geometrical pincushion distortion, based on the 
currently active spatial correction. Unwarping is 
important for frames which are to be processed 
by GADDS or other programs which need spa-
tially corrected input. The data reduction pro-
grams for crystallographic data perform the 
spatial correction internally, and do not require 
unwarped frames. Users of FRAMBO and 
SADIE would use SPATIAL /UNWARP only in 
special cases.

Each pixel of the corrected output frame is gen-
erated by splitting the counts of each raw pixel 
into its corresponding unwarped pixel bins. First 
the exact unwarped pixel location (real value) is 
computed from the raw pixel location (integer 
value). Next the weighting fractions (real values) 
are computed for the four surrounding unwarped 

pixel locations (integer values). Using these 
weighting fractions, the raw pixel's counts are 
divided into the four surrounding unwarped pixel 
bins, so the sum of bins equals the original raw 
pixel counts. Therefore, each count is preserved 
during the unwarping process, although some 
counts are spatially corrected off the frame 
image dimensions, so the total counts in the 
frame will decrease slightly.

An unwarped frame image is equivalent to a 
perfect flat detector. Pixels are perfect squares 
across this flat detector. There is no spatial dis-
tortion or pin cushioning effects. There is no 
variation of intensity sensitivity between pixels. 
A perfectly radiating point source will not pro-
duce a flat intensity image, but rather a slight 
decay of intensity from the detector center to the 
edges. Geometric effects cause pixels at the 
edges to represent a smaller solid angular 
region than the pixels at the detector center. 
Software processing will handle these geometric 
variations of frame pixels during integration into 
raw spectrum.

NOTE: The isotope source is not a true point 
source, but rather a Lambert radiator where the 
intensity will drop as the cosine of the incidence 
angle.
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6.10.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input Frame Filename)     
[frame1.000]

Name of first file to be unwarped. Default is 
frame1.000. If you leave this item blank, or 
specify a “wildcard” filename pattern, press-
ing the ENTER key or the left mouse button 
will display a list of the current filenames 
matching the pattern. You can choose one 
from the displayed list by moving to it with 
the arrow/page keys or mouse and pressing 
ENTER or the left mouse button. You will be 
returned to the input panel with the selected 
filename filled in. If you leave this item 
blank, it is the same as entering a *.* wild-
card pattern. Both filenames and patterns 
entered here are merged with the CONFIG-
URE /EDIT frame directory, as described 
above.

$2 ..........................(# of Frames to Process)     
[1]

Number of frames in the series to unwarp.

$3 ..........................(Output Frame Filename)     
[frame1u.000]

Name of unwarped frame file that will be 
created. The default is frame1.unw. If no 
output extension is specified, a .unw exten-

sion is used. If you leave this item blank, or 
specify a “wildcard” filename pattern, press-
ing the ENTER key or the left mouse button 
will display a list of the current filenames 
matching the pattern. You can choose one 
from the displayed list by moving to it with 
the arrow/page keys or mouse and pressing 
ENTER or the left mouse button. You will be 
returned to the input panel with the selected 
filename filled in. If you leave this item 
blank, it is the same as entering a *.* wild-
card pattern. Both filenames and patterns 
entered here are merged with the CONFIG-
URE /EDIT frame directory, as described 
above.

/NONORMALIZATION(Suppress I Normaliza-
tion (Y/N)?)     [no]

In command line mode, enter “nonormaliza-
tion” if you want the system to bypass inten-
sity normalization (described above). In the 
input panel specify “Y” at the prompt to 
bypass intensity normalization (the default 
“N” causes the system to normalize intensi-
ties).

/DISPLAY=<n> ..... (Max Display Counts)     [16]

Enter 0 if you do not want the correction 
frame displayed; any other number selects 
display and is used to set the white level of 
the display.
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/XENGEN..............(Xengen output format 
(Y/N)?)     [no]

In the input panel, enter “Y” to write the out-
put frame in XENGEN format (more cor-
rectly, in the old PCS computer format), “N” 
otherwise. The default selection is “N” 
(Bruker format). If you're going to use these 
frames as input to GADDS, use “N” here.

/NOBEAMCENTER(Suppress Unwarping Beam 
Ctr (Y/N))     [yes]

Normally, SPATIAL /UNWARP overwrites 
the X,Y beam center coordinates stored in 
the output frame header with the spatially 
corrected values. /NOBEAMCENTER sup-
presses the update of the beam center in 
the output header. In GADDS, where the 
beam center may already be unwarped, 
/NOBEAMCENTER is usually required, 
while in FRAMBO where the beam center is 
always stored in warped coordinates, this 
option is left off. The default in the input 
panel is “Y.”
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6.11 Process > Corrections > LPA

Menu Command: Process > Corrections > LPA

Accelerator: none

User Level: 2

SLAM Syntax:

CORRECTIONS  /LPA  $1  $2  $3  
/MONOCHROMATOR=<n>  /AIRMU=<n>  
/NOREVERSE

Calculate and apply Lorentz, polarization, air 
and faceplate absorption corrections, then apply 
the “reverse” corrections for Lorentz and polar-
ization to obtain intensities equivalent to a con-
ventional powder diffractometer with a 
monochromator and scintillation counter.

6.11.1 Lorentz

For a completely random sample the forward 
and reverse Lorentz corrections are identical 
and effectively cancel each other out.

6.11.2 Polarization

The forward polarization correction:

The reverse polarization correction:

where: 

2α = two-theta of monochromator

2θ = two-theta of Bragg reflection

2β = angle of reflection vector from horizon-
tal plane

6.11.3 Air and Faceplate Absorption

Be absorption calculations account for path 
length differences due to geometry. Photons at 
the center of the detector travel through a 
shorter Be path than a photon at the edge of the 
detector.

Nominal AIRMU is 0.00021 per pixel; (about .01 
per cm) assuming 8.0KV (Cu K(alpha)), 80:20 
N2:O2, 20°C, 760mm Hg, 47.5 pixels/cm. At 
detector distance of 12 cm, difference in correc-
tion across face is < 1%, so AIRMU need not be 
very precise.

For speed considerations, we will only calculate 
the LPA correction every 16 (or 32 for 1K 
frames) pixels along the detector. Intermediate 
pixel corrections may be determined using linear 
extrapolation.

[ ] θαββαββ
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6.11.4 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input Filename)   [$FRAME]

Enter filename for first input frame in series 
to process.

$2 ..........................(# of Frames to Process)   [1]

Enter # consecutive frames to process.

$3 ..........................(Output Filename)    [$NULL]

Enter filename for first output corrected 
frame.

/MONOCHROMATOR=<n>(Mono. 2T)  [26.6]

Enter monochromator 2-theta (0 if filter).

/AIRMU=<n> .........(Air Mu in Cm-1)     [0.01]

Enter air absorption coefficient.

/NOREVERSE ......(Suppress Reverse Corr. 
Y/N)     [No]

Enter Y to suppress reverse polarization 
correction.
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6.12 Process > Corrections > Fiber

Menu Command: Process > Corrections > Fiber

Accelerator: none

User Level: 2

SLAM Syntax:

CORRECTIONS /FIBER  $1  $2  $3  
/X=<n>  /Y=<n>  /Z=<n>  
/NSTEPS=<n>  /MU=<n>  /RADIUS=<n>

Calculates an absorption correction table based 
on a long fiber. It is assumed that the fiber along 
its axis is longer than the diameter of the inci-
dent beam in all orientations. In the directions 
perpendicular to the fiber axis, the fiber is 
smaller than the diameter of the incident beam.

The sample vector is expressed in goniometer 
head coordinates where when the goniometer 
angles are all zero:

+X = direction of incident beam (away from 
tube)

+Y = normal to X & Z and forms right-handed 
coordinate system

+Z = vertical direction (up)

For speed considerations, we will only calculate 
the absorption correction every 16 (or 32 for 1K 
frames) pixels along the detector. Intermediate 
pixel corrections may be determined using linear 
extrapolation.

Divide the cross section of the fiber into little 
boxes of volume dV.

Let: p = path length to box

q = path length of diffracted beam

a = incident beam angle to normal

b = diffracted beam angle to normal

µ = absorption coefficient

Then the absorption formula is given by:

6.12.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Input File)     [$FRAME]

Enter filename for first input frame in series 
to process.

$2 ......................... (# Frames to Process)     [1]

Enter # consecutive frames to process.

$3 ......................... (Output File)     [$NULL]

Enter filename for first output corrected 
frame.

iii dVbqapaeA )( +−∑= µ
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X=<n> ...................(Sample vector X)     [1]

Y=<n> ...................(Sample vector Y)     [0]

Z=<n> ...................(Sample vector Z)     [0]

Input the coordinates (in the goniometer 
head coordinate system) of the vector which 
is along the fiber axis. If the fiber axis points 
vertically, the coordinates are 0,0,1.

NSTEPS=<n> .......(Num integration steps)     
[10]

For the numerical integration algorithm input 
the number of integration steps along the 
radius. The more integration steps the 
greater the accuracy, but the longer the time 
for calculation. A value of 10 seems to give 
sufficient accuracy.

MU=<n> ................(Sample mu cm-1)     [3.0]

Enter sample mu in cm-1.

RADIUS=<n> ........(Radius cm)     [0.03]

Enter sample radius in cm.
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6.13 Process > Corrections > Plate

Menu Command: Process > Corrections > Plate

Accelerator: none

User Level: 2

SLAM Syntax:

CORRECTIONS /PLATE  $1  $2  $3  
/X=<n>  /Y=<n>  /Z=<n>  /MU=<n>  
/THICKNESS=<n>

Calculates an absorption correction table based 
on a flat plate of infinite dimensions and a given 
thickness. Thus, the flat plate is larger than the 
incident beam in all directions for all orienta-
tions.

The sample vector is expressed in goniometer 
head coordinates where when the goniometer 
angles are all zero:

+X = direction of incident beam (away from 
tube)

+Y = normal to X and Z and forms right-
handed coordinate system

+Z = vertical direction (up)

For speed considerations, we will only calculate 
the absorption correction every 16 (or 32 for 1K 
frames) pixels along the detector. Intermediate 
pixel corrections may be determined using linear 
extrapolation.

Both transmission and reflection cases are han-
dled:

t = thickness of plate

a = incident beam angle to normal

b = diffracted beam angle to normal

µ = absorption coefficient

Reflection absorption formula is given by:

Transmission absorption formula is given by:
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6.13.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$FRAME]

Enter filename for first input frame in series 
to process.

$2 ..........................(# Frames to Process)     [1]

Enter # consecutive frames to process.

$3 ..........................(Output File)     [$NULL]

Enter filename for first output corrected 
frame.

X=<n> ...................(Sample vector X)     [1]

Y=<n> ...................(Sample vector Y)     [0]

Z=<n> ...................(Sample vector Z)     [0]

Input the coordinates (in the goniometer 
head coordinate system) of the vector which 
is normal to the face of the sample and 
points away from the incident beam side of 
the sample. If the x-ray beam is along the 
normal to the sample face the vector coordi-
nates are equal to 1,0,0.

MU=<n> ................(Sample mu cm-1)     [3.0]

Enter sample mu in cm-1.

THICKNESS=<n> .(Thickness cm)     [0.03]

Enter sample thickness in cm.
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6.14 Process > Smooth > Average • 
Smooth image with 3x3 boxcar 
average filter

Menu Command: Process > Smooth > Average

Accelerator: none

User Level: 1

SLAM Syntax: SMOOTH  /AVERAGE

Two filters are provided to smooth frame 
images: average will compute the average pixel 
value, while median determines the median 
pixel value. Both filters utilize a 3x3 pixel box 
and ignore any pixel outside the active pixel map 
(see MASK).

6.14.1 Arguments

None. Command executes immediately.

6.15 Process > Smooth > Median • 
Smooth image with 3x3 median filter

Menu Command: Process > Smooth > Median

Accelerator: none

User Level: 1

SLAM Syntax: SMOOTH  /MEDIAN

Two filters are provided to smooth frame 
images: average will compute the average pixel 
value, while median determines the median 
pixel value. Both filters utilize a 3x3 pixel box 
and ignore any pixel outside the active pixel map 
(see MASK).

6.15.1 Arguments

None. Command executes immediately.
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6.16 Process > Smooth > Convolve • 
Smooth image by convolving with 
average neighborhood

Menu Command: Process > Smooth > 
Convolve

Accelerator: none

User Level: 1

SLAM Syntax: SMOOTH  /CONVOLVE  $1

The average neighborhood filter will smooth the 
frame image using the average pixel value of a 
user-defined pixel box. This filter will ignore the 
active pixel map (see MASK).

6.16.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Width in pixels)     [2]

Enter width in pixels of neighborhood to 
convolve.
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6.17 Process > Calibrate • Calibrate 
detector distance, angle and center 
using a known standard

Menu Command: Process > Calibrate

Accelerator: none

User Level: 1

SLAM Syntax:

CALIBRATE $1 /MININT=<n> 
/DISTANCE=<n> $2 /ANGLE=<n> $3  
/X=<n> /Y=<n> $4 /AUTO /NOERASE 
/DELAY=<n>

Precise detector position cannot be determined 
by visual methods, but require taking a frame of 
a known standard and comparing the measured 
Debye-Scherrer rings with the calculated lines 
based on various detector positional parame-
ters. Detector distance, swing angle, and beam 
center are determined permitting accurate 2-
theta and chi values from other routines, such 
as INTEGRATE.

The calibration process requires a data frame(s) 
using a known standard sample. Typically 
corundum, quartz, or silicon is used but in prac-
tice any material exhibiting high stability and 
extremely sharp diffraction lines can be used. 
Also uses GADDS$SYSTEM:profile.pro for defi-
nition of the lineshape function.

In interactive mode, the standard d/I file is 
superimposed over the collected data frame. 

The user can move the detector position or the 
detector beam position using either the cursor 
keys or the trackball. On a fully calibrated frame, 
the calculated Debye-Sherrer lines will precisely 
center over the lines in the data frame.

Toggling between the calibration of the detector 
distance and the swing angle and the calibration 
of the detector center is performed by pressing 
the “C” key. As an aid during interactive calibra-
tion the detector distance, swing angle, and cen-
ter are continuously displayed and updated on 
the screen.

To align the detector center, move the calibration 
lines until a calculated and a measured Debye-
ring exhibit the same center. This is most easily 
accomplished with an on-axis data frame; if the 
data frame is off-axis, it can still be done by 
examining the offset at the extreme top and bot-
tom of the display.

To align the detector distance, use the cursor 
keys to expand or contract the calibration lines. 
To align the swing angle, use the cursor keys to 
shift left or right the calibration lines. When cor-
rectly calibrated, all calculated Debye-rings will 
be precisely centered over the corresponding 
lines in the data frame.

Upon exiting CALIBRATE, the detector parame-
ter offsets are stored in the frame header. Gen-
eral GADDS users cannot change the 
calibration and must inform their administrator if 
the calibration is off. If the user is an administra-
tor, this message appears: “Update configura-
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tion with new distance and beam center?” 
Answer yes to update the current configuration 
with the new distance and beam center. All 
future frames collected will have the calibrated 
values in their frame headers. Thus, CALI-
BRATE should be performed before any data 
frames are collected in order that the proper 
experimental values are written into the frame 
header.

If the detector distance was changed, the SPA-
TIAL /UNWARP file will be wrong. You will need 
to reload the brass image, set the correct detec-
tor distance, and reprocess the spatial correc-
tion tables. Secondly, the beam center stored in 
the configuration setup is already unwarped, so 
during any SPATIAL /UNWARP command, set 
the /NOBEAMCENTER switch to “Y.”

6.17.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Standard filename / PDF2 
number)     [corundum.std]

The input standard calibration file contains a 
list of d-spacing's and intensities for a given 
standard. GADDS is supplied with files for 
alumina, corundum, quartz, and silicon. 
Other standards can be added with a text 
editor. By default the directory 
GADDS$SYSDATA: (or SAXI$SYSTEM:) is 
used unless otherwise specified. If avail-

able, the JCPDS PDF2 CD-ROM may be 
read for any standard -- simply enter a valid 
PDF number separated by “ “, “,” or “-”.

/MININT=<n>........ (Minimum relative 
intensity)     [5]

When reading the standard file, all lines 
below this threshold will be ignored and thus 
not displayed.

/DISTANCE=<n> .. (Sample to detector distance 
(cm))     [from frame header]

The default is read from the frame header. 
This distance is measured from the sample 
to the front of the detector face and is read 
off the scale below the detector.

$2 ......................... (Delta distance)     [0.05]

Enter the interactive sensitivity for calibrat-
ing the detector distance in cm.

/ANGLE=<n>........ (Detector swing angle)    
[from frame header]

Default from frame header. Detector swing 
angle in degrees.

$3 ......................... (Delta angle)     [0.00]

Enter the interactive sensitivity for calibrat-
ing the detector angle in degrees.
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/X=<n> ..................(Detector X-center)     [from 
frame header]

Default from frame header. Detector X-cen-
ter in pixels. The origin is taken as lower left 
corner of frame.

/X=<n> ..................(Detector Y-center)     [from 
frame header]

Default from frame header. Detector Y-cen-
ter in pixels.

$4 ..........................(Delta XY)     [0.5]

Enter the interactive sensitivity for calibrat-
ing the detector center in pixels. Range 0.1 
to 10.

/AUTO ...................(Auto mode Y/N)     [No]

Enter “Y” to perform an automatic least 
squares fit of the calibration standard 
line(s), prior to allowing user manipulation of 
the detector parameters.

/DELAY=<n> .........()     [0.0]

Delay before exiting routine—useful in demo 
loops only.

/NOERASE ...........()     [No]

Prevents erasing the calibration lines when 
exiting routine.
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7.  Analyze Routines

7.1 Analyze > Cursors > Box • 
Display statistics of pixels in 
rectangular region

Menu Command: Analyze > Cursors > Box

Accelerator: F5

User Level: 1

SLAM Syntax: CURSORS /BOX  $1 $2 $3 $4 
/DELAY=<n> /NOERASE

When invoked from the menu or when run from 
the command line without arguments, Analyze > 
Cursor > Box starts running directly (that is, 
there are no dialog items to be filled in). A rect-
angular cursor (from 2x2 to 1024x1024 pixels in 
size) appears in the detector frame area and 
can be dragged or resized by the mouse or key-
board arrow keys. Several quantities (described 
below) related to the currently displayed frame 
at the cursor position are displayed in real time 

at the right of the image. Pressing ENTER or 
releasing the left mouse button exits, returning 
you to the menu. Pressing ESC or clicking the 
right mouse button while dragging with the left 
button pressed toggles between position-
change mode and size-change mode. The cen-
ter of the box remains fixed while the size 
changes as the mouse is dragged.

When moving or sizing the box with the arrow 
keys, you can press CTRL along with an arrow 
key to move in increments ten times larger than 
for the unmodified arrow key.

Analyze > Cursor > Box can also be used to 
clear or fill the area inside a box to a specified 
value, allowing you to edit the image with basic 
functions. When you press BACKSPACE (or 
DELETE on the extended, middle keypad), 
GADDS displays a dialog box where you can 
enter a value to set all pixels inside the box cur-
sor. The default value is equal to the current 
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background estimate based on pixel values 
around the box perimeter. Pressing ESC or 
clicking the Cancel button exits without chang-
ing pixel values. After editing the image, you can 
use the SAVE command to write the image in 
edited form. This function can be performed only 
interactively (that is, there is no way to clear the 
area in a box with command-line commands).

By providing arguments on the command line, 
you can direct GADDS to compute the box cal-
culations once at one specified position, after 
which control returns immediately to the com-
mand line.

The line weight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

Analyze > Cursor > Box can display HKL indices 
corresponding to the centroid position based on 
the current orientation matrix (that is, the one 
refined in the last ReflArray > LeastSquares 
command). These values will be correct for 
frames acquired in Bruker-format frames in gen-
eral. They will probably NOT be correct for XEN-
GEN–1.3-format frames, because those frames 
do not contain the required setting angle infor-
mation.

If logging is turned on (see the File > LogFile 
command for more information), the quantities 
computed for the final position of the cursor prior 
to exiting the command are written to the output 
logfile. If scripting is enabled (see File > Script-
File), a non-interactive CURSOR command cor-
responding to the final cursor position is written 
to the output script file.

The SLAM command arguments are:

$1

The X-coordinate of the lower left of the box 
in pixels. The range is from 0 to framesize-1; 
default value is 256.

$2

The Y-coordinate of the lower left of the box 
in pixels. The range is from 0 to framesize-1; 
default value is 256.

$3

The width of the box in pixels. The range is 
from 0 to framesize-1; default is 32.

$4

The height of the box in pixels. The range is 
from 0 to framesize-1; default is 32.

/DELAY=<n>

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
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on screen long enough for the user to dis-
cern its position.

/NOERASE:

Suppresses erasure of the cursor on exit. 
Since the cursors are drawn by “toggling” 
the sense of the screen pixels, you can 
erase a cursor left from a /NOERASE by 
reissuing the command with the same 
parameters. The Analyze > Clear command 
is another way to erase cursors left over 
from /NOERASE options.

The following output statistics are displayed on 
screen in real time, and are also written to the 
log file if applicable.

XY-PIXEL:

X- and Y-center of box in pixels (range from 
0 to framesize-1), with the origin (X=0,Y=0) 
at the lower left of the screen.

WIDTH,HT:

Width and height of the box, in pixels.

TOTALCTS:

Sum of the pixel values in rectangular box.

MAXIMUM:

Largest pixel value in the box.

MEAN:

The average of the pixels values contained 
in the box.

I:

Integrated intensity (minus background). 
The background is computed as the aver-
age of the points on the perimeter of the 
box, excluding all points which are more 
than 3 standard deviations above the mean.

SIGMA(I):

Standard deviation of integrated intensity, I.

I/SIGMA(I):

Integrated intensity divided by its standard 
deviation.

BACKGND:

Average of points on perimeter of box, 
excluding those points which are more than 
3 standard deviations above the mean.

XCNTROID:

Raw X-coordinate of centroid of intensity, in 
pixels. 

YCNTROID:

Raw Y-coordinate of centroid of intensity, in 
pixels.

HKL:

If an orientation matrix is in effect, the HKL 
indices corresponding to the intensity cen-
troid are also output.
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XUNWARPED:

If a spatial correction is in use, this provides 
spatially corrected X-coordinate of centroid 
of intensity, otherwise this value will be iden-
tical to the raw coordinate.

YUNWARPED:

If a spatial correction is in use, this provides 
spatially corrected raw Y-coordinate of cen-
troid of intensity, otherwise this value will be 
identical to the raw coordinate.
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7.2 Analyze > Cursors > Circle • 
Display position and size of circular 
cursor

Menu Command: Analyze > Cursors > Circle

Accelerator: F6

User Level: 1

SLAM Syntax: CURSORS /CIRCLE $1 $2 $3 
/DELAY=<n> /NOERASE 

When invoked from the menu or when run from 
the command line without arguments, Analyze > 
Cursor > Circle starts running directly; that is, 
there are no dialog items to be filled in. A circu-
lar cursor with a small crosshair at its center 
appears in the detector frame area, and can be 
dragged or resized under control of the mouse 
and/or keyboard arrow keys. Several quantities 
(described below) related to the currently dis-
played frame at the cursor position are displayed 
in real time at the right of the image. Pressing 
ENTER or releasing the left mouse button exits, 
returning you to the menu. Pressing ESC or 
clicking the right mouse button while dragging 
with the left button pressed toggles between 
position-change mode and size-change mode 
where the center of the circle remains fixed 
while the size changes as the mouse is 
dragged.

When moving or sizing the circle with the arrow 
keys, you can press CTRL along with an arrow 

key to move in increments ten times larger than 
for the unmodified arrow key.

When used in this interactive manner, the com-
mand also provides the option to drive the spin-
dle axis (phi) to a position where the zero-layer 
diffraction circle represented by the circular cur-
sor would be at its closest approach to the direct 
beam center. Pressing the D key drives the phi 
axis to the new position (as indicated in the 
prompt on the bottom status line).

By providing arguments on the command line, 
you can direct the cursor computations to be 
performed once at a single specified position, 
after which control returns immediately to the 
command line.

The line weight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

If logging is turned on (see the File > LogFile 
command for more information), the quantities 
computed for the final position of the cursor prior 
to exiting the command are written to the output 
logfile. If scripting is enabled (see File > Script-
File), a non-interactive CURSOR command cor-
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responding to the final cursor position is written 
to the output script file.

The SLAM command arguments are:

$1

X-coordinate of the circle center in pixels. 
The range is from 0 to framesize-1; default 
value is 256.

$2

Y-coordinate of the circle center in pixels. 
The range is from 0 to framesize-1; default 
value is 256.

$3

Radius of the circle in pixels. The range is 
from 0 to framesize/2 -1; the default value is 
64.

/DELAY=<n>

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on screen long enough for the user to dis-
cern its position.

/NOERASE

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 

the same parameters. The Analyze > Clear 
command is another way to erase cursors 
left over from /NOERASE options.

The following output statistics are displayed on 
screen in real time and written to the logfile, if 
applicable (for non-pole figure frames).

COUNTS:

Value of pixel at circle center.

XY-PIXEL:

X- and Y-coordinate of circle center (range 
from 0 to framesize-1), with origin (X=0, 
Y=0) being located at lower left of screen.

R-PIXELS:

Radius of circle in pixels.

DEGREES:

Radius of circle in degrees 2-theta.

ANGSTRMS:

Radius of circle, Angstroms.

The following output statistics are related to 
single-crystal alignment based on the posi-
tion of a circle of reflections arising from a 
zero-level layer. 

LAYER(A):

Spacing of planes normal to the beam axis 
in the case where the crystal is aligned, so 
that the diffracted layer circles are centered 
on the direct beam.
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SPINDLE:

Change required to phi axis position (in 
degrees) to move the diffracted layer circle 
to the beam center

PARA-ARC:

Change required to goniometer head arc 
which is parallel to the detector plane at 2-
theta,omega,phi = (0,0,0), in order to move 
the diffracted layer circle to the beam center.

PERP-ARC:

Change required to goniometer head arc 
which is perpendicular to the detector plane 
at 2-theta,omega, phi = (0,0,0), in order to 
move the diffracted layer circle to the beam 
center.

Pole figures are handled slightly differently. On 
these frames, the following output statistics are 
displayed on-screen in real time, and are also 
written to the logfile if applicable.

XY-Pixel:

Coordinates of current pixel (range from 0 to 
{framesize-1}), with origin (0,0) being 
located at lower left of screen.

R-Pixels:

Radius in pixels.

TotalCts:

Sum of counts on/inside circular box.

Maximum:

Maximum pixel intensity in circular box.

Mean:

Average counts in circular box.

I:

Integrated intensity (minus background). 
The background is computed as the aver-
age of the points on the perimeter of the 
box, excluding all points which are more 
than three standard deviations above the 
mean.

sigma(I):

Standard deviation of integrated intensity.

I/SimgaI:

Integrated intensity divided by its standard 
deviation.

Backgnd:

Average of points on perimeter of box, 
excluding those points which are more than 
three standard deviations above the mean.

XCntroid:

Raw X-coordinate of centroid of intensity.
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YCntroid:

Raw Y-coordinate of centroid of intensity.

ACntroid:

Alpha angle of centroid of intensity.

BCntroid:

Beta angle of centroid of intensity.
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7.3 Analyze > Cursors > Pixel • 
Show pixel positions and values in 
displayed frame

Menu Command: Analyze > Cursors > Pixel

Accelerator: F7

User Level: 1

SLAM Syntax: CURSORS /PIXEL $1 $2 
/DELAY=<n> /NOERASE /DUMP

When invoked from the menu, or run from the 
command line without arguments, Analyze > 
Cursor > Pixel starts directly (that is, it requires 
no additional input). A full-window crosshair cur-
sor appears in the detector frame area and can 
be dragged under control of the mouse and/or 
keyboard arrow keys. Several quantities 
(described below), related to the currently dis-
played frame at the cursor position, are dis-
played in real time to the right of the image. 
Pressing ENTER or releasing the left mouse 
button exits, returning you to the menu. Pressing 
ESC or clicking the right mouse button while 
dragging with the left button pressed displays a 
pixel map of the numeric values in memory for a 
17- x 17-pixel grid centered on the pixel under 
the crosshair. In this display, a box appears 
around the value for the pixel currently under-
neath the cursor. Pressing any mouse or key-
board key returns to display of the data frame 
and the interactive crosshair cursor.

When dragging the cursor with the arrow keys, 
you can press CTRL along with an arrow key to 
move in increments ten times larger than for the 
unmodified arrow key.

By providing arguments on the command line, 
you can direct the cursor computations to be 
performed once at a single specified position, 
after which control returns immediately to the 
command line.

The line weight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

Analyze > Cursor > Pixel can display HKL indi-
ces corresponding to the cursor position based 
on the current orientation matrix (that is, the one 
refined in the last Crystal > LS command). 
These values will be correct for frames acquired 
with GADDS and for Bruker-format frames in 
general. They will probably NOT be correct for 
XENGEN–1.3-format multi-wire detector frames 
acquired data collection software earlier than 
FRAMBO V2, since those frames do not contain 
the required setting angle information.

If logging is turned on (see the File > LogFile 
command for more information), the quantities 
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computed for the final position of the cursor prior 
to exiting the command are written to the output 
logfile, as are the values in each 17x17 numeric 
pixel dump. If scripting is enabled (see File > 
ScriptFile), a non-interactive CURSOR com-
mand corresponding to the final cursor position 
is written to the output script file.

The SLAM command arguments are:

$1

X-coordinate in pixels of the crosshair cen-
ter. The range is from 0 to framesize-1; 
default value is 256.

$2

Y-coordinate in pixels of the crosshair cen-
ter. The range is from 0 to framesize-1; 
default value is 256.

/DELAY=<n>

Specifies a time interval to wait before eras-
ing the cursor and returning control to the 
program. This is for use in scripts, where it 
is desirable for the cursor to remain on 
screen long enough for the user to discern 
its position.

/NOERASE

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 

the same parameters. The Analyze > Clear 
command is another way to erase cursors 
left over from /NOERASE options.

/DUMP

Displays a 17x17 numeric pixel dump at the 
specified position. If a keyboard or mouse 
event doesn't occur within the time-out value 
set in the Edit > Config dialog, the display 
times out and control is returned to the com-
mand line. If logging is enabled, a copy of 
the pixel dump is also written to the logfile.

The following output statistics are displayed on 
screen in real time and are also written to the 
logfile if applicable (for non-pole figures).

XY-PIXEL:

X- and Y-coordinates of current pixel (range 
from 0 to framesize-1), with origin (0,0) 
being located at lower left of screen.

COUNTS:

Counts at current pixel.

XUNWARPED:

If a spatial correction is in use, provides 
spatially corrected X-coordinate of current 
pixel, otherwise this value will be identical to 
the raw coordinate.
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YUNWARPED:

If a spatial correction is in use, provides 
spatially corrected Y-coordinate, otherwise 
this value will be identical to the raw coordi-
nate.

DX:

Signed pixel X-distance from frame center.

DY:

Signed pixel Y-distance from frame center.

2-THETA:

2-Theta value at current pixel.

ANGSTRMS:

Resolution in Angstroms at current pixel.

HKL:

If an orientation matrix is in effect, the HKL 
indices corresponding to the current pixel 
are also output.

Pole images are handled slightly differently. On 
these frames, the following output statistics are 
displayed on-screen in real time and are also 
written to the logfile if applicable.

XY-PIXEL:

X- and Y-coordinates of current pixel (range 
from 0 to framesize-1), with origin (0,0) 
being located at lower left of screen.

COUNTS:

Counts at current pixel.

DX:

Signed pixel X-distance from frame center.

DY:

Signed pixel Y-distance from frame center.

Alpha:

Alpha angle at current pixel.

Beta:

Beta angle at current pixel.

Chi:

Chi angle at current pixel (90-alpha).

Phi:

Phi angle at current pixel (same as beta).
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7.4 Analyze > Cursors > Vector • 
Measure distances on displayed 
frame

Menu Command: Analyze > Cursors > Vector

Accelerator: F8

User Level: 1

SLAM Syntax: CURSORS/VECTOR  $1 $2 $3 
$4 /DELAY=<n> /NOERASE

When invoked from the menu or when run from 
the command line without arguments, Analyze > 
Cursor > Vector starts running directly (that is, 
there are no dialog items to be filled in). A rub-
ber-band vector cursor appears in the detector 
frame area and can be dragged or resized by 
the mouse or keyboard arrow keys. Several 
quantities (described below) related to the cur-
rently displayed frame at the cursor position are 
displayed in real time at the right of the image. 
Pressing ENTER or releasing the left mouse 
button exits, returning you to the menu. Pressing 
ESC or clicking the right mouse button while 
dragging with the left button pressed toggles 
between position-change mode and size-
change mode. The vector origin remains 
anchored while the vector endpoint moves as 
the mouse is dragged.

When moving or sizing the cursor with the arrow 
keys, you can press CTRL along with an arrow 
key to move in increments ten times larger than 
for the unmodified arrow key.

By providing arguments on the command line, 
you can direct GADDS to compute the calcula-
tions once at one specified position, after which 
control returns immediately to the command 
line.

The line weight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

If logging is turned on (see the File > LogFile 
command for more information), the quantities 
computed for the final position of the cursor prior 
to exiting the command are written to the output 
logfile. If scripting is enabled (see File > Script-
File), a non-interactive CURSOR command cor-
responding to the final cursor position is written 
to the output script file.

The SLAM command arguments are:

$1

The X-coordinate of the lower left of the vec-
tor in pixels. The range is from 0 to frame-
size-1; default value is 256.
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$2

The Y-coordinate of the lower left of the vec-
tor in pixels. The range is from 0 to frame-
size-1; default value is 256.

$3 

The X-length of the vector pixels. The range 
is from 0 to framesize-1; default value is 32.

$4 

The Y-length of the vector in pixels. The 
range is from 0 to framesize-1; default value 
is 1.

/DELAY=<n>

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on screen long enough for the user to dis-
cern its position.

/NOERASE

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 
the same parameters. The Analyze > Clear 
command also provides a way to erase cur-
sors left over from /NOERASE options.

The following output statistics are displayed on 
screen in real time and are also written to the 
logfile if applicable (for non-pole figure frames).

ORIGCNTS:

Counts of pixel at vector origin.

ENDPCNTS:

Counts of pixel at vector endpoint.

X-ORIGIN:

X-coordinate of origin in pixels.

Y-ORIGIN:

Y-coordinate of origin in pixels.

X-ENDPT:

X-coordinate of endpoint in pixels.

Y-ENDPT:

Y-coordinate of endpoint in pixels.

X-MIDPT:

X-coordinate of midpoint in pixels.

Y-MIDPT:

Y-coordinate of midpoint in pixels.

D-PIXEL:

Length of vector in pixels.

D-~DEG:

Length of vector in degrees 2-theta.
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D-~ANGST:

Length of vector in Angstroms.

CHI:

Angle of the vector in degrees clockwise 
from -χ. This chi convention is the same as 
that used on a 4-circle diffractometer (that 
is, if the vector origin is at the beam center 
and the endpoint is on a reflection taken at 
omega=0, chi is the angle to which you 
would drive the goniometer to place the 
reflection in the equatorial plane on the pos-
itive 2-theta side).

Pole image frames are handled slightly differ-
ently. On these frames, the following output sta-
tistics are displayed on-screen in real time and 
are also written to the logfile if applicable.

ORIGCNTS:

Counts of pixel at vector origin.

ENDPCNTS:

Counts of pixel at vector endpoint.

X-ORIGIN:

X-coordinate of origin in pixels.

Y-ORIGIN:

Y-coordinate of origin in pixels.

X-ENDPT:

X-coordinate of endpoint in pixels.

Y-ENDPT:

Y-coordinate of endpoint in pixels.

A-Origin:

Alpha angle at origin in degrees.

A-Endpt:

Alpha angle at end point in degrees.

B-Origin:

Beta angle at origin in degrees.

B-Endpt:

Beta angle at end point in degrees.

Angle:

Angle between two poles in degrees.
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7.5 Analyze > Cursors > Conic • 
Display constant two-theta conic 
lines

Menu Command: Analyze > Cursors > Conic

Accelerator: F9

User Level: 1

SLAM Syntax: CURSORS  /CONIC  $1 $2 
/DELAY=<n> /NOERASE

When invoked with the CONIC option from the 
CURSORS submenu or when run from the com-
mand line without arguments, CURSORS 
/CONIC starts running directly (that is, there are 
no items to be filled in on an input panel). A full-
window conic cursor appears in the detector 
frame area, and can be moved under control of 
the mouse and/or keyboard arrow keys. Press-
ing the ENTER key or left mouse button exits, 
returning you to the CURSORS submenu. 

The lineweight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

By providing arguments on the command line, 
you can direct the CURSORS /CONIC computa-

tions to be performed once at a single specified 
position, after which control returns immediately 
to the command line.

If logging is turned on (see the LOGFILE com-
mand for more information), the quantities com-
puted for the final position of the cursor, prior to 
exiting the command, are written to the output 
logfile. If scripting is enabled (again, see LOG-
FILE), a non-interactive CURSORS command 
corresponding to the final cursor position is writ-
ten to the output script file.

The SLAM command arguments are:

$1

X-coordinate in pixels of the crosshair cen-
ter. The range is from 0 to {framesize-1}; 
default value is 256.

$2

Y-coordinate in pixels of the crosshair cen-
ter. The range is from 0 to {framesize-1}; 
default value is 256.

/DELAY=<n>

Specifies a time interval to wait before eras-
ing the cursor and returning control to the 
program. This is for use in scripts, where it 
is desirable for the cursor to remain on-
screen long enough for the user to discern 
its position.
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/NOERASE

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 
the same parameters. The CLEAR com-
mand also provides a way to erase cursors 
left over from /NOERASE options.

The following output statistics are displayed on-
screen in real time and are also written to the 
logfile if applicable.

Counts:

Counts at current pixel.

XY-Pixel:

X- and Y-coordinate of current pixel (range 
from 0 to {framesize-1}), with origin (X=0, 
Y=0) being located at lower left of screen.

2-Theta:

2-Theta value of Debye-Scherrer ring at cur-
rent pixel.

Angstrms:

Angstroms of Debye-Scherrer ring at cur-
rent pixel.

Lambda:

Wavelength used to calculate statistics.

Chi:

Chi value of Debye-Scherrer ring at current 
pixel.
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7.6 Analyze > Cursors > Rbox • 
Display statistics of pixels in rotated 
rectangular region

Menu Command: Analyze > Cursors > Rbox

Accelerator: F10

User Level: 1

SLAM Syntax: CURSORS /RBOX  $1 $2 $3 $4 
/DELAY=<n> /NOERASE

When invoked with the RBOX option from the 
CURSORS submenu or when run from the com-
mand line without arguments, CURSORS 
/RBOX starts running directly (that is, there are 
no items to be filled in on an input panel). A rect-
angular cursor from 2x2 to 128x128 pixels in 
size appears in the detector frame area, and can 
be moved or re-sized under control of the 
mouse and/or keyboard arrow keys. Pressing 
the ENTER key or left mouse button exits, 
returning you to the CURSORS submenu. 
Pressing the ESC key or the right mouse button 
toggles between position-change mode and 
size-change mode where the lower left corner of 
the box remains anchored while the upper left 
corner moves under mouse control.

Analyze > Cursor > RBox can also be used to 
clear or fill the area inside a box to a specified 
value, allowing you to edit the image with basic 
functions. When you press BACKSPACE (or 
DELETE on the extended, middle keypad), 
GADDS displays a dialog box where you can 

enter a value to set all pixels inside the box cur-
sor. The default value is equal to the current 
background estimate based on pixel values 
around the box perimeter. Pressing ESC or 
clicking the Cancel button exits without chang-
ing pixel values. After editing the image, you can 
use the SAVE command to write the image in 
edited form. This function can be performed only 
interactively (that is, there is no way to clear the 
area in a box with command-line commands).

The lineweight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion. 

By providing arguments on the command line, 
you can direct the CURSORS /RBOX computa-
tions to be performed once at a single specified 
position, after which control returns immediately 
to the command line.

If logging is turned on (see the LOGFILE com-
mand for more information), the quantities com-
puted, for the final position of the cursor prior to 
exiting the command, are written to the output 
logfile. If scripting is enabled (again, see LOG-
FILE), a non-interactive CURSORS command 
corresponding to the final cursor position is writ-
ten to the output script file.
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The SLAM command arguments are:

$1  

The X-coordinate of the center of the box in 
pixels. The range is from 0 to {framesize-1}; 
default value is 256.

$2 

The Y-coordinate of the center of the box in 
pixels. The range is from 0 to {framesize-1}; 
default value is 256.

$3 

The width of the box in pixels. The range is 
from 0 to 128; default value is 32.

$4 

The height of the box in pixels. The range is 
from 0 to 128; default value is 32.

/DELAY=<n>

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on-screen long enough for the user to dis-
cern its position.

/NOERASE

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 

the same parameters. The CLEAR com-
mand also provides a way to erase cursors 
left over from /NOERASE options.

The following output statistics are displayed on-
screen in real time and are also written to the 
logfile, if applicable.

X-Center:

X-center of box in pixels (range from 0 to 
{framesize-1}), with origin (X=0) being 
located at lower left of screen.

Y-Center:

Y-center of box in pixels (range from 0 to 
{framesize-1}), with origin (Y=0) being 
located at lower left of screen.

Width:

Width of box in pixels.

Height:

Height of box in pixels.

TotalCts:

Sum of counts in rectangular box.

I:

Integrated intensity (minus background). 
The background is computed as the aver-
age of the points on the perimeter of the 
box, excluding all points which are more 
than three standard deviations above the 
mean.
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Sigma(I):

Standard deviation of integrated intensity.

I/SigmaI:

Integrated intensity divided by its standard 
deviation.

Backgnd:

Average of points on perimeter of box, 
excluding those points which are more than 
three standard deviations above the mean.

XCntroid:

Raw X-coordinate of centroid of intensity.

YCntroid:

Raw Y-coordinate of centroid of intensity.

Maximum:

Maximum pixel intensity in box.

Mean:

Average counts in box.

HKL:

If an orientation matrix is in effect, the HKL 
indices corresponding to the current inten-
sity centroid are also outputted.

XUnwarped:

If a spatial correction is in use, provides 
spatially corrected X-coordinate of centroid 

of intensity, otherwise this value will be iden-
tical to the raw coordinate.

YUnwarped:

If a spatial correction is in use, provides 
spatially corrected raw Y-coordinate of cen-
troid of intensity, otherwise this value will be 
identical to the raw coordinate.
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7.7 Analyze > Graph > File • 
Plot points from ASCII disk file

Menu Command: Analyze > Graph > File

Accelerator: Ctrl+G

User Level: 1

SLAM Syntax: GRAPH /FILE $1 
/QUADRANT=<n> /PRECLEAR  /NOCLEAR

This command plots X-Y graphs from disk-resi-
dent data. The input data file must be in 
PLOTSO format (as described in Appendix D). 
Examples of PLOTSO-format files generated by 
GADDS are ._pj flood-field projection intermedi-
ate data files, ._fl flood-field corrections, ._ix 
spatial correction files, ._if raw-to-corrected spa-
tial maps, and ._it corrected-to-raw spatial 
maps.

When invoked from the menu, or run from the 
command line without arguments, Analyze > 
Graph > File displays a dialog box where you 
can view/edit the arguments described below. 
Pressing ENTER or clicking the OK button starts 
graphing the specified file. Pressing ESC or the 
Cancel button returns you to the menu.

See PLOTSO file format, Section 13.7, for more 
details.

7.7.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Plot Data Filename)     
[plotso.dat]

This parameter specifies the ASCII data file 
to graph. This filename is merged with the 
current data directory specified in the 
Project > New/Edit/Copy dialog before the 
program attempts to access the file. If you 
leave this field blank or enter a wildcard file-
name pattern in the Analyze > Graph > File 
dialog, the program will display a list of file-
names from which you can select the 
desired data file.

/QUADRANT=<n> (Quadrant)     [0]

This argument specifies whether you want 
the graph to appear covering the entire 
frame display area (enter “0”), or just one of 
the four quadrants (enter 1 through 4 as 
appropriate). The default value is 0 (full 
frame window). Quadrants are 0 = full win-
dow, 1 = lower left, 2 = lower right, 3 = upper 
left, and 4 = upper right.

/PRECLEAR......... (Pre-Clear (Y/N) ?)     [No]

This argument specifies whether or not the 
screen area (full or quadrant, depending on 
the value of /QUADRANT above) will be 
cleared before the plot is drawn. In menu 
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mode, check this item to clear the memory, 
or leave it unchecked if you want to superim-
pose the graph on the data frame currently 
displayed in that quadrant.

/NOCLEAR............(No-Clear (Y/N) ?)     [No]

This parameter is specified to suppress 
clearing any previously displayed graph. It is 
useful in script mode to add labels to graphs 
before printing.
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7.8 Analyze > Graph > Vector • 
Plot profile along vector in displayed 
frame

Menu Command: Analyze > Graph > Vector

Accelerator: Ctrl+V

User Level: 1

SLAM Syntax: GRAPH /VECTOR $1 $2 $3 $4 
/QUADRANT=<n> /DELAY=<n> /NOERASE

When you want to plot an arbitrary one-pixel 
slice through the data use the GRAPH /VEC-
TOR sub-command. This routine is similar to 
CURSOR /VECTOR in that you use the cursor 
to identify the beginning and ending points of a 
rubber-band vector. When you've specified the 
path of interest in this manner, GRAPH /VEC-
TOR then plots the intensities of all pixels 
located along that path as an X-Y graph of inten-
sity (counts) versus position along the line (in 
pixels).

When invoked with the VECTOR option from the 
GRAPH submenu or when run from the com-
mand line without arguments, GRAPH /VEC-
TOR displays an input panel where you can 
view/modify the arguments described below. 
When in the panel, pressing the ENTER key or 
left mouse button begins interactive path-of-
interest selection with a vector cursor. The ESC 
key or right mouse button returns you from the 
input panel to the GRAPH submenu.

When you're selecting a path-of-interest, a rub-
ber-band like vector cursor appears in the detec-
tor frame area, and can be moved or re-sized 
under control of the mouse and/or keyboard 
arrow keys. Pressing the ENTER key or left 
mouse button plots the graph of pixel value ver-
sus distance along the vector, then exits, return-
ing you to the GRAPH submenu. Pressing the 
ESC key or right mouse button toggles between 
position-change mode and size-change mode 
where the vector origin remains anchored while 
the vector endpoint moves under mouse control. 
If you want to exit without computing and draw-
ing the graph, use CTRL-BREAK.

The lineweight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

By providing arguments on the command line, 
you can direct the GRAPH /VECTOR computa-
tions and graphing to be performed once at a 
single specified position, after which control 
returns immediately to the command line.

If logging is turned on (see the LOGFILE com-
mand for more information), the quantities com-
puted, for the final position of the cursor prior to 
exiting the command, are written to the output 
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logfile. If scripting is enabled (again, see LOG-
FILE), a non-interactive GRAPH /VECTOR com-
mand corresponding to the final cursor position 
is written to the output script file.

7.8.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(X-Origin)     [256]

The X-coordinate of the lower left of the box 
defining the region-of-interest in pixels. The 
range is from 0 to {framesize-1}; default 
value is 256.

$2 ..........................(Y-Origin)     [256]

The Y-coordinate of the lower left of the box 
defining the region-of-interest in pixels. The 
range is from 0 to {framesize-1}; default 
value is 256.

$3 ..........................(X-Length)     [32]

The X-length of the vector pixels. The range 
is from 0 to {framesize-1}; default value is 
32.

$4 ..........................(Y-Length)     [0]

The Y-length of the vector in pixels. The 
range is from 0 to {framesize-1}; default 
value is 1.

/QUADRANT=<n> (Quadrant)     [0]

This parameter specifies whether you want 
the graph to appear covering the entire data 
frame (enter “0”), or just one of the four 
quadrants (enter 1 through 4 as appropri-
ate). The default value is 0 (full frame win-
dow). Quadrants are 0 = full window, 1 = 
lower left, 2 = lower right, 3 = upper left, and 
4 = upper right.

/DELAY=<n>......... ()     [0.0]—available in com-
mand mode only

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on-screen long enough for the user to dis-
cern its position.

/NOERASE........... ()     [No]—available in com-
mand mode only

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 
the same parameters. The CLEAR com-
mand also provides a way to erase cursors 
left over from /NOERASE options.

The following output statistics are displayed on-
screen in real time, and are also written to the 
logfile if applicable.
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OrigCnts:

Counts of pixel at vector origin.

EndpCnts:

Counts of pixel at vector endpoint.

X-Origin:

X-coordinate of origin in pixels.

Y-Origin:
Y-coordinate of origin in pixels.

X-Endpt:

X-coordinate of endpoint in pixels.

Y-Endpt:

Y-coordinate of endpoint in pixels.

X-Midpt:

X-coordinate of midpoint in pixels.

Y-Midpt:

Y-coordinate of midpoint in pixels.

D-Pixel:

Length of vector in pixels.

D-~Deg:

Length of vector in degrees 2-theta.

D-~Angst:

Length of vector in Angstroms.

Chi:

Angle of the vector in degrees clockwise 
from -X. This chi convention is the same as 
that used on a 4-circle diffractometer (i.e., if 
the vector origin is at the beam center and 
the endpoint is on a reflection taken at 
omega=0, chi is the angle to which you 
would drive the goniometer to place the 
reflection in the equatorial plane on the pos-
itive 2-theta side).
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7.9 Analyze > Graph > Rocking • 
Plot rocking curve profile through 
frames

Menu Command: Analyze > Graph > Rocking

Accelerator: Ctrl+R

User Level: 1

SLAM Syntax:

GRAPH /ROCKING $1 $2 $3 $4 
/QUADRANT=<n> 
/FRAME_HALFWIDTH=<n> 
/DELAY=<n> /NOERASE

GRAPH/ROCKING draws a graph in the frame 
window (or a specified quadrant) called a “rock-
ing curve.” This graph shows integrated intensity 
in a specified rectangular area as a function of 
scan angle, and requires that you have a contig-
uous series of frames available for input.

Before running GRAPH /ROCKING, a set of 
data frames must be collected with fixed step 
size in any angle. Use the DISPLAY or LOAD 
command to display the central frame about 
which you want the rocking curve to be com-
puted. Then, invoke GRAPH /ROCKING, where 
a rectangular cursor like the one in CURSORS 
/BOX is used to select a region within the data 
frame. From this, the program calculates the 
background-subtracted intensity for that region 
in each frame and displays the results in a plot 
of intensity versus scan angle. Background-sub-

tracted intensity is determined in the same way 
as for CURSORS /BOX. The background is 
computed as the average of the points on the 
perimeter of the box, excluding those points 
which are more than 3 standard deviations 
above the mean. You have to be careful to 
choose the correct box size, since in some 
cases the X,Y centroid of the x-ray reflection 
may change as a function of scan angle.

While the program attempts to graph the inten-
sity as a function of scan angle, if the scan angle 
is not available in the frame headers, or if the 
frame headers all contain the same value for the 
scan angle, the intensity is graphed as a func-
tion of frame number.

When invoked with the ROCKING option from 
the GRAPH submenu or when run from the 
command line without arguments, GRAPH 
/ROCKING displays an input panel where you 
can view/modify the arguments described 
below. When in the panel, pressing the ENTER 
key or left mouse button begins interactive 
region-of-interest selection with a box cursor. 
The ESC key or right mouse button returns you 
from the input panel to the GRAPH submenu.

When you're selecting a region-of-interest, a 
rectangular cursor from 2x2 to 128x128 pixels in 
size appears in the detector frame area, and can 
be moved or re-sized under control of the 
mouse and/or keyboard arrow keys. The arrow 
keys are very useful for precise, 1-pixel adjust-
ments. Pressing the ENTER key or left mouse 
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button computes the intensity versus scan angle 
curve and draws it on the screen. Pressing the 
ESC key or right mouse button toggles between 
position-change mode and size-change mode 
where the lower left corner of the box remains 
anchored while the upper left corner moves 
under mouse control. If you want to exit without 
computing and drawing the graph, use CTRL-
BREAK. Depending on the number of frames 
specified with the FRAME HALFWIDTH argu-
ment (see below) the rocking curve can take 
several seconds to compute.

The lineweight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

By providing arguments on the command line, 
you can direct the GRAPH /ROCKING computa-
tions and graphing to be performed once at a 
single specified position, after which control 
returns immediately to the command line.

If logging is turned on (see the LOGFILE com-
mand for more information), the quantities com-
puted, for the final position of the cursor prior to 
exiting the command, are written to the output 
logfile. If scripting is enabled (again, see LOG-
FILE), a non-interactive GRAPH /ROCKING 

command corresponding to the final cursor posi-
tion is written to the output script file.

7.9.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (X-Origin)     [256]

The X-coordinate of the lower left of the box 
defining the region-of-interest in pixels. The 
range is from 0 to {framesize-1}; default 
value is 256.

$2 ......................... (Y-Origin)     [256]

The Y-coordinate of the lower left of the box 
defining the region-of-interest in pixels. The 
range is from 0 to {framesize-1}; default 
value is 256.

$3 ......................... (Width)     [16]

The width of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 16.

$4 ......................... (Height)     [16]

The height of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 16.

/QUADRANT=<n> (Quadrant)     [0]

This parameter specifies whether you want 
the graph to appear covering the entire data 
frame (enter “0”), or just one of the four 
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quadrants (enter 1 through 4 as appropri-
ate). The default value is 0 (full frame win-
dow). Quadrants are 0 = full window, 1 = 
lower left, 2 = lower right, 3 = upper left, and 
4 = upper right.

/FRAME_HALFWIDTH=<n>(Frame Half-
width)     [5]

Enter the number of frames ON EACH SIDE 
of the currently displayed frame to be 
included in the rocking curve. Make sure 
that you don't exceed the number of frames 
actually available for processing in either 
direction.

/DELAY=<n> .........()     [0.0]—available in com-
mand mode only

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on-screen long enough for the user to dis-
cern its position.

/NOERASE ...........()     [No]—available in com-
mand mode only

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 
the same parameters. The CLEAR com-

mand also provides a way to erase cursors 
left over from /NOERASE options.

The following output statistics are displayed on-
screen, and are also written to the logfile if appli-
cable.

X-Center:

X-center of box in pixels (range from 0 to 
{framesize-1}), with origin (X=0) being 
located at lower left of screen.

Y-Center:

Y-center of box in pixels (range from 0 to 
{framesize-1}), with origin (Y=0) being 
located at lower left of screen.

Width:

Width of box in pixels.

Height:

Height of box in pixels.

TotalCts:

Sum of counts in rectangular box in the cen-
tral frame

I:

Integrated intensity (minus background) in 
the central frame. The background is com-
puted as the average of the points on the 
perimeter of the box, excluding all points 
which are more than three standard devia-
tions above the mean.
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Sigma(I):

Standard deviation of integrated intensity in 
the central frame. This value is not dis-
played if an orientation matrix is available. 
Instead, the HKL's area displayed.

I/SigmaI:

Integrated intensity divided by its standard 
deviation in the central frame. This value is 
not displayed if an orientation matrix is avail-
able. Instead, the HKL's area displayed.

I (3D):

3D integrated intensity for the spot. This is 
the sum of the 2D background-subtracted 
intensity on each of the component frames.

I3D/Sig:

The 3D integrated intensity divided by its 
standard deviation

XCntroid:

The X-centroid, in pixels, of the 3D inte-
grated intensity

YCntroid:

The Y-centroid, in pixels, of the 3D inte-
grated intensity

ZCntroid:

The Z-centroid, of the 3D integrated inten-
sity. This is the centroid in the direction 
through the frames, and is expressed in 

degrees, or in frame number if the scan 
angle wasn't available in the component 
frame headers. That is, the units are the 
same as those indicated for the X-axis on 
the resulting graph.

HKL:

If an orientation matrix is in effect, the HKL 
indices corresponding to the 3D intensity 
centroid are also output.
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7.10 Analyze > Graph > Poster • 
Interactively annotate displayed 
graph or frame

Menu Command: Analyze > Graph > Poster

Accelerator: None

User Level: 1

SLAM Syntax: GRAPH /POSTER 

Analyze > Annotate has several subcommands 
to produce hard-copy plots and pictures suitable 
for poster presentation and publishing. When 
you choose this command from the menu, the 
program displays a right-cascading submenu 
containing these subcommands. When you 
invoke GRAPH /POSTER from the command 
line, no qualifiers are allowed, a submenu of dia-
log buttons will appear and the program will wait 
until you've made a selection. GRAPH 
/POSTER will execute only in interactive mode.

The subcommands are summarized in the fol-
lowing table:

Each subcommand is described below.

Menu Command: Analyze > Annotate > New

SLAM Syntax: GRAPH /POSTER /NEW

This command clears the annotation list in 
preparation for starting a new series of 
annotations. Subsequent annotation com-
mands are appended to the annotation list, 
which can then be saved with the Analyze > 
Annotate > Save subcommand. A saved 
annotation list can later be redisplayed with 
the Analyze > Graph > File command.

Menu Command: Analyze > Annotate > Edit

SLAM Syntax: GRAPH /POSTER /EDIT

All poster annotations are stored in a 
PLOTSO file format. These commands can 
be edited with a simple screen editor. After 

Menu SLAM Description

New /NEW Start a new list of annota-
tions

Edit /EDIT Edit current annotations

Clear /CLEAR Clear annotations within 
rectangular region

Save /SAVE Save annotations to 
PLOTSO file

Text /TEXT Position text on screen

Label /LABEL Label spots/peaks using d, 
I, hkl, TH, 2T, etc

Arrow /DRAW /
ARROW

Draws an arrow pointer

Box /DRAW /
BOX

Draws a rectangular box

Circle /DRAW /
CIRCLE

Draws an ellipse

Dot /DRAW /
DOT

Draws a single dot

Line /DRAW /
LINE

Draws a straight line

Style /DRAW /
STYLE

Switches between solid and 
dashed line styles
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exiting the /EDIT command, the graphics 
plane is erased and the poster annotations 
are redrawn.

NOTE: This will erase all graphs displayed prior 
to invoking the Analyze > Annotate command.

Menu Command: Analyze > Annotate > Clear

SLAM Syntax: GRAPH /POSTER /CLEAR

This command will clear a rectangular 
region. When selected, a cross hair cursor 
is visible. Position the crosshairs at a corner 
of the box to be erased. Anchor the corner 
by pressing ENTER or the left mouse but-
ton. (The cross hairs will disappear and be 
replaced with a rectangular box with one 
corner being the anchored point just 
selected and the other corner at the current 
cursor position). Press ENTER or the left 
mouse button to position the second box 
corner. The box is erased, and a crosshair 
cursor appears for positioning the next box. 
Pressing ESC or the right mouse button will 
return you to the menu.

Menu Command: Analyze > Annotate > Save

SLAM Syntax: GRAPH /POSTER /SAVE

This command will save all poster annota-
tions in a PLOTSO file on disk. It can later 
be loaded with the Analyze > Graph > File 
command.

Menu Command: Analyze > Annotate > Text

SLAM Syntax: GRAPH /POSTER /TEXT

Text can be positioned and sized interac-
tively using GRAPH /POSTER /TEXT. When 
selected, the user must first enter the text 
string to be displayed. All trailing spaces are 
removed from the text string, but leading 
spaces are retained. A box cursor will 
appear reflecting the size of the text string. 
Position the box cursor, then press ENTER 
or the left mouse button. The box will disap-
pear, the text will be drawn, and the user will 
be prompted to enter the next text string to 
drawn. Pressing ESC or the right mouse 
button will return you to the draw menu. 
Pressing <F1> or the center mouse button 
will toggle the size mode. Moving the cursor 
left (or right) will increase (or decrease) the 
size of the text string in the x direction. Up 
and down cursor movement will change the 
height of the text. Press ENTER or the left 
mouse button to anchor the text size.

Menu Command: Analyze > Annotate > Label

SLAM Syntax: GRAPH /POSTER /LABEL

Spots or peaks can be labeled interactively 
with this command. When selected, a dialog 
box will appear. Choose what type of data to 
retrieve (either theta's, 2-theta's, d's, I's, or 
hkl's); and choose where to retrieve that 
data from (either the frame, raw trace, or 
peaks table). And choose what marker char-
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acter to use to highlight the data. A 
crosshairs cursor will appear and the 
selected label will appear within the mes-
sage window. Pressing ENTER or the left 
mouse button will draw the marker at the 
current cursor position and automatically 
send the user into the /TEXT option to edit, 
position, and size the label to be drawn (see 
Analyze > Annotate > Text). Pressing ESC 
or the right mouse button will return you to 
the menu without drawing the label.

Menu Command: Analyze > Annotate > Arrow

SLAM Syntax: GRAPH /POSTER /DRAW 
/ARROW

This command will draw an arrow. When 
selected, a cross hair cursor is visible. Posi-
tion the crosshairs at the point of the arrow 
to be drawn, press ENTER or the left mouse 
button. The crosshairs will disappear and be 
replaced with an arrow with the point 
anchored at the selected position and the 
tail at the current cursor position. Position 
the tail of the arrow, press ENTER or the left 
mouse button. The arrow is drawn, and a 
crosshair cursor appears for positioning the 
next arrow. Pressing ESC or the right 
mouse button will return you to the menu.

Menu Command: Analyze > Annotate > Box

SLAM Syntax: GRAPH /POSTER /DRAW /BOX

This command will draw a rectangular box. 
When selected, a crosshair cursor is visible. 
Position the crosshairs at a corner of the 
box to be drawn. Anchor the corner by 
pressing ENTER or the left mouse button. 
The crosshairs will disappear and be 
replaced with a rectangular box with one 
corner being the anchored point just 
selected and the other corner at the current 
cursor position. Position the second box cor-
ner, press ENTER or the left mouse button. 
The box is drawn, and a crosshair cursor 
appears for positioning the next box. Press-
ing ESC or the right mouse button will return 
you to the menu.

Menu Command: Analyze > Annotate > Circle

SLAM Syntax: GRAPH /POSTER /DRAW /CIR-
CLE

This command will draw an ellipse. When 
selected, a crosshair cursor is visible. Posi-
tion the crosshairs at the center of the 
ellipse and press ENTER or the left mouse 
button to anchor this spot. The crosshairs 
will disappear and be replaced with an 
ellipse drawn with the center anchored and 
the width and height selected from the cur-
sor. Move the mouse until the width and 
height are correct, press ENTER or the left 
mouse button. The ellipse is drawn, and a 
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crosshair cursor appears for positioning the 
ellipse center. Pressing ESC or the right 
mouse button will return you to the menu.

Menu Command: Analyze > Annotate > Dot

SLAM Syntax: GRAPH /POSTER /DRAW /DOT

This command will draw a single dot. When 
selected, a crosshair cursor is visible. Posi-
tion the crosshairs at the position to draw 
the dot and press ENTER or the left mouse 
button. A dot is drawn and the crosshairs 
will remain for positioning the next dot. 
Pressing ESC or the right mouse button will 
return you to the menu.

Menu Command: Analyze > Annotate > Line

SLAM Syntax: GRAPH /POSTER /DRAW /LINE

This command will draw a line segment 
between two points. When selected, a 
crosshair cursor is visible. Position the 
crosshairs at the start of the line segment 
and anchor the line segment by pressing 
ENTER or the left mouse button. The 
crosshairs will disappear and be replaced 
with a line segment between the anchored 
point and the current cursor position. Posi-
tion the line segment end point and press 
ENTER or the left mouse button. The line 
segment is drawn, and a crosshair cursor 
appears for positioning the next line. Press-
ing ESC or the right mouse button will return 
you to the menu.

Menu Command: Analyze > Annotate > Style

SLAM Syntax: GRAPH /POSTER /DRAW 
/STYLE

This command will toggle between drawing 
objects with a solid line style to drawing the 
objects with a dashed line style. The current 
style is displayed in the DRAW submenu 
title bar when using the SLAM command 
line.
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7.11 Analyze > Graph > HKL • Plot 
HKL curve profile through frames

Menu Command: Analyze > Graph > HKL

Accelerator: None

User Level: 2

SLAM Syntax: GRAPH /HKL $1 /QUAD-
RANT=<n> $2 $3 /DELAY=<n> /NOERASE

GRAPH/HKL draws a graph in the frame win-
dow (or a specified quadrant) called an “hkl 
curve.” This graph shows integrated intensity in 
a specified rectangular area as a function of hkl 
position, and requires that you have a contigu-
ous series of frames collected using SCAN 
/HKL, available for input.

7.11.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(1st frame)     [hkl01.000]

The name of the first frame in the HKL scan 
series.

/QUADRANT=<n>.(Quadrant)     [0]

This parameter specifies whether you want 
the graph to appear covering the entire data 
frame (enter “0”), or just one of the four 
quadrants (enter 1 through 4 as appropri-
ate). The default value is 0 (full frame win-

dow). Quadrants are 0 = full window, 1 = 
lower left, 2 = lower right, 3 = upper left, and 
4 = upper right.

$2 ......................... (Width)     [32]

The width of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 32.

$3 ......................... (Height)     [32]

The height of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 32.

/DELAY=<n>......... ()    [0.0]—available in com-
mand mode only

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on-screen long enough for the user to dis-
cern its position.

/NOERASE........... ()    [No]—available in com-
mand mode only

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 
the same parameters. The CLEAR com-
mand also provides a way to erase cursors 
left over from /NOERASE options.
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7.12 Analyze > Graph > Psi • Plot Psi 
curve profile through frames

Menu Command: Analyze > Graph > Psi

Accelerator: None

User Level: 2

SLAM Syntax: GRAPH /PSI $1 
/QUADRANT=<n> $2 $3  /DELAY=<n>  
/NOERASE

GRAPH/PSI draws a graph in the frame window 
(or a specified quadrant) called an “psi curve.” 
This graph shows integrated intensity in a speci-
fied rectangular area as a function of psi angle, 
and requires that you have a contiguous series 
of frames collected using SCAN /PSI, available 
for input.

7.12.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(1st frame)     [psi01.000]

The name of the first frame in the PSI scan 
series.

/QUADRANT=<n>.(Quadrant)     [0]

This parameter specifies whether you want 
the graph to appear covering the entire data 
frame (enter “0”), or just one of the four 
quadrants (enter 1 through 4 as appropri-
ate). The default value is 0 (full frame win-

dow). Quadrants are 0 = full window, 1 = 
lower left, 2 = lower right, 3 = upper left, and 
4 = upper right.

$2 ......................... (Width)     [32]

The width of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 32.

$3 ......................... (Height)     [32]

The height of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 32.

/DELAY=<n>......... ()    [0.0]—available in com-
mand mode only

Specifies a time interval in seconds to wait 
before erasing the cursor and returning con-
trol to the program. This is for use in scripts, 
where it is desirable for the cursor to remain 
on-screen long enough for the user to dis-
cern its position.

/NOERASE........... ()    [No]—available in com-
mand mode only

Suppresses erasure of the cursor on exit. 
Note that the cursors are drawn by “tog-
gling” the sense of the screen pixels; thus, 
you can erase a cursor left from a 
/NOERASE by reissuing the command with 
the same parameters. The CLEAR com-
mand also provides a way to erase cursors 
left over from /NOERASE options.
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7.13 Analyze > Graph > Write • 
Write generated curve to file

Menu Command: Analyze > Graph > Write

Accelerator: None

User Level: 1

SLAM Syntax:

INTEGRATE  /WRITE  $1  /FILENAME=<s>  
/FORMAT=<s>  /APPEND  /SCALE=<n>

See Peaks > Integrate > Write command.

7.14 Analyze > Percent Crystal > 
External • Amorphous region 
external from Bragg peak

Menu Command: Analyze > Percent Crystal > 
External

Accelerator: None

User Level: 1

SLAM Syntax: PER_CRYSTAL /EXTERNAL 
$1 $2 $3 $4 $5 $6 $7 $8 /COMPTON

PER_CRYSTAL provides a quick method to esti-
mate a percent crystallinity using frame data. 
Frames must have air scatter (and sample 
holder scattering) effects subtracted out to 
obtain meaningful results.

Calculates percent crystallinity within an user-
defined region. The user must specify both an 
amorphous only region and a crystalline plus 
amorphous region. These regions should not 
overlap. Pixels are summed in both regions.

With the separation of amorphous and crystal-
line contributions, the percent crystallinity calcu-
lation is simply,

where:

%C=percent crystallinity
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Ic=intensity in crystalline region

Ia=intensity in amorphous region

7.14.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..... (Two-Theta Begin for Amorphous Reg) 
[10]

$2 ..... (Two-Theta End for Amorphous Reg)    
[20]

$3 ..... (Chi Begin for Amorphous Region)     [0]

$4 ..... (Chi End for Amorphous Region)     [30]
Defines conic region for amorphous region.

$5 ..... (Two-Theta Begin for Crystalline Reg)   
[10]

$6 ..... (Two-Theta End for Crystalline Region) 
[20]

$7 ..... (Chi Begin for Crystalline Region)     [60]

$8 ..... (Chi End for Crystalline Region)     [90]
Defines conic region for crystalline region.

/COMPTON...........(Compton Scattering Y/N)     
[No]
Enter “Y” to subtract the Compton scattering 
effect from the amorphous result. The Compton 
scattering must be previously calculated using 
PER_CRYSTAL /COMPTON.
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7.15 Analyze > Percent Crystal > 
Internal • Amorphous region 
surrounds Bragg peak

Menu Command: Analyze > Percent Crystal > 
Internal

Accelerator: None

User Level: 1

SLAM Syntax: PER_CRYSTAL /INTERNAL $1 
$2 $3 $4 $5 $6 $7 $8 /LINEAR /COMPTON

PER_CRYSTAL provides a quick method to esti-
mate a percent crystallinity using frame data. 
Frames must have air scatter (and sample 
holder scattering) effects subtracted out to 
obtain meaningful results.

Calculates percent crystallinity within a user-
defined region. The user must specify both an 
amorphous region and an internal crystalline 
region. Pixels along the 2-theta boundaries of 
the crystalline region are integrated to obtain a 
left and right background value. The amorphous 
contribution under the crystalline region is 
assumed to be a linear function in 2-theta and 
constant in chi.

An alternate, non-linear background function is 
available. All pixels selected within the amor-

phous only region are used to solve for a 2nd 
order polynomial using a least-squares tech-
nique:

bkg = a0 + a1 * x + a2 * y + a3 * x2 + a4 * x * y + 

a5 * y2

With the separation of amorphous and crystal-
line contributions, the percent crystallinity calcu-
lation is simply,

where:

%C=percent crystallinity

IO=observed intensity

IC=calculated background

C= over crystalline region

A+C=over amorphous and crystalline region

7.15.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..... (Two-Theta Begin for Amorphous Reg)   
[0]

$2 ..... (Two-Theta End for Amorphous Reg)    
[30]

$3 ..... (Chi Begin for Amorphous Region)     [0]
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$4 ..... (Chi End for Amorphous Region)     [360]
Defines conic region for amorphous region.

$5 ..... (Two-Theta Begin for Crystalline Region)   
[5]

$6 ..... (Two-Theta End for Crystalline Region) 
[25]

$7 ..... (Chi Begin for Crystalline Region)     [5]

$8 ..... (Chi End for Crystalline Region)     [355]
Defines conic region for crystalline region.

/LINEAR ................(Linear Algorithm Y/N?)     
[Yes]

Use to specify either a linear amorphous func-
tion underneath the crystalline peak, or a poly-
nomial function.

/COMPTON...........(Compton Scattering Y/N)     
[No]

Enter “Y” to subtract the Compton scattering 
effect from the amorphous result. The Compton 
scattering must be previously calculated using 
PER_CRYSTAL /COMPTON.
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7.16 Analyze > Percent Crystal > 
Compton • Define the incoherent 
scattering due to the Compton effect

Menu Command: Analyze > Percent Crystal > 
Compton

Accelerator: None

User Level: 1

SLAM Syntax: PER_CRYSTAL /COMPTON $1 /
SCALE=<n> /XSCALE=<n>

Calculates and displays the Compton scattering 
curve. Uses table in file: 
GADDS$SYSDATA:compton.tbl.

7.16.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..... (Empirical Formula)     [Al+3  2 O-2 3]

Enter empirical formula with valence states 
of ions.

/SCALE=<n>.........(Scale)     [1.0]

Enter scaling factor multiplier.

/XSCALE=<n> ......(X Scale)     [0]

Enter X scale: 0=(sin theta)/lambda, 
1=theta, 2=2theta.
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7.17 Analyze > Percent Crystal > Full 
• Calculate and use an amorphous 
background frame

Menu Command: Analyze > Percent Crystal > 
Full

Accelerator: None

User Level: 1

SLAM Syntax: PER_CRYSTAL  /FULL  $1  
/DISPLAY=<n>  $2  /RADIUS=<n>  
/HEIGHT=<n>

PER_CRYSTAL provides a quick method to esti-
mate a percent crystallinity using frame data. 
Frames must have air scatter (and sample 
holder scattering) effects subtracted out to 
obtain meaningful results.

Calculates the percent crystallinity by extracting 
an amorphous background frame. With the sep-
aration of amorphous and crystalline contribu-
tions, the percent crystallinity calculation is 
simply,

where:

%C=percent crystallinity

IO=observed intensity

IB=intensity background frame

In the case of polymers, where part of the struc-
ture is unstructured and part of it is crystalline in 
nature, there are two contributors to the diffrac-
tion pattern: a lower-level broadly distributed 
intensity which is the result of amorphous scat-
tering, and the stronger peeks which are the 
result of structure element of the polymer.

A method for background estimation that has 
proven effective in other domains is based on 
morphological processing. Morphological image 
processing is based on two operations: dilation 
and erosion. The parameters of the operations 
are defined by a matrix of kernel values, called 
the operator's “structure element” (SE). The 
dilation of an image F by a structuring element 
S, denoted as D = F ⊕ S, is defined as 

where d ∈ D, f ∈ F, and s ∈ S. Conversely, the 
erosion of an image F by a structuring element 
S, denoted as E = F _ S, is defined as

where f and s are as before and e ∈ E.

The background of a diffraction pattern can be 
estimated with a composite morphological oper-
ation, called “opening.” The morphological 
opening operation (denoted as M = F o S) is 
defined as
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where m ∈ M and the same SE is used in both 
the erosion and the dilation.

Opening can be interpreted physically as taking 
an object whose top surface is described by the 
SE, pressing it up against the underside of the 
intensity surface of the image and moving it 
about, as shown in Figure 7.1. The result of the 
opening is found by tracing the highest point 
reached by the object at each pixel in the image. 
If the object is a sphere, then the algorithm has 
been called the “rolling ball algorithm.” As long 
as the ball is large enough, it can not enter the 
positive excursions that correspond to the 
peaks; however, it can track a slowly varying 
background very well.

Figure 7.1 - A metaphor for the rolling ball algorithm

Unfortunately, the background estimate pro-
duced by the rolling ball filter is not robust in the 
presence of noise. As shown in Figure 7.2, 
noise spike “gouges” jutting sharply into the 

background will force the ball sharply down-
ward, producing erroneous background estima-
tion (i.e. the ball will follow the noise spike, not 
the true background). By applying a noise 
reduction technique to remove these negative 
excursions before the rolling ball operation, the 
background estimation becomes much more 
robust with respect to noise (see SMOOTH).

The 3D shape of the rolling ball is a half-ellipsoid 
where both axes in the XY plane are identical 
and the negative intensity direction is irrelevant, 
thus producing a half-dome shape.

Figure 7.2 - Depiction of why rolling ball filter is sensitive to 
noise
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7.17.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input frame)     [$FRAME]

Enter name of input frame or $frame.

/DISPLAY=<n>......(Max display counts)     [16]

Enter # counts corresponding to white.

$2 ..........................(Bkgd frame)     [$NULL]

Enter name of output background frame or 
$null.

/RADIUS=<n> .......(Radius)     [25]

Enter the radius of the rolling ball in pixels. 
This determines the size in the XY plane for 
the rolling ball. Range is 1 to 50. You should 
determine the half-width (in pixels) of the 
broadest feature in your frame images and 
use a value greater than that half-width. 
Remember that the broadest feature may 
consist of overlapping peaks; use the half-
width of background to background of these 
overlapping peaks feature.

/HEIGHT=<n> .......(HEIGHT)     [2]

Enter the height of the rolling ball in pixels. 
This determines the shape or flatness of the 
rolling ball in the intensity direction. Range 
is 0 to 20. A rule of thumb is height < radius 
/ 2. Use lower numbers to reduce the effects 

of upward creep, where the ball can fit 
inside the peaks, and produce background 
frames with some crystallinity intensity not 
removed.
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7.18 Analyze > Pole Figure > Scheme 
• Determine data collection scheme 
for pole figure

Menu Command: Analyze > Pole Figure > 
Scheme

Accelerator: None

User Level: 1

SLAM Syntax:

POLE_FIG /SCHEME $1
/DISTANCE=<n> /2THETA1=<n> 
/OMEGA1=<n> /PHI1=<n> /CHI1=<n> 
/AXIS1=<n> /WIDTH1=<n> /NUM1=<n> 
/THETA11=<n> /THETA21=<n> 
/2THETA2=<n> /OMEGA2=<n> 
/PHI2=<n> /CHI2=<n> /AXIS2=<n> 
/WIDTH2=<n> /NUM2=<n> 
/THETA12=<n> 
/THETA22=<n>/2THETA3=<n> 
/OMEGA3=<n> /PHI3=<n> /CHI3=<n> 
/AXIS3=<n> /WIDTH3=<n> /NUM3=<n> 
/THETA13=<n> 
/THETA23=<n>/2THETA4=<n> 
/OMEGA4=<n> /PHI4=<n> /CHI4=<n> 
/AXIS4=<n> /WIDTH4=<n> /NUM4=<n> 
/THETA14=<n> /THETA24=<n> 
/DIRECTION=<s> /MAPPING=<s> 
/REFLECTION /X=<n> /Y=<n> /Z=<n>

Pole figure frames are stereographic projections 
of the pole density sphere where each pixel of 
the pole figure frame represents the pole density 

of crystallites possessing a particular orienta-
tion. Pole maps of this kind are the preferred 
method for describing a material's texture.

The radius of the pole figure is called alpha and 
the azimuthal angle is called beta. These angles 
are related to the sample orientation by:

alpha—angle between reflecting plane and 
normal to the reference plane in the sample.

beta—angle between the reference direc-
tion and the normal to the diffractometer 
direction.

Consider a polycrystalline-textured specimen at 
a fixed orientation within an x-ray beam. The dif-
fracted rays from a particular hkl plane form a 
cone, where the azimuthal intensity variation is 
related to the orientation of the sample about 
the incident x-ray beam. The intersection of this 
diffraction cone and an area detector form a cir-
cle of intensity data that maps to a great circle 
on the pole sphere. By varying the sample ori-
entation to the incident beam, this circle of data 
can map to other regions of the pole sphere. 
Thus by measuring the distribution of diffracted 
rays at various sample positions, the relative 
pole density at every point along the pole figure 
may be obtained.
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7.18.1 Scheme

The complexity of the pole figure and the 
required precision will determine the number of 
frames that are necessary to collect. Further 
complications arise whenever the area detector 
is off-axis and only intersects a portion of the dif-
fracted cone. To aid the diffractionist, the data 
collection scheme can be determined using the 
SCHEME command. After inputting the goniom-
eter settings, the scan angle, step, and number 
of frames, along with the 2-theta of the desired 
pole, the SCHEME option will display where the 
simulated data will map on the pole figure pro-
jection. Complete coverage of the pole sphere 
can be assured, along with the reduction of 
duplicate data for shorter data collection times.

For complete coverage, omega must be half of 
the frame 2-theta angle. Otherwise a hole will be 
in the center of the pole image. 

In script mode, always use /2THETA1=<> 
through /2THETA4=<>, where runs not used 
should have blank values.

7.18.2 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Pole 2T)     [10.]

2-theta of desired hkl pole. While the pole 
2T can be different than the detector 2T, it 
must intersect the detector face.

/DISTANCE=<n>…(Distance)     [7.0]

Detector distance in cm.

/NUM=<n>............ (# Frames)     [36]

Number of frames to collect at these set-
tings.

/2THETA=<n>....... (2Theta)     [0.0]

/THETA1=<n>....... (Theta-1)     [0.0]

Initial 2-theta goniometer setting. On θ-θ 
systems, this is the θ1 tube axis.

/OMEGA=<n>....... (Omega)     [0.0]

/THETA2=<n>....... (Theta-2)     [0.0]

Initial omega goniometer setting. On θ-θ 
systems, this is the θ2 detector axis.

/PHI=<n> .............. (Phi)     [0.0]

Initial phi goniometer setting.

/CHI=<n>.............. (Chi)     [0.0]

Initial chi goniometer setting.

/AXIS=<n>............ (Scan Axis #)     [3]

Goniometer axis for scanning: 2=OM, 
3=PH, 4=CH.

/WIDTH=<n> ........ (Frame Width)     [5.0]

Step size of scan axis between frames.
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/CLEAR.................(Pre-Clear Y/N)     [Yes]

Y will clear both the screen display and any 
output file or SCAN /MULTIRUN menu 
requests. N will draw additional pole data 
onto previous SCHEME results and also 
append to any output file or the SCAN 
/MULTIRUN list.

/DIRECTION=<S> (Projection Direction)     [1]

Enter projection direction of sphere: 1=X 
(beam), 2=Y, 3=Z (Up).

/MAPPING=<s> ....(Mapping)     [Stereo]

Enter Stereo or Polar.

/REFLECTION ......(Reflection only? Y/N)     [No]

Enter “Y” for reflection only mode. All points 
from transmission through the sample are 
tossed out. Requires sample vector to be 
entered.

/X=<n> ..................(Sample vector X)     [0]

Enter sample vector in X direction on goni-
ometer head.

/Y=<n> ..................(Sample vector Y)     [0]

Enter sample vector in Y direction on goni-
ometer head.

/Z=<n> ..................(Sample vector Z)     [1]

Enter sample vector in Z direction on goni-
ometer head.
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7.19 Analyze > Pole Figure > Process 
• Process frames into pole figure 
image

Menu Command: Analyze > Pole Figure > Pro-
cess

Accelerator: None

User Level: 1

SLAM Syntax:

POLE_FIG /PROCESS $1 $2 $3 $4 $5 
/POLE=<n> /MAPPING=<s> 
/BACKGROUND $6 $7 $8 $9 /FIBERGEOM 
/ABSORPTION=<s> /X=<n> /Y=<n> 
/Z=<n> /MU=<n> /RADIUS=<n> 
/NSTEPS=<n> /REFLECTION

Pole figure frames are stereographic projections 
of the pole density sphere where each pixel of 
the pole figure frame represents the pole density 
of crystallites possessing a particular orienta-
tion. Pole maps of this kind are the preferred 
method for describing a material's texture.

The radius of the pole figure is called alpha and 
the azimuthal angle is called beta. These angles 
are related to the sample orientation by: 

alpha—angle between reflecting plane and 
normal to the reference plane in the sample.

beta—angle between the reference direc-
tion and the normal to the diffractometer 
direction.

Consider a polycrystalline-textured specimen at 
a fixed orientation within an x-ray beam. The dif-
fracted rays from a particular hkl plane form a 
cone, where the azimuthal intensity variation is 
related to the orientation of the sample about 
the incident x-ray beam. The intersection of this 
diffraction cone and an area detector form a cir-
cle of intensity data that maps to a great circle 
on the pole sphere. By varying the sample ori-
entation to the incident beam, this circle of data 
can map to other regions of the pole sphere. 
Thus by measuring the distribution of diffracted 
rays at various sample positions, the relative 
pole density at every point along the pole figure 
may be obtained.

7.19.1 Process

GADDS provides a quick processing of a series 
of frames to obtain pole figures at a specific two-
theta. For each frame in the series, a 2-theta 
integration is performed using the normalized-
bin method with the resulting chi trace mapped 
to a appropriate pixel locations on a pole figure 
frame. Where multiple chi intensities map to the 
same pixel on the pole image, the average 
intensity is used. Likewise, if multiple intensities 
from different data frames map to the same pixel 
on the pole image, the average of the possibly 
averaged intensities is used.

The background correction is made by integrat-
ing background intensity values in the immedi-
ate vicinity of the Bragg angle. Two background 
values are determined, their angles being below 
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and above the Bragg angle, with the final back-
ground determined by linear extrapolation 
between the low and high background values. It 
is important that the background intensity values 
are determined at a two-theta value that avoids 
any Bragg peak intensity in all frames of the 
series.

For a particular Bragg angle, the background 
intensity is determined by integrating a low and 
high background region in two-theta. Each 
resulting background trace (in chi) is smoothed 
using a three-point average. The background 
below the Bragg peak is determined by linear 
interpolation between the low and high back-
ground values.

If the background obtained for a certain value of 
sample inclination is higher than the measured 
intensity in the pole figure, its subtraction would 
lead to a negative intensity in the pole figure. 
This would be physically meaningless because 
there cannot be negative probability in the pole 
figure. The background correction will simply 
replace any negative values with zero and dis-
play a warning message with the maximum neg-
ative value that was encountered. Usually 
significant errors of this sort occur by the mis-
placement of the two-theta values for integrating 
the background regions.
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7.19.2 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(2theta start)     [24.5]

Two-theta start of Bragg peak region.

$2 ..........................(2theta end)     [26.5]

Two-theta end of Bragg peak region.

$3 ..........................(Chi start)     [0.0]

Chi start of Bragg peak region.

$4 ..........................(Chi end)     [360.0]

Chi end of Bragg peak region.

$5 ..........................(Output file)     [pole_fig.dat]

Output file name for pole figure which is 
stored as a psuedo frame image.

/POLE=<n> ...........(Projection direction)     [1]

The processed pole figure may have it's nor-
mal direction along 1=X (beam), 2=Y, or 3=Z 
(up). The correct value depends on the ori-
entation of the sample.

/MAPPING=<s> ....(Mapping)     [STEREO]

Enter STEREO or POLAR. Usually STE-
REO.

/BACKGROUND... (Remove background Y/N)     
[Yes]

Present to perform background correction. 
Background is calculated for each frame.

$6 ......................... (Low bkg begin)     [24.0]

$7 ......................... (Low bkg end)     [24.2]

Two-theta start and end of low background 
region.

$8 ......................... (High bkg begin)     [26.8]

$9 ......................... (High bkg end)     [27.0]

Two-theta start and end of high background 
region.

/FIBERGEOM....... (One fiber frame Y/N)     [No]

Enter “Y” to extract a pole figure from a sin-
gle frame using fiber geometry. Basically, 
the phi direction is indeterminate for fibers, 
thus the single frame will be used at various 
phi positions—every two degrees.

/ABSORPTION=<s>(Absorption model)     
[None]

Enter absorption model as “None,” “Fiber,” 
or “Plate.”
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/X=<n> ..................(Sample vector X)     [0]

/Y=<n> ..................(Sample vector Y)     [0]

/Z=<n> ..................(Sample vector Z)     [1]

Enter sample vector in X,Y,Z direction on 
goniometer head.

/MU=<n> ...............(Sample mu cm-1)   [131.22]

Enter sample mu in cm-1.

/RADIUS=<n> .......(Radius/Thickness cm)     
[0.05]

Enter sample radius (for fibers) or thickness 
(for plates) in cm.

/NSTEPS=<n> ......(Num integration steps)   [10]

Enter number of steps.

/REFLECTION ......(Reflection only? Y/N)     [No]

Enter “Y” for reflection only mode. All points 
from transmission through the sample are 
tossed out.
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7.20 Analyze > Pole Figure > 
Interpolate • Interpolate a processed 
pole figure image

Menu Command: Analyze > Pole Figure > Inter-
polate

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /INTERPOLATE $1 
/DISPLAY=<n> /WIDTH=<n> $2

Pole figures are displayed using a bitmapped 
image with each pixel location representing an 
alpha and beta sample orientation. Mapped pix-
els have intensities of the pole density plus one, 
while unmapped pixels possess the value of 
zero. For better visualization of the pole figure 
image, it is useful to interpolate a value for all 
the unmapped pixels.

7.20.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$FRAME]

Input filename for pole figure or $frame.

/DISPLAY=<n>......(Max Display Counts)     [-2]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 
example, corresponding to white) on the dis-

play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -2; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.

/WIDTH=<n> ........ (Width)     [2]

Half-width of interpolation box in pixels.

$2 ......................... (Outputfile)     [$NULL]

Output filename to store interpolated pole 
figure image or $null.
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7.21 Analyze > Pole Figure > Tilt • Tilt 
pole figure about a new polar origin

Menu Command: Analyze > Pole Figure > Tilt

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /TILT $1 
/DISPLAY=<n> /X=<n> /Y=<n> $2

Frequently, the diffractionist would like to visual-
ize the pole sphere from a different viewing 
angle or orientation. Or perhaps the pole figure 
needs to be positioned with particular sample 
directions. For these reasons, the TILT and 
ROTATE options have been provided. The TILT 
option allows a new position on the sphere to be 
positioned at the origin of the projection, while 
the ROTATE option performs rotation of the 
image about the origin. INVERT flips the image 
from top to bottom.

7.21.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$FRAME]

Input filename for pole figure or $frame.

/DISPLAY=<n>......(Max Display Counts)     [-2]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 

the maximum display memory value (for 
example, corresponding to white) on the dis-
play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -2; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.

/X=<n>.................. (X Origin)     [0]

x offset of new origin.

/Y=<n>.................. (Y Origin)     [0]

y offset of new origin.

$2 ......................... (Output File)     [$NULL]

Output filename to store tilted pole figure 
image or $null.
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7.22 Analyze > Pole Figure > Rotate • 
Rotate pole figure about beta 
(azimuthal) angle

Menu Command: Analyze > Pole Figure > 
Rotate

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /ROTATE $1 
/DISPLAY=<n> $2

Frequently, the diffractionist would like to visual-
ize the pole sphere from a different viewing 
angle or orientation, or perhaps the pole figure 
needs to be positioned with particular sample 
directions. For these reasons, the TILT and 
ROTATE options have been provided. The TILT 
option allows a new position on the sphere to be 
positioned at the origin of the projection, while 
the ROTATE option performs rotation of the 
image about the origin. INVERT flips the image 
from top to bottom.

7.22.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$FRAME]

Input filename for pole figure or $frame.

/DISPLAY=<n> ..... (Max Display Counts)     [-2]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 
example, corresponding to white) on the dis-
play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -2; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.

/ANGLE=<n>........ (CCW Angle)     [0.0]

Angle of rotation about the origin (center).

$2 ......................... (Output File)     [$NULL]

Output filename to store rotated pole figure 
image or $null.
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7.23 Analyze > Pole Figure > 
Symmetrize • Symmetrize pole figure 
using various Laue symmetries

Menu Command: Analyze > Pole Figure > 
Symmetrize

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /SYMMETRIZE $1 
/DISPLAY=<n> $2 /LAUE=<s>

All pole spheres possess Laue symmetry (e.g., 
orthorhombic materials exhibit mmm symme-
try), therefore one needs to collect only an 
octant or quadrant of the pole sphere to gener-
ate the entire sphere. Conversely, one can use 
the symmetry feature as a smoothing function.

SYMMETRIZE supports Laue symmetries for 
triclinics (i), monoclinics (2/m), orthorhombics 
(mmm), and tetragonals (4/m, 4/mmm). Laue 
symmetries for trigonals, hexagonals, and 
cubics are not supported at this time; however 
one can use 2/m or mmm for hexagonals and 
mmm for cubics.

7.23.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$FRAME]

Input filename for pole figure or $frame.

/DISPLAY=<n> ..... (Max Display Counts)     [-2]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 
example, corresponding to white) on the dis-
play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -2; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.

$2 ......................... (Output File)     [$NULL]

Output filename to store symmetrized pole 
figure image or $null.

/LAUE=<s>........... (Laue Symmetry)     [2/m]

Enter Laue symmetry as “i,” “2/m,” “mmm,” 
“4/m,” “4/mmm.” Currently other Laue sym-
metries are not supported, but some may be 
approximated by using a lower inherent 
symmetry. For instance, hexagonals “6/m” 
inherently possess “2/m” symmetry and “6/
mmm” possess “mmm” symmetry, while 
cubics “m3” or “m3m” possess “mmm” sym-
metry.
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7.24 Analyze > Pole Figure > Invert • 
Invert pole figure about x-axis

Menu Command: Analyze > Pole Figure > Invert

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /INVERT $1 
/DISPLAY=<n> $2

Frequently, the diffractionist would like to visual-
ize the pole sphere from a different viewing 
angle or orientation, or perhaps the pole figure 
needs to be positioned with particular sample 
directions. For these reasons, the TILT and 
ROTATE options have been provided. The TILT 
option allows a new position on the sphere to be 
positioned at the origin of the projection, while 
the ROTATE option performs rotation of the 
image about the origin. INVERT flips the image 
from top to bottom.

7.24.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$frame]

input filename for pole figure or $frame.

/DISPLAY=<n>......(Max Display Counts)     [-2]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 

example, corresponding to white) on the dis-
play. The special value -1 directs the pro-
gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -2; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.

$2 ......................... (Output File)     [$null]

Output filename to store inverted pole figure 
image or $null.
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7.25 Analyze > Pole Figure > Texture-
AT • Create Texture-AT file from pole 
figure frame (binary)

Menu Command: Analyze > Pole Figure > 
TextureAT

Accelerator: None

User Level: 1

SLAM Syntax:

POLE_FIG /TEXTUREAT $1 /TITLE=<n> 
/HKL=<n> /APPEND /ALPHAINC=<n> 
/BETAINC=<n> /REFLECTION

Besides the storing of bitmapped images, the 
pole figure may be exported in either TEX-
TURE-AT file format or popLA file format for 
ODF calculations or other processing with those 
or other software packages. See appendices for 
the format of these data files. A 3 x 3 pixel 
region is averaged before writing to a TEX-
TURE-AT file.

ODF-AT performs an ODF using harmonic 
methods which represents the ODF as a 
weighted sum of spherical harmonic functions 
chosen so as to possess the symmetry of both 
the specimen and the crystal system. Unfortu-
nately, the spherical harmonic expansion can 
lead to non-physical results, because the best fit 
ODF may exhibit regions in which the values are 
negative, which is nonsense for a probability 
density function. Such problems particularly 

arise in cases where the ODF is sharply 
peaked, thus the harmonic method is more 
suited to ODFs which are not sharply peaked.

7.25.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Texture-AT File)     [texture]

Output filename for TEXTURE-AT data file. 
Extension defaults to either *.trw (transmis-
sion) or *.rrw (reflection).

/TITLE=<n> .......... (Title)     [$title]

Title for data file.

/HKL=<n>............. (HKL)     [100]

hkl of this pole.

/APPEND ............. (Append Y/N?)     [No]

Y to add this pole figure to an existing TEX-
TURE-AT file, N to deleted any existing file 
and create a new TEXTURE-AT file. For 
ODF calculations, two or three poles must 
be collected in the same TEXTURE-AT data 
file.

/ALPHAINC=<n> .. (Declination Inc.)     [1.0]

Step size of alpha, declination angle.

/BETAINC=<n>..... (Azimuthal Inc.)     [1.0]

Step size of beta, azimuthal angle.
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/REFLECTION ......(Reflection mode Yes/No)     
[No]

Present to produce TEXTURE-AT file in 
reflection mode format.

7.26 Analyze > Pole Figure > popLA • 
Create popLA data file from pole 
figure frame (ASCII)

Menu Command: Analyze > Pole Figure > 
PopLA

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /POPLA $1 
/TITLE=<n> /HKL=<n> /APPEND

Besides the storing of bitmapped images, the 
pole figure may be exported in either TEX-
TURE-AT file format or popLA file format for 
ODF calculations or other processing with those 
or other software packages. See appendices for 
the format of these data files.

popLA performs an ODF using vector methods. 
The orientation space is divided up into a num-
ber of “cells” within which the ODF is assigned a 
constant value. A simple initial value of each cell 
is determined from the experimental data. The 
resultant pole figures from such an ODF are 
compared with the observed pole figures and 
adjustments are made to improve the match. 
This process is repeated until no further 
improvement is observed. Vector methods are 
best suited to ODFs that contain a few sharp 
features.
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7.26.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Popla File)     [popla.epf]

Enter output popLA file name (*.epf).

/TITLE=<n>...........(Title)     [$TITLE]

Enter pole figure title (or “$TITLE” for frame 
title).

/HKL=<n>..............(HKL)     [100]

Enter hkl indices, i.e. 111 (or “hkl” if 
unknown).

/APPEND ..............(Append Y/N?)     [No]

Append to existing output file [no => over-
writes].
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7.27 Analyze > Pole Figure > 
Orientate • Calculate Hermans and 
White-Spruiell orientation indices

Menu Command: Analyze > Pole Figure > 
Orientate

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /ORIENT $1 
/DISPLAY=<n> $2 /APPEND /FILM /HKL=<s>

A widely used analytical representation of unit 
cells in a specimen is based on the second-
order moment of a specific unit cell direction 
(hkl) with respect to a specific direction in the 
specimen (M). These second moment functions 
are used to define an orientation index for a 
one-dimensional structure (fiber) and an index 
for a two-dimensional structure (film). These 
indices are directly related to certain physical 
properties such as birefringence.

Calculation of orientation indices requires evalu-
ation of the angle between a specific crystallo-
graphic direction and a processing direction. 

Both the sample and the pole projection must be 
defined as below:

NOTE: The crystallographic axes must be 
orthogonal. We have only implemented the 
algorithm for orthorhombic symmetry (and thus 
tetragonals and cubics).

For materials oriented uniaxially about a single 
processing direction (such as would be the case 
for spun fibers), one usually calculates Hermans 
orientation indices for each crystallographic axis 
with respect to that processing axis. Herman's 
orientation indices are defined by:

where:

X = processing direction, i.e. MD, TD, N

x = crystallographic direction

( )
2
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,
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a = angle between above

<...> = averaged over entire pole figure

Table 7.1 – Some limiting cases of orientation and their 
second moments and orientation indices

Typically, Herman's indices are plotted on a 
Stein triangle. The three apexes of the triangle 
correspond to the crystallographic axis (a, b, c) 
being parallel to the z-axis of the sample. The 
edges of the triangle represent the orientation of 
a crystallographic axis being perpendicular to 
the z-axis. A condition of no orientation is the 
origin.

White-Spruiell orientation indices are useful on 
polymer films, where orientations occur with 
some degree of biaxial character. White-Spruiell 
orientation indices are usually displayed on an 
isosceles triangle. The three apexes of the trian-
gle correspond to perfect orientation along a 
particular direction, whereas the center of the 
triangle corresponds to isotropic orientation.

S(MD,x) = 2<cos2 a>MD,x + <cos2 a>TD,x - 1

S(TD,x) = 2<cos2 a>TD,x + <cos2 a>MD,x – 1

7.27.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Pole Figure File)  [$FRAME]

Enter pole figure file name (or $FRAME for 
current frame).

/DISPLAY ............. (Max Display Counts)     [15]

Enter # counts corresponding to white.

$2 ......................... (Increment)     [1.0]

Enter delta angle in degrees for summa-
tions.

/APPEND ............. (Append Y/N)     [No]

Enter “Y” to append results to previous trian-
gle plot.

/FILM .................... (Film Y/N)     [No]

Enter “Y” for 2D structures such as films, “N” 
for 1D structures such as fibers.

/HKL=<s> ............. (HKL)     [001]

Enter hkl of pole figure used for labelling 
purposes. If unknown, enter “hkl.”

Orientation Angle c,z <cos2 c,z> Fc,z

Chain axis is parallel 
to the fiber axis

0 1 +1.0

Chain axis perpen-
dicular to the fiber 
axis

90 0 -0.5

Chain axis oriented a 
random

random 1/3 0.0

Equal bimodal orien-
tation of chains

0 or 90 1/3 0.0
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7.28 Analyze > Pole Figure > Stein • 
Plot Stein triangle using calculated 
Hermans indices

Menu Command: Analyze > Pole Figure > Stein

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /STEIN $1 $2 
/APPEND

Typically, Herman's indices are plotted on a 
Stein triangle. The three apexes of the triangle 
correspond to the crystallographic axis (a, b, c) 
being parallel to the z-axis of the sample. The 
edges of the triangle represent the orientation of 
a crystallographic axis being perpendicular to 
the z-axis. A condition of no orientation is the 
origin.

In certain cases the reflection from the hkl plane 
will be too week in intensity to give useful data. 
In such cases, one must interpolate the desired 
second-moment from second-moments of two 
or more other hkl poles for which data is obtain-
able. For our orthogonal case, the expression of 
second-moments for orthogonal relationships:

<cos2 a,z> + <cos2 b,z> + <cos2 c,z> = 1 eq. 1

From which it follows:

Fa,z + Fb,z + Fc,z = 0   eq. 2

Second-moment for an hk0 pole can be interpo-
lated using:

<cos2 hk0,z> = e2 <cos2 a,z> + f2 <cos2 b,z>

eq. 3

where e and f are the direction cosines between 
the a- and b-axes with the hk0 plane.

Stein triangles are plotted using Fa,z and Fc,z 
Herman's indices. These are directly calculated 
from h00 and 00l poles. Alternately, one can 
obtain these two values from h00 and 0k0 poles 
or 0k0 and 00l poles and applying equation 2. 
Otherwise, it gets more complicated. One needs 
the crystal lattice and at least three poles, such 
as 110, 210, and 001. By applying equation 3, 
one can derive the Herman's indices.

For more details and for other non-orthogonal 
crystal systems, the reader is referred to:

Wilchinsky, Z. W., “Recent Developments in the 
Measurement of Orientation in Polymers by X-
ray Diffraction,” Advances in X-ray Analysis, 6, 
231-241, 1962.

Alexander, L. E., X-ray Diffraction Methods in 
Polymer Science, Wiley-Interscience, 1969, sec-
tion 4.4.
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7.28.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(F(a,z))     [0.0]

Enter fa,z: typically F(MD,h00) from 
/ORIENTATE command.

$2 ..........................(F(c,z))     [0.0]

Enter fc,z: typically F(MD,00l) from 
/ORIENTATE command.

/APPEND ..............(Append Y/N)     [No]

Enter “Y” to append results to previous trian-
gle plot.
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7.29 Analyze > Pole Figure > 
Normalize • Normalize pole image, so 
random = 100 counts

Menu Command: Analyze > Pole Figure > 
Normalize

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /NORMALIZE $1 
/DISPLAY=<n> /NVAL=<n> $2

Normalize the pole image to either the average 
intensity of a random sample or psuedo-normal-
ize to the average intensity of the collect pole 
image. In the normalized pole image, an inten-
sity of 100 represents the random intensity.

7.29.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$frame]

Input filename for pole figure or $frame.

/NVAL=<n>............(Norm Value)     [0]

Normalization value or 0=pseudo normalize 
using the average intensity value of the dis-
played pole image.

/DISPLAY=<n>......(Max Display Counts)    [255]

Intensity to map as white.

$2 ......................... (Output File)     [$null]

Output filename to store interpolated pole 
figure image or $null.
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7.30 Analyze > Pole Figure > 
Contours • Draw contour plot of 
pole figure

Menu Command: Analyze > Pole Figure > 
Contours

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /CONTOURS $1 
/INTERVAL=<n>

Pole figures can be displayed in three methods:

1. As frame images were each pixel is dis-
played by a color indicating it's intensity.

2. As a contour plot were lines of equal inten-
sity are drawn at given intervals.

3. As a 3D surface plot where intensity is rep-
resented by height.

7.30.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Input File)     [$FRAME]

Enter the input pole figure filename (or 
$FRAME).

/INTERVAL=<n>....(Contour Interval)     [16]

Enter the contour interval.
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7.31 Analyze > Pole Figure > Surface 
• Draw 2D surface plot of pole figure

Menu Command: Analyze > Pole Figure > 
Surface

Accelerator: None

User Level: 1

SLAM Syntax:

POLE_FIG /SURFACE $1 /ROTATION=<n> 
/ELEVATION=<n> /COARSENESS=<n>  
/LOGSCALE

Pole figures can be displayed in three methods:

1. As frame images were each pixel is dis-
played by a color indicating it's intensity.

2. As a contour plot were lines of equal inten-
sity are drawn at given intervals.

3. As a 3D surface plot where intensity is rep-
resented by height.

The surface algorithm is very susceptible to 
noise. If the frame was not smoothed, then a 
Process > Smooth > Convolve command is 
automatically suggested (see Section 6.16), 
however, in command mode, only a warning is 
displayed “Frame type is not SMOOTHED.”

7.31.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Input File)     [$FRAME]

Enter the input pole figure filename (or 
$FRAME).

/ROTATION=<n> .. (Rotation)     [0]

Enter the rotation angle.

/ELEVATION =<n> (Elevation)     [30]

Enter the elevation angle for viewing 3D 
plot.

/COARSENESS=<n>(Coarseness)     [5]

Enter the coarseness for drawing the sur-
face plot.

/LOGSCALE......... (Logscale)     [No]

Check to display using a logrithmic intensity 
scale.
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7.32 Analyze > Pole Figure > Fiber • 
Take a “cut” through pole figure and 
display I versus tilt angle

Menu Command: Analyze > Pole Figure > Fiber

Accelerator: None

User Level: 1

SLAM Syntax: POLE_FIG /FIBERPLOT  $1  $2  
$3  $4  /NORMAL=<n>  /STEPSIZE=<n>

Use this command to display a slice through the 
pole figure as an intensity-versus-alpha angle 
plot.

7.32.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Tilt Start)     [0.0]

Enter starting tilt angle in degrees.

$2 ..........................(Tilt End)     [90.0]

Enter ending tilt angle in degrees.

$3 ..........................(Beta)     [0.0]

Enter beta of conic region in degrees.

$4 ..........................(Height)     [0]

Enter height of conic region. Range 0 to 5 
degrees.

/NORMAL=<>....... (Normalize Intensity)     [1]

Normalize intensities. 0=sum, 1=avg.

/STEPSIZE=<n>... (Step Size)     [0.5]

Enter step size for tilt angle axis in degrees.
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7.33 Analyze > Stress > Conventional 
• Process frame images into data file 
for STRESSplus package

Menu Command: Analyze > Stress > 
Conventional

Accelerator: None

User Level: 1

SLAM Syntax:

STRESS /CONVENTIONAL $1 $2 $3 $4 
/NORMAL=<n> /STEPSIZE=<n> 
/2THETA=<n> $5 /FILENAME=<s>

DIFFRACplusSTRESS is Windows NT-based 
software designed for residual stress calcula-
tions. This document describes the use of DIF-

FRACplusSTRESS to analyze residual stress 
data collected with a General Area Detector Dif-
fraction System (GADDS).

7.33.1 Hardware Requirement for Stress 
Measurements

One of the following sample stages is required 
to perform stress measurements with GADDS:

XYZ Stage

1/4-Circle Eulerian Cradle at chi = -90 posi-
tion

Two-Position Chi Stage at chi = -90 position

For all of the above stages, the sample surface 
must face the operator when omega=0 and face 

the incident beam when omega=90. For stress 
tensor measurements, phi rotation is required.

7.33.2 Data Collection with GADDS

Data can be collected either SingleRun with 
omega-scan for normal stress measurements 
(single phi, phi=0) or MultiRun with omega-scan 
for stress tensor measurements (multiple phi, 
e.g., phi=0, 45 and 90). All frames must have the 
same file name and consecutive extension num-
bers. For MultiRun, it is required to set the same 
run number for all runs in the EditRuns menu.

The psi-tilt is achieved by sample omega rota-
tion, the so-called “iso-inclination mode.” Use 
the following equations to determine omega-
scan angles, where (2T) is the estimated peak 
position:

If the detector is set at positive swing angle: 
omega = psi + (2T)/2.

If the detector is set at negative swing angle: 
omega = 180 - psi - (2T)/2.

For example, to set psi at 45, 30, 15, 0, -15, 
-30, -45 for iron (211) whose 2T=156 with the 
detector swinging negative, the omega scan val-
ues are 57, 72, 87, 102, 117, 132, 147.
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7.33.3 Data Processing with GADDS

For GADDS software version 3.323 or above, 
the stress function is added under the Analyze 
menu. Follow these steps to process the data:

1. Load the first frame.

2. Select Stress under the Analyze menu.

3. In the pop-up windows, several variables 
must be set. Particularly: “2theta start” and 
“2theta end” for the peak of interest with 
appropriate background. “Chi start” and “Chi 
end” for the chi integration range. The val-
ues should be 90+/-x. x is normally set 
below 10 degrees. Set to 5 degrees if not 
sure. “Normalize intensity”—use a default 
value of 3. “Peak 2T”—input the estimated 
or pre-determined 2T peak position. This 
value is used to calculate psi tilt. “File-
name”—the processed data will be saved in 

DIFFRACplus format into this filename.

4. Check OK to start processing. The 2-theta 
and Chi range can be redefined using the 
mouse for each of frame. Click in the inte-
gration box for each frame.

7.33.4 Stress Calculation

DIFFRACplusSTRESS can open the data saved 
in the last step. For data format compatibility 
reasons, the psi-tilt of GADDS data is saved as 

the chi value for DIFFRACplusSTRESS. As such, 

DIFFRACplusSTRESS will process GADDS data 
as if it were collected in side-inclination mode, 
although the GADDS data was collected in iso-
inclination mode. This will not change the stress 
result as long as the absorption and polarization 
corrections are not performed in 

DIFFRACplusSTRESS. These corrections can 
be made in GADDS before data processing with 

DIFFRACplusSTRESS. Verify that those correc-
tion functions are disabled when analyzing 

GADDS data with DIFFRACplusSTRESS.

7.33.5 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (2-theta start)     [0.0]

Enter lower 2T of conic region in degrees.

$2 ......................... (2-theta end)     [30.0]

Enter upper 2T of conic region in degrees.

$3 ......................... (Chi start)     [0.0]

Enter lower chi of conic region in degrees.
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$4 ..........................(Chi end)     [360.0]

Enter upper chi of conic region in degrees.

/NORMAL=<n> .....(Normalize intensity)     [3]

Normalize intensities: 0=none, 1=avg, 2=arc 
length, 3=solid angle, 4=bin method.

/STEPSIZE=<n> ...(Step size)     [0.1]

Enter step size in degrees.

/2THETA=<n> .......(Peak 2T)     [156.0]

Enter peak 2T for calculations.

$5 ..........................(Title)     [$TITLE]

Enter title string or $TITLE to leave 
unchanged.

/FILENAME=<s>...(File name)     [stress.raw]

Enter output file name for RAW data.
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7.34 Analyze > Stress > Scheme 2D

Menu Command: Analyze > Stress > Scheme 
2D

Accelerator: None

User Level: 1

SLAM Syntax:

STRESS /SCHEME2D  $1  /PEAK=<n>  
/DISTANCE=<n>  $2  
[/2THETA=<n>|/THETA1=<n>]
[/OMEGA=<n>|/THETA2=<n>]  /PHI=<n>  
/CHI=<n>  /AXIS=<n>  /WIDTH=<n>  
/CLEAR

Use this command to determine proper scan 
parameters when stress measurements are 
required and to determine which stress direc-
tions are properly determined.

7.34.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Output file)     [$NULL]

Output file for multirun scan listing. $SCAN 
will automatically update directly to the 
SCAN /MULTIRUN menu. $NULL will skip 
this feature.

/PEAK=<n> ...........(Stress peak)     [156.0]

2T or d-spacing of desired stress peak.

/DISTANCE=<n> .. (Distance) [7.0 cm]

Detector distance in cm.

$2 ......................... (# frames)     [36]

Number of frames to collect.

/2THETA=<n> /THETA1=<n>(2Theta or Theta1) 
[-135.0 deg]

Detector swing angle in degrees.

/OMEGA=<n> /THETA2=<n>(Omega or 
Theta2)     [0.0 deg]

/PHI=<n>.............. (Phi)     [0.0 deg]

/CHI=<n>.............. (Chi)     [90.0 deg]

The sample positioning angles in degrees.

/AXIS=<n>............ (Scan axis #)     [2 - omega]

Goniometer axis for scanning: 2-omega, 3-
phi, 4-chi.

/WIDTH=<n> ........ (Frame width)     [5.0 deg]

Step size of scan axis between frames.

/CLEAR ................ (Pre-clear?)     [Y]

Check “Y” to clear both the screen display 
and the output file or Scan > MultiRun list. 
Uncheck “N” to append to screen and output 
file or run list.
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7.35 Analyze > Stress > Biaxial 2D • 
Biaxial stress measurements from 
frame images, Analyze > Stress > 
BiaxialShear2D, Analyze > Stress > 
Triaxial2D

Menu Command: Analyze > Stress > Biaxial 2D, 
Analyze > Stress > BiaxialShear2D, Analyze > 
Stress > Triaxial2D

Accelerator: None

User Level: 1

SLAM Syntax:

STRESS  [/BIAXIAL2D | /SHEAR2D | 
/TRIAXIAL2D]  $1  $2  $3  $4  
/NORMAL=<n>  /STEPSIZE=<n>  
/NUMBER=<n>  /2THETA=<n>  $5  
/FILENAME=<s>  /HKL=<s>  
/YOUNG=<n>  /POISSON=<n>  
/ARX=<n>  /LINESHAPE=<n>  
/CUTOFF=<n>  /REPROCESS  
/BKGFIT=<s>  /KALPHA2=  /PHI=<n>  
/PSI=<n>  /UNITS=<s>

Preferred stress calculation algorithm. (See the 
User Manual for details).

Biaxial stress solves:

p11σ11 + p12σ12 + p22σ22 + (1-2v)/E σph = ln (sin 
θ0/ sin θ)

Biaxial Shear stress solves:

p11σ11 + p12σ12 + p22σ22 + p13σ13 + p23σ23 
+ (1-2v)/E σph = ln (sin θ0/ sin θ)

Triaxial stress solves:

p11σ11 + p12σ12 + p22σ22 + p13σ13 + p23σ23 
+ p33σ33 = ln (sin θ0/ sin θ)

The final stress report is somewhat different, 
otherwise these three commands are identical.

Biaxial stress reports:

Biaxial Shear stress solves:

Triaxial stress solves.

Data collection condition Stress report

W scan only σ11

Chi scan only σ22

All other cases σ11 σ12 σ22 and σph

Data collection condition Stress report

W scan only σ11 and σ13

Chi scan only σ22 and σ23

All other cases σ11 σ12 σ22 σ13 σ23 

and σph

Data collection condition Stress report

All cases (must scan 2 axes) σ11 σ12 σ22 σ13 σ23 

and σ33
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Reprocessing Stress Data:

Frequently, obvious errors can occur and you 
would like to toss out specific data points from 
the calculation. There are two methods to repro-
cess data.

Method 1: Reprocess from <filename>.txt that 
must be created using the [Write] button. You 
must use the base filename with the .txt exten-
sion (defaults to edit.txt). Then use notepad to 
edit this file and in the last table add an addition 
column to reject data points. Use the letter “R” 
or the word “rejected” (case is not important). 
Finally, restart the Stress command with the 
reprocess option checked.

Method 2: Reprocess from <filename>.lst that is 
always created. This is also an ASCII file that 
can be edited with notepad. Any peak with “L” 
limit condition or missing standard deviation is 
rejected. Typically, peaks that are poorly refined 
have a large standard deviation and you may 
want to reject these peaks. Delete any existing 
<filename>.txt as these will be processed before 
the .lst file. Finally, restart the Stress command 
with the reprocess option checked.

7.35.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (2theta start)     [154.5]

Enter lower 2-theta of conic region 
(degrees).

$2 ......................... (2theta end)     [157.5]

Enter upper 2-theta of conic region 
(degrees).

$3 ......................... (Chi start)     [70.0]

Enter lower chi of conic region (degrees).

$4 ......................... (Chi end)     [110.0]

Enter upper chi of conic region (degrees).

/NORMAL=<n>..... (Normalize intensity)     [3]

Normalize intensities (0=sum, 1=avg, 2=arc, 
3=solid angle, 4=bin, 5=norm bin).

/STEPSIZE=<n>…(Step size)     [0.1]

Enter the step size (degrees).

/NUMBER=<n> .... (# of sub-regions)     [15]

Enter the number of sub-regions to inte-
grate.

/2THETA=<n>....... (Peak 2T or d)     [156.0]

Enter unstressed 2T (or d) for triaxial tensor 
calculations.
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$5 ..........................(Title)     [$TITLE]

Enter title string (or $TITLE to leave 
unchanged).

/FILENAME=<s>...(File name)     [stress.raw]

Enter output filename for RAW data.

/HKL=<s>..............(hkl)     [211]

Enter hkl of line.

/YOUNG=<n>........(Young’s modulus)     
[210,000]

Enter Young's modulus for material.

/POISSON=<n> ....(Poisson’s ratio)     [0.28]

Enter Poisson's ratio for material.

/ARX=<n> .............(Arx)     [1.0]

Enter anisotropicity factor (1.0=isotropic).

/LINESHAPE=<n>.(Lineshape)     [4]

Enter 1=Gaussian, 2=Lorentzian, or 
4=Pseudo-Voigt2.

/CUTOFF=<n> ......(Cutoff)     [0]

Enter peak cutoff in percent of max (ignore 
peaks below cutoff).

/LINESHAPE.........(Lineshape) [4 Psuedo-Voigt 
2]

Enter 0 = centroid, … Note for centroid 
method, you cannot refine the backgrounds, 

fit Kalpha2, or use the peak cutoff value, but 
you can subtract out a fixed background.

/REPROCESS...... (Reprocess only?) [N]

Check “Y” to skip integration of all input 
frames. Program will try to read the stress 
report file <basename>.txt (must be created 
with verbose output to get data table). If that 
fails, it will read profile fitting output <base-
name>.lst. Reprocessing is useful to throw 
out bad data points or recalculate stress 
from new input parameters.

/BKGFIT=<s> ....... (Background fit) [Both]

This command can handle the backgrounds 
during profile fitting in eight ways:

Both Initializes and refines both back-
grounds.

Low Initializes and refines low (left) 
background; high background is 
fixed at initial value.

High Initializes and refines high 
(right) background; low back-
ground is fixed at initial value.

Neither (Init Both & Fixed)
Initializes and fixes both back-
grounds.

Zero & Fixed
Initializes at zero and fixes both 
backgrounds.
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Init Low & Fixed
Initializes at low and fixes both 
backgrounds.

Init High & Fixed
Initializes at high and fixes both 
backgrounds.

Init Avg & Fixed
Initializes at average of low and 
high, and fixes both back-
grounds.

/KALPHA2.............(Fit Kalpha2?)  [N]

Check “Y” to fit Kalpha2 wavelength in pro-
file fitting routine.

/PHI=<n>...............(Phi)  [0.0]

/PSI=<n>...............(Psi)  [90.0]

Enter the sample angles for the arbitrary 
stress in the stress report.

/UNITS=<s> ..........(Stress units)  [MPa]

Select MPa, Ksi, or Psi. 1.0 MPa = 0.145 Ksi 
= 145.0 Psi.
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7.36 Analyze > Stress > View 2D • 
View biaxial stress and original frame 
images

Menu Command: Analyze > Stress > View 2D

Accelerator: None

User Level: 1

SLAM Syntax:

STRESS  /VIEW2D  $1  /DISPLAY=<n>  
/DATA  /LINE  /DELAY=<n>  
/DIRECTION=<s>

Use this command to display the fitted observed 
data and/or the calculated stress line to the orig-
inal frame files for quick, visual confirmation of 
correctness. Can be used in movie or single 
frame mode.

7.36.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(First frame)     [stress.000]

Enter first frame of series to display.

/DISPLAY=<n>......(Display limit)     [-1]

Enter 0 for no display, otherwise this item 
specifies the number of counts mapped into 
the maximum display memory value (for 
example, corresponding to white) on the dis-
play. The special value -1 directs the pro-

gram to pick a reasonable value by 
scanning through the pixels in the frame 
prior to display; the special value -2 directs 
the program to use whatever setting is cur-
rently in effect. The default value is -1; the 

allowed range is from -2 to 106 counts. 
Smaller values make the displayed image 
look brighter; larger values make look 
darker.

/DATA.................... (Overlay data points)     [Yes]

Check “Y” to display the 2T/CH data points 
as “X.”

/LINE .................... (Overlay stress line)     [Yes]

Check “Y” to display the calculated stress as 
a line.

/DELAY=<n>......... (Movie delay time)     [-1.0]

Enter time in seconds between frames or 
-1.0 for no movie.

/DIRECTION=<s> (Movie direction)     [+]

Enter either “+” or “-” for the direction 
through frames.
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7.37 Analyze > Mapping

Menu Command: Analyze > Mapping

Accelerator: None

User Level: 1

SLAM Syntax:

MAPPING  $1  /FRAME=<s>  /RUN=<s>  
$2  /SLAM=<s>

Use this command to process a run series 
where each run is identically processed to 
obtain a “mapping parameter value” per each 
run. A run could be frames collected on a sam-
ple position in X and Y (or Y and Z) or a sample 
position in a sample library (see Collect > 
Scan > Grid Targets). Each resultant value 
across the runs is sent to and mapped in the 
GADDSMAP utility program. The mapping pat-
tern will show sample variations with position or 
variations in samples in a sample library. Such 
information is frequently used for quality control.

When selected, a dialog box appears to enter 
the mapping parameters. You must select what 
parameter you want to map across all the runs. 
You must enter the first frame in the run series 
and the last run number. After clicking [OK], the 
frame headers of these runs will be read to 
determine the XY (or YZ) mapping grid. Frames 
must be collected on a grid, but some missing 
frames are allowed.

Next GADDS brings up the dialog box for input-
ting processing parameters needed to calculate 
the requested parameter to map. Which dialog 
box appears depends on which parameter is 
being mapped. For more information, see the 
appropriate command for this dialog box.

7.37.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (First frame) 
[map_0_001.gfrm]

/FRAME=<s>........ (To frame number)     [001]

/RUN=<s>............. (To run number)     [G]

These three parameters define the run 
series to process.

$2 ......................... (Map parameter)     [Area]

Area (integration area)

% (internal)

% (external)

% (full)

Peak 2theta

Peak height

Peak fwhm

Peak area
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Biaxial Sigma 11 stress

Biaxial Sigma 12 stress

Biaxial Sigma 22 stress

Biaxial Sigma ph stress

Shear Sigma 11 stress

Shear Sigma 12 stress

Shear Sigma 22 stress

Shear Sigma 13 stress

Shear Sigma 23 stress

Shear Sigma ph stress

Triaxial Sigma 11 stress

Triaxial Sigma 12 stress

Triaxial Sigma 22 stress

Triaxial Sigma 13 stress

Triaxial Sigma 23 stress

Triaxial Sigma 33 stress

/SLAM=<s> ...........()     [blank]

This parameter is used in script mode. It is 
the script command for the processing 
parameters dialog box. In menu mode, just 
leave this blank.
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8.  Peaks Routines

8.1 Peaks > Mask > Create • 
Create a new active pixel mask for 
this frame

Menu Command: Peaks > Mask > Create

Accelerator: None

User Level: 1

SLAM Syntax: MASK /CREATE $1 /FILTER 
/BORDER=<n>

MASK /CREATE is used to create a bitmask for 
defining active pixels. This bitmask is used in 
INTEGRATE, SMOOTH, and PER_CRYSTAL 
commands.

The user should be aware the bitmask or the 
octagon mask are used exclusively. That is if the 
bitmask is define, the octagon mask is ignored 
and visa versa.

8.1.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Threshold)     [1]

Threshold in counts. All Pixels whose value 
is below this threshold are flagged as inac-
tive.

/FILTER ................ (Filter)     [No]

Entering “Y” will filter out isolated inactive 
pixels and restore them to active status.

/BORDER=<n>..... (Border)     [1]

Number of pixels to extend the inactive pix-
els regions to eliminate partially blocked pix-
els from the active pixel bitmask.
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8.2 Peaks > Mask > Edit • Edit the 
active pixel mask

Menu Command: Peaks > Mask > Edit

Accelerator: None

User Level: 1

SLAM Syntax: MASK /EDIT (interactive only)

Use this command to manually edit the active 
pixel mask, pixel by pixel. You can turn off or on 
masked pixels with a click of the mouse. Hint: 
Zoom in on the image for better visualizing of 
individual pixels.

8.3 Peaks > Mask > Save • Save 
active pixel mask to disk file

Menu Command: Peaks > Mask > Create

Accelerator: None

User Level: 1

SLAM Syntax: MASK /SAVE $1

MASK /SAVE will store the current active bit-
mask to a disk file. Active bitmasks must be 
explicitly saved, because only the filename is 
stored in the frame header. One may also need 
to re-save the frame image, if the frame header 
was modified to include a new bitmask.

The user should be aware the bitmask or the 
octagon mask is used exclusively. That is if the 
bitmask is define, the octagon mask is ignored 
and visa versa.

8.3.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Bitmask Filename)     
[active.msk]

Filename of active pixel bitmask, “$NULL,” 
will cancel.
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8.4 Peaks > Mask > Read • Read 
active pixel mask from disk file

Menu Command: Peaks > Mask > Create

Accelerator: None

User Level: 1

SLAM Syntax: MASK /READ $1

MASK /READ will read an active bitmask file 
from disk and load it as the current bitmask. The 
special “$NULL” can be used to define a bit-
mask with all active pixels.

The user should be aware the bitmask or the 
octagon mask are used exclusively. That is if the 
bitmask is define, the octagon mask is ignored 
and visa versa.

8.4.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Bitmask Filename)     
[active.msk]

Filename of active pixel map, “$NULL,” to 
load an all active bitmask.

8.5 Peaks > Mask > View • View 
active pixel mask on screen

Menu Command: Peaks > Mask > Create

Accelerator: None

User Level: 1

SLAM Syntax: MASK /VIEW $1

MASK /VIEW allows viewing the active pixels 
mask on top of a frame image. All inactive pixels 
are masked out with a dot. Active pixels are left 
alone. The special bitmask “$NULL” can be 
used to clear the mask image, while “$MASK” 
refers to the current bitmask.

NOTE: MASK /VIEW does not change the cur-
rent active bitmask or octagon mask.

8.5.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Bitmask Filename)    
[$MASK]

Filename of active pixel map, “$NULL,” to 
clear window, “$MASK,” to view current 
active pixel map.
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8.6 Peaks > Mask > Octagon • 
Alternate active pixel mask using 
octagon region

Menu Command: Peaks > Mask > Create

Accelerator: None

User Level: 1

SLAM Syntax: MASK /OCTAGON $1 $2 $3 $4 
$5 $6 $7 $8

MASK /OCTAGON defines an octagon shaped 
mask which excludes pixels located on or out-
side the octagon from all INTEGRATE, 
SMOOTH, and PER_CRYSTAL commands. 
MASK /OCTAGON is frequently used on off-axis 
frames, where the beam stop does not occlude 
a portion of the image and on short time dura-
tion frames where the counting statistics are 
inadequate to properly define a bitmask of 
active pixels.

The user should be aware the bitmask or the 
octagon mask is used exclusively. That is if the 
bitmask is define, the octagon mask is ignored 
and visa versa.

8.6.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

Enter requested values in frame pixels.

512-mode
Defaults

1024-mode
Defaults

$1 (MIN X)    [0] [0]

$2 (MIN X+Y)    [60] [120]

$3 (MIN Y)    [0] [0]

$4 (MAX X-Y)    [451] [902]

$5 (MAX X)   [511] [1023]

$6 (MAX X+Y)    [962] [1924]

$7 (MAX Y)  [511] [1023]

$8 (MAX Y-X)    [451] [902]
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8.7 Peaks > Integrate > Chi • 
Perform chi integration in conic 
region -> F(2T)

Menu Command: Peaks > Integrate > Chi

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /CHI $1 $2 $3 $4 
/NORMAL=<n> /STEPSIZE=<n>

INTEGRATE /CHI will integrate a region along 
the chi direction and plot the results as intensity 
versus 2-theta. The resulting trace may be writ-
ten to a file using INTEGRATE /WRITE com-
mand, or inputted into the PEAKS /LOAD 
command.

The area to integrate is defined by specifying 
the 2-theta and chi range for the Debye-Scher-
rer cone. Chi zero is defined at 6 o'clock and 
goes CCW. Interactively, the user may redefine 
any of the integration region’s limits by selecting 
the limit's line number (1 to 4) and then using 
the cursor keys. The current integration region 
limits are continuously updated and displayed 
on the screen. While interactively modifying an 
integration limit, the <ESC> key or right button 
will restore the limit to its original value, while 
the <ENTER> or left button will accepts the new 
value for this limit. It is also feasible to move the 
entire integration window by pressing the “M” 
key, using the cursors to position a new center of 

the integration window, then pressing the 
<ENTER> key.

Once the integration window is defined, press-
ing <ENTER> will start the integration calcula-
tions and display the message:

Wait=Integrate; ESC,Other buttons=Quit

Normally, one waits for the calculations to finish 
and to plot the resulting data trace; however, 
should you wish to abort the procedure, press 
<ESC>. If too few data points were calculated, 
the command will terminate immediately. Other-
wise, the message below appears:

Warning—aborted early—Press ENTER to 
continue, ESC to abort.

Pressing <ESC> will terminate the INTEGRATE 
/CHI command immediately, while <ENTER> 
will accept the truncated data trace from the par-
tially integrated window (the upper chi limit was 
lowered) and display the trace.

While GADDS provides several methods of con-
verting frame images into raw spectra, you 
should be familiar with the differences between 
each method. Methods 0 and 4 are summations, 
while methods 1, 2, 3, and 5 are normalized to a 
ten pixel region.

1. Sum pixels:

2. Average pixel:

3. Arc Length: (quick and dirty)
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4. Solid Angle:

5. Bin Method

6. Normalized Bin: (preferred)

Methods 0 to 3 are described later. They are 
quick and dirty methods. In contrast, the bin 
method produces the most accurate results, 
although at a slower pace. The bin method will 
produce narrower profiles (FWHMs), smoother 
spectra, and improved relative intensities across 
the spectra.

Bins are determined by the start, end and step-
size of the integration. Say you requested the 
range 5 to 65 in 0.5 steps. The first bin covers 
the range 4.75 to 5.25; the second bin covers 
5.25 to 5.75; …; the last bin covers the range 
64.75 to 65.25. The idea is to place all of the 
observed intensity within each bin range into 
that bin. Each frame pixel covers one or more 
integration bins. The intensity of the each frame 
pixel is divided into these integration bins, using 
the fractional area as the weighting factor (eq. 
1). The sum of all of the fractional areas for any 
given pixel must equal one (eq. 2).

       N

Ii = Σ InAn,i eq. 1.

       n=1

          M

1.0 = Σ An,I eq. 2.

          i=1

WhereI = Intensity

i = integration bin number

n = frame pixel number

A = fractional area

N = total number of frame pixels

M = total number of integration bins

For speed considerations, the frame pixels at 
the edges of the integration region are not han-
dled precisely. For chi integration, if the center of 
the pixel lies within the specified chi integration 
region, then the entire pixel is used. If the pixel 
center is outside region, then the entire pixel is 
unused. So narrow chi integration regions, less 
than a pixel width, should not be used for chi 
integration. For 2-theta integration, if the center 
of the pixel lies within the specified 2-theta inte-
gration region, then the entire pixel is used. If 
the pixel center is outside the region, but any 
pixel corner is inside the 2-theta region, then ¼ 
of the pixel is used. So narrow or zero width 2-
theta integration regions can be used for 2-theta 
integration (needed for pole figure processing).

The normalized bin method varies from the 
above, only by normalizing each bin by the total 
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fractional area of all pixels for that bin (eq. 3). 
We scale the result by a factor of ten.

             N                 N

Ii = 10 [ Σ InAn,i ]/[ ΣAn,i] eq. 3.

             n=1              n = 1

The quick and dirty methods utilizes Bresen-
ham's Algorithm, which draws the conic lines 
with discrete pixels on a grid (see Figure 8.1). Its 
main advantage over the bin method is speed. 
Its disadvantages are accuracy, with broader 
FWHM and noisier spectra. With Bresenham's 
algorithm, you must select an appropriate inte-
gration step width. Too small and you integrate 
all the same pixels as in the previous integration 
step. Too large and you skip pixels between inte-
gration steps (the intensity at those pixels are 
never used in the spectra). Even with a good 
step width, the intensity at some pixels will be 
used for consecutive integration steps and an 
occasional pixel or two could be completely 
skipped.
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Figure 8.1 -  Bresenham's algorithm

Essentially, Bresenham bisected the problem 
into two cases depending upon the slope of the 
line. For steep slopes, the next pixel along the 
line always increases by one pixel in the vertical 
direction (Y), while the horizontal direction (X) 
may or may not increase by one pixel. Similarly, 
the converse exists for gentle slopes; the next 
pixel always increments in W, with or without an 
increment in Y. Negative slopes are handled by 
negating the X axis. Bresenham's algorithm 

adapts easily to computer graphics displays for 
line drawing.

The area detector image is stored as intensity 
values on a square pixel grid. For integrating 
along either 2θ or χ lines, Bresenham's algo-
rithm is used to determine the pixels along the 
line, and the intensities at each pixel are 
summed (method=0) or averaged (method=1). 
These methods equally weight the intensities of 
all pixels.

x
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The modified version of Bresenham's algorithm 
(see Figure 8.2) used by Bruker improves inte-
gration through summing the individual intensity 
values multiplied by a weighting factor (x1+x2), 
either arc length or solid angle. (While solid 
angle is technically more correct, in practice this 
weighting scheme gives nearly identical results 
as arc length, but is slower). This modified inte-
gration method must consider the previously 

chosen pixel, and so four cases arise for each 
slope region. The weighting given to each inten-
sity value varies by as much as forty percent, 
which improves the relative integrated intensi-
ties between vertical or horizontal regions and 
moderately sloped regions along a Debye ring. 
With highly textured samples, the resultant 2θ 
profiles exhibit true relative intensities between 
peaks of varying χ positions.

Figure 8.2 - Modified version of Bresenham's algorithm
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When executed interactively, the INTEGRATE 
/WRITE is executed upon successful termina-
tion. For more information, see the description 
of the INTEGRATE /WRITE sub-command.

8.7.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(2-Theta Start)     [0.00]

Enter lower 2-theta of conic region in 
degrees. Valid range is 0 to 179.

$2 ..........................(2-Theta End)     [30.00]

Enter upper 2-theta of conic region in 
degrees. Valid range is 1 to 180.

$3 ..........................(Chi Start)     [0.00]

Enter lower chi of conic region in degrees. 
Valid range is -360 to 180.

$4 ..........................(Chi End)     [360.00]

Enter upper chi of conic region in degrees. 
Valid range is -180 to 360.

/NORMAL=<n> .....(Normalize intensity)     [5]

When integrating pixels along a conic line 
segment, each pixel may be weighted by a 
normalization factor. Available normaliza-
tions are 0=none (sums all active pixels), 
1=average pixel (sum of pixels / number of 
pixels), 2=arc length (sum of {pixels * arc 
length} / sum of arc lengths), 3=solid angle 

(sum of {pixels * solid angle} / sum of solid 
angle), 4=bin method, 5=normalized bin 
method. See Peaks > Integrate > Chi for full 
description of this normalization method.

/STEPSIZE=<n>... (Step size)     [0.1]

The angle step width in degrees. The 
default of 0.1 works well for frames taken at 
7 cm. Frames taken at 10 cm may need a 
smaller stepsize.
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8.8 Peaks > Integrate > 2Theta • 
Perform 2-theta integration in conic 
region -> F(chi)

Menu Command: Peaks > Integrate > 2theta

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /2THETA $1 $2 $3 
$4 /NORMAL=<n> /STEPSIZE=<n>

INTEGRATE /2THETA will integrate a region 
along the 2-theta direction and plot the results 
as intensity versus chi. Such chi plots are useful 
for examining texture effects within the data. The 
resulting trace may be written to a file using 
INTEGRATE /WRITE command, or inputted into 
the PEAKS /LOAD command.

The area to integrate is defined by specifying 
the 2-theta and chi range for the Debye-Scher-
rer cone. Chi zero is defined at 6 o'clock and 
goes CCW. Interactively, the user may redefine 
any of the integration region’s limits by selecting 
the limit's line number (1 to 4) and then using 
the cursor keys. The current integration region 
limits are continuously updated and displayed 
on the screen. While interactively modifying an 
integration limit, the <ESC> key or right button 
will restore the limit to its original value, while 
the <ENTER> or left button will accepts the new 
value for this limit. It is also feasible to move the 
entire integration window by pressing the “M” 
key, using the cursors to position a new center of 

the integration window, then pressing the 
<ENTER> key.

Once the integration window is defined, press-
ing <ENTER> will start the integration calcula-
tions and display the message:

Wait=Integrate; ESC,Other buttons=Quit

Normally, one waits for the calculations to finish 
and to plot the resulting data trace; however, 
should you wish to abort the procedure, press 
<ESC>. If too few data points were calculated, 
the command will terminate immediately. Other-
wise, the message below appears:

Warning—aborted early—Press ENTER to 
continue, ESC to abort

Pressing <ESC> will terminate the INTEGRATE 
/2THETA command immediately, while 
<ENTER> will accept the truncated data trace 
from the partially integrated window (the upper 
chi limit was lowered) and display the trace.

When executed interactively, the INTEGRATE 
/WRITE is executed upon successful termina-
tion. For more information, see the description 
of the INTEGRATE /WRITE sub-command.
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8.8.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(2-Theta Start)     [0.00]

Enter lower 2-theta of conic region in 
degrees. Valid range is 0 to 179.

$2 ..........................(2-Theta End)     [30.00]

Enter upper 2-theta of conic region in 
degrees. Valid range is 1 to 180.

$3 ..........................(Chi Start)     [0.00]

Enter lower chi of conic region in degrees. 
Valid range is -360 to 180.

$4 ..........................(Chi End)     [360.00]

Enter upper chi of conic region in degrees. 
Valid range is -180 to 360.

/NORMAL=<n> .....(Normalize intensity)     [3]

When integrating pixels along a conic line 
segment, each pixel may be weighted by a 
normalization factor. Available normaliza-
tions are 0=none (sums all active pixels), 
1=average pixel (sum of pixels / number of 
pixels), 2=arc length (sum of {pixels * arc 
length} / sum of arc lengths), 3=solid angle 
(sum of {pixels * solid angle} / sum of solid 
angle), 4=bin method. See Peaks > Inte-
grate > Chi for full description of this normal-
ization method.

/STEPSIZE=<n>... (Step size)     [0.1]

The angle step width in degrees. The 
default of 0.1 works well for frames taken at 
7 cm. Frames taken at 10 cm may need a 
smaller stepsize.
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8.9 Peaks > Integrate > Area • 
Perform area integration in conic 
region -> integer

Menu Command: Peaks > Integrate > Area

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /AREA  $1  $2  $3  
$4

Integrates total counts inside (and on) a user 
defined conic region. Does not subtract out 
background.

8.9.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(2-Theta Start)     [0.00]

Enter lower 2-theta of conic region in 
degrees. Valid range is 0 to 179.

$2 ..........................(2-Theta End)     [30.00]

Enter upper 2-theta of conic region in 
degrees. Valid range is 1 to 180.

$3 ..........................(Chi Start)     [0.00]

Enter lower chi of conic region in degrees. 
Valid range is -360 to 180.

$4 ......................... (Chi End)     [360.00]

Enter upper chi of conic region in degrees. 
Valid range is -180 to 360.
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8.10 Peaks > Integrate > Slice • 
Perform chi integration in rectangular 
region -> F(2t)

Menu Command: Peaks > Integrate > Slice

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /SLICE $1 $2 $3 $4 
/NORMAL=<n> /STEPSIZE=<n>

INTEGRATE /SLICE will integrate a rectangular 
region along the chi direction and plot the 
results as intensity versus 2-theta. The resulting 
trace may be written to a file using INTEGRATE 
/WRITE command, or inputted into the PEAKS 
/LOAD command.

The area to integrate is defined by specifying 
the 2-theta range, chi, and height of rectangular 
box. Chi zero is defined at 6 o'clock and goes 
CCW. Interactively, the user may redefine any of 
the integration region’s limits by selecting the 
limit's line number (1 to 4) and then using the 
cursor keys. The current integration region limits 
are continuously updated and displayed on the 
screen. While interactively modifying an integra-
tion limit, the <ESC> key or right button will 
restore the limit to its original value, while the 
<ENTER> or left button will accepts the new 
value for this limit.

Once the integration window is defined, press-
ing <ENTER> will start the integration calcula-
tions and display the message:

Wait=Integrate; ESC,Other buttons=Quit

Normally, one waits for the calculations to finish 
and to plot the resulting data trace; however, 
should you wish to abort the procedure, press 
<ESC>. If too few data points were calculated, 
the command will terminate immediately. Other-
wise, the message below appears:

Warning—aborted early—Press ENTER to 
continue, ESC to abort

Pressing <ESC> will terminate the INTEGRATE 
/SLICE command immediately, while <ENTER> 
will accept the truncated data trace from the par-
tially integrated window (the upper chi limit was 
lowered) and display the trace.

When executed interactively, the INTEGRATE 
/WRITE is executed upon successful termina-
tion. For more information, see the description 
of the INTEGRATE /WRITE sub-command.

8.10.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (2-Theta Start)     [0.00]

Enter lower 2-theta of conic region in 
degrees. Valid range is 0 to 179.

$2 ......................... (2-Theta End)     [30.00]

Enter upper 2-theta of conic region in 
degrees. Valid range is 1 to 180.
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$3 ..........................(Chi Angle)     [90.00]

Enter chi of rectangular region in degrees. 
Valid range is -360 to 360.

$4 ..........................(Height in Pixels)     [10]

Enter height in pixels of rectangular region. 
Valid range is 0 to {framesize-1}.

/NORMAL=<n> .....(Normalize intensity)     [3]

When integrating pixels along a conic line 
segment, each pixel may be weighted by a 
normalization factor. Available normaliza-
tions are 0=none (sums all active pixels), 
1=average pixel (sum of pixels / number of 
pixels), 2=arc length (sum of {pixels * arc 
length} / sum of arc lengths), 3=solid angle 
(sum of {pixels * solid angle} / sum of solid 
angle). See Peaks > Integrate > Chi for a full 
description of this normalization method.

/STEPSIZE=<n> ...(Step size)     [0.1]

The angle step width in degrees. The 
default of 0.1 works well for frames taken at 
7 cm. Frames taken at 10 cm may need a 
smaller stepsize.
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8.11 Peaks > Integrate > Write • 
Write integration results to disk file

Menu Command: Peaks > Integrate > Write

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /WRITE $1 
/FILENAME=<n> /FORMAT=<n> /APPEND

INTEGRATE /WRITE will output the results from 
either integration to a disk file format which is 
compatible with conventional powder diffraction 
data processing software. Four file formats are 
supported:

• PLOTSO is simple ASCII file format which is 
very portable to any computer platform.

• OLD_DIFFRAC-AT is the file format used by 
ancient PC-based software. This file format 
is binary and is difficult to read on non-PC 
platforms.

• DIFFRAC-AT is the file format used by older 
PC-based software. This file format is binary 
and is difficult to read on non-PC platforms.

• DIFFRACplus is the file format used by the 

Bruker DIFFRACplus software. This file for-
mat is binary and is difficult to read on non-
INTEL platforms.

INTEGRATE /WRITE is capable of output any 
one of the supported file formats. All four file for-
mats are also capable of supporting multiple 

ranges. To write the data to a new scan range of 
an existing file, set the append flag.

8.11.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Title)     [auto default]

Title of plot. In SLAM mode enclose the title 
in quotes.

/FILENAME=<n> .. (File Name)     [auto default]

Name of the RAW data file to create or 
append.

/FORMAT=<n> ..... (Format)     [DIFFRACplus]

Enter file format as either: DIFFRACplus, 
DIFFRAC-AT, OLD-DIFFRAC-AT, or 

PLOTSO. DIFFRACplus is the latest file for-
mat and thus the preferred option. PLOTSO 
files have standard ASCII format. Non-
Bruker programs should be able to read 
PLOTSO files (i.e., LOTUS 123, and MS 
EXCEL). File extensions are defaulted to 
*.RAW for most formats and to *.PLT for 
PLOTSO format.

/APPEND.............. (Append as Additional 
Range)     [Yes]

Enter “Y” to write this new data range as the 
next range in any existing file. If the file 
doesn't exists, it will be created with this 
data as the first and only range. Enter “N” to 
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delete any existing file(s) and create a new 
one range raw data file(s).

/SCALE .................(Scale Factor)     [1.0]

Enter multiplicative scale factor or 1.0 for 
none. The entire range of the written raw 
data file will be multiplied by this scale fac-
tor.

8.12 Peaks > Integrate > Clear • 
Clear graph on top of image

Menu Command: Peaks > Integrate > Clear

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /CLEAR

INTEGRATE /CLEAR will remove the results 
from the previous integration from the screen 
without erasing the data frame.

8.12.1 Arguments

None. Command executes immediately.
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8.13 Peaks > Integrate > Rectangle • 
Perform rectangle integration for 
detector testing

Menu Command: Peaks > Integrate > 
Rectangle

Accelerator: None

User Level: 1

SLAM Syntax: INTEGRATE /RECTANGLE  $1  
$2  $3  $4  /VERTICAL

Use this command to sum pixel intensities along 
either the vertical or horizontal directions. Useful 
for diagnostic purposes mainly.

8.13.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(X start)     [1]

X pixel of rectangle left side.

$2 ..........................(X end)     [510]

X pixel of rectangle right side.

$3 ..........................(Y start)     [1]

Y pixel of rectangle bottom side.

$4 ..........................(Y end)     [510]

Y pixel of rectangle top side.

/VERTICLE........... (Verticle Y.N)     [Yes]

Check to integrate vertical, uncheck to inte-
grate horizontal.
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8.14 Peaks > Refl. Array > Threshold 
• Place spots/threshold in a series of 
frames into the array

Menu Command: Peaks > Refl. Array > 
Threshold

Accelerator: None

User Level: 1

SLAM Syntax:

REFL_ARRAY /THRESHOLD $1 $2 /CON-
TIG=<n> /COUNTS=<n> /SIGMA=<NN> 
/XEXMIN=<n> /XEXMAX=<n> /RMAX=<n> 
/DMIN=<n> /DMAX=<n> /DBIAS=<n> 
[$3 $4 $5 $6 $7 $8]

This routine provides a means for automatically 
picking reflections from a series of data frames 
and placing them in the Reflection Array. The 
algorithm provides control over selection factors 
such as intensity threshold and resolution range.

Spots entered into the array in this manner 
always have the A flag set, and contain the goni-
ometer setting angles, detector X,Y position, 
intensity normalized to 1 deg/min, and I/sigma. If 
the pixels above the threshold span more than 
one frame, the computed scan-angle centroid is 
more precise, and the C flag is set for that 
reflection. These “centered” reflections are 
especially suitable for autoindexing and least 
squares; however, if you can't find many reflec-
tions that span frames, you can set the C flags 

manually with the REFL_ARRAY /MODIFY com-
mand to force the autoindexing and least 
squares to use all the reflections found by 
/THRESHOLD. If a valid spatial correction is in 
effect (highly recommended), the X,Y values 
entered into the array will represent the spatially 
corrected X,Y position, and the S flag for that 
reflection will be set; otherwise, the raw X,Y will 
be entered and the S flag will be clear.

In the special case where you’re thresholding 
reflections from a single frame ($2 = 1; see 
below) the program automatically sets the C 
flags. This makes indexing from a single frame 
(or better, from two nearly orthogonal oscillation 
pictures) more convenient. When attempting to 
index from one or two oscillation pictures, it is 
best to use fairly wide frames (e.g., 0.5–1.5 
degrees) to insure that changes in all three HKL 
indices are represented in each picture.

Normally, the setting angles for each frame are 
extracted directly from the frame itself; however, 
XENGEN-format frames taken with data collec-
tion software earlier than FRAMBO Version 2 do 
not contain the required information. You can 
still threshold frames acquired with earlier ver-
sions with use of the setting angle “override” 
options, described below. Make sure that these 
override options are all set at their default values 
(of 9999) unless you're processing old frames.

When invoked with the THRESHOLD option 
from the REFL_ARRAY submenu or when run 
from the command line without arguments, 
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REFL_ARRAY /THRESHOLD displays an input 
panel where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button begins 
refinement of the unit cell and orientation 
parameters; the ESC key or right mouse button 
returns you to the REFL_ARRAY submenu. You 
can interrupt thresholding in progress with the 
CTRL-BREAK key combination.

When thresholding starts, the program displays 
the name of the last frame thresholded and the 
number of spots found on the bottom status line. 
Note that if the number of spots per frame is 
larger than 512/N where N is the number of 
frames being thresholded, your threshold is too 
low or you're thresholding too many frames. 
Autoindexing and least squares run optimally if 
they have at least 25 and preferably 50–100 
“centered” spots; more is overkill. The recom-
mended procedure prior to indexing (but after 
the detector distance, flood-field correction, spa-
tial correction, and beam center have been 
determined) is to threshold about half the 
desired number of spots from a few frames (say, 
10 contiguous frames) into a blank Reflection 
Array, and then repeat the procedure with 
another series of 10 frames starting about 90 
degrees in scan angle from the first set.

After all frames have been read in, the program 
requires a few seconds to compute integrated 
intensities and sort the output. Upon comple-
tion, a scrolling output window is displayed con-
taining the resulting output text. If logging is 

enabled (see LOGFILE) the contents of this win-
dow are also written to the logfile. When viewing 
the output, pressing ENTER or the left mouse 
button displays a pop-up menu of options, 
including export of ASCII data; for example, the 
contents of the window could be sent to a file or 
printer with this function. You can also move 
through the window contents with the page 
keys, arrow keys or with mouse motion. Press-
ing ESC or the right mouse button exits the out-
put window. The program then displays the 
prompt:

<n> SPOTS WILL BE INSERTED IN 
ARRAY AT # <M>

--PRESS ENTER TO CONTINUE, ESC TO 
QUIT

where <n> represents the number of reflections 
found and <M> represents the line number of 
the first empty record in the Reflection Array. If 
you press the ENTER key or left mouse button, 
the program stores the thresholded reflections in 
the array, then displays the Reflection Array in 
an editing window for review (see REFL_ARRAY 
/EDIT for description and operation of the edit-
ing window). Pressing the ESC key or right 
mouse button at the above prompt, or from 
within this editing window, returns you to the 
REFL_ARRAY submenu. The output window 
contents are described in more detail below.

If REFL /THRESHOLD was invoked from the 
command line, the output window is displayed 
subject to a 10 s timeout to allow command 
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scripts to run without intervention. If you do not 
press a key or mouse button within 10 s after the 
output window is displayed, the program will 
continue as if the ESC key had been pressed.

When invoked from the command line, REFL 
/THRESHOLD can take the following arguments 
(where <n> represents a numeric value, & indi-
cates continuation on the next line). Optional 
command-line parameters are shown in square 
brackets. If you don't supply these parameters 
on the command line, the command still runs 
without intervention, with the default value 
(9999=get value from frame header) assumed:

8.14.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(First Input File Name)    
[FRAME.000]

Enter the file name for the first frame in the 
series to process. For example, if you have 
15 data frames to be thresholded beginning 
with SAMPL.001 and ending with 
SAMPL.015, then you would enter 
“SAMPL.001” as the first frame in the series. 
When in the input panel, if you leave this 
entry blank or specify a “wildcard” filename 
pattern, pressing the ENTER key or the left 
mouse button will display a list of the current 
filenames matching the pattern. You can 
choose one from the displayed list by mov-

ing to it with the arrow/page keys or mouse 
and pressing ENTER or the left mouse but-
ton. You will be returned to the input panel 
with the selected filename filled in. If you 
leave this item blank, it is the same as enter-
ing a *.* wildcard pattern. Both filenames 
and patterns entered here are merged with 
the CONFIGURE /EDIT frame directory (se 
CONFIGURE /EDIT for a description of how 
this is done).

$2 ......................... (# Frames to Process)     [7]

Enter the number of consecutive frames to 
process. It is not necessary to enter all 
frames in a series. Try to pick number of 
frames and threshold that result in about 
100 spots being written to the array.

/CONTIG=<n>...... (Max Pixel Separation)     [1]

Enter the maximum number of pixels of sep-
aration still considered contiguous within a 
given reflection. Statistical fluctuations could 
cause a pixel within a reflection to drop 
below the threshold whereas its neighbors 
exceed the threshold. Raising the value 
given here allows pixels to be considered 
part of the same reflection even if they are 
separated by below-threshold pixels. The 
default of 1 specifies that pixels must be 
contiguous, and should be satisfactory for 
the vast majority of cases.
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/COUNTS=<n>......(Raw Count Threshold)     
[50]

Process pixels that have counts equal to or 
greater than this value. Try to pick a value 
that will place about 100 reflections in the 
array. Note that a threshold that is low 
enough to accept background points as 
possible reflections can cause autoindexing 
to fail. A quick way of determining a thresh-
old is to display a frame with the minimum 
display counts set to zero and the maximum 
display counts set to a power of 2 (for exam-
ple, 64 or 128), then use the CONTRAST 
command to threshold the image. Move the 
mouse all the way to the left for maximum 
contrast (i.e., a sharp black-to-white transi-
tion), then move the mouse up and down 
until a reasonable number of spots (for 
example, 100 divided by the number of 
frames you're going to threshold) is visible. 
You can then estimate the threshold from 
the point where the black-to-white transition 
occurs in the color bar at the right of the 
screen.

/SIGMA=<n> .........(I/Sigma Threshold)     [20]

Retain only those reflections with I/sigma 
(that is, its intensity divided by its standard 
deviation) at or above this value times the 
thermal falloff compensation derived from 
the value given for /DBIAS below. I/SIGMA 
computed for each reflection is multiplied by 

EXP(DBIAS * S2) where S is sin(theta)/

lambda. If the result is lower than the value 
specified here, the reflection is rejected.

/XEXMIN=<n> ...... (Minimum Excluded X)     [0]

Exclude spots with an X-centroid between 
the value specified here and that specified 
as /XEXMAX below. This is useful for 
excluding the area near the beam stop. The 
value is in pixels in the Bruker coordinate 
convention with X,Y=(0,0) at the lower left of 
a displayed frame.

/XEXMAX=<n> ..... (Maximum Excluded X)     
[30]

Exclude spots with an X-centroid between 
the value specified as /XEXMIN above and 
the value specified here. This is useful for 
excluding the area near the beam stop. The 
value is in pixels in the Bruker coordinate 
convention with X,Y=(0,0) at the lower left of 
a displayed frame.

/RMAX=<n>.......... (Radius Cutoff)     [265]

Enter the maximum allowed distance of a 
reflection centroid from the detector center 
(in pixels). Reflections which exceed this 
value are rejected. Valid range is from 0 to 
300.

/DMIN=<n>........... (Minimum Angstroms)     
[1.5]

Enter the minimum allowed interplanar 
spacing in Angstroms corresponding to a 
reflection centroid. Reflections at higher 
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(better) resolution than the value specified 
here are rejected.

/DMAX=<n> ..........(Maximum Angstroms)     
[100]

Enter the maximum allowed interplanar 
spacing in Angstroms corresponding to a 
reflection centroid. Reflections at lower 
(worse) resolution than the value specified 
here are rejected.

/DBIAS=<n>..........(Temperature Factor)     [10]

Enter the B-factor in Angstroms2 used to 
bias the I/sigma threshold test as a function 
of resolution. I/SIGMA computed for each 

reflection is multiplied by EXP(DBIAS * S2) 
where S is sin(theta)/lambda. If the result is 
lower than the value specified as /SIGMA 
(see above), the reflection is rejected.

$3 ..........................(2-Theta override)     [9999]

Enter the swing (2-theta setting) angle in 
degrees to be assumed for the frame series. 
The default value, 9999, specifies that the 
swing angle is to be extracted from the 
frames themselves, which is the normal 
mode of operation. If you're processing old 
XENGEN-format frames (acquired with soft-
ware earlier than FRAMBO Version 2), you'll 
need to explicitly specify the angle here. For 
frames in XENGEN or BRUKER format 
acquired with FRAMBO V2 or higher, spec-
ify 9999.

$4 ......................... (Omega override)     [9999]

Enter the starting omega setting angle in 
degrees to be assumed for the frame series. 
The default value, 9999, specifies that 
omega is to be extracted from the frames 
themselves, which is the normal mode of 
operation. If you're processing old XEN-
GEN-format frames (acquired with software 
earlier than FRAMBO Version 2), you'll need 
to explicitly specify the angle here. For 
frames in XENGEN or BRUKER format 
acquired with FRAMBO V2 or higher, spec-
ify 9999.

$5 ......................... (Phi override)     [9999]

Enter the starting phi setting angle in 
degrees to be assumed for the frame series. 
The default value, 9999, specifies that phi is 
to be extracted from the frames themselves, 
which is the normal mode of operation. If 
you're processing old XENGEN-format 
frames (acquired with software earlier than 
FRAMBO Version 2), you'll need to explicitly 
specify the angle here. For frames in XEN-
GEN or BRUKER format acquired with 
FRAMBO V2 or higher, specify 9999.

$6 ......................... (Chi override)     [9999]

Enter the chi setting angle in degrees to be 
assumed for the frame series. The default 
value, 9999, specifies that chi is to be 
extracted from the frames themselves, 
which is the normal mode of operation. If 
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you're processing old XENGEN-format 
frames (acquired with software earlier than 
FRAMBO Version 2), you'll need to explicitly 
specify the angle here. For frames in XEN-
GEN or BRUKER format acquired with 
FRAMBO V2 or higher, specify 9999.

$7 ..........................(Scan axis override)     
[9999]

Enter the scan axis number (2 for omega, 3 
for phi) to be assumed for the frame series. 
The default value, 9999, specifies that the 
scan axis is to be extracted from the frames 
themselves, which is the normal mode of 
operation. If you're processing old XEN-
GEN-format frames (acquired with software 
earlier than FRAMBO Version 2), you'll need 
to explicitly specify the axis here. For frames 
in XENGEN or BRUKER format acquired 
with FRAMBO V2 or higher, specify 9999.

$8 ..........................(Frame width override)     
[9999]

Enter the signed frame width in degrees to 
be assumed for the frame series. The 
default value, 9999, specifies that the width 
is to be extracted from the frames them-
selves, which is the normal mode of opera-
tion. If you're processing old XENGEN-
format frames (acquired with software ear-
lier than FRAMBO Version 2), you'll need to 
explicitly specify the width here. For frames 
in XENGEN or BRUKER format acquired 
with FRAMBO V2 or higher, specify 9999.

8.14.2 Threshold Output

An example of the output from REFL_ARRAY 
/THRESHOLD is shown below, resulting from 
thresholding of the eight myoglobin test frames 
supplied with the software. It begins with an 
overall statistical summary of the number of 
reflections found and their disposition. This sum-
mary contains:

# FOUND

Total number of reflections above the 
threshold found

# ON FIRST OR LAST FRAME

Reflections which have intensity on the first 
or last frame are rejected because their 
scan angle cannot be accurately deter-
mined.

# IN X-EXCLUSION RANGE

This is the number of reflections rejected 
because their X-centroid was between the 
limits specified as /XEXMIN and /XEXMAX.

# OUTSIDE RADIUS LIMIT

This is the number of reflections rejected 
because the distance of their X,Y centroid 
from the detector center was larger than the 
limit given as /RMAX.
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# OUTSIDE RES LIMITS

This is the number of reflections rejected 
because their X,Y-centroid was outside of 
the resolution limits specified as /DMIN and 
/DMAX.

# < I/SIGMA THRESHOLD

This is the number of reflections rejected 

because their (I/SIGMA) * EXP(DBIAS * S2) 
was below of the threshold specified as 
/SIGMA.

# ORPHAN PIXELS

This is the number of reflections rejected 
because there was only a single pixel over 
the threshold.

# BIFURCATED

This is the number of spots where the 2D 
intensity on one frame merges with the 2D 
intensity of more than one spot on an adja-
cent frame. These reflections are rejected.

TOTAL # USEABLE

Number of non-rejected reflections found.

# CENTERED FOR LS

The number of reflections with the C flag 
set. These are reflections whose intensity 
spanned more than one frame, and are 
especially suitable for autoindexing or least 
squares (LS).

TOTAL # UNUSED

Number of rejected reflections

Following the overall statistics is a reflection-by-
reflection summary. For each reflection, a line 
contains (in order) the X,Y and scan-angle cen-
troids (X and Y are in pixels, and scan angle is in 
degrees), the integrated intensity normalized to 
1 deg/min, the intensity divided by its standard 
deviation, the resolution of the reflection in Ang-
stroms, and a hexadecimal code where each set 
bit indicates a status condition. Conditions 4 and 
8 (code 000C hex when combined) are desir-
able; the others cause the reflection to be 
rejected. Bit assignments in the status code are:

Bit # Value (Hex) Meaning

0 1 Reflection rejected if set

1 2 Reflection is bifurcated

2 4 Found a close 2D spot on 
adjacent frame

3 8 Reflection spans frames

4 10 Orphan pixel

5 20 Excluded by X limits

6 40 Excluded by resolution limits

7 80 Excluded by radius limit

8 100 Excluded by I/sigma limit
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Example output follows:

Example 8.1 - REFL_ARRAY /THRESHOLD Output from 
Eight Myoglobin Test Frames

Reflection disposition:
# found = 133
# on first or last frame = 33
# in X-exclusion range = 5
# outside radius limit = 10
# outside res. limits = 0
# < I/sigma threshold = 0
# orphan pixels = 11
# bifurcated = 0
Total # useable = 107
# “centered” for LS = 26
Total # unused = 26

X Y Rot Inorm #Sig D Code
82.9 51.2 -0.3 627 112 4.1 000C
33.3 99.1 -0.4 468 97 5.4 000C
142.1 309.5 -0.4 344 83 4.2 000C
82.9 196.2 -0.6 379 87 5.6 000C
130.0 127.2 -0.6 285 76 4.1 000C
156.7 28.7 -0.7 223 67 3.2 000C
164.6 264.0 -0.7 228 68 4.0 000C
198.8 241.4 -0.7 205 64 3.5 000C
95.1 77.1 -0.6 175 59 4.2 000C
96.6 357.5 -0.6 179 60 4.6 000C
177.8 104.2 -0.3 142 53 3.4 000C
269.2 173.1 -0.3 97 44 2.8 000C
145.1 403.4 -0.7 121 49 3.6 000C
222.9 151.2 -0.7 77 39 3.2 000C
94.6 149.6 -0.4 81 40 4.9 000C
219.5 450.4 -0.6 49 31 2.8 000C
190.3 80.3 -0.6 51 32 3.2 000C
192.9 29.7 -0.7 47 31 3.0 000C
34.9 313.0 -0.4 71 38 6.8 000C
58.8 195.7 -0.3 63 36 6.3 000C
119.6 333.3 -0.3 53 33 4.4 000C
141.2 196.4 -0.3 52 32 4.3 000C

281.8 150.3 -0.4 22 21 2.7 000C
107.0 287.4 -0.7 32 26 5.0 000C
322.7 376.5 -0.3 14 17 2.4 000C
155.1 79.3 -0.6 10 14 3.5 000C
107.2 52.7 -0.8 355 85 3.8 0005
141.2 173.6 -0.8 369 86 4.2 0001
164.8 286.4 -0.8 334 82 3.9 0001
83.4 287.8 -0.2 325 81 5.5 0005
164.4 219.1 -0.8 246 70 4.0 0005
117.8 173.3 -0.1 230 68 4.6 0001
165.5 127.6 -0.3 178 60 3.7 0000
175.7 196.5 -0.1 177 60 3.8 0001
70.6 75.7 -0.2 191 62 4.5 0005
143.7 53.8 -0.1 135 52 3.5 0001
210.9 285.8 -0.2 98 44 3.4 0001
167.7 378.3 -0.5 99 45 3.5 0000
267.9 3.1 -0.9 63 36 2.5 0001
224.1 330.9 -0.3 84 41 3.2 0000
134.1 428.5 -0.2 93 43 3.6 0001
210.3 196.4 -0.3 85 41 3.4 0000
263.7 400.4 -0.7 56 34 2.7 0000
82.8 219.2 -0.1 87 42 5.7 0001
352.0 51.8 -0.5 36 27 2.2 0000
33.9 195.3 -0.3 90 43 7.2 0000
82.9 101.5 -0.8 75 39 4.6 0000
177.6 331.6 -0.8 65 36 3.6 0000
176.6 308.8 -0.3 65 36 3.7 0000
176.1 173.8 -0.7 60 35 3.7 0000
329.7 240.1 -0.1 37 27 2.5 0001
202.8 377.3 -0.5 50 32 3.2 0000
58.2 100.7 -0.5 60 35 5.0 0000
83.8 311.2 -0.7 60 35 5.4 0000
106.5 242.1 -0.4 57 34 5.1 0000
225.0 353.8 -0.8 39 28 3.1 0001
180.7 401.7 -0.6 38 28 3.3 0000
215.7 55.4 -0.4 33 26 2.9 0000
199.2 285.9 -0.9 39 28 3.5 0001
284.2 352.7 -0.6 27 23 2.7 0000
108.7 380.6 -0.2 41 29 4.2 0005
142.1 103.7 -0.5 38 28 3.8 0000
304.1 240.0 -0.6 25 23 2.6 0000
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294.8 126.9 -0.7 23 21 2.6 0000
321.4 102.0 -0.8 20 20 2.4 0005
236.8 353.7 -0.3 24 22 3.0 0000
257.1 285.0 -0.2 24 22 2.9 0001
190.1 354.3 -0.5 27 23 3.4 0000
400.8 98.7 -0.3 13 16 2.1 0000
300.1 503.1 -0.5 16 18 2.3 0000
211.5 308.2 -0.4 26 23 3.3 0000
256.9 196.0 -0.4 21 21 2.9 0000
234.9 128.2 -0.8 21 21 3.0 0000
200.4 128.1 -0.4 23 22 3.3 0000
296.8 353.0 -0.2 17 18 2.6 0005
132.4 380.0 -0.8 26 23 3.9 0005
325.7 53.4 -0.8 11 15 2.3 0000
304.2 262.2 -0.5 13 16 2.6 0000
303.9 217.5 -0.7 12 16 2.6 0000
290.0 424.7 -0.9 11 15 2.5 0001
257.5 173.6 -0.8 12 16 2.9 0000
106.4 219.3 -0.7 18 19 5.1 0000
210.6 173.7 -0.8 14 17 3.3 0005
315.9 217.4 -0.4 10 14 2.5 0000
106.7 264.7 -0.5 16 18 5.1 0000
316.2 239.9 -0.3 8 13 2.5 0000
210.8 218.8 -0.2 11 15 3.4 0001
234.9 151.0 -0.2 10 14 3.1 0001
60.6 407.7 -0.9 13 16 4.6 0001
182.7 2.8 -0.5 9 13 2.9 0000
269.6 150.3 -0.7 8 13 2.8 0000
316.3 262.0 -0.3 7 12 2.5 0000
436.9 191.6 -0.2 4 9 2.0 0001
157.7 426.6 -0.8 9 14 3.4 0001
258.4 307.4 -0.5 8 12 2.9 0000
328.4 217.5 -0.2 6 11 2.5 0001
73.4 432.3 -0.7 10 14 4.2 0000
145.8 1.4 -0.7 8 13 3.2 0000
59.9 312.0 -0.5 11 15 6.0 0000
231.6 4.0 -0.2 5 10 2.7 0001
307.2 126.6 -0.4 4 9 2.5 0000
209.7 476.2 -0.3 5 10 2.8 0000
292.0 262.0 -0.9 4 9 2.7 0001

244.6 240.8 -0.5 5 10 3.1 0000
257.0 218.1 -0.2 4 9 3.0 0001
213.3 103.9 -0.6 5 10 3.1 0000
198.6 218.8 -0.9 5 10 3.5 0001
379.1 50.9 -0.3 2 7 2.1 0010
337.2 400.8 -0.8 3 7 2.3 0010
312.7 503.5 -0.2 2 7 2.2 0011
334.0 102.0 -0.7 2 6 2.3 0010
270.4 329.3 -0.4 3 7 2.8 0010
303.5 195.3 -0.9 2 6 2.6 0011
244.7 218.5 -0.6 3 7 3.1 0010
260.4 104.3 -0.6 2 6 2.8 0010
250.3 377.0 -0.5 2 6 2.8 0010
147.2 454.3 -0.6 2 7 3.3 0010
72.0 25.8 -0.3 2 7 3.9 0010
23.8 435.2 -0.6 170 59 4.7 002C
7.9 98.7 -0.8 299 78 5.9 0025
22.8 362.3 -0.2 97 44 6.1 0021
8.8 194.9 -0.6 88 42 8.5 0020
9.7 314.0 -0.8 13 16 7.8 0020
-2.6 362.4 -0.6 773 125 6.8 008C
48.6 434.3 -0.5 396 89 4.5 008C
61.8 459.2 -0.5 179 60 4.0 008C
95.7 26.0 -0.7 117 49 3.7 008C
136.7 480.4 -0.3 77 39 3.2 008C
86.4 457.2 -0.8 687 118 3.8 0085
-3.9 146.8 -0.2 288 76 7.6 0085
35.3 409.2 -0.9 117 49 5.0 0081
38.3 459.1 -0.5 26 23 4.3 0080
75.5 483.8 -0.9 11 15 3.7 0081
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8.15 Peaks > Refl. Array > Pick • 
Select spots from currently displayed 
frame to put in array

Menu Command: Peaks > Refl. Array > Pick

Accelerator: None

User Level: 1

SLAM Syntax:

REFL_ARRAY /PICK $1 $2 $3 $4 
/START=<n> /QUADRANT=<n> 
/FRAME_HALFWIDTH=<n>

This option provides an interactive means for 
adding reflections to the array. This is useful in 
cases where a known reflection has fallen below 
threshold during automatic picking, or when you 
want to isolate specific reflections to see if there 
is a satellite or twinning in the sample. This com-
mand is very similar to GRAPH /ROCKING, 
except that the computed 3D intensity-weighted 
centroid coordinates and setting angles are 
entered into the Reflection Array on completion.

Before running REFL_ARRAY /PICK, a set of 
data frames must be collected with fixed step 
size in any angle (a single frame is sufficient, but 
the centroid in scan angle will not be precisely 
determined, and the rocking curve will not be 
displayed). Use the DISPLAY or LOAD com-
mand to display the central frame about which 
you want the rocking curve to be computed.  
Then, invoke REFL_ARRAY /PICK, where a 
rectangular cursor like the one in CURSORS 

/BOX is used to select a region within the data 
frame. From this, the program calculates the 
background-subtracted intensity for that region 
in each frame. If /FRAME-HALFWIDTH is 
greater than zero (that is, if intensity was 
obtained from more than a single frame) the 
program also displays the results in a plot of 
intensity versus scan angle. Background-sub-
tracted intensity is determined in the same way 
as for CURSORS /BOX. The background is 
computed as the average of the points on the 
perimeter of the box, excluding those points 
which are more than 3 standard deviations 
above the mean. You have to be careful to 
choose the correct box size, since in some 
cases the X,Y centroid of the x-ray reflection 
may change as a function of scan angle.

When invoked with the PICK option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
REFL_ARRAY /PICK displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button begins 
interactive region-of-interest selection with a box 
cursor. The ESC key or right mouse button 
returns you from the input panel to the 
REFL_ARRAY submenu.

When you're selecting a region-of-interest, a 
rectangular cursor from 2x2 to 128x128 pixels in 
size appears in the detector frame area, and can 
be moved or re-sized under control of the 
mouse and/or keyboard arrow keys. The arrow 
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keys are very useful for precise, 1-pixel adjust-
ments. Pressing the ENTER key or left mouse 
button computes the intensity versus scan angle 
curve and draws it on the screen. Pressing the 
ESC key or the right mouse button toggles 
between position-change mode and size-
change mode where the lower left corner of the 
box remains anchored while the upper left cor-
ner moves under mouse control. If you want to 
exit without computing, drawing the graph, and 
entering the reflection into the array, use CTRL-
BREAK. Depending on the number of frames 
specified with the FRAME HALFWIDTH argu-
ment (see below) the rocking curve can take 
several seconds to compute.

The lineweight of the cursor can be increased 
from the default thickness of 1 pixel by defining 
the environment variable SAXI$CURSWEIGHT 
with an integer value from 2 to 7. In general, 
SAXI$CURSWEIGHT=3 is a good value to use 
if you want thick cursors. Odd values are better 
than even ones, since the extra thickness is then 
added symmetrically about the true cursor posi-
tion.

On completion, the setting angles, the X,Y and 
scan-angle centroids, the intensity and I/sigma 
are entered into the Reflection Array in the spec-
ified record number, or in the next available 
record number if specified as zero. The A flag is 
set in the new Reflection Array entry. If the scan-
angle centroid was computed from intensity on 
more than one frame, the C flag is set. If a valid 

spatial correction is in effect, the corrected X,Y 
are placed in the Reflection Array and the S flag 
is set, otherwise the raw X,Y are stored and the 
S flag is clear. If a valid orientation matrix is in 
effect, the nearest integer HKL indices are also 
entered into the array and the H flag is set.

The output statistics written to the status area in 
the middle right of the screen, and to the output 
logfile if logging is enabled, are detailed in the 
description of the GRAPH /ROCKING com-
mand.

By providing arguments on the command line, 
you can direct the REFL_ARRAY /PICK compu-
tations and graphing to be performed once at a 
single specified position, after which control 
returns immediately to the command line.

If logging is turned on (see the LOGFILE com-
mand for more information), the quantities com-
puted, for the final position of the cursor prior to 
exiting the command, are written to the output 
logfile. If scripting is enabled (again, see LOG-
FILE), a non-interactive REFL_ARRAY /PICK 
command corresponding to the final cursor posi-
tion is written to the output script file.
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8.15.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(X-Origin)     [256]

The X-coordinate of the lower left of the box 
defining the region-of-interest in pixels. The 
range is from 0 to {framesize-1}; default 
value is 256.

$2 ..........................(Y-Origin)     [256]

The Y-coordinate of the lower left of the box 
defining the region-of-interest in pixels. The 
range is from 0 to {framesize-1}; default 
value is 256.

$3 ..........................(Width)     [16]

The width of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 16.

$4 ..........................(Height)     [16]

The height of the box defining the region-of-
interest in pixels. The range is from 0 to 128; 
default value is 16.

/START=<n> .........(Reflection #)     [0]

This specifies the position in the Reflection 
Array into which the new reflection is to be 
stored. The first line in the Reflection Array 
is numbered 1. If you specify a value of zero 
here (the default), the new reflection will be 

placed in the first available empty line of the 
array.

/QUADRANT=<n> (Quadrant)     [0]

This parameter specifies whether you want 
the graph to appear covering the entire data 
frame (enter “0”), or just one of the four 
quadrants (enter 1 through 4 as appropri-
ate). The default value is 0 (full frame win-
dow). Quadrants are 0 = full window, 1 = 
lower left, 2 = lower right, 3 = upper left, and 
4 = upper right.

/FRAME_HALFWIDTH=<n>(Frame Halfwidth)   
[5]

Enter the number of frames ON EACH SIDE 
of the currently displayed frame to be 
included in the rocking curve. Make sure 
that you don't exceed the number of frames 
actually available for processing in either 
direction. If FRAME_HALFWIDTH is zero, 
intensity will be taken from only the frame 
which is currently displayed. The scan-angle 
centroid will not be precisely determined in 
this case, and the C flag will not be set for 
the new record inserted into the reflection 
array. In this case, a rocking curve is not dis-
played (and response is therefore much 
faster).
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8.16 Peaks > Refl. Array > Index • 
Autoindex to compute HKL’s of 
angles-only reflections

Menu Command: Peaks > Refl. Array > Index

Accelerator: Ctrl+I

User Level: 1

SLAM Syntax:

REFL_ARRAY /INDEX $1 /AAX=<n> 
/BAX=<n> /CAX=<n> /U1=<n> /U2=<n> 
/U3=<n> /FCELL=<n> /SIGA=<n> 
/NOREDUCE /VERBOSE /FGROUP=<n> 
/HKLTOL=<n> /FFIT=<n>

REFL_ARRAY /INDEX is used following 
REFL_ARRAY /THRESHOLD (and/or /PICK) to 
determine HKL indices for those reflections in 
the array which have at least the A and C flags 
set, that is, those reflections which contain set-
ting angles, X, Y and span more than one frame 
(are “centered”). Autoindexing determines, in 
addition to HKL indices for each reflection, a 
rough crystal orientation and, unless specified 
otherwise, the reduced primitive unit cell.

There are two ways to perform indexing depend-
ing on the setting of the /NOREDUCE qualifier 
described below. The normal method deter-
mines the reduced primitive unit cell, whose axis 
lengths must fall within the ranges specified in 
the input (if you don't know the axis lengths, 
specify large ranges). Following this method of 

autoindexing, you should run REFL_ARRAY /
BRAVAIS to determine the correct Bravais lat-
tice based on the metric symmetry of the 
reduced primitive cell; for example, if you have a 
centered lattice, /BRAVAIS will determine the 
parameters of the centered cell and will trans-
form the reflection indices to the centered-cell 
indices. Following the Bravais lattice determina-
tion, you would then run REFL_ARRAY /
LEASTSQ to refine the unit cell parameters, 
crystal orientation and detector positional cor-
rections.

The second indexing method, used when 
/NOREDUCE is set, suppresses the conversion 
to the reduced primitive cell. In this case, the 
program looks for a solution which fits both the 
input axis length ranges AND the input cell 
angle ranges. The method can be useful, for 
example, for indexing a known centered unit cell 
directly on the centered lattice. Following index-
ing by this /NOREDUCE method, you will typi-
cally bypass the Bravais lattice step and run 
REFL_ARRRAY /LEASTSQ to refine the cell, 
orientation, etc. However, if you do use the Bra-
vais lattice option after indexing by the /NORE-
DUCE method, be sure to specify the correct 
lattice type in the /BRAVAIS input panel. For 
example, if you index on a known C-centered 
lattice, but specify a P (primitive) input lattice in 
the /BRAVAIS panel, the Bravais lattice output 
will probably not be what you intended. This 
/NOREDUCE indexing method should be used 
ONLY when you're sure you already know the 
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correct unit cell, since it bypasses a very impor-
tant step in the unit cell determination. Remem-
ber that errors in an initial determination of unit 
cell from a few precession pictures are fairly 
common—the normal indexing method followed 
by the Bravais lattice determination should 
always be used in early stages of a problem to 
check the initial choice of unit cell.

The Reflection Array can hold a maximum of 
512 reflections; however, autoindexing and 
determination of orientation requires only a 
small fraction of this number. Usually, 25 reflec-
tions is the bare minimum you'll need, with 50–
100 reflections about optimal. While determina-
tion of orientation from just a few contiguous 
frames is possible (for example, the FRAMBO 
and SADIE verification tests determine the ori-
entation of a myoglobin crystal from eight con-
tiguous frames), you'll get much more precise 
cell parameters if you threshold a few frames 
taken 90 degrees or so in scan angle from the 
first set, adding them to the Reflection Array 
prior to indexing.

If you can't obtain enough reflections with the C 
flag set, you can set this flag with the /MODIFY 
sub-command; however, the precision of the 
resulting cell parameters and orientation will not 
be as good as if centered reflections were used.

Autoindexing is performed with the algorithm 
developed by Sparks, operating on difference 
vectors derived from the input reflections. Differ-
ence vectors are classified into groups based on 

a specified input tolerance. Any group formed 
from fewer than $1 difference vectors (where $1 
is specified on input as defined below) is 
ignored. Up to 100 such groups are used by the 
program. This is a very reliable indexing tech-
nique. If indexing on difference vectors fails, the 
program tries indexing on the full vectors; how-
ever, the difference vector approach is more reli-
able and if it fails, the full vector approach will 
seldom succeed. If for some reason, the pro-
gram cannot find a solution, check for one of the 
following:

1. Prior to taking data on a new sample 
(including new flood-field and spatial correc-
tions), make sure you have entered the cor-
rect sample-detector distance and correct 
X,Y beam center in the CONFIGURE /EDIT 
panel. (REFL_ARRAY /INDEX displays the 
current X,Y beam center coordinates in its 
input panel title bar for your review). Don't 
guess at the beam center; measure it from 
an image taken with after removing or repo-
sitioning the beam stop (make sure the 
direct beam is suitably attenuated before 
trying to record it or you could damage the 
detector!) The 0.060" aluminum cover plate 
shipped with the detector is good for this 
purpose with a sealed tube, or with a rotat-
ing anode run at low power setting (5 KW or 
less with 0.3 x 3mm filament and 0.3 mm 
collimator; less if your beam is larger). The 
ADD command is useful for accumulating a 
direct-beam image.
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Always take another image WITH THE ALU-
MINUM COVER PLATE IN PLACE after 
replacing/repositioning the beam stop to 
make sure it is properly re-located. If you 
need to make positional adjustments, use 
the ADD command with realtime display 
enabled and a /RESET interval of 1 to a few 
seconds for coarse positioning. You may 
than want to take some longer frames to 
perform fine adjustments based on the 
background recorded immediately around 
the beam stop after removing the cover 
plate.

Remember, if your specified beam center 
coordinates are in error by more than half 
the smallest center-to-center spot spacing, 
the chances for mis-indexing increase sub-
stantially.

2. You must use the same flood-field correction 
for taking the data frames from which spots 
are extracted as for taking the fiducial plate 
image used as input to the spatial correc-
tion. Take the brass plate image AFTER the 
flood-field.

3. A good, recently determined spatial correc-
tion, computed from a fiducial-plate frame 
taken at the SAME distance as the frames 
from which the Reflection Array spots were 
obtained must be installed, preferably prior 
to thresholding frames to populate the 
Reflection Array.

4. When using frames written in XENGEN for-
mat by earlier versions of the software, the 
setting angles contained in the frame may 
not be correct. In particular, frames taken 
with phi scans on a 4-circle goniometer may 
be incorrectly interpreted as omega scans. 
The setting angles in the reflection array 
may thus show the scan angle in the 
OMEGA position instead of the PHI posi-
tion, with the result that the sense of the 
scan angle will be reversed from its true 
direction (OMEGA is a right-handed rotation 
and PHI is left-handed). Autoindexing does 
not work correctly unless the sense of the 
scan angle is correct. If this problem occurs, 
use the /MODIFY sub-command to negate 
the scan angle values or to move the omega 
values into the phi field, then zero the 
omega values (see REFL_ARRAY /MOD-
IFY). Frames written in XENGEN format by 
earlier versions of the software can contain 
zero for the swing angle. Again, you can use 
/MODIFY to insert the correct values in the 
Reflection Array.

5. Make sure you haven't used too low a 
threshold in the REFL_ARRAY /THRESH-
OLD command. The Reflection Array should 
contain the positions of strong spots, not 
those of high background points.

When invoked with the INDEX option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
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REFL_ARRAY /INDEX displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button begins 
refinement of the unit cell and orientation 
parameters; the ESC key or right mouse button 
returns you to the REFL_ARRAY submenu. You 
can interrupt autoindexing progress with the 
CTRL-BREAK key combination.

When autoindexing starts, the program displays 
the message “AUTOINDEXING...” on the bot-
tom status line. Indexing should usually be com-
pleted within 10 to 30s. Upon completion, a 
scrolling output window is displayed containing 
the resulting output text. If logging is enabled 
(see LOGFILE) the contents of this window are 
also written to the logfile. When viewing the out-
put, pressing ENTER or the left mouse button 
displays a pop-up menu of options, including 
export of ASCII data; for example, the contents 
of the window could be sent to a file or printer 
with this function. You can also move through 
the window contents with the page keys, arrow 
keys or with mouse motion. Pressing ESC or the 
right mouse button exits the output window, con-
tinuing with the REFL_ARRAY /INDEX com-
mand. This first output window contains the 
results of the indexing and reduced primitive unit 
cell determination, and is presented for review 
PRIOR to re-indexing the Reflection Array. It is 
described in more detail below. When you've 
reviewed the output and exited the window, fol-
lowing prompt  is displayed.

RE-INDEX REFLECTION ARRAY: ARE 
YOU SURE? (Y OR ENTER=YES; N OR 
ESC=NO)

Press the Y key, the ENTER key or the left 
mouse button to write HKL indices into the 
reflections in the array and set the H flag of each 
reflection, otherwise press the N key, ESC key, 
or right mouse button to quit autoindexing and 
return to the REFL_ARRAY submenu without 
changing the Reflection Array.

If you've chosen to continue, the program 
updates the Reflection Array HKL indices and 
flags, then displays a second scrolling output 
window containing least-squares statistics 
related to the differences between observed and 
calculated HKL indices and scan angle, includ-
ing histograms of the distributions of these dif-
ferences. This is very similar to the output from 
REFL_ARRAY /LEASTSQ; but is derived from a 
relatively crude linear least squares and will 
show substantially larger deviations. It is 
described in more detail below. When you exit 
this second output window (with the ESC key or 
right mouse button), the program returns to the 
REFL_ARRAY submenu (to the BRAVAIS sub-
command, since it's usually invoked next).

If REFL /INDEX was invoked from the command 
line, each output window is displayed subject to 
a 10 s timeout to allow command scripts to run 
without intervention. If you do not press a key or 
mouse button within 10 s after the output win-
dow is displayed, the program will continue as if 
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the ESC key had been pressed. Similarly, the 
prompt RE-INDEX REFLECTION ARRAY... 
described above will in that case time out after 
10 s as if the ENTER key had been pressed.

8.16.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

/AAX=<n> .............(Expected A-Axis Length)    
[80.00]

A trial A-axis vector is accepted only if its 
length is in the range AAX * MAX(1-
FCELL,0.01) to AAX * (1+FCELL). The 
allowed input range is 1-2500 Angstroms 
and the default value is 80 A. If you know 
the axis length, enter it here and make 
FCELL small, otherwise, make the best 
guess you can. You can use the CURSORS 
/VECTOR and CURSORS /CIRCLE com-
mands to derive approximate unit cell axis 
lengths.

/BAX=<n> .............(Expected B-Axis Length)     
[80.00]

A trial B-axis vector is accepted only if its 
length is in the range BAX * MAX(1-
FCELL,0.01) to BAX * (1+FCELL). The 
allowed input range is 1-2500 Angstroms 
and the default value is 80 A. If you know 
the axis length, enter it here and make 
FCELL small, otherwise, make the best 

guess you can. You can use the CURSORS 
/VECTOR and CURSORS /CIRCLE com-
mands to derive approximate unit cell axis 
lengths.

/CAX=<n>............. (Expected C-Axis Length)    
[80.00]

A trial C-axis vector is accepted only if its 
length is in the range CAX * MAX(1-
FCELL,0.01) to CAX * (1+FCELL). The 
allowed input range is 1-2500 Angstroms 
and the default value is 80 A. If you know 
the axis length, enter it here and make 
FCELL small, otherwise, make the best 
guess you can. You can use the CURSORS 
/VECTOR and CURSORS /CIRCLE com-
mands to derive approximate unit cell axis 
lengths.

/U1=<n> ............... (Expected Alpha Cell Angle)     
[90.00]

Specifies the alpha unit cell angle in 
degrees when a known unit cell is assumed. 
This value is used ONLY when assuming a 
known unit cell; if ASSUME KNOWN UNIT 
CELL is specified as “N” on the input panel 
or /NOREDUCE is absent in command line 
mode, this value is ignored.

/U2=<n> ............... (Expected Beta Cell Angle)     
[90.00]

Specifies the beta unit cell angle in degrees 
when a known unit cell is assumed. This 
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value is used ONLY when assuming a 
known unit cell; if ASSUME KNOWN UNIT 
CELL is specified as “N” on the input panel 
or /NOREDUCE is absent in command line 
mode, this value is ignored.

/U3=<n> ................(Expected Gamma Cell 
Angle)     [90.00]

Specifies the gamma unit cell angle in 
degrees when a known unit cell is assumed. 
This value is used ONLY when assuming a 
known unit cell; if ASSUME KNOWN UNIT 
CELL is specified as “N” on the input panel 
or /NOREDUCE is absent in command line 
mode, this value is ignored.

/FCELL=<n>..........(Axis Length Deviation)     
[0.75]

Specifies the fractional range of axis lengths 
which will be accepted for trial A,B, and C 
axis solutions. A trial axis vector is accepted 
only if its length is in the range AX * MAX(1-
FCELL,0.01) to AX * (1+FCELL) where AX 
is one of the lengths specified above for 
/AAX, /BAX or /CAX. The allowed input 
range is 0.0-2.0 and the default value is 
0.75. If you know the axis lengths, enter 
them as /AAX, /BAX, /CAX make FCELL 
small (for example, 0.1), otherwise, make 
the best guesses you can. You can use the 
CURSORS /VECTOR and CURSORS /CIR-
CLE commands to derive approximate unit 
cell axis lengths.

/SIGA=<n> ........... (Cell Angle Deviation)     
[0.1]

Specifies the fractional range of cell angles 
which will be accepted for trial solutions 
when a known unit cell is assumed. This 
value is used ONLY when assuming a 
known unit cell; if ASSUME KNOWN UNIT 
CELL is specified as “N” on the input panel 
or /NOREDUCE is absent in command line 
mode, this value is ignored.

A trial cell angle is accepted only if its length 
is in the range ANGLE * MAX(1-
FCELL,0.01) to ANGLE * (1+FCELL) where 
ANGLE is one of the lengths specified 
above for /U1, /U2 or /U3. The allowed input 
range is 0.0-2.0 and the default value is 0.1.

/NOREDUCE........ (Assume Known Unit Cell 
(Y/N) ?)  [No]

If specified as “Y” on the input panel, or as 
/NOREDUCE in command line mode, this 
qualifier suppresses the normal computa-
tion of the reduced primitive cell. Instead, 
the program attempts to find a solutions only 
for the input A, B, C, ALPHA, BETA, 
GAMMA values as described above. This is 
NOT recommended for general operation, 
since it bypasses a very important step in 
determination of the correct unit cell. How-
ever, in cases which are difficult to index, 
the additional constraints supplied by the 
known cell angles (used only when /NORE-
DUCE is in effect) may help, and in cases of 
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known cells with centered lattices, /NORE-
DUCE enables you to index on the centered 
lattice directly and bypass the extra Bravais 
lattice transformation step (again, NOT a 
good thing to do unless you're very sure that 
your input cell is the correct one).

/VERBOSE............(Verbose Output (Y/N) ?)     
[Yes]

Specifies that “long-form” indexing output is 
desired. If this qualifier is set (i.e., “Y” in the 
input panel, or present on the command 
line), the first output window contains lists of 
the difference vectors and full vectors, and 
the second output window contains a reflec-
tion-by-reflection listing of observed versus 
calculated HKL's and scan angles; other-
wise these lists are not written. The default 
in the input panel is “Y.”

$1 ..........................(Minimum # Vectors in 
Group)     [2]

The small integer value you specify here 
determines how many difference vectors 
with nearly identical components must be 
found before the difference vectors will be 
included in the autoindexing. The vectors in 
any cluster which does not contain at least 
this number of difference vectors are 
ignored. The default of 2 should be satisfac-
tory in most cases. If you supply a value of 
1, every difference vector will be included in 
the calculations. As you specify higher val-

ues, you increase the confidence level that 
an observed group corresponds to a true 
reciprocal-lattice difference vector; however, 
you at the same time reduce the number of 
groups available for autoindexing. Valid 
range is 1–999; however, you'll want to stay 
at the lower end of this range.

/FGROUP=<n>..... (Length Fraction for Group-
ing)     [0.3]

Specifies how closely the components of 
difference vectors must agree before they 
will be placed in the same group. Difference 
vectors which belong to the same group are 
averaged together, and the autoindexing is 
actually performed on the groups, not on the 
individual difference vectors. The value 
given here divided by the largest allowed 
unit cell axis length (computed from /AAX, 
/BAX, /CAX, and /FCELL below) represents 
the maximum allowed distance between the 
endpoints of two difference vectors (assum-
ing they're at a common origin). If the dis-
tance between a difference vector endpoint 
and that of the current group average is 
larger than this value, it is not included in the 
group (and in fact starts a new group). If the 
distance is within this limit, the difference 
vector is averaged into the group. The 
default of 0.3 should be satisfactory in most 
cases; that is, if two difference vector end-
points are identical within about 1/3 of the 



Peaks Routines GADDS Software Reference Manual

8 - 38 M86-E01008

shortest possible difference vector, they are 
included in the same group.

/HKLTOL=<n> .......(Fractional HKL Devia-
tion)     [0.1]

Difference vector groups whose calculated 
HKL indices are integers within this speci-
fied tolerance are considered to be “fit” by 
the current axial vector solution. For each 
difference vector group, the difference 
between H, K, or L index calculated from the 
trial axis vector solution and the nearest 
integer to that index is computed. If the 
absolute value of the difference is within the 
/HKLTOL value, the solution fits that differ-
ence vector group. In order for an axis-vec-
tor solution to be accepted, it must fit at 
least FFIT * N difference vector groups, 
where FFIT is described below, and N is the 
total number of difference vector groups 
included in the indexing. The default value 
of 0.1 should be suitable in most cases, 
although if you have large unit cell axis 
lengths (say, > 250 A), you may want to 
increase it, for example, to 0.2. Valid input 
range is 0-1, although it is not a good idea to 
increase this parameter to much above 
0.25.

/FFIT=<n> .............(Fraction which must be fit)     
[0.8]

A trial axis vector is accepted only if the 
number of difference groups it fits is at least 
FFIT * N where FFIT is the value specified 

here and N is the total number of difference 
vector groups included in the indexing. The 
default value of 0.8 should be suitable in 
most cases. If the program cannot find a 
solution and you've checked the spatial cor-
rection, beam center, etc. as described 
above, you might try decreasing this number 
(e.g., to 0.7). Valid input range is 0-1, but if 
you have to reduce this number to 0.5 or 
lower to find a solution, something is wrong.

8.16.2 Autoindexing Output

Two examples of the output from REFL_ARRAY 
/INDEX is shown below. Both have the /VER-
BOSE qualifier set. Example 1 is the first output 
window from indexing of the eight myoglobin 
test frames. If you're familiar with Bruker's scin-
tillation counter software, this output is similar. 
The indexing was performed with 26 “centered” 
reflections extracted with a /THRESHOLD sub-
command, as performed by the FVERIFY.SLM 
test sequence supplied with the program; how-
ever, the indexing here was performed specify-
ing /AAX=90 /BAX=90 /CAX=45 /FCELL=0.1. 
The output and indexing time in this case are 
significantly shorter than those obtained in the 
test sequence, which specifies /AAX=80 
/BAX=80 /CAX=80 /FCELL=0.75.

The first output line contains the axis length lim-
its in Angstroms used to filter trial axis vector 
solutions in the order minimum, maximum A; 
minimum, maximum B; minimum, maximum C; 
followed by the maximum HKL difference vector 
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index used to compute test solutions. These val-
ues are computed from the input /AAX /BAX 
/CAX and /FCELL.

Next is a list of the trial axis vector solutions. 
Each record consists of two or more lines. The 
first line contains the solution number, the axis 
length in angstroms, a figure of merit (actually a 
residual—lower values are better) indicating the 
rms deviation from integer HKL indices calcu-
lated from the solution combined with a mea-
sure of the vector length, three integers which 
define the direction of the axis (this is the integer 
triple described by Sparks in Computational 
Crystallography, D. Sayre, ed., Oxford (1982) pp. 
1–18), and a bit mask containing a 1 for each 
difference vector group which is fit by the solu-
tion and a 0 for each group that is not fit. The 
first line holds mask elements for up to 50 
groups; if the number of groups is larger, the 
mask is continued on the second line immedi-
ately below the first 50 elements.

Starting at the second line of each record (the 
third if the bit mask requires a second line) is a 
list of angles between the solutions. The num-
bers are in degrees, with the first number in the 
list representing the angle from the current solu-
tion to solution #1; the second, to solution #2, 
and so on. Angles near 90 degrees are high-
lighted with a trailing “*”; angles near 60 or 120 
degrees, with a “#”.

Following the list of axis vectors is the chosen 
triple of solutions for the three crystallographic 

axes, derived from the three non-coplanar axis 
vectors with best (lowest) figures-of-merit. The 
shortest solutions with good integerness of cal-
culated HKL indices have the best figures-of-
merit. In addition to the solution number and 
length of each axis chosen, the XYZ compo-
nents of each axis vector are displayed.

If the program was not able to find an accept-
able set of three solutions from its first group of 
trial solutions (generated from a basis set con-
sisting of the three shortest non-coplanar differ-
ence vector groups), the output will contain the 
message

RETRYING WITH NEXT SHORTEST VEC-
TOR

followed by another listing of axis vector solu-
tions. If you see this message (even several 
occurrences of it) followed by successful index-
ing, it is no cause for concern. If necessary, the 
program continues to step through the differ-
ence vector groups generating trial solutions 
from a new basis set of three such groups until a 
solution is found or until the number of groups 
has been exhausted. If this occurs, the output 
will contain the lines

INDEXING FAILED ON DIFFERENCE 
VECTORS

RE-TRYING WITH FIRST 100 FULL VEC-
TORS
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and a final attempt at indexing on the full vectors 
is made.

Following the axis vector solution, a unit cell 
reduction by the method of Buerger is per-
formed. The output contains the resulting 
reduced primitive unit cell, with parameters in 
the order A,B,C (Angstroms), ALPHA, BETA, 
GAMMA (degrees).

If verbose output has been specified, a list of the 
difference vector groups follows. A line for each 
group contains the group number, its length in 
Angstroms, its reciprocal-lattice components, 
and the number of difference vectors in the 
group.

A linear least squares is then performed to 
refine the parameters of the reduced primitive 
cell with, the refined parameters displayed in the 
same order, followed by the unit cell volume in 
cubic Angstroms). These values and their stan-
dard deviations are automatically transferred to 
the /BRAVAIS sub-command input panel, for 
subsequent determination of the /BRAVAIS lat-
tice based on the metric symmetry of the 
reduced primitive cell.

If verbose output was specified, the least 
squares result is followed by a list of the input 
full vectors with their calculated HKL indices. A 
line for each vector contains the vector number, 
the number of the vector closest to it (i.e., the 
one which yielded the smallest difference vec-
tor), the calculated HKL indices expressed as 
real numbers (if these values are not close to 

being integers, something is wrong; most should 
be within 0.1 of an integer value), and the corre-
sponding reciprocal lattice vector components.

Example 2 below is sample output from the 
same indexing run displayed in the second out-
put window following re-indexing of the Reflec-
tion Array. The output results from a rough linear 
least-squares refinement of the reduced primi-
tive unit cell to the indexed full vectors. It is simi-
lar to the output produced by REFL_ARRAY /
LEASTSQ, although the refinement will not be 
as precise.

First are several tabular histograms, showing the 
distribution of the unsigned differences between 
observed and calculated values of H,K,L, scan 
angle (always labeled OMEGA, even if the scan 
angle was actually PHI), and detector X,Y posi-
tion. In all cases, the more closely bunched 
toward the left side of the histogram the differ-
ences are, the better the refinement. Scan angle 
differences are in degrees, and X,Y differences 
are in pixels. Following the histograms are the 
overall average and rms differences for these 
same quantities, H,K,L, scan angle, X, and Y. 
The myoglobin example shown below is a very 
good one. Often the numbers are two or three 
times higher. The AVG values indicate any sys-
tematic bias in the results. Unlike the case for 
REFL_ARRAY /LEASTSQ, the AVG values will 
probably be significant here; however if they are 
large compared with the corresponding RMS 
values, you might suspect mis-indexing or mis-
alignment of the system. In such a case, make 
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sure you have a good spatial correction and cor-
rect estimates for the detector distance and 
beam center entered in the CONFIGURE /EDIT 
panel.

Following the overall statistics is a reflection-by-
reflection summary of the agreement for each 
reflection in the reflection array. Each record 
consists of two lines, the first containing the 
reflection as it's entered in the reflection array 
(i.e., the “observed” values), and the second 
containing the differences for HKL, scan angle 
(always converted into omega rotation) and 
detector X,Y with the sense OBSERVED - CAL-
CULATED. This output shows both those reflec-
tions included in the least squares, and those 
not included (for example, reflections without the 
C flag set). It also shows computed HKL indices 
for reflections which do not have the H flag set. It 
does not include reflections which do not have 
the A flag set, since there are many possible 
combinations of setting angles and detector X,Y 
which could correspond to given HKL indices.
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The two example outputs follow (neither case 
assumes a known unit cell): 

Example 8.2 - Output from indexing of 8 Myoglobin Test Frames, prior to re-indexing the Reflection Array

Axis limits, max index:    81.000  99.000  81.000  99.000  40.500  49.500   13

 # Length FOM H 1H 2H 3 Reflections fit
Angles between solutions

 1 46.159 0.01 1 1 0 1111111111111111

 2 92.542 0.01 0 1 1 1111111111111111
 89.4*

 3 92.318 0.02 2 2 0 1111111111111111
  0.0  89.4*

 4 91.833 0.01 1 1 2 1111111111111111
 90.0*119.6# 90.0*

 5 92.707 0.03 1 2 3 1111111111111111
 89.4* 59.4# 89.4* 60.2#

Predicted reduced primitive axes are:
Soln# X Y Z Length
  4 -87.10253 -29.05033 -1.61254 91.83340
  2 -68.84866 61.83576 -0.53702 92.54236
  1  0.90663 -0.11663 -46.14998 46.15903

Reduced primitive cell is:
    91.833    92.542    46.159    89.398    89.984    60.372

Difference Vectors:
    #        Length              X1             X2              X3    Freq
    1    40.05527    -0.00803    -0.00913    -0.02180    2
    2    32.87223    -0.00410    -0.02093    -0.02170    2
    3    30.28461    -0.01281    -0.03043    -0.00017    2
    4    25.39675    -0.01247    -0.03035    -0.02177    2
    5    22.04425    -0.01167     0.00270    -0.04375    2
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    6    18.34492    -0.01719    -0.05173    -0.00059    2
    7    18.29090    -0.00113    -0.03306     0.04353    2
    8    17.00628    -0.01710    -0.05170    -0.02218    2
    9    16.32388    -0.00953    -0.04254     0.04304    2
   10   14.31518    -0.01803    -0.05208     0.04292    2
   11   13.87408    -0.02895    -0.04912    -0.04410    2
   12   12.60927    -0.02206    -0.07317     0.02118    2
   13   11.18752    -0.03342    -0.07032    -0.04390    2
   14    9.18217     -0.03102    -0.08251     0.06396    2
   15    9.03692     -0.01905    -0.00642    -0.10882    2
   16    7.90768     -0.01505    -0.06411     0.10796    2

Least squares cell parameters:
    92.865    91.946    46.174    89.264    89.442    59.640   340159.50

Full vectors:
    # NEAR       H          K           L              X1              X2              X3
    1    9      -8.99      6.99      7.99    -0.04561    -0.16710    -0.17374
    2   20     -5.99      6.01      5.98    -0.02503    -0.12757    -0.12977
    3   21     -9.98    10.99     -2.99    -0.04181    -0.22498     0.06442
    4   20     -7.01      8.99      1.99    -0.02324    -0.17308    -0.04331
    5   15     -9.98      9.99      4.99    -0.04328    -0.21235    -0.10873
    6   26   -13.00      9.00      9.00    -0.07110    -0.22841    -0.19636
    7    3    -11.01    11.99     -1.00    -0.04587    -0.24611     0.02100
    8    7    -13.00    13.00     -0.01    -0.05838    -0.27656    -0.00078
    9    2      -9.01      7.99      7.02    -0.04215    -0.17936    -0.15221
   10   24    -8.02      9.02     -5.00    -0.03361    -0.18313     0.10781
   11   26  -12.99    11.00      5.99    -0.06419    -0.25246    -0.13093
   12   14  -18.00    14.00      3.02    -0.09522    -0.33492    -0.06701
   13   10  -10.99      9.99     -7.01    -0.05529    -0.22290     0.15082
   14   11  -15.00    12.98      4.00    -0.07382    -0.29497    -0.08783
   15    4     -7.99      9.00      4.01    -0.03086    -0.18211    -0.08697
   16   13  -16.01    11.00     -9.01    -0.09371    -0.28161     0.19354
   17   11  -14.00    10.99      7.00    -0.07223    -0.26154    -0.15278
   18    6   -15.00      9.99      9.00    -0.08397    -0.25896    -0.19665
   19    0     -5.00      7.01     -3.01    -0.01564    -0.13087     0.06517
   20   19    -6.00      8.00      2.01    -0.01865    -0.15188    -0.04339
   21   10    -8.99      9.99     -4.01    -0.03773    -0.20412     0.08625
   22    4     -9.97    11.00      2.02    -0.04029    -0.22467    -0.04399
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   23   12    -19.00     14.00      4.00    -0.10323    -0.34409    -0.08877  
   24   19      -7.99       9.99     -1.98    -0.02880    -0.19450     0.04293   
   25   16    -21.98     13.99     -6.00    -0.13114    -0.37279     0.12776
   26    5     -12.02     10.02      7.01    -0.05949    -0.23122    -0.15272

Example 8.3 - Output from indexing of 8 Myoglobin Test Frames, after reindexing the Reflection Array (Truncated)

Histograms:
.00 .05 .10 .15 .20 .25 .30 .35 .40 .45 +Inf

H 26 0 0 0 0 0 0 0 0 0
K 26 0 0 0 0 0 0 0 0 0
L 26 0 0 0 0 0 0 0 0 0

Omega 26 0 0 0 0 0 0 0 0 0

0.00 0.25 0.50 0.75 1.00 1.25 1.50 1.75 2.00 2.25 +Inf
X 20 6  0 0 0 0 0 0 0 0
Y 20 5 1 0 0 0 0 0 0 0

H K L Omega X Y
AVG 0.001 -0.002 0.001 -0.002 0.039 0.038
RMS 0.010 0.011 0.009 0.017 0.215 0.227

  # Flags       H     K      L     2-Theta     Omega       Phi        Chi            X            Y      Inorm         I/Sig
  1 ACHS     -9      7      8    -30.000       -0.271    0.000    0.000    82.85      51.23      626.60        112
                -.01  -.01  +.02                       0.006                                 0.00       0.40
  2 ACHS     -6      6      6    -30.000       -0.443    0.000    0.000     33.26     99.06      467.95          97
               +.00  -.02  +.02                      -0.016                                 0.23       0.64
  3 ACHS   -10    11     -3    -30.000       -0.448    0.000    0.000   142.13   309.54      344.28          83
                -.01 +.00  +.00                      -0.006                                -0.22      -0.06

 .
                            .
                              .
                                etc.
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8.17 Peaks > Refl. Array > Bravais • 
Determine Bravais lattice and 
perform HKL transformations

Menu Command: Peaks > Refl. Array > Bravais

Accelerator: Ctrl+B

User Level: 1

SLAM Syntax:

REFL_ARRAY /BRAVAIS $1 $2 $3 $4 $5 $6 
$7 /SIGA=<n> /SIGB=<n> /SIGC=<n> 
/SIGMA=<n> /SIGBEST=<n>

REFL_ARRAY /BRAVAIS determines possible 
Bravais lattices corresponding to the specified 
input unit cell parameters and standard devia-
tions, based strictly on the metric symmetry. 
Possible solutions are ranked according to 
degree of symmetry and a goodness-of-fit. The 
highest-symmetry solution whose goodness-of-
fit is better than an input threshold is flagged as 
the most likely solution. You can accept that 
solution or one of the other possible solutions, in 
which case the reflections in the Reflection 
Array will be automatically re-indexed according 
to the selected unit cell.

Normally, you will invoke this command immedi-
ately after autoindexing the Reflection Array with 
the REFL_ARRAY /INDEX command. 
REFL_ARRAY /INDEX automatically stores its 
resulting reduced primitive unit cell parameters 
and their standard deviations in the /BRAVAIS 

input panel, and you can usually invoke /BRA-
VAIS without changing any of the input panel 
values.

The goodness-of-fit is a measure of how well a 
trial Bravais lattice fits the input unit cell parame-
ters. Lower values are better. The scale is arbi-
trary (this is NOT a true least-squares 
goodness-of-fit; don't expect values near 1), but 
in general good solutions will have values less 
than 10. The input panel allows you to set two 
different thresholds on the goodness-of-fit. The 
first is the threshold below which a solution is 
listed in the output. The second is the threshold 
below which a solution can be flagged as the 
“best” solution. The highest symmetry solution 
whose goodness-of-fit is below this second 
threshold is marked as the best solution. The 
default values are 20 and 6 respectively for 
these thresholds, and they should work well in 
most cases.
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The possible Bravais lattices determined by the 
program are:

If for some reason you need to use a different, 
non-standard setting, you can use 
REFL_ARRAY /TRANSFORM to transform the 
HKL indices in the reflection array prior to run-
ning the /LEASTSQUARES sub-command.

When invoked with the BRAVAIS option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 

REFL_ARRAY /BRAVAIS displays an input 
panel where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button begins 
refinement of the unit cell and orientation 
parameters; the ESC key or right mouse button 
returns you to the REFL_ARRAY submenu. 

When refinement starts, the program displays 
the message “PERFORMING LATTICE 
SEARCH” on the bottom status line. The deter-
mination should usually be completed within a 
second or two. Upon completion, a scrolling out-
put window is displayed containing the resulting 
output text. If logging is enabled (see LOGFILE) 
the contents of this window are also written to 
the logfile. When viewing the output, pressing 
ENTER or the left mouse button displays a pop-
up menu of options, including export of ASCII 
data; for example, the contents of the window 
could be sent to a file or printer with this func-
tion. You can also move through the window 
contents with the page keys, arrow keys or with 
mouse motion. Pressing ESC or the right mouse 
button exits the output window, continuing with 
the /BRAVAIS sub-command. The output is 
described in more detail below. 

After you exit the output window, an input win-
dow appears requesting you to enter the solu-
tion number of the Bravais lattice you want to 
use, with a default value corresponding to the 
solution labelled as “best” (that solution is pre-
ceded in the output window by the characters 
“>>>”). If you enter a non-zero solution number, 

Program Output Description

CUBIC F Face-centered cubic

CUBIC I Body-centered cubic

CUBIC P Primitive cubic

RHOMBOHEDRAL (OBV);

     HEXAGONAL R 
     SETTING

Rhombohedral on hexago-
nal axes

TRIGONAL P (NO C-AXIS 
SYMMETRY);

     HEXAGONAL P (C-AXIS 
     SYMMETRY) 

Trigonal/hexagonal

TETRAGONAL I Body-centered tetragonal

TETRAGONAL P Primitive tetragonal

ORTHORHOMBIC F Face-centered orthorhombic

ORTHORHOMBIC I Body-centered orthorhombic

ORTHORHOMBIC C C-centered orthorhombic

ORTHORHOMBIC P Primitive orthorhombic

MONOCLINIC C C-centered monoclinic

MONOCLINIC P Primitive monoclinic

TRICLINIC P Primitive triclinic



GADDS Software Reference Manual Peaks Routines

M86-E01008 8 - 47

pressing the ENTER key or left mouse button 
selects the input solution number, and re-
indexes the reflections in the Reflection Array to 
correspond to the selected Bravais lattice, then 
returns to the REFL_ARRAY submenu with the 
LEASTSQ option highlighted (since that's usu-
ally the next operation). If you enter a solution 
number of zero and press ENTER or the left but-
ton, the program returns to the submenu without 
re-indexing the array. Pressing ESC or the right 
mouse button in the input window returns you to 
the /BRAVAIS scrollable output window for 
reviewing the output prior to selecting a solution.

If REFL /BRAVAIS was invoked from the com-
mand line, the output window is displayed sub-
ject to a 10 s timeout to allow command scripts 
to run without intervention. If you do not press a 
key or mouse button within 10 s after the output 
window is displayed, the program will continue 
as if the ESC key had been pressed. In com-
mand line mode, the “best” solution is always 
selected—no second input window is displayed 
for selecting a solution number.

8.17.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Lattice Type)    [P]

Usually the unit cell parameters you supply 
in this input panel correspond to the 
reduced primitive cell determined by 

REFL_ARRAY /INDEX, which are automati-
cally transferred from /INDEX to the /BRA-
VAIS input panel. While you'll normally use 
the default input panel values set up be the 
/INDEX sub-command, you can also per-
form Bravais lattice determination by directly 
entering unit cell parameters on the input 
panel. If you know that the parameters you 
enter here correspond to a non-primitive lat-
tice, enter the known lattice type here. Valid 
types are:

P: Primitive

A: A-centered

B: B-centered

C: C-centered

I: Body-centered

F: Face-centered

R: Rhombohedral

If you change this entry, it is a good idea to 
reset it to P when you exit. The /INDEX sub-
command does NOT automatically update 
this item when it exits. The default is P.

$2 ......................... (Current A Axis Length)   
[10.0]

Specifies the A-axis length in Angstroms of 
the input unit cell to be tested for correspon-
dence with other lattices. This item is auto-
matically filled in with the value from the 
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reduced primitive cell when you run /INDEX. 
Default is 10. Valid input range is 1 to 2500.

$3 ..........................(Current B Axis Length)     
[10.0]

Specifies the B-axis length in Angstroms of 
the input unit cell to be tested for correspon-
dence with other lattices. This item is auto-
matically filled in with the value from the 
reduced primitive cell when you run /INDEX. 
Default is 10. Valid input range is 1 to 2500.

$4 ..........................(Current C Axis Length)     
[10.0]

Specifies the C-axis length in Angstroms of 
the input unit cell to be tested for correspon-
dence with other lattices. This item is auto-
matically filled in with the value from the 
reduced primitive cell when you run /INDEX. 
Default is 10. Valid input range is 1 to 2500.

$5 ..........................(Current Alpha Cell Angle)     
[90.0]

Specifies the ALPHA unit cell angle in 
degrees of the input unit cell to be tested for 
correspondence with other lattices. This 
item is automatically filled in with the value 
from the reduced primitive cell when you run 
/INDEX. Default is 90. Valid input range is 0 
to 179.

$6 ......................... (Current Beta Cell Angle)     
[90.0]

Specifies the BETA unit cell angle in 
degrees of the input unit cell to be tested for 
correspondence with other lattices. This 
item is automatically filled in with the value 
from the reduced primitive cell when you run 
/INDEX. Default is 90. Valid input range is 0 
to 179.

$7 ......................... (Current Gamma Cell Angle)     
[90.0]

Specifies the GAMMA unit cell angle in 
degrees of the input unit cell to be tested for 
correspondence with other lattices. This 
item is automatically filled in with the value 
from the reduced primitive cell when you run 
/INDEX. Default is 90. Valid input range is 0 
to 179.

/SIGA=<n> ........... (Standard Deviation of A)     
[0.03]

Specifies the A-axis standard deviation in 
Angstroms of the input unit cell to be tested 
for correspondence with other lattices. This 
item is automatically filled in with the value 
from the reduced primitive cell when you run 
/INDEX. Default is 0.03. Valid input range is 
0 to 999.
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/SIGB=<n> ............(Standard Deviation of B)     
[0.03]

Specifies the B-axis standard deviation in 
Angstroms of the input unit cell to be tested 
for correspondence with other lattices. This 
item is automatically filled in with the value 
from the reduced primitive cell when you run 
/INDEX. Default is 0.03. Valid input range is 
0 to 999.

/SIGC=<n>............(Standard Deviation of C)     
[0.03]

Specifies the C-axis standard deviation in 
Angstroms of the input unit cell to be tested 
for correspondence with other lattices. This 
item is automatically filled in with the value 
from the reduced primitive cell when you run 
/INDEX. Default is 0.03. Valid input range is 
0 to 999.

/SIGMA=<n> .........(Max Sigmas for any SOLN)     
[20]

Solutions with goodness-of-fit below this 
value are listed in the output window. Those 
with goodness-of-fit above the value are 
rejected. The default of 20 should be satis-
factory for most purposes. Valid input range 
is 0 to 999.

/SIGBEST=<n> .....(Max Sigmas for best SOLN)     
[6]

Solutions with goodness-of-fit below this 
value are candidates for the “best” solution, 

indicated in the output window with the char-
acters “>>>”. The highest-symmetry solu-
tion with goodness-of-fit below this value is 
flagged as the “best” solution. The default of 
6 should be satisfactory for most purposes. 
Valid input range is 0 to 999.

8.17.2 Bravais Lattice Output

An example of the /BRAVAIS output window 
contents is shown below in EXAMPLE 1. It con-
tains a summary of the values on the input panel 
followed by the number of solutions found with 
goodness-of-fit within the /SIGMA threshold. 
Next is a list of the solutions. Solutions are 
grouped according to lattice type, with each 
group preceded by a line containing one of the 
Bravais lattice types listed above. Higher-sym-
metry Bravais lattices are listed before those 
with lower symmetry. Each solution is displayed 
on two lines. The first line contains the solution 
number, its goodness-of-fit (labeled #SIG), its 
unit cell parameters in the order A, B, C (Ang-
stroms), alpha, beta, gamma (degrees). The 
second line contains the rows of the 3 x 3 trans-
formation matrix which would transform the HKL 
indices from the input lattice to the lattice corre-
sponding to the solution. The rows are sepa-
rated by slashes; thus, using the standard 
mathematical convention, the nine elements on 
the third line are in the order T11,T12,T13/ 
T21,T22,T23/ T31,T32,T33. If you stack these 
rows above one another (the first row on top), 
the resulting matrix will pre-multiply a column 
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HKL vector in the input cell to give a column 
HKL vector in the new cell.

Example 8.4 - Bravais Lattice Output for Myoglobin Test Data

#Sigmas for acceptance of any soln, best soln:      20.0       6.0
Input lattice type:  P
Input cell and standard deviations:
       92.865  91.946  46.174  89.264  89.442  59.640   340159.50
         0.476    0.494    0.036

Number of solutions =   14

       #   #Sig    A               B              C            Alpha         Beta          Gamma
TRIGONAL P (NO C-AXIS SYMMETRY); HEXAGONAL P (C-AXIS SYMMETRY)
>>> 1   2.98    91.906      91.946     46.174    90.736       89.827      119.323
  -1.00   1.00   0.00/         0.00      -1.00       0.00/          0.00          0.00     1.00/

ORTHORHOMBIC C
       2   2.55    92.865     158.674    46.174    90.527       90.558       89.971
  -1.00   0.00   0.00/        1.00       -2.00       0.00/          0.00          0.00     1.00/

       3   2.98    91.906     160.341    46.174    89.255       89.827       90.661
   1.00  -1.00   0.00/       -1.00      -1.00        0.00/          0.00          0.00    -1.00/

       4   3.02    91.946     160.272    46.174    89.776       90.736       90.689
   0.00  -1.00   0.00/        2.00      -1.00        0.00/          0.00          0.00     1.00/

MONOCLINIC C
       5   1.31   158.674    92.865      46.174    89.442       90.527       90.029
   1.00  -2.00   0.00/        1.00       0.00        0.00/          0.00          0.00     1.00/

       6   1.72    91.946     160.272    46.174    90.224       90.736      89.311
   0.00   1.00   0.00/        2.00      -1.00        0.00/          0.00          0.00    -1.00/

       7   1.74   160.341    91.906      46.174    89.827       90.745      89.339
   1.00   1.00   0.00/       1.00       -1.00        0.00/          0.00          0.00    -1.00/

       8   2.19    92.865    158.674     46.174    90.527       90.558      89.971
  -1.00   0.00   0.00/       1.00       -2.00        0.00/          0.00          0.00     1.00/
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      9   2.45    91.906    160.341     46.174    89.255       90.173      89.339
  1.00  -1.00   0.00/       1.00        1.00        0.00/          0.00          0.00     1.00/

     10   2.96   160.272   91.946      46.174    90.736       90.224      89.311
 -2.00   1.00    0.00/       0.00       -1.00        0.00/          0.00          0.00     1.00/

MONOCLINIC P
     11   2.55    91.906   46.174       91.946    90.736     119.323     89.827
  1.00  -1.00   0.00/        0.00        0.00      -1.00/           0.00          1.00     0.00/

TRICLINIC P
     12   0.00    46.174   91.906       91.946    60.677       89.264     89.827
  0.00   0.00  -1.00/       1.00        -1.00       0.00/           0.00         -1.00     0.00/

     13   2.62    46.174   91.906       92.865   120.317      90.558     90.173
  0.00   0.00  -1.00/      -1.00         1.00       0.00/          1.00           0.00     0.00/

     14   2.62    46.174   91.946       92.865    59.640       89.442     89.264
  0.00   0.00  -1.00/        0.00       -1.00       0.00/          -1.00          0.00     0.00/
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8.18 Peaks > Refl. Array > LeastSq • 
Determine orientation and refined 
cell parameters

Menu Command: Peaks > Refl. Array > LeastSq

Accelerator: Ctrl+L

User Level: 1

SLAM Syntax:

REFL_ARRAY /LEASTSQ $1 $2 $3 $4 $5 
$6 $7 /DXC=<n> /DYC=<n> 
/DISTANCE=<n> /ROLL=<n> /YAW=<n> 
/U1=<n> /U2=<n>  /U3=<n> /HKLTOL=<n> 
/HALFWIDTH=<n> /MASK=<n> 
/PARNAME=<n>

REFL_ARRAY /LEASTSQ determines and 
refines the crystallographic orientation matrix, 
unit cell parameters, and detector positional cor-
rections given a valid list of indexed x-ray spots 
in the Reflection Array. Its output contains the 
orientation matrix, the refined parameters and 
their standard deviation, refinement and agree-
ment statistics, and a reflection-by-reflection list 
of observations versus least-squares calculated 
values.

Usually, the reflection array will have been popu-
lated through a previous REFL_ARRAY 
/THRESHOLD or /PICK, followed by 
REFL_ARRAY /AUTOINDEX to index the array, 
then REFL_ARRAY /BRAVAIS to determine the 
Bravais lattice and perform any required trans-
formation of HKL indices. (However, all of this 

can be done only after you have a good spatial 
correction computed, and accurate values for 
the detector distance and X,Y beam center 
stored in the CONFIGURE /EDIT input panel). 
This leaves the array in a state where least 
squares can be performed.

The Reflection Array can hold a maximum of 
512 reflections; however, determination of orien-
tation requires only a small fraction of this num-
ber. Usually, 25 reflections is the bare minimum 
you'll need, with 50–100 reflections about opti-
mal. While determination of orientation from just 
a few contiguous frames is possible (for exam-
ple, the FRAMBO and SADIE verification tests 
determine the orientation of a myoglobin crystal 
from eight contiguous frames), you'll get much 
more precise cell parameters if you threshold a 
few frames taken 90 degrees or so in scan angle 
from the first set, adding them to the Reflection 
Array prior to indexing.

The least squares can incorporate crystal-sys-
tem constraints if desired. By default, the pro-
gram performs a quick linear least squares (of 
the type used in the P3 program) which deter-
mines unit cell parameters and orientation, but 
doesn't refine any of the detector positional cor-
rections or apply constraints. The result (cou-
pled with guesses of zero for the small detector 
positional corrections) is used as an initial guess 
for a nonlinear refinement which incorporates 
detector positional corrections and constraints. 
While crystal-system constraints are useful if 
you want to obtain the best unit cell parameters, 
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you should usually NOT use constraints to 
determine the matrix to be used for data collec-
tion or data reduction; the unconstrained matrix 
is usually better for this purpose. The default is 
unconstrained refinement.

When invoked with the LEASTSQ option from 
the REFL_ARRAY submenu or when run from 
the command line without arguments, 
REFL_ARRAY /LEASTQ displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button begins 
refinement of the unit cell and orientation 
parameters; the ESC key or right mouse button 
returns you to the REFL_ARRAY submenu. You 
can interrupt a refinement in progress with the 
CTRL-BREAK key combination; however, the 
current orientation matrix (e.g., for use by the 
CURSORS commands for computing HKL indi-
ces) at that point is undefined.

When refinement starts, the program displays 
the message “REFINING...” on the bottom sta-
tus line. Refinement should usually be com-
pleted within 10 or 15s. Upon completion, a 
scrolling output window is displayed containing 
the resulting output text. If logging is enabled 
(see LOGFILE) the contents of this window are 
also written to the logfile. When viewing the out-
put, pressing ENTER or the left mouse button 
displays a pop-up menu of options, including 
export of ASCII data; for example, the contents 
of the window could be sent to a file or printer 

with this function. You can also move through 
the window contents with the page keys, arrow 
keys or with mouse motion. Pressing ESC or the 
right mouse button exits the output window, 
returning you to the REFL_ARRAY submenu. 
The output is described in more detail below. 

If REFL /LEASTSQ was invoked from the com-
mand line, the output window is displayed sub-
ject to a 10 s timeout to allow command scripts 
to run without intervention. If you do not press a 
key or mouse button within 10 s after the output 
window is displayed, the program will continue 
as if the ESC key had been pressed.

Upon completion, the program updates the val-
ues in the input panel to their refined values 
(which you'll see if you re-run REFL /LEASTSQ, 
for example, to apply a different set of con-
straints.)

8.18.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (LSQRS/Constraint Type 
(0-9))     [1]

Specifies the type of crystal-system con-
straints to be applied. Types are:

0—Perform only the linear least squares; 
don't proceed with non-linear refinement
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1—Linear least squares followed by uncon-
strained non-linear refinement

2—Linear least squares followed by non-lin-
ear refinement with monoclinic-C con-
straints (alpha=beta=90)

3—Linear least squares followed by non-lin-
ear refinement with monoclinic-B con-
straints (alpha=gamma=90)

4—Linear least squares followed by non-lin-
ear refinement with monoclinic-A con-
straints (beta=gamma=90)

5—Linear least squares followed by non-lin-
ear refinement with orthorhombic con-
straints (alpha=beta=gamma=90)

6—Linear least squares followed by non-lin-
ear refinement with tetragonal constraints 
(A=B, alpha=beta=gamma=90)

7—Linear least squares followed by non-lin-
ear refinement with trigonal/hexagonal con-
straints (A=B, alpha=beta=90, gamma=120)

8—Linear least squares followed by non-lin-
ear refinement with rhombohedral con-
straints (A=B=C, alpha=beta=gamma)

9—Linear least squares followed by non-lin-
ear refinement with cubic constraints 
(A=B=C, alpha=beta=gamma=90)

If you negate constraint type 1–9, the pre-
ceding linear least squares is suppressed, 
and initial guesses are obtained directly 

from the values in the input panel. This 
might save a few seconds if you're re-run-
ning the previous least-squares (which 
updated the input panel parameters to their 
refined values on previous exit) with a differ-
ent constraint type.

The default, 1, should be satisfactory for 
most purposes.

$2 ......................... (A Axis Length)     [10.0]

Initial guess for the A-axis length in Ang-
stroms on entry, updated to the refined 
value on exit. Note that if the constraint type 
($1) is 1–9, the value you start with here 
doesn't matter, since the program will per-
form a linear least squares to compute initial 
guesses for refinement. Valid range is 1-
9999 Angstroms.

$3 ......................... (B Axis Length)     [10.0]

Initial guess for the B-axis length in Ang-
stroms on entry, updated to the refined 
value on exit. (See comments for $2 above).

$4 ......................... (C Axis Length)     [10.0]

Initial guess for the C-axis length in Ang-
stroms on entry, updated to the refined 
value on exit. (See comments for $2 above).

$5 ......................... (Alpha Cell Angle)     [90.0]

Initial guess for the alpha unit cell angle in 
degrees on entry, updated to the refined 
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value on exit. Valid range is 1–179 degrees. 
(See comments for $2 above).

$6 ..........................(Beta Cell Angle)     [90.0]

Initial guess for the beta unit cell angle in 
degrees on entry, updated to the refined 
value on exit. Valid range is 1–179 degrees. 
(See comments for $2 above).

$7 ..........................(Gamma Cell Angle)     [90.0]

Initial guess for the gamma unit cell angle in 
degrees on entry, updated to the refined 
value on exit. Valid range is 1–179 degrees. 
(See comments for $2 above).

/DXC=<n> .............(X Beam Center Correc-
tion)     [0.0]

Initial guess for the CORRECTION to the 
detector beam center X-coordinate in pixels. 
Zero is usually a good value. Note that if the 
constraint type ($1) is 1–9, the value you 
start with here doesn't matter, since the pro-
gram will set the initial guesses for the 
detector positional corrections to zero when 
it performs the linear least squares. This 
entry is updated with its refined value on 
exit. Valid range is -256 to 256.

/DYC=<n> .............(Y Beam Center Correc-
tion)     [0.0]

Initial guess for the CORRECTION to the 
detector beam center X-coordinate in pixels. 

Zero is usually a good value. (See com-
ments for /DXC above).

/DISTANCE=<n> .. (Detector Distance Correc-
tion)     [0.0]

Initial guess for the CORRECTION to the 
detector distance in CM. Zero is usually a 
good value. Valid range is -10 to 10 CM. 
(See comments for /DXC above).

/ROLL=<n>........... (Detector Roll Angle)     [0.0]

Initial guess for the detector roll angle in 
degrees. Zero is usually a good value. Roll 
is defined as right-handed rotation of the 
detector about the goniometer X-axis (the 
direct beam axis) when the swing angle is 
zero. At zero roll, the detector Y-axis is par-
allel to the goniometer Z-axis. Valid range is 
-60 to 60 degrees. (See comments for /DXC 
above).

/YAW=<n> ............ (Detector Yaw Angle)     [0.0]

Initial guess for the detector yaw angle in 
degrees. Zero is usually a good value. Yaw 
is defined as right-handed rotation about the 
detector Y-axis (the vertical axis). At zero 
yaw, the detector X-axis is parallel to (but 
reversed in direction from) the goniometer 
Y-axis. Valid range is -60 to 60 degrees. 
(See comments for /DXC above).
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/U1=<n> ................(1st U-Matrix Eulerian 
Angle)     [0.0]

Initial guess for the first Eulerian angle in 
degrees. The Eulerian angles define the ori-
entation of the crystal axes relative to the 
goniometer XYZ axes when the goniometer 
angles have been driven to zero. They 
define the unitary component of the orienta-
tion matrix (i.e., they define the U matrix in 
Busing and Levy's terminology). The first 
Eulerian angle is a rotation about Z (analo-
gous to the omega angle on a 4-circle goni-
ometer); the second is a rotation about X' 
(analogous to chi), and the third is a rotation 
about Z'' (analogous to phi). Note that if the 
constraint type ($1) is 1–9, the value you 
start with here doesn't matter, since the pro-
gram will get the initial guesses for the Eule-
rian angles from the linear least squares. 
This entry is updated with its refined value 
on exit. Valid range is -360 to 360 degrees.

/U2=<n> ................(2nd U-Matrix Eulerian 
Angle)     [0.0]

Initial guess for the second Eulerian angle in 
degrees. (See comments for /U1 above).

/U3=<n> ................(3rd U-Matrix Eulerian 
Angle)     [0.0]

Initial guess for the third Eulerian angle in 
degrees. (See comments for /U1 above).

/HKLTOL=<n>....... (Max Allowed HKL 
Deviation)     [0.25]

When the least squares is begun, a compar-
ison between the HKL values in the reflec-
tion array and HKL's computed based on 
the setting angles and detector X,Y is made 
for each reflection. Any reflection with a cal-
culated index which deviates from the value 
in the array by more than the tolerance 
specified here is removed from the least 
squares, by clearing its H flag. The following 
prompt is issued when any reflections are 
outside the tolerance (where <n> is the 
number of reflections removed):

<n> REFLECTION(S) REMOVED FROM 
LS (OUTSIDE HKL TOL)

--PRESS ENTER TO CONTINUE, ESC TO 
QUIT

Pressing ENTER or the left mouse button 
continues with the refinement; pressing 
ESC or the right mouse button returns you 
to the REFL_ARRAY submenu (however, 
the H flags of the out-of-tolerance reflec-
tions remain cleared; you can restore them 
with a /MODIFY command). If the command 
was started from a script or from the com-
mand line, this prompt will time out in 10s (if 
it receives no response before then) assum-
ing an ENTER response, to allow scripts to 
run without intervention.
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The default of 0.25 should be satisfactory in 
most cases. Valid range is 0.1 to 999; this 
quantity is dimensionless.

/HALFWIDTH=<n>(Frame Halfwidth)     [0.125]

Specifies half the scan width per frame in 
degrees (on average) of the frames from 
which the records in the reflection array 
were extracted. This value is used to deter-
mine the weighting of observed X,Y posi-
tions versus that of observed scan angle in 
the least squares. That is, the non-linear 
least squares minimizes the residual

sum[Wxy * (Xobs-Xcalc)2 + Wxy * (Yobs-

Ycalc) 2 + Wz * (Zobs-Zcalc) 2]

where Xobs and Xcalc are the observed 
and calculated detector X, Yobs and Ycalc 
are the observed and calculated detector Y, 
and Zobs and Zcalc are the observed and 
calculated scan angle for each spot. The rel-
ative weights Wxy and Wz are determined 
according to:

Wxy = 1./(Exy) 2  and   Wz = 1./(0.5 * H) 2

where Exy is an estimate of the positional 
standard deviation of a reflection and H is 
the frame halfwidth specified here (0.25 of 
the frame width appears to be a fair esti-
mate for the expected rms error in scan 
angle).

A smaller value for the halfwidth will give 
more weight to the scan angle information; a 
larger value gives it less weight. The valid 
range is 0.001 to 9999. The scan angle 
information is very powerful in determining a 
correct solution, and it is probably better for 
the value you enter here to be too low than 
too high. The default is 0.125 (correspond-
ing to 0.25 degree frames).

/MASK=<n>.......... (Constraint Mask)     [0]

Specifies that certain variables are to be 
held fixed in the non-linear refinement. The 
default value of 0 frees all variables, allow-
ing the refinement to proceed normally, and 
should be satisfactory in almost all cases. 
The value you specify here is a decimal inte-
ger corresponding to a bit mask, where a 
set bit fixes its assigned parameter and a 
clear bit frees the parameter. The bit/param-
eter assignments are:

For example, if you specify a value of 96 
(=32 + 64), the program would refine the 

Bit#      Value Parameter

0 1 Detector X positional correction

1 2 Detector Y positional correction

2 4 Detector distance correction

3 8 Detector roll

4 16 Detector yaw

5 32 Unit cell axis lengths

6 64 Unit cell angles
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crystal orientation and detector parameters, 
leaving the unit cell parameters (axis 
lengths and angles) fixed. Note that if you 
wanted them to remain fixed at the values 
specified in the input panel rather than at 
the initial guesses computed by the linear 
least squares, you would have to specify a 
negative value for the constraint type (see 
$1 above).

/PARNAME=<n> ...(Output Parameter File-
name)     [newfram0.p4p]

Specifies the filename to which the orienta-
tion matrix and refined parameters are writ-
ten. This file can be read by ASTRO. It is an 
ASCII file which can be typed, edited, and 
transferred to other computer types (as long 
as the transfer software handles any differ-
ing end-of-line conventions correctly). By 
convention, these filenames end with a ._pr 
extension. The base name of the file 
defaults to the base name of the last set of 
frames processed with REFL_ARRAY 
/THRESHOLD if any, otherwise to 
NEWFRAM0. An example of a ._pr file is:

Each line contains a 5-character item name 
followed by data in free format. The items 
are:

NAME: The data set name, usually the base 
name of the frames processed in the last 
REFL_ARRAY /THRESHOLD command

WAVE: X-ray wavelength in Angstroms

ORT1,2,3: Rows of the orientation matrix. 
The storage convention is that, as written 
here, you could use the matrix to pre-multi-
ply a column HKL vector (in the standard 
mathematical notation) to give a column 
reciprocal lattice vector.

DIST: Nominal detector distance, CM

DETP: The six positional corrections. In 
order they are:
Detector X positional correction (pixels)
Detector Y positional correction (pixels)
Detector distance correction (CM)
Detector pitch (deg)
Detector roll (deg)
Detector yaw (deg)

XCYC: Raw X,Y pixel coordinates of the 
direct beam at swing angle of zero.

The matrix determined by FRAMBO is a 
true orientation matrix; that is, it is indepen-
dent of the starting goniometer angles of the 
scan series used to determine it. While it 
cannot be used directly by XENGEN, in 
many cases it is possible to use the Eulerian 

NAME:swmyo1

WAVE: 1.541840

ORT1: -0.008553 -0.012507 0.000284

ORT2: -0.009394 0.002745 0.000005

ORT3: -0.000143 -0.000237 -0.021975

DIST: 12.000000

DETP:      4.5299    0.5312    -0.2006    0.0000    0.1999    0.0029

XCYC: 255.000000    242.000000
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angles output by FRAMBO's least squares 
to derive initial pseudo-goniostat angles for 
the XENGEN REFINE program. The follow-
ing relationships apply ONLY IN THE CASE 
WHERE THE STARTING GONIOMETER 
OMEGA, PHI, AND CHI FOR THE FRAME 
SERIES INPUT TO THE SPOTS PRO-
GRAM ARE ALL ZERO. Note that a 3-circle 
goniometer is always at chi=45 degrees. 
Below OMEGA(X), PHI(X) and CHI(X) rep-
resent the XENGEN pseudo-goniostat 
omega, phi, and chi, respectively.

The /U1 Eulerian angle in FRAMBO is 
equivalent to -PHI(X)

The /U2 Eulerian angle in FRAMBO is 
equivalent to 180 + CHI(X)

The /U3 Eulerian angle in FRAMBO is 
equivalent to OMEGA(X)

If your starting frame angles were different 
from zero, you can use the XENGEN 
NEWRUN program to compute the pseudo-
goniostat angles in the following steps:

• Use REFINE to create a .upr file containing 
zero-setting-angle pseudo-goniostat angles 
according to the relationships above.

• Run NEWRUN. Enter 0 0 0 for the old set-
ting angles, and the omega, chi, phi starting 
angles of your frame series for the new set-
ting angles.

• NEWRUN will print the values of the 
pseudo-goniostat angles at your starting 
setting angles.

Since the parameters used in the least 
squares refinement are different in 
FRAMBO from those in XENGEN, there is 
no guarantee that pseudo-goniostat angles 
derived from FRAMBO's Eulerian angles 
will be close enough to permit REFINE to 
run. We are not recommending that you try 
to use FRAMBO's indexing and least 
squares instead of the autoindexing in 
REFINE on a regular basis; the relation-
ships between the angles are described 
above because they may occasionally be 
useful under special circumstances.

8.18.2 Least Squares Output

An example of the output frame REFL_ARRAY 
/LEASTSQ is shown below. It begins with the 
orientation matrix (in the same convention as 
described above for the ._pr file) and the refined 
unit cell parameters. The unit cell parameters 
are listed horizontally in the order A, B, C, 
ALPHA, BETA, GAMMA, VOLUME, with lengths 
in Angstroms, angles in degrees, and the vol-
ume in cubic Angstroms. Below each cell 
parameter is its estimated standard deviation.

Next are several tabular histograms, showing 
the distribution of the unsigned differences 
between observed and calculated values of 
H,K,L, scan angle (always labeled OMEGA, 
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even if the scan angle was actually PHI), and 
detector X,Y position. In all cases, the more 
closely bunched toward the left side of the histo-
gram the differences are, the better the refine-
ment. Scan angle differences are in degrees, 
and X,Y differences are in pixels. Following the 
histograms are the overall average and rms dif-
ferences for these same quantities, H,K,L, scan 
angle, X, and Y. The myoglobin example shown 
below is a very good one. Often the numbers 
are two or three times higher. The AVG values 
indicate any systematic bias in the results; if 
these values are a substantial fraction of the 
corresponding RMS values, you might suspect 
mis-indexing or mis-alignment of the system. In 
such a case, make sure you have a good spatial 
correction and correct estimates for the detector 
distance and beam center entered in the CON-
FIGURE /EDIT panel.

Next are the five refined detector positional cor-
rections, with the X and Y beam center correc-
tion in pixels, the detector distance correction in 
CM and the angular corrections in degrees. In 
this example, our estimate of the X beam center 
was just a guess, and was not very good as the 
result indicates. Depending on the smallest 
inter-spot separation on the input frames, you 
may not be able to get away with this poor an 
estimate (off by 4 pixels) in your own data sets. 
You should try to specify the beam center to bet-
ter than half the smallest center-to-center spot 
separation.

The refined Eulerian angles come next, with the 
three values in order corresponding to /U1, /U2, 
and /U3 in degrees.

A line containing overall refinement statistics fol-
lows, with values of the starting and ending 
residual, goodness of fit, number of refinement 
cycles actually performed, and a completion 
code. The residuals give an indication of the 
amount of improvement made by the non-linear 
refinement relative to the initial guesses com-
puted by the linear least squares. Usually the 
residual improves by a factor of two or more. 
The goodness of fit is relative to an estimated 
0.2-pixel error in detector X,Y position of a 
reflection centroid, and an estimated 0.25 
frame-width error in scan angle. If the goodness 
of fit is less than 1.0, the refinement is better 
overall than these nominal estimates; values 
higher than 1.0 indicate that the fit is not as 
good. The completion code is for diagnostic use 
by Bruker. It is normally 0; if it is nonzero and the 
number of refinement cycles is listed as 20, it 
indicates that the solution might benefit from 
additional cycles of refinement. In this situation, 
negate the CONSTRAINT TYPE (see descrip-
tion of the $1 argument) and re-rerun the least 
squares, and the refinement will continue where 
it left off. Other cases where the completion 
code is non-zero indicate that no further 
improvement in the residual can be made even 
though some of the gradients are non-zero, and 
indicates that we've probably underestimated 
the magnitude of round-off errors in the compu-
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tations (the solution, however, should still be 
valid). Please notify Bruker if you see many non-
zero completion codes.

Following the overall statistics is a reflection-by-
reflection summary of the agreement for each 
reflection in the reflection array. Each record 
consists of two lines, the first containing the 
reflection as it's entered in the reflection array 
(i.e., the “observed” values), and the second 
containing the differences for HKL, scan angle 
(always converted into omega rotation) and 
detector X,Y with the sense OBSERVED - CAL-
CULATED. This output shows both those reflec-
tions included in the least squares, and those 
not included (for example, reflections without the 
C flag set). It also shows computed HKL indices 
for reflections which do not have the H flag set. It 
does not include reflections which do not have 
the A flag set, since there are many possible 
combinations of setting angles and detector X,Y 
which could correspond to given HKL indices. 
Use the /HCALC sub-command if you need to 
determine angles corresponding to specific 
HKLs.

An example output (truncated after the first few 
reflections) for least squares on reflections from 
the series of eight contiguous test frames pro-
duced with a hexagonal myoglobin crystal is 
shown below. The refinement was uncon-
strained. The cell parameters in this example 
are not very good, and their standard deviations 
are correspondingly large. They would be better 

if we thresholded an additional set of frames 
starting at a scan angle 90 degrees or so away 
from the first eight prior to indexing and least 
squares.
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Example 8.5 - Least Squares Output from the Eight Test Frames

Orientation Matrix:
 -0.00855331 -0.01250697  0.00028393
 -0.00939403  0.00274520  0.00000470
 -0.00014339 -0.00023734 -0.02197455

Lattice parameters & Standard deviations:
   90.8317   90.1132   45.5042    90.314    89.964   119.944     322733.90
     0.9975     1.8806     0.4779      0.348      0.091       0.238       13974.49

Histograms:
            .00   .05   .10   .15   .20   .25   .30   .35   .40   .45   +Inf
          H    26      0     0      0     0      0       0      0      0      0
          K    26      0     0      0     0      0       0      0      0      0
          L    26      0     0      0     0      0       0      0      0      0
 Omega    26      0     0      0     0      0       0      0      0      0

          0.00  0.25  0.50  0.75  1.00  1.25  1.50  1.75  2.00  2.25  +Inf
        X      22      4       0       0       0       0       0       0       0      0
        Y      25      1       0       0       0       0       0       0       0      0

                          H           K            L     Omega          X           Y
      AVG      0.000     0.000     0.000     0.000     0.000     0.000
      RMS      0.012     0.006     0.006     0.014     0.147     0.137
Detector corrections:  X-Cen   Y-Cen      Dist      Roll     Yaw
                                   4.530  -0.531  -0.201   0.200   0.003

Eulerian angles:     -95.154 178.930 -37.169

Nonlinear refinement:    StartingRes       FinalRes           GOF    #Cycles    Code
                                     6.49567E-01     2.76423E-01    0.44              4          0 

  # Flags     H   K   L    2-Theta   Omega     Phi       Chi         X         Y  Inorm    I/Sig
  1 ACHS   16  -7   8   -30.000   -0.271    0.000   0.000  82.85  51.23  626.60  112
              +.02-.01+.01                0.004                            -0.26    0.15

  2 ACHS   12  -6   6   -30.000   -0.443    0.000   0.000  33.26  99.06  467.95   97
              +.01+.00+.01              -0.022                            -0.14    0.28
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3 ACHS   21 -11  -3 -30.000  -0.448   0.000   0.000 142.13 309.54  344.28   83
            +.01+.00+.00            -0.012                            -0.16     0.02
                                 .
                                 .
                                 .
                                 .
                                etc.
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8.19 Peaks > Refl. Array > Edit • 
View/modify the reflection array

Menu Command: Peaks > Refl. Array > Edit

Accelerator: Ctrl+E

User Level: 1

SLAM Syntax: REFL_ARRAY  /EDIT

When you select EDIT from the REFL_ARRAY 
submenu the system displays a “scrollable” win-
dow listing all of the reflections currently in the 
reflection array. You can add to, delete from, or 
reorganize the list as desired by using the 
appropriate screen-editing functions. This is 
very useful for making minor corrections, 
changes, and deletions; however, some of the 
other sub-commands, such as /SORT and 
/MODIFY can operate globally on the entire 
array, and provide a faster method for making 
more extensive changes.

REFL_ARRAY /EDIT is an interactive command 
only. You can invoke it from the command line, 
but it will not proceed without intervention. There 
is no built-in 10s timeout on REFL_ARRAY 
/EDIT like there is on other scrolling output win-
dows. The command line syntax is:

REFL_ARRAY /EDIT

Some of the other sub-commands, such as 
/MODIFY automatically invoke /EDIT on com-
pletion (but only when they have been invoked 
from the REFL_ARRAY submenu) so you can 

review the results. Operation in such a case is 
the same as described here.

Like other scrollable windows, the 
REFL_ARRAY /EDIT window displays the ASCII 
“icon” |/\\/| at the left of the title bar. You can 
move through the text in the array with the page 
keys, arrow keys, or mouse motion. If you press 
the ESC key or right mouse button, the program 
will return to the REFL_ARRAY submenu. If you 
press the ENTER key or left mouse button when 
in the scrolling edit window, the program dis-
plays a pop-up menu of editing functions. You 
can then use the cursor keys or mouse to select 
a specific function to implement. Press ENTER 
or the left mouse button again to execute it, or 
ESC/right button to return to the editing window.

The functions in the pop-up menu are as fol-
lows:

Exit

Return to REFL_ARRAY submenu, saving 
changes to array. The ESC key or right 
mouse button performs the same function 
when you're in the editing window.

Edit

Edit displayed lines, using mouse or cursor 
to move between lines.

UpPage

Move up one page (screen) in list of reflec-
tions. The PgUp key (Prev on VAX) per-
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forms the same function when you're in the 
editing window.

DownPage

Move down one page (screen) in list of 
reflections. Note that you cannot move 
down past the end of the list. The PgDn key 
(Next on VAX) performs the same function 
when you're in the editing window.

Top

This moves you to the first line in the reflec-
tion array. The key combination CTRL-PgUp 
has the same effect when you're in the edit-
ing window.

Bottom

This moves you to the last line in the reflec-
tion array. The key combination CTRL-PgDn 
has the same effect when you're in the edit-
ing window.

Write

Writes all lines or selected lines to an ASCII 
file on disk for storage and future use. If a 
range of lines has been highlighted with 
SELECT (see below) only the highlighted 
range is written to the file, otherwise the 
entire array is written.

Read

Appends lines from a disk file (for example, 
created by WRITE) to the end of the array. 

You can use the Cut and Paste functions to 
move the new lines elsewhere if necessary. 

Select

This function is used to highlight (select) a 
range of lines in the array, permitting writing, 
cutting, copying and pasting a specified 
range. Pressing the F7 key has the same 
effect when you're in the editing window.

Cut

This removes a selection from the array and 
places it in the paste buffer. Use PASTE to 
reinsert the line(s) that were cut. Pressing 
the F8 key has the same effect when you're 
in the editing window.

Store

Makes a copy of the current selection (this is 
the same as CUT, but does not remove the 
selected text from the array) and places it in 
the paste buffer. Pressing the F9 key has 
the same effect when you're in the editing 
window.

Paste

Inserts the contents of the paste buffer 
ahead of the current line. Pressing the F10 
key has the same effect when you're in the 
editing window. If there aren't enough free 
lines in the array, the paste will not be per-
formed.
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The items in the Reflection Array have the fol-
lowing definition:

FLAGS

The status of a reflection is indicated by a 
series of single-character flags that are dis-
played in this field. There are four possible 
flags, having the following meanings. The 
flags always appear in sorted order, ACHS, 
ACS, AH, etc. with no intervening spaces. If 
you're entering or changing the flags in the 
/EDIT sub-command, you can enter the 
flags in a different order, but make sure that 
there are no imbedded spaces.

A This reflection record includes the 
goniometer settings angles and the 
the X,Y position of the reflection rela-
tive to detector origin (in the standard 
Bruker pixel coordinate convention). 
This flag is automatically set by 
REFL_ARRAY /THRESHOLD and 
/PICK when they enter a new reflec-
tion into the array. If this flag is not set, 
the /INDEX and /LEASTSQ sub-com-
mands ignore the reflection.

H This reflection record includes the HKL 
indices. Autoindexing automatically 
sets this flag when it computes the 
HKL indices. If this flag is not set, 
REFL_ARRAY /LEASTSQ ignores the 
reflection.

C This reflection is “centered” in scan 
angle; that is, there was sufficient 
information to determine the centroid 
in scan angle to better than 1 frame 
width. REFL_ARRAY /THRESHOLD 
and /PICK automatically set this flag if 
the spot intensity (e.g., for those pixels 
above the threshold) spanned more 
than one frame. If the reflection 
appeared on only one data frame it, 
the C flag is not set. In a case where 
there are too few spots spanning 
frames, you can use the /MODIFY 
sub-command to add the C flag to all 
reflections in the set. In general, it 
doesn't affect the autoindexing capa-
bility of the program to do this; how-
ever, the RMS deviation in the scan 
angle (as output by the /LEASTSQ 
sub-command) is typically much larger 
when these spots are included, and 
the orientation and cell parameters 
may not be as precise.

S Indicates that the values of the X,Y 
spot positions in this reflection record 
have been corrected with a valid spa-
tial correction (obtained by processing 
a brass fiducial plate image with the 
SPATIAL /NEW, /PROCESS or /LOAD 
command). REFL_ARRAY /THRESH-
OLD and /PICK automatically set this 
flag and store the corrected X,Y values 
if a spatial correction was in effect 
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when they were executed. If this flag is 
absent, REFL_ARRAY /INDEX and 
/LEASTSQ assume that the X,Y val-
ues in this record are raw values, and 
explicitly correct them in the course of 
their computations.

X Display angles in XSCANS conven-
tions with X,Y at detector center, 
instead of goniometer settings and X,Y 
pixel location.

H,K,L

The HKL crystallographic indices. /INDEX 
automatically computes these indices and 
stores them in the array. /BRAVAIS and 
/TRANSFORM transform these indices 
among different unit cell possibilities and 
conventions. If HKL indices are not available 
for a reflection /LEASTSQ ignores it.

2-THETA, OMEGA, PHI, CHI

The goniometer setting angles. /THRESH-
OLD and /PICK automatically enter these 
values into the array based on the angles 
found in the frame headers. If the C flag is 
set, the scan angle (omega or phi) will typi-
cally be set to the intensity-weighted cen-
troid value computed by /THRESHOLD or 
/PICK; otherwise, the scan angle is set to 
that corresponding to the frame on which 
the spot was located. If angles are not avail-
able for a reflection,  /INDEX and 
/LEASTSQ ignore it.

X,Y

These are the X- and Y-centroids of the 
reflection on this line in the Bruker pixel 
coordinate convention.  /THRESHOLD and 
/PICK automatically enter these values into 
the array. If a spatial correction is in effect at 
the time, the entered X,Y values are cor-
rected for spatial distortion and the S flag is 
set; otherwise, raw X,Y values are entered 
and the S flag is not set. If X and Y are not 
available for a reflection, /INDEX and 
/LEASTSQ ignore it.

INORM

This is the normalized intensity for the 
reflection.  /THRESHOLD and /PICK auto-
matically enter this value into the array. The 
intensity is normalized to 1 deg/min scan 
velocity.

I/SIGMA

This is the ratio of the reflection intensity to 
its standard deviation. /THRESHOLD and 
/PICK automatically enter this value into the 
array. /THRESHOLD uses I/SIGMA (modi-
fied by a specified sin(theta) bias) as a sort 
key, and reflections entered automatically 
be /THRESHOLD are thus approximately in 
order of decreasing I/SIGMA (with “cen-
tered” reflections coming before “uncen-
tered” reflections).
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8.19.1 Line Editing

You can edit text within a line with the same 
functions used to edit text in an input panel. The 
data you enter on each line is read, validated 
and reformatted according to the flags you sup-
ply at the beginning of the line. For a given com-
bination of flags, the program expects there to 
follow a certain number of numeric values in free 
separated by spaces. If the number of items or 
their type doesn't agree with the flag settings, 
the program issues and error message and asks 
you to re-enter the line. Modifying the A and H 
flags from with REFL_ARRAY /EDIT (as 
opposed to /MODIFY) can be a tricky process 
and is therefore not recommended.
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8.20 Peaks > Refl. Array > Modify • 
Alter specified item for a range of 
reflections in the array

Menu Command: Peaks > Refl. Array > Modify

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY /MODIFY $1 $2 
/FIELD=<n> /VALUE=<s>

This option lets you make global changes to all 
or part of a specified column in the Reflection 
Array. It is possible to add and subtract flags 
from a range of lines, set a particular column to 
a constant value, negate the values in a column, 
or transfer the values from one column into 
another column.

When invoked with the MODIFY option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
REFL_ARRAY /MODIFY displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button performs 
the specified modifications, then displays the 
resulting array in an editing window for review, 
identical to the REFL_ARRAY /EDIT window 
(see REFL_ARRAY /EDIT). Pressing ESC or 
the right mouse button in the editing window or 
in the input panel returns you to the 
REFL_ARRAY submenu.

8.20.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (First Reflection #)     [1]

This is the line where you want the selection 
range to start. Line numbers start at 1. For 
example, if you want to modify only reflec-
tions 5 through 7, you would enter “5” in the 
FIRST REFLECTION # parameter. Default 
is 1. Valid range is 1–512.

$2 ......................... (Last Reflection #)     [512]

This is the line where you want the range to 
end. Line numbers start at 1. To continue 
the previous example, if you want to modify 
only reflections 5 through 7, you would enter 
“7” in the LAST parameter. Default is 1. 
Valid range is 1–512.
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/FIELD=<n>...........(Field to Modify)     [1]

Specify which field (column) you want to 
change. You specify the field by its column 
number. Default is 1. Valid range is 1–12. 
Field numbers are:

/VALUE=<s> .........(New Value)     [-C]

Enter the value to which the entries in the 
specified column and range of lines are to 
be set. REFL_ARRAY /MODIFY also sup-
ports the following “special” values:

+f, -f where f is one of the flag characters A 
C H or S. This sets or clears the speci-
fied flag, leaving the state of the other 
flags unaffected for each reflection. 
The field # must be 1 if you use this 
option.

- Negates all the numeric values in the 
specified range. The field number 
must be 2–8 (i.e., only applies to HKL 
indices and setting angles).

#N where N is the number of a field in the 
same group. This copies the values 
from column #N into the column being 
modified. This works within two differ-
ent groups of columns, the HKL group 
(#2–4) and the setting angle group 
(#5-8). Thus, if the value you specified 
for /FIELD is 7, only #5, #6, #7, or #8 is 
a valid copy operation; #2 would not 
work in this case.

Examples:

1. Set the C flags of all reflections in the 
array, leaving all the other flags intact:

REFL_ARRAY /MODIFY 1 512 /FIELD=1 
/VALUE=+C

2. Change the scan angle extracted from a 
frame series from omega to phi, effectively 
reversing the sense of the scans (assuming 
all the existing phi values in the array are the 
same):

REFL_ARRAY /MODIFY 1 512 /FIELD=7 
/VALUE=#6

REFL_ARRAY /MODIFY 1 512 /FIELD=6 
/VALUE=0.0

Field # Description

1 Flags (for example, ACHSX)

2 H index

3 K index

4 L index

5 2-Theta setting (swing) angle

6 Omega setting angle

7 Phi setting angle

8 Chi setting angle

9 Detector X pixel coordinate

10 Detector Y pixel coordinate

11 Intensity

12 I/sigma
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3. Change the swing angle for reflections 
107–200 to -30 degrees:

REFL_ARRAY /MODIFY 107 200 /FIELD=5 
/VALUE=-30.0

8.21 Peaks > Refl. Array > Sort • 
Sort all or part of array on a specified 
parameter

Menu Command: Peaks > Refl. Array > Sort

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY /SORT $1 $2 
/FIELD=N /DESCENDING

This command lets you sort the reflection array, 
or a specified range of lines within the array, in 
ascending or descending order. The array may 
be sorted on any of the 12 Reflection Array col-
umns:

FLAGS, H, K, L, 2THETA, OMEGA, PHI, 
CHI, X, Y, INORM, I/SIGMA

This provides a means for organizing the array 
in a manner more suitable for publication (e.g., 
placing it in hkl order; 001 002 003...), or that will 
facilitate editing, problem diagnosis, etc.

When invoked with the SORT option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
REFL_ARRAY /SORT displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button begins the 
sort; the ESC key or right mouse button returns 
you to the REFL_ARRAY submenu. When sort-
ing starts, the program displays the message 
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“SORTING...” on the bottom status line. Sorting 
should be completed within a few seconds. On 
completion the program displays the resulting 
array in an editing window for review, identical to 
the REFL_ARRAY /EDIT window (see 
REFL_ARRAY /EDIT). Pressing ESC or the 
right mouse button in the editing window returns 
you to the REFL_ARRAY submenu.

When you sort on one of the HKL indices, the 
program automatically performs secondary and 
tertiary sub-sorts on the other two indices. For 
example, if you sort on H, the program performs 
that sort, then sorts on K for each H, and on L 
for each K. The result would look something like 
this:

H K L
0 0 1
0 0 2
0 0 3
0 1 0
0 1 1
0 1 2
1 0 0
1 0 1
1 0 2
1 0 3
1 1 0
1 1 3
1 1 5
etc.

Similarly, if you sort on one of the scan angles, 
sub-sorts are performed on the other scan 

angles. The sub-sorts are performed in the fol-
lowing order:

8.21.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (First Reflection #)     [1]

This is the Reflection Array line where you 
want the sort range to start. The first line is 
numbered 1. For example, if you want to 
sort only reflections 9 through 50, you would 
enter “9” as the $1 parameter.

$2 ......................... (Last Reflection #)     [512]

This is the line where you want the sort 
range to end. To continue the previous 
example, if you want to sort only reflections 
9 through 50, you would enter “50” in the 
LAST parameter.

Specified
Sort Key

Secondary
Sort

Tertiary
Sort

Quaternary
Sort

H K L None

K L H None

L H K None

2-Theta           Omega Phi Chi

Omega               2-Theta           Phi Chi

Phi                2-Theta           Omega          Chi

Chi 2-Theta Omega Phi
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/FIELD=<n> ..........(Sort Field)     [1]

Specifies number of the column you want to 
sort on. Column numbers are:

/DESCENDING.....(Descending (Y/N) ?)     [No]

If you enter Y for this item on the input 
panel, or if this qualifier is present on the 
command line, the sort is in descending 
order, otherwise it is in ascending order.

Field # Description

1 Flags (for example, ACHSX)

2 H index

3 K index

4 L index

5 2-Theta setting (swing) angle

6 Omega setting angle

7 Phi setting angle

8 Chi setting angle

9 Detector X pixel coordinate

10 Detector Y pixel coordinate

11 Intensity

12 I/sigma
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8.22 Peaks > Refl. Array > Transform 
• Transform HKLs in array according 
to specified 3x3 matrix

Menu Command: Peaks > Refl. Array > 
Transform

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY /TRANSFORM $1 
$2 $3 $4 $5 $6 $7 $8 $9

REFL_ARRAY /TRANSFORM lets you enter the 
nine elements of a specific HKL transformation 
matrix, and transforms the HKL indices of all 
indexed reflections (i.e., those whose H flag is 
set) in the Reflection Array by that matrix. The 
input matrix pre-multiplies a column HKL vector 
formed from each input HKL to yield a column 
vector containing the transformed HKL. You 
would use this function, for example, if you 
needed to use a non-standard space group set-
ting (e.g., orthorhombic with the B axis longest), 
to transform the indices to correspond to the 
desired setting prior to performing least 
squares.

When invoked with the TRANSFORM option 
from the REFL_ARRAY submenu or when run 
from the command line without arguments, 
REFL_ARRAY /TRANSFORM displays an input 
panel where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button performs 

the specified transformation; the ESC key or 
right mouse button returns you directly to the 
REFL_ARRAY submenu without updating the 
matrix. Following a successful transformation, 
the program displays the resulting Reflection 
Array in an editing window for review, identical to 
the REFL_ARRAY /EDIT window (see 
REFL_ARRAY /EDIT). Pressing ESC or the 
right mouse button in the editing window returns 
you to the REFL_ARRAY submenu.

8.22.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

Note that the element order on the input panel 
corresponds to the standard mathematical con-

vention (e.g., (1,3) is 3rd column on 1st row). It 
has nothing to do with FORTRAN storage con-
ventions. As entered, the matrix will pre-multiply 
a column HKL vector to give a transformed col-
umn HKL vector.

$1 ......................... (Matrix(1,1))     [1.0]

Value for row 1, column 1 of orientation 
matrix

$2 ......................... (Matrix(1,2))     [0.0]

Value for row 1, column 2 of orientation 
matrix
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$3 ..........................(Matrix(1,3))     [0.0]

Value for row 1, column 3 of orientation 
matrix

$4 ..........................(Matrix(2,1))     [0.0]

Value for row 2, column 1 of orientation 
matrix

$5 ..........................(Matrix(2,2))     [1.0]

Value for row 2, column 2 of orientation 
matrix

$6 ..........................(Matrix(2,3))     [0.0]

Value for row 2, column 3 of orientation 
matrix

$7 ..........................(Matrix(3,1))     [0.0]

Value for row 3, column 1 of orientation 
matrix

$8 ..........................(Matrix(3,2))     [0.0]

Value for row 3, column 2 of orientation 
matrix

$9 ..........................(Matrix(3,3))     [1.0]

Value for row 3, column 3 of orientation 
matrix
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8.23 Peaks > Refl. Array > Matrix • 
Enter an orientation matrix 
(e.g., from external program)

Menu Command: Peaks > Refl. Array > Matrix

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY /MATRIX $1 $2 
$3 $4 $5 $6 $7 $8 $9

REFL_ARRAY /MATRIX lets you enter the nine 
elements of a specific orientation matrix. The 
resulting matrix is treated as if it had been deter-
mined by REFL_ARRAY /LEASTSQUARES. In 
general, this is not as accurate as running 
REFL_ARRAY /LEASTSQUARES, since the lat-
ter simultaneously refines both the matrix ele-
ments and the detector positional corrections—
here, we're only entering a matrix. Nevertheless, 
if you have an existing matrix (for example, from 
P3 or XSCANS), REFL_ARRAY /MATRIX could 
allow you to immediately index a few spots on a 
frame and run least squares without the need for 
autoindexing.

When invoked with the MATRIX option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
REFL_ARRAY /MATRIX displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button installs the 
specified orientation matrix and returns you to 

the REFL_ARRAY submenu; the ESC key or 
right mouse button returns you directly to the 
REFL_ARRAY submenu without updating the 
matrix.

When REFL_ARRAY /MATRIX updates the ori-
entation matrix, it also extracts the unit cell 
parameters from the matrix and places them in 
the REFL_ARRAY /BRAVAIS and /LEAST-
SQUARES input panels as defaults (in the case 
of the /LEASTSQUARES panel, the Eulerian 
angle defaults are also extracted from the input 
matrix). You can use this feature to compute the 
cell parameters and Eulerian angles corre-
sponding to a given orientation matrix.

8.23.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

Note that the element order on the input panel 
corresponds to the standard mathematical con-

vention (e.g., (1,3) is 3rd column on 1st row). It 
has nothing to do with FORTRAN storage con-
ventions. As entered, the matrix will pre-multiply 
a column HKL vector to give and column recip-
rocal-lattice vector. The matrix must conform to 
the common convention used in FRAMBO, P3, 
XSCANS, ASTRO, GADDS, etc.:

$1 ......................... (Matrix(1,1))     [1.0]

Value for row 1, column 1 of orientation 
matrix
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$2 ..........................(Matrix(1,2))     [0.0]

Value for row 1, column 2 of orientation 
matrix

$3 ..........................(Matrix(1,3))     [0.0]

Value for row 1, column 3 of orientation 
matrix

$4 ..........................(Matrix(2,1))     [0.0]

Value for row 2, column 1 of orientation 
matrix

$5 ..........................(Matrix(2,2))     [1.0]

Value for row 2, column 2 of orientation 
matrix

$6 ..........................(Matrix(2,3))     [0.0]

Value for row 2, column 3 of orientation 
matrix

$7 ..........................(Matrix(3,1))     [0.0]

Value for row 3, column 1 of orientation 
matrix

$8 ..........................(Matrix(3,2))     [0.0]

Value for row 3, column 2 of orientation 
matrix

$9 ..........................(Matrix(3,3))     [1.0]

Value for row 3, column 3 of orientation 
matrix
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8.24 Peaks > Refl. Array > Hcalc • 
Compute X, Y, and scan angle for 
specified HKL

Menu Command: Peaks > Refl. Array > Hcalc

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY /HCALC $1 $2 $3 
$4 $5 $6 $7 $8 $9

Given an orientation matrix, specified HKL indi-
ces, a scan axis, and setting angles for the other 
axes, REFL_ARRAY /HCALC computes the 
detector X and Y in pixels and the scan angle at 
which the reflection will be observed. You must 
already have computed a valid orientation 
matrix with REFL_ARRAY /LEASTSQ prior to 
executing this command.

In general, there are two solutions. Depending 
on the angle between the scan axis and recipro-
cal-lattice vector, the setting angles you specify 
for the non-scan axes, and the current detector 
distance, one, both, or none of the solutions 
may be observable. The program displays the 
results in a scrollable output window.

When invoked with the HCALC option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
REFL_ARRAY /HCALC displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button solves for 

the positions at which the specified HKL can be 
observed; the ESC key or right mouse button 
returns you directly to the REFL_ARRAY sub-
menu. Following a successful computation, a 
scrolling output window is displayed containing 
the resulting output text. If logging is enabled 
(see LOGFILE) the contents of this window are 
also written to the logfile. When viewing the out-
put, pressing ENTER or the left mouse button 
displays a pop-up menu of options, including 
export of ASCII data; for example, the contents 
of the window could be sent to a file or printer 
with this function. You can also move through 
the window contents with the page keys, arrow 
keys or with mouse motion. Pressing ESC or the 
right mouse button exits the output window, 
returning you to the REFL_ARRAY submenu. 
The output is described in more detail below. In 
GADDS, the program will prompt you on the bot-
tom status line as to whether you want to drive 
to one of the solutions; for example, 

DRIVE TO SOLN #1 AT -30.00 150.62  0.00  
0.00? (Y OR ENTER=YES; N OR ESC=NO)

If you answer one of these prompts with the Y 
key, ENTER key, or left mouse button, GADDS 
attempts to drive the goniometer to that position. 
If you answer with the N key, ESC key, or right 
mouse button, the goniometer remains where it 
is. The operation in SADIE is the same, except 
that the drive prompts are not issued.

In some cases, no rotation about the specified 
scan axis exists which will place the specified 
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HKL in the diffracting condition. If this occurs, 
the program displays the message

REFLECTION NOT OBSERVABLE -- 
PRESS ENTER OR MOUSE TO RETURN

Pressing the ENTER key or left mouse button 
returns you to the input panel (or to the com-
mand line if the command was invoked from 
there).

8.24.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(H)     [0]

Enter the H index of the reflection whose 
position is to be computed. Default is 0 and 
valid range is -9999 to 9999. Real values 
may be used; they are not rounded to inte-
ger values prior to computing the position.

$2 ..........................(K)     [0]

Enter the K index of the reflection whose 
position is to be computed. Default is 0 and 
valid range is -9999 to 9999. Real values 
may be used; they are not rounded to inte-
ger values prior to computing the position.

$3 ..........................(L)     [2]

Enter the L index of the reflection whose 
position is to be computed. Default is 2 and 
valid range is -9999 to 9999. Real values 

may be used; they are not rounded to inte-
ger values prior to computing the position.

$4 ......................... (Scan Axis #)     [2]

Enter the axis number (2 for omega or 3 for 
phi) of the axis whose position (to place the 
specified HKL in the diffracting condition, if 
possible) is to be computed. The values that 
you specify below for the other three goni-
ometer axes are kept fixed for the purposes 
of computation. The value that you supply 
below for this scan axis makes no differ-
ence.

$5 ......................... (2-Theta)     [0.00]

Enter the detector swing angle in degrees at 
which the scan angle and detector X,Y of 
the specified HKL reflection are to be com-
puted. Default is zero and valid range is 
-360 to 9999.

$6 ......................... (Omega)     [0.00]

Enter the omega goniometer angle in 
degrees at which the scan angle and detec-
tor X,Y of the specified HKL reflection are to 
be computed. If you've specified a scan axis 
of 2 (see above), any valid value is OK here. 
Default is zero and valid range is -360 to 
9999.

$7 ......................... (Phi)     [0.00]

Enter the phi goniometer angle in degrees 
at which the scan angle and detector X,Y of 
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the specified HKL reflection are to be com-
puted. If you've specified a scan axis of 3 
(see above), any valid value is OK here. 
Default is zero and valid range is -360 to 
9999.

$8 ..........................(Chi)     [0.00]

Enter the chi goniometer angle in degrees 
at which the scan angle and detector X,Y of 
the specified HKL reflection are to be com-
puted. Default is zero and valid range is 
-360 to 9999.

$9 ..........................(Frame Size)     [512]

Enter number of linear pixels in a frame, 512 
or 1024.

8.24.2 HCALC Output

Example 8.6 below is an output window from 
REFL_ARRAY /HCALC. The output window 
starts with a line containing the input HKL indi-
ces, followed by the two solutions, if available. 
The three non-scan axes will contain the same 
values as you specified in the input panel. The 
value of the scan axis that would place the spec-
ified HKL in the diffracting condition in degrees 
is also shown. The X,Y position in pixels (in the 
Bruker convention with (0,0) at the left of a dis-
played frame) is shown both in spatially cor-
rected coordinates (X(cor),Y(cor)) and in raw 
coordinates (X(raw),Y(raw)). If the corrected 
coordinates are too far outside the detector 
active area for raw coordinates to be computed, 
the X(raw), Y(raw) columns contain the text 
“OUTSIDE DETECTOR AREA.”

Example 8.6 - REFL_ARRAY /HCALC Output

Calculated positions for HKL =  16.00  -7.00   8.00:

Soln #  2Theta   Omega     Phi     Chi  X(cor)  Y(cor)  X(raw)  Y(raw)

     1  -30.00   15.45    0.00    0.00 -632.24  548.21: outside detector area

     2  -30.00  162.07    0.00    0.00  175.03  427.07  173.71  425.44

Determine desired solution (1 or 2).  Press ESC to continue ...
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8.25 Peaks > Refl. Array > Clear • 
Erase the reflection array and current 
orientation matrix

Menu Command: Peaks > Refl. Array > Clear

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY  /CLEAR

Use this command to erase the reflection array 
that is currently in use and to delete the orienta-
tion matrix associated with it. This is useful if 
you're starting analysis of a new sample, have 
(for example) used too low a threshold in speci-
fying spots for the array and wish to start over, 
or if you suspect twinning and would like to cal-
culate the orientation matrices for different sets 
of reflections to test the crystal quality.

When you invoke CLEAR from the 
REFL_ARRAY submenu or specify 
REFL_ARRAY /CLEAR on the command line, 
the program issues the warning on the bottom 
status line:

ERASE REFLECTION ARRAY: ARE YOU 
SURE? (Y or ENTER=YES; N or ESC=NO)

Press the Y key, Enter key, or left mouse button 
to erase the array and return control to the pro-
gram, or the N key, ESC key, or right mouse but-
ton to return without erasing the array. If you've 
invoked REFL_ARRAY /CLEAR from the com-
mand line, this prompt will time out in 10s, 

assuming a “Y” answer, allowing script files to 
run unattended. If you however press a key 
within the 10s period, the wait for timeout is can-
celled, and the program will take the action 
you've just specified.

8.25.1 Arguments

None. Command executes immediately.
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8.26 Peaks > Refl. Array > Load • 
Read in orientation matrix from 
existing .p4p or ._pr file

Menu Command: Peaks > Refl. Array > Load

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY /LOAD $1 $2 $3

When invoked with the LOAD option from the 
REFL_ARRAY submenu or when run from the 
command line without arguments, 
REFL_ARRAY /LOAD displays an input panel 
where you can view/modify the arguments 
described below. When in the panel, pressing 
the ENTER key or left mouse button performs 
the load command. Pressing ESC or the right 
mouse button returns you to the REFL_ARRAY 
submenu.

8.26.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(Filename)     [lys.p4p]

Enter name of P4P or LS parameter (*._pr) 
file to load. If extension is omitted, GADDS 
will try P4P, then _PR.

$2 ......................... (Overwrite Reflections?) 
[No]

Check to overwrite reflection array list with 
list in P4P/LS file.

$3 ......................... (Overwrite Crystal Info?) 
[No]

Check to overwrite Project > Edit crystal info 
items.
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8.27 Peaks > Refl. Array > Rspace • 
Reciprocal space viewing for 
interactive indexing

Menu Command: Peaks > Refl. Array > RSpace

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY  /RSPACE

Rspace command is designed to perform inter-
active indexing on an HKL list consisting of mul-
tiple domains. These domains can be either the 
same structure with different orientations, or dif-
ferent structures.

Rotate

Use Rotate to view the HKL reflections in 
reciprocal space. The idea is to rotate the 
view until the reciprocal space planes line-
up. All reflections lining up on planes are 
from a single domain.

Zero all angles

Rotate to initial position. Sort of a return to 
starting point.

Set plane

Select points on a plane. These points are 
assigned to a group (up to five groups may 
be used). Typically used after rotating until 
reflections line up on planes.

Zoom in (2x)

Select new center of rotation, the zoom by a 
factor of 2.

Zoom out

Zoom out by a factor of 2.

Delete group

Assigns all points of a group to the global 
group. The reflections are not deleted, so it 
reverses the effects of “Set plane.”

Write group

Write a group to a file. This file can be read 
under Refl_array /Edit and then indexed.

Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

None..................... ()     []

Due to the interactive nature of this com-
mand, /RSPACE cannot be executed in 
SLAM mode.
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8.28 Peaks > Refl. Array > CDF 
Search • Search the CDF database for 
structure with specified unit cell

Menu Command: Peaks > Refl. Array > CDF 
Search

Accelerator: None

User Level: 1

SLAM Syntax:

REFL_ARRAY /CDF $1 $2 $3 $4 $5 $6 $7 
$8 /FORMULA=<s> /TYPE=<s> /FILE=<s> 
/VERBOSE

REFL_ARRAY /CDF (CDF Search on the sub-
menu) lets you search the NIST Crystal Data 
File for any published lattice parameters that 
match the lattice parameters for your crystal. 
Supports either the ICDD Crystal Data or the 
newer NIST Crystal Data 1999 database.

Before CDF search may be used, the CDF index 
file must be generated by running 
\saxi\gadds32\indxtl.exe. INDXTL requires a 
couple of files as input:

SAXI$CDCODE:codens.dat

SAXI$CDROM:crystal.dat

And generates as output the index file:

SAXI$CDF:cryidx.bin

INDXTL takes a long time to run, so be patient.

8.28.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (A Axis Length)     [10.0]

$2 ......................... (B Axis Length)     [10.0]

$3 ......................... (C Axis Length)     [10.0]

$4 ......................... (Alpha Cell Angle)     [90.0]

$5 ......................... (Beta Cell Angle)     [90.0]

$6 ......................... (Gamma Cell Angle)     [90.0]

These are the 6 unit cell parameters you 
want to find matching entries for. Normally 
they will be those for the mounted crystal, 
but you may enter parameters for any unit 
cell. The values in the input panel are auto-
matically updated with the results of the 
REFL /BRAVAIS or REFL /LEASTSQ when-
ever these commands are run.

$7 ......................... (Decimal Fraction Devia-
tion)  [0.01]

The program searches for any unit cell with 
axis lengths in the range of (1 - d) * input 
axis length to (1 + d) * input axis length. The 
variable d is the DECIMAL FRACTION 
DEVIATION. A value of 0.01 is a good value 
for the first search.
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$8 ..........................(Lattice Centering Type)     
[P]

Enter the lattice type (P,A,B,C,I,F or R), 
where P=Primitive, A, B or C=Edge-cen-
tered, I=Body-centered, F=Face-centered, 
or R=Rhombohedral. The input panel value 
is automatically updated with the results of 
the REFL /BRAVAIS or REFL /LEASTSQ 
whenever these commands are run.

/FORMULA=<s> ...(Chemical Formula)     [?]

This item is currently unused; in a later ver-
sion the program may allow selection by 
chemical formula.

/TYPE=<s> ...........(Search Type)     [BOTH]

The NIST Crystal Data File is divided into 
Organic and Inorganic structures. Choose 
Organic, Inorganic or Both.

/FILE=<s> .............(Output File Name)     
[hits.out]

The information from the NIST Crystal Data 
File for each match that is found is written to 
an output file, in addition to being displayed 
on the screen. Enter a file name for this file.

/VERBOSE............(Verbose Output)     [N]

Controls the amount of information sent to 
the output file. Choose Y to put the entire 
CDF record(s) out to the output file.

8.28.2 CDF-Search Algorithm

The current version of the NIST Crystal Data 
File contains unit cell parameters for over 
144,000 crystals whose lattice parameters have 
been published. This file is not included with 
GADDS. It can be obtained, in CD-ROM format, 
from:

NIST

Need address here.

An index file containing reduced cell axial 
lengths and cell volumes was prepared to 
enable the search algorithm to search the CD-
ROM very efficiently. INDXTL, a program that 
builds this index, is included in the GADDS dis-
tribution.

From the input lattice parameters and lattice 
type, the reduced unit cell parameters are calcu-
lated. The index file is searched for all possible 
matches that have a, b, c and volume within the 
DECIMAL FRACTION DEVIATION. For each 
match, the corresponding NIST Crystal Data 
File record is read. If the cell angles are within 
the prescribed limits, all information for that 
record is written to a match file. The matches 
are then sorted by a goodness-of-fit parameter 
(the best matches will be first) and written to the 
output file.

The search algorithm takes only a few seconds 
to complete. If you get too few matches, 
increase the DECIMAL FRACTION DEVIATION. 
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If you get too many matches, decrease the 
DECIMAL FRACTION DEVIATION. The output 
information includes the reduced unknown cell, 
the reduced Crystal Data Cell, the chemical 
name and the literature reference.

8.29 Peaks > Refl. Array > Save • 
Save the reflection array in a .p4p file

Menu Command: Peaks > Refl. Array > Save

Accelerator: None

User Level: 1

SLAM Syntax: REFL_ARRAY  /SAVE

Save the current reflection array and other rele-
vant information in a P4P file for use by other 
programs such as SHELXTL. While Least-
Squares will automatically create a P4P file, 
after manual editing of the reflection list, you 
may wish to update the P4P file.

The file name is taken from the current data set 
name. As the command executes you will see 
the messages:

OK to create: XXXX.P4P? Yes No

Overwrite XXXX.P4P? Yes No

Created: | Updated: XXX.P4P.

8.29.1 Arguments

None. Command executes after confirmation.
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9.  Special Routines

9.1 Special > PDF2 > View • 
View PDF2 card on screen

Menu Command: Special > PDF2 > View

Accelerator: None

User Level: 1

SLAM Syntax: PDF2 /VIEW $1 /NBS*AIDS 
/TYPE=<n>

The PDF2 /VIEW command can scroll through 
selected PDF patterns in either “pretty” format 
or in the native NBS*AIDS format.

9.1.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(PDF Number)     [33-1161]

The PDF number is defined by a set number 
and a pattern number. These numbers can 

be separated by a space, a comma, or a 
dash. (i.e., “33 1161”, “33,1161”, or “33-
1161” are all valid PDF numbers.

/NBS*AIDS ........... (Format)     [No]

Information about each diffraction pattern is 
stored in NBS*AIDS format on the CD-ROM 
(see the ICDD-JCPDS NBS*AIDS83 man-
ual for more details). Users can choose to 
view the complete NBS*AIDS image format 
or view the “pretty” format which is much 
easier to read. The output is in 80 columns.

/TYPE=<n>........... (Data Type)     [3]

The D/I table can be outputted as either:

0 = author's reported method (original data 
as reported in literature)

1 = theta values in degrees

2 = 2-theta values in degrees
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3 = d-spacings in Angstroms

4 = sin(theta) 2

5 = Q values

9.2 Special > PDF2 > Print • 
Print PDF2 card to printer or file

Menu Command: Special > PDF2 > Print

Accelerator: None

User Level: 1

SLAM Syntax: PDF2 /PRINT $1 $2 /NBS*AIDS 
/TYPE=<n> /CARD

PDF2 /PRINT command can print any selected 
PDF patterns in either “pretty” format, the native 
NBS*AIDS format, or the standard JCPDS card 
image in 128 column format.

9.2.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (PDF Number)     [33-1161]

The PDF number is defined by a set number 
and a pattern number. These numbers can 
be separated by a space, a comma, or a 
dash. (i.e., “33 1161”, “33,1161”, or “33-
1161” are all valid PDF numbers.

$2 ......................... (Print Device)     
[SAXI$PRINTER]

Enter either the filename or device which is 
to receive the printout. The default device is 
SAXI$PRINTER, which you can define as a 
logical name to point to a file or device if 
desired. For example, the DOS command 
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SET SAXI$PRINTER=PRN would direct 
output to a parallel printer. Alternatively, you 
can just enter the output name directly in the 
input panel, for example, PRN. If you specify 
a filename, the system “prints to disk” creat-
ing a file with that filename on the system 
hard disk which may later be output directly 
to a printer without having to run GADDS. 
Under DOS, a command like COPY /B <file-
name> PRN would copy your output file to a 
parallel LaserJet printer.

/NBS*AIDS............(Format)     [No]

Information about each diffraction pattern is 
stored in NBS*AIDS format on the CD-ROM 
(see the ICDD-JCPDS NBS*AIDS83 man-
ual for more details). Users can choose to 
view the complete NBS*AIDS image format 
or view the “pretty” format which is much 
easier to read. The output is in 80 columns.

/TYPE=<n> ...........(Data type)     [3]

The D/I table can be outputted as either:

0 = author's reported method (original data 
as reported in literature)

1 = theta values in degrees

2 = 2-theta values in degrees

3 = d-spacings in Angstroms

4 = sin(theta) 2

5 = Q values

/CARD .................. (Card format ?)     [No]

An alternative format is the standard JCPDS 
card image format, where the output is simi-
lar to the “pretty” format but the d-spacing 
table is positioned to the right of the name, 
cell, and comments boxes. This output is in 
128 column format. If selected /CARD will 
override the /NBS*AIDS switch.



Special Routines GADDS Software Reference Manual

9 - 4 M86-E01008

9.3 Special > PDF2 > Display • 
Graph PDF2 card above frame image 
as Debye-Scherrer rings

Menu Command: Special > PDF2 > Display

Accelerator: None

User Level: 1

SLAM Syntax: PDF2 /DISPLAY $1 /DASHED

PDF2 /DISPLAY will draw the PDF pattern's d-
lines on top of any displayed frame image for 
quick pattern matching or verification.

9.3.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ..........................(PDF Number)     [33-1161]

The PDF number is defined by a set number 
and a pattern number. These numbers can 
be separated by a space, a comma, or a 
dash. (i.e., “33 1161”, “33,1161”, or “33-
1161” are all valid PDF numbers.

/DASHED ..............(Dashed lines?)     [No]

Defines whether the PDF pattern lines are 
drawn using a solid or dashed conic lines on 
top of the frame image.
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9.4 Special > PDF2 > Search • 
Search PDF2 by mineral, inorganic, 
or organic name

Menu Command: Special > PDF2 > Search

Accelerator: None

User Level: 1

SLAM Syntax: PDF2 /SEARCH $1 /MINERAL 
/INORGANIC /ORGANIC

Perform an ASCII search on various indexes on 
the PDF2 CDROM. The search is case-insensi-
tive. Wildcard characters are not permitted. The 
inputted search text must match the first letters 
of the index keys to be considered a hit. Thus, 
“Quartz” will match all keys starting with 
“Quartz.”

05-0490 D QUARTZ

33-1161   QUARTZ

** end ** Return to main menu

You can display any hit by selecting that line and 
[OK]. To exit select the last line “** end ** Return 
to main menu” and [OK].

9.4.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Search string)     [Quartz]

Enter search string (up to 40 characters); 
may truncate.

/MINERAL ............ (Mineral index)     [Yes]

“Y” to search mineral name index file: 
PDF2$KEY:pdf2.s04.

/INORGANIC........ (Inorganic index)     [No]

“Y” to search inorganic name index file: 
PDF2$KEY:pdf2.s03.

/ORGANIC ........... (Organic index)     [No]

“Y” to search organic name index file: 
PDF2$KEY:pdf2.s09.
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9.5 Special > PDF2 > Clear • 
Clear PDF2 overlay graph

Menu Command: Special > PDF2 > Clear

Accelerator: None

User Level: 1

SLAM Syntax: PDF2  /CLEAR

PDF2 /CLEAR command will clear the graphics 
overlay plane while preserving the displayed 
frame image. Thus, any pattern displayed with 
PDF2 /DISPLAY command can be quickly 
cleared.

9.5.1 Arguments

None. Command executes immediately.
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9.6 Special > Commandmode • 
Switch between command line and 
menu mode

Menu Command: Special > Commandmode

Accelerator: Ctrl+K

User Level: 1

SLAM Syntax: MENUMODE

The MENUMODE command requires no argu-
ments. It toggles back and forth between menu 
mode and command line / command file mode.

When operating the system in menu mode, the 
software is programmed to automatically prompt 
you for input of options and arguments via dia-
log boxes when a menu item is selected. This is 
particularly useful when first learning the sys-
tem, or when you do not wish to either memo-
rize the parameters for all commands or 
continually refer to this manual. On the other 
hand, the command mode allows you to execute 
command scripts, which can be used, for exam-
ple, to automate repetitive tasks.

Special > Command Line makes both these 
operating modes available. To go from menu 
mode to command line mode, click the Special > 
Command Line menu item. To return to menu 
mode from command line mode, enter the fol-
lowing command at the prompt:

GADDS> MENUMODE

If you start GADDS with the /LOCK qualifier, all 
commands in the Level menu are disabled 
(grayed) including Special > Command Line. 
However, SLAM command scripts can still be 
executed from the User menu.

For more information on command line and 
command file (scripts) see the GADDS User’s 
Manual: Scripts section.

9.6.1 Arguments

None. Command executes immediately.
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9.7 Special > System • Suspend 
program and invoke the Command 
Prompt processor

Menu Command: Special > System

Accelerator: None

User Level: 1

SLAM Syntax: SYSTEM  $1

Use the SYSTEM command to spawn either a 
single command or a session. Spawning a sin-
gle command permits the execution of external 
programs, such as a temperature controller soft-
ware, without leaving the GADDS environment. 
If the spawn command is non-interactive, it may 
even be used within a script file.

Spawning a session allows the execution of one 
or numerous programs in the native operating 
system command interpreter (e.g., CMD.EXE) 
by temporarily returning you to that environ-
ment. The GADDS software is kept resident in 
the operating system, and when you are fin-
ished with the system level program(s) you can 
quickly return to the configuration existing when 
you selected SYSTEM without having to save or 
reload the configuration file, display or other 
parameters.

Under NT, use the syntax “CMD /K <com-
mand>” to execute the <command> in a Com-
mand Prompt window (DOS emulator), “CMD” 
or “CMD /K” to execute a session, or “<pro-
gram>” to execute a specific program. (To return 

to GADDS type “exit” at the prompt.) GADDS 
will confirm your request with the message:

Suspend GADDS while spawning another task?

Continue and GADDS closes the logfile and 
autoscript file, then minimizes the GADDS win-
dow while the spawn tasks runs. When the 
spawned task finishes and exits, the GADDS 
window is restored, and the logfile and auto-
script file(s) are restored/reactivated.

9.7.1 Arguments

Each argument is listed below by its SLAM com-
mand line name, followed by its dialog box 
prompt in parentheses:

$1 ......................... (Command)     []

“<program>” to spawn a single program, 
“CMD /K <command>” to spawn a single 
command (for example dir), or “CMD /K:” to 
spawn a command prompt session.
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9.8 Special > Spawn PROFILEplus • 
Spawn PROFILEplus (or TOPAS P) 
with current spectra

Menu Command: Special > Spawn PROFILE-
plus

Accelerator: None

User Level: 1

SLAM Syntax: SPAWN

Use this command to spawn (start as separate 
task) the profile fitting package with the current 
integrated spectra. Either TOPAS2, TOPAS P or 

PROFILEplus can be spawned. By default the 
program is found in either:

• GADDS$SYSTEM: directory

• PROF$SYSTEM: directory

• <Drive>\Topas2P directory

• <Drive>\TopasP directory

• <Drive>\Profile directory

• <Drive>\DiffPlus directory

So if the program cannot file the executable, 
define the environment variable PROF$SYS-
TEM: to point to the directory specification.

9.8.1 Arguments

None. Command executes immediately.

9.9 Special > Redraw • Redraw 
current screen (e.g., if corrupted by 
window manager)

Menu Command: Special > Redraw

Accelerator: None

User Level: 1

SLAM Syntax: REDRAW

Use this command to force GADDS to redraw 
the screen. Useful whenever the screen 
becomes corrupted. Only the current frame 
image, display header, and goniometer status 
windows are redrawn when you choose this 
command. Any information displayed in the pre-
vious quadrants and the statistics window are 
lost, as is any overlay graphics.

9.9.1 Arguments

None. Command executes immediately.
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9.10 Special > Level 1, Special > 
Level 2, and Special > Level 3 • 
Switch to simple, advanced or admin-
istrator menu interface

Menu Command: Special > Level 1, Level 2 or 
Level 3

Accelerator: None

User Level: 1

SLAM Syntax: LEVEL1     LEVEL2     LEVEL3

GADDS's menu bar can be switched between 
an abbreviated form (which contains only those 
commands needed for routine diffraction prob-
lems) and those needed for expert diffraction-
ists. Additionally, the detector administrator 
account will see a third level for the full set of 
commands needed for calibration and manage-
ment of the system in addition to data collection. 
The abbreviated form is the “Special > Level 1” 
menu bar, the full form is the “Special > Level 2” 
menu bar, and the administration form is the 
“Special > Level3” menu bar. You can use these 
commands to switch between the two (or three) 
menu bars. You can also use the startup qualifi-
ers /LEVEL2, /LEVEL3, and /LOCK to start 
GADDS at a specific user level, and/or disable 
the Level menu commands, locking GADDS at 
the startup user level. See Startup Qualifiers, 
Section 1.3 for more information.

9.10.1 Arguments

None. Command executes immediately.
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10.  User Task Routines

10.1 User > * • Execute user task

Menu Command: User > * (user defined)

Accelerator: Ctrl+F1 through Ctrl+F12

User Level: 1

SLAM Syntax: None

Up to sixteen user-defined commands, called 
User Tasks, may be added to the User menu on 
the menu bar by modifying GADDS$SYS-
DATA:usertask.ini. When GADDS is started, it 
reads this file to modify the menu bar to add all 
the defined user tasks. When a user task is 
selected, GADDS reads this file again to retrieve 
the parameter prompts, parameter help line, and 
the script filename. The script associated with 
the selected task is then executed. Up to 10 
parameters may be added to any user task, and 
they are treated as replaceable parameters 

within the script file. If no parameters are associ-
ated with the user task, then the task begins 
executing immediately.

Instructions on modifying usertask.ini file are 
found in the header of that file. The following 
example (corresponding to one section of the 
GADDS$SYSDATA:usertask.ini file) defines 
user task number 12 to execute the SLAM com-
mand script d:\frames\scripts\process.slm:

[12]

menu=”My Collect”

help=”My favorite data collection process”

slam=”D:\frames\scripts\process”

prompt=”Filename”,”Enter filename specifi-
cation”

prompt=”Title”,”Enter title string”
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11.  Help Routines

11.1 Help > Software Reference • 
Display Software Reference online 
documentation

Menu Command: Help > Software Reference

Accelerator: None

User Level: Ctrl+H

SLAM Syntax: HELP /REFERENCE     or     
HELP

Spawns or displays the GADDS Software Refer-
ence Manual. This is either a PDF document, a 
windows help file, or ASCII *._TP files located in 
the GADDS$SYSTEM: directory. The Acrobat 
reader must be installed to display PDF files.

11.1.1 Arguments

None. Command executes immediately.
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11.2 Help > User’s guide • Display 
User’s Manual online documentation

Menu Command: Help > User’s Guide

Accelerator: None

User Level: Ctrl+M

SLAM Syntax: HELP /USERGUIDE

Spawns or displays the GADDS User’s Manual. 
This is either a PDF document, a windows help 
file, or ASCII *._TP files located in the 
GADDS$SYSTEM: directory. The Acrobat 
reader must be installed to display PDF files.

11.2.1 Arguments

None. Command executes immediately.

11.3 Help > Mapping • Display online 
documentation for GADDSmap

Menu Command: Help > Mapping program

Accelerator: None

User Level: None

SLAM Syntax: HELP /MAP

Spawns or displays the GADDSmap online doc-
umentation. This is either a PDF document or a 
windows help file. The Acrobat reader must be 
installed to display PDF files.

11.3.1 Arguments

None. Command executes immediately.
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11.4 Help > About • Display program, 
trademark, copyright, and license 
information

Menu Command: Help > About

Accelerator: None

User Level: 1

SLAM Syntax: ABOUT

Displays the program’s version number, copy-
right notice, trademarks, license information, 
and developer names.

For information about the goniometer, see 
Edit > Configure > ShowModel, Section 4.5.

11.4.1 Arguments

None. Command executes immediately.

11.5 Help > Errata • Display changes 
to printed documentation

Menu Command: Help > Errata

Accelerator: None

User Level: 1

SLAM Syntax: HELP /ERRATA

Displays the online errata for the printed 
GADDS manuals

11.5.1 Arguments

None. Command executes immediately.
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11.6 Help > Releases notes • Display 
release notes

Menu Command: Help > Release notes

Accelerator: None

User Level: 1

SLAM Syntax: HELP / RELNOTES

Displays the program’s online release notes.

11.6.1 Arguments

None. Command executes immediately.
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12.  SLAM Routines

Most SLAM commands have been discussed in 
earlier sections with headings corresponding to 
the menu bar (where menu commands equiva-
lent to the SLAM commands can be found). 
Some SLAM commands are unique to com-
mand mode and are fully discussed in this sec-
tion. All SLAM commands are listed in Appendix 
G for reference.

12.1 Echo

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: ECHO /OUT=<s> /APPEND 
/WAIT=<n> $1 $2 $3 .... $8 $9 $0

ECHO is available only on the SLAM command 
line (that is, at the GADDS> prompt) and is used 
for writing command scripts. For example, it can 
be used to write a specific set of PLOTSO direc-

tives into a file for subsequent screen display 
with the GRAPH /FILE command, all from within 
the SLAM command script.

Each argument is listed below by its command 
line name.

$1, $2 ... $9, $0 

Enter the text strings to be written to the out-
put file. If your text contains slashes or more 
than ten separate blank-delimited words, 
enclose the text in double quotes.

/OUT=<s>

Enter the name of the output file to receive 
the text.

/APPEND

If this qualifier is given, the text gets 
appended to the output file if the file already 
exists, otherwise a new output file is created 
to receive the text. If this qualifier is omitted, 
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the output file is overwritten if it already 
exists.

/WAIT=<n>

Enter a value to represent the number of 
seconds to wait after text is displayed. The 
script will continue after this number of sec-
onds or when you press a key, whichever 
occurs first. The valid value range is -1 to 

1.0x1010 seconds. A value of -1 will wait 
indefinitely until you press a key.

Example:

The following commands direct GADDS to dis-
play double-height text in its image area, then to 
wait for 16 seconds (or a keyboard key) before 
continuing:

echo /out=wrtext.tmp “!@!C1,2”

echo /app /out=wrtext.tmp “!@!A .1 .75” “In 
this example, we determine”

echo /app /out=wrtext.tmp “!@!A .1 .70” “the 
structure of a small compound,”

echo /app /out=wrtext.tmp “!@!A .1 .65” “the 
YLID (C[11] H[10] N[2] S).”

graph /file /quad=0 wrtext.tmp

wait 16.
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12.2 Menumode

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: MENUMODE

MENUMODE is available in command line 
mode at the GADDS> prompt. Use this com-
mand to exit command mode and to return to 
menu mode. MENUMODE takes no arguments.

12.3 Quit

Menu Command: App menu Close, Close box

Accelerator: Alt+F4 (NT only)

User Level: Command, All

SLAM Syntax: QUIT

QUIT is available in command line mode at the 
GADDS> prompt, or from the application menu 
or close box on the title bar. Whereas File > Exit 
GADDS updates the configuration file before 
returning to the operating system, QUIT does 
not save the configuration, but instead throws 
away any changes you've made since starting 
the program. QUIT takes no arguments.
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12.4  Peaks

While the TOPAS software package sports 
superior profile fitting algorithms, GADDS still 
has some primitive profile fitting features. If your 
profile fitting needs are minimal, the GADDS 
PEAKS command may be sufficient for your 
needs. 

To access PEAKS:

1. Go to Special > Command Mode.

2. Select Peaks. A pop-up menu of all the 
PEAKS commands will appear.

3. Type MENUMODE (or MENU) to exit com-
mand mode and return to menubar control.

If you constantly use these old PEAKS com-
mands, add them to your “usertasks.” The pro-
vided file “usertask.pks” is a good start. Replace 
your “usertask.ini” with this file (rename to user-
task.ini). Then you will see these old Peaks 
commands under the “User” heading.

NOTE: If you cancel or get an error message, 
the message is displayed below and the pro-
gram stays in command mode (you must type 
“menu”). While it is possible to write script files 
with error handling so “MENUMODE” is always 
executed, then you don’t see an error message.

PEAKS has twelve subcommands:

EXIT Close the PEAKS submenu and return to the 
GADDS menu

AUTO Automatically locate and refine peaks

CLEAR Clear pattern/graphs in selected quadrant(s)

LOAD Load *.PKS file

MANUAL Manually select peak positions and parameters

POSTER Annotate screen before printing

PROFILE Define peak profile shapes

REFINE Refine peak parameters after manual editing

SAVE Save peak table to disk file

SIMULATE Simulate peak profile shapes

VIEW View the current peak parameter table

ZOOM Select new plotting limits
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When you start PEAKS from the command line, 
you need to specify one of these subcommands 
as a qualifier (if not, the submenu appears and 
GADDS waits until you have made a selection). 
To select one of these options, highlight it with 
the arrows or mouse. A help message appears 
on the bottom status line describing the action 
taken by the selected item. To start the selected 
option, press ENTER. To exit and return to the 
menu bar, select EXIT or press ESC.

PEAKS uses profile analysis to produce very 
accurate peak positional, intensity, and FWHM 
data. Also, standard deviations of peak parame-
ters can be obtained. At least once after installa-
tion and prior to executing either PEAKS/AUTO 
or PEAKS/REFINE, you must generate the 
required peak profile(s) by running PEAKS/
PROFILE. These profile lineshapes are used in 
the least squares refinement of all peak parame-
ters. During the least squares refinement, any 
peak parameter may be fixed or variable 
(refined).

Representative profile lineshapes can be either 
collected data or simulated data using mathe-
matical functions. PEAKS/SIMULATE allows 
you to use a Cauchy (Lorentian), Gaussian, 
modified Cauchy, asymmetrical Cauchy, 
Pseudo-Voigt, Pearson VII, or split Pearson VII 
function to model the profile shape.

PEAKS/PROFILE creates the profile lineshape 
file by allowing you to select one or more repre-
sentative lineshapes at various 2θ positions. 

Each lineshape should be an isolated peak and 
the profile fitting algorithm works best with line-
shapes taken at low, medium and high 2θ 
angles. The α2 contribution must be either con-
sistently present or consistently absent from all 
peak profiles. All profiles are stored in a special 
format of DIFFRAC-AT raw data structure and 
the individual profile shapes can be displayed 
with PEAKS/LOAD.

PEAKS/AUTO analyzes a diffraction pattern by 
searching for peaks, resolving overlapping 
peaks, and refining the position, intensity and 
FWHM of all peaks. If the selected profile line-
shapes have α2 removed, AUTO can refine both 
the α1 and α2 lines simultaneously, providing the 
resolution of the overlapped α2 line with an 
unrelated α1 line, as in the “five fingers of 
quartz” region. AUTO first dissects the scan 
range into multiple regions which include data 
points of at least BKGDSIG standard deviations 
above background. Each region must start in 
background and end in background or the 
peak(s) are not found (in this case, you must 
use PEAKS/MANUAL to locate peaks). Each 
region has a maximum number of steps (cur-
rently 1024) and a maximum number of allowed 
peaks (15). You may have to manually manipu-
late regions with numerous overlapping peaks.

For each region, the background is assumed to 
be a linear function in 2θ. Least squares esti-
mates of the left and right backgrounds are per-
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formed. With the removal of background, the 
largest remaining sample point is compared to 
PEAKSIG times the standard deviation of that 
point. Values greater than this quantity result in 
a peak being added. Least squares estimates 
are performed on peak position, FWHM and 
intensity, as well as the backgrounds. GADDS 
then reiterates, identifying and removing the 
largest peak from the remaining data until either 
15 peaks are found or the largest residual inten-
sity is below PEAKSIG times standard deviation. 
The standard deviations generated by AUTO are 
measures of the precision of the refined param-
eters. Systematic errors such as 2θ zero error, 
sample positional error, and absorption must be 
taken into account.

PEAKS/MANUAL is used to interactively choose 
peaks and their parameters. The most frequent 
use of MANUAL is to correct any shortcomings 
of PEAKS/AUTO, which is known to have diffi-
culties whenever the scan range begins or ends 
within a peak and with extremely complicated 
patterns with more than 15 overlapping peaks. 
MANUAL lets you enter all peak and back-
ground data, as well as variables you want to 
refine. After entering or modifying peaks param-
eters with MANUAL, PEAKS/REFINE performs 
a least squares fit of all variable parameters. 
Very accurate results can be obtained from 
user-specified peaks.

The final peak parameter table can be saved to 
an ASCII file with PEAKS/SAVE. Also, PEAKS/
VIEW re-lists the current peak parameter table 

on the screen. The ASCII peak parameter files 
consist of three sections:

• General header with file, date, title, wave-
lengths, and range.

• Peak data table with ds, 2Ts, Is, Irel, and 
FWHMs.

• Background data table with 2T start and end 
of each region and backgrounds.

Full visual screen control is accomplished with 
PEAKS/CLEAR. Screen text windows can be 
cleared; or the raw data trace, peak profiles, or 
both can be cleared from any quadrant. Addi-
tional options permit the destruction of the raw 
or peak data from internal memory.



GADDS Software Reference Manual SLAM Routines

M86-E01008 12 - 7

12.4.1 PEAKS/AUTO

AUTO analyzes a diffraction pattern, searching 
for peaks, resolving overlapping peaks, and 
refining the position, intensity and FWHM of all 
peaks. If the selected profile lineshapes have α2 
removed, AUTO can refine both the α1 and α2 
lines simultaneously, providing resolution of the 
overlapped α2 line with an unrelated α1 line as 
in the “five fingers of quartz” region. AUTO first 
dissects the scan range into multiple regions 
which include data points of at least BKGDSIG 
standard deviations above background. Each 
region must start in background and end in 
background or the peak(s) are not found (in this 
case, you must use PEAKS/MANUAL to locate 
peaks). Each region has a maximum number of 
steps (currently 1024) and a maximum number 
of allowed peaks (15). You may have to manu-
ally manipulate regions with numerous overlap-
ping peaks.

For each region, the background is assumed to 
be a linear function in 2θ. Least squares esti-
mates of the left and right backgrounds are per-
formed. With the removal of background, the 
largest remaining sample point is compared to 
PEAKSIG, multiplied by the standard deviation 
of that point. Values greater than this quantity 
result in a peak being added. Least squares 
estimates are performed on peak position, 
FWHM and intensity, as well as the back-
grounds. GADDS then reiterates, identifying and 
removing the largest peak from the remaining 

data until either 15 peaks are found or the larg-
est residual intensity is below PEAKSIG times 
standard deviation.

The standard deviations generated by AUTO are 
measures of the precision of the refined param-
eters. Systematic errors such as 2θ zero error, 
sample positional error, and absorption must be 
taken into account. During the least squares, the 
refined parameters are background, peak 2θ, 
peak-intensities, and the FWHM. The FWHM 
are grouped (variable, but all peaks within a 
region possess the same FWHM); however, dur-
ing the final refinement, the FWHM are set to 
variable. If the least squares fails to converge, 
the FWHM are fixed and a final refinement is 
performed.

PEAKS/MANUAL is used to interactively choose 
peaks and their parameters. The most frequent 
use of PEAKS/MANUAL is to correct any short-
comings of PEAKS/AUTO, which is known to 
have difficulties whenever the scan range 
begins or ends within a peak and with extremely 
complicated patterns with more than 15 overlap-
ping peaks. PEAKS/MANUAL lets you enter all 
peak and background data, as well as variables 
which you wish to refine. See Applied Crystal-
lography by J. Taupin (1973) volume 6, page 
266.
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When started from the command line, PEAKS/
AUTO takes the following arguments:

PEAKS /AUTO $1 /FWHM=[n] /PEAKSIG=[n] /

BKGDSIG=[n] /VERBOSE /GRAPH /SPLIT=[n] 

&

/FLAG=[n] /RATIO=[n] $2 $3

where the arguments are:

$1 (CALIBRATION FILE) Calibration file containing representative profile lineshapes.

BKGDSIG=[n] (BKGD) Background significance used to determine regions containing peaks.

PEAKSIG=[n] (PEAK SIGNIFICANCE) Peak significance to adding new peaks.

FWHM=[n] (INITIAL FWHM) Initial FWHM is used to:

•    Determine minimum size of region (removes spurious background points).

•    Capture tails of peaks by extending regions twice the FWHM.

•    Attempt to resolve peaks with a FWHM 1.75*input as two overlapping peaks.

•    Set initial FWHM of new peaks before refinement.

VERBOSE (VERBOSE OUTPUT Y/N) Non-verbose output lists only the resulting peak parame-
ters. Verbose output lists regions, refinements with standard deviations, and the final 
peak parameter table.

GRAPH (GRAPH PEAKS Y/N) Check the box to draw the resulting fitted peak profiles.

FLAG=[n] (NUMBER OF WAVELENGTHS) [Default: 1] Flag = 1 or 2. Determines the number 
of wavelengths present.

NOTE: If the profile shapes contain a1 and a2 lines, FLAG must be set to “1”.

SPLIT=[n] (ALPHA-1/ALPHA-2 SPLIT) [Default: 0.0] Alpha-1 to alpha-2 split at true zero. May 
be non-zero for incident beam monochromator systems.

RATIO=[n] (ALPHA-1/ALPHA-2 RATIO) [Default: 0.5] Alpha-1/alpha-2 intensity ratio.

$2 (2THETA BEGIN) Starting 2θ for peak fitting.

$3 (2THETA END) Ending 2θ for peak fitting.
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12.4.2 PEAKS/CLEAR

Full visual screen control is accomplished with 
CLEAR. Screen text windows can be cleared. 
Also, the raw data trace, the peak profiles, or 
both, can be cleared from any quadrant. Addi-
tional options let you destroy raw or peak data 
from internal memory.

When started from the command line, PEAKS/
CLEAR takes the following arguments:

PEAKS /CLEAR $1 /DATA_SAVE /TRACE_SAVE 

/PEAKS_SAVE /FIT_SAVE /SCREEN_SAVE

where the arguments are:

$1 (SCREEN QUADRANT) Quadrant to clear:

1 = none

0 = full

1-4 = respective quadrants

5-6 = top or bottom half of screen

DATA_SAVE (PRESERVE RAW DATA Y/N) Check the box to preserve raw data in internal memory.

TRACE_SAVE (PRESERVE RAW TRACE Y/N) Check the box to preserve graphic raw data trace.

PEAKS_SAVE (PRESERVE PEAK DATA Y/N) Check the box to preserve peak parameters in internal memory.

FIT_SAVE (PRESERVE PROFILES Y/N) Check the box to preserve graphic peak profiles.

SCREEN_SAVE (PRESERVE TEXT SCREENS Y/N) Check the box to preserve text screens.
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12.4.3 PEAKS/LOAD

Raw data traces must be displayed with INTE-
GRATE or PEAKS/LOAD, which can read either 
a DIFFRAC-AT v1 or v2 file, DIFFRAC-5000 file, 
or a PLOTSO file, regardless of which computer 
platform is being operated. GADDS can directly 
read DIFFRAC-5000 files, on which only ranges 
in the first series are accessible.

When started from the command line, PEAKS/
LOAD takes the following arguments:

PEAKS /LOAD $1 /RANGE=[n] /QUADRANT=[n]

where the arguments are:

$1 (INPUT FILENAME) DIFFRAC-AT v1/v2, DIFFRAC-5000 or PLOTSO file containing raw data. The 
file format does not need to be specified, PEAKS/LOAD automatically determines which file format 
is being read.

RANGE=[n] (INPUT RANGE) Scan range to read. On DIFFRAC-5000 files, only ranges in the first series can 
be accessed.

QUADRANT=[n] (DISPLAY QUADRANT) Specifies the quadrant to display the raw data trace:

0 = full screen

1-4 = respective quadrants

5-6 = top or bottom half of screen
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12.4.4 PEAKS/MANUAL

MANUAL is used to interactively choose peaks 
and their parameters. The most frequent use of 
MANUAL is to correct any shortcomings of 
PEAKS/AUTO, which is known to have difficul-
ties whenever the scan range begins or ends 
within a peak, and with extremely complicated 
patterns with more than 15 overlapping peaks. 
MANUAL lets you enter all peak and back-
ground data, as well as variables which you 
wish to refine. At least once after installation and 
before executing MANUAL, you must run 
PEAKS/PROFILE to generate the required peak 
profile(s) file. These profile lineshapes are used 
to overlay the manually inserted peaks overtop 
the displayed raw data pattern. After entering or 
modifying peaks parameters with MANUAL, 
PEAKS/REFINE performs a least squares fit of 

all variable parameters. Very accurate results 
can be obtained from user-specified peaks.

MANUAL can be used in interactive mode only. 
When you choose PEAKS/MANUAL from the 
menu bar, a vertical cursor appears. Within the 
statistics window is the wavelength, 2θ, d-spac-
ing, and intensity for the current cursor position. 
If the cursor resides within a peak region, the 
region start/end and backgrounds area also dis-
plays in the statistics window. The peak parame-
ters (2T, d, I, FWHM) of the nearest peak within 
the peak region are also displayed.

MANUAL has four options. Press ENTER or the 
left mouse button to display the submenu, or  
press the first letter of the subcommand to 
directly enter that option. Choices are:

ADD Add a new peak. All peak parameters are defaulted using values obtained 
at the current cursor position and a pop-up entry menu appears. Upon 
exiting, the peak is saved and a peak profile is drawn.

DELETE Delete the peak nearest the current cursor position. No further arguments 
are required. The peak profile is also deleted.

MODIFY Modify a peak’s current parameters. A menu appears with the current 
peak parameters. Upon exiting, the peak profile is erased and redrawn 
with the new parameters.

REGION Add or modify a region’s current parameters. A menu appears with the 
current (or defaulted) region parameters. Upon exiting, all peaks within the 
region are erased and redrawn with the new region parameters.
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If you try to add a peak before you specify a 
peak region, both REGION and ADD are exe-
cuted.

When started from the command line, PEAKS/
MANUAL takes no arguments and can only be 
run in interactive mode. Command line syntax 
is:

PEAKS /MANUAL

12.4.5 PEAKS/POSTER

With this command, you can interactively anno-
tate plots or frame images. PEAKS/POSTER 
has seven subcommands:

When you choose PEAKS/POSTER from the 
menu bar, GADDS displays a pop-up submenu 
containing these subcommands. When you start 
PEAKS/POSTER from the command line, no 
qualifiers are allowed. The submenu appears 
and GADDS waits until you have made a selec-
tion. PEAKS/POSTER runs in interactive mode 
only. To select one of the options, highlight it 
with the arrows or mouse. A help message 

appears on the bottom status line describing the 
action taken by the selected item. Press ENTER 
to run the selected item. To exit or return to the 
menu bar, select EXIT or press ESC.

EXIT Close the POSTER submenu and return to GADDS 
menu

DRAW Draw various objects on screen

EDIT Edit current annotations

CLEAR Clear annotations within rectangular region

LABEL Label spots/peaks using d, I, HKL, TH, 2T, etc.

SAVE Save annotations to PLOTSO file

TEXT Position text on screen
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PEAKS/POSTER/DRAW

When you choose PEAKS/POSTER/DRAW 
from the menu bar, GADDS displays a pop-up 
submenu containing these subcommands:

PEAKS/POSTER/DRAW/ARROW

PEAKS/POSTER/DRAW/ARROW is used to 
draw an arrow. When selected, a crosshair is 
visible. To draw an arrow:

1. Use the mouse to position the crosshairs at 
the point of the arrow to be drawn and press 
ENTER. The crosshairs are replaced with 
an arrow that has the point anchored at the 
selected position and the tail at the cursor 
position.

2. Position the tail of the arrow and press 
ENTER. The arrow is drawn and a 
crosshairs cursor appears to position the 
next arrow.

3. When you are finished, press ESC to return 
to the DRAW menu.

PEAKS/POSTER/DRAW/BOX

PEAKS/POSTER/DRAW/BOX is used to draw a 
rectangular box. When selected, a crosshair 
cursor is visible. To draw a box:

1. Use the mouse to position the crosshairs at 
a corner of the box to be drawn.

2. Press ENTER to anchor the corner. The 
crosshairs are replaced with a rectangular 
box with one corner at the anchored point 
just selected and the other corner at the cur-
rent cursor position.

3. Position the second box corner and press 
ENTER. The box is drawn and a crosshairs 
cursor appears to position the next box.

4. When you are finished, press ESC to return 
to the Poster menu.

EXIT Close the DRAW submenu and return to the POSTER menu

ARROW Draw an arrow pointer

BOX Draw a rectangular box

CIRCLE Draw an ellipse

DOT Draw a single dot

LINE Draw a straight line

STYLE Switch between solid and dashed line styles
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PEAKS/POSTER/DRAW/CIRCLE

PEAKS/POSTER/DRAW/CIRCLE is used to 
draw an ellipse. When selected, a crosshair cur-
sor appears. To draw a circle:

1. Use the mouse to position the crosshairs at 
the center of the ellipse and press ENTER 
to anchor this spot. The crosshairs are 
replaced with an ellipse drawn with the cen-
ter anchored and the width and height 
selected from the cursor.

2. Move the mouse until the width and height 
are correct and press ENTER. The ellipse is 
drawn, and a crosshairs cursor appears to 
position the ellipse center.

3. When you are finished, press ESC to return 
to the POSTER menu.

PEAKS/POSTER/DRAW/DOT

PEAKS/POSTER/DRAW/DOT is used to draw a 
single dot. When selected, a crosshair cursor 
appears. To draw a dot:

1. Use the mouse to position the crosshairs at 
the point you want to draw the dot and press 
ENTER. A dot is drawn and the crosshairs 
remain to position the next dot.

2. When you are finished, press ESC to return 
to the POSTER menu.

PEAKS/POSTER/DRAW/LINE

PEAKS/POSTER/DRAW/LINE is used to draw a 
line segment between two points. When 
selected, a crosshairs cursor is visible. To draw 
a line segment:

1. Position the crosshairs at the start of the line 
segment to anchor the segment and press 
ENTER. The crosshairs are replaced with a 
line segment between the anchored point 
and the current cursor position.

2. Position the line segment end point and 
press ENTER. The line segment is drawn 
and a crosshairs cursor appears to position 
the next line.

3. When you are finished, press ESC to return 
to the POSTER menu.

PEAKS/POSTER/DRAW/STYLE

PEAKS/POSTER/DRAW/STYLE is used to tog-
gle between drawing objects with a solid line 
and drawing objects with a dashed line style. 
The current style is displayed in the submenu 
title bar.

PEAKS/POSTER/EDIT

All poster annotations are stored in a PLOTSO 
file format. These commands can be edited with 
a simple screen editor. After exiting EDIT, the 
graphics plane is erased and the poster annota-
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tions are redrawn. This erases all graphs dis-
played before starting PEAKS/POSTER.

PEAKS/POSTER/CLEAR

PEAKS/POSTER/CLEAR is used to clear a 
rectangular region. When selected, a crosshair 
cursor appears. To clear a region:

1. Position the crosshairs at a corner of the 
box to be erased.

2. Press ENTER to anchor the corner. The 
crosshairs are replaced with a rectangular 
box that has one corner anchored at the 
point just selected and the other corner at 
the current cursor position.

3. Position the second box corner and press 
ENTER. The box is erased and a crosshairs 
cursor appears to position the next box.

4. When you are finished, press ESC to return 
to the DRAW menu.

PEAKS/POSTER/SAVE

PEAKS/POSTER/SAVE saves all poster anno-
tations in a PLOTSO file on disk. It can later be 
retrieved with PEAKS/FILE. Enter the PLOTSO 
filename and choose whether to APPEND.

PEAKS/POSTER/TEXT

Text can be positioned and sized interactively 
with PEAKS/POSTER/TEXT. To use TEXT:

1. Select TEXT from the PEAKS/POSTER 
submenu and press ENTER. You are 
prompted to enter the text string to be dis-
played.

2. Enter the text string to be displayed and 
press ENTER. All trailing spaces are 
removed from the text string, but leading 
spaces are retained. A box cursor appears 
that reflects the size of the text string.

3. Press ESC to return to the DRAW menu.

4. Move the cursor left (or right) to increase (or 
decrease) the size of the text string in the “x” 
direction. Move the cursor up and down to 
change the height of the text.

5. Press ENTER to anchor the text size.

6. Use the mouse to position the box cursor 
and press ENTER. The box disappears and 
the text is drawn. You are then prompted to 
enter the next text string to draw.

PEAKS/POSTER/LABEL

Spots or peaks can be labeled interactively with 
PEAKS/POSTER/LABEL. To use LABEL:

1. Select LABEL from the PEAKS/POSTER 
submenu. A pop-up menu appears.



SLAM Routines GADDS Software Reference Manual

12 - 16 M86-E01008

2. Choose what type of data to retrieve (Data 
type): θs, 2θs, ds, Is, or HKLs.

3. Choose where to retrieve the data from 
(LABEL option): the frame, raw trace, or 
peaks table.

4. Choose what marker character to use to 
highlight the data. A crosshairs cursor 
appears and the selected label appears in 
the message window.

5. Press ENTER to draw the marker at the cur-
rent cursor position and automatically dis-
play the TEXT option; when you have 
finished, press ESC to return to the 
POSTER menu without drawing the label.

6. Edit, position and size the label to be drawn 
(see GRAPH/POSTER/TEXT).
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12.4.6 PEAKS/PROFILE

PEAKS/PROFILE has four subcommands:

When you choose PEAKS/PROFILE from the 
PEAKS menu, GADDS displays a pop-up sub-
menu containing these subcommands. When 
you start PEAKS/PROFILE from the command 
line, you need to specify one of these subcom-
mands as a qualifier (if not, the submenu 
appears and GADDS waits until you have made 
a selection). To select one of the options, high-
light it with the arrows or mouse to highlight the 
desired selection. A help message appears on 
the bottom status line describing the action 
taken by the selected item. To begin the high-
lighted action, press ENTER. When you are fin-
ished, select EXIT or press ESC to return to the 
menu bar.

Representative profile lineshapes can be either 
collected data, or simulated data using mathe-
matical functions. SIMULATE allows you to use 
a Cauchy (Lorentian), Gaussian, modified 
Cauchy, asymmetrical Cauchy, Pseudo-Voight, 
Pearson VII, or a split Pearson VII function to 
model the profile shape.

PROFILE creates the profile lineshape file by 
allowing you to select one or more representa-

tive lineshapes at various 2θ positions. Each 
lineshape should be an isolated peak and the 
profile fitting algorithm works best with line-
shapes taken at low, medium, and high 2θ 
angles. The α2 contribution must be either con-
sistently present or consistently absent from all 
peak profiles.

Profile lineshape is selected by specifying a 2θ 
background range on both sides of a peak. The 
average intensity within the low and high back-
ground regions is used to subtract a linear back-
ground from beneath the Bragg peak. The 
resulting peak function is rescaled and stored 
with the FWHM and 2T position in a profile 
parameter file, which is a special format of a  
DIFFRAC-AT v1 raw data file. Individual profile 
functions can be displayed with PEAKS/LOAD.

PEAKS/PROFILE/NEW

When started from the command line, PEAKS/
PROFILE/NEW takes the following arguments:

PEAKS /PROFILE /NEW $1 $2 $3 $4 $5

EXIT Close PROFILE submenu and return to PEAKS menu

NEW Create a new profile lineshape file

ADD Add a profile to existing lineshape file

DELETE Delete a profile from an existing lineshape file
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where the arguments are:

PEAKS/PROFILE/ADD

When started from the command line, PEAKS/
PROFILE/ADD takes the following arguments:

PEAKS /PROFILE /ADD $1 $2 $3 $4 $5

where the arguments are:

PEAKS/PROFILE/DELETE

When started from the command line, PEAKS/
PROFILE/DELETE takes the following argu-
ments:

PEAKS /PROFILE /DELETE $1 $2

where the arguments are:

$1 (CALIBRATON FILE) Filename for profile file (deletes existing file).

$2,$3 (START LOW BKGD) Low background start and end 2θ.

$4,$5 (START HIGH BKGD) High background start and end 2θ.

$1 (CALIBRATON FILE) Filename for profile file to append or insert new profile.

$2,$3 (START LOW BKGD) Low background start and end 2θ.

$4,$5 (START HIGH BKGD) High background start and end 2θ.

$1 Filename of profile file.

$2 Profile number to delete (profiles stored in ascending 2T order).
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12.4.7 PEAKS/REFINE

PEAKS/REFINE performs a least squares fit of 
all variable parameters. Very accurate results 
can be obtained from user-specified peaks.

When started from the command line, PEAKS/
REFINE takes the following arguments:

PEAKS /REFINE $1 /VERBOSE /GRAPH /

SPLIT=[n] /FLAG=[n] /RATIO=[n] $2 $3

where the arguments are:

$1 (CALIBRATION FILE) Calibration file containing representative profile lineshapes.

VERBOSE (VERBOSE OUTPUT Y/N) Non-verbose output lists the resulting peak parameters. Verbose output lists 
regions, refinements with standard deviations, as well as the final peak parameter table.

GRAPH (GRAPH PROFILE Y/N) Check the box to draw the resulting fitted peak profiles.

FLAG=[n] (NO. OF WAVELENGTHS) [Default: 1] Flag = 1 or 2. Determines the number of wavelengths present.

NOTE: If the profile shapes contain a1 and a2 lines, FLAG must be set to 1.

SPLIT=[n] (ALPHA1/ALPHA2 SPLIT)  [Default: 0.0] a1 to a2 split at true zero. May be non-zero for incident beam 
monochromator systems.

RATIO=[n] (ALPHA2/ALPHA1 RATIO) [Default: 0.5] a1/a2 intensity ratio.

$2 (2THETA START) Starting 2θ for peak fitting.

$3 (2THETA END) Ending 2θ for peak fitting.
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12.4.8 PEAKS/SAVE

SAVE copies the peak parameter table from 
memory to a specified disk file for retention. The 
peak file is ASCII and can easily be printed on 
any printer or read by any screen editor. The 
ASCII peak parameter files consist of three sec-
tions:

• General header with file, date, title, wave-
lengths, and range.

• Peak data table with ds, 2Ts, Is, Irel, and 
FWHMs.

• Background data table with 2T start and end 
of each region and background.

The peak parameter table is created with either 
AUTO or MANUAL. It is modified with MANUAL 
and REFINE and can be destroyed with CLEAR.

When started from the command line, PEAKS/
SAVE takes the following arguments:

PEAKS /SAVE $1 /APPEND

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses:

$1 (PEAKS FILE) Filename to create or append 
another peak table.

APPEND (APPEND Y/N) Check the box to append the new 
peak table at the end of any existing file. Leave it 
blank to overwrite any existing peak file.
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12.4.9 PEAKS/SIMULATE

SIMULATE has nine subcommands. When you 
choose it from the menu bar, GADDS displays a 
submenu containing the subcommands. When 
you start PEAKS/SIMULATE from the command 
line, you need to specify one of the subcom-
mands as a qualifier (if not, the submenu 
appears and GADDS waits until you have made 
a selection). The subcommands are:

To select one of the options, highlight it with the 
arrows or mouse. A help message appears on    
the bottom status line describing the action 
taken by the selected item. To begin the high-
lighted action, press ENTER. When you are fin-
ished, select EXIT or press ESC to return to the 
menu bar.

Profile lineshapes are used in the least squares 
refinement of all peak parameters. Representa-
tive profile lineshapes can be either collected 
data, or simulated data using mathematical 

functions. SIMULATE lets you use a Cauchy 
(Lorentzian), Gaussian, modified Cauchy, asym-
metrical Cauchy, Pseudo-Voigt, Pearson VII or a 
split Pearson VII function to model the profile 
shape.

Profile lineshape functions used by SIMULATE 
are given below:

You must supply the 2θ value of the peak and 
any required exponents or weight fractions. 
PEAKS/SIMULATE/VIEW then calculates and 
displays the lineshape function.

EXIT Close REFINE submenu and return to 
PEAKS menu

CAUCHY Symmetric Cauchy function (Lorentzian)

GAUSSIAN Symmetric Gaussian function

MODCAUCHY Modified Cauchy function

ASYMCAUCHY Asymmetric Cauchy function

PSEUDO Pseudo-Voigt function

PEARSON Pearson VII function

SPLIT Split Pearson VII function

COSINE Cosine function for c scans

Gaussian A exp ( (x/k)2)

Cauchy (Lorentzian) A (1 + k2 x2)-1

Modified Cauchy A (1 + k2 x2)-N

Asymmetric Cauchy above with different N for each 
side of peak

PSEUDO-Voigt A [ w(x) + (1-w) G (x) ]

Pearson VII A [1 + 4 (2-M -1) (x/k)2]-M

SPLIT Pearson VII above with different M for each 
side of peak

Cosine 1+cos x



SLAM Routines GADDS Software Reference Manual

12 - 22 M86-E01008

PEAKS/SIMULATE/CAUCHY

When started from the command line, PEAKS/
SIMULATE/CAUCHY takes the following argu-
ment:

PEAKS /SIMULATE /CAUCHY $1

where the argument is:

PEAKS/SIMULATE/GAUSSIAN

When started from the command line, PEAKS/
SIMULATE/GAUSSIAN takes the following argu-
ment:

PEAKS /SIMULATE /GAUSSIAN $1

where the argument is:

PEAKS/SIMULATE/MODCAUCHY

When started from the command line, PEAKS/
SIMULATE/MODCAUCHY takes the following 
arguments:

PEAKS /SIMULATE /MODCAUCHY $1 

/EXPONENT=[n]

where the arguments are:

PEAKS/SIMULATE/ASYMCAUCHY

When started from the command line, PEAKS/
SIMULATE/ASYMCAUCHY takes the following 
arguments:

PEAKS /SIMULATE /ASYMCAUCHY $1 

/LOWEXP=[n] /HIGHEXP=[n]

where the arguments are:

PEAKS/SIMULATE/PSEUDO

When started from the command line, PEAKS/
SIMULATE/PSEUDO takes the following argu-
ments:

PEAKS /SIMULATE /PSEUDO $1 

/FRACTION=[n]

where the arguments are:

$1 (2THETA)

$1 (2THETA)

$1 (2THETA)

Exponent=[n] (EXPONENT)

$1 (2THETA)

LOWEXP=[N] (EXPONENT)

HIGHEXP=[N] (EXPONENT)

$1 (2THETA)

FRACTION=[n] (CAUCHY FRACTION)
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PEAKS/SIMULATE/PEARSON

When started from the command line, PEAKS/
SIMULATE/PEARSON takes the following argu-
ments:

PEAKS /SIMULATE /PEARSON $1 

/EXPONENT=[n]

where the arguments are:

PEAKS/SIMULATE/SPLIT

When started from the command line, PEAKS/
SIMULATE/SPLIT takes the following argu-
ments:

PEAKS /SIMULATE /SPLIT $1 /LOWEXP=[n] 

/HIGHEXP=[n]

where the arguments are:

PEAKS/SIMULATE/COSINE

When started from the command line, PEAKS/
SIMULATE/COSINE takes the following argu-
ment:

PEAKS /SIMULATE /COSINE $1

where the argument is:

$1 (2THETA)

EXPONENT=[n] (EXPONENT)

$1 (2THETA)

LOWEXP=[n] (EXPONENT)

HIGHEXP=[n (EXPONENT

$1 (2THETA)
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12.4.10 PEAKS/VIEW

VIEW displays the current peak parameter table. 
The peak parameter table is created with either 
AUTO or MANUAL. It is modified with MANUAL 
and REFINE and may be destroyed with 
CLEAR. When started from the command line, 
VIEW takes no arguments:

PEAKS /VIEW

12.4.11 PEAKS/ZOOM

ZOOM lets you rescale the currently displayed 
raw data pattern with new axes. Both the upper    
left corner and lower right corner of the graph 
must be specified. Enter the new values or 
select them with the mouse. Interactively, press 
R to restore the graph to full axes.

When started from the command line, PEAKS/
ZOOM takes the following arguments:

PEAKS /ZOOM $1 $2 $3 $4 /RESTORE

Each argument is listed below by its command 
line name, followed by its input panel prompt in 
parentheses:

$1 (ZOOM 2T-LEFT)

$2 (ZOOM 2T-RIGHT)

$3 (ZOOM I-MIN)

$4 (ZOOM I-MAX)

RESTORE (RESTORE Y/N)—overrides $1–$4 and restores to original axes.
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12.5 Ratemeter

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: RATEMETER $1/RESET=<n> 
/SHUTTER

The ratemeter option of Collect > Goniometer > 
Manual command is available in command 
mode. See Collect > Goniometer > Manual, 
Section 5.11 for more details.

Each argument is listed below by its command 
line name.

$1 ..........................(max seconds)    [9999]

Enter maximum number of seconds for 
exposure.

/RESET=<n>.........(Reset Interval)     [0.5] 

Enter number of seconds between read-
outs.

/SHUTTER ............(Open & Close Shutter)     
[No]

Check to open shutter before and close 
after this command.

12.6 Spawn

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: SPAWN

SPAWN is available in command mode at the 
GADDS> prompt. Use this command to spawn 
another program, but unlike the SYSTEM com-
mand, GADDS is not suspended until the 
spawned command terminates.

Each argument is listed below by its command 
line name.

$1 ......................... (Command) []

See system command.
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12.7 Video/Live

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: VIDEO /LIVE

Use this command to place the VIDEO program 
into “live” video mode. This command executes 
immediately without any arguments.

12.8 Video/Freeze

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: VIDEO /FREEZE

Use this command to place the VIDEO program 
into “frozen” video mode. This command exe-
cutes immediately without any arguments.
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12.9 Wait

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: WAIT $1

WAIT is available only in command line mode, at 
the GADDS> prompt. WAIT suspends execution 
of the program for a specified time. If you press 
ENTER or the left mouse button during the wait 
period, the program aborts the wait and pro-
ceeds. This command is useful in scripts, where 
you want to display a frame or text and have it 
remain visible for some minimum length of time. 

The valid value range is -1 to 1.0x1010 seconds. 
WAIT will wait indefinitely if you specify a time 
value of -1. Syntax is:

WAIT $1

where $1 is the wait time in seconds, as a real 
number.

12.10 ! (comment)

Menu Command: None

Accelerator: None

User Level: Command

SLAM Syntax: ! (any text string)

Use the ! command to add comment lines within 
a script file. Simply place the “!” character at the 
start of any line and follow it with your comment 
statement.

! myscript.slm: created 26Mar98 by KLS

! - - - - - - - - - - - - - - - - - - -

!

! Load first frame in series

DISPLAY...
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12.11  @ (execute script file)

Menu Command: None, but see UserTasks

Accelerator: None

User Level: Command

SLAM Syntax: @filename p1 p2 p3 p4 p5 p6 p7 
p8 p9 p0

Use the @ command to execute commands 
from a script file while in GADDS's command 
line mode. You must specify the name of the 
script file immediately after the @ symbol. By 
convention, SLAM script files have the extension 
.slm, and a .slm extension is assumed if none is 
given in the @ command. The program looks for 
a script file in three places: current project direc-
tory, system data directory (see GADDS$SYS-
DATA:) or common script directory (see 
GADDS$SCRIPT:). Follow the filename with the 
optional replaceable parameters. Replaceable 
parameters are space deliminated. Any replace-
able parameter with embedded spaces must be 
enclosed within double quotes.

A script file is simply an ASCII file containing a 
list of SLAM commands in which each line is an 
individual SLAM command that is executed in 
sequential order. It is very powerful, and pro-
vides a convenient means for automating the 
more mundane sequence of commands from 
within the GADDS environment. For more infor-
mation on script files (creating, editing, nesting, 
replaceable parameters, and running scripts), 
see the GADDS User’s Manual, Scripts section.

When the script is invoked, each of the lines 
executes in sequence as if it had been typed at 
the command line using the parameters and 
arguments included within the script. That is, 
GADDS simply starts at the beginning of the 
script file and proceeds one line at a time until it 
reaches the end, at which point it stops.

To interrupt a script while in use, press 
CTRL+BREAK. This will stop the script execu-
tion and exit from the script, returning the user to 
the program's command line prompt. (To return 
to menus, enter menu mode.)

Several example scripts are provided in your 
system. The scripts are stored in the 
GADDS$TEST: directory and are used as part 
of the demo loop. To execute this demo on the 
frame buffer, enter:

GADDS> @GADDS$TEST:gadds
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13.  Utility Programs

13.1 FrmFix (FRaMe header FIX-up 
utility)

The program FRMFIX is designed to correct all 
known problems with Bruker frame file headers. 
Specifically it can:

• convert frames taken by MICRODIF for 
DOS to version 8 frame headers. These 
frames can then be read under GADDS for 
NT (but not under MICRODIF for DOS).

• correct frames taken by GADDS for NT ver-
sion 3.300 to 3.302. Under these “beta” NT 
release, the “AXES2:” and “ENDING2:” lines 
were incorrectly located at records 076 and 
077 and the “FILENAM:” record contained 
garbage.

• correct frames taken with improper fixed 
angle settings.

• correct frames with negative scan time bug. 
These frames were taken for over 12 hours 
and overnight under programs for DOS.

• correct frames with 360 degree scan width 
bug. These frames were taken in “STEP” 
mode under GADDS for DOS or GADDS for 
NT prior to v3.310.

• correct CCD frames taken on large CCD 
with SMART v4.040 (requires the switch 
/BIGCCD).

• correct frames with the first LINEAR frame 
header parameter having a value that is 
below 1.0. This is incorrectly stored as the 
reciprocal of the true value. So far, this prob-
lem has only been seen on 2K CCD sys-
tems when using 512 frame size but, 
theoretically, could occur on any area detec-
tor system.
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• correct CCD frames for bad OCTMASK 
frame header parameters (frame taken by 
SMART, to be used by GADDS).

• correct for unreasonable scan times when 
external trigger was used. ELAPSDA and 
CUMULAT values are less than 0.05 sec-
onds. Just use ELAPSDR as the scan time.

• correct frames collected on systems where 
the phi axis was configured to rotate in the 
wrong direction (Phi should rotate clock-
wise).

The command frmfix runs the program. When 
you run frmfix, it starts an interactive dialog. 
Default values are displayed in square brackets 
after the prompt. Pressing the ENTER key is the 
same as entering this default.

FRAME FILENAME ?

Enter the name of the input Bruker format frame. 
You must give the full pathname. FRMFIX does 
not merge filenames with the current frame 
directory. However, FRMFIX does translate logi-
cal names under NT or UNIX, and wildcard 
characters (that is, “*”, “?”) are allowed.

AXIS NUMBER TO RESET ?

Enter 0=none, 1=2T, 2=Om, 3=Ph, 4=Ch, 5=X, 
6=Y, 7=Z.

This feature is particularly useful for manually 
adjustable chi stages, where a scan series was 
collected while the program contained the wrong 
fixed chi setting.

VALUE TO SET AXIS ?

Enter new value for scan axis entered above.

As the program executes, Frmfix will display 
messages stating what was fixed or the mes-
sage:

Frame.000: Frame header is OK; no fix-up 
was required.

Alternately all input may be given on the com-
mand line. Brackets “[ ]” signify optional parame-
ters and are not typed. <n> signifies that a 
number is required.

FRMFIX filename [/AXIS=<n> 
/VALUE=<n>] [/BIGCCD]

/BIGCCD

Updates frame header of CCD frames col-
lected under SMART v4.040 to specify large 
CCD detector instead of small CCD.
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13.2 Frm2Frm (FRaMe to FRaMe file 
format conversion utility)

Frm2Frm is useful to import of export frame data 
files to other programs. 

Frm2Frm converts to and/or from:

• Bruker frame format (ASCII header, 
BINARY counts, ASCII overflow table).

• Bruker ASCII frame format (ASCII header, 
ASCII counts).

• TIFF (CHESS format) (BINARY header, 
BINARY counts).

It can also convert to (but cannot read these file 
formats):

• Small Bruker frame format (half-size, that is, 
1K -> 512).

• JPEG (courtesy of Larry Finger).

And finally, it can also convert from (but cannot 
write these file formats):

• Bruker new frame format (ASCII header, 
BINART counts, Overflow tables).

• APS frame format (ASCII header, BINARY 
counts)

• TIFF (MMX/MarCCD frame format) 
(BINARY header, BINARY counts).

FRM2FRM only requires the names of certain 
files as user input. The user has the option of 

entering all filenames on the command line or 
leaving the command line blank and having the 
program prompt the user for all filenames. Wild-
cards are permitted in filename inputs.

Syntax for command line (console version only):

FRM2FRM [/B] [/Z] [/#] [/FORMAT:#] 
filename[.tif] [/OUT:filename[.out]]
[/PIXPERCM:##.##] [/CMTOGRID:##.##]

filename.ext1

Required. The name of the frame image file. 
The input file format is automatically deter-
mined.

filename.ext2

Optional. Defaults to “<filename>.out”.

# 

Optional. Defaults to Bruker. Possible values 
are:

1 = Bruker frame file

2 = small Bruker frame file (half-size, that is 
1K -> 512)

3 = Bruker ASCII file

4 = TIFF file

5 = JPEG (courtesy of Larry Finger)

6 = imageNCIF (n.y.i.)
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[/B]

Batch mode: suppresses final “Hit <Return> 
to continue” message.

[/Z]

Allow frame dimensions in multiples of 512, 

instead of 512*2n (512, 1024, 2048, 4096). 
(SAINT currently does NOT support these 
odd frame dimensions of 1536, 3072, and 
6144).

[/#]

Force output frame file to be 1, 2 or 4 bytes 
per pixel. (file is saved without an overflow 
table).

[/P:##.##] 

PIXPERCM for imported frames. Default is 
0.0= ignore.

[/C:##.##] 

CMTOGRID for imported frames. Default is 
0.0=ignore.

NOTE: Brackets “[ ]” are not type. They are used 
to bracket optional or defaulted values.

NOTE: All command line switches may be 
abbreviated and the separator character may be 
“:”, “=”, or “-” (that is, “/F:1”, “/F=1”, and “/FOR-
MAT-1” are equivalent).

NOTE: The command line arguments may be in 
any order.

Current limitations (ignored fields in file header 
of various frame formats):

• Bruker: Defaults to version 8 frame headers 
with 4096-byte overflow.

• Bruker ASCII: Cannot read this format, only 
writes this format.

• TIFF: Reading TIFF files has many limita-
tions:

TIFF must be a single, full-size, mono-
chrome, and uncompressed image.

File headers are defaulted to best guess 
values.

CHESS: private tags are not translated. 
Numerous frame header items are defaulted 
to best guesses.

MMX/MarCCD: handles only omega or phi 
scan series.

• Assume angles are already in Bruker 
conventions, except for chi (CHImar + 
90.0 = CHIbruker). This works for frame 
series collected at 2t=0, Om=0, phi, 
Ch=0, which convert to 0, 0, phi, 90 in 
Bruker angle conventions.

• Frame number and Number of frames in 
series are not converted.
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• CCD temp is not converted.

• Detector roll, pitch and yaw are not con-
verted.

• NEXP and CCDparms are not converted.

• imageNCIF: (n.y.i.)

• APS: Read only; FRM2FRM cannot write 
this frame file format.

Angles in frame header are not converted to 
Bruker conventions.

NOTE: For compatibility with software requiring 
512-byte overflow table, use the environment 
variable: “SET SAXI$512MAXOVF=1”.
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13.3 GADDSMAP (GADDS MAPping 
program)

This utility program is automatically started 
when the Analyze > Mapping command starts to 
process the run series. As each map parameter 
(e.g., integrated area) is calculated, the X, Y, 
and map parameter value is sent to GADDS-
MAP. The result is a map of a parameter versus 
XY sample position (or different samples if a 
sample library was used).

The mapping can be displayed by either a value 
scale or by a pass/fail criteria. Ratio between 
two map files can be displayed and saved. The 
*.gmap file format is documented in online help.

For more information, see online documentation 
for GADDSMAP.

13.4 Indxtl • NIST index generator

INDXTL builds a hard-disk resident index to a 
NIST CDF CD-ROM. GADDS uses this index to 
reduce the time required to perform a CDF 
search. Normally this index file will reside in 
GADDS$SYSTEM:cryidx.bin. You must use 
INDXTL to create this file before GADDS will 
perform a CDF search.

The NIST Crystal Data CD is available in two 
major forms:

1. NIST 1999 and later: The inorganic and 
organic databases reside in separate files, 
which are CR/LF terminated.

2. ICDD 1997 and earlier: One file contains the 
inorganic followed by the organic, which is 
not CR/LF terminated.

To run INDXTL, the following environment vari-
ables should be defined (and the NIST CDF CD-
ROM must also be placed in the CD-ROM 
drive):

SAXI$CDF:

This variable defines the directory in which 
to write the Crystal Data Information File 
binary index files CRYIDXINO.BIN and 
CRYIDXORG.BIN (new) or CRYIDX.BIN 
(old).

SAXI$CDROM:

This variable defines the drive and directory 
for the Crystal Data Information Files 
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CRYSTI.DAT and CRYSTO.DAT (new) or 
CRYSTAL.DAT (old). This is usually a 
CDROM disk and directory of 
<drive>:\ORIGFMT\ (new) or drive>:\CRYS-
TAL\ (old).

SAXI$CDCODE:

This variable defines the drive and directory 
for the Crystal Data CODENS Files 
CODENINO.TXT and CODENORG.TXT 
(new) or CODENS.DAT (old). This is usually 
a CDROM disk and directory of <drive>:\ 
(new) or <drive>:\CRYSTAL\VAXIND\ (old).

When you run INDXTL, it starts an interactive 
dialog. Default values are displayed on the line 
before the prompt. Pressing a forward slash fol-
lowed by the ENTER key is the same as enter-
ing this default. The program requests the 
following information and will then run for sev-
eral minutes periodically printing the number of 
entries processed as a progress indicator:

OPTIONS

  9. Exit

  1. Create indexes for new format (1999 

or later)

  0. Create index for old format

DEFAULT OF CRYSTAL DATA FILE NAME = 

<default name>

CHOOSE DEFAULT (/) OR INPUT NEW NAME:

Enter the pathname of the CRYSTAL.DAT 
file. Typically this will be on the CD-ROM in 
<cd-rom drive>:\CRYSTAL\CRYSTAL.DAT, 
where <cd-rom drive> represents the drive 
letter of the CD-ROM on your system.

DEFAULT OF CODENS FILE NAME = <default 
name>

CHOOSE DEFAULT (/) OR INPUT NEW NAME:

Enter the pathname of the CODENS.DAT 
file. Typically this will be on the CD-ROM in 
<cd-rom drive>:\CRYSTAL\VAX-
IND\CODENS.DAT, where <cd-rom drive> 
represents the drive letter of the CD-ROM 
on your system.
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13.5 Merge • RAW file range 
merging utility

This utility program combines the specified 
ranges from up to ten RAW data files into a sin-
gle range RAW data file. Mostly, Merge is used 
to combine the integrated 2T spectra from sev-
eral area detector frames of differing swing 
angle into a single continuous range which is 

more suitable for most DIFFRACplus routines 
such as phase characterization and identifica-
tion.

The user has the option of entering ALL filena-
mes on the command line, or to leave the com-
mand line blank and have the program prompt 
the user for all filenames, ranges and options. 
The resultant merged raw file is always written 

in DIFFRACplus format; however, the inputted 
raw files may be of several and even different file 
formats:

• DIFFRAC-PLUS raw or sim file format.

• DIFFRAC-AT V2 (a.k.a. V3) raw or sim file 
format.

• DIFFRAC-AT V1 raw or sim file format.

• PLOTSO file format (ASCII).

Merge checks the file and range header records 
to ensure the mergibility of the ranges. Several 
checks produce fatal errors:

• Collected on different x-ray tubes (anode).

• Collected at different temperatures.

• Collected at different generator voltage.

• Collected at different generator current.

• Collected using different step widths.

• Collected using overlapping step widths.

• Collected using different scan axes.

Other checks only produce warnings and the 
user must decide if the ranges are compatible:

• Collected on different dates.

• Collected by different users.

• Collected on different goniometer models.

• Collected on different goniometer stages.

• Collected at different detector distances.

• Collected for different step times.

• Collected using different scan types.

Syntax for command line:

MERGE [/B] [/A] [/S] [/R#[:#]] filein[.raw] 
[/R#[:#]]  [+filein[.raw] [/R#[:#]] [+...]]  
[merge[.out]]

[/B] 

Batch mode: suppresses final “Hit <Return> 
to continue” message.

[/A] 

Averages overlapped regions instead of 
using weighting factor.
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[/S] 

Scales merged ranges to first using intensity 
fit scale factor.

[/R#[:#]] 

Merge specific ranges # to #, inclusive. 
Defaults to all ranges. If [:#] is missing, the 
ending range defaults to the first range and 
only one range is merged. The location of 
the switch is important. Placed after 
MERGE, /R specifies the default ranges for 
all input files. When placed after a filename, 
/R specified the ranges only for that file and 
will override the default range(s) settings.

filein[.raw] 

First input filename. Must be entered, but 
extension will default to [.raw]. The input file 
format is automatically determined.

[+...] 

Additional input filename(s) and their ranges 
to merge may be specified up to a maximum 
of 10 filenames.

[merge[.out]]

Output merged data file. Defaults to 
“merge.out”.

NOTE: Brackets “[ ]” are not type. They are used 
to bracket optional or defaulted values.

NOTE: All command line switches may be 
abbreviated and the separator character may be 
“:”, “=”, or “-” (that is, “/F:1”, “/F=1”, and “/FOR-
MAT-1” are equivalent).

NOTE: The command line arguments are order 
specific.

Current limitations (ignored fields in file for-
mats):

• RAW PLUS: supplemental range header 
records (osc, psd, com).

• RAW PLUS: reading RAW1.00 measuring 
electronics may be incorrect.

• RAW V2: diffractometer configuration word.

• RAW V2: oscillating drive, amplitude, speed.

• RAW V2: supplemental range header 
record for comment (4).
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Other limitations:

• Cannot merge an additional range in 
between two other ranges. One must reor-
der the ranges such that the additional 
range is being added to the head or tail of 
the previously merged ranges.

Range start end

1 10.0 40.0

2 60.0 90.0

3 35.0 65.0    <- Fails!

• Cannot merge a range when previous 
ranges are a subset of current range.

Range start end

1 10.0 40.0

2 05.0 90.0    <- Fails!

13.6 PDFnoind • PDF2 index 
generator

PDFnoind builds a hard-disk resident index to 
an ICDD PDF2 CD-ROM. It is required for ICDD 
PDF2 set 47 and higher. For set 46 and earlier, 
PDFnoind also works, but the index file is also 
distributed on the PDF2 CDROM. GADDS uses 
this index to reduce the time required to perform 
a PDF2 search. Normally this index file will 
reside in PDF2$IND:pdfno.ind. You must use 
PDFNOIND to create this file before GADDS will 
perform a PDF2 search.

To run PDFNOIND, the following environment 
variables should be defined (and the ICDD 
PDF2 CD-ROM must also be placed in the CD-
ROM drive):

PDF2$PDF:

This variable defines the drive and directory 
for the ICDD PDF2 Database File, 
PDF2.DAT. This is usually a CDROM disk, 
and directory of <drive>:\PDF2\.

PDF2$IND:

This variable defines the drive and directory 
for the ICDD PDF2 Index File, PDFNO.IND, 
created by this utility. This must be a hard 
disk, usually C:\PC-PDF\.

When you run PDFNOIND, it starts immediately 
and will then run for several minutes, periodi-
cally printing the number of entries processed 
as a progress indicator.
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13.7 Plotso

PLOTSO is a separate program for displaying X-
Y graphs of data stored in simple ASCII text 
files. PLOTSO can be started by entering the 
name of the ASCII file to be plotted on the DOS 
command line as in the following example:

PLOTSO SAXI$TEST:PLOTSO.DAT

If the filename is not given, PLOTSO will prompt 
for it. You can print the plot to any supported 
printer (that is, HP-compatible printer) by press-
ing CTRL+P after the graph has been drawn. A 
PRINT SCREEN panel appears with default set-
tings for both the printer device and printer type. 
The default print filename is SAXI$PRINTER. 
You can either define this name as a logical 
name or environment variable, or input a differ-
ent filename on the panel; use PRN to write 
directly to a printer on the PC, or SYS$PRINT to 
write directly to the VAX print queue. The default 
printer type is PCL4 (HP LaserJet or compatible 
printer). PLOTSO can also create TIFF files, 
which can be imported into word processors. 
TIFF files produced on the PC will include the 
PLOTSO window border and title, while on other 
computer platforms only the plot is sent to the 
TIFF file.

PLOTSO data files are simple ASCII text files 
which contain X,Y pairs in (FORTRAN-compati-
ble) free format, one pair per line. This results in 
a simple X-Y plot with automatic scaling of the 
axes to accommodate the data. The data file 

may optionally contain directives, which are 
lines starting with the special 3-character 
sequence (!@!) that allow you greater control 
over the appearance of the plot and also allow 
multiple plots to be defined in the same file. The 
directive prefix !@! must begin in the first col-
umn of a line, one directive per line. A line with 
the character “!” in the first column is taken as a 
comment and skipped, unless it starts with the 
directive prefix. Most of the directives need to be 
followed by a few parameters, again in free for-
mat. Some of the directives require you to spec-
ify X,Y fractional coordinates. The convention for 
these coordinates is that (X,Y) = (0.0, 0.0) corre-
sponds to the lower left of the graph viewport 
and (X,Y) = (1.0, 1.0) corresponds to the upper 
right. When you use a directive, the directive 
remains in effect for all remaining lines in the 
file, unless superseded by another occurrence 
of the directive. The directives are: 

!@!A

Writes a text string at specified X,Y frac-
tional coordinates. Requires the fractional X, 
fractional Y, and text string as parameters. 
Example: “!@!A 0.5,0.5 Your line of text 
here”.

!@!C

Specifies X,Y character size for subsequent 
annotation text. Requires the X character 
size and Y character size as parameters. 
Each size is specified as an integer from 1 
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to 4. Example: “!@!C 1,2”. (By default, text 
is written in size 1,1.)

!@!G

Normally the plot is drawn with a dashed 
grid highlighting certain tic marks. This 
directive lets you specify whether or not the 
grid is to be drawn. Examples are: “!@!G1” 
(to enable drawing of the grid) or “!@!G0” 
(to disable drawing of the grid).

!@!L 

Sets plot axis limits, overriding the auto-
scaling normally performed. Requires four 
parameters, Xmin, Ymin, Xmax, Ymax cor-
responding to the lower X, lower Y, upper X, 
and upper Y axis limits, respectively. If both 
the lower and upper limit for an axis are 
specified as zero, autoscaling is restored for 
that axis. The default limits are 0,0,0,0, 
meaning that auto-scaling is performed on 
each axis. When an axis is auto-scaled, a 
“nice” interval for tic marks is determined. 
This interval is always 1, 2 or 5 times some 
power of 10. Limits are then chosen which 
are integer multiples of this interval and 
which contain the range of values input for 
the axis being auto-scaled. An example of 
this directive is: “!@!L0,0,100,0”. (This 
example specifies that the X-axis will range 
from 0 to 100, and the Y will be auto-scaled 
based on the range of the input Y-values.)

!@!M

Specifies the character to be used as a 
Marker. The Marker Character is plotted at 
each subsequent X,Y point. The marker 
character must immediately follow the direc-
tive (that is, it must be the fifth character on 
the line). Examples are: “!@!M+” (to plot a + 
at each input X,Y position) or “!@!M” (to dis-
able plotting of a character at each X,Y posi-
tion).

!@!N

Specifies that subsequent X,Y points should 
be drawn as a new plot, rather than added 
to the existing set of axes. This directive 
requires no parameters. If you use this 
directive, you'll want to make sure to specify 
separate “!@!V” viewport directives for each 
plot, so they don't overlap within the graph-
ing window.

!@!P

Specifies that the X,Y points encountered 
so far are to be drawn and that subsequent 
points will be drawn as a separate curve. If 
you're drawing multiple plots, issue a “!@!P” 
after the X,Y pairs of the first plot to draw it, 
followed by a “!@!N” to begin the second. If 
you're drawing multiple curves in the same 
plot, issue “!@!P” after the X,Y pairs in each 
curve.
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!@!S

Specifies a line style for a connecting line to 
be drawn between X,Y pairs. Supply one of 
the characters 0,N,S or D as a parameter. 
Line styles are: “!@!S0” or “!@!SN” (for no 
connecting line, for example, for scatter 
plots), “!@!SS” (for a solid connecting line), 
and “!@!SD” (for a dotted connecting line).

!@!V

Specifies the viewport to be used for the 
subsequent plot, in fractional coordinates 
representing the fraction of the entire area 
available for graphs. Requires the four 
parameters Xmin, Ymin, Xmax, and Ymax, 
which represent the lower X, lower Y, upper 
X, and upper Y viewport limits, respectively. 
By default, these limits are 0,0,1,1, meaning 
that the viewport occupies the entire graph-
ing area. For example, if you wanted to con-
fine the graph to the left half of the available 
area, you could issue the directive: 
“!@!V0,0,.5,1”.

!@!X 

This directive specifies the X-axis label. Fol-
low the directive with the text to be drawn 
along the X axis. By default, the text is “X-
AXIS.” For example, if you're plotting a func-
tion versus time, you might issue the direc-
tive “!@!XTime (seconds)”.

!@!Y

This directive specifies the Y-axis label. Fol-
low the directive with the text to be drawn 
along the Y axis. By default, the text is “Y-
AXIS.” For example, if you’re plotting pixel 
values as a function of position, you might 
issue the directive “!@!YPixel Value”. Nor-
mally, Y-axis text is written vertically (but not 
rotated, since some graphic environments, 
most notably X-Windows, don't support 
rotated text); however, if the text contains 
hyphens or parentheses, it writes the text 
horizontally. In this latter case, you need to 
keep the axis label very short.

!@!DB

Draws a rectangular box at specified 
X,Y,W,H fractional coordinates. Requires 
the fractional X, fractional Y, fractional W, 
and fractional H as parameters. Example: 
“!@!DB 0.5,0.5,0.1,0.1”.

!@!DD

Draws a dot at specified X,Y fractional coor-
dinates. Requires the fractional X and frac-
tional Y as parameters. Example: “!@!DD 
0.5,0.5”.

!@!DE

Draws an ellipse at specified X,Y,W,H frac-
tional coordinates. Requires the fractional X, 
fractional Y, fractional W, and fractional H as 
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parameters. Example: “!@!DE 
0.5,0.5,0.1,0.1”.

!@!DL

Draws a line segment between specified 
X1,Y1,X2,Y2 fractional coordinates. 
Requires the fractional X1, fractional Y1, 
fractional X2, and fractional Y2 as parame-
ters. Example: “!@!DL 0.5,0.5,0.1,0.1”.

!@!E

Erases a rectangular box at specified 
X,Y,W,H fractional coordinates. Requires 
the fractional X, fractional Y, fractional W, 
and fractional H as parameters. Example: 
“!@!E 0.5,0.5,0.1,0.1”.

See SAXI$TEST:PLOTSO.DAT for an example 
of a PLOTSO data file.

The syntax for starting PLOTSO by:

• NT is: PLOTSO /X=<n> /Y=<n> /W=<n> 
/H=<n> DATA_FILE

• IRIX is: PLOTSO -X=<n> -Y=<n> -W=<n> 
-H=<n> DATA_FILE

When you start PLOTSO you can also specify 
the qualifiers /W=<n> and /H=<n> on the com-
mand line, where <n> represents a numeric 
value. The value given for /W is the desired win-
dow width in pixels and the one for /H is the 
desired window height (if you want the full 
screen but are not sure of the number of screen 
pixels, use /W=9999 /H=9999. Under NT or IRIX 

you can also specify the X and Y pixel numbers 
desired for the upper left corner of the graphics 
window with /X=<n> and /Y=<n>. If the /W and 
/H are not given, they default to 704 and 600 
respectively (providing a screen dump which 
reasonably covers the full page width of both the 
LaserJet (at 100 dpi) and the PaintJet (at 90 
dpi). The window width affects the print screen 
option. The program requests a dot-per-inch 
resolution from the printer that is equal to or 
higher than the screen width in pixels divided by 
7.75 inches. The following screen widths fill the 
printed page reasonably well:

NOTE: The smaller widths result in faster screen 
dumps, especially when the printer is on a serial 
port.

/W=704 (default) LaserJet @ 100 dpi, PaintJet @ 90 dpi

/W=520 LaserJet @ 75 dpi, PaintJet @ 90 dpi

/W=1024 LaserJet @ 150 dpi, PaintJet @ 180 dpi
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13.8 Prbatch • Profile fitting in batch 
mode utility

Used internally by GADDS to perform profile fit-
ting on raw spectra. For more information, see 
PROFILEplus manual.

13.9 PVWave • Precision Visual’s 
Wave procedures

Bruker provides procedures for importing and 
exporting data in Bruker file formats from within 
Precision Visual's Wave software (version 3.0).

Directory: C:\SAXI\PVWAVE

13.9.1 SAXII_READ_D5000 (VAX only)

PV-Wave procedure to read a Bruker DIFFRAC-
5000 raw data file. Up to ten ranges will be read 
and displayed.

Usage:

.run saxii_read_d5000

saxii_read_d5000, xarray, yarray [, filename]

where:

SAXII_READ_
D5000.PRO

PV-wave procedure to read a 
Bruker D5000 file.

SAXII_READ_
FRAME.PRO

PV-wave procedure to read a 
Bruker frame file.

SAXII_READ_
PLOTSO.PRO

PV-wave procedure to read a 
Bruker PlotSO file.

SAXII_SAVE_
D5000.PRO

PV-wave procedure to save a 
Bruker D5000 file.

SAXII_SAVE_
FRAME.PRO

PV-wave procedure to save a 
Bruker frame file.

SAXII_SAVE_
PLOTSO.PRO

PV-wave procedure to save a 
Bruker PlotSO file.
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xarray (dimension (500,10)) returns the 
2theta values of up to ten ranges.

yarray (dimension (500,10)) returns the 
intensity counts of up to ten ranges.

filename DIFFRAC-5000 *.RAW filename. If 
missing the procedure will ask for the file-
name.

13.9.2 SAXII_READ_FRAME

PV-Wave procedure to read a Bruker area 
detector frame. Header is type to screen and the 
image is displayed, and the color table is stretch 
to fit. This version handles 8-, 16-, or 32-bit 
frames WITHOUT an overflow table.

PV-Wave's image color table works only on byte 
images. Values above 256 are clipped upon 
being displayed. Thus, the user may wish to use 
the HIST_EQUAL function to rescale 16- or 31-
bit frames into byte images:

image = hist_equal (image)

tv, image

Usage:

.run saxii_read_frame

saxii_read_frame, image [, filename, 
header]

where:

image (dimension (512,512)) returns the 
byte/word/dword image data

filename Frame data filename. If missing the 
procedure will ask for it.

header (dimension (*,80)) returns the 
header information

13.9.3 SAXII_READ_PLOTSO

PV-wave procedure to read a Bruker PLOTSO 
file.

Usage:

.run saxii_read_plotso

saxii_read_plotso, xarray, yarray [, filename]

where:

xarray (dimension (500,10)) returns the 
2theta values of up to ten ranges.

yarray (dimension (500,10)) returns the 
intensity counts of up to ten ranges.

filename PLOTSO filename. If missing the 
procedure will ask for it.
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13.9.4 SAXII_SAVE_D5000 (VAX only)

PV-wave procedure to save an array as a Bruker 
d5000 file.

Usage:

.run saxii_save_d5000

saxii_save_d5000, xarray, yarray [, file-
name]

where:

xarray (dimension (500,10)) 2theta values of 
up to ten ranges.

yarray (dimension (500,10)) intensity counts 
of up to ten ranges.

filename DIFFRAC-5000 *.RAW filename. If 
missing the procedure will ask for the file-
name.

13.9.5 SAXII_SAVE_FRAME

PV-Wave function to save a Bruker area detec-
tor frame. Header is modified from the original 
frame header. This version handles 8-, 16-, or 
32-bit frames WITHOUT an overflow table.

Usage:

.run saxii_save_frame

saxii_save_frame, image [, filename, 
header]

where:

image (dimension (512,512)) byte/word/
dword image data

filename Frame data filename. If missing the 
procedure will ask for it.

header (dimension (*,80)) header informa-
tion

13.9.6 SAXII_SAVE_PLOTSO

PV-wave procedure to save an array as a Bruker 
PLOTSO file.

Usage:

.run saxii_save_plotso

saxii_save_plotso, xarray, yarray [, filename]

where:

xarray (dimension (500,10)) 2theta values of 
up to ten ranges.

yarray (dimension (500,10)) intensity counts 
of up to ten ranges.

filename PLOTSO filename. If missing the 
procedure will ask for it.
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13.10 Raw12Fix • Fixes file headers 
of DIFFRAC-5000 files ported from 
PC to VAX

After copying a Diffrac-5000 file from PC to a 
VAX over the network, the RECL in the file 
header on the VAX file may be incorrectly set at 
512-bytes. This is the default for the Community 
DOS NETCOPY /V command and other net-
work packages. RAW12FIX will change the 
RECL in the file header.

Syntax: RAW12FIX filename[.raw]

or

$ run saxi$system:RAW12FIX

Enter filename [ra:*.raw]: filename

NOTE: RAW12FIX.VMS must be copied to VMS 
computer and renamed to RAW12FIX.EXE.

13.11 Raw2Raw • RAW to RAW file 
format conversion utility

Use RAW2RAW to export or import RAW spec-
tra in various data file formats.

Converts to and/or from:

• DIFFRAC-PLUS raw or sim file format.

• DIFFRAC-AT V2 (aka V3) raw or sim file for-
mat.

• DIFFRAC-AT V1 raw or sim file format.

• PLOTSO file format (ASCII).

Can also convert to (but cannot read these file 
formats):

• DBW and DBWS file formats (ASCII).

• GSAS file format (ASCII).

• UXD file format (ASCII).

Can also convert from (but cannot write these 
file formats):

• DIFFRAC-5000 V2 (VAX/VMS)

• DIFFRAC-5000 V1 (VAX/VMS)

• NACS (VAX/VMS)

• NACS (PDP-11/TSX|RT-11)

• DIFFRAC-11 (PDP-11/RSX)

• DIFFRAC-5 (PDP-11/RSX)

• Philips UDF format (may read only a subset 
of UDF files).
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RAW2RAW only requires the names of certain 
files as user input. The user has the option of 
entering ALL filenames on the command line, or 
to leave the command line blank and have the 
program prompt the user for all filenames. Wild-
cards are permitted in filename inputs.

Syntax for command line:

RAW2RAW [/B] [/FORMAT:#] filename[.raw] 
[/OUT:filename[.out]]

Additional switches for UXD output: [/C] [/I:#] 
[/N] [/Sc] [/W:#] [/2]

[/B]

Batch mode: suppresses final “Hit <Return> 
to continue” message.

filename[.raw]

Required. The name of the RAW data file 
containing ranges. The input file format is 
automatically determined.

filename[.out]

Optional. Defaults to “<filename>.out”.

#

Optional. Defaults to DIFFRAC-PLUS. Pos-
sible values are:

1 = DIFFRAC-AT V1

2 = DIFFRAC-AT V2/V3

3 = DIFFRAC-PLUS

4 = PLOTSO

5 = DBW

6 = DBWS

7 = GSAS

8 = UDX

[/C]

CPS mode: Outputs data points in CPS, 
default is intensity.

[/I:#]

Item number: Outputs data points

[/N]

Noheader mode: Suppress output of header 
information.

[/Sc]

Separator: ,=comma, ;=semi-colon, 
s=space, t=tab, n=none.

[/W:#]

Width: Width of each item in characters for 
default separator.

[/2]

2theta mode: Include 2T angle on each line 
of data points.
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NOTE: “[]” are not typed. They are used to 
bracket optional or defaulted values.

NOTE: All command line switches may be 
abbreviated and the separator character may be 
“:”, “=”, or “-”. (i.e., “/F:1”, “/F=1”, “/FORMAT-1” 
are equivalent).

NOTE: The command line arguments may be in 
any order.

Current limitations (ignored fields in file for-
mats):

• RAW PLUS: supplemental range header 
records (osc, psd, com).

• RAW PLUS: reading RAW1.00 measuring 
electronics may be incorrect.

• RAW V2: diffractometer configuration word.

• RAW V2: oscillating drive, amplitude, speed.

• RAW V2: supplemental range header 
record for comment (4).

• DIFFRAC-5000 V2: 

scintillation detector parameters

conversions of slit settings (mm to degrees)

temperature parameters

other angle settings (chi, phi, x, y)

• DIFFRAC-5000 V1: many fields are not con-
verted.

• NACS VMS: temperature hold time.

• NACS TSX/RT-11: not yet implemented!

• DIFFRAC-11:variable slit settings, fixed 
theta angle/delay time.

• DIFFRAC-5: totally untested!

• UXD: Only minimal information is in header.
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13.12 SAXAD.SYS • Bruker HISTAR 
NT Driver

SAXAD.SYS is the NT Driver to support and 
access the Bruker’s Area Detector Fast Interface 
card. For normal configurations, the SETUP pro-
gram will properly install and configure this 
driver.

SAXAD driver will allocate 4.25 Mbytes of NON-
PAGED memory. This will greatly affect perfor-
mance on low memory NT systems. A system 
with at least 20 Mbytes of memory is recom-
mend. Increase virtual memory to at least 35 
Mbytes; the WNT default of 21 Mbytes is insuffi-
cient. For users who do not collect large frames, 
set MaxFrameSize = 512 in the registry as this 
will free 3 Mbytes of unused non-paged mem-
ory.

During data collection and flood fields, the 
SAXAD driver executes at the level 
“LOW_REALTIME_PRIORITY”. Only when the 
driver checks for an event and no event is in the 
queue, does the driver permit any time alloca-
tion to other processes.

For real-time display during data collection or 
flood field, the NT system must be equipped 
with a super fast video card such as a PCI local 
video card. An ISA bus video card will be excru-
ciatingly slow.

Possible error messages during loading of 
driver:

“Not enough memory was available to allocate 
internal storage needed...”

STATUS_INSUFFICIENT_ RESOURCES, if 
out of system memory. Reboot might work, 
else add memory. Or set MaxFrameSize = 
512.

“The hardware locations for saxad0 could not be 
translated to something...”

STATUS_NONE_MAPPED, if NT cannot 
map port. Hopefully this error never occurs.

“The hardware addresses for saxad0 are 
already in use by another device”

STATUS_DEVICE_ 
CONFIGURATION_ERROR if IO port is 
already in use.
Change IO port address on FAD interface 
card and in registry.

“Unable to detect Bruker's FAD interface board”

STATUS_NO_SUCH_DEVICE if Bruker 
FAD interface fails to respond. Possibly bad 
board or jumper settings. Or PDC was off 
when computer was booted.

“Unable to create the symbolic link for saxad0”

STATUS_NO_SYMBOLICLINK_ CRE-
ATED    NT cannot create a link to driver. 
Hopefully this error never occurs.
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“Unable to create the device map entry for 
saxad0”

STATUS_NO_DEVICEMAP_CREATED   
Driver could not update registry. Hopefully 
this error never occurs.

Possible error messages during execution of 
driver:

“Application program passed a buffer too small 
to device saxad0”

STATUS_BUFFER_TOO_SMALL           Bug 
in GADDS.EXE - report it!

“Application program passed an invalid parame-
ter to device saxad0”

STATUS_INVALID_PARAMETER          
Bug in GADDS.EXE - report it!

13.12.1 Registry Keys (Optional)

DebugLevel:

[0] Determines which additional debug mes-
sages are sent to the Event Log. Range is 0 
to 5.

0. Normal warning and error messages only.

1. Above plus driver load and unload mes-
sages.

2. Above plus device I/O messages.

3. Above plus data collection messages.

4. Above plus dispatch control messages.

5. Above plus data collection polling mes-
sages. (May overflow queue).

PortIOAddress:

[340 hex] Port IO Address of SAXAD Inter-
face Card.

MaxFrameSize:

[1024] Valid values are 512 or 1024.

Orientation:

[0] Defines the mounting orientation of the 
HISTAR detector.

0.  +x, +y, The default.

1.  +x, -y, Useless.

2.  -x, +y, Useless.

3.  -x,-y, Rotated 180 CW

4.  +y, +x, Useless.

5.  +y, -x, Rotated 270 CW.

6.  -y, +x, Rotated 90 CW

7.  -y, -x., Useless.



GADDS Software Reference Manual Utility Programs

M86-E01008 13 - 23

13.13 SaxHelp • Bruker help topic 
display utility

NOTE: This program is now obsolete. Bruker 
now supplies help files in either Windows help 
file format or Acrobat PDF file format.

SaxHelp is used to display the Bruker help topic 
files: *._tp.

13.14 ToSAXII • Convert PCS 
XENGEN format frames to new 
SAXII format

The new SAXII format for data frames 
addresses the issues of data portability, speed 
of image I/O and display, and storage of all the 
data acquisition conditions required to reduce 
the data. Header and overflow information are 
stored in portable ASCII rather than binary—
critical data such as setting angles can thus be 
stored portably as floating point values. The 
pixel values themselves are necessarily binary, 
but are assured to start on a 512-byte boundary 
and are stored a a byte stream without delimit-
ers of any kind. This format is completely trans-
portable between a VAX and X-1000 frame 
buffer over the network.

Older PCS computers used a XENGEN format 
for data frames. These files can be converted to 
the newer SAXII format using TOSAXII. The 
user will be prompted for any missing header 
information. Example session follows:

=> TOSAXII

Under DOS, UNIX, or VMS, the command 
tosaxii runs the program, which prompts you for 
the following additional information. Default val-
ues are displayed in square brackets after the 
prompt. Pressing the <ENTER> key (<Return> 
key on VAX) is the same as entering this default.

INPUT FILENAME ? 
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Enter the name of the input XENGEN format 
frame. You must give the full pathname. 
TOSAXII does not merge filenames with 
GADDS's or VGADDS's current frame directory; 
however, TOSAXII does translate logical names 
under DOS, VMS or UNIX.

INPUT .UPR FILENAME (BLANK IF NONE) ?

If you want to insert orientation information 
determined by XENGEN's REFINE program into 
the output frame header, supply the full path-
name of the XENGEN parameter file. See the 
discussion above for more information. Other-
wise, press the <ENTER> key without supplying 
a filename (<Return> key on VAX). GADDS 
users will simply press <ENTER>.

INPUT .UCA FILENAME (BLANK IF NONE) ?

If you have a .uca (“spline”) spatial calibration 
file from XENGEN, TOSAXII will obtain the 
beam center coordinates from it. Supply the full 
pathname here, otherwise press <ENTER> 
without supplying a filename, and TOSAXII will 
explicitly prompt for the beam center coordi-
nates with the prompts:

BEAM X CENTER (XENGEN COORDS) ?

BEAM Y CENTER (XENGEN COORDS) ?

Supply the coordinates of the direct beam at 
swing angle of zero, in the XENGEN convention 
(0,0 at upper right in a frame displayed with 
GADDS or VGADDS).

OUTPUT FILENAME ?

Enter the full pathname to give the output data 
frame.

OUTPUT FRAME TITLE ?

The text you supply here is written to the output 
SAXII frame header in the first title record, and 
will be shown (truncated to 20 characters) on 
the screen when you display the output frame.

SAMPLE-DETECTOR DISTANCE IN CM 
(.LE.0 TO USE CURRENT)

If you want to override the detector distance that 
exists in the input frame header, enter the new 
value here, otherwise just press <ENTER>.

SWING ANGLE, DEG (9999. TO USE CUR-
RENT)

If you want to override the detector swing angle 
that exists in the input frame header, enter the 
new value here, otherwise just press <ENTER>.
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A.  Area Detector Frame Format

The Bruker format addresses issues of data 
portability, speed of image I/O and display, and 
storage of all the data acquisition conditions 
required to reduce the data. Header and over-
flow information are stored in portable ASCII, 
rather than binary. Critical data, such as setting 
angles, can thus be stored portably as formatted 
floating-point values. The pixel values them-
selves are binary, but they are assured to start 
on a 512-byte boundary for quick, easy access 
(using Byte IO routines), and they are stored as 
a byte stream without delimiters of any kind.This 
format is completely transportable between all 
computers and networks, including PCs, NT 
workstations, and SGI systems. The only coding 
difference on these systems is that big-endian 
systems such as SGI must byte-swap the pixel 
values in the (relatively rare) case where it 
encounters a 16-bit frame.

Up to 32 bits/pixel are supported, although 
frames are stored where possible as 8 or 16 bits 
per pixel with an overflow table like that on ear-
lier systems (but this overflow table is ASCII, as 
described below). BYTE ORDER OF PIXEL 
VALUES IN FRAMES WHICH ARE STORED IN 
THIS FORMAT ON DISK, TAPE, ETC. IS 
ALWAYS “LITTLE-ENDIAN” (LSB first, even 
though the header contains a flag indicating the 
pixel byte ordering). Bruker does not support 
big-endian frames that otherwise look like this 
format. The 16-bit format is fully implemented. If 
more than 4096 overflows occur on attempted 
compression to 8 bits, the frame buffer will com-
press to 16 bits with an overflow table (the 
GADDS HI-STAR and SMART CCD frame buff-
ers accumulate 32 bits/pixel internally).
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At the top level, a frame in Bruker format can be 
represented as:

Header
Image data
Overflow table
Trailer 1
.
.
.
Trailer N

A.1 Header

The header is 1) typeable ASCII and 2) an even 
multiple of the 512-byte disk block size. Each 
entry in the header is an 80-byte unterminated 
ASCII line. Thus, the header size is always a 
multiple of 5 disk blocks to hold an integral num-
ber of lines. The first eight characters of each 
item contain the item name, with the remaining 
72 characters for ASCII data. Thus, the organi-
zation of the header can be represented as:

HEADER
Item_name1 (8 char): Item_Data1 (72 chars)
Item_name2 (8 char): Item_Data2 (72 chars)
.
.
.
Item_nameN (8 char): Item_DataN (72 chars)

This organization has several advantages. First, 
fast random access can be performed on the 
header to pull out or rewrite an individual entry. 
During random access, the item names provide 
a method for checking for corruption of the 
header block.

Second, frames are actually TYPEable on both 
PCs and workstations if the screen wraps at 80 
columns. The padding to a multiple of 5 disk 
blocks contains ASCII dot characters. The last 
characters of the padding are a CTRL+Z and a 
CTRL+D. This convention provides a “warning 
indicator” on a workstation during which a 
CTRL+S or CTRL+C can be issued, before the 
binary pixel values start to appear. On a PC, an 



GADDS Software Reference Manual Area Detector Frame Format

M86-E01008 A - 3

MS-DOS TYPE command stops when it hits the 
CTRL+Z. Presence of the item names makes 
the output easily interpretable.

Third, the format is highly portable, because dif-
ferent byte and word ordering conventions don't 
enter into the interpretation of ASCII data. Items 
currently contained in the header are listed 
below in positional order. The format is expand-
able. New information to be added to the header 
will always be added at the end. A version num-
ber is present at the start of the header so pro-
grams can deal with new header information. 
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The header items are:

Mnemonic Offset Version Type Description

FORMAT: 0 1 Int Frame format. Always “86” for Bruker-format frames or 100 for 
New Bruker format frames.

VERSION: 1 1 Int Header version #, such as 1, 2, 3, 4, 5, 7, 8, 9, 10, or 11.

HDRBLKS: 2 1 Int Header size in 512-byte blocks, such as 10 or 15.

TYPE: 3 1 C String indicating king of data in the frame. Valid primary types 
are:
DEFAULT
Add frame
Rotation frame
SCAN FRAME
UNWARPED
UNWARPED LINEAR
FIDUCIAL PLATE
FLOOD FRAMES
FLOOD TABLE
BACKGROUND
<A> & <B> COMBINATION
POLE FIGURE, [POLAR | STEREO | WULFF]
STRESS, SCHEME

Sometimes the primary type is appended with
CALIBRATED
FIBER
LPA
MULT_FF
PLATE
SMOOTHED

Pole figure type may be appended with:
INTERPOLATED
INVERTED
NORMED
ROTATED
SCHEME
SYMMETRIZED
TILTED
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SITE: 4 1 C Site name, from Edit > Configure > User settings

MODEL: 5 1 C Diffractometer model, from SAXI$ADMODEL

USER: 6 1 C Username, from Edit > Configure > User settings

SAMPLE: 7 1 C Sample ID, from Project > New/Edit

SETNAME: 8 1 C Basic data set name

RUN: 9 1 Int Run number within the data set

SAMPNUM: 10 1 Int Specimen number within the data set

TITLE: 11–18 1 C User comments (8 lines)

NCOUNTS: 19 1,9 Int Total frame counts (followed by reference counts in Ver 9).
9: Adds direct-beam monitor counts to NCOUNTS line

NOVERFL: 20 1 Int Number of overflows

MINIMUM: 21 1 Int Minimum counts in a pixel

MAXIMUM: 22 1 Int Maximum counts in a pixel

NONTIME: 23 1 Int Number of on-time events

NLATE: 24 1 Int Number of late events.

FILENAM: 25 1 C (Original) frame filename

CREATED: 26 1 C Date and time of creation

CUMULAT: 27 1 R Accumulated exposure time in seconds

ELAPSDR: 28 1 R Requested time for last exposure in seconds

ELAPSDA: 29 1 R Actual time for last exposure in seconds

OSCILLA: 30 1 Int Nonzero if acquired by oscillation

NSTEPS: 31 1 Int # steps or oscillations in this frame

RANGE: 32 1 R Scan range in decimal degrees (unsigned)

START: 33 1 R Starting scan angle value, decimal degrees

INCREME: 34 1 R Scan angle increment between frames (signed)

NUMBER: 35 1 Int Sequence number of this frame in series (@0)

NFRAMES: 36 1 Int Total number of frames in the series

ANGLES: 37 1 4R Diffractometer angles (2T, OM, PH, CH)

NOVER64: 38 1 Int Number of pixels > 64K
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NPIXELB: 39 1 Int Number of bytes/pixel, such as 1, 2, or 4.

NROWS: 40 1 Int Number of rasters in frame, such as 512, 1024, or 2048.

NCOLS: 41 1 Int Number of pixels/raster, such as 512, 1024, or 2048

WORDORD: 42 1 Int Order of bytes in word (0=LSB first)

LONGORD: 43 1 Int Order of words in a longword (0=LSW first)

TARGET: 44 1 C X-ray target material: Cu, Mo, Ag, Fe, Cr, Co, or other.

SOURCEK: 45 1 R X-ray source kV

SOURCEM: 46 1 R X-ray source milliamps

FILTER: 47 1 C Filter/monochromator setting: Such as:
Parallel, graphite
Ni Filter
C Filter
Zr Filter
Cross coupled Goebel Mirrors

CELL: 48–49 1 6R Unit cell A,B,C,ALPHA,BETA,GAMMA

MATRIX: 50–51 1 9R Orientation matrix (P3 conventions)

LOWTEMP: 52 1,8,9 1: Int
8: Int,3R

9: 3Int

Low temp flag. Note: Version 8 and 9 headers diverge.
8: Add sub-mnemonic TEMP: Adds set point K, ramp rate deg/
min, hold time sec
9: Adds experimental temperature in hundredths C and CCD 
sensor temperature in hundredths C

ZOOM: 53 1 3R Zoom: Xc, Yc, Mag

CENTER: 54 1 2R X, Y of direct beam at 2-theta = 0

DISTANC: 55 1 R Sample-detector distance, cm

TRAILER: 56 1 Int Byte pointer to trailer info

COMPRES: 57 1 C Compression scheme ID, if any. Such as: NONE

LINEAR: 58 1 C Linear scale, offset for pixel values, typically 1.0, 0.0.

PHD: 59 1 2R Discriminator: Pulse height settings

PREAMP: 60 1 R Preamp gain setting

CORRECT: 61 1 C Flood table correction filename

WARPFIL: 62 1 C Brass plate correction filename
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WAVELEN: 63 1, 8 3R
8+: 4R

Wavelengths (average, a1, a2)
8+: Adds beta wavelength.

MAXXY: 64 2 2R X,Y pixel # of maximum counts

AXIS: 65 3 Int Scan axis (1–4 for 2-theta, omega, phi, chi) Default is 2.

ENDING: 66 3 4R Actual goniometer angles at end of frame

DETPAR: 67–68 4 6R Detector position corrections (dX,dY,dDist,Pitch,Roll,Yaw)

LUT: 69 4 C Recommended display lookup table

DISPLIM: 70 4 2R Recommended display limits

PROGRAM: 71 4 C Name and version of program writing frame, such as:
GADDS for WNT  V4.0.07

ROTATE: 72 5 Int Nonzero if acquired by rotation of phi during scan

BITMASK: 73 5 C File name of active pixel mask associated with this frame or 
$NULL

OCTMASK: 74–75 5 8Int Octagon mask parameters to use if BITMASK=$null

ESDCELL: 76–77 7 6R Unit cell parameter standard deviations
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DETTYPE: 78 7

8

C

8+: C, 2R

Detector type
MULTIWIRE (default)
CCD-PXL (small CCD)
CCD-PXL-2K (Large CCD)
CCD-PXL-ARR (Mosaic)
CCD-PXL-L6000
CCD-PXL-KAF1500
UNKNOWN (imported)
OTHER (imported)
Version 8+: Added sub-mnemonics PIXPERCM: and CMTO-
GRID: which are needed for UNKNOWN or OTHER types. If 
these values are missing, the defaults are:
DETTYPE:PIXPERCM:CMTOGRID:
------------------------------------------------
MULTIWIRE47.52.0
CCD-PXL-2K56.020.8
CCD-PXL-ARR32.000.4
CCD-PXL-KAF150051.20.8
CCD-PXL-L6000N56.020.8
CCD-PXL-L6000F56.020.8
CCD-PXL-L6500  32.001.5
CCD-PXL-KAF281.920.8
CCD-PXL-KAF     81.920.8
CCD-PXL-MSPD   81.920.8
CCD-PXL    81.920.8
CCD-PXL-LDI      83.3330.0
CCD-MMXImported frames must ask for settings.
UNKNOWN Imported frames must ask for settings.
OTHER       Imported frames must ask for settings.

NEXP: 79 7,9,10 7: Int
9: 2Int
10:3Int

Number of exposures:  1=single, 2=correlated sum
(followed by fixed bias ADU in Vers 9).
9: Adds per-exposure bias level in ADU to NEXP line
10: Adds baseline offset (normally 32),  Adds Orientation (value 
of SAXI$INVERTCCD), Adds Overscan flag (1 if overscan 
used)

CCDPARM: 80 7 5R CCD parameters: readnoise, e/ADU, e/photon, bias, full scale

CHEM: 81 7 C Chemical formula in CIFTAB string, such as “?”

MORPH: 82 7 C Crystal morphology in CIFTAB string, such as “?”
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NOTE: Items in version 6 headers are obsolete 
(MICRODIF). Use FRMFIX to convert these 
frame headers to version 8.

NOTE: Version 5 and 8 items are mainly for 
GADDS.

NOTE: Version 7 and 9 items are mainly for 
SMART.

NOTE: Version 9 and 10 items do not add addi-
tional lines to the header, but instead append 
additional values to a previously existing line.

CCOLOR: 83 7 C Crystal color in CIFTAB string, such as “?”

CSIZE: 84 7 C Crystal dimensions (3 ea) in CIFTAB string, such as “?”

DNSMET: 85 7 C Density measurement method in CIFTAB string, such as “?”

DARK: 86 7 C Name of dark current correction

AUTORNG: 87 7 5R Auto-ranging: gain, high-speed time, scale, offset, full scale

ZEROADJ: 88 7 4R Goniometer zero corrections (refined in least squares)

XTRANS: 89 7 3R Crystal XYZ translations (refined in least squares)

HKL&XY: 90 8 5R HKL and pixel XY for reciprocal space scan

AXES2: 91 8 4R Diffractometer setting linear axes (4 ea). (X, Y, Z, Aux)

ENDING2: 92 8 4R Actual goniometer linear axes @ end of frame. (X, Y, Z, Aux)

93

94

95
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A.2 Image Data

The image data is a simple byte stream (no 
record delimiters) with one, two, or four bytes 
per pixel, as defined in the header. If the data 
are two bytes per pixel, the least-significant byte 
is first.

The order of the pixels in the file corresponds to 
the display of pixels on a screen, like the raster-
scan order of a CRT display. The first pixel in the 
file corresponds to the upper-left corner of the 
display, the 512th to the upper right, and the last 
pixel to the lower right. This data ordering con-
vention is the one used by most display devices 
and by the X-Windows library. Frames display 
as if viewed from the source toward the detector. 

A.3 Overflow Table

The overflow table is stored as ASCII values. 
Each overflow entry is 16 characters, compris-
ing a 9-character intensity and a 7-character 
pixel # offset. The table is padded to a multiple 
of 512 bytes. In an 8-bit frame, any pixel with a 
value of 255 in the image needs to be looked up 
in the overflow table to determine its true value 
(even if the true value is 255, to allow overflow 
table validity checks, which could not otherwise 
be made). In a similar manner, any pixel in a 16-
bit frame with a value of 65535 must be looked 
up in the overflow table to determine its true 
value. To look up a pixel value, compute its pixel 
displacement (for example, in a 512x512 frame, 
512*j + k, where j is the zero-based row number 
and k is the zero-based column number), and 
compare the displacement with that of each 
overflow table entry until a match is found. While 
the overflow table is normally sorted on dis-
placement, it is not guaranteed to be sorted, so 
we recommend that you search the whole table 
until you find a match.
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A.4 Trailers

The header contains a byte pointer (item name 
“TRAILER,” set to zero if none) to the location in 
the file of any “trailer” data that has been tacked 
onto the image. This provision won't be used 
immediately, but provides later expansion capa-
bility. For example, if a frame is derived from 
processing some other (parent) frame, the 
header of the parent could be tacked onto the 
processed frame as a trailer to provide process-
ing history. The format of a trailer is:

TRAILER

Trailer size in 512-byte blocks (1 byte)

3-byte pad

Trailer data
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B.  DIFFRACplus Raw Data File Format

The general format of a RAW file is a general file 
header of 712-bytes, followed by a variable 
length range header, which in turn is followed by 
the range's data records. Range header and 
data records are repeated for all defined ranges.

RAW_HEADER: 712-bytes of information that 
starts every RAW file. This is identical to 
DIF_HEADER structure, except for the initial ID 
code.

Offset Code Description

0 C8 ASCIIZ: “RAW1.01” for the 2. release 
[@2]

     “RAW1.00” for the 1. release

     Note: “RAW2” and “RAW” are
     DIFFRAC-AT

8 I4 current file status:

     0  = unmeasured

     1  = measured

     2  = active

     3  = aborted

     4  = interrupted

     10 = simulated data [@2]

12 I4 total number of measured ranges

16 C10 ASCIIZ [@2], in mm/dd/yy format, e.g. 
“12/31/95”

26 C10 ASCIIZ [@2], in 24 hours format, e.g. 
“18:34:04”

36 C72 ASCIIZ [@2], username ( operator ) or 
“Unknown” or “\0”

108 C218 ASCIIZ [@2], company name, etc. or 
“Unknown” or “\0”

326 C60 ASCIIZ [@2], sample identification

386 C160 ASCIIZ [@2], comment

546 C2 2-bytes of padding for alignment

548 I4 goniometer model: 

     0  = Theta/2-Theta D5000

     1  = Theta/Theta D5000

     2  = D5000-matic
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     3  = AL/Theta-D5000

     4  = GADDS/FRAMBO [@2]

     5  = SAXS [@2]

     6  = SMART [@2]

     7,8,9 = reserved

     10 = Theta/2-Theta D5005

     11 = Theta/Theta D5005

     12 = reserved

     13 = AL/Theta D5005

     20 = Theta/2-Theta other

     21 = Theta/Theta other

     22 = Matic other

     23 = AL/Theta other

     9999 = unknown

552 I4 goniometer stage:

     0  = Standard

     1  = Synchron. rotation

     2  = Rotation reflection

     3  = Rotation transmission

     4  = Open cradle

     5  = Closed cradle

     6  = Phi

     7  = Chi

     8  = XYZ

     9  = Low temp.

     10 = High temp.

     11 = External temp.

     12 = Other

     16 = Phi stage at fixed chi [@2]

     17 = 4-circle [@2]

     18 = Small XYZ stage [@2]

     19 = Large XYZ stage [@2]

     20 = 1/4-circle [@2]

     9999 = unknown

556 I4 sample changer:

     0  = None

     1  = 40-position

     2  = Y-matic

     3  = X/Y-matic

     9999 = unknown

560 I4 goniometer controller

     0  = STD only

     1  = STD+TC

     2  = STD+FDC

     3  = STD+FDC+TC

     16 = GGCS [@2]

     9999 = unknown

564 R4 goniometer radius in mm.

     9999.0 = unknown, 0.0 = unknown
     [@2]

568 R4 diverg.slit fix incidence in degrees, 
9999.0 = unknown

572 R4 sample slit fix incidence in degrees, 
9999.0 = unknown

576 I4 primary soller slit: 

     0 = not present

     1 = present

     1 = 2 deg (@2.1)

     2 = 4 deg (@2.1)
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     3 = other (@2.1)

     9999 = unknown

580 I4 primary monochromator:

     0  = None

     1  = Transmission

     2  = Reflection

     3  = Ge220 2-bounce

     4  = Ge220 4-bounce

     5  = Ge440 4-bounce

     6  = Flat graphite (@2.1)

     7  = Single Goebel mirror (@2.1)

     8  = Crossed Goebel mirror (@2.1)

     9  = Flat Germanium 111 (@2.1)

     10 = Flat Silicon 111 (@2.1)

     9999 = unknown

584 R4 anti slit diffracted side in degrees, 
9999.0 = unknown

588 R4 detector slit diffr. side in degrees, 
9999.0 = unknown

592 I4 secondary soller slit:

     0  = not present

     1  = present

     1  = 2 deg (@2.1)

     2  = 4 deg (@2.1)

     3  = other (@2.1)

     9999 = unknown

596 I4 thin film:

     0  = not present

     1  = present

     1  = 0.4 deg (@2.1)

     2  = 0.15 deg (@2.1)

     3  = 0.08 deg (@2.1)

     9999 = unknown

600 I4 beta filter ( Yes=1, No=0 ), 9999 = 
unknown

604 I4 secondary monochromator:

     0  = None

     1  = graphite

     2  = LiF

     3  = Ge220 channel cut

     4  = Goebel mirror

     9999 = unknown

608 C4 ASCIIZ [@2], Anode material e.g. “Cu”

612 C4 4-bytes of padding for alignment

616 R8 average wavelength in A (Obs. or nm)
(i.e. (Ka1+Ka2+R21)/(1+R21))

624 R8 primary wavelength in A (Obs. or nm)
(i.e. Ka1)

632 R8 secondary wavelength in A (Obs. or 
nm) (i.e. Ka2)

640 R8 tertiary wavelength in A (Obs. or nm) 
(i.e. KB)

648 R8 intensity ratio of secondary to primary 
wavelength

656 C4 wavelength unit name: [@2] now 
always “A”

(obs) in “RAW1.00” files both “A” or 
“nm” were used.

660 R4 intensity ratio of tertiary to primary 
wavelength
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RAW_RANGE_HEADER: 304-bytes of range 
header information that precedes every range in 
a RAW file. Similar to DIF_RANGE_HEADER, 
but DIFFERENT!

664 R4 total sample run time:

     9999.0 = unknown (obs.)

     -1.0 = unknown [@2]

668 C44 reserved for expansion

Offset Code Description

0 I4 always 304, length of primary range 
header in bytes

4 I4 number of measured data

8 R8 theta start in degrees

16 R8 two-theta start in degrees

24 R8 chi start in degrees, use 9999.0 if not 
present or unknown

32 R8 phi start in degrees, use 9999.0 if not 
present or unknown

40 R8 x start in mm., use 9999.0 if not 
present or unknown

48 R8 y start in mm., use 9999.0 if not 
present or unknown

56 R8 z start in mm., use 9999.0 if not 
present or unknown

Note: may use actual values for fixed 
axes

64 R8 div.slit start in degrees if divslit_code 
== “fix”

(9999.0 if not present)

72 C8 div.slit code ASCIIZ: “V20”, “V6”, “V4”, 
“V2”, “fix”

“V#” where # = sample illumination in 
mm

or “Unkn” for unknown

or “fix” for fixed

80 R8 anti.slit start in degrees if antislit_code 
= “fix”

(9999.0 if not present)

88 C8 anti.slit code ASCIIZ: “V20”, “V6”, 
“V4”, “V2”, “fix”

“V#” where # = sample illumination in 
mm

or “Unkn” for unknown

or “fix” for fixed

96 I4 [@2] detector used for this range

(obs.) detector code for detector #1

     0  = none (now invalid value [@2])

     1  = Scintillation

     2  = Proportional

     3  = Solid State

     4  = Other

     5  = PSD,

     16 = X-1000 [@2]

     17 = Hi-Star [@2]

     18 = CCD [@2]

     19 = Large CCD [@2]

     20 = Mosaic CCD [@2]

     9999 = unknown

100 R4 [@2] highvoltage used in V, 9999.0 for 
unknown

(obs) highvoltage in V of detector #1, 
9999.0 for unknown
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104 R4 [@2] amplifier gain used in ??, 9999.0 
for unknown

(obs) amplifier gain in ?? of detector 
#1, 9999.0 for unknown

108 R4 [@2] lower level used in V, 9999.0 for 
unknown

(obs) lower level in V of detector #1, 
9999.0 for unknown

112 R4 [@2] upper level used in V, 9999.0 for 
unknown

(obs) upper level in V of detector #1, 
9999.0 for unknown

116 I4 [@2] measuring channel: 1 or 2

(obs.) detector code for detector #2

120 R4 [@2] unused field

(obs.) highvoltage in V of detector #2, 
9999.0 for unknown

124 R4 [@2] unused field

(obs.) amplifier gain in ? of detector 
#2, 9999.0 for unknown

128 R4 [@2] alternate LLD as fraction of 
channel full scale

(obs.) Lower level in V of det. #2, 
9999.0 for unknown

132 R4 [@2] alternate ULD as fraction of 
channel full scale

(obs.) Upper level in V of det. #2, 
9999.0 for unknown

136 C8 ASCIIZ: “IN” or “OUT”, (“nc” if not 
present), “Unkn” for unknown

144 R8 start of aux. axis 1 (up to now 0.0 ) 
(i.e. h of hkl scan)

152 R8 start of aux. axis 2 (up to now 0.0 ) 
(i.e. k of hkl scan)

160 R8 start of aux. axis 3 (up to now 0.0 ) 
(i.e. l of hkl scan)

(i.e. psi of psi scans)

168 I4 scan mode: step “SS” = 0 or continu-
ous “SC” = 1

172 C4 4-bytes of padding for alignment

176 R8 step size: increment of 1st scan axis in 
drive units

184 R8 step size: increment of 2nd scan axis 
in drive units: 0.0

192 R4 step time in seconds: 1.0 if unknown 
[@2]

196 I4 scan type

     0  = locked coupled

     1  = unlocked coupled

     2  = 2theta scan | detector scan

     3  = omega scan | rocking curve

     4  = chi scan

     5  = phi scan

     6  = x scan

     7  = y scan

     8  = z scan

     9  = aux1 scan [@2]

     10 = aux2 scan [@2]

     11 = aux3 scan [@2]

     12 = psi scan [@2]

     13 = hkl scan [@2]

     14 = reciprocal space scan [@2.1]
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     129 = PSD fixed scan [@2]

     130 = PSD fast scan [@2]

     257 = pixel s can (SAXS v4.X) [@2]

200 R4 delay time before a measurement was 
started in seconds.

(obs.) 9999.0 = unknown, [@2] -1.0 = 
unknown

204 R4 the time the range was started relative 
to the time when the

sample was started in sec. (obs.) 
9999.0 = unknown

[@2] -1.0 = unknown

208 R4 rotation speed in rps ( 0.0 = no rota-
tion )

212 R4 temperature in K (-1.0 for room)

216 R4 heating/cooling rate of the TC in K/s

220 R4 delay in sec. before measurement if 
TC, -1.0 for unknown [@2]

224 I4 generator voltage kV or 
9999=unknown

228 I4 generator current mA or 
9999=unknown

232 I4 display plane number, needed for 3D 
display

236 C4 4-bytes of padding for alignment

240 R8 actually selected wavelength in A

248 I4 currently 0, but reserved for varying 
multiple scan parameters

during a single scan in a non-standard 
fashion:

     two_theta -> bit 0

     theta     -> bit 1

     chi       -> bit 2

     phi       -> bit 3

     x         -> bit 4

     y         -> bit 5

     z         -> bit 6

     aux1      -> bit 7

     aux2      -> bit 8

     aux3      -> bit 9

     time      -> bit 10

     temp      -> bit 11

     e.g. chi and phi = 2**2 + 2**3 = 12

252 I4 length of each data record in bytes: 
currently 4 ( float );

but if the varying parameters are not 
0, the data record length

is 4 + 8 * number of bits set in above 
varying parameter flag

e.g. chi and phi vary ==> data record 
length = 8+8+4 = 20

256 I4 total size of all supplementary range 
header records.

if there are no extra defined records, 
this value is 0.

260 R4 [@2] smoothing width in degrees 
0.0 = not smoothed

264 I4 [@2] flagword for simulated meas. 
condition

     bit 0->simulate a different slit option

     bit 1->variable slits are simulated

     Thus the valid settings are:

     00=no data manipulation
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RAW SUPPLEMENTARY RANGE HEADERS: 
Each supplementary range header record is 
composed of a variable number of bytes. The 
total number of supplementary range header 
bytes is store in offset 256 of the range header. 
A value of 0 indicates that there are no supple-
mentary range headers. The currently defined 
supplementary range header records are listed 
below:

     01=converted to fixed slits from
      var.

     10=no data manipulation

     11=converted to var. slits from
      fixed

268 C4 [@2] 4-bytes of padding for alignment

272 R4 [@2] step size: increment of 3rd scan 
axis: 0.0

280 C24 reserved for expansion

Offset Code Description for Oscillation 
record

0 I4 record type: 100 = oscillation parame-
ters

4 I4 record length: 40-bytes

8 I4 oscillation drive:

     0  = tube

     1  = sample

     2  = detector

     3  = chi

     4  = phi

     5  = x

     6  = y

     7  = z

12 C4 4-bytes of padding for alignment

16 R8 oscillation amplitude in degrees or mm

24 R4 oscillation speed in degrees or mm 
per sec.

28 C12 reserved for expansion

Offset Code Description for PSD record

0 I4 record type: 110 = PSD parameters

4 I4 record length: 40-bytes

8 R8 actual two theta of goniometer in deg

16 I4 first channel used

20 C20 reserved for expansion

Offset Code Description for Optimized 
Quantitative Measurement 
record

0 I4 record type: 120 = OQM parameters

4 I4 record length: 72-bytes

?? undefined at this time
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Offset Code Description for Quantitative 
Compound Indicator record

0 I4 record type: 130 = QCI parameters 
(obsolete)

4 I4 record length: variable number of 
bytes

8 I4 variable type: 0=peak; 1= low back-
ground; 2= high background

12 C?? ASCII: compound name

16 C12 reserved for expansion

Offset Code Description for Comment 
record

0 I4 record type: 140 = comment

4 I4 record length: variable number of 
bytes

8 C?? ASCII: comment, stored without null 
termination

Offset Code Description for Removed Data 
record

0 I4 record type: 150 = removed data for 
search

4 I4 record length: 32-bytes

8 R4 excluded 2-theta start in degrees

12 R4 excluded 2-theta end in degrees

16 I4 (obs.) number of points in this part

20 C12 reserved for expansion

Offset Code Description for Offset Assigned 
by EVA record

0 I4 record type: 190 = offset assigned by 
EVA

4 I4 record length: 32-bytes

8 R4 2-theta offset in degrees

12 R4 intensity offset in % of max

16 C16 reserved for expansion

Offset Code Description for Area Detector 
Parameters record [@2]

0 I4 record type: 200 = area detector 
parameters

4 I4 record length: 72-bytes

8 C8 reserved

16 R4 integration range: 2T start

20 R4 integration range: 2T end

24 R4 integration range: chi start or chi angle

28 R4 integration range: chi end or height + 
1000.0

32 I4 normalization method: 1=avg, 2=arc 
length, 3=solid angle, 4=bin

36 C20 program name: i.e. “GADDS-NT ver 
3.301”

56 R4 actual 2theta of goniometer

60 R4 actual omega of goniometer

64 R4 actual phi of goniometer

68 R4 actual chi goniometer
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RAW_DATA: The data records immediately fol-
low the range header (and supplementary range 
headers, if any). The data is stored as counts in 
R4 format. Should non-standard varying param-
eters be used, then each data record is com-
prised of the counts in a R4 field, followed by 
several R8 fields.

Codes used are:

I2 = 16-bit integer, I4 = 32-bit integer

R4 = 32-bit real, R8 = 64-bit real

Cn = ASCII character string of n bytes, no 
null character.

Cn = ASCIIZ character string of n bytes, 
ends in null character.

[@2] = new field or value for “RAW1.01” version 
files.

(obs) = obsolete field or value for “RAW1.00” 
version files.
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C.  DIFFRAC-AT Raw Data File Format

Diffrac-AT V1 raw data files are stored in a direct 
access, binary file without any record delimina-
tors.

Record Format Field description

1 A4 “RAW” File identification text

2 I4 Number of steps for this range 
(1–32767)

3 R4 Measurement time per step 
(.1–999.0)

4 R4 Step size for this range in 
degrees

5 I4 Flag word in DACO-MP format, 
meaningful bits are:

     1024 = theta fixed

     2048 = continuous scan

     8192 = 2theta fixed (rocking
     curve)

     16384 = chi range

     16384 + 8192 = phi range

6 I4 Sample number in sample 
changer, 0=manual insertion

7 R4 Two-theta start in degrees, 
-1E6=unknown

8 R4 Theta start, -1E6=unknown

9 R4 Chi start, -1E6=unknown

10 R4 Phi start, -1E6=unknown

11–18 8A4 Sample name (32 characters)

19 R4 K alpha 1 wavelength

20 R4 K alpha 2 wavelength, 0.0 if 
monochromator used

21–38 -- Unused

39 I4 Number of ranges following this 
range, 0=single range

40–39+x xR4 Data in raw counts, not counts/
second.

 where x = number of steps in range
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Additional ranges use this same format and are 
appended to the end of the first range.

NOTE: Early Diffrac-AT raw data files did not 
repeat the “RAW” on additional ranges.

Profile *.PRO File Format (identical to Diffrac-AT 
V1 with these changes).

Diffrac-AT V2/V3 raw data files are stored in a 
direct access, binary file without any record 
deliminators. The structure starts with a 256-
byte file header block, followed by a range 
header and data block, which are repeated for 
each range in the file.

Record Format Field description

1 A4 “PRO” instead of “RAW”

29 R4 Two-theta of Imax in profile

30 R4 FWHM of profile

31 R4 Offset of peak angle position 
from the Imax position in profile

Offset Format Field description

0 A4 “RAW2” File identification text

4 I2 Number of ranges in this file

6 ?2 Unused

8 A32 Sample base name

40 A128 Sample extended name /comments

168 A20 Date/time measured: 07-Jun-1995 
18:20:00

188 A2 Chemical symbol for tube anode

190 3R4 Lambda1, Lambda2, Intensity ratio

202 I2 Diffractometer code (0=2th/th, 
-1=th/th)

204 I2 Diffractometer configuration word

206 R4 Lambda 3 or K beta wavelength

210 R4 Total sample run time in seconds

214 R8 Date/time measured in Lotus123 for-
mat

222 ?34 Unused

Offset Format Field description

0 I2 Total number of bytes in range 
header

2 I2 Step count for this range

4 I2 Stepping drive ID: 1–6 drive 1 to 6

8 = PSD fixed position; 9 = PSD fast 
scan; 10 = drives 1 and 2

6 I2 Step mode:

     bit 0 = step scan mode 
    1:continuous;

     bit 1 = calibration indicator

8 R4 Step time: time per step (in sec-
onds)

12 R4 Step size for range

16 6R4 Starting axes position for range

40 I2 Slit I position: 32767=FA1, 
32766=FA2

42 I2 Slit II position: 32767=FA1, 
32766=FA2

44 I2 Detector slit: 0=fine, 1=coarse

46 I2 Temperature in Kelvin: -1=room
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48 I2 Oscillating drive: 0 = none, 1–6 = 
drives 1 to 6, 7 = spinner

     10,11 = 1 and 2 coupled +,-

50 R4 Oscillation amplitude: 999=mechan-
ically fixed

54 R4 Oscillation speed

58 I2 Rotation code: 0 = none, 1–4 = 
15–120 rpm, 5 = sync, 6 = SC

60 ... Variable supplementary information 
records

60+x nR4 Raw data, counts, 4 bytes per step
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D.  PLOTSO Raw Data File Format

The PLOTSO Raw Data File Format is a subset 
of the general PLOTSO data file format (see 
PLOTSO, Section 13.7). The general format is 
an ASCII header, followed by an ASCII table of 
data. Range and data records are repeated for 
all defined ranges.

!@!!GADDS PLOTSO FILE: [Chi | R.C. | 2th 
| Rect | Pixel | ????] integration type

Identified file as PLOTSO RAW file.

!@!!Title: string

Sample title.

!@!!Comment:: string

General comment such as original frame file 
name.

!@!!Wavelengths: Kavg, Ka1, Ka2, Beta

Wavelengths.

!@!!Integration range: 2Theta: X to X   
Gamma: X to X
!@!!Integration range: 2Theta: X to X   
Gamma: X   Width: X

Area detector integration region.

!@!!Integration method: pixel summation | aver-
age pixel | normalized by arc length | normalized 
by solid angle | bin summation | bin normalized | 
interpolated | unknown

How data was converted from frame to 
spectra.

!@!N

Specifies that subsequent X,Y points should 
be drawn as a new plot, rather than added 
to the existing set of axes.
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!@!SS

Specifies a line style for a connecting line to 
be drawn between X,Y pairs. Supply one of 
the characters 0,N,S or D as a parameter.  
Line styles are: “!@!S0” or “!@!SN” (for no 
connecting line, for example, for scatter 
plots), “!@!SS”  (for a solid connecting line), 
and “!@!SD” (for a dotted connecting line).

!@!M

Specifies the character to be used as a 
Marker. The Marker Character is plotted at 
each subsequent X,Y point. The marker 
character must immediately follow the direc-
tive (that is, it must be the fifth character on 
the line). Examples are: “!@!M+” (to plot a + 
at each input X,Y position) or “!@!M” (to dis-
able plotting of a character at each X,Y posi-
tion).

!@!L 0.0 0.0 0.0 0.0

Sets plot axis limits, overriding the auto-
scaling normally performed. Requires four 
parameters, Xmin, Ymin, Xmax, Ymax cor-
responding to the lower X, lower Y, upper X, 
and upper Y axis limits, respectively. If both 
the lower and upper limit for an axis are 
specified as zero, autoscaling is restored for 
that axis. The default limits are 0,0,0,0, 
meaning that auto-scaling is performed on 
each axis. When an axis is auto-scaled, a 
“nice” interval for tic marks is determined. 
This interval is always 1, 2 or 5 times some 

power of 10. Limits are then chosen which 
are integer multiples of this interval and 
which contain the range of values input for 
the axis being auto-scaled. An example of 
this directive is: “!@!L0,0,100,0”. (This 
example specifies that the X-axis will range 
from 0 to 100, and the Y will be auto-scaled 
based on the range of the input Y-values.)

!@!XDegrees       

This directive specifies the X-axis label.  
Follow the directive with the text to be drawn 
along the X axis. By default, the text is “X-
AXIS”. For example, if you're plotting a func-
tion versus time, you might issue the direc-
tive  “!@!XTime (seconds)”.

!@!YCounts

This directive specifies the Y-axis label.  Fol-
low the directive with the text to be drawn 
along the Y axis. By default, the text is “Y-
AXIS”. For example, if you're plotting pixel 
values as a function of position, you might 
issue the directive “!@!YPixel Value”. Nor-
mally, Y-axis text is written vertically (but not 
rotated, since some graphic environments, 
most notably X-Windows, don't support 
rotated text);  however, if the text contains 
hyphens or parentheses, it writes the text 
horizontally. In this latter case, you need to 
keep the axis label very short.
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2theta, Intensity data pairs or 2theta, Intensity, 
Q, stderr table.

The actual data spectra.



PLOTSO Raw Data File Format GADDS Software Reference Manual

D - 4 M86-E01008



M86-E01008  E- 1

E.  TEXTURE-AT Raw Data File Format

Texture-AT raw data files are stored in a byte 
stream, binary file without any record delimina-
tors. File extensions are *.rrw for reflection or 
*.trw for transmission.

Table E.1 – Range Header Block

Offset Format Field description

+0 A4 “RAW” File identification text

+4 I4 Number of steps for this range 
(1–32767)

+8 R4 Measurement time per step 
(.1–999.0)

+12 R4 Step size for this range in 
degrees

+16 I4 Flag word in DACO-MP format, 
meaningful bits are:

     1024 = theta fixed

     2048 = continuous scan

     8192 = 2theta fixed (rocking
     curve)

     16384 = chi range

     16384 + 8192 = phi range

+20 I4 Sample number in sample 
changer, 0=manual insertion

+24 R4 Two-theta in degrees

+28 R4 Theta for reflection, 2theta + 
alpha for transmission

+32 R4 Alpha for reflection, Beta start for 
transmission

+36 R4 Beta start for reflection, 0.0 for 
transmission

+40 A32 Sample name (32 characters)

+72 R4 K alpha 1 wavelength

+76 R4 K alpha 2 wavelength, 0.0 if 
monochromator used

+80 4R4 Background information for this 
range

     2theta for low background
     measurement, -1 = none

     2theta for high background
     measurement, -1 = none
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Table E.2 – Data Range Block

Additional ranges use this same format and are 
appended to the end of the first range.

Table E.3 – Measuring Parameters Block (placed as trailer 
block)

     intensity at low 2theta rescaled
    to measuring time per circle

     intensity at high 2theta, 0.0 =
     none

+96 A32 Sample name extension (charac-
ters 33-64 of sample name)

+128 R4 Linear absorption coefficient * 
thickness

+132 I4 Pointer to measuring parameters 
block in this file

+136 I2 Measurement code

     1 = texture-less standard 
     with background

     2 = texture-less standard 
     without background

     3 = unknown sample without
     background

     4 = unknown sample, back-
     ground measured for first chi
     only

     5 = unknown sample, back-
     ground measured at phi=0 for
     all chi's

     6 = unknown sample with full
     background measurements

+138 14X Reserved for future use. Must be 
0

+152 I4 Number of data ranges after this 
one

Offset Format Field description

+156     #R4    Counts, not counts/
sec

Offset Format Field description

+0 8A8 hkl parameters in ASCII for up to 8 
pole figures. Blank=unused.

+64 8R4 2theta values for up to 8 pole fig-
ures. -1E31=unused.

+96 8R4 low background 2theta for up to 8 
pole figures. -1E31=unused.

+128 8R4 high background 2theta for up to 8 
pole figures. -1E31=unused.

+160 R4 alpha start for reflection, 
-1E6=unused.

+164 R4 alpha end for reflection, 
-1E6=unused.

+168 R4 alpha step

+172 R4 beta start

+176 R4 beta end

+180 R4 beta step size

+184 R4 measuring time per step for reflec-
tion, 0.0=unused

+188 R4 alpha start for transmission, 
-1E6=unused.

+192 R4 alph end for transmission, 
-1E6=unused.
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+196 R4 measuring time per circle for back-
ground(s), -1=unused.

+200 4X unused, reserved bytes

+204 R4 x-oscillation amplitude in mm

+208 R4 x-oscillation speed in mm/sec

+212 R4 measuring time per step for trans-
mission, 0.0=unused.

+216 16R4 contour levels, 15 values maxi-
mum, -1=unused, #16 must be -1.

+280 16I2 display colors for contours

+312 16I2 plotter pen colors for contours

+344 R4 CRT aspect ratio, unused

+348 R4 x scale factor of printer, unused

+352 R4 y scale factor of printer, unused

+356 R4 linear absorption of sample

+360 X2 unused

+362 A64 axis label

+426 A64 site label

+490 A64 analytical program comments, i.e. 
‘GADDS v2.0’

+554 A32 name of data file for texture-less 
sample, i.e. correction file

+586 L1 .true. = continuous step scan 
mode

+587 L1 .true. = inverted transmission 
mode

+588 L1 .true. = no reference sample avail-
able/used

+589 I2 actual number of alpha scans in 
file (ignore R and T repeats)

+591 I2 max number of alpha scans = 
1 + 90 /alpha_step

+593 I2 max number of beta steps = 
360 / beta_step

+595 R4 actual alpha start in the file

+599 R4 alpha start / 2 in radians = 
[+595]*PI/360

+603 R4 beta start in radians = 
[+172]*PI/180

+607 R4 delta alpha / 2 in radians = 
[+168]*PI/360

+611 R4 delta beta in radians = 
[+180]*PI/180

+615 I2 actual number of pole figures in 
the file

+617 I2 number of pole figures currently 
selected for display

+619 I2 current display mode

1 = color 3D, 2 = BW 3D, 3 = con-
tours, 4 = maxima, 5 = phi cut

+621 I2 pole figure rotation, degrees as 
integer, normally 0

+623 I2 inclination for 3D view, degrees as 
integer

+625 3I2 3 values of chi for 3 phi-cuts as 
integers

+631 2X unused

+633 8A8 hkl of pole figures, same as [+0]

+697 I2 maxima search option

1 = 8 points, 2 = 12 points, 3 = 20 
points, 4 = 32 points
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+699 R4 absolute minimum of normalized 
data, computed by TEXD5

+703 R4 absolute maximum of normalized 
data, computed by TEXD5

+707 I2 diameter of pole figures for plotter 
in cm

+709 I2 number of copies for plotter

+711 L1 must be 0, .true. = data collection 
still in progress

+712 8R4 x-values for 8 pole figures in mm

+744 8R4 y-values for 8 pole figures in mm

+776 14X unused

+790 A64 sample name (repeated)

+854 A32 data file name

+886 R4 sample thickness

+890 L1 .true. for a texture-less sample

+891 1X unused

+892 R4 thichness of transmission sample

+896 124X unused

+1020 A32 name of .TEX file used for mea-
surement

+1052 I2 number of pole figures in the file, 
same as [+615]

+1054 I2 number of background positions in 
the file

+1056 I2 number of beta steps in the file

+1058 I2 number of beta steps in reflection 
mode

+1060 I2 number of beta steps in transmis-
sion mode

+1062 8R4 2theta of pole figures, same as 
[+64] and [+24] in range header

+1094 130X reserved
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F.  POPLA Data File Format

REF: Kocks, Kallend, Wenk, Rollett, and Wright 
“popLA: Preferred Orientation Package - Los 
Alamos,” LA-CC-89-18, GTDA. Oct. 1995.

popLA data files are stored in ASCII format. 
Valid extensions are:

• *.epf   experimental pole figure

• *.npf   normalized pole figure

• *.rpf   rotated pole figure

• *.tpf   tilted pole figure

line 1: specimen, date, and title

line 2: parameter line

A8 specimen name / filename (no central spaces 
allowed, trailing OK)

A72 popLA suggests that date is first part of title

A5 hkl or other identification for pole image

F5.1 alpha step, usually 5.0 (currently only 5.0 is sup-
ported)

F5.1 alpha max, range 5.0–80.0 (GADDS always 
writes 80.0)

F5.1 beta step, usually 5.0 (currently only 5.0 is sup-
ported)

F5.1 beta max, usually 360.0 or 90.0 (GADDS always 
uses 360.0)

I2 alpha offset start: 0 = 0.0, 1 = 2.5 (GADDS 
always uses 1)

I2 beta offset start: 0 = 0.0, 1 = 2.5 (GADDS always 
uses 1)

3I2 choice of axes labels. (GADDS always assumes 
1,2,3)

I5 scaling factor times 100.0. Default is 100 (scal-
ing factor of 1).

I5 scaled background counts, usually 0 (GADDS 
always writes 0)

A? extra bytes are unknown and unnecessary
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line 3+: data lines

line—last line must be blank to identify the end 
of a set. Then there may be either end of file or 
another set, starting with another first line.

1X,18I4 data in integers scaled by factor in line 2. Scal-
ing factor is only used when Imax exceeds 
9999; otherwise, one uses 1.0 scale factor. 
Data is outputted one beta scan at a time start-
ing at alpha = 0.0 to alpha max. The start of 
each beta scan begins a new line.
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G.  SLAM Command Reference

The following are the GADDS SLAM Command 
syntax for all valid commands. <n> denotes 
numeric value. <s> denotes string value.

! (any text string)
@filename p1 p2 p3 p4 p5 p6 p7 p8 p9 p0
ADD $1 /CLEAR /PATTERN /COUNTS=<n> /DISPLAY=<n> /REALTIME /RESET=<n> /SHUTTER
BADPIXELS /PROCESS $1 $2 $3 $4 $5 $6 $7 /LOCAL
CALIBRATE $1 /MININT=<n> /DISTANCE=<n> $2 /ANGLE=<n> $3  /X=<n> /Y=<n> $4 /AUTO /NOERASE
       /DELAY=<n>
CLEAR  $1 /QUADRANT=<n> /GRAPHICS_SAVE /IMAGE_SAVE
CONFIGURE /EDIT /USER=<s> /SITE=<s> /CALIBDIR=<s> /MINCPS=<n> /TIMEOUT=<n> /NAMECHAR=<n>
       /RUNCHARS=<n> /RUNBASE=<n> /NUMCHARS=<n> /NUMBASE=<n> /LOWTEMP /TEMP=<n> /XBEAM=<n>
       /YBEAM=<n> /FRAMESIZE=<n> /DISTANCE=<n>
CONFIGURE /ADMIN /TARGET=<s> /WAVELENGTH=<n> /ALPHA1=<n> /ALPHA2=<n> /BETA=<n> /UNITS=<s>
       /KV=<n> /MA=<n> /STANDBYKV=<n> /STANDBYMA=<n> /MONOCHROMATOR=<s> /OFFSET=<n>
CONFIGURE /READ $1
CONFIGURE /WRITE $1
CONFIGURE /SHOWMODEL
CONFIGURE /COLORS $1 /WINBG=<n> /WINFG=<n> /CURSOR=<n> /HIGHLIGHT=<n> /BORDER=<n> /GRAPH=<n>
       /OVERLAY=<n> /MATCH1=<n>
CONTRAST /LO=<n> /HI=<n>
CORRECTIONS /LPA  $1  $2  $3  /MONOCHROMATOR=<n>  /AIRMU=<n>  /NOREVERSE
CORRECTIONS /FIBER  $1  $2  $3  /X=<n>  /Y=<n>  /Z=<n>  /NSTEPS=<n>  /MU=<n>  /RADIUS=<n>
CORRECTIONS /PLATE  $1  $2  $3  /X=<n>  /Y=<n>  /Z=<n>  /MU=<n>  /THICKNESS=<n>
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CURSORS /BOX  $1 $2 $3 $4 /DELAY=<n> /NOERASE
CURSORS /CIRCLE $1 $2 $3 /DELAY=<n> /NOERASE 
CURSORS /PIXEL $1 $2 /DELAY=<n> /NOERASE /DUMP
CURSORS /VECTOR  $1 $2 $3 $4 /DELAY=<n> /NOERASE
CURSORS /CONIC  $1 $2 /DELAY=<n> /NOERASE
CURSORS /RBOX  $1 $2 $3 $4 /DELAY=<n> /NOERASE
DETECTOR /CU
DETECTOR /FE
DETECTOR /YVSX
DETECTOR /EVSE
DETECTOR /ADD  $1  /CLEAR  /PATTERN  /COUNTS=<n>  /DISPLAY=<n>  /REALTIME  /RESET=<n> 
        /SHUTTER
DETECTOR /DETRESET
DETECTOR /XEVSX
DETECTOR /YEVSX
DETECTOR /PDCCUSTOM  $1  $2  $3
DISPLAY /NEW $1 /QUADRANT=<n> /LO=<n> /HI=<n> /X=<n> /Y=<n> /MAG=<n> /AUTOINCREMENT
       /GRAPHICS_SAVE /ORIENTATION /VIDEO /OVERLAY
DISPLAY /NEXT
DISPLAY /PREVIOUS
DISPLAY /MOVIE+
DISPLAY /MOVIE-
DISPLAY /RMOVIE+
DISPLAY /RMOVIE-
DISPLAY /RNEXT
DISPLAY /RPREVIOUS
DISPLAY /HKL $1 $2 $3
ECHO /OUT=<s> /APPEND /WAIT=<n> $1 $2 $3 .... $8 $9 $0
EXIT
LOOD /NEW  $1  /COUNTS=<n>  /DISPLAY=<n>  /REALTIME  /FILE=<s>  /XMIN=<n>  /YMIN=<n> 
       /MAG=<n>  /SHUTTER
FLOOD /LOAD  $1 
FLOOD /REPROCESS  $1  $2  /XMIN=<n> /YMIN=<n>   /MAG=<n>
FLOOD  /LINEAR
FRAME_INFO $1
GONIOMETER /MANUAL  $1  $2  $3  $4  $5  $6  $7  $8
       Or GONIOMETER /MANUAL  $1  $2  $3  $4  $5
RATEMETER  $1  /RESET=<n>  /SHUTTER
GONIOMETER /OPTICAL  [$1  $2  $3  $4  $5  $6  $7  $8 | $1  $2  $3  $4  $5]
GONIOMETER /FLATSAMPLE /X1=<n> /Y1=<n> /Z1=<n> /X2=<n> /Y2=<n> /Z2=<n> /X3=<n> /Y3=<n> /Z3=<n>
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GONIOMETER /UPDATE  [$1  $2  $3  $4  $5  $6  $7  $8  $9 |  $1  $2  $3  $4]
GONIOMETER /LIMITS [$1 $2  $3  $4  $5  $6  $7  $8  $9  $0 | $1 $2  $3  $4  $5  $6  $7  $8  $9 
       $0  /XMAX=<n>  /XMIN=<n>  /YMAX=<n>  /YMIN=<n>  /ZMAX=<n>  /ZMIN=<n>  /AMAX=<n> 
       /AMIN=<n>  /DMIN=<n>  /DMAX=<n>]
GONIOMETER /EXTLIMITS
GONIOMETER /SPEEDS  [$1  $2  $3  $4  $5  $6  $7  $8  $9 | $1  $2  $3 | $1  $2]
GONIOMETER /ZERO
GONIOMETER /ATTENUATOR
GONIOMETER /SHUTTER
GONIOMETER /LASER
GONIOMETER /GENERATOR  $1  $2  /WAIT
GONIOMETER /FIXEDAXES  $1  $2  $3  $4  $5  $6  $7  $8
GONIOMETER /HOME  $1  $2
GONIOMETER /PARK
GONIOMETER /XYZ  $1  $2  $3  $4
GONIOMETER /TEMP  $1  /RAMP=<n>  /HOLD=<n>  /WAIT
GONIOMETER /ENCODERS  [$1  $2  $3  $4 | $1  $2  $3  $4 $5 $6 $7 $8 $9]
GRAPH /FILE $1 /QUADRANT=<n> /PRECLEAR  /NOCLEAR
GRAPH /VECTOR $1 $2 $3 $4 /QUADRANT=<n> /DELAY=<n> /NOERASE
GRAPH /ROCKING $1 $2 $3 $4 /QUADRANT=<n> /FRAME_HALFWIDTH=<n> /DELAY=<n> /NOERASE
GRAPH  /POSTER
GRAPH /HKL $1 /QUADRANT=<n> $2 $3 /DELAY=<n> /NOERASE
GRAPH /PSI $1 /QUADRANT=<n> $2 $3  /DELAY=<n>  /NOERASE
HELP
HELP /REFERENCE
HELP /USERGUIDE
HELP /ERRATA
HELP /MAP
HELP /RELNOTES
INTEGRATE /CHI $1 $2 $3 $4 /NORMAL=<n> /STEPSIZE=<n>
INTEGRATE /2THETA $1 $2 $3 $4 /NORMAL=<n> /STEPSIZE=<n>
INTEGRATE /AREA  $1  $2  $3  $4
INTEGRATE /SLICE $1 $2 $3 $4 /NORMAL=<n> /STEPSIZE=<n>
INTEGRATE /WRITE $1 /FILENAME=<n> /FORMAT=<n> /APPEND
INTEGRATE /CLEAR
INTEGRATE /RECTANGLE  $1  $2  $3  $4  /VERTICAL
INTEGRATE  /WRITE  $1  /FILENAME=<s>  /FORMAT=<s>  /APPEND  /SCALE=<n>
LEVEL1
LEVEL2
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LEVEL3
LOAD  $1  $2  /DISPLAY=<n> /SCALE=<n> /OFFSET=<n> /LOGSCALE /USE_CONFIG
LOGFILE /NEW $1 /APPEND
LOGFILE [/ON | /OFF]
LOGFILE /SCRNEW $1 /APPEND
LOGFILE [/SCRON | SCROFF]
MAPPING  $1  /FRAME=<s>  /RUN=<s>  $2  /SLAM=<s>
MASK /CREATE $1 /FILTER /BORDER=<n>
MASK /SAVE $1
MASK /READ $1
MASK /VIEW $1
MASK /EDIT (interactive)
MASK /OCTAGON $1 $2 $3 $4 $5 $6 $7 $8
MENUMODE
PDF2 /VIEW $1 /NBS*AIDS /TYPE=<n>
PDF2 /PRINT $1 $2 /NBS*AIDS /TYPE=<n> /CARD
PDF2 /DISPLAY $1 /DASHED
PDF2 /SEARCH $1 /MINERAL /INORGANIC /ORGANIC
PDF2  /CLEAR
PER_CRYSTAL /EXTERNAL $1 $2 $3 $4 $5 $6 $7 $8 /COMPTON
PER_CRYSTAL /INTERNAL $1 $2 $3 $4 $5 $6 $7 $8 /LINEAR /COMPTON
PER_CRYSTAL /COMPTON $1 /SCALE=<n> /XSCALE=<n>
PER_CRYSTAL /FULL  $1  /DISPLAY=<n>  $2  /RADIUS=<n>
POLE_FIG /SCHEME $1 /POLE=<n> /DISTANCE=<n> $2 [/2THETA=<n> |/THETA1=<n>]  [/OMEGA=<n> |
       /THETA2=<n>] /PHI=<n> /CHI=<n> /AXIS=<n> /WIDTH=<n> /CLEAR $3 /MAPPING=<s> /REFLECTION
       /X=<n> /Y=<n> /Z=<n>
POLE_FIG /PROCESS $1 $2 $3 $4 $5 /POLE=<n> /MAPPING=<s> /BACKGROUND $6 $7 $8 $9 /FIBERGEOM
       /ABSORPTION=<s> /X=<n> /Y=<n> /Z=<n> /MU=<n> /RADIUS=<n> /NSTEPS=<n> /REFLECTION
POLE_FIG /INTERPOLATE $1 /DISPLAY=<n> /WIDTH=<n> $2
POLE_FIG /TILT $1 /DISPLAY=<n> /X=<n> /Y=<n> $2
POLE_FIG /ROTATE $1 /DISPLAY=<n> $2
POLE_FIG /SYMMETRIZE $1 /DISPLAY=<n> $2 /LAUE=<s>
POLE_FIG /INVERT $1 /DISPLAY=<n> $2
POLE_FIG /TEXTUREAT $1 /TITLE=<n> /HKL=<n> /APPEND /ALPHAINC=<n> /BETAINC=<n> /REFLECTION
POLE_FIG /POPLA $1 /TITLE=<n> /HKL=<n> /APPEND
POLE_FIG /ORIENT $1 /DISPLAY=<n> $2 /APPEND /FILM /HKL=<s>
POLE_FIG /STEIN $1 $2 /APPEND
POLE_FIG /NORMALIZE $1 /DISPLAY=<n> /NVAL=<n> $2
POLE_FIG /CONTOURS $1 /INTERVAL=<n>
POLE_FIG /SURFACE $1 /ROTATION=<n> /ELEVATION=<n> /COARSENESS=<n>  /LOGSCALE
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POLE_FIG /FIBERPLOT  $1  $2  $3  $4  /NORMAL=<n>  /STEPSIZE=<n>
PRINT  $1 /FORMAT=<n> /THRESHOLD=<n> /GREYSCALE
PROJECT /SWITCH $1 
PROJECT /LOAD $1 (not recommended to use in SLAM mode)
PROJECT /NEW /CNAME=<s> $1 /TITLE=<s> /WORKDIR=<s> /FORMULA=<s> /MORPH=<s> /CCOL=<s>
       /DENSITY=<s> /DENSMETH=<s> 
PROJECT /COPY /CNAME=<s> $1 /TITLE=<s> /WORKDIR=<s> /FORMULA=<s> /MORPH=<s> /CCOL=<s>
       /DENSITY=<s> /DENSMETH=<s> /CLEAR /RESET
PROJECT /EDIT /TITLE=<s> /FORMULA=<s> /MORPH=<s> /CCOL=<s> /DENSITY=<s> /DENSMETH=<s> /CLEAR
       /RESET
PROJECT /BACKUP $1 $2 $3 /NOCALIB /NOWORK
PROJECT /REMOVE $1 
PROJECT /DELETE $1 
PROJECT /MAKEDEF
QUIT
RATEMETER $1/RESET=<n> /SHUTTER
REDRAW
REFL_ARRAY /THRESHOLD $1 $2 /CONTIG=<n> /COUNTS=<n> /SIGMA=<NN> /XEXMIN=<n> /XEXMAX=<n>
       /RMAX=<n> /DMIN=<n> /DMAX=<n> /DBIAS=<n> [$3 $4 $5 $6 $7 $8]
REFL_ARRAY /PICK $1 $2 $3 $4 /START=<n> /QUADRANT=<n> /FRAME_HALFWIDTH=<n>
REFL_ARRAY /INDEX $1 /AAX=<n> /BAX=<n> /CAX=<n> /U1=<n> /U2=<n> /U3=<n> /FCELL=<n> /SIGA=<n>
       /NOREDUCE /VERBOSE /FGROUP=<n> /HKLTOL=<n> /FFIT=<n> 
REFL_ARRAY /BRAVAIS $1 $2 $3 $4 $5 $6 $7 /SIGA=<n> /SIGB=<n> /SIGC=<n> /SIGMA=<n> /SIGBEST=<n>
REFL_ARRAY /LEASTSQ $1 $2 $3 $4 $5 $6 $7 /DXC=<n> /DYC=<n> /DISTANCE=<n> /ROLL=<n> /YAW=<n>
       /U1=<n> /U2=<n>  /U3=<n> /HKLTOL=<n> /HALFWIDTH=<n> /MASK=<n> /PARNAME=<n>
REFL_ARRAY  /EDIT
REFL_ARRAY /MODIFY $1 $2 /FIELD=<n> /VALUE=<s>
REFL_ARRAY /SORT $1 $2 /FIELD=N /DESCENDING
REFL_ARRAY /TRANSFORM $1 $2 $3 $4 $5 $6 $7 $8 $9
REFL_ARRAY /MATRIX $1 $2 $3 $4 $5 $6 $7 $8 $9
REFL_ARRAY /HCALC $1 $2 $3 $4 $5 $6 $7 $8 $9
REFL_ARRAY  /CLEAR
REFL_ARRAY /LOAD $1
REFL_ARRAY  /RSPACE
REFL_ARRAY /CDF $1 $2 $3 $4 $5 $6 $7 $8 /FORMULA=<s> /TYPE=<s> /FILE=<s> /VERBOSE 
REFL_ARRAY  /SAVE   $1  $2  $3
SAVE $1 /TITLE=<s> /XENGEN /DISPLAY=<n>
SCAN /SINGLERUN  $1  [/2THETA=<n> | /THETA1=<n>]  [/OMEGA=<n> | /THETA2=<n>>]  /PHI=<n> 
       /CHI=<n>  /X=<n.  /Y=<n>  /Z=<n>  /AUX=<n>  /AXIS=<n>  /WIDTH=<n>  /SCANTIME=<n> 
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       /TITLE=<s>  /SAMPLE=<s>  /NUMSAMPLE=<n>  NAME=<s>  /RUN=<s>   /FRAMENO=<s>  
       /DISPLAY=<n> /REALTIME  /CLEAR  /OLDXENGEN  /MODE=<n>  /ROTATE  /VIDEO 
       /OSCILLATE=<s> /AMPLITUDE=<n> [/SNAME=<s>  /SRUN=<n>  /SFRAME=<s>]
SCAN /EDITRUNS (interactive command only)
SCAN /MULTIRUN $1 /TITLE=<s> /SAMPLE=<s> /NUMSAMPLE=<n> /DISPLAY=<n> /REALTIME /CLEAR
       /OLDXENGEN /STARTRUN=<n> ENDRUN=<n> /MODE=<n> /ROTATE /VIDEO /OSCILLATE=<s>
       /AMPLITUDE=<n> [/SNAME=<s>]
SCAN /RESUMERUNS  $1  /TITLE=<s>  /SAMPLE=<s> /NUMSAMPLE=<s>/DISPLAY=<n> /REALTIME /CLEAR
       /OLDXENGEN /STARTRUN=<n> /ENDRUN=<n> /MODE=<n> /ROTATE /VIDEO $2 /SNAME=<s>
       [/2THETA=<n> | /THETA1=<n>] [/OMEGA=<n> | /THETA2=<n>] /PHI=<n> /CHI=<n> /X=<n> /Y=<n>
       /Z=<n> /AUX=<n> /AXIS=<n> /WIDTH=<n> /SCANTIME=<n> /RUN=<s> /FRAMENO=<s> $3
SCAN /ROTATION $1 /TTZERO /PHI=<n> /CHI=<n> /DISPLAY=<n> /REALTIME /RESET=<n>
SCAN /HKL $1 $2 $3 /SCANTIME=<n> /TITLE=<s> /SAMPLE=<s> /NUMSAMPLE=<n> /NAME=<s> /RUN=<s>
       /FRAMENO=<s> /DISPLAY=<n> /REALTIME
SCAN /PSI $1 $2 /SCANTIME=<n> /TITLE=<s> /SAMPLE=<s> /NUMSAMPLE=<n> /NAME=<s> /RUN=<s>
       /FRAMENO=<s> /DISPLAY=<n> /REALTIME
SCAN /COUPLED $1 $2 $3 /WIDTH=<n> /SCANTIME=<n> /TITLE=<s> /SAMPLE=<s> /NUMSAMPLE=<n>
       /NAME=<s> /RUN=<s> /ROTATE /X=<n> /Y=<n> /REALTIME
SCAN /ZONE $1 /WIDTH=<n> /SCANTIME=<n> /DISPLAY=<n>
SCAN /AXIAL $1 /WIDTH=<n> /SCANTIME=<n> /DISPLAY=<n>
SCAN /SELECTTARGETS
SCAN /GRIDTARGETS /XBEG=<n> /XEND=<n> /XINC=<n> /YBEG=<n> /YEND=<n> /YINC=<n> /TRANSMISSION
SCAN /EDITTARGETS
SCAN /MULTITARGETS $1 [/2THETA=<n> | /THETA1=<n>] [/OMEGA=<n> | /THETA2=<n>] /PHI=<n> /CHI=<n>
       /AXIS=<n> /WIDTH=<n> /SCANTIME=<n> $2 /TITLE=<s> /SAMPLE=<s> /NUMSAMPLE=<s>
       /DISPLAY=<n> /REALTIME /CLEAR /STARTRUN=<n> /ENDRUN=<n> /MODE=<n> /ROTATE /VIDEO
SCAN /MASTER  $1  /SEND_CONFIG
SCAN /SLAVE
SHUTTER
SMOOTH  /AVERAGE
SMOOTH  /MEDIAN
SMOOTH  /CONVOLVE  $1
SPATIAL /NEW $1 /COUNTS=<n> /DISPLAY=<n> /REALTIME /FILE=<s> /XENGEN /THRESHOLD=<n> /SHUTTER
SPATIAL /LOAD  $1 
SPATIAL /LINEAR
SPATIAL  /PROCESS $1 /THRESHOLD=<n>
SPATIAL /UNWARP $1 $2 $3 /NONORMALIZATION /DISPLAY=<n> /XENGEN  /NOBEAMCENTER
SPAWN
STRESS /CONVENTIONAL $1 $2 $3 $4 /NORMAL=<n> /STEPSIZE=<n> /2THETA=<n> $5 /FILENAME=<s>
STRESS /SCHEME2D  $1  /PEAK=<n>  /DISTANCE=<n>  $2  [/2THETA=<n> | /THETA1=<n>]  
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        [/OMEGA=<n> | /THETA2=<n>]  /PHI=<n>  /CHI=<n>  /AXIS=<n>  /WIDTH=<n>  /CLEAR
STRESS  /BIAXIAL2D  $1  $2  $3  $4  /NORMAL=<n>  /STEPSIZE=<n>  /NUMBER=<n>  /2THETA=<n>  $5 
        /FILENAME=<s>  /HKL=<s>  /YOUNG=<n>  /POISSON=<n>  /ARX=<n>  /LINESHAPE=<n> 
        /CUTOFF=<n>  /BKGFIT=<s> /KALPHA2 /PHI=<n> /PSI=<n> /REPROCESS
STRESS /SHEAR2D …(same as biaxial2d)
STRESS /TRIAXIAL …(same as biaxial2d)
STRESS  /VIEW2D  $1  /DISPLAY=<n>  /DATA  /LINE  /DELAY=<n>  /DIRECTION=<s>
SYSTEM  $1
VIDEO /LIVE
VIDEO /FREEZE
WAIT $1
ZOOM  $1  $2  $3
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H.  Remote Operations (SMARTservice)

Online GADDS now supports remote operation 
from another program when GADDS is in com-
mand mode and another package called 
SMARTservice is loaded and started. SMART-
service operates as an NT Service, which is 
always running as part of the operating system. 
From any networked computer, you can connect 
to SMARTservice using winsockets. You can 
either use TELNET or write your own winsocket 
program to communicate with SMARTservice.

Remotely you can send to GADDS:

• Any SLAM command

• Hard abort (CTRL+C or CTRL+BREAK)

• Soft abort (ESC)

• Pause (CTRL+S)

• Resume (CTRL+Q)

Remotely you can receive from GADDS:

• Log file as it’s generated

• Informational messages

• Error messages

• Angle, Drive, Shutter, Laser, Attenuator sta-
tuses

Remotely you can send to NT:

• Command to start a program (such as 
GADDS)

• Command to kill a program

• Command to reboot frame buffer

Typically, you can use TELNET to remotely and 
efficiently monitor data collection status. Simply 
connect via winsockets (modem or network) to 
SMARTservice. Then connect to the GADDS 
log file (when you are just monitoring the log file, 
GADDS may be running in either menu or com-
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mand mode). You will see the last ten lines of 
the log file, enough to easily determine whether 
GADDS is still running or stopped with an error 
condition. New lines will display as they are 
received.

For more elaborate remote control of GADDS, 
you must either write your own winsocket-
enabled program or modify a third party pack-
age such as EPICS, LABVIEW, or SPECS to 
send commands over winsockets. Bruker does 
not supply any such winsocket-enabled pro-
gram.

See the SMARTservice Software Manual for 
more details.

NOTE: Bruker supplies PCAnywhere32 on our 
frame buffers for remote diagnostics by our ser-
vice department using either modems or a net-
work. PCAnywhere32 allows the entire desktop 
of the frame buffer to be remotely controlled 
from another computer running PCAnywhere32. 
You can install the client version of 
PCAnywhere32 on another NT workstation to 
remotely control the frame buffer (see PCAny-
where license agreement). Use PCAnywhere32 
when you wish to run the GADDS program but 
are sitting in front of a different computer. Use 
SMARTservice when you wish to control the 
GADDS program from another program, such 
as EPICS, LABVIEW, SPECS, or TELNET.
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I.  Electronic Tracking of Instrument 
Configuration Changes (Bruker Log 
Service)

GADDS now supports electronic tracking of 
instrument configuration changes. GADDS only 
logs the Bruker Instrument Administrator 
changes such as:

• Calibrate: New detector parameters.

• Collect > Goniometer > Encoders: New 
encoder offset(s).

• Edit > Configure > User/Admin: New cali-
bration direction, New detector parameters, 
and New wavelength parameters.

• Flood > New: New flood correction.

• Project > Overwrite defaults: New system 
defaults.

• Spatial > New: New spatial correction.

NOTE: Currently goniometer controller configu-
ration changes other than encoder offsets are 
not logged, such as direct editing of device.ini 
when changing stages.

These changes are converted to a two-line 
ASCII string containing information for program 
and version, date, time, user, and log string. For 
example:

GADDS 4.1.02:  Date: Thu 12-Oct-2000  

Time: 14:54:17  User: SmitKL

Log: Configure > Edit: New wavelen 

parms: Cu 1.54184 1.54056 1.54439 

1.39222
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This informational string is sent to two places:

• ..\BrukerInstrumentLog.txt

• Bruker_FDA_GLP_LogService

The BrukerInstrumentLog.txt is typically located 
in the directory C:\saxi. You can use notepad to 
view this file.

The Bruker_FDA_GLP_LogService is a Win-
dows 2000/NT Service that can be written to 
accept these electronic signatures and send it 
anywhere on your network. Essentially, Bruker 
provides a hook for easy customization so you 
can provide electronic tracking of the Bruker 
instrument in a means compatible with your spe-
cial laboratory requirements, regulations, and 
company policy. Bruker does not write this 
Bruker_FDA_GLP_LogService. Interested par-
ties should contact Bruker to obtain the docu-
ment: “Integrating Bruker Instruments into an 
FDA 21 CFR part 11 compliant laboratory.”

NOTE: VIDEO 1.3.02 also supports electronic 
tracking of instrument configuration changes.
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