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This document describes how to install Microcontrollers
Driver Suite. It also provides instructions on removing the
previous version of Microcontrollers Driver Suite from the
Eclipse environment.

To install Processor Expert Software Microcontrollers
Driver Suite, double-click the installation package and a
wizard will guide you through the installation process. There
is no license necessary to run this product.

1 Eclipse Plugin Installation

If you are using an existing Eclipse environment, make sure
that you have installed the supported version of Eclipse. If
you have not installed supported version of Eclipse yet, it is
recommended to download the supported version from the
link below:

http://www.eclipse.org/downloads/packages/eclipse-ide-cc-devel
opers-includes-incubating-components/indigor
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Remove Previous Version

1.1 Windows

To install the product on the Windows host system, following are the prerequisites:

» Administrator rights are required to run Eclipse Updater to install this product on a Windows
system when the Eclipse is installed into the Program Files folder.

» If you are running Windows with non-administrative user account, you need to install Eclipse and
this product in another folder. For example, C:\Freescale\PExDriverSuite v10.0.0.

» Eclipse stores your projects in a folder called workspace. This folder needs to be setup in any folder
that you can fully access. For example, C:\Profiles\<username>\workspace.
The product has been tested on:
* Windows Vista Home Premium (32-bit, 64-bit)
e Windows 7 Home Premium (32-bit, 64-bit)
» Windows XP Professional (32-bit, 64-bit)
* Windows Vista Business (32-bit, 64-bit)
* Windows 7 Professional (32-bit, 64-bit)
* Windows 8 Professional (32-bit, 64-bit)

1.2 Linux

To install the product on Linux, following is the prerequisite:

» Eclipse stores your project in a folder called workspace. For example,
/home/<username>/workspace. Make sure your workspace has read/write permissions set to be
accessible by Eclipse.

The product has been tested on:
e Linux Ubuntu 10.4 (32-bit, 64-bit)
* Linux Red Hat Enterprise 5.4 (32-bit, 64-bit)

2 Remove Previous Version
If you have already installed previous version of Microcontrollers Driver Suite, it is recommended to
remove it first.

1. Run the Eclipse environment.

2. Select Help > Install New Software from the main menu bar. The Available Software screen
appears.
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2 Install

Available Software

Select a site or enter the location of & site, \D —
. . | :
Work with: v | ’ Add...

Find more saftware by working with the 'Available Software Sites' preferences,

Name Version
[]@ There is no site selected,

Details

Shaw only the latest versions of available software [ Hide items that are already instaled

[¥] Group items by category I Whatis already installed? I
Contact all update sites during install to find required software

=
2) Cancel

Remove Previous Version

Figure 1. Available Software Screen — What is already installed Link

3. Click the What is already installed? link. The Eclipse Installation Details window appears

displaying a list of already installed software (Figure 2).

& Eclipse Installation Details

Installed Software |Installatinn History | Features | Plug-ins || Configuration

- B

®®. Microcontrollers Driver Suite Feature 2.2.0 com. free

Marme Wersion Id
@ Eclipse IDE For C/C++ Developers 1.3.2,20110218... epp.package.cpp
@: FSL Eclipse Updater Custarn Actions 2.0.4.F3L_b110... com. freescale updater. customaction. .

Processaor Expert Software - Microcontrollers Driver Suite 5.2 for Freescale Kinetis, ColdFire+

with Dervice Initialization

([

£

® l Update. ., H Uninskall. .. ” Properties ]

Close

Figure 2. Eclipse Installation Details Window — List of Already Installed Software

4. Select Microcontrollers Driver Suite Feature in the list and click Uninstall. The Uninstall

Details window appears.
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& Uninstall

Uninstall Details

Review and confirm the items to be uninstalled,

Details

Processor Expert Software - Microcontrollers Driver Suite 5.2 For Freescale Kinetis, ColdFire+

Wersion

Mare...

[ Finish ] [ Cancel

Figure 3. Uninstall Details Window

5. Click Finish to start the uninstallation process. The Software Updates dialog box appears.

=

& Software Lipdates

fou will need ko restart Eclipse
\“_ﬁ

far the installation changes to take effect, You

may try ko apply the changes without resktarting, but this may cause errors,

Restart MNow

J

Mok Mow ] [&pply Changes Mow

Figure 4. Software Updates Dialog Box

6. Click Yes to restart Eclipse. This removes

the previous version of Microcontrollers Driver Suite.

NOTE

Do not forget to manually remove o
previous installation.

3

bsolete Processor Expert folder from the

Installing Microcontrollers Driver Suite

Table 3-1 lists the sources of the installation packages of Microcontrollers Driver Suite.

Table 3-1. Microcontrollers

Driver Suite Installation Sources

File

Description

com.freescale.eclipse3.6.updater.custom.updatesite.zip

Extended Eclipse updater package (for Eclipse 3.6)

com.freescale.eclipse3.7.pexdrv10_0.updatesite.zip

Product installation package (for Eclipse 3.6)

com.freescale.eclipse.3.7.updater.custom.updatesite.zip

Extended Eclipse updater package (for Eclipse 3.7)

com.freescale.eclipse3.7.pexdrv10_0.updatesite.zip

Product installation package (for Eclipse 3.7)

PEXDRVSPEXUG.pdf

Processor Expert User Manual

PEXDRVSDEVINUG.pdf

Device Initialization User Manual

PEXDRVINSTALLUG.pdf

Product installation guide (this document)
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Table 3-1. Microcontrollers Driver Suite Installation Sources

PEXDRVGETSTARTEDUG.pdf Getting Started Guide
README.txt Last minute release information (text format)
README.html Last minute release information (html format)

To install Microcontrollers Driver Suite, you need to first install the FSL Eclipse Updater.

3.1 Installing FSL Eclipse Updater
1. Run the Eclipse environment.
2. Select Help > Install New Software from the main menu bar. The Available Software window

appears (Figure 5).
2 Install
Available Software ’—J
Select a site or enter the location of a site. —
=
Work with: | type or select a site v| | Add... |

Find more software by working with the 'Available Software Sites' preferences.

MName Version
1@ There is no site selected.

Details

Show only the latest versions of available software [ Hide items that are already installed
[ Group items by category What is already installed?

Contact all update sites during install to find required software

@ Cancel

Figure 5. Available Software Window

3. Click Add to create a new update site. The Add Repository dialog box appears.
4. Type a name for the update site in the Name text box, for example, Updater (Figure 6).
5. Click Archive and find the updater installation package (Figure 6).

&

r% Add Repository El
]

Tarme: |Updater H Local...

Location: |eescale.eclipseS.ﬁ.updater.custnm.updatesite.zip!,l'| | l archive, .. ]

@j [ [9]9 I[ Cancel ]

Figure 6. Add Repository Dialog Box

Processor Expert Software — Microcontrollers Driver Suite Installation Guide, Rev. 3

Freescale Semiconductor 5



Installing Microcontrollers Driver Suite

6. Click OK. The FSL Eclipse Updater appears in the Available Software window (Figure 7).

r% Install |Z|@1

Available Software

Check the items that you wish to install,

—

) -

Wark with: |Updater-jar:FiIe:,l'C:,l'PExDrvS,l'com.Freescale.eclipseS.6.updater.custom.updatesite.zi[ v“ Add... ]

Find more software by warking with the "Available Software Sites” preferences.

Name
=) [w] 000 Freescale Update

@ F5L Eclipse Updater Cuskom Actions

Yersion
t
2.0.1.F5L_b110415

’ Select Al ngselect all

1 item selecked

Details

Shaw anly the |atest versio
Group items by category

@

ns of available software [(]Hide iterns that are already installed

What is already inskalled?

Contact all update sites during install to find required software

Figure 7. F

SL Updater in Available Software Window

7. Select FSL Eclipse Updater Custom Actions and click Next. The Install Details screen appears

(Figure 8).

o
& Install

Install Details

Review the items to be installed,

e

=3
i

Mame

‘-'ﬂ'- F5L Eclipse Updater Custom Actions

Wersion Id

2.0.1.F5L_bt10...

com. freescale, updater, customaction. ..

Size: Unknown
Dietails

@

FSL Eclipse Updater Custom Actions (Helios +3.6.13)

Mare,..

]|

Cancel

Figure 8. Install Details Screen

8. Click Finish. The Selection Needed screen appears.
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& Selection Needed Rl

Do vou trust these certificates?

3 - Microsoft Software Yalidation vZ2; Freescale Semiconductor

[} Freescale Semiconductor; Digital 1D Class

Select all ] [ Deselect Al

= Freescale Semiconductar; Digital ID Class 3 - Microsoft Software Validation w2; Freescale Semiconductar
Freescale Semiconductor; Digital ID Class 3 - Microsoft Software Validation v2; Freescale Semiconduckor

@ [ o ] [ Caricel

L

Figure 9. Selection Needed Screen

NOTE

It is necessary to install FSL Eclipse Updater first before installing the
Microcontrollers Driver Suite. The FSL Eclipse Updater is required to be
installed into the Eclipse environment for first time update only. Once
installed, it is not required to install it again in next updates.

9. Check the Freescale Semiconductor; Digital ID Class 3 checkbox.

10. Click OK. The Software Updates dialog box appears (Figure 4).

11. Click Yes to restart Eclipse. This completes the installation of FSL Eclipse Updater.
After restarting Eclipse, perform installation for the Microcontrollers Driver Suite part as described below.

3.2 Installing Microcontrollers Driver Suite Package

Run the Eclipse environment.

Go to Help > Install New Software.

Click Add to create a new update site. The Add Repository dialog box appears.

Type a name for the update site in the Name text box, for example, PExDrv (Figure 10).

Click Archive and specify the product installation package, in the Location text box. Refer
Table 3-1 to find the product installation package for your Eclipse version.

IR .
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& Add Repositony El
]

Tame: |PExDrv | l Local...

Location; |nm.FreescaIe.ecIipseS.G.pexdr\-’S_Z.updatesite.zip!,l'l| [ Archive, ., ]

(?_:l I Ok H Cancel l

Figure 10. Specify Product Installation Package Details

6. Click OK. The Microcontrollers Driver Suite package appears in the Available Software window
(Figure 11).

& |nstall |Z|@
Available Software

Check the items that you wish ko install, —
sy =

Work with: | PExDry - jarifile:/CPExDrv4fcom. freescale. eclipse3. 6. pexdreS_2 updatesite. zip!/ s | [ Add. .. ]

Find more software by working with the "awvailable Software Sites” preferences,

Mame Version
= [«] 000 Microcontrollers Driver Suite 5.2

B¥. Microcontrollers Driver Suite Feature

[ Seleck All ] [ Deseleck All ] 1 item selected

Dretails

Processor Expert Software - Microcontrollers Driver Suite 5.2 For Freescale Kinetis, ColdFire+

More. ..
Show only the latest versions of available software [JHide items that are already installed
Group items by category what is already installed?

[] Contact all update sites during install ko find required software

g
@

Figure 11. Microcontrollers Driver Suite Package

7. Select Microcontrollers Driver Suite in the Name column, and click Next. The Install Details
screen appears (Figure 12).
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& Install

Install Details

Review the items to be installed.

1d

com.freescale. proces:
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Details
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Figure 12. Install Details Screen — Microcontrollers Driver Suite

8. Click Next. The Review Licenses screen appears (Figure 13).

r%‘ Install = @g‘
W
D3

Review Licenses

Licenses must be reviewed and accepted before the software can be installed,

License text (For Processor Expert Driver Suite Feature 1,0.0):

IMPORTANT, Read the following Freescale Software License Agreement (“agresment”) completely, By selecting the 1 ~

Accept” button at the end of this page, you indicate that you accept the terms of this Agreement,
FREESCALE SOFTWARE LICENSE AGREEMENT

This is & legal agreement between you (either as an individual or as an authorized representative of your employer) and
Freescale Semiconductor, Inc, (*Freescale™. It concerns your rights to use this file and any accompanying written
thaterials and executable computer programs (the *Software®), In consideration for Freescale allowing you to access the
Software, you are agreeing to be bound by the terms of this Agreement, If you do not agree ko all of the terms of this
Agreement, do not activate or install the Software, If vou change your mind later, stop using the Software and delete all
copies of the Software in your possession or contral. Any copies of the Software that you have already distributed,
where permitted, and do not destroy will continue to be governed by this Agreement, Your prior use will also continue to
be governed by this Agreement,

(O 1do not accept the terms of the license agreement

@

Figure 13. Review Licenses Screen

[

Finish ] [ Cancel

9. Accept the license agreement and click Finish. The Selection Needed screen appears.

10. Check the Freescale Semiconductor; Digital 1D CI

ass 3 checkbox and click OK.

11. Click Yes in the Software Updates dialog box to restart Eclipse. This completes the installation

of Microcontrollers Driver Suite.

After successful installation, the Processor Expert menu appears in the Eclipse environment (Figure 14).
Select Processor Expert > Show Views to display the Processor Expert perspective.
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Figure 14. Processor Expert Perspective

You can start using the Microcontrollers Driver Suite inside the Eclipse environment. Select File > New
> Processor Expert Project to create a new configuration project. For more details, refer the

Microcontrollers Driver Suite Getting Started User Guide.
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