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About the document

Congratulations on working with DVS-NMS System!!

This user-friendly software is developed for managing SNMP Compatible Network Elements like
Hubs/Routers/Hosts/Switches/Print Servers etc.

The User Manual is divided into three chapters.

The first chapter deals with Introduction of DVS-NMS system and the features of it. It describes
the architecture and functions of two modules in the system - the DVS-NMS SERVER and DVS-
NMS CLIENT.

The second chapter deals with installation and configuration of the system.

The third chapter deals with using the various features present in the system.
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1 OVERVIEW

1.1 Overview
DVS-NMS software is a simple and robust network management software for comprehensive
management of SNMP based networks. This software is based on SNMPv2 protocol.

Simple Network Management protocol (SNMP) is a TCP/IP based network management
protocol to manage devices. Each of the SNMP capable devices is called as SNMP agent. These
agents can be running on any kind of network device like switches, routers, servers, end-hosts
etc. Our software acts as an SNMP manager to control these various agents present in your
network.

Each of these agents uses MIB (Management Information Base) to store management related
information. This information varies from configuration to status parameters.

SNMP protocol provides a framework to GET this information from agents to the manager, to
SET this information, agents reporting critical faults in form of TRAPS to the manager.

1.2 Features
• SNMP version 1 and version 2 compliant.
• Very simple upgradation path to all coming SNMP versions.
• Can run on Windows 98, Windows 95, Windows 2000, Linux machines.
• User friendly way to autodiscovery of network.
• Selective way of drawing of autodiscoverd network.
• User friendly way to draw the network diagram (topology of network) and then manage it. It

provides a way to save the network diagram in a file, which can be used later.
• The entire network can be surveyed to find which network elements are up and which

network elements are down.
• Supports SNMP SET, GET and GET-NEXT request in this release. Also supports listening

of  SNMP TRAPS.
• SNMP GET and GET-NEXT is done using MIB Browser feature of the product, which

displays the MIB in form of a tree.
• SNMP SET is done using MIB Editor feature of the product.
• SNMP set request is authenticated, so that a malicious user getting hold of user interface of

the product can’t do any damage to the network.
• Listen for SNMP TRAPS and notify user on reception. Also provides tabular detail of

recently received traps.
• The user interface module and the module, which actually communicates with the SNMP

agent are divided. This gives flexibility, scalability and lesser load on the system. Both the
modules can run on the same machine or different machines.
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1.3 Architecture
DVS-NMS system is based on a client-server architecture. So, it has got two distinct modules -
DVS-NMS Server and DVS-NMS Client. Both of these can reside on same machine or can
reside on different machines. There should be only one server running in the system while there
can be multiple client software running on different machine.

1.3.1 DVS-NMS Server
This piece of software communicates with the different SNMP agents. It collects up the
information from the SNMP agents and then sends this information to DVS-NMS Client based
on users query.

DVS-NMS Server is written in ANSI C and it runs on both Linux and Win32 (95/98/NT/2000)
platforms. The definition of MIB is stored on the server in a text format in which new objects
can be added easily to make it compatible with the new SNMP versions.

SNMP get request does not require any authentication, but SNMP set request is authenticated
using a username and password.

1.3.2 DVS-NMS Client
This module provides a user friendly front end and communicates with the DVS-NMS Server
using a TCP/IP based messaging interface. Once the server is installed and running, user can use
the client to manage the network. The user’s view to the product is only through the NMS client.

The client connects to DVS-NMS server at TCP port number 5555, on which DVS-NMS Server
must be already listening. Once the TCP connection has been established, the client sends the
various SNMP requests to server. These requests can be to get a particular MIB variable, to set a
particular MIB variable etc. The server then communicates with the corresponding network
agent using SNMP protocol, collects up the response and sends it to the client. The client then
displays this information in form of a MIB tree.

DVS-NMS Client is Java based written using JDK1.2 and hence is platform independent.

Figure 1 : Overview of DVS-NMS System
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2 INSTALLATION AND CONFIGURATION

2.1 Requirements
DVS-NMS Server: Pentium (or higher) system with 32 MB RAM or higher. Running Windows
NT or Windows 95 or Windows 98 or Linux.
DVS-NMS Client: As the code is written in Java and can run on any platform supporting Java.
Also it require “JAVA Runtime Environment” to work. It comes with the “Java Development
Kit” or user can install it separately. It is available for free and can be downloaded from
http://www.java.sun.com/products/jdk1.2/jre/index.html.

2.2 Installation
Assuming installation of both client and server on a same Windows 98 machine and the
CDROM drive is the D drive in the system,
Place the CD that came with the release into CDROM drive.
Open a MSDOS prompt by clicking in Start -> Programs -> MSDOS Prompt.
On the DOS prompt, run the following commands to install the DVS-NMS Server:-
d:\
cd server
setup.exe

Setup will ask the destination directory to install the program and then will install the server
program.

Note: By default the server will be installed in “C:\Program Files\DVS-NMS\Server” directory.

On the DOS prompt, run the following commands to install the DVS-NMS Client:-
d:\
cd client
setup.exe

Setup will ask the destination directory to install the program and then will install the client
program.

Note: By default the client will be installed in “C:\Program Files\DVS-NMS\Client” directory.

2.3 Configuration of Server
The username and corresponding password needs to be added for all those users (network
administrators) who will be having rights to do SNMP SET, which can change the configuration
at SNMP agents. These usernames and passwords are stored in a text file named “auth.txt” in the
server installation directory. Usernames and their passwords can be added manually in the file,
by editing the file using any text editor such as NOTEPAD. The example file is enclosed below:

netadmin1 qwerty1
netadmin2 qwerty2
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where netadmin1 and netadmin2 are usernames and qwerty1 and qwerty2 are passwords.

2.4 Configuration of Client
Client needs to be provided with the IP address of the machine on which DVS-NMS server is
running. If both the server and the client run on same machine, no configuration is required
because the client has been configured for localhost by default.

If server is running on the machine other than localhost then client when started ask for the “IP
Address” of the machine on which server is running. And ask for restart of the client.

Also, configuration of the IP Address of the server can be done through “Option” in Menu of the
Client. But it requires restart of the client to communicate with changed server.
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3 RUNNING

3.1 Running the Server

To run DVS-NMS Server go to Start->Programs->DVS-NMS Server. Click on “DVS-NMS
Server”. This will open a console window, which shows DVS-NMS Server is running.

Note: Please start the NMS server before starting the NMS client.

3.2 Running the Client
Assuming you have already installed “JAVA Runtime Environment”.

To run DVS-NMS Client go to Start->Programs->DVS-NMS Client. Click on “DVS-NMS
Client”. This should start your client.

When client starts, it will try to connect to the DVS-NMS server. Once the connection is
successful, the user interface will be displayed at the client side, otherwise, it will display
message to start DVS-NMS Server. The IP Address of the DVS-NMS Server by default is
“localhost”. User can give the IP Address of the machine (in case, if server is not running on the
localhost) in the text box provided by the error message and then have to restart the client.

Figure 2 : Error Window From Client if  NMS Server is not running.

3.2.1 Autodiscovery of  Network

User can autodiscover his/her network with this feature of DVS-NMS. Autodiscovery of network
is done in very controlled way. User can specify that, upto what depth he/she wants to discover
the network and also from where discovery should start. It means user can discover a particular
subnet’s network elements by giving that subnet’s router’s address as a seed router and by giving
a depth value user can specify upto what depth he/she wants to discover the network, that means
starting from seed address how many subnets should be discovered.
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Figure 3 : Supplying Seed address and depth for autodiscovery

After autodiscovery of network, NMS display the discovered information in very user
convenient way. Autodiscovered network is displayed in the form of  routers, hosts, segments,
domain as node of tree and then related information is arranged in the form of subtree. Also brief
detail can be viewed in bottom panel by single-left button click on the nodes, like,  by clicking
on “Routers” will show the no of routers, their name, interfaces etc. while clicking on particular
Segment will show details of that Segment i.e. table of all the hosts and routers in the subnet.
Similarly routers and host specif brief details can be observed in bottom panel.

NMS  also discover NetBIOS domains in the network and show the domainwise listing of hosts.
Also it fetches the NetBIOS names of the hosts if SNMP configured names are not available.

Figure 4 : Autodiscovered Network
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By right clicking on the nodes of routers and hosts it will display pop-up menu there. From
which user can select the action. Like, he can select to open the MIB Browser(later explained) to
browse MIB of that router/host, or he can ping (explained later) to that router/host, whose results
are also displayed in the bottom panel.

3.2.2 Drawing Autodiscovered Network

NMS can draw autodiscoverd network in very user friendly and selective way. To draw network
on canvas click on tools on the top menu, then click on “Draw Autodiscovered Network”, then

NMS will provide box with the list of autodiscovered routers. After selecting routers to draw and

Figure 5 : Router and Host Select Window

clicking “Next” NMS will provide user the box with list of autodiscovered hosts. After selecting
hosts and clicking “OK” NMS will draw the selected routers and hosts joined with proper
segments automatically. This selective drawing of network is very useful when network is very
big and user wants to draw and manage only few critical routers and hosts.
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Figure 6 :  Drawing Autodiscovered Network

3.2.3 Creating the network diagram
When user starts the client software and a connection is made with the server, a drawing canvas
will be displayed on which the user can draw various network elements
(segment/routers/hosts/switches) to be managed. A network element is a managed entity running
SNMP agent. These elements can be an IP router, a TCP/IP based host/server, Ethernet
switches/hubs.  A segment is similar to a LAN segment and it is a logical entity, which joins the
other elements in the network.

Click on Edit tab in the main menu and a sub-menu as displayed in following figure will be
displayed.

After selecting a specific network element to draw, a window is displayed to enter the data
specific to that element.  For example for a host, hostname and its IP address need to be entered.

After entering the required data, the software draws that element on canvas. User can then move
this element anywhere on the canvas. User can create various network elements and then join the
network elements using segments. For instance, to join a router interface to segment, user will
right click first on the interface (to be connected to the segment) and then on segment, software
will automatically draw a line between router’s interface and the segment. Similarly other
network elements can be joined to form a logical view of the network.
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3.2.4 Saving the network diagram

User can save this network diagram to server in form of file to be reloaded later. To save the
current network diagram, click on File->Save configuration tab. Provide the filename which will
be saved on the NMS server.

3.2.5 Loading the network diagram
To load the saved network diagram from the server, click on File->Load configuration. Enter the
name of the network configuration file. This will load the network diagram from the server onto
the NMS-client user interface.

3.2.6 Doing the Network Survey
The network diagram can be surveyed using the Network Survey feature. Using this feature, the
entire network can be surveyed in order to check whether the network elements (i.e.
router/hosts/switches as well as there interfaces) up or down.

To do a network survey, click on Tools->Network Survey.
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The result of network survey is shown by change of color of network elements. The red colored
elements are down, while the  blue colored elements are up.

Figure 7 : Network Survey

3.2.7 SNMP GET using MIB Browser
It gives a facility to browses the MIB in a hierarchical way (similar to the way in which
Windows Explorer displays the directory tree). It generates a tree of MIB objects, which can then
be browsed by the user. It means user can browse the tree by single clicking on a node. If the
node is a leaf node, it shows its current value in a panel besides the tree. Similarly if the node
represents a table, then it shows the whole table in the panel. If the node is not a leaf node, it will
expand the tree to one more branch and user can browse it further in similar way.

Each SNMP agent has got a community name, which is like a password to access the
information maintained by the agent. By using DVS-NMS client, the user can get information
about all the agents of which the community name is known to the user.

User can open the MIB browser for each network element by double clicking on the network
element. Each browser will open in separate window so that user can switch among them very
easily.
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Figure 8: MIB Browser displaying part of TCP MIB
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3.2.8 SNMP SET using MIB Object Editor
MIB Object Editor allows SNMP SET command. Using this editor, user can issue SNMP set
command to any writeable SNMP object and change it its values. But the modification of MIB
objects value can be done only after proper authentication.

To change the value of any MIB variable, click on the value of the MIB variable which is
already displaying in the value panel beside MIB tree and user will get the “SET window” if
authenticated already ,if not then user will be asked to check the SET box which will present user
an “Authentication window” to authenticate himself to server. Same time, user have to enter
proper community name for SETting the MIB variable in “Community Name” text box beside
SET check box. The user will be prompted for authentication. Enter the username and the
password, which was given during configuration.

Figure 9: Authentication before SNMP SET

Enter the value to be modified in the leaf node. In case of table, user can directly enter the value
in the table and after pressing ENTER, client sends the SET request for this object to DVS-NMS
server. The server then sends the SNMP SET message to the corresponding agent and then server
respond to client with the result of the operation.
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Figure 10: SETting/changing the table value.

Figure 11: SETting/changing any leaf OID value
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3.2.9 Listens to SNMP TRAP

NMS also listens to SNMP TRAP from the SNMP AGENTS, and notify the user about the trap
immediately by displaying “Trap Arrived!!” in the bottom panel. Then user can check for the
trap details by clicking on the Trap->”View recent traps” on the main menu.   This will display
the detailed table of recently received traps giving the type, generating agent and time at which it
is generated.

Figure 12 :  SNMP Trap Table
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3.2.10 Network Tools

This feature increase the hold of network administrator on his network. This includes the very
well known and valuable tools. In this release NMS includes “ping”. To ping the desired host
click on Tools->Network Tools->ping. NMS display the result of ping in the bottom panel. More
Network tools will be added in future releases.

Figure 13 : Ping Option Window

This will open a window to enter the IP address or name of the host to ping. User can also
specify the size of ICMP packet (ping packet) and number of packets to be pinged to the host.
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Figure 14 : Ping Results


