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Copyright

EVS Broadcast Equipment SA— Copyright © 2003-2014. All rights reserved.

Disclaimer

The information in this manual is furnished for informational use only and subject to
change without notice. While every effort has been made to ensure that the information
contained in this user manual is accurate, up-to-date and reliable, EVS Broadcast
Equipment cannot be held responsible for inaccuracies or errors that may appear in this
publication.

Improvement Requests

Your comments will help us improve the quality of the user documentation. Do not
hesitate to send improvement requests, or report any error or inaccuracy on this user

manual by e-mail to doc@evs.com.

Regional Contacts

The address and phone number of the EVS headquarters are usually mentioned in the
Help > About menu in the user interface.

You will find the full list of addresses and phone numbers of local offices either at the end
of this user manual (for manuals on hardware products) or at the following page on the
EVS website: http://www.evs.com/contacts.

User Manuals on EVS Website

The latest version of the user manual, if any, and other user manuals on EVS products
can be found on the EVS download center, on the following webpage:
http://www.evs.com/downloadcenter.
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http://www.evs.com/downloadcenter
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1. About the Application

License Controller is an automatic application that checks the status of the IP2Archive
licenses in the XSecure database and synchronizes this information with the IP2Archive
database.

1. About the Application 1
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2.

2.1.

2.2,

Starting the Application

After Installation

Double-click the License Controller icon to start the application. You can also start the
application by double-clicking the executable file (.exe) in the installation folder. The
splash screen appears.The splash screen appears followed by an Oracle Login dialog
box.

IPE Archive

© License Controller Version: 01.04

=V5

Logging on to as ...

The application logs into the database. Then, the Settings window appears allowing you to
configure the application.

See section "Configuring the Application" on page "8".

After Configuration

Double-click the License Controller icon to start the application. You can also start the
application by double-clicking the executable file (.exe) in the installation folder.

The splash screen appears. The application logs into the database.

2. Starting the Application



i .
CONFIGURATION MANUAL IP2Archive 1.4 License Controller 1.0 I / .

2.3. Version Check

Introduction

The version of the application will be checked when the application logs into the
IP2Archive database at startup. The status of the version that is returned is displayed on
the application splash screen.

Logging on to as ..

Version Statuses

The following version and license statuses can be returned:

Status Description Color | Action Required
Current The actual version of the application. no No action required.
color

The application starts
automatically.

Outdated = A newer version of the application red Click OK to start the
exists, but this version can still be used. application at once.
The application version that should be By default, the
installed is displayed. application starts
automatically after 10
seconds.
Obsolete ' A newer version of the application red Click OK to continue.
exists and must be used. This version
may not be used anymore. The application shuts
down.

The application version that should be
installed is displayed.

2. Starting the Application 3
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Status Description

Color | Action Required

Undefined The version of the application is not
defined in the MAD database.

Beta A test version.

black

blue

Click OK to continue.

The application shuts
down.

Click OK to start the
application.

By default, the
application starts
automatically after 10
seconds.

2. Starting the Application
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2.4. Main Window Overview

General Description

The main window displays the active and non-active tasks of the application. It allows you
to monitor the tasks that are being performed. It also allows you to manually start and stop

the application or a particular task.

License Controller

Logging

Area Description

The table below describes the various parts of the main window:

Part Name Description
1. Menu bar The menu bar contains three menus: File, Settings and
Help.

2. Starting the Application
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Part Name Description

2. Tasks pane The Tasks pane contains the name and a brief description
of the tasks performed by the application. Only the tasks
that were activated by you in the System settings will be
performed at start-up.

If you want to manually run certain tasks for test purposes,
you have to stop the application, select the corresponding
check box in the Active column, and then click the Start
button. This button only becomes available after you have
clicked the Stop button.

3. Start/Stop buttons | These buttons are used to manually start and stop the
application.

4, Log pane The Log pane lists application events (= logs) and can be
useful. The date and time of each event is displayed.
These logs are also saved in the log files.

Menu Bar

File Menu

The File menu contains only one command: Exit. It is used to exit the application. Click
the File menu or use the keyboard shortcut keys ALT + F or F10 + F to openit. Click Exit
or use the keyboard shortcut key X to exit the application.

Settings Menu

The Settings menu does not contain any commands. It immediately gives access to the
application settings. Click the Settings menu or use the keyboard shortcut keys ALT + S
or F10 + S to access the settings.

Help Menu

The Help menu contains only one command: About. Click the Help menu or use the
keyboard shortcut keys ALT + H or F10 + H to openiit.

With the About command the application about box can be opened. The about box
displays the application software version, the date until which the application license is
valid, the name and version of the database the application is logged on to and the login
name used.

Click About or use the keyboard shortcut key A to open the about box.

6 2. Starting the Application
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IP2 Archive

License Controller ¥ [FileYersion]
[DatabaseYersion]
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Logged on to [DatabaseName] as [Login]

2.5. Overview Tasks

The table below gives a brief description of the tasks performed by License Controller.

Number Task Description

1 Synchronize licenses | License Controller checks the status of the
IP2Archive licenses in the XSecure database and
synchronizes this information with the IP2Archive
database.

2. Starting the Application
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3. Configuring the Application

3.1. Settings Window

Opening the Settings Window

The Settings window allows you to configure your application. The first time the
application is launched after it has been installed, the Settings window opens
automatically.

System settings

echan  E-mail aption:  Timers

p Application histary

F.eep alive :

Keep connection alive interyval : B0

The Settings window can also be accessed through the Settings menu in the main
window. To make this menu available, click the Stop button. The application will stop
performing its tasks.

8 3. Configuring the Application
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Edit Mode

To be able to edit the Global and/or System settings, you first have to enter a password.
To put the Settings window into Edit Mode, proceed as follows:

< Enter into edit mode

1. Click the Enter Into Edit Mode button

A dialog box appears.

Password Dialog

Enter password:

2. Enter the administrator password and then click OK.

The Settings window enters into Edit Mode.

Edit Mode

3. Configuring the Application
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3.2.

3.2.1.

3.2.2.

System Settings

Overview System Settings Subcategories

The System settings are divided into the following subcategories:
*+  MAD Options

» Oracle Connection

+ E-Mail Options

+  Timers

+ Tasks

For each subcategory a tab is provided.

MAD Options Tab

The MAD Options tab allows you to configure the log file management.

daps (-1 = nes

Configuring the Log File Management

To be able to configure the log file management, you have to select the Log Files check
box.

In the Directory field you can enter the path of the log storage directory or you can browse
forit by clicking . By default, the logs will be saved in the directory: C:\EVSLogs\MAD\
[Application name].

If the A New Log Every Day check box is selected, a new log file is started every day.
By default, this option is not selected.

You can also specify a time interval (in days) after which the logs should be removed from
the log storage directory. If you enter -1’, the logs are never removed from the storage
directory. By default, the logs are cleaned up after 90 days.

Configuring the LogMemo Size

In the LogMemo group box you can specify the maximum number of lines retained by the
Log pane. By default, the Log pane displays 256 lines.

10

3. Configuring the Application
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3.2.3. Oracle Connection Tab

The Oracle Connection tab allows you to configure the connection with the Oracle
database.

Oracle login

: databaze name
Login narne :

Uze thiz login name

Uze autologin

4 & pplication histary

p contiection alive interyal :

time(z]

iy Test Dracle

Entering the Database Name

In this field you have to enter the name of the database the application has to connect to.

If the Use This Database Name check box is selected, the name of the database will
automatically appear in the Oracle login dialog box at start-up.

Entering the Login Name

In this field you have to enter a login name. If the Use This Login Name check box is
selected, the login name will automatically appear in the Oracle login dialog box at start-

up.
Entering a Password
In this field you have to enter a password. If the Use Auto Login check box is selected,

the application automatically logs into the selected database at start-up. The Oracle login
dialog box does not appear.

3. Configuring the Application 11
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Checking Application History

By clicking the Application History button, you can open a chronological list of all
software versions of the application. To get more details about each version (creation
date, name of programmer, status, additional remarks), you have to click + next to the
version number.

Activating Keep Alive

If the option Keep Connection Alive is selected, a message is sent to the database at
regular time intervals to avoid idle connections from being closed by the firewall. These
intervals can be set by you.

If the option Try to Reconnect if Keep Alive Fails is selected, the application will try a
number of times to reconnect with the database.

If the option Report Status in Database Everytime Keep Alive Timer Triggers is
selected, the status of the connection is reported in the database each time the Keep
Alive Timer sends a trigger to send a Keep Connection Alive message.

If the option Report Status of Tasks is selected, the status of the tasks (ok or not ok) is
reported to the database.

Testing the Oracle Connection

The Test Oracle button allows you to check the validity of the database name, login and
username you entered.

If these data are valid, then the following message appears next to the Test Oracle
button: ‘OK’.

If the login name or password is invalid, then a message box appears with the following
message: ‘ORA-01017: invalid username/password; logon denied’.

If the database name is invalid, then a message box appears with the following message:
‘ORA-12154:TNS: could not resolve the connect identifier specified’.

If you omit the password, then a message box appears with the following message:
‘ORA-01005: null password given; logon denied’.

If you do not enter a database name, login and usermame, then a message box appears
with the following message: ‘ORA-12560: TNS: protocol adapter error’.

You can also check the software version of the application by clicking the Test Oracle
button. If the software version is up-to-date, then the following message appears:
‘Current— The Current Version'. If the software version is outdated, then the following
message appears: ‘Unknown Version Application! Please contact the EDP department.’

If you close the Settings window without testing the validity of the database name, login
and username you just entered, then a message box appears.

Information

12
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3.2.4.

If you click Yes, then the Settings window is closed and the original values are restored. If
you click Cancel, then the Settings window does not close and you can test the values by
clicking the Test Oracle button.

If you change the current database settings, test the connection and then close the
Settings window, a message box will appear.

Information

If you click Yes, the application is stopped and closed. A manual restart will be required.
Click Cancel to continue.

E-Mail Options Tab

In case the application is capable of sending e-mail messages, the E-Mail Options tab will
allow you to configure an e-mail account, enter the e-mail address of the default sender
and recipients, and enter a default e-mail subject. If the application is not capable of
sending e-mail messages, the settings in this tab cannot be used.

B Send email
SHTP login
Tirme-out :

[

Intemal mail settings  Extermal mail settings

Frorm:

To be able to configure the e-mail account, you have to select the Send E-Mail check
box. The fields in the Mail System Settings and Mail Message Settings group box become
available.

Configuring an E-Mail Account
In the Mail System Settings group box you have to enter the IP address and port number

of the SMTP server and specify a timeout. In the SMTP Login group box you can enter a
user name and password.

3. Configuring the Application 13
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Configuring a Default E-Mail Message

The Mail Message Settings group box contains two tabs: Internal Mail Settings and
External Mail Settings.

The Internal Mail Settings tab can be used to configure a default e-mail message that will
be sent to the EVS developers and the customer when an error occurs.

The External Mail Settings tab can be used to configure a default e-mail message that will
be sent to the customer to notify him about an error. In each tab you have to enter the
sender’s email address, the email address of the various recipients and a subject. It
should be noted that this tab is not always used.

When you insert multiple e-mail addresses in any of the header fields, make sure you
separate them by a comma.

To test the settings and manually send an e-mail message, click the Send Mail button.

For the new settings to take effect, close and restart the application. Check the TOM.ini
file in the installation folder of the application for the e-mail addresses and subject entered
here.

[General]

TemporaryFiles. Text=edtTemporaryFilesDir
Emailwanted. Checked=0

Port. Text=25

HOSTID. Text=

Timeout. Text=5000

SMTPLogin. Checked=1

Mailuser. Text=

MailPasswd. Text=ylcwaD8bs1hdK17uHg8knw==
MailPasswdUnicode. Text=79CIGqDro/FCDBASFhtZkw=—
Mal [From. Text=

MailTo. Text=

MailCc. Text=

MailBcc. Text=
Mailsubject. Text=
ExternMailFrom. Text=
ExternMailTo. Text=
ExternMailCc. Text=
ExternMailBcc. Text=
ExternMailsubject. Text=
cb5avescreenbumpUnHand [edErrors. Checked=1
chsaveunforcederrors. Checked=1
cbsavescreenbumphandledErrors. Checked=1
cbautomaticLogin. Checked=0
chuseknownDatabase. Checked=0
chuseThisLogin. Checked=0
chkkeepConnectionalive.Checked=0
chkTryToreconnect. Checked=0

14
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3.2.5.

3.2.6.

Timers Tab

The Timers tab allows you to set time intervals for some automated tasks.

Perforr

Time betwee

Configuring Auto-Start

In the Auto Start group box you can specify the time interval after which the application
automatically starts performing its tasks. By default, this is set to 10 seconds.

Setting a Time Interval Between Tasks

In the Perform Tasks group box you can specify the length of the time interval (in
seconds) between two subsequent tasks. By default, this is set to 30 seconds.

Tasks Tab

The Tasks tab gives an overview of the active tasks.

Active by de Active

In the Active by Default column you can activate the tasks that must be performed by
default at start-up by selecting the corresponding check box. The Active column displays
the tasks that are currently selected in the main window.

The Synchronize Licenses task should be activated

3. Configuring the Application 15
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