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Survey distance calculation (T10)
The Survey Distance Calculator calculates the total distance travelled in one or more 
surveys, based on the flight data recorded.  You can use the results for accounting 
purposes.

You can choose which parts of the surveys to include in the calculation according to 
survey, flight and traverse line numbers.  INTREPID will graphically display flight 
paths of the selected data if required.

You can choose whether to calculate the distance accurately from point to point or 
assume that each traverse line is approximately straight and use the end points of 
the traverse lines.

If you are processing unprojected data (data with geographical coordinates– latitude 
and longitude), you can specify the average height of the survey above the datum for 
the purposes of the calculation.

Projections and measurement units
If the data is projected, INTREPID assumes that it has already been transformed 
into a suitable coordinate system with distances in metres. It therefore does not 
transform the input data and calculates distances by simply integrating along each 
individual traverse line, The resultant distances will naturally depend on the 
projection used.

If the data is unprojected, INTREPID assumes that its location data has geographic 
coordinates (latitude and longitude) relative to the AGD84 datum.  INTREPID 
calculates all distances along the surface of the AGD84 ellipsoid using Robbin's 
formula.  INTREPID  allows for a nominal height of the survey area above the 
datum.1

1. The current version of INTREPID can only calculate survey distance for unprojected 
data in geographic coordinates relative to the AGD84 datum.  If your unprojected data has 
a different datum, you must transform it to AGD84 before using this tool.  INTREPID 
cannot calculate survey distance for unprojected data in metres (i.e., data with projection 
RAW).  If you regularly process unprojected data which is 'raw' or has a different datum, we 
can customise the tool for you.  Please contact our technical support service for further 
information.
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Using the Survey Distance Calculator tool

>> To use the Survey Distance Calculator with the INTREPID graphic user 
interface
1 From the Utility menu in the Project Manager, choose Survey Distance 

Calculator, or use the command sdist.exe.  INTREPID displays the Survey 
Distance Calculator tool. 

2 If you have previously prepared file specifications and parameter settings for 
Survey Distance Calculator, load the corresponding task specification file using 
Load Options from the File menu.  (See Specifying input and output files for 
information about specifying files).  If all of the specifications are correct in this 
file, go to step 9.  If you wish to modify any settings, carry out the following steps 
as required.  

3 Specify the dataset to be processed.  Use Open Input Dataset from the File menu.  
(See Specifying input and output files for information about specifying files).  

4 Specify the report output file if required.  Use Specify Output Report from the 
File menu.  (See Specifying input and output files for information about specifying 
files).  

5 Specify the traverse lines you wish to include in the calculation.  Choose Select 
Lines from the Options menu and complete the Traverse Line Ranges dialog box.  
(See Selecting the traverse lines to include in the calculation for details). 

6 Select whether to perform the calculation in Accurate mode (point to point 
measurements) or Standard mode (whole line measurements).  Use Accurate 
from the Options menu  (See Specifying the precision of the distance calculations 
for details). 

7 Select whether to display the flight paths of the traverse lines as they are 
processed.  Use Plot Flight Path from the Options menu.   (See Graphic display of 
the flight paths calculated for details). 

8 If you are processing unprojected data, specify the average height of the survey 
above the datum.  Use Altitude from the Altitude menu.  (See Specifying the 
average survey height for details). 

9 When you have made specifications according to your requirements, choose Apply.  
INTREPID will perform the calculation. 

10 If you wish to record the specifications for this process in a task specification 
(.job) file in order to repeat a similar task later or for some other reason, use 
Save Options from the File menu.  (See Displaying options and using task 
specification files for detailed instructions.)
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11 If you wish to repeat the process, repeat steps 2–10, varying the specifications as 
required.

12 To exit from Survey Distance Calculator, choose Quit from the File menu.
___

To view the current set of specifications choose Show from the Survey Distance 
Calculator window. INTREPID displays them in a separate window.   See Displaying 
options and using task specification files for details and an example of a set of 
specifications. 

You can view Help information by choosing options from the Help menu (See Help). 

You can execute Survey Distance Calculator as a batch task using a task specification 
(.job) file that you have previously prepared.  See Displaying options and using task 
specification files for details. 

Specifying input and output files
To use Survey Distance Calculator, you will need to specify: 
• The line dataset whose distance is to be calculated, 
• The file name for the report if you wish to save it.
Choose the options as required from the File menu.  

In each case INTREPID displays an Open dialog box.  Use the directory and file 
selector to locate the file you require.  (See "Specifying input and output files" in 
Introduction to INTREPID (R02) for information about specifying files).  

Vector dataset notes:  INTREPID will identify fields for the process from the 
dataset aliases.  The dataset must have the following aliases identifying appropriate 
fields. 

See "Vector dataset field aliases" in INTREPID database, file and data structures 
(R05) for more information about aliases.
Open Input Dataset Use this to specify the line dataset for the data you wish to 

process.  INTREPID uses the dataset aliases to determine the field names for the 
X,Y (location) data (See "Vector dataset field aliases" in INTREPID database, file 
and data structures (R05) for details).  

Alias Field

X X coordinate (location)

Y Y coordinate (location)

LineNumber Line number field

FlightNumber Flight number field
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Specify Output Report INTREPID creates a report of the calculation.  You can 
instruct INTREPID to save the report by specifying a file name for the report.  
(See Survey Distance Calculator reports for more information about the report).

Load Options If you wish to use an existing task specification file to specify the 
survey distance calculation, use this menu option to specify the task specification 
file required.  INTREPID will load the file and use its contents to set all of the 
parameters for the survey distance calculation.  (See Displaying options and using 
task specification files for more information ).

Save Options If you wish to save the current Survey Distance Calculator file 
specifications and parameter settings as a task specification file, use this menu 
option to specify the filename and save the file.  (See Displaying options and using 
task specification files for more information).

Selecting the traverse lines to include in the calculation
You can select traverse lines to be included in the calculation by specifying ranges of 
survey and/or flight and/or traverse line numbers.  You can only specify one range at 
each level.

>> To select traverse lines for inclusion in the calculation,
1 Choose Select lines from the Options menu.

INTREPID displays the Traverse Line Ranges dialog box.

2 Complete the dialog box with the lower and upper survey/flight/traverse line 
number limits, then choose OK.  The default values are 0 and 999999 at all levels.
INTREPID will restrict the calculation to the traverse lines whose identifications 
fall within the ranges you specified.  It displays a tick against Select Lines in the 
Options menu.

>> To disable Select Lines and include the whole dataset in the calculation
Choose Select Lines from the Options menu again when it has a tick against it.  
INTREPID will turn off the Select Lines option and remove the tick. 
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Graphic display of the flight paths calculated
INTREPID can display graphically the flight paths of the traverse lines included in 
the calculation.  The display appears in the Survey Distance Calculator window.  

The Plot Flight Path option in the Options menu indicates whether INTREPID 
displays the flight paths.  You can turn it on and off by choosing it.  If it is turned on 
(showing a tick), INTREPID displays the flight paths.  If it is turned off (not showing 
a tick), INTREPID will not display the flight paths.

Survey Distance Calculator reports
The Survey Distance Calculator displays a report of its results in a scrollable report 
window.  You can dismiss the report window by choosing Done in the report window.  
The window will reappear if another message is sent to it.  You can save the report as 
an ASCII file if required.  (See Specifying input and output files for instructions).
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Specifying the precision of the distance calculations
You can choose whether to 
• Calculate the distance accurately from point to point along the traverse lines (i.e., 

calculate distances between each successive pair of X, Y coordinates and sum 
these distances),

• Assume that each traverse line is approximately straight and use the end points 
of the traverse line.  (If data gaps exist in the traverse line, INTREPID 
approximates each continuously defined section by a straight line. In other words, 
INTREPID ignores data gaps.)

___

The Accurate option in the Options menu indicates which method INTREPID will 
use.  You can turn it on and off by choosing it.  If it is turned on (showing a tick), 
INTREPID will use the point to point measurement method.  If it is turned off (not 
showing a tick), INTREPID will use the whole traverse line measurement method.  

Specifying the average survey height
If you are processing unprojected data, distances will differ slightly at different 
heights.  You can specify the average height of the survey above the datum. 

>> To specify the average survey height
Choose Altitude from the Altitude menu.

INTREPID displays the Average Survey Height dialog box.

Specify the average survey height above the datum (above sea-level) and choose OK.  
INTREPID will use this parameter in the calculation. 

Note:  Even though the menu and dialog box refer to Altitude, INTREPID requires 
and uses the average survey height above the datum.  Future versions of INTREPID 
will correct this discrepancy. 

Apply
When you choose Apply, INTREPID performs the survey distance calculation, 
displaying the flight paths and/or saving the report file if required. 
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Help
You can use the help menu to display help text on the topics shown in the menu 
illustration below.

Exit
To exit from Survey Distance Calculator choose Quit from the File menu.

Displaying options and using task specification files 
Displaying options

>> To display the current task specifications
Choose Show from the Survey Distance Calculator window.  INTREPID displays the 
current file specifications and parameter settings in a report window.

Using task specification files
You can store sets of specifications for Survey Distance Calculator in task 
specification (.job) files.  

>> To create a task specification file with the Survey Distance Calculator tool
1 Specify all files and parameters.
2 If possible, execute the task (choose Apply) to ensure that it will work.
3 Choose Save Options from the File menu.  Specify a task specification file 

(INTREPID will add the extension .job)  INTREPID will create the file with the 
current parameters. 

For full instructions on creating and editing task specification files see INTREPID 
task specification (.job) files (R06) files.

>> To use a task specification file in an interactive Survey Distance 
Calculator session
Load the task specification (.job) file (File menu, Load Options), modify any settings 
as required, then choose Apply. 

>> To use a task specification file for a batch mode Survey Distance 
Calculator task
1 Type the command sdist.exe with the switch -batch followed by the name (and 

path if necessary) of the task specification file.  
For example, if you had a task specification file called surv_cal.job in the current 
directory you would use the command

sdist.exe -batch surv_cal.job
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Task specification file example
Here is an example of an Survey Distance Calculator task specification file.

Process Begin
   Name = surveyDistance
   DataBase = /disk1/surveys/p538/SEC/
   Parameters Begin
      ReportFile = ""
      SelectLines = No
      PlotFlightPath = No
      Accurate = Yes
      Altitude = 0.00
      MinSurveyNumber = 0
      MaxSurveyNumber = 999999
      MinFlightNumber = 0
      MaxFlightNumber = 999999
      MinLineNumber = 0
      MaxLineNumber = 999999
   Parameters End
Process End
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