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INSTRUCTIONS FOR USE—WARNING

This product is conform to the 89/336/EEC Directive. It complies with the ITE EN55022 standard for
EMC emissions and generic 50082-1 (1992 edition) immunity standards.

This product is an FCC Class-A apparatus. In a residential environment, it may cause
radioelectrical disturbances.

In addition, this programming board is not contained in an outer casing; consequently, it cannot be
immune against electrostatic discharges (ESD). It should therefore be handled only in static safe
working areas. Please refer to Appendix A Safety Requirements on page 15 for relevant safety
information
so
lete

so
lete

USE IN LIFE SUPPORT DEVICES OR SYSTEMS MUST BE EXPRESSLY AUTHORIZED.

STMicroelectronics PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN
LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS WRITTEN APPROVAL OF
STMicroelectronics. As used herein:
1. Life support devices or systems are those
which (a) are intended for surgical implant into
the body, or (b) support or sustain life, and whose
failure to perform, when properly used in
accordance with instructions for use provided
with the product, can be reasonably expected to
result in significant injury to the user.
2. A critical component is any component of a life
support device or system whose failure to
perform can reasonably be expected to cause the
failure of the life support device or system, or to
affect its safety or effectiveness. 
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1 INTRODUCTION

The STICK provides the programming hardware interface between your ST7 and
your host PC, running either ST7 Visual Programmer (STVP7) or ST7 Visual
Develop (STVD7) software.

The STICK takes advantage of the In-Circuit Communication (ICC) protocol for
ST7 to provide both in-circuit programming (ICP) of the ST7 soldered on your
application board, or socket programming of your microcontroller using an
ST7SBxx socket board.

Thanks for choosing ST7! This manual will help
you get started programming your ST7
microcontrollers with your ST7 FLASH STICK. 

The ST In-circuit Communication Kit (STICK)
is a powerful, flexible programming tool that is
ideal when you are getting started developing
applications in the world of ST7 Flash
microcontrollers.

Figure 1: Programming configurations

In-Circuit Programming 
Configuration

Socket Programming 
Configuration

STVP7 or STVD7,
ST7 FLASH STICK 

ST7 on your application board

STVP7 or STVD7,
ST7 FLASH STICK,

ST7SBxx Socket Board
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The STICK is delivered ”ready-to-use” for in-circuit programming of an MCU that
has been installed on a properly configured application board. However, socket
programming of ST7 MCUs requires an additional ST7SBxx socket board. For
more information about socket programming with the STICK, you can refer to the
ST7SBxx Socket Board User Guide.

1.1 About this manual...

This manual will help you set up your STICK programming tool and connect it to
your PC. Here you will find:

• Setup instructions

• Detailed hardware information

• A trouble shooting guide for your programming tool

For more information about the hardware and software intended for use with your
STICK, refer to the following documents:

ST7 Visual Programmer online help– information about the STVP7 programming
interface

ST7 Visual Develop User Manual– information about the STVD7 programming
interface

ST7SBxx Socket Board User Guide– setup information for socket programming

ST7xxxx Datasheet– includes information about ICC connection and micro-
controller programming that is specific to your MCU

1.1.1 Revision history

Date Revision Description

Nov 2000 1.1 • Updated Section 1.2 – includes support of windows XP

Jun 2001 1.2 • Added Table 1 – Revision history table

• Added Section 2.3 – setting up ICP connection

• Added Section 3.1 – programming from STVD7

Table 1: STICK User Manual Revision History
5/26
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1.2 Host PC system requirements

Both hardware and software components of the STICK have been designed to
work with PCs meeting the following requirements:

• One of the following operating systems: Microsoft® Windows® 98, 2000,

Millennium, NT® or XP®.

• Intel® Pentium (or compatible) processor with minimum speed of 133 MHz.

• Minimum RAM of 32 MB (64 MB recommended).

• 50 MB of free hard disk space to install all of the ST7 tools.

• Parallel port

Note: Windows® 2000, NT® and XP users must have administrator privileges to install the required
software.

1.3 Getting assistance

For more information, application notes, FAQs and software updates on all the ST
microcontroller families, check the CD-ROM or our website:

www.st.com/mcu

For assistance on all ST microcontroller subjects, for help using your programming
tools, refer to the contact list provided in Product Support on page 23. We’ll be glad
to help you!
6/26
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2 GETTING STARTED

2.1 Delivery checklist

Check that your ST7 FLASH STICK contains the following:

• One STICK interface board (marked “ST7 FLASH STICK-LPT”).

• One AC/DC power supply adaptor.

• One PC parallel port cable.

• One 10-pin HE10 type ribbon cable for ICC connectors.

• The “Microcontroller Development Tools” CD-ROM containing ST7 Visual
Programmer (STVP7) software, ST7 Visual Develop (STVD7) and other ST7
software development tools.

2.2 Setting up the hardware

1 Set the W1 jumper on your STICK to correspond to the application power
supply (VDD).

The W1 jumper must be set to one of the three following positions:

- VDD: The power supply voltage of the STICK’s ICC buffer follows the VDD

used by your ST7. This position allows you to work with any power supply
voltage supported by your MCU (refer to your ST7xxxx Datasheet for
supported VDD). When the jumper is in this position, you must connect the

application power supply to pin 7 of the ICC connector.

Figure 2: STICK component layout

Power supply 
connector (J2)

W1 Jumper

ICC connector 
(JP1)

Test Points (TP1)
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- 5 V: The power supply voltage of the STICK’s ICC buffer is 5 V. You don’t
need to connect the application VDD to pin 7 of the ICC connector, but your

application must be powered by 5 V +/- 5%.

- 3.3 V: The power supply voltage of the STICK’s ICC buffer is 3.3 V. You
don’t need to connect the application VDD to pin 7 of the ICC connector, but

your application must be powered by 3.3 V +/- 5%.

2 Connect the STICK to the parallel port of your host PC with the supplied
parallel cable.

Note: Be sure to use the provided PC parallel port cable—using a longer cable may cause
malfunctions. Connect the cable directly between the host PC and the STICK—using
additional cables or switch boxes between the host PC and the STICK may cause
malfunctions.
If a dongle is already connected to the PC’s parallel port, it should not interfere with the
STICK. However, if your STICK malfunctions, remove the dongle and restart the setup.

3 Power on the STICK using the provided AC/DC power supply, which you plug
into the J2 connector. Ensure that the power supply is adapted to the mains
voltage and outlet type used in your country.

4 Connect the ICC cable to the ICC connectors on your STICK (JP1) and your
application board (for more information about installing an ICC connector on
your application board, refer to Section 2.3).

5 Power up your application board.

You are now ready to program your ST7. For more information about the
programming sequence, refer to Chapter 3:  Programming with STVD7 or STVP7
on page 12, or refer to your software’s on-line help file.
8/26
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2.3 In-circuit programming considerations

The In-Circuit Communication (ICC) protocol for ST7 makes it possible to in-circuit
program your application to an ST7 FLASH microcontroller while the device is
mounted on your application board. However, when you start developing your
application, you must integrate an ICC connector into your application hardware.
To help you implement in-circuit programming (ICP) in the development of your
application, this section provides a summary of points you should consider when
installing an ICC connector.

2.3.1 ICC Connection Requirements

To connect to your application board for ICP, you must
install a 10-pin, HE-10 type connector, which receives the
STICK’s ICC cable and relays the required signals to the
ST7 on your application board.

Using the In-Circuit Communication (ICC) protocol for ICP
requires that a minimum of 4 and as many as 6 pins of
your ST7 be connected to the STICK (see Figure 3, below
and Table 1 on page 10).

Figure 3: ICC interface

HE-10 type 
connector

ST7 FLASH 
STICK
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Isolation of ICCDATA and ICCCLK pins

As soon as your STICK is plugged into the application board the ICCDATA and
ICCCLK pins must not be used by other application devices, even if you are not
programming your MCU. If the application uses these pins as inputs, isolation such
as a serial resistor must be implemented to prevent other application devices from
forcing a signal on either of these pins. The application board must not drive
current in excess of 1mA.

If the ICCDATA and ICCCLK pins are only used as outputs by the application, no
signal isolation is necessary.

For ST7 MCUs with no ICCSEL pin, during normal operation the ICCCLK pin must
be pulled-up internally or externally (10KΩ pull-up required in noisy environments).
This is to avoid entering ICC mode unintentionally during a reset. For more
information, refer to the ST7 ICC Protocol Reference Manual.

Isolation of the RESET pin

During a programming session, you must ensure that the programming tool
controls the ST7’s RESET pin so that no external reset is generated by the
application. This can lead to a conflict if the application reset circuitry signal
exceeds 5mA (push-pull output or pull-up resistor <1k). To avoid such conflicts, a
Shottky diode can be used to isolate the application reset circuit.

ST7 pin Connects to

ICCDATA ICC input serial data pin ICCDATA

ICCCLK ICC output serial clock pin ICCCLK

RESET Device reset ICCRESET

ICCSEL/VPP Programming voltage ICCSEL/VPP

OSC1 or OSCIN * Main clock input for external ICCOSC

VDD * Device power supply VDD_APPLI

VSS Device power supply (ground) GND

* Optional connection for the STICK, see text.

Table 1: ICC connection requirements
10/26
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ICCSEL/VPP pin

The application pull-down resistor must not be lower than 10kΩ.

ICCOSC pin * 

The ICCOSC pin of the ICC connector must be connected to the ST7’s OSC1 or
OSCIN pin if the clock is not provided by the application, or if the application clock
source is not programmed in the option byte. This connection allows you to start
your ICP session using the ICP OPT Disable programming mode. In this mode,
the STICK provides a clock source to initiate communication with the ST7 at a
frequency of 8MHz.

For ST7 devices with multi-oscillator capability, when the ICCOSC pin is
connected, the OSC2 pin should be grounded.

If your application provides a clock signal and you are certain that it is programmed
in the ST7’s option byte, you can start your ICP session using the ICP OPT Enable
programming mode. In this mode, your application clock source provides the clock
signal for initiating communication with your ST7 and ICCOSC is not connected to
your ST7.

VDD_APPLI pin *

This pin is used by the programming tool’s power supply follower, which adapts the
voltage of the tool’s signals to your application’s VDD. If the application board VDD
is equal to 5v or 3.3v, VDD_APPLI is not connected. However, the W1 jumper must
be set to the appropriate position (5v or 3.3v). For all other VDD values supported
by your ST7 (refer to your ST7xxxx Datasheet), this pin must be connected and the
W1 jumper set to the VDD position.
11/26
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3 PROGRAMMING WITH STVD7 OR STVP7

You can configure and control the programming of your ST7 with ST7 Visual
Programmer (STVP7) or ST7 Visual Develop (STVD7) software running on your
host PC. This chapter provides a brief procedure to help you get started
programming with each software. For more details refer to their respective on-line
help files.

3.1 Start programming with STVD7

1 Launch STVD7.

2 Open the workspace and project that you used when developing your
application. You will have selected your MCU during the early stages of
application development.

3 Select Tools>Programmer.

4 Configure the options in the Settings tab:

- Board: STICK

- Port: LPT1 or LPT2

- Check Erase Before Programming if you are reprogramming an MCU
with HDFlash memory.

- Programming Mode:

If your ST7’s option byte does not include OSCTYPE, then ICP is the only
in-circuit programming mode available to you.

Note: For some of the most recent circuits that include OSCTYPE, ICP programming mode is
available instead of ICP OPT Disable or Enable.

If your ST7’s option byte includes OSCTYPE, then you can choose:

ICP OPT Disable– a safe mode that must be used if your application clock
circuitry doesn’t match the OSCTYPE option byte selection. In this mode,
an external source with a square wave signal from 0 V to VDD must be

provided either by the STICK via the ICC connector pin 9 (ICCOSC safe
clock), or your application. 

ICP OPT Enable– used only if your application clock circuitry matches the
OSCTYPE option byte selection. In this case, the ICC connector pin 9 is
not connected and the ICCOSC safe clock is not used.

5 Power on your application board and connect the ICC cable between your
STICK and the application.
12/26
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6 Select the Memory Area tab then select a memory area. Click on Add, then
use the browse window to identify the file (.s19, .hex) to program the selected
memory area with. Repeat this step as necessary for each memory area.

7 Select the Option Byte tab to configure any option byte settings.

8 Select the Program tab and click on Start to program your ST7.

3.2 Start programming with STVP7

The following describes a basic procedure for programming your application to
your MCU without creating a project in STVP7.

Note: Setting up a project is a way of configuring STVP7 so that you can use the same
configuration each time you run STVP7. For more information about projects, refer to
STVP7’s on-line help.

1 Launch STVP7

2 In the Configuration window specify:

- Hardware: STICK

- Port: LPT1 or LPT2

- Programming mode:

Select ICP mode if your ST7’s option byte does not include OSCTYPE. The
Device field will change to show the list of devices that only use this mode.

Note: For some of the most recent circuits that include OSCTYPE, ICP programming mode is
available instead of ICP OPT Disable or Enable.

If your ST7’s option byte does include OSCTYPE, you can choose one of
the following options:

ICP OPT Disable– a safe mode that must be used if your application clock
circuitry doesn’t match the OSCTYPE option byte selection. In this mode,
an external source with a square wave signal from 0 V to VDD must be

provided either by the STICK via the ICC connector pin 9 (ICCOSC safe
clock), or your application.

ICP OPT Enable– used only if your application clock circuitry matches the
OSCTYPE option byte selection. In this case, the ICC connector pin 9 is
not connected and the ICCOSC safe clock is not used.

When you choose one of the modes, the Device field will display the list of
devices that support these modes.
13/26
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- Device:

Select the name of your MCU from the list in the Device field. Keep in mind
that the list displayed for ICP mode is different from that displayed for the
other two in-circuit programming modes.

3 Erase memory before reprogramming (HDFlash only) by selecting
Erase>Active sector(s). If you want the memory to be erased systematically
before programming, you can activate the Erase Device Memory Before
Programming feature (Edit>Preferences).

4 Select files (.s19, .sx, .hex) for programming to memory areas. Select the tab
for the memory area (for example, PROGRAM MEMORY or DATA MEMORY),
then select File>Open. Locate the file using the resulting browse window and
click on Open.

5 Select the Option Byte tab. Option bytes can be configured using the list boxes
in this tab or by loading a HEX or S19 file with the previously used option byte
settings. To program option bytes from a file, select the Option Byte tab, then
click on File>Open to load the file containing the option byte settings.

6 Program your ST7 by selecting Program>All Tabs (on active sectors, if any).

7 Check the content by selecting Verify>All Tabs (on active sectors, if any). If
you want to check the programmed content systematically after programming,
ensure that the Verify After Programming feature is activated
(Edit>Preferences)
14/26
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STICK User Manual Appendix A Safety Requirements

15/26

APPENDIX A SAFETY REQUIREMENTS

• Any tester, equipment, or tool used at any production step, or for any
manipulation of semiconductor devices, have its shield connected to ground.

• The product must be placed on a conductive table top, made of steel or clean
aluminum, or covered by an antistatic surface (superficial resistivity equal to or

higher than 0.5 MΩ/cm2), grounded through a ground cable (conductive cable
from protected equipment to ground isolated with a 1 MΩ resistor placed in
series). All manipulation of finished goods must be done at such a grounded
worktable.

• The worktable   free of all non-antistatic plastic objects.

• An antistatic floor covering grounded through a conductive ground cable (with
serial resistor between 0.9 and 1.5 MΩ) should be used.

• It is recommended that you wear an antistatic wrist or ankle strap, connected to
the antistatic floor covering or to the grounded equipment. 

• If no antistatic wrist or ankle strap is worn, before each manipulation of the
powered-on tool, you touch the surface of the grounded worktable.

• It is recommended that antistatic gloves or finger coats be worn.

• It is recommended that nylon clothing be avoided while performing any
manipulation of parts.
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APPENDIX B: TROUBLESHOOTING

This appendix covers some of the problems that may occur, and how to solve
them.

B.1 Test pins

The STICK is equipped with test pins located at TP1 (see board layout in Figure 2
on page 7). If you have problems with programming, these pins can help you
pinpoint anomalies in the ICC communication by testing or checking the ICC
signals. 

Pin Signal Description

1 GND This pin is marked with a white dot.

2 Power The external power supply value can be checked 
here. It is an unregulated 12 V DC power supply. 
Its value should be in the range 13.5 V to 23 V 
depending on the current load.

3 VCC The VCC is regulated at 5 V +/- 5%.

4 VCC_a This is the operational amplifier output that follows 
the voltage value selected by the W1 jumper. It 
should be equal to:

• your application VDD voltage value if W1 is in
the VDD position,

• 5 V if W1 is in the 5 V position,
• 3.3 V if W1 is in the 3.3 V position.

5 ICCSEL_VPP This signal may be at 0 V, 5 V or 12 V. This test 
point is used during factory test. You do not have 
to check it.

Table 1 Test pins
16/26
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B.2 Error messages

The following sections explain the cause of some common error messages.

B.2.1 “PC parallel port cable not connected”

Most communication failures between the host PC and the STICK stem from
problems in the parallel port connection. To prevent communication problems,
when setting up your parallel port connection:

• Use the parallel cable provided with your STICK—using a longer parallel cable
may cause malfunctions. 

• Connect the cable directly between the host PC and STICK interface board—
the insertion of additional cables or switch boxes between the host PC and the
interface board may cause malfunctions.

• Remove any parallel port dongles.

• Ensure that the parallel port address is in the range 03BC-03BF or 0378-037F
or 0278-027F.

• Ensure that the parallel port is not disabled in your PC. For example, in the

IBM® ThinkPad™, you can select “infrared printing (LPT) port on”.

B.3 “Problem on supply voltages”

When you have supply voltage problems the green LED will not come on. To find
the cause of the problem:

• Check that the AC/DC power supply adaptor is firmly connected to both the
main power supply and to the STICK interface board. To check that the main
power supply is on, disconnect the ICC cable and measure the voltage on test
pin 2 of TP1 (see Test pins on page 16). This pin should have an unregulated
DC value in the range 18 V to 21 V. 

Note: Ground is on TP1 pin 1 (white dot mark).

• Check that the W1 jumper is set to one of the three positions, see Section 2.2
on page 7. If it is set on the “VDD” position, check that the ICC cable is
connected properly and that your application’s VDD is connected to ICC
connector pin 7. Your application VDD must be in the range 2.4 V to 5 V. The
voltage measured on test pin 4 of TP1 (see Test pins on page 16), must be the
same voltage value that you selected with the W1 jumper.

• Check that there is 5 V on test pin 3 of TP1 (see Test pins on page 16).
17/26
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If you have made all of these checks and you still get the “Problem on supply
voltages” message, contact your ST distributor or sales office (see Product
Support on page 23) in order to have your STICK repaired.

B.4 “Cannot communicate with the device”

Check that:

• The ICC cable is correctly connected.

• You have selected the right ST7 device.

• The ICC signals are clear and within the following ranges:

- ICCDATA: This application signal must not drive more than 1 mA.

- ICCCLK: This application signal must not drive more than 1 mA.

- ICCRESET: This application signal must not drive more than 5 mA.

- ICCSEL_VPP: The pull-down resistor must not be lower than 10 kOhm.

• You have selected the right programming mode (see Chapter 3 on page 12).
Remember that:

- If you use ICP OPT Enable mode, check that your application clock
circuitry does match the CLOCK SOURCE and OSCTYPE options already
programmed in the ST7 Flash microcontroller option byte. For devices out
of factory you have to check these values in datasheet. If you don’t know
these values you have to select ICP OPT Disable.

- ICP OPT Disable mode, ensure that external source clock is a square
wave signal from 0 V to VDD. If not, you have to connect ICCOSC safe
clock (ICC connector pin 9) to the OSC1 pin of the ST7Flash
microcontroller in your application
18/26
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APPENDIX C: GLOSSARY

This appendix gives a brief definition of acronyms and names used in this manual.

HDFlash

High density FLASH memory is based on FLASH technology. HDFlash is used for
microcontrollers with 4K up to 60Kbytes of FLASH memory. It is programmed byte
by byte but erased by sector.

ICC protocol

In-Circuit Communication protocol is a way of exchanging data between an
ST7 Flash microcontroller and an external system (i.e. PC) using minimum
hardware and ST7 I/Os in the user application. In the ST7 Flash microcontrollers,
this protocol is handled by the ICC monitor.

ICC monitor

Software that handles the ICC protocol, embedded in a reserved memory area of
the ST7 Flash microcontroller. At RESET, using specific signal sequence, the ST7
jumps to this ICC monitor which allows it to download programs in RAM and to
execute them. This feature is used to implement the ICP functionality.

In-Circuit Programming (ICP)

This is programming the ST7 FLASH memory while ST7 Flash microcontroller is
plugged into the application board.

In-Circuit Testing (ICT)

This is testing ST7 Flash micro and/or your application through the ST7 Flash
microcontroller while it is plugged into the application board.

In-Circuit Debugging (ICD)

This is debugging your application while the ST7 Flash microcontroller is plugged
into the application board. 

ST7 Flash microcontroller 

An ST7 microcontroller with electrically erasable memory that can be either XFlash
or HDFlash memory.

STICK

ST In-circuit Communication Kit. 
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XFlash

Extended FLASH memory is based on EEPROM technology. XFlash provides
extended features such as byte re-programming (by means of byte erasing) and
data EEPROM capability. XFlash microcontrollers are available between 1K to
16 Kbytes.
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PRODUCT SUPPORT

If you experience any problems with this product, contact the distributor or the
STMicroelectronics sales office where you purchased the product. Phone numbers
for major sales regions are provided in the Contact List, below.

In addition, at our Internet site www.st.com/mcu, you will find a complete listing of
ST sales offices and distributors, as well as documentation, software downloads
and user discussion groups to help you answer questions and stay up to date with
our latest product developments.

Software updates
All our latest software and related documentation are available for download from
the ST Internet site, www.st.com/mcu. 

Hardware spare parts
Your development tool comes with the hardware you need to set it up, connect it to
your PC and connect to your application. However, some components can be
bought separately if you need additional ones. You can order extra components,
such as sockets and adapters, from STMicroelectronics, from the component
manufacturer or from a distributor.

To help you find what you need, a listing of accessories for ST development tools
is available on the ST internet site, www.st.com/mcu. 
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Contact List

North America

Canada and East Coast

STMicroelectronics
Lexington Corporate Center
10 Maguire Road, Building 1, 3rd floor
Lexington, MA 02421
Phone: (781) 402-2650

Mid West

STMicroelectronics
1300 East Woodfield Road, Suite 410
Schaumburg, IL 60173
Phone: (847) 585-3000

West coast

STMicroelectronics, Inc.
1060 E. Brokaw Road
San Jose, CA 95131
Phone: (408) 452-8585

Note: For American and Canadian customers seeking technical support the US/
Canada is split in 3 territories. According to your area, contact the appropriate
sales office from the list above and ask to be transferred to an 8-bit
microcontroller Field Applications Engineer.

Europe

France +33 (0)1 47 40 75 75
Germany +49 89 46 00 60
U.K. +44 162 889 0800

Asia/Pacific Region

Japan +81 3 3280 4120
Hong-Kong +85 2 2861 5700
Sydney +61 2 9580 3811
Taipei +88 6 2 2378 8088
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consequences of use of such information nor for any infringement of patents or other rights of third parties which may result from its use.
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