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1 Introduction

CAESARII® is a PC-based program developed and marketed by COADE
Engineering Physics Software, Inc, USA. It is an engineering tool used
in the mechanical design and analysis of piping systems.

The PDMS to CAESARII interface (STRESS-C) extracts data from
PDMS databases and outputs a CAESAR neutral file, which is
suitable for input into CAESARII. Details of CAESARII neutral files are
given in the CAESARII User's Manual.

This release of the PDMS - STRESS-C interface version 2.4.1 is
compatible with CAESARII version 4.20. PDMS STRESS-C is based on
PDMS DARs Mk11.3SP1 and runs under Windows NT Version 4.0
(Service Pack 5).

Please check the letter accompanying the StressC release for any
changes to these versions, as this manual is not always revised for each
new release.
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2 Before You Begin

It is assumed that you are familiar with the following:

•  CAESARII

•  The general principles of pipe stress analysis techniques.

•  PDMS operations and PDMS databases.

•  If you want to set up a Properties database containing the physical
properties of pipes, you should also be familiar with PDMS
PROPCON.

For more information on CAESARII, refer to the CAESARII User's
Manual. For more information on PDMS refer to the PDMS manuals; in
particular, the PDMS DESIGN Reference Manual and the PDMS
PROPCON Reference Manual.
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3 Data for Pipe Stressing

The PDMS Design and Catalogue databases contain the 3D geometry
data on which a PDMS Model is based. The databases also contain
administrative and control data relating to pipes and components, the
relationships between them, and a description of each item. The design
data extracted by the STRESS-C interface consists of information such
as Positions, Pipe Diameters, Pipe Thickness, etc.

In order to use the PDMS model for pipe stressing, additional data
describing the physical properties of the piping components is required.
This data includes material property and component property data. You
can set up a PDMS Properties database to store this information using
PDMS PROPCON, or the Interface can use default values. The default
values can be replaced in CAESAR II if necessary. The default values
are for low carbon steel or material code 1, details of which are given in
the CAESARII Quick Reference Guide.

There are two types of data extracted from a PDMS Properties database:
Material Property Data and Component Property Data. Sections 3.1 and
3.2 describe how the property data is extracted if the PDMS Properties
database is set.

3.1 Material Property Data

The material property data in a Properties database is only accessed if
appropriate reference attributes are set in DESIGN. The reference
attributes that must be set are MATR (Material Reference) and FLUR
(Fluid Reference) for PDMS Branches. These reference attributes point
from the Branch to elements in the Properties database.

•  The Material Reference (MATR) is used to obtain:
Young's modulus
Poisson's Ratio
Expansion Coefficient
Pipe Density.

•  The Fluid Reference (FLUR) is used to extract Fluid Density.

See Appendix A for more details.
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3.2 Component Property Data

Like the Catalogue database, the Component Property data in the
Properties database is referenced from the specification component
(SPCO). The Properties database is referenced from the component
reference (CMPR) whereas the Catalogue database is referenced from
the catalogue reference (CATR). These references are independent,
which means that there is not necessarily a one-to-one relationship
between catalogue component and the property component.

The component hierarchy in the Properties database is as follows:

•  CMPW (component world)

•  CMPT (component type)

•  CMPD (component data)

•  TUBD (tube data)

The TUBD and CMPD elements store the physical data, and it is these
elements which are referenced by the component reference (CMPR). The
Outside Diameter (OUTD), Actual Bore (ACBO), Component Weight
(CWEI) and Corrosion Allowance (CORA) attributes of these elements
are the component properties which are accessed by the interface. For
more details see Appendix A.

Note that implied tube must always have a TUBD data element in the
Properties database. The SPCO for implied tube is referenced by the
branch head tube specification (HSTU) and the component leave tube
specification (LSTU).
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4 Input to STRESS-C

PDMS Pipes and Branches are the only PDMS elements that the
interface can process. If you input a Branch, the interface will process all
Branches belonging to the owner Pipe of the input Branch.

It is possible to extract a piping network. It is, however, the user's
responsibility to make sure that the pipes within a network are
connected correctly. If the program finds that a connection does not
exist, it will prompt you with an indication of where the problem is by
displaying a database reference of the element.

Note the following points about design data input to the interface:

•  Branches with bores less than or equal to 2 inches or 50 millimetres
will not be processed, unless the -b option is given on the command
line (see section 7).

•  Pipe bores that are not included in a predefined table stored in the
interface will not be processed. Pipes must have actual bores in the
range 0.84 inch to 48 inches for Imperial units and 21.34 millimetres
to 1219.2 millimetres for metric units. See Appendix B for the details
of these tables.

•  Piping Components must have ISODRAFT Symbol Keys.

•  Connection References of the model must be correct.

•  ATTA elements whose ATTY attribute is either unset or set to NUL
are assumed to be supports and will be transferred. Any other ATTA
elements will be ignored.

•  The memory allocation for the STRESS-C processing uses the base
memory allocation quantity N1 described in the Generic Neutral
Files section of the Caesar II Technical Reference Manual. The
default value for N1 is 2000, unless the –n option is given on the
command line (see section 7).

The main exclusions of the functionality for this implementation are:

•  Restraint data.

•  Tees are not recognised.
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•  Some PDMS elements are skipped, including:
GASK, NOZZ, LJSE, PCLA, SHU, VENT, WELD

•  Records are not generated in the CAESARII file in the following
cases:

•  FLAN components with SKEYs set to FLLB or FLBL.

•  INST components with SKEYs set to IDPL or IDFL.

•  PCOM components with SKEYs set to PL, SP, SR, SB, EX or FX.

If any of these components are at the end of a pipe run, the dimensions
for the last items could be affected because appropriate records have not
been created.

The interface currently creates single nodal records for components such
as Tees and standard Elbows. If these components do not have off-leg or
out-leg connections in the model, the dimensions and the model for these
components may be affected in CAESAR II.
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5 Output from STRESS-C

The interface generates two text files:

•  The text file with a .cii suffix is the CAESARII neutral file that is
used as an input file to the CAESARII program. This file consists of
all the data necessary to perform an analysis in the CAESARII
program. The .cii files will have to be transferred to a PC where they
can be read in by CAESARII.

•  The text file with a .dat suffix is a work file that contains the
connection reference information for the pipes. This file gives you
information on the elements processed and their nodal location with
respect to each other. It is not required by CAESARII.

The first section of the .dat file contains information on pipe head,
pipe tail, component connection references, and positional data. The
second section contains the from node and to node data. This section
mimics the CAESARII Data Matrix file format. Additional fields are
inserted to show the from element type and to element type.
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6 Installing STRESS-C

STRESS-C is a PDMS DARs (Data Access Routines) based application
and therefore must be used within a PDMS environment. The
environment variables required by PDMS are also required by
STRESS-C. The PDMS environment must exist as outlined in the
PDMS Installation Guide.

The interface works with the FLEXMAN security system.

In order to install STRESS-C, insert the CD and follow the instructions.
After extracting the release, your main Cadcentre product release
directory will contain a new subdirectory named StressC241.

During the installation, the PDMS main folder is located. This folder
name is then used to update the RUN_STRESSC.BAT file by adding the
PDMS DARs directory into the PATH environment variable. This
enables STRESS-C to find the DARs Dynamic Link Library (DLL) at
run time.

Note that is possible to install PDMS without installing the DARs
system. If this has been done, re-run the PDMS Installation to add
DARs.

RUN_STRESSC.BAT can be run from the MS-DOS command line, this
will allow you to run the interface from any directory. For an interactive
STRESS-C session, run RUN_STRESSC.BAT without any command line
arguments. For a batch session run it with the name of the file
containing the batch commands as the command line argument. Extra
STRESS-C program arguments can be specified in the
STRESSC_OPTIONS environment variable.

For command line use, you can set up a command alias to run STRESS-
C from any directory, eg, if STRESS-C is installed in
C:\CADCENTRE\StressC241:

doskey stressc=C:\CADCENTRE\StressC241\run_stressc.bat $*

The CD supplied by Cadcentre also contains some examples, a README
file and a PDMS test project. The details on how to run STRESS-C
using the examples are given in the README file.
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6.1 Installing the Cadcentre Sitefile

You will need to obtain licences for the appropriate version of STRESS-
C  (currently 2.4.1) from Cadcentre for each machine to be used.

Please now read the FLEXMAN Installation Guide for instructions on
setting up your sitefile.

6.2 Testing the Installation

This section explains how to use the confidence tests supplied with
STRESS-C (the PDMS to CAESARII Interface) program. Please check
the readme.txt file in the installation folder for any updated
instructions.

Note that the test project TVO is an optional component of the
Installation, but is installed by default. The confidence tests require this
project.

The installation folder should contain the following:

tvo000 A PDMS test project for STRESS-C

readme.txt A file containing any updated instructions for
running the confidence tests

RES_CADC Results produced from running STRESS-C at
CADCentre Ltd

RES_YOU Results to be produced from running STRESS-C
by YOU

StressC.exe PDMS to CAESARII Interface

Snapshots Folder which includes screen snapshots of the
three pipes generated by the interface; see below
(eg pipe1)

run_stressc.bat Script to set up the environment for and run the
STRESS-C executable in interactive or batch
mode.

diff_results.bat Script to compare results in RES_YOU against
RES_CADC  

testit.bat Script to run the STRESS-C installation test in
batch mode

testit.in File containing the commands for the batch
mode installation test
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6.2.1 Running the Installation Test in Batch Mode

1. Open a Command-Prompt window,
(for example by choosing Programs > Command Prompt from the
Start-menu)

2. Change to the StressC installation disc and folder, for example
cd /d C:\cadcentre\StressC241

3. Run the test script:
testit

This script (testit.bat) takes input commands from the testit.in file, and
writes its results into the RES_YOU folder.

4. Run the comparison script
diff_results

This script (diff_results.bat) compares the standard results supplied in
RES_CADC with those you have just created. There should be no major
numerical differences.

Files with extensions ".cii" in the folder "RES_YOU" are CAESARII
neutral files and may be transferred to CAESARII for stress analysis.
All these files have their rigid weights set. In CAESARII, you need to set
at least one anchor point. Read the STRESS-C User Guide, especially
Appendix C (C.5 Rigid Weights and Anchors); you do not need to set
rigid weights, unless you want to modify the existing weights.

The snapshots of the pipes you have just processed are in the snapshots
folder. Read the file Readme.txt from that folder.

6.2.2 Running the Installation Test Interactively

This section details the interactive equivalent to the testit script used
above.
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1. Open a Command-Prompt window,
(for example by choosing Programs > Command Prompt from the
Start-menu)

2. Set up a command alias for the interface, eg:
doskey
stressc=C:\CADCENTRE\StressC241\run_stressc.bat $*

3. Change to the RES_YOU sub-folder of the STRESS-C installation
folder, for example
cd /d C:\cadcentre\StressC241\RES_YOU

4. Run STRESS-C by typing the alias name, eg:
stressc

5. If everything is OK, the interface will produce some prompts and
messages and require user's input as follows.

User responses are shown in Bold Italic, like this. The Enter, or
Carriage Return key is shown as ����. Some lines have been slightly
modified, and some blank lines removed to improve the layout.

*********************************************************
* *
* STRESS-C Version 2.4.1 (Jul 24 2001) *
* Cadcentre Ltd. Copyright (c) 1995 through 2001 *
* *
* PDMS to CAESARII Neutral File Output *
*********************************************************

Enter Project Name (<cr> to quit) .....: TVO����
Enter Username/Password (<cr> to quit) : SYSTEM/XXXXXX����

PDMS Professional DARs C Interface Mk11.3.SP1 (WINDOWS-NT 4.0)
(19 Apr 2001 09:49)
This version of PDMS was issued to Cadcentre Altrincham
and will only operate on hardware specified to CADCENTRE

PDMS Professional DARs Mk11.3.SP1 (WINDOWS-NT 4.0) (19 Apr 2001
: 09:49)
Copyright CADCENTRE 1974 to 2001.
Issued to Cadcentre Altrincham

Enter MDB Name (<cr> to quit) .........: /APPLIC����
Current Units are MM Bore MM Dist
Enter Pipe name, or <cr> to process, or <q> to quit: /100-B-1����
Enter Pipe name, or <cr> to process, or <q> to quit: ����

Enter CAESARII output file name...: PIPE1����

** Creating CAESARII output file PIPE1.cii **
** Creating CAESARII output file PIPE1.dat **
**WARNING** Material reference not set. /100-B-1-B1
**WARNING** Fluid reference not set. /100-B-1-B1
**WARNING** Material reference not set. /100-B-1-B2
**WARNING** Fluid reference not set. /100-B-1-B2
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**WARNING** Material reference not set. /100-B-1-B3
**WARNING** Fluid reference not set. /100-B-1-B3

Process another Pipe? Y/N : Y����

Enter Pipe name, or <cr> to process, or <q> to quit: /250-B-5����
Enter Pipe name, or <cr> to process, or <q> to quit: ����

Enter CAESARII output file name...: PIPE2����

** Creating CAESARII output file PIPE2.cii **
** Creating CAESARII output file PIPE2.dat **
**WARNING** Material reference not set. /250-B-5-B1
**WARNING** Fluid reference not set. /250-B-5-B1
**WARNING** Material reference not set. /250-B-5-B2
**WARNING** Fluid reference not set. /250-B-5-B2

Process another Pipe? Y/N : Y����
Enter Pipe name, or <cr> to process, or <q> to quit: /100-C-12����
Enter Pipe name, or <cr> to process, or <q> to quit: /100-C-15����
Enter Pipe name, or <cr> to process, or <q> to quit: /100-C-16����
Enter Pipe name, or <cr> to process, or <q> to quit: ����

Enter CAESARII output file name...: PIPE3����

** Creating CAESARII output file PIPE3.cii **
** Creating CAESARII output file PIPE3.dat **
**WARNING** Material reference not set. /100-C-12-B
**WARNING** Fluid reference not set. /100-C-12-B
**WARNING** Material reference not set. /100-C-12-B1
**WARNING** Fluid reference not set. /100-C-12-B1
**WARNING** Material reference not set. /100-C-12-B2
**WARNING** Fluid reference not set. /100-C-12-B2
**WARNING** Material reference not set. /100-C-12-B3
**WARNING** Fluid reference not set. /100-C-12-B3
**WARNING** Material reference not set. /100-C-12-B4
**WARNING** Fluid reference not set. /100-C-12-B4
**WARNING** Material reference not set. /100-C-12-B5
**WARNING** Fluid reference not set. /100-C-12-B5
**WARNING** Material reference not set. /100-C-12-B6
**WARNING** Fluid reference not set. /100-C-12-B6
**WARNING** Material reference not set. /100-C-12-B7
**WARNING** Fluid reference not set. /100-C-12-B7
**WARNING** Material reference not set. /100-C-12-B8
**WARNING** Fluid reference not set. /100-C-12-B8

Process another Pipe? Y/N : N����
Success

6.3 Troubleshooting the Installation

6.3.1 StressC License

To run STRESS-C you must have a FLEXMAN License for both Stress-
C itself, and also for PDMS.
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If you do not have the correct licenses, or if they have expired, or if your
FLEXMAN setup is incorrect you may receive the following error
message:

***** FATAL SITEFILE ERROR *****

Please contact your CADCENTRE Support representative.

6.3.2 Environment Variables

STRESS-C, like PDMS, requires several environment variables to be
set up. The run_stressc.bat script sets up all those required to run the
examples, but you may need to modify this script to add the
environment variables for your own projects.

The relevant variables are:

PDMSEXE The main PDMS Executable folder, for example
set PDMSEXE=C:\CADCENTRE\pdms11.3
This folder is used, among other things, to locate the
PDMS message file.

PATH The Windows search path, used to find among other
things, DLLs needed by STRESS-C. This should
include both the PDMSEXE folder, and its dars
subfolder, eg
PATH
%PDMSEXE%;%PDMSEXE%\dars;%PATH%

XXX000
(where XXX is
the project code)

The location of the Project database, eg for project
TVO:
set
TVO000=C:\CADCENTRE\StressC241\tvo000

XXXMAC
(where XXX is
the project code)

Another Project location, eg for project TVO:
set
TVO000=C:\CADCENTRE\StressC241\tvomac
(Note that although this variable has to be set up,
the corresponding folder need not exist!)

If the PATH is incorrectly set up, STRESS-C may be unable to find the
DARs DLL (see section 6.3.3).

If the project variables are not set up STRESS-C may report:
Enter Project Name (<cr> to quit) .....: XXX����
Environment variable XXX000 not set for Project XXX
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If the project variables are set up but not correctly, then the DARs
library within STRESS-C may report:
(43,59) Unable to open system DB for project XXX. Is your
environment variable set correctly?
(43,58) Unable to open template database for project

6.3.3 The DARs DLL

If, when you execute STRESS-C, you get a popup containing words
similar to
StressC.exe - Unable To Locate DLL

The dynamic link library d3lib.dll could not be found in your path. You
need to add the location of d3lib.dll (perhaps
c:\CADCENTRE\PDMS11.3\dars) to your PATH, or possibly copy
d3lib.dll to the same directory as the .exe.

6.3.4 The PDMS Message File

If the PDMS message file cannot be located, or is incorrect, the message
INVALID CALL TO D3EMSG may be issued.

If this occurs, ensure that:

•  The variable %PDMSEXE% is pointing to the correct PDMS 11.3
folder

•  The %PDMSEXE% folder contains the files modmac.mac,
message.dat and attlib.dat

•  The file modmac.mac in that folder contains text similar to:
$( $)
$( MODULE 84 DARS $)
$( $)
MODULE 84 DARS
M DESI R
M CATA R
M PROP R
M PADD R
M DICT R
M DESI DEFAULT
BUFFER 2560000
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7 Using STRESS-C

7.1 Invoking STRESS-C

The interface can be started up on an MS-DOS command line by typing:

StressC.exe [-v <version number>] [-b <minimum pipe bore>]
 [-n <base memory allocation>] [-batch] [-help]

The text within the square brackets denotes the command line options
described in section 7.3.

The environment conditions that are required for running StressC.exe
are defined by the run_stressc.bat file.

Alternatively, you can select the following options from the Start menu:

Start > Programs > CADCENTRE > StressC241 > Run StressC241

This will start up the interface without any command line options.

7.2 Command Line Options

The following command line options are available:

-v <version number>
This allows you to state which version of Caesar II is being used. Before
version 3.22 the headers are short, whereas they are long in this and
subsequent versions. Additional fields are added to the output format of
the .cii files when version 4.20 is selected. The STRESS-C default is to
produce version 4.20 output format.

-b <minimum pipe bore>
This allows you to define the minimum pipe bore to be processed. The
pipe bore is specified in the project units, and internal conversions are
made. The default is 2.0in. (50.8mm).
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-n <base memory allocation>
This allows you to set the base memory allocation quantity N1 described
in the Generic Neutral Files section of the Caesar II Technical Reference
Manual. The N1 value (and fractions of it) set internal table sizes for
STRESS-C processing. The default value for N1 is 2000, unless the –n
option is given on the command line.

-batch

This option allows you to run STRESS-C without needing to input the
project name, user name and password interactively. This means that
STRESS-C jobs can be fully predefined and run or rerun as required.
Batch mode does not prompt when an existing .cii file is to be
overwritten.

See below for further details.

-help

This option causes the STRESS-C program to display its banner and
details of its usage from the command line.

7.3 Interaction with STRESS-C

When you start up STRESS-C, the interface banner is displayed along
with the PDMS DARs and operating system version. For example:
*********************************************************
* *
* STRESS-C Version 2.4.1 (Jul 24 2001) *
* Cadcentre Ltd. Copyright (c) 1995 through 2001 *
* *
* PDMS to CAESARII Neutral File Output *
*********************************************************

PDMS Professional DARs C Interface Mk11.3.SP1 (WINDOWS-NT 4.0)
(19 Apr 2001 09:49)

You will be requested to enter the project name.
Enter Project Name (<cr> to quit) .....: TVO����

You will be requested to enter the username and password.
Enter Username/Password (<cr> to quit) : SYSTEM/XXXXXX����

You will be prompted to enter the MDB name. The name must be a
PDMS name preceded by an optional slash. After the MDB name has
been entered, the current project units will be reported. This information
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is used to determine the conversion units that will be passed to
CAESAR.
Enter MDB Name (<cr> to quit) .........: /APPLIC����

You will be prompted to enter the name of the pipes to be processed. The
names must be valid PDMS names preceded by an optional slash. The
program accepts more than one pipe (i.e. a network of pipes) by entering
the pipe names at the prompt. A carriage return entered here signifies
the end of inputting pipes. Quitting from the program is possible by
entering 'Q'.

You will then be prompted to enter the name of the output file, which
will be input into CAESARII. CAESARII requires that input filenames
for jobs should not be longer than six characters. The name does not
require a preceding slash. It can be a full path name. If the file already
exists, you will be prompted as to whether the file should be overwritten
or not.
Enter Pipe name, or <cr> to process, or <Q> to quit: /3"-B-14����
Enter Pipe name, or <cr> to process, or <Q> to quit: ����
Enter CAESARII output file name. Must be (6) characters or less ..:
PIPE1����
C3DAT.cii exists. Overwrite Y/N ? Y����
** Creating CAESARII ouput file PIPE1.cii **
** Creating CAESARII ouput file PIPE1.dat **

The interface creates two files based on the output filename, one
filename with an extension .cii and one filename with the extension
.dat (for example: PIPE1.cii and PIPE1.dat).

STRESS-C will generate warning messages during processing to help
you resolve any problems before the information is imported into
CAESARII. Warnings will be generated for material and fluid references
that are not set at the branch being processed, as well as pipe bores that
are not found in the internal bore tables.

 For example:
**WARNING** Fluid reference not set. /3"-B-14/1
**WARNING** Fluid reference not set. /3"-B-14/2
**WARNING** No matching pipe bore found.
**WARNING** Branch bore is less than 2.00in.

Branch will not be processed.
**WARNING** Branch bore is less than 2.00in.

Branch will not be processed.
**WARNING** Branch bore is less than 2.00in.

Branch will not be processed.

After successful completion of the run you are prompted:
Process another Pipe? Y/N : N����
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If you press Y in response to the prompt, the interface will go back to the
beginning and ask for the pipe to be processed and the output filename.
If you press N or just press RETURN the program will exit with the
message:
Success

Sample .dat and .cii output files are supplied on the installation tape or
CD.

CAESARII can load the files produced by the interface to display and
analyse the pipes (see Appendix C)

7.4 Batch Operation of STRESS-C

STRESS-C operates in batch mode when it is run with the command line
–batch option and requires a file containing details of the job.

Form a file containing all of the replies that would be entered just as
when STRESS-C is run interactively, each on a new line. There will be
no prompt about overwriting an existing .cii file, so always omit this
from the file. Remember to include a blank line where the user is
prompted supply a <cr> to quit supplying pipe names.

Here is what the file job1.in would contain for the previous interactive
example:
TVO
USER/PASSWORD
/MASTER
/3”-B-14

PIPE1
N

The batch job would then be run using the run_stressc.bat script with
the command:

run_stressc job1.in

CAESARII can load the files produced by the interface to display and
analyse the pipes (see Appendix C).
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8 Error Messages

As the interface processes the Pipes, it may come across some errors in
the model. The interface will output error messages describing the
nature of the error and then stop. You can then carry on with another
pipe or you can correct the model from within PDMS. Once the model is
corrected, you can re-run the pipe that had errors.

The formats of such errors are:
Element not connected: <element reference number>

Pipe/Branch: <PDMS element name> --> Attribute name

Piping-Component/Propcon Ref: --> Attribute name

Where <PDMS element name> is the name of the element where the
error exists and Attribute name indicates the attribute with the fault.

Attribute name may be one of the following:
HBORE
PHEAD
HREF
HREF (Type)
TBORE
PTAIL
TREF
TREF (Type)
Ppoint (0)
CREF
REF
CRFA
MATR
FLUR
TYPE
"Problems with Attributes"
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9 Notes on the Translation

•  Node numbering starts from 10 and is incremented by 10.

•  PDMS ATTA numbering starts from 20,000 and is incremented by
10. You can use ATTAs as Anchor points in CAESARII.

•  Connection References start from 25,000 and are incremented by 10.

•  The orientation displayed in CAESARII is the same as PDMS ISO 3
from DESIGN.

•  Conversion units (that is, project units) are extracted from PDMS
Design databases: Imperial units are ENGLISH in CAESARII, metric
units are SI in CAESARII. If the project units are imperial, the
CAESARII output file will be in ENGLISH units.
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Appendix A - Properties

This Appendix lists the properties that can be extracted from a
Properties database, and the elements that store the values. The default
values are based on a low carbon steel or material code 1, and they are
used if a Properties database is not accessed.

Young's Modulus
If the element TYOU exists, the value of the element YOUN will be
used.

The default value is 29500000.0.

Poisson's Ratio
If the element TPOI exists, the value of the element POIS will be used.

The default value is 0.292.

Expansion Coefficient
If the element TEXP exists, the value of the element EXPA will be used.

The default value is the value of the Design attribute TEMP for the
Branch.

Material Density
If the element TDEN exists, the value of the element DENS will be used.

The default value is 0.28993.

Fluid Data
If the element TDEN exists, the value of the element DENS will be used.

The default value is 0.0.

Wall Thickness
If the Outside Diameter (OUTD) and Actual Bore (ABOR) elements are
set, wall thickness can be calculated.

The default value is 0.25 inches (6.35 mm).

Corrosion
If Component data for Properties Database is set, the corrosion
allowance is extracted from the attribute CORA.
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The default value is 0.0.

Component Weight
If Component data for Properties Database is set, then component
weight is extracted from attribute CWEI.

The default value is 0.0.
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Appendix B - Bore Sizes Used

This Appendix presents the tables of actual bore sizes used in the
interface. The interface allows bore sizes within the ranges included in
the tables below:

Actual bores allowed in Imperial units are:

0.840 1.050 1.315 1.660 1.900 2.375 2.875

3.500 4.000 4.500 5.563 6.625 8.625 10.750

12.750 14.000 16.000 18.000 20.000 22.000 24.000

26.000 28.000 30.000 32.000 34.000 36.000 42.000

48.000

Actual bores allowed in Metric units are:

21.34 26.67 33.40 42.16 48.26 60.33 73.03

88.90 101.60 114.30 168.28 219.08 273.05 323.85

355.60 406.40 457.20 508.00 558.80 609.60 660.40

711.20 762.00 812.80 863.80 914.40 965.20 1016.00

1066.80 1117.60 1168.40 1219.20



PDMS - STRESS-C User Guide
Version 2.4.1

26

Appendix C - Loading the CAESAR file into
CAESAR

This Appendix gives a brief explanation of how the CAESAR file
produced from the interface can be loaded into CAESAR. You can ignore
this Section if you are familiar with the CAESARII and running the
External Interfaces from the CAESARII menus.

C.1 Creating "_A" file:

Once a .cii file is generated by the interface, it should be transferred to a
PC where CAESAR program can be run. You can then run CAESARII.

When the CAESARII window appears, bring up the Neutral File
Generator for from the main menu:

Tools > External Interfaces > CAESAR II Neutral File

Set the conversion type to Convert Neutral File to CAESAR II Input File
and browse to select the .cii file. Pressing the convert button will create
a ._A file in the same directory.

C.2 Converting Units

The units are already included in the .cii file. If you require to change
the units, then bring up the Caesar II Input File Units Conversion form
from the main menu: Tools > Convert Input to New Units.

Select the ._A file created above as the input file; select the new units
and the name of the new ._A file. Press the OK button to perform the
conversion.

C.3 Inputting the Data

From the main menu, open the required ._A file. All the data generated
by the interface should now be visible.
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C.4 Viewing the Data

If you want to look at the data graphically, bring up the Piping Input
form from the main menu: Input > Piping.

From the main menu of this form bring up the required graphical view
form: Plot > Standard Graphics or Plot > 2D Modeler.

If you require to view it in spreadsheet format select: Edit > List.

C.5 Rigid Weights and Anchors

You can input Rigid Weights for all valid elements which can have rigid
weights (for example, Valves, Flanges, Pcoms, etc. Note that Bends do
not have rigid weights).

You should also enter at least one Anchor point; this can be done while
using the Piping Input form from the main menu: Input > Piping.

Decide where the Anchor should be placed and move to its element with
the CaesarII user interface and then add a Restraint of type Anchor. The
piping can be checked by selecting: File > Start Run.

C.6 Error Checking and Analysis

Error checking can be done using the Piping Input form. Display this by
selecting from the main menu: Input > Piping

The piping can be checked from the Piping Input main form by selecting:
File > Start Run.

This will perform a series of checks on the elements if there are no fatal
errors during this stage, you can then activate File > Batch Run from
the "PIPING QUIT MENU" to continue with the static analysis of the
run. An analysis is carried out and you should be able to activate
appropriate options (i.e. Statics option from the main menu) to see the
results. The CAESARII User Manual explains further how to start the
analysis process and how to view the results.
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