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1 IGESDXFTOMAYA
CONVERTER

IgesDxfToMaya is a stand-alone OpenModel application available on UNIX and
Windows. It converts IGES and DXF files to Maya ASCII files using OpenModel.
Most of the information in those data files are provided by OpenModel in its own
data structures from which the IgesDxfToMaya converter retrieves the information,
re-organizes it, and outputs it in Maya ASCII file format.

RUNNING IGESDXFTOMAYA

There are two ways in which you can use the IgesDxfToMaya converter to load IGES
and DXF files into Maya: Interactively and Batch mode (recommended).

Interactively
You can drag-and-drop, open, or import an IGES|DXF file directly in Maya. As soon
as Maya recognizes the file type, it spawns a separate process to run the
IgesDxfToMaya converter, generates a temporary Maya ASCII file, loads the Maya
file, and deletes it after loading.

The advantage of this approach is a relatively simple workflow. However, it is
inefficient to convert the IGES|DXF file everytime it is loaded into Maya, especially
when the conversion process has approximately the same memory requirements as
Maya. This large amount of memory consumption is due to the the size of the
OpenModel DSOs (Dynamically Shared Objects), which is the first reason why we
designed this converter to be a stand-alone application. It is more efficient to use the
following approach to bring IGES|DXF files into Maya.

Batch mode (recommended)
You run the IgesDxfToMaya converter from a shell window to convert the
IGES|DXF file to a Maya ASCII file and load the resulting file into Maya. You only
need to convert your file once and use the converted Maya file in subsequent
loadings. The IgesDxfToMaya command is located in the same directory as the Maya
executable. Its command line syntax and various options are explained in the next
section.
MAYA TRANSLATORS
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IGESDXFTOMAYA CONVERTER | 1
IgesDxfToMaya command
IGESDXFTOMAYA COMMAND

Syntax:

IgesDxfToMaya [iges|dxf file name] [options]

Example:

IgesDxfToMaya example.dxf -o example.ma

General options

IGES file options

Notes:

• The options for converting IGES|DXF files are only available when
you use the converter in the batch mode.

• All the options, except the specification of the output file name (-o),
are used by OpenModel functions for retrieving information. These
options are based on the Alias import options.

Option Values Default Description

-o any string none Output file name

Option Values Default Description

-g on | off off When set to on, all geometry retrieved
from the IGES file will be grouped under
a node named “IGES_FILE”. Otherwise,
this group node will not be created.

-c on | off off When set to on, multiple knots are
removed based on continuity in IGES
Parametric Curve and Surface geometry.

-a on | off off When set to on, supported geometric
entities that have been flagged for use as
annotation are retrieved. Otherwise,
ignored.
MAYA TRANSLATORS

6



IGESDXFTOMAYA CONVERTER | 1
IgesDxfToMaya command
DXF file options

-tts on | off on When set to on, retrieved trimmed or
bounded surfaces whose boundaries are
the same as, or iso-parametric to, the
natural boundaries of the untrimmed
surface, are converted to untrimmed
surfaces by shrinking the surface to the
trim boundaries. Otherwise, trimmed
surfaces are represented as trimmed
surfaces.

-ttf on | off off When set to on, retrieved trimmed or
bounded surfaces that are planar are
converted to face geometry in
OpenModel. Maya will convert it back to
a trimmed surface.

-s any number 1.0 All retrieved geometry is scaled by this
factor in world space.

Option Values Default Description

-g on | off off When set to on, all geometry retrieved
from the DXF file is grouped under a
node named “DXF_FILE”. Otherwise,
this group node will not be created.

-ls on | off on Determines whether or not shaders are to
be loaded from the “shader” sub-
directory of the current project.

-ab on | off off Determines whether “anonymous” DXF
BLOCK entities are processed or ignored.
Anonymous blocks are automatically
generated by the AutoCAD “HATCH”
command and represent the hatch lines
used to pattern polygons.

-ft polyset |
surface

polyset This indicates the type of geometry
resulting from conversion of DXF
3DFACE, SOLID, and TRACE entities.

-pt polyset |
surface

polyset This indicates the type of geometry
resulting from conversion of DXF
POLYLINE and LINE entities.

Option Values Default Description
MAYA TRANSLATORS
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IGESDXFTOMAYA CONVERTER | 1
IgesDxfToMaya command
-u inches |
miles | feet
| mils |
microinches
| kilom | m
| cm | mm
| microns

inches Set the unit for DXF coordinate data—the
units of the DXF coordinate data are not
stored in the file.

-s any number 1.0 All retrieved geometry is scaled by this
factor in world space.

Option Values Default Description
MAYA TRANSLATORS
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2 STUDIOIMPORT PLUG-IN AND
TRANSLATOR

StudioImport is a translator for Studio wire files (previously known as Alias wire
files) available on IRIX, Windows, and Linux.

LOADING STUDIOIMPORT

To load the StudioImport file Translator:

Once Maya is installed:

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded button for the StudioImport plug-in.

OPENING STUDIO WIRE FILES

To open a Studio wire file:

Select File > Open Scene and select the Studio wire file you want to open from the
file browser selection.

Note

StudioTools v10 now uses a different file format for its wire files. This new
file format should cause no change in your everyday use of StudioTools
because the file provides all of the same capabilities as the old
Alias|Wavefront wire file. This new file format will be compatible with
new releases of StudioTools, so you won't need a translator to use Version
10 files in future releases.
MAYA TRANSLATORS
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STUDIOIMPORT PLUG-IN AND TRANSLATOR | 2
Opening Studio wire files
STUDIOIMPORT CONVERSION ISSUES

The following are known issues for StudioImport conversion as of Maya 4.5.

• Studio SID data is not supported in the StudioImport plug-in.

• Any paint data will not be translated into Maya. SID shapes will translate as Maya
surfaces.

• Poly sets will lose texture coordinates on translation to Maya.

• Area and Linear lights are not transferred correctly.
MAYA TRANSLATORS
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3 EXPORTING FILES FROM
MAYA

For details on exporting to formats other than Maya through the user interface or
plug-ins, please see “Managing Files and Projects” in Using Maya: Essentials.

MAYATOALIAS CONVERTER

MayaToAlias is a Maya plug-in for UNIX and Windows that uses OpenMaya API to
get the scene information from Maya, and then exports it using OpenModel to a wire
file (version 9.7.3) or IGES or DXF file, depending on which export file format is
chosen.

To load the MayaToAlias plug-in:

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded button for the MayaToAlias plug-in.

Now you can export Maya content to wire, IGES, or DXF format through the usual
export mechanism.

To export a Maya file to wire, IGES, or DXF:

1 Select File > Export All or File > Export Selection.

2 Select a file name and file type, and then click Export.

aliasWireExport, IGESexport, and DXFexport are three of the options in the File Type
pull-down menu.

MayaToAlias exports the following from Maya to wire files:

• transform nodes

• hierarchy

• instanced objects

• NURBS curves

• NURBS surfaces

• trimmed surfaces

• meshes
MAYA TRANSLATORS
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EXPORTING FILES FROM MAYA | 3
Exporting to Wavefront (OBJ)
• cameras

MayaToAlias exports the following from Maya to IGES format:

• transform nodes

• instanced objects (become copied objects in IGES)

• NURBS curves

• NURBS surfaces

• trimmed surfaces

• meshes

MayaToAlias exports the following from Maya to DXF format:

• transform nodes

• instanced objects (become copied objects in DXF)

• NURBS curves

• NURBS surfaces

• trimmed surfaces (become surfaces and curves in DXF)

• meshes

Release Notes

• If you get an error message when using MayatoAlias of the form “Creating surface
fails - node [nodename], it is because Studio Tools and Maya have different
requirements for a valid NURBS surface. Valid NURBS surfaces in Maya may not be
valid in Studio Tools, hence they are not created. Usually the problem can be fixed
by changing Open to Periodic in either U or V direction (this can be done by using
the Edit Surfaces > Open/Close Surfaces tool. Ensure that the Surface direction is set
correctly by opening the option box).

EXPORTING TO WAVEFRONT (OBJ)
The objExport plug-in lets you export Maya polygon data to the Wavefront OBJ
ASCII file format. It successfully converts:

• Maya texture coordinate and vertex normal information.

• Maya renderable set information into material names.

• Maya component set information into groups.

To load the objExport plug-in:

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded button for the objExport plug-in.

To export a file in OBJ format:

1 Select File > Export All or File > Export Selection.

2 Choose OBJexport as the file type and then click Export.
MAYA TRANSLATORS
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EXPORTING FILES FROM MAYA | 3
Exporting to RenderMan
For details on exporting to OBJ format, see Using Maya: Essentials.

EXPORTING TO RENDERMAN

The ribExport plug-in adds the new file format RIBexport to the File > Export All...
options menu. This lets you export scenes created in Maya in the RIB (RenderMan)
format.

To load the ribExport plug-in:

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded button for the ribExport plug-in.

To export a file in RIB format:

1 Select File > Export All or File > Export Selection.

2 Select RIBexport as the file type and then click Export.

The plug-in exports NURBS and polygonal geometry. All types of animation in
Maya are supported, including keys, expressions, path, deformations, and motion
blur.

The ribExport plug-in supports ambient, directional, point, and spot lights. Simple
non-textured shaders are supported, although only the shader color is exported; all
other shading attributes are ignored. Phong and Blinn shaders are exported as
“plastic” and Lambert shaders are exported as “matte.” Per-face shading groups are
not supported; only shading groups that are assigned to objects or object instances
are exported.

Note

objExport does not export OBJ formatted curves, surfaces, smoothing
groups, or point group materials. It also does not support NURBS. You
should use the MayaToAlias plug-in for scenes that contain NURBS
surfaces.

Note

Alias|Wavefront provides the source code for the objExport plug-in as part
of the Maya Developer’s Toolkit. Ensure that you have installed the
Toolkit, and you will find the source code in .../devkit/plug-ins/

objExport.cpp.

Note

This plug-in only supports the Export All file access mode. RIB file import
is not supported.
MAYA TRANSLATORS
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EXPORTING FILES FROM MAYA | 3
Exporting to RenderMan
When exporting Maya scenes into RIB, note that the # character is a special
formatting character in RenderMan image names (See section 4.1.10 of the
RenderMan user manual for information on its formatting capabilities). If you want
to include a real # character in a RenderMan image name, you must use “##”.

The image name constructed by the ribExport plug-in includes the contents of the
“imageName” attribute of the renderable cameras. If you want to include the special
RenderMan formatting characters in an image, the imageName attribute is the place
those characters should be placed.

RIBexport Options
Default File
Extensions Specifies whether the .rib extension will be appended to the

specified file name. The .rib extension is not added if the
specified filename already contains that extension.

Single File
Output If Yes, each frame is written to a single file. If No, all frames are

written to one file.

Extension
Padding If the Single File Output option is off, this option specifies whether

the RIB file extensions will be padded with 0’s.

Geometry
Motion Blur Specifies whether geometry motion blur information is written to

the RIB file.

Pixel Samples Specifies the number of samples taken for each pixel. This value
will be used for both the X and Y directions.

Note

Alias|Wavefront provides the source code for the ribExport plug-in as part
of the Maya Developer’s Toolkit. Ensure that you have installed the
Toolkit, and you will find the source code in .../devkit/plug-ins/

ribExport.cpp.
MAYA TRANSLATORS
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4 IGES AND DXF ENTITY
SUPPORT

The following tables list IGES entities supported in Maya and DXF entities supported
in Maya.

IGES ENTITIES SUPPORTED IN MAYA

Type Form IGES Entity

100 0 circular arc

102 0 composite curve

104 0-3 conic arc

106 1 copious data

106 2 copious data

106 11 copious data

106 12 copious data

106 63 closed area

108* 0* plane

108 1 plane

110 0 line

112 0 parametric curve

114 0 parametric surface

118 0-1 ruled surface

120 0 surface of revolution
MAYA TRANSLATORS
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IGES AND DXF ENTITY SUPPORT | 4
DXF entities supported in Maya
DXF ENTITIES SUPPORTED IN MAYA

122 0 tabulated cylinder

124 0 transformation matrix

126 0-5 rational b-spline curve

128 0-9 rational b-spline surface

130 0 offset curve

140 0 offset surface

141 0 boundary entity

142 0 curve on surface

143 0 bounded surface

144 0 trimmed surface

308 0 subfigure definition

402 7,9 associativity instance

406 1 property - definition levels

408 0 singular subfigure instance

406 15 name

DXF Entity

ARC no thickness

ARC with thickness

CIRCLE no thickness

CIRCLE with thickness

POINT, with thickness

LINE/3DLINE no thickness

LINE/3DLINE with thickness

3DFACE/SOLID/TRACE

POLYLINE/3D open

POLYLINE/3D closed
MAYA TRANSLATORS
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IGES AND DXF ENTITY SUPPORT | 4
DXF entities supported in Maya
POLYLINE/3D with thickness

POLYLINE/3D Mesh

POLYLINE/Polyface Mesh

BLOCK

INSERT

LAYER

DXF Entity
MAYA TRANSLATORS

17



IGES AND DXF ENTITY SUPPORT | 4
DXF entities supported in Maya
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5 MAYA OPENFLIGHT
IMPORTER/EXPORTER

The OpenFlight file translator plug-in provides extended functionality to Maya to
help address the needs of the Visual Simulation customer. This is done by providing
a data translator to read the currently existing OpenFlight databases into Maya.
Accompanying the OpenFlight database importer is an OpenFlight Exporter.
Functionality that was found to be missing from Maya was added in the form of new
node types that can be created and edited from within the Maya modeling
environment.

INSTALLING OPENFLIGHT

Run the setup and follow the prompts. OpenFlight will be installed where Maya is
installed. A message similar to the following is displayed:

OpenFlight has found Maya 4.5 at C:\Program 
Files\AliasWavefront\Maya4.5. The software will be installed into 
this location.

LOADING OPENFLIGHT

To load the OpenFlight file Translator:

Once Maya is installed:

1 Open Maya and select Window > Settings/Preferences > Plug-in Manager.

2 Click the loaded button for the Open/Flight plug-in, fltTranslator.

IMPORTING/EXPORTING OPENFLIGHT FILES

OpenFlight is a 3D file format. The file importer/exporter is an OpenMaya plug-in.
Any of the Beads that can be imported into Maya can also be exported (see
"Supported OpenFlight Beads" on page 25).
MAYA TRANSLATORS
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MAYA OPENFLIGHT IMPORTER/EXPORTER | 5
Workflow Considerations
The exported file contains a subset of the imported data. External file or texture
references point to the referenced files in their current directories. Should it be
necessary to move an exported file to a location that does not allow access to the
original file references, these referenced files can be copied into the same directory as
the target OpenFlight file and the references will read correctly.

To open an OpenFlight file:

Select File > Open Scene and select the OpenFlight file you want to open from the
file browser selection.

To export an OpenFlight file:

Select File > Export All (or Export Selection), and choose OpenFlight from the File of
type drop-down list.

Version compatibility
You can read (import) versions from 14.2 up to 15.7, but only export 15.7 files.

WORKFLOW CONSIDERATIONS

The following are workflow issues you should consider when working with
OpenFlight files in Maya.

When importing files
OpenFlight models are built with a Z-up axis up orientation. When a model is read
into Maya using File > Open, the default orientation in Maya is repositioned so that
Z is the up vector (normally Maya’s Y axis is oriented as the up vector).

When files are read into Maya using File > Import, the orientation is not affected by
the import. You must correctly orient the imported data yourself.

When exporting files
Here are some of the limitations to consider when exporting an OpenFlight file from
Maya:

• Models are always exported in color RGB mode.

• The units are always meters.

• No animation can be exported.

• No lights or cameras can be exported.

• The exporter only supports a single texture map per face. Layered textures will
result in only the first texture being exported.

• 2D and 3D procedural textures will not be exported.

• Many Maya rendering parameters have no direct equivalent in OpenFlight.

• Degree of Freedom Beads are only created when Limits are set on a Maya group/
transformation node.
MAYA TRANSLATORS
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MAYA OPENFLIGHT IMPORTER/EXPORTER | 5
Workflow Considerations
When using Switch Nodes
Support has been added to Maya for OpenFlight Switch nodes. Switch nodes allow
for an array of visibility masks to be applied to a group transform node. Each child
node’s visibility is represented by one bit in the visibility mask. (Current
implementation only supports up to 32 children.)

The switch node is implemented as a helper node that is applied to a group
transform node and can be viewed and selected through the Hypergraph. The
currently selected mask can be modified through the Attribute Editor associated
with the switch node.

Switch Nodes are created automatically when an OpenFlight database with Switch
Nodes is read into Maya. They may also be created using the fltSwitch command
from within the Maya modeling environment.

Switch node attributes

fltSwitch Command
Synopsis FltSwitch [flags]

Return Value [string[]] (object name or node name on create)

Description This command is used to create, edit or query Switch Nodes from
within Maya.

Flags -p(c) The parent group transform node.

-cm(eq) Set or query the current switch node mask.

-n(ceq) The name of the node to be operated on.

-am(e) Append a mask based on the current object selection.

-em(e) Edit the currently active mask based on the current object
selection.

-dm(e) Delete the current mask.

Example

// Create a Switch node

fltSwitch -n sw1;

// After some geometry has been added under sw1, masks maybe 
created by selecting the geometry to be visible under the switch 
for the mask and and then using the fltSwitch command as follows.

Name Long (Short) Type Default Flags

outputVis (out) Tint32 0 R

curMask (in) Tint32 0 RWSK

maskWidth (mkw) Tint32 0 RWS

numMasks (nmk) Tint32 0 RWS

masks (mks) Tint32 0 ARWS
MAYA TRANSLATORS

21



MAYA OPENFLIGHT IMPORTER/EXPORTER | 5
Workflow Considerations
fltSwitch -e -am -n sw1;

// Setting the current mask to the desired switch will enable that 
mask.

fltSwitch -e -cm 0 -n sw1;

When using Light Points
Support has been added to Maya for OpenFlight Light Points. Light Points allow for
an array of lights to be created that have no render properties.

Light Points are implemented as a shape in Maya. They are created automatically
when an OpenFlight database with Light Points is read into Maya. Additionally,
Light Points can be created from within Maya using the MEL command,
fltLightPoints.

Each Light Point Shape can contain any number of Light Points. By selecting a Light
Point Shape and opening its Attribute Editor, all Light Points attributes are available.
Many of these attributes have no visible effect within Maya but can still be edited,
saved, and exported.

Light Point attributes

Name Long (Short) Type Default Flags

LightPointsMin (lpmn) double3 0 RWS

LightPointsMax (lpmx) double3 0 RWS

SurfaceMaterialCode (smc) Tint16 0 RWS

FeatureId (fid) Tint16 0 RWS

BackColor (bc) Tint32 0 RWS

DisplayMode (dm) Enum 0 RWS

Intensity (ity) Float 0 RWS

BackIntensity (bit) Float 0 RWS

MinimumDefocus (mndf) Float 0 RWS

MaximumDefocus (mxdf) Float 0 RWS

FadingMode (fm) Tint32 0 RWS

FogPunchMode (fpm) Tint32 0 RWS

DirectionalMode (drm) Tint32 0 RWS

RangeMode (rm) Tint32 0 RWS

MinimumPixelSize (mnps) Float 0 RWS

MaximumPixelSize (mxps) Float 0 RWS
MAYA TRANSLATORS
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Workflow Considerations
fltLightPoints Command
Synopsis fltLightPoints [flags]

ActualSize (aps) Float 0 RWS

TransparentFalloffPixelSize (tfps) Float 0 RWS

TransparentFalloffExponent (tfe) Float 0 RWS

TransparentFalloffScalar (tfs) Float 0 RWS

TransparentFalloffClamp (tfc) Float 0 RWS

FogScalar (fs) Float 0 RWS

SizeDifferenceThreshold (sdt) Float 0 RWS

DirectionalType (drt) Enum 0 RWS

HorizontalLobeAngle (hla) Float 0 RWS

VerticalLobeAngle (vla) Float 0 RWS

DirectionalFallofExponent (dfe) Float 0 RWS

DirectionalAmbientIntensity (dai) Float 0 RWS

AnimationPeriod (ap) Float 0 RWS

AnimationPhaseDelay (apd) Float 0 RWS

AnimationEnabledPeriod (aep) Float 0 RWS

Significance (sig) Float 0 RWS

Calligraphic (call) Tint32 0 RWS

Flags (flgs) Tint32 0 RWS

XanimRotateAxis (xra) Float 0 RWS

YanimRotateAxis (yra) Float 0 RWS

ZanimRotateAxis (zra) Float 0 RWS

LightColors (lc) Double3 0 ARWS

LightNormals (ln) Double3 0 ARWS

InputLightPoints (ilp) 0x58000014 0 RW

OutputLightPoints (olp) 0x58000014 0 RS

WorldLightPoints (wlp) 0x58000014 0 ARS

CachedLightPoints (clp) 0x58000014 0 RWS
MAYA TRANSLATORS
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Workflow Considerations
Return Value [string[]] (object name or node name)

Description This command is used to create Light Points from within Maya.

Flags -d(c) The distance between light points.

-c(c) The number of light points to be created.

-n(c) The node name to be created.

-p(c) The parent group transform node.

-nt(c) If specified, then no parent transform will be created. In this
case a parent must also be specified with the –p flag.

-clr(ce) The RGB color value to be applied to all created light
points. Each value should be in the range from 0.0 - 1.0. In edit
mode if no light points are selected then the light point shape
name must be specified using -n.

-nml(ce) The Normal to be applied to all created light points. In
edit mode if no light points are selected then the light point shape
name must be specified using -n.

Example

// Create 3 light points spaced 0.5 UI units apart

fltLightPoints –c 3 –d 0.5

fltLightsOnCurve Script
Synopsis fltLightsOnCurve [arguments]

Return Value None

Description This script uses an existing curve and creates a given number of
Light Points using the currently selected curve as a placement
guide. The Light Points will be evenly spaced along the curve.

Note—The curve is used for construction purposes only and will be modified by this
script.

To use this script:

1 Create a curve to use as a placement guide for the Light Points.

2 Select the curve and then execute the script.

Example

// Create 3 Red Light Points equally spaced along the selected 
curve

fltLightsOnCurve 3 1.0 0.0 0.0;

Arguments Arg1An integer that specifies the number of Light points to be
created.

Arg2A float that specifies the Red component of the assigned color
for the Light Points (0.0 – 1.0)

Arg3A float that specifies the Green component of the assigned
color for the Light Points (0.0 – 1.0)
MAYA TRANSLATORS
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MAYA OPENFLIGHT IMPORTER/EXPORTER | 5
Supported OpenFlight Beads
Arg4A float that specifies the Blue component of the assigned
color for the Light Points (0.0 – 1.0)

Degree Of Freedom (DOF) Nodes
All transform nodes in Maya can represent DOF nodes. They each have limit
information available and by default work within their own co-ordinate space.

To create a DOF from a Maya transform node:

Set a limit on a group transform node from the Attribute Editor.

Level Of Detail (LOD) Nodes
Maya’s LOD nodes work slightly differently from the OpenFlight LOD nodes. To
simulate the behavior of OpenFlight LOD nodes, all children of an OpenFlight LOD
node are grouped together under a single group transform node that is controlled by
the LOD node. A null transform node can also be inserted before and/or after the
controlled LOD node to satisfy Maya’s switch in/switch out requirements.

Maya’s LODs are also tied to a particular camera. When importing an OpenFlight
file, a camera named fltLOD is created. To activate the LOD behavior, you must use
this camera. If new LOD nodes are created from within Maya, they should likewise
be associated with the LOD camera.

SUPPORTED OPENFLIGHT BEADS

The following table provides comparisons between OpenFlight and Maya.

Warning!

Deleting these nodes will cause the LOD to behave incorrectly.

OpenFlight Beads Maya equivalent/comment

Control Records

Instance Definition Instanced geometry

Instance Reference Instance group node

POP Changes move up to the previous parent in the DAG

PUSH Creates a child under the current parent

Unsupported Control Records

Extension

POP Subface See PUSH Subface
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PUSH Subface Maya cannot support hierarchy on co-planer surfaces. Instead
the next face to be created will be offset by 1 mm in the direction
of the normal.

Pop Attribute Reserved for MultiGen

Push Attribute Reserved for MultiGen

Primary Records

Degree-of-Freedom Record Maya transforms are used to represent DOF’s. See "Workflow
Considerations" on page 20 for more information.

EXTERNAL REFERENCE File reference to another OpenFlight database.

FACE Shape node for a face. Faces are part of a polymesh within Maya.

GROUP Group transform node.

HEADER Header record for an OpenFlight file. Sets orientation, field of
view, etc. Sets the appropriate orientation and UI units.

Level-of-Detail Level of detail group node.

Light Source A Light.

Light Point A special node type associated with the OpenFlight translator.
See "When using Light Points" on page 22” for more details.

OBJECT Transform node.

SWITCH A special node type associated with the OpenFlight translator.
See “Switch Nodes” under “Work Flow Considerations” for
more details.

Unsupported Primary Records

Binary Separating Plane Allows for the modeling of databases without Z information

Curve B-spline, Cardinal, also known as Catmull-Rom, and Bezier.

CAT Continuously Adaptive Terrain Skin. A triangle mesh for high
fidelity, real-time viewing.

Clip Region

Extension Node User defined node information.

MESH Poly mesh. (This is not widely supported and may not be
available in the first release)

Morph Vertex List Works in conjunction with LOD node to morph geometry
depending on the distance from the camera.

Road Segment

Road Construction
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Road Path

Sound Sound emitter position

Text

Ancillary Records

Continuation Not a node but simply a continuation of a vertex list. Records are
limited to 64K in size.

LONG ID A node name greater than 7 characters to be applied to the
previously read node. Maya node names do not have this
restriction so the name is applied directly to the node.

REPLICATE Multiple instances of the current transform node.

TRANSFORMATION
MATRIX

Transform matrix to be applied to the current transform node.

Unsupported Ancillary Records

Bounding Volume

CAT Data Header

CAT Data Key

CAT Data Face

Extension Attribute 3rd party support.

Local Vertex Pool

MESH PRIMITIVE

MultiTexture Allows support for up to 8 textures per vertex (May not be in
first release).

Road Zone (Pointer to a file that contains grid elevation data)

UV List Follows Vertex List and contains texture layer information.

Vector (Only used for light point faces).

Palette Records

Color Palette A collection of color entries. Maya does not use a color palette.
Each vertex holds the corresponding RGB color.

LIGHT PALETTE Lights are DAG node entries in Maya.

MATERIAL PALETTE Material become Shaders within Maya. See Texture Palette

TEXTURE PALETTE Textures are applied to shaders within Maya. Shaders have an
associated shading group that all nodes using this texture are
connected to.
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KNOWN ISSUES

The following outlines the known issues in OpenFlight Version 1.0.

Known issues:

1 Light Sources cannot be exported. Currently a single ambient light is always
exported.

2 An attempt is made to map Eye Points to Cameras in Maya; however, the mapping
appears incorrect in some cases. Eye points are not exported from Maya.

3 Track Planes are not supported.

4 Point Lights are omni-directional only.

5 The only way to freeze a DOFs co-ordinates from within Maya is to export the scene
as an OpenFlight file and then read it back in.

6 Articulations on group nodes are not supported.

Eyepoint and Trackplane
Palette

Implemented as Cameras in Maya. (See "Known Issues" on
page 28.)

Light Source Palette

VERTEX PALETTE Vertices are part of a polymesh in Maya.

VERTEX LIST See Vertex Palette.

Vertex Palette Header Followed by vertex data.

Vertex with Color Polymesh vertex data.

Vertex with Color and
Normal

Polymesh vertex data.

Vertex with Color, Normal
and UV

Polymesh vertex data.

Vertex with Normal and
UV

Polymesh vertex data.

Unsupported Palette Records

Key Table

Linkage Palette

Line Style Palette Maya has only 1 line style.

Name Table

Sound Palette

Texture Mapping
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7 Maya’s LODs need to be extended to better handle the flexibility of the OpenFlight
LODs.

8 UI-based tools are missing to support Light Points, Switch nodes, and LODs.

9 If you perform a Freeze Transformations on a translated Light Point, Maya versions
older than 4.0.3 will crash. This can be fixed by updating to Maya 4.0.3.

10 File textures may only be applied to the color attribute of a Maya shader. Textures
applied to other attributes are ignored.

11 Normals on faces are ignored on import. Maya regenerates the normals based on the
vertex ordering. However edge settings are preserved.
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6 STUDIOPAINT PLUG-IN AND
TRANSLATOR

The StudioPaint plug-in and translator allows StudioPaint compatibility with Maya.
StudioPaint is available with IRIX only. If you plan to use Maya with StudioPaint,
you must load the StudioPaint plug-in for Maya. If you plan to use StudioPaint with
Maya files, you must install the Maya translator for StudioPaint.

If you have StudioPaint installed on your system, the StudioPaint plug-in for Maya
and the Maya translator are automatically installed when you install Maya.

In some situations, you may need to manually install the StudioPaint plug-in for
Maya and/or the Maya translator for StudioPaint. For example, if you do not have
StudioPaint installed on your system and you install Maya, and then install
StudioPaint later, you must manually install the Maya translator for StudioPaint.

Similarly, if you have StudioPaint installed on your system and do not have Maya
installed, but would like to be able to use StudioPaint with Maya files, you must
manually install the Maya translator for StudioPaint.

INSTALLING THE STUDIOPAINT PLUG-IN AND TRANSLATOR

To install the StudioPaint plug-in for Maya and/or the Maya translator for
StudioPaint:

1 Insert the Maya CD in the CD-ROM drive.

2 From the Desktop, choose Toolchest > System > Software Manager.

You are prompted for a password.

3 Enter the root password.

The Software Manager opens.

Notes

You must have Maya already installed before you can load the StudioPaint
plug-in for Maya.

You must have StudioPaint already installed before you can load the Maya
translator for StudioPaint.
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4 In the Available Software field at the top of the window, type /CDROM/dist and
press Enter.

5 Click the Customize Installation button.

6 Turn off the Software > Short Product Names option so the full product names are
listed.

7 Do either of the following:

To install the StudioPaint plug-in for Maya, select the Alias|Wavefront
StudioPaintMaya Plug-in option.

To install the Maya translator for StudioPaint, select the Alias|Wavefront
StudioPaint - Maya 4.5 Update option.

8 If there are conflicts, Software Manager will alert you. If needed, click the Conflicts
button, and resolve the conflicts.

9 Click the Start button.

10 Choose File > Exit to exit from Software Manager.

11 Log out and then log in again.

LOADING THE STUDIOPAINT PLUG-IN

To load the StudioPaint plug-in for Maya:

1 From the Maya main menu, select Window > Settings/Preferences > Plug-in
Manager. The Plug-in Manager window opens.

2 Click the loaded button for the StudioPaint plug-in.

Note

If Software Manager tells you that Inventor n32 Run-time is missing, you
must install Inventor n32 Run-time from the IRIX (version 6.5.8 or higher)
Operating System CD before installing the StudioPaint plug-in and
translator for Maya. Choose File > Exit to exit from Software Manager and
see Installing Inventor n32 Run-time in the StudioPaint 9.5 Supplement.
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