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VueLink 1
Introduction
VueLink for SAP PLM provides an interface between SAP PLM System and 
AutoVue. This interface enables users to add powerful viewing and Markup 
capabilities to the following SAP GUI front end components:

• SAP GUI for Windows on Windows platforms 
• SAP GUI for Java on the Macintosh platform

VueLink for SAP PLM provides an interface between the SAP PLM System and 
the AutoVue family of products. This interface enables you to add powerful 
viewing and Markup capabilities to your SAP PLM System via a Web browser or 
SAP GUI in an intranet or the Internet.

VueLink and AutoVue will provide you with the following functionality:

• Document viewing of native formats.
• Graphically marking up documents using a rich set of graphical and textual 

tools.
• Reviewing your Markups and those of your co-workers.
• Full-security linking to the SAP PLM System.

This manual is intended for the users of VueLink and the System Administrator 
or other individual who performs the VueLink setup.

Note:  

• Throughout this manual the family of AutoVue Products is referred to as 
AutoVue. The AutoVue family of products includes AutoVue, AutoVue 
Professional, AutoVue SolidModel, AutoVue SolidModel Professional and 
Office. These products are available in Windows, UNIX or Java.

• AutoVue Professional, AutoVue SolidModel Professional and Office 
provide Markup features. Refer to the User’s manual for further information 
about the specific features and file formats supported by each AutoVue 
product.
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2 VueLink
Functional Overview
VueLink for SAP PLM adds document viewing and Markup capabilities to the 
SAP PLM System. It provides a seamless interface between SAP GUI for Java 
and SAP GUI for Windows clients and AutoVue in an intranet/Internet 
environment. Markups are automatically saved on the SAP PLM System and are 
available for other users to edit and/or view depending on their document access 
level.

VueLink for SAP PLM and AutoVue provide users with the following powerful 
features and capabilities:

• View documents securely in their native format or their Adobe Acrobat PDF 
rendition from the SAP PLM System without editing them.

• View more than 200 2D & 3D Engineering and Business document formats.
• View Multi-content objects.
• Simultaneously work with multiple Markup layers and files.
• Create Markups directly on stored documents or renditions using a rich set 

of annotation tools.
• Create hyperlink connections to other related documents.
• Consolidate several Markup files (perhaps from different reviewers) into one 

Markup file.
• Control access to Regular, Master and Consolidated Markup files.
• Associate Markups with a specific document revision. Markups may be 

migrated to new revisions as required.
• Graphically compare different revisions of engineering drawings.
• Print documents with headers, footers and Watermark information queried 

from specified document attributes.

VueLink for SAP PLM also provides you with a basis to which other powerful 
functions can be added via custom-designed tools to further enhance the SAP 
PLM installation. Custom-designed tools offer many possibilities. For example, 
you can create ‘intelligent’ custom stamps such as an Engineering stamp that 
queries for information which can be included as Markups.

In addition, custom applications can be created to extract relevant information 
from an AutoCAD or MicroStation file and automatically link it with information 
from your SAP PLM system or other system.

And remember that all these features are available from your Web browser by 
using Cimmetry’s Client-Server edition of AutoVue.

AutoVue is fully configurable for you to customize your own tools. If you prefer, 
contact your account manager or our technical support representatives to discuss 
the possibilities of having us design a tool to meet your specific business needs.
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Why Does the SAP PLM System 
User Need a Viewing/Markup 
Tool?
Typically, in an organization, a document has a life cycle and is routed to several 
people as part of a workflow cycle. Refer to the following figure for an example 
of a possible workflow cycle.

At minimum, there are three types of people who interact with a document:

• Creator/author of a document: The creator is usually the person 
responsible for creating or modifying a document with an editing application 
such as Microsoft Word or AutoCAD.

• Reviewer of document: This individual usually reviews a document and 
provides comments to the author or other reviewer. In a paper-based 
environment, the document is printed on paper and sent to a list of reviewers. 
Each reviewer provides feedback in several ways, directly marks up the 
paper output using a pen, attaches sticky notes, and creates one or more 
Markups. The annotated document along with other material is then sent to a 
supervisor who reviews the material (possibly with several other reviewers) 
and may consolidate the comments into one set. This set is then passed back 
to the creator for making modifications to the document. Several revisions, 
or versions of the document may be produced during this process.
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4 VueLink
• Users of documents: Once the review cycle is complete, possibly 
involving several versions of the document, the document is published. The 
final document is made available to those requiring View Only access to the 
document. At this stage, the document may be provided for viewing either in 
its native format or as a print rendition.

VueLink provides the capability of marking up a document and storing Markup 
information in a separated document in the SAP PLM System. There are 
different types of Markup entities offered in addition to hyperlinking capabilities.

Markup File Management
More than one Markup file can be attached to a document or a rendition. In 
addition, you have the option of displaying one or more Markup files 
simultaneously. If the currently displayed document has registered Markups, a 
red lightbulb button displays in the lower left corner of the status bar alerting the 
user to the existence of one or more Markup files. Markup files are also 
automatically traced by the revisions of a document so that each revision has a 
distinct set of related Markup files. When Markups are valid for a subsequent 
revision they can be promoted to that particular revision.

Engineering Documents
VueLink is fully equipped to handle complex engineering documents that may 
consist of external references, layers and blocks.

Cached Metafiles
With AutoVue, it is possible to enhance the viewing performance of large 
drawings by using cached metafiles. A metafile is a lightweight format 
developed by Cimmetry, and represents a true replica of the original format. 
Every time you view a file with AutoVue and you close the applet window or 
view another file, AutoVue automatically generates a metafile and checks it into 
SAP PLM.

When viewing a file, AutoVue checks if a cached metafile rendition exists inside 
SAP PLM. If a cached metafile exists, AutoVue checks it out instead of the 
native file.
Cimmetry Systems Corp.
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VueLink Features
The section covers the features that VueLink adds to AutoVue Client-Server 
Edition:

• Viewing Documents
•   Viewing a Document from the SAP GUI for Java/Windows Client
•   Accessing DMS Files
•   Viewing Multiple Originals

• Markups
•   Creating a Markup
•   Saving a new Markup File
•   Saving an existing Markup File
•   Displaying Markups
•   Promoting Markups
•   Deleting Markups
•   Consolidating Several Markups into a Single Markup
•   Saving as Master Markup

• Printing Document Attributes as Headers, Footers or Watermarks
• Converting Files 
• Comparing Files
• File Overlays
• Cross Probing
• MockUp
• Batch Print

Viewing Documents

Viewing a Document from the SAP GUI for 
Java/Windows Client
1 Log on to SAP GUI for Windows on Windows platforms or SAP GUI for 

Java on the Macintosh platform.
Cimmetry Systems Corp.



6 VueLink
2 To log in, enter your Client, Login Name and Password.

3 Browse to the document or search for the document you want to display with 
AutoVue.

4 Double-click the document you want to display.
The Document Display page appears. The document's details are 
displayed on this page.
The Document data tab and the Originals tab contain all the files 
checked in for this document.
Cimmetry Systems Corp.
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5 To select a file to display, double-click the desired item on the Document 
data tab or the Originals tab.
Cimmetry Systems Corp.



8 VueLink
AutoVue client is launched and prompts for authorization. 
6 Specify the User Name and the Password, then click OK.

The selected file is displayed.
Note:  
•   If you have configured outplace viewing, a browser window is launched 

and AutoVue applet loads in the new browser window.

•   If you have configured inplace viewing, AutoVue applet loads within the 
SAP GUI window.
Cimmetry Systems Corp.
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Accessing DMS Files
AutoVue provides a way to access files that are in the SAP PLM system from 
within the AutoVue window: DMS Search. You can use this option to select files 
from within the SAP PLM system when you need to open files for viewing, 
comparison, cross-probe, mockup, batch printing or overlays.

If any operation requires you to open files, the File Open dialog box lets you 
search the SAP PLM system. 

DMS Search
1 Click the DMS Search button in the File Open dialog box. 
Cimmetry Systems Corp.



10 VueLink
A dialog box appears that lets you specify a search criteria.

2 To search for a file in the DMS specify a search criterion based on: 
Document Type, Name, Part, Version or User. 

3 To limit the number of files that appear in the search results, specify a value 
in the Max Results section.

4 When you finish specifying your search criterion, click Search. 
5 AutoVue searches through the SAP PLM system for all documents  that 

match the search criterion and populates the Search results section with 
the search results.

6 Select a file from the Search results and click Load File to display the file 
in AutoVue.

Viewing Multiple Originals
VueLink for SAP PLM and AutoVue provide users the ability to navigate 
through multiple originals checked into a document.
Cimmetry Systems Corp.
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1 Launch AutoVue for the first original of a document that contains multiple 
originals.

2 Select View > MultiContent > Next Document. 
The next original is now displayed in AutoVue.

3  To navigate to the previous original, select View > MultiContent > 
Previous Document.
The previous original is now displayed in AutoVue.

4 To jump to a particular original, select View > MultiContent > 
Document Number and specify the number for the original to which you 
want to jump.
AutoVue displays the specified original.

Markups
The three types of Markup files are normal Markups, consolidated Markups, and 
Master Markups.

• Normal Markups: The default Markup when using a new setup.
• Consolidated Markups: You can load several files simultaneously and 

edit them to create a consolidated Markup where the contents of all files 
consolidate to display as one file. This type of Markup is especially helpful 
when you want to group reviews from various individuals to forward 
collectively to another person or group of reviewers.

• Master Markups: Markup files that display automatically when you open 
a document. This type of Markup alerts the viewer that important changes 
were made to the document content. This benefits the workflow cycle when 
changes to a document need to be noted but the document itself has not been 
modified in the authoring application.

Creating a Markup
1 Display a document within AutoVue.
2 Enter Markup mode by selecting File > Markup from the menu or right-

clicking and selecting Markup.

Note:  You can also click the Markup button  in the toolbar.

The current active document is displayed in Markup mode ready for you to 
create Markups.

3 To create a new Markup file, click New in the Open markup dialog box.
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12 VueLink
The current active document is displayed in Markup mode. You are ready to 
create Markups.

4 If after you have finished creating a Markup you want to create another one, 
select File > New from the menu. 

Note:  You can also click the New button  in the toolbar.

Saving a new Markup File
1 Select File > Save from the menu.

The Save Markup File As dialog box appears.

2 Complete the Name box.
Cimmetry Systems Corp.
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3 Select the Markup file type. There are three types: normal (default), 
master and consolidated.

4 Click OK.
The Markup file is saved and remains displayed in the AutoVue viewing 
window.

Saving an existing Markup File
1 Select File > Save from the menu.

The Markup file is saved and remains displayed in the AutoVue viewing 
window.

Displaying Markups
1 After the selected file displays in AutoVue, enter Markup mode by selecting 

File > Markup from the menu or right-clicking and selecting Markup.

Note:  You can also click the Markup button  in the toolbar.

2 Select File > Open from the menu.
Cimmetry Systems Corp.



14 VueLink
The Open markup dialog box appears.

3 Select the Markup file(s) to view, and then select the active Markup.
4 Click OK.

Promoting Markups
It is possible to promote Markups from an earlier version to the current version of 
a document. When Markups are promoted, they are saved against the new 
version of the document.

1 After displaying a file with AutoVue, enter Markup mode by selecting 
File > Markup from the menu or right-clicking and selecting Markup. 
The Open Markup dialog box appears. In the following image, some 
columns were narrowed to show the Version column.

Note:  You can also click the Markup button  in the toolbar.

2 To display the Markup files from previous versions of the base file, select 
All revisions.
Cimmetry Systems Corp.
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The Markup files are displayed for the previous version of the base file.

3 Select one Markup file from the previous version.
The Markup file will be shown with the current version base file.
Note:  When you save the selected Markup (with or without any 
modification), it would be saved as the Markup of the current base file 
version.

4 Enter Markup mode.
Note:  If there are no Markups for the document, the document is opened in 
Markup mode.

5 Select File > Open.
If Markups exist for the document, the Open Markup dialog box appears.

6 Select All revisions.
All Markups from all previous versions of the document are now displayed.

7 Select the Markup that has to be promoted.
8 Click OK.

The document is now opened in Markup mode and the selected Markup is 
displayed.

9 Select File > Save as.
The Save dialog box appears.

10 Specify a name for the Markup and save.
The Markup is now saved with the current version of the document.
Cimmetry Systems Corp.
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Deleting Markups
1 After displaying a file with AutoVue, enter Markup mode by selecting 

Markup from the File menu or right-clicking and selecting Markup.
The Open markup dialog box appears.

Note:  You can also click the Markup button  in the toolbar.

2 Select one or more Markups from the list.
3 Click Delete.
4 At the prompt, click Yes to confirm the deletion of the Markups you 

selected to delete.
The selected Markup(s) are deleted from the list of Markups in the Open 
markup dialog box.

Consolidating Several Markups into a 
Single Markup
The Consolidate option lets you create a new Markup combining copies of 
selected parts of different Markups. This option is available only if multiple 
Markups are loaded. During the review cycle consolidation simplifies document 
revisions by providing authors with one consolidated Markup rather than several 
Markup files.
Cimmetry Systems Corp.
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1 After the selected file displays with AutoVue, from the File menu, select 
Open.
The List of Markup File(s) dialog box appears.

2 Select Markup files to view.
3 Select the active Markup file.

Your new updates will be saved to the active Markup you selected.
4 Click OK.

All the selected Markup files display simultaneously.
5 Select File > Consolidate. The Consolidated Markups dialog box 

appears.

Review

Document

AUTHOR

Revise

Consolidate
all reviews
into one 
document

EDITORSAUTHOR

Review

Review
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6 Select the Markup layers you want to consolidate.
7 Enter the name of the consolidated Markup file.
8 If you wish to display this consolidated Markup file as the active Markup file 

and close the other Markups once the consolidation is complete, select 
Close All Markups.

9 Click OK.
10 Enter Markup Name and Title.
11 Click OK.

The consolidated Markup file is saved.

Saving as Master Markup
AutoVue tags Markup files as normal, consolidated or master. Master Markups 
are immediately displayed when their base document is displayed. When viewing 
a document, Master Markups are automatically loaded and displayed in Markup 
mode. Although non-owners can view Master Markups, they cannot change the 
Master Markups or create their own Master Markups.

After you have finished marking up a document:

1 From the File menu, select Save or Save As.
The Save Markup File dialog box appears.

2 Complete the Name field.
3 For Markup file type, select master.

4 Click OK.
The Master Markup file is created and stored in the Markup database. When 
another user logs on and views this file, AutoVue Markup mode 
automatically launches, loads and displays your Master Markups.

Printing Document Attributes as 
Headers, Footers or Watermarks
AutoVue lets you print document attributes in a header, footer or as a watermark.

1 Select File > Print from the AutoVue menu.
Cimmetry Systems Corp.
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The Print Properties dialog box appears.

2 Customize the Print Properties.

Headers/Footers
This group defines the headers and footers to be included on every printed page 
of the document.

1 Click the Headers/Footers tab.
2 Enter text manually in the Header and Footer boxes and/or choose from 

the Insert Code drop-down list box to set the information for headers and 
footers. The following is the complete list of codes:

3 When you have finished, click OK.
Cimmetry Systems Corp.
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Watermarks
A watermark prints faintly and transparently under the current document’s 
contents. With the Watermarks group, the watermark is defined as it will 
appear on the printed document.

1 Click the Watermarks tab.
2 Enter the text in the Watermark Text box. 

The text displays as it will appear on the document.
3 Click Font to customize the font.
4 When you have finished, click OK.

Converting Files
With AutoVue, it is possible to convert documents to other formats such as TIFF 
and check in the converted document into the conversion folder in the SAP PLM 
system.

Note:  Only the TIFF format is currently supported for saving as a rendition.

1 After displaying a file with AutoVue, select File > Convert.
The Convert dialog box appears.
Cimmetry Systems Corp.
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2 Select TIFF from the drop-down list Convert To Format.
3 Select the Rendition checkbox under Output.
4 Modify the options for Scale, Size, Region, Pages and Color Depth.
5 Click OK to start conversion.

AutoVue converts the file to the TIFF format and checks it into SAP PLM as 
a rendition to the original file.

Comparing Files
With the Compare feature, documents of the same type (raster or vector) are 
visually compared. The two selected files are simultaneously displayed in their 
own windows with the comparison findings displayed in a third viewing window. 
This feature is very useful for finding similarities and differences in revisions of a 
drawing.

With AutoVue, it is possible to compare the current document with another 
document that is in the SAP system or with any of its past versions.

1 After displaying a file with AutoVue, select File > Compare.
The File Open dialog box appears.

Note:  If a document has multiple versions, all of its previous versions are 
listed in the Document versions drop-down list. Select a version from the 
Document versions drop-down list.

2 To search through the SAP PLM system, click Search DMS. 
Specify a search criteria and select a file from the Search Results. 
Note:  See Accessing DMS Files for more information.

3 To select a local file, click Browse. Browse through the local file system 
and select a file.

4 To specify a URL, type in the URL in the File Name field.
AutoVue displays three windows: the first contains the original document; 
the second contains the version to compare against; and the third window 
Cimmetry Systems Corp.
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contains the comparison results. Additions appear in green, deletions in red 
and unchanged parts in blue.

File Overlays
With AutoVue, it is possible to specify either a file on the local file system or a 
file saved in the SAP PLM system.

1 Select File > Overlay. The File Open dialog box appears.

2 To search through the SAP PLM system, click Search DMS. 
Specify a search criteria and select a file from the Search Results. 
Note:  See Accessing DMS Files for more information.

3 To select a local file, click Browse. Browse through the local file system 
and select a file.
Cimmetry Systems Corp.
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4 To specify a URL, type in the URL in the File Name field.
5 Click OK after you select a file.

Cross Probing
AutoVue provides the ability to crossprobe EDA drawings. Cross probing is the 
ability to select elements in the schematic and have them mapped to the 
corresponding components in the layout drawings and vice versa. Cross probing 
can also be done between the 2D View and the 3D View of the same document.

With AutoVue, it is possible to select files that are either on the local file system 
or in the SAP PLM system for cross probing.

1  Display a document with AutoVue.
2 Select the Cross Probe from the file menu. The Select files for cross-

probing dialog box appears.

3 Select Add File from the Select files for cross-probing dialog box. 
The File Open dialog box appears.
Cimmetry Systems Corp.



24 VueLink
4 To select a local file, click Browse. Browse through the local file system 
and select a file.

5 To search the SAP PLM system for a file, click Search DMS. 
Select a file from the search results. 
Note:  See Accessing DMS Files for more information.

6 To specify a URL, type the URL in the File Name field.
7 Click OK when you finish selecting a file.

MockUp
AutoVue provides Digital MockUp capability. Mockup is the ability to import 
and combine any number of native CAD files, regardless of file format, to create 
a virtual assembly including: CATIA, Pro/E, UG, SolidWorks, Inventor, JT, Solid 
Edge, etc.

With AutoVue, it is possible to select files that are either on the local file system 
or in the SAP PLM system for digital mockup.

1  Display a 3D document with AutoVue.
2 Select MockUp from the file menu. The Import Design dialog box 

appears.
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3 Select Add from the Import Design dialog box. The File Open dialog 
box  appears.

4 To select a local file, click Browse. Browse through the local file system 
and select a file.

5 To search the SAP PLM system for a file, click Search DMS. 
Select a file from the search results. 
Note:  See Accessing DMS Files for more information.

6 To specify a URL, type the URL in the File Name field.
7 Click OK when you finish selecting a file.

Batch Print
You can use AutoVue to print a set of files in a batch process.

1 Display a document with AutoVue.
2 From File menu, select Batch Print. The Batch Print dialog box appears.
Cimmetry Systems Corp.
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3 To add a file from the local file system, click Browse. The File Open 
dialog appears. Select a file to add it to the print list.

4 To search through the DMS, click DMS Search. The Search dialog box 
appears. Specify a search criteria and select the file from the search results to 
add it to the print list
Note:  See Accessing DMS Files for more information.

5 When you finish selecting files, click Print. The selected files are printed.
Cimmetry Systems Corp.
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Feedback
Cimmetry Systems products are designed according to your needs. We would 
appreciate your feedback, comments or suggestions. Contact us by fax, e-mail or 
telephone. There is a feedback button on our Web site that activates an easy-to-
use feedback form. Please let us know what you think!

General Inquiries

Sales Inquiries

Customer Support

Telephone: +1 514-735-3219

Fax: (514) 735-6440

E-mail: info@cimmetry.com

Web Site: http://www.cimmetry.com

Telephone: +1 514-735-3219 or 1-800-361-1904

Fax: (514) 735-6440

E-mail: sales@cimmetry.com

Telephone: +1 514-735-9941

Web Site: http://www.cimmetry.com/support
Cimmetry Systems Corp.
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