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Apple Motion 5 Cookbook  
Creating motion graphics and visual effects in the past used to be a daunting process. 
Performing tasks such as animating text, match moving, compositing, and connecting 
individual layers would involve extremely long workflows that would take days, even 
months to complete. That's where Motion comes in. It was designed to make these tasks 
simpler and easier so that the user can focus on the creation. The application works 
seamlessly with Final Cut and has the editor and motion graphics artist in mind every 
step of the way. 

So, welcome to Apple Motion 5 Cookbook. Throughout this book, you'll learn to  
create sophisticated motion graphics using the incredible tools and content inside the 
application. Through a series of recipes, we will cover tips and tricks for easy navigation 
of the interface, animating layers with behaviors and keyframes, applying filters, using 
Motion's vast content library, creating replicator and particle systems, and working in 
both 2D and 3D environments. With exercise files accompanying this book as an 
additional download, you will walk away with real-world projects to apply your new 
skills to. Let's get cooking! 

What This Book Covers 
Chapter 1, Getting Around the Interface, explores becoming more comfortable  
inside Motion and navigating ourselves through the various windows. 

Chapter 2, Looking at Motion's Library, explores working with and manipulating  
the vast content available to us right inside Motion. 

Chapter 3, Making It Move with Behaviors, explores instant animation techniques  
by dragging and dropping various behaviors onto elements into our project. 

Chapter 4, Making It Move with Keyframes, explores classic animation techniques  
in Motion and the options available to add, cut, copy, and manipulate keyframes  
on parameters. 

Chapter 5, Let's Make Text, explores working with text in Motion by changing text  
style, saving presets, and animating text with behaviors. 

Chapter 6, Paint and Masks, explores the Paint Stroke tool and the brush stroke presets 
available from the Library. We will also look at using masks to add effects to specific 
parts of our image, as a utility tool and to create animation. 

Chapter 7, Let's Make Particles, explores the basics of Motion's extremely powerful 
particle systems and how we can manipulate its parameters to create dynamic  
motion graphics. 
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Chapter 8, Replicators – It's No Fun By Yourself, explores the basics of the replicator  
and how almost any element in Motion can be used to create seamless animation  
through patterns. 

Chapter 9, Motion Tracking and Keying, explores VFX techniques including match 
moves, offset tracking, and green screen removal. 

Chapter 10, Intro to 3D, explores adding cameras and lights to our projects to interact 
with our elements in 3D space. 

Chapter 11, Publishing Your Work to FCP X, focuses on integrating Motion into FCP  
X by creating titles, transitions, effects, and generators for the Media Browser. 

Chapter 12, Customization and Exporting, explores a few customization techniques  
for various workflows. We also look at exporting movies, stills, and image sequences 
from Motion and exporting through another application called Compressor. 
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2
Looking at 

Motion's Library

In this chapter, we will cover:

  A brief tour of the Library tab

  Importing fi les from the Content library

  Applying a Glow fi lter to a layer

  Copying fi lters and applying fi lters to a group

  Controlling the fi lter order

  The power of cloning

  The power of blend modes 

  Customizing a gradient generator

  Applying a blend mode to a gradient

  Adding a frame and changing a drop zone's content

  Adding a Flourish and applying fi lters
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Introduction
As motion graphic artists and editors, we are constantly looking for content to bring into our 
projects and compositions. Some of this content can come from an onset location that we want 
to manipulate, while other content we create on the computer, such as text. What's amazing 
about Motion is that it ships with a library of content you can use royalty free in any of your 
projects. You already have some of the content you apply to images on hand, while other content 
you can create and use from scratch. The best part is that usually you don't have to look any 
further than in the Library to create breathtaking, broadcast-worthy visuals for a variety of 
different situations. Let's dive in to see the vast richness available for our projects.

A brief tour of the Library tab
Motion's Library is very similar to Final Cut Pro's Media Browser. Unlike the File Browser 
where we import material from outside of Motion, the Library contains fi lters, behaviors, 
generators, content, and  presets available within Motion. It also gives us a gateway to a few 
external application libraries, such as iTunes and iPhoto. In this recipe, we'll have an overview 
of the Library tab.
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How to do it...
1. Launch Motion. Set the Preset to Broadcast HD 720p, Frame Rate to NTSC-DV, 

29.97, and Duration to 10 seconds. Press OK.

2. Click on the Library tab located on the left-hand side of the interface. Take a 
second to look at all the categories that are displayed. Choose Behaviors. On the 
right-hand side, a list of subcategories display. Currently All is selected, and the 
content of that subcategory appears in the lower part of the window, as displayed 
in the following screenshot:

 

 

For More Information:  
www.packtpub.com/apple-motion-graphics-5-cookbook/book 

 

http://www.packtpub.com/apple-motion-graphics-5-cookbook/book


Looking at Motion's Library

48

3. At the bottom of the Library tab, click on the magnifying glass icon. Similar to 
Spotlight on the Mac OS, we can now search in the subcategory. Type in write on 
in the search fi eld.  All the behaviors in the subcategory disappear except for the 
Write on behavior, as shown here:

4. Click on the Content category. At fi rst, it appears that there is nothing inside. The All 
subcategory does not show any items. This occurs because we haven't cleared our 
search results and it just so happens there is no item by the name of Write on in the 
Content category. Click on the x icon in the search fi eld to clear it. Now over  1300 
items are displayed in the Content category. Click the spotlight icon again to close 
the search fi eld.

5. Scroll down in the All subcategory until you can see Atom 01. Select it. In the upper 
part of the Library tab, a preview displays showing you it's animated:

6. Click on a few more items in the Content library to get familiar with some of the 
items available to you. In the next recipe, we're going to import some of them 
into our project!
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See also
  The Importing fi les from the Content library recipe.

Importing fi les from the Content library
In the previous recipe, we had a   brief tour of the Library tab and learned how we can easily 
search, select, and preview items. In this recipe, we'll import a few items into our project and 
see how to use them.

How to do it...
1. You can continue from the project you created in the previous recipe, or if you're 

starting here, launch Motion. Set the Preset to Broadcast HD 720p, Frame Rate 
to NTSC-DV, 29.97, and Duration to 10 seconds. Press OK.

2. Click on the Library tab and choose the Content category. On the right-hand side, 
select the Background subcategory.

3. As the subcategory implies, these items are meant to be used as backgrounds in 
your project. To change the way these items are being displayed, use the icon on the 
bottom right-hand corner with four squares. All the backgrounds are now displayed as 
icons. We can change the size of them by clicking on the duration slider, as shown in 
the following screenshot (next to the magnifying glass icon):

4. Click and select a few of the items below to view them in the upper window. Find and 
select Chalkboard Scratchy.
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5. Make sure your playhead is at the beginning of the Timeline and the group in the 
Layers tab is selected. Click on the Apply button at the top of the Library, as shown 
in the following screenshot, to set the selected background as the background   of your 
project. Select the Canvas and press Shift + Z to fi t the video in the window. Press the 
Space bar to play the project.

6. We can even import content from our library while we are playing back our projects. 
Make sure your project is still playing. In the Library, select the group in the Layers 
tab. In the Library, under Content, select the Symbols subcategory. Scroll down and 
select Radio Hazard, as shown in the following screenshot:
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7. Click on the Apply button.   The content is added to the group and starts at the 
beginning of the project, as shown here:

See also
  The A brief tour of the Library tab recipe.

Applying a Glow fi lter to a layer
For those of you from Final   Cut X, applying effects to your projects is probably second nature 
but many of you may not realize that the vast majority of the effects in the Media Browser 
come directly from Motion. At any time, if you Ctrl +click or right-click these effects, you would 
see an option to open a copy of it in Motion, as shown in the following screenshot:
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Let's see how easy it is to add a fi lter to a clip in Motion.

How to do it...
1. From this chapter's project folder, double-click and open the 02_03 project.. The project 

consists of an   Aqua Ball from Motion's Content library. It has been scaled up in size. 
We want to add a fi lter to it. Make sure the Aqua Ball is selected in the Layers tab.

2. Click on the Library tab. Locate the Filters category and select it. Select the Glow 
subcategory. There are eight different glows to choose from, as shown in the 
following screenshot:
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3. Select the Light Rays fi lter and click on the Apply button at the top of the Library tab. 
The fi lter is   now applied to the Aqua Ball.

4. With the Aqua Ball selected, press F3 to go to the Filters tab of the Inspector. Notice 
how the Light Rays fi lter is attached to your image. It seems to affect the brightest 
areas of the Aqua Ball. First, let's play with the Mix slider by dragging it to 0 and 
slowly back to 100, as indicated in the following screenshot:

5. Experiment with each of the other parameter sliders to get a feel for the effect on the 
Aqua ball (threshold and radius have a greater effect than the other two parameters). 
I   used 150 for Amount, 8 for Glow, and 2 for Expansion. The results can be seen in 
the following screenshot:

 

 

For More Information:  
www.packtpub.com/apple-motion-graphics-5-cookbook/book 

 

http://www.packtpub.com/apple-motion-graphics-5-cookbook/book


Looking at Motion's Library

54

6. Turn the fi lter on and off to see the before and after of the results by clicking the blue 
square for the fi lter in the Layers tab.

There's more…
The magic of fi lters lies in our ability to keyframe them and create animation. Lucky for us, the 
majority of Motion parameters on   fi lters are keyframable!

Keyframing fi lters
While the result of the previous  example is a static effect, notice that if you hover your mouse 
over the right-hand side of any of the parameters in the Filters tab, a diamond shape pops 
up, as indicated in the following screenshot. Filters become even more powerful when we 
make variable changes to them over time. Keyframing is our tool for creating animation. Two 
keyframes at different places in time and with different values result in an animation. Filters 
can even be used as transitions between clips to create dynamic effects. We'll cover more of 
this in Chapter 4, Making It Move with Keyframes.

Don't sweat the fi lters
There are 132 fi lters in Motion's library! Don't sweat it if you don't know what each one 
does. Your desire to add fi lters and play with the parameters is all you need to discover 
all the options that are out there. So start exploring!

See also
  The Copying fi lters and applying fi lters to a group recipe.

  The Controlling the fi lter order recipe.

Copying fi lters and applying fi lters to a 
group

Motion 5 gives us   incredible fl exibility when we work with fi lters. By using simple copying and 
pasting procedures, we are able to easily move fi lters in between layers and groups.
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How to do it...
1. From this chapter's project folder, open the 02_04 project.

2. The project consists of two Aqua Balls from Motion's library. One of them has a Light 
Rays fi lter on it, which we applied in the previous recipe. We would like to apply this 
fi lter to the other Aqua Ball, too.

3. Select the Light Rays fi lter in the Layers tab. Go to the Edit menu and choose Copy. 
Select the   Aqua Ball without the fi lter and go to the Edit menu and choose Paste, as 
shown in the following screenshot:

4. Let's add a blur fi lter to both the Aqua Balls as well. Rather than apply a fi lter to each 
ball, we can apply the fi lter to the group they're both in. Select Group 1 in the Layers 
tab. Click on the Library tab. Locate the Filters category and select it. Select the Blur 
subcategory. Select Defocus and click Apply. The Blur fi lter is now applied to both the 
Aqua Balls.

5. With Group 1 selected, press F3 to go to the Filters tab of the Inspector. The 
Defocus fi lter is attached to your group. Change a few of the parameters to see if 
you can increase the blur. I changed the Amount value to 20 and the Shape value 
to Polygon.
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There's more...
Like any other application, you should get to know some keyboard shortcuts to speed up your 
workfl ow process.

Using Command + Command + C and Command + V when copying 
multiple fi lters
You can also copy a fi lter to   multiple clips using Command + C to copy the fi lter, make a 
multiple selection on the clips you want to apply the fi lter to, and press Command + V to paste 
it to all of them.

See also
  The Applying a Glow fi lter to a layer recipe.

  The Controlling the fi lter order recipe.

  The The power of cloning recipe.

Controlling the fi lter order
Like any good recipe, the order  in which we follow steps can make or break the meal we eat. 
The same can hold true for fi lters in Motion. In some instances, if we apply one fi lter before 
another, it can have a very different result than if the order was reversed. Let's take a look at a 
simple example where this applies.

How to do it...
1. Navigate to this chapter's folder and open the 02_05 project.

2. This project consists of an Earth Transparent layer from Motion's Content library. 
Click the disclosure triangle to reveal its fi lters and press F3 to go to the Filters tab of 
the Inspector.

3. There are two fi lters on the layer. One fi lter was meant to colorize the earth map, 
while the other created a border around the map with a blue color. This problem 
arises because we added the Colorize fi lter after the Border fi lter, and this is 
affecting both the border and the layer. Select the Simple Border fi lter in the 
Layers tab and drag it up so that it's on top of the Colorize fi lter. Notice how the 
border now has its intended blue background, as shown in the following screenshot:
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See also
  The Applying a Glow fi lter to a layer recipe.

  The Copying fi lters and applying fi lters to a group recipe.

The power of cloning
In the previous recipe, we saw  how easy it was to copy and paste fi lters from one layer to 
another or to a group. Sometimes in a Motion graphics workfl ow, it's necessary to duplicate 
layers. A problem can occur when we want to change the fi lters on these layers. Both the 
duplicate and the original layers would each have to be changed manually. If you begin to 
change or manipulate fi lters several times, this can become a very tedious process. This is 
where cloning comes in handy. Any changes we make to fi lters on the original layer, the clone 
will follow along. As an added bonus, it also allows for better performance in Motion. Let's take 
a look at an example in action.

How to do it...
1. Open the 02_06 project from this chapter's project folder. This project consists of the 

Arrow 01 group from Motion's Content library.
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2. Click on the disclosure triangle for the Arrow 01 group and reveal its content. Notice 
there are two fi lters on the group—a Colorize and Trail fi lter. Press F3 to go to the 
Filters tab of the Inspector.

3. Press the Space bar to play back the project. Notice how the Remap White value 
on the Colorize fi lter has been turned to blue, and also notice how in the Trail fi lter, 
eleven echoes have been created lasting for a duration of one second.

4. Select the Arrow 01 group  in the Layers tab and go to the Object menu and choose 
Make Clone Layer, as shown in the following screenshot:
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5. Notice that a new layer has been created just above the Arrow group, as shown in 
the following screenshot. Select Clone and press F1 to go to the Properties tab of 
the Inspector. Change the Position X value to –400. Clones have independent Scale, 
Position, and Rotation properties from the original. Press the Space bar to play back 
and see the two arrows animate.

6. Stop the playback. Move to a frame where you can see both the arrows in the Canvas, 
or go to the one second and the thirty-fi fth frame mark. Select the Arrows 01 group 
and press F3 to go the Filters tab of the Inspector.
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7. Right-click or Ctrl + click the Remap White value and change the color to a red of 
your liking, as shown in the following. Under the Trails fi lter, set Echoes to 4.

8. Press the Space bar to play back the project. Notice how the clone adopts the original 
group's fi lter changes, and  you only had to switch one set of values!

There's more...
When we move our layer's Position co-ordinates, it's a good practice to know what the 
values mean.

Grid 101
Having a basic understanding of how  Position co-ordinates work in Motion 5 can come in 
handy. When dealing with the x and y positions, we can easily break down our screen into four 
basic quadrants. The quadrants hold either positive or negative values. Here is a breakdown 
of the grid system in Motion 5; the same holds true in FCP X:
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Clones and switching sources
If we are working with one  layer in a project that has clones and later decide there may be 
another element that works better in its place, we can actually swap out the source. See the 
following example. In Picture 1, there was a photo of chalk that was cloned and scaled lower 
in size. The still picture of the ruler replaced the chalk and its clone. To achieve this, the ruler 
was dragged on top of the original chalk layer. The clone simply follows suit!

Picture 1 Picture 2

See also
  The Copying fi lters and applying fi lters to a group recipe.

The power of blend modes
When you're trying to develop  looks for your images, blend modes can achieve exciting results. 
Blend modes are used in almost all imaging applications and truly are a foundation of motion 
graphics and compositing. While there is a ton of content about blend modes, such as Motion 
5's user manual, sometimes it's better to see for yourself and experiment with a still image. 
Let's take a look at a few examples.

How to do it...
Let's create a new project and add a still from Motion's library:

1. Launch Motion. Set Preset to Broadcast HD 720p, Frame Rate to NTSC-DV, 
29.97, and Duration to 10 seconds. Press OK.

2. Click on the Library tab. Go to the Content category and select the Images 
subcategory. At the bottom of the Library window, double-click the Traditions folder 
and select the Watercolor 02 still image. In the preview area, you can see that the 
project's size is 2048 by 1362. That's much larger than our 1280 x 720 project.
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3. Making sure your playhead is at the beginning of the project. Click on the Apply 
button to add the Watercolor 02 image to the project. We're going to experiment 
with a few different  types of looks with this abstract image by duplicating it and 
changing one of the layer's blending modes.

4. With Watercolor 02 selected in the Layers tab, go to the Edit menu and choose 
Duplicate, as shown in the following screenshot. Select Watercolor 02 copy.

5. Click on the Properties tab of the Inspector. Under the Blending category, set Blend 
Mode to Multiply, as shown in the following screenshot. The Watercolor 02 copy 
image blends together with the original Watercolor 02 image. Multiply looks at the 
darker colors in both images and multiplies them together. To see the before and 
after result, in the Layers tab, click on the checkmark next to Watercolor 02 copy. 
Click the empty box to turn the copy back on.

6. In the Properties tab, drag the Opacity slider up and down to see how this can be 
combined with the Multiply blend mode. Bring the Opacity slider back up to 100.

7. Set Blend Mode to Add. Notice how we receive a different effect. Add looks at the 
brighter parts of the  image and adds them together.

8. Experiment with different Blend Mode values and Opacity settings to get a feel for 
some of the possibilities.
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See also
  The Applying a blend mode to a gradient recipe.

Customizing a gradient generator
Gradients are fun and easy to use.  Some gradients in Motion can be applied to different 
types of objects. We can apply gradients to shapes, text, particles, and a variety of different 
objects to create cool looks. We can create other gradients from scratch. To do this, we need 
to generate the gradient.

How to do it...
1. Launch Motion. Set the Preset to Broadcast HD 720p, Frame Rate to NTSC-DV, 

29.97, and Duration to 10 seconds. Press OK.

2. Click on the Library tab. Go to the Generators category. There are several generators 
for you to choose from. Choose Gradient and click Apply. Go to the Window menu 
and choose Show HUD, if it's not already showing. Use the following screenshot 
for reference:
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3. A great place to start customizing your gradient is by looking at the various presets 
that ship with  Motion. Next to the word Gradient is an icon. Click it to reveal the 
gradient presets and select any random one. I choose Dusk as shown here:

4. Set Type to Radial. Press the I icon to go to the Generators tab of the Inspector. You 
can see that we have more options for our gradient here than in the HUD.

5. Click the disclosure triangle to the left of the word Gradient. Let's change the position 
of the radial gradient and then adjust its color setting.

6. Scrub the Start Y Value and drag it to -360. Set the Y End value to -1120.

7. In the gradient icon at the top, there are two parts to the line. The upper-most part 
contains the opacity tags for the gradient. The fact that they are both white means it's 
fully opaque. The bottom part contains the color stops for the gradient. Currently, this 
radial gradient consists of four colors. We're going to delete one of them. Click on the 
color tag on the left, drag it down, and release your mouse.  You should see a puff of 
smoke quickly appear. Use the following screenshot for reference:
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8. Drag the light purple color tag over a little to the left. We're going to change its color. 
Click on that color stop and notice how it loads in the Color window below. Use the 
following screenshot for reference. Ctrl + click the stop to the right of the word Color 
and adjust as desired.

There's more...
Here are a few quick tips on working with and adjusting your gradient.
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Adding color and opacity stops
To add tags to the gradient,  simply click the color or opacity line. Wherever you click on the 
line, a  color stop will be added at that position. Click the upper white line to add opacity tags 
and click the lower colored line to add color tags.

We can also reverse a gradient's direction.

Reversing gradient colors
We can easily reverse the  colors on a gradient by clicking on the appropriate button to the 
right of the tags, as shown in the following image:

See also
  The The power of blend modes recipe.

  The Applying a blend mode to a gradient recipe.

Applying a blend mode to a gradient
In this recipe, we're going to   use a gradient generator and apply a blend mode to it so that 
we can enhance the sky in the image below it. While a still image is used in this recipe, this 
technique can be applied with moving footage as well.
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How to do it...
We'll begin by navigating to this chapter's exercise folder on your drive.

1. Open the 02_08 project, which consists of a still image of a sky. Select the still in the 
Layers tab.

2. Click on the Library tab. Go to the Generators category. There are several generators 
for you to choose from. Choose Gradient and click Apply. Go to the Window menu 
and choose Show HUD, if it's not already showing.

3. Make sure the gradient is selected in the Layers tab. In the HUD, next to the word 
Gradient is an icon. Click it to reveal the gradient presets and select Desert Sun, as 
shown in the   following screenshot:
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4. With the gradient still selected in the Layers tab, Ctrl + click directly in the Canvas 
window. Choose Edit Position from the list, as shown. The gradient controls are now 
displayed on the screen:

5. The gradient is going to be used as a fi lter for the following image. Press 
Command + - to zoom out   on your Canvas. Drag the triangle controls to increase 
the spread and position of the gradient. Use the following screenshot for reference:

6. Press Shift + Z to fi t the Canvas to your window. In the HUD, set Blend Mode to 
Screen. Slide down the Opacity value. Change the Blend Mode value to Linear 
Burn. Play   with the Opacity and Position values of the gradient to suit your taste.
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See also
  The The power of blend modes recipe.

  The Customizing a gradient generator recipe.

Adding a frame and changing a drop zone's 
content

Drop zones give us the ability to swap  either video or a still in replace of a placeholder graphic. 
Drop zones are great in helping motion graphic designers automate their workfl ow. Let's say 
you have a news program that uses the same "Coming Next" animation every week, but the 
videos and still content in that animation constantly change. You can easily set up a drop 
zone, so that you can use that same graphic over and over again while literally  dropping in 
video and stills to their respective places.

How to do it...
1. Launch Motion. Set the Preset to Broadcast 720p, Frame Rate to 29.97, and 

Duration to 10 seconds.

2. Click on the Library tab to open it. Go to Content. There are 1349 items to choose 
from. Click the magnifying glass at the bottom-left of the window. Type in Vertical.
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3. Select any frame with an arrow in the middle of it and choose Import. Select the 
Vertical group and press F1 to go to the Properties tab of the Inspector.

4. Decrease the Scale value  to 50. Select the Vertical group and hit Command + D 
twice to make two copies.

5. In the Layers tab, select one copy and drag it to the left of the Canvas. Repeat the 
step for the other copy, but drag it to the right. We'll make sure they're precisely 
aligned in the next step.

6. Name each of the frames accordingly. Select all three and from the Object menu 
choose Alignment | Distribute Horizontal Centers. Go back to the Object menu 
and choose Alignment | Distribute Vertical Centers. Use the following screenshot 
for reference:

7. You may see that in the center of each frame, it says Drop Zone as long as the 
group is selected. Drop zones are meant to be replaced with stills or video clips. 
Let's add some sources to the  drop zone. Click the disclosure triangle for one of 
the Vertical groups.

8. Let's navigate to our File Browser by pressing Command + 1. Make sure Collapsed 
Image Sequences is turned off, as shown in the following screenshot. Navigate to the 
cat pictures from this chapter's media folder. Select one you like.

 

 

For More Information:  
www.packtpub.com/apple-motion-graphics-5-cookbook/book 

 

http://www.packtpub.com/apple-motion-graphics-5-cookbook/book


Chapter 2

71

9. Drag the picture from the File Browser onto the Drop Zone layer in the Layers tab 
and wait for the hooked arrow, as shown in the following screenshot. Release your 
mouse. Press F4 to go to the Image tab of the Inspector, if it's not already displaying.

10. Scale and position the image in the  frame to your liking. A sample is shown in the 
following screenshot:
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11. Repeat the preceding steps for the other two empty frames. Use the following 
screenshot for reference:

There's more...
Drop zones in Motion publish over to FCP X!

Drop zones for FCP X
You may have noticed in FCP X that   certain transitions and templates have drop zones. We 
can create drop zones in Motion from the Object menu in any of our projects, as shown in the 
following screenshot. On top of this, we can save our project as a title, effect, or generator and 
manipulate that drop zone directly in FCP X. So, if you have a recurring show with the same 
intro animation and you need to continually update certain video segments, drop zones are 
for you!

Anchor points
How does that image scale? It's all  about the anchor point! To illustrate how anchor points 
work a bit more, try adding some text to you project by pressing the T key. Press Esc once it's 
entered to go back to the selection tool and then press F7 to show the HUD. Change the size 
of the text and notice that when you scale it up, it scales from the lower-left corner. Press 
Command + Z to undo. Change the text alignment to center and scale it up again. Notice how 
the text scales from the center. Alignment acts as a text's anchor point and determines how 
the object scales and rotates.
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See also
  The Applying a Glow fi lter to a layer recipe.

  The Copying fi lters and applying fi lters to a group recipe.

  Spinning and throwing a ball in Chapter 3, Making It Move with Behaviors.

  An intro to Text behaviors in Chapter 3, Making It Move with Behaviors.

  Sequence Text in Chapter 5, Let's Make Text.

Adding a Flourish and applying fi lters
The Content library in   Motion is a great way to start to visualize some of the possibilities 
Motion has to offer. In this recipe, we'll be taking a look at some of the possibilities that 
are available with combining some content from Motion's library along with some fi lters.

How to do it...
1. Launch Motion. Set the Preset to Broadcast 720p, Frame Rate to 29.97, and 

Duration to 10 seconds. Click OK.
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2. Click on the Library tab. Go to the Content category. There are 1349 items to choose 
from. Click the magnifying glass at the bottom-left of the window. Type in Flourish, as 
shown in the following screens hot:

3. Select Flourish and click Apply to add it to the project.

4. Click the disclosure triangle to reveal the content of the Flourish group. It consists of 
an Ornament layer that is turned off and is referenced by a replicator. The replicator 
controls how many ornaments we see, while the Sequence Replicator behavior 
controls how the ornaments are being animated on screen. Clear the search fi eld 
by clicking on the x icon in the search window.

5. Go to the Filters category.   Go to the Distortion subcategory and select the Mirror 
fi lter. Drag it to the Flourish group. Notice how you can change the position of the 
Mirror fi lter directly in the Canvas by dragging the onscreen control.

6. Press Command + 2 to go back to the Library and select the Glow subcategory. 
Select Outer Glow. Drag it on to the Flourish group. Press F3 to go to the Filters tab. 
Set the Radius value to 4, Brightness to 50, and Outer Color to orange, as shown in 
the following screenshot. Press the Space bar to play back.
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7. Let's add some text directly over the fl ourish and throw on a few behaviors to have 
it appear to be moving together. Make sure you're on the fi rst frame of the project. 
Select the group in the Layers Tab. Type T to select the type tool, or select it from the 
toolbar by clicking on the T icon.

8. Type ORGANIC in the Canvas and press the Esc key to go back to the default 
selection tool. Press F7 to   bring up the HUD. Choose Impact as the font type, set 
Size to 121, and make sure the alignment is set to center, as shown in the following 
screenshot. Position it directly over top of the fl ourish in the Canvas.
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9. Option + click the Outer Glow fi lter to copy it to the Organic text. Make sure Outer 
Glow Copy is selected, and in the HUD change the Inner and Outer Color values 
of the text to a purple and blue color of your liking. Use the following screenshot 
for reference:

10. Let's have the text start a bit later and have it fade in as well as grow on screen. With 
the Organic text selected, jump to one second and the tenth frame mark in your 
Timeline. Press the I key to trim the layer's in-point to that location.

11. Press Command + 2 to go to the Library tab and select the Behaviors category. 
Select the Basic subcategory and drag the Grow/Shrink and Fade in/Fade Out 
behaviors to the Organic text layer in the Layers tab.

12. Press F2 to go to the Behaviors   tab of the Inspector. Set the Fade In Time value to 
30 and the Fade Out Time value to 0.
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13. Under Grow/Shrink, change the Scale value to 10, as shown in the following 
screenshot. Press the Space bar to play back your project.

See also
  Applying a Fade in/Fade Out and Grow/Shrink behavior to a still in Chapter 3, Making 

It Move with Behaviors.

  Changing the text format in Chapter 5, Let's Make Text.

  Changing the text style in Chapter 5, Let's Make Text.
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Where to buy this book 
You can buy Apple Motion 5 Cookbook from the Packt Publishing website: 
http://www.packtpub.com/apple-motion-graphics-5-cookbook/book.  
Free shipping to the US, UK, Europe and selected Asian countries. For more information, please 
read our shipping policy. 

Alternatively, you can buy the book from Amazon, BN.com, Computer Manuals and 
most internet book retailers. 
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