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Apple Server Diagnostics tests your server for  
hardware issues.

Apple Server Diagnostics, also referred to as Server Diagnostics, runs a customizable  
set of tests to help you diagnose issues with the following components:

AirPortÂÂ

BluetoothÂÂ ®

Boot ROMÂÂ

Ethernet controllerÂÂ

FanÂÂ

Hard driveÂÂ

MemoryÂÂ

ProcessorÂÂ

SensorÂÂ

USB portsÂÂ

Video controllerÂÂ

1Overview and Requirements



You can run Apple Server Diagnostics in Extensible Firmware Interface (EFI), which  
is referred to as Server Diagnostics EFI, or in Mac OS X Server, which is referred to as 
Server Diagnostics Mac OS X.

By running Server Diagnostics EFI, you can diagnose hardware issues that prevent 
Mac OS X Server from successfully starting up. You can also run tests without 
interference from Mac OS X Server.

However, Server Diagnostics Mac OS X provides an enhanced interface and has 
more extensive sensor, hard drive, and video controller tests. For a comparison and 
description of available tests, see “Server Diagnostics Test Reference” on page 37.

You can test the server by running Server Diagnostics on the server. You can also run 
Server Diagnostics remotely on a computer with a network connection to the server.

Note:  This guide describes how to use Apple Server Diagnostics version 3X108, which 
is included on the Admin Tools disc (Mac OS X Server version 10.6 or later).
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Overview of Server Diagnostics Configurations
You can install and run Server Diagnostics in a variety of ways, so choose the method 
that best suits your needs. There are several options, each with advantages and 
disadvantages:

Option Considerations

Use the preinstalled Server Diagnostics EFI Advantages:

ÂÂ You can use Server Diagnostics EFI.
ÂÂ You don’t need a portable storage device.
ÂÂ No installation is necessary.

Disadvantages:

ÂÂ You need physical access to the server.
ÂÂ Damage to the startup volume may prevent 

access to Server Diagnostics EFI.
ÂÂ You can’t save logs or screenshots locally.
ÂÂ You must restore Server Diagnostics if you 

erase the volume it’s installed on.

Install Server Diagnostics EFI on a portable 
storage device

Advantages:

ÂÂ You can use Server Diagnostics EFI.
ÂÂ You can use the same portable storage device 

to test multiple servers.
ÂÂ You can save logs and screenshots locally.

Disadvantages:

ÂÂ You need physical access to the server.
ÂÂ You need a volume on the portable storage 

device that has 100 MB of available space and 
that doesn’t have Mac OS X or Mac OS X Server 
installed.

ÂÂ The portable storage device must be physically 
connected to the server.

Host a NetBoot server Advantages:

ÂÂ You can use Server Diagnostics EFI.
ÂÂ You don’t need to install Server Diagnostics 

on an internal volume on the server or on a 
portable storage device.

ÂÂ You can use a single Server Diagnostics install 
image to test multiple servers.

Disadvantages:

ÂÂ You need physical access to the server.
ÂÂ You need a server to host NetBoot service and 

the Server Diagnostics install image.
ÂÂ The server must be on the same subnet as the 

NetBoot server.
ÂÂ You can’t save logs or screenshots locally.



Option Considerations

Start up the Server Diagnostics EFI located on the 
Admin Tools disc

Advantages:

ÂÂ You can use Server Diagnostics EFI.
ÂÂ You can use the same disc to test multiple 

servers.

Disadvantages:

ÂÂ You need network access to the server.
ÂÂ You can’t save logs locally.

Install Server Diagnostics Mac OS X on a portable 
storage device

Advantages:

ÂÂ You can use Server Diagnostics Mac OS X.
ÂÂ You can use a single portable storage device to 

test multiple servers.

Disadvantages:

ÂÂ You need an empty volume on the portable 
storage device with 10 GB of available space.

ÂÂ You must install Mac OS X Server on the empty 
volume.

ÂÂ The portable storage device must be physically 
connected to the server.

Install Server Diagnostics Mac OS X on an internal 
volume

Advantages:

ÂÂ You can use Server Diagnostics Mac OS X.
ÂÂ You don’t need physical access to the server to 

run Server Diagnostics Mac OS X remotely (if 
you have Apple Remote Desktop).

Disadvantages:

ÂÂ You need an empty volume on the server with 
10 GB of available space.

ÂÂ You must install Mac OS X Server on the empty 
volume.
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Requirements
Before you can run Server Diagnostics, you must meet general, storage device, and 
local and remote requirements.

General Requirements
To run Server Diagnostics, you need the following:

A Mac Pro with Mac OS X Server v10.6 or later installedÂÂ

The ÂÂ Mac OS X Server Install DVD and Admin Tools disc included with the Mac Pro 
(both discs should be version 10.6 or later)

Storage Device Requirements
Depending on whether you want to run Server Diagnostics EFI, Server Diagnostics 
Mac OS X, or both, you need empty volumes on the server or on a portable  
storage device.

To run Server Diagnostics Mac OS X, the storage device must use the GUID Partition 
Table partition scheme. If you’re running only Server Diagnostics EFI on the storage 
device, you don’t need to use the GUID Partition Table partition scheme.

You can run both versions of Server Diagnostics by having two empty volumes on the 
same server or portable storage device. You need at least one of the following:

In order to You need

Run Server Diagnostics EFI A volume on the server that has at least 100 MB 
of available space, but doesn’t have Mac OS X or 
Mac OS X Server installed

Run Server Diagnostics Mac OS X An empty volume on the server with at least 
10 GB of available space, which will be used for  
a dedicated Mac OS X Server installation

Test multiple servers and run Server  
Diagnostics EFI

A USB 2.0 flash drive, or USB 2.0 or FireWire hard 
drive with a volume that has at least 100 MB of 
available space but doesn’t have Mac OS X or 
Mac OS X Server installed

Test multiple servers and run Server Diagnostics 
Mac OS X

A USB 2.0 or FireWire hard drive that has an 
empty volume with at least 10 GB of available 
space



Local and Remote Requirements
To run Server Diagnostics locally on the server, you need to connect a keyboard, 
mouse, and display.

To run Server Diagnostics remotely, you need the following:

A Macintosh computer with Mac OS X v10.6 or later installed. This computer is ÂÂ
referred to as the host computer.

A server with Mac OS X Server v10.6 or later installed. This server is referred to as  ÂÂ
the client server.

A network connection with DHCP active or a direct Ethernet connection from the ÂÂ
host computer to the client server.

The client server must have Server Diagnostics installed on an internal volume or on ÂÂ
a connected portable storage device; or it must be able to run Server Diagnostics 
from a NetBoot server.

The host computer must run Server Diagnostics Mac OS X. The client server can run ÂÂ
Server Diagnostics EFI or Server Diagnostics Mac OS X.

If the client server is running Server Diagnostics Mac OS X, you must be able to ÂÂ
log in to the root account. The root account gives a system administrator complete 
access to the server.

NetBoot Server Requirements
To host Server Diagnostics EFI on a NetBoot server, your NetBoot server must:

Have Mac OS X Server v10.5 (10.5.8 or later recommended) or Mac OS X Server v10.6 ÂÂ
(10.6.4 or later recommended) installed.

Be on the same subnet as the server being tested.ÂÂ

Have 100 MB of hard disk space available for a Server Diagnostics NetBoot image.ÂÂ
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Before you can run Server Diagnostics, you must set up your 
testing environment and install Server Diagnostics.

Make sure you meet Server Diagnostics requirements before attempting setup  
and installation. For information, see “Requirements” on page 9.

Server Diagnostics EFI is preinstalled on the server. The instructions in this chapter 
show you how to install Server Diagnostics in a different location or set up  
a NetBoot server.

Setting Up a Storage Device for Server Diagnostics 
Installation
To set up an internal volume or portable storage device for Server Diagnostics 
installation, you need at least 100 MB of available space for Server Diagnostics EFI 
or at least 10 GB of available space for Server Diagnostics Mac OS X, which requires 
installing Mac OS X Server. These requirements are described in detail in “Storage 
Device Requirements” on page 9.

If you’re installing Server Diagnostics Mac OS X on a volume, the storage device should 
use the GUID Partition Table partition map scheme.

To view the storage device’s partition map scheme, open Disk Utility and select the 
storage device. Make sure you select the storage device and not a volume within the 
storage device.

At the bottom of the Disk Utility window, Partition Map Scheme should be GUID 
Partition Table.

To repartition an in-use storage device, run Disk Utility from the Mac OS X Install DVD 
or the Mac OS X Server Install DVD or run Disk Utility while your server is connected to 
another computer and is in target disk mode. These methods erase the contents of 
your server’s hard disk and require you to reinstall and reconfigure Mac OS X Server.

2Setup and Installation



WARNING:  The following instructions could erase all data on your storage device. 
Back up critical data before performing the following instructions.

To create and format empty storage device volumes:
	 1	 Insert the Mac OS X Server Install DVD.

	 2	 Restart the server and hold down the server’s Option key while it restarts.

	 3	 When a list of startup disks appears, select Mac OS X Server Install Disc and click the 
arrow button.

If it isn’t listed and you’re connecting to a computer over AirPort, select the AirPort 
network in the pop-up menu under the startup disk list.

	 4	 Select a language and click Next (right-arrow).

	 5	 Choose Utilities > Disk Utility.

	 6	 Select the storage device you want to set up.

Make sure you select a storage device, and not volumes within the storage device. 
Volumes within a storage device are indented one level.

	 7	 Click the Partition tab.

	 8	 If the partition map scheme of the storage device isn’t GUID Partition Table and you’re 
going to install Server Diagnostics Mac OS X, choose something besides “Current” in 
the Volume Scheme pop-up menu, then click Options, select GUID Partition Table, and 
click OK.

Changing the volume scheme erases all data on the storage device.

	 9	 Review the partition sizes and adjust them to meet Server Diagnostics storage 
requirements.

To do this Do this

Display a partition’s size Click the partition and review the Size field.

Set the size of the partition Edit the Size field.

Create more partitions Select a partition and click the Add (+) button.

Delete partitions Select it and click the Delete (–) button.

Name a partition Select it and enter a name in the Name field.

Because this name is used when selecting which 
volume to start up Mac OS X from, choose a 
name that identifies the volume as being used 
for Server Diagnostics.

	 10	 If you’re installing Server Diagnostics EFI on a volume, select the volume and choose 
MS-DOS (FAT) from the Format pop-up menu.
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If you’re installing Server Diagnostics Mac OS X on a volume, select the volume and 
choose Mac OS Extended (Journaled).

	 11	 Click Partition.

	 12	 Choose Disk Utility > Quit Disk Utility, and then choose Mac OS X Installer > Quit 
Mac OS X Installer.

After you finish setting up volumes, you can install Server Diagnostics EFI or Server 
Diagnostics Mac OS X. For information, see the following topics:

“ÂÂ Installing Server Diagnostics EFI” on page 13

“ÂÂ Installing Server Diagnostics Mac OS X” on page 14

Installing Server Diagnostics EFI
Before you install Server Diagnostics EFI, make sure your storage device has a volume 
that has at least 100 MB of available space and that is formatted as MS-DOS (FAT). 
The volume will be erased, so make sure all important data on the volume is backed 
up. For more information, see “Setting Up a Storage Device for Server Diagnostics 
Installation” on page 11.

To perform these instructions, you need the Admin Tools disc v10.6 or later included 
with the server.

If you perform this task to install Server Diagnostics EFI on an internal volume on the 
server, you need administrator access to the server. If you perform this task to install 
Server Diagnostics EFI on a portable storage device, you can use any computer that 
you have administrator access to.

If you want to connect a host computer directly to the server and the host computer 
doesn’t provide DHCP service on the port used to connect to the server, you must 
create a file on the server that assigns an IP address to the server. However, if the host 
computer provides DHCP service, don’t create this file. For information about how to 
find out if a computer is providing DHCP service, see Network Services Administration at 
www.apple.com/server/macosx/resources.

To install Server Diagnostics EFI:
	 1	 Insert the Admin Tools disc.

	 2	 On the server, open AppleServerDiagnosticsEFI.pkg (located in /Diagnostics/  
on the disc).

	 3	 Follow the onscreen instructions, and at the Select Destination step, choose a volume 
that has at least 100 MB of available space and doesn’t have Mac OS X Server installed.

	 4	 If you’re asked to authenticate, authenticate as a user with administrator privileges.

http://www.apple.com/server/macosx/resources


	 5	 If you want to connect a host computer directly to the server and the host computer 
doesn’t provide DHCP service on the port used to directly connect to the server, do 
the following:

	 a	 Open TextEdit (located in /Applications/).

	 b	 In a new file, enter an IP address that’s not in use by the host computer.

For example, enter:

123.123.123.123

If TextEdit doesn’t open with a new blank file, choose File > New.

	 c	 Choose Format > Make Plain Text.

	 d	 Choose File > Save As.

	 e	 Name the file axd_set_ip_address, and then change the location of the file to the 
volume with Server Diagnostics EFI installed.

	 f	 Select “If no extension is provided, use ‘.txt’,” and then click Save.

Restoring Server Diagnostics EFI
Server Diagnostics EFI is preinstalled on the startup volume. If you erase the startup 
volume, you’ll erase Server Diagnostics EFI. If you install Server Diagnostics EFI instead 
of restoring it, you can’t start up Server Diagnostics EFI by holding down the D key at 
startup.

To restore Server Diagnostics EFI:
	 1	 Insert the Admin Tools disc.

	 2	 On the server, open AppleServerDiagnosticsHD.pkg (located in /Diagnostics/ on the 
disc).

	 3	 Follow the onscreen instructions, and at the Select Destination step, choose a volume 
that has Mac OS X Server installed.

	 4	 If you’re asked to authenticate, authenticate as a user with administrator privileges.

Installing Server Diagnostics Mac OS X
Before you install Server Diagnostics Mac OS X, make sure that your storage device 
uses the GUID Partition Table partition scheme and that it has an empty volume with 
10 GB of available space. For more information, see “Setting Up a Storage Device for 
Server Diagnostics Installation” on page 11.
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If you perform this task to install Server Diagnostics Mac OS X on an internal volume 
on the server, you need administrator access to the server. If you perform this task 
to install Server Diagnostics Mac OS X on a portable storage device, you can use any 
computer you have administrator access to.

Installing Server Diagnostics Mac OS X involves three steps:

Install Mac OS X Server with minimal options selected.ÂÂ

Copy Server Diagnostics Mac OS X from the ÂÂ Admin Tools disc to /Applications/.

Configure Mac OS X Server.ÂÂ

By dedicating a minimal installation of Mac OS X Server for use with Server Diagnostics 
Mac OS X, you reduce the risk of server processes interrupting Server Diagnostics 
testing.

To install Server Diagnostics Mac OS X:
	 1	 Insert the Mac OS X Server Install DVD.

	 2	 Restart the server and hold down the server’s Option key while it restarts.

	 3	 When a list of startup disks appears, select Mac OS X Server Install Disc and click the 
arrow button.

If it isn’t listed and you’re connecting to a computer over AirPort, select the AirPort 
network in the pop-up menu under the startup disk list.

	 4	 Continue through the installer until you reach the step where you select the disk to 
install Mac OS X Server on.

	 5	 Select a volume that’s at least 10 GB.

If the volume isn’t empty, choose Utilities > Disk Utility. Select the volume. In the Erase 
pane, click Erase. After the volume is erased, choose Disk Utility > Quit Disk Utility.

	 6	 Click Customize, deselect all checkboxes, click OK, and then click Install.

When the Installer finishes installing Mac OS X Server, the computer restarts and the 
Mac OS X Server setup assistant opens.

	 7	 Continue through the setup assistant and enter information that’s requested.

In the Users and Groups step, select Configure Manually. Don’t enable services.

When you finish entering information in the setup assistant, the login window appears.

	 8	 Log in with the user name “root” and the password of the user you created in the 
setup assistant.

You must set up and run Server Diagnostics Mac OS X as root. Otherwise, you can’t test 
the server you’ve installed Server Diagnostics Mac OS X on.

	 9	 Insert the Admin Tools disc.



	 10	 Open a Finder window and drag the AppleServerDiagnostics.app file from 
/Diagnostics/ on the Admin Tools disc to the /Applications/ folder on the server.

	 11	 If you’re setting up a client server, open a Finder window, select the /Applications/ 
folder, choose New Folder from the Action (gear) pop-up menu, and name the folder 
AppleServerDiagnosticsClient.

Client servers are remotely controlled by host computers.

	 12	 Open System Preferences (located in /Applications/) and change the following options 
in System Preferences panes.

System Preferences pane Recommended configuration

Accounts Select the System Administrator account, 
and click Login Items. Click Add (+), select 
AppleServerDiagnostics.app (typically located in 
/Applications/), and click Add.

CDs & DVDs In all pop-up menus, choose Ignore.

Desktop & Screen Saver In the Screen Saver pane, drag the “Start screen 
saver” slider to Never.

Energy Saver In the Sleep pane, drag both sliders to Never, and 
deselect “Put hard disk(s) to sleep when possible.”

Exposé and Spaces In the Exposé pane, in all pop-up menus, choose 
“–.” In the Spaces pane, deselect Enable Spaces.

Software Update In the Scheduled Check pane, deselect “Check for 
updates.”

If you can’t change settings in System Preferences, click the lock button and 
authenticate.

After installing the Server Diagnostics Mac OS X, you must log in as root to run Server 
Diagnostics to test your own server. If you don’t log in as root, Server Diagnostics 
Mac OS X enters host mode and waits for a connection to a client server to control.

Setting Up a NetBoot Server
Before you set up a NetBoot server, make sure you have an available server that meets 
the requirements described in “NetBoot Server Requirements” on page 10.

After you set up a NetBoot server, you install the Server Diagnostics NetBoot image. 
Because the Server Diagnostics NetBoot image is a special image, you can’t use System 
Image Utility to delete the image.

For information about deleting the Server Diagnostics NetBoot image, see “Deleting 
the Server Diagnostics NetBoot Image” on page 18.
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To set up a NetBoot server:
	 1	 Open Server Admin (located in /Applications/Server/).

	 2	 If the server that will host NetBoot isn’t listed, do the following:

	 a	 Click the Add (+) button and choose Add Server.

	 b	 Enter the IP address of the server in the Address field and enter the user name and 
password of the server administrator in the User Name and Password fields.

	 c	 Click Connect.

	 3	 Click the disclosure triangle for the server that will host NetBoot.

	 4	 If NetBoot isn’t listed, select the server and click Settings; then, in the Services pane, 
select NetBoot and click Save.

	 5	 Select NetBoot, click Settings, and then click General.

	 6	 In the “Enable NetBoot on at least one port” list, select the Enable checkboxes for the 
interfaces that you want to serve the Server Diagnostics NetBoot images over.

If multiple network interfaces are listed, it’s likely that only one of the interfaces is on 
the same subnet as your server.

If you’re not sure which interface is on the same subnet, open Network Utility (located 
in /Applications/Utilities/) on your NetBoot server and your server. In the Info pane, 
choose different network interfaces on the NetBoot server and your server and 
compare the IP Address fields.

Usually, computers are on the same subnet if their IP addresses start with same 
numbers (for example, they may both start with 192.168.2).

	 7	 In the volume list, select the Images checkbox and Client Data checkbox for the 
volume that will store the Server Diagnostics NetBoot image.

The volume must have at least 100 MB of available space.

	 8	 Click Save.

	 9	 In a Finder window, navigate to the Diagnostics folder on the Admin Tools disc, and 
then open AppleServerDiagnosticsNetBoot.pkg.

	 10	 Follow the onscreen instructions to install the Server Diagnostics NetBoot package.

	 11	 In Server Admin, select NetBoot, and then click Images.

	 12	 If the Server Diagnostics NetBoot image has the same index (listed in the Index 
column) as another image, deselect the Enable checkbox for the conflicting image.

Don’t change any default Server Diagnostics NetBoot image settings.

	 13	 Click Start NetBoot.



Deleting the Server Diagnostics NetBoot Image
You can’t use System Image Utility to delete the Server Diagnostics NetBoot image. 
Instead, you must delete the Server Diagnostics NetBoot image in the NetBoot image 
folder, which is located at:

/Volumes/volumename/Library/NetBoot/NetBootSP#

Replace volumename with the name of the volume that you’re installing the Server 
Diagnostics NetBoot image onto. The number (#) varies, depending on whether you’re 
using several NetBoot volumes.

If you’re using only one NetBoot volume, the Server Diagnostics NetBoot image is 
located in NetBootSP0. If you’re using several NetBoot volumes, the Server Diagnostics 
NetBoot image may be located in a different folder (for example, NetBootSP1, 
NetBootSP4, or NetBootSP11).

To delete the Server Diagnostics NetBoot image:
Open a Finder window and delete AXD.nbi from the NetBoot image folder.mm
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This chapter describes several methods that let you change 
the startup disk to the volume with Server Diagnostics 
installed.

Before you start up Server Diagnostics, make sure everything is properly installed and 
configured. For information, see Chapter 2, “Setup and Installation.”

Changing the Startup Disk
Server Diagnostics is usually installed on a dedicated volume to minimize the risk of 
server processes interrupting the tests. Because of this, you must change the startup 
disk to the volume with Server Diagnostics installed before you can use the tools.

To test a client server remotely, first start up Server Diagnostics on the host computer 
and then start up Server Diagnostics on the client server.

To start up Server Diagnostics, set the startup volume of the server to the volume or 
disk image containing Server Diagnostics.

If Mac OS X Server starts up by default on your server, you can change the startup disk 
in the Startup Disk pane of System Preferences. Otherwise, you can temporarily change 
the startup disk by holding down a key while starting up the server:

Goal Hold down this key at server startup

Choose the Server Diagnostics volume before 
starting up Mac OS X

Option

Start up the preinstalled Server Diagnostics EFI D

Start up using the Server Diagnostics EFI disk 
image from a NetBoot server

F1

If you erase the volume Server Diagnostics EFI is installed on, you can’t use the D key 
to run it.

3Starting Up Server Diagnostics



If you insert the Admin Tools CD in another computer and run Remote Install Mac OS X 
(located in /Applications/Utilities/ on the computer), you can hold down the Option 
key and choose the Administration Tools volume before starting up Mac OS X to run 
Server Diagnostics EFI from the disc.

The Startup Disk pane of System Preferences can start up Server Diagnostics Mac OS X, 
but not Server Diagnostics EFI. You can press the Option key at startup to start up 
Server Diagnostics Mac OS X or Server Diagnostics EFI.

The server becomes unavailable when you use Server Diagnostics. Before starting 
tests, alert users that the server will be unavailable.

Changing the Startup Disk in System Preferences
If Mac OS X Server starts up by default on your server, you can use System Preferences 
to change the startup disk. The list of startup volumes includes internal volumes and 
connected portable storage device volumes.

When you change the startup disk in System Preferences, you can’t select a startup 
disk with Server Diagnostics EFI installed. To change the startup disk to the volume 
with Server Diagnostics EFI installed, change the startup disk at startup. For 
information, see “Changing the Startup Disk Temporarily at Startup” on page 21.

To change the startup disk in System Preferences:
	 1	 Open System Preferences on the server, and then select Startup Disk.

	 2	 If the lock icon is locked, click it and then authenticate as a system administrator.

	 3	 Select the startup disk with the Server Diagnostics and click Restart.

When you’re done using Server Diagnostics, change the startup disk back to the 
volume you were using previously.

Changing the Startup Disk Using the Command-Line Interface
If Mac OS X Server starts up by default on your server, you can use the command-line 
interface to change its startup disk. You can use the command-line interface to start 
up from internal volumes and connected portable storage device volumes.

You can also change the startup disk of a remote server using the command-line 
interface. Remote login must be enabled on the remote server (enabled by default). 
You can enable remote login in the Sharing pane of System Preferences.

When you change the startup disk using the command-line interface, you can’t select 
a startup disk with Server Diagnostics EFI installed. To change the startup disk to the 
volume with Server Diagnostics EFI installed, change the startup disk at startup. For 
more information, see “Changing the Startup Disk Temporarily at Startup” on page 21.
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You must be able to authenticate as the root account to change the startup disk using 
the command-line interface.

Note:  The Terminal commands described in this task are case-sensitive, and must be 
entered as shown.

To change the startup disk using the command-line interface:
	 1	 Open Terminal (located in /Applications/Utilities/).

	 2	 If you want to connect to a remote server, enter the following in the Terminal window, 
and authenticate when requested:

ssh username@serveraddress

Replace username with the short name of a user who can authenticate as the root 
account on the server. Replace serveraddress with the URL, IP address, or host name of 
the server.

	 3	 Enter the following, and then authenticate as the root account:

sudo bless -folder "/Volumes/volumename/System/Library/CoreServices" 
-setBoot

Replace volumename with the name of the volume you want to start up from.

When you’re done using Server Diagnostics, change the startup disk back to the 
volume you were using previously.

Changing the Startup Disk Using Apple Remote Desktop
If you have Apple Remote Desktop, you can change the startup disk of remote 
computers to an internal volume or connected portable storage device volume.

For information about using Apple Remote Desktop to set a computer’s  
startup disk, see the Apple Remote Desktop Administrator Guide, located at  
www.apple.com/remotedesktop.

Changing the Startup Disk Temporarily at Startup
If your server has trouble starting up Mac OS X Server or doesn’t have Mac OS X Server 
installed, you can temporarily change the startup disk by holding down a key while 
the server is starting up. This requires that you have a keyboard and mouse attached 
to the server and that you can restart the server.

If a firmware password is set, you can’t temporarily change the startup disk by holding 
down the D or F1 key. You can do it by holding down the Option key, but you must 
authenticate with the firmware password.

For information about disabling the firmware password, see “Disabling the Firmware 
Password” on page 22.

http://www.apple.com/remotedesktop/


To temporarily change the startup disk at startup:
	 1	 Restart the server.

	 2	 While the server is restarting, hold down the Option key until a list of volumes appears.

If you’re asked to authenticate, enter the firmware password and click the Continue 
(right-arrow) button.

If you haven’t erased the preinstalled Mac OS X Server volume with Server Diagnostics 
EFI, you can start up Server Diagnostics EFI by holding down the D key instead of the 
Option key.

To start up Server Diagnostics EFI from a NetBoot image hosted on a NetBoot server, 
hold down the F1 key instead of the Option key.

Each alternative starts up Server Diagnostics EFI and bypasses the list of volumes 
described in the next step.

	 3	 If you displayed the list of volumes instead of immediately starting up Server 
Diagnostics, select the volume with Server Diagnostics, and then click the arrow 
button to start up.

The Server Diagnostics EFI volume is listed as EFI Boot. If you’ve inserted the Admin 
Tools disc in another computer with Mac OS X or Mac OS X Server v10.6 or later 
installed and you run Remote Install Mac OS X, the Server Diagnostics EFI volume is 
listed as Administration Tools.

After you finish using Server Diagnostics EFI and restart the server, it starts up from the 
default startup volume.

Disabling the Firmware Password
If a firmware password is enabled, you can’t temporarily change the startup volume by 
pressing and holding F1 or D at startup.

If a firmware password is enabled and you try to temporarily change the startup 
volume by holding down the Option key at startup, you must authenticate.

To disable the firmware password:
	 1	 Insert the Mac OS X Server Install DVD.

	 2	 Restart the server and hold down the server’s Option key while it restarts.

	 3	 When a list of startup disks appears, select Mac OS X Server Install Disc and click the 
arrow button.

If the disk isn’t listed and you’re connecting to a computer over AirPort, select the 
AirPort network in the pop-up menu under the startup disk list.
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	 4	 After selecting a language, choose Utilities > Firmware Password Utility.

	 5	 In Firmware Password Utility, click Change.

	 6	 Deselect “Require password to change firmware settings,” and click OK, then 
authenticate when asked.

	 7	 Choose Firmware Password Utility > Quit Firmware Password Utility.

	 8	 Choose Mac OS X Installer > Quit Mac OS X Installer.

	 9	 Click Startup Disk, select the startup disk with Mac OS X Server installed, and then  
click Restart.
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Server Diagnostics Mac OS X and Server Diagnostics EFI have 
different interfaces and functionality. This chapter describes 
how to use both sets of Server Diagnostics.

Before you can use Server Diagnostics, make sure you’ve properly started up the tools. 
For information, see Chapter 3, “Starting Up Server Diagnostics.”

Setting Server Diagnostics to Host, Client, or Local Mode
Server Diagnostics can start up in any of three modes, depending on whether:

You’re opening Server Diagnostics EFI or Server Diagnostics Mac OS XÂÂ

Any of the computers on the same subnet are host computersÂÂ

A host computer is directly connectedÂÂ

You’re logged in as rootÂÂ

You’re running Server Diagnostics Mac OS X on a computer that isn’t a Mac Pro with ÂÂ
Mac OS X Server installed

4Using Server Diagnostics
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The following table describes the three modes:

Mode Description Automatically enters mode if

Host The computer searches for 
servers that are on the same 
subnet and start Server 
Diagnostics in remote mode. 
When one is found, the host 
computer controls Server 
Diagnostics on the client server.

You run Server Diagnostics 
Mac OS X and:

ÂÂ The computer isn’t a Mac 
Pro with Mac OS X Server 
installed

ÂÂ You’re not logged in as root

Client The server can be controlled by 
a host computer.

You’re running Server 
Diagnostics EFI and a host 
computer is on the same subnet 
or is directly connected.

Local The server runs all tests locally. You’re running Server 
Diagnostics EFI and a host 
computer isn’t on the same 
subnet and isn’t directly 
connected.

If you’re logged in as root on the server and you run Server Diagnostics Mac OS X, you 
can choose which mode to enter.

Remotely Testing a Client Server
To test a client server, you first start up Server Diagnostics on the host computer, set it 
to connect to the client server, start up the Server Diagnostics on the client server and 
then set the client server to be a client of the host computer.

The host computer must run Server Diagnostics Mac OS X. The client server can run 
Server Diagnostics Mac OS X or Server Diagnostics EFI. The available tests are based on 
which Server Diagnostics the client server is running.

When you start up Server Diagnostics EFI, the server looks for a host computer. If it 
finds a host computer, the server enters client mode. If it doesn’t find a host computer, 
the server enters local mode.

When you start up Server Diagnostics Mac OS X, the server becomes a host computer 
if either of the following are true:

You logged in to Mac OS X with an account that isn’t root.ÂÂ

You’re running Server Diagnostics Mac OS X on a computer that isn’t a Mac Pro with ÂÂ
Mac OS X Server installed.

If Server Diagnostics Mac OS X doesn’t automatically become a host computer, it asks 
if it should connect to a client server, be a client of a host computer, or run tests locally.



To remotely test a client server:
	 1	 On the host computer, open Server Diagnostics Mac OS X (typically located in 

/Applications/).

	 2	 Choose from the following:

If the host computer is a Mac Pro with Mac OS X Server installed and you’re logged ÂÂ
in as root, when Server Diagnostics Mac OS X opens, a dialog asks you to choose 
which mode to enter. Choose “Connect to remote server” and click OK.

If your computer isn’t a Mac Pro with Mac OS X Server installed, the dialog doesn’t ÂÂ
appear, and Server Diagnostics Mac OS X automatically enters host mode.

	 3	 On the client server, change the startup disk to a volume with Server Diagnostics  
and restart it.

You can also temporarily change the startup disk to be a volume with Server 
Diagnostics on it or to a Server Diagnostics NetBoot disk image when you start  
up the server.

For information about how to change or temporarily change the startup volume, see 
Chapter 3, “Starting Up Server Diagnostics.”

	 4	 If you’re starting up Server Diagnostics Mac OS X, log in as root.

	 5	 If Server Diagnostics Mac OS X doesn’t open automatically, open the Apple Server 
Diagnostics application (typically located in /Applications/), choose “Client of a remote 
host,” and then click OK.

If you’re starting up Server Diagnostics EFI, the server enters client mode.

	 6	 Verify that the host computer and client server have established a successful 
connection by reviewing the following:

The IP address field in the Server Diagnostics window on the host computer should ÂÂ
match the IP address assigned to the client server.

The name of the Server Diagnostics window on the host computer is “Apple Server ÂÂ
Diagnostics remote log,” not “Apple Server Diagnostics local log.”

The log area of the client server uses more of the Server Diagnostics window.  ÂÂ
Shut Down, Restart, and a few other buttons are removed.
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Testing the Local Server Using Server Diagnostics EFI
To test the local server, make sure none of the computers on the same subnet as the 
server is running Server Diagnostics Mac OS X in host mode. If a computer on the 
same subnet is running Server Diagnostics Mac OS X tools in host mode, the server 
automatically enters client mode.

To test the local server using Server Diagnostics EFI:
Restart the server and hold down the Option or F1 key to start up the volume or mm

NetBoot disk image with Server Diagnostics EFI.

For information about how to temporarily change the startup volume while starting 
the computer, see Chapter 3, “Starting Up Server Diagnostics.”

When Server Diagnostics EFI starts up and doesn’t find a host computer, it enters  
local mode.

Testing the Local Server Using Server Diagnostics Mac OS X
To test the local server, you must log in as root. If you don’t log in as root, Server 
Diagnostics Mac OS X enters host mode.

To test the local server using Server Diagnostics Mac OS X:
	 1	 Change the startup disk of the server to a volume with Server Diagnostics Mac OS X, 

restart it, and log in as root.

	 2	 If Server Diagnostics Mac OS X doesn’t open automatically, open it (typically located in 
/Applications/).

	 3	 When Server Diagnostics Mac OS X opens, choose “Local” from the dialog that appears 
and click OK.



Using Server Diagnostics EFI
In Server Diagnostics EFI, the test controls and test selections are split across two 
panes. Regardless of which pane you’re looking at, you can do the following:

View the test log, test settings, and statusÂÂ

Start testsÂÂ

Clear the test logÂÂ

Restart the serverÂÂ

Shut down the serverÂÂ

Detailed status

Test controls

Test Selections list

Test

Test category

Test log

Select All and
Deselect All buttons

For more information about Server Diagnostics EFI, see the following sections.
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Customizing Server Diagnostics EFI Test Settings
You can customize Server Diagnostics test settings by choosing which tests are run, 
whether to loop tests, and whether to stop or continue testing when an error occurs.

To customize Server Diagnostics EFI test settings:
	 1	 In Server Diagnostics EFI, select the test settings you want.

To do this Do this

Choose which tests are run Do any of the following:

ÂÂ To select a test, select the checkbox next to 
the test.

ÂÂ To select a specific test within a category of 
tests, click the disclosure triangle next to the 
category, and then select individual tests.

ÂÂ To select all tests, click Select All.
ÂÂ To remove all tests, click Deselect All.

Loop all selected tests Do one of the following:

ÂÂ To loop selected tests a specific number of 
times, select “Loop # times” and replace # with 
the number of times to loop.

ÂÂ To run tests once, select “Loop # times” and 
replace # with the number 1.

ÂÂ To loop tests for a specific amount of time, 
select “Loop for # hours and # minutes” and 
replace # with number of hours and minutes 
to loop. When the specified time is reached, 
the current loop must complete before the 
tests stop. For example, if one loop of your 
test set takes 2 hours to complete and your 
specified time is 3 hours, Server Diagnostics 
stops testing in 4 hours. (Instead of stopping 
at 3, it waits for the current test set loop to 
complete before stopping.)

Change what to do when an error occurs In the On Error pop-up menu, do one of the 
following:

ÂÂ To stop testing when the first error occurs, 
choose Stop.

ÂÂ To continue testing when errors occur, choose 
Continue.

	 2	 To run the test, click Test.



Clearing the Test Log
The test log contains all test messages that have occurred during the current  
Server Diagnostics session. If you quit Server Diagnostics, the log is cleared.

To clear the test log without quitting Server Diagnostics, click Clear Test Data.

Viewing the Hardware Profile
The hardware profile lists all hardware components in the server.

You can view the hardware profile by choosing Hardware Profile > Display  
Hardware Profile.

Shutting Down or Restarting the Server
You can shut down or restart the server in Server Diagnostics EFI.

To shut down or restart the server:
Click Shut Down or Restart.mm

Viewing Saved Logs
When you start up Server Diagnostics EFI from a volume in MS-DOS (FAT) format, 
it creates a log of its test results in the /AppleServerDiagnosticsLogs/ folder of the 
volume with Server Diagnostics EFI installed.

This log is updated as tests complete. If the server crashes during tests, review the  
log to see which test it crashed on.

If you run the preinstalled Server Diagnostics EFI or Server Diagnostics EFI from the 
Admin Tools disc, or a NetBoot disc image, logs aren’t saved.

The logs are named AppleServerDiagnostics_date_time_serialnumber.txt.

The date and time indicate when Server Diagnostics EFI started up. The time is in 
Greenwich Mean Time (GMT), using a 24-hour format.

The values use this format:

Value Format Example

date DDMonYear 15Jul2009

time HH_MM_SS 19_23_46

serialnumber ########### AB12345CD6E
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Taking Screenshots
You can take screenshots of Server Diagnostics EFI, which are saved as BMP files in the 
root folder of the volume with Server Diagnostics EFI installed.

If you run Server Diagnostics EFI from the Admin Tools disc, a NetBoot disc image, or  
a volume that isn’t in MS-DOS (FAT) format, you can’t take screenshots.

To take a screenshot:
In Server Diagnostics EFI, press Command-Shift-3.mm

After you press Command-Shift-3, the system pauses for a few seconds and then takes 
the screenshot.

Using Server Diagnostics Mac OS X
Server Diagnostics Mac OS X changes based on whether you’re running it locally, as a 
client, or as a host. In client mode, you can’t change test settings, select different tests, 
or shut down or restart the server. Therefore, the test log uses most of the window.

In local and host mode, you can access all Server Diagnostics Mac OS X features in the 
main window.

Local or client IP address Log status Currently viewed log

Detailed status

Test controls

Test Selections list

Test category

Test log

Select All and
Deselect All buttons

For more information about using Server Diagnostics Mac OS X, see the following 
sections.



Customizing Server Diagnostics Mac OS X Test Settings
You can customize Server Diagnostics test settings in several ways by choosing which 
tests are run, whether to loop tests, and whether to stop or continue testing when an 
error occurs.

To customize Server Diagnostics Mac OS X test settings:
	 1	 In Server Diagnostics Mac OS X, select the test settings you want.

To do this Do this

Choose which tests are run In the Test Selections list, do the following:

ÂÂ To select a test, select the checkbox next to 
the test.

ÂÂ To select a specific test within a category of 
tests, click the disclosure triangle next to the 
category, and then select individual tests.

ÂÂ To select all tests, click the Select All (+) button.
ÂÂ To remove all tests, click the Deselect All (–) 

button.

Loop all selected tests Select “Loop tests by,” and then do the following:

ÂÂ To loop selected tests a specific number of 
times, select Count and enter a number of 
times to loop.

ÂÂ To loop selected tests for a specific amount 
of time, select Time and enter the number of 
hours and minutes to loop. When the specified 
time is reached, the current loop must 
complete before the tests stop. For example, 
if one loop of your test set takes 2 hours to 
complete and your specified time is 3 hours, 
Server Diagnostics Mac OS X stops testing in 
4 hours. (Instead of stopping at 3, it waits for 
the current test set loop to complete before 
stopping.)

Change what to do when an error occurs In the On Error pop-up menu, do the following:

ÂÂ To stop testing when the first error occurs, 
choose Stop.

ÂÂ To continue testing when errors occur, choose 
Continue.

	 2	 To save your customized test settings for future use, in the Test Group pop-up menu, 
choose Save Current Group, enter a name for the group, and click OK.

For more information, see “Working with Test Groups” on page 33.

	 3	 To run the test, click Start Testing.

When the test completes, a PASSED or FAILED message appears on screen.

	 4	 Click anywhere to close the message.
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Working with Test Groups
You can create test groups based on your customized test settings. These are similar 
to templates because they allow you to reuse your test settings without having to 
change each setting individually. After choosing a test group, you can still change  
its settings.

There are several test groups included with Server Diagnostics Mac OS X. These test 
groups stop when an error occurs, and they aren’t looped.

Test group Test selections

Default All memory, fan, hard drive, sensor, SMC PID 
sensor, and power supply tests. Ethernet 
MAC address verification and ROM checksum 
verification.

Quick Test All sensor tests.

You can also export a test group to a file. By exporting a test group, you can use that 
file to re-create that test group on other Server Diagnostics installations. For example, 
if you install Server Diagnostics Mac OS X on several servers, you can copy the test 
group file to each of them, making identical tests available without having to manually 
create a new test group.

To work with test groups:
In Server Diagnostics Mac OS X, choose the options you want.mm

To do this Do this

Use a test group In the Test Group pop-up menu, choose a test 
group.

Create a new test group In the Test Group pop-up menu, choose Save 
Current Group. Enter a name for the group and 
click OK.

Delete a test group In the Test Group pop-up menu, choose a test 
group. Choose Edit > Delete Test Group.

You can’t delete the Default or Quick Test test 
groups.

Export a test group Choose File > Export Test Group, choose a 
location, name the test group, and click Save.

Import a test group Choose File > Open, select an .axdconfig file, and 
click Open.



Viewing Logs
You can view the following types of logs in Server Diagnostics Mac OS X:

Log type Description

Test All messages from tests run in the current Server 
Diagnostics Mac OS X session.

Hardware Info Listing and description of all installed hardware.

When you view logs in Server Diagnostics Mac OS X, a colored circle next to the log 
name indicates whether the log is able to be loaded.

Color Status

No circle You haven’t loaded the log during this Server 
Diagnostics session, or the log hasn’t been 
created yet.

Yellow The log didn’t load. This usually occurs when 
there isn’t any data in the log.

Green The log loaded.

To view logs:
	 1	 Open Server Diagnostics Mac OS X.

	 2	 If tests are running, wait for them to complete or stop them.

If tests are running, you can view only the test log.

	 3	 Do any the following:

To do this Do this

View logs in the current or chosen volume Choose a log from the “View log” pop-up menu.

Search for specific text within the log Enter text in the search field. When you press 
Return, matching text is highlighted in the log 
area.

Clear logs Choose Logs > Clear current Log, or choose Logs 
> Clear All Logs.

The name of the currently viewed log replaces 
current.

Refresh logs Choose Logs > Refresh Current Log.
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Setting Log Preferences
You can set up log preferences so the Server Diagnostics test logs are saved to a file at 
a location you choose. Server Diagnostics test logs are created when you start a Server 
Diagnostics session.

When Server Diagnostics Mac OS X saves a log, it overwrites any log of the same name. 
Log preferences can customize the name of the log file so that the log files aren’t 
overwritten.

If you don’t use any naming options, the log is saved as:

AppleServerDiagnostics_serialnumber_mode_autosave_log.txt

If you’re testing locally, mode is replaced by “local.” If you’re testing remotely, mode is 
replaced by “remote.”

If you use all naming options, the log is saved as:

AppleServerDiagnostics_serialnumber_mode_autosave_log_date_ethernetMACaddress 
uniquename.txt

The appended values use this format:

Value Format Example

date DD_Mon_Year 15_Jul_2010

ethernetMACaddress ##_##_##_##_##_## 01_23_45_67_89_ab

uniquename - # - 1

The unique name is appended only if a file with the same name exists.

A log for the local server with all naming options enabled (using the example values) 
is saved as:

AppleServerDiagnostics_AB12345CD6E_local_autosave_log_15_
Jul_2010_01_23_45_67_89_ab - 1.txt



To set log preferences:
	 1	 In Server Diagnostics Mac OS X, choose AppleServerDiagnostics > Preferences.

	 2	 To automatically save test logs, select “Auto-save test log.”

If you don’t select this option, you can’t perform the steps that follow.

	 3	 To choose the location of the automatically saved log, click “Choose auto-save 
location,” select a location, and then click Open.

	 4	 Configure the test log naming options.

To do this Do this

Ensure newly created log files don’t overwrite old 
log files

Select “Use unique name.”

Append the Ethernet address of the server that’s 
being tested

Select “Append Ethernet Address.”

Append the run time and date of the session’s 
first tests

Select “Append time and date.”

Shutting Down or Restarting the Server
If you’re running Server Diagnostics Mac OS X on the local server or on a host 
computer, you can shut down or restart the server by clicking Shut Down or Restart.

If the server is in client mode, you can’t shut down or restart the server locally.

Quitting Server Diagnostics Mac OS X While a Test Is Running
If you try to quit Server Diagnostics Mac OS X while a test is running, you can’t print 
or save logs from the current Server Diagnostics session. Make sure you print or save 
critical logs before quitting.

Instead of quitting in the middle of a test, you can stop the current test, print or save 
logs, and then quit.
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This reference describes the tests available in Server 
Diagnostics and gives estimates for how long the tests  
take to complete.

The types of tests available depend on if you’re using Server Diagnostics EFI or Server 
Diagnostics Mac OS X, and on your server model and configuration.

Comparison of Available Tests
The following table compares the tests available by component, depending on 
if you’re using Server Diagnostics EFI or Server Diagnostics Mac OS X. For more 
information about the specific tests available for each component, see “Server 
Diagnostics EFI Tests” on page 38 and “Server Diagnostics Mac OS X Tests” on page 44.

A % indicates that a test is available:

Component tested Available in Server 
Diagnostics EFI

Available in Server 
Diagnostics Mac OS X

Notes

AirPort % % Different tests are 
available depending  
on the tool.

Bluetooth %

Ethernet controller % % Different tests are 
available depending  
on the tool.

A
pp

en
di

x

Server Diagnostics Test Reference
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Component tested Available in Server 
Diagnostics EFI

Available in Server 
Diagnostics Mac OS X

Notes

Hard drive % % Different tests are 
available, depending on 
the tool and whether 
solid state drives are 
installed.

Memory (simple) % This tests all memory 
using a single CPU core.

Memory (multicore) % This tests all memory 
using all available CPU 
cores.

Memory (extended) % Tests all memory.

Power supply %

Processor %

Sensor % % Server Diagnostics 
Mac OS X has an 
additional sensor test.

SMC PID sensor % %

USB port % %

Video controller %

Server Diagnostics EFI Tests
These tests are available if your server is running Server Diagnostics EFI.

Startup Tests
These tests run when you start up Server Diagnostics EFI.

Test Estimated completion time Description

Hardware Existence 1 second Compares a table of sensors and 
fans with what’s connected to 
the logic board. If a sensor or 
fan isn’t found, an error occurs.

All sensors and hard drives 
found can be individually tested 
using sensor and hard drive 
tests.

Boot ROM Checksum 1 second Verifies the Boot ROM 
checksum.

Boot ROM FW GUID MAC Addr 
Checksum

1 second Verifies the Boot ROM FireWire 
GUID MAC address checksum.



	 Appendix    Server Diagnostics Test Reference	 39

Test Estimated completion time Description

Boot ROM Headers and Data 
Checksum

15 seconds Verifies headers and data 
checksum for all firmware 
volume regions throughout  
the Boot ROM.

Verify BOF Flash with CRC 1 second Verifies that the low and high 
limits for testing sensors are 
correctly set.

SMBIOS Self-Test 1 second Checks the SMBIOS tables for 
32-bit errors (type 18) and 64-
bit errors (type 33). Also verifies 
that the mapped-in DIMM size 
is appropriate for the slot it’s 
inserted into. If there’s a size 
mismatch, an error occurs.

When the server tests memory 
at startup, it maps out bad 
memory. This mapped-out 
memory is hidden from the 
system and diagnostics so the 
non-SMBIOS memory tests don’t 
test it. The SMBIOS test reports 
these mapped-out DIMMS.

AirPort Tests
Test Estimated completion time Description

PCI-E LinkWidth Verification 1 second Verifies PCI link width is as 
expected.

Ethernet Controller Tests
Test Estimated completion time Description

MAC Address Verification 1 second Verifies MAC address isn’t all FFs 
or 00s.
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Hard Drive Tests
When Server Diagnostics EFI starts, it performs a hardware existence test. Hard drives 
found during this test can be tested individually using hard drive tests.

Test Estimated completion time Description

Full Read 3 hours for a 1 TB drive Performs a DMA full-read scan 
at 1250 RPM. This checks the 
entire hard drive for slow-read 
failures.

This test is available for hard 
drives, but not solid-state drives.

Abbreviated Read 2 minutes Performs a DMA scan at 1250 
RPM. This checks the first 10 GB 
of the hard drive for slow-read 
failures.

This test is available for hard 
drives, but not solid-state drives.

Check SMART Status 1 second Check the SMART status of  
a hard drive.

This test is available for hard 
drives, but not solid-state drives.

Memory Tests

Simple Memory Tests
In Server Diagnostics EFI, memory tests (simple, multicore, and extended) are grouped 
under Memory tests.

Note:  The time required to complete memory tests correlates to the amount of 
memory being tested. These estimates are based on testing 8 GB of memory.

Test Estimated completion time Description

Address as Data 15 seconds Tests memory using the 
memory address as data.

Patterns 40 seconds Tests memory using different 
data patterns.

Marching Ones and Zeros 30 seconds Tests memory by walking 1s and 
0s up and down memory.

Knaizuk Hartmann 20 seconds Tests memory using this 
algorithm.

MOD3 1 minute Tests memory using this 
algorithm.

March U 3 minutes Tests memory using Van de 
Goor’s March U algorithm.
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Test Estimated completion time Description

Random 45 seconds Uses pseudo-random values.

Block Checkerboard 32 15 seconds Alternates 32-bit words with all 
1s and all 0s, and then with all 
0s and all 1s.

Bit Checkerboard 32 15 seconds Alternates bits with all 1s and 
all 0s, and then with all 0s and 
all 1s.

Sequential Byte Block 32 32 minutes Fills bytes sequentially with 
patterns starting at 0x00 and 
ending at 0xFF.

Walking One 32 15 minutes Walks 1s up and down memory.

Walking Zero 32 15 minutes Walks 0s up and down memory.

Walking Spread Bit 32 15 minutes Walks 0b01 up and then walks 
0b10 down memory.

Walking Bit Flip 32 15 minutes Alternates words with walking 
1 and walking 0, and then 
alternates with walking 0 and 
walking 1.

Multicore Memory Tests
In Server Diagnostics EFI, all memory tests (simple, multicore, and extended) are 
grouped under Memory tests.

Note:  The time required to complete memory tests correlates to the amount of 
memory being tested. These estimates are based on testing 8 GB of memory.

Test Estimated completion time Description

MP Block Checkerboard 10 seconds Alternates 32-bit words with all 
1s and all 0s, and then with all 
0s and all 1s.

MP Bit Checkerboard 10 seconds Alternates bits with all 1s and 
all 0s, and then with all 0s and 
all 1s.

MP Sequential Byte Block 16 minutes Fills bytes sequentially with 
patterns starting at 0x00 and 
ending at 0xFF.

MP Walking One 7 minutes Walks 1s up and down memory.

MP Walking Zero 7 minutes Walks 0s up and down memory.

MP Walking Spread Bit 7 minutes Walks 0b01 up and then walks 
0b10 down memory.
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Test Estimated completion time Description

MP Walking Bit Flip 7 minutes Alternates words with walking 
1 and walking 0, and then 
alternates words with walking 0 
and walking 1.

Check Hardware Errors 2 seconds Tests specific registers for 
memory related errors. Running 
this test at the end of memory 
testing may help catch memory 
errors generated during other 
memory tests.

Extended Memory Tests
Extended memory tests test all available memory.

In Server Diagnostics EFI, memory tests (simple, multicore, and extended) are grouped 
under Memory tests.

The availability of extended memory tests depends on the server model you test.

Note:  The time required to complete memory tests correlates to the amount of 
memory being tested. These estimates are based on testing 8 GB of memory.

Test Estimated completion time Description

Extended Memory Test P00F 10 seconds Tests memory using pattern 0. 
This fails if an error occurs.

Extended Memory Test P01F 10 seconds Tests memory using pattern 1. 
This fails if an error occurs.

Extended Memory Test P02F 10 seconds Tests memory using pattern 2. 
This fails if an error occurs.

Extended Memory Test P03F 10 seconds Tests memory using pattern 3. 
This fails if an error occurs.

Extended Memory Test P04F 10 seconds Tests memory using pattern 4. 
This fails if an error occurs.

Extended Memory Test P05F 10 seconds Tests memory using pattern 5. 
This fails if an error occurs.

Extended Memory Test P06F 10 seconds Tests memory using pattern 6. 
This fails if an error occurs.

Extended Memory Test P07F 10 seconds Tests memory using pattern 7. 
This fails if an error occurs.
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Power Supply Tests
Test Estimated completion time Description

Good 1 second Checks if the power supply’s 
good bit is set. If it’s not set, this 
could indicate that the power 
supply isn’t seated well or is bad, 
or that there’s no AC connected.

Processor Tests
Test Estimated completion time Description

L1 Cache Test 3 seconds Verifies that the L1 cache is 
good on all processor cores.

Sensor Tests
When Server Diagnostics EFI starts, it performs a hardware existence test. Sensors 
found during this test can be tested individually using sensor tests.

Test Estimated completion time Description

Sensor Reads 1 second Verifies that the sensor reads are 
within the preset sensor limits.

SMC PID Sensor Tests
The System Management Controller (SMC) monitors the Proportional Integral 
Derivative (PID) controller which controls several important temperature sensors.

Test Estimated completion time Description

SMC PID Sensor 1 second Verifies that the sensor reads 
controlled by the PID are within 
the preset sensor limits.

USB Tests
Connect USB devices before running USB tests.

Test Estimated completion time Description

Presence 1 second Verifies that a USB device is 
connected.
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Server Diagnostics Mac OS X Tests
These tests are available if your server is running Server Diagnostics Mac OS X.

Startup Tests
These tests run when you start up Server Diagnostics Mac OS X.

Test Estimated completion time Description

Hardware Existence 1 second Compares a table of sensors and 
fans with what’s connected to 
the logic board. If a sensor or 
fan isn’t found, an error occurs.

Sensors, and hard drives found 
can be individually tested using 
sensor, hard drive tests.

SMBIOS Self-Test 1 second Checks the SMBIOS tables for 
32-bit errors (type 18) and 64-
bit errors (type 33). Also verifies 
that the mapped-in DIMM size 
is appropriate for the slot it’s 
inserted into. If there’s a size 
mismatch, an error occurs.

When the server tests memory 
at startup, it maps out bad 
memory. The SMBIOS test 
reports these mapped-out 
DIMMS.

AirPort Tests
Test Estimated completion time Description

AirPort MAC Address Verification 1 second Verifies MAC address isn’t all FFs 
or 00s.

AirPort Power Cycle 5 seconds Verifies AirPort by performing 
a wireless scan after turning 
AirPort power off, then turning 
AirPort power on.
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Bluetooth Tests
Test Estimated completion time Description

Bluetooth USB Interface 1 second Verifies USB interface between 
host and Bluetooth.

MAC Address Verification 1 second Verifies MAC address isn’t all FFs 
or 00s.

Bluetooth Power Cycle 10 seconds Verifies USB interface between 
host and Bluetooth after turning 
Bluetooth power off and then 
turning Bluetooth power on.

Ethernet Controller Tests
Data loop tests can add to network traffic. Consider disconnecting from the network 
before running data loop tests.

Test Estimated completion time Description

MAC Address Verification 1 second Verifies MAC address isn’t all FFs 
or 00s.

MAC Loopback 25 seconds Verifies that there’s no data 
mismatch between sent and 
received data while looping 
within the MAC (a sublayer of 
the datalink layer in the ISO 
network reference model).

PHY 1000 Loopback 25 seconds per port Verifies that there’s no data 
mismatch between sent and 
received data while looping 
within the physical transport 
medium (PHY) at 1000 Mbps.

PHY Jumbo Packet Loopback 25 seconds per port Verifies that there’s no data 
mismatch between sent and 
received jumbo packet data 
while looping within the 
physical transport medium 
(PHY) at the the highest 
supported speed.
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Hard Drive Tests
When Server Diagnostics Mac OS X starts, it performs a hardware existence test.  
Hard drives and solid-state drives found during this test can be tested individually 
using hard drive tests.

Test Estimated completion time Description

Threaded Surface Scan 3 hours for a 1 TB drive Scans the entire surface of  
a hard drive.

This test is available for hard 
drives, but not solid-state drives.

Threaded Surface Short Scan 2 minutes Scans the first 10 GB of a hard 
drive.

This test is available for hard 
drives, but not solid-state drives.

Check SMART Status 1 second Checks the SMART status of  
a hard drive.

This test is available for hard 
drives, but not solid-state drives.

Short Random Multi-block 5 minutes Performs a threaded, random 
multi-block read of random 
ranges of the target hard drive. 
This isn’t a full surface scan, 
but it causes rapid seeking and 
reading of hard drive blocks. If 
a block can’t be read, an error 
occurs.

This test is available for hard 
drives, but not solid-state drives.

SSD Threaded Media Scan Not available Scan’s the entire accessible area 
of a solid-state drive.

This test is available for solid-
state drives, but not hard drives.

SSD New Drive SMART Data Not available Checks the SMART status of a 
solid-state drive.

This test is available for solid-
state drives, but not hard drives.
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Sensor Tests
When Server Diagnostics Mac OS X starts, it performs a hardware existence test. 
Sensors found during this test can be tested individually using sensor tests.

Test Estimated completion time Description

Sensor Reads 1 second Verifies that the sensor reads are 
within the preset sensor limits.

SMC PID Sensor Tests
The System Management Controller (SMC) monitors the Proportional Integral 
Derivative (PID) controller which controls several important temperature sensors.  
SMC sensors can be tested individually using these tests.

Test Estimated completion time Description

SMC PID Sensor 1 second Checks the SMC PID sensor 
warning counter for erratic 
behavior.



USB Tests
Connect USB devices before running USB tests.

Test Estimated completion time Description

Presence 1 second Verifies that a USB device is 
connected.

Video Controller Tests
To run these tests, a display that supports 1024 by 768 or higher resolution must be 
attached to graphics cards being tested. The displays can’t be in sleep mode. For 
example, if you have two graphics cards, they both need a display attached and both 
displays must not be in sleep mode.

Test Estimated completion time Description

OpenGL Point 10 seconds Verifies video controller using  
a 2D point test.

OpenGL Line 10 seconds Verifies video controller using  
a 2D line test.

OpenGL Triangle 10 seconds Verifies video controller using  
a 2D triangle test.

OpenGL Quad 10 seconds Verifies video controller using  
a 2D quadrilateral test.

OpenGL Quad with Texture 10 seconds Verifies video controller using  
a 2D textured quadrilateral test.

OpenGL Rectangle 10 seconds Verifies video controller using  
a 2D rectangle test.

OpenGL Cube 10 seconds Verifies video controller using  
a 3D cube test.

OpenGL Cube with Fog 10 seconds Verifies video controller using  
a 3D cube with fog test.

OpenGL Wireframe 10 seconds Verifies video controller using  
a 3D wireframe test.

OpenGL Solid Red Model 10 seconds Verifies video controller using  
a 3D solid red model test.

OpenGL Solid Red Model with 
Fog

10 seconds Verifies video controller using a 
3D solid red model with fog test.

Fragment Instruction 1 minute Tests every instruction of the 
ARB fragment program.

Vertex Instruction 40 seconds Tests every instruction of the 
ARB vertex program.
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